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SOFTWARE COPYRIGHT AND LICENSE AGREEMENT 
 

Grant of Limited License  
 

softelec gmbh (hereafter called softelec) grants a limited, non-exclusive right to use the software installed on computers (PC's) - workstations or a 
network server. In addition, softelec grants the right to only one (1) user or - in the event of network licenses - to the number of user stated in the 
network license agreement to activate and use the software at any one time once the user of the software has registered with softelec and thereafter 
received the corresponding authorization code. The license(s) and thereby the value of the purchased software product(s) is personified in the 
delivered hardlock. If a hardlock gets lost or stolen softelec will only deliver a new hardlock at full cost of the initially purchased software. softelec 
strongly recommends to insure the hardlock with the value of the purchase software to protect the investment. This limited, non-exclusive license 
agreement supercedes any other previous released agreement unless granted in writing and signed by softelec. 
 

For the demonstration version of the software, unlimited multiple installations are permissible. 
 

Copyright 
 

The contents of the software (recorded on CD's) and the associated manuals are the sole property of softelec and are protected by applicable 
copyright laws. This software may not be multiplied, copied, altered, decrypted, decompiled, changed, or disassembled in any manner without written 
authorization from softelec. A single backup copy is authorized. The user agrees not to transfer title of this software at any one time without first 
notifying softelec. All rights are reserved. No part of the manuals may be reproduced, transmitted, transcribed, stored on a retrieval system or 
translated into any language or computer language, in any form or means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise 
without the express written consent of softelec as punishable by applicable copyright laws. softelec is registered licensee of SZKI Recognita AG 
(OCR) for the use exclusively with VP products.  
 

The use of this software constitutes agreement to the terms said herein. If you do not agree with the terms of this agreement - DO NOT OPEN AND 
INSTALL THE SOFTWARE, promptly return the software, including manuals, binders, hardware lock key, written material, and containers to the 
location from which you obtained them for refund. 
 

Terms 
 

This license agreement becomes effective on the day of purchase and remains in full force until termination. softelec may terminate the license in the 
case the purchaser fails to comply with any of the terms and conditions of this agreement. The purchaser may terminate the license agreement at any 
time by returning the complete software (recorded on diskettes and/or CD's), including manuals, binders, hardlock key, written material, and containers. 
 

Disclaimer 
 

softelec reserves the right to modify the hardlock key, the manuals and/or the associated software at any time, particularly with the intent of further 
development, and undertakes no guarantee to issue notification of modifications, additions, or further developments; nor does the company obligate 
itself to implement such modifications, additions, or further developments in earlier versions of the manual or the software. Any such modifications are 
considered upgrades in which the registered license holder shall have the option to purchase. The license holder is granted the right to obtain license 
upgrades at no extra costs which become available within a maximum of 90 days after the date of his written purchase order. 
 
 

Limited Warranty 
 

softelec warrants that the media containing the software is free from defects in material and workmanship. This limited warranty is valid for a period of 
ninety (90) days from the date of delivery as evidenced by a copy of receipt, provided any faults or defects that may, in spite of the care taken in 
manufacture, become apparent are reported to softelec within thirty (30) days of their occurrence. The only entitlement granted by this warranty is 
repair or replacement of the supplied product at the sole discretion of softelec. Regardless of the nature of any damage or loss in any way connected 
with the software, sole and exclusive liability to be borne by softelec shall not exceed the purchase price of the product.  
 

This program is provided "as is". softelec specifically disclaims all other warranties, expressed or implied, including but not limited to 
implied warranties for merchantability and fitness for a particular purpose with respect to defects in the CD, diskette, hardlock, or 
documentation, and the software license granted herein in particular, and without limiting operation of the software license with respect to 
any particular application, use or purpose. In no event shall softelec be liable for any loss of profit or any other commercial damage, 
including but not limited to special, incidental, consequential or other damages.  
 

Legal Action 
 

This agreement shall be construed, interpreted, and governed by the laws of the Federal Republic of Germany. Venue for any cause of legal 
actions shall be in the city of Munich.  
 

Trademarks 
 

Windows and its derivations are registered trademarks of Microsoft Corporation. AutoCAD and RasterDWG are registered trademarks of Autodesk, 
Inc. Other registered product names are proprietary to their respective owners.  
 

softelec logo, Greek head design, VPHybridCAD, VPstudio, VPmap, VPmax, VPlite, VPraster, VPindex, VPview are registered trademarks of 
softelec gmbh.  
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SECTION 1   
INTRODUCTION  

 

Welcome 
 
Congratulations to your purchase of a VP software product from softelec, the leading specialist 
in hybrid (raster and vector) editing, color management, and raster-to-vector conversion! For a 
better orientation you will find your specific VP software product listed below. It is part of either 
one of the two major product lines: 
 
VPHybridCAD V16: VPstudio, VPstudio mono, VPlite, VPraster, VPraster edit 
 

VPmap Series V9: VPmap pro, VPmap 
 
For simplification the term VP software is used in this manual when general references apply to 
any product of both product lines. 
 
Since its introduction in 1990, VP software products have been constantly improved on quality 
and productivity. New algorithms and programming techniques have resulted in extraordinary 
quality improvements, outstanding features, unique functions, needle pegging conversion speeds, 
and convincing user friendliness. softelec’s own VP software technology guarantees that you are 
obtaining the finest in professional products for your scanning, archiving, raster and vector 
editing, or conversion tasks for all applications in CAD/CAM, AEC, FM, or GIS.  
 
The latest VP software versions again enclose significant improvements and enhancements. 
These are designed to further extend application ranges and productivity in your CAD, GIS, or 
archiving system environment. We hope to meet your requirements in the best way, and we do 
wish you a successful work with your VP software! 
 
 

What are VP software products and who needs them?  
 
The importance of raster data processing has seen notable growth, especially in the field of CAD 
where legacy information, such as "old" drawings, manually created plan designs, and other 
technical documents prevail in b/w paper (copies, blueprints, transparencies) or gray scale and 
color images (photographs, films, color prints). To redrawing those manually in a CAD program 
(using CAD functions or a digitizer) is very time consuming and, in most cases, inaccurate and 
cost intensive. To overcome these drawbacks, b/w and color scanners for small and large formats 
are used to generate raster data (digital photographs) from those documents which then can be 
easily edited or if necessary, converted to vector entities for further use in CAD applications. 
 
VP software represents a number of individual software products with advanced editing and 
conversion capabilities for raster and vector (= hybrid) data. VPstudio and VPmap pro, softelec's 
premier products, contain the highest and most sophisticated hybrid editing capabilities for b/w, 
gray scale, and color raster data together with automatic or interactive raster-to-vector conversion 
functions. Often, all necessary drawing/document modifications can be completely executed with 
a VP software product, without the need to load the file into an additional GIS software. The 
results can be saved to different hybrid formats or exported to CAD or GIS compatible formats, 
such as DXF, DWG, DGN, ESRI SHP or MapInfo MIF. 
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Anyone with the need to digitally process technical paper drawings, colored images, maps, plans 
or sketches will inevitably face this question: "How do I capture legacy drawings for use in my 
system in a manner that saves time and money?" At softelec, we firmly believe that VP software 
products clearly respond to this question in many positive ways, and that they offer an optimum 
solution for any relevant application, such as 
 
• Mechanical Construction (MCAD) 
• Civil Engineering, Facility Management, Architecture (AEC, FM) 
• Plant Design (Piping) 
• Energy Supplies (ECAD) 
• Infrastructure planning 
• GIS applications and cartography 
• Land Survey engineering and ground map documents 
• Any application for extracting geographical information from scanned maps and other 

documents. 
 
 

VP Software Highlights  
 
VPHybridCAD and VPmap Series products contain outstanding, often unique features for 
advanced hybrid processing. These features can guarantee for highest possible productivity. This 
is a selection: 
 
• Direct Large Format and TWAIN scanner interface 
• MDI (Multi Document Interface) for raster images and vector data 
• Two installation platforms: Windows and AutoCAD / BricsCAD / ZWCAD, 

 32-bit and 64-bit mode 
• Unique multi page TIF processing  
• No real size limitation (64,000 pixel) for raster image import 
• Automatic raster image clean up for b/w and color 
• Multiple rubber-sheeting/format calibration modes 
• Automatic and semi-automatic color reduction 
• Dimensioning for raster and vector data (Windows) 
• Interactive and automatic vectorization 
• Ortho-equalization of geometry 
• Symbol library manager via "network clipboard" 
• Symbol Search (Raster and Vector) 
• Quick Symbol Recognition 
• Table and drawing header recognition and clean up 
• Multiple CAD functions (Windows) 
• Full compatible hybrid file format for AutoCAD: RasterDWG 
• Command interface via keyboard 
• Application integration via DDE/OLE 
• Customization of functions, menus, and toolbars 
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Additional Functions of VPmap Series  
 
VPmap Series products also contain additional functions which support hybrid processing 
applications especially for maps and geodata in the field of GIS: 
 
• Expanded raster image import (incl. Erdas, ER Mapper, Landsat) 
• Support of about 2.000 pre-defined Coordinate Systems/Projections and re-projections 
• Simple placing and position adjustment of raster images 
• GeoTIFF Import/Export 
• ESRI (.shp) and MapInfo (.mif) import/export 
• Multiple rubber-sheeting/calibration modes 
• Project and attribute management 
• Attribute query 
• Intelligent polygon/polyline creation 
• Dashed polyline tracing 
• Automatic attribute assigment 
• Automatic transformation of text into attributes 
• Polygon ortho-equalization and overlap correction 
• Automatic correction/transformation of  polylines and polygons 
• Point entity insertion from library 
• Independence from a GIS platform 
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Concept of this Manual    
 
This manual has been organized to help you to quickly find operation terms, commands, and 
description of functions and to supply you with brief, but sufficient explanations. The manual 
applies to the following VP products:  
 
VPHybridCAD V16: VPstudio, VPstudio mono, VPlite, VPraster, VPraster edit 
 

VPmap Series V9: VPmap pro, VPmap 
 
The icon at the top on each page indicates the product(s) to which the information and/or 
commands apply. If specific commands on a page are limited to other products or product groups 
this is marked with a corresponding icon at the corresponding command. 
 
Please, see the product listings on the upper right on each page (see above). When filled, the 
marks in front of a product name indicate the availability of the described function for a specific 
product. When not filled, the described function is not available in the respective product. The 
following icon indicates that the described functions are only valid for VPmap pro and VPmap: 

 
 
Great efforts have been made to define each function and each setting of a parameter only once 
in detail. Therefore, an alphabetic index provides a quick means of finding these descriptions. 
 
Keys and key combinations are represented by [ ] enclosing the keys' designation. For example, 
the "Enter" or "Return" key is shown as [Enter] whereas a key combination (short-cut) opens as 
[Ctrl + C]. 
 
Functions that can be mouse-clicked for activation/deactivation in a check box are represented as 
{on/off}. 
 
Command line commands are indicated with "CMD:" followed by the command term for all 
Windows installed products and most commands with CAD installations. Standard CAD 
commands are used instead, if AutoCAD, BricsCAD, or ZWCAD provide an adequate command. 
Then, the CAD commands are listed below with the prefix "CAD:". In such cases, the indicated 
icons are only available under Windows. Please see the following examples: 
 
Command is available for both Windows and CAD installations: 

CMD: VPRTEXT ► Dialog 
 
Two different commands for Windows and CAD installations: 

CMD: VPDRAWPOLY <X1>, <Y1>, <X2>, <Y2> …  
CAD: _pline  

 
The given value ranges do not necessarily define an internal limitation, but specify a meaningful 
range - be aware that using values outside of the "normal" range can cause unexpected results. 
Default values represent values either set up during installation or values to be used, e.g. when 
parameter values are reset. 
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Conclusion    
 
This manual will familiarize you with all the functions of your VP software. It is meant to be both: a 
source of reference and a guideline to the latest hybrid (raster + vector) processing technology. 
The most expedient way to learn how to use your VP software product professionally and 
effectively is to start with the Tutorial and to follow the applicable lesson sequence. Once 
completed, you will have a good command on your VP software product to significantly increase 
your raster productivity. 
 

Enjoy working with your VP software! 
 
As a reminder, please register your VP software product with softelec (by mail, fax, or online) 
within 30 days after installation to receive an unlimited license access.  
 
Visit our website at http://www.softelec.com for the latest product information, for technical 
support, for available updates, upgrades, and service packs.  
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SECTION 2   
INSTALLATION  

 

Introduction  
 
VP software requires for operation Microsoft Windows 7 or higher. Depending on the 
configuration of your computer network you may install the software using local licensing or 
network licensing. 
 
The purchased VP software product is delivered with a 30 days time limited operation license. 
The user is required to register the software within that time frame with softelec using either the 
online registration accessible from within the software, or sending the completed registration form 
to softelec by mail or fax. Softelec will then return a code to the user which extends the license for 
unlimited use. 
 
 

Software License Control (Hardlock)  
 
Any VP software Full Version product requires a hardlock (dongle) controlling the product 
license. Without a proper installed hardlock any product will only operate in the Demo Mode (no 
hardlock for the license control required). 
 
The hardlock may contain one or more product licenses. Regardless of the installation mode and 
the number of licenses controlled by the hardlock there are two methods of operation: 
1. Local Licensing: you need to attach the USB hardlock to one of the USB ports of the 

computer where the VP software is installed. Typically, this method of operation is used if the 
hardlock contains a single license only. Then, for every additional VP software installation an 
additional single license hardlock is required. 
 

2. Network Licensing: this method of operation is preferable if two or more VP software 
licenses are to be controlled by one hardlock, but may also be used for a single license 
("floating" license), where you can access the VP software license on any network computer, 
but only operate one license at a time. You need to attach the hardlock to a workstation 
serving as "VP network server" or "dongle server" (usually your network server) executing 
the VPLicenseManager so that the license(s) is/are accessible by other workstations. 

 The VPLicenseManager has to be installed on the workgroup server and can only operate 
under Windows XP or higher.  

 
Local Licensing does not require the installation of the VPLicenseManager. 
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Hardlock Driver  

 
The workstation or server controlling the hardlock needs a system driver for proper operation. 
This driver is provided with your package and is installed together with the VP software. You may 
also install it manually by following the instructions found in the file README.TXT on the CD. 

 In order to install the hardlock driver during the standard installation or manually, you need 
administrative rights. 

 The installation routine will not install the hardlock driver(s) if the selected software is 
installed as a Demo Version! If, at a later state, you want to use the software as a full 
version (together with the purchased hardlock), you need to manually install the hardlock 
driver.  

 
 

Attaching the Hardlock (Dongle) 
 
The driver software will be installed automatically with the VP software program (full version). If 
required, it can also be installed separately later. Installation files can be found on the VP 
software CD or are available at www.softelec.com – downloads – utilities/drivers. 
 

 Attach the hardlock only after a successful software installation to one of your 
computer's/server's USB-Ports. 

 
 

Package Contents  
 
Your VP software package contains the following: 
 

• 1 VP Software CD 
• 1 Hardlock (dongle) 
• 1 Registration form 

http://www.softelec.com/
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Installing VP Software   
 

General 
 
The install program SETUP_VP.EXE guides you through each step to successfully install and 
configure the software of your choice and the required hardlock driver on your computer. If your 
CD function AutoRun is enabled, the initial screen will pop up automatically upon insertion of the 
VP software CD offering you several choices. Select VPHybridCAD or VPmap Series and follow 
the advice: 
 

 
 
The required hardlock drivers (Sentinel) will be installed or updated automatically if a VP software 
Full Version product is installed. 
 
The installation setup allows you to specify several options. These include the target location and 
the required components of the VP software.  
 
Prior to starting the setup routine please terminate any running application and read the file 
README.TXT if available on the VP software CD. 

 Administrator rights are necessary to install the hardlock driver. 
 
After a successful installation of the software or the hardlock driver it is often necessary to reboot 
the computer in order to allow the operating system to update the DLLs. A dialog box will appear, 
asking the user to restart the computer now or at a later stage. 
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Performing the Installation 
 
The setup starts automatically after inserting the CD into the CD-ROM drive (AutoRun). Only if 
your Operating System (OS) does not support this feature or AutoRun is disabled you have to 
start the setup program SETUP_VP.EXE manually from the root directory of the CD.  
 
In the initial setup window click the item "VPHybridCAD" or "VPmap Series", select "Full 
Version" or "Demo Version" (as desired) and select the desired program language from the 
appearing dialog. In the sequel you are guided through the setup dialogs allowing user defined 
settings. We recommend to choose "typical" as the setup type. 
 
On a 64-bit operating system another selection shows up to choose between 32-bit and 64-bit 
program installation.  
 

Local Licensing 
 
During setup you will be asked whether your hardlock resides locally or on the VP network server. 
Choose "Local". 
 
 

Network Licensing 
 
If you want to operate the software on a network (you have either multiple licenses purchased or 
you want to use a single license floating) you need to install your hardlock on the server. 
Therefore, choose "Network Server". The next dialog prompts you for the name of the server 
bearing the hardlock ("dongle server").  

 Enter the name, not the IP-address of the server!  
 
There are different ways to specify the server: 
 
COMPUTERNAME 

Name of the computer as entered during the installation of the Windows OS. Leading 
backslashes ("\\") are not required! 

 
COMPUTERNAME:192.168.0.1 

The IP-Address can be enter after the computer name separated by ':'. This is useful in larger 
networks and can speed up the rooting to the server and thus the license. 

 
COMPUTERNAME:COMPUTERNAME.DOMAINNAME 

In some 'heterogeneous' networks it might be necessary to use this combination to clearly 
resolve the server name (e.g. DHCP). 
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When working with multiple dongles on different servers please use the following syntax: 
 

COMPUTERNAME1; COMPUTERNAME2 

The computer names of the servers must be separated by semicolon. 
 

If you don't know the name of the "dongle server" (= "VP network server") you may leave the 
entry empty and proceed with the installation. You may change the dongle server name in the VP 
software (Options->Settings->License) later. 

 In order to use Network Licensing, the VPLicenseManager (see below), the hardlock driver, 
and the hardlock (dongle) must be installed on the same computer (server). 

 
 

First Start after Installation and Registration  
 
Unless you have purchased special VP software licenses such as Multi Licenses or Educational 
Licenses, which require a pre-registration, your software operates on a 30 days time limit allowing 
for execution of the required registration with softelec. At any start of the VP software a dialog 
opens remembering you to register and displaying the expiration date of the license. After the 
expiration date the software will only run in demo mode, unless the code for unlimited use has 
been entered. This code will be send to you as soon as you have registered with softelec. 
 
You can register online from within the VP software (press button "Register On-line" in the dialog 
box or select menu Help ► Register VPxx on the Internet) or fill out the attached registration 
form completely and legibly and send or fax it back to softelec. After checking the registration 
contents softelec returns a code to be entered with the next software start. 
 

 

 You will receive technical support and update/upgrade notices from softelec only if 
you have properly registered your VP software. Registration of VP software products 
with your dealer does not constitute a proper registration. 

 All user data received will only be used for internal expenditure within the softelec sales and 
support cycle and will not passed over to third parties! 
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Uninstalling  
 
To remove a VP software product from your computer click on the icon Uninstall and follow the 
instructions.  
 
The hardlock driver(s) will NOT be removed. If the driver is not required by any other program, 
you can uninstall those using "Add/Remove Programs" from the Control Panel. 
 
 

Updating / Upgrading / Service Pack  
 
Software upgrades (to a higher VP software product level) or updates (to a new release of the 
same VP software product) may require a code that is issued to you upon purchase. After 
installing the upgrade or update and starting it for the first time you will be asked to enter the 
code. With a successful entry the code can be discarded.  

 For updating a VP network license hardlock (the lock is attached to the VP network 
server) use the program UPDATELOCK.EXE residing in the CD directory VPHardlock for 
entering the update code. For more information please read the text file ReadMe.TXT in the 
root directory of the CD. 

 
Service packs are released from time to time for bug fixes and smaller software improvements. 
They can be downloaded from our website and are usually self-installing. 
 
You may install and use the new VP software release together with a previous release although 
this is not recommended. However, do not install the new version into the same directory!  
 
 

System Requirements  
 
Proper operation requires a specific configuration of hardware and software to guarantee overall 
functionality. The fastest CPU in your PC is the most desirable! The software requires at least 
4 GB of RAM, but this is not recommended and today's PCs often have higher memory 
installations. Drawing formats of DIN A0 (E size) and larger, gray scale or color images of any 
size require a minimum of 8 GB. More is recommended for large size color images. File size and 
entity contents of a drawing define the actual amount of RAM required.  
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Installing the VPLicenseManager   
 
The VPLicenseManager needs to be installed only if you have a computer network and the 
hardlock is attached to a remote computer ("dongle server"). This software controls and manages 
the VP software licenses in the network. 
 
 

Requirements 
 
The VPLicenseManager may be installed as a service only on computers (server or workstation) 
operating under Windows XP or higher. 

 As a maximum number, ten concurrent users are allowed to connect to a license server 
running with Windows XP prof.! This is a restriction of the operating system, not of the 
VPLicenseManager. More users can connect using a newer version of Windows or a server 
operating system like Windows Server 2003. 

 

The software clients may run under Windows 7 or higher. It is necessary that the clients have 
access to the "dongle server" (an account must exist for each user). We strongly recommend 
installing the VPLicenseManager on the Domain Controller Server! 
 

An alternative solution is to create a share with a default user name and a respective password. 
Every user that needs to access the "dongle server" has to connect this share with this specific 
name and the specific password. This can be done by either using the Windows Explorer, with a 
special logon script, or by using the VPNetManager.  
 
 

Installation 
 For the following steps you have to be logged on to the dongle server as "Administrator"! 

 Attach the hardlock (dongle) only after a successful software installation. 
 
1. Install the VPLicenseManager software either  

- by choosing Network / Hardlock - VPLicenseManager in the installation’s main window, or 
- by running VPLicenseManagerSetup.exe from the VPLicenseManager folder on the VP 

software CD. 
2. Apply the dongle to a USB server port. 
 
The VPLicenseManager files are copied to the System32 (32-bit Windows) or SysWOW64 (64-
bit Windows) subdirectory of your Windows directory. 
 
In general, a reboot of the server is not required! In some cases it might happen that the 
VPLicenseManager service is not started automatically after installation. In this case you can 
start the service manually through the computer administrative console. To check whether the 
VPLicenseManager has been installed and is running, please use the VPNetManager 
(described below) for checking. 
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The VPLicenseManager service is installed with the startup option 'automatic'. That means the 
service will be automatically restarted after any reboot of the computer. 
 
If the VPLicenseManager is installed and running, you can find out with the program 
VPNetManager (see below). 
 
 

Uninstallation 
 For the following steps you have to be logged on to the dongle server as "Administrator"! 

 
Variant 1: 

Remove the license manager using the Windows Control Panel. 
 

Variant 2: 
Start the Windows command prompt. Change to the installation directory of the license manager 
(e.g. \Windows\System32 or \Windows\SysWOW64) and execute the following command: 

VPLicenseManager.exe -remove 

The VPLicenseManager service is removed. 
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Monitoring the VPLicenseManager   
 

VPNetManager - Introduction 
 
The VPNetManager allows monitoring the VPLicenseManager servers in your network. The 
number of the available licenses, the licenses in use, and the users accessing the 
VPLicenseManager servers can easily be overlooked. 
 
The VPNetManager.EXE application is located in the CD directory VPNetManager. It can be 
started from the installation menu (Network / Hardlock ► Run VPNetManager) or it can be 
installed (by copying) on any computer (Windows XP or higher) in the network. 
 
After the first start of the application the following dialog appears: 
 

 
 

Manage License Servers 
 
If started for the first time or if no server is listed to be monitored the application will automatically 
search the entire network for VPLicenseManager servers (see Search Servers).  
 

Search Servers 

 Menu: Servers, Function: Search Servers  

The application will search the network for any VPLicenseManager servers. The search may be 
stopped by clicking the icon again. 
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 Depending on the size of your computer network the search may take a long time. You can 
speed up this process by adding the server name manually (see below). 

 If you don't have an account on a computer that is currently being checked a dialog opens 
asking you to logon with a different user name and password. See also VPLicenseManager 
- Requirements. 

 

When the search has been completed the left window frame displays the symbols for the found 
VPLicenseManager server(s) (green screen) and those for the connected hardlock(s). 
 

Add Server 

 Menu: Servers, Function: Add Server  

Enter the name of a VPLicenseManager server: 
 

 

 If you don't have an account on the computer a dialog opens asking you to logon with a 
different user name and password. See also VPLicenseManager - Requirements. 

 
When successfully completed, the server and the attached hardlock(s) will be displayed in the left 
window frame: 

 
 

 The green screen indicates that the VPLicenseManager server is working in normal mode. 

 A red screen indicates that the computer could not be found in the network, i.e. the net path 
may be wrong or the computer is not operating. 

 The blue screen indicates that the computer is not a VPLicenseManager server, i.e. the 
VPLicenseManager has not been installed or the program was stopped. 

 A yellow screen indicates that the computer is operating, but another error has occurred. 
An additional error message is displayed in the status bar of the VPNetManager. 

 If the hardlock is not attached to the VPLicenseManager server the symbol for the hardlock 
will not be displayed. 
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Remove Server 

 Menu: Servers, Function: Remove Server  

The currently selected server will be removed from the list and will not be monitored any more. 
 

Default Server 

 Menu: Servers, Function: Default Server  

A dialog opens displaying a list of all VP applications installed on the local computer and the 
respective license server settings: 
 

 
 
Instead of checking and changing the server settings in each program you can easily do this with 
this function. Double-click on the program you want to modify and choose a new server: 
 

 
 
You can also assign the setting (No Server) meaning that a locally attached hardlock will be used 
by the selected program. 
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Sample 
 
The following sample dialog shows an active VPLicenseManager on the computer 
LICENSESERVER with two hardlocks containing 9 product categories, each marked by a key 
symbol. Each category may contain several licenses of that product.  
 

 
 
In this sample one license of VPstudio is currently in use by the user VPuser.  
 
 

Manage Users 
 
A user has to be a member of a user group (user type). There are two types of user groups: 
group Administrator or group Monitor. Monitor users have the right to monitor the license 
servers, the available licenses, and the licenses in use. Administrator users have additional rights 
to create or delete users. 
 
After the installation of the VPLicenseManager only two users are defined:  

Name Password User group 
Administrator Administrator Administrator 
MonitorUser no password required Monitor 

 With the first logon the Administrator's password should be changed immediately! 
 
When starting the VPNetManager you are automatically logged on as the default user 
MonitorUser. If this default user is deleted on a license server, only the server name and the 
status of the VPLicenseManager is displayed, however there will be no information on licenses. 
This way administrators can control the access to any license information: delete the standard 
user MonitorUser and create new individual user accounts. 
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Logon 

 Menu: General, Function: Logon  
 

 
 
The user will be logged on to the selected server. Note that the user name and the password 
entry are case sensitive! Additionally, the VPNetManager will try to log on the user to any listed 
VPLicenseManager server. If this fails for a server the user will be prompted again to enter a 
username and a password for this server. With Cancel the process is aborted. 
 

Change Password 

 Menu: User, Function: Change Password  

This function is available for all users except for the default user MonitorUser. Users of the group 
Monitor may only change their own passwords while users of the group Administrator may 
change the passwords of all users.  
 

 
 

Create 

 Menu: User, Function: Create  

This function is available only for users who are members of the user group Administrator. A 
new user can be created either on the selected server or on all listed servers: 
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Depending on the selected option a new user of the selected group, either of type Administrator 
or MonitorUser will be created. With the activated option On All Servers the system will try to 
register the user on all listed servers. The password default is the user name 
 

Delete 

 Menu: User, Function: Delete  

This function is available only for users who are members of the user group Administrator. A 
dialog appears to delete users from the user list. All registered users of the selected server are 
displayed.  
 

 

 The user will be deleted without a warning message. 
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SECTION 3   
SYSTEM SETTINGS, GENERAL FUNCTIONS  

 

General Information   
 
VP Software products are in full compliance with the graphic user interface conventions of 
Windows and AutoCAD/BricsCAD/ZWCAD respectively. The software has been designed to allow 
the installation either under Windows (as a stand-alone program) or integrated inside AutoCAD, 
BricsCAD, or ZWCAD (as an application). Hence, detailed operation instructions may vary with 
respect to the installation environment. 
 
VP Software has a Multi Document Interface (MDI) allowing for opening an unlimited number of 
documents at the same time and edit/process the contents of the documents simultaneously. You 
can open raster files, vector drawings, or hybrid files containing raster and vector entities.  
 
Anyone document can contain one or more raster images and/or vector data. The data maybe 
organized all in one page or in different pages of the same document (Multi Page Document), 
whereby the Page Control function controls the pages. In a multi page document only one page 
can be displayed at anyone time. For Multi Page TIFF Files the page control function also allows 
to select a particular raster image for editing/processing the contained data. This multi page 
document handling applies only to VP Software products operating under Windows. 
 
Most functions and routines can be activated through graphic symbols (icons), by selecting the 
appropriate command from the menus and submenus, or by invoking the adequate commands at 
the command line. [F1] offers access to an extensive online help at any time. 
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Program Start  
 

  Start your VP Software with either one of these icons. 
 

 
Main Menu Sample: VPmap pro showing all Toolbars 
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  One of these icons starts your AutoCAD/BricsCAD/ZWCAD together with your VP 
Software when installed as an CAD application.  

Your CAD software starts before the installed VP Software product. You will see mainly the CAD 
environment with additional toolbars and the VP Software menu included in the CAD menu: 

 
Main Menu Sample: AutoCAD with VPmap pro 

 
If VP is started in a CAD environment, a CUI file (Custom User Interface) will be created which 
contains all necessary details for ribbons, menus and  toolbars. Moreover, you will be prompted 
whether you want to create a new Workspace (see corresponding CAD help) or whether you 
want the current workspace to be expanded. 
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Start from command prompt 
 
For normal operation you should start VP Software using the shortcut listed above. In some 
cases, however, you may want to start it directly from a Windows command prompt. The 
application you have to start is main.exe in the VP Software installation directory. 
 

CMD: MAIN.EXE [/?] [FILENAME] [/DDE] [/AUTOMATION] [/EMBEDDING] [/P <FILENAME>] 
 [/PT <FILENAME> <PRINTER> <DRIVER> <PORT>] [/B <SCRIPT>] 
 [/T <TEMPLATENAME>] 

/? Show dialog with usage 
FILENAME File to open on start 
/DDE Start up and await DDE command 
/DDENOSHOW Start up and await DDE command, hide window 
/AUTOMATION Start up as an OLE automation server 
/EMBEDDING Start up to edit an embedded OLE item 
/P <FILENAME> Print file to default printer 
/PT <FILENAME> <PRINTER> <DRIVER> <PORT> 
 Print file to specific printer 
/B <SCRIPT> Script file to execute (only for products which support the script command) 
/T <TEMPLATE> Template file to load 
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General Handling   
 

Manual, Online Help  
 
VP Software is delivered with an extensive product documentation. An Online Help system is also 
included and provides retrieval of specific function descriptions. 

 

Menu: Help ► Help Topics 
 

CMD: VPHELP 

The Online Help is provided in various manners: 
 

Help Menu 
You will find Online Help in the menu item Help - Help Topics.  
 

Command Line 
Enter  vphelp at the command line.  
 

F1 Key 
Using the [F1] key. When a dialog has been opened specific information regarding this dialog will 
be displayed. 
 

Help Button 

 Click on this button first, then on any other button in the program for obtaining related 
information. 

 
Toolbars  

 
Upon the first start of  VP Software a selection set of the available toolbars is displayed. All 
toolbars can be switched on/off according to individual user preferences. They can also be 
positioned and configured by following the Windows conventions. Additional custom toolbars with 
arbitrary commands can be added. 
 
Icon and pull-down menu commands that cannot be activated in the program's current status 
(e.g. no raster loaded) appear "grayed".  
 

 Only CAD: A few special toolbars, such as the coordinate display or the list of raster images 
contained in the current document, cannot be generated by a CUI file. These will be created 
as Windows standard tool bars and cannot be combined with CAD toolbars. 

 
Each toolbar can be customized individually by removing or adding icons as they are needed. 
 
A specific positioning of toolbars can be saved as permanent and will be available at any time 
when it is needed. 
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Show/Hide Toolbars (only Windows) 
• Context menu: A right click with the mouse on any docked toolbar opens the context menu 

for toolbars. The toolbar state show or hide can be changed here. 

• System dialog "Customize": In this dialog (call up see below) multiple toolbars can be 
showed or hided. 

• Button "Close": Floating (non-docked) toolbars can be closed (hidden) by clicking the close 
button. 

 
 

Customize Toolbars (only Windows) 
With the system dialog Customize the toolbar state show/hide may be changed. Further toolbars 
can be modified and new toolbars can be created. The dialog can be opened in two different 
ways: 

• Click on the Customize-button of any docked toolbar... 

 
 ...and select Add or Remove Buttons ► Customize...  

• or open the dialog Toolbars (Menu Options ► Toolbars) and click on Customize. 
 
The dialog initially opens with the Toolbars tab.: 
 

 
 

Show/Hide 
Click the checkbox of the toolbar to show or hide it. 
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Create a new Toolbar 

With New... a new, empty toolbar is created. The name may be chosen freely. 
 

Add Icons 
Change to the tab Commands:  
 

 
 
In the column Categories the main menu items of the VP software are listed. The column 
Commands list all available commands from the selected menu.  
 
To add a command click and drag with pressed mouse button the selected command to the 
desired toolbar. 
 

Move/Copy Icons 
Select an icon and drag it with pressed mouse button to the new position within the current or to 
another toolbar. Holding down the [Ctrl] key while dragging will copy the icon. For this operation 
the Customize dialog must be opened. 
 

Delete Icons 
Click with the right mouse button on an icon and select Delete  from the context menu. For this 
operation the Customize dialog must be opened. 
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Customize Toolbars (Quick Access) (only Windows) 
 

Move Icons 
Keep the [Alt] key pressed, click on an icon in a toolbar and drag it with pressed mouse button to 
the new position within the current or to another toolbar. For this action the customize dialog is 
not required. 
 

Copy Icons 
Keep the [Ctrl] + [Alt] key pressed, click on an icon in a toolbar and drag it with pressed mouse 
button to the new position within the current or to another toolbar. For this action the customize 
dialog is not required. 
 

Remove Icons 
Keep the [Alt] key pressed, click on an icon in a toolbar and drag it out of the toolbar (not to 
another toolbar). For this action the customize dialog is not required. 
 
 

Organize Toolbars (only Windows) 
 

Menu: Options ► Toolbars 
CMD:  VPTOOLBARS 

 

 
 

Show Customize Buttons 
When active each docked toolbar is extended with the Customize button.  
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Arrange Toolbars automatically 
When active the toolbars will be automatically rearranged to ensure an optimal view if the 
program window is resized. 
 

Profile 
The arrangement of the toolbars can be saved either to the registry or to a file and thus can be 
restored any time.  
 

Scaling 
Toolbars and Menus are scaled according to the selected scale factor.  

 The size of dialogs is not affected by this setting. To enlarge the entire program including 
the dialogs and subwindows, use the scaling function of your Windows operating system. 

Large Icons: The size of toolbar icons (bitmaps) is doubled.  
 

Customize... 
Opens the system dialog Customize (see above). 
 

Reset to Default 
Reset toolbars to the initial state. All modifications and custom toolbars will be deleted. 
 
 

Dockable Windows 
Windows like the project bar or the symbol library can be docked to the edge of the program 
window. When dragging such a window the position marker appears.  

 
Dragging a window with pressed mouse key onto one of the markers the docking position of the 
window will be displayed. Releasing the mouse will please the window on the selected position. 
Releasing the mouse without this preview will keep the window in an non docked state. 
 
To dock windows on top of each other creating tabbed windows drag the window over another 
window and select the center marker: 

 
When the mouse is release the window docks on top of the other window. Tabs will appear on the 
lower edge of the window with the names of the windows. To release a window right click on the 
tab and select floating from the context menu.  
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Dockable windows are: 

• Command Line 
• Project Bar 
• Browser 
• Symbol Library 
• Birds Eye 
• Attribute Bar 

Dialog Boxes  
 
VP Software uses fixed size and re-sizeable dialog boxes. Once you have set up the size of a 
variable dialog box this size will be saved and re-used the next time you call this dialog.  
 
If a dialog box uses columns for displaying matching information, the width of each column will be 
adjusted. You may use keyboard commands according to Windows conventions to modify the 
arrangement of columns. However, these individual arrangements will not be saved: 
 
 

Status Display (only Windows) 
 
There is a comment box at the lower left screen margin showing: 

• Activated function, or 
• Required activities to proceed, or 
• Messages, or  
• Progress during execution. 

On the right there are 2 boxes for: 
• Count for selected elements 
• The local RGB color value if the cursor is positioned on a colored or gray scale 

image. 
When no function has been activated the comment box remains empty, while a 'For Help, press 
F1' indication appears on the left. 
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Display Control Functions    
 

Raster [F4] {on/off} 
 

 Toolbar: View Bar 
 

Menu: View ► Show Raster 
 

CMD: VPRDISPLAY ► {on/off} 

This function toggles the display of raster data on and off. When you load a raster file, the display 
of raster data is enabled automatically. The item in the menu will be indicated accordingly.  
 

Vector [F5] {on/off} (only Windows) 
 

 Toolbar: View Bar 
 

Menu: View ► Show Vector 
 

CMD: VPVDISPLAY ► {on/off} 

This function toggles the display of vector data on and off. When you load a vector file the display 
of vector data is enabled automatically. The item in the menu will be indicated accordingly.  
 
 

Plot Style View {on/off} (only Windows)  
 

 Toolbar: View Bar 
 

Menu: View ► Plot Style View 
 

KMD: VPPLOTSTYLEVIEW ► {on/off} 

Vector data will be displayed according to the colors and widths from the current plot style 
settings. In case that no plot style file is defined, this function is not available. See 
Plot Style Settings for further information. 
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Bird's Eye {on/off} 
 

 Toolbar: View Bar 
 

Menu: View ► Bird's Eye 
 

CMD: VPBIRDEYE ► {on/off} 

This function toggles the display of a separate window showing the whole drawing. A green frame 
indicates your actual zoom position. Clicking and dragging inside this bird's eye window performs 
a dynamic pan of your current view. Clicking the right mouse button and drawing a rectangle will 
zoom to the rectangle area. Using the mouse wheel zooms into or out of the view’s center. 
 
 

Zoom Functions (only Windows) 
 
When operating with AutoCAD/BricsCAD/ZWCAD all CAD zoom functions are available. 
 

Zoom Extents [NUM x] 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Extents 
 

CMD: VPZOOMX 

The drawing is displayed to its full extents. The drawing's center is mapped to the center of the 
display. 
 

Zoom Selection 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Selection 
 

CMD: VPZOOMSEL 

This function is only available when objects are selected. After selecting objects the function sets 
a new zoom window, so that all selected objects are displayed in the drawing area. 
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Zoom Window 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Window 
 

CMD: VPZOOMW 

Define a window in your document to enlarge a section. 
You can also use the Fast Zoom Window function by holding down [Ctrl+Space] and then 
defining a zoom window. 
 

Zoom Pixel [NUM ÷] 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Pixel 
 

CMD: VPZOOMPIXEL  

Enlarges the display to show each pixel, i.e. each raster pixel is represented by one dot on the 
screen. 
 

Zoom In 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom In 
 

CMD: VPZOOMIN 

This function zooms in incrementally to the maximum pixel viewing level while maintaining the 
viewing center point. 
 

Zoom Out 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Out 
 

CMD: VPZOOMOUT  

This function zooms out incrementally maintaining the screen center point in view, if possible. 
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Zoom Previous 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Previous 
 

CMD: VPZOOMPREV  

This function lets you work your way back through previous zoomed views. The program 
remembers a maximum of 32 views. It does not recall pan operations. 
 

Zoom Dynamic 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Dynamic 
 

CMD: VPDYNZOOM  

This function lets you zoom dynamically by clicking with the left mouse button onto the screen 
and move the mouse up (zoom in) or down (zoom out). 
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Pan Functions (only Windows) 
 
When operating with AutoCAD/BricsCAD/ZWCAD all CAD pan functions are available. 
 

Pan [Cursor Keys]  

Menu: View ► Pan ► Pan Right, Pan Left, Pan Up, Pan Down 
 

CMD: VPPANRIGHT, VPPANLEFT, VPPANUP, VPPANDOWN 

You can pan using the scroll bars at the bottom and right of the active window, or using the pan 
keys on the keyboard. 
 

Pan Page [Shift]+ [Cursor Keys] 

Menu: View ► Pan ► [Shift]+Pan Right, Pan Left, Pan Up, Pan Down 
 

CMD: VPPAGERIGHT, VPPAGELEFT, VPPAGEUP, VPPAGEDOWN 

You can pan using the scroll bars at the bottom and right of the active window, or using the pan 
keys + [Shift] on the keyboard. 
 

Dynamic Pan 

 Toolbar: Zoom 
 

Menu: View ► Pan ► Pan Dynamic  
 

CMD: VPDYNPAN  

Click with the left mouse button onto your document and move (pan) as required. Release the 
mouse button to stop panning. You can also initiate the Dynamic Pan function by holding down 
[Space] or the center mouse button. The function is active as long as you are holding the key or 
button. 
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Using the Mouse  
 

Display Modes of Mouse Position 
Within the work area the mouse position is displayed as a Cross cursor. It appears as the default 
Windows arrow cursor in toolbars, menus, or the status area. At the command line it will be 
displayed as a standard Text cursor. 

 A triple white frame box (instead of the standard crosshair) indicates that with the next mouse 
click this area will be zoomed in to allow for a precise positioning with the then following click. To 
configure the zoom size use the General tab in the System Settings dialog. 
 

Using the Mouse to Select Elements 
Use the left mouse button to pick for Selection. 

 Elements to select can be in raster or vector format (Direct Raster Selection mode 
“Vector/Raster Selection“ or “Vector/Raster Selection incl. Stop at Intersections“); all other 
Direct Raster Selection modes will only work on raster data. (See Section 4).  

 In case that the selection mode does not support vector selection the cursor is changed to 
the rasterselectioncursor: 

 
When vector elements are overlaying raster elements only vector elements will be selected 
initially, while raster elements need to be selected again. Selected elements are displayed in a 
different way than not-selected elements. They bear grips for individual modification and colors or 
line types may change to highlight the selection. 
 

Selecting entities in an image can be done in four different ways: 
 

Clicking 
Click on the respective element within the cursor's snapping range. Only one element will be 
selected per click. 
 

Window 
You specify a rectangle by holding down the left mouse button and dragging the mouse from left 
(1) to right (2). All elements completely enclosed by the rectangle will be selected. The 
rectangle will be displayed with a full frame. 
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Crossing 
You specify a rectangle by holding down the left mouse button and dragging the mouse from 
right (1) to left (2). All elements touched or enclosed by the rectangle will be selected. The 
rectangle will be displayed with a dashed frame. 

  
 

Polygon Selection 
Via context menu you can start the polygon selection mode. A clockwise drawn polygon selects 
only elements completely enclosed by the polygon. The polygon will be displayed with a full 
frame. 

  
A counterclockwise drawn polygon makes a crossing selection: all elements touched or 
enclosed by the polygon will be selected. The polygon will be displayed with a dashed frame  

  
 

Deselection of selected Elements 
To deselect elements from a previous selection hold the [SHIFT] key and repeat your  selection 
(see above for selection modes).  

To cancel a selection or to deselect all selected elements, press the right mouse button for the 
context menu, or press [ESC]. 
 
 

Context Menus 
Use the right mouse button to open context menus. There is a general context menu defined in 
the software registry. Other menus depend on active functions or commands. 
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Zoom 
You can use the mouse center wheel to  

• zoom in/ zoom out . 
• move up/move down (scroll) when holding the [Ctrl] key. 
• move left/move right when holding the [SHIFT] key. 
• move the display arbitrary when holding down (pan dynamic). 
• zoom all by double clicking 

 
 

Combined Mouse Keyboard Operation 
 

Angle Snap (only Windows) 
Pressing [Shift] while moving the mouse limits the angle of the following movement: 

• With 2 point lines including positioning or other help lines (such as text direction etc.) only 
n x 45° directions are possible. 

• With polylines the drawing direction of the second and all further segments is limited to 
only follow a multiple rectangle (n x 45°) with reference to the first segment. This allows for 
drawing rectangle polygons having a base (1st segment) at any angle.  

 
 

Create a Raster Object 
By holding the [Ctrl] key and by dragging a rectangle with the left mouse key a raster object can 
be simply created from an existing raster structure. It can be processed by using the available 
functions from the context menu. 
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Command Line   
 
VP Software offers a command line input and execution via keyboard. All functions can be 
initiated by command line input. Commands are only available (executable) if a document has 
been opened, except for specific commands like Open, New, Help, etc. Processing a command 
sequence can be initiated by using a Scripting File. 
 
The command line window is sizeable, dockable/undockable, and can be switched off when not 
needed. The window is split into two parts: The upper part shows the command history, while new 
commands are entered to the lower part. It automatically appears on keyboard input. To activate 
the command line simply press [Shift]+[Return]. Command line inputs may look like this: 

 
 
In a CAD installation, the respective command line can also be used for VP commands. Please 
see your CAD program documentation for more details.  
 
Commands can only be started when the command line shows the Command> prompt. 
Otherwise, the command line prompts for specific input due to the running command.  
 
However, using a command with a preceding single tick mark (‘) will start the command 
regardless of the command line state. This can be useful, for instance, when during the drawing 
of a line (VPDRAWLINE) a zoom command shall be executed (‘VPZOOMX). 
 
The available commands and their functions are listed in the Appendix of this manual. The 
shortcut "CMD" refers to VP software commands valid for Windows and CAD operation. 
Commands with the shortcut "CAD" refer to commands valid only for CAD operation. 
 
The available commands are listed with the corresponding functions in this manual.  
 
A command string consists of the command header and can be extended by 
options/parameters. Any command starts with the two letters "VP" followed by the command 
name. The command header is the main command for any particular function or operation. For 
entering you may use upper and/or lower case letters. Enter [Return] for execution. 
 
The command syntax is as follows: 
 

VPXXXX  <X1>,<X2>  <X3> [/P|Parameter <X1>, <X2>] 
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The preceding characters VP may be omitted in stand-alone mode. They are only mandatory 
when operating with AutoCAD/BricsCAD/ZWCAD to separate VP software commands from CAD 
commands or from commands of other applications. 

 If VP software is operated under a CAD program, the system variables CMDDIA or FILEDIA 
determine whether the command line parameters for a VP command will be queried. Other 
than with CAD commands, these need then to be entered as a complete line, including 
spacing between individual value entries. 

 
Options <X1> <X2>,<X3> 

Options are command supplements which may be required to execute the command. As 
indicated in the dialog Registered Commands some commands do not allow options at all, some 
may have options, and some always require options. The values X1, X2 etc. can be separated by 
either comma(s) or space(s). This delimiter strategy allows for entering an extended command 
string prior to executing the complete command with [Return].  
 

Parameter [/P|Parameter <X1>] 
Parameters are always optional. Therefore, they are listed in this manual in brackets. A 
parameter definition starts with a "/" (slash) followed by a parameter’s name or abbreviation. 
Names and abbreviations will be displayed with a separating "|" (dash), e.g. "/P|Parameter". A 
parameter can require options, which are demanding if the parameter is used at all. These 
parameters are shown within the brackets enclosing the parameter and the required options. 
 

Delimiter 
Options and parameters have to be separated with a delimiter. As delimiters either a comma or a 
space character are available. Multiple spaces and/or commas between two option values are 
interpreted as one delimiter. 
 
If a parameter uses either a space or a comma as part of the parameter - e.g. if you use a file 
name as the parameter to the command VPOPEN which carries space(s) - you need to enter this 
parameter in quotations marks: VPOPEN "C:\VP SAMPLE.TIF".  
 

Command Query 
If you enter any command followed by a slash and a question mark, e.g. VPDRAWLINE /?, the 
system will display all options/parameters for this command. 
 

Repeating Commands 
Entered commands can be repeated by using [ ] and [ ] cursor keys. 
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Completing Commands 
You may use the [TAB] key to complete a command. A repeated  pressing on [TAB] will prompt 
the next command option in alphabetical order. Using  [SHIFT] + [TAB] reverses this order.  

Example:  "VPDRA" and  [TAB] will prompt "VPDRAWPIX". 
 "VPDRA" and  [SHIFT]+ [TAB] will prompt "VPDRAWCOPY". 
 

Alias Names 
The command header of a command string may be replaced by an alias name, usually a short 
abbreviation being especially useful with commands which are often used. The file 
ALIASES.PGB located in the SUPPORT subdirectory contains alias names which may be 
modified or extended at users discretion. The default alias names are listed in the APPENDIX. 
 

Entering Coordinate Values 
Coordinates can be entered in absolute values as x,y, in relative values as @x,@y, in length and 
angle values as l<phi, or only as length I value (while the angle value will result from the current 
mouse cursor position and the last coordinate value pair). A mixed entering of absolute and 
relative values is also possible, e.g. @x,y or x,@y. 
 
The last coordinate value pair is prompted in the command line as <x,y>. You can confirm values 
with [Enter] or change values with [Tab]. 

 A comma is always considered as a separating symbol. Thus, to enter decimal values a 
decimal point must be applied, regardless of any other settings in your Windows system. 

 
Command Line {on/off} (only Windows) 

 

Menu: View ► Command Line 
 

CMD: VPCMDLINE 

Switches the command line on and off.  
 
 

Activate Command Line (only Windows) 
 

Menu: View ► Command Line 
 

CMD: VPACTCMDLINE 

Activates the command line at any program state. 
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List Commands 
 

Menu: Options ► Registered Commands 
 

CMD: VPLISTCOMMANDS  

A list of all available commands will be displayed: 
 

 
 
You can double-click Yes in the column Command Parameters to access the parameters that 
are available for the respective command. When changes have been made leave the dialog with 
OK to use the command with new parameters. 
 
Example for the VPSPECKLES command: 
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File Menu   
 
This menu manages the loading, saving, import and export of raster and vector files. When a 
scanner device is connected drawings can be scanned directly into the software. You can also 
load program extensions, print/plot hybrid (raster and/or vector) data and exit the program. 
 
All functions are in compliance with standard Windows conventions. Hence, descriptions will only 
be given in detail regarding differing functions or on those which are of high importance. 

 When operating VP software with AutoCAD/BricsCAD/ZWCAD the CAD commands Open, 
Save and Save as need to be applied to open and save DWG files. To load and save raster 
images the VP commands Import and Export can be applied. 

 
 

New [Ctrl + N]  
 

 Toolbar: Standard 
 

Menu: File ► New 
 

CMD: VPNEW 
 

CAD: _new 

A new document opens. If a prototype drawing file has been assigned it will be read and the 
environment of the new document is set accordingly. 
 
By default  a dialog pops up to specify a prototype drawing. Whether this dialog shows up or not 
can be set here, or at Options ► System settings... Tab Files/Paths. 

 
Select the desired prototype drawing from the list or Browse for a File. 
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Any new specified prototype drawing will be added into the list for future use. The default 
prototype drawing is preselected. Use [Del] or the context menu to delete an entry from the list. 
 
Use only for his document: The selected prototype drawing is loaded. With the next New 
command the default prototype drawing is preselected again. 
 
Set as default: The selected prototype drawing is also set as new default. See also Options ► 
System Settings..., Tab Files/Paths. 
 
Always use Prototype Drawing: Related to the Open command. By default only on Open of 
pure raster files the prototype drawing is preloaded. For vector data like DWG files the prototype 
drawing is not preloaded. With this option set to on the prototype drawing is always used, 
independent from the file format to open. See also Options ► System Settings..., Tab 
Files/Paths. 
 
If you want to create a new (empty) raster image for a document (new or containing data) use the 
function New Raster from the Edit Menu (see Section 4). 
 
 

Open [Ctrl + O] (only Windows) 
 

 Toolbar: Standard 
 

Menu: File ► Open 
 

CMD: VPOPEN ► Dialog  
 

CMD: VPOPEN <File Name> [P|Page <value>] [k|Keep <0|1>] 
 

CAD: _open ► Dialog 

When clicking this command a dialog box opens to select one or more files (raster, vector, or 
hybrid) for loading into a new document.  



 VP Software Manual 

44   Section 3     System Settings, General Functions Manual V16 - V9 / E 
 

  
 

 
 
All supported files are displayed. When selecting a file the file information and a preview is 
shown if the function Preview is switched on and this file format provides a preview.  
 
The list of supported formats can be found in the Appendix.  
 
The selected file will be opened in a new document. Depending on the settings, a prototype 
drawing will be preloaded (see below). 
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Multi Page Documents [P|Page <value>] 
For multi page files you can select to either open all pages or only a particular page (page no.).  

Default All pages 
 

Keep Document [k|Keep <0|1>] 
No new document is created when loading a file. Instead the content of the current document is 
cleared. Using this options with scripting or batch jobs can reduce memory consumption or 
overload. 
 
Default  0 
 

Prototype Drawing 
Shows the current prototype drawing. You may select a previous used prototype drawing from the 
drop-down list. The default prototype drawing is preselected. The drop-down list is disabled if the 
selected file format is a vector format. 
 
Use always allows to specify a prototype drawing for vector formats as well. This switch is equal 
to the one in Options ► System Settings..., Tab Files/Paths. 
Off:  Depending on the file format of the selected file the drop-down list is enabled or not. If 

enabled the selected prototype drawing will be preloaded. 
On:  The selected prototype drawing will always be preloaded. 
 
For more information about the prototype drawing see in Options ► System Settings..., Tab 
Files/Paths. 
 

Options 
Some file formats offer additional settings through the Options button. For more information see 
File Format Options below in this section.  

 The native VP format RVD replaces the formats VCF and VCI used in earlier VP products. 
However, input filters still allow for loading or importing those formats. 

 CGM: the import of raster is limited to uncompressed 1bit (b/w), 8bit (indexed color), 24bit 
(true color), and RLE compressed 1bit data. 
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Multiple File Selection  
 
When more than one file has been selected the following dialog appears to control how the 
individual files are going to be opened: 
 

 
 

• All files into one document  
All selected files are loaded as separate raster objects in one document 

• All files into one document, but to individual pages (Multipage)  
Creates a multi page document 

• One document for each file  
Opens each selected file as separate document 

 When operating under CAD only the first option is available! 
 

Update Coordinate System  
 
When opening a raster file containing coordinate settings and placing information (e.g. TFW or 
GeoTIFF) a dialog will ask how to handle this information. 
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Update Coordinate System (UCS): The data of a TIFF file is used to update the coordinate 
system; the image is placed accordingly. 

Transform Data to current UCS Settings: The existing coordinate system remains unchanged; 
the insertion point’s coordinates of the image are transformed accordingly. 

Ignore Placing and UCS Information: The existing coordinate system remains unchanged - no 
transformation is performed; the image is inserted at the position (0,0). 

Default: Update Coordinate System (UCS) 

 
Backup Copy  

 
If a backup copy is found for the selected file, a dialog pops up: 
  

 
 
You can decide to load the original file or the backup copy.  
 
For more information about automatic saving see Options ► System Settings..., Tab 
Files/Paths. 
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Browser   

 Toolbar: Browser 
 

Menu: File ► Browser 
 

CMD: VPBROWSER  

The following dialog opens: 

 
 

The Browser allows an easy way to open a new document by Drag & Drop or double click. 
Multipage documents display a folder symbol in the upper left corner. Double click will create a 
preview with all pages from the document.  
 
The context menu command Browser Configuration offers additional settings for the Browser: 
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Import  
 

Menu: File ► Import 
 

CMD: VPIMPORT ► Dialog 
 

CMD: VPIMPORT <File Name(s)> [P|Page <PageNo>][/m|Mode <Mode>] 
 [/x|XInsert <XInsert>][/y|YInsert <YInsert>][[/sx|ScaleX <ScaleX>] 
 [/sy|ScaleY <ScaleY>][/a|Angle <Angle>][/b|BlockDefs <BlockDefs>] 

The content of a file is merged with the active document. Existing document settings in the active 
document, e.g. layer names, will be kept; the layer settings of the imported files are discarded. 
This may lead to a different display of the imported file, e.g. if the layer properties are different in 
the active document. 
 
The Import dialog equals the Open dialog (see above), with the following changes: 
• additional option to Specify Insertion Point 
• the section Prototype Drawing is hidden, because on Import no new document is created 

When using a multiple file selection together with the option Create individual documents 
the Open command is used instead of Import! 
 

 This command may also be started by the Open -Icon while [Ctrl]+[Shift] is pressed. 
 

(Positioning) Mode /m 
This command line option specifies how the imported file is to be positioned: 
 

0 - use (Positioning) data from file 
1 -  ignore all data 
2 -  interactive 
3 -  use subsequent data 

 

In interactive mode (2) the Specify Insertion Point dialog is displayed for positioning. For a 
direct input of insertion point values, scaling, and rotation use mode 3.  
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Specify Insertion Point {on/off} 
 
If you set this parameter to on you can define the insertion point for the file you are going to 
import. 
Default on 
 

 
 
You can either select Specify on Screen or enter values for the parameters Insertion Point, 
Scaling, and Rotation. You may also pick the Base Point on the import file. Otherwise, the base 
point is at the lower left corner of the file. 
 
When importing a file, which contains coordinate settings and placing information (e.g. GeoTIFF) 
they will be recomputed to the actual UCS settings. 
 

 In case of projected coordinate systems with different projection types in the imported and 
current document a geographic 2D transform will be performed to adjust the UCS settings. For a 
user defined transform see User Coordinate System in chapter 4 (VPmap Series only).  
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Merge Block Definitions 
 
If the file to be imported contains block definitions which already exist by name, you have to 
decide how to handle this conflict. If not specified otherwise this dialog pops up for each conflict. 
 

 
 

Keep existing block definition 
The block definition of the file to be imported will be ignored. Any references to this block 
definition will be assigned to the existing block definition. This may change the appearance of the 
imported block reference(s). 
 

Import new block definition 
The new imported block definition will replace the existing block definition. All blocks referencing 
to the old block definition will be reassigned to the new block definition. This may change the 
appearance of the existing block reference(s). 
 

Rename new block definition 
The new imported block definition will be renamed. All references, existing or new imported, stay 
untouched.  
 

Do this for all conflicts 
If activated, the chosen procedure will also be used for any further conflicts. The dialog will not 
show up again. 
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Save [Ctrl + S] (only Windows) 
 

 Toolbar: Standard 
 

Menu: File ► Save 
 

CMD: VPSAVE ► Dialog 
 

CMD: VPSAVE <File Name(s)>  
 

CAD: _save ► Dialog 

If you use this command the first time after loading a document, the Export dialog pops-up to ask 
for a file name. As Default the name and extension of the opened file will be offered. Any future 
save of this file will automatically overwrite the previous save without any message.  
 

If the selected file format does not support all data of the document (e.g. any raster file format 
does not support any vector information) a warning will pop up on first use. 
 

 
 

Preview 
You can switch the preview on or off. The preview displays the data which will be saved. 
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Options 
For some file formats the Options … button will be enabled. In this case there are additional 
options available to specify how to save the data. For details please refer to the File Format 
Options later in this section. 
 

Layers 

The dialog Layer Manager is displayed for modifications of the layers’ export settings. See 
Section 4: Document Settings, Document Functions for details. 
 

Multi Page Document 
If your document is a multi page document you can save all pages into a multi page document or 
all pages into single files (i.e. each page into a separate file). The options All as multi page file 
is only available for specific file formats (e.g. TIFF + PDF). 
 
When saving multi page documents with the option As single files the software will prompt for a 
filename for each page. When using "%d" as part of the filename it will be replaced by the page 
count automatically. 
 
If you select Page No. "n", only this page will be saved into a separate file. 

 If you select/specify an already existing file (name) and this format supports multi page 
(e.g. TIFF + PDF), on Save you will be asked whether you want to override the existing file 
or append your current document as new page to the existing file. When Overwrite is 
selected only the modified pages will be replaced in the file. This happens only if no pages 
have been added, removed, or less than 30% have been modified. In all other cases the 
whole file will be written. Overwriting individual pages will increase the file size. To compact 
the file it is recommended to save it once in a while to a new filename.  

 
Only selected (on/off) 

Only the selected entities and/or images are exported. 

Default: on (if entities are selected) 
 

Georeferencing 
An additional file with placing data is created if the option Write Placing File is set to on. These 
files are used mainly by geographic applications (GIS). The file name equals the name of the 
raster file. The file extension is assigned according to the placing format (e.g. TFW or TAF). 

 In order to produce a valid TFW file the User Units of user coordinate system must be set 
to Meters [m]. Otherwise, an error message is displayed. 

 
Clear Undo Buffer (on/off) 

When saving is complete, all data in the undo buffer is deleted. 

Default: off 
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Save As (only Windows) 
 

 Toolbar: Standard 
 

Menu: File ► Save as 
 

CMD: VPSAVEAS ► Dialog 
 

CAD: _saveas ► Dialog 

Similar function as Save, except that the dialog always opens for assigning a file name. 
 
 

Export  
 

Menu: File ► Export 
 

CMD: VPEXPORT ► Dialog 
 

CMD: VPEXPORT <File Name(s)> [P|Page <value>] [O|Options <options string>] 

This function is very similar to Save with the difference that the document name is not changed to 
the name of the export file. Furthermore and without notice only those elements supported by the 
selected format will be saved. Exporting to e.g. TIF will only save the active raster image, since 
the format neither supports multiple raster data on one page nor any vector data. The options /tfw 
and /tfwf control the generation of Placing files (see Save) and, if so, which format should be 
used. 

 This command may also be started by the Save-Icon while the [Ctrl] is pressed. 
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Multi Raster Export 
 

Menu: File ► Multi Raster Export 
 

CMD: VPMULTIREXPORT ► Dialog 
 

CMD: VPMULTIREXPORT <dest. path> <File format> [/rn <0|1>] [/dn <0|1>] [/bn <Name>] 
 [/o <Options>] 

Export all raster objects of the current document. If raster objects are selected when starting this 
command, only these will be exported. The command can run interactively or automatic. 
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Dest. path 
Destination path. Enter a valid path or use the browse button to select one. 
 

Save as type 
Destination file format. Select one of the supported raster file formats. You can also choose the 
VP internal RVD format. 
 

Options... 
If the selected file format has additional save options, these options can be specified here. By 
default the last used settings for Export or Save will be used. Any modifications here will not 
override the last used settings and are valid only for this process. 
 

Mode 
• Automatic: The raster objects will be saved according to the settings below without any 

further prompt.  
• Ask for each file name:  Interactive Mode. For each raster object a dialog pops up to specify 

the file name.  
 

Existing files (only automatic mode) 
• Override without warning: Any existing file will be automatically overwritten. No warning will 

pop up and the process will not stop.  
• Stop and ask for new file name: The automatic process will stop and a dialog pops up to 

ask for new file name (see interactive Mode below)  
 

File name generation 
• Use raster name: The name of the raster object as shown in the Project Bar will be used. 
• Automatic: A Base name is used and a counter is appended, e.g. Name(001). As Base 

name either the document name (= document title) or any Other name specified below 
can be used. 

 
Parameter 

When starting the command with a complete command line (e.g. in a script), it always runs in the 
Automatic mode.  
/rn 1 = use raster name, 0=use base name (default: 1) 
/dn 1 = document name is base name, 0 = use other name (default: 1) 
/bn base name (default: the document name) 
/o options of the chosen file format. See File Format Options below (default: last used) 
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Interactive Mode / Existing files 
 
The dialog below pops up in either the interactive mode, or, if specified, if a file already exists: 

  
 
You can specify a new file name and a new destination path. If a file with this name already exists 
a warning will be shown.  
 
 

Save as RasterDWG (only CAD)  
 

  
 

Menu: File ► Save as RasterDWG 
 

CAD: _vpsaverdwg ► Dialog 

Saves the active document to a hybrid RasterDWG file.  
 
 

Close 
 

Menu: File ► Close 
 

CMD: VPCLOSE 
 

CAD: _close 

Closes the active document. If the document has been modified a message will ask, if the 
modified file should be saved or not. 
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Close without Safety Prompt (only Windows)  
 

CMD: VPCLOSEALWAYS 

Closes the active document without safety prompt ("Save changes?"). The purpose of this 
command lies mainly in script processing, when after a file export the document is still marked as 
modified but shall be closed anyhow. 
 
 

File Format Options 
 
Some file formats allow for setting additional parameters. The dialogs can be opened with the 
Options buttons in the Open/Import and Save/Export dialogs respectively.  
 
The available options for file formats are described below. 
 
 

Geo Referencing  
 
If the option Write Placing File is checked a separate file will be generated and saved under the 
name of the raster file but with the extensions TFW or TAF containing the positioning information 
of the raster image. This placing information will often be used in GIS applications for a correct 
placing with regards to the coordinate system. 

 In order to generate a valid TFW file the User Units must be set to Meter [m]. Otherwise, 
an error message appears. 

 
 

RVD Export Options  
 
For compatibility with older VP products the appropriate RVD file version can be selected. 
  

 
Default: VPHybridCAD V13/VPmap V6 

 Any RVD file version that is not the actual one may lead to a loss of data: e.g. the new 
Leader entity cannot be saved in any RVD-Version older than V13/V6. 
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JPEG Export Options  
 
When exporting raster data to JPEG you can specify the Quality of the created JPEG-file. 
 

 
 

Low Quality means high compression (small files), but also high color quality loss, High Quality 
means the opposite.  

Default:  75%. 
 
 

GIF Export Options  
 
The GIF file format allows you to specify a color via which should be transparent (not displayed). 
This color can be specified for all following exports to GIF. 
 

 
 

Do not write Transparency {on/off} 
This option turns off the transparency (none of the colors will be set to transparency).  

Default:  on 
 

Transparency by Palette Index 
The color according to the palette index displayed in the Image Palette dialog will be set to 
transparency. 

Default:  off 



 VP Software Manual 

60   Section 3     System Settings, General Functions Manual V16 - V9 / E 
 

  
 

Use Image Transparency where available 
Use the color, that is set under Transparency in the Image Palette dialog. 

Default: off 
 

Transparency by RGB Value 
The color defined by its RGB value will be set to transparency. Since only palette entries can be 
set transparent and often the RGB value does not exactly match a palette entry, there is an 
additional switch to find the nearest color in the palette. 

Default:  off 
 

Match Nearest Color {on/off} 
If checked on the closest index value matching the defined RGB value will be used to set this 
color to transparency. 

Default:  off 
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TIFF Export Options  
 
Exporting raster images using the TIFF file format provides a choice of several compression 
methods and strip sizes. The current settings are saved and will be used for future TIFF export 
operations. Modifications in the settings are recommended only if problems are encountered 
when loading exported files into other applications. 
 
For most images the default settings produce the smallest file sizes and can be loaded into most 
applications. 
 
When clicking the Default button all options are reset to default values. 
 

 
 

Strip Control 
TIFF data can be written in whole (single strip) or in strips. Select between: 

• Auto calculates the strip size so that it amounts to roughly 8 KB of 
uncompressed data. 

• Single Strip writes the file in whole. 
• Multi Strips The number of Rows Per Strip can be entered into the edit field. 

 Default: 512 

Default: Single Strip 

 A large number of strips result in large file sizes. Also, do not choose the option Auto with 
very wide images (> 6.000  pixels). 
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Color Options 
The compression method affects the resulting file size substantially. Colored images can be 
compressed as follows: 

• Uncompressed the data will not be compressed. 
• LZW Typically generates the smallest file sizes. 
• Packbits Compresses data using the Packbits method. 

Default: LZW 
 

Monochrome Options 
The compression method affects the resulting file size substantially. Monochrome (b/w) images 
can be compressed as follows: 

• Uncompressed the data will not be compressed. 
• CCITT Group 4 Generates highly compressed data. 

Default: CCITT Group 4 

 

GeoTIFF  
 

Do not write GeoTIFF information {on/off} 
If turned on a standard TIFF format without additional information about projection or geocentric 
coordinate systems will be generated. 
 

Define GeoTIFF information {on/off} 
Activating this option enables the button Define … to specify which kind of GeoTIFF data will be 
generated and included into the TIFF file. Pressing the button opens an extended dialog for 
specifying the primary keys for a GeoTIFF geo-referencing. 
 
In the GeoTIFF Options dialog you can choose whether to work with the standard GeoTIFF tag 
values according to the GeoTIFF 1.0 specifications or to have an extended list of tag values, 
which has been compiled from the EPSG Coordinate System Database. Also, settings from 
existing GeoTIFF files can be imported using the Load from File Browse … button. 
 
For detailed information on the GeoTIFF extension values please refer to: 

• GeoTIFF www.remotesensing.org/geotiff/geotiff.html 
• European Petroleum Survey Group (EPSG): www.epsg.org 

 

http://www.epsg.org/
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PDF Import Options  
PDF files can be imported as is on an object basis or as a single raster image. 

 
 

Read PDF Objects {on/off} 
The file is read on an object basis. As PDF does not support arc or circle elements, the option 
Convert Polylines to Arcs and Circles forces the program to try a re-computation of polylines to 
automatically convert them to an arc or circle. The Fit Tolerance is the maximum allowed 
deviation between the original polyline and the computed arc or circle. 
 

Convert each page to a single raster image {on/off} 
The content of each page is read as a single raster image. With Resolution and the image type 
settings (Truecolor, Indexed, Gray Scale or B&W) the image can be further specified. 
 

Try to extract text objects {on/off} 
In case the file contains text it will be preserved as individual objects.  
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PDF Export Options   
 
With the export into PDF the PDF version, placing, and extents, as well as the compression of 
raster data can be controlled. The compression method affects the resulting file size substantially. 
 

 
 

PDF/A conformity 
This will generate a PDF file for long-term archiving. Description... opens a dialog to enter 
optional information on Author, Theme and Keywords.  
 

Color Images 
Colored images can be compressed as follows: 

• LZW  Lossless compression. 
• DCT/JPG Compression with possible losses. Use the slider button to determine 

the compression degree (Quality). Low Quality will result in a high 
degree of data compression, however, with high losses of detail 
information. High Quality will result in a reverse effect. 

• Uncompressed Data will no be compressed.. 

Default: LZW 
 75% (with DCT/JPG compression) 
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Black&White Images r 

Black& White images can be compressed as follows: 

• Uncompressed the data will not be compressed. 
• CCITT Group 4 Generates highly compressed data. 

Default: CCITT Group 4 
 
 
DWG/DXF Import Options  

 

 
 

Layout Mode 
Determines which layout of the DWG / DXF file is to be loaded. You can either select the saved 
active layout or the standard model space. Alternatively, and prior to opening, a dialog can be 
displayed for individual layout selection (Show list with all available layouts), or to load all 
available layouts (Load all layouts (multi page mode). 

Default: Open drawing in saved layout 
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Password Protected Files 
• Ask for the password on open On opening a password protected file the 
  password has to be entered in a dialog. 

• Always use this password If many files use the same password it can be 
entered here for usage with all protected files. 
For safety it is saved in encrypted form. 
On opening a file no dialog is displayed. 

• Do not open password protected files Password protected files are not loaded. No 
dialogs or messages are displayed. 

Default: Ask for the password on open. 
 

Convert drawing 
The display of DXF / DWG drawings may differ from the display in other CAD programs. This may 
occur e.g. with line types, text styles, or polylines with assigned widths and bulges. For a display 
more true to the original all entities may be converted into basic entities like lines, polylines, and 
splines on import.  

 The conversion is only advised if the drawing shall be rasterized. Since the conversion 
produces a large number of entities the import may take a very long time. 

Default: No conversion 
 

Line widths 
VP Software uses absolute line widths, i.e. the display is independent of the zoom scale factor. 
With some drawings this may result in disproportionately thick entities. In this case use the option 
Set all line widths to 0.0. Alternatively, line widths may be adapted in the Layer Manager after 
loading. 
Default: Do not convert line widths 
 

Hatches 
Specify a directory where you want to search for hatch pattern styles. 
Default: \VPxx directory\SUPPORT\ 
 

Character Set 
You can determine which character set should be applied on import of non-Unicode text. Choose 
between Determine character set automatically (character set saved in the imported file) and 
Always use this character set (pre-defined character set). 

Default: Determine character set automatically 
 

Measurement 
You can determine which measuring unit will be used in the imported file. Automatic will assign 
the unit according to the currently active document (like on Import). 
Default: From file 
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DWG/DXF Export Options  
 

 
 

File Format 
Determines in which format DWG or DXF files will be saved. 

Default: AutoCAD 2007 compatible 
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Raster 
If you want to save raster data you can choose between RasterDWG and AutoCAD format. 
 
The RasterDWG format developed by softelec allows to save all raster image data inside one 
DWG file together with all vectors. Otherwise, you have to handle two or more files for one 
document (the DWG file and the raster file(s)). 
 
The RasterDWG format conforms to the DWG specifications. That is why RasterDWG files may 
be loaded into every standard AutoCAD product, BricsCAD, and ZWCAD. However, you need a 
RasterDWG driver for the corresponding product in order to display the raster data. Otherwise, 
only empty frames with a message are displayed. This RasterDWG freeware utility is available on 
your softelec product CD and at www.softelec.com. Once installed with 
AutoCAD/BricsCAD/ZWCAD, it allows for viewing and printing of both raster and vector data.  

Default: Save in AutoCAD Format 
 
Save Raster file(s) automatically generates file names without prompting the user.  

Default: off 
 

Seedfile 
If a Seedfile is specified it is opened and its content will be added to the document to be saved. 
This allows for establishing basic settings, such as grid, limits, coordinate system, or entities 
(company logos, drawing headers) in all DWG files. 

Standard: void 
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Conversion of VP entities 

Polygons can be exported either as Hatches or as Polylines using the option Export polygons 
as.  

Default: Hatches 
 

Character Set 
Determines the file’s character set (codepage). The exact setting can be important, e.g. if a file is 
to be opened on a computer with a different active codepage setting.  

Default: currently active system character set 
 

DXF: Floating-point precision 
The number of decimal places can either be set automatically according to settings in the 
current file, or it can be set as user defined. 

Default: Automatic 
 
 

DGN Import Options  
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Model Mode 
Determines which DGN file model will be loaded. You can choose between the saved  active 
model and a permanent default model. You can also choose to display all available models for 
an individual model selection prior to opening (Show list with all available models). 

Default: Always load active model  
 

Linewidth 
VP Software uses absolute linewidth values, i.e. their display depends on the zoom stage. In 
some drawings this may lead to displaying disproportionate thick elements. In these cases you 
can use the option Set all linewidths to 0.0. All linewidth values can also be adjusted individually 
in the Layer Manager. 

Default: Scale linewidths by  10.0 
 

Scaling 
VP Software uses absolute length values for linetypes, i.e. their display depends on the zoom 
stage. In some drawings this may cause details to disappear from the display. In these cases you 
can change the scaling value accordingly. 

Default: Scale linetypes by 1.0 
 

Convert Drawing 
The display of DGN files in VP software may differ from their display in MicroStation©. This may 
occur e.g. for linetypes, textstyles, or polylines with specific widths or curves. To ensure a proper 
display these elements can be converted to basic element structures, such as lines, polygons and 
arcs. 

 The conversion is only recommended if you want to rasterize the loaded DGN file. The 
conversion may also cause to generate very many basic elements. Thus, loading the file 
may take considerable more time. 

Default: No Conversion 
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DGN Export Options  

 
The following DGN export options are available in the Options dialog. 

 
 

File Format 
Files can only be saved in V8 Format. 
 

Seedfile 
Activate and specify if you want to use a specific seedfile.  

Default: off 
 

Line widths 
Line widths can be changed to a fixed width of 1 pixel or to a specific pixel number per 1mm. 

Default: Set all line widths to 1 pixel 
 

Raster 
Raster data can be saved in two different ways. Either, they can be embedded in the DGN file or 
they can be saved in an extra file as an attachment to the DGN file. 

Default: Embed Raster in DGN File 
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Save Raster File(s) automatically will generate separate Raster files with no user prompting. 

Default: off 
 

Attributes 
Specify whether attributes will be exported as text with the given Textheight in user units. 

Default: on; Textheight: 3.0  
 

Advanced 
A dialog opens to determine Master Units and Sub Units: 
 

 
 
Master Units always refer to the current User Units. Sub Units may be set automatically 
depending on the Master Units, or you set them individually. 
 
List of automatic settings Master Units – Sub Units: 
 

mm - µm in - µi 
cm - mm ft - in 
m - mm yd - in 
km - m mi - ft 

 nm - ft 

Default: Depending on Master Units 
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CGM Export Options  

 
To export a CGM file options for CGM Version, Parameter Type (Precision), Layer Information, 
and type of Raster Export within the CGM file can be defined. 
 

 
 

CGM Version 
Select between Version 1, 3, or 4. 

Default: Version 3 
 

Parameter Type 
Choose between Real (i.e. all data are saved as floating point values, larger coordinate values 
are possible; this may be necessary if the drawing size is very large) and Integer (all data are 
saved as integer values). With Integer either 16-bit (small drawing size) or 32-bit (large drawing 
size or higher precision) can be specified. 

Default: Real 
 

Layer Information 
Since the CGM-format does not contain layer assignment, this setting allows for keeping the layer 
information of VP Software by the entity color: all elements are assigned to the color of their layer 
and therefore, can easily be identified in another CGM-program.  

Default: off 
 



 VP Software Manual 

74   Section 3     System Settings, General Functions Manual V16 - V9 / E 
 

  
 
Raster 

If Write out Raster is on the raster data will be saved inside the CGM file. b/w raster can be 
saved either uncompressed or RLE-compressed; colored raster will always be saved 
uncompressed. 

Default: off 
 

SVG/SVGZ Export Options  
 
The following options are available when exporting in SVG/SVGZ format: 
 

 
 

Output Size 
You can choose between Keep original Size in millimeters or pixels or Scale to fix Size. For 
the latter you can specify custom maximum Width and Height values. 

Default: Keep original Size (px) 
 

Precision 
Coordinate precision (digits) may be specified either directly (Exact n digits), or it may be 
calculated automatically by the program. 

Default: Automatic 
 
Ellipses as Polylines: Ellipses are exported as polylines. 

Default off 
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Raster Images 
Raster images can be exported as external references, i.e. images will be saved as separate 
files. The raster name is used as file name. You can specify the file format and a subdirectory 
for the files. 

Default off (= embedded) 
 

Text 
Hotspot Text as Rectangles: Instead of a text a filled rectangle will be exported. You can specify 
the transparency, the color, and the width of a frame of the rectangle. With Keep Text, the text 
plus a rectangle is exported. 

Default off 
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SHP Export Options   
 
A dialog opens to define the interpretation of entities, since the SHP format only supports 
lines/polylines, polygons, and points:  
 

 
 
Each shape file can only contain one entity type. Therefore, for each layer and each of these 
three entities types (if more than one entity type has been assigned to a particular layer) one 
separate file will be created with the suffix: 

• POLYLINE 
• POLYGON 
• POINT 

 
Shape File Options 

The option Use Layer Name as Filename means that the specified filename will be ignored and 
the files will be created at the specified location using the layer names. 
 
Furthermore, you can select which entities you want to export: Points, Polylines, Polygons. 
 
If the Write Z Coordinates option is turned on, all elements will be written as 3D elements. 
 

Entity Conversion 
The Precision defines the maximum deviation between the original entity (e.g. circle) and the 
converted entity (e.g. polyline). 
 
With the other options you can specify how specific entities like texts or hatches should be treated 
on export. 
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MIF Export Options   
 
For generating a MIF file options for Layer Settings, File Version, Delimiters, Precision, and 
Coordinate System settings can be defined. 
 

 
 
When saving data to the MIF format, the entities of each layer will be saved into a separate file. 
The layer name will be appended to the specified file name. 
 

Use Layer Name as Filename {on/off} 
If this option is turned on, the specified file name will be ignored and the filename will be equal to 
the layer name. 
 

MapInfo File Options 
Select the Version (300 or 450) of the MIF format. 
 
The Delimiter will be used to delimit the data fields in the MID file. 
 
Since the MIF format does not support all geometric entities available with VPmap Series 
products the not supported entities will be converted to polylines (e.g. elliptical arcs). The 
Precision defines the maximum error allowed for this conversion. 
 

Coordinate System 
Specify None if no coordinate system information should be stored in the MIF file. By default 
these data will then be interpreted as degree coordinates. 
 
Activating the From File option allows you to specify a reference file for the coordinate system. 
The coordinate string from this file will be displayed in the dialog. It is possible to modify the string 
in the dialog. 
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Scan   
 

 Toolbar: Scan 
 

Menu: File ► Scan 
 

CMD: VPSCAN ► Dialog 
CMD: VPSCAN [/L|Lastscanner] 

This function allows for operating connected scanners either using a TWAIN Interface or by the 
built-in Large Format Scanner Interface. Major large format scanners can be operated directly 
from within the program. Depending on the type of scanner a corresponding dialog box opens to 
enter the essential parameter settings according to the respective scanner's specifications. For 
more information regarding supported scanners see the Appendix. If more than one scanner is 
attached you can select the desired scanner from the upcoming dialog.  

L|Lastscanner The dialog for the scanner selection is suppressed. 

Scanners controlled by the TWAIN interface have individual user interfaces for setting-up and 
operating the scanner. If a TWAIN driver is available on system level (i.e. installed and activated) 
then VP Software will offer to operate this scanner.  

Using the built-in large format scanner interface the following dialog appears: 
 

 
Scanner Dialog for Large Format Scanners 
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Functions 

 
Depending on the connected scanner, the software supports the following scan modes: 

• Black/White 
• Grayscale 
• Color (Indexed, 256 colors max.) 
• Truecolor 

All other options will be activated or deactivated according to the specifications of the connected 
scanner device. 
 
The upper area of the dialog is divided into two areas: 

Left window: Display of an area of the scan in 1:1. Use the slider of the right window to 
specify the horizontal position of the area. 

Right window: Overview window: a small frame indicates which area is currently 
displayed in the left window. 

 
Buttons: 

Scan Start scan. 
Stop Stop scan. 
Close Close scan dialog. 

 
General Functions: 

Scan Mode Sets the current scan mode (b/w, gray scale, and color). 
Scan Width Depending on scanner type: Format and/or Variable 

With CalComp, Océ, Contex scanners: 
Variable: paper is left or right aligned (0 position) 
Format:  paper is centered 
Scan Width is set according to scale (units) on scanner. 

Resolution Depending on scanner type: fixed and/or variable. 
Append Page The image will be appended as a new page to the current document. 
Palette Scan using a previously generated palette (only in color mode). 

 
Black/White Options: 

Depending on the scanner type the following functions are available: 
Line Enhancement Increases the line thickness. 
Dynamic Enhance  Increases the contrast. 
Adaptive Threshold Threshold depending on Area.  
Threshold Standard threshold (0 - 255). 
Adaptive Level Contrast threshold (0 - 100). 
Background Suppression Suppression of speckles (0 - 100). 
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Color and Grayscale Options: 

Brightness Range: -128 - 128. 
Contrast Range: 10 - 1000 (in %). 
Blur Filter to reduce dithering in color scans : 0 - 3. 

 
When executing a 256 color scan, the following dialog box appears after pressing Scan: 
 

 
 

Computed Color Map The system performs a prescan to calculate an optimized palette 
for the current drawing. The palette size can be selected between 
4 and 256 colors. 

Linear Color Map A standard palette will be used for the scan. The palette 
represents the whole color space. 
8, 16, 27, 125, 216 and 256 colors can be selected. 

Load Palette Load a specific palette (*.VPL) which has been previously 
generated (by Save Palette). 

 
 

Description of Terms 
 
Different manufacturers use different terms for the same functions of their scanners. The 
following table shows the terms used by VP Software and their equivalents: 
 

VP Software Dialog Scanner Function 
Adaptive Threshold Adaptive Area Threshold 

2D-Adaptive Threshold 
Adaptive Level Area Brightness 
Background Suppression Variability 
Line Enhancement Edge Enhancement 
Dynamic Enhancement Dark Enhancement 
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Print [Ctrl + P]  
 

 Toolbar: Standard 
 

Menu: File ► Print 
 

CMD: VPPRINT ► Dialog 
CMD: VPPRINT [/VPP <VALUE>] [/P <VALUE>] [/FT|FROMTO <FROM PAGE> <TO PAGE>] 
 [/BW] [/MP] [/MR]  [/SLW] [/CW <VALUE>]  
 [/S|SCALING <SCALING><X-OFFSET><Y-OFFSET>] [/V|VIEW] 
 [/W] [/WIN|WINDOW <STARTX><STARTY><ENDX><ENDY>] [/C|COPIES <VALUE>] 
 

CAD: _plot ► Dialog 

Any printer or plotter device installed under the operating system may be used for printing raster 
and/or vector data. However, the capability of processing raster data not only depends on the 
printer/plotter model, but also on the installed Windows drivers. A dialog box opens to determine 
scale, offset, paper format, and printing area. Raster and/or vector data can be selected for 
printing according to the monitor screen display. 
 

Using the command line: 
/vpp <value> Settings file (if set, all other values will be ignored) 
/p <value> Printer Name 
/f <value> Output Path 
/ft <value> Page Range to Print (negative values for active page) 
/bw  Print as Black&White 
/mp  Use Printer Driver 
/mr  Print as Image (Rasterize) 
/slw  Scale Line Widths 
/cw <value> Width Table File 
/s <value> Scaling and Offset 
/v  Print View 
/w  Whole Drawing 
/win <value> Window 
/c <value> Number of Copies 
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Without command line parameters, the printer dialog opens for selection and specification. When 
the command line is used the last used printer is selected: 
 

 
 
Select the Print Range and the number of Copies. Other options are: 
 

Extents 
Choose between Whole Drawing, Current View, or Window. For the latter check the button 
right to the Window option and set a window with two click points in the preview area. The 
selected window area will be displayed with a red frame. 
 

Printing Options 
Choose between Use Printer Driver (default setting) or Print as Image. If you encounter 
problems when printing hybrid data (i.e.. a mix of raster and vector data) or with large formats due 
to limitations of the standard printer driver use the option Print as Image. Then, VPHybridCAD 
rasterizes all entities into a temporary plot file and sends this file to the printer/plotter. Use the 
option Print as Black&White to print color vector data on black&white printer with a better 
quality.  
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Plot Style Definitions 
To control printing colors and line widths either the Layer Settings for printing or a Plotstylefile 
may be specified. Supported plot style files are AutoCAD CTB or user generated RTB files. The 
settings can be reviewed and changed using the modify button. 
 
With the option Scale Linewidths vector linewidths will be printed with a scaling factor set in 
Scaling. Without this option linewidths will always be printed according to their settings. 
 

Scaling 
Allows for arranging the image size according to user demands in terms of scaling and offset. 
With Fit Paper Size the selected Extents will be scaled to fill the entire paper space. Drawing 
Scale and Fixed Scaling will scale elements in the selected extents with the given factor or 
percentage. 
 

Preview Area 
The preview area’s display can be adjusted with the buttons on top of the dialog. A green frame 
display the printer’s current paper settings. The outer frame refers to the paper extents while the 
inner frame refers to the print space. When Fit Paper Size is switched off the paper extents 
position can be moved with the mouse. When releasing the mouse button the move values will be 
updated. The zoom factor can be changed with the mouse wheel. 
 

Save Settings 
Save the actual printing settings including the printer and its properties. The file format for print 
settings is VPP. 
 

Load Settings 
Load a previous saved print settings file (VPP). 
 
 

Print Preview 
 

Menu: File ► Print Preview 
 

CAD: _preview ► Dialog 

The Preview option allows for previewing print results to support an accurate positioning. 
 
 

Print Setup 
 

 

CMD: VPPRINTSETUP ► Dialog 
 

CAD: _plottermanager ► Dialog 

A printer/plotter can be selected and activated. 



 VP Software Manual 

84   Section 3     System Settings, General Functions Manual V16 - V9 / E 
 

  
 

Load Extensions  
 

Menu: File ► Extensions 
 

CMD: VPEXTENSIONS ► Dialog 

Loads the software extensions to the program. A dialog box opens, listing all available extensions 
and showing their status. An extension can be loaded and installed (activated for use). The 
program usually loads and installs all necessary extensions:  
 

 
 
 

Exit  
 

Menu: File ► Exit 
 

CMD: VPEXIT 
 

CAD: _exit 

Exits the program. If there is modified data in memory which you have not saved yet, a box opens 
asking you to save before the program terminates. 
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Plot Style Settings (only Windows)  
 

Menu: Options ► Plots Style Settings... 
 

CMD: VPPLOTSTYLE ► Dialog 

 This command may also be started by the Plot Style View-Icon while the [Ctrl] is pressed. 
 

Plot style files are used to adjust colors and line width for printing and plotting. With Options 
Plot Style Settings the usage of plot style files can be configured. The following dialog will open: 

 
A general plot style file for all documents can be selected, created, or modified in the General 
Settings section. Valid plot style files are AutoCAD CTB files or VP generic RTB files. In case of 
CTB files the VP software will only interpret the color and line width information. 

Default: None 
 
The Current Document Settings section shows the settings for the active document. When 
opening a DWG file which is linked to a CTB file, this CTB file (if found) is automatically loaded. 

 In case that the CTB file is not found in the directory of the DWG file or in the path for 
Support and SHX Font File as specified in the Systems Settings (see further down in this 
chapter) and Current File is set to Use default file, the default file is automatically loaded.  

When Show warning if plot style file is missing is activated a corresponding message 
will be displayed. 

Default: Use default file 
 

Create a new plot style file 

 Click this button to create a new plot style file. The Color Data dialog will open that allows to 
define for each color a Width and Print Color (see also chapter 4: Color Manager). The 
defined width values from the current document will be used. 
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View / modify plot style file 

 The Color Data dialog will open with the specified Valued (Width and Print Color) from the 
selected plot style file (see also Chapter 4: Color Manager).  

 Changes can only be saved to the VP generic RTB format.  

When choosing a new file name for saving, the Default file or Current file is automatically 
updated.  
 
 

Modify Plot Style  
 

 
 

The dialog displays the colors from the loaded plot style file. A Width and a Print Color is 
assigned to each color. The settings may be modified for single or multiple selections of colors. 
With the width By Entity all entities of this color are displayed with their original width (width 
either from entity or the one specified in the layer settings)  
 
Width and Print Colors can be loaded from and saved to plot style files. Use Load to import 
these values from a CTB or RTB file. With Save As… the current settings can be saved to a RTB 
file. 
 
With Save & Close the changes will be confirmed and saved to the selected plot style file. 

 In case the original plot style file is an AutoCAD CTB file, the Save as... dialog will open, 
since only the RTB format is supported for writing.  
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System Settings    
 
The system settings define the general operation environment of your program.  
 

Menu: Options ► System Settings 
 

CMD: VPSYSTEMSETTINGS ► Dialog 

A dialog box opens to define the system's general setting values. 
 
 

General Tab 
 

 
 

Drawing Units  
Choose either mm or inches. The drawing units you select determine how the raster image will 
be interpreted in terms of units of measure. The units have an effect on the X/Y coordinate 
system and on all depending values and parameter settings. 

Default: mm 
 

Default Text Font  
Selection of the default text fonts for text style creation. All existing and scaleable True Type 
Fonts in your Windows system are available. 

Default Font: Arial 
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Zoom-In on First Click 

This option controls the automatic zoom for commands that use the "triple frame" cursor, e.g. the 
VPDESKEW command. 

Default: 1:16 
 
Pick Box Size  

This setting controls the size of the cursor square box (in pixels of the monitor screen) used when 
elements are selected (pick area). It also defines the grip size of the selected entities. 

Default: 8 [pixels] 
 

Cmd Echo {on/off}  
Set to on the command name is displayed in the command line window whenever the command 
is started via menu or toolbar button. 

Default: on 
 

Display Info 
Show Context Menus  
When set to on, the default context menu appears when clicking with the right mouse key. The 
default context menu will be replaced by other special menus, depending on the active function. 

Default: on 
 
Show Status Tooltips  
When set on status messages will be displayed as tooltips next to the mouse cursor.  

Default: on 
 

Show Warnings 
Current Layer off  
When set on a warning will come up upon switching off a current layer setting. 

Default: on 
 
Current Raster off  
When set on a warning will come up upon switching off a current raster setting. 

Default: on 
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Colors Tab 
 

 
 
Some of the screen colors can be defined individually: 

Category: Screen color: Screen color: 
 white on black black on white 

• Window Background (black) (white) 
• Cursor (green)  (black) 
• Active Image Border (red)  (red) 
• Raster Selection (red) (red) 
• Speckles (green) (green) 
• Raster Holes (red) (red) 
• Move Grip (black) (white) 
• Other Grips (black) (white) 

The System Default values (in brackets) can be reactivated when clicking on the white on black 
or black on white buttons. 
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Files / Paths Tab 
 

 
 

Auto Save {on/off}  
While working with the program an automatic save of open documents will occur at selectable 
intervals. You can specify the Interval and the Drive and the Path for the Auto Save individually.  

Default: on 
Default Directory: no entry = document's current directory  
 
For the auto save operation the system uses the filename of each document extended by "_" 
(underscore) + numbering. The extension is RVD. Sample: ARCH.TIF will be auto saved as 
ARCH_0157.RVD 

Default interval: 60 [minutes] 
 

Purge Auto Save Files on Close 
If you set purge auto save files on close to on the system will delete all auto save files on closing 
a session. 

Default: off 

 We strongly recommend not to switch off Auto Save.  
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Prototype Drawing  
With a Prototype Drawing you can create documents according to your needs.  
 
The prototype drawing is a RVD file, which is preloaded with every new document (Open or 
New). The prototype drawing may contain predefined objects like layers, line types, text styles, or 
block definitions. It may also contain visible entities like a drawing frame. For different kind of 
projects you may use different prototype drawings. 
 
A new prototype drawing is created in two steps:  
1. Create an empty document or open an existing prototype drawing. Then adjust/create layers, 

line types, user units, etc. to your need. Save this document in the internal RVD file format. 
2. Specify this RVD file in the according edit field or use the Browse button to search for it. 

Default: \<VP directory>\SUPPORT\PROTO.RVD 

 By default the prototype drawing is only preloaded on New  or on Open  of a pure raster file 
or with a PDF file. With file formats that contain also layers, line types, etc. the prototype 
drawing is not preloaded, unless you have explicitly activated the switch below. 

 
Always use Prototype Drawing: If on the prototype drawing is preloaded with every Open, 
regardless of the file format. 

Standard: off 
 
Show selection dialog: If on the New command will show a dialog to select a specific prototype 
drawing.  

Standard: on 
 
Support Path  

The directory of files containing parameters, prototypes, and other auxiliary information. 

Default directory: \VPxx directory\SUPPORT 
 

SHX-Font File Search Paths  
These directories are used by the software to search for SHX font files. The 
AutoCAD/BricsCAD/ZWCAD system paths (if existent) are registered here upon installation of the 
software. 

Standard: If existent: CAD system paths; else: Empty 
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Open / Save Tab 
 

 
 
You can specify which folder you want to use as a standard for open, import. save and export. 
 
 

License Tab  
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Enable Full Version {on/off} 
Activates a VP Software full version product permanently. Otherwise, the software operates in 
demo mode and will not search for a license (hardlock). 
 
If you have your VP Software installed as Network License(s), enter the Server Name to search 
for an available license or browse for the server computer.  
 

Get a Trial License 
Opens a dialog that either prepares an e-mail to apply for a Trial License or to activate the 
returned license. With this Trial License your Demo Version runs temporarily as a full version. 
 

Enable Network Search {on/off} 
If set to on, the whole network will be scanned for a valid VP Software Network License, if no 
license can be found at the predefined location. This operation may take some time. 
 

Install Hardlock Driver 
If the proper driver for the hardlock (Sentinel or Hasp) is not yet installed, the button Install 
hardware lock driver is active. Click on the button for driver installation. 

 To modify these settings administrative rights are required! To start VP in administrative 
mode use right mouse click on the VP start icon and select the "Run as Administrator" 
option. Installation of the hardlock driver always requires administrative rights. 

 
 

Raster Image Tab  
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Default Resolution 

If a loaded/imported raster image does not contain a valid resolution (DPI) a standard value will 
be set. 
Default: 300 DPI 
 
 

Move Raster Images to active Layer {on|off} 
The currently active layer will be assigned automatically to a new loaded/imported raster image. 
Default: off 
 

Move Raster Images to this Layer {on|off} 
The named layer will be assigned automatically to a new loaded/imported raster image. The layer 
will be created automatically if it has not been created before. 
Default: on, Raster 
 

Highlight active image {on|off} 

The active raster image will be highlighted with a colored frame. The frame color can be defined 
in the Colors tab. 
Default: on 

 
Black and White Draw Mode 

The options are Draft and Enhanced. With Enhanced a B&W image is displayed on the screen 
as gray scale image. Depending on the zoom state thinner lines are faded out. Single pixels and 
small objects might disappear at all. In Draft mode a "black wins" algorithm is used ensuring that 
almost all pixels and thin lines are displayed. Enlarging to 1:1 or more will always display all pixels 
from the raster image. 

Default: Draft 
 

Color Image Draw Mode 
 
The options are Draft, Enhanced and Proof. These display methods differ in speed (Draft = 
quick, Proof = slow) and a better visibility of details in small scaled views or zoom extends 
(Enhanced and  Proof). 

Default: Enhanced 
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Raster Selection Tab  
 

 
 

This tab controls how entities are created when using the Direct Raster Selection. For more 
details on Direct Raster Selection see Section 4. 
 
 

CAD Entity Recognition {on/off} 
 
If switched on the Direct Raster Selection tries to generate CAD Entities. Depending on the 
additional settings these can be arcs, circles, lines, or more complex entities. 

Default: on 
 

Arcs & Circles {on/off} 
If switched on the Direct Raster Selection tries to generate arcs and circles. 

Default: on 
 

Angle Correction {on/off} 
Corrects small deviations at 0 and 90 degrees. 

Default: on 
 

Stop at Intersections {on/off} 
Entities are only recognized up to the next intersection with other elements. 

Default: off 
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Complex Entity Recognition {on/off} 
If switched on the Direct Raster Selection tries to generate complex entities like dashed lines, 
hatchings, or text. This can be controlled in more detail with the options describes below. 

Default: off 
 

Max. Recognition Area 
The area range in the drawing that is examined to find complex entities. The larger the value, the 
more processing time will be needed to find entities. The value (in base units) is the edge length 
of a square which is centered around the click point. Only entities that are completely inside this 
square will be considered. 

Default: 100 [mm] or 3.937 [inch] 
 

Dashed Lines {on/off} 
If switched on the Direct Raster Selection tries to generate dashed lines. 

Default: off 
 

Hatching {on/off} 
If switched on the Direct Raster Selection tries to generate hatchings. 

Default: off 
 

Text {on/off} 
If switched on the Direct Raster Selection tries to generate text while the text settings can be 
changed using the Advanced button. 

Default: off 
 
 

Advanced 
 
A dialog opens which controls text search details: 
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Max. Text Height 
Defines the maximum size of isolated structures to be processed during entity recognition. 
Choose a maximum text height for searching text structures up to the specified height. 

Default: 4 mm, 0.157 inch 
 

Search Directions 
The search for different text orientations can be limited. With more active options the text 
interpretation process will take longer respectively. 
 
Search Directions are: 

• Only Horizontal 
• Horizontal and Vertical 
• Arbitrary 

Default: Arbitrary 
 

Only Polylines {on/off} 
If switched on the Direct Raster Selection tries to generate only polylines which stop at 
intersections. 

Default: off 
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Redlining Configuration Tab   
 

 
 
Enable or disable access restrictions. 
 

Enable Access Restrictions 
If Enable Access Restrictions is activated the path to the redlining configuration file is required. 
Then, a logon to the redlining session using user name and password is required. 
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Change Password 
Clicking Change Password opens a dialog box to modify the password for redlining. 
 

 
 
 

Shortcuts Tab   
 

 
 

For frequent insertions you can define up to 35 ASCII character strings as character shortcuts, 
especially those which are not available from a direct keyboard entry. Use the Windows character 
map (CHARMAP.EXE) for selection. Use [Alt + 1] - [Alt + 9] and [Alt+A] - [Alt+Z] while entering 
or correcting text strings to insert these special characters.  
 
Also, shortcuts are helpful for supporting quick insertion of repeatedly used text strings, prefixes, 
suffixes, etc.  

Default shortcuts: see Dialog Box above 
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User Interface Look Tab (only Windows)  
 

 
 

Select Scheme 
Here you can change the look of the User Interface. Several designs are offered for selection. 
Depending on your Windows version the User Interface may look slightly different from the 
displayed preview. 
 

Reset Dialogs 
All dialogs will be resetted to their default size and position. Use this function if some dialogs do 
not appear on the screen e.g. in case of a monitor switch. 
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File Extensions (Windows only)  
 
Here you can specify which file types will be associated with VP. If checked, the Windows 
Explorer shows these kinds of files with a VP- Icon and starts VP to load the file when double-
clicked. 
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OCR Options    
 

Menu: Options ► OCR Options  
 

CMD: VPSHOWOCRDIALOG  

The following dialog opens: 
 

 
 
Character Set defines the recognizable characters and/or numbers.  
 
The text recognition may be adjusted to the specific content of a drawing. These options are 
available:  
 

Recognize any characters of this language {on/off} 
Characters of the selected language are to be recognized. Upper case and lower case characters 
and numbers can be distinguished additionally. 
Default: on, English 
 

Recognize numbers only {on/off} 
Only numbers are to be recognized. As an option, a separate recognition for Handwritten 
numbers can be used.  
Default: off 
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Recognize additional characters only {on/off} 
Only characters, special characters and numbers defined in Additional Characters are to be 
recognized. 
 

Additional Characters 
All characters, special characters and numbers defined here are to be recognized in addition to 
those characters defined in Character Set. 
Default: none 
 

Text in Boxes 
If checked the program tries to filter any lines around or in between the text to recognize. 
Default: off 

 
Remove space characters 

All gaps between characters which are recognized as space characters will be deleted.  
Default: off 
 

Use Training files {on/off} (for non-Asian languages only) 
With OmniPage Professional (not part of the VP software) training file (*.otn) can be generated. 
This can improve the recognition rate of specific characters that appear in similar documents.  
 

Use Spell checking {on/off} (for non-Asian languages only) 
For the following languages dictionaries are available:  

German (R_GER), English (R_ENG), Italian (R_ITA), Spanish (R_SPA), Catalan (R_CAT), 
French (R_FRE), Netherlands (R_DUT), Portuguese (R_POR), Danish (R_DAN), 
Swedish (R_SWE), Norwegian (R_NOR), Finnish (R_FIN), Greek (R_GRE), Polish (R_POL), 
Hungarian (R_HUN), Czech (R_CZH). 

 
With User Dictionary {on/off} (for non-Asian languages only) 

In addition individual dictionaries can be used. A user dictionary is a simple text file with a single 
word in one line followed by the character "A" in the next line. 

 
In case that the Spell checking Dictionary is set to "None" only the User Dictionary will be 
used.  

 Remark: Even with Training files or the use of dictionaries the OCR might produce 
wrong results. The OCR uses multiple criteria to evaluate its results and terms, which 
look similar to words in the dictionary but might still interpret them wrong. 
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Remove lines/boxes 
Useful for forms with boxes for each character. If on, these boxes will be removed before the 
recognition is performed. 
Default: off 
 

Text is thin/ normal/ fat 
Specify whether text is thin, normal, or fat. 
Default: normal 
 

Adjust to fix font size (only for single line recognition) 
The raster text is automatically scaled to an optimal text height for the OCR engine. This option is 
also useful if the texts is broken or has low placed characters like an underscore. For Asian 
languages this option should be always on. 
Default: off 
 

Try 2. Recognition (only for multi-line recognition) 
If Text is larger n Pixel (for non-Asian languages only): If the recognized characters are larger 

than the specified size, the text will be downscaled and a second recognition will be 
performed. The best result will be used. 

 
If Text has a H/W smaller than <value> (for Asian languages only): If the recognized character 

width to height ratio is smaller than the specified value, the text will be upscaled and a second 
recognition will be performed. The best result will be used. This may improve the recognition 
of Asian half-width fonts. 

Default: off 
Size: 60 Pixel 
H/W: 0.7 
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Symbol Library    
 

 Toolbar: Symbol Library 
 

Menu: Edit ► Symbol Library Manager  
 

CMD: VPSYMBLIB  

The following dialog opens: 
 

 
 
You can read data from any directory of your hard disk and load accessible files into the library 
manager. With Drag & Drop symbols, blocks, or even complete drawings can be copied from the 
symbol library into a document and vice versa. Symbol Library display options and modes can be 
set in the menu Options ► Symbol Library Configuration.  

 Search and select the directory from where you want to load data into the Library Manager. The 
folder history list displays a maximum of 20 entries. 
 
Wildcards can be used to preview only files which match a specified name pattern. For example, 
if you want to see only files that start with the character "b" you can use wildcard patterns like b*, 
b*.*, b*.tif, *.tif, etc. (according to standard conventions). 
 
All formats accepted by VP software can be loaded.  
 
Folder symbols in the upper left corner indicate vector drawings containing blocks and multipage 
files. Use double-click or select Show Blocks from the context menu to display these block 
definitions or pages respectively. 
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Functions 
 

Drag & Drop 
 
Import a file with a left mouse click in the Symbol Library and dragging the file into an existing 
document. The file will be opened in a separate window when dragging it onto a toolbar or when 
no document has been opened. Files may also dragged and copied into a Windows Explorer 
folder; with holding [Shift] files will be moved. 
 
To add individual elements from a document to the Symbol Library select them and click on any 
position, however, by avoiding an element grip. Wait until the cursor changes to Drag & Drop 
mode. Now, drag the element into the Symbol Library (file format is always the internal RVD). A 
file name will be assigned automatically. To change the file name click the file with the right 
mouse button and use Rename from the context menu . 
 

Copy (only Windows) 
The clipboard provides a convenient way to exchange files, especially when a specific file needs 
to be used several times in sequence. Click the file with the right mouse button and Copy. The 
file may then be inserted multiple times with Edit ► Paste. 
 
Data from the clipboard may also be added from the context menu with Paste to the current 
Symbol Library folder. 
 

Paste 
A double left mouse click in the Symbol Library will insert a file to the active document. There are 
three different modes which can be defined in the Symbol Library Configuration.  
 

Delete / Rename 
Files can be renamed or deleted directly. Click the right mouse button on the respective file and 
select the command from the context menu. 
 

Show Blocks 
In vector drawings this context menu command will display all block definitions of the respective 
file. In case that the select file is a multi page document all pages are displayed. 
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Symbol Library Configuration 
 

 Toolbar: Symbol Library 
 

Menu: Options ► Symbol Library Configuration  
 

Context menu: Symbol Library Configuration 
 

CMD: VPSYMBLIBCONFIG  
 
 

General Tab 
 

 
 

View/Navigation 
Symbols with a folder symbol attached to the upper left corner will not be inserted on a double 
click. Instead, the content will be displayed like in a subdirectory. In general, this will happen with 
multi-page files or with block definitions. 
 
With the option Include subdirectories all files in a subdirectory of the current Symbol Library 
folder will be displayed. 

Default: off 
 
The option Enable directory navigation displays the superior directory and all existing 
subdirectories with a folder symbol. With a double click the selected directory will become the new 
Symbol Library folder. 

Default: on 
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When switched on the option Expand multipage files displays an individual symbol for each 
page of a multi page document. 

Default: off 
 
The option Expand contents of items displays a folder symbol in the upper left corner of a 
document when block definitions or more than one page are contained. 

Default: on 
 

Insert 
These options provide control of how files are inserted with a double click. 
 
When  Show insert dialog is switched on the insert dialog will appear. 

Default: off 
 

 
 
With Use Merge for positioning the Merge command will be started and completed for the 
selected file, i.e. it will be merged with the document’s active raster image. 

Default: off 
 
With Insert at default position the selected file will be placed according to the contained 
placement information in the file. 

Default: on 
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Display Tab 
 

Thumbnail / List 
The display mode can be switched between Thumbnail and List. Thumbnail will provide an 
image preview, List will provide file information in detail.  

Default: Thumbnail 
 

 
 
Columns controls the number of thumbnails in a row in the Symbol Library. List provides various 
options for displaying file information in detail. 
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Paper Format Manager     
 

Menu: Options ► Paper Format Manager  
 

CMD: VPPAPERMANAGER 
 
The following dialog appears: 
 

 
 

Add/Edit 
A dialog opens for adding or modifying a paper format. The format properties are interpreted as 
values in drawing units (mm or inch). 
 

 
 
The properties of the selected paper format are preset. A new paper format is created when the 
Name is changed. Otherwise, the selected format will be modified. 
 

Width 
The new Width of the selected format. If As Desired is on, the Width field will be grayed. In any 
case the width of this format is the full width of the image to be processed. 
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Height 
The new Height of the selected format. If As Desired is on, the Height field will be grayed. In 
any case the height of this format is the full height of the image to be processed. 
 

Margins  
The 4 margins determine the distances between the drawing frame and the physical paper 
limits (= Width and Height). For example, the length of the paper form (taken from edge to edge 
of the paper) minus both margins (left and right) defines the actual frame length of the drawing. 
 

Different Margins {on/off} 
If not selected only one margin value serves for all 4 margins of the drawing. 

Default: off  
 

Reset Forms 
Discards all modifications on the standard formats (incl. deletion). User defined formats are 
deleted. 
 

Delete Format(s) 
Deletes the selected paper format(s).  
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SECTION 4   
DOCUMENT SETTINGS, DOCUMENT FUNCTIONS, 
BASIC EDITING  
  

General Information   
 
These settings define your CAD environment for each document such as layers, linetypes, colors, 
text styles, image settings for raster files etc. You may use the Prototype Drawing to set up your 
personal environment. The prototype drawing will be loaded automatically to a new document or 
whenever you start with a raster file into a new document. If you save a document to RVD format 
or export a document to RVD, RDWG, DWG, or another vector or hybrid format your 
environmental settings will be saved or exported (as far as the export format allows for) to that 
file. 
 
 

Page Control (only Windows)    
 
If a document has more than one page you can use the page control toolbar for page selection 
and manipulation. Inaccessible icons are grayed. The commands are grouped in the Page menu 
item.  
 

 
 

Page Display 
 

First Page [Pos 1] 

 Toolbar: Page Control 
 

Menu: Page ► View ► First 
 

CMD: VPFIRSTPAGE  

Displays the first page. 
 

Previous Page [Page Down] 

 Toolbar: Page Control 
 

Menu: Page ► View ► Previous 
 

CMD: VPPREVPAGE  

Displays the previous page. 
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Next Page [Page Up] 

 Toolbar: Page Control 
 

Menu: Page ► View ► Next 
 

CMD: VPNEXTPAGE  

Displays the next page. 
 

Last Page [End] 

 Toolbar: Page Control 
 

Menu: Page ► View ► Last 
 

CMD: VPLASTPAGE  

Displays the last page. 
 

Select Page  
The selection box displays the actual page no. out of the total number of pages in this document.  

 
You can select any other page. 
 

Direct selection of a Page 

Menu: Page ► Go To 
 

CMD: VPGOTOPAGE ► Dialog 
CMD: VPGOTOPAGE <Value> 

A dialog opens for selecting the page to display. The page number can also be entered directly at 
the command line. 
 
 

Insertion and Deletion of Pages 
 

Insert page to first position 

Menu: Page ► Insert ► First Position 
 

CMD: VPPINSERTFIRST 

Inserts a new page before the first page. 
 

Insert page before active page 

Menu: Page ► Insert ► Before 
 

CMD: VPPINSERTBEFORE 

Inserts a new page before the active page. 
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Insert Page after active page 

 Toolbar: Page Control 
 

Menu: Page ► Insert ► After 
 

CMD: VPPINSERTAFTER 

Inserts a new page after the actual page.  
 
Insert page to end 

Menu: Page ► Insert ► Last Position 
 

CMD: VPPINSERTLAST 

Adds a new page after the last page. 
 

Delete Page 

 Toolbar: Page Control 
 

Menu: Page ► Delete Page 
 

CMD: VPDELETEPAGE ► Safety prompt 
CMD: VPDELETEPAGE [Start] [End] [/a|Always] 

Deletes the current page. 

Start The number of the first page to be deleted. 
Default: active page 

End The number of the last page to be deleted. 
Default: same as Start 

A|Always Suppress the safety prompt (for use in scripts and batch processing). 
Default: off 

 The deletion of pages cannot be undone. For this reason the safety prompt has to be 
answered with "Yes" first. 

 
 
Import of Pages 

 When importing pages with any command, the option Edit ► Undo is not available.  Use 
Page ► Delete Page  instead.  
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Import to first position 
 

Menu: Page ► Import ► First Position 
 

CMD: VPPIMPORTFIRST ► Dialog 
CMD: VPPIMPORTFIRST <File> [/p|Page <Value>] 

The Import dialog opens for selection of a single page to be imported as a new page before the 
first page.  

File File name to be imported. 

P|Page Page to be imported. 
Default Page 1 
 
 

Import page before active page 
 

Menu: Page ► Import ► Before 
 

CMD: VPPIMPORTBEFORE ► Dialog 
CMD: VPPIMPORTBEFORE <File> [/p|Page <Value>] 

The Import dialog opens for a selection of a single page to be imported as a new page before the 
active page. 

File File name to be imported. 

P|Page Page to be imported. 
Default Page 1 
 
 

Import page after active page 
 

Menu: Page ► Import ► After 
 

CMD: VPPIMPORTAFTER ► Dialog 
CMD: VPPIMPORTAFTER <File> [/p|Page <Value>] 

The Import dialog opens for a selection of a single page to be imported as a new page after the 
active page. 

File File name to be imported. 

P|Page Page to be imported. 
Default Page 1 
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Import page to end 
 

Menu: Page ► Import ► Last Position 
 

CMD: VPPIMPORTLAST ► Dialog 
CMD: VPPIMPORTLAST <File> [/p|Page <Value>] 

The Import dialog opens for a selection of a single page to be imported as a new page after the 
last page  

File File name to be imported. 

P|Page Page to be imported. 
Default Page 1 
 
 

Moving Pages 
 Moving of pages - regardless of the used command - cannot be undone with Edit ► Undo. 

Instead, use a command from the group Page ► Move once again to restore the previous 
page order. 

 
 

Move page(s) to first position 
 

Menu: Page ► Move ► To First. 
 

CMD: VPPMOVEFIRST [Start] [End] 

Move one or more pages to first position. 

Start Number of the first page to be moved. 
Default active page 

End Number of the last page to be moved. 
Default same as [Start] 
 
 

Move page(s) towards the beginning 
 

Menu: Page ► Move ► Towards Beginning. 
 

CMD: VPPMOVEBEGIN [Start] [End] [Destination] 

Move one or more pages towards the beginning. 

Start Number of the first page to be moved. 
Default active page 
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End Number of the last page to be moved. 
Default same as [Start] 

Destination Number of the page where the pages will be moved to. 
Default one page towards the beginning 

Example: VPPMOVEFORW 
 The active page is moved one position before. 
 VPPMOVEFORW 8 11 5 
 Pages 8-11 (included) are moved before page 5. 
 
 

Move page(s) towards the end 
 

Menu: Page ► Move ► Towards End. 
 

CMD: VPPMOVEEND[Start] [End] [Destination] 

Move one or more pages towards the end. 

Start Number of the first page to be moved. 
Default active page 

End Number of the last page to be moved. 
Default same as [Start] 

Destination Number of the page where the pages will be moved to. 
Default one page towards the end 
 
 

Move page(s) to end 
 

Menu: Page ► Move ► To Last. 
 

CMD: VPPMOVELAST [Start] [End] 

Move one or more pages to the last position. 

Start Number of the first page to be moved. 
Default active page 

End Number of the last page to be moved. 
Default same as [Start] 
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Scanning Pages 
 Scanning of pages - regardless of the used command - cannot be undone with Edit ► 

Undo. Instead, use the command Page ► Delete Page. 
 
 

Scan page to first position 
 

Menu: Page ► Scan ► To First Position 
 

CMD: VPSCANFIRST ► Dialog 
CMD: VPSCANFIRST [/q|Quiet] 

The Scan dialog opens. Upon confirmation with OK the scanned page is inserted as the first 
page. 

q|Quiet The dialog for the scanner selection will be suppressed and the last used scanner is 
selected. 

 
 

Scan page before the active page 
 

Menu: Page ► Scan ► Before 
 

CMD: VPSCANBEFORE ► Dialog 
CMD: VPSCANBEFORE [/q|Quiet] 

The Scan dialog opens. Upon confirmation of the dialog with OK the scanned page is inserted 
before the active page. 

q|Quiet The dialog for the scanner selection will be suppressed and the last used scanner is 
selected. 

 
 

Scan page after the active page 
 

Menu: Page ► Scan ► After 
 

CMD: VPSCANAFTER ► Dialog 
CMD: VPSCANAFTER [/q|Quiet] 

The Scan dialog opens. Upon confirmation of the dialog with OK the scanned page is inserted 
after the active page. 

q|Quiet The dialog for the scanner selection will be suppressed and the last used scanner is 
selected. 
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Scan page to end 
 

Menu: Page ► Scan ► To Last Position 
 

CMD: VPSCANLAST ► Dialog 
CMD: VPSCANLAST [/q|Quiet] 

The Scan dialog opens. Upon confirmation of the dialog with OK the scanned page is inserted as 
the last page  

q|Quiet The dialog for the scanner selection will be suppressed and the last used scanner is 
selected. 

 
 

Organizing Pages 
 

Menu: Page ► Organise 
 

CMD: VPORGANISE ► Dialog 

The dialog Organise Pages opens. 
 

 
 
The dialog is structured in three main groups. A preview of the selected page is shown together 
with display options on the left side. In the dialog’s center a list of pages of the active document is 
displayed. Commands for changing the page order are available on the right side. 
 
The display options and commands (Zoom in, Zoom out, Zoom window, Zoom pixel, Zoom 
extents, Show raster and Show Vector) equal the commands in main document windows. 



 VP Software Manual 

120   Section 4     Document Settings, Documents Functions, Basic Editing Manual V16 - V9 / E 
 

  
 
One or more pages can be selected for processing in the pages list using the standard Windows 
selection methods. Each page has a Number and a Location. The Number reflects the number 
of the page at the time the dialog was opened and remains unchanged until the dialog is closed. 
Location shows either Loaded or Not Loaded depending on whether the page already resides in 
memory or not. A preview is only shown for loaded pages. Otherwise “N/A” is displayed in the 
preview window. The commands will also work on pages that are not loaded. 

Delete: The selected pages are deleted. 
Load: The selected pages are loaded to memory for preview. 
To Top: The selected pages are moved to the top. 
Up: The selected pages are moved up.  
Down: The selected pages are moved down.  
To Bottom: The selected pages are moved to the bottom. 
OK: Confirms the changes for the document. Since delete operations cannot be undone 

a safety prompt is displayed if the command Delete has been used. 
Cancel: The dialog is closed and the modifications are discarded. Pages that were loaded 

into memory using Load are not unloaded and will be kept in memory. 
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Layer Manager    
 

 Toolbar: Layers 
 

Menu: Options ► Layer Manager  
 

CMD: VPLAYERS  [/a <Name>] [</n <Name> ] [/m <Name>] [/l <Name>] |/c <Name>]  
 [/w <Value>] [/s <1|0>] [/l <1|0>] 
 

CAD: _layer 

The Layer Manager allows for setting up an unlimited amount of layers with different options 
according to user requirements. For each layer you can define the following settings: 

• To be the Active Layer (current layer)  
• Layer Name 
• Layer Name on Export 
• Linetype of Layer 
• Color, Status, and Width of Display, when Printing, with Rasterize, on Export 

 
All settings follow standard CAD conventions. 
 

Command line 
/a <Layer Name> Change the active/current Layer 
/n <New Name> Create a new Layer with the specified values 
/m <Layer Name> Modify an existing Layer to the specified values 
/l <Name> Name of an existing Linetype.  
/c <Name> Name of a Color. See Color Manager: 
/w <value> Line width 
/s <1|0> Display status (show/hide) 
/l <1|0> Lock status (locked/unlocked) 
 
 
If no parameters are specified, the dialog box is displayed: 
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As default settings you will find Layer 0. Layer 0 is intended to host preferably vector entities; 
linetype is continuous and width is set to 0.00. This layer may also be used for raster and/or 
hybrid entities.  

Default: Layer 0 
 
The dialog box can be defined by Table Type for displaying the settings for All, or separately for 
Display, Print, Rasterize, or Export. If the table type is set to All the dialog box appears as 
follows: 
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Table Type 
Select items the dialog should display: All, Display, Print, Rasterize, or Export respectively. 

Default: Display 
 

Active Layer (Current Layer)  
Select which layer becomes the active layer. You may also change the selection at any time using 
the layer selection box from the toolbar: 
 

 
Default: Layer 0 

 
New 

Create a new layer. A dialog appears where you can define Name, Status, Linetype, Color, and 
Line Width for the new layer. The dialog comes up with 5 default values identical for all tables and 
assigns Layer 1, 2, ..n as layer and export layer name. You can modify any default values. 
Clicking some of the entries will bring up a list box for selection (e.g. Colors): 
 

 
 

If you need to have different values for Display or other options (e.g. Print, Rasterize, Export) you 
can modify these values after OK in the Layer Manager dialog. 

Default values: see Dialog 
 

Copy 
Create a copy of the settings of the selected layer. The layer name receives a number as a suffix 
which will be incremented with every copy command. Select the copied layer in the dialog for any 
modification. 
 

Delete 
Any layer without entities assigned to this layer can be deleted. 

 
Export Name 

If required special names may be assigned to a layer only for exporting the data of a document. 

Default: Layer Name 
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Linetype 
You can assign a linetype to a layer. If the Active Linetype (see: Linetype Manager) selection 
box is set to "By Layer" then all entities drawn in that layer are drawn with the linetype assigned 
to that layer. If such entities are transferred to other layers having different linetypes assigned to 
them the entities change their linetypes accordingly. 
 
As default the linetype is continuous. Other linetypes are available in the selection box if they 
have been defined. If a new linetype is required, select Other. Then, the Linetype Manager 
dialog opens for setting up a new linetype. Next, the system returns to the layer manager dialog. 

Default: Continuous 
 

Color 
Select a color for the layer. You can select different colors for the display, for printing, for 
rasterizing entities, and for export. The 8 standard colors are available. With selecting Others the 
Color Manager appears where you can select any desired color. 

Default: All White 
 

Status {on/off} 
The layer can be switched on or off. You can switch the layer on or off separately in the display, 
for printing, for rasterizing entities, and for export. 

Default: All on 
 

Status Locked {on/off} 
The layer can be locked. This property may only be useful when editing a drawing as it controls 
whether elements in this layer can be selected, thus modified, or if they are inaccessible. 

Default:  Unlocked 
 

Width 
Set the width of (vector) entities to the desired values. Width 0.00 is the standard setting in a CAD 
environment. You may want to have a different setting for Rasterize and/or Print in order to 
display the entities with their actual width. 

 The Layer defines the line width of an element on display, print, rasterize, or export  
 
0.0 or larger: The width of the layer will be used. The individual width of an element will be 

ignored.  
By Entity: The individual width of each element on this layer will be used 
By Color: The color of an element defines its width. The individual width of the element will be 

ignored. All elements with the same color have the identical width. You can define the 
width of a color in the Color Manager. 

 

Default: All 0.00 
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Attributes  
Closes the layer manager, confirms all changes, and opens the attribute manager. See below 
Attributes for details. 
 

  
 

Transfer to Current Layer (only Windows)   
 

 Toolbar: Layers 
 

Menu: Edit ► Transfer to ► Current Layer  
 

CMD: VPSHIFTLAYER <Name> 

Selected entities are transferred to the current layer. 
 
If a layer is specified, the selected entities are transferred to this layer. 
 
 

Pick Layer (only Windows)  
 

 Toolbar: Layers 
 

Menu: Edit ► Pick Property ► Pick Layer  
 

CMD: VPPICKLAYER 

The layer of a clicked entity becomes the current layer. 
 

Preview 
Before clicking onto the entity the name of the layer is displayed in the status bar. This is 
indicated by a little i added to the cursor.   
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Project Bar (only Windows)   
 

 Toolbar: Layers 
 

Menu: Options ► Project Bar  
 

CMD: VPPROJECTBAR  

This command opens the dialog window Project Bar: 
 

 
 
It displays the tree structure of all currently available layers and - as sub-entries to each layer - all 
loaded raster images. The currently active layer is shown with a highlighted name. The currently 
active raster image is indicated in bold letters.  
 
The Check Box in front of each layer or entry indicates the display status: visible or non-visible. 
Clicking on a check box toggles the display status of this entry. 
 

 The Color of each layer/entry is indicated by an according colored square.  
 This icon indicates the Color 7, which is black on a white background and white on a black 

background. 
 
Clicking on a layer name with the left mouse button sets this layer as Active Layer, clicking on a 
raster image name sets this image as Active Raster.  
 
The Draw Order can be changed by dragging (left click+move) a layer to a new position in the 
tree. On drop (release left mouse button) the layer will be inserted below the actual (highlighted) 
layer and the draw order will be re-arranged accordingly. The entities of the layer on top position 
of the tree will be drawn first, the entities of the layer on bottom position of the tree will be drawn 
last (its entities will be drawn above all other entities). 

 Raster Images will always be drawn first (below the vector entities). All new created entities 
will always be drawn on top, regardless of their layer position in the tree. 

 
Pressing the [Ctrl] key on drop will assign the dragged layer as sub-layer to the actual 
(highlighted) entry. This way families of layers can be arranged and then easily switched on and 
off together by clicking the checkbox of the main layer. 
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Dragging the name of a raster image changes the layer of this image. The [Ctrl] key has no 
function. 
 
On right mouse click inside the project bar dialog one of the three following menus appear 
(nothing selected, Raster selected, Layer selected): 

 
 

Expand All Items 
All sub items are displayed in the tree structure. 
 

Import 
Imports a new file into this project. If the selected file is a raster image and the mouse was 
positioned on top of a layer, then the imported image will automatically be assigned to this layer. 
See File Import for details. 
 

Export 
Exports the selected document/image. See File Export for details. 

Layer Manager... 
The Layer Manager dialog pops-up and allows to create/edit all layers. 
 

Redraw 
The draw order of all entities will be re-arranged according to the actual tree structure and the 
document will be redrawn. 
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All Layers On 
All layers become visible. 
 

All Layers Off 
All layers become invisible. 
 

Unlock all Layers 
All layers will be unlocked. 
 

Lock all Layers 
All layers will be locked. 
 

Lock/Unlocked Layer (Unlocked/Locked Layer selected) 
The selected layer will be locked/unlocked. 
 

Properties (Raster selected) 
Opens the standard properties dialog for the selected raster. 
 

Image Settings (Raster selected) 
Opens the image settings dialog for the selected raster. 
 

Delete (Raster selected) 
Deletes the selected raster. 
 

Change Color (Raster selected, Layer selected) 
Opens the color manager dialog for the selected item. 
 

Set to Active (Raster selected, Layer selected) 
Sets the selected item as active item. 
 

Cancel Menu 
Closes the context menu without changes. 
 

Attribute Manager...  
The Attribute Manager dialog pops up to create/edit attributes. 
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Width Manager (Windows only)    
 

 Toolbar: Width 
 

Menu: Options ► Width Manager  
 

CMD: VPWIDTH 
 

CAD: _lweight 

The Width Manager allows to configure the line widths. You can add or remove widths. 
 

 
 

Standard Width 
Shows the list of widths available in all documents. If necessary you can add, edit or delete a 
width. A new width, created by the Pick Width command will be not  displayed here, because it is 
only available in the current document (see Pick Width). 
 

New 
Creates a new Standard Width.  
 

Edit 
Modifies an existing width entry. Except: width 0.0. 
 

Delete 
Deletes an existing width entry. Except: width 0.0. 
 

Reset 
All widths will be reset to their default values. Any new added widths will be deleted. 
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Pick Width Settings 
Use the exact width: The Pick Width command measures the exact width and adds it to the 

current document (if not yet existing).  
Match to existing width: The Pick Width command selects the closest width value of the 

current document as new current width. 
 

 Some formats (e.g. DWG/DXF) support only a list of predefined width values. In case of 
export to such a format other width values will be adjusted accordingly.  

 
 

Pen (current) Width  
 
Displays the current width, which will be used when drawing a new element. The layer symbol in 
front of the width value means that the width of the current active Layer is used. In this case you 
cannot change the current Pen Width. Only if the active layer has the width setting By Entity you 
can select individual width values for new elements. Individual widths of the document are the first 
entries of the list followed by the standard width values.  

  
Default: <Width of the active Layer> 

 The layer settings define the line width of the elements for display, print, rasterize, and 
export. See Layer Manager, Width.  

 
CAD: The default display width for all elements is 0.0. For rasterize or plot the layer and/or plot 

style settings are used.  
 
 

Assign Current Width (Windows only)  
 

 Toolbar: Width 
 

Menu: Edit ► Transfer to ► Current Width  
 

CMD: VPSHIFTWIDTH <width value> 

The current width is assigned to the selected entities. 
 
If a width value is specified, this width is assigned to the selected entities. 
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Pick Width (Windows only)  
 

 Toolbar: Width 
 

Menu: Edit ► Pick Width  
 

CMD: VPPICKWIDTH> 

The line width of an element or a raster structure can be measured by clicking on it. This width 
value becomes the new current width. Depending on the settings in the Width Manager the exact 
width value or the standard width nearest to it is used (see Width Manager). 

 This function is only available if the active Layer has the width value By Entity  

 New width values (= a none standard width) are only part of the current document. Use the 
Width Manager to add new width values available for all documents. 
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Linetype Manager    
 

 Toolbar: Linetypes 
 

Menu: Options ► Linetype Manager  
 

CMD: VPLINETYPES [/a <Name>] 
 

CAD: _linetype 
 

Command line 
/a <Name> Change the active/current Linetype 
 
 
If no parameters are specified, the dialog box is displayed: 
 

 
 

The first line showing the name "By Layer" is not a linetype. Instead, it is used in the linetype 
selection box (below) to indicate that the linetype used for an entity will be controlled by the 
linetype assigned to the layer. If such an entity is transferred to different layers it may have 
different linetypes. 
 

Active Linetype  
Select the active linetype. You may also change the selection at any time using the linetype 
selection box from the toolbar. 

 
Default: By Layer 

 
New 

Creates a new linetype with the default settings. You can modify the names, the description, the 
"Continuous" mode, and assign segments (one or more), each of which consists of a gap and a 
dash in order to create dashed and dash dotted linetypes.  
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Delete 
Any linetype not assigned to a layer and/or entity can be deleted. 
 

Import... 
New line types can be imported from AutoCAD-compatible LIN files– even more complex types 
including text and/or symbols. The following dialog appears: 
 

 
 

Choose a LIN file via the file symbol or enter a LIN file path. The contained line types will be 
listed. Click to select the line types you want to import – multiple selection with [Ctrl] or [Shift]. 
OK confirms the selection and import. 
 

Export Name 
If required special names may be assigned to linetypes only for exporting the data of a document. 

Default: Same as Name 
 

Description 
Allows for a graphical description of the designed linetype. 
 

Continuous {on/off} 
If continuous is set to on a linetype assigned to a polyline is arranged in a way that the 'dash' - 
'gap' periods continue also at corners (vertices). Hence a corner becomes "invisible" in case there 
is no dash. 

Default: on 
 

Global Scale Factor 
Dash and Gap length for all linetypes can be scaled. This may be necessary for adjustments to a 
specific User Coordinate System. 

Default: 1.0 
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Segments 
A linetype other than continuous may consist of one or more segments - each of them containing 
a gap and a dash. A maximum of 16 segments may be assigned to one linetype. 
Fields appear grayed when the selected line type contains text or symbols. 

Default: 0 
 

Dash 
Define the dash length for each segment. A dash length of 0.00 represents a "dot". 

Default: 0.00 
 

Gap 
Define the gap length for each segment. 

Default: 0.00 
 
 

Assign Current Linetype (only Windows)  
 

 Toolbar: Linetypes 
 

Menu: Edit ► Transfer to ► Current Linetype  
 

CMD: VPSHIFTLTYPE <Name> 

The current linetype is assigned to the selected entities. 
 
If a linetype is specified, this linetype is assigned to the selected entities. 
 
 

Pick Linetype (only Windows)  
 

 Toolbar: Linetypes 
 

Menu: Edit ► Pick Property ► Pick Linetype  
 

CMD: VPPICKLINETYPE 

The linetype of a clicked entity becomes the current linetype. 
 

Preview 
Before clicking onto the entity the name of the linetype is displayed in the status bar. This is 
indicated by a little i added to the cursor.   



VP Software Manual  

Manual V16 - V9 / E Section 4     Document Settings, Documents Functions, Basic Editing   135
 

Text Style Manager    
 

 Toolbar: Text Styles 
 

Menu: Options ► Text Style Manager  
 

CMD: VPTEXTSTYLES [/a <Name>] 
 

CAD: _style 

The text style manager allows for defining text styles. All text fonts available in your Windows 
Operating System can be used and assigned to text styles for successive use in your VP 
software. 
 

Command line 
/a <Name> Change the active/current Text Style 
 
 
If no parameters are specified, the dialog box is displayed: 
 

 
 
You can select any available text style in the list for modification or deletion. When clicking New 
an additional text style will be listed. Settings will be copied from an existing style. Use the tools 
for modifications. 
 

Active Text Style  
Select the active text style. You may also change the selection at any time using the text style 
selection box from the toolbar. 

 
Default: Text 
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New 
Defines a new text style by copying the setting from the last selected one or from the last entry 
respectively. You can modify the names, the fonts, the style, and assign height and width/height 
ratio individually.  
 
The Preview displays the selected font. You may enter (edit) the displayed standard text in order 
to see the text style with a particular text string. 
 

Delete 
Any text style not being assigned to a layer and/or entity can be deleted. 
 

Export Name 
If required special names may be assigned to text styles only for exporting the data of a 
document. 

Default: Text 
 

Height 
Assign the height to the text style. 

Default: 10.00 
 

Width to Height Ratio 
Assign a width/height ratio. 

Default: 0.70 
 

Font 
Select any available font from the drop list. 

Default: Arial 

 If the current document was loaded from a PDF file, there might be font names with the 
extension embedded. These fonts are special fonts that were loaded from the PDF file. 
Because these special fonts may be only a sub-set (= they do not contain all standard 
characters) you should not use them for a new text style. Also, exporting them to other file 
formats than RVD may lead to undesired results. 

 
Export Font 

Select any available font from the drop list if you want a different font for data export. 

Default: Same as Font 
 
Select between the styles Regular, Bold, Bold Italic, and Italic. 

Default: Regular 
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Big Font 

Additionally, a Big Font can be set up for Asian characters or other symbols when a SHX font 
has been selected. This field is grayed for TrueType fonts. 

Default: none 
 

Charset 
This field is only available when VP software has been installed with AutoCAD 2004 –2006. In this 
case a character set can be specified (e.g. Japanese, Chinese) for fonts which support various 
character sets (e.g. Arial) By default the character set of the operating system is preset.  
For all other installations the character set is always Unicode.  

Default: Unicode 
 
 

Assign Current Text Style (only Windows)  
 

 Toolbar: Text Styles 
 

Menu: Edit ► Transfer to ► Current Text Style  
 

CMD: VPSHIFTTSTYLE <Name> 

The current text style is assigned to the text entities of the selected entities. Other selected 
entities will be ignored. 
 
If a text style is specified, this style is assigned to the selected text entities. 
 
 

Pick Text Style (only Windows)  
 

 Toolbar: Text Styles 
 

Menu: Edit ► Pick Property ► Pick Text Style  
 

CMD: VPPICKTEXTSTYLE 

The text style of a clicked text entity becomes the current text style. 
 

Preview 
Before clicking onto the text entity the name of the text style is displayed in the status bar. This is 
indicated by a little i added to the cursor.   
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Color Manager (only Windows)   
 

 Toolbar: Color 
 

Menu: Options ► Color Manager  
 

CMD: VPCOLORS  [/a <Name>] 

The color manager allows for selecting and assigning colors wherever required.  
 

Command line 
/a <Name> Change the active/current Text Style 
 
 
If no parameters are specified, the dialog box is displayed: 
 

 
 
In the upper part the currently Selected Color is displayed as color icon with its name and the 
color components in RGB (Red-Green-Blue) and CMY (Cyan-Magenta-Yellow). When By 
Layer is selected the color of the current layer is displayed. With By Block the color icon is 
always black. 
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Standard Colors 
The field contains 240 colors and below the 16 standard colors. Together they create the VP 
standard palette. When moving over the color field the color names and their RGB components 
are shown. 
 

By Layer 
This button assigns the color of the active layer as selected color By Layer. Entities created with 
this color will be displayed with the color of their layer. You have to assign the layer color in the 
Layer Manager.  
 

By Block 
This button assigns the color of the block as selected color. If you use this option for entities 
which will be assembled to a block you may assign any color to that block.  

 In this case all entities forming the block must have assigned the color By Block. 
 
 

Width 
A dialog appears where a Width can be assigned for each color.  
 

 

 In order to display entities with the width from their color, the layer of the element must have 
the width set to By Color. 

 
The width assignment to a color is most important when printing/plotting or for rasterizing entities. 
For example, setting the width for all layers in the section Print (Layer Manager) to By Color 
allows for adjusting the plot output line width by the entity color, regardless of the layer location of 
an entity. All red entities will then be plotted with the assigned width. The same applies for 
rasterizing elements.  
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Custom Color 
 
The dialog is extended by a list of Custom Colors. 
 

 
 

Create/Modify Custom Colors  

  The following dialog shows up: 
 

 
 

Beside the color itself, a Name  and a Width  can be assigned. With OK the dialog is closed and 
the created/modified color is listed as Custom Color.  
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Automatic color creation 

 This icon is active when a colored raster image is loaded and you can pick a pixel from a colored 
image. In case the color is not one of the VP standard colors a new Custom Color will be created 
with a default name and width and is selected as the Selected Color. Otherwise the 
corresponding standard color is selected. The color manager is closed with OK. 

 

 This icon is active when a colored raster image is loaded and you can pick a pixel from the 
active image’s palette. . In case the color is not one of the VP standard colors a new Custom 
Color will be created with a default name and width and is selected as the Selected Color. 
Otherwise the corresponding standard color is selected. The color manager is closed with OK. 
 
 

Assign Current Color (only Windows)  
 

 Toolbar: Color 
 

Menu: Edit ► Transfer to ► Current Color  
 

CMD: VPSHIFTCOLOR  <NAME> 

The current color is assigned to the selected entities. 
 
If a color is specified, this color is assigned to the selected entities. 
 
 

Pick Color (only Windows)  
 

 Toolbar: Color 
 

Menu: Edit ► Pick Property ► Pick  Color  
 

CMD: VPPICKCOLOR  

The color of a clicked entity or raster pixel becomes the current color. In case the color is not one 
of the VP standard colors a new Custom Color will be created. 
 

Preview 
Before clicking onto the entity the name of the color is displayed in the status bar. This is 
indicated by a little i added to the cursor.   
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Match Properties  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Match Properties 
 

CMD: VPMATCH 

Properties like Layer, Line Type, Text Style and Color are copied from one entity to another.  

Select a source entity from which the properties should be copied. After that select the entities 
that should receive these properties. 

In case entities were already selected before the function call, these entities will receive the 
properties from the source entity to select. 
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Compare Revisions   
 

  Toolbar: Properties/Editing 
 

Menu: Edit ► Compare Revisions  
 

CMD: VPCOMPARE ► Import Dialog  

Compares a loaded file with a saved file and highlights the differences in content. The files are not 
changed by this. 
 
This function is only available if a file is already loaded.  
 
On first start, the import dialog opens to load the second file (reference file) for comparison with 
the loaded file (original file). Content differences are displayed in different colors: 

 Background color Equal Only in original Only in reference 
 White Black Green Magenta 
 Black White Cyan Red 

While the Compare-View is active you can operate all other functions, but any action will only 
affect the original drawing. For example you can use the redlining functions to mark the 
differences or use the print command to plot the compare view. 

Right-click to open the context menu (left: reference file contains raster data, right: reference file 
contains vector data):  

   
Finish 

The program returns to the view of the original file. 
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Advanced Compare Mode 
In this mode, the accuracy with which the comparison is performed can be set. If the accuracy is 
low, small differences are ignored. The marked differences between the two files can be turned 
on or off individually. In addition, the result of the comparison can be saved in a PDF file. 
 
The following color scheme is used, regardless of the background color: 
Grey:  identical areas 
Blue:  areas only existing in the original file (first file) 
Red:  areas only existing in the reference file (second file)  
 
A toolbar with the additional functions is displayed: 

 Show/hide areas only existing in the original file. 

 Show/hide areas only existing in the reference file. 

 Save result as PDF. 

 Accuracy: A low accuracy increases the tolerance. 

 End the advanced compare mode. 
 

Adv. Settings … 
Opens a dialog with settings for the advanced compare mode: 

• Accuracy 
• Settings for vector data 
• PDF export options 

 
Load State 

Load a previously saved compare state (reference file and adjustments made, see below). 
 

Save State 
Save the current state (original file, reference file, and adjustments made) to continue at a later 
time. See also Load Compare State below.  
 

Load new File to Compare 
The import dialog opens to select a new reference file. 
 

Move 
Move the reference file by selecting a source and target point. 
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Adjust (2 Points) 
Move and scale the reference file by selecting two source and  target points. 
 

Adjust (3 Points) 
Move, scale, and rotate the reference file by selecting three source and target points. 
 

Adjust Vector Linewidth (only available if the reference file contains vector data) 
A dialog pops-up to set the display line width for all vector entities of the reference file: 
 

 
If the original drawing contains raster data, you can pick the new line width form the original 
drawing. 

 
Adjust Raster Width + (only available if the reference file contains raster data) 

Perform a one step dilatation (thickening) on the reference file. 
 

Adjust Raster Width - (only available if the reference file contains raster data) 
Perform a one step erosion (thinning) on the reference file. 
 
 
On closing the function, all information about the reference file and adjustment settings are stored. 
On restart, the previously specified file will be loaded and adjusted - the compare view is active. 
To compare the original file with a new file use the context menu. 
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Load Compare State   
 

  Toolbar: Properties/Editing 
 

Menu: Edit ► Load Compare State  
 

CMD: VPCOMPLOAD ► Dialog  

Load a saved compare state. The original file and the reference file are loaded and all 
adjustments are made. If a file is already loaded, only the reference file is loaded.  

 Make sure that the original file and the reference file exist. 
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User Coordinate System    
 

 Toolbar: Coordinates 
 

Menu: Options ► User Coordinate System 
 

CMD: VPUSERCOORDS [/pc <value>] [/uc <value>] [/s <value>] [/up <value>]  
 [/d <value>] [/t <value>] [/dc <value>] 

VP software supports a Standard (Cartesian) Coordinate System and also a wide range of 
predefined Projections. Additional individual User Defined projections can be defined. 
 

Command line: 
/pc <value> Coordinate System EPSG Code (see dialog, VPmap Series only) 
/uc <value> User Unit Code (see dialog) 
/s <value> Drawing Scale 
/up <value> Precision of Coordinate Display (0-8) (default = 2) 
/d <value> Coordinate Display: 0: User Units / 1: Unprojected (Degrees) (Default=0) 
/t Coordinate Transform: 0: Keep Values / 1: Keep Values in Degrees / 2: 

Adjust Coordinates 
/dc <value> EPSG Datum Conversion Code (see dialog). Use ‘+’ for two step 

conversion (VPmap Series only) 
 
 
Without parameters or using the icon a dialog box opens for setting up the user coordinate 
system: 
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By entering values for  

• Coordinate System / Projection (only VPmap Series) 
• User Units 
• Drawing Scale 

the coordinate system can be adjusted to specific requirements of the active document. 
 

Coordinate System / Projection (only VPHybridCAD) 
This field always appears grayed and contains Standard (Cartesian). However, when a file is 
opened containing Coordinate System information (e.g. GeoTIFF) a Coordinate System with a 
specific projection can be displayed. In this case Parameter becomes available to check on 
projection parameters. However, these cannot be changed.  

 To set up and edit a specific Coordinate System with projections you will need to apply  
softelec’s VPmap Series products (VPmap, VPmap pro).  
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Coordinate System / Projection (only VPmap Series)  
Select between a Standard (Cartesian), a User Defined projection, or one of about 2.000 
predefined Coordinate Reference Systems. When User Defined or a predefined System is 
selected the Parameter button is enabled to view and/or edit the Projection parameters. 
 
If a predefined system has been selected the Projection dialog only allows to review the 
parameters (sample of a German Gauss-Krueger system with a Bessel ellipsoid and a 
Transverse Mercator projection method with belonging parameters). 
 
When a User Defined system has been selected the values for Datum or Ellipsoid, Projection 
Type, and belonging parameter values need to be specified. 
 

   
 Gauss-Krueger User Defined 
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VPmap Series supports about 340 predefined Datums which rest on about 40 predefined  
Ellipsoids. The following table shows the supported Projection Types and the required  
parameters: 
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Albers Equal Area           
American Polyconic           
Bonne           
Cassini-Soldner           
Equidistant Cylindrical           
Hotine Oblique Mercator           
Lambert Azimuthal Equal Area           
Lambert Conic Conformal (1 SP)           
Lambert Conic Conformal (2 SP)           
Lambert Conic Near Conformal           
Mercator (1 SP)           
Mercator (2 SP)           
Modified Azimuthal Equidistant           
New Zealand Map Grid           
Oblique Mercator           
Oblique Stereographic           
Polar Stereographic (Variant A)           
Polar Stereographic (Variant B/C)           
Transverse Mercator           
UTM Zoned Grid           
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 VPmap Series displays the values for False Easting and False Northing always in 
Meters, regardless of the selected or predefined User Units of the Coordinate System. 
Correspondingly, they need to be entered in Meters for a User Defined system. 

 
With OK the Projection dialog closes and the User Coordinate System dialog is again active for 
further setup of User Units and Drawing Scale. 
 

User Units / Drawing Scale  
The User Units and the Drawing Scale should be set to a value which corresponds to the 
document data. This information may either be part of the legend/drawing header in a raster 
image or it needs to be known due to other information. This allows for measurements (using 
function [F2]) in the document or for a direct use of real coordinate values for e.g. construction 
(see section 8) or rubber sheeting (see section 6). 

 
Display 

Choose between Display Coords. in User Units and Display Coords. Unprojected (in 
Degrees). The second option is only available when a coordinate system with projection has 
been selected. When selected all coordinate input requiring coordinate values in User Units must 
be entered as degree-minutes-seconds (DMS). Possible formats are: 
 

Input Format Sample Input Value 
<d>°<m>'<s.nn>" -48°15'30" -48°15'30" 
<d>°<m.nnnn>' -48°15.5' -48°15'30" 
<d.nnnnn>  -48.2583333 -48°15'30" 
<d>°<m>'<s.nn>" [EWNS] 48°15'30" S -48°15'30" 

 
Instead of using signed values the post-fix East/West and North/South can be used to specify the 
direction. 

 Instead of using the degrees (°), minutes ('), or seconds (") signs you can also separate the 
values by a double point (:) (<d>:<m>:<s.nn>). This may especially be necessary for 
complex command line input or scripting to differ the coordinate values from e.g. long file 
names with ("). 

 
Precision defines the number of decimal places. 

Default: Display Coords. in User Units 
Precision: 0.00 
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Place Raster and/or Vector Data on OK {on/off} 
If set to on after confirming the User Coordinate System settings with OK a dialog pops up to 
specify a new origin for the existing raster and/or vector data. See the following command. 
 

OK 
If the coordinate system has been modified another dialog pops up on OK to specify whether 
existing document data should be transformed to the new coordinate system or not: 
 

 
 

Keep actual Coordinate Values 
Use this option when the coordinate values in the document are already displayed correctly. 
Typically, this is the case when a vector drawing with no or wrong coordinate system information, 
but real coordinate values has been imported. AutoCAD drawings may be examples (*.DWG) 
when they have been created in an English (inch) environment, but were drawn with Metric 
(millimeter or meter) coordinates. Also, ESRI shape files (*.SHP) may be another example when 
no corresponding projection file (*.PRJ) is available. Especially, typical GIS formats like MapInfo 
MIF files and ERSI SHP files may contain vector data with coordinate values in degrees. In these 
cases the Values are in Degrees option needs to be applied. 
 

Adjust Coordinate Values to the new Coordinate System 
Use this option when the coordinate values displayed for the document are "paper" units. 
Typically, this is the case when a raster image without any placing and coordinate system 
information has been imported. 
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If you have changed the coordinate system from one projection to another, a datum conversion / 
transform may be necessary. The following dialog appears to specify the Conversion Operation: 
 

 
 

Select one of the available Coord Conversion Operations from the top combo box. The dialog 
will immediately update the information about Accuracy, EPSG code, Area in which this 
operation should be applied, and what kind of operation it is (here: Coord Frame Rotation).  
 
Sometimes it might be necessary to make the conversion in two steps, e.g. first from the Source 
CRS to WGS84 and then from WGS84 to the Target CRS. Select the second operation from the 
available operations of the combo box below.  
 
On OK raster and vector data will be transformed due to the selected operation(s). If None is 
selected the coordinate values are converted through the geographic 2D domain (e.g. source 
projected coordinates - Geographic 2d - target projected coordinates). 
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Place / Adjust Data 
 

 Toolbar: Coordinates 
 

Menu: Edit ► Place / Adjust Data  
 

CMD: VPPLACE ► Dialog 

Use this function to reposition, rotate, or scale the whole drawing or parts of it.  
 
When a drawing already contains Raster and Vector data the following dialog appears to 
place/adjust data accordingly: 

 

 
 

The option Active Raster Image only applies to this object. Whole Drawing applies to all objects 
in the drawing. 
 
An individual Selection can be made in case no previous selection has been made. Specify your 
selection after OK (see status message). 
 
After OK or in case the drawing only contains one raster image the following dialog appears: 
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By choosing Select Point or Select Distance consecutively you can specify an arbitrary number 
of reference points or reference distances. After choosing either option click on a point/distance in 
the drawing first (distance click positions must be close to horizontal or vertical). Then, enter a 
target position value/target distance value in User Units. Target values can also be taken from 
the drawing, e.g. from a reference vector element.  The Vector Snap is available. 
 

Select Point 
Select a point in the drawing. The current coordinate of the point is displayed in the Placing 
Reference dialog: 

 
The actual value can now be entered or, using [F2], selected from the drawing. 
 

Select Distance 
Select a reference distance from the drawing by drawing a line (the reference should be either 
vertical or horizontal). The measured Length is displayed in the dialog. Adjust the value or use 
[F2] to measure a new value from the drawing. 
 
An unlimited number of reference are allowed. Measurement entries can be deleted from the list 
with Delete Entry. 
 
With OK adjustment, rotation and scaling (anisotropic) will be calculated from all entries, 
depending on the number and form of the selected reference points or distances. 

 For a simple placement one reference point is sufficient. For a simple and accurate scaling 
one reference distance is sufficient. It is recommended to specify a preferably long 
distance with a known actual value in the drawing. 
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Image Settings   
 

 Toolbar: Image Settings 
 

Menu: Options ► Image Setting  
 

CMD: VPIMAGESETTINGS ► Dialog 
CMD: VPIMAGESETTINGS [/M|METHOD <METHOD>] [/E|EXACT <EXACT>] 
 [/T|THRESHOLD <THRESHOLD>] [/C|COLORMODE <COLORMODE>] 
 [/FG|FOREGROUNDCOLOR <RED;GREEN;BLUE>] 
 [/BG|BACKGROUNDCOLOR <RED;GREEN;BLUE>] 
 [/DPI|RESOLUTION <RESOLUTION>] [FILE] 

Displays the raster file settings and allows for modifications. Use this function to define the Image 
Characteristics for vectorization and tracing and - most important for gray scale and color 
images - the Active Color Definition.  
 
 

B/W Images 
 

With b/w raster files the image settings dialog looks like this: 
 

 
 
It displays the Path of the image (may be void for new images), the Image Characteristics, and 
the Image Properties. 
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Image Characteristics [/M|METHOD <METHOD>] 
The image characteristics define the main structure of an image. They have a successive 
influence on the conversion process when vectorizing or tracing. Select according to the 
prevailing entity type in the image, or according to the one you are looking for during the edit and 
conversion process. Choose either: 

• Predominantly lines /M 0 

• Predominantly areas /M 1 

• A mixture of areas and lines with the width threshold at "n.nn" [baseunits] for 
switching to outlines (area) /M 2 /T n.nn. 

 
Exact {on/off} [/E|EXACT <EXACT>] 

Especially with dense contour drawings containing thin contour lines you can set this parameter to 
on (/E 1) in order to increase the preciseness of following the contours. Be aware though, that 
this setting will increase the amount of vertices with polylines significantly and also the amount of 
you vector data! 
 

Image Properties 
Displays Resolution (/DPI), Image Size in pixel (Width and Height), and Image Type.  



 VP Software Manual 

158   Section 4     Document Settings, Documents Functions, Basic Editing Manual V16 - V9 / E 
 

  
 

Gray Scale and Color Images   
 
The basic image settings dialog opens like this: 
 

 
 
The upper sections are the same as with b/w raster files. The image specifications (path, 
resolution, image size, and image type) are displayed. Define the Image Characteristics 
according to the prevailing entity type in the image.  
 
In the lower sections you can set the Foreground/Background Definition and the Color 
Definition. 
 
 

Foreground/Background Definition  
 
Since gray scale and color images contain multiple gray scales or colors, the foreground color 
needs to be specified. The advantage of defining the foreground color of the image individually is 
that it allows to select color patterns (i.e. multiple colors) to serve as "one" active color. The 
image can then be treated like a b/w raster file and the foreground color may be traced, 
converted, or used to select entities or snap to entities while editing. You can save a color pattern 
definition to a file and re-load it at any time to the same image as long as the color palette of the 
image has not been modified (e.g. with color reduction functions). This way you can change the 
foreground color definition with respect to the entities you want to trace, redraw, vectorize etc. 

 It is highly recommended to only use uncompressed raster formats or lossless 
compression formats when scanning document originals! Do not use JPEG or similar 
compression formats implying losses of information.  

 
Use the Color Reduction function first in order to reduce the amount of colors as far as possible 
- especially minor colors should be converted to their nearest major colors, thus creating images 
with significantly less colors without a loss of information. 
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You have the choice between three different definition modes: 
 

Automatic  /C 0 
An automatic algorithm calculates which colors are foreground colors and which colors are 
background colors. 
 

Define Foreground /C 1 
The colors set with Advanced Settings are treated as foreground colors and, thus, form the 
active pixels which can be picked and modified. 
 

Define Background /C 2 
The colors set with Advanced Settings are treated as background colors and, thus, form the 
inactive pixels which compose the document’s "paper" space. 
 
 

Advanced Settings 
 
With most images it will be very difficult or even impossible to reduce the colors to an extent that 
different types of entities are assigned to different but solid colors. Instead, you need to select a 
color pattern in order to group all major pixels of an entity into the active color. Clicking the 
advance settings button brings up an extended dialog: 
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Active Color Palette Calculation 
Use the tools from this section to define the active color: 
 

 
 
When an active color has not been defined in the previous dialog, yet, use the pipette cursor 
button and pick a new active color from the image. Zoom functions will support your selection.  
 

Region around Active Color 
Click this radio button and pick a representative color from your image. This color appears at the 
color indicator and all pixels having this color are displayed with the complementary color in the 
image: 

 
 

Use the zoom buttons to view the most significant area of your drawing for picking the reference 
color. 
An expanded definition of the active color will be possible with this function. It will generate a color 
pattern based on the color region of the active color.  Use the slider control to define the color 
region (see below Variation), or pick single additional colors from the image for fine tuning your 
selection.  
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Variation 
Moving this slider creates a widening color corridor around the selected color. Colors with an 
increasing distance to the selected color will be included and added to the color pattern which 
composes the active color (more and more pixels are getting highlighted).  
 

Range defined by Active Color and Second Color 
Click this radio button if the entities in your image are composed from a variety of lighter and 
darker colors of the same kind, or if they are composed from two base colors. You can define the 
color corridor's direction by selecting the colors at both ends of the range. 
 
Use the zoom and pan functions for picking the active color and the second color. Then use the 
variation slider to create a proper entity selection: 
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Switching to the B/W View you can check the quality of color pattern selection:  
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Color Map  
 
Clicking this button adds another section to the dialog and displays the palette of the active 
image. All selected colors composing the active color are marked: 
 

 
 
The palette has been organized in a way that the active color selected first is in the upper left 
corner, while all other colors are arranged according to their distance to the active color. Colors in 
the two upper display rows have been selected for the second color and with the slider variation.  
 
Additional colors have been selected and picked to avoid interruptions along entities. 
 

Save Map 
Once you have composed a proper active color you can save this color map for later use. This 
allows for creating different maps for different entity selections. 
 
 

Load Map [FILE] 
Re-loads a previously saved map for an active color setting. A re-load is only possible if the 
palette of the image has not been modified after the map was saved. 
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Foreground Color  
 
Specifies the color that is used to rasterize modified raster entities back into the image. 
 

Pick Color 
If your gray scale or color image contains only few colors, each of which represents a different 
type of information entity (for example: roads are straight red, rivers are straight blue, forest areas 
are green etc.), you can pick the color of your choice from your image (pipette cursor button) or 
the image palette (image palette button) and set this color as foreground color. The selected color 
or gray scale value will be indicated. 
 
 

Background Color  
 
For erasing or moving entities in gray scale or color images you can specify the background color 
to be filled in instead of the former entity. 
 

Pick Color 
Pick the color from your image (pipette cursor button) or the image palette (image palette button).  

 The background color must be different from the foreground color! 
 
 

Select Active Image   
 

 Toolbar: Image Settings 
 

Menu: Edit ► Select Active Image  
 

CMD: VPSELECTACTIMAGE [NAME] 

This function will be enabled if a document contains more than one image. Select an image to 
become the active image and click this icon. You may also select the active image from the 
current image selection box: 
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Image Palette   
 

 Toolbar: Image Settings 
 

Menu: View ► View Image Palette 
 

CMD: VPIMAGEPAL 

Displays the current palette of the active image (maximum 256 colors): 
 

 
 

Palette Colors 
This section shows all colors contained in the image. If you move the cursor over the color fields 
(without selecting), the RGB values and the palette position of the respective color are displayed 
below the palette matrix. 

 
Selected Color 

Clicking a particular color displays its RGB and CMY values. You can modify colors by entering 
new values into the corresponding fields. Changes will be displayed in the color field as soon as 
you remove the cursor focus from the field. Instead of modifying  the selected color directly, you 
can also use the Windows Color Dialog. 
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Transparency {on/off} 
If you want a color to be transparent switch this option to on and select a palette index. The color 
can be selected from the active image using the pipette button. The option is disabled for true 
color images. The transparency setting is used e.g. when working with the GIF file format. 
 
Default: off 
 

Create B/W Image   
 

 Toolbar: Image Settings 
 

Menu: Raster, Color ► Create B/W Image 
 

CMD: VPCREATEBWRASTER [/D|DELETE 0/1] 

When a colored image is the active image this command creates a B/W version of the image as a 
separate raster object overlaying the original image. If no color map has been assigned the 
automatic settings will be used. The original color image can be deleted with entering /d 1 in the 
command line or in a script. 
 
 

Display B/W Image  
 

 Toolbar: Image Settings 
 

Menu: View ► B/W Display 
 

CMD: VPBWRASTER 

When a color map has been assigned to the active image this command displays the image as if 
it were a B/W image. The command is a switch. A second call will restore the original color view 
of the image. 
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Attributes - General Information   
 
Attributes contain additional information directly linked to geometrical entities (raster and/or 
vector). This data can be used for certain information about the entity. For example, the attributes 
of a polygon representing a house placed on a piece of land may contain information about the 
address, the owner, the size, etc. The list of Attribute Fields assigned to the Layer of the entity 
defines the quantity and kinds of attributes. Attributes are compatible to other Geographical 
Information System (GIS) software packages; they can also be used for other purposes like 
Facility Management (FM). To export this use either the SHP file format (exchange format of 
ESRI ArcInfo) or the MIF file format (exchange format of MapInfo). 
 
For performance reasons attributes are stored in a memory database and not in a disk based 
database. However, the registry key ..\DBManager\MemoryDatabase can change the mode. In 
this case the database is stored in the user’s temporary directory. 
 
 

Attribute Manager  
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Attribute Manager 
 

CMD: VPMANAGEATTRIBS ► Dialog  

Allows you to import, create, modify, and delete Attribute Fields for a Layer. 
 

 
 
From the Combo Box choose the layer (e.g. Rail) for which you want to add/edit/delete attribute 
fields. 
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Import Fields From Existing Database 
 

 Click this icon and select a data source file. This could be either a DBF file, the database file of 
the Shape File Format (SHP), a MID file of the MIF file format, or an ODBC compliant database 
(like Microsoft Access MDB).  
 
In case of DBF or MID a directory select dialog pops up to choose the directory where the DBF or 
MID files of an existing project reside. Otherwise the standard Windows dialog Select Source 
Data appears: 
 

 
 
On OK the dialog for selecting a table opens. The field definitions of one table at a time can be 
imported. 
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In the following dialog Select Database Fields clear the checkmarks of fields not to be imported. 
 

 
 
In some cases the Field Type Definition dialog shows up for modifying the field type. This 
happens if the field type used in the database is non-standard and therefore not recognized by 
VP software: 
 

 
 
The selected attribute fields will be imported and displayed with their field specifications. 
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To also import field data, apart from the field definitions, you need to proceed as follows:  
 
First, an attribute needs to be defined  which has the same name as the first field in the table you 
want to import. This attribute needs to be „unique“, i.e. each element has to have a different 
value. If this is compliant the following message appears after importing the field definitions: 
 

 
 
Upon confirmation the data will be imported and will be assigned to the present elements. The 
data value must comply with the existing attribute value.  
 

Add New Attribute Field 
 

 Clicking this icon opens a dialog to specify a new attribute field: 
 

 

 
Enter the desired field Name and specify Type, Length/Scale, and Precision if necessary. 
 
Standard ODBC field types are: 

Char Float 
Numeric Real 
Decimal Double 
Integer Date Time 
Small Int Var Char 

 
A Default Value can be preset. The VP software allows to specify some special Default Values 
which will be automatically computed from the entity properties: 
 

@Angle the angle of a block, ellipse, mtext or text 
@Area the area of a polygon, closed polyline or circle 
@BlockAttribute the value of a specified block attribute 
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@Circumference the circumference of a polygon, closed polyline or circle 
@Color the color name of the entity, object 
@Doc.Name the name of the document 
@Elevation the elevation/Z-coord. of a polyline, polygon or point 
@Extents the extents of the element 
@ExtentsX the element extents in x-direction 
@ExtentsY the element extents in y-direction 
@Linetype the linetype name of the entity, object 
@Point the point type 
@ObjectType the object type name of the entity 
@String the string content of a text entity 
@X-Position the x coordinate of a block, mtext, point or text 
@Y-Position the y coordinate of a block, mtext, point or text 

 

Choosing one of the above values causes the field to be set to the status Constant. 
 

Each database field can be defined as  
Required {on/off} 
Constant (value) {on/off} 

 
A Constant value is not editable by the user, a Required field must be set to a valid value. 
 

To minimize input effort you can also setup a Rule for a field. Available Rules are: 

• Auto-Increment/Decrement: With each entity/object you add the current value will be 
incremented/decremented. An additional dialog allows to set the start value, the step size, 
and the direction (increment or decrement). Can be used for all field types, but only if the 
field input are numbers. 

• Restricted Range: An additional dialog allows to specify a valid range of data for this field. 
Can be used for all field types, but only if the field input are numbers. 

• Boolean: The field can only contain data of the type Yes/No, Y/N, True/False, T/F or 1/0. 
You can select between these options in an additional dialog. 

• List: The field can only contain predefined values. Enter values in a separate dialog after 
confirming with OK. You can also specify, whether new values will be accepted and 
whether a new element color can be assigned automatically according to the element’s list 
value. For each list entry you can also specify a character which will then simplify your 
data entry by using [Ctrl] +<character> as a placeholder. Specified lists can be saved and 
they can be reloaded to be used in other documents. 

• Boolean/Color: As in Boolean. Additionally, elements will be assigned colors as specified 
in Boolean. 

• Object Color: Set an index value from 0 to 255 for a color selection from the standard 
color palette. This color will be assigned to an object. 

OCR: Activates text recognition within the raster image region. You can specify text recognition 
settings in a separate dialog after OK.  
This rule is only recommended for newly generated polygons. Subsequent settings for existing 
elements will be ignored. 
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Modify Attribute Field Properties 
 

 Select a attribute field and then click this icon. A similar dialog as above opens containing the 
field properties for modifications. 

 Attention: Some modifications like changing the Name or the Type of a field may lead to a 
loss of attribute data of already existing entities/objects from this layer. 

 
 

Modify Field Order 
 

  Allows to move a attribute field up or down in the list order. 
 
 

Delete Attribute Field 
 

 Deletes the selected attribute field. 
 
 

Attribute Bar  
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Show Attributes 
 

CMD: VPSHOWATTRIBS ► (Toolbar) 
 

The Attribute Bar allows to view/edit the attribute data of an entity. If you add a new entity to the 
database by Tracing or Drawing then the focus switches automatically to the first editable 
attribute field of the Active Layer for data entry. Use the Windows functions keys [Tab], 
[Shift]+[Tab], [Enter], [Up], [Down] to move through the list of the attribute fields. 
 

For a faster entering a list of last entries is available for all fields, unless a specific rule has been 
assigned to them. Also, [F2] or the [...] button allows for a text recognition (raster image) or a text 
transfer (vector data). Handling is described in detail in the command line and in the status bar.  
 
If no entity is selected then the Attribute Bar displays the list of the attribute fields of the Active 
Layer.  
 

When several elements are selected their attribute values can be viewed and modified 
simultaneously. All elements will then receive a new value for the modified attribute field. When 
selected elements contain different values in one or more attribute fields this will be indicated with 
the term “*VARIES*“  
 

When a rule is used for several fields to change the element color, you can use the context menu 
(right click on the respective field) to specify which field is to become active in the current view. 



VP Software Manual  

Manual V16 - V9 / E Section 4     Document Settings, Documents Functions, Basic Editing   173
 

   
 

Attribute Inspector (only Windows) 
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Inspector 
 

CMD: VPINSPECTOR ► (Select Entity)  
 

Move the cursor over an entity and remain there (for about half a second) until a tool tip with the 
attribute data of this entity appears. If you want to change this data click onto the entity and edit 
the data in the Attribute Bar. 

 
 

Query Attributes (only Windows) 
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Query Attributes 
 

CMD: VPQUERYATTRIBUTES ► Dialog 
CMD: VPQUERYATTRIBUTES <QUERY> 

 
Query 

A complete SQL query to send to the database. If the query contains quotes like " or ' the query 
has to be quoted using `or ´ characters! 
 
Example: 
 

VPQUERYATTRIBUTES `SELECT * FROM "A Table" WHERE "Attr." LIKE '%Test'` 
 
The dialog Create/Run Query opens; depending on the last used tab – Simple Query or 
Advanced Query – this tab opens again: 
 
 



 VP Software Manual 

174   Section 4     Document Settings, Documents Functions, Basic Editing Manual V16 - V9 / E 
 

   
 

Simple Query 
 
This tab presents an easy way to find elements using standard queries. No knowledge of SQL is 
necessary to build a valid query which will be executed when pressing OK. 
 

 
 

Search Attributes of Layer 
Specifies the layer where to search for attributes. 

Default: Active Layer 
 

Search Field 
A field can be specified using a combo box. All attributes of the selected layer are available as 
search fields. To show all values without filtering use the option Select All. A filter operator can 
be specified with Using Operator. Depending on the type of field there may be different 
operators in the combo box. Available operators are: 
 

LIKE (Text only) Equal text using % as a wildcard character. 
NOT LIKE (Text only) Unequal text using % as a wildcard character. 
< Less than 
<= Less than or equal 
> Greater than 
>= Greater than or equal 
= Equal 
!= Unequal 

Compare with Value is the operator’s parameter. 
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Sorting 
Specifies how results will be sorted. You can choose no sorting with None, and Ascending or 
Descending for a specific attribute. 

Default: Ascending, First attribute of the layer 
 

SQL Query 
The generated SQL query is displayed as a reference here. 
 

Advanced Query 
 
This tab presents a way for the experienced user to make arbitrary SQL queries which are 
supported by the underlying SQLite database. For a complete description of the available SQL 
commands and the referring syntax please refer to http://www.sqlite.org/lang.html 
 

 
 

Query History 
The last 20 queries used. Double-click a query or select it and use the From History button to 
transfer it to the edit field SQL Query. With the latter it can be modified or reused. 
 

http://www.sqlite.org/lang.html
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SQL Query 
The SQL query that shall be executed when clicking on OK. You can transfer a query from the 
Simple Query tab by pressing From Simple Query. Queries can be loaded and saved to text 
files using Load and Save. 
 
To show the results, the dialog Attributes shows up: 
 

 
 
The query results cannot be edited directly! To change attributes click the row of the desired 
value you want to edit and use the Attribute Bar to change the desired attributes. 
 
When clicking into a field - or selecting elements (rows or columns) - the zoom window is adjusted 
to display the corresponding elements. OK and Cancel close the dialog and keep elements with 
selected fields as the active selection. Print opens a print dialog to print attributes. 
 
 

Export Attributes 
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Export Attributes 
 

CMD: VPEXPORTATTRIBUTES ► Dialog 
CMD: VPEXPORTATTRIBUTES /f|Filter <filter name> /o|Options <filter options> 

This command exports the attributes of all layers to an existing database. 
 
When called without parameters, a dialog opens with a list of available database export modules 
(filters). After successful selection, the settings dialog of the selected filter is displayed (or several 
dialogs, depending on the filter). The export starts with the termination of the filter configuration. 
 

Command line parameters 
Filter Name (/f): Name of the database export module. 

Filter Options (/o): Options for the database export module.  
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Create filter options with the help of the script generator: Start the script generator (menu 

File ► Create script...). Select VPEXPORTATTRIBUTES from the list of Available 
Commands by double-clicking on it - the command will be added to the list Selected 
Commandst and the corresponding options will be displayed.  

Now select a Filter on the right and click on the small button in the Options section to open 
the corresponding filter options dialog. Here you can make the desired settings. When you 
close the dialog, the filter options are displayed as text. This text can be copied and used as  
parameter. 

 
 

Review Attributes 
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Review Attributes 
 

CMD: VPREVIEWATTRIBUTES ► Dialog 

All attributes of the active layer are displayed in a dialog where attributes can be changed. 
Just double-click into a field to edit it. When clicking into a field or selecting elements (rows or 
columns) the zoom window is adjusted to show the corresponding elements. OK confirms the 
changes and keeps the elements as active selection, whose fields are selected. OK and Cancel 
close the dialog and keep elements with selected fields as the active selection.  Print opens a 
print dialog to print attributes. 
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Add Labels  
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Add Labels  
 

CMD: ADDLABELS ► Dialog 

Inserts Attributes as text (labels) in the drawing. Attributes will become permanently visible. A 
dialog appears to select Attributes: 
 

 
 

Attributes 
Select an Attribute Layer first, and activate one or more attributes from the list by double-clicking 
them.  
 

Horizontal, Vertical 
Label alignment according to the element’s geometric center.  
 

Align to Lines, Splines, etc. 
Labels will be aligned in parallel to lines, polylines, or splines. Using horizontal alignment a line’s 
start, end, or center point (polyline, spline) can be specified as the insertion position. Vertical 
alignment specifies the label’s position according to the line or the segment (above, below 
centered). 
 

Add Attribute Name 
When set on the Attribute‘s name will be inserted in front of the label. A Name Delimiter, i.e. a 
character separating the name from the value, can be added. 
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Layer 
The label’s target layer. You can use an existing layer or define a new layer. A new layer will be a 
copy of the selected Attribute layer with additional name details (see below Layer Suffix / Prefix).  
 

Add Labels 
Inserts the selected Attributes as text labels. When labels of the selected Attribute layer have 
been inserted in the drawing before, they will be deleted and replaced by the new selection.  
 

Undo 
The last insertion operation will be cancelled. Possibly deleted labels will reappear. 
 

Advanced 
Displays / hides advanced options. 
 

Label Properties 
Label text properties can be specified, such as Angle, Height, w/h, Style, Color. You can also 
modify the Spacing of label lines.. 
 

Layer Suffix / Prefix 
Characters preceding or following the new layer name (see above Layer). 
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Entity Selection and Handling    
 

Vector Entity Selection 
 
The selection mode is CAD-like. Pick any vector entity. The selected entities are displayed in a 
highlight mode (dashed) and contain grips (handles) for entity modifications. The base point grip 
is marked with a cross. All standard CAD operations are possible. 
 

Raster Selection   
 

 Unless raster editing is limited to the Active Image (see Section 8) any raster entity or object 
can be selected regardless to which raster image it belongs. 
 
There are 2 ways of selecting raster entities/objects:  

• Direct Raster Selection (Pick, Window, Crossing) for single raster entities 
(line, circle, arc, polyline etc.) and,  

• Raster Object Selection for raster entities consisting of complex raster 
structures, which should not be broken up into their entities. 

Raster selection with gray scale or color images will be handled like b/w images once the active 
color has been defined using the function Image Settings. 
 
 

Direct Raster Selection   
 

 Toolbar: Raster Selection Mode 
 

Menu: Edit ► Direct Raster Select  
 

CMD: VPDSEL 
 
If switched on raster and/or vector entities can be selected using pick mode, windowing, or 
crossing. If switched off only vector entities will be selected. 
If switched on a toolbar is displayed offering different selection modes: 

 
Blue buttons offer hybrid selections.: 
Vector/Raster Selection  
Vector/Raster Selection Stop at Intersection  
Raster and/or Vector elements can be selected while using pick mode, window selection, cross 
selection, or polygon (inside or crossing) selection (via context menu). 
 

Click on a Raster element or window selection of a Raster structure 
The program will generate Vector elements from the selection including width values. When using 
the Stop at Intersection mode single vectors will end at intersections as existing in the selected 
Raster structure. 



VP Software Manual  

Manual V16 - V9 / E Section 4     Document Settings, Documents Functions, Basic Editing   181
 

  
 

 When pressing [Ctrl] while using window selection all image elements will be selected to 
one coherent Raster object. This is equivalent to the Raster Object Selection with the 
mode Window. No vector data will be generated. 

 
Elements are displayed with grips in the Raster selection’s current color. Each selected element 
can be modified just as a „conventional“ vector element. 
 
The remaining selection modes refer to Raster structures exclusively. 

 As long as one of these modes are active, the raster selection cursor  is used. 
 

Raster Selection Rectangle  

 All Raster structures inside a window selection will be selected. 
 

Raster Selection Polygon  

 All Raster structures inside a closed polygon selection will be selected. 
 
The polygon selection is confirmed with a double click or with [Enter]. 
 

Raster Selection Pick 

 The cursor changes to a Pipette symbol. Clicking on the Raster (active color is assigned) will 
select all Raster structures joined with the click position. 
 

Raster Selection Line  

 Generates a 2-point line. 
 
The underlying Raster is selected. Crossing Raster structures will be ignored. 
 

Raster Selection Arc  

 Generates an arc element with three points:  
• First click point = Start point arc 
• Second click point = End point arc 
• Third click point = Radius and direction arc  

The underlying Raster is selected. Crossing Raster structures will be ignored. 
 



 VP Software Manual 

182   Section 4     Document Settings, Documents Functions, Basic Editing Manual V16 - V9 / E 
 

  
 

Raster Selection Circle  

 Generates a circle element with three points (see  above). 

The underlying Raster is selected. Crossing Raster structures will be ignored.  

With „End Command“ in the context menu (right mouse click), the generated Vector elements will 
be converted back to Raster elements if elements have not been transferred to a Vector layer. 

Default: on 
 

 If vector entities are located inside the selection area (selected by window or crossing) only 
vector elements are selected. You need to repeat the selection process for the raster 
entities (second window or crossing selection). 

 
Direct Raster Selection Settings [F8] 

 

 Toolbar: Raster Selection Mode 
 

Menu: Edit ► Direct Raster Selection Settings…  
 

CMD: VPDSELSETTINGS ► Dialog 
 
Opens the Raster Selection tab in the System Settings dialog. For a detailed description of the 
dialog and the available options please see Section 3. 
 
 

Raster Object Selection    
 

 Toolbar: Select Raster 
 

Menu: Edit ► Raster Select  
 

CMD: VPSELRASTER ► Toolbar 

This function allows for selecting more complex raster structures and multiple raster entities 
combined to a raster object. The following set of icons appear after activating this function for 
choosing an appropriate raster object selection mode:  
 

 
 
The options can also be changed during execution via the command line or via the context menu. 
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Raster structures generated with any of the selection modes are displayed in the current raster 
selection color (default: red).  

 Repeated selection will expand the object continuously if the "+" button is active. [Shift] 
toggles the actual state temporarily.  

 If the "-" button is active while re-selecting any previously selected raster entity or structure 
this part will be deselected from the total selection. [Shift] toggles the actual state temporarily. 

 Undo's the last selection or de-selection command. 
 

 Clicking on this button or pressing [Enter] confirms the selection. 
 

Select Rectangle  

 The complete raster inside a rectangle window will be selected.  
 

Select Polygon  

 The complete raster inside a closed polygon will be selected.  

Close the polygon with a double mouse click or with [Enter].  
 

Select Pick Raster  

 The cursor is replaced by a pipette symbol. If you click on the raster (with the active color 
assigned to it) all raster structures connected with the click point will be selected. 
 

Select CAD Entities   

 Selects standard CAD entities (line, circle, arc). The cursor changes to a Needle and Thread 
cursor as long as this selection mode is active.  
 

Select Arc  

 Generates an arc object by defining three points:  
• 1st click point = start point arc 
• 2nd click point = end point arc 
• 3rd click point = arc curvature and direction 

A raster arc underlying the construction arc is selected. Crossing raster structures will be ignored. 
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Select Circle  

 Generates a circle object by defining three points (see above). 
 
A raster circle underlying the construction circle is selected. Crossing raster structures will be 
ignored.  
 

Select Line  

 Generates an individual 2-point line. 

A raster line underlying the construction line is selected. Crossing raster structures will be 
ignored. 
 

Select Inside Window  

 Raster elements will be selected if they are located entirely inside the selection window. 
Elements which extend beyond the frame will be ignored. Crossing raster entities are ignored. 
 

Select Crossing Window 

 Selects all raster elements which are located completely inside the selection frame, and also 
those elements which are located only partially inside the selection frame. 
 

Select Fence  

 Selects all raster elements touched by a selection polyline (fence). 
 

Select Dirt Inside Window  

 Selects all objects inside a dragged window, except for crossing lines, circles, arcs. 
 
 

Quick Selection [Ctrl]+[F]  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Quick Selection...  
 

CMD: VPQSELECT ► Dialog 
CMD: VPQSELECT <Command> [/p|Pick p|a|l|f] [/t|Type <value>] [/prop|Property <value>] 
 [/o|Operator <value>] [/v|Value <value>] [/m|Modify 0|1] [/nor|NoRaster] [/nov|NoVector] 
  [/rdl|Redlining] 
 

CAD: _qselect 
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This function allows for selecting entities through user defined rules. The result is a specific entity 
selection that can be used for further operations. Also, an existing selection of entities can be 
reduced or expanded. 
 
A Command can be specified for immediate execution after the selection is finished. This option 
is especially useful for script processing. 
 
When the dialog is suppressed using the p (Pick) option you have the choice between three 
different selection modes: 
 
/p a: Pick all elements in the drawing. 
/p p: Pick elements using the mouse. 
/p l: Pick last element that has been modified/created. A special registry key 

(..\Selection\SelCount) controls how many elements from the history are selected when 
using this option. 

/p f: Depending on the following filter parameters /T (Type) and/or /prop (properties) with /O 
(operator) and /V (value) one or more elements will be selected. When a selection list has 
already been set up this will serve as a base. 

/p w Window selection. The window is specified with these subsequent coordinates: <x1> <y1> 
<x2> <y2>  

/p c Cross selection. The window is specified with these subsequent coordinates: <x1> <y1> 
<x2> <y2> 

/t Selection according to type of element, such as Line, Arc, Circle, etc. 
/prop Selection according to a specific property of one or more elements. All element properties 

that are available in the properties dialog are acceptable; e.g. Layer and Linetype, but 
also geometric properties such as Xm (= x-value of circle center, Ym (= y-value of circle 
center), R (= radius). 

/o Relational operator. Available are: "=" (equals), "<>" (not equal), "<" (less than) und ">" 
(more than), "*" (name or text comparison with wildcards), and "%" (text comparison for 
numbers only). Operators are available depending on the individual filter property. 

/v Comparative value. Depending on the parameters above this can e.g. be a layer name or 
a number value. When filtering text content you can also use these wildcards: * (arbitrary 
number of arbitrary characters) and ? (single arbitrary character). When the "% Only 
Numbers" operator is selected, the value specifies the number of digits before and after 
the decimal point (e.g.: /v 4.2 selects all numbers with 4 digits before and 2 digits after the 
decimal point). /v 0 selects all texts representing numbers. 

/m 0: a new selection list will be generated. 1: the existing selection list will be changed.. 
Default value is 0. 

 
The three additional options /nor (NoRaster), /nov (NoVector) and /rdl (Redlining) control 
which basic entity types (raster, vector, redlining) are selected when using the p option. 
 
Example 1: Selection of all circle elements with a radius of less than 5 drawing units: 

VPQSELECT /p f /t Circle /prop R /o > /v 5 
 
Example 2: Deletion of all circle elements in layer L1 with a radius of more than 5 drawing units. 

This requires two subsequent commands: 
VPQSELECT /p f /t Circle /prop R /o > /v 5 
VPQSELECT /p f /t Circle /prop Layer /o = /v L1 VPDELETE 
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Apply to The filter criteria can be applied to the Whole drawing or the Current 

selection. Current selection is only available if entities were selected before 
starting the command. 

Pick Object Temporarily closes the dialog for selecting entities from the document by 
using the mouse. 

Object type Shows the types of the entities in the selection or in the drawing and (if there 
are different types) All.  

Properties Determines the criteria for filtering. The property list changes according to the 
selected Object Type. Selecting a property changes the available options for 
Operator and Value. In order to select a property the Operator must not be 
set to Select All! 

Operator Controls the value range for the filter. Depending on the selected property the 
following operators are offered: Select All, = Equals, <> Not Equal, 
> Greater Than, < Less Than, and * Wildcard Match. Possible wildcards 
are: 

*  a sequence of arbitrary characters 
?  a single arbitrary character 
#  a arbitrary digit.  

Not all operators are available for each property. 
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Value The property value for the criterion. If known values exist for the selected 
property they are provided in a selection list. Otherwise type in a Value. 

Filtered entities meet the filter criteria 
 Those entities that meet the filter criteria are selected. 

Filtered entities do NOT meet the filter criteria 
 Those entities that do NOT meet the criteria are selected. 

Selection (Modify existing set) 
An existing selection set is reduced or expanded according to the filter criteria. 

Selection (Create new set)  
 A new selection set is generated from the result of the filtering. 

 
 

Select All [Ctrl]+[A] 
 

Menu: Edit ► Select All  
 

CMD: VPSELALL 

Selects all elements which are visible and not on a locked layer (exception: redlining elements). 
As a default the command VPQSELECT /p a is started. This can be changed using the registry 
key ..\Selection\SelAllCMD. 
 
 

Select by Color 
 

CMD: VPSELBYCOLOR <Color1> [<Color2>] [<Color3>]… 

Select all elements, which have the specified Color. If a entity has the color “By Layer”, the color 
of the layer is compared with the specified value(s). 
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Snap Functions  
 

Drawing Aids [Shift]+[F8] (only Windows) 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Drawing Aids  
 

CMD: VPSNAPSETT ► Dialog 

A dialog box opens to specify settings for Grid, Snap to Coordinates, Ortho and Polar Snap, 
Vector Snap, Raster Snap and the Snap Modes. 
 

 
 

Coordinate Snap [F9] {on/off} 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Coordinate Snap  
 

CMD: VPSNAPCOORD ► {on/off} 
 

CAD: _snap 

The Coord Snap can be specified in the menu Drawing Aids (Windows only). The option can be 
switched on/off clicking this icon or using [F9]. Values for X- and Y-spacing refer to the user 
coordinate system.  

Default: X = Y = 1 



VP Software Manual  

Manual V16 - V9 / E Section 4     Document Settings, Documents Functions, Basic Editing   189
 

  
 

Grid [SHIFT]+[F9] {on/off} 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Grid  
 

CMD: VPSNAPGRID ► {on/off} 
 

CAD: _grid 

The Grid can be specified in the menu Drawing Aids (Windows only). It can be switched on/off 
clicking this icon or using [F9]. Values for X- and Y-spacing refer to the user coordinate system.  

Default: X = Y = 5 
 
 

Ortho Snap [F10] {on/off} 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Ortho Snap  
 

CMD: VPSNAPORTHO ► {on/off} 
 

CAD: _ortho 

The Ortho Snap limits the directions while drawing entities to n x 45°. 
 
 

Polar Snap [SHIFT]+[F10] {on/off} 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Polar Snap  
 

CMD: VPSNAPPOLAR ► {on/off} 

The Polar Snap corrects deviations to the orthogonal directions (n x 45°) within the value angle 
while drawing entities. The value for angle is given in degrees. 

Default: 3° 
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Raster Snap [F11] {on/off} 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Raster Snap  
 

CMD: VPSNAPR ► {on/off} 

Clicking this icon or using [F11] allows for switching the snap on or off. The raster snap operates 
on b/w, gray scale, and color images, where snapping occurs to the active color defined in 
Image Settings. The Snap Mode toolbar allows for activating snap modes. 

Default: off 
 
 

Vector Snap [F12] {on/off} (only Windows) 
 
In the CAD installation, use the CAD OSNAP function, instead.  
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Vector Snap  
 

CMD: VPSNAPV ► {on/off} 
 
Clicking this icon or using [F8] switches the snap on or off. The Snap Mode toolbar allows for 
activating snap modes. 

Default: off 
 

Snap Modes 
Whenever the Snap function (Windows: Raster Snap and Vector Snap, CAD: Raster Snap) is 
activated, a toolbar opens for snap mode selection: 

 
If both snaps functions (only Windows) are activated the snap priority also needs to be defined in 
the toolbar. With CAD installations the raster snap has always priority. 

Default: snap priority on vector  
 
Any of the five available snap modes can be activated, even simultaneously: 

 Nearest snaps to the nearest point of an element 

 Intersection snaps to the nearest intersection of elements 
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 End Point  snaps to the nearest end point of an element 

 Center  snaps to the center of the nearest circle or arc 

 Quadrant  snaps to a quadrant (0°, 90°, 180°, 270°) of the nearest circle or arc 

 Midpoint snaps to the nearest midpoint of an element 

 Perpendicular snaps to an element perpendicularly 

 Tangent snaps to an element tangentially 
 
The active mode can be changed clockwise to a different snap mode with [TAB]. The different 
snap modes are displayed with their symbols as listed in the dialog box.  
 
Use the selection boxes Marker Size and Marker Color to modify the symbols' display. 

Default: Marker Size : 6 pixels 
 Marker Color: Yellow 
 
With CAD use the corresponding settings or the additional OSNAP options for vector entities. 
 
 

Undo [Ctrl]+[Z] / [Alt]+[Backspace]  
 

 Toolbar: Standard 
 

Menu: Edit ► Undo  
 

CMD: VPUNDO  
 

CAD: _undo 

This function will Undo a previous command or function. The command can be repeated for a 
maximum of 32 steps per page or 50 steps per document. The icon (and menu command) is 
grayed if to be undone. 
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Redo [Ctrl]+[Y]  
 

 Toolbar: Standard 
 

Menu: Edit ► Redo  
 

CMD: VPREDO  
 

CAD: _redo 
 
Repeats the last command or function which has been undone. The icon (and menu command) is 
grayed if there are no commands in memory. 
 
 

Delete Entities  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Delete ► Delete Entities  
 

CMD: VPDELETE  
 

CAD: _erase 

Deletes the selected entities. You can also use [DEL] on your keyboard. 
 
 

Explode Entities (Origin)  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Explode Entities  
 

CMD: VPEXPLODE  
 

CAD: _explode 

Breaks up the structure of the selected elements. Blocks, Hatch, Polylines, Splines, and Text 
are exploded and separated into their composing base elements. This allows for corrections of 
misinterpretations resulting from a vectorization. 
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Drag & Drop  
 
Use this standard Windows function to move entities, objects, images, drawings between 
document windows in VP software to or from the symbol library, and to or from other applications. 
 
Supported formats are: RVD (native VP format), Bitmap, Enhanced Metafile, Text, CAD (paste 
only), Windows Explorer files. When two or more files are dragged together from, for instance, the 
Windows Explorer to the main application window, the Multiple File Selection dialog pops up. 
For more information, please see the Open command in Section 3. 
 
With an CAD installation, please see the corresponding manual.  
 
 

Cut [Ctrl]+[X], Copy [Ctrl]+[C], Paste [Ctrl]+[V]  
 

 Toolbar: Standard 
 

Menu: Edit ► Cut  
 

CMD: VPCUT  
 

CAD: _cutclip 
 

 Toolbar: Standard 
 

Menu: Edit ► Copy to Clipboard 
 

CMD: VPCLIPCOPY  
 

CAD: _copyclip 
 

 Toolbar: Standard 
 

Menu: Edit ► Paste  
 

CMD: VPPASTE [<X>,<Y>] 
 

CAD: _pasteclip 

These standard Windows functions allow for exchanging entities, objects, images, drawings 
between other applications and VP software. 
Supported formats: RVD (native VP software format), Bitmap, Enhanced Metafile, Text, CAD 
(paste only). 
For an installation with CAD see the corresponding manual. 
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Cut/Copy 
Click Cut or Copy and select the entities/objects you want to copy. Confirm the selection with 
[Return]. For raster object selection, use the function Select Raster from the context menu (right 
mouse click). You may also select entities/object first and confirm the selection. Then, click Cut or 
Copy. 
 

Paste 
Entities appear with their base point attached to the cursor. Place them at the desired position or 
enter the destination coordinates in the command line. 
 
 

Measure Distance [F2] (only Windows)  
 

Menu: View ► Distance  
 

CMD: VPMEASURE  

Pressing the [F2] key opens the Measure Distance Dialog. The white area shows the current 
cursor position and the values are permanently updated when moving the cursor in the work 
space. The upper section shows the values in base units, either [mm] or [inch] depending on the 
system settings (Options - Settings). The lower section displays the same values according to 
the settings in the user coordinate system. 
 
Measurement results will be displayed in the lower gray area (pane).  
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Three basic operation types are available which can be set with the left three buttons in the 
dialog’s far upper section: 
 

 Accumulate the measurement results indicated by (+) in the result pane. 

 Subtract the measurement results, indicated by (-) in the result pane. 
 

 Take one measurement at a time. 
 
Different values can be measured using the buttons on the dialog’s right hand side: 

 Measure the length and angle of a line by clicking two points in the drawing. 

 Measure an angle by clicking three points in the drawing. The center point is the intersection of 
the two lines forming the angle you want to measure. 

 Measure an angle by clicking four points in the drawing. 

 Measure the length of a polyline by clicking its vertices. Complete the measurement with a 
double-click or press ENTER. 

 Measure the circumference and area of a closed polyline through clicking its vertices. Finish the 
measurement using a double-click, or using ENTER. 

 Measure the circumference and area of a rectangle by clicking two points in the drawing. 

 Click an element. Different properties are displayed depending on the element type. 
 
This function is very helpful for measuring parameter values that rely on information from a 
drawing. You can click the parameter field and select [F2]. The result will be inserted directly into 
the parameter field. 
 
 

Redraw [Ctrl]+[R] (Windows only)  
 

 Toolbar: Standard 
 

CMD: VPREDRAW  

This option redraws the current display. 
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Properties [F3]  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Properties  
 

CMD: VPPROPSHOW ► Dialog  
 

CAD: _properties 

The properties dialog opens and displays the properties of the selected entity or the common 
properties of entities (left: Windows, right: CAD): 
 

  
 
You can modify the properties of any raster or vector entity as far as modifications are feasible. 
 

Selected Raster Entities 
Pick-selected raster entities (appearing in red color by default) are converted into special vector 
entities and remain in that color and condition after leaving the properties dialog. You can either 
return to the previous state using Undo commands or rasterize the entities into the image. 
 
This "intermediate" state allows for modifications. For example, if you assign a raster line to an 
active vector layer the line becomes a vector entity after confirmation but stays in red color. Using 
the function Assign Current Color the color display can be changed. 
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Changing Properties 
 

 
 
In the General field combo boxes open for modifications when clicking into the corresponding 
value fields. Select from the available choices.  
 
In the Geometry field you may enter new values (keyboard or [F2] function). 
 
 

Change Properties 
 

CMD: VPCHANGEPROP [/prop|Property <property>] [/v|Value <value>]  
 
This command can be used to change almost any properties of previously (!) selected elements. It is 
primarily meant for using it with scripts or in a batch process. 
 

/prop Specific properties of one or more elements will be changed. All property entries 
listed in the properties dialog for an element are available, e.g. Layer and Line 
Type, but also geometric properties such as Xm (= X-value of circle center points), 
Ym (= Y-value of circle center points), R (= radius). Exceptions include special 
properties, such as single vertices of polylines, or dimension properties referring to 
dimension styles. 

/Value Defines a new property value.  
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Group Entities    
 

 Toolbar: Group Entities 
 

Menu: Edit ► Group Entities  
 

CMD: VPGROUP  

Start the function and select all elements/objects you want to include in a group. Confirm the 
selection with [Return]. You may also select elements/objects first and then start the function. A 
Group will be created according to the settings in CAD Options. You may also change these 
settings from the context menu. 
 
Opposed to a Block a selected Group will display individual element handles for individual 
modifications.  
 

Ungroup Entities   
 

 Toolbar: Group Entities 
 

Menu: Edit ► Ungroup Entities 
 

CMD: VPUNGROUP  

Start the function and select all Groups you want to dissolve. Confirm the selection with [Return]. 
You may also select a Group first and then start the function. 
 
 

Edit Group   
 

 Toolbar: Group Entities 
 

Menu: Edit ► Edit Group  
 

CMD: VPPROPEDITGROUP  

Start this function and choose a Group you want to edit. A toolbar appears offering options to 
Add or Remove elements: 

 
Choose an option and click on the element you want to add or remove. Click the green 
checkmark symbol to finish. 
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Draw Order   
 
Enables the draw order of raster and vector entities relative to each other whereby all raster 
entities are always positioned behind all vector entities. This means, raster and vector 
entities/objects form two separate areas of front-to-rear orders, e.g. a raster entity can never be 
drawn in front of vectors and vice versa. 
 
 

In Front [Shift]+[Pg Up] 
 

 Toolbar: Draw Order 
 

Menu: Edit ► Draw Order ► In Front  
 

CMD: VPDRAWFRONT  

The selected entity/entities will be drawn in front (on top of all other entities). Activate this function 
and select the entities. Confirm the selection with [Return]. You may also select the 
entities/objects first and then call the function. 
 

To Back [Shift]+[Pg Dn] 
 

 Toolbar: Draw Order 
 

Menu: Edit ► Draw Order ► To Back  
 

CMD: VPDRAWBACK  

The selected entity/entities will be drawn in the back (behind of all other entities). Activate this 
function and select the entities. Confirm the selection with [Return]. You may also select the 
entities/objects first and then call the function. 
 
 

Above Entity  
 

 Toolbar: Draw Order 
 

Menu: Edit ► Draw Order ► Above Entity  
 

CMD: VPDRAWABOVE  

The selected entity will be drawn above a certain reference entity. Activate this function and 
select the entities. Confirm the selection with [Return]. You may also select the entities/objects 
first and then call the function. Then select the reference entity above the first selected entities 
should be drawn. 
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Behind Entity  
 

 Toolbar: Draw Order 
 

Menu: Edit ► Draw Order ► Behind Entity  
 

CMD: VPDRAWBEHIND 

The selected entity will be drawn behind a certain reference entity. Activate this function and 
select the entities. Confirm the selection with [Return]. You may also select the entities/objects 
first and then call the function. Then select the reference entity behind the first selected entities 
should be drawn. 
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Rasterize Functions   
 

New Raster  
 

 Toolbar: Rasterize 
 

Menu: Raster ► New Raster  
 

CMD: VPNEWRASTER ► Dialog 
CMD: VPNEWRASTER [/cf|Color Format <Color Format>] [/b|Bckgrnd <Bckgrnd>] [/p|Palette 
<Palette>] [/f|Format <Format>] [/m|Margin <Margin>] [/o|Orientation <Orientation>] [/w|Width 
<Width>] [/h|Height <Height>] [/u|Units <Units>] [/dpi|Resolution <DPI>] [/ce|Center <Center>] 
[/x|XPosition ] [/y|YPosition] [/gs|Global Scale <Global Scale>] 

Creates a new "empty" raster image into the current document. A dialog opens for specifications: 
 

 
 
You can specify Color Format, Background Color, Format and Resolution. You can also 
define the Position of the new raster in the document. 
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Size Section [/f /o /w /h /u] 
Define the image format.  
 
Fit to Extents [/f 0]: The size is calculated depending on the drawing extents so that all elements 

fit into the new raster image. 
 
Custom [/f 2]: A custom size can be specified. By pressing the button Specify on Screen you 

can draw a window for the size. 
 
Paper Format: Specify the size by selecting a format from the list of standard formats. 

 [/f 1]: Selects the best fitting format from the list of standard formats so that all elements 
fit into the new raster image. Also, the best orientation will be chosen. 

 Opens the Paper Format Manager. Existing formats can either be customized or new 
formats can be created. 

 
Margin [/m]: Adds an additional border around the raster image. 

Default: 2 [units] 
 
Resolution [/dpi]: The resolution of the new image in DPI. A higher resolution improves the 

quality of the raster, but also increases the required memory. 

Default: 300 DPI 
 

Scaling Section  
Custom [/gs]: Scaling factor for the raster image. The actual size of the raster (the size in pixels) 

is reduced by this factor. Set a larger scaling factor to reduce the required memory for colored 
images or large drawings. 

Default: 1 : 1 
 
Scale to fit [/sf]: Calculates the scaling factor for the raster image to fit the drawing extents. The 

actual size of the raster (the size in pixels) remains unchanged. 
 

Name 
Enter a name for the new raster image. This name is suggested as the file name for export. 

Default: Untitled 1 
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Color Section [/cf /b /p] 
Choose the color depth for the new raster image: Black & White (/cf 0, default), Grayscale (/cf 1), 
256 Colors (indexed) (/cf 2), True Color (RGB) (/cf 3). If you select 256 colors you can either 
choose a standard palette, or load an existing palette (e.g. from another raster image), or create a 
palette with the used layer colors and entity colors. 
 
For a color depth other than b/w you can specify the background color. 
 

Position [/ce /x /y] 
With checking on Center to Entities the new raster is positioned around the entities. 
 
With Insert at: you can either enter an offset position in reference to document's origin, or by 
pressing Specify on Screen you can define the insertion position with the mouse. 
 

Mosaic 
This functionality is only available for Rasterize to Paper Format (see below). 
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Rasterize  
 

 Toolbar: Rasterize 
 

Menu: Raster ► Rasterize  
 

CMD: VPRASTERIZE ► Dialog 
CMD: VPRASTERIZE [<RTB-File>]  [/dw|Default Width <Default Width>]  [/fw|Fixed Width 
<Fixed Width>]  [/r|Raster <1|0>] [/v|Vector <1|0>] [/e|Erase <0|1>] [/s|Selection <0|1>] [/d|Delete 
<1|0>] [/ct|Color Table <0|1>] [/opt|Optimize Palette <1|0>] 

Rasterizes the selected entities/objects into the target raster image. A dialog opens for speci-
fications of the rasterization process: 
 

 
General Tab 

 
Left: Windows version, right: CAD version. 
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Target Raster Section 
The Target Raster is always the active image. Use Rasterize to Paper Format to rasterize into 
a new image (see below).  
 
If the target raster is an indexed image you can activate Optimize Palette in order to create a 
new palette for best color representation of all entities that will be rasterized. 
 

Rasterize Entities Section 
Click the entity type (Raster Entities/Objects and/or Vector Entities) you want to rasterize. If 
you check on All all entities of the selected type will be rasterized. Otherwise, you need to select 
the entities prior to the rasterize command. 
 
With the setting Erase Mode to on all raster pixels underlying the vectors are erased. 
 
Delete Entities after Rasterization {on/off}:  Deletes all selected entities after they have been 

rasterized. 
 

Rasterization Method Section (CAD only) 
In a CAD environment, the CAD rasterization method (AutoCAD plotter driver) is also available. 
Since this method is very time-consuming, it should only be used if inaccuracies (e.g. missing 
elements) occur with the internal rasterization method. 
 
Internal: VP software rasterization method. Fast, but can be inaccurate with certain elements. 

AutoCAD plotter driver: CAD software rasterization method. Time consuming but accurate. A 
plot style file containing width and color settings is required (default: vpc.ctb). With Start Plot 
Style Table Editor, this file can be modified. 
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Widths and Colors Tab [/dw /fw] 
 

If you use the AutoCAD plotter driver method the Widhts and Colors tab is switched off. 

  
 

Layer Table mode 
The layer of elements determines the width and color with which they are rasterized. 
 
All layer settings with respect to the Rasterize mode are listed. You can switch on or off layers 
and modify line width and color of layers for rasterization. Modified values will also appear in the 
Layer Manager and saved to the document. A standard line width can be assigned for all 
unspecified layers at the command line using /dw. With operator /fw a specific line width can be 
assigned for all elements. 
 

Color Table mode 
The color of elements determines the width and color with which they are rasterized. 
 
All colors of the drawing are listed; the corresponding width and print (rasterize) color can be 
modified. 
 
 
With Save As and Load you can save and reload the settings in the RTB format (e.g. for 
processing with the Batch Manager). AutoCAD plot style tables (CTB files) can be loaded but not 
saved. 
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Rasterize to Paper Format  
 

 Toolbar: Rasterize 
 

Menu: Edit ► Rasterize to Paper Format  
 

CMD: VPRASTERIZEPF ► Dialog 
CMD: VPRASTERIZEPF [/sf <Scale to Fit>] [/td <Tiled>] [/tx <TileX>] [/ty <TileY>]  
 + all parameters from VPNEWRASTER and VPRASTERIZE 

This function operates the same way as Rasterize, except that a new raster (Fit to the Extents) 
will always be generated. When desired you may select other formats. 
 
Selecting all entities (raster and vector) and checking Delete Entities after Rasterization will 
result in a new raster image fitting to the extents of all entities. The "old" raster will be deleted. 
 
In order to change the size and type of the target raster click the Setup button: 
 

 
 
The dialog options are described in New Raster above. For the Mosaic section see below. 



 VP Software Manual 

208   Section 4     Document Settings, Documents Functions, Basic Editing Manual V16 - V9 / E 
 

  
 

Mosaic 
 
Instead of creating a single target raster image you can optionally choose to rasterize into an 
array of tiles by activating Create Tiles. When clicking the Tile Size button the dialog for setting 
up the tiles opens: 
 

 
 
All tiles will receive an equal size. This means that the image might be extended in all directions 
when creating the tiles.  
 
The number of tiles can be specified directly by selecting Number of Sections and entering 
X-Count and Y-Count. Alternatively, the tile size can be specified in these two edit boxes when 
Size in and the desired units are selected. 
 
Tile Size shows the currently defined absolute size of each tile in pixels as a reference. 
 
The option Size in creates quadratic tiles by default. By setting Non-Quadratic to on you can 
specify the tile height independently from the tile width. 
 
Moreover, you may specify a Reference Position where the split operation should start. Valid 
options are: 
 UCS Grid Position Origin of the UCS. 
 Image: Upper Left Upper left corner of image. 
 Image: Lower Left Lower left corner of image. 
 Image: Upper Right Upper right corner of image. 
 Image: Lower Right Lower right corner of image. 
 Image is Centered Image is centered on the tiles. 
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Export to Files {on/off} 
This option allows to export each created tile into a separate file (when set on).  
 
On closing the dialog with OK you are requested to enter the base file name for all split files. 
Two digits in parenthesis will be appended as (0-0), (0-1), etc. The first digit indicates the row (top 
to bottom), the second digit indicates the column (left to right). 

Default: off 
 
Create Image Tiles in Document {on/off} 

Set this option to off to avoid the creation of the tiles in the document. 
This will save processing time and memory if the tiles are exported and are not needed in the 
document for modifications. 

Default: on 
 

Command line 
/td <Tiled> Create Tiles (1 = Tiles by Size, 2 = Tiles by Number) 
/tx <TileX> Tile size/number in x direction (size in Units, see New Raster) 
/ty <TileY> Tile size/number in y direction (size in Units, see New Raster);  

Default: Tile size x 
 
 

Rasterize Paperspace (CAD only)  
 

  
 

Menu: Raster ► Rasterize Paperspace 
 

CMD: VPRASTERIZEPS ► Dialog 

This command is only available with CAD and only when a layout is active. The active layout will 
be rasterized with all included layout settings, such as paper size, scaling, and plot style table. 
Final result is a TIF file. The following dialog appears with the command:  
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Color Format 
The new raster image’s color format can be defined (b/w, 256 colors, RGB true color). With 256 
colors selected an CAD standard palette will be generated. 
 

Resolution 
Resolution of the new image in DPI. 
 

File Name 
Path and name of the new image. 
 

Show Result {on/off} 
Before a new image will be created a preview control window appears when set to on:  
 

 
 
The function will be completed on OK. The result image will be saved. The function terminates 
without a save with Discard. 
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SECTION 5   
RASTER FILE EDITING, CUT TO DRAWING FORMAT, 
SCALE FILE  
  

General Information   
 
The main menu Raster contains editing functions for all kinds of raster data. Some raster file 
editing functions on gray scale or colored images need proper Active Color and Background 
Color settings. The Image Settings dialog will then pop-up automatically. The raster file editing 
functions always affect the entire raster file. Especially, they provide functions for quick clean-up 
of scanned raster data. 
 
On gray scale or color images (i.e. non-B/W) some raster edit functions cause a re-
sampling/interpolation. In the menu Options ► Resampling Settings... this process can be 
specified. 
 

 If a document contains multiple raster images, only the Active Raster Image will be 
processed. Exception: In case of an active selection the selected raster image or raster 
object will be processed. 

 
 

Resampling Settings...    
 

Menu: Options ► Resampling Settings... 
 

CMD: VPROPSETTINGS ► Dialog 
 
When colored or gray scaled raster images are transformed (e.g. rotated, scaled, or rubber 
sheeted etc.) a proper setup of the Resampling Settings will improve the quality of the output 
due to the specified method since the program needs to perform an interpolation or integration 
during the transformation process. Depending on the performed action (scale up or scale down) 
and the type of the raster data (paletted or true color) different methods should be used.  
 
Any transformation method other than Nearest Neighbour might increase the processing time 
significantly due to extended calculation methods. 
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A dialog opens for selection of the appropriate process settings: 
 

 
 
 

Resampling / Interpolation 
 
The option Do not resample / interpolate allows to turn off the re-sampling process. 

There are three levels of scaling: No/Low Scaling, Scale down, Scale up. For each level the re-
sampling method can be defined independently. The No/Low Scaling selection method will be 
used if the image size changes by less than 20% up or down (e.g. scale factor approx. 0.8 
through 1.2). This applies to rotations and most rubber sheeting transformations. 
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The re-sampling methods can be divided into three different types: 
 

Method Type Description 
Nearest Neighbour Resample / Interpolate No resampling (Default) 
Bilinear Resample / Interpolate Four point interpolation  
Cubic Convolution Resample / Interpolate Interpolation by a cubic function 
Hermite 
Bell 
B-Spline 
Mitchell 
Lanczos 2 
Lanczos 3 

Filter, 
can be used for up and 
down scaling 

The color of an individual output pixel is 
the filter value (kind of weighted mean 
value) of a number of input (source) 
pixels. 

    4 - Point Gauss  
    9 - Point Gauss  
  16 - Point Gauss  
  25 - Point Gauss  
  36 - Point Gauss  
  49 - Point Gauss  
  64 - Point Gauss  
  81 - Point Gauss  
100 - Point Gauss  

Integration,  
mainly used for down 
scaling 

The color of an individual output pixel is 
the integrated color value of the colors of 
a number of (now removed) input pixels. 

 
Use the Resample / Interpolate type for No/Low Scaling. For higher scaling values (up or down) 
the Filter or Integration methods might significantly improve the results. 
 
Due to the limited number of colors in paletted images, the re-sampling does not have the same 
effect as in true color images! 
 
The Apply to RGB / Grayscale and Paletted checkboxes allow to assign the selected re-sample 
/ interpolate functions accordingly. 
 
 

Palette Options 
 

Recalculate Palette {on/off} 
If checked on a new palette will be calculated for the image, when a re-sampling method other 
than Nearest Neighbour has been defined. 
 

Quantization Method, Number of Samples 
Select the quantization method and the number of samples for the recalculation. The 
Quantization Method defines the way how the palette is calculated from the samples. Again, 
choosing a high value for Number of Samples (e.g. 25%) will increase the conversion time by 
about the same amount! 
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Raster Edit Functions     
 

Auto Cleanup  
 

 Toolbar: Raster Operations 
 

Menu: Raster ► Raster Operations ► Auto Cleanup 
 

CMD: VPCLEAN 

Most raster files from (orthogonal) technical drawings need to be deskewed and despeckled. This 
functions starts an automatic despeckling, filling raster holes, and deskewing of the active raster 
file. The maximum size of the removed speckles or filled holes is 128 pixels. Speckles with a 
regular outline (e.g. dots, dots of dashed lines, decimal dots) will not be removed. Deskewing is 
performed by selecting a major vertical line in the image. 
 

For color/gray scale images the Active Image Settings for active color and background color will 
be used to remove/fill speckles accordingly.  

 Auto Cleanup of poor drawings, e.g. weak, thin, and fragmented raster elements will show 
an increasing degeneration of the image due to despeckling. Be aware of that! 

 
 

Raster Functions 
• Automatic Cut 
• Cut Window, Polygon 
• Crop (Trim) Window, Polygon 
• Deskew 
• Invert 
• Rotate Quadrantal 
• Rotate Arbitrary 
• Horizontal Mirror 
• Vertical Mirror 
• Remove Speckles 
• Smooth 
• Morphology 

 

These editing functions can be run individually. Some frequently used operations can be 
combined into a single process (see All Raster Operations). 
 
 

Automatic Cut  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Automatic Cut 
 

CMD: VPAUTOCUT 

The empty margin regions of a raster image are cut automatically.  
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Cut Window  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Cut 
 

CMD: VPCUTWINDOW ► Define Window 
CMD: VPCUTWINDOW ► x1 y1 x2 y2 

This function cuts a section from the active raster file for further processing. You determine the 
desired image area by dragging a Window with the mouse or with specified window coordinates. 
The new raster file contains information according to the selected window frame. 
 
 

Cut Polygon  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Polygon Cut 
 

CMD: VPPOLYCUT ► Draw Polygon 
CMD: VPPOLYCUT ► x1 y1 x2 y2 x3 y3 .... 

A polygon area can be defined with the cursor or by clicking on a closed vector polyline. Please 
note that for the latter option the polyline must be clicked first before starting the Cut Polygon 
function. A new rectangle raster file limited by the extents will be generated. 
 
 

Crop Window  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Trim / Crop 
 

CMD: VPCROP ► Define Window 
CMD: VPCROP ► x1 y1 x2 y2 

This function erases all raster information from the active raster file outside of the selected 
window area. The original raster file size remains (width and height in pixels). 
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Crop Polygon  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Polygon Trim 
 

CMD: VPPOLYCROP ► Draw Polygon 
CMD: VPPOLYCROP ► x1 y1 x2 y2 x3 y3 .... 

This function erases all raster information from the active raster file outside of the selected 
polygon area (for selection of polygon areas see above Cut Polygon). The original raster file size 
remains (width and height in pixels). 
 
 

Deskew  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Deskew 
 

CMD: VPDESKEW ► Draw Reference Line 

This function lets you correct small skewing errors that frequently occur during scanning. The 
whole file is aligned with a horizontal or vertical reference line. 
 
When you choose this function, the cursor appears with a triple frame box to be positioned at the 
first starting point of the reference line you wish to define. When you click on the first point, the 
area is enlarged to a ratio of 1:1. The standard screen cursor appears allowing you to accurately 
pick the starting point of the magnified reference line with a mouse click. Then, the program 
zooms back to the extents and the cursor returns with a triple frame box again. You apply the box 
in the same way to pick the end point of the reference line.  
 
The program begins the transformation of deskewing the image. A progress indicator is 
displayed.  

 The Raster Snap [F8] should be switched off for optimum deskew accuracy. 
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Autodeskew  
 

  
 

CMD: VPAUTODESKEW 

This function can be initiated from the All Raster Operations dialog or by a remote command. 
The function works on a long vertical line as reference for executing the auto-deskewing on the 
active raster image. The function is part of the Auto Cleanup function. 
 
For color/gray scale images the Active Image Settings for active color will be used to find a 
reference line. 
 
 

Invert  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Invert 
 

CMD: VPINVERT 

This function inverts the pixel color in the active raster file. With b/w raster data black pixel 
become white and vice versa. With gray scale or color images the composite color will be 
assigned to each pixel. 

 
 

Rotate Quadrantal  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Rotate Quadrantal 
 

CMD: VPROTATE90 ► Define Top Side (mouse click or NUM keys) 
 

CMD: VPROTATE90 <Number of 90° sections: -3 - 3> [/a|All] 

This function rotates the whole raster file by 90°, 180°, or 270°. You use a rotation box attached 
to the cursor to click the side of the image that is to be at the top of the display after the rotation. 
With the command line option /a you can rotate the whole document (raster and vector data).  
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Rotate Arbitrary  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Rotate Arbitrary 
 

CMD: VPROTATE ► Dialog 
 

CMD: VPROTATE <Angle> 

This function rotates the whole raster file through any angle you wish. A dialog box appears 
where you enter the rotation angle and select the basis of rotation.  
 

 
 
Specify the angle by entering the value via keyboard (absolute rotation angle) or by drawing a 
reference line using [F2]. In the latter case, North will rotate the raster file in such a way that the 
reference line is vertical after rotation. Horizontal will rotate the raster file until the reference line 
becomes horizontal. 

Entry: keyboard or [F2] 
Range: - 360° - +360° 
Default: 0° 

 
 

Horizontal Mirror  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Horizontal Mirror 
 

CMD: VPHMIRROR 

The raster file is mirrored across the vertical axis (y-axis).  
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Vertical Mirror  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Vertical Mirror 
 

CMD: VPVMIRROR 

The raster file is mirrored across the horizontal axis (x-axis). 
 
 

Remove Speckles  
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Raster Operations ► Remove Speckles 
 

CMD: VPSPECKLES ► Dialog 
 

CMD: VPSPECKLES [A ► Automatic] [D ► Dirt <value>] [H ► Hole <value>] [R ► Review] 

This function clears artifacts (unwanted isolated clusters of pixels, i.e. "speckles" or "dirt") from 
the b/w raster data or fills in vacant pixels (holes) in the raster. A dialog box opens to enter a 
pixel size value for clearing speckles or filling holes. The speckle and/or hole size can also be 
entered by picking a sample speckle and/or hole from the raster file. 
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On OK you will be prompted to define a window or polygon area. Detected raster elements will be 
deleted or filled, or the program continues with Review Results when activated. 
 
For color/gray scale images the Active Image Settings for active color and background color will 
be used to remove/fill speckles.  
 
 

Options 
 

Automatic [A⏐AUTOMATIC] 
This mode uses the maximum size of 128 pixels for removing speckles or filling holes. Any found 
speckles with a regular outline (e.g. dots, dots of dashed lines, decimal dots) will not be removed. 
If this command is used in the command line including /a, or if it is used in a script, the respective 
maximum size of 128 can be adjusted with the subsequent d or h parameters  
 

User Defined 
Any isolated pixel area/hole smaller than or equal to the selected Dirt/Hole Size will be 
recognized regardless of its shape. 
 

Dirt Size  [D⏐Dirt <value>] 
Specify the number of pixels or pick a reference structure from your image that constitutes the 
maximum size of artifacts you want to remove. In conjunction with the parameter A (automatic) 
the max. dirt size will be limited. 
 

Range: 0 - 255 pixels 
Default: 0 
 



VP Software Manual  

Manual V16 - V9 / E Section 5     Raster File Editing, Cut to Paper Format, Scale File   221
 

   
 

Hole Size [H⏐Hole <value>] 
Specify the pixels required to fill the largest hole or pick a reference structure from your image. In 
conjunction with the parameter A (automatic) the max. hole size will be limited. 
 

Range: 0 - 255 pixels 
Default: 0 

 The maximum limit of 255 Pixels  (or 128 for automatic mode) is the recommended default 
value. For larger values (e.g. due to an image with a high resolution (DPI) ) adjust these 
values in the registry editor (regedit.exe) manually at: 

 
HKEY_CURRENT_USER\Software\softelec gmbh\V9\<VPxx>\[ACAD|WIN]\Rfedit 
 
or 
 
HKEY_CURRENT_USER\Software\softelec gmbh\V16\<VPxx>\[ACAD|WIN]\Rfedit 
 
Values: 
MaxSpeckleSize Maximum dirt- and hole size for mode User Defined.  
MaxAutoSpeckleSize Maximum dirt size for mode Automatic. 
MaxAutoHoleSize Maximum hole size for mode Automatic. 

 Larger values here will consume system resources (memory) and time in any case. Even if 
you have not specified the maximum values for dirt and hole size in the dialog or at the 
command line. 

 
Area 

Whole Drawing The whole drawing will be processed. 
Rectangular Area Choose this option to perform despeckling only inside a window area. 
Polygon Area Choose this option to perform despeckling only inside a polygon area. 
 

Review result before rasterizing {on/off}  [R⏐Review] 
If set to off all detected raster elements (dirt, holes) will be deleted/filled immediately. 
 
If set to on, all detected raster elements (dirt, holes) will be. displayed as follows: 

Dirt =   green 
Holes =   red 

 
These elements can be reviewed. When elements shall not be deleted/filled they can be removed 
from the selection (see below Window De-Selection). With [Return] the remaining elements are 
removed (dirt) or filled (holes). 
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Several modes are available via command line input: 
Window De-Selection 

 [w] starts the de-selection mode (default: active). Marked elements (green or red) can 
be de-selected by drawing a rectangle around one or more structures (window 
selection). These will be displayed in magenta color. 
De-selected elements can be re-selected by pressing [SHIFT] and a repeated window 
selection. 

 
Polygon De-Selection 

 [p] will switch into a polygon de-selection mode. 
 
Add Dirt 

With [a] single dirt elements can be added for deletion. 
 
Presettings for color display of dirt and hole elements can be modified in the menu Options – 
System Settings. 
 
 

Smooth Raster  
 

 Toolbar: Raster Operations (All) 
 

Menu: Filter ► Smooth Raster 
 

CMD: VPSMOOTH [/NR] [/NF] [/L <Value>] 

The Smooth Raster function eliminates rough surfaces, isolated pixels, and fills small holes in 
raster data. The process requires several runs (max.: 16) detecting relevant elements or 
structures. 
For color/gray scale images the Active Image Settings for the active color and background color 
will be used to remove/fill the pixels. 
 

 
Original         Result 

Options 
 

No Cleanup [NR] 
Pixels will not be deleted. 
 

No Filling [NF] 
Holes will not be filled. 
 

Max. Number of Runs [L <Value>] 
Maximum number of runs to delete pixels or raster holes. 
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All Raster Operations  

 

 Toolbar: Raster Operations 
 

Menu: Raster ► Raster Operations ► All Raster Operations 
 

CMD: VPRFE ► Dialog 

This function opens a dialog box where several frequently used raster file editing functions can be 
activated for sequential processing. 
 

 
 
For details on the available raster file editing functions see the above descriptions. 
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Morphology    
 

 Toolbar: Raster Operations (All) 
 

Menu: Filter ► Morphology 
 

CMD: VPMORPHO ► Dialog 
 

CMD: VPMORPHO <D|Dilatation|E|Erosion|C|Closing|O|Opening> <Value1> <Value2> 

The Morphology function allows to improve a raster file by increasing/thickening (Dilatation) or 
decreasing/thinning (Erosion) the raster (mainly lines), or Closing Area or Opening Area 
(mainly raster areas).  
 
For color/gray scale images the Active Image Settings for the active color and background color 
will be used to perform the operation.  
 
Clicking this icon opens a dialog box displaying a small section of the raster according to the 
window box on the active raster image. You can click the cursor into an area of interest on the 
raster image which will then be displayed in the dialog box. Select an appropriate function and 
define the Diameter (in pixels). The result of the operation can be reviewed online. Use the Pan 
and Zoom functions for checking. Clicking with the cursor into another area of the raster file will 
show the operation results there. 
 
Click OK to execute the operation on the whole raster file. 
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Options 
 

Dilatation (Thickening) [D|Dilatation] 
The raster structures are enlarged around their contours by the number of pixels specified by 
Diameter. This way, thin raster line structures can be improved. Larger values bear the risk of 
line interconnections. 

Default: Dilatation 
 

Erosion (Thinning) [E|Erosion] 
The raster structures are stripped down around their contours by the number of pixels specified 
by Diameter. This way, raster line structures can be thinned out. Larger values bear the risk of 
broken lines. 
 

 
           Original Raster      Thinning (Diameter=1) Thickening (Diameter=2) 

 
Closing Area [C|Closing] 

This is a combination of Thickening and Thinning the raster structure with the same value of 
Diameter. It allows to closing narrow interruptions inside raster areas without changing the 
contour of the area, e.g. closing the interruption of a road or river crossing a forest area. This 
happens especially when exporting colors into a b/w raster file. 
 

 
              Original Image      Closing Area (Diameter=9) 
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Opening Area [O|Opening] 
The opposite to Closing Area. Small interconnections, especially in raster areas will be removed 
without changing the contour of the area. 
 

 
                   Original Image       Opening Area (Diameter=12) 

 
Leave Skeleton <Value2> 

When Erosion and Opening is specified you can turn on this switch to avoid that entities (lines or 
points) are entirely removed. The specified value is the minimum thickness of a line or point in 
pixels. 
 

Intensity <Value1> 
This value defines (in pixels) the intensity of the above operations. 

Default: 0 pixel 
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Cut to Drawing Format    
 

 Toolbar: Rubbersheeting 
 

Menu: Raster ► Cut to Drawing Format 
 

CMD: VPCUTTOPAPER ► Dialog 

This function allows for cutting a raster file to fit to a selected format (size).  
 

The cut to drawing format function can only be executed on an image which is not scaled or 
displayed with an angle (review and/or modify with the function Properties). Otherwise, the 
following message appears: 
 

 
 
If you don't allow the software to modify those values the function will be cancelled.  
A dialog box appears to select a drawing format or to define a new format with its settings. 
 

 
 
After selecting Paper Format, Layout Orientation, and Margins click OK for execution. The 
cursor will then be replaced by a rectangle (or a double rectangle if margins have been specified) 
representing the new image boundaries. Place the (inner) rectangle at the desired position with a 
left mouse click. To rotate the rectangle by 90° press [Ctrl] or use the right mouse button while 
positioning the rectangle. A new raster image will be generated according to the outer rectangle 
boundaries. If Crop/Trim to Margin has been selected the area between the inner and outer 
rectangle will be erased (cropped). 

 The drawing should be deskewed and rotated to the desired orientation prior to starting this 
procedure. 
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Options 
 
 

Use Auto Selection {on/off} 
If set to on the Paper Format that matches the raster image best is selected. Otherwise, the last 
used format is selected. 

Default: on 
 

Paper Format 
The majority of standard formats are available for selection. In addition, individual values for 
Width and Height can be entered. 
 

Margins  
The 4 margins determine the distances between the drawing frame and the physical paper 
limits (= paper size). For example, the length of the paper form (taken from edge to edge of the 
paper) minus both margins (left and right) defines the actual frame length of the drawing. 
 

Different Margins {on/off} 
If not selected only one margin serves for all 4 sides of the drawing. 

Default: off 
 

Crop/Trim to Margin {on/off} 
This function erases all raster information within the specified margins (i.e. between the two 
rectangles). 

Default: off 
 

Format Manager 
The Format Manager provides a customization of existing formats or new formats can be defined 
(see Section 3). 
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Scale    
 

 Toolbar: Raster Operations (All) 
 

Menu: Raster ► Scale 
 

CMD: VPSCALE ► Dialog 
CMD: VPSCALE <X-Scale> [Y-Scale] 
CMD: VPSCALEDPI <DPI> 

 
Allows for scaling a raster drawing in Isotropic, Non-Isotropic, or Resolution(dpi) mode. A 
dialog box opens to select the scaling method and to enter the required values. 
 

 
 

Isotropic Mode 
The drawing will be scaled with equal values in x and y direction. Enter the actual value via 
keyboard or use [F2] to take it from the drawing; then, enter the adequate target value, or use 
the [F2] function again. 

Default: 1:1  
 

Non-Isotropic Mode 
This mode allows for different scaling values in x and y directions. The actual reference values 
can also be taken from the image using [F2]. The target values can be entered via keyboard, or 
by also using the [F2] function. 

Default: (x = y) = 1:1 

 
Resolution (dpi)  Mode 

Scale the drawing by specifying a new resolution for the raster image. The extents in base units 
(mm or inch) will remain constant. The actual value is grayed and displays the actual resolution 
of the raster image. Enter the desired resolution as target value. 

Default: 400 dpi 
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SECTION 6   
RUBBER SHEETING, 4 POINT DRAWING CALIBRATION, 
SPLIT FILE, MERGE FILES  

 

General Information   
 
To complete the rubber sheeting of raster files efficiently, especially in cartographic and cadastral 
applications, the following parameter settings and functions should be considered: 

1. Step: Adjustment of the coordinate system according to the specific map. 
2. Step: Rubber sheeting set-up. 
3. Step: Entering of reference points, including correction values, where necessary. 
4. Step: Execution of the rubber sheeting with previously selected transformation function. 

The user will be guided through all necessary steps automatically. 
 
 

Rubber Sheeting Functions  
 
You can choose one out of 9 Polynomial functions or the Triangular (Exact) Transformation 
Function supporting different rubber sheeting requirements. With the polynomial functions the 
setting Automatic (default setting) the software will select the highest possible function (up to 
Cubic) after entering the reference points. With each function, the minimum number of coordinate 
values (reference points) is indicated. For a successful calibration the input of more than the 
minimum number of reference point is recommended: 
 

Function Min. no. of 
ref. points 

Original state Result 

Helmert 2 Rotated square  
Affine 3 Arbitrary parallelogram Orthogonal 
Linear 4 Arbitrary rectangle   
Projective 4 Arbitrary quadrangle or 
Quadratic 6 Arbitrary quadrangle incl. local distortion  
Cubic 10 Arbitrary quadrangle incl. increased local 

distortion 
aligned 

Quartic 15 Cushion and local distortions square 
Quintic 21 Cushion and local distortions  
Sextic 28 Cushion and local distortions  
Exact 3 Any distortion  

 
Reference points should be distributed evenly across the image. If this is not the case, local 
distortions can have a major impact on the entire raster file. 
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Higher functions (quadratic and cubic) should be performed with about twice the minimum 
number of points. When using a grid a minimum of 16 points (quadratic) or 25 points (cubic) is 
recommended. Also, there should be an even number in each of the x and y directions. 
 
The Triangular (Exact) function corrects any (nonlinear) distortion in a raster file. It is especially 
useful if you need to correct particular points to exact positions. However, high deviations of the 
displacement direction within an area may lead to bent or cornered lines. 
 
A warning message will appear in cases where the mathematical equation cannot be solved 
properly. Entering additional reference points or - if these do not exist - choosing a lower 
transformation function can solve the problem. 
 
Imagine a square with different grades of distortion. Rubber sheeting functions can correct the 
following distortions: 
 

 

 

Helmert ► 

 

 

Affine ► 

 

 

Linear ► 

 

 

Quadratic ► 

 

 

Cubic ► 
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Multi Point Rubber Sheeting    
 

 Toolbar: Rubbersheeting 
 

Menu: Raster ► Rubber Sheeting ► Multi Point Rubber Sheeting 
 

CMD: VPRUBMULTI ► Dialog 

Starts the rubber sheeting function on the active raster image. Follow the system's advice to set 
up a proper environment for the rubber sheeting process. 
 
 

Set Up User Coordinate System 
 
The dialog box User Coordinate System appears allowing for setting up the user coordinate 
system for a particular raster image. This includes some specific values to define for the rubber 
sheeting process: 
 

 
 
By entering values for  

• Coordinate System / Projection (only VPmap Series) 
• User Unit 
• Drawing Scale 

 
the coordinate system can be adjusted to the specific requirements of a rubber sheeting process.  
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Coordinate System / Projection (only VPHybridCAD) 
This field always appears grayed and contains Standard (Cartesian). However, when a file is 
opened containing Coordinate System information (e.g. GeoTIFF) a Coordinate System with a 
specific projection can be displayed. In this case Parameter becomes available to check on 
projection parameters. However, these cannot be changed.  

 To set up and edit a specific Coordinate System with projections you will need to apply  
softelec’s VPmap Series products (VPmap, VPmap pro).  

 
Coordinate System / Projection (only VPmap Series) 

Select a Standard (Cartesian), a User Defined projection, or one of about 2.000 predefined 
Coordinate Reference Systems. If User Defined or a predefined System is selected the 
Parameter button is enabled to view and/or edit the Projection parameters .  
 
 

User Units / Drawing Scale 
 
The User Units and the Drawing Scale should be set to a value which corresponds to the 
document data. This information may be either part of the legend or the drawing header in a 
raster image or it must be known due to other information sources. This allows for measurements 
(using function [F2]) in the document and for direct use of real coordinate values for the target 
points of rubber sheeting. 
 
See Section 4 for detailed information about VP software’s coordinate system settings and 
options. 
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Rubber Sheet Settings  
 
After having set up the User Coordinate System you need to define the rubber sheeting 
parameters:  
 

 
 
 

Calculation Mode 
 
Choose between the polynomial calculation functions and the triangular function. 
 

Polynomial 
The polynomial functions calculate the correction of the distortion at all reference points with an 
integral polynomial equation. The higher the polynomial function, the smaller the remaining 
distortions will become after rubber sheeting. However, there may be remaining distortions. The 
advantage of these functions is the lack of bends along straight lines. With setting Automatic the 
highest possible polynomial function will be selected automatically with reference to the number of 
entered input points. 

Default: Automatic 
 

Triangular (Exact) 
This function splits the image into triangles between all reference points. It will reliably correct 
distortions at all reference points. Still, you need to consider that lines crossing different triangles 
may be bend at the limits of a triangle section. However, there will be no offsets.  
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Options 
 
For any modifications on the User Coordinate System you can call this dialog again. 
 

Automatic Zoom Factor 
Whenever the function requires a picking of a reference point from the raster image and the 
frame box cursor appears, the system zooms in using this zoom factor.  

Default: 1:1 
 

Specify Input Window 
This option is only available if the Input of Reference Points is either set to From File or to 
From Grid. It allows to specify a window to limit the area of the raster file reference point input. 
Nevertheless, the rubber sheeting function is executed on the whole image. 
 
 

Target Reference Points 
 
Here you can select the way of entering or marking (on screen) the Target Reference Points for 
later calibration. All Actual Reference Points are always taken from the raster image (see Input 
of Reference Points). 
 
 

1. Manual (Edit Target Points) 
 
This selection allows you to pick the reference points on your raster image and to enter the 
corresponding target positions via keyboard.  
 
After clicking OK the main rubber sheeting dialog appears. You then need to click Input Points to 
start the process of entering the reference points. The cursor switches to a frame box allowing for 
zooming in with the next click. The standard cursor appears for clicking the actual reference point 
on the drawing/map. The edit point dialog opens for entering the target position of that reference 
point: 
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Weighting of Point 
Allows for weighting the influence of a particular reference point with respect to other reference 
points on the polynomial equitation. With the triangular calibration method this value cannot be 
modified. 

Default: 1 
 

Control Point 
If you check this parameter when editing a reference point this point will not be rubber sheeted. 
Instead, it is intended to serve as a control point. This parameter is always reset for the next 
editing. 
 
On clicking OK the dialog is closed and the values appear in the main rubber sheeting dialog. 
Repeat this process until all reference points have been entered. Then click OK in the main 
rubber sheeting dialog to execute the rubber sheeting. 
 
For further processing see Rubber Sheeting Dialog. 
 
 

2. Manual (Pick from Vector Drawing) 
 
Use this mode if you have a vector drawing to which you want to rubber sheet the raster image in 
a way that it fits with its reference points to corresponding points on the vector drawing. Import the 
vector drawing and ensure that the layer containing the vectors is switched on. Activate the vector 
snap and use appropriate snap modes. 
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After clicking OK the main rubber sheeting dialog appears. Click Input Points to start the process 
of entering the reference points (i.e. the Actual Position) on your raster image. The cursor 
switches to a frame box allowing for zooming in with the next click on the area of the first 
reference point. The standard cursor re-appears for clicking the precise position. From that 
position a green line is stretched to the cursor. Then, click the corresponding point (i.e. the Target 
Position) on the vector drawing. Use the Pan and Zoom functions, if necessary; here, the vector 
snap supports precise positioning. The frame box cursor re-appears for clicking the area of the 
next reference point. The software zooms in again for clicking the precise position. Proceed in the 
same way until all reference points and target positions have been defined. The values are 
displayed in the main rubber sheeting dialog. The best suitable polynomial rubber sheeting 
function will be selected automatically. Execute the rubber sheeting with OK in the dialog. 
 

Sample 

 

 
 

3. Use Intersections of Vector Entities 
 
Use this mode to calibrate a drawing according to intersections between vector elements, such as 
lines and polylines, or to the center of (small) circles. You will be asked to select the vector 
elements. The system will calculate and display all intersections (numbered automatically) 
between the elements. For each intersection which serves as a Target Point you need to pick the 
respective actual position on the image. The system supports precise inputs by zooming in and 
out automatically (frame box cursor). All reference points will be listed in the main rubber sheeting 
dialog and the best fitting rubber sheeting function will be selected automatically. 
 
Click OK for starting the rubber sheeting process. For entering the actual positions of the 
reference points see Input of Reference Points. 
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Sample of Intersection Point by Vector Elements 

 
 
 

4. Input from File 
 
For target reference points stored in a text file you can use this function to read the target 
coordinates. If the target reference points are not distributed all over the raster file you can limit 
the area of interest for entering the actual positions of the points by specifying a window (check 
Specify Input Window in Options). Nevertheless, the rubber sheeting process will be executed 
on the whole image. 
 

Clicking OK in the dialog Rubber Sheet Settings allows you to specify and read the contents of 
a text file. A subsequent dialog contains specific settings. 
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After confirming the settings with [OK] a dialog displays the number of the required actual input 
points. 
 

Begin Coordinates with Row 
Coordinate files that have been generated by other applications may contain additional text 
information. If it is located at the beginning of the file you can skip this part by entering the line 
number where the import of coordinate values starts. You can get the line number from the 
displayed list. Then, all preceding data is removed from the list and the row number is set to 1. 

Default: 1 
 

Separator 
Select the characters that are used in the text file to separate consecutive coordinate values from 
each other. In the displayed list you may check the correct settings.  

 X and Y coordinates must be displayed in individual columns. 
 

Select Columns for X and Y coordinate 
Here you can enter the column numbers (see the display list’s header) for the target values of X 
and Y coordinates. When a projection has been specified in the current coordinate system the 
option „Degrees“ will offer to define target values in geographical coordinates. 
 

Actual 
As for the target values, you can also enter the actual values of a distorted document. When 
activated the columns for X and Y coordinates need to be specified. The option Pixel will interpret 
all imported values as pixel coordinates (origin at upper left). 
 
OK brings you to the main rubber sheeting dialog for entering the actual reference points. 
 
 

5. From Grid 
 
If the reference points are evenly distributed throughout the drawing on an even or irregular grid 
you can choose this procedure for a system supported input of the reference points. You need to 
specify the grid distance for the X (or X and Y) coordinate by entering the value or using [F2] 
function to measure the distance between two points on the raster image. Then, round the values 
so they comply to the original grid. For precise positioning of the grid with respect to the actual 
reference point do not forget to define the USC origin at the lower left reference point (see Set Up 
User Coordinate System). 

Default X: 100 
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Different Grid {on/off} 
If the grid has a different spacing in X and Y direction switch on this option and enter the 
corresponding spacing values into the X and Y fields.  

Default: off 
 

Grid Angle 
If the grid on the map is rotated enter the rotation angle in this field.  

Default: 0° 
 

Keep the Grid Angle {on/off} 
You can check this option on if you want to keep the grid angle of your map after rubber sheeting. 
Otherwise, the map will be rotated to an orthogonal orientation of the grid. 

Default: off 
 
This way a grid for all target points will be generated and automatically assigned to the actual 
points on the raster image. If the grid does not cover the entire raster file you can limit the area of 
interest by specifying a window (check Specify Input Window in Options). Nevertheless, the 
rubber sheeting process will be executed on the whole image. 
 
Clicking OK shows the specified grid on the map or asks for dragging a window for a limitation of 
the area. Then, the main rubber sheeting dialog appears.  
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Input of Reference Points  
 
After completing the Rubber Sheet Settings, the main rubber sheeting dialog box appears 
prompting for the entry of reference points and the choice of a rubber sheeting function.  
 
 

Input Points {on/off} 
 
If you have selected the modes 3 or 4 (User Intersections of Vector Entities or Input from 
File) in the Rubber Sheet Settings you will find all target reference points listed in the dialog. 
With all other modes the listing in the dialog will be empty at this stage. 
 

 
 
The button Input Points for picking the actual reference points from the raster image/map can be 
clicked to start the process.  
 
With modes 3, 4, or 5 the system zooms in according to the selected zoom factor to the first point 
(a green line is stretched from the target point to the cursor), so you can pick the actual position 
from the raster image. The system then jumps to the area of the second reference point and so 
on. After all required reference points have been picked the system zooms out and displays in the 
dialog actual and target position of each point. 
 

 
 
With mode 1 and 2 the actual and the target reference points need to be entered/edited as 
explained above. If the Automatic Zoom Factor in the Rubber Sheet Settings is on the cursor 
switches to the zoom frame box at each initial positioning click. 
 
For picking the actual points you can switch on the raster snap, although this is only 
recommended if the reference points on the raster are very clear and crisp.  
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As soon as the minimum number of reference points is entered (according to the selected rubber 
sheeting function), the remaining offset (Error) from the target position for each reference point 
after the rubber sheeting process will be calculated and displayed. If the calculation mode 
Polynomial has been selected the system will automatically select a higher transformation 
function with increasing number of reference points and will calculate the errors accordingly. 
 
If the cursor jumps to an area with a missing or unclear reference point (sometimes you may even 
look at an "empty" screen), you should first zoom out for control using the (-) zoom icon. If there is 
no actual reference point or you have moved beyond the map's extents skip this point by using 
the right mouse button. 
 
At each reference position cross marks and vectors indicate the following: 

• Label No. of the Reference Point 
• Red cross = actual value 
• Green cross = target value 
• Yellow cross  = attainable correction 
• Distance green/yellow = remaining offset from the target value 

 
After all reference points have been entered switch off the button Input Points. 
 
 

Rubber Sheeting Function 
 
With the Polynomial Calculation Mode you can select the desired rubber sheeting function or 
Automatic. With Automatic the program suggests a suitable function automatically and will 
calculate correction values concurrently while in the input mode. In proportion to the number of 
entered reference points the system will suggest a higher transformation function, i.e. providing 
the highest attainable rubber sheeting precision. A lower transformation function can always be 
chosen. 

 If the mathematical equation cannot be solved properly, a warning message will appear. In 
this case more reference points ought to be entered or a lower function should be selected. 

 
 

Button Functions 
 
Save allows saving of reference values and settings to a file (extension .RYP) preferably in the 
raster file's directory. You also can export a text file (select the extension .TXT) containing all 
information of the current rubber sheeting setup for documentation (e.g. reference point 
coordinates).  
 
Load will load a .RYP file to continue with rubber sheeting operations. 
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Error Statistics opens an info box showing error statistics: 
 

 
 
Delete Point deletes the current reference point. 
 
Edit Point opens another dialog box to edit a reference point. The actual value can be taken 
directly from the raster drawing by using [F2].  
 
Grid/UCS brings you back to the Rubber Sheet Settings dialog (see before). 
 
Cancel will terminate rubber sheeting operations at any time. 
 
OK starts the rubber sheeting. The progress indicator appears. After completion the corrected 
file will be displayed containing yellow and green cross signs to review the accuracy of rubber 
sheeting. Termination with OK. The new file should be saved. 
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4 Point Drawing Calibration    
 

 Toolbar: Rubbersheeting 
 

Menu: Raster ► Rubber Sheeting ► Calibrate to Drawing Format 
 

CMD: VPRUB4POINT 

This function is especially designed for rubber sheeting of technical drawings based on a 
drawing's paper format. Usually, technical drawings are created on transparencies with a drawing 
frame bearing an orientation to the paper format. This drawing frame will be used as a scale 
reference for the necessary rubber sheeting process. It is also assumed that the drawing's 
contents will remain in the desired scale after the rubber sheeting process. 
 

limit of raster file

upper margin

lower margin

left
margin

right
margin

drawing frame

paper edge

reference points reference points

 
 
 

Preparation 
 
The 4 point drawing calibration function can only be executed on an image which is not scaled or 
displayed with an angle (review and/or modify with the function Properties). Otherwise, the 
following message appears: 
 

 
 
If you don't allow the software to modify those values the function will be cancelled.  
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When invoking the command or clicking the above icon a dialog box appears to select a drawing 
format or to define a new format with its settings: 
 

 
 
This function allows for rubber sheeting a raster file to fit to a selected format (size).  
 
 

Options 
 

Use Auto Selection {on/off} 
If set to on the Paper Format that matches the raster image best is selected. Otherwise, the last 
used format is selected. 

Default: on 
 

Paper Format 
The majority of standard formats are available for selection. In addition, individual values for 
Width and Height may be entered. 
 

Margins 
The 4 margins determine the distances between the drawing frame and the physical paper 
limits (= paper size). For example, the length of the paper form (taken from edge to edge of the 
paper) minus both margins (left and right) defines the effective drawing frame's length. 
 
While each paper format can bear different values for margin distances, Save as Default saves 
the actual margins for permanent use with the selected form size. 
 

Different Margins {on/off} 
If set to off, only one margin serves for all 4 sides of the drawing. 

Default: off  
 

Crop/Trim to Margin {on/off} 
This function erases all raster information within the specified margins (i.e. between the two 
rectangles). 

Default: off 
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Format Manager 
The Format Manager provides a customization of existing formats or new formats can be defined 
(see Section 3). 
 
 

Calibration 
 
After selection of the Paper Format and Margins and clicking OK a rectangle representing the 
selected paper form is placed on your drawing. If there are margins specified a double rectangle 
will be displayed instead. The cursor appears with a frame box linked to the upper left corner of 
the (inner) rectangle of the drawing format. Click the upper left corner of the raster image for 
zooming into this area and then place the appearing standard cursor precise on the frame corner 
of your raster drawing. The system jumps to the next corner (upper right) and the frame box is 
now linked to the corresponding corner of the (inner) rectangle. Proceed as before. After having 
clicked all 4 corners the rubber sheeting process is executed and the final raster image appears 
on screen for saving. 

 The drawing should be deskewed and rotated to the desired orientation prior to starting this 
procedure. 
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Split a File (only VPmap Series)   
 

 Toolbar: Split+Merge 
 

Menu: Raster ► Raster Operations ► Split 
 

CMD: VPSPLIT ► Dialog 
 

CMD: VPSPLIT <X-Size/Number> <Y-Size/Number> [/M <Value>] [/R <Value>] [/E] [/T] 
 [/OX <Value>] [/OY <Value>] [/N <File Name>] 

You can manually split a raster file into a maximum of 625 sections by positioning up to 24 
horizontal and 24 vertical split lines on the drawing or automatically by specifying a tile size (or 
count) in order to generate equal-sized tiles (mosaics). The tiles can be saved into separate files 
or will replace the current raster in the document. 
 

The split function can only be executed on an image, which is not displayed with an angle (review 
and/or modify with the function Properties). Otherwise, the following message appears: 
 

 
 
If you don't allow the software to modify this value the split function will be cancelled.  
 

When executing this command on the active raster file a dialog box opens to define the number 
or size of horizontal and vertical sections. In manual mode a maximum of 25 sections in each 
direction may be selected: 
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Specify Sections Individually 
On OK you can position the split lines on the image. 
 
The status line calls for a positioning of the first horizontal split line. Follow these steps to 
position all horizontal, and then all vertical split lines:  

• Click where the first line should be positioned. Zoom and Pan commands are available. 

• The split line appears in green. 

• Clicking the right mouse button opens the context menu. You can delete the last split line with 
Undo and re-position it again. 

• Continue until all horizontal split lines have been set. Select Add Vertical Split Line(s) from 
the context menu and set the desired vertical split lines.  

• After positioning the last line select Finish Input from the context menu to start processing.  
 
The new raster images which are going to be created will be named according to the original 
image and their position in correspondence to the original file: 

First digit: Horizontal position (row, top to bottom) 
Second digit: Vertical position (column, left to right) 

The origin (0-0) resides at the upper left.  
 

Manual Split [/M M] 
Select the number of Horizontal Sections (Y-Direction) and Vertical Sections (X-Direction). On 
OK you will be asked to position the split lines on the image. 
 
The status line calls for positioning of the first horizontal split line. Follow these steps for 
positioning all horizontal, and then vertical split lines:  

• Click where the first line should be positioned. Zoom and Pan commands are transparent. 

• The split line appears in green. 

• Clicking the right mouse button opens the context menu. You can delete the last split line with 
Undo and re-position it again. 

• Continue until all horizontal and vertical lines have been selected. After positioning the last 
line the process starts.  

 
The new raster images which are going to be created will be named according to the original 
image and their position in correspondence to the original file: 

First digit: Horizontal position (row, top to bottom) 
Second digit: Vertical position (column, left to right) 

The origin (0-0) resides at the upper left.  
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Mosaicing 
With this mode all tiles will have an equal size, which means the image might be extended in all 
directions when creating the tiles. Four different modes are available to define the size of the tiles: 
 Number of Sections /M C Define the number of tiles in X- and Y-direction. 
 Size in Pixel /M P Specify the absolute size of each tile in pixels 
 Base Units /M B Specify the size of each tile in the currently used 
   Base Units (mm or inch) 
 UCS Units /M U Specify the size of each tile in the units of the current 
   User Coordinate System (e.g. m) 
 
The lower part of the dialog will show the currently defined absolute size of each tile in pixels as a 
reference. 
 
The option Number of Sections creates quadratic tiles by default. By setting Non-Quadratic to 
on you can specify the tile height independently from the tile width. 
 
Further, you may specify a Reference Position where the splitting should start. Valid options are: 
 UCS Grid Position /R U Only effective with the options Base Units or UCS Units! 
 Image: Upper Left /R UL Upper left corner of image 
 Image: Lower Left /R LL Lower left corner of image 
 Image: Upper Right /R UR Upper right corner of image 
 Image: Lower Right /R LR Lower right corner of image 
 Image is Centered /R C Image is centered on the tiles 
 

Overlap Margin {on/off} [/O] 
This option allows to increase the tile size by a specified margin in order to create overlapping 
tiles. A margin value can be entered in the adjoining edit field. 
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Export to Files {on/off} [/E /N <File Name> /T /OX<XN> /OY <YN> 
This option allows to export each created tile into a separate file (set on).  
 
In the dialog mode you are requested to enter the base file name for all split files. In the 
command line mode the filename of the image is automatically used as the base file name. Two 
digits in parenthesis will be appended as (0-0), (0-1), etc. The first digit indicates the row (top to 
bottom), the second digit the column (left to right). 
 

/N <Name> Base ( and path) for tiles. Tile numbers will be added in format (X-Y). 
/T Coordinate values of the lower left corner and of the upper right corner in the 

original file will be written to a text file in user units.  
/OX <XN> Numbering of tiles in X direction will start at XN , not at 0. 
/OY <YN> Numbering of tiles in Y direction will start at YN , not at 0. 

 
 

Default Settings 
If only <Vertical Size/Count> <Horizontal Size/Count> are specified on the command line, the 
command will be executed with the options /M M which means Manual Split. 
 
The default value for the /R option is /R UL which means that the upper left corner of the image 
will be identical to the upper left corner of the first tile. 
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Split a File (only VPHybridCAD)   
 

 Toolbar: Split+Merge 
 

Menu: Raster ► Raster Operations ► Split 
 

CMD: VPSPLIT ► Dialog 
 

CMD: VPSPLIT <X-Count> <Y-Count> [/E] 

You can manually split a raster file into a maximum of 625 sections by positioning up to 24 
horizontal and 24 vertical split lines on the drawing or automatically by specifying a tile size (or 
count) in order to generate equal-sized tiles (mosaics). The tiles can be saved into separate files 
or will replace the current raster in the document. 

The split function can only be executed on an image, which is not displayed with an angle (review 
and/or modify with the function Properties). Otherwise, the following message appears: 
 

 
 
If you don't allow the software to modify this value the split function will be cancelled.  
 
Normally, a dialog opens to define the number of tiles in the raster image: 
 

) 
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Arbitrary 

On OK you can position the split lines on the image. 
 
The status line calls for a positioning of the first horizontal split line. Follow these steps to 
position all horizontal, and then all vertical split lines:  

• Click where the first line should be positioned. Zoom and Pan commands are available. 

• The split line appears in green. 

• Clicking the right mouse button opens the context menu. You can delete the last split line with 
Undo and re-position it again. 

• Continue until all horizontal split lines have been set. Select Add Vertical Split Line(s) from 
the context menu and set the desired vertical split lines.  

• After positioning the last line select Finish Input from the context menu to start processing.  
 

The new raster images which are going to be created will be named according to the original 
image and their position in correspondence to the original file: 

First digit: Horizontal position (row, top to bottom) 
Second digit: Vertical position (column, left to right) 

The origin (0-0) resides at the upper left.  
 

Fixed <X-Count> <Y_Count> 
Select the number of Vertical Sections (X-Direction) and Horizontal Sections (Y-Direction). On 
OK you will be asked to position the split lines on the image. 
 
The status line calls for positioning of the first horizontal split line. Follow these steps for 
positioning all horizontal, and then vertical split lines:  

• Click where the first line should be positioned. Zoom and Pan commands are transparent. 

• The split line appears in green. 

• Clicking the right mouse button opens the context menu. You can delete the last split line with 
Undo and re-position it again. 

• Continue until all horizontal and vertical lines have been selected. After positioning the last 
line the process starts.  

 
The new raster images which are going to be created will be named according to the original 
image and their position in correspondence to the original file: 

First digit: Horizontal position (row, top to bottom) 
Second digit: Vertical position (column, left to right) 

The origin (0-0) resides at the upper left.  
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Export to Files {on/off} [/E] 
This option allows to export each created tile into a separate file (set on).  
 
In the dialog mode you are requested to enter the base file name for all split files. In the 
command line mode the filename of the image is automatically used as the base file name. Two 
digits in parenthesis will be appended as (0-0), (0-1), etc. The first digit indicates the row (top to 
bottom), the second digit the column (left to right). 
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Merge Raster Files   
 

 Toolbar: Split+Merge 
 

Menu: Raster ► Raster Operations ► Merge 
 

CMD: VPMERGE ► Dialog 

Two raster images can be merged into one image. The active raster image is always the base 
image to which a second image will be positioned, scaled, and merged. If you select another 
raster image (if available) prior starting the command, then this image will be merged to the 
active raster. 
If no other image (already imported into the document) has been selected, the system opens the 
import dialog and requests to load a raster file as second image for merging.  
Thereafter, a dialog box appears to select the appropriate merging method:  
 

 
 

Options 
 

As is 
Merges the two images as they are displayed on screen. 
 

Specific Corner 
Enlarges the dialog and offers to select the position of the second image with respect to the active 
image. This function is designed for quick and easy positioning of raster images with no margins: 
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Move 
Allows the raster object to be moved with respect to the active raster image without scaling 
and/or rotation according to one moving vector. You are requested to draw a line (the move 
vector) defining the move distance and angle. Then both files are merged. 
 

Fit 
Calls for two moving vectors. This way, the raster object can be scaled, moved, and/or rotated 
according to the two vectors with respect to the active raster image. Then both images are 
merged. 
 

Cut Edge 
This function is similar to Fit, as it also uses two moving vectors for fitting the second image to 
the active image. However, this function cuts both images along a line through the 2 target points 
of the drawn vectors. With the following dialog you can switch between 2 remaining images: 
 

  
 

Draw Line {on/off} 
Allows for drawing a user defined line for cutting both images instead of the line through the target 
points. 
 

Update View {on/off} 
Updates the display after entering each of the moving vectors to show the actual  position of the 2 
images.  
 

Opaque (B/W images only) {on/off} 
If checked on b/w raster images are treated opaque, i.e. the section of the active image 
underneath the moved raster image is not visible.  

 
Keep as separate Images {on/off} 

If checked on the two images will not be merged into one new image, but stay as two separate 
images adjusted to each other. 
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Any two image formats can be merged. When merging different color, gray scale, and b/w raster 
images, a dialog may open to select the target color depth: 
 

 
 
If you merge two paletted images based on different palettes, you can choose either to calculate 
a new palette or to create a true color image (recommended). 
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SECTION 7   
COLOR REDUCTION, SEPARATION, FILTERS  
    

General   
 
When color or gray scale originals are scanned with applicable scanner devices, you will generate 
very large raster files containing millions of colors. To process these files in CAD programs, it is 
important to optimize the color and gray scale information. This can be done either by reducing 
minor colors, combining colors, or by leveling color transitions to reduce the information for each 
of the remaining colors, thus render a proper interpretation possible. 
 
To accomplish this, VP software’s built-in scanner interface allows you, besides executing full 
color (24 bit) scans, to limit the number of colors to be captured to 256 colors or less by using a 
color conversion table (image palette). This table is based on either a standard color palette or on 
an adaptive palette created during a prescan. Thus, an indexed color image will be generated. 
 
An indexed image contains 256 or less colors/gray scales. Each index represents a specific color 
by its portions of the three basic colors red, green, and blue (each basic color having a value from 
0 to 255) that have been assigned during the scan process to a palette. Hence, a palette is a 
table where each of the image's colors (256 or less) is assigned proportions of the basic red, 
green, and blue color (i.e. RGB). 
 
Using the color reduction process, the original total number of colors can be reduced to create 
solid colors. Thus, the original file size may be reduced dramatically, while the image's 
representation may improve at the same time. The overall goal is to reduce the number of colors 
or gray scale tones and to condense the contained information on base colors. 
 
The color separation process allows only for reducing colors but also for creating (and, if 
necessary for exporting) bi-level (b/w) raster images from remaining or individually selected 
colors. These images can be processed just like any other "regular" b/w file.  
 
For further processing color images can be treated as bi-level images. In this case the active 
(foreground) pixels are composed from a color or gray scale pattern. (Function: Image Settings, 
see Section 4). 
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Scanning Colors    
 
After inserting an original document and setting up the scanner (see your scanner manual and/or 
Section 3), the assignment of a palette can be activated. Also, an existing palette can be 
selected if you don't want to scan in full color. A dialog box appears to define the palette (color 
map) for the color reduction to a maximum number of 256 colors: 
 

 
 
When choosing Linear Color Map a conversion will be executed according to the standard color 
palette. 
 

When choosing Computed Color Map a prescan will follow to detect the existing colors in the 
actual original. From these colors an individual color palette will be generated. 
 

In the selection box the desired maximum number of colors can be specified. 
 

The dialog box closes on OK followed by the prescan and the calculation of the color palette. 
Then, the selected scan function will be executed. 
 

After every Stop action in the scan menu or when reaching the end of the document, the current 
calculated palette will no longer be valid. When repeating the scan action, a new palette will be 
calculated and assigned. If you switch from Forward to Scan directly, though, the same palette 
will be used. 
 
 

Color (Gray Scale) Reduction  
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Color Reduction 
 

CMD: VPREDUCE ► Dialog 
 

CMD: VPREDUCE [RM|RedMethod <VALUE>] [C|Color <Value>] [P|Palette <Filename>] 

If the active raster file is a full color image (RGB) or contains more than 256 colors/gray scales a 
dialog box appears for selecting an automatic color reduction method and the number of colors 
after this first step: 
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Default: Color Reduction Method: Median Cut 

Reduce to Colors: 256 
 
The active raster image will be converted to a indexed file with the selected amount of colors. 
Then, the dialog box for color manipulation appears, displaying all existing colors in the raster 
image: 

 
 
The dialog boxes contain two main areas: the lower Preview Area displays the image as it will 
look after any step of color manipulation/reduction, while the upper Histogram Area presents the 
colors currently contained in the image. 

 In the preview area the default cursor is a pipette which allows colors to be selected from the 
raster image by clicking with the left mouse button on anyone pixel. To select the color of an area 
click and drag the mouse for a window selection of all colors enclosed. Use Pan and Zoom 
functions for a precise selection. 

 To deselect colors from within the Preview hold the [Shift] key while re-selecting as described 
above. Colors can also be deselected by clicking again on a selected color in the histogram area. 
The first selected color will flash in the histogram area. It serves as the Target Color for the 
subsequent operation(s). 
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Preview Area  
 

Preview Modes 
Any color or color pattern selected in the histogram or preview area will be displayed in the 
preview area corresponding with the selected preview modes: On, False Color, and Flash. 
 
On: Activates the display of selected and/or modified colors in the preview. Selected colors are 
displayed in the preview with their Target Color. 
 
False Color: For better distinction check false color. It shows the selected colors not in the target 
but in its complementary color. 
 
Flash: Toggles the view of the selected colors on and off automatically. 
 
 

Pan and Zoom 
To move around the Preview you can use the scrollbars. There are several zoom commands 
available: 

 Zoom Extents shows the entire image in the preview window. This is the initial state when 
the dialog opens. 

 Zoom Window switches the cursor in the preview into a crosshair for selecting an image 
area to zoom in. Then, the cursor switches back to a pipette. 

 Zoom 1:1 switches the cursor to a magnifier glass in the Preview. Click the desired center of 
the view with the left mouse button for zooming in. Then, the cursor switches back to a pipette. 

 Zoom In. 

 Zoom Out. 

 Zoom Previous shows the previous view of the image. 

 Zoom Next shows the view before the Zoom Previous state. 
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Processing Buttons 
OK: Executes all color reduction operations on the active raster image and leaves the dialog. Use 
the function Undo if you want to return to the status prior to starting Color Reduction. 
 
Cancel: Closes the dialog box without changes in the original image. 
 
Reset: Rejects all modifications of the color reduction process. It restores the original palette.  
 
Load: Opens the load dialog for loading a color reduction palette (Raster Palette, .RPL). Included 
in this file are the image's original and reduced palettes. You can only load a color reduced 
palette if the original palette and the saved reduced palette match. In case you want to apply a 
certain color reduced palette to several scanned images make sure that these images have been 
scanned to the same palette. 
 
Save: Opens the dialog for saving a color reduction palette (Raster Palette, .RPL). You can load 
the palette with Load in this dialog or in the Scan dialog.  
 
 

Histogram Area  
 
In this area the image colors are represented either as Columns (if 50 or less colors remain) or 
as a Button Array, with one button for each color. The buttons can be clicked for selecting colors 
(if not picked from the image). In pressed status they indicate which colors have been selected. 
Clicking the right mouse button on the color button array and dragging a window, while keeping 
the mouse button pressed selects all included buttons. 
 
The first selected color flashes in the histogram area. It serves as the target color for reduction. 
Deselecting this color by clicking the color button again will cancel the selection of colors. 
 
The column height in the histogram indicates the frequency rate of colors in the image. There is 
also an action button below each column. Clicking the action button adds or removes this color to 
or from the list of selected colors. 
 
When the Histogram is displayed a slider on the right can be moved up and down to scale the 
frequency bars of the histogram. This option is intended for a better view of minor frequency 
rates. 
 
The context menu (right mouse click) offers some of the major functions: Combine Colors, 
Export Color(s) to Raster File(s), De-select All. 
 

Color Sort Options  
 
There are two Histogram Sort Options available:  
 

Count Sort 
Shows all colors in the order of their frequency rate in the image. The most frequently contained 
color is displayed in the upper left position of the button array and as the first left column 
respectively. 
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Color Sort 
Shows all colors sorted according their relative color distance. The darkest color is displayed in 
the upper left position of the button array and as the first left column respectively. 
 

Count Sort: 

 
Color Sort: 

 
 

Modify a Color  

 If you want to change a color, select this color in the color button array (or in the column 
histogram) or pick from the image and then click on this icon. The standard Windows color dialog 
opens for selecting a new color: 
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Color and Pixels Area: 
 
When clicking on a color button or the respective color bar the color's frequency rate in the entire 
image is displayed in the Color and Pixels Area: 
 

 
 
 

Automatic Color Reduction  

 Clicking this icon in the color reduction dialog starts the automatic color reduction. A dialog box 
opens displaying the actual number of colors used and asks for entering the desired number of 
colors after reduction (minimum number = 10) and offers the selection of a reduction method: 

 
Default: Median Cut 
 
With OK the image will be updated and displayed in the preview dialog window with the reduced 
color palette.  
 
 

Interactive Color Reduction  

 Clicking this icon in the color reduction dialog executes the color reduction of all selected colors 
to the Target Color. The number of remaining colors is reduced accordingly. If less than 51 
colors remain the color display in the histogram area changes to a column representation.  
 
The Target Color receives a double frame in the button array for a better distinction between a 
target color and those to be combined. 
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There are different ways to select colors for reduction: you can click on the respective button in 
the histogram area or on an image pixel in the preview area. In the latter case, the cursor appears 
as a pipette. Multiple colors can be selected in the histogram area while keeping the right mouse 
button pressed and dragging a window, and in the preview area by dragging a window while 
keeping the left mouse button pressed. The selected colors are indicated by an inverse (pressed) 
button state in the histogram area. The color selected first will be the Target Color, thus receiving 
a highlighted frame and a flashing display. 
 
To deselect a color click on the corresponding color button or click on a pixel of the respective 
color in the Preview while pressing [Shift]. If the target color is deselected, all other selected 
colors will also be deselected. 
 
 

Split (Explode) Color  

 If you select a color which other colors have been combined to previously (by automatic or 
interactive color reduction) you can click this icon to explode the color back into its components.  
 
 

Reduce only Minor Colors  

 Clicking this icon allows for a selective automatic color reduction of minor colors in the image to 
their adjacent major colors. A dialog box opens: 

 
Moving the slider or entering a value (max. 10%) will select all minor colors (from the end of the 
color histogram in count mode) controlled by the percentage with respect to the whole image and 
according to the remove mode. This process provides a quick reduction of all minor colors in an 
image which usually do not represent any valuable information. 
 

Accumulated for All Colors 
The displayed value is the total percentage of all selected minor colors.  
 

Absolute for Singular Colors 
Those colors are selected each of which has a share of the displayed percentage or less in 
relation to the whole image.  
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Convert Image to B/W  

 Click this icon to convert the image into a b/w raster file. The colors of the image will be 
converted to b/w according to the standard b/w conversion palette. 
 
 

Undo, Redo 

  Undo and Redo will undo or redo the individual reduction steps. This way you can test 
the effects of reduction on a varying number of colors. The number of undo steps is limited to 32. 
 
 

Export Selected Colors  

 Click this icon to export the currently selected color(s). A dialog box opens for defining the 
export process: 
 

 
 

Export to File(s) 
Generates an individual b/w raster file for each selected color. After entering a file name all files 
will receive a suffix: "_sepNN" (NN starts counting from 01) and saved in TIFF format. The colors 
will be numbered from left to right and from top to bottom according to the selected colors in the 
histogram area. 
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Add to Active Document 
Creates new layers to the active image each of which contains the b/w raster of one of the 
selected colors. If Automatic Layer Definition is checked the system assigns the RGB values as 
names for each layer. Otherwise the following dialog opens allowing the selection of any available 
layer or creating new layers for each exported color: 
 

 
 

All Selected Colors in one Image 
Creates a new raster image containing all selected colors. A b/w image will be created by default. 
With the following option you can create a colored image:  
 

Create Colored Image 
Creates a colored image containing the currently defined background color and all selected 
colors.  
 

Color Filling  

 Click this icon to fill areas. In the preview area the cursor changes to a fill cursor. It allows to fill 
a color pattern area in the image with one solid color by clicking into the area. The fill function 
calculates a mean color value of the pattern and fills the area with the closest palette color. If you 
have selected a color prior to activating this function, this color is used for filling. 

 The Color Filling function stays active until it is switched off again. The filling Color can 
only be modified (selected) when the Color Filling function is switched off. 
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Single Pixel Pen  

 Select the active color (either click on a color button of your choice, define a new color being 
active, or select the active color with the pipette from the image). Then click this icon to change a 
single pixel to the active color by a left mouse click. 

 The Color Filling function stays active until it is switched off again. The filling Color can 
only be modified (selected) when the Color Filling function is switched off. 

 
 

Add New Color 

 If you want to fill with a specific color you can either select it from the histogram area (i.e. click 
on the desired color) or add a new color to the palette by clicking this icon. Adding colors is only 
possible if less than 256 colors are used in the image. 
 
 

Automatic Color Cleanup (Reduction)  
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Automatic Color Cleanup  
 

CMD: VPCOLORCLEAN  

Click this icon to perform an automatic color reduction. The algorithm searches for the main 
colors in the image and combines color pattern to solid colors as far as possible. For remaining 
color pattern use the interactive color reduction process. 
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Palette Functions   
 

Load Palette  
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Load Palette 
 

CMD: VPPALLOAD ► Dialog 

This icon opens the load dialog for selecting a palette file (format: .RPL). The selected file is 
loaded to the active raster image. 
 
 

Save Palette  
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Save Palette 
 

CMD: VPPALSAVE ► Dialog 

Click this icon to save the current palette from the active image to a file. This function is only 
available with indexed raster images. The palette will be saved in the format .RPL. 
 
 

Palette Transformation  
 

General 
The transformation of a palette compensates for possible scan weaknesses (e.g. contrast or 
brightness) or lets you modify an image's color representation to individual needs. Especially 
converting gray scale images to false color images allow for a better distinction of specific 
information. 

There are several palette transformation functions to choose from, depending on how the image 
should look like after it has been transformed. However, each transformation function will not 
change the index structure of the image palette but only the assigned values for the three basic 
colors. Thus, the original pixel information remains untouched. 
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Transformation 
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Palette Transformation 
 

CMD: VPPALTRANS ► DIALOG 
CMD: VPPALTRANS [/B <VALUE>] [/C <VALUE>] [/BP <VALUE>] [/WP <VALUE>]  
 [/G <VALUE>] [/SG <VALUE>] 

Enhances the quality of an image by transforming the color table. Changes can be made fast and 
easy in the Color Table Transformation dialog or directly from the command line. For more 
information about the transformation functions see next topic: Transformation (Advanced). 
 

 
 

Color Tone 
Brightness [/b <brightness>]:  Range from -127 to 127, default 0.  
Contrast [/c <contrast>]: Range from -100 to 100, default 0.  
 

Color Balance 
Black Point  [/bp <black point>]:  Range from 0 to 255, default 0.  
White Point [/wp <white point>]: Range from 0 to 255, default 255.  
 

Gamma Correction 
Gamma [/b <gamma>]:  Range from 0.14 to 7.0, default 1.0.  
S-Gamma [/b <turn point>]: Range from 0 to 255, default 255.  
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Show Original Image / Show Preview 
Switch from preview to original image and back. 
 

Reset Values 
Any changes will be reset. 
 
 

Transformation (Advanced) 
 

Menu: Raster ► Color ► Advanced Palette Transformation 
 

CMD: VPPALTRANSADV ► DIALOG 

Start the command to open the dialog for the advanced palette transformation. It is organized in 
three sections:  

• Transformation Area 
• Output View 
• Input View 

 
Transformation Area determines how palette entries will be modified. The input and output areas 
both contain views of the actual image, however, the output view shows the image based on the 
currently transformed palette.  
 

In the transformation area you select the transformation function and define process values if 
required. The graphical representation of the transformation is shown on the right and allows for 
adjustments. 
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The vertical axis in the transformation view represents the output values of the current palette 
(black is on the bottom, white on top). In case you have chosen a colored image the axis is 
displayed in red, green, and blue. Otherwise, it will appear in gray. The palette's input values are 
represented accordingly by a horizontal axis (black is on the left, white on the right). The Output 
axis' color succession can be reversed using the Invert checkmark. The following diagram shows 
how to read the Transformation View. 

 
 

With two different transformation functions used in this example above the same value of the 
input palette is transformed into two different output values. 
 
 

Transformation Functions  
 
The combo box allows selection of one of the available transformations: 

• Automatic Brightness/Contrast* 
• Brightness/Contrast* 
• Automatic Smooth* 
• Smooth*, # 
• Gamma Correction 
• S-Gamma Correction 
• Steps 
• Lines 

 
The transformations marked with (*) bear a default setting when selected depending on the 
image. "Automatic" transformations do not carry settings that can be modified. Transformations 
marked with (#) can only be modified in the numerical view. Selecting a new transformation 
changes both the numerical and the transformation view. To modify the transformation settings 
you can edit in both views. 
 

Connect {on/off} 
When this checkmark is on and a color image is to be processed, then the three basic colors red, 
green, and blue will be treated together. Thus, only one curve is displayed in the Transformation 
View. 
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Handles 
Moreover, the combined treatment of the three basic colors with Connect will set a primary active 
color. It is the one that carries handles, even if the Handles checkmark is not set. It is also 
highlighted in the numerical view, or it is the only color that is represented by a curve (if Show 
RGB is deactivated). With Connect, the active color's current attribute values will be assigned to 
the remaining two basic colors. 
 

View RGB 
If this checkmark is on and Connect is off with a color image, there are three curves, each with a 
different color.  
 
To modify only one color set Connect to off. Then the active color's curve (red, green, or blue) is 
displayed. Depending on the View RGB checkmark setting the other two colors will either be 
accessible, too, or they are not displayed. 
 
There are three ways to select a specific color for modification:  

• Select the desired color (Red, Green or Blue) in the numerical view. 
• Click with the right mouse button in the transformation view window. 

A popup menu appears for selecting a color. 
• Set the Handles checkmark and click on the desired color's curve handle.  

 
The parameter settings of a transformation can be modified in the numerical view or in the 
transformation view. 
 
In the numerical view, select the parameter by expanding (i.e. double clicking) the desired color, 
and click on one of the parameters. You can modify the value either by moving the slider or by 
entering the desired value in the edit field. The affected handle will be indicated by changing to a 
brighter color. The transformation area and the output view show the new setting accordingly. 

In the transformation view, dragging any one of the curve handles can modify the transformation. 
To move the transformation curves with the appropriate handle the cursor symbol changes. The 
numerical area and the output view show the new setting accordingly. 
 

Steps and Lines 
The Steps and Lines transformations do not carry curve handles by default. However, you can 
place optional handles on the curves in the Transformation View by clicking with the left mouse 
button. To remove a handle click on it with the right mouse button. 
 

Reset  
Sets the actual transformation back to its initial state. 
 

Cancel  
Closes the dialog without modifying the image's palette. 
 

OK  
Closes the dialog, confirming the modifications to the image's palette. 
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Output Area 
The output area is organized in two sections: the output view and a set of buttons to modify the 
output view and, thus, the image's palette. 

Red, Green, and Blue display an image in the corresponding colors of the palette. Gray 
generates a gray scale representation of a color image while All displays an image in all of the 
three basic colors.  

The output axis of the transformation view reflects a modification to these settings. Selecting Red, 
Green, Blue, or Gray can also change the numerical view and the transformation view.  
 
With Move set to on, the output view will be synchronized with the movements of the input view 
sliders. 
 

Input Area 
The input view shows the whole image by default. The view can be modified using the standard 
zoom and pan functionality.  
 
The output view changes according to the modifications of the input view.  
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Palette Transformation Table   
 

Transformation Effect Value, Handle 

Automatic Brightness/ 
Contrast 

The palette is stretched to fit the whole 
dynamic range without loss of 
information. 

- 

Brightness/Contrast The brightness and contrast of the image 
can be adjusted. 

Brightness(X),  
Brightness(Y),  

Contrast,  

Automatic Smooth The palette is modified so that in the 
Output every palette entry has the same 
frequency. 

- 

Smooth The palette is modified so that in the 
Output each palette entry has the same 
frequency. The scale factor modifies the 
transformation. 

Scale factor,- 

Gamma Correction Black and white remain unchanged while 
the intermediate palette values are 
modified: 
Gamma<1: stretching of lighter values, 
compression of darker values. 
Gamma >1: stretching of darker values,  
compression of lighter values.  

Gamma,  

S-Gamma Correction Black, white, and the Turnpoint remain 
unchanged while intermediate palette 
values will be modified. 
Gamma<1: stretching of lighter and 
darker values, compression of values 
within the Turnpoint range 
Gamma>1: compression of lighter and 
darker values; stretching of values within 
the Turnpoint range. 

Gamma,  
Turnpoint,  

Steps A range of Input values is transformed to 
one Output value. 

Handle X,  
Handle Y,  

Lines Multiple effects depending on individual 
value settings (handles). 

Handle X,  
Handle Y,  
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Color Filter Operations    
 

 Toolbar: Color Tools 
 

Menu: Raster ► Filter ► Color Filter Operations 
 

CMD: VPFILTER ► DIALOG 

With these filter functions, you can improve the quality of your color or gray scale images. For 
quality reasons use filters only on full color or at least 256 gray scale raster files.  
 
Click this icon to start filter operations on the active image. The following dialog opens: 
 

 
 
Select the desired filter and the results are displayed in the output section. With respect to the 
selected filter the following options apply. 
 

Size 
Select the desired filter size. The size value indicates the border length of a square (matrix). The 
filter calculation will be based on the pixels within the range of this square. 
 

Original                Median Size 3     Average Size 3 
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Weight 
Weight controls the filtering result being multiplied with the entered value, thus stretching or 
compressing the generated result (contrast). 

Default: 1.0000 
 

Same Average {on/off} 
This check box provides for a selection whether the filter's coefficient should be weighted in a way 
that the average value in the original remains unaffected. This option has no meaning for filters 
bearing a coefficient sum of 0. For this kind of filters the image's dynamic range will be shifted to 
enable the display of possibly generated negative values. 

Default: off 
 

Offset 
Offset moves the filtering result to brighter values with a positive offset and to darker values with 
a negative offset (brightness). 

Default: 0 
 

Create Different Image {on/off} 
If checked on the color differential between the original and the filtered image will be created and 
displayed. 

Default: off 
 

Apply 
If the results in the output section are satisfying, click on Apply to execute the filter on the active 
image. The filter dialog disappears. 
 

Change Image Palette 
If the active image is based on a palette (i.e. it is not a true color image) you can create a New 
Palette or convert the file to True Color. 
 
 

Fast Median and Fast Blur (Average)  
 
These filters are used to decrease noise in an image. However, border transitions will be diffused. 
The Median filter is slower than the Average option, but it has a lower blur effect on color 
transitions. Neither will affect the color palette. 
 
All other blur filter have a fixed size setting, ready for use. The size setting is indicated but cannot 
be changed. 

 
 

Edge Detection (Sharpen) Filter   
 
Select from the listed filters. There are mainly two well known basic filter groups available: Kirsch 
and Laplace. The filter matrices can be viewed in the Filter Matrix dialog box (click on Edit after 
you have selected a filter).  
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Effect 
 
Select from the listed filters. 
 
 

Custom  
 
Design your own filter matrix. The application of filters in image processing is a very complex 
subject that cannot be described in detail in this manual. Only those with color processing 
experience should work on the items in this section, since unpredictable and unwanted image 
manipulations are likely to occur otherwise!  
 

New 
The Filter Matrix dialog opens:  
 

 
 
Enter a name and select the desired values for your filter. 
 
This dialog allows for defining several filter options. With three, five, and seven you can switch 
between the available filter sizes. If a matrix size applies to a filter it will be listed. Otherwise the 
filter will not be listed and the matrix elements receive a 0 as default value. 

Rotate - 90°  rotates the displayed filter a quarter-turn clockwise. 
Rotate +90°  rotates the displayed filter a quarter-turn counter clockwise. 
Rotate - 45°  rotates the displayed filter an eighth-turn clockwise. 
Rotate +45°  rotates the displayed filter an eighth-turn counter clockwise. 

 
Edit 

Allows reviewing and/or modifying any available filter matrix. If you modify a listed filter you will be 
asked if you want to overwrite the existing definition. You may also assign the new filter to another 
section or even create a new filter section. 
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Delete 
Deletes a selected filter. 
 
 

Custom Filter Table   
 

Filter Type Name Size  Direction 
  3 5 7  

Blur Filters Blur 
Gaussian 
Crosshatch 

 
 
 

 
 
 

 
 
 

0 
0 

 
Edge Detection Filters Horizontal 

Vertical 
 
 

   
 

 kirsch_e 
kirsch_n 
kirsch_ne 
kirsch_nw 
kirsch_s 
kirsch_se 
kirsch_sw 
kirsch_w 

 
 
 
 
 
 
 
 

   
 
 
 
 
 
 
 

 l2rdiagonal     

 laplace1 
laplace2 
laplace3 
sharpen 
speckle 

 
 
 
 
 

 
 
 
 

  
 
 
 
 

 sobel_horiz. 
sobel_vert. 

 
 

   
 

Effect Filters north 
south 
west 
east 

 
 
 
 

   
 
 
 

 3d 
deeppress 
jigglevert 
woodcut 
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Fill Function    
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Fill 
 

CMD: VPFILL 

This function operates only on paletted or b/w images. 
 
Click this icon. The cursor changes to a fill cursor. Click into the desired area of your active raster 
image. 
 

Default Filling 
As a default the system generates from the pattern around the clicking position the mean value of 
the found colors and fills the area with the closest color from the palette. With the option Fill 
Exact only a coherent area will be filled which carries the same color value as the pixel clicked.  
 

Filling Options 
Clicking the right mouse button allows to select different filling modes from the context menu: 

Paletted Images 
• Use Mean Color of Region (default) 
• Use Active Color of Image (defined in dialog Image Settings) 
• Use Background Color of Image (defined in dialog Image Settings) 
• Use Active Color 
• Fill Exact 

B/W Images 
• Fill with Raster 
• Erase Raster 

 
Clicking repeatedly into the same region at slightly different positions generates best filling 
results, even though the color pattern may vary. 
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Color Image Conversion    
 

Convert Image Palette/Type 
 

 Toolbar: Color Tools 
 

Menu: Raster ► Color ► Convert Image Palette/Type 
 

CMD: VPCONVERTPAL ► DIALOG 
 

CMD: VPCONVERTPAL /cv <value> [/rm <value>] [/c <value>] [/lp <value>] [/sp <value>]  
   [/gray <value>] [/bw <value>] 

This conversion function lets you easily convert an image with regards to the contained 
colors/gray scales. A dialog opens for specification of the conversion process: 
 

 
 

Convert to True Color [/cv 0] 
Select this option to convert the image into a full color file (RGB). 
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Convert to Palette [/cv 1] 
Select this option to convert the image into an indexed file with a maximum of 256 colors. 
 
Color Reduction [/rm < method>] [/c <number of colors>]: Select an automatic color 
reduction method and the number of colors you wish to reduce to. 
 
Load Palette/Reduction [/lp <palette>]: Choose a system palette or load your previously saved 
palette or color reduction file (*.RPL). The current image palette will be reduced and mapped to 
the selected one. 
 

Set Palette [/sp <palette>] 
This option is only available for indexed images. The current image palette will be replaced by a 
system palette or a loaded palette. The colors are not mapped to the selected palette. 
 

Convert to Grayscale [/gray <Channels>] 
Converts the image palette to grayscale. You can also choose the channel for conversion: 

• All Channel  <0> 
• Red Channel  <1> 
• Green Channel  <2> 
• Blue Channels  <3> 

 
Convert to B/W [/bw <threshold>] 

Binarizes the image. Select a threshold by moving the slider for setting up the separation between 
black and white. 

Default Threshold: 128 
 
 

Pan and Zoom 
Use the slider buttons to navigate inside the preview. There are several zoom options available.  

 Zoom All displays the entire image in the preview. This will be the active view after opening the 
dialog. 

 Zoom Window switches the cursor to a crosshair in the preview to select an image area for a 
zoom command. 

 Zoom 1:1 switches the cursor to a magnifier glass in the Preview. Click the desired center of the 
view with the left mouse button for zooming in. 

  Zoom in, Zoom out. 
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Color Classification    
 

General 
 
The classification of colors is an alternative method to reduce the number of colors (i.e. the 
amount of data) in an image – especially of color patterns. The process as featured in  
VP software and described in this chapter is a combination of user interaction and automatic 
routines. 
 
The principal concept of color classification is based on combining color patterns scattered over 
an image into a single color automatically. This is based upon probes taken from the image and 
then extracting the color pattern information into  "class" information. 
 
Imagine a scanned map having many shades of blue colors that represent water areas. In order 
to reduce the number of these different blue tone patterns, they will be gathered, then "classified" 
automatically and assigned as a single class with the color BLUE. At the end, this color will be 
given a title "nickname" to symbolize "water areas" in the map. Hence, now the color graphic 
information has been simplified, such as "blue" for water, "brown" for land, "green" for vegetation, 
"red" for streets, "black" for text, and so on.  
 
To attain a proper automatic classification, you need to initially set the program to the colors you 
want to assign as these color group classes. This is done by assigning color probes from 
representative areas in the image. The program will then process and generalize this information 
to be used for the entire image. The operational steps are described as follows. 
 
 

Color Classification 
 

 Toolbar: Classification 
 

Menu: Raster ► Color ► Color Classification 
 

CMD: VPCLASSIFY ► Dialog 
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Load a color or grayscale image and start this function. The Classification dialog appears:  
 

 
 
There are 16 classes available. Each name and color of a class can be modified with Modify 
Class. The color of a class (target color) can be specified independent from the actual color to be 
classified. 
 
These steps are required to run a classification process  

• Pick Probes: Link classes with areas of similar colors/color patterns in the image. 
Not all classes need to be applied. 

• Process Probes and Test Classification: Test whether the selected probes cover 
all actual color areas in the image appropriately. Improve on results by adding or 
removing probes.  

• Run Classification: The image will be converted according to selected probes and 
specified classes 

 
 

Pick Probe 

  Click on a list item in Classes to activate a class. Depending on the active Pick Probe 
option the cursor will appear as a bucket symbol (Area) or as a pipette symbol (Line/Text). 
 
Select probes for the active class by clicking on different color areas in the image or use window 
rectangle selection. Matching areas in the image will then be displayed in the active class color. If 
the picked probe is not appropriate for a specific class click the right mouse button to discard it or 
click on the button: Remove Probe 

 If you take more probes for a particular class, the classification quality can improve. This is 
especially important if color patterns vary in different areas. It is recommended that you do 
not reduce colors until you have completed classification of colors. This may improve on the 
color classification process. 
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Save Probes 
Selected probes will be saved. You also can use these probes for other, structurally similar 
images.  
 

Load Probes 
Loads saved probes. Corresponding image areas will not be displayed. 
 
 

Process Probes, Test Classification 
 
Click on Process probes to generate a new classification according to the probes. 
 
A hit rate will be calculated for each probe (in percentage). High percentages indicate that similar 
color areas may be classified in the image just as well. Low percentages indicate that probes do 
not cover color areas in the image appropriately. Probes with lower hit rates have a negative 
effect on the overall classification process. Thus, they should be removed and replaced by new 
probes taken from the image. 
 
For each class and its probes, the minimum hit rate will be displayed in a list field (Min.Hit Rate). 
Check all classes and delete probes (Remove Probes) with low hit rates (<10-20%).  Consider to 
pick and add new probes for better results. 
 
The classification must be re-calculated (Process Probes) if probes have been added or 
removed. 
 
Check the current classification setup by clicking on Test Classification. Now you can select a 
sample image area to test your classification setup. According to your results you can modify your 
setup for individual classes (delete and add probes). You can test several different sample image 
areas. 
 
Click Save Classification to keep your results. You can now use this classification setup for 
other, structurally similar images (Load Classification). 
 

Test Areas 
Results of image test areas can be made visible/invisible (Show on/off) or deleted (Clear). 
 
 

Run Classification 
 
Click OK to run the Classification on the entire image. The dialog closes and the function is 
finalized. Cancel leaves the dialog without prompting to save a classification setup. 
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SECTION 8   
CAD TOOLS   

 

General Information   
 
VP software offers a wide range of CAD drawing functions. Each of them is supported by a set of 
Drawing Aids (see section 3) e.g. snapping, grid etc. All coordinates/values can  also be 
entered via Command Line (see Section 3). Coordinate values can be entered absolute as x,y , 
relative as @x,@y; or relative as length and angle as d<phi. You can also mix absolute and 
relative values (e.g. @x,y or x,@y). 
 
The last used coordinate/value is offered in the command line as <x,y> and can be taken over as 
is with [Return], or for editing with [Tab]. 
 
 

Raster Settings    
 
All drawing functions can by executed in respect to the raster below (if any). This can be an 
immediate rasterization of the CAD entity, or a smart erase of the underlying raster pixel 
structure. 
 
The following functions allow for defining several drawing features. The functions are valid for any 
kind of raster image (b/w, gray scale, color). 
 
 

Active Image only {on/off}  
 

 Toolbar: Direct Raster Edit 
 

Menu: Edit ► Work only on Active Image 
 

CMD: VPSIMAGE  
 
When switched on the subsequent raster edit operations will only be executed on the Active 
Image. 
 

Dynamic Width {on/off}   
 

 Toolbar: Direct Raster Edit 
 

Menu: Edit ► Edit Raster ► Dynamic Width 
 

CMD: VPDYNWIDTH  
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This function is only available if the active layer is set to a Line Width (Display) "By Entity". 
Setting Dynamic Width to on allows for automatically assigning the line width of the underlying 
raster entity where the draw command starts. This assigned line width remains fixed until a new 
width is detected. The detected line width is indicated in the line width field. 

 
Due to the possible roughness of raster entities the Dynamic Width derived from an entity may 
differ by 1-2 pixels. 
 
 

Erase Raster Background {on/off} 
 

 Toolbar: Direct Raster Edit 
 

Menu: Edit ►Edit Raster ► Erase Raster Background 
 

CMD: VPERASERASTER 

When drawing Erase Raster [Ctrl-E] can be used to erase the raster original in the background 
simultaneously.  
 
In case entities are already selected when the function is started their structure will be erased 
from the underlying raster. The functions keeps its previous state (on or off). 
 
This function can be only activated (set to on) if a raster image is available in the document.  
 
With color or gray scale images the background will not be erased. Instead, the background 
pixels to be erased will be filled with the Background Color defined in Image Settings. 
 
 

Rasterize Online {on/off}  
 

 Toolbar: Direct Raster Edit 
 

Menu: Edit ►Edit Raster ► Rasterize Online 
 

CMD: VPRASTERIZEONLINE 

This function can be only activated (set to on) if a raster image is available in the document. 
Then, drawn entities are rasterized immediately into the underlying raster using the assigned 
width. If the active layer has been assigned the "Rasterize" width setting "By Entity", the line 
width of the raster entity can be defined (functions Line Width, Dynamic Width) and is used for 
the rasterization. Otherwise the "Rasterize" width of the layer will be used. 

The original drawn vector entity will be deleted. 

With color or gray scale images the entities are rasterized in the color they have, or in the closest 
color available from the color palette. 
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Erase Online {on/off}  
 

 Toolbar: Direct Raster Edit 
 

Menu: Edit ►Edit Raster ► Erase Online 
 

CMD: VPERASEONLINE 

This function can only be activated (set to on) if a raster image is available in the document. 
Then, drawn entities are rasterized immediately similar to the function Rasterize Online. 
However, the rasterize entities will be erased from the underlying raster. 
 
The original drawn vector entity will be deleted. 
 
With color or gray scale images the "erase" entities are rasterized into the image with the 
background color defined in Image Settings. 
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CAD Options   
 
Defines the default behavior of some/all CAD Tools 
 

 Toolbar: Draw 
 

Menu: Options ► CAD Options  
 

CMD: VPDRAWOPTIONS ► Dialog 

A dialog box opens for selection and value input. The settings apply to all drawing functions. 
 

General Tab 
 

 
 

Show Grips {on/off} 
If set to on the grips of all entities are displayed while drawing. This provides help for designing 
new entities by snapping to existing start, end, and center points. 
 

Zoom-in on First Click {on/off} 
If set to on the program zooms in on the first mouse click of a set point while in drawing mode for 
a more precise positioning (with the second mouse click).  
 
Zoom Factor specifies the factor of zooming in from the current zoom state.  

Default: off 
Default Zoom Factor: 1 : 4 
 

Highlight Entities 
Applies to all functions with preview. Select the color in which highlighted entities are drawn. 

Default: Color 211 
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Special Tab (only Windows) 
 

 
 
 

Arrowhead  
The length of a Pointer Arrowhead (Leader) and a Dimension Arrowhead can be defined. 
Values can be entered according to the selected drawing unit. The values only affect new entities. 

Defaults: 3.0 [mm] or 0.1 [inch] 
 

Set to Nearest End Point {on/off} 
If set to on the Pointing Arrowhead (Leader) will be positioned at the nearest end of a selected 
line automatically (one click). Otherwise you have also to define the direction of the pointing 
arrowhead (two clicks). 

Default: off 
 

Text 
Defines the procedure for creating text entities: 

Place Text then Enter String First the insertion point and rotation is specified, then the text is 
entered. 

Enter String then Place Text First enter the text, then specify the insertion point and rotation.  

Default: Place Text then Enter String 
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Polygon Tab (only Windows) 
 

 
 

Defines the settings to generate filled polygons. 
 

Specify on Draw 
While drawing a polygon a dialog will pop up to specify the fill pattern individually for each polygon 
to draw. 
 

Fixed 
All polygons will be created with the respective specified pattern. 
 

Hatch Style 
Select the fill pattern from a list of hatch styles. 
The fields Opacity, Scale, Angle, and Spacing are available for editing depending on the 
selected style. There are three predefined Hatch Styles: 
SOLID the edit field Opacity is available for entering a value from 0-100% 
LINES the edit fields Angle and Spacing are available for specifying a line based fill 

pattern. 
CROSSHATCH the edit fields Angle and Spacing are available for specifying a crosshatched 

fill pattern. 
 

For all other Hatch Styles the edit fields Angle and Scale are available to rotate or 
stretch/squeeze the fill pattern. 
Default: SOLID 
Opacity: 50% 
Scale: 1.0 
Angle: 45° 
Spacing: 1 
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Draw Border 
When on the border lines of the polygon are displayed. The elements line width is used. 
Default: on 
 

Border Color {on/off} 
If on the borderlines of the polygon will be displayed in the selected color. Otherwise the element 
color is used. 

Default: off 
Default: By Layer 
 
 

Polyline Tab (only Windows) 
 

 
 

As Multiline {on/off} 
If set on a number of single 2-point lines will be generated instead of a polyline. Each line can be 
assigned to a different layer, color, or linetype while in drawing mode.  

Default: off 
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Create Block from Polyline {on/off} 
A block is created after drawing a polyline (or MPolyline or Rectangle). The block consists of the 
element and the attributes of a specified Prototype Block (the geometry of the latter will be 
ignored). A dialog appears to enter attribute details: 
 

 
Example: Prototype Block Area 

 
The Prototype Block AREA will be offered as default. The block contains Parcel Number, Area 
(default value @area) and Circumference (default value @circumference). Default values will be 
filled automatically. 
 
For more default value options with attributes see below: Create Block ► Attributes ► Attribute 
Definition Properties. 

Default: off 
Default Block Prototype: AREA 
 

Allow Line Picking {on/off} 
When activated existing lines or polylines can be picked, so that they also become part of a new 
polyline. Thus, these vertices will be doubled, belonging to the existing lines and to the new 
polyline.  

Default: off 
 

Insert Vertex in Underlying Line/Polyline {on/off} 
If you draw a polyline and set a vertex on a underlying line or polyline, then this underlying entity 
will be edited automatically. It will receive an additional vertex at the same position as the new 
polyline. A line will be modified to a polyline.  
 
In case the new polyline only crosses without setting a vertex then the underlying line/polyline will 
not be modified. 

Default: off 

 You can use only one of the two above options at a time! 
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Fixed Distance between two Vertices {on/off} 
When on the next vertex can only be placed in a defined Distance from the previous one. This 
way you can digitize an underlying raster polyline with a predefined accuracy. 

Default: off 
Distance: 3.0 [mm] or 0.1 [inch]  
 
 

MPolyline Tab (only Windows)   
 

 
 

Distance 
Define the Distance between the two borderlines of the MPolyline. 

Default: 3.0 [mm] or 0.1 [inch] 
 

Draw Center Line {on/off} 
When on the Center Line of the MPolyline is also drawn. Also, a special Linetype for the Center 
Line can be specified.. 

Default: off 
Linetype: By Layer 
 

Filled {on/off} 
When on the area between the two borderlines of the MPolyline will be drawn in the specified 
Color and Opacity. 

Default: off 
Color: By Layer 
Opacity: 100% 
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Draw Line Caps {on/off} 
When on flat Caps will close an MPolyline at start and end points. 

Default: off 
 

Draw Upper Line {on/off} 
When off the upper border line of the MPolyline will not be drawn. 

Default: on  
 

Draw Lower Line {on/off} 
When off the lower border line of the MPolyline will not be drawn. 

Default: on 

 The terms Upper Line and Lower Line are defined when drawing a line from left to right. 
 
 

Group Tab (only Windows)   
 

 
 
 

Show grips of each entity {on/off} 
When switched on and a group is selected, the group’s move grip and all grips of all group 
entities are displayed. Single entities can now be moved, rotated, and scaled in size. When 
switched off only the group’s move grip is available. 

Default: on 
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Creation: Properties of selected entities 
There are two options when creating a group (see: Edit ► Group Entities): 

• Assign current styles 
• Keep styles of each entity 

 
With Assign current styles all entities of a group will receive the current settings for active layer, 
active linetype, active color, and active line width. Otherwise, the original settings will remain. 
 

Stamp Tab  
 

 
 
Defines settings for the Stamp function.  

 To use the Stamp function blocks/block definitions are needed. Block definitions containing 
attributes can be filled with values automatically or manually depending on the name or the 
default value. See below in this section for more information on Creating/Modifying Block 
definitions. 

 
Stamp File 

The path and name of a file which is to be used as a stamp pattern. A sample file is provided in 
the VP support folder (StampSample.rvd). 
 
The following settings are only relevant for stamp files containing block definitions with attributes:  
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Values from an INI file 
Path and name of an INI file containing default values for a stamp block. 

Different values for each drawing is turner off: The INI file contains one section [Stamp], 
followed by pairs of attribute name from the stamp block and its value in parenthesis.  
Sample: [Stamp] 
 Attribute1="Value 1" 
 Attribute2="Value 2" 
A sample file can be found in the support directory from VP (StampSample.ini). 
 
Different values for each drawing is tuner on: The INI file contains one section per file. The 
association is done through the section name (e.g. [Mech.tif]) followed by pairs of attribute name 
from the stamp block and its value in parenthesis.  
Sample: [File1.tif] 
 Attribute1="Wert 1" 
 Attribute2="Wert 2" 
 [File2.tif] 
 Attribute1="Wert 3" 
 Attribute2="Wert 4" 

Default: Values from an INI file  on 
 Different values for each drawing off 
 

Add Values Automatically 
When on and depending on their Default value specific attributes of the stamp block will be 
assigned automatically.  

Default value of attribute Result 
@UserName Name of the registered user 
@Date Current date 

For more default value options with attributes see below: Create Block ► Attributes ► Attribute 
Definition Properties 
Default: off 
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Check/Edit Values 
When on the stamp block’s attributes will be displayed in a dialog prior to the actual stamping. 
Also, at this stage attributes can be edited manually: 
 

 
Default: off 
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Draw Functions    
 

 Drawing always occurs in the active layer, with the active line type and the active color. If 
the active line width and/or the color are set to "By Layer" the assignments of the active 
layer are used. Otherwise, the selected settings are displayed in the corresponding fields. 
(see Section 4). 

 With VP software as an CAD application most of the CAD draw functions are used instead. 
Please refer to the CAD handling and manual; it may differ from the description below.  

 
 

Orthogonal Drawing 
 
Activating the Ortho Snap or pressing the [Shift] key while executing a drawing command 
constrains the drawing direction to n x 45° of the coordinate system. Also, when Drawing 
Polylines additional segments will be drawn with orthogonal orientation in relation to the first line 
segment. The latter may be drawn without an orthogonal orientation. For example: draw a 
rectangle at any angle (Closed Polyline) and do not use the Ortho Snap in the first place. 
Instead, press the [Shift] key after drawing the first line. 
 
 

Pixel (only Windows)  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Pixel 
 

CMD: VPDRAWPIX ► Toolbar 

For freehand drawing or freehand erasing in a raster image.  
 

  
 

 Drawing Color: The color used for drawing (only for grey level or color images). The Color 
Manager opens on click. 

 Pick Color: Provides a direct selection of a drawing color with a click  in an image (only for 
grey level or color images).  

 Pixel Size: Drawing width in pixel. 

 Dynamic Width: When active a drawing width will be assigned directly according to the 
raster structure (e.g. a line) picked in an image (only for b/w images). 

 Draw Pixel: Drawing with the selected Drawing Color (grey level or color images) or in the 
raster color (b/w images). 
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 Draw Pixel (Foreground Color): Drawing with the defined foreground color in Image 
Settings (see Section 4) (grey level or color images) or in the raster color (b/w images). 

 Erase Pixel: Erasing pixel with the defined foreground color in Image Settings (see Section 
4) (grey level or color images) or in the raster color (b/w images). 

 

The [Tab] key allows for a fast switch between Draw and Erase functions. You can increase or 
decrease the pen width with [>] and [<] keys. 
 
 

Line  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Line ► Line 
 

CMD: VPDRAWLINE <X1>, <Y1>, <X2|@X2>, <Y2|@Y2|°Y2> 
 

CAD: _line 

Draws a 2-point line.  
 

In the command line enter 4 coordinates or 2 coordinates (start point), and a relative coordinate 
(@X2, @Y2), or length (@X2) and angle (°Y2 or <Y2). 
 
 

Polyline  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Line ► Polyline 
 

CMD: VPDRAWPOLY <X1>, <Y1>, <X2>, <Y2> [Xn, Yn, ......]  
 

CAD: _pline 

Draws a polyline with any number of vertices. Complete the polyline by double-clicking the left 
mouse button or press [Enter]. Close an open polyline by selecting the appropriate function from 
the context menu. 
 

In the command line enter the coordinates of all vertices. 
 

mailto:X2|@X2
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Closed Polyline  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Line ► Closed Polyline 
 

CMD: VPDRAWCPOLY <X1>, <Y1>, <X2>, <Y2> [<Xn>, <Yn>, ......]  
 

CAD: _pline  _c 

Draws a closed polyline with any number of vertices. Complete the polyline by double-clicking the 
left mouse button or pressing [Enter]. 
Press and hold the [Shift] key to draw orthogonal vertices to a previous vertex in any 
orientation. 
Press and hold the [Shift] and the [Ctrl] key after setting the first vertex to draw a 2-point 
orthogonal rectangle or, pressing and holding the [Shift] and the [Ctrl] key after setting the 
second vertex to draw a rectangle with any base direction. 
 
 

MPolyline   
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Line ► MPolyline 
 

CMD: VPDRAWMPOLY <X1>, <Y1>, <X2>, <Y2> [Xn, Yn, ......]  
 

CAD: _mline 

Draws a multi polyline with any number of vertices. Complete a multi polyline by double-clicking 
the left mouse button or press [Enter]. Close an open multi polyline by selecting the appropriate 
function from the context menu. The appearance of the multi polyline depends on the actual 
settings in CAD Options ► MPolyline.  
At the command line enter the coordinates of all vertices. 
 

Options (Command line / Context menu) 
Distance 
Changes the distance of the two border lines. 
Options 
Opens the CAD Options dialog. See also CAD Options ► Tab MPolylinie 
Remove 
Removes the last vertex. At least 2 vertices are required. 
Close 
Creates a closed MPolyline by connecting the first vertex and the last vertex. The drawing 
process terminates thereafter. At least 3 vertices are required. 
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Rectangle   
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Rectangle 
 

CMD: VPDRAWPOLYRECT <X1>, <Y1>,  <X2|@X2>, <Y2|@Y2> 
 

CAD: _rectang 

Drawing a rectangle. 
In the command line enter 4 coordinates, or 2 coordinates (first corner) and width, height (@X2, 
@Y2). 
 
 

Spline   
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Spline 
 

CMD: VPDRAWSPLINE <X1>, <Y1>, <X2>, <Y2> [<Xn>, <Yn>, ......]  
 

CAD: _spline 

Draws a B-Spline through the click points. Complete the Spline by double-clicking the left mouse 
button or pressing [Enter]. 
 
 

Arc (3-point)  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Arc ► 3 Points 
 

CMD: VPDRAWARC3POINT <X1>, <Y1>, <X2|@X2>, <Y2|°Y2>, <X3|@X3>, <Y3|°Y3> 
 

CAD: _arc 

Draws an arc through three points:  
1st click point = start point arc 
2nd click point = end point arc 
3rd click point = arc curvature and direction 

In the command line enter 6 coordinates or 2 coordinates (start point), and twice the distance 
(@X2), and angle (°Y2 or <Y2) of the second and third point from the previous point. 

mailto:X2|@X2
mailto:X2|@X2
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Arc (4-point) 
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Arc ► Center, Radius, Angles 
 

CMD: VPDRAWARCCENTRAD <X>, <Y>, <R>, <Phi1>, <Phi2> 
 

CAD: _arc 

Draws counterclockwise an arc with a defined radius and length 
1st click point = center 
2nd click point = radius 
3rd click point = start point arc 
4th click point = end point arc 

In the command line enter the coordinates of the start point, the radius, and the angles to the start 
and to the end point. 
 
 

Arc (with tangential connections, only Windows) 
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Arc ► Tangent, Center 
 

CMD: VPDRAWARCTANGCENT <X1>, <Y1>, <X2|@X2>, <Y2|°Y2>, <X3|@X3>, <Y3|°Y3> 

Draws an arc with tangential connections to 2 selected line ends. After selecting the two lines, 
radius, position and, if desired, lengthening or shortening of the lines, a third mouse click will 
complete the arc element. Pressing the [Shift] key creates orthogonal connections. 

 
 

Circle (Radius)  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Circle ► Center, Radius 
 

CMD: VPDRAWCIRCLECENTRAD <X>, <Y>, <R> 
 

CAD: _circle 

Draws a circle with center point (first click) and radius (second click). 

mailto:X2|@X2
mailto:X2|@X2
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Circle (2-point) 
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Circle ► 2 Points 
 

CMD: VPDRAWCIRCLE2POINT <X1>, <Y1>, <X2|@X2>, <Y2|°Y2> 
 

CAD: _circle  _2p 

Draws a circle through two points (= diameter). 
 
 

Circle (3-point) 
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Circle ► 3 Points 
 

CMD: VPDRAWCIRCLE3POINT <X1>, <Y1>, <X2|@X2>, <Y2|°Y2>, <X3|@X3>, <Y3|°Y3> 
 

CAD: _circle  _3p 

Draws a circle through three points. 

 

 
Circle (Tangent-Tangent-Radius) 

 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Circle ► 2 Tangents + Radius 
 

CMD: VPDRAWCIRCLETTR 

CAD: _circle  _ttr 

Draw a circle by selecting two lines/polylines, arcs, or circles and specifying a radius. There might 
be multiple solutions. The solution with the tangent points nearest to the click points will be 
inserted. 
 

mailto:X2|@X2
mailto:X2|@X2
mailto:X2|@X2
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Circle (Tangent-Tangent-Tangent) 
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Circle ► 3 Tangents 
 

CMD: VPDRAWCIRCLETTT 
 

CAD: _circle  _ttt 

Draw a circle by selecting three lines/polylines, arcs, or circles. There might be multiple solutions. 
The solution with the tangent points nearest to the click points will be inserted. 
 
 

Ellipse  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Ellipse 
 

CMD: VPDRAWELLIPSE <X1>, <Y1>, <a>, <b>, <Phi>, <Phi1>, <Phi2> 
 

CAD: _ellipse 

Draws an ellipse with the origin (first click), the semi major axis (second click) and the semi minor 
axis (third click). 
 
In the command line enter the center coordinates, the length of the "a" and the "b" axis, the angle 
<Phi> of the "a" axis, and the start and end angle of the ellipse. A full ellipse is drawn if Phi1 = 0 
and Phi = 360. 
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Filled Rectangle (WINDOWS only)  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Filled Rectangle 
 

CMD: VPDRAWRECTANGLE <X1>, <Y1>, <X2|@X2>, <Y2|°Y2> 

Draws a filled rectangle. If Polygon Tab Specify on Draw is selected in CAD Options, a dialog 
pops up by starting the command which allows to set the fill pattern for each rectangle 
individually. 

 
 

Opacity 
Indicates the opacity/transparency factor for the Hatch style SOLID. A 100% value indicates full 
opacity without any transparency.  

Default: 50% 
 

Angle, Scale, Spacing 
A selected Hatch Style will be displayed according to these settings. 
 

Alignment 
A selected Hatch Style will be aligned in parallel or vertical according to the 
rectangle’s/polygon’s longest side line. 

Default: Do not align 
 

Draw Border 
If on the borderlines of the polygon will be displayed. The elements line width will be used.  

Default: on 
 

Border Color 
If on the borderlines will be displayed in the selected color. Otherwise the elements color will be 
used. 

Default: off 
Default: By Layer 

mailto:X2|@X2
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Polygon (only Windows)  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Polygon 
 

CMD: VPDRAWPOLYGON <X1>, <Y1>, <X2>, <Y2> [Xn, Yn, ......]  

Draw a filled polygonal area with any number of vertices. If Polygon Tab Specify on Draw is 
selected in CAD Options, a dialog pops up by starting the command which allows to set the fill 
pattern for each polygon individually (see above).  
 

Complete the polygon by double-clicking the left mouse button or press [Enter]. 
 
Press and hold the [Shift] key to draw orthogonal vertices to a previous vertex in any 
orientation. 
 
Press and hold the [Shift] and the [Ctrl] key after setting the first vertex to draw a filled 2-point 
orthogonal rectangle or, pressing and holding the [Shift] and the [Ctrl] key after setting the 
second vertex to draw a filled rectangle with any base direction. 
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Text  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Text ► Text 
 

CMD: VPDRAWTEXT <X1>, <Y1>, <Text>, [Height], [W2H], [Phi], [Align] 
 

CAD: _text 

Writes text in any orientation. After selecting this function, draw a line to determine the text start 
point (first click) and the direction. Use the [Shift] key for orthogonal placement. A dialog box 
appears for the text entry.  
 
If the option Enter String then Place Text is selected the Special Tab of CAD Options, the 
following dialog will pop up immediately to enter the text. Then, you need to place the text. 
 

 
Dialog in advanced display 

 
A new text can be entered or a previously entered text can be selected from the list. 

 Shortcuts 
A list of shortcuts for e.g. special characters like a diameter sign opens. It can also be used for 
frequently used expressions. See System Settings - Shortcuts. 
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  Apply Text Style settings to text box 
If on the text in the edit box will be displayed with the font and width-to-height settings of the 
selected text style (preview mode). Otherwise the system default font for edit boxes will be used.  

Default: on 
 

Text Style 
Select the appropriate text style. All text styles defined in the Text Manager for this document are 
available. 

Default: <active textstyle> 
 

Height 

The text height value. When the selected text style has a defined height unequal to 0.0 this height 
will be displayed. Otherwise, the last used value is displayed.  
 

Width 
The width-to-height ratio.  
 
Default: < from text style> 
 

Align 
Text orientation according to the text insertion point.  

Default: left 
 

Angle 
Text angle position. 
Default: entered angle (drawn by line) or last angle (fix angle) 
 

  Fix Angle {on/off} 
If on the next text will be drawn with the current angle. Only the insertion point has to be 
specified.  
 

Multiline {on/off} 
If set to on you can insert additional text lines with the specified spacing after the first text line has 
been entered and is displayed. Type the text string for each following line into the command line 
and confirm with [Enter]. End the text input function with [ESC]. 
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Erase Raster Background {on/off} 
If you want to replace text in an raster image you may need to erase the original raster text. In this 
case check this function on and select whether to use a rectangle or a polygon for erasing. 
After clicking OK in the dialog you need to define the erase area first. Then, the new text will 
appear. With color or gray scale images the background will not be erased. Instead, the 
background will be filled with the Background Color defined in Image Settings.  
In the command line enter values for start point and the text, and text height, width, angle, and 
alignment (optional). The erase background function is not available via command line. 
 
 

Multiline Text   
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Text ► Multiline Text 
 

CMD: VPDRAWMTEXT <X1>, <Y1>, <X1>, <Y1> ► Dialog 
 

CAD: _mtext 

Draw a rectangle to specify the text area. The dialog opens for entering and formatting the multi 
line text: 
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Text Fonts 
All available system fonts can be selected and assigned to the text string or to portions of it. 
 

Text Height 
Select the text and enter the desired text height via keyboard. 
 

Line Distance 
Defines the spacing between text lines with reference to the standard line distance. 
 

Position 
With reference to the specified text area (rectangle) you have multiple choices to position the 
multi line text. 
 

Bold, Italic, Underline 
These options allow for modifying the selected font. 
 

Import Text 
Allows to importing text from a file. 
 

No Wrap 
If on the entered text will not be wrapped according to the drawn rectangle (text area). Otherwise 
linefeeds will be added where possible (e.g. at spaces) to mach the text area as far as possible. 
 
 

Dimension Arrow (only Windows)     
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Pointing (Leader) ► Dimension 
 

CMD: VPDRAWARROWDIM  

Places a dimension arrow at the end of a dimension line (first selection), which intersects with or 
ends on an extension line (second selection). The arrowhead points to the second line. See CAD 
Options regarding arrowhead size. 
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Pointing Arrow (only Windows)  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Pointing (Leader) ► Pointing Leader 
 

CMD: VPDRAWARROWPOINT 

Places a pointing arrow on a line. The First mouse click selects the line where you want to place 
the arrowhead.  
 
If in your CAD Option the checkbox Set to Nearest End Point is on the arrowhead will be 
directly placed at one of the ends of the line. Otherwise the Second mouse click determines the 
position of the arrowhead. See CAD Option regarding arrowhead size. 
 
 

Point  
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Point 
 

CMD: VPDRAWDONUT <X>, <Y> 
 

 CAD: _point 

Places a point element at the selected position. Point styles and sizes can be defined in a dialog: 
 

 
 

Point Style 
Choose a point style family from the combo box. Available are the *Default style, which contains 
only a filled donut as point style, the *CAD style, which contains the AutoCAD typical point styles, 
and any True Type Font which is installed on the computer. Click one of the buttons below in the 
combo box to select the desired Point Style. The number of this Point Style is displayed 
beneath the Symb. Number. 
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Fonts... 
A dialog pops-up which allows you to pre-select these point style families, which should be 
offered in the combo box. 

Default: <all available fonts> 
 

Elevation: 
Specify the elevation (Z-Coordinate) for the point(s) to be inserted. 

Default:  0.0 
 

Size 
Specify the Size of the Point in base units. 

Default: 3.0 
 

Absolute {on/off} 
If set on the specified size is absolute, otherwise it is relative, which means the point is always 
displayed with the same size, regardless of the current zoom state. 
 

Snap to Line/Intersection {on/off} 
When on an automatic snap is active to lines and/or to line intersections which lay inside the 
cursor box of the click position while placing a point. 

Default: on 
 

Stamp    
 

 Toolbar: Draw 
 

Menu: Vector ► Draw ► Stamp 
 

CMD: VPSTAMP <X>, <Y>, [/XALIGN|XA <XALIGN>], [/YALIGN|YA <YALIGN>], [/INI|I <INI>],  
 [/FILE|D|F <FILE>], [/BLOCK|B <BLOCK>], [/REVIEW|P|R] 

Inserting a stamp into a document. If the stamp is defined as a block attributes can be assigned 
automatically or manually prior to the stamping process (e.g. user name, date, project name, 
etc.). The stamp will be rasterized immediately when any raster data is contained in the 
document. 

Any file format supported by VP software can be used as a stamp. For stamp blocks an INI file 
(text file) can be used which contains values for a block. Settings can be defined in CAD Options 
or via command line input. See also CAD Options - Stamp Tab above in this section. 
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Stamping may be set up via the command line as follows: 

X, Y Insertion point of stamp block 
Default: 0.0 / 0.0 

/xAlign|xa <xAlign> 

 

x-alignment of stamp block according to document. Values for 
<xAlign>:  
none:  absolute coordinates 
left:  left aligned 
right:  right aligned 
center:  centered vertically 
Default: none 

/yAlign|ya <yAlign> 

 

y-alignment of stamp block according to document. Values for 
<yAlign>: 
none:  absolute coordinates 
left:  left aligned 
right:  right aligned 
center:  centered vertically 
Default: none 

/Ini|i <Ini> File containing values for stamp. 
Default: see CAD Options 

/File|d|f <File> File containing stamp block. 
Default: see CAD Options 

/Block|b <Block> Name of stamp block. When the stamp file contains several blocks 
a specific stamp block can be selected with <Block>. 
Default: see CAD Options 

/Review|p|r Check values before insertion. 
Default: see CAD Options 



 VP Software Manual 

314   Section 8     CAD Tools Manual V16 - V9 / E 
 

  
 

Hatch (Fill)   
 

 Toolbar: Hatch 
 

Menu: Vector ► Hatch ► Hatch 
 

CMD: VPMAKEHATCH ► Dialog 
 

CAD: _bhatch 

After selecting this function, a dialog pops up to specify a hatch style and a creation mode. 
 

 
 

Hatch Style 
Select a fill pattern from the list of hatch styles. 
 
The fields Opacity, Scale, Angle, and Spacing are available for editing depending on the 
selected style. There are three predefined Hatch Styles: 
 
SOLID the edit field Opacity is available for entering a value from 0-100% 
LINES the edit fields Angle and Spacing are available to specify a line based fill 

pattern. 
CROSSHATCH the edit fields Angle and Spacing are available to specify a crosshatched fill 

pattern. 
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For all other Hatch Styles the edit fields Angle and Scale are available to rotate or to 
stretch/squeeze a fill pattern. 

Default: SOLID 
Opacity: 50% 
Scale: 1.0 
Angle: 45° 
Spacing: 1.0 
 

Creation Mode 
Select Border:  Select the bordering lines of the desired area in sequence. Pressing [Enter] or 

Create creates the hatch inside the borders according to the Hatch Style 
settings. Selected text strings inside the borders will be isolated from the hatch. 
 

A warning pops up in case  the hatch area is not completely enclosed by 
bordering lines  
 

Pick Area:  Pick into the desired area which is enclosed by existing vector entities. The 
hatch inside the borders will be created according to the Hatch Style settings. 
 

A warning pops up in case a completely enclosed hatch area cannot be 
computed from the pick point. 

 
Show/Hide Style List 

Switches the preview of the available Hatch Styles on/off. 
 
 

Edit Hatch (only Windows)  
 

 Toolbar: Hatch 
 

Menu: Vector ► Hatch ► Edit Hatch 
 

CMD: VPHATCHEDIT 
 
Select the hatch to edit its entities. Depending on the type of the selected hatch different edit 
modes are available.  
 
If the selected hatch was created by several lines with the Combine to Hatch function (see 
section 9) or it was created by an automatic Raster to Vector Conversion (see Section 13), the 
following toolbar appears 
 

 
 
and the selected hatch appears highlighted.  
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Select Add Lines, Remove Lines, or Edit Lines and select then the appropriate lines. Finish 
editing with End Edit or [Return]. Then select the next hatch to edit. Leave the command with 
[ESC]. 
 
If the selected hatch was created by the Hatch command or by the Draw Rectangle, Draw 
Polygon command the Hatch dialog appears (see before) to specify another hatch style / fill 
pattern. 
 

  
 

Hatch Style Manager (only Windows)   
 

 Toolbar: Hatch 
 

Menu: Vector ► Hatch ► Hatch Style  Manager 
 

CMD: VPHATCHSTYLEMANAGER 

A dialog pops up and displays a list off all available Hatch Styles. 
 

 
 

Load from File… 
Opens an File Open dialog to specify a *.PAT file. VP software supports the import of AutoCAD 
compatible hatch pattern files. 
 

Show/Hide Style List 
Switches the preview of the available Hatch Styles on/off. 
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Make Corner (only Windows)  
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Make Corner 
 

CMD: VPCORNER ► Select 2 Entities 

The end points of two selected entities (line, polylines, arcs) are lengthened or shortened to form 
a corner. Click-select each of the two entities close to the end to be modified.  
 
An error message appears when it is impossible to execute this function. 
 
 

Trim   
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Trim Elements 
 

CMD: VPTRIM ► Select Entities  

Trims entities to cutting edges.  
 
Select the cutting edges (lines, polylines, arcs, circles, and ellipses) and confirm the selection with 
[Enter]. The selected entities appear highlighted.  
 
Now, click an entity to trim at the next intersection with the edges. The click point defines the part 
of the entity to be removed. If this part lies between two cutting edges then this segment will be 
deleted and the entity will be transformed into two entities. 
 
Pressing [CTRL] while selecting an entity, having no intersections with the cutting edges, extends 
the edges to find additional intersections. 
 
Pressing [SHIFT] while selecting an entity, switches to the Extend mode and extends the entity 
to the next cutting edge instead of trimming it. 
 
End the function with [Enter] or select End Command from the context menu.  
 
An error message appears when it is impossible to execute this function. 
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Extent   
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Extent Elements 
 

CMD: VPEXTENT ► Select Entities 

Extends entities to boundary edges.  
 
Select the boundary edges (lines, polylines, arcs, circles, and ellipses) and confirm the selection 
with [Enter]. Now, click on an entity for extension to the next boundary edge. The click point 
defines the part of the entity to be extended.  
 
Pressing [CTRL] while selecting an entity having no intersections with the boundary edges, 
extends the edges to find additional intersections. 
 
Pressing [SHIFT] while selecting an entity, switches to the Trim mode and trims the entity to the 
next intersection with the cutting edges. 
 
End the function with [Enter] or select End Command from the context menu.  
 
An error message appears when it is impossible to execute this function. 
 
 

Auto Trim (only Windows)  
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Auto Trim 
 

CMD: VPAUTOTRIM ► Select Entities 

Adjusts entities to boundary/cutting edges.  
 
Select the boundary/cutting edges (lines, polylines, arcs, circles, and ellipses) and confirm the 
selection with [Enter]. Select one or more entities to adjust them to the boundary/cutting edges. If 
an entity can be trimmed as well as extended, the mode causing the smallest modification will 
automatically be used. 
 
Pressing [CTRL] while selecting an entity having no intersections with the boundary/cutting 
edges, extends the edges to find additional intersections. 
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End the function with [Enter] or select End Command from the context menu.  
 
An error message appears if it is not possible to execute this function. 
 
 

Chamfer   
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Chamfer 
 

CMD: VPCHAMFER ► Select Entities 

Bevels the edges of objects. All modes and settings can be changed either in the command line 
or in the context menu.  
 
Select either two entities (line, polyline) or one polyline. The (virtual) corner or the edges will be 
beveled. 

 This cursors shows, that the function cannot be performed (wrong selection, no corner, or no 
space for the chamfer). 
 

Valid Entities 
Raster and Vector data 
• Lines 
• Polylines 
 

Methods 
Lines and Polylines Mode: Both entities will be modified. A line will be shortened or extended to 

the intersection (if necessary). The same applies to the selected segment of a polyline. The 
rest of the polyline will be removed. At the intersection a new line according to the settings 
(distance or angle) will be inserted.  

If two lines are selected, the chamfer will be inserted as new entity. If at least one polyline is 
selected the entities, including the chamfer element, will be combined to one polyline. 

If a line or a segment of a polyline is to short to add a chamfer of the specified size, the 
function cannot be performed. 

 
Chamfer between polyline and line (the crosses mark the click points) 
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Entire Polyline Mode: The whole polyline will be transformed. At every vertex a new segment - 

according to the settings - will be inserted..  

If a segment is to short, its corners stay unchanged.. 

 
Chamfer at the vertices of a polyline (the cross marks the click points) 

Default: Lines and Polylines 
 

Chamfer methods 
Distance method: The two distances D1 and D2 define the size of the chamfer. Distance D1 is 

applied to the first element, distance d2 to the second. For Entire Polyline mode the values 
D1 and D2 are applied in the order of the vertices. 

 
The distances D1 and D2 define the chamfer  
(Cross 1 and 2 shows the order of selection) 

 
Angle method: A distance D and an angle α define the size of the chamfer. Both values are 

applied to the first select entity. For Entire Polyline mode the values are applied in the order 
of the vertices.. 

 
The chamfer is defined by the distance D and angle α   

(Cross 1 and 2 shows the order of selection) 
 

Default: Distance method 
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Prompts 
Select first entity or [Entire Polyline, Angle|Distance, Values]: The mode Lines and 

Polylines is active. Select the first entity by a click or change the mode with e. With a or d you 
can switch from distance mode to angle mode and vise versa. With v you can specify the 
values of active mode (D1 and D2, or D and α). 

 
Select Entity or [Lines and Polyline, Angle|Distance, Values]: The mode Entire Polyline is 

active. Select a polyline (function will be executed immediately) or switch back to Lines and 
Polyline mode with l. With a or d you can switch from distance mode to angle mode and vise 
versa. With v you can specify the values of active mode (D1 and D2, or D and α). 

. 
 
Select first entity or [Entire Polyline, Angle|Distance, Values]: The mode Lines and 

Polylines is active. Select the second entity to finish the command.  
 
Specify first distance <D1>, Specify second distance <D2>: Review or modify the values D1 

and D2. You can enter the values directly or measure them from the drawing.  

Default: 5 mm / 0,197 Inch 
 5 mm / 0,197 Inch 

 
Specify distance <D>, Specify angle <α>: Review or modify the values D and α. You can enter 

the values directly or measure them from the drawing.  

Default: 5 mm / 0,197 Inch 
 45° 

 
Show Preview [on/off] (context menu) 

If on, the result will be displayed on mouse move over an entity.  

Default: on 
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Fillet   
 

 Toolbar: Edit Vectors  
 

Menü: Vector ► Edit ► Fillet 
 

KMD: VPFILLET ► Select Entities 

Rounds and fillets the edges of objects. All modes and settings can be changed either in the 
command line or in the context menu.  
 
Select either two entities (line, polyline) or one polyline. The (virtual) corner or the edges will be 
rounded. If two parallel lines are selected, an arc will be inserted to connect them, independent 
from the fillet settings. 

 This cursors signals, that the function can not be performed (wrong selection or no space for the 
fillet). 
 

Valid Entities 
Raster and Vector data 
• Lines 
• Polylines 
 

Methods 
Lines und Polylines mode: Both entities will be modified. A line will be shortened or extended to 

the intersection (if necessary). The same applies to the selected segment of a polyline. The 
rest of the polyline will be removed. At the intersection a new arc according to the specified 
radius will be inserted.  

If two lines are selected, the fillet will be inserted as new entity. If at least one polyline is 
selected the entities, including the new arc element, will be combined to one polyline (with 
bulges). 

If a line or a segment of a polyline is to short to add a chamfer of the specified size, the 
function cannot be performed. 

 
Fillet between polyline und line (the crosses mark the click points) 
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Mode Entire Polyline: The whole polyline will be transformed. At every vertex a new bulge 

segment - according to the settings - will be inserted.  

If a segment is to short, its corners stay unchanged.. 

 
Rounding of Polyline (the cross marks the click point) 

Default: Lines und Polylines 
 

Radius 
The radius of the fillet. 

Default: 5 mm / 0,197 Inch 
 

Prompts 
Select first entity or [Entire Polyline, Radius]: The Mode Lines and Polylines is active. Select 

the first entity or switch the mode with e. Enter r to change the Radius. 
 
Select Entity or [Lines and Polylines, Radius]: The Mode Entire Polyline is active. Select a 

polyline to finish the command or to switch the mode with l. Enter r to change the Radius. 
 
Select second entity or [Entire Polyline, Radius The Mode Lines and Polylines is active. 

Select the second entity to finish the command or switch the mode with e. Enter r to change 
the Radius  

 
Specify Radius <Value>: Review or modify the value of the Radius You can enter the value 

directly or measure it from the drawing. 
 

Ignore parallel Lines [on/off] (context menu) 
If off, parallel Lines will be connect by an arc, independent from the current Radius setting.  

Default: off 
 

Show Preview [on/off] (context menu) 
If on, the result will be displayed on mouse move over an entity.  

Default: on 
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Cut (only Windows)   
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Cut Element 
 

CMD: VPCUT ► Select Entities 

Cuts an entity into two new entities.  
 
Select an entity (line, polyline, arc, circle). Specify the cutting point by clicking on the entity or by 
selecting a reference object. 
 
 

Break (only Windows)   
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Break Element 
 

CMD: VPOBREAK ► Select Entities 

Breaks an entity at two points and remove the section in between.  
 
Select an entity (line, polyline, arc, circle) by clicking it. This first click point also defines the first 
break point. Specify the next point to break the entity into two and erase the section in between. 



VP Software Manual  

Manual V16 - V9 / E Section 8     CAD Tools   325
 

Blocks (Windows only)     
 

General Information 
 
In the following sections, the distinction between a block definition and a block should be well 
understood: 

• A block definition defines the geometric structure of a block as well as the number and types 
of its attributes. A block definition is unique and part of the document, but it is not visible in the 
displayed drawing. 

• A block is a reference to a block definition (= the image of a block definition) at a given 
position. It can be rotated and scaled (isotropic and non-isotropic). Any number of blocks of a 
block definition can be inserted in a drawing. 

• Blocks can be composed of vectors and/or raster elements/objects. However, all elements 
(vectors and raster elements) of a block are referenced as vectors. If an inserted block is 
rasterized, all block elements will be rasterized. 

 
Selected elements can be combined to a block. Create a new block from previously selected 
elements by using the Combine to new Block command. In addition, you can import block 
definitions (Import - DXF/DWG) that have been created in a CAD system. These block definitions 
become part of the document and blocks can be placed at any location using Insert Block. If you 
plan to use the block definition(s) for other documents, we recommend to save the block 
definition(s) to the prototype drawing. This way, the block definition becomes available when 
you use the prototype drawing (Options ► System Settings ► Tab Files/Paths). 
 
For preparing a new prototype drawing containing block definitions loaded from external 
DWG/DXF files just import the file(s) and then save the new drawing in RVD format under a name 
of your choice. If this file is used as a prototype drawing, the block definitions become 
permanently available.  
 
To achieve the same effect with block definitions that are created from drawing elements via 
Create Block, delete all drawing elements (raster and vectors including all blocks) and then save 
the "empty drawing" as described above. If you want to add additional block definitions to an 
existing prototype drawing, start with the prototype drawing (click on New). Then, create or load 
blocks, erase them, and save the "empty drawing/document" as a new RVD file. 
 
Attributes can be assigned to a block definition. The procedure and functionality are similar to 
AutoCAD. Assignment of attributes is especially important for the Symbol Search function, since 
replacing the found symbols by a block allows for assigning symbol text strings to attributes. 
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Create Block 
 

 Toolbar: Block 
 

Menu: Vector ► Block ► Create Block 
 

CMD: VPMAKEBLOCK ► Select Entities ► Dialog 
 

CAD:  _block 

Creates a new block definition from the selected elements and inserts a block at the position of 
the selection. A dialog opens to specify the block definition: 
 

 
Dialog in advanced display 

 
 

Block definition Properties 
 

Name 
Name of a new block definition. A warning message appears if the name already exists or if the 
entry is left empty. 

Default: Block001  
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Base Point 
The insertion point of a new block definition. The default position is the geometric center of all 
selected elements. With Pick you can set the insertion point to a new position by clicking in the 
drawing. 
 

Change Color of Members to ByBlock 
If this parameter is enabled, all elements will be displayed in the color of the inserted block. If 
switched off  all members keep their own colors. 

Default: off  
 

Attributes 
Open/Close the dialog with an advanced display for editing attribute definitions (see below).  
 
 

Text / Attribute Definitions 
 
Attribute definitions can be converted from existing text, or they can be added from scratch. 
Available text and new attribute definitions are listed in the table’s upper right. Text and attribute 
definition properties of a selected entry will be displayed in the respective fields and can be 
modified (see below). 
 
Selected attribute definitions or text are highlighted with grips in the preview window. They can be 
moved, rotated, and scaled in size. 
 
 

Convert selected Text to Attribute Definition 

A green checkmark ( ) indicates a selected text to be converted to an attribute definition. The 
mark can be set and deleted in different ways: 

• Select/De-Select the option Convert selected Text to Attribute Definition. 

• Double click  on a text entry. 

• Single click on the first column (green checkmark) of a text entry. 
 
On creation of a block definition all checkmarked text will be replaced by attribute definitions. 
 

New Attribute Definition  

 Inserts a new attribute definition. New attribute definitions will always be checkmarked, A de-
selection is not available. 

 Deletes a new attribute definition. Text cannot be deleted. 
 

Change Order  

    These buttons allow for moving table entries up and down. 
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Attribute Definition Properties  
Active only when a new attribute definition or text to be converted has been selected. 
 
Name A name of an attribute definition may only be used once per block definition. A warning 

message appears on double naming. 

Prompt Is displayed upon block insertion. The name will be displayed when left empty, 

Default Preset attribute value upon block insertion. Optional a field function can be selected from 
a list, which reflect characteristics of the block itself. There are two kinds of field functions:  

Prefix @ - Permanent Field Functions: Each time the attributes of the block are displayed 
(double click or via properties [F3]) the value is recomputed for the current state of the block 
or drawing. The value cannot be changed. 
Sample: The function @Date always displays the current date. 

Prefix # - Initial Field Function: When the block is inserted the value is preset with the 
value computed from the current state of the block or drawing. This value is inserted as a 
normal editable attribute. 
Sample: The function #Date creates and attribute with the date when the block was 
inserted. The value can be modified after. 
Circumference Calculates and sets the circumference of the block as attribute value 
Area Calculates and sets the area of the block as attribute value 
Angle Assigns the insertion angle of the block as attribute value 
Y-Position Assigns the y-coordinate as attribute value 
X-Position Assigns the x-coordinate as attribute value 
Name Assigns the name of the block as attribute value 
User Assigns the Windows user name as attribute value 
Date Assigns the current date as attribute value 

 Some field function are only available in one mode (permanent or temporary). 

Mode 
Invisible Attribute will not be displayed in an inserted block 
Constant Attribute value cannot be edited or positioned in a block 
Verify AutoCAD Flag: here, no significance 
Preset AutoCAD Flag: here, no significance 

 
Basic Properties (Text Properties)  

You can modify text specific properties of a selected attribute definition or of a selected text:  
Textstyle, Layer, Color, Align, Angle, Height, Width. 
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Combine to (Existing) Block 
 

 Toolbar: Block 
 

Menu: Vector ► Block ► Combine to Block 
 

CMD: VPCOMBINEBLOCK ► Select Entities ► Dialog 

Replaces the selected elements with a block which references a specified, already existing block 
definition. A dialog opens to specify the block properties. 
 

 
 
Selected elements will be grayed in the preview display. See the selected block definition 
displayed above. With the block definition's grips you can move, rotate, or scale it in size.  

Name 
Name of the selected block definition. Other block definitions can be selected from a list. The last 
block definition applied is offered by default. 

Attributes 
Attribute definitions of the selected block definition. When a selected text element is underlying an 
attribute definition, this will be assigned as an attribute value. If no text can be assigned the 
attribute definition’s default value will be used. Click on the value for desired changes. 

Insertion Point 
Insertion point of the new block. The geometric center point of selected elements is offered as 
default. With Specify on screen you can place the new block with the mouse after OK. 
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Scaling 

Scaling of the new block. An isotropic scaling of 1.0 is offered as default. With Specify on 
screen you can scale the block with the mouse after OK. 
 

Adjust Block Size to Selection 
The block size is adjusted automatically to the overall size of selected elements. 

Default: off  

Rotation 
Rotation angle of the new block. 0.0 degrees are offered as default. With Specify on screen you 
can rotate the block with the mouse after OK. 

Block Properties 
Layer and Color of the new block. Currently active settings are offered as default. 
 
 

Modifying Block definitions (only Windows)  
 

 Toolbar: Block 
 

Menu: Vector ► Block definitions 
 

CMD: VPSHOWBLOCKDEFS ► Dialog 

Opens a dialog showing all block definitions of the current drawing and provides several functions 
for modifying one or more selected block definitions. 
 

 
 

Show hidden Block definitions 
Block definitions with a name starting with * (formerly used for hatching, measuring, etc.), will be 
displayed or hidden. 

Default: off  
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Delete 

 Delete the selected block definition(s). If the drawing contains blocks referring to one of the 
selected block definitions a dialog will appear with options to proceed as required. 
 

 
 

Keep block definition: The current block definition will not be deleted. The process continues 
with the next selected block definition. 

Explode Block(s):Referenced blocks will be exploded, i.e. block elements will be inserted in the 
drawing while the block will be deleted. 

Delete Blocks Referenced blocks will be deleted from the drawing. 

Do this for all conflicts: If more then one block definition was selected to be deleted, the 
selected method to solve the conflict will be used for any further block definition. The dialog 
will not pop up again.  

Cancel The whole process will stop. No further block definitions will be deleted. 
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Exchange 
 

 All blocks of the document referring to this block definition can be changed to another block 
definition which you can choose in the dialog. 
 

 
 

Previous values will be assigned to attributes bearing the same name. All other attributes receive 
the new definition's default values. 
 

Offset 
Moves a block’s base point according to the entered value.  

Default: No offset 
 

Scaling 
A new block can be inserted with the original scaling of the former block, or it can be assigned an 
additional or a new scaling. 

Default: Original scaling 
 

Rotation 
A new block can be inserted with the original rotation of the former block, or it can be assigned an 
additional or a new rotation. 

Default: Original rotation 
 



VP Software Manual  

Manual V16 - V9 / E Section 8     CAD Tools   333
 

  
 

Modify 
 

 Applies to a single block definition. Opens a dialog to modify the insertion point and attribute 
definitions: 
 

 
 

Base Point 
The coordinates display x/y values which refer to the block definition’s geometric center. 0.0/0.0 
indicate a base point in the block definition’s center point. Values can be modified directly. With 
the option Move Base Point you can move the base point on a grip with the mouse. 
 

Attribute Definitions 
Available attribute definitions can be modified or deleted. New attribute definitions can be added. 

 New Attribute Definition Creates a new attribute definition. If the drawing contains blocks 
which are referenced with this block definition, new attributes will be added to these blocks, 
including their default values.  

 Delete Attribute Definition  Deletes the selected attribute definition. If the drawing 
contains blocks which are referenced with this block definition, the respective attributes will be 
deleted from these blocks.  

    Change Position Move a marked entry up/down in the table list. 
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Attribute Definition Properties  
See above: Create Block ► Attribute Definitions ► Attribute Definition Properties. 
 

General Text Properties  
You can modify text specific properties of a selected attribute definition or of a selected text:  
Textstyle, Layer, Color, Align, Angle, Height, Width. 
 
 

Rename 

 Renames the selected block definition(s): 
 

 
 

 
A New Name will be assigned on OK. If the name is already in use a respective message 
appears to enter a unique name. 
 
 

Copy Block Definition 
 

 Copies a selected block definition: 
 

 
 

Enter a name for a new block definition. If the name is already used in the current document a 
message appears to enter new name. 



VP Software Manual  

Manual V16 - V9 / E Section 8     CAD Tools   335
 

  
 

Review 

 This functions allows for checking the attributes of all blocks of the selected block definition. A 
message appears if the block definition does not contain attribute definitions. The function zooms 
to the first block of that block definition and opens this dialog: 
 

 
 
Use Previous and Next to go through all blocks. You can modify the currently displayed 
attributes or Explode the block. 
 
 

Insert Block   
 

 Toolbar: Block 
 

Menu: Vector ► Block ► Insert Block 
 

CMD: VPINSERTBLOCK ► Dialog 
CMD: VPINSERTBLOCK <Name> <X> <Y> [/xs|xScale <value>] [/ys|yScale <value>] 
  [/a|Angle|phi <value>] 
 

CAD: _insert 

Inserts one or multiple block(s). This function is only available if block definitions are contained in 
the current document. 
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Dialog Insert Block with expanded block preview: 
 

 
 
Select a block from the list (Name) or click a thumbnail to select from the preview. The selected 
block will be displayed in the preview. 
 
A block’s Insertion Point, Scaling and Rotation can be readily assigned or you can specify 
settings on screen (Specify on Screen).  
 

Insert only one block 
By default the Insert Block command allows to insert multiple blocks. If this option is on the 
command stops after the first insertion is completed. Also if Specify on Screen is off the 
command will stop after the insertion is completed. 

Default: off 
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With OK the dialog closes and the block will be inserted. A second dialog will open to enter 
attribute values if the selected block contains attributes. 
 

 
 
The block will be either inserted at the specified position (=Insertion Point) or - if Specify on 
Screen is on - is attached to the cursor for free positioning.  
 
Select another Block (from dialog: Attributes, or from: context menu) will interrupt the repeat 
mode, and you can select another block for insertion. 
 
Finish the function with [Esc]. 
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Edit Attributes 
 
A double click on a block with attributes will open a dialog for editing: 
 

 
 
Editable attributes are marked with a pen icon. You can edit values and properties. Constant 
attributes are marked with a lock symbol. To edit these values you have to edit the block definition 
itself. See Block definition ► Modify.... 
 

Block 
Name of the block definition this block is referencing to. 
 

List 
Attributes of this block with their Name, Prompt, and Value. 
  

Type 
Type of the selected list entry. Either an attribute or an (constant) attribute definition. In the 
second case all entry fields are grayed out.  
 

Value 
Value of the attribute or attribute definition. 
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Properties  
Text properties: Text specific properties of the selected attribute. You can modify the Text Style, 

Layer, Color, Alignment, Angle, Height, and Width. 

Attribute properties 
Invisible The attribute will not be displayed. 
Constant The attribute value can neither be edited nor positioned. 
Verify AutoCAD Flag: Here without any meaning 
Prompt AutoCAD Flag: Here without any meaning 

 
 

Draw Attdef 
 

 Toolbar: Block 
 

Menu: Vector ► Block ►Draw Attdef  
 

CMD: VPATTDEF ► Dialog 
CMD: VPATTDEF <x> <y> <Name> <Prompt> <Default> [/inv <0|1>] [/const <0|1>]  
 [/verify <0|1>] [/preset <0|1>] [/h <height>] [/w2h <width>] [/phi <angle>]  
 [/a <Alignment>] 
 

CAD: _attdef 

Adds an attribute definition to the current drawing. 
 
Similar to the Draw Text command you have to specify an insertion point and a base line 
(Except: Fix Angle, see below).  
 

 
 
Name The name of the attribute definition. 

Prompt The display name during the Insert Block command. By default this is the Name.  
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Default The pre-set value. 

Properties 
Invisible The attribute will not be displayed. 
Constant The attribute value can neither be edited nor positioned. 
Verify AutoCAD Flag: Here without any meaning 
Prompt AutoCAD Flag: Here without any meaning 

 
See also: Create Block ► Attribute Definition ► Attribute definition properties. 
 

Text Properties 
Specify text properties. You can set: Text Style, Layer, Color, Alignment, Angle, Height, and 
Width.  
 

  Fix Angle {on/off} 
If on the next attribute definition will use the preset angle. You only have to specify the insertion 
point.  
 

Command line parameters 
For all other properties of the attribute definition the active layer, text style, and color is used. 
Name Name 
Prompt Prompt 
Default Default 
/inv  Invisible flag (default: 0) 
/const  Constant flag (default: 0) 
/verify  Verify flag (default: 0) 
/preset  Preset flag (default: 0) 
/h  Text height (default: Height of the active text style) 
/w2h  width-to-height ratio (default: height of the active text style) 
/phi  Angle (default: 0.0) 
/a  Alignment (default: left) 
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Edit Attribute Definition 
 
With a double click on an existing attribute definition a dialog pops up to edit the attribute specific 
properties (see Draw Attdef).  
 

 
 
For all other properties use the general Show Properties [F3] command. 
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SECTION 9   
HYBRID EDITING TOOLS   

 

General Information   
 
With VP software the formerly sharp line between raster and vector vanishes. 
 
Clicking on (picking) a "line" - regardless if it is a vector or a raster line as part of a raster 
structure - this "line" is highlighted as an individual entity. It receives grips for moving, copying, 
rotating, stretching, or whatever is required. In the properties dialog the entity is indicated as a 
"line", including specific features (layer, color, width).  
 
VP software allows for editing raster and vector entities in the same way. While using the hybrid 
functions you will almost forget about the difference between the raster and the vector world. Still, 
there are some differences to note: 

• Vector entities are usually drawn with 0.00 width and may receive a width while they are 
printed/plotted (according to the layer settings "Print"). Raster entities always have a width 
assigned to them, even a width 0.00 is interpreted as 1 pixel width. 

• When you select raster entities (pick, window, or crossing) they are temporarily converted into 
vectors (having assigned the width of the raster). Later, after finishing an edit command, the 
entities will be rasterized back into the image. 

• If you modify the properties of a "raster" entity it remains a vector with a width assigned. It 
needs to be rasterized (right mouse menu) if you want it to become a raster entity again. 
However, you may leave it as a vector anyway. 

• If you assign a vector layer to a raster entity (by modifying the properties) it will receive the 
width of this layer (usually 0.00). It now appears as any other vector entity residing in that 
vector layer. 

• You can mix raster and vector entities/objects in the same layer if you define the layer width 
"By Entity".  

• To rasterize selected vector entities the rasterize settings of the relevant vector layers have to 
be adjusted.  

 
The standard right mouse menu, containing editing commands offers these functions (the menu 
structure may vary, depending on which particular functions are currently used): 
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Raster Text   
 

 Toolbar: Select Raster 
 

Menu: Edit ► Raster Text 
 

CMD: VPRTEXT ► Dialog 

Provides direct editing of text in raster images. 
 
Text can be selected by rectangle selection (rotated or non-rotated) and is transferred to the OCR 
(text recognition). A dialog appears displaying the recognized text in a preview window. In the 
preview window the text can be adjusted (move, rotate, scale) directly according to the raster 
image. Also, text properties and output mode can be defined. 
 

 
 
Recognized text is displayed and can be edited in the Text field.  

 Special characters (if configured) are directly accessible pressing this button or via the keys 
[Alt+1] thru [Alt+9] and [Alt+A] thru [Alt+O]. 
 

Start Point 
The text insertion point (lower left corner) in the document. 
 

Angle, Height, Text Style, Layer, Color, Alignment 
Options defining text properties.  
 

  Lock / unlock Value 
Locked values remain unchanged with continuous use of the Raster Text function. This will e.g. 
result in creating text with a uniform height value. 
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OCR Options (Text recognition) 
Specify the settings for the text recognition. Select from predefined and user defined settings for 
the recognition (OCR, e.g. only numbers, special characters). New settings are saved and will be 
available for other projects as well.  
 
Predefined settings are: 

Global OCR Settings: The currently specified OCR settings (can be changed with Options – 
OCR Settings, see Chapter 4). 
Only Letters: All letters, but no numbers (digits) are recognized.  
Only Numbers: Only numbers are recognized. 

Default: Global OCR Settings 

 New settings . After specifying a name the dialog for the OCR Settings will show up. 

 Modify: Opens the dialog for the OCR Settings to modify the selects settings. 

 Delete the selected settings. 
 

New Selection 
Closes the dialog and cancels the current selection. Use this function to select a new raster text 
due to a previous wrong selection.  
 
 

Output Tab 
 
Defining the text insertion mode:  
 

 
 

Create Vector Text 
New text will be inserted as vector text 

Default: on 
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Rasterize Text  
New text will be inserted and rasterized. 

Default: on 
 

Adjust Text on OK 
When on text will be inserted with grips and can be adjusted (move, rotate, scale). The action 
terminates with [Return] or with a right mouse click and End Command. Text will be inserted 
according to the defined options. 

Default: off 
 

Erase Raster Background  
When on the selected raster will be erased before adjusting text or after adjusting text. 

Default: on, after adjusting text 
 

Copy to Clipboard 
The text is copied to the clipboard and can be used in other applications. 

Default: on 
 
 

Selection Mode Tab 
 
Defining how to select  raster text: 
 

 
 

2-Point Rectangle  
Best for non-rotated text. A rectangle will be drawn with two points (start point, opposite corner). 
The text angle is 0°. 

Default: off 
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3-Point Rectangle 
For rotated and non-rotated text. A rectangle will be drawn with three points (start point, angle, 
and height). Text angle is defined by the rectangle’s angle. With holding the [SHIFT] key the 
angle input is limited to steps with 45°; a temporary switch to 2-Point Rectangle selection is 
provided with holding the [CTRL] key 

Default: on 
 
Switching between selection modes is provided via the context menu (right mouse). 
 
 

Display Tab 
 
Defining display options for the preview window: 

 

 
 

Display New Text In Window 
When on the original raster and new text will be displayed in the preview window. 

Default: on 
 

Use Default Text Color 
When on new text will be displayed in the default color. Changes to the color with Change. When 
off new text will be displayed according to the settings in Properties.  

Default: off 
 

Opacity 
Defines the opacity level of new text displayed in the preview window. 

Default: 50% 
 
OK inserts new text according to the selected modes. 
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Search Raster Symbols   
 

 Toolbar: Select Raster 
 

Menu: Edit ► Raster Symbols 
 

CMD: VPRSEARCH ► Dialog 
CMD: VPRSEARCH  <smax> [/smin <SizeMin>] [/m <mode>] [/e <erase>] [/l <layername>] 

Searching for symbols or structures in a raster image defined by their size. Elements detected 
can be transferred into a new raster image or they can be converted into polylines. 
 
After starting the function without command line parameters the following dialog appears to set up 
options for Raster Symbol Search: 
 

 
 

Symbol Size smax, [/smin] 
Defining the search for elements by their Min. Size and Max. Size in user units. 

Default: 0.0 User Units (Min. Size) 
 5.0 User Units (Max. Size) 
 

Extract To New Raster Image [/m 0] 
All elements detected will be transferred to a new raster image. The extents of the new image 
correspond with the size of the original raster image. The new image will be placed on the target 
layer. 

Default: on 
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Vectorize Outline [/m 1] 
The contours of each element detected will be converted into polylines. Polylines will be placed 
on the target layer. 

Default: off 
 

Erase Symbol From Raster [/e 0|1] 
Elements detected will be deleted from the original raster image. 

Default: on 
 

Transfer Results to Layer [/l] 
Target layer for the new raster image or for polylines created. 

Default: Layer 0 
 

Search Area 
Defining the search area in the original raster image. With options Rectangular Area and 
Polygon Area the respective area can be defined after OK.  

Default: Whole Drawing 
 

Review Results 
When switched off all elements detected will be processed immediately (new raster image or 
conversion into polylines).  
 
When switched on all elements detected will appear in a green color display. Elements can be 
excluded by window selection; they may be included again by holding the [SHIFT] key during  
window selection. Processing continued with  [RETURN]. 

Default: off 
 

Command Line Parameters 
Required Parameters 
<smax> maximum size of raster symbols in user coordinates 
 
Optional Parameters 
/smin <value> minimum size of raster symbols in user coordinates, default: 0.0 
/m <mode> Mode (0 = extract to new raster image, 1 = vectorize outline), default: 0 
/e <erase> Erase symbols from raster (0 = do not erase, 1 = erase), default: 1 
/l <layername> Target layer for the new raster image. Default: "0" for mode 1 (vectorize 

outline), "Raster" for mode 0 (extract to new raster image) 
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Edit Object(s)    
 

Delete Entities  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Delete Function: Delete Entities  
 

CMD: VPDELETE  
 

CAD: _erase 

Deletes the selected entities. You can also use [DEL] on your keyboard. 
 
 

Explode Entities (Origin)  
 

 Toolbar: Properties/Editing 
 

Menu: Edit Function: Explode Entities  
 

CMD: VPEXPLODE  
 

CAD: _explode 

Breaks up the structure of the selected elements. Blocks, Hatch, Polylines, and MText are 
exploded and separated into their composing base elements. This allows for corrections of 
misinterpretations resulting from a vectorization. 
 
 

Move  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Move  
 

CMD: VPMOVE [<x> <y> [/a] [/bx 0|1|2] [/by 0|1|2] 

Moves selected elements to either a specific position (absolute) or by a certain distance (relative). 
You can also rotate and/or scale the elements during this command. 
 
For coordinate input use either the command line or use the mouse, optional with the snapping 
methods.  
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Command line: 
x  Shift X 
y  Shift Y 
/a  Absolute (Default=No) (x and y are absolute coordinates) 
/bx <value> Base point X:  0=Left, 1=Center, 2=Right (Default=0) 
/by <value> Base point Y:  0=Bottom, 1=Center, 2=Top (Default=0) 
 
Left, center, right and bottom, center, top mean the according values of the active selection set. 
 

Prompts: 
Select Entities: If the command was started without a selection, you have to specify which 

elements you want to move. Use the standard selection methods and confirm with [Enter]. 
 
Insert Basepoint or [Relative]: Start point of the displacement line. [Enter] selects the center of 

the current selection as base point. Switch to the Relative mode with r and [Enter].  
 
Specify second point of displacement or [Move,Scale,Rotate]: The destination coordinates. 

The base point will be moved to this position, or in Relative mode, the selection is moved by 
this amount of the x and y coordinate. Switch to Scale with s or to Rotate with r.  

 
Specify scale factor or [Move,Scale,Rotate]: You are in the Scale mode. Either enter a scale 

factor and confirm with [Enter], or move the mouse to enlarge or reduce the selection. 
Confirm with a mouse click. The command switches back to the Move mode. To switch the 
mode without any scaling, use m for the Move mode or r for Rotate. 

 
Specify rotation angle or [Move, Scale, Rotate]: You are in the Rotate mode. Either enter an 

angle in degrees and confirm with [Enter], or move the mouse to rotate. Confirm with a 
mouse click. The command switches back to the Move mode. To switch the mode without any 
rotation, use m for the Move mode or s for Scale. 

 
You can also switch the mode via context menu. Additional options are: 
  

Show Original Selection 
A copy of the selection is displayed at its original position. You can use the object snap methods. 

Default: on 
 

Rasterize 
The selected elements will be rasterized at their current position into any raster objects beneath. 
This option is only available if there are any raster objects in the document. 
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Copy  
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Copy 
 

CMD: VPCOPY [<x> <y> [/a] [/bx 0|1|2] [/by 0|1|2] 

Copies selected elements to either a specific position (absolute) or by a certain distance 
(relative). You can also rotate and/or scale the elements during this command. 
 

Command line: 
x  Shift X 
y  Shift Y 
/a  Absolute (Default=No) (x and y are absolute coordinates) 
/bx <value> Base point X:  0=Left, 1=Center, 2=Right (Default=0) 
/by <value> Base point Y:  0=Bottom, 1=Center, 2=Top (Default=0) 
 
Left, center, right and bottom, center, top mean the according values of the active selection set. 
 
For coordinate input use either the command line or use the mouse, optional with the snapping 
methods.  

 
Prompts: 

Select Entities: If the command was started without a selection, you have to specify which 
elements you want to copy. Use the standard selection methods and confirm with [Enter]. 

 
Insert Basepoint or [Relative]: Start point of the displacement line. [Enter] selects the center of 

the current selection as base point. Switch to the Relative mode with r and [Enter].  
 
Specify second point of displacement or [Copy,Scale,Rotate]: The destination coordinates. 

The base point will be moved to this position, or in Relative mode, the selection is moved by 
this amount of the x and y coordinate. Switch to Scale with s or to Rotate with r.  

 
Specify scale factor or [Copy,Scale,Rotate]: You are in the Scale mode. Either enter a scale 

factor and confirm with [Enter], or move the mouse to enlarge or reduce the selection. 
Confirm with a mouse click. The command switches back to the Copy mode. To switch the 
mode without any scaling, use c for the Copy mode or r for Rotate. 

 
Specify rotation angle or [Copy, Scale, Rotate]: You are in the Rotate mode. Either enter an 

angle in degrees and confirm with [Enter], or move the mouse to rotate. Confirm with a 
mouse click. The command switches back to the Copy mode. To switch the mode without any 
rotation, use c for the Copy mode or s for Scale. 

 
You can also switch the mode via context menu. Additional options are: 
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Highlight Original Selection 
The selection is highlighted at its original position. You can use the object snap methods. 

Default: on 
 

Rasterize 
The selected elements will be rasterized at their current position into any raster objects beneath. 
This option is only available if there are any raster objects in the document. 
 
 

Scale 
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Scale 
 

CMD: VPSCALEENT [/sx|ScaleX <ScaleX>] [/sy|ScaleY <ScaleY>] 

Enlarges or reduces selected elements (absolute or relative to a reference length). 
 

Command line: 
/sx <ScaleX> Scaling in X direction (1.0 is default) 
/sy <ScaleY> Scaling in Y direction (1.0 is default) 
 
For coordinate input use either the command line or use the mouse, optional with the snapping 
methods.  
 

Prompts: 
Select Entities: If the command was started without a selection, you have to specify which 

elements you want to scale. Use the standard selection methods and confirm with [Enter]. 
 
Select Basepoint: The base point of the transformation. [Enter] selects the center of the current 

selection as base point.  
 
Specify scale factor or [Copy, Reference]: Enter a scale factor and confirm with [Enter], or 

move the mouse to enlarge or reduce the selection on screen. Confirm with a click. Just 
[Enter] will use the last entered scale factor, displayed in <..>. To create a Copy of the 
selection enter c. Switch to the Reference mode with r. The scale factor will then be 
computed out of the specified reference length and a second destination length (see below). 

 
Specify reference length: Either enter a value and confirm with [Enter] or specify a length on 

screen. You can use the last specified value, displayed in <..>, with [Enter]. 
 
Specify reference length: Specify second point: On screen mode. Finalize the reference 

length by a the second point. 
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Specify new Length or [Points]: Either enter a new destination length, or enter p to specify the 

new length with a two-point line on screen. You can use the last specified value, displayed in 
<..>, with [Enter]. 

 
Specify new Length: Specify first point: First point of destination length. 
 
Specify new Length: Specify second point: Second point of destination length.  
 
You can also switch the mode via context menu. Additional options are: 
 

Highlight Original Selection 
The selection is highlighted at its original position. You can use the object snap methods. 

Default: on 
 

Rasterize 
The selected elements will be rasterized at their current position into any raster objects beneath. 
This option is only available if there are any raster objects in the document. 
 
 

Rotate 
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Rotate 
 

CMD: VPROTATEENT <Angle> 

Rotates the selected elements around a base point (absolute or relative). 
 

Command line: 
<Angle> Rotation angle 
 
For coordinate input use either the command line or use the mouse, optional with the snapping 
methods.  
 

Prompts: 
Select Entities: If the command was started without a selection, you have to specify which 

elements you want to rotate. Use the standard selection methods and confirm with [Enter]. 
 
Select Basepoint: The base point of the transformation. [Enter] selects the center of the current 

selection as base point.  
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Specify rotation angle or [Copy, Reference]: Enter a rotation angle and confirm with [Enter], or 

move the mouse to rotate the selection on screen. Confirm with a mouse click. Just [Enter] 
will use the last entered rotation angle, displayed in <..>. To create a Copy of the selection 
enter c. Switch to the Reference mode with r. The rotation angle will then be computed out of 
the specified reference angle and a second destination angle (see below). 

 
Specify reference angle: Either enter a value and confirm with [Enter] or specify an angle on 

screen. You can use the last specified value, displayed in <..>, with [Enter]. 
 
Specify reference angle: Specify second point: On screen mode. Finalize the reference angle 

by a the second point. 
 
Specify new angle or [Points]: Either enter a new destination angle, or enter p to specify the 

new angle with a two-point line on screen. You can use the last specified value, displayed in 
<..>, with [Enter]. 

 
Specify new angle: Specify first point: First point of destination angle. 
 
Specify new angle: Specify second point: Second point of destination angle.  
 
You can also switch the mode via context menu. Additional options are: 
 

Show Original Selection 
A copy of the selection is displayed at its original position. You can use the object snap methods. 

Default: on 
 

Rasterize 
The selected elements will be rasterized at their current position into any raster objects beneath. 
This option is only available if there are any raster objects in the document. 
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Mirror 
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Mirror 
 

CMD: VPMIRRORENT 

Mirrores the selected elements at a mirror axis. For better point input use the snap methods. 
 

Prompts: 
Select Entities: If the command was started without a selection, you have to specify which 

elements you want to mirror. Use the standard selection methods and confirm with [Enter]. 
 
Draw mirror line [Select line to mirror on (s)]: Specify the first point of the desired mirror line. 

Use s  to switch to a selection mode. 
 
Second point of mirror axis: Specify the second point of the desired mirror axis. Use s  to 

switch to a selection mode. 
 
Select line to mirror on [Draw mirror line (d)]]: Pick a vector line as mirror axis. Use d to 

switch to the draw mode. 
 
Erase source objects [Yes/No]: Type y to erase the original selection, n keeps it. Default is n.  
 
You can also switch the mode via context menu. Additional options are: 
 

Highlight Original Selection 
The selection is highlighted at its original position. You can use the object snap methods. 

Default: on 
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Array 
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Array 
 

CMD: VPARRAYENT 

This function allows a multiple copy and positioning of raster and/or vector entities in a 
rectangular or circular order. 
Activate this function and select the entities/objects you want to array. Confirm the selection with 
[Return]. You may also select the entities/objects first and then call the function. For raster 
selection, use the function Select Raster from the context menu (right mouse click).  
 
A dialog pops up for specifying the array structure: 
 

 
 
 

Rectangle 
 
The selected entities will be arranged on a rectangular grid. 
 

Row 
Specify the number of rows and the Offset between each array entity. 

Default: 1 
Default Value: 1.0 [mm]  
 

Column 
Specify the number of columns and the Offset between each array entity. 

Default: 1 
Default Value: 1.0 [mm]  
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Orientation 
Choose between: 

• upwards to the left 
• downwards to the left  
• upwards to the right 
• downwards to the right 

Default: upwards to the left 
 

Angle of Array 
The angular orientation of the array (not the array entities!) to the grid. 

Default: 0.0° 
 
 

Polar 
The selected entities will be arranged along an imaginary circle. 
 

Center Point 
The center point of the imaginary circle. 
 

Total number of objects 
The number of additional entities (plus one for the original selection) to be arranged. 

Default: 1 
 

Angle to fill 
Specify the angle of the imaginary circle. Entities will be positioned alongside accordingly. 

Default: 360° (full circle) 
 

Arrange objects with rotation {on/off} 
The copied objects will be rotated around their center point according to their position on the 
imaginary circle. 
Default: on 
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Offset 
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Edit Object(s) Function: Offset 
 

CMD: VPOFFSETENT 

Copies selected entities and adds them parallel (lines, raster) or concentric (arcs, circles, and 
ellipses) to the original entities. 
 

Prompts: 
Select Entities: If the command was started without a selection, you have to specify which 

elements you want to offset. Use the standard selection methods and confirm with [Enter]. 
 
Specify offset distance: Specify the distance (by value or by drawing a line on screen) to the 

existing elements.  
 
Second Point: Second point of line, which defines the distance. 
 
Insert Point: Specify the side on which the new elements should be inserted.  
 
You can also switch the mode via context menu. Additional options are: 
 

Highlight Original Selection 
The selection is highlighted at its original position. You can use the object snap methods. 

Default: on 
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Combining Elements    
 
These functions allow you to combine selected entities (raster or vector) to form a complete, or 
even a new entity. These functions can be applied to raster or vector entities particularly 
generated by the vectorization process, as well as to manually drawn entities. 
 
In this sense, "to combine" means to group entities, for example, two or more lines segments to 
form a single line or a complete single arc. Due to a poor original or inaccurate drawing, the 
vectorization process may often result in broken lines, several arcs fractions instead of a circle, 
etc. Using the Combine to commands, clean-up can be accomplished easily, quickly and at high 
precision. 
 
If several entities are combined to create a new entity, the new entity is calculated according to 
the method of the least square error. For example, the outer end points of two lines being joined 
are not necessarily identical to the endpoints of the new line.  
 
If entities with differing properties (e.g. layer or line type) are combined, the properties of the 
resulting object are determined by the dominant (i.e. largest) entity. 
 
There are two basic methods for combining entities: 
• Select the entities first, then click on the function icon (single call). 
• Select the function by clicking on the icon, then select the entities and complete the function 

by pressing [Enter]. The function remains active for subsequent operations (multiple call). 
 
 

Combine to Line  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Line 
 

CMD: VPCOMBINETOLINE ► Select Entities 

Combines the selected entities to a single line. The angle of the resulting line is the mean angle 
of the combined entities. Arcs can be combined to lines as well. 
 
 

Combine to Orthogonal Line  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Orthogonal Line 
 

CMD: VPCOMBINETOORTHOLINE ► Select Entities 

Combines the selected entities to an orthogonal line. This function can be used to deskew 
individual and non-orthogonal lines. 
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Combine to Polyline  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Polyline 
 

CMD: VPCOMBINETOPOLYLINE ► Select Entities 

Combines the selected entities to a polyline. Use this command to combine individual polyline 
segments (e.g. on a map) to a single polyline. 
 
 

Combine to Closed Polyline  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Closed Polyline 
 

CMD: VPCOMBINETOCLOSEDPOLYLINE ► Select Polyline 

Combines the selected entities to a closed polyline or closes a selected polyline. 
 
 

Combine to MPolyline  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► MPolyline 
 

CMD: VPCOMBINETOMPOLYLINE ► Select Elements 

Links selected elements to a multi-polyline. Other elements than lines will be exploded in raw 
vectors first. The command allows for combining single polyline fragments (e.g. in maps) to a 
multi-polyline. 
 
 

Combine to Closed MPolyline  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Closed MPolyline 
 

CMD: VPCOMBINETOCLOSEDMPOLYLINE ► Select Elements 

Links selected elements to a closed multi-polyline or closes a selected multi-polyline. 
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Combine to Polygon (only Windows)  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Polygon 
 

CMD: VPCOMBINETOPOLYGON ► Select Entities 

Combines the selected entities to a polygon. Use this command to combine individual polygon 
entities (e.g. on a map) to a single polygon. 
 
 

Combine to Spline  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Spline 
 

CMD: VPCOMBINETOSPLINE ► Select Entities 

Combines the selected entities to a B-spline. 
 
 

Combine to Closed Spline  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Closed Spline 
 

CMD: VPCOMBINETOCLOSEDSPLINE ► Select Entities 

Combines the selected entities to a closed B-spline or closes a selected spline. 
 
 

Combine to Arc  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Arc 
 

CMD: VPCOMBINETOARC ► Select Entities 

Combines selected entities to an arc. 
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Combine to Circle  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Circle 
 

CMD: VPCOMBINETOCIRCLE ► Select Entities 

Combines selected entities to a circle. 
 
 

Combine to Ellipse  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Ellipse 
 

CMD: VPCOMBINETOELLIPSE ► Select Entities 

Combines selected entities to an ellipse. 
 
 

Combine to Elliptical Arc  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Elliptical Arc 
 

CMD: VPCOMBINETOELLIPTICALARC ► Select Entities 

Combines selected entities to a partial ellipse. 
 
 

Combine to Text (Interactive Text Recognition)  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Text 
 

CMD: VPCOMBINETOTEXT ► Select Entities ► Dialog 

Processing selected raster or vector elements with text recognition. A dialog appears displaying 
the recognized text in a preview window. In the preview window the text can be adjusted (move, 
rotate, scale) directly according to the raster image. Also, text properties and output mode can be 
defined. 
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Recognized text is displayed and can be edited in the Text field.  
 

Start Point 
The text insertion point (lower left corner) in the document. 
 

Angle, Height, Text Style, Layer, Color, Alignment 
Options defining text properties.  
 

  Lock / unlock Value 
Locked values remain unchanged with continuous use of the Combine to Text function. This will 
e.g. result in creating text with a uniform height value. 
 

Flip 
Rotates the selection by 180° and starts recognition process again. 
 

OCR Options (Text recognition) 
Specify the settings for the text recognition. Select from predefined and user defined settings for 
the recognition (OCR, e.g. only numbers, special characters). New settings are saved and will be 
available for other projects as well.  
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Predefined settings are: 

Global OCR Settings: The currently specified OCR settings (can be changed with Options – 
OCR Settings, see Chapter 4). 
Only Letters: All letters, but no numbers (digits) are recognized.  
Only Numbers: Only numbers are recognized. 

Default: Global OCR Settings 

 New settings . After specifying a name the dialog for the OCR Settings will show up. 

 Modify: Opens the dialog for the OCR Settings to modify the selects settings. 

 Delete the selected settings. 
 

New Selection 
Closes the dialog and cancels the current selection. Use this function to select a new raster or 
vector text due to a previous wrong selection.  
 

Output Tab 
 
Defining the text insertion mode:  
 

 
 

Create Vector Text 
The new text will be inserted as vector text. 

Default: on 
 

Rasterize Text  
New text will be inserted and rasterized. 

Default: on 
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Adjust Text on OK 
When on text will be inserted with grips and can be adjusted (move, rotate, scale). The action 
terminates with [Return] or with a right mouse click and End Command. Text will be inserted 
according to the defined options. 

Default: off 
 

Erase Raster Background  
When on the selected raster will be erased before adjusting text or after adjusting text. 

Default: on, after adjusting text 
 

Copy to Clipboard 
The text is copied to the clipboard and can be used in other applications. 

Default: on 
 
For Display Tab see Raster Text above in this section. 
 
OK inserts new text and deletes the original selection. 
 
 

Combine to MText (Multiline Text Recognition)  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Multiline Text 
 

CMD: VPCOMBINETOMTEXT ► Select Entities ► Dialog 

Transfers selected entities to the multiline text recognition routine. If raster and vectors are 
selected together, then only the vectors are processed. The multiline text editor dialog appears, 
displaying the recognized text strings for formatting: 
 

 



 VP Software Manual 

366   Section 9     Hybrid Editing Tools Manual V16 - V9 / E 
 

  
 

Text Fonts 
All available system fonts can be selected and assigned to the text string or to portions of it. 
 

Text Height 
Applies the entered height to the marked text strings. 
 

Line Distance 
Defines the spacing between text lines with reference to the standard line distance. 
 

Position 
With reference to the specified text area (rectangle) you have multiple choices to position the 
multi line text. 
 

Bold, Italic, Underline 
These options allow for modifying the selected font. 
 

Import Text 
Allows to import text from a file. 
 
 

Combine to Hatch  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Hatch 
 

CMD: VPCOMBINETOHATCH ► Select Entities  

The selected line entities are combined to form a hatch.  
 
You can add additional lines to a hatch by selecting these lines and the hatch and then activate 
this function again. 
 
 

Combine Options  
 

 Toolbar: Combine to  
 

Menu: Vector ► Combine to ► Settings 
 

CMD: VPCOMBINESETTINGS ► Dialog  

Options to set up selection and input modes for all Combine To functions. 
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Output Tab 
 

 
 
Defining how combined elements will be inserted. 
 

Create Vectors 
Combined elements will be inserted as vectors. 
 

Rasterize 
Combined elements will be rasterized directly. 
 

Auto Mode 
Insertion mode depends on the selection. 

Only raster elements selected: elements will be rasterized. 
Vector(s) included in selection: elements will be inserted as vectors. 
 

Default: Auto Mode 

 These options do not apply to functions Combine to Text and Combine to MText. 
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Properties Tab 
 

 
 
Defining properties of combined elements (layer, color, etc.). These options refer to inserted 
vector elements only.  
 

Use Properties of first selected entity 
The new element receives the same properties as the first selected element. Use this function to 
add several elements to a main element without changing its properties. 
 

Fixed 
Independent from the selection. Current property settings in the document apply to combined 
elements. 
 

Automatic 
Depending on selection. Properties of the dominant element in the selection (i.e. the largest or 
longest element) will apply to the new element. 

Standard: Automatic for all 

 These options do not apply to functions Combine to Text and Combine to MText. 
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Accuracy Tab 
 

 
 

Curves 
Circle, arcs, splines, and ellipses will be exploded into short line segments. These will form the 
new combined element. Tolerance refers to the maximum distance of the line segments to the 
original curve.  
 
Lower tolerance values will result in an increased accuracy, however, will also create more data. 

Default: 1.00 User Units 
 

Angle Correction 
Applies to function Combine to Line. The option will correct angle positions of lines to 0° or 90° 
when a maximum deviation is defined for this correction. 

Default: off 
 

Remove redundant vertices 
Refers to function Combine to Polygon. Vertices of overlaying (double or multi) line segments 
will be deleted. 

Default: on 
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Attributes Tab  
 

 
 
Here you can specify which attributes a new entity will receive from an entity in the selection. You 
can use attributes from the first, or biggest, or longest entity. 
 

Show dialog to select / modify attributes 
A dialog appears during combine operations offering attributes of all selected entities. Default is 
set to the first or to the biggest entity (according to the selection). 

Default: on 
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Select Attributes 
 
Depending on the combine-to settings  (see Attributes Tab) this dialog appears when entities are 
going to be combined: 
 

 
 
Attributes of all selected entities are offered. Default is set to the first or to the biggest entity. 
 

Apply 
Selected attributes are assigned to the new entity. 
 

Skip 
The new entity will be created without attributes.  
 

Cancel 
The function will be terminated. 
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Adjust Text   
 
These functions allow you to align and/or adjust height, angle, and line space of text entities. 
Other text properties, such as text style, layer, or color remain unchanged. 
 
The functions can be used in two operation modes: 

• Select text entities first, then execute a command, or  

• Select the command first, then select text entities. 

 Only single line text can be edited. Multiline text or other entities will be ignored. 
 
 

Align Left  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Align Left 
 

CMD: VPADJUSTLEFT ► Select Entities 

Specify a point (on-screen or in the command line) to define the X-value the text shall be left 
aligned to. The Y-value, height, and angle of the text remain unchanged. 
 
 

Align Right  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Align Right 
 

CMD: VPADJUSTRIGHT ► Select Entities 

Specify a point (on-screen or in the command line) to define the Y-value the text shall be left 
aligned to. The X-value, height, and angle of the text remain unchanged. 
 
 

Center Horizontally 
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Center Horizontal 
 

CMD: VPADJUSTXCENTER ► Select Entities 

Specify a point (on-screen or in the command line) to define the X-value the text shall be 
centered (=half of the text width) to. The Y-value, height, and angle of the text remain 
unchanged. 



VP Software Manual  

Manual V16 - V9 / E Section 9     Hybrid Editing Tools   373
 

  
 

Align Top 
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Align Top 
 

CMD: VPADJUSTTOP ► Select Entities 

Specify a point (on-screen or in the command line) to define the Y-value the text shall be aligned 
to at the upper edge(s). The X-value, height, and angle of the text remain unchanged. 
 
 

Align Bottom  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Align Bottom 
 

CMD: VPADJUSTBOTTOM ► Select Entities 

Specify a point (on-screen or in the command line) to define the Y-value the text shall be aligned 
to at the lower edge(s). The X-value, height, and angle of the text remain unchanged. 
 
 

Center Vertical  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Center Vertical 
 

CMD: VPADJUSTYCENTER ► Select Entities 

Specify a point (on-screen or in the command line) to define the Y-value the text will be centered 
(=half of the text height) to. The X-value, height, and angle of the text remain unchanged. 
 
 

Align with Line Space  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Align with Line Space 
 

CMD: VPADJUSTLINESPACE ► Select Entities 
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After text selection the following dialog opens: 
 

 
 

Line Space 
Enter a fixed value (0.5 up to 4 times the text height), or select Align on screen to adjust text 
interactively (see below) after the dialog closes. 
 
Default:  Align with fixed value 
Value: 1.0x 
 

Text settings 
Specify the desired uniform Text height and a mutual alignment (left, right or centered). 

Default: 3 [mm], Left 
 
After confirmation of the values with OK a grip is shown near the top text for group positioning. If 
Align on screen was selected the line space can be adjusted with a second grip near the bottom 
text. 
 
The modifications are accepted with [Enter] or selecting Enter from the context menu. Discard 
the changes with [ESC] or select Cancel from the context menu. 
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Assign Same Height  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Assign Same Height 
 

CMD: VPADJUSTHEIGHT ► Select Entities 
 
Specify the new text height for all selected text entities. The height can be entered in the 
command line or it can be specified by drawing a reference line on-screen. 
 
 

Assign Same Angle  
 

 Toolbar: Adjust Text 
 

Menu: Vector ► Adjust Text ► Assign Same Angle 
 

CMD: VPADJUSTANGLE ► Select Entities 
 
Specify the new angle for all selected text entities. The angle can be entered in the command line 
or it can be specified by drawing a reference line on screen. 
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Special Tools   
 
Review Text  

 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Review Text 
 

CMD: VPREVIEWTEXT ► Dialog 

Allows for reviewing and editing of text in a drawing or from a selection. You can review 
vectorized text and manually entered text. 
 
Dialog Text Review with expanded Properties bar: 
 

 
 
Current text will be displayed in the preview window along with the underlying raster, if any. Text 
can be moved, rotated, and scaled in size in the preview window.. 
 
The current text will be zoomed in the drawing. The zoom factor depends on the size of the text. 
From this value, choose Zoom to increase/decrease this factor: For vectorized text the 
assembled vectors will be displayed, instead of the actual text. 
 
When reviewing vectorized text all those vector entities to be replaced by the ASCII text can be 
included by selecting those entities. If you've selected an entity by mistake, deselect it with [Shift] 
and click on the highlighted entity(s). On occasion, you may want to explode a text back into the 
vector entities, since the interpretation could be wrong: simply delete the text and press OK to 
restore the original vector(s). This is another way of exploding. 
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In the dialog you can change all text properties and edit the text directly (using the keyboard). 
Using the Shortcuts button, you can enter special characters or text strings.  

  Undo/Redo last changes. 

  Jump to first/previous text. 

 Indicates which text is reviewed in the current sequence. 

  Jump to following/last text 

 Deletes current text. Original vectors will be restored with vectorized text. 

 Pause: Review will be interrupted and dialog is closed. All modifications are saved. 
Pressing again will continue the review run at the current text position. 

 Close: Review will be closed. All modifications are saved. Using Review Text function 
again will continue the review run at the current text position. 

  Displays/closes the properties bar. 

  Lock / unlock values: Locked values remain unchanged for following text. This will e.g. 
result in creating text with a uniform height value.  
 

Review Text - Settings 
 

 
 

Review Mode 
You can specify which kind of text will be reviewed. Change the mode when a warning message 
appears. 

Default: Review all Text 
 

Preview Window 
Set color and transparency for the preview display. 
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Vector Cleanup   
 

 Toolbar: Regeneration  
 

Menu: Vectorize ► Vector Cleanup 
 

CMD: VPVECCLEAN 

With this function topology errors in vector data can be corrected, such as overlaps (overshoots) 
and gaps (undershoots). Also, short, separated elements can be eliminated. Moreover, joined 
lines can be combined to polylines, closed areas can be combined to polygons. 

The function will only be useful for lines and polylines. All other elements will either be ignored or 
will be converted to polylines (see Options). 
 
 

Cleanup Tab 

 
 

Extend Undershoots 
Gaps resulting from too short vectors will be closed.  
 

Remove Overshoots 
Overlaps resulting from too long vectors will be eliminated.  
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Close Apparent Intersections 
Gaps between two lines and/or polylines will be closed. The virtual intersection of both line 
segments must match the tolerance value. 
 

Snap Nodes 
Nodes that are close to each other will be joined.  
 

Insert Vertex at Intersection 
A vertex will be inserted at intersecting lines or intersecting polylines.  
 

Break Elements at Intersection 
Results in an element break if the element (a line or a polyline) is intersected at any position. 
 

Distance / Tolerance: 
Maximum distance for undershoots, overshoots, apparent intersections, or between nodes to be 
cleaned.  

Default: 0.5 User Units 
 
 

Topology Tab 
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Chain Entities to Polylines 
After cleanup, joined lines or polylines will be chained to polylines which end with a node or have 
open endings. 
 

Create Polygons 
Areas closed by lines or polylines will be replaced with polygons residing in the active layer. 
Lines/polylines of the outline will be kept. If several polygons are overlaying each other you can 
combine them to one coherent polygon (Create polygons with holes). Polygons which lie 
completely inside a bigger polygon will be converted to holes. 
 

Remove Redundant Vertices 
Vertices on straight line/polyline segments will be deleted. 

 
Insert Vertices 

Additional vertices will be inserted to line segments. Lines will be split into segments not longer 
than the entered value.  

Default: 5.0 User Units 
 

Insert vertices with equal spacing 
Adds vertices to a segment with an equal distance.  
 
 

Entity Handling Tab 
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Remove Duplicate Objects 
Duplicate (overlaying) elements will be deleted. The Distance / Tolerance value controls how 
close elements need to be overlaying each other. 
 

Remove Zero Length Objects 
Lines and 2-point polylines with equal start and end points will be deleted.  
 

Short Objects 
Elements shorter than Distance / Tolerance will be deleted. They need to have at least one open 
ending. 
 

Distance / Tolerance: 
Maximum distance (in user units) for removing duplicate elements. Maximum length (in user 
units) for removing short objects. 

Default: 1.0 User Units 
 

Convert Entities to Polylines 
Elements, such as Lines, Circles, Arcs, Ellipses, Splines and Bulged Polylines will be 
considered for a cleanup process (e.g. calculation of intersections). They will , however, not be 
modified. To entirely include these elements in a cleanup process they need to be converted to 
polylines. The selected element types will be converted to polylines according to the current 
Tolerance value (in user units).  
 
Default: 0.5 User Units 
 
 

Regenerate 
 

 Toolbar: Regeneration  
 

Menu: Vectorize ► Regenerate 
 

CMD: VPREGENERATE 

Applies to all or currently selected closed polygons and closed polylines. Generates gapless and 
none-overlapping adjoining areas. Use this function to process traced or vectorized 
polygons/polylines with the settings defined in Regenerate Settings. 
 
 

Regenerate Settings 
 

 Toolbar: Regeneration  
 

Menu: Vectorize ► Regenerate Settings 
 

CMD: VPREGENERATESETTINGS ► Dialog 
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Match Borders 
The polygons/polylines will be re-calculated according to their neighborhood distance at any one 
vertex to the closest vertex of other polygons/polylines. This ensures that contours of neighboring 
entities will not have gaps in between. A vertex with a greater distance to a neighboring vertex 
than Max. Distance will not be re-adjusted. 

Default Value: 0.3 [mm] 

 A good value for the distance of two vertices that should be combined is the width of the 
original raster borderline. 

 
Create Orthogonal Polylines/Polygons 

Within the value for Deviation the line segments of polygons/polylines will be aligned orthogonally 
to each other. 

Default Value: 5.0 [Degrees] 
 

Insert Vertices at Intersections 
Create additional vertices at the intersections of polygons/polylines. 
 

Remove Redundant Vertices 
Vertices lying on straight line segments are removed from polygons/polylines. 
 

Insert Vertices 
Line segments will be subdivided to Max. Segment Length by insertion of additional vertices. 

Default Value: 1.0 [mm] 
 

OK 
Settings will be adopted and the dialog closes. 
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Apply 
Settings will be adopted and the dialog closes. Regenerate will start. 
 
 

Text to Attribute Conversion 
 

 Toolbar: Regeneration  
 

Menu: Vectorize ► Text to Attributes 
 

CMD: VPTEXTTOATTRIB /l <Layer> /a <Attribute> /t <Text> [/d] 

Converts text inside of polygons to attributes and assigns them to the polygon elements. Thus, 
the drawing must contain Attribute Definitions. 
 

Command line: 
/l <Layer> Assign attributes to polygons from this layer 
/a <Attribute> Attribute Definition to use 
/t <Text> Use text from this layer 
/d  Delete assigned text (default: no)  
 
 
If no command line is specified this dialog pops up: 
 

 
 

Assign attributes to polygons from layer 
Specifies the polygons‘ layer attributes will be assigned to. Only layers with Attribute Definitions 
can be selected. 
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Attribute 
An Attribute Definition of the polygon layer. Text will be converted according to this Attribute 
Definition. 
 

Use text from layer 
Specifies the layer of text elements. Residing text will be converted to attributes. 
 

Delete assigned text 
When switched on all treated text will be deleted after the conversion. 

 

  
 

Transform   
 

 Toolbar: Transform 
 

Menu: Vector ► Transform to 
 

CMD: VPTRANSFORMTO [/l|Line <value>] [/p|Polyline <value>] [/mp|MPolyline <value>]  
 [/s|Spline <value>] [/a|Arc <value>] [/c|Circle <value>] [/ea|Elliptical Arc <value>]  
 [/e|Ellipse <value>] [/pn|Polygon <value>] [/pt|Point <value>] [/blk|Block <value>] [/mt|MText] 

Use this function to change the type of entities or to adjust lines orthogonally; e.g. convert all 
selected polylines of a drawing into "splines", or align entities of type "line" vertically and 
horizontally. You can also convert curved entities (arcs, circles, ellipses, and splines) to a set of 
lines. 
 

Command line: 
/l <value> Transform Line 
/p <value> Transform Polyline 
/mp <value> Transform MPolyline 
/s <value> Transform Spline 
/a <value> Transform Arc 
/c <value> Transform Circle 
/ea <value> Transform Elliptical Arc 
/e <value> Transform Ellipse 
/pn <value> Transform Polygon 
/pt <value> Transform Point 
/blk <value> Transform Block 
/mt  Transform MText [0|1] to Text 
Other available target types: ol|Ortho Line, ls|Linesegments 
 
Specify as <value> the desired target entity type E.g. the command 

vptransformto /p ls 
 transforms all polylines to line segments. Not all combinations are valid. 
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If no command line is specified, a dialog box opens for setting up the parameters: 
 

 
 
You can apply the transformation to the currently selected entities or to all vector entities in the 
drawing by changing the Mode. 
 
The Transformation Settings show a table with the presently existing entity types in the drawing 
(From) and their target type (To) for the transformation. The green check mark on the left 
indicates that this entity type will be transformed. You can deactivate the transformation of types 
by clicking in the far left table column. 
 
The target type (To) of the highlighted entity type can be changed by clicking on the desired type 
in the list on the right. If Show all Types is on you can review and modify the transformation 
settings for all entity types – even of those currently not present in the drawing. These settings will 
be kept when the program is closed. Thus, you can create a global transformation list for future 
tasks. 
 
Please note the following limitations: 

• points can only be transformed to blocks 
• blocks can only be transformed to points 
• MText can only be transformed to text 

 
When double-clicking the destination type Ortho Line or Block, the according settings dialog 
pops-up (see below). 
 
By default the target types and the original entity types are identical. 
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Advanced Settings - Curves 
 

 
 

Accuracy 
Circle, arcs, splines, and ellipses will be exploded into short line segments. These will form the 
new combined element. Tolerance refers to the maximum distance of the line segments to the 
original curve.  
 
Lower tolerance values will result in an increased accuracy, however, will also create more line 
segments. 

Default: 0.50 User Units 
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Advanced Settings – Lines 
 

 
 

Ortho Lines 
For the target type Ortho Line only. When Adjust all lines is switched on all lines will be set to 
0° and/or 90° reference angle positions. When Adjust only lines with a deviation smaller than 
is switched on only lines according to the given deviation value will be included. 

Default: No Transformation 
 
 

Advanced Settings - Block 
 

 
 
For the target type Block you can specify the block definition. If this block definition also has 
attribute definitions, the new blocks will get attributes with default values. 
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If a block definition was selected on a previous run, and this block definition is not available in the 
current document, than the selection is empty. In this case, import the desired block definition to 
the document, select another entry, or do not use block as target type. 
 

Properties 
The new Blocks will be inserted with the following properties. 
 
Offset: The block will be inserted at the center point (insertion point) of the object to be replaced. 

You can specify an Offset to this point.  

Default: X = 0.0, Y = 0.0 
 
Scaling: The block will be inserted with the specified scaling. To enter different values for X and 

Y you have to uncheck Isotropic.  

Default: X = 1.0, Y = 1.0 
 
Rotation: The block will be inserted with the specified angle.  

Default: 0.0 
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Assign Elevation   
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Assign Elevation 
 

CMD: VPASSIGNELEVATION ► Dialog 

A dialog box opens for setting up the elevation assignment procedure: 
 

 
 

General 
 
Enter the Step Size, i.e. the increment of altitude steps referring to your drawing/map.  

Default: 100.00 
 

Keep Modified Color {on/off} 
If checked on the polylines keep their new color after termination of the assignment process. 

Default: off 
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Color Settings 
Allows defining the new color assigned to any polyline which has been processed (i.e. has been 
assigned an elevation): 
 

 
 
For example: the color of all red polylines is changed to dark red after processing. This way it is 
easy to see which polylines have already been modified.  
 
Change Color allows to assign any other color to a base color (usually the layer color). 
 
 

Automatic Mode 
 
In this mode the elevation will be assigned automatically to the selected polylines. It is assumed 
that all contour lines have a common altitude difference (step size) between 2 contour lines 
(polylines). Therefore, you need to select some neighboring contour lines with a crossing line and 
define the start elevation and a mode (increasing or decreasing). With Assign all selected 
contour lines receive their corresponding elevation and the new color, too (to indicate the 
modification). 
 

Start Elevation 
Enter the value of the start elevation for the contour line crossed first during selection. 

Default: 0.0 
 

Mode 
The mode allows for selecting whether the start elevation should increase or decrease along the 
selection line. 
 

Stop and Show Each Polyline 
The process will stop after assigning the new altitude to any polyline for control reasons. 
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Select 
Select polylines by drawing a line across. All intersected polylines will be selected.  
 

Clear 
Resets a selection. 
 

Assign 
Assigns a new elevation to the selected polylines depending on the settings (ascending / 
descending). The elevation of a polyline can be reviewed using tooltips. 
 
 

Manual Mode 
 
The manual mode allows to individually assign an elevation to a selected contour line. Select the 
desired polyline. The following menu opens and shows the actual elevation of the selected 
polyline in the first line: 
 

 
 
You may pick a neighborhood reference elevation if available and add or subtract the assigned 
step size. 

Selecting Edit and Assign Elevation opens a dialog to enter the new elevation: 
 

  
 
With End Manual Assignment you return to the main dialog. 
 
 

Close 
 
Terminates the assignment process. If not otherwise confirmed all modified contours receive their 
original color back and the dialog closes. 
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Check Elevation  
 

 Toolbar: Edit Vectors 
 

Menu: Vector ► Edit ► Check Elevation 
 

CMD: VPCHECKELEVATION ► Dialog 
 
A dialog box opens for checking and setting elevation values: 
 

 
 
The areas on the right and at the bottom display the cross-section profiles of the elevation model 
at the current position of the crosshair. The right area displays the vertical cross-section, while 
and the bottom area displays the horizontal cross-section. 
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With the zoom buttons at the top of the dialog you can check the elevation model in more detail: 
 

 Zoom In. 

 Zoom Out. 

 Zoom Window allows for selecting a rectangular image area to zoom in. 

 Zoom 1:1. Click the desired center of the view with the left mouse button to zoom in. Then, 
the cursor changes back to  crosshair. 

 Zoom Extents shows the entire image in the preview window. This is the default view. The 
raster and vector entities can be switched on and off: 

 

 View Raster shows the raster image in the dialog when on. 

 View Vectors shows the vector entities in the dialog when on. 
 
Moving the crosshair over a contour shows its elevation in a tool tip. Double clicking modifies the 
elevation of a contour. The Edit / Assign Elevation dialog opens. 
 
 

Divide Polygon  
 

Divide By Line 
 

 Toolbar: Divide Polygon 
 

Menu: Vector ► Divide Polygon ► By Line  
 

CMD: VPDIVLINE 
 
Divides a polygon into two single polygon objects by drawing a boundary line.  
 
Select a polygon object first. Then draw a polyline: the polygon will be divided alongside the 
boundary polyline. Make sure to only divide into two parts. 
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Divide By Offset 
 

 Toolbar: Divide Polygon 
 

Menu: Vector ► Divide Polygon ► By Offset 
 

CMD: VPDIVOFFSET 
 
Divides a polygon into two single polygon objects. The boundary line will be defined according to 
the distance to the polygon’s border.  
 
Select a polygon object first. Then click on the polygon’s border - a boundary line parallel to the 
selected border will appear. You can move the boundary line with your mouse, or you can enter a 
fix distance value in the command line.  
 
 

Divide By Ratio 
 

 Toolbar: Divide Polygon 
 

Menu: Vector ► Divide Polygon ► By Ratio 
 

CMD: VPDIVRATIO 
 
Divides a polygon into two single polygon objects by entering a ratio value related to the surface 
area. 
 
Select a polygon object first. Then click on the polygon’s border-  a boundary line parallel to the 
selected border will appear. Enter a ratio value in the command line; e.g. „50“ will result  in two 
polygon objects with an equal surface area. 
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SECTION 10   
DIMENSIONS   

 

General Information  
 
VP software offers extensive features to create dimension in your drawings - for both vector and 
raster. By adapting individual dimension styles you can generate CAD-style dimensions in up-to-
date standards. 
In general, dimensions are created in the Active Layer with the Active Dimension Style. 
 

 
 

Dimension Modes  
 
To create dimensions four different modes can be selected by turning the switches Manual Mode 
and Text Mode on or off. These modes may be changed at user’s discretion while a dimension 
function is active. 
 
 

Manual Mode {on/off} (only Windows) 
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Manual Mode 
 

CMD: VPDIMMANUAL  

If set to on the origin points of the dimension are set manually. Otherwise, an entity (raster or 
vector) has to be selected to create a dimension. Then, the origin points are defined by the 
geometry of the selected entity. 

Default: off 
 
 

Text Mode {on/off} (only Windows)  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Text Mode 
 

CMD: VPDIMTEXT  

If set to on the user may enter or modify dimension text when creating a new dimension. 
Otherwise, the measurement figure of the drawing is used as text. The text properties symbolize 
the measurement figure with “<>“.  
In addition, the dimension text may be extended by the dimension type (e.g. “R“ for radial) or style 
(e.g. tolerances). 

Default: off 
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Dimension Style    
 
Dimension Style Manager  

 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Dimension Style 
 

CMD: VPDIMSTYLE 
 

CAD: _dimstyle 

The following dialog opens: 
 

 
 
All currently available dimension styles are displayed. 
 
 

Active 
 

 After selecting a dimension style from the list it can be defined as the active 
dimension style by clicking Active. You may also change the selection at any time using the 
dimension style selection box from the toolbar. 
 
 

New 
 
A new dimension style can be created with New. The following dialog opens: 
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New Name: 
Enter the desired name for the new dimension style. 
 
 

Begin with 
Choose whether the new dimension style should be preset with the Default Settings or with the 
properties of an existing dimension style. 
 
 

Next 
Click Next to proceed with the creation of the new dimension style. The dialog Dimension Style 
opens (see below) to define the properties of the new dimension style. 
 
After closing the dialog with OK the newly created dimension style is added to the list of available 
dimension styles in the Dimension Style Manager where it can be set to active.  
 
 

Cancel 
No new dimension style will be created. 
 
 

Modify 
 
The Dimension Style dialog opens (see below) for modifications of the dimension style 
properties. 
 

Delete 
 
The selected dimension style will be deleted. A respective message appears in case this style is 
already used in the current document, or if this style is the currently active dimension style. 
 

OK / Cancel 
 
OK closes the Dimension Style Manager and accepts all modifications. Cancel discards all 
modifications. 
 
 

Dimension Style Properties 
 
This dialog allows for modifications of the dimension style selected in the Dimension Style 
Manager. 
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Tab Lines  
 

 
 

Baseline distance

Extension lines

Dimension lines

Offset from origin

Arrow size

 Extend beyond dimension line

 
 

Dimension Lines 
Color Select the desired color for the dimension line and the arrow heads (arrow 

or line) from the list. 
Default: White 

Linewidth Select the line width for the dimension line. 
Default: 0.00 [mm] 

Baseline Distance Enter the distance between two dimension lines in the dimension type 
Baseline Dimension. 
Default: 3.75 [mm] 
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Draw dim line between ext lines  
 Valid for radial and diameter dimensions. Extents the dimension line to 

the center of the arc, or to the opposite side of the circle. 

Default: on 
 

Extension Lines 
Color Select the desired color for the extension lines from the list. 

Default: White 
 
Linewidth Select the line width for the extension lines. 

Default: 0.00 [mm] 
 
Extend beyond dim lines Specify how much the extension lines should protrude the dimension 

lines. 
Default: 1.25 [mm] 

 
Offset from origin Specify the distance to offset the extension lines from the origin points that 

define the dimension. 
Default: 0.63 [mm] 

 
 

Tab Arrows 
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Arrowheads 
Select the shape of arrowheads from a list of predefined symbols. 

First First (left) arrowhead 
Default: Closed filled 

Second Second (right) arrowhead 
Default: Closed filled 

Leader Arrowhead of leader  
Default: Closed filled 

Arrow Size Specify the length of the arrow or oblique tick. 
Default: 2.5 [mm] 

 
User defined symbols can also be used. To do so, create first a block definition (or import it from 
a library). Then, click in the list on Others… to open the selection dialog.  

 

 In order for the block to fit to the dimension entity, its size must be adjusted to a width and 
height of 1.0. 
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Tab Text 
 

 
 

Placement:
At extension line 1,

Above

Dimension text

Text Height

Offset from
dimension line

Placement:
Centered,
Centered

Placement:
At extension line 2,

Outside

 
 
 

Text Appearance 
Text Style Select the desired text style for the dimension text from the list (see Text Style, 

Chapter 4). 

Default: Text 
 
Text Color Select the desired text color for dimension text from the list. 

Default: White 
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Text Height Specifies the desired text height for dimension text. 

Default 2.50[mm] 
 
 

Text Placement 
Vertical Specifies the position of the dimension text on the dimension line. Choose between 

Centered, Above, or Outside. 

Default: Above 
 
Horizontal Specifies the position of the dimension text along the dimension line. Choose 

between Centered, At Ext Line 1, or At Ext Line 2. 

Default: Centered 
 
 
Offset from Dim Line 

Specifies the distance of the dimension text from the dimension line when Above 
or Outside is selected for the horizontal text position. 

Default: 0.63 [mm] 
 

Text Alignment 
Horizontal The dimension text is always horizontal. 
 
Align with dimension line  

The dimension text is parallel to the dimension line. 

Default: Align with dimension line 
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Tab Primary Units 
 
The following settings are only valid when the dimension text is to show the actual measurement 
figure, i.e. the text contains “<>”. Otherwise, the dimension text will be displayed as entered. 
 

 
 

Linear Dimensions 
Precision Choose the number of decimal places in dimension text from the list. 

Default: 0.00 
 

Decimal separator Choose between ‘.’Period, ‘,’Comma and ‘ ‘Space as separator  for 
the decimal format. 

Default: '.'Period 
 

Round off The step size for rounding the dimension text, e.g. at a value of 0.25 the 
dimension text 10.73 is rounded off to 10.75. 

Default: 0.00 (no round off) 
 

Zero Suppression 
Leading {on/off} If set to on a dimension text with a value less than 1 starts with the 

decimal separator (e.g. 0.50 => .50). 

Default: on 
 

Trailing {on/off} If set to on all trailing zeros of a dimension text are suppressed. 

Default: on 
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Tab Tolerances 
 

 
 

No Tolerance

Symmetrical
Tolerance

Deviation
Tolerance

Limits

Basic Tolerance

 
 

Tolerance Format 
Method Choose between the tolerance methods None, Symmetrical, 

Deviation, Limits and Basic from the list. 
Default: None 

Precision Choose the number of decimal places for tolerance values from the list. 
Default: 0.0000 

Upper Value Specifies the value for the deviation with method Symmetrical or the 
upper value for methods Deviation and Limits. 
Default: 0.00 
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Lower Value Specifies the lower tolerance value for methods Deviation and Limits. 

Default: 0.00 
 
Scaling of height Specifies a scale factor for text heights. This value is multiplied with the 

dimension text height to define the text height for tolerance values. 

Default: 1.0 
 
 

Zero Suppression 
Leading {on/off} If set to on a dimension text with a value less than 1 starts with the 

decimal separator (e.g. 0.050 => .050). 

Default: on 
 

Trailing {on/off} If set to on all trailing zeros of a dimension text are suppressed. 

Default: on 
 
 

Transfer to Current Dimension Style (only Windows) 
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Transfer to Current Dimension Style 
 

CMD: VPSHIFTDIMSTYLE <NAME> 
 
Selected dimensions are transferred to the current or specified dimension style. 
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Dimension Types   
 

Linear Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Linear 
 

CMD: VPDIMLINEAR 
 

CAD: _dimlinear 
 
The dimension line is always horizontal or vertical. The extension lines may possess different 
lengths. 
 
At first the origin of the two extension lines (and with that the length of the dimension line) is 
determined. Either select the entity to dimension (line, arc, circle, or polyline segment) or -only in 
Manual Mode - specify the origin of the first and second extension line. 
 
The dimension line is now moveable in order to set the extension lines’ lengths. Specify the 
position of the dimension line by mouse click or enter the coordinates at the command line. The 
dimension will be added to the drawing. 
 
In Text Mode the dialog for entering the dimension text is displayed after specifying the origin of 
the extension lines. 
 
 

Aligned Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Aligned 
 

CMD: VPDIMALIGNED 
 

CAD: _dimaligned 
 
The dimension line is parallel to the entity. Therefore, the extension lines always possess the 
same length. 
 
At first the origin of the two extension lines (and with that the length of the dimension line) is 
determined. Either select the entity to dimension (line, arc, circle, or polyline segment) or -only in 
Manual Mode - specify the origins of the first and second extension line. 
 
The dimension is now moveable in order to set the extension lines’ lengths. Specify the position 
of the dimension line by mouse click or enter the coordinates at the command line. The dimension 
will be added to the drawing. 
 
In Text Mode the dialog for entering the dimension text is displayed after specifying the origin of 
the extension lines. 
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Radial Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Radius 
 

CMD: VPDIMRADIUS 
 

CAD: _dimradius 
 
At first the value of the radius is determined. Select the entity to dimension (arc or circle). Now, 
the dimension line can be rotated around the center. At the same time, specify the position of the 
dimension text and angle of the dimension line by mouse click or enter the coordinates at the 
command line. The dimension will be added. 
 
In Manual Mode specify two points for center and length (angle included in this) by mouse click 
or at the command line. Now, position the dimension text with a third point. The dimension will be 
added. 
 
In Text Mode the dialog for entering the dimension text is displayed after specifying the radius 
value. 
 
 

Diameter Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Diameter 
 

CMD: VPDIMDIAMETER 
 

CAD: _dimdiameter 
 
At first the value of the diameter is determined. Select the entity to dimension (arc or circle). 
Now, the dimension line can be rotated around the center. At the same time specify the position 
of the dimension text and angle of the dimension line by mouse click or enter the coordinates at 
the command line. The dimension will be added. 
 
In Manual Mode specify two points for start and end point of the diameter (angle included in this) 
by mouse click or at the command line. Now, position the dimension text with a third point. The 
dimension will be added to the drawing. 
 
In Text Mode the dialog for entering the dimension text is displayed after specifying the diameter 
value. 
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Angular Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Angular 
 

CMD: VPDIMANGULAR 
 

CAD: _dimangular 
 
Specifies the dimension of the angle between two lines, an arc, or of a circle segment. 
 
 

Angle between two lines: 
Select two lines. The dimension line arc is attached to the cursor to specify its position and the 
extension lines’ lengths. A mouse click adds the dimension to the drawing. 
 
 

Angle of a circle segment: 
Select a circle. The click position of the selection also determines the start of the segment and the 
origin of the first extension line. Specify the end of the segment and the origin of the second 
extension line by clicking again. Now, the dimension line arc is attached to the cursor to specify 
the extension lines’ lengths and the position of the dimension line arc. Clicking the left mouse 
button adds the dimension to the drawing. 
 
 

Angle of an arc: 
Select an arc. Now, the dimension is attached to the cursor to specify the extension lines’ lengths 
and the position of the dimension line arc Clicking the left mouse button adds the dimension to 
the drawing. 
 
 

Manual Mode 
The first point sets the center. The second and third points define the start and end points of the 
dimension line arc together with the origins of the extension lines. Specify the extension lines’ 
lengths and the position of the dimension line arc with the fourth point.  
 
In Text Mode the dialog for entering the dimension text is displayed after specifying the angle. 
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Continue Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Continue 
 

CMD: VPDIMCONTINUE 
 

CAD: _dimcontinue 
 
Continue the dimension from the second extension line of the previous dimension. In Manual 
Mode the dimension to continue has to be selected first. Only the dimension types Linear, 
Aligned, and Angular can be continued. The length of the new dimension line is specified by 
mouse click or by entering the coordinates at the command line. The dimension is added to the 
drawing and may be continued. 
 
Exit the function by clicking the respective icon again or by hitting [Esc]. 
 
In Text Mode the dialog for entering the dimension text is displayed after specifying the 
dimension line. 
 
 

Baseline Dimension  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Baseline 
 

CMD: VPDIMBASELINE 
 

CAD: _dimbaseline 
 
Above the previously inserted dimension an additional dimension of the same type is added. In 
Manual Mode the dimension has to be selected first. Only the dimension types Linear, Aligned, 
and Angular can be used for this function. The distance between the dimension lines is defined 
by the specified Baseline Distance in the Dimension Style. The length of the new dimension 
line is specified by mouse click or by entering the coordinates at the command line. The 
dimension is added to the drawing and an additional dimension may be entered. 
 
Exit the function by clicking the respective icons again or by hitting [Esc]. 
 
In Text Mode the dialog for entering the dimension text is displayed before specifying the 
dimension line. 
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Leader  
 

 Toolbar: Dimension 
 

Menu: Vector ► Dimensions ► Leader 
 

CMD: VPLEADER 
 

CAD: _leader 
 
Insert a new Leader by specifying the start point and the end point. Like in Text Mode a dialog 
pops up to enter the desired leader text. 
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SECTION 11   
TABLE RECOGNITION   

 

General Information   
 
The Table Recognition offers you enhanced functions to modify text tables in raster files: adjust 
the content and the shape of an existing table to adapt it to your requirements. Additionally, you 
can convert tables into vector format and export it to other applications. 
 
The Table Recognition can be applied to b/w images as well as to gray scale or colored images. 
 
 

Table Recognition  
 

 Toolbar: Table Recognition 
 

Menu: Vectorize, Function: Table Recognition  
 

CMD: VPTABLEREC ► Dialog 
CMD: VPTABLEREC /f|Filter <Filter Name> /o|Options <Filter Options> [/q] <x1> <y1>  
 <x2> <y2>  

After starting the function without command line parameters, the table needs to be selected. Draw 
a rectangle around the table region. If you are working on a gray scale or colored image the 
active color has to be specified first (see chapter 4: Image Settings). 
 
Then, the following dialog appears: 
 

  
 
The upper area displays the original raster for control purposes, while in the lower area you can 
modify the recognized table interactively. 
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Output settings 
 
These settings determine in which way the modified table will be inserted into the document. 

Rasterize Table: deletes the original table and replaces it with the modified table. 
Make Vector Table: converts the modified table into vectors. 
Only Text Output: only the text is transferred, the lines of the table are deleted. 
Erase Original Raster: the original table will be erased. 
 
If the original table in the raster image shall be erased (Rasterize Table or Make Vector Table 
with option Erase Original Raster switched on) a colored rectangle is shown in the upper area of 
the dialog. You can move the border lines of the rectangle to change its size. 
 
 

Content of table / Text 
 
To create or modify text click into a cell - a blinking cursor appears identifying this cell as the 
active cell. The active cell is also marked in the raster table in the upper area. 
 
The Table Recognition is operating "line based", i.e. when modifying the text format this will 
always affect the entire line (of a cell) indicated by the blinking cursor (active line). Select multiple 
lines to modify more than one line. 

 A text must fit completely into a cell and in between the set indents. Formatting or changing 
text with non-fitting sizes will be stopped automatically. A warning message will appear in 
the status bar of the dialog. Right-click on the status bar to open a context menu with the 
warning settings. 

 
Textstyle 

Change the textstyle to modify the display of text. For more information see CAD-Options below.  
 

Indent 
With the indent markers you can set horizontal and vertical indents: 

  
The indent shown refers to the active line. If multiple lines are selected the minimal indents of all 
lines are shown. Changes are applied to the active line / selected lines.  
 
If you have selected multiple lines in one column the new indents will be assigned to all lines. 
Selected lines in more than one column are modified individually so that the indents of each line 
are changed by the same factor. 
 
Text in the selected lines will be re-adjusted. 
 

Line Distance 
The line distance of the active line is displayed. There is no display when multiple lines with 
different line distances are selected. Changes are applied to the active line / selected lines. 
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Text Height 
The text height of the active line is displayed. There is no display if multiple lines with different text 
heights are selected. Changes are applied to the active line / selected lines. 
 

Adjust Text 

   The horizontal adjustment of the active line is displayed. There is no display if multiple 
lines with different settings are selected. Changes are applied to the active line / selected lines.  
 

   The vertical adjustment of the active line is displayed. There is no display if multiple 
lines with different settings are selected. Changes are applied to the active line / selected lines. 
 
The adjustment refers to the indent markers. 
 

Cut, Copy, Paste  

   Use these functions to cut or copy text and to paste it to different locations. Formatting 
options at the insertion point will be applied to the new text. 
 
 

CAD Options 
 
These options are necessary only if a table shall be converted to vectors (except: Textstyle). The 
default setting for all text is the Active Textstyle, the Active Layer, and the Active Color. 
 

Textstyle 
The textstyle of the active line is displayed. To change the textstyle choose an entry from the list 
or select Other... to open the Textstyle Manager (see chapter 4: Textstyle Manager). 
 

Layer 
The layer of the active line is displayed. To change the layer, choose an entry from the list, or 
select Other... to open the Layer Manager (see chapter 4: Layer Manager). 
 

Color 
The color of the active line is displayed. To change the color choose an entry from the list. 
 

OCR Options (Text recognition) 

Initially, the whole table is recognized with the Global OCR Settings. Use the cell selectors  

 (see below) to select a row/column of cells. Select a different OCR setting from the list to 
apply these settings to the selected cells. With Re-Recognize the selected are recognized again 
with the new settings. 
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Predefined settings are: 

Global OCR Settings: The currently specified OCR settings (can be changed with Options – 
OCR Settings, see Chapter 4). 
Only Letters: All letters, but no numbers (digits) are recognized.  
Only Numbers: Only numbers are recognized. 

Default: Global OCR Settings 

 New settings . After specifying a name the dialog for the OCR Settings will show up. 

 Modify: Opens the dialog for the OCR Settings to modify the selects settings. 

 Delete the selected settings. 
 

Re-Recognize 
The currently selected cells are recognized again with the OCR settings assigned to them. 
 
 

Shape of Table / Cells 
 
Use the following functions to modify the shape of the table. Cells, rows, or columns may be 
resized, added, or erased. 

 If you are going resize a table do not forget to resize the erase rectangle in the upper area, 
too. 

 While cells are modified text cannot be selected or modified. 
 

Display original raster in the lower area 

 The selected raster table is displayed in the lower area for checking purposes. 
 

Select cells 

  Click into a cell to select a complete row or column. 
 
Create cells 

 Create new cells by drawing border lines in the lower area. The new lines are snapped to 
existing border lines. 

 
Delete cells 

 Delete cells by removing their border lines. Click on the line to be removed or window-select 
multiple lines. Only empty cells can be deleted. 
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Adjust cell size 

  Applies the same width or height to all selected cells. The average value of widths and 
heights will be used. 

 
Resize cells 

 Resize cells by moving their border lines. 
 
 

Copy raster structures 
 

 The Table Recognition function will only create lines and texts automatically. If your table 
contains other raster structures (e.g. images, logos) which you would like to keep in the new table 
then use this function to copy these structures. Start the function and draw a rectangle around the 
desired raster structure in the upper area. It will copy the raster selection into the lower area. Use 
the mouse for correct positioning.  
 
 

Export 
 
A dialog pops up to select one of the available database export modules. 

 

 The export can only work if the table is homogeneous, i.e. the number of cells in each row 
must be identical. Otherwise an error message appears. 
 
 

Finish the Table Recognition 
 
Click Ok to close the dialog. According to the Output Settings the new table will be inserted into 
the raster file or converted in vectors. Cancel will discard all changes. 
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Fast Table Recognition with Export 
 
For fast table recognition with subsequent export, the command can be started with command 
line parameters. This method allows a table to be recognized and exported with little interaction 
(see also Export above). 
 

Required Parameters 
Filter name (/f): Name of the database export module. 

Filter options (/o): Options for the database export module (see below). 
 

Optional Parameters 
No Dialogs (/q): With this parameter no dialogs are displayed during the execution of the 

command. 

Position of the table (x1 y1 x2 y2): Coordinates of the area on which the table recognition is to 
be performed. 

 
Creating the Filter Options using the Script Generator 

Start the script generator (menu File ► Create Script...). Double-click  VPTABLEREC in the 
list Available Commands - the command will be added to the Selected Commands list and the 
corresponding options will be displayed. 
 
Select a Filter in the options on the right. Then, click on the small button in the Options field to 
open the corresponding filter options dialog. Now you can make the desired settings. When you 
close the dialog, the filter options are displayed as a text string. This string can be copied and 
used as command line parameter. 
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SECTION 12   
INTERACTIVE TRACING   

 

General Information   
 
The trace functions allow for interactive raster-to-vector conversion. 
 
The active raster file should be cleaned or corrected before proceeding. Depending on the type of 
original, the CAD Trace function can be used to generate CAD elements, such as lines, circles or 
arcs, typical for technical drawings. The Contour Trace function creates polylines and offers a 
conversion into splines, preferably for GIS applications. On drawings that contain intersecting 
contours the function Interactive Trace is useful to create connected polylines or splines with 
maximum control: at each intersection the user can decide on the direction to continue the 
contour. 
 
Tracing is also provided for color and grayscale raster data. Their interpretation will refer to the 
settings definitions in Image Settings (see Section 4).  
 
The traced raster elements can be erased automatically from the raster image by using the option 
Erase Raster Background (see below). 
 
 

 Trace Settings   
 

 Toolbar: Tracing 
 

Menu: Vectorize ► Trace Settings 
 

CMD: VPTRACESETTINGS 

A dialog box opens to define the trace settings for Contour Trace and Interactive Trace. 
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General Tab 
 

 
 

Straightening 
The parameter Straightening defines how precise the trace process follows a raster line. 
Medium or High reduces the number of vertices significantly. However, it also reduces the 
precision of the line following process. The highest precision (especially when tracing contour 
lines) is achieved by setting straightening to None and selecting Exact in the Image Settings 
dialog. Hence, these settings will generate significantly more vertices in polylines. 

Default: Weak 
 

Remove Artifacts {on/off} 
When Remove Artifacts is activated, short line segments or line spurs ("artifacts") are 
automatically removed, which otherwise would lead to unwanted trace results. The size of these 
artifacts can be entered via keyboard or measured using the [F2] key. 

Default: off 
Default value: 1[mm] or 0.04[inch] 
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Gap Jump {on/off} 
Small interruptions in the raster image, very often due to faded and old originals, will be closed 
automatically up to a reasonable distance.  

 If the value is set too high neighboring contours may be connected unintentionally! 

Default: off 
Default value: 0.1[mm] or 0.004[inch] 
 
 

Assign Raster Width to Contour {on/off} 
The width of the underlying raster will be assigned to the traced entity. Otherwise, the active Pen 
Width is used.  

Default: on 
 
 

Contour/Interactive Trace Tab 
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Stop at Intersections {on/off} 
The line following process will stop at each crossing/intersection. Otherwise, the most probable 
direction will be taken and the line following process continues. 

Default: off 
 

Assign Elevation {on/off} 
After tracing a polyline or spline you are prompted for an elevation value. The tracing process 
attempts to find elevation numbering information that interrupts the contour. If successful, the 
elevation is presented in the dialog as the default value and the contour is continued across the 
gap. In the Interactive Trace mode the gap will not be closed automatically. The [Shift] key can 
be used to append the continuation to the traced contour. This way you can create 3D models of 
a contour map for other applications.  

Default: off 

For reviewing the elevation model use the function Check Elevation. 

 Since VP software can only display 2D entities you will not see this additional spatial 
information. Instead, load the data into a CAD system capable of displaying three- 
dimensional vector data.  

 
Append Mode {on/off} 

After tracing a polyline or spline a dashed line between the cursor and the end of the trace entity 
appears. It indicates that the element traced next will be appended. For example, if you have 
broken raster lines this option allows for an easy combination of traced elements. 
 
Holding down the [Shift] key interrupts this mode to start a new line. 
 
If Pan to Entity End is on, the system pans to the nearest end of the last traced contour line 
automatically. This will help to find the next line to continue with. 

Default: off 
 
Instead of activating the permanent Append Mode you may also press the [Shift] key whenever 
you want to append a new element to the previous one. This intermediate append status will be 
indicated by a "+" sign at the trace cursor. 
 

Produce Splines {on/off} 
Generates splines instead of polylines. 

Default: off 

 The program can generate splines with an arbitrary number of vertices. However, not all 
CAD programs are able to process splines with a large number of vertices. 
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Trace Dashed Lines {on/off} 
For tracing dashed contours activate this option and enter a representative Max. Dash Length 
and a Max. Gap Length. For best results use the [F2] key and measure the correct values from 
the drawing. Increase the Tolerance value if the tracing process leaves out dashes. 

Default Tolerance: 50.0% 
 
 

Additional Interactive Trace Tools 
 

Show Zoom Window {on/off} 
A small window shows a detailed view of the intersection and the possible directions as green 
(most probable and therefore preferred direction) and red (optional) arrows. 

Default: on 
 

Confirm Contour {on/off} 
When reaching the end of a contour the cursor changes to the OK? symbol for confirmation or 
modification. Click the left mouse button to accept the contour result or use Back from the context 
menu to go one trace step back. 

Default: off 
 

Stop at Closed Contours {on/off} 
Tracing will stop when the contour forms a closed loop. 

Default: off 
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Polygon Trace Tab  
 

 
 
 

Object Creation 
 
Choose between Closed Polylines and Polygons. Clicking the Setup button allows for defining 
the hatch style for polygons: 
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Hatch Style 
Select a hatch style defining the fill pattern. 
 
Depending on the selected style the fields Opacity, Scale, Angle, and Spacing are available for 
editing. There are three predefined Hatch Styles: 
 

SOLID the edit field Opacity is available for entering a value in the range 0-100% 
LINES the edit fields Angle and Spacing are available for specifying the 

appearance of the line based fill pattern. 
CROSSHATCH the edit fields Angle and Spacing are available for specifying the 

appearance of the crosshatched fill pattern. 
 

For all other Hatch Styles the edit fields Angle and Scale are available to rotate or 
stretch/squeeze the fill pattern. 

Default: SOLID 
Opacity: 50% 
Scale: 1.0 
Angle: 45° 
Spacing: 1 
 

Draw Border 
If on the borderlines of the polygon will be displayed. The elements line width will be used.  

Default: on 
 

Border Color 
If on the borderlines will be displayed in the selected color. Otherwise the elements color will be 
used. 

Default: off 
Default: By Layer 
 
 

Switch to Draw Mode on Failure 
 
If the trace algorithm is unable to find a closed contour you have the choice to switch into manual 
draw mode Always, Never, or with Ask me decide to switch after a message comes up.  
 
The system offers you a closed polyline contour attached to the cursor with one vertex, allowing 
to manually enter additional vertices along the desired image contour in order to complete the 
tracing. The green line to the cursor indicates where to add the next vertex (next click). End with 
[Enter] or double click.  
 
A right mouse pop-up menu offers you additional editing features. 

Default: Always 
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Zoom-In on first Click {on/off} 
If set to on the program zooms in on the first mouse click while in drawing mode for a more 
precise positioning (with the second mouse click) of vertices.  

Default: off 
 

Use Raster Snap {on/off} 
If this option is set on the Raster Snap [F11] will be activated with its current settings when the 
software switches into draw mode. 

Default: off 
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Post Processing {on/off} 
 

Match Borders {on/off} 
The created polygons/polylines will be recalculated automatically according to their neighborhood 
distance at any one vertex to the closest vertex of other polygons/polylines. This ensures that 
contours of neighboring entities do not have gaps in between. Any vertex distance larger than this 
value will not be re-adjusted. 

Default: on 
Default Value: 0.3 [mm] 

 Always turn on this function if you want to generate gapless and none-overlapping adjoining 
areas. A good value for the distance of two vertices, which should be combined, is the width 
of the original raster borderline. 

 
Ignore Small Circles {on/off} 

If corners of an area are marked by small circles (e.g. indicating landmark measure points) with 
about the value of Diameter in the original raster image, the circle contour will be ignored. 
Instead, a single vertex will be generated in the center of each small circle. 

Default: off 
Default Value: 1.5 [mm] 
 

Create Orthogonal Polylines/Polygons {on/off} 
Within the value of Deviation the line segments of the polygon/polyline will be aligned 
orthogonally to each other. This option can also be switched on/off via the context menu at the 
time the polygon trace command is active. 

Default: off 
Default Value 5° 
 
 

Erase Raster Background   
 

 Toolbar: Raster Edit 
 

Menu: Edit ► Erase Raster Background 
 

CMD: VPERASERASTER 

To erase raster elements automatically while following the tracing routine, click the Erase Raster 
Background [Ctrl+E] icon prior to starting the tracing. All traced raster elements will be deleted 
from the raster image. 
 
With color or gray scale images the background will not be erased. Instead, the background 
pixels to be erased will be filled with the Background Color defined in Image Settings. 
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CAD Trace    
 

 Toolbar: Tracing 
 

Menu: Vectorize ► CAD Trace 
 

CMD: VPCADTRACE 

CAD trace allows to recognizing the CAD elements line, circle, and arc and assigning them to 
the current layer. Special CAD elements, such as ellipses, arrows, donuts, line types, small 
circles, hatches, or text can be drawn or combined from the traced data using the editors. (See 
Section 8 + 9). 

 After clicking the CAD Trace icon, a Needle and Thread cursor appears to directly click on 
the raster data for element tracing. Pressing the [Shift] key (adding a "+" sign to the cursor and 
displaying a dashed line to the traced element) links the last traced CAD element to the next one, 
while preserving the element type (line, arc, circle) of the element initially traced. Arcs covering an 
angle of close to 360° will be closed and converted to a circle automatically. 
 
Clicking the right mouse button opens the following context menu where you can force the system 
to recognize a particular element: 
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Contour Trace    
 

 Toolbar: Tracing 
 

Menu: Vectorize ► Contour Trace 
 

CMD: VPCONTOURTRACE 

Use this function to trace polylines or splines in the currently active layer.  

 Click with the Nail cursor on the raster line. The trace module runs from this point in both 
directions, until it reaches the end of the line or stops at an intersection where the directions of the 
branches do not meet the internal angle tolerance. 
 
Pressing the [Shift] key while clicking on the next raster line piece allows to continue the previous 
polyline. In this case, the Nail cursor appears with a "+" sign and a dashed display line is drawn to 
the traced contour. 
 
If you are in Append Mode, the cursor is linked by a dashed line to the end of the traced line and 
the next part will be appended automatically. Pressing the [Shift] key will interrupt the append 
mode and a new line can be traced, although the Append Mode still is active. 

 In order to add new vertices to a traced contour line at the current position press the [Ctrl] 
key. A "pin" cursor appears linked by a dashed line to the end of the traced contour. Clicking the 
left mouse button generates a new vertex at the click position, regardless if there is an active 
raster below. This allows for tracing across longer interruptions. From here, the tracing may 
continue. 
 
In Append Mode you can add vertices by just clicking into an area without an active raster, i.e. 
without using the [Ctrl] button. 
 
Clicking the right mouse button opens the context menu for editing as described below. 
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Contour Trace Edit Commands  
 
At any point during the contour tracing operation you may click the right mouse button to open the 
context menu. The editing commands interrupt the tracing, but they will not abort it. 
 

 
 

Edit Contour 
The command Edit Polyline/Spline is executed. The last created polyline can be edited now in 
many ways (e.g. extend, shorten, explode, ...). After the editing is concluded the contour trace 
command will continue.  
 
Refer to section Edit Polyline/Spline later in this chapter for an detailed description of the 
different functions. 
 

Change Branch 
 
Allows correcting the automatic routing of the trace function at junctions or crossings in the case 
that the auto tracing selected an unwanted direction. Just click onto the desired direction. This will 
result in an "Undo" of the tracing by returning to the junction where the correct (user selected) 
direction branches off. 
 

Close Polyline 
Closed the last created polyline. 
 

Cancel Menu 
The context menu is closed and the Contour Trace command is continued. 
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Interactive Trace    
 

 Toolbar: Tracing 
 

Menu: Vectorize ► Interactive Trace 
 

CMD: VPTRACEINTERACTIVE 

Use this function to trace polylines or splines in the currently active layer.  

 Click with the Nail cursor on the raster line. The trace module runs from this point in both 
directions, until it reaches the end of the line or stops at an intersection. At Intersections arrows 
appear for selecting the next tracing direction (if the option Show Zoom Window is switched on 
the arrows are also visible in the zoom window). Click on the respective arrow to continue the 
contour in the desired direction. When hitting the [Enter] key instead, the tracing follows the most 
probable direction indicated by a green arrow. 
 

 
 
In case it is not desired that the contour continues over branches use Stop Here from the context 
menu. The contour may be continued from the other end if there is a branch, too. 
 

Selecting Stop All creates a contour reflecting the current trace state – tracing will stop at both 
ends of a contour. 
 

Back returns to the last intersection. 
 
Pressing the [Shift] key while clicking on the next raster line segment allows to continue the 
previously created polyline/spline. In this case, the Nail cursor appears with a "+" sign and a 
dashed line is drawn from the cursor to the traced contour. 
 

If you are in Append Mode, the cursor is always linked by a dashed line to the end of the traced 
line and the next section will be appended automatically. Pressing the [Shift] key will interrupt the 
append mode and a new line can be traced, although the Append Mode remains active. 

 In order to add new vertices to a traced contour line at the current position press the [Ctrl] 
key. A "pin" cursor appears linked by a dashed line to the end of the traced contour. Clicking the 
left mouse button generates a new vertex at the click position, regardless if there is an active 
raster below. This allows for tracing across longer interruptions. From here, the tracing may 
continue. 
 

In Append Mode you can add vertices by just clicking into an area without an active raster, i.e. 
without using the [Ctrl] button. 
 

When tracing a contour, clicking the right mouse button opens the context menu for editing as 
described in section Contour Trace above. 
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Polygon Trace    
 

 Toolbar: Tracing 
 

Menu: Vectorize ► Polygon Trace 
 

CMD: VPPOLYGONTRACE 

Use this function to trace closed polylines/polygons in the current active layer.  

 Click with the Nail cursor inside an area and NEAR to a contour (border) line. The trace 
module runs from this point in both directions, until a closed contour is detected. Structures that 
lie completely inside this area (i.e. not touching the traced contour) will be ignored. According to 
your Trace Settings (see above) additional operations may take place. Use the right mouse 
button menu to edit the contour manually (see above). 
 
When pressing the [Shift] key the Nail cursor appears with a "+" sign and switches into the 
append mode. Now, clicking inside another area combines (if the second area is completely 
outside the first one) or excludes (if the second area lies inside the first one) this second area 
to/from the first one. 
 
 

Multi-Polygon Trace   
 

 Toolbar: Tracing 
 

Menu: Vectorize ► Multi-Polygon Trace 
 

CMD: VPMULTITRACE 

Use this function to trace closed polylines/polygons in the current active layer from raster 
structures which are divided into multiple portions (e.g. hatched areas). 

 The Nail cursor appears. Draw a line ACROSS all dividing lines (hatch lines). Finish your 
input with [Enter] or a double click. The generated polyline/polygon will include all areas which 
are touched by the construction line. According to your Trace Settings (see above) additional 
operations may take place. Use the right mouse button menu to edit the contour manually. 
 
When pressing the [Shift] key the Nail cursor appears with a "+" sign and switches into the 
append mode. Now, clicking inside another area combines (if the second area is completely 
outside the first one) or excludes (if the second area lies inside the first one) this second area 
to/from the first one.  
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Tracing Hatches 
 
A special extension enabled by the [CTRL] key allows both functions Polygon Trace and Multi-
Polygon Trace to automatically trace hatches and, thus, omitting the hatch lines during the trace 
process. 
 
Pressing the [CTRL] key and clicking ON one of the hatch lines generates a polygon of the 
whole area. Hatch lines will be ignored.  
 
Release the [CTRL] key and use the [Shift] key (append mode) to finish an uncompleted  
hatched area. Continue by clicking inside again NEAR a contour of one of the remaining hatch 
areas. 
 
 

Edit Polyline/Spline   
 

 Toolbar: Properties/Editing 
 

Menu: Vector ► Edit Polyline/Spline 
 

CMD: VPPEDIT 

Use this function to edit polylines, splines, and polygons. If no entity is selected upon execution of 
this function you are asked to select an entity for modification. The selected entity is displayed 
with moving grips at each vertex and the Edit Polyline/Spline/Polygon toolbar pops up. 
 

 
 
The initial mode is Append Vertices which lets you append vertices to the nearest end of the 
entity. If the entity is closed the Edit Mode will be activated instead. 
 
Clicking the right mouse button activates the edit contour menu which contains the same 
functions as the toolbar and additional zoom commands: 
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 Edit Vertices 
In this mode vertices can be moved (holding down the left mouse button and dragging), added, or 
removed ([Ctrl]+Click). End this function by selecting a different function from the toolbar or from 
the context menu. Leave the menu with End Command. 

 Cut 
Cuts a polyline/spline at the click position. The result will be two separate contour lines. A closed 
contour (closed polyline) can be opened using this command. End this function by selecting a 
different function from the toolbar or from the context menu. Leave the menu with End 
Command. 

 Append Vertices 
Adds vertices one by one at the current click point by joining it to the nearest end of the contour. 
A dashed line indicates on which end the vertex will be added. To append to the far end hold 
down the [Ctrl] key. End this function by selecting another function from the toolbar or context 
menu. Leave the menu with End Command. 

 Remove Previous Vertices 
Deletes vertices at the nearest line end. A dashed line indicates on which end of the contour the 
vertex will be removed. With each click one more vertex will be removed. To remove vertices from 
the far end hold down the [Ctrl] key. End this function by selecting another function from the 
toolbar or context menu. Leave the menu with End Command. 
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 Remove Vertices up to 
Deletes vertices at the nearest line end up to the vertex clicked. A dashed line indicates on which 
end of the contour the vertices will be removed. To remove vertices from the far end hold down 
the [Ctrl] key. End this function by selecting another function from the toolbar or context menu. 
Leave the menu with End Command. 

 Close Polyline/Spline 
Connects both ends of a contour with a line to form a closed contour. 

 Combine with Polyline 
The cursor switches to the selection mode. Select a polyline to combine it with the one, which is 
currently edited.  

 Multi Mode 
A Combination of Edit Vertices, Append Vertices and Combine with Polyline. 

 Explode Polyline 
Breaks a polyline into its line segments. The function Edit Polyline/Spline will be terminated. 

 Remove Area (for Polygons only) 
Excludes an area from a polygon. Click inside or on the outline of the area to remove it from the 
polygon. 

 Edit Next Entity 
Accept the changes and select the next entity to edit. 

 Undo  
Undo the last modification. 

 Redo  
Redo the last Undo operation. 

 End Command 
Use this command or hit [Enter] to leave the edit mode and confirm the modifications. 
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SECTION 13   
VECTORIZATION (RASTER-TO-VECTOR CONVERSION)  
    

General Information   
 
The automatic vectorization (raster-to-vector conversion) combines raster thinning and entity post 
processing into one operation. The vectorization process converts the Active Color of a raster 
file to vectors. The definition of the Active Color allows converting any type of raster data (b/w, 
gray scale, or color) into vectors: 

• With b/w raster data (bi-level) the foreground pixels are assigned as Active Color. No 
definition required. 

• With color or gray scale images use the function Image Settings to define a specific Active 
Color by selecting a color or a color pattern (See Section 4). Otherwise, an automatic 
binarization method will define the active foreground pixels. 

Parameter settings are used to determine the vectorization method, to define the area of the 
raster file to be converted, and to control the post processing. In order to obtain best conversion 
results, ensure that the raster data have been prepared properly (cleaned, adjusted, corrected) by 
using the raster file editing tools. 
 
The Vectorization Wizard supports a proper selection of the vectorization parameters according 
to the current raster data and allows for a fast learning and for quickly becoming an expert. 
 
 

Vectorize and Vectorize Parameters   
 

 Toolbar: Vectorization 
 

Menu: Vectorize ► Vectorize 
 

CMD: VPVECTORIZE ► Dialog 
 

CMD: VPVECTORIZE [NAME.PCF] [/m|Method <Value>] [/e|Exact <Value>] []/t|Threshold 
 <Value>] 

Starting the raster-to-vector conversion on the active raster image or on a selected image. First, 
the parameter dialog opens for reviewing or modifying parameters, or to load a parameter file.  
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Clicking OK starts the conversion. 

Using the command line the vectorization can be controlled with the following parameters: 
 

NAME.PCF The name of an existing parameter file 

/m|Method <Value> 
 

 

 

 

 

<Value> controls the image characteristics:  

0: Predominantly Lines 

1: Predominantly Areas 

2: Mixture of Lines and Areas 

-1: Use the value of the image settings 

Default: -1 

/e|Exact <Value> 
 

 

 

 

<Value> controls the accuracy of the vectorization: 

0: No increased accuracy 

1: Increased accuracy 

-1: Use the value of the image settings 

Default: -1 

/t|Threshold <Value> 

 

<Value> (in pixel) controls the process where to switch from 
centerline to outline vectorization. 

Default: 15 
 
If you only want to view or edit the vectorizing parameters without starting the vectorization, use 
this function to open the parameter dialog: 
 
 

 Toolbar: Vectorization 
 

Menu: Vectorize ► Vectorize Parameter... 
 

CMD: VPVECPARAMETERS ► Dialog 
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There are seven tabs that are used for defining or selecting all necessary parameters for the 
vectorization and post processing: 

• Method 
• General 
• Basic 
• Text 
• Advanced 
• Hatches/Symbols 
• Layers 

 
Using Save and Load parameter settings can be saved for later use, including the vectorization 
mode. By default, settings are saved in the SUPPORT subdirectory with a .PCF extension and 
can be re-loaded. Settings of the function Advanced Image Setting... can be saved and re-
loaded in the corresponding dialog. 

A loaded parameter file overwrites all currently active parameters in the parameter dialog. When 
a parameter value of a loaded parameter file is changed manually, the name of the active 
parameter file will be set in parentheses. 

Reset restores all parameter values to their default settings and deletes the current parameter file 
name replacing it with Untitled. 
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Standard Parameter Files  
 
VP software contains some standard parameter files matching the raster sample files for 
conversion. Also, there are combinations created for originals of the following types: 

• Mechanical (MECH.PCF) 
• Architecture (ARCH.PCF) 
• Cadastral maps (GROUND.PCF) 
• Geological maps (GEO.PCF) 

 
These parameter files can be loaded and may be easily modified to meet your drawings' 
peculiarities. They should be saved with a new name. The files reside in the SUPPORT 
subdirectory. 
 

Method Tab  
 

 
 

Image Characteristics (Vectorization Method) 
Three vectorization methods are available: 

• Predominantly Lines 
• Predominantly Areas 
• Mixture of Areas and Lines 

Default: Predominantly Lines 
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Predominantly Lines (Centerline Vectorization): The center of each raster structure is 

determined by thinning inwards from the edges and converting the remaining raster structure 
as line chains consisting of individual line segments. In the case of raster structures having a 
width of more than 62 pixels, centerline vectorization switches to outline vectorization for the 
remaining area, i.e. after thinning inwards by 62 pixels. These remaining raster structures are 
represented by their contours.  

In general, this is the optimum vectorization method for technical drawings. 

 In order to avoid objects from "hollowing out" when using this method do not scan above 
600 dpi, since raster line widths can easily exceed the 62 pixel threshold. 

 
Predominantly Areas (Outline Vectorization): Converts the contours of raster structures to line 

chains, creating line structures which wrap around all of the raster elements. This 
vectorization method suits best for the conversion of originals containing filled areas, 
text, or logos. 

 
Mixture of Areas and Lines (Centerline/Outline): Switching permanently between centerline 

and outline vectorization methods can be set to any threshold value. A typical application 
for this combined method would be the conversion of architectural floor plans, in 
which main walls may be represented by broad, filled areas.  

 
Threshold: This parameter can only be set when selecting Mixture of Areas and Lines 
(centerline/outline vectorization). The value (in units) determines the turning point from where 
raster structures are no longer converted to centerlines, but instead will be represented by 
their contours. 

 The threshold value must be carefully calculated. It should be a value larger than the 
largest line width (for centerline recognition) yet, small enough to avoid centerlining 
objects that should be outlined. Otherwise, you run the risk of constantly switching 
between centerline and outline vectorization for the same element, due to varying 
widths. Also, the value correlates with the scanning resolution, since it is internally 
converted into pixels. 

Range: 0.4  -  3 mm (0.015  -  0.1 inch) 

Default: 15 pixels = 1.27 mm (0.05 inch) @ 300 dpi 
 
Exact {on/off}: The standard vectorization process will straighten vectors during the thinning 

process in order to reduce the amount of generated data. This happens especially across 
edges and along contours with the area vectorization. An additional setting Exact to on, the 
thinning process follows exactly the raster structure. This results in significantly increasing file 
sizes! 

Activating this parameter can be useful when vectorizing text outlines or in GIS 
applications where a high precision with contour lines is required. 

Default: off 
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Advanced Color Settings 
This button becomes active if the raster file is in gray scales or colors. In this case, clicking 
the button opens the dialog Advanced Image Settings allowing to define a color or a color 
pattern as Active Color. For details see Section 4. 

On leaving the Image Settings dialog you return to the Vectorization Parameter dialog. 

 An Active Color should be defined previous to a vectorization of grayscale or color 
images. Otherwise, it will be defined automatically by the program (automatic binarization).  

 
Vectorization Area  

The vectorization area can only be set when the dialog is started with Vectorize. 
The available options are: 

• Whole Drawing 
• Rectangular Area 
• Polygon Area 

 
Especially for large originals, the rectangular area option enables you to "test" (on one or several 
sections) the correct parameter settings for best results before converting the entire drawing.  
 
A selected Vectorization Area may enclose multiple raster images. 

 This selection will not be saved to the PCF file! 

Default: whole drawing 
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General Tab  
 

 
 
These parameters control the degree of line straightening, angle correction, line chaining, gap 
jump, and grid snap. 
 
 

Straightening  
This parameter affects the quality of line straightening as well as circle, ellipse, and arc 
extraction. The following options are available: 

• None 
• Weak 
• Medium 
• Strong 

 
None: The None setting will not execute any straightening. While it provides the highest degree 

of precision in the correspondence of raster structure and vector data (especially with the 
parameter Exact set to "on"), the recognition and extraction of geometric elements is not 
possible. This setting is recommended for contour maps (GIS) and artistic artwork (i.e. logos) 
when the Line Chaining parameter is used to generate polylines. 
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Strong: This setting enforces the extraction of as many long, straight lines (long 2-point lines), 

circles, and arcs as possible. The tolerance range is expanded to favor a greater degree of 
extraction, particularly for architectural and engineering drawings. 

 
Weak or Medium: This setting aims for a compromise between the extraction of lines, circles, 

and arcs versus a congruence with the raster image. This usually leads to the generation of 
an increasing number of fragmented line segments. Moreover, arc elements may be 
generated instead of a circle, especially when the raster circle does not have an even radius.  

 A setting of Strong or Medium is especially suitable for originals which are 
predominantly orthogonal and which are not too dense regarding their information 
structure (mechanical engineering, architecture, etc.). 

Default: Strong 
 
 

Angle Correction {on/off}  
Despite the necessary deskewing of the raster file to a reference line using the raster editor, 
parallel lines are usually not exactly parallel, horizontal, or vertical. The Angle Correction 
function corrects the individual angle of lines within the drawing having an angle offset smaller 
than Deviation at the angles 0° and 90°. There are  three additional angles of your choice to 
define the correction for. 

Default: off 
 
Deviation: Determines the maximum deviation from the reference angle that is to be corrected. 

Since substantial angle deviations may occur in individual line segments, the value should 
usually be set to 2 - 5°. If the value is too high, you run the risk of snapping lines that should 
run within this angle setting without correction. 

Default: 3° 
 
Reference Angles: When angle correction is on, 0° and 90° are the default angles. There are 

three other possible angles that can be entered or measured using [F2]. 

Range: 0° - 90° 
Default: 0°, 0°, 0° 
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Polylining {on/off}  
This setting controls the chaining of individual lines pieces into polylines. In the case of 
geographic contour maps, for example, polylines are generated if Polylining is activated. The 
best possible conformity with the original is achieved when Straightening is set to None or Weak 
with Exact set to on (however, this creates large vector files because of the large number of 
vertices!). 

Default: off 
 
Interrupt at Intersections: Limits chaining to areas between intersections if Line Chaining is 

on. 
 
Running through Intersections: Chains lines across intersections if Line Chaining is on. The 

direction of the smallest angle range at an intersection will be chosen for chaining. 

Default: Interrupt at Intersections 
 
Create Polygons {on/off}: This parameter is used to convert closed polylines to filled polygons. 

The fill pattern is SOLID with the specified Opacity value. 

Default: off 
Opacity: 50% 

 
Create Splines {on/off}: This parameter is used to create splines instead of polylines. 

Default: off 
 

Connect Fragmented Lines over a Gap of: {on/off}  
Small breaks in the raster data, due to faded and old originals, can be joined together in lines, 
circles, and arcs up to a reasonable distance. A high value setting will result in false lines or arcs.  

Default: off 
Value: 0.1 mm, 0. 004 inch 

 If the value is set too high, neighboring vectors can be connected! To correct this, simply 
lower the distance length and run the post processing again. 
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Basic Tab  
 
In this tab you can choose circle and arc extraction, as well as recognition of dashed and dash 
dotted lines, Donuts and Arrowheads. 

 
 

Line Types {on/off}  
Toggles the recognition of dash dotted and dashed line types on and off. An individual line type 
is usually generated for every non-solid line in the original. However, the number of line types can 
be limited by using Classified to for classification. 
 
At least three partial segments are required to recognize a line type. 

Default: off 
 
Individual Unlimited: An individual line type is generated for each line found. 
 
Classified to: The found lines are classified. The value for Classified to determines how many 

classes of dash dotted and dashed lines will be created. The master linetypes for the 
classification are extracted from the found linetypes. If linetypes are already defined in the 
Linetype Manager and those linetypes fit to the found lines, these linetypes are used. 

Default: 3 
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Max. Gap Length: Defines the maximum gap length in a dashed or dash dotted line to be 

searched for. 

Default: 3 mm or 0.1 inch 
 
Max. Dash Length: Defines the maximum length of a single dash element in a dashed or dash 

dotted line to be searched for. 

Default: 5 mm or 0.2 inch  

 False dashed lines could be generated in poor drawings with weak solid lines. It is best to 
leave this function off if the drawing to be converted only contains a few dashed line 
segments. After post processing, you can easily combine the line pieces to one line and 
then convert it into a dashed or dash dotted line. 

On the other hand this function can help to assemble broken line pieces in poor raster data 
to a dashed line which can easily be converted into a solid line. 

 
Circles {on/off}  

Circles are recognized having a diameter exceeding the Min. Diameter. 

Default: 2 mm or 0.1 inch 
Default: on 
 

Arcs {on/off}  
Enables the recognition of arcs. In order to avoid unwanted arc interpretations, arc recognition is 
determined by the Min. Angle parameter. Only arcs with a greater angle than the entered value 
are recognized as arcs.  

Range: 0° - 90° 
Default: 10° 
Default: on 
 

Ellipses {on/off}  
Enables the recognition of ellipses and elliptic arcs. 

Default: off 
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Text Tab 
 
In this tab you can set the options for the text recognition (OCR): 

 

  
 

Text {on/off}  
With Text set to on either text recognition (OCR) or text separation can be selected. Choose the 
maximum text height for searching text structures up to this height.  
 
Limiting the search to Horizontal and Vertical or Only Horizontal text will significantly increase 
the accuracy of recognition and the search speed. It should be selected whenever possible. This 
also applies for smaller Max. Text Height settings. 

Default: off 
 

The following parameters control which texts should be looked for and recognized. 
 
Max. Text Height: Defines the maximum size of the isolated structures to be processed during 

separation or recognition. Use [F2] for accurate measurement. Set the text height to a value 
representing the majority of the text in the document - do not use singular or only a few large 
text strings as a reference! 

Default: 4.0 mm, 0.15 inch 
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All Text is detached {on/off}: Only text will be taken that is not connected to any other structure 

e.g. long lines. 

Default: off 
 
In Line Format: The vector data (lines, circles, arcs) separated by the Max. Text Height 

parameter are displayed in the selected layer (Default: "Text") as "pseudo text", i.e. the 
entities are grouped to a block. This block can be edited (especially replaced by any ASCII 
characters) with the Review Text function. 

Default: off 
 
In ASCII Format (OCR): The detected raster text is interpreted using the OCR function and 

converted into ASCII text strings.  

Default: on 
 
Text Search Direction: The search for different text orientations can be limited. The more 

directions are enabled, the longer the text interpretation process will take (only available with 
Text Recognition). Direction selections are: 

• Only Horizontal 
• Horizontal and Vertical 
• Arbitrary Direction 

 
OCR Options (Text recognition): Specify the settings for the text recognition. Select from 

predefined and user defined settings for the recognition (OCR, e.g. only numbers, special 
characters). New settings are saved and will be available for other projects as well.  

 
Predefined settings are: 

Global OCR Settings: The currently specified OCR settings (can be changed with Options – 
OCR Settings, see Chapter 4). 
Only Letters: All letters, but no numbers (digits) are recognized.  
Only Numbers: Only numbers are recognized. 

Default: Global OCR Settings 

 The Global OCR Settings reflect the current OCR settings. In case these settings are 
modified between two vectorization processes, the result of the second process might 
differ from the first one. 

 Create new setting . After specifying a name the dialog for the OCR Settings will show 
up. 

 Opens the dialog for the OCR Settings to modify the selects settings. 

 Delete the selected settings. 
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Output 
The following parameters control the creation of text entities. 
 
Text Heights 

Individual: Each text element has its own text height. Its Value is This value is either 
Computed from the raster data or the value returned From OCR Engine is taken. In the later 
case text heights tend to be larger, nevertheless they fit well if only upper case letters and 
numbers are recognized.  
 
To Text Styles: If not already defined up to 6 text styles will be generated: T1 (1.8 mm), T2 
(2.5 mm), T3 (3.5 mm), T4 (5 mm), T5 (8 mm), and T6 (10 mm). The height/width ratio is 1.0 
and the font specified in the Systems Settings (see Chapter 4) is assigned. In case that the 
styles T1-T6 already exist there values are not modified. 
The recognized texts will be assigned to the best fitting text style and its height is set to the 
corresponding value. 

Default: To Text Styles 
 
Text Width: The height/width ratio of the assigned text style is either accepted (Fix from Text 

Style(s)) or calculated for each text from the OCR result (Fit to original). 
 

Default: Fix from Text Style(s) 
 
Layer: A Layer can be selected where all recognized/separated text will reside. 

Default: Text 
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Advanced Tab  
 
In this tab parameters for the recognition of small circles, dimension arrows (arrowheads), and 
donuts are set. 
 

 
 
 

Small Circles {on/off}  
This option has been specifically designed for the recognition of small circles up to a diameter of 
approximately 2 [mm] or 0.08 [inch], corresponding to approximately 25 pixels at 300 dpi with 
increased tolerance. Arcs spanning an angle larger than 270° are closed to form full circles. 

Default: off 
 
Diameter: Enter the average diameter of circles to be recognized. 

Default: 1.5 mm or 0.06 inch  
 
Assign New {on/off}: A new diameter can be assigned to recognized circles. 

Default: 1.5 mm or 0.06 inch 
 
Extend Lines to Center {on/off}: This option extends lines to the center of a small circle which 

actually end on the circle, but point at the circle's center. 

Default: off 
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Layer: A layer can be selected where all recognized small circle elements will reside. 

Default: S 
 
Replace by Block Entity {on/off}: Each recognized small circle will be replaced by a block. 

Instead of the default block MPOINT any block can be used. 

Default: off 
 
 

Hatches/Symbols Tab  
 

 
 
 

Hatch Recognition {on/off}  
This option toggles the search for hatch patterns to on or off. The lines assigned to a hatch 
pattern are collected and saved in a Block. A minimum of five parallel lines are required to create 
a hatch block. In addition, a hatch is only recognized if the angular deviation of its lines relative to 
one of the three Reference Angles is less than the parameter Angle Range and the angle 
tolerance of the individual elements does not exceed 5°. Also, all lines must have connections to 
the respective border element (other lines, arcs, circles). 

Default: off 
 
Max. Line Distance: This value defines the maximum distance between parallel lines forming a 

hatch. 

Default: 5 mm or 0.2 inch 
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Angle Range: The offset (+/-) from any of the three reference angles specifies the angle 

tolerance while searching for a hatch. 

Range: 5 - 35° 
Default: 5° 

 
Reference Angles: A maximum of three base angles can be entered. 

Defaults: 45°, 45°, 45° 
 
Layer: A layer can be selected where all recognized hatches will reside. 

Default: Hatch 
 

Symbols {on/off}  
Use this option to turn on and off searching for symbols during vector post processing. 
 
Clicking on Prototypes opens the dialog box for the selection of symbols for the search process. 
 

 
 
Available Symbols: Lists the available symbols. For a search process you can select symbols 

from Favorites or from the current Search Path. 
  
Selected Symbols: Lists the selected symbols for the search process. Use Add and Remove to 

modify the selection. 
 

For information on creating prototypes see Section 14. 
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Layers Tab  
 
The Layers tab allows you to assign three layers to three line width classes. The dynamic 
preview enables an individual setting of the line width classes according to the current raster file. 
 

 
 
The values for the class limits (thresholds) determine the maximum widths up to which lines, 
circles, arcs, etc. are assigned to the adequate layers. The layer limits can be changed using the 
slider controls. It is not possible to enter threshold values via keyboard. 
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Preview 
The preview offers a practical, simple, and precise on-screen setting of the limits. You can switch 
raster or vector layers on and off for a better viewing of details. Pan and zoom functions are 
available. By changing any of the limits using the sliders you can immediately view the results. 
 

 
 

Layers 
Each of the three line width classes Thin Line, Medium Line and Thick Line can be assigned to 
specific layers. Select "Other…" from the Layer list to start the Layer Manager (see section 4) 
and to create new layer(s). 

Default: L1, L2, L3 
 

Adopt Raster Color for Vector Objects {on/off} 
This option is only available when processing colored images. When set to on the generated 
vector objects will not have the default color By Layer, but the color of the underlying raster pixel 
structure. To indicate this, the colors in the slider layer display appear hatched instead of solid. 

Default: off 
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Create Sublayers for: 
For each of the three base layers (line width classes) sub-layers for arcs, circles, and line types 
other than solid may be created if such entities are recognized with the corresponding width 
during the vectorization process. The indicated suffixes are appended to the corresponding base 
layers. 

Default: off 
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Vectorize Contour   
 

 Toolbar: Vectorization 
 

Menu: Vectorize ► Vectorize Contour 
 

CMD: VPVECCONTOUR ► Dialog 

This function has been designed for an easier automatic vectorization of contour maps. Some of 
the above Vectorization Parameters are readily predefined. Only Lines and Polylines will be 
created. Also, a special recognition option for Dashed Polylines is available. 
 

 
 

Straightening 
This parameter affects the quality of line straightening. The following options are available: 

• None 
• Weak 
• Medium 
• Strong 

 
None: The None setting will not perform any straightening. However, it provides the highest 

degree of precision in the correspondence of raster structure and vector data (especially with 
the parameter Exact set to "on" in Image Settings) 

 
Strong: This setting enforces the extraction of polyline segments as long as possible. The 

tolerance range is expanded to favor a higher degree of extraction, particularly for 
architectural and engineering drawings. 
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Weak or Medium: This setting aims for a compromise between the extraction of polylines versus 

a high correspondence with the raster image. This usually will lead to the creation of an 
increasing number of polyline segments.  

 
Interrupt at Intersections: Limits chaining to areas between intersections. 
 
Running through Intersections: Chains lines across intersections. The direction of the smallest 

angle range at an intersection will be chosen for chaining. 

Default: Interrupt at Intersections 
 
Create Polygons {on/off}: This parameter is used to convert closed polylines to filled polygons. 

The fill pattern is SOLID. 

Default: off 
 

Image Settings 
The actual Image Characteristics are displayed. Modify will pop up the Image Settings dialog 
for modifications. For colored images the Foreground and Background Definitions can also be 
modified here. 
 

Dashed Polylines {on/off} 
Dashed Polylines will be searched when set to on. The function is not limited to straight lines 
and dashes may have any shape. With Max. Dash and Gap Length the maximum length of a 
single polyline and the maximum distance between the end points of two polylines which will be 
chained to a dashed polyline can be specified.  
 
The Linetype of detected Dashed Polylines will be generated as Automatic due to the detected 
dash-gap sequences, or as Fixed with the specified Linetype. 

Default: on 
Max. Dash Length: 5 mm or 0.2 inch 
Max. Gap Length: 3 mm or 0.1 inch 
Linetype: Automatic 



 VP Software Manual 

456   Section 13     Vectorization Manual V16 - V9 / E 
 

  
 

Text Tab  
 
Setting up options for text recognition (OCR): 

 
 

Text {on/off}  
When Text is activated a text recognition (OCR) or text separation (in Line Format) can be 
selected. The text search is controlled with a value for the maximum text height. 

Limiting the search to Horizontal and Vertical or Only Horizontal text will significantly increase 
the accuracy of recognition and the search speed. It should be selected whenever possible. This 
also applies for smaller Max. Text Height settings. 

Default: off 
 
Recognition: The following parameters control which texts should be looked for and recognized. 
 
Max. Text Height: Defines the maximum size of the isolated structures to be processed during 

separation or recognition. Use [F2] for accurate measurement. Set the text height to a value 
representing the majority of the text in the document - do not use singular or only a few large 
text strings as a reference! 

Default: 4.0 mm, 0.15 inch 
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All Text is detached {on/off}: Only text will be taken that is not connected to any other structure 

e.g. long lines. 

Default: off 
 
In Line Format: The vector data (lines, circles, arcs) separated by the Max. Text Height 

parameter are displayed in the selected layer (Default: "Text") as "pseudo text", i.e. the 
entities are grouped to a block. This block can be edited (especially replaced by any ASCII 
characters) with the Review Text function. 

Default: off 
 
In ASCII Format (OCR): The detected raster text is interpreted using the OCR function and 

converted into ASCII text strings.  

Default: on 
 
Text Search Direction: The search for different text orientations can be limited. The more 

directions are enabled, the longer the text interpretation process will take (only available with 
Text Recognition). Direction selections are: 

• Only Horizontal 
• Horizontal and Vertical 
• Arbitrary Direction 

 
OCR Options (Text recognition): Specify the settings for the text recognition. Select from 

predefined and user defined settings for the recognition (OCR, e.g. only numbers, special 
characters). New settings are saved and will be available for other projects as well.  

 
Predefined settings are: 

Global OCR Settings: The currently specified OCR settings (can be changed with Options – 
OCR Settings, see Chapter 4). 
Only Letters: All letters, but no numbers (digits) are recognized.  
Only Numbers: Only numbers are recognized. 

Default: Global OCR Settings 

 The Global OCR Settings reflect the current OCR settings. In case these settings are 
modified between two vectorization processes, the result of the second process might 
differ from the first one. 

 Create new setting . After specifying a name the dialog for the OCR Settings will show 
up. 

 Opens the dialog for the OCR Settings to modify the selects settings. 

 Delete the selected settings. 
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Output 
The following parameters control the creation of text entities. 
 
Text Heights: 
 

Individual: Each text element has its own text height. Its Value is This value is either 
Computed from the raster data or the value returned From OCR Engine is taken. In the later 
case text heights tend to be larger, nevertheless they fit well if only upper case letters and 
numbers are recognized.  

 
To Text Styles: If not already defined up to 6 text styles will be generated: T1 (1.8 mm), T2 
(2.5 mm), T3 (3.5 mm), T4 (5 mm), T5 (8 mm), and T6 (10 mm). The height/width ratio is 1.0 
and the font specified in the Systems Settings (see Chapter 4) is assigned. In case that the 
styles T1-T6 already exist there values are not modified. 
 
The recognized texts will be assigned to the best fitting text style and its height is set to the 
corresponding value. 

 
Default: To Text Styles 
 
Text Width: The height/width ratio of the assigned text style is either accepted (Fix from Text 

Style(s)) or calculated for each text from the OCR result (Fit to original). 
 

Default: Fix from Text Style(s) 
 
Layer: A Layer can be selected where all recognized/separated text will reside. 

Default: Text 
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Layers Tab  
 
The Layers tab allows for to assigning three layers to three line width classes. The dynamic 
preview enables an individual setting of the line width classes according to the current raster file. 
 

 
 
The values for the class limits (thresholds) determine the maximum widths up to which lines, 
circles, arcs, etc. are assigned to the appropriate layers. The layer limits can be changed using 
the slider controls. It is not possible to enter threshold values via keyboard. 

 
Preview 

The preview offers a practical, simple, and precise on-screen setting of the limits. You can switch 
raster or vector layers on and off for a better view of details. Pan and zoom functions are also 
available. By changing any of the limits using the sliders you can immediately see the results. 
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Layers 
Each of the three line width classes Thin Line, Medium Line, and Thick Line can be assigned to 
specific layers. Select "Other…" from the layer list to start the Layer Manager (see section 4) 
and to create new layer(s). 

Default: L1, L2, L3 
 

Adopt Raster Color for Vector Objects {on/off} 
This option is only available when processing colored images. Then, if set to on, the generated 
vector objects will not have the default color By Layer, but the color of the underlying raster pixel 
structure. To indicate this, the colors in the slider layer display appear hatched instead of solid. 
 
Default: off 
 

Create Sublayers for Dashed Polylines: 
For each of the three base layers (line width classes) sub-layers for dashed Polylines may be 
created if such entities are recognized with the corresponding width during the vectorization 
process. The indicated suffixes will be appended to the corresponding base layers names. 

Default: off 
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Vectorization Wizard    
 

 Toolbar: Vectorization 
 

Menu: Vectorize ► Wizard 
 

CMD: VPVECWIZARD ► Dialog 
 
After loading and preparing the raster file to be vectorized click this icon. The first tableau of the 
Wizard appears: 
 

 
 
Here, you can decide to use the wizard for selecting and defining all necessary parameters, or to 
switch to the standard parameter dialog. For detailed description of all parameter see the 
beginning of this section. 
 
If you want to get the wizard support press Next. 
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Select the Image Characteristics which best fit your current drawing with respect to the expected 
results. With Mixture of Areas and Lines set the Threshold to determine the line width from 
where raster structures are to be converted into outlines. 
 
You may activate Exact for a higher accuracy. This is especially useful with maps containing 
narrow contour lines. However, be aware of the fact that this will result in significantly larger 
vector files! 
 
Click Next! 
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If you do not have a fitting parameter file a new parameter set needs to be created according to 
your current raster file. Select the Basic Drawing Style. Now, some parameters will be set 
automatically. The following tableaus will only show parameters dealing with Mechanical/ 
Electrical Drawings. If you select other drawing types, you may see different tableaus. 
 
Click Next! 
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If you select to load a parameter file from your support directory the wizard support will come to 
an end. No additional selection or setting of parameters is required.  
 

 
 
Clicking on Finish will bring up the Parameter Dialog where you can review all parameters and 
may modify them, if necessary. 
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If Angle Correction set to on, define the tolerance angle of deviation from the reference angles 
(here: 30°, 45°, and 60°). 
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Select the Text Recognition and the interpretation of the found raster text strings. You need to 
specify (measure with [F2]) the maximum text height from your drawing. 
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Define the hatch parameters if to be searched for. The max. distance between parallel lines, the 
reference angles (here: 0° and 45°), and the tolerable deviation from those angles are required. 
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Select Arrow Recognition if your drawing contains any and specify (measure with [F2]) a length. 
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Donuts as they are used e.g. in electrical plans, can be recognized with a specified diameter 
(measure with [F2]) and will be transferred to the selected Layer. 
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You may want to recognize the Dashed or Dash-Dotted Line Types. Create either individual 
types or classify them into groups. Measure the maximum dash and gap lengths with [F2] for 
definition. 
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Finally, define the line width classification assigned to layers and colors. The layers L1, L2, L3 
are default layers. You may select other layers specified in the Layer Manager.  
 
The Preview allows for a more precise and individual setting of the class limits according to your 
drawing. 
 
The option Adopt Raster Color for Vector Objects is only available when processing colored 
images. When set to on the generated vector objects will not have the default color By Layer, but 
the color of the underlying raster pixel structure. 
 
All necessary parameters have been set or selected. Additional parameters are set by the wizard 
automatically. 
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Clicking Finish brings you to the Parameter Dialog, now containing all set parameters. You can 
review (and modify) the parameter values. Also, these settings may be saved and used with 
similar raster files. 



VP Software Manual  

Manual V16 - V9 / E Section 13     Vectorization   473
 

  
 

 
 
Click OK to start the conversion process. 
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SECTION 14   
SYMBOL RECOGNITION / REPLACEMENT  
   

General   
 

The Symbol Recognition function will search for vectors which form a specific pattern and will 
replace these with blocks. Basically, the function is referred to symbols. These contain one or 
more search patterns and a replacement block.  
 
A search pattern of a symbol will be created by marking the vector pattern to search for (sample) 
in the drawing. When more samples are marked which differ only slightly, this will result in 
creating a search pattern with an increased tolerance, thus, it will help to improve on the overall 
search result. Please note, however, that the individual samples do not differ too much in their 
structure. Otherwise, the function may not be able to create a valid search pattern. 
 

 
Example: correct and incorrect marking of samples for a search pattern 

 
A symbol may contain several different search patterns. This means that with this symbol several 
different search patterns will simultaneously be substituted with a replacement block. 
 

 Search patterns containing a large number of vector elements will result in a long function 
runtime, and they may also lead to poor search results. In these cases it may be more 
suitable to carry out replacements manually (see Section 8: Combine to Block). 

 
A replacement block of a symbol is a block definition which is either created from the search 
pattern, or it can be an existing block definition in the drawing. The design of a replacement block 
is independent from the search pattern. When a replacement block contains attributes, text or 
number information can be adopted separately for each pattern found.  
 

 
Example: symbol recognition with one symbol and two search patterns 
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The symbols created will be saved as .PSB files and will also be available for other drawings.  
 

There are two symbol recognition functions available: Quick Symbol Recognition for a simple 
definition of search patterns and immediate search runs.  
 

The more advanced Symbol Recognition allows for additional modifications of symbols,  e.g. 
modifying replacement blocks, add/delete search patterns, or changing search tolerances.  
 
 

Quick Symbol Recognition    
 

 Toolbar: Symbol Recognition 
 

Menu: Vectorize ► Quick Symbol Recognition 
 

CMD: VPSIMPLESYMBREC ► Dialog 

Activating the Quick Symbol Recognition dialog. When the dialog appears vector structures 
(samples) can be selected directly in the drawing. These will be displayed in the preview window. 
With each additional sample the tolerance for the following recognition process will be increased. 
However, too many samples selected may result in unwanted results. Thus, two or three different 
samples are recommended for best results. 
 

Search will start the recognition process. A new symbol will be created and saved as a PSB file in 
the respective folder. The symbol contains the search pattern generated from all selected 
samples and the replacement block generated from the search pattern. The result of the symbol 
recognition will be displayed. 
 

In case that selected samples differ considerably and no valid search pattern can be generated, a 
warning message appears. The recognition process may still be continued, or selected samples 
may be checked again and wrongly selected samples may be deleted. 
 
For each process a new symbol and a new block definition will be generated. The advanced 
function Symbol Recognition provides processing options with already existing symbols or block 
definitions (see below in this section). 
 

Quick Symbol Recognition dialog with unfolded path box for symbol files: 
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Name 
Name of symbol which will be saved to the symbol folder. A default name will be assigned and 
may be changed individually.  
 

  On/off display for symbol folder. 
 

Symbol Folder 
Folder location for symbols. The path may be entered directly or browsed. The dropdown list 
displays the history of selected paths. 

 Browse for a folder. 
 

Sample 
Displays the number of samples selected for a search pattern. 
 

 Browsing selected samples forward/back. 
 

 Deleting the sample displayed. 
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Symbol Recognition   
 

 Toolbar: Symbol Recognition 
 

Menu: Vectorize ► Symbol Recognition 
 

CMD: VPSYMBREC ► Dialog 
 

CMD: VPSYMBREC [<NAME PSB>, <NAME PSB>, <NAME PSB>, ...] 

When the function is activated with symbol files (search patterns) the symbol search will start 
immediately. 

Example: vpsymbrec "d:\symbols\res1.psb","d:\symbols\res2.psb" 

Without any parameters entered, a dialog opens where symbols (search patterns) can be 
organized and selected for a search process. 
 

 
 
Symbols can be selected from the search path or from the list of favorite symbols. To select 
multiple symbols at the same time use [Ctrl] or [Shift] when selecting. Symbols in the favorites 
list are permanently available, independent from the current search path. 

With no symbol or more than one symbol is selected per list, the preview display is inactive. 
 

Symbol Data 
Displays Search Pattern(s) and the belonging replacement block of the selected symbol. If the 
symbol contains several search patterns these can be viewed individually. The saving location of 
the symbol file is indicated. Use Modify Symbol to edit the symbol (see below). 
 

 Go to next or previous symbol. 
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Symbol in Search Path 
Displays all symbols (*.psb files) in the current path. Enter a path directly or browse. In a 
dropdown list contains recently used paths.  

 Browse for a path. 
 
A New Symbol will be saved to the current path. Different symbols from different sources can be 
saved and organized. 
 

Favorite Symbols 
Contains symbols for frequent use, independent from the current path. Add to Favorites adds 
symbols from the current path to this list. You can Remove symbols from the list. The respective 
file will not be deleted. 
 
 

New Symbol 
 
The Search Pattern dialog opens: 
 

 
 
When the dialog appears samples can be selected directly in the drawing. These will be displayed 
in the preview window. With each additional sample the tolerance for the following recognition 
process will be increased. However, too many samples selected may result in unwanted results. 
Thus, two or three different samples are recommended for best results. 
 

Sample 
Indicates how many samples have been selected. 

 Go to next or previous sample. 

 Deletes the displayed sample. 
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A replacement block can be defined with Continue.  

 A warning message appears when selected samples differ significantly, so that no common 
search pattern can be generated. In this case the problem samples need to be deleted.  

 
 

Replacement Block / Text Conversion 
 
Define a replacement block for the new symbol. When text is contained in the selected search 
pattern this text can be linked with attributes from the replacement block. From each pattern 
found individual text or numbering information can be adopted.  
 

 
 

Symbol Name 
Name / file name of the symbol. The prompted name can be modified. 
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Replacement Block 
Defines a replacement block for the new symbol.  

Create New Block Definition: A new block definition will be generated with the elements of 
the search pattern. The option Change color of Members to "By Block" will change the 
elements’ colors to the color By Block. All elements of the replacement block will be 
assigned the block’s color, i.e. they will then be displayed in the color of the inserted 
block..  

Use existing Block Definition: Offers all available block definitions in the document for 
selection. During the search run the block will be rotated automatically, but not scaled. 
Therefore, search patterns and replacement blocks should have comparable sizing. If this 
is not possible to obtain you may assign a fixed scaling factor to the replacement block 
(see below Modify Symbol).  

 
 

Options for Text in Search Pattern 
Select a text from the list and choose from the following options: 

Link to Attdef.: Links text with an attribute from the replacement block. A selection list with 
available attributes appears when an existing block definition is used. With a new block 
definition the text element will be converted to an attribute. You can assign a name for this 
attribute 

Keep as Text: Will not link text with an attribute. With a new block definition: the text element 
will not be converted. 

Remove from Block (only with new block definition): The text will be excluded from the new 
block definition. 

 
When the selected replacement block does not contain any attributes only the option Keep as 
Text will be available.  
 
With Create a new symbol will be created and saved according to the current path settings. The 
main dialog reappears.  
 
 

Modify Symbol 
 
A symbol’s search patterns can be reviewed or new patterns can be added. A replacement block 
can be substituted and the text links can be changed. Moreover, the replacement block’s search 
and insertion parameters can be altered.  
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Dialog Modify Symbol with expanded settings bar: 
 

 
 

Search Pattern 
Displays all search patterns of a symbol.  

 Go to next or previous search pattern. 

 Deletes the displayed search pattern. 

 
Add new Search Pattern to Symbol 

 Adds a new search pattern. Select samples for a new search pattern in the following dialog (see 
New Symbol). On close the dialog Modify Symbol reappears. A symbol may be composed of 
several different search patterns. This means that a replacement block will be inserted with this 
symbol for several different patterns. 
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Replacement Block 
Displays the replacement block for a symbol. To modify the replacement block select another 
block definition from the list. All block definitions contained in the document are available for 
selection. 

 A substitution of a replacement block will result in a loss of links between text (in search 
patterns) and attributes (in replacement blocks). 

 
Options for Text in Search Pattern 

Select a text from the list and choose from the following options: 

Link to Attdef.: Select the replacement block’s attribute you want to link with the text from the 
list.  

Keep as Text: No link with an attribute.  
 
When the selected replacement block does not contain any attributes only the option Keep as 
Text will be available. 
 

Save As 
A dialog opens to save a symbol. You may e.g. create several symbols with identical search 
patterns, but with different replacement blocks without creating new symbols each time. 
 

Advanced 
Opens or closes the settings bar. 
 

Search Pattern Settings 
Defines search tolerances for each search patterns of a symbol.  
 
Tolerance (%): Defines the tolerance range for a search with a particular prototype. 

Range: 5 - 75 % 
Default: 15 % 

 
Max. Gap: Defines the largest break/interruption (i.e. open line segments in the symbol 

contour) in pixels which will be tolerated during a search. 
Range: 1 - 20 Pixels 
Default: 3 Pixels 

 
The values displayed have been calculated by the program during the prototype creation. 
Recommended minimum settings are Tolerance = 15% and Max. Gap = 3 Pixels. 
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Replacement Block Settings 
Use the X-Scaling and Y-Scaling to adapt a block to the geometric requirements of the original. 

 Please ensure that the block's connection shape and size correspond with the search 
pattern. 

 
 

Search and Replace 
 
The function Search and Replace becomes available only after at least one symbol is selected 
from the search path list or from the favorites list. When activated the program will search for 
selected symbols in the document or in a selection area of the document.  
 
All matching patterns will be substituted with a corresponding replacement block. Text in the 
search pattern will be linked to the block’s attributes and adopted.  

 Please note that blocks will only be rotated, but not scaled (for scaling see above Modify 
Symbol)!  

 
When a search run is completed the number of symbols found will be indicated. The function is 
ready for a new search.  
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CAD Symbol Search    
 
The CAD Symbol Search function is meant for drawings created with CAD programs. Opposed to 
vectorized drawings the search accuracy will be much higher. The function handling differs only 
slightly from the regular symbol search as follows. 
 

 Toolbar: CAD Symbol Search 
 

Menu: Vectorize ► CAD Symbol Search 
  

CMD: VPSYMBSEARCHV ► Dialog 
 

CMD: VPSYMBSEARCHV [<NAME.VSB>, <NAME.VSB>, <NAME.VSB>, ...] 

A symbol search process will run immediately if the command is started with specified symbol 
files. 
Example: vpsymbsearchv "d:\symbole\res1.vsb","d:\symbole\res2.vsb" 
 
Without any parameter entering a dialog opens where symbols are administered where they can 
be selected for a search process: 
 

 
 
For symbol administration see above Symbol Search. 
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Search Options 
Include mirrored Symbols The search process will also include symbols which are mirrored  
horizontally or vertically. The replacement block will be inserted accordingly. 
 
Keep existing Blocks: Blocks already existing in the drawing will remain unchanged.  
 
Replace original Patterns: Vectors of found patterns will be deleted upon insertion oft he 
replacement block. 
 

New Symbol 

 To create a new symbol only one search pattern is required.  It can be selected directly in the 
drawing. A selection of belonging vectors can be done by a rectangle window selection or by 
clicking on the individual elements. De-select elements by clicking with [SHIFT]. Confirm your 
selection with [Enter]. 
 
To continue see above (Replacement Block.). 
 
The new symbol will be saved as VSB file in the specified folder. 
 

Search (and Replace) 

 Symbols marked in Search Path or in Favorite Symbols will be processed. For each found 
search pattern a replacement block will be inserted. The search pattern’s vector elements will be 
kept or deleted according to the search option settings. 
 
When the search process has ended the number of found symbols will be displayed. The function 
can now be used for the next search process. 
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SECTION 15   
ADDITIONAL TOOLS  
   

General Information  
 
The BatchManager provides a setup of tasks that can be applied to file sets, e.g. to all files 
residing in a directory and their subdirectories, etc. The BatchExecutor executes these tasks in a 
background process without user interaction. 
 
You can also write your own Script File to interactively perform tasks that have a defined 
sequential order. Scripts can be executed on command level or as part of the BatchExecutor. 
 
The toolbar User Commands allows for assigning up to 10 commands or scripts to buttons in the 
toolbar. With this feature work flow routines can easily be integrated and commands can be made 
better and faster accessible! 
 
Batch Compare automatically compares the revisions of multiple pre-selected files. 
 
 

 BatchManager  
 

 Toolbar: Batch Manager 
 

Menu: File ► BatchManager 
 

CMD: VPBATCH ► Dialog 
 

CMD: VPBATCH <NAME.BJB> 

The supplied batch job file is opened and executed, or a dialog box opens. Batch Jobs can be 
created, modified, deleted, saved, loaded, and executed: 
 

 
 
If no batch job has been created, yet, the job list appears empty. 
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Create Batch Job 
Creates a new batch job (see below).  
 

Modify Batch Job 
The settings of a selected Batch Job can be modified.  
 

Delete Batch Job 
A selected Batch Job is deleted from the job list. 
 

Load Job List 
Loads a previously saved Batch Job from file. 
 

Save Job List 
Saves a Batch Job to a file. 
 

Run BatchExecutor 
Starts the BatchExecutor and executes the current job list. 
 
 

Create Batch Job 
 
A file and task set can be defined to create a new Batch Job. The dialog Select Files opens to 
select the source files for the desired batch process. 
 

 
 

Base Path 
Type in the location of the source files or use the button for browsing. 
 
Select single or multiple files in the Preview area and add them to the Selection list using the 
button Add or Add All. 
 
To remove selected single or multiple files from the Selection list use the button Remove. 
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Wildcards 
To show only files in the Preview that match a specified wildcard pattern, type the pattern into the 
edit field Wildcards. For example, if you want to see only files that start with the character "b" you 
can use wildcard patterns like b*, b*.*, b*.tif, *.tif, etc. (according to standard conventions). The 
wildcard character "?" is a variable for a single character, thus the pattern test?.tif would find the 
file test1.tif. However, neither the file test20.tif, nor the file test.tif would be included. Without 
entering a specific pattern, the default pattern "*.*" is used instead, finding all files which have a 
file extension and which can be loaded using the available import filters. 
 

Include Subdir. 
If this checkmark is on the preview recursively shows all found files and all subdirectories in Base 
Path. 
 

Add Wildcards 
Use this button to add a source to the Selection list that uses Wildcards. You can use this 
feature to create a batch job that works on a specific directory, rather than on a specified set of 
files. For example, you can create a batch job for the directory c:\scanned files\*.*. No matter 
which files were residing in the directory at the time of the batch job creation, whenever the batch 
job is executed, all files residing in the directory will be processed. 
 

Page Selection 
When selecting one or more multipage files a dialog pops up to specify which pages should be 
processed in the batch: 

 
Default: All  
 
The dialog appears only once for each selection (Add/Add All). The specified settings apply to all 
multipage files in this selection. Therefore only multiple files that should be processed in a similar 
way should be selected at a time.  



VP Software Manual  

Manual V16 - V9 / E Section 15     Additional Tools   489
 

  
 
 Settings 

 
Pressing this button allows for defining the appearance and display of the files in the Preview: 
 

 
 
You can either choose to display Thumbnails (Images), a List (fast) of file names, or a list of file 
names with Details. You can also select to see all pages of a multi page file as single items 
(Expand Multipage Files). The columns' arrangement defines the size of the thumbnails. The 
Autoload function can be limited, in order to prevent loading large files for display which might 
take too much time. 
 
Finally, Tool Tip information, displayed when moving the cursor over the source images' display, 
can be defined individually in Displayed File Details. 
 
Click OK to return to the Select Files dialog. 
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Task Setup 
 
In the Select Files dialog click OK once all files have been assigned for processing to the 
Selection list. Next, the Task Setup dialog opens where you can create the batch process. 
 

 
 

Task Sequence 
Gradually select the standard or user defined tasks and add them to the task list using the Add > 
button. Depending on each specific task a dialog comes up for setting up parameters. See the 
corresponding sections of this manual for a detailed description. 
 
In the Custom/Script parameter dialog you can enter commands with parameters as you would 
do in the program's regular command line. You can also Load or paste commands from an 
existing script file. Be sure not to use commands that would require user input. Otherwise, these 
commands cannot be executed. 
 
Use the < Remove button to delete a selected task from the Task Sequence. 
 

Task Path 
Enter or browse to a Task Path for saving the custom parameters of a task. 
 

Delete Task 
Deletes a selected user defined task file. The standard tasks cannot be deleted. 
 

Modify Parameters 
To review and modify the parameters of a task, select the task in the Task Sequence list and 
click on Modify Parameters. 
 

Task Order 
The Up and Down buttons can be used to change the process order of the tasks. 
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Output Options 
 
Click Next to specify the output options. The output dialog opens: 
 

 
Path 

Type in or browse to the directory where the processed files will be saved. If Keep Directory 
Structure is checked on the processed files will be saved in subdirectories of Path in the original 
order of the source files. 
 

File Name 
The name of target files can be composed of the original file name and a prefix and/or a suffix: 

<Prefix><Original File Name><Suffix> 
If desired select the corresponding option(s) Add Prefix/Add Suffix and enter the character 
strings. When working with multi page files you can use the special sequence %02d to write out 
the page number. You can omit 0 if you do not want trailing zeros. 2 is the number of digits the 
page number should have. 
 

File Format 
The result of a batch process can be saved to any VP supported file type. Depending on the file 
type additional multi page and/or File Format Options (see Chapter 3: File Format Options) are 
available. 

 Note: Not all formats support all data types. Saving data to an unsuitable file format may 
result in empty or incomplete data sets! 
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When processing multi page files use Preserve Multipage Files and Copy unprocessed Pages 
to keep the complete multi page file (equal number of pages). With Discard unprocessed pages 
only the selected (processed) pages (see above Page Selection) will be saved to the output file.  

With Single Files with single page each processed page is saved to an individual file. This is 
the only available option if the selected file type does not support multi page output.  

Use One Multipage File to save all processed pages/files into one single multi page file. Define 
the name of the output file. The file location is specified with the Path setting.  
 

Print 
Activate the Print option to send the resulting files to a printer. If No File Output is checked files 
will be printed, but not saved. 
 
You can change the printer and the print options by clicking Settings. 
 

Misc. Options 
By switching Use Prototype Drawing you can apply layer settings from a specified Prototype 
Drawing to the source files. This way you can easily adapt e.g. layer widths and colors to certain 
standards of an organization or to a general norm. 

Activate Delete Input Files after Processing if you want to delete the original files. 
 
Click Finish to complete the job setup. The Batch Manager dialog re-appears. 
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 BatchExecutor   
 
To start the BatchExecutor, click on Run BatchExecutor in the BatchManager (which also 
executes the job list) or double click the icon in the VP program group. 
 

 
 
You may also start the BatchExecutor from the windows command line prompt. A job file and 
other options can be specified by parameters. Enter 
 
 BatchExecutor.exe /? 
 
to display the available options. 
 

Load 
If you have started the BatchExecutor from the BatchManager the setup jobs are loaded 
automatically. Otherwise, you first need to load a previously saved job list using the Load button. 
Already displayed jobs will be deleted. 
 

Run! 
Clicking Run! starts the job execution. All displayed files will be processed sequentially. The 
Status for each file changes from Ready to Running and, after process execution to Finish. 
 

Stop 
Aborts the processing immediately. 
 

Output 
The Output window displays the currently executed commands. 
 

Exit when finished 
Close the BatchExecutor when all jobs are finished. The output messages are redirected to a log 
file residing in the SUPPORT subdirectory of the VP software installation directory. In the 
example above (Job 1) the log file is named Job 1_log.txt. 
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Scripting    
All VP software commands which can be executed from command line level can also be 
assembled into a plain text file to define the order of consecutive tasks for batch processing. This 
script can be executed from the command line, in a batch, or automatically on program start. 
 
The syntax and available parameters of a particular command will be displayed in the command 
window on entering the desired command with the parameter "/?". 
 
 

Creating a Script 
 

Create Script 
 

Menu: File ► Create Script... 
 

CMD: VPCREATESCRIPT ► Dialog 

The Script Generator dialog pops up. You can easily create new scripts or edit existing ones by 
drag-and-drop commands and/or adjusting parameters: 
 

 
 
The selected command sequence can be tested and edited multiple times until the desired result 
is reached. Existing script files can be loaded and manipulated.  
 

Available Commands  
The list offers all VP commands which are available in your product and which are able to run via 
command line. Use the edit field to filter for commands. E.g. “draw” to get all draw commands. 
Clear the field to get all commands again. To select a command drag-and-drop it into the 
Selected Commands window, or double click it. 
 

Selected Commands 
Command list of the current script. You can adjust the parameters of each command, change its 
orders, or erase one from your script.  
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Change Order  

    Moves a selected command to top/up/down/to bottom. 
 

Delete Command 

 Deletes the selected command from your script. 
 

As Batchjob 
On: The Test will run in a batch mode. Any user interaction will be suppressed. Make sure you 

have specified all parameters probably. Otherwise the script will either stop with an error or 
ignore this command (e.g. all commands which expect a selection). 

Off: The script allows user interaction. The script will stop on any command that is not completely 
specified through its parameters and ask for user input. 

 
Test 

Runs the actual script as defined in the list. When finished the program stops with a Question 
mark cursor. This gives you the opportunity to review the result. With a click the Script 
Generator dialog pops up again.  
For multiple test runs or before finishing the command, a message pops up to reset the document 
to its initial state. 

 
Load 

Loads an existing script file. Default extensions for script files are TXT and SCR. But also any 
other extension is valid as long as this file contains a VP valid script. The commands of the script 
with its parameters will be entered into the Selected Command list. If the script file contains 
unknown command or unknown parameters an error message pops up. 
 

Save 
Saves the script as shown in the Selected Commands list to a file. You can use this script file 
either in a batch job or run it directly (see Execute Script). 
 
 

Text Editor 
 
Use an editor (e.g. the Windows Notepad) and type each command into a separate line (like you 
would do in the command line window).  
 
The following example imports a raster file (the file name may include drive and path if 
necessary), despeckles the file using the automatic despeckle option, deskews the file, and 
exports the cleaned file to a new file: 
 

VPimport <File Name> 
VPspeckles /a 
VPautoDeskew 
VPexport <New File Name> 
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Save this script file as plain text with an arbitrary extension, e.g. "CleanFile.TXT". 

Depending on the commands the execution will stop and prompt the user for input, e.g. if you 
don't enter the parameter <File Name> the open dialog will open for selection. Instead of <New 
File Name> you can also use pre-defined wildcard characters to reflect the original <File Name>: 

%FILEPATH% Path of current file 
%FILENAME% Name of current file (without path and file extension) 
%FILEEXT% File extension of current file 

 
Especially, this may be helpful when scripts are used in a batch process. Example: With the 
following command, each processed file is saved into the folder c:\tmp, adding a suffix to the 
original file name, and keeping the original file extension: 

VPexport "c:\tmp\%FILENAME%_ready. %FILEEXT%" 
 

Execute Script 
 

CMD: VPSCRIPT ► Dialog 
 

CMD: VPSCRIPT <NAME> 

If a script file is specified, this script is executed immediately. Otherwise a file open dialog pops 
up to select a script file. 
 
Depending on the command of the selected script the process may stop for user input. If e.g. no 
file name was specified for an import command, the file open dialog shows up.  
 

Execution on program start 
For execution of the script on program start call the VP software main program MAIN.EXE with 
the parameter /b and the script file name. For example: 
 

Main.exe /b c:\Scripts\CleanFile.txt 
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User Commands   
 

 Toolbar: User Commands 
 

Menu: Options ► User Commands... 
 

CMD: VPWORKFLOW ► Dialog 

The dialog Workflow Configuration opens. 

 
 
The dialog is divided into two sections. The commands on the left side in Available Settings 
allow for managing user commands in setting files. The right section of the dialog shows the 10 
available commands of the loaded setting. 
 

Available Settings 
 

 Directory:Specifies the directory that is used for searching existing setting files. Found files 
are displayed in the list. All files with the extension .wfl are shown while their extension is 
suppressed in the list. 

 Create... :A new settings file is created in the specified directory. Enter an unused Name in 
the upcoming dialog. The currently active Commands will be taken over automatically. 

 Load:The selected settings are loaded and displayed in the Commands list. If the currently 
active commands contain unsaved modifications a safety dialog opens to confirm that the new 
settings shall be loaded. 

 Save:The Commands are saved with the selected name. Existing commands are 
overwritten without safety prompt. 

 Delete... :The selected settings are deleted from the Settings Directory. Deletion has to be 
confirmed in a safety prompt. 
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Commands 
The Commands list displays the currently active definitions for the available 10 user commands. 

The column Command shows the default name of the command for an unambiguous 
identification (user0 - user9). 

Alias displays the user defined synonym for the command. If the user has not assigned any 
synonyms, the default command names are listed here. 

The column Definition contains the commands which will be executed when the user command 
is started.  
 
 

Create / Modify User Commands 
 
With the button  Modify... the dialog Modify Command opens for creation or modification of 
the selected commands’ properties. 

 

 
 
Command:The unique name of the command as it is used by the system. It cannot be changed 

by the user. 

Alias: Customizable name (synonym) for the user command. With this alternative name the 
command can also be called in the command line or in scripts. 

It should not contain blanks or special characters in order to avoid the necessity of quoting 
the command in the command line or in scripts! 

Definition: The command associated with this user command. Possible are command line 
commands, scripts or the call of other programs (see below). 
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Edit Script…: Opens a dialog for creating or editing script files. 

 
 

File name: Name of the script file. The name can either be entered directly or selected with 
the button  If a script has already been assigned to the user command, the 
corresponding file name is displayed here. 

The content of the specified file (if available) is displayed in the text window (command 
list) and can be edited. 

Append from File: The contents of selected script files are copied to the command list. 
 
Click OK to close the dialog and create or change the specified file. The definition of the user 
command is adapted accordingly. 
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Definition 
 

Enter a command as used in the VP software command line input or as a path to a Windows 
application or as a file as used in the Windows command line input in the Definition field. 
 
Examples: 
 
1. A single command (load a prototype drawing)  

vpopen “C:\My Documents\A4\Frame.rvd“ 

2. Processing a sequence of commands (see Command Script in this section for creation of a 
script file) 

vpscript “C:\scripts\cleanfile.txt“ 

3.  Execution of an application (e.g. Windows Notepad) 

c:\windows\notepad.exe 
4. Start of an application through a registered file type  

http://www.softelec.com (start standard Internet browser) 
or 

c:\database\Drawings.mdb (start MS Access with Drawings.mdb) 

As an additional option the file name of the active document can be passed on to the application 
using <File>. For example, you can print in the background in a second program instance: 

"C:\programme\vpview\main.exe" /p <File> 
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Batch Compare   
 

Menu: File ► Batch-Compare... 
 

CMD: VPBATCHCOMPARE ► Dialog 

With Batch Compare, several files or file groups can be selected and compared with each other. 
The result of each comparison is saved in a PDF file for later review. See also Chapter 4: 
Advanced Compare Mode. 
 
 

File Selection 
 
On start the dialog Batch Compare opens. 
 

 
 

Revision 1 / 2 
Path: Path to the files to be added to the file list. Enter or select a path with the button . 
 
Filter: Specifies which files from the selected folder (path) should be added to the file list. Either 

all files (*.*) can be specified or only a selection. The selection is made either via the file 
extension (e.g. *.tif ), a name pattern (e.g. file*.*) or both (e.g. file*.tif). See also Wildcards 
(Batch Manager - Create Batch Job) above. 
Default:  *.* 

 
Add: Adds the files to the associated file list according to the criteria specified above. This 

process can be repeated with different path and filter settings. 
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File List: List of selected files. For multi-page files, each page is listed separately. The order of 
the entries determines which files/pages should be compared. 

   : Use these buttons to move a marked entry up or down.  
 
Remove: Removes selected entries from the file list. 
 

Settings… 
Opens a dialog with settings for the advanced compare mode: 

 
 
Accuracy: Accuracy of the comparison. If the accuracy is low, small differences between the files 

are ignored. 
Default:  Low 

 
Raster for Vector data: With these settings the quality of the comparison can be changed, if a 

file contains vectors. The values are optimized for average drawings and should not be 
changed. 
Default:  300 (Resolution) 
Default:  5000 (max. Pixel Size) 

 
PDF Export: Specifies which areas are to be displayed in the PDF file containing the result of the 

comparison.  

Note: The PDF file always contains all areas. Here you can only specify which areas are 
visible when the PDF file is opened for the first time. Disabled areas can be switched on in 
the PDF reader at any time. 
Default:  show all 

 
Next 

Closes the file selection and proceeds to the output options. 
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Output Options, Start Batch Compare 
 
The following dialog appears:  

 
 
Path: The folder in which the PDF files are to be written. 
 
Add Prefix: Character string that precedes each file name. 

Default:  off 
 
Add Suffix: Character string that is appended to each file name. 

Default:  off 
 

Start Batch Compare 
Press Run to start the compare process. The files (or individual pages) are compared using the 
order in the file lists. For each individual comparison, a PDF file containing the result of the 
comparison is created in the target directory. The name of the first file (Revision 1) is used as the 
file name, in the case of multi-page files the respective page number is added. 
 
When the process is finished, a corresponding message appears. 
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SECTION 16   
REDLINING (WINDOWS ONLY)  
  

General Information   
 
Redlining is a powerful feature to insert mark-ups into an existing drawing. These mark-ups can 
be used to highlight inaccuracies of the drawing, required modifications, or just any kind of 
information for other viewers, e.g. production process handling information, design remarks, etc. 
The redlining entities may be visible to all viewers or hidden at any time.  

In addition to the general redlining functions, VP software offers the possibility to restrict the 
access (view, modify, etc.) to these entities on a user/password basis (see Section 3 System 
Settings - Redlining Tab). 
 
 

 Redlining Functions  
 
The Redlining toolbar offers the following functions: 

• Activate/Deactivate Redlining Mode 
• Import Redlining Data 
• Export Redlining Data 
• Redlining Settings 
• Review Redlining Data 
• Delete Redlining Data 
• Insert Ellipse 
• Insert Cloud 
• Insert Arrow 
• Insert Transparent Rectangle 
• Pick Entity 

 
 

Activate Redlining 
 

 Toolbar: Redlining 
 

Menu: Redlining ► View Redlining 
 

CMD: VPRDLON 

Use this command to activate or close the Redlining functionality. Depending on the access 
rights (see Section 3 System Settings - Redlining Tab), a user will see all the redlining entities of 
that document, or some, or none. When access restrictions are set-up, the user will be prompted 
to enter a user name and a password for logon. 



VP Software Manual  

Manual V16 - V9 / E Section 16     Redlining   505
 

  
 

 
 

Redlining will be activated automatically by loading a drawing which contains redlining 
information. 
 
 

Import  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Import 
 

CMD: VPRDLIMPORT ► Dialog 
 

CMD: VPRDLIMPORT <File Name> 

Allows for importing redlining data from an RLF file. 
 
 

Export  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Export 
 

CMD: VPRDLEXPORT ► Dialog 
  

CMD: VPRDLEXPORT <File Name> 

Redlining data may be exported to RLF, RVD, DWG, DXF, DGN, or CGM file formats. Except for 
the native RVD format, only the redlining data will be exported! RLF is VP software's internal 
format for redlining data with access restriction information. 
Use the native RVD format if access restrictions have been set-up and the whole drawing, 
including redlining information, should be saved to an unrestricted file (e.g. to send the data to 
another party for reviewing). All other export formats will only contain the currently visible (see 
below) redlining entities. These are treated as blocks with attributes, separated on different layers 
depending on the way they have been created. 
 
 

Settings  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Settings 
 

CMD: VPRDLSETTINGS ► Dialog 

Specifies the standard settings for the creation of redlining entities. A dialog opens containing two 
tabs. 
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General Tab 
 

 
 
Define Text Height, Arrow Size, Arc Radius (for cloud entities), and Opacity of the color for the 
redlining entities. Select the Color. These settings apply to the creation of new entities. 
 
Text Height and Color can be modified individually for each entity. 
 
 

Drawing Mode 
 

 
 

Cloud 
Select whether a rectangle or a polygon is to be drawn when drawing a cloud entity. 
 

Transparent Entity 
Select whether a rectangle or a polygon is to be drawn when drawing a transparent entity. 
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Pick Entities 
Select whether a picked polyline or polygon is converted to a cloud entity or a transparent entity.  

Specify, if the picked entity is to be deleted. 
 
 

Filter Tab 
 

 
 
Defines which redlining entities are displayed in the document depending on the user restrictions.  
 

Filter 
By Owner allows for displaying either the redlining mark-ups of: 

• All or  
• From: Selected creators.  

 
By Type allows the selection of the entities according to their status:  

• all entities,  
• revised entities,  
• not revised entities,  
• approved entities,  
• not approved entities. 
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Redlining Review  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Review Redlining 
 

CMD: VPRDLREVIEW ► Moves to 1st redlining entity and opens redlining properties. 

Starts or continues the review of the redlining mark-ups. The program zooms in automatically on 
each redlining entity and displays the properties in a dialog box. Depending on the access rights 
the user may edit the text of each entity or revise/ approve the mark-up. 

 
 

Next, Previous 
Use Next to review the next redlining item and Previous to go back to the last entity reviewed.  
 

Stop 
Stop closes the dialog box. If the review function is called again it will start at the last item 
reviewed. The next entity of the list will be displayed. 
 

Delete Redlining Entities  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Delete Redlining Entities 
 

CMD: VPRDLDELETE ► Select Entities. 

Deletes the selected redlining entities.  
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Insert Ellipse  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Ellipse 
 

CMD: VPRDLELLIPSE ► Requires 2 mouse clicks to define the position and size of the ellipse. 

Inserts a redlining entity with the shape of an ellipse. The size of the ellipse is adjustable in both 
directions by moving the mouse.  
 

Short Text, Comment 
On the second mouse click a dialog box opens to enter a Short Text (headline, which is 
permanently displayed with the entity) and a Comment for the entity. Text Height and Color for 
this entity may be modified from their default values (defined by the Redlining Settings). 
 

 
 
After pressing OK the Short Text can be placed on the drawing. 
 
 

Insert Cloud 
 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Cloud 
 

CMD: VPRDLCLOUD ► Draw a rectangle or polygon 

Inserts a cloud redlining entity. Depending on the drawing mode, a rectangle or a polygon entity 
will be drawn. Change the drawing mode in the settings or via the context menu. 

Same handling as Insert Ellipse. 
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Insert Arrow 
 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Arrow 
 

CMD: VPRDLARROW ► Requires one mouse clicks to define the position of the top of the arrow.  

Inserts a redlining entity with the shape of a pointing arrow. Same handling as Insert Ellipse. 
 
 

Insert Transparent Rectangle 
 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Transp. Rectangle 
 

CMD: VPRDLTRECT ► Draw a rectangle or polygon 
 
Inserts a transparent redlining entity. Depending on the drawing mode, a rectangle or a polygon 
entity will be drawn. Change the drawing mode in the settings or via the context menu. 
 
Same handling as Insert Ellipse. If required, use the Properties to modify the transparency. 
 
 

Pick Entity 
 

 Toolbar: Redlining 
 

Menu: Redlining ► Pick Entity 
 

CMD: VPRDLPICK ► Click on a vector entity (closed polylines/polygons or circles/ellipses only). 
 
Converts selected vector entities to redlining entities.  
 
Closed polylines and polygons will be converted to transparent entities or cloud entities, 
depending on the current settings (see also Settings - Drawing Mode). The drawing mode can 
also be changed via the context menu. Circles and Ellipses will be converted to ellipse entities. 
 
The picked entity will be deleted, if specified in the settings (default: on).  
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Redlining Configuration    
 
In some applications it may be of interest to limit the access of users with redlining.  
 
Imagine the following situation: A company has a support center which creates redlining mark-
ups (e.g. modification demands or improvement requests from customers) into an existing 
drawing. The support staff should only insert new entities, but not remove or modify items 
inserted by other employees. At a higher level a manager reviews these entities, and marks those 
as Revised which should actually go into re-design etc. Then, the "revised entities" are disabled 
from any modification. The draftsman in charge may modify the drawing according to the redlining 
mark-ups and their comments, but he may not modify the redlining or even remove the entities. At 
a final supervision level another manager checks the document modifications and compares them 
with the redlining mark-ups. He then approves the modifications checking Approved or he may 
erase these entities from the drawing if no further check or approval is necessary. 
 
To achieve this structure, restrictions can be set up for each user depending on his function 
inside the company hierarchy. Use the program RLCFG.EXE located on the CD in the directory 
\Redlining. Copy the program to any location on your hard disk. 
 
If the program is called the first time it will show the following dialog: 
 

 
 
Specify a path for the configuration file and press New to create a new configuration setting. If a 
configuration file has already been set up, just enter the path where it is located and press OK.  

 For proper operation of the Redlining Configuration file it is demanding that the 
administrator and all added users have read/write access rights to the location of the 
configuration file! 

 
After generation of a new configuration file only one user is available by default: the 
ADMINISTRATOR (no password). You can start to add and/or modify users and/or groups. On 
Exit the configuration file will be updated and saved.  

 When calling the program again a Logon and Administrator Rights are required to open 
the program. 
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Configure Redlining Users/User Groups 
 
The user management is similar to the one used with Windows NT/2000/XP. User Groups 
having specified rights may be created and Users may be assigned to the groups. A user can 
only be a member of one group and has the rights specified for that group! 
 
The following rights can be specified: 

• Admin All rights are assigned to an Administrator.  
This user can also create, modify, and delete users and groups. 

• View The user can only view (look at) the redlining entities and their properties. 

• Print The user can print the redlining entities. If this right is switched off, the 
redlining entities will not be printed even though the entities are displayed. 

• Export The user can export the redlining data to an unrestricted vector or hybrid 
file. 

• Create The user can create/add new entities. He is allowed to modify, edit, or erase 
these entities created by himself (he is the owner) until they are revised. 

• Modify The user can modify (move, change) any redlining entity which is not 
revised. 

• Edit The user can edit the text/comment of any redlining entity which is not 
revised. 

• Erase The user can erase any redlining entity. 

• Revise The user can set the 'revised' flag to an entity. 

• Approve The user can set the 'approved' flag to an entity. 

• No Rights User has no redlining rights at all.  
He will not even see redlining entities on a document. 

 
 

List Users 
 

 
 
Displays a list of all users, their groups, and access rights. 
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New User 
 

 
 
Creates a new user. Enter the user name and the password. Assign the user to any available 
group as a new member.  
 
 

Edit User 
 

 
 
Edits an existing user. You can modify his password or the group assignment. 
 
 

Delete User 
 

 
 

Deletes an existing user. 

 An error message appears if the last user or the ADMINISTRATOR should be deleted! This 
is not possible. 
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New Group 
 

 
 
Creates a new group. Specify a group name and the access rights for this group. 
 
 

Edit Group 
 

 
 
Edits an existing group. Modify the rights of that group. Any changes apply to all users of the 
group. 
 
 

Delete Group 
 

 
 
Deletes a group. A group can only be deleted if there are no users assigned to it! 
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SPECIFICATIONS    
 

General Specifications for all VPHybridCAD Products  
 
Import / Export Formats See Appendix 
 
Scanner Interface 

 
TWAIN 

 
Raster Image Formats 

 
No real limitation: 16 million x 16 million pixels max., 
VPlite: Up to A2 ("C") @ 300 DPI,  
i.e. 16,000 x 16,000 pixels max., total 36 million pixels 

 
General Functions 

 
Multi document interface 
Multi page documents (only on Windows) 
Command line interface 
Layer, linetype, text style, width, color manager 
Project bar (only Windows) 
Image settings 
User coordinate system (user units, scale, origin) 
Coord snap 
Grid, grid snap 
Ortho, polar, tangent, perpendicular snap 
Raster and vector snap 
Measure: distance, angle 
Undo, redo, Redraw 
Drag'n drop 
Cut/copy/paste 
Properties (view, modify) 
Select, delete entities 
Quick selection 

 
Functions of Raster Editor 

 
Auto Deskew and Despeckle 
Automatic Cut 
Window/Polygon cut, crop,  
Cut to drawing format, 
Deskew raster file 
Rotate raster file: 90°, 180°, 270°, arbitrary angle 
Mirror, Invert raster file 

 Scale drawing 
Despeckle raster file/window: 1 thru 128 pixels 
Fill holes in raster file/window: 1 thru 128 pixels 

 
Raster Editing 

 
Select raster (pick, window, polygon),  
Copy, Move, Erase raster  
Draw raster entities 
Edit text 

 
Raster Object 

 
Copy to, Paste from symbol library 
Create Raster Object with raster selection  
Raster Object separation 
Move, Copy, Scale, Rotate raster object 
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Functions of Vector Editor Select vector entities  

Modify/Match layer assignments 
Draw: line, polyline, spline, arc, circle, ellipse,  
 quadrangle or polygon area 
Insert: arrowhead, point with style 
Entities:  adjust, move, copy, scale, rotate, mirror 
Text:  create, move, rotate, scale  
Direct text edit: text, multiline text 
 

Color Operations  Automatic binarisation 

CAD Settings Object snap modes  
Length of pointing and dimension arrowhead 
Hatch: single/cross, angle, line distance, solids 
Transparency: on/off, fix/variable 

Graphical User Interface Command input via mouse, keyboard (command line) 
DDE/OLE interface 
Toolbars moveable and customizable 
Online help 

Graphical Display 
 

Graphical resolution according to OS and hardware 
ZOOM and PAN function 
Bird's eye 
Overlay of raster data and vectors 
Modification of presentation colors (foreground, cursor, 
background, grips, etc.) 

Plot, Print Whole drawing, current view, paper format 
Scaling: fit paper/custom scaling factor 
Raster data and/or vector data, selectable through layer 
settings. 
Linewidth table 
Preview 

Operating Systems Windows 7 or higher (32bit + 64bit) 
AutoCAD 2010 - 2020 (32bit+64bit) 
BricsCAD V18 - V20 (32bit + 64bit) (pro+platinum) 
ZWCAD 2020 

Recommended Hardware Windows 7 compatible PC (8 GB) or better 
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VPstudio (additional Specifications)  
 
Direct Scanner Interface CalComp, Colortrac, Contex, Océ, Vidar, Xerox  
 
Add. General Functions 

 
Page control 
Symbol library 
Command script 
Rasterize entities  
Color conversion RGB/PAL, RGB/bw, PAL/RGB, 
RGB/bw, view palette 
Trim, autotrim, extend entities 
Chamfer, Fillet 
Cut, break entities 
Build corner between entities 
Stamp 
Compare revisions 

 
User Commands 

 
Customize toolbar commands 
Execute single commands, command sequences, 
command scripts, other applications 

 
Table Recognition 

 
Modify shape and content of raster tables 
Convert table in vectors  

 
Functions of Raster Editor 

 
Click-select, raster entities 
Select raster objects 
Modify, move, copy, combine raster entities/objects 
Split raster file 
Merge, adjust 2 raster files 
Rubber sheeting (4 point, multi point) 
Smooth entities with raster selection (arc, circle, line) 
Fill raster (b/w, colors) 
Filter: morphology, smooth raster 
Raster symbol search 

 
Functions of Vector Editor 

 
Multiline Text: create, move, rotate, scale  
Edit objects: Array, offset  
Edit, combine, adjust: 
 line, polyline, spline, arc, circle, ellipse 
Edit linetypes, text  
Review texts  
Create/edit, explode, insert blocks 
Create and edit block attributes 
Create, explode, erase hatch/solids 
Smooth transitions between elements 
Adjust, align textTransform Arcs, Circles, Ellipses, Splines 
into Polylines  

 
Dimensions 

 
Linear, aligned, radial, diameter, angular, continue, 
baseline 
Dimension style manager 
Automatic mode, manual mode 
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Color Operations  Filter: pre-defined (Median, Sharpen, etc.) 

 custom filter up to size 7×7 pixels 
Color reduction: automatic/interactive/minor colors 
Color separation 
Color classification  
Load/save palette 
Contrast/brightness/white point/black point/gamma 
correction 

 
Vectorization  

 
Line, arc, circle, ellipse extraction 
Small circle recognition/replacement 
Line width (weight) classification 
Line straightening, line chaining 
Line type recognition: dashed, dash-dotted 
Element and line width assignment to layers  
Angle correction 
Gap jump 
Coord snap 
Arrowhead, Connection dot (donut) recognition 
Hatch extraction  
Text recognition (OCR) 

Area File, window or polygon area on b/w or active color 
Methods of Vectorization Centerline 

Outline 
Centerline/outline 

Threshold selectable 5 thru 63 pixels 
Advanced Image Settings Select color/gray scale pattern for active color 

Accuracy ± 1 pixel = ± 0.0635 mm = ± 2.5 mils (@ 400 DPI) 
Wizard Support with parameter setting 

Tracing 
 

On b/w or active color 
With or without erasure of raster background (b/w): 
CAD entities (line, arc, circle) 
Contour line 
Dashed contour line  

Settings Image settings for definition of the active color 
Produce splines 
Straightening parameter 
Assign elevation 
Vectorization method 

OCR Choose character set from 28 languages 
Special characters, handwritten text recognition 

Symbol Search 
 

Settings 

Symbol search and extraction/replacement with automatic 
attribute assignment 
Parameter files (load, edit, save) 
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Color Transparency 

 
Settings 

Draw quadrangle or polygon area and fill with selectable 
transparent color. 
0 thru 100 % transparency 

Redlining Redlining objects: 
 Ellipse, arrow, cloud, transparent  
Head line and comment text input 
Free positioning of head line text 
Pick entity to convert to redlining object 
User access control and rights configuration 
Redlining save and export 

Batch 
Processing 

Vectors Execute scripts 

Vectorization 
Export to vector file 
Rasterize 

 Raster Automatic Cleanup (Despeckle/Fill holes),  
Automatic Deskew,  
Smooth,  
Invert, Mirror (horizontal), 
Rotate: 90°, 180°, 270°, 
Despeckle: 1 thru 128 pixels, 
Fill holes: 1 thru 128 pixels, 
Convert to other raster formats 
Rubber sheeting ( multi point) execution 
Cut to paper format 
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VPstudio mono (additional Specifications)  
 
Import Formats Raster Only b/w images 
 
Export Formats 

 
Raster 

 
Only b/w images 

 
Direct Scanner Interface 

 
CalComp, Colortrac, Contex, Océ, Vidar, Xerox  

 
Add. General Functions 

 
Page control 
Symbol library  
Command script 
Rasterize entities  
Trim, autotrim, extend entities 
Chamfer, Fillet 
Cut, break entities 
Build corner between entities 
Stamp 
Compare revisions 

 
User Commands 

 
Customize toolbar commands 
Execute single commands, command sequences, scripts, 
other applications 

 
Table Recognition 

 
Modify shape and content of raster tables 
Convert table in vectors  

 
Functions of Raster Editor 

 
Click-select, raster entities 
Select raster objects 
Modify, move, copy, combine raster entities/objects 
Split raster file 
Merge, adjust 2 raster files 
Rubber sheeting (4 point, multi point) 
Smooth entities with raster selection (arc, circle, line) 
Fill raster  
Filter: morphology, smooth raster 
Raster symbol search  
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Functions of Vector Editor 

Multiline Text: create, move, rotate, scale  
Edit objects: Array, offset  
Edit, combine, adjust: 
 line, polyline, spline, arc, circle, ellipse 
Edit linetypes, text  
Review texts  
Create/edit, explode, insert blocks 
Create and edit block attributes 
Create, explode, erase hatch/solids 
Build corners between elements 
Trim elements 
Smooth transitions between elements 
Adjust, align text 
Transform Arcs, Circles, Ellipses, Splines into Polylines  

 
Dimensions 

 
Linear, aligned, radial, diameter, angular, continue, 
baseline 
Dimension style manager 
Automatic mode, manual mode 

 
Vectorization  

 
Line, arc, circle, ellipse extraction 
Small circle recognition/replacement 
Line width (weight) classification 
Line straightening, line chaining 
Line type recognition: dashed, dash-dotted 
Element and line width assignment to layers  
Angle correction 
Gap jump 
Coord snap 
Arrowhead, Connection dot (donut) recognition 
Hatch extraction  
Text recognition (OCR) 

Area File, window or polygon area on b/w or active color 
Methods of Vectorization Centerline 

Outline 
Centerline/outline 

Threshold selectable 5 thru 63 pixels 
Accuracy ± 1 pixel = ± 0.0635 mm = ± 2.5 mils (@ 400 DPI) 

Wizard Support with parameter setting 
 
Tracing 

 

 
With or without erasure of raster background  
CAD entities (line, arc, circle) 
Contour line 
Dashed contour line  

Settings Produce splines 
Straightening parameter 
Assign elevation 
Vectorization method 
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OCR Choose character set from 28 languages 

Special characters, handwritten text recognition 
  
 
Symbol Search 

 
Settings 

 
Symbol search and extraction/replacement with automatic 
attribute assignment 
Parameter files (load, edit, save) 

 
Redlining 

 
Redlining objects: 
 Ellipse, arrow, cloud, transparent  
Head line and comment text input 
Free positioning of head line text 
Pick entity to convert to redlining object 
User access control and rights configuration 
Redlining save and export 

 
Batch 
Processing 

 
Vectors 

 
Execute scripts 

Vectorization 
Export to vector file 
Rasterize 

 Raster Automatic Cleanup (Despeckle/Fill holes),  
Automatic Deskew,  
Smooth,  
Invert, Mirror (horizontal), 
Rotate: 90°, 180°, 270°, 
Despeckle: 1 thru 128 pixels, 
Fill holes: 1 thru 128 pixels, 
Convert to other raster formats 
Rubber sheeting ( multi point) execution 
Cut to paper format 
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VPlite (additional Specifications)  
 
Import Formats Raster Only b/w images, limited size 
 
Export Formats 

 
Raster 

 
Only b/w images, limited size 

 
Raster Image Formats 

 
Up to A2 ("C") @ 300 DPI,  
i.e. 16,000 x 16,000 pixels max., total 36 million pixels 

 
Add. General Functions 

 
Symbol library  
Rasterize entities  
Trim, autotrim, extend entities 
Chamfer, Fillet 
Cut, break entities 
Build corner between entities 

 
Functions of Raster Editor 

 
Click-select, raster entities 
Select raster objects 
Modify, move, copy, combine raster entities/objects 
Rubber sheeting (4 point, multi point) 
Smooth entities with raster selection (arc, circle, line) 
Fill raster  
Filter: smooth raster   

 
Functions of Vector Editor 

 
Multiline Text: create, move, rotate, scale  
Edit objects: Array, offset  
Edit, combine, adjust: 
 line, polyline, spline, arc, circle, ellipse 
Edit linetypes, text  
Review texts  
Create/edit, explode, insert blocks 
Create and edit block attributes 
Create, explode, erase hatch/solids 
Build corners between elements 
Trim elements 
Smooth transitions between elements 
 

Vectorization  Line, arc, circle, ellipse extraction 
Small circle recognition/replacement 
Line width (weight) classification 
Line straightening, line chaining 
Line type recognition: dashed, dash-dotted 
Element and line width assignment to layers  
Angle correction 
Gap jump 
Coord snap 
Arrowhead, Connection dot (donut) recognition 
Hatch extraction  
Text recognition (OCR) 
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Vectorization  Area File, window or polygon area on b/w or active color 
Methods of Vectorization Centerline 

Outline 
Centerline/outline 

Threshold selectable 5 thru 63 pixels 
Accuracy ± 1 pixel = ± 0.0635 mm = ± 2.5 mils (@ 400 DPI) 

Wizard Support with parameter setting 
 
Tracing 

 

 
With or without erasure of raster background  
CAD entities (line, arc, circle) 
Contour line 
Dashed contour line  

Settings Produce splines 
Straightening parameter 
Assign elevation 
Vectorization method 

 
OCR 

 
Choose character set from 28 languages 
Special characters, handwritten text recognition 

 
Symbol Search 

 
Settings 

 
Symbol search and extraction/replacement with automatic 
attribute assignment 
Parameter files (load, edit, save) 
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VPraster (additional Specifications)  
 
Direct Scanner Interface CalComp, Colortrac, Contex, Océ, Vidar, Xerox  
 
Add. General Functions 

 
Symbol library 
Rasterize entities  
Color conversion RGB/PAL, PAL/RGB, view palette 
Trim, autotrim, extend entities 
Chamfer, Fillet 
Cut, break entities 
Build corner between entities 
Stamp 
Compare revisions 

 
User Commands 

 
Customize toolbar commands 
Execute single commands, command sequences, scripts, 
other applications 

 
Table Recognition 

 
Modify shape and content of raster tables 
Convert table in vectors  

 
Functions of Raster Editor 

 
Click-select, raster entities 
Select raster objects 
Modify, move, copy, combine raster entities/objects 
Split raster file 
Merge, adjust 2 raster files 
Rubber sheeting (4 point, multi point) 
Smooth entities with raster selection (arc, circle, line) 
Fill raster (b/w, colors) 
Filter: morphology, smooth raster  

 
Functions of Vector Editor 

 
Multiline Text: create, move, rotate, scale  
Edit objects: Array, offset  
Edit, combine, adjust: 
 line, polyline, spline, arc, circle, ellipse 
Edit linetypes, text  
Review texts  
Create/edit, explode, insert blocks 
Create and edit block attributes 
Create, explode, erase hatch/solids 
Build corners between elements 
Trim elements 
Smooth transitions between elements 
Adjust, align text 

 
Dimensions 

Linear, aligned, radial, diameter, angular, continue, 
baseline 
Dimension style manager 
Automatic mode, manual mode 
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Color Operations  Filter: pre-defined (Median, Sharpen, etc.) 

 custom filter up to size 7×7 pixels 
Color reduction: automatic/interactive/minor colors 
Color separation 
Color classification  
Load/save palette 
Contrast/brightness/gamma correction 

 
Tracing 

 

 
On b/w or active color 
With or without erasure of raster background (b/w): 
CAD entities (line, arc, circle) 
Contour line 
Dashed contour line  

Settings Image settings for definition of the active color 
Produce splines 
Straightening parameter 
Assign elevation 
Vectorization method 

 
OCR 

 
Choose character set from 28 languages 
Special characters, handwritten text recognition 

 
Color Transparency 

 
Settings 

 
Draw quadrangle or polygon area and fill with selectable 
transparent color. 
0 thru 100 % transparency 

 
Redlining 

 
Redlining objects: 
 Ellipse, arrow, cloud, transparent  
Head line and comment text input 
Free positioning of head line text 
Pick entity to convert to redlining object 
User access control and rights configuration 
Redlining save and export 

 
Batch 
Processing 

 
General 

 
Vector 

 
Raster 

 
Execute scripts 
 
Rasterize 
 
Automatic Cleanup (Despeckle/Fill holes),  
Automatic Deskew,  
Smooth,  
Invert, Mirror (horizontal), 
Rotate: 90°, 180°, 270°, 
Despeckle: 1 thru 128 pixels, 
Fill holes: 1 thru 128 pixels, 
Convert to other raster formats 
Rubber sheeting ( multi point) execution 
Cut to paper format 
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SPECIFICATIONS    
 

General Specifications for all VPmap Series Products  
 
Import Formats Raster GeoTIFF,  JPG, ECW, MrSID, and others (see Appendix) 

 Vector SHP, MIF, DXF, DWG, DGN, and others (see Appendix) 

Hybrid (Raster + Vector) RVD (softelec format), RasterDWG, CGM, VCF, VCI 

Scanner Interface Large Format Scanner Interface (see Appendix) 

TWAIN 
 

Export Formats 
 

Raster GeoTIFF, GIF, JPG, and others (see Appendix) 

Vector SHP, MIF, DXF, DWG, DGN, and others (see Appendix) 

Hybrid (Raster + Vector) RVD (softelec format), RasterDWG/RDWG, CGM 
 

Raster Image Formats 
 

No real limitation: 16 million x 16 million pixels max. 
 

General Functions 
 

Multi document interface 
Multi page documents  
Project Bar 
Command line interface 
Layer, linetype, text style, width, color manager 
Image settings 
User coordinate system (user units, scale,  projection) 
Coord snap 
Grid, grid snap 
Ortho, polar snap 
Raster and vector snap 
Measure: distance, angle, area, length 
Undo, Redo, Redraw 
Cut/copy/paste, drag'n drop 
Properties (view, modify) 
Select, delete entities 
Quick Selection 
Stamp 
Compare revisions 
Attributes: create, import, export, assign, search 
Build corners between elements 
Trim, extend elements 
Chamfer, Fillet 
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Functions of Raster Editor Auto Deskew and Despeckle 
Window/Polygon cut, crop,  
Cut to paper format, 
Deskew raster file 
Rotate raster file: 90°, 180°, 270°, arbitrary angle 
Mirror, Invert raster file 
Scale drawing 
Despeckle raster file/window 
Fill holes in raster file/window  
Filter: morphology, smooth raster 
Split / Mosaic raster file 
Merge, adjust 2 raster files 

 
Functions of Raster Editor 

 
Rubber sheeting (4 point, multi point) 
Smooth entities with raster selection (arc, circle, line) 
Fill raster (b/w, colors) 
 

Raster Editing Click-select raster entities 
Select raster objects 
Modify, move, copy, combine raster entities/objects 
Copy, Move, Erase raster  
Draw raster entities 
Edit text 

 

Raster Object 
 

Copy to, Paste from symbol library 
Create Raster Object with raster selection 
Move, Copy, Scale, Rotate raster object 

 

Functions of Vector Editor 
 

Select vector entities  
Move, copy, scale, rotate, mirror, offset, array entities 
Draw: line, polyline, mline, spline, arc, circle, ellipse, 

quadrangle or polygon area 
Edit, combine, adjust: 

line, polyline, polygon, spline, arc, circle, ellipse 
Insert: arrowhead, point (donut), attribute 
Entities:  adjust, move, copy 
Modify layer assignments 
Edit linetypes, text  
Review texts  
Create/edit, explode, insert blocks 
Create and edit attributes 
Create, modify, explode, erase hatch/solids 
Smooth transitions between elements 
Assign and check elevation 
Text:  create, move, rotate, scale, adjust  
Regenerate polylines, polygons 
Transform arc, circle, ellipse, spline to polyline 
Vector Cleanup, elements and topology 
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Dimensions Linear, aligned, radial, diameter, angular, continue, 
baseline 
Dimension style manager 
Automatic mode, manual mode 

 

Color Operations  
 

Filter:  pre-defined (Median, Sharpen, etc.) 
custom filter up to size 7×7 pixels 

Color reduction: automatic/interactive/minor colors 
Color separation 
Color classification  
Load/save palette 
Contrast/brightness/gamma correction 
Automatic binarization 

 
Color Transparency 

 
Settings 

 
Draw quadrangle or polygon area and fill with selectable 
transparent color. 
0 thru 100 % transparency 
 

 
OCR 

 
Choose character set from 28 languages 
Special characters, handwritten text recognition 

 
Tracing 

 

 
On b/w or active color 
With or without erasure of raster background (b/w): 
CAD entities (line, arc, circle) 
Contour line, polygon, multiple polygons 
Dashed contour line  

Settings Image settings for definition of the active color 
Produce splines 
Straightening parameter 
Assign elevation 
Vectorization method 
Zoom window 
Post processing 

 

CAD Settings 
 

Object snap modes  
Length and dimension arrowhead 
Hatch: single/cross, angle, line distance, solids 
Transparency: on/off, fix/variable 
Point size and style 

 

User Commands 
 

Customize toolbar commands 
Execute single commands, command sequences, 
command scripts, other applications 

 

Table Recognition 
 

Modify shape and content of raster tables 
Convert table in vectors  
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Redlining Redlining objects: 
 Ellipse, arrow, cloud, transparent  
Head line and comment text input 
Free positioning of head line text 
Pick entity to convert to redlining object 
User access control and rights configuration 
Redlining save and export 

 
Batch 
Processing 

 
General 

 
Vector 

 
Raster 

 
Execute Scripts 
 
Rasterize 
 
Automatic Cleanup (Despeckle/Fill holes),  
Automatic Deskew,  
Invert, Mirror (horizontal), Smooth, 
Rotate: 90°, 180°, 270°, 
Despeckle, Fill holes 
Convert to other raster formats 
Rubber sheeting ( multi point) execution 
Cut to paper format 

 
Graphical User Interface 

 
Command input via mouse, keyboard (command line) 
DDE/OLE interface 
Toolbars moveable and customizable 
Online help 

 

Graphical Display 
 

Graphical resolution according to OS and hardware 
ZOOM and PAN function 
Bird's Eye 
Overlay of raster data and vectors 
Modification of presentation colors (foreground, cursor, 
background, grips, etc.) 

 

Plot, Print 
 

Whole drawing, current view, paper format 
Scaling: fit paper/custom scaling factor 
Raster data and/or vector data, selectable through layer 
settings. 
Linewidth 
Preview 

Operating Systems Windows 7 or higher (32bit + 64bit) 
AutoCAD 2010 - 2020 (32bit+64bit) 
BricsCAD V18 - V20 (32bit + 64bit) (pro+platinum) 
ZWCAD 2020 

Recommended Hardware Windows 7 compatible PC (8 GB) or better 
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VPmap pro (additional Specifications)  
 
Vectorization  Area File, window or polygon area on b/w or active color 

Methods of Vectorization Centerline 
Outline 
Centerline/outline 

Threshold selectable 5 thru 63 pixels 
Advanced Image Settings Select color/gray scale pattern for active color 

Accuracy ± 1 pixel = ± 0.0635 mm = ± 2.5 mils (@ 400 DPI) 
Wizard Support with parameter setting 

 
Vector Post Processing  

 

 
Line, arc, circle, ellipse extraction 
Small circle recognition/replacement 
Line width (weight) classification  
Line straightening, line chaining 
Line type recognition: dashed, dash-dotted 
Polyline type recognition: dashed, dash-dotted 
Element and line width assignment to layers  
Angle correction 
Gap jump 
Coord snap 
Arrowhead, Connection dot (donut) recognition 
Hatch extraction  
Text recognition (OCR) 

 
Symbol Search 

 
Settings 

 
Symbol search and extraction/replacement with automatic 
attribute assignment 
Parameter files (load, edit, save) 

 
Batch 
Processing 

 
Vectors 

 
Vectorization and vector post processing 
Export to vector file 
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APPENDIX   
 

Supported Raster Formats VPHybridCAD  
(R = only Import; W = only Export; R / W = Import + Export) 
 

Extension Format Name Black&White Color Multipage 
BMP Windows Bitmap R / W R / W  
B4 Boeing EDMICS R   
C4 EDMICS R / W   
CAL, CG4, RST Cals Raster R / W   
CIT, RLE, TG4 Intergraph R / W   
COT, CRL Intergraph  R / W  
DCX DCX Raster R R Yes2 
G3, G4, RLN GTX Raster R   
GIF Internet GIF R / W R / W  
GP4 Cals Raster R / W   
GR4 ABB Group 4 R   
HRF Hitachi Raster R   
IFF, ILBM Amiga IFF R R  
IG4, IGS Image Systems R R (Gray)  
IM1 Sun Raster R   
IM8 Sun Raster  R  
JPG, JPEG JPEG  R / W  
MIL Cals Raster R / W   
NIF Navy TIFF R R  
OPT Optigraphics R   
PDF Adobe PDF R/W1 R/W1 Yes2 
PNG PNG Raster R / W R / W  
PCX PCX Raster R / W R / W  
RAS Sun Raster R R  
RLC Image Systems R / W   
RLC Xerox RLC R   
RLE Intergraph R / W R / W  
RLN M.O.S.S. RLN R / W   
RNL GTX Raster R   
SUN Sun Raster R R  
TGA Targa Graphics R R  
TIF, TIFF TIFF Raster R / W R / W Yes2 
VIF ABB Raster R   

1 VPCAD: only Raster  
2 VPCAD: only single page 
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Supported Raster Formats VPmap Series  
(R = only Import; W = only Export; R / W = Import + Export) 
 

Extension Format Name Black&White Color Multipage 
BIL GeoSPOT  R  
BMP Windows Bitmap R / W R / W  
B4 Boeing EDMICS R   
C4 EDMICS R / W   
CAL, CG4, RST Cals Raster R / W   
CIT, RLE, TG4 Intergraph R / W   
CRL, COT Intergraph  R / W  
DCX DCX Raster R R Yes 
ECW, ERS ER Mapper R / W R / W  
FST, FF7, HD Landsat  R  
G3, G4, RNL GTX Raster R   
GIF Internet GIF R / W R / W  
GIS, LAN Erdas Raster  R  
GOE NOAA GOES  R  
GP4 Cals Raster R / W   
GR4 ABB Group 4 R   
HRF Hitachi Raster R   
IDC Core IDC  R  
IFF, ILBM Amiga IFF R R  
IG4, IGS Image Systems R R (Gray)  
IM1 Sun Raster R   
IM8 Sun Raster  R  
JP2, J2K, J2C JPEG 2000  R / W  
JPG, JPEG JPEG  R / W  
MIL Cals R / W   
NIF Navy TIFF R R  
OPT Optigraphics R   
PDF Adobe PDF R/W1 R/W1 Yes2 
PNG PNG Raster R / W R / W  
PCX PCX Raster R / W R / W  
RAS Sun Raster R R  
RLC Image Systems R / W   
RLC Xerox RLC R   
RLN M.O.S.S. RLN R / W   
SID LizardTech MrSID R R  
SUN Sun Raster R R  
TGA Targa Graphics R R  
TIF, TIFF TIFF Raster R / W R / W Yes 
VIF ABB Raster R   

1 VPCAD: only Raster  
2 VPCAD: only single page 
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 Supported Vector Formats VPHybridCAD  
 

Extension Format Name VPwin VPacad 

  Vector Hybrid* Vector Hybrid* 
CGM Computer Graphics Metafile R / W R / W R R 
DGN Microstation Design File R / W R / W R R 
DWG AutoCAD R / W    
DWG Raster-DWG R / W R / W  R / W 
DWT AutoCAD R  R  
DXF AutoCAD R / W    
HP2, PLT, PRN HPGL/2 Plot File R  R  
IGES 2-D IGES W  W  
SVG,SVGZ Scaleable Vector Graphics W W   
RVD Softelec Native Format R / W R / W R R 
VCF Old Softelec Native Format R  R R  R 
VCI Old Softelec Native Format R  R R  R 

*) Hybrid = Vector + Raster 
 

  
 

 Supported Vector Formats VPmap Series  
 

Extension Format Name VPwin VPacad 

  Vector Hybrid* Vector Hybrid* 
CGM Computer Graphics Metafile R / W R / W R R 
DGN Microstation Design File R / W R / W R R 
DWG AutoCAD R / W    
DWG Raster-DWG R / W R / W  R / W 
DWT AutoCAD R  R  
DXF AutoCAD R / W    
HP2, PLT, PRN HPGL/2 Plot File R  R  
IGES 2-D IGES W  W  
MIF MapInfo R / W  R  
SIM SIMA R / W  R  
SVG,SVGZ Scaleable Vector Graphics W W   
RVD Softelec Native Format R / W R / W R R 
SHP, GEN ESRI R / W  R  
VCF Old Softelec Native Format R  R R  R 
VCI Old Softelec Native Format R  R R  R 

*) Hybrid = Vector + Raster 
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Individual Extensions for File Formats (Alias Extensions)   
 
VP software allows you to load and process files which were saved in one of the above file 
formats, however, with other extensions (e.g. files in the TIFF Raster format with the extension 
*.TR). In order to load and process these files you have to create a text file named VP.INI in your 
program directory (e.g. c:\program files\softelec\vpstudio v16) with the following content: 
 
[Import] 
TR="My TIFF File (*.TR),*.TIF" 
 
General: 
<Alias Extension>="<File Description> (*.<Alias Extension>),*.<VP Extension>" 
 
'Alias Extension' specifies the individual extension of a saved file. 'VP Extension' specifies one of 
the standard VP file formats.  
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Supported Scanners   
 
The following table contains the currently supported large format scanners via the direct scanner 
interface: 
 

 

Manufacturer 
 

 

BW / Grayscale 
 

 

Color 
 

CalComp ScanPlus III x00 
ScanPlus III 80 
ScanPlus III x00 -T 
ScanPlus III 800 - T PLUS 
ScanPlus III 800 - T COPY 

ScanPlus III x10 - C 
ScanPlus III x10 - C Copy 
 

Colortrac  CT 36-400 
340 GX+ 
360 CX / GX (+) 
380 CX / GX 
3640 GX / 3680 GX 
4260 GX / 4280 GX 
4860 GX / 5480 GX 
SmartLF 4080 M/C/E 
SmartLF Cx M/C/E 
SmartLF Gx 25/42 (T) M/C/E 

Contex FSS x000 MP 
FSS x200 DSP 

TDS 8000 DSP 

FSS x300 (COPY/PLUS) DSP 

FSS 225x PANORAMA 
 
All Crystal Models 
All Premier Models 
 

FSC x000 DSP 
FSC x010 (COPY) DSP 
FSC x040 CHROMA 
FSC x050 MAGNUM 
 
 
All Chameleon Models 
All Chroma Models 
All Copymate Models 
All Cougar Models 
All Hawk-eye Models 
All Magnum Models 
All Puma Models 
All Toucan Models 
All HD Models 
All SD Models 
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Manufacturer 
 

 

BW / Grayscale 
 

 

Color 
 

HP All Contex OEMs All Contex OEMs 

Océ G60x5 
G60x5-S 
G6035-Sx 
G6045-S 
47xx 
MS 403x 

4770 / 4780 
CS 40xx 
CS 41xx (Q / S) 
CS 4052 

Vidar TruScan 800 
TruScan Flash 
TruScan Select 
 
Flash 600 (e+) 
Surveyor 600 (e) 
TruScan Select 

TruScan Spectra 
TruScan TITAN 
 
All Select Models 
All Atlas Models 
All Latitude Models 
All Lynx Models 
All Nova Models 
All Spectra Models 
Titan H36 (+) / 600e 
All HD Models 
All SD Models 

XEROX 7346 
7356 

 

 
If your scanner is not listed above or has been updated and requires a new driver/interface, 
please visit our website for news regarding third party scanners. You can download new drivers, 
which may support your scanner or improve the support. 
 
 

TWAIN Interface 
 
VP software offers a TWAIN interface. If your Scanner does also supply a TWAIN interface it can 
be used to connect to VP software. You should find further information on the TWAIN interface in 
your Scanner documentation 
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Default Command Alias Names    
Command Header English Alias Name 

Windows, ACAD 
Alias Name 
Windows 

VPAUTODESKEW VPRAD RAD 
VPCLEAN VPRCL RCL 
VPCROP VPRCR RCR 
VPCUTWINDOW VPRC RC 
VPDESKEW VPRD RD 
VPDRAWARC3POINT VPA3 A3 
VPDRAWARCCENTRAD VPA A 
VPDRAWARCTANGCENT VPAT AT 
VPDRAWARROWDIM VPAR AR 
VPDRAWARROWPOINT VPARP ARP 
VPDRAWCIRCLE2POINT VPC2 C2 
VPDRAWCIRCLE3POINT VPC3 C3 
VPDRAWCIRCLECENTRAD VPC C 
VPDRAWCPOLY VPPC PC 
VPDRAWDONUT VPD D 
VPDRAWELLIPSE VPE E 
VPDRAWLINE VPL L 
VPDRAWMTEXT VPM M 
VPDRAWOPTIONS VPDO DO 
VPDRAWPOLY VPP P 
VPDRAWPOLYGON VPPO PO 
VPDRAWRECTANGLE VPR R 
VPDRAWSPLINE VPSP SP 
VPDRAWTEXT VPT T 
VPEXIT VPX X 
VPHMIRROR VPRH RH 
VPINVERT VPRI RI 
VPMORPHO VPRM RM 
VPNEXTPAGE VPN N 
VPOPEN [Ctrl-O] [Ctrl-O] 
VPPOLYCROP VPRCRP RCRP 
VPPOLYCUT VPRCP RCP 
VPPREVPAGE VPPV PV 
VPRFE VPRR RR 
VPROTATE VPRO RO 
VPROTATE90 VPR9 R9 
VPSAVE [Ctrl-S] [Ctrl-S] 
VPSAVEAS VPSA SA 
VPSCALE VPRSC RSC 
VPSMOOTH VPRSM RSM 
VPSPECKLES VPRS RS 
VPVECTORIZE VPV V 
VPVMIRROR VPRV RV 

 

Use this format for modifying or entering new Command Aliases saved to the file ALIASES.PGP 
(SUPPORT subdirectory): 

VP<AliasName>,*<CommandName> 
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Keyboard Shortcuts     
 
All keyboard shortcuts are listed in the menu next to their commands, too 
 

Function keys 
[F1] Help 
[Shift] + [F1]  Context Help  
[F2] Measure 
[F3] Properties 
[Shift] + [F3]  Image Settings  
[F4] Show / hide Raster 
[F5] Show / hide Vectors 
[F8] Raster Selection Settings 
[Shift] + [F8]  Drawing Aids  
[F9] Coord Snap on/off 
[Shift] + [F9]  Show / hide Grid  
[F10] Ortho Snap on/off 
[Shift] + [F10] Polar Snap on/off 
[F11] Raster Snap on/off 
[F12] Vector Snap on/off 
 

Cursor control keys 
[ ] Scroll up 
[ ] Scroll down 
[←] Scroll left 
[→] Scroll right 
[Shift] + [ ]  Page up 
[Shift] + [ ]  Page down 
[Shift] + [←]  Page left 
[Shift] + [→]  Page right 
 

Zoom functions 
[Mult] (Numeric keypad)  Zoom all 
[Div] (Numeric keypad) Zoom pixel 
[5] (Numeric keypad) Zoom window 
[Space] + left mouse button pressed  Pan dynamic 
 

Multipage functions 
[Pg Up] Previous page 
[Pg Dn] Next page 
[Home] First page 
[End] Last page 
 

Draw order 
[Shift] + [Pg Up] Draw in front 
[Shift] + [Pg Dn] Draw in background 
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Various functions 
[Ctrl] + [A] Select all 
[Ctrl] + [C] Copy 
[Ctrl] + [E] Erase raster background 
[Ctrl] + [F] Quick select 
[Ctrl] + [N] New 
[Ctrl] + [O] Open 
[Ctrl] + [P] Print 
[Ctrl] + [R] Redraw 
[Ctrl] + [S] Save 
[Ctrl] + [T] Combine to text 
[Ctrl] + [V] Paste 
[Ctrl] + [X] Cut 
[Ctrl] + [Y] Redo 
[Ctrl] + [Z] Undo 
 
[Ctrl] + [Ins] Copy 
[Shift] + [Del]  Cut 
[Shift] + [Ins]  Paste 
 
[Shift] + [Enter] Show / activate command line 
 
[Del] Delete 
[Esc] Cancel 
 
[Alt] + [Backspace] Undo 
 
[Win Menu]  right mouse click 
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Toolbars (overview)   
 
The overview shows all toolbars of the VP software. Depending from the installed product some 
toolbars might be reduced or not available. 

 

 Adjust Text 

 Attributes 

 BatchManager 

 Block 

 Browser 

 CAD Symbol Search 

 Classification 

 Color Tools 

 Color 

 Combine to 

 Coordinates 

 Dimension 

 Direct Raster Edit 

 Divide Polygon 

 Draw Order 

 Draw 

 Edit Vectors 

 Group Entities 
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 Hatch 

 Image Settings 

 Indexing 

 Layers 

 Linetypes 

 Page Control 

 Properties/Editing 

 Raster Edit 

 Raster Operations (All) 

 Raster Operations 

 Raster Selection Mode 

 Rasterize 

 Redlining 

 Regeneration 

 Rotate Views 

 Rubbersheeting 

 Scan 

 Select Raster 

 Snap 

 Split+Merge 
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 Standard 

 Symbol Library 

 Symbol Recognition 

 Table Recognition 

 Text Styles 

 Tracing 

 Transform 

 User Commands 

 Vectorization 

 View Bar 

 Width 

 Zoom 
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Filter Parameter   
 

CGM Export  
 

Registry Entries 
Path: \Filter\CGM 
 
Version: 1/3/4  (CGM Version, default: 3) 

IntegerMode: 0  (Real - 32bit floating point) 
 1 (Integer) 

32bitMode: 0  (16 bit Integer) 
 1  (32 bit Integer) 

LayerInfo: 0/1  (Keep Layer Information no/yes, default: 1) 

ExportRaster 0/1  (Write out Raster no/yes, default: 0) 

RLE: 0  (b/w Raster uncompressed) 
 1  (b/w Raster RLE compressed) 

ColorRLE: 0  (colored Raster uncompressed) 
 1  (colored Raster RLE compressed) 
 
 

Parameter 
"/v <version> /int <integermode> /long <32bitmode> /r <raster> /rle <compression>  
/colorrle <compression> /laycol <layercolor>" 
 
/v <version> 1/3/4  (CGM version) 

/int <integermode> 0  (real - 32bit floating point) 
 1 (integer) 

/long <32bitmode> 0  (16 bit integer) 
 1  (32 bit integer) 

/r <raster> 0/1  (write raster data no/yes) 

/rle <compression> 0  (b/w raster uncompressed) 
 1  (b/w raster RLE compressed) 

/colorrle <compression> 0  (colored Raster uncompressed) 
 1  (colored Raster RLE compressed) 

/laycol <layercolor> 0/1  (keep layer info via colors no/yes) 
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CGM Import  
 

Registry Entries 
Path: \Filter\CGM 
 
UseLayerWidth: 0 (by Entity) 
 1 (by Layer) 

HatchSpacing: [value] (hatch pattern - spacing, default: 1.0) 

HatchScaling: [value]  (hatch pattern - scaling, default: 1.0) 

DefaultDPI: [value]  (default resolution for raster images, default: 72) 

DefaultLTypeScaling: [value]  (linetype scaling - default linetypes, default: 1.0) 

EmbeddedLTypeScaling: [value]  (linetype scaling - embedded linetypes, default: 1.0) 

BezierAccuracy: [value]  (interpolation accuracy, default: 20) 
 
 

Parameter 
" /widthbylayer <linewidth> /spacing <hatchspacing> /scaling <hatchscaling> 
/dpi <resolution> /defaultltypescale <linetype-scaling>  
/embeddedltypescale <linetype-scaling> /bezieraccuracy <accuracy>" 
 

/widthbylayer <width> 0 (by entity) 
 1 (by layer) 

/spacing <spacing> [value] (hatch pattern - spacing) 

/scaling <scaling> [value]  (hatch pattern - scaling) 

/dpi <resolution> [value]  (default resolution for raster images) 

/defaultltypescale <scaling> [value]  (linetype scaling - default linetypes) 

/embeddedltypescale <scaling> [value]  (linetype scaling - embedded linetypes) 

/bezieraccuracy <accuracy> [value]  (interpolation accuracy) 
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DGN Export  
 

Registry Entries 
Path: \Filter\DGN 
 
Seedfile 
UseSeedfile: 0/1  (Use Seedfile no/yes, default: 0) 

SeedfileV8: [text]  (name and path of seedfile, default: "") 

Line Widths 
LineWeightMode: 0  (Set all Line Widths to 1 Pixel) 
 1  (Convert Line Widths) 

MM2Pixel: [value] (conversion factor: 1mm to … Pixel, default: 1) 

Raster 
ExportRaster: 0  (Do not save Raster) 
 1  (Embed Raster in DGN-File) 
 2  (Save Raster in extra File(s)) 
 4  (Save Raster in extra File(s) – Save Raster File(s) 

automatically) 
WriteBlackAndWhiteRasterUncompressed: 0  (compress embedded raster) 
 1  (do not compress embedded raster) 

Attributes 
ExportAttributes: 0/1  (Export Attributes as Tags no/yes, default: 1) 

AttributetextHeight: [value]  (Text Height of Tags, default: 3.0) 

WriteTagsAndAttributes: 0/1 (Export Attributes as Tags and DGN Attributes no/yes, 
default: 1) 

Miscellaneous 
ExplodeDimensions: 0/1  (explode dimensions no/yes, default: 1) 

Units 
SU_AutoMode: 0  (Sub Units - Manual Mode) 
 1 (Sub Units depending on Master Units – Auto Mode) 

SU_Units: -6 (Picometers) 
 -5 (Nanometers) 
 -4 (Decimeters) 
 -3 (Mils, milli inch) 
 -2 (Microinches) 
 -1 (Micrometers) 
 1 (Millimeters) 
 2 (Centimeters) 
 3 (Meters) 
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 4 (Kilometers) 
 5 (Inches) 
 6 (Feet) 
 7 (Yards) 
 9 (Miles)  
 
 

Parameter 
"/lwmode <linewidthmode> /mm2pix <linewidthfactor> nodim <explode>   
/raster <rastermode> /bwuncomp <compression> /attribs <attributes> /attheight <textheight>  
/tags <DGNattributes> /autosu <subunitsmode> /su <subunits> /seed <seedfile>"  
 
/lwmode <linewidthmode> 0  (set line width to 1 pixel) 
 1  (convert line widths) 

/mm2pix <linewidthfactor> [value] (conversion factor: 1mm to … Pixel) 

/nodim <explode> 0/1 (explode dimensions) 

/raster <rastermode> 0  (do not save raster) 
 1  (embed raster) 
 2  (save raster in extra file(s)) 
 4  (save raster in extra file(s) – save raster file(s) 

automatically) 

/bwuncomp <compression> 0 (compress embedded raster) 
 1 (do not compress embedded raster) 

/attribs <attributes> 0/1  (export attributes as tags no/yes) 

/attheight <textheight> [value] (text height of tags) 

/tags <DGNattributes> 0/1 (export attributes as tags and DGN-attributes) 

/autosu <subunitsmode>  0/1 (sub units auto mode no/yes) 

/su <subunits> -6 - 9 (sub units) 

/seed <seedfile> ""  (do not use seedfile) 
 [text] (name and path of seedfile to use) 
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DGN Import  
 

Registry Entries 
Path: \Filter\DGN 
 
Model Mode 
LoadModel: 0  (Always load default model) 
 1 (Always load active model) 
 2 (Show list width all available models) 

Linewidth 
LinewidthScale: [value]  (Scale linewidth by value, default: 10.0) 
  (negative value: Set all linewidths to 0.0) 

Scaling 
LinetypeScale: [value]  (Scale linetypes by value, default: 1.0) 

Convert drawing 
RenderMode: 0  (No conversion) 
 1 (Convert complex entities into basic entities) 
 3 (Convert complex entities, convert arcs and circles) 
 5 (Convert complex entities, convert text) 
 7 (Convert complex entities, convert arcs, circles, and text) 
 
 

Parameter 
"/mm <model> /lwz <linewidthmode> /lw <linewidthscale> /ls <linetypescale>  
/rm <rendermode>" 
 
/mm <model> 0  (load default model) 
 1  (load active model) 
 2 (show list with all models) 

/lwz <linewidthmode> 0/1  (set line widths to 0.0 no/yes) 

/lw <linewidthscale> [value]  (line widths scale factor) 

/ls <linetypescale> [value]  (linetype scale factor) 

/rm <rendermode> 0  (no conversion) 
 1 (Convert complex entities into basic entities) 
 3 (Convert complex entities, convert arcs and circles) 
 5 (Convert complex entities, convert text) 
 7 (Convert complex entities, convert arcs, circles, and text) 
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DWG/DXF Export  
 

Registry Entries 
Path: \Filter\DWG / \Filter\DXF 
 
 
On Override of existing files 
OnlyUpdateRaster: 0/1  (Update/append only raster no/yes, default: 0) 

File Format 
Version: 13/14/2000/2004/2007/2010/2013/2018 (AutoCAD Version, default: 2007) 

Raster 
Save Raster: 0  (Do not save Raster, default for DXF) 
 1  (Save in Raster DWG Format) 
 2  (Save in AutoCAD Format, default for DWG) 

AutoSave ISM: 0/1  (Save Raster File(s) automatically no/yes, default: 0) 

Conversion of VP entities 
ConvertPolygon: 0  (Export Polygons as Hatches) 
 1  (Export Polygons as Polylines) 

Seefile 
Seedfile: [text]  (name and path of seedfile to use, default: "") 

Character Set 
ExportCodepage: 1  (Use system code page) 
 [value]  (Windows code page) 

DXF: Floating point precision 
Precision_Auto: 0/1  (DXF: Automatic – Fit to actual drawing content no/yes, 

default: 1) 

Precision: [value] (DXF: User defined – use … digits, default: 16) 
 
 

Parameter 
"/v <version> /r <rastermode> /conv <rendermode> /prec <precision> /seed <seedfile>  
/cp <codepage> /up <updateraster>" 
 
/v <version> [value]   (AutoCAD version) 

/r <rastermode> 0  (do not save raster) 
 1 (save as RDWG) 
 2 (save in AutoCAD format) 
 3 (save in AutoCAD format, save raster files automatically) 



 VP Software Manual 

550   Appendix     Filter Parameter Manual V16 - V9 / E 
 

   
 

/conv <rendermode> 0 (convert polygons to hatches) 
 1 (convert polygons to polylines) 

/prec <precision> 0 (DXF: calculate floating point precision automatically) 
 [value] (DXF: floating point precision) 

/seed <seedfile> [text] (name and path of seedfile to use) 

/cp <codepage> [value] (windows codepage) 

/up <updateraster> 0/1 (Update/append only raster no/yes) 
 
 

DWG/DXF Import  
 
Registry Entries 

Path: \Filter\DWG / \Filter\DXF 
 
Layout Mode 
ActiveLayout: 0 (Open drawing in model space mode) 
 1 (Open drawing in saved layout) 
 2 (Show list with all available layouts) 
 3 (Open model space and all layouts – multipage mode) 
 4 (Open all layouts except model space – multipage mode) 

Convert drawing 
RenderMode: 0  (No conversion) 
 1  (Convert complex entities) 
 2  (Convert complex entities, show warning dialog) 

Render Curves: 0/1  (convert arcs and circles no/yes, default: 0) 

Render text: 0/1  (convert text no/yes, default: 0) 

Render Dashed: 0/1  (layout only: convert dashed lines no/yes, default: 1) 

Render DashedLines: 0/1  (model only: convert dashed lines no/yes, default: 0) 

Line widths 
ImportLinewidth: 0  (Set all line widths to 0.0) 
 1  (Do not convert line widths) 

Password Protected Files 
PasswordMode: 0  (Do not open password protected files) 
 1 (Ask for the password on open) 
 2 (Always use this password) 

Password: [text]  (crypted password, default: "") 
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Hatches 
PatternPaths: [text]  (name and path of hatch definition files *.pat, default: "") 

Character Set 
defaultCodePage: 0  (Determine character set automatically) 
 [value]  (Always use this character set) 

Measurement 
Measurement: 0  (Leave units unchanged) 
 1 (Convert units according to current document settings) 
 2 (Units are in inch, scale with 25.4) 
 3 (Units are metric, scale with 1.0) 

Miscellaneous 
ReadDim: 0/1  (explode dimensions yes=0/no=1, default: 1) 

LoadBlockdefs: 0/1  (layout only: read blockdefinitions no/yes, default: 0) 

ReadEmptyLayout: 0/1  (layout only: load empty layouts no/yes, default: 0) 

Render Paper Border: 0/1  (layout only: load paper borders no/yes, default: 1) 
 
 

Parameter 
"/vm <layout> /rm <conversion> /rc <curves> /rt <text> /rd <dashed> /rdm <dashed>  
/rp <paperborder> /lm <linewidth> /mm <units> /dim <dimensions> /blkdef <blockdefs>  
/rel <emptylayout> /pp <hatchfile> /cp <codepage> /pm <passwordmode> /pw <password>" 
 
/vm <layout> 0   (load model space) 
 1 (load active layout) 
 2 (show list of all layouts) 
 3 (load all layouts) 

/rm <conversion> 0  (no conversion) 
 1 (convert complex entities) 
 2 (convert complex entities, show warning dialog) 

/rc <curves>  0/1 (convert arcs and circles no/yes) 

/rt <text>  0/1 (convert text no/yes) 

/rd <dashed>  0/1 (convert dashed lines no/yes) 

/rd <dashed>  0/1 (layout only: convert dashed lines no/yes) 

/rdm <dashed>  0/1 (model only: convert dashed lines no/yes) 

/rp <paperborder>  0/1 (layout only: load paper border no/yes) 

/lm <linewidth>  0 (set all linewidths to 0.0) 
 1 (do not modify linewidth) 
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/mm <units> 0  (leave units unchanged) 
 1 (convert units according to current document settings) 
 2 (units are in inch, scale with 25.4) 
 3 (units are metric, scale with 1.0) 

/dim <dimensions>  0/1 (explode dimensions yes=0/no=1) 

/blkdef <blockdefs> 0/1 (layout only: read blockdefs no/yes) 

/rel <emptylayout> 0/1 (load empy layouts no/yes) 

/pp <hatchfile>  [text] (name and path of hatch definition files *.pat) 

/cp <codepage>  0 (determine character set automatically) 
 [value] (always use this character set) 

/pm <passwordmode> 0  (do not open password protected files) 
 1 (ask for the password on open) 
 2 (always use this password) 

/pw <password>  [text] (password) 
 
 

GIF Export  
 

Registry Entries 
Path: \Filter\Gif 
 
Transparency: 0  (Do not write Transparency) 
 1  (Transparency Palette Index) 
 2  (Use Image Transparency) 
 5  (Transparency by RGB value) 

PaletteIndex: 0-255 (palette index, default: 0) 

Red: 0-255 (color value, default: 0) 

Green: 0-255 (color value, default: 0) 

Blue: 0-255 (color value, default: 0) 

MatchRGB: 0/1  (match nearest color no/yes, default: 0) 
 
 

Parameter 
"" (no transparency) 
"/TRANS /PAL <palette index>" (transparency by palette index) 
"/TRANS /PAL" (use image transparency) 
"/TRANS /RGB <red green blue>" (Transparency by RGB value) 
"/TRANS /RGB <red green blue> /MATCH " (Transparency by RGB value, match nearest color) 
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JPEG Export  
 

Registry Entries 
Path: \Filter\JPEG 
 
Quality: 0-100  (Quality, default: 75) 
 
 

Parameter 
/QUALITY <quality> [value] (Quality) 
 

 
 

MIF Export  
 

Registry Entries 
Path: \Filter\MIF 
 
Layer Settings 
UseLayerNames: 0/1 (use layer name as filename no/yes, default: 1) 

MapInfo File Options 
Version: [value] (file version, default: 300) 

Delimiter: [text] (delimiter, default: ,) 

ConvPrecision: [value] (accuracy = value / 1000000, default: 100000) 

Coordinate System 
Degrees: 0/1 (coordinates in degrees=1/from file=0, default: 1) 

Prototype: [text] (file) 

CoordSys: [text] (projection data from file) 

CoordFromDoc: 0/1 (coordinates from document, default: 0) 
 
 

Parameter 
"/layernames <bylayer> /version <version> /convprec <accuracy> /degrees <degrees>  
/delimiter <character> /prototype <file> /coordsys <coord.system>" 
 
/layernames <bylayer> 0/1  (use layer name as filename no/yes) 

/version <version> [value]  (file version)  
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/convprec <accuracy> [value]  (accuracy * 1000000)  

/degrees <degrees> 0/1  (coordinates in degrees=1/from file=0)  

/delimiter <character> [text]  (delimiter)  

/prototype <file> [text]  (file)  

/coordsys <coord.system> [text]  (projection data from file)  
 

PDF Export  
 

Registry Entries 
Path: \Filter\PDF 
 
General 
PDFA: 0/1  (PDF/A conform no/yes, default: 0) 

Author: [text]  (Author, default: "") 

Subject: [text] (Subject, default: "") 

Keywords: [text] (Keywords, default: "") 

Placing/Extents 
AtOrigin: 0 (Keep Coordinates if possible) 
 1  (Move to Paper origin) 

PaperFrame: [value] (Additional Frame, positive/negative value: on/off,  
default: 2.0) 

Compression Method 
ColorCompression: 0  (LZW) 
 1  (JPG) 
 2  (uncompressed) 

Quality: 0-100  (Quality, default: 75) 

BWCompression: 0  (CCITT Group 4) 
 1  (uncompressed) 
 
 

Parameter 
"/col <colorcompression> /bw <bwcompression> /q <quality> /pdfa <PDFA> /origin <placing>  
/frame <margin>" 
 
/col <colorcompression> 0 (uncompressed) 
 1 (LZW) 
 2 (JPG) 
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/bw <bwcompression> 0 (uncompressed) 
 4 (CCITT Group 4) 

/q <quality> 0-100  (quality) 

/pdfa <PDFA> 0/1  (PDF/A conform) 

/origin <placing> 0  (keep coordinates) 
 1 (move to paper origin) 

/frame <margin> [value] (additional margin, positive/negative value: on/off) 
 
 

PDF Import  
 

Registry Entries 
Path: \Filter\PDF 
 
AsImage: 0 (Read PDFObjects) 
 1  (Convert into Raster Image) 

DPI: [value] (Resolution, default: 200) 

Extracttext: 0/1 (Try to extract text objects no/yes, default: 0) 

ColorDepth: 1 (As Truecolor Image) 
 2 (As Indexed (Paletted) Image) 
 3 (As Gray Scale Image) 
 4 (As b/w Image) 

ConvertPoly: 0/1 (convert polylines to arcs/circles no/yes, default: 1) 

FitTolerance: [value] (fit tolerance, default: 0.0002) 
 

Parameter 
"/mode <mode> /dpi <resolution> /col <colormode> /text <textconversion>  
/convert <convertpolylines> /tolerance <fittolerance>" 
 
/mode <mode> 0 (read PDF-Objects) 
 1 (convert into raster image) 

/dpi <resolution> [value]  

/col <colormode> 1 (as RGB image) 
 2 (as indexed image) 
 3 (as gray scale image) 
 4 (as b/w image) 

/text <textconversion> 0/1 (convert text no/yes) 

/convert <convpolylines> 0/1 (convert polylines to arcs/circles no/yes) 

/tolerance <fittolerance> [value] (fit tolerance) 
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RVD Export  
 

Registry Entries 
Path: \Filter\RVD 

Version: [value] (RVD compatible to) 
  - 1=VPHybridCAD V7 
  - 2=VPmap V1 
  - 3=VPHybridCAD V8 
  - 4=VPmap V2 
  - 5=VPHybridCAD V9/VPmap V3 
  - 6=VPHybridCAD V10 
  - 7=VPHybridCAD V11/VPmap V4 
  - 8=VPHybridCAD V12/VPmap V5 
  - 9=VPHybridCAD V13/VPmap V6 
  - 10=VPHybridCAD V16/VPmap V9 
 
 

Parameter 
"/v <Version>" 
 
/v <Version> [value]  (file version) 
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SHP/GEN (ESRI) Export   
 

Registry Entries 
Path: \Filter\ESRI 
 
Shapefile Options 
ExportFlags: [value]  (shapefile options, default: 0x1007) 
  - export points (0x01) 
  - export polylines (0x02) 
  - export polygons (0x04) 
  - write z-coordinate (0x10) 
  - layer name as file name (0x1000) 
  - use file name as folder name (0x2000) 
  - overwrite without warning (0x4000) 

Entity Conversion 
TypeConversion: [value]  (entity conversion, default: 0x01) 
  - block to point (0x01) 
  - text to point (0x02) 
  - closed spline to polygon (0x04) 
  - closed ellipse to polygon (0x08) 
  - Circle to polygon (0x10) 
  - closed polyline to polygon (0x20) 
  - explode hatches (0x40) 

ConvPrecision: [value] (accuracy = value / 1000000, default: 100000) 
 
 

Parameter 
"/exportflags <options> /typeconv <conversion> /convprec <accuracy>" 
 
/exportflags <options> [value]  (shapefile options) 

/typeconv <conversion> [value]  (entity conversion)  

/convprec <accuracy> [value]  (accuracy * 1000000)  
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SVG Export  
 

Registry Entries 
Path: \Filter\SVG 
 
Output Size 
SizeMode: 0 (Keep original size in pixel) 
 1 (Scale to fix size) 
 2 (Keep original size in millimeter) 

MaxWidth: [value]  (only if SizeMode = 1: Width in pixel, default: 300) 

MaxHeight: [value]  (only if SizeMode = 1: Height in pixel, default: 200) 

Precision 
Precision: -1  (Automatic) 
 [value]  (Use decimal places, number of digits) 

MinLineWidth: [value]  (min. line width in 1/1000 units, default: 200) 

DotSize: [value]  (min. dot size for dash-dotted lines  
  in 1/1000 units, default: 200) 

SVGHeaderType: 0 (Use default SVGHeader) 
 1 (read from SVGHeader) 

SVGHeader: [text]  (SVG-Header, default: "xmlns= 
  "http://www.w3.org/2000/svg" xmlns:xlink= 
  "http://www.w3.org/1999/xlink"\n") 

DocHeaderType: 0 (Use default DocHeader) 
 1 (read from DOCHeader) 

DOCHeader: [text]  (Doc-Header, default: "<!DOCTYPE svg PUBLIC  
  "-//W3C//DTD SVG 1.1//EN" "http://www.w3. 
  org/Graphics/SVG/1.1/DTD/svg11.dtd"[\n") 

UseSVGInfo: 0  (Use default SVGInfo) 
 1 (read from SVGInfo) 

SVGInfo: [text]  (SVG Info, default: "width="%g%s" height="%g%s"  
  viewBox="0 0 %g %g" onload="if(typeof 
  (parent.fileLoaded) != 'undefined')  
  parent.register2();">\n") 

XLink: [text]  (XLink entry, if attributes "XLink" are present, default:  
  "<a xlink:type="simple" xlink:actuate= 
  "onRequest" xlink:href="#%s"nxlink:show= 
  "replace" xmlns:xlink= 
  "http://www.w3.org/1999/xlink">\n") 
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XLinkNoZeros: 0/1 (remove leading zeros ("0") in attributes "XLink" 
  no/yes, default: 1 ) 

NotInLink: [text]  (Characters to be removed from attributes "XLink", 
  default: "") 

NotInId: [text]  (Characters to be removed from Hotspot links  
  (attribute "id"), default: "") 

SkipLen: [value]  (minimum size for ellipses in 1/1000 units,  
  default: 0) 

EllipseAsPolyline: 0/1  (convert ellipses to polylines no/yes, default: 0) 

RasterAsReference: 0  (Embed Raster Images) 
 1 (Save Raster Images as external Reference) 

RefSubDir: [text]  (Subdirectory for external Raster Images,  
  default: "") 

RefFormat: [text]  (File format for external Raster Images  
  default: "PNG ") 

HotspotsLast: 0/1  (write all elements of layer HotspotLayer at the end  
  of the file, default: 1) 

HotspotLayer: [text]  (Name of Hotspot layer, default: "CC_HOTSPOT") 

TextToRect: 0  (Hotspots as Text) 
 n (Hotspots as transparent rectangles with a frame width 
  of n pixel) 
 -n (negative value: Hotspots as texts and transparent 
  rectangles with a frame width of n pixel) 

RectColor: -1 (transparent rectangles in text color) 
 [value]  (RGB color value of transparent rectangles) 

TextOpacity: [0-100]  (Opacity of transparent rectangles, default: 0) 

TextInPt: 0/1  (text size in pt (1/72 inch) no/yes, default: 1) 
 
 
Parameter 
 
"/mode <size> /w <width> /h <height> /p <precision> /minwidth <linewidth>  
/Svg<SVGHeader> /Doc <DocHeader> /Info <SVGInfo> /XLink <XLinkEntry> /NoZeros 
<NoZeros> /NotInLink <character> /NotInId <character> /skiplen <MinSize> /EasP <ellipses> 
/AsRef <raster> /RefDir <directory> /RefFormat <format> /Last <ToEnd> /Layer <name> 
/Rects <HotspotFormat> /RectColor <Color> /Opacity <OpacityValue> /FontPt <TextSize>"  
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/mode <size> 0 (Keep original size in pixel) 
 1 (Scale to fix size) 
 2 (Keep original size in millimeter) 

/w <width> [value]  (only if SizeMode = 1: Width in pixel) 

/h <heigth> [value]  (only if SizeMode = 1: Height in pixel) 

/p <precision> -1  (Automatic) 
 [value]  (Use decimal places, number of digits) 

/minwidth <liniewidth> [value]  (min. line width in units!) 

/Svg<SVGHeader> [text]  (SVG-Header) 

/Doc <DocHeader> [text]  (Doc-Header) 

/Info <SVGInfo> [text]  (SVG Info) 

/XLink <XLinkEntry> [text]  (XLink entry, if attributes "XLink" are present) 

/NoZeros <NoZeros> 0/1 (remove leading zeros ("0") in attributes "XLink" 
  no/yes) 

/NoZeros <NoZeros> 0/1 (remove leading zeros ("0") in attributes "XLink" 
  no/yes) 

/NotInLink <character> [text]  (Characters to be removed from attributes "XLink")   

 

/NotInId <character> [text]  (Characters to be removed from Hotspot links  
  (attribute "id")) 

/skiplen <MinSize> [value]  (minimum size for ellipses in units!)  

/EasP <ellipses> 0/1  (convert ellipses to polylines no/yes) 

/AsRef <raster> 0  (Embed Raster Images) 
 1 (Save Raster Images as external Reference) 

/RefFormat <format> [text]  (Subdirectory for external Raster Images)  

/RefFormat <format> [text]  (File format for external Raster Images)  

/Last <ToEnd> 0/1  (write all elements of layer HotspotLayer at the end  
  of the file) 

 

/Layer <name> [text]  (Name of Hotspot layer) 

/Rects <Hotspotformat> 0  (Hotspots as Text) 
 n (Hotspots as transparent rectangles with a frame width 
  of n pixel) 
 -n (negative value: Hotspots as texts and transparent 
  rectangles with a frame width of n pixel) 
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/RectColor <color> -1 (transparent rectangles in text color) 
 [value]  (RGB color value of transparent rectangles) 

/Opacity <OpacityValue> [0-100]  (Opacity of transparent rectangles) 

/FontPt <TextSize> 0/1  (text size in pt (1/72 inch) no/yes) 
 
 

TIFF Export  
 

Registry Entries 
Path: \Filter\Tiff 
 
Strip Control 
StripMode: 0  (Auto) 
 1  (Single Strip) 
 2  (Multiple Stripes) 

RowsPerStrip: [value] (Rows Per Strip, default: 512) 

Color Options 
ColorCompression: 0  (uncompressed) 
 1  (LZW) 
 2  (Packbits) 

Monochrome Options 
MonoCompression: 0  (uncompressed) 
 1  (CCITT Group 4) 

 
 

Parameter 
"/col <color options> /bw <bw options> /st <strip control> <number of rows>" 
 
/col <color options> 0 (uncompressed) 
 l (LZW) 
 p (Packbits) 

/bw <bw options> 0 (uncompressed) 
 4 (CCITT Group 4) 

/st <strip control> a  (automatic) 
 s  (single strip) 
 m  (multiple stripes) 

<number of rows> [value] (rows per strip) 
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XDW Export  
 

Registry Entries 
Path: \Filter\XDW 

Create: [text] (create XDW using TIF/JPEG, default: TIF) 

Append: [text] (append original data) 
  - none 
  - PDF 
  - DWG 
  - RVD 
 
 

Parameter 
"/C <filetype> /A <filetype>" 
 
/C <filetype> [text]  (create XDW) 

/A <filetype> [text]  (append original data)  
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DDE and OLE   
 
VP software features a Windows compliant DDE and OLE interface that allows other applications 
to communicate with it. This may be useful in conjunction with, for example, a database 
application, which manages files that can be viewed and processed with VP software. 
Specifically, you can: 

1. Create a VP software object via OLE automation and execute commands on it.  
2. Establish a DDE link to VP software to execute commands via DDE.  

 Note: You can not link or embed a VP software object in an OLE container application (OLE 
compound file)! 

 
To 1: OLE Automation capable programs (like Microsoft Excel) may create and operate 

on a 'VP.Document' object (OLE short name). The available automation functions 
are (written in C):  

 
long    GetProcessID (); 
short   Execute (BSTR pszCommand); 
long    GetDocumentCount (); 
BSTR    GetDocumentName (long lDocumentNumber); 
boolean CloseDocument (BSTR lpszDocument); 
long    ShowWindow (BSTR lpszDocument, long iShow); 
long    GetLastError (BSTR* pszErrorString, long lErrorLength); 

 
There's a type library called VP.TLB installed in the VP software directory, which can be read by 
software development tools (like Microsoft Visual C++). In this case, the function prototypes listed 
above will be automatically generated in your target language. 
 

To 2: The VP software is a DDE server that accepts the start of a conversation with the 
following data:  

Application: VPxx 
Topic: System 

 
The DDE interface can handle WM_DDE_EXECUTE commands with the following syntax: 
 

[command1][command2][command3]... 
 
Do not omit the brackets ('[...]')! This way, you can execute an unlimited number of commands at 
once. 
 
The commands that are available for DDE execution are all commands you can use from the 
command line of VP software. 
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Example, OLE via Visual Basic: 

 
Sub InvertWithVPOLE(strFile) 
 
    Dim strImp As String 
    Dim strExp As String 
    Dim VP As Object 
    Set VP = CreateObject("VP.Document") 
 
    strImp = "open " & Chr(34) & strFile & Chr(34) 
    strExp = "export " & Chr(34) & strFile & Chr(34) & " /p -1" 
 
    VP.Execute (strImp) 
    VP.Execute ("invert") 
    VP.Execute (strExp) 
    VP.Execute ("closealways") 
    VP.Execute ("exit") 
 
    MsgBox "File has been inverted and exported with OLE!" 
 

End Sub 
 

The above Visual Basic program uses OLE to invert a drawing. Only the most important 
command you can use with VP software and OLE has been used in this example: Execute. With 
Execute you can start all commands that are available via the command line. 
 
Note: closealways closes a document even if it is still modified. You should always use the exit 
command to close down the OLE application when you no longer need it. 
 
OLE generally works on invisible documents. There are two possible scenarios: 1) The 
application is already started: OLE opens an new, but invisible document. 2) The application is 
not yet started: The application is started completely invisible. Thus OLE is restricted to batch 
processing. For interactive task you can use DDE or scripting. 
 
 

Example, DDE via Visual Basic: 
 
Private Sub InvertWithVPDDE(strFile) 
    Dim intChan 
    Dim strImp As String 
    Dim strExp As String 
 
    'Use System Topic to connect to VP 
    'VP must be running in order to connect 
 

    intChan = DDEInitiate("VPxx", "System") 
 
    strImp = "[open " & Chr(34) & strFile & Chr(34) & "]" 
    strExp = "[export " & Chr(34) & strFile & Chr(34) & " /p -1]" 
 

    DDEExecute intChan, strImp 
    DDEExecute intChan, "[invert]" 
    DDEExecute intChan, strExp 
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    DDEExecute intChan, "[closealways]" 
 
    MsgBox "File has been inverted and exported with DDE!" 
 
    'Terminate DDE conversation 
    DDETerminate intChan 
 
End Sub 
 
The above Visual Basic program uses DDE to invert a drawing. Note the square brackets, that 
must be used to encapsulate all commands. All commands you can start from the command line 
can be used. 
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