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Software License Agreement 

Rasterex as - All rights reserved. 

No part of this documentation may be altered, adapted, or translated into other languages without prior 
written permission from the Rasterex. It is prohibited to create any documents based on this original. 

RxSpotlight and its logotype as well as Rasterex and its logotype are the trademarks of Rasterex*. 

Microsoft Windows is the registered trademark of the Microsoft Corporation. MS-DOS is the registered 
trademark of the Microsoft Corporation. Pentium and Pentium Pro are the registered trademarks of the Intel 
Company. 

Other program and equipment names are the registered trademarks of the corresponding companies. 

Rasterex and the Licensee agreed as the follows: 

Object: Rasterex Software products including programs and documentation (hereafter referred to as the 
license). 

The license described in the Rasterex product User Guide, shall be distributed in accordance with the terms 
of the License Agreement and cannot be used, transferred or sold under any conditions, other than what is 
clearly specified in the following Agreement. 

License Agreement 
RASTEREX transfers the Licensee a non-exclusive License to use the license supplied under this 
Agreement according to the conditions specified bellow. Should the Licensee not agree to the terms of the 
Agreement the installation must be terminated before the activation of said license and return for a full 
refund within 30 days of the purchase. RASTEREX will on receipt of all deliverables and after confirmation to 
non-activation of the license make a 100% refund of the amount paid for the license. 

1. License 

1.1 Under this License the Licensee may use the programs on one consecutive computer only. To use 
the programs on several consecutive working computers the Licensee shall obtain the corresponding 
number of paid Licenses. 

1.2 The Licensee is entitled to make one archive copy of the license, which automatically becomes 
RASTEREX property and falls under this Agreement. 

1.3 The documentation may not be copied and/or distributed in any way or form. 

1.4 The Licensee shall prevent the license from being used, copied or distributed without authorization. 

1.5 This License is valid from the date the Licensee obtains it and until its termination. Should the 
„Licensee break the terms of this License agreement it will automatically void the terms of the agreement.  

1.6 All rights of name, contents and appearance of the package shall be the exclusive property of 
RASTEREX. 

1.7 The present version and all the following license versions shall fall under the terms of this License 
Agreement or any future License Agreement that supersedes this agreement. 

2. Warranty 

2.1 RASTEREX warrants that the Software is free from defects at delivery and for a period of ninety 
(90) days of normal use from the date of the original purchase. Should any defects be detected RASTEREX 
shall replace the defected materials. Minor non-fatal bugs and compatibility issues relating to normal product 
uses does not constitute defects.  

2.2 RASTEREX has no warranty responsibility for the license or the results of the usage of this license 
in terms of accuracy, correctness, reliability or similar. 

2.3 RASTEREX is not responsible for any damage, directly or indirectly linked with the use of or 
misuse of this license. 

2.4 No other information, except for the present License, obtained by the licensee shall cause any 
RASTEREX warranty responsibility. 

3. Modifications in the programs and new versions 

3.1 The Licensee will have to fill out and return to RASTEREX the User‟s Registration Card in order for 
the Licensee to have the right of getting any possible supplements, new license copies on preferential terms 
and notice of errors corrections. 

Additional Licensee Agreement for Pro version 
1. In case of using Engine scanning functionality: 

The Sublicensee agrees to include the following provisions in (i) the header or similar file in software and (ii) 
prominently in its documentation and to require its sublicensees to include these provisions in similar 
locations: The TWAIN Toolkit is distributed as is. The developer and distributors of the TWAIN Toolkit 
expressly disclaim all implied, express or statutory warranties including, without limitation, the implied 
warranties of merchantability, noninfringement of third party rights and fitness for a particular purpose. 



RxSpotlight User Guide 
 

3 

Neither the developers nor the distributors will be liable for damages, whether direct, indirect, special, 
incidental, or consequential, as a result of the reproduction, modification, distribution or other use of the 
TWAIN Toolkit. 

2. In case of using opening of DjVu files: 

• You have acquired ABBYY SDK that includes software licensed by copyright owner of ABBYY 
SDK from LIZARDTECH, INC. Those installed software products of LIZARDTECH origin, as well as any 
associated media, printed materials, and «online» or electronic documentation («SOFTWARE») are 
protected by copyright laws and international copyright treaties, as well as other intellectual property laws 
and treaties. The SOFTWARE is licensed, not sold.  

• If you do not agree to this End User License Agreement («EULA»), do not use the ABBYY SDK. 
Promptly contact supplier of ABBYY SDK for instructions on return of the unused ABBYY SDK for a refund. 
Any use of the SOFTWARE, including but not limited to use of ABBYY SDK, will constitute your agreement 
to this EULA (or ratification of any previous consent).  

• Grant of License. You are granted a personal, nonsublicensable, nontransferable, nonexclusive 
license to use the SOFTWARE as integrated in ABBYY SDK (as well as any associated documentation).═ 
You will not rent, sell, lease or otherwise distribute the SOFTWARE or any part of it. 

• NO WARRANTIES FOR THE SOFTWARE. THE SOFTWARE IS PROVIDED «AS IS» AND WITH 
ALL FAULTS. THE ENTIRE RISK AS TO SATISFACTORY QUALITY, PERFORMANCE, ACCURACY, AND 
EFFORT (INCLUDING LACK OF NEGLIGENCE) IS WITH YOU. ALSO, THERE IS NO WARRANTY 
AGAINST INTERFERENCE WITH YOUR ENJOYMENT OF THE SOFTWARE OR AGAINST 
INFRINGEMENT. IF YOU HAVE RECEIVED ANY WARRANTIES REGARDING THE ABBYY SDK OR THE 
SOFTWARE, THOSE WARRANTIES DO NOT ORIGINATE FROM, AND ARE NOT BINDING ON, 
LIZARDTECH.  

• NO LIABILITY FOR CERTAIN DAMAGES. EXCEPT AS PROHIBITED BY LAW, LIZARDTECH 
SHALL HAVE NO LIABILITY FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL OR INCIDENTAL 
DAMAGES ARISING FROM OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE 
SOFTWARE. THIS LIMITATION SHALL APPLY EVEN IF ANY REMEDY FAILS OF ITS ESSENTIAL 
PURPOSE. 

• Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse 
engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that such activity is 
expressly permitted by applicable law notwithstanding this limitation.  

• Export Restrictions. You acknowledge that the SOFTWARE, or any part thereof, or any process or 
service that is the direct product of the SOFTWARE (the foregoing collectively referred to as the «Restricted 
Components») are of U.S. origin. You agree to comply with all applicable international and national laws that 
apply to these products, including the U.S. Export Administration Regulations, as well as end-user, end-use 
and destination restrictions issued by U.S. and other governments. 

3. In case of using opening of PDF files: 

• You have acquired ABBYY SDK that includes software licensed by copyright owner of ABBYY 
SDK from Adobe. The term "Adobe Software" includes Adobe Technology and related documentation, and 
any upgrades, modified versions, updates, additions, and copies thereof. The Adobe Software is licensed, 
not sold.  

• If you do not agree to this End User License Agreement («EULA»), do not use the ABBYY SDK. 
Promptly contact supplier of ABBYY SDK for instructions on return of the unused ABBYY SDK for a refund. 
Any use of the Adobe Software, including but not limited to use of ABBYY SDK, will constitute your 
agreement to this EULA (or ratification of any previous consent).  

• License Grant and Restrictions. ABBYY grants you a non-exclusive right to use the Adobe 
Software under the terms of this Agreement. You may make one backup copy of the Adobe Software, 
provided the backup copy is not installed or used on any computer. 

• Intellectual Property Rights. The Adobe Software is owned by ABBYY and its suppliers, and its 
structure, organization and code are the valuable trade secrets of ABBYY and it suppliers. The Adobe 
Software is also protected by United States Copyright law and International Treaty provisions. You may not 
copy the Adobe Software, except as provided in this Agreement. Any copies that you are permitted to make 
pursuant to this Agreement must contain the same copyright and other proprietary notices that appear on or 
in the Adobe Software. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble 
or otherwise attempt to discover the source code of the Adobe Software. Except as stated above, this 
Agreement does not grant you any intellectual property rights in the Adobe Software.  

• Font License. If the Adobe Software includes font software you may embed the font software, or 
outlines of the font software, into your electronic documents to the extent that the font vendor copyright 
owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-
Adobe owned fonts. You may fully embed any font owned by Adobe. 

• THE FOREGOING STATES THE SOLE AND EXCLUSIVE REMEDIES FOR ABBYY'S BREACH 
OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, ADOBE AND ITS SUPPLIERS 
MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY 
PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL ADOBE OR ITS SUPPLIERS 
BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING 
ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY.  



RxSpotlight User Guide 

4 

Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special 
damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so 
the above limitations may not apply to you. To the extent permissible, any implied warranties are limited to 
thirty (30) days. This warranty gives you specific legal rights. You may have other rights which vary from 
state to state or jurisdiction to jurisdiction.  

• Export Rules. You agree that the Adobe Software will not be shipped, transferred or exported into 
any country or used in any manner prohibited by the United States Export Administration Act or any other 
export laws, restrictions or regulations (collectively the «Export Laws») - In addition, if the Adobe Software is 
identified as export controlled items under the Export Laws, you represent and warrant that you are not a 
citizen, or otherwise located within, an embargoed nation and that you are not otherwise prohibited under 
the Export Laws from receiving the Adobe Software. All rights to use the Adobe Software are granted on 
condition that such rights are forfeited if you fail to comply with the terms of this Agreement.  

• General Provisions. If any part of this Agreement is found void and unenforceable, it will not affect 
the validity of the balance of the Agreement, which shall remain valid and enforceable according to its terms. 
This Agreement shall not prejudice the statutory rights of any party dealing as a consumer.  

• Trademarks. Adobe and Adobe PDF Library are either registered trademarks or trademarks of 
Adobe Systems Incorporated in the United States and/or other countries. 
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General Notes 

RxSpotlight is a versatile raster-to-vector converter. With RxSpotlight, scanned 
images such as maps, drawings, sketches and other graphics can be edited, updated 
and vectorized semi-automatically and automatically.  

RxSpotlight is also a powerful hybrid drawing editor. Hybrid drawings consist of a 
monochrome, greyscale or colour raster image overlaid with vector elements. Multiple 
raster images can be loaded, and the number of raster images handled during one 
session is limited only by the computer memory available. RxSpotlight allows the 
loaded images to be freely arranged in a limitless workspace. 

The different natures of vector and raster objects imply the use of different operations 
to process them. Some of them are intuitively obvious, some are a bit tricky, and 
some require acquaintance with specific concepts. 

The main areas where RxSpotlight is applied are CAD/CAM, GIS, EDM/TDM and 
Repro. 

RxSpotlight is also versatile in handling varied file formats. RxSpotlight allows users to 
import AutoCAD files (*.dwg, *.dxf, *dwf), Microstation Design (*.dgn), ESRI Shape 
(*.shp), HPGL/2 (*.plt, *.hp, *.hpg), raster images from files PDF, and also vector data 
and document files that were created in previous versions of RxSpotlight or in 
Vectory. An entire RxSpotlight document or selected objects can be exported to 
AutoCAD, MapInfo (*.mid) format, ESRI Shape-format, HPGL/2 formats, and objects 
selected from a current document can be exported to a new RxSpotlight document. 
.Raster images can also be exported to PDF, multipage TIF and multipage CIT files. 
RxSpotlight supports most raster formats including TIFF (also multipage and geo-
referenced) , RLC, CIT (also multipage), BMP, JPG, JPEG, PCX, CAL, ECW, C4, 
TG4, CT4, T4, MrSID (SID), CG4, GP4, MIL, PNG, JP2 and J2K. 

RxSpotlight is useful when working with electronic documents with raster images and 
there is a need to perform unusual or too “intellectual for computer” tasks. 

The rough skeleton of RxSpotlight is based on the following techniques: 

 Vectorization – conversion of raster lines, arcs, and circles to vector objects. 
RxSpotlight supports automatic vectorization, selecting and special tracing 
procedures. 

 Rasterization – converting vector objects to raster images. 

 Recognition of characters and raster symbols of arbitrary shape and complexity. 

 Binarization – picking a raster image, the dots of which are the same colour as, or 
similar to, a specified colour. 

 Calibration – eliminating the distortion of a scanned image due to either initial 
distortion  or scanning errors. 

 Correction and filtration to further prepare an image for vectorization. 
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 Layering – transferring required information from one image layer to another 
as a result of operations or based on the criteria of pixel colour and object 
size. 

 Creating new vector and raster objects. 

RxSpotlight supports all these techniques with multiple additional tools that smooth 
the workflow and enable the user to solve complex and unusual tasks. 

Having learned the power of RxSpotlight, efficiency is considerably increase and 
goals are reached avoiding time-consuming and boring operations. 

Why not simply vectorize it all? 
Novice users of RxSpotlight ask the question: “What is this mess of buttons and 

commands for? Why not simply press this Red Button  and get vectors out of 

raster immediately?” 

OK, if the temptation is irresistible, try it, just to make sure that it works. 

If this operation is performed on several different images, then the following rules may 
soon be derived: 

 The automatic vectorization result is fine on simple images. It is satisfactory on 
complex images that are free of distortions caused by scanning, poor storage 
and the like. It is still good if the complex image is full of standard symbols, texts, 
hatches, arrows etc. that are found in technical drawings and geographical 
maps.  

 and Red Button pressing results are very unsatisfactory on arbitrary images that 
are full of speckles, distortions, broken and faded lines, texts, dimension lines, 
arrows, complex symbols, floodfilled areas, etc. 

The last group of images usually contains the most valuable information that can be 
extracted when the unnecessary noise is filtered out. The automatic vectorization for 
such extraction must be accompanied by many hours of manual improvement and 
time-consuming cleaning. Note also that in many cases we do not actually need 
vectorized images at all; we want our raster image to be cleaned or improved or just 
to change a part of it. 

Now let us introduce one of RxSpotlight
 
features that provide extreme flexibility and 

precision when working with raster images. 

 

Consider a fragment of raster image, consisting of a 
circle crossed by lines. We want to make the circle 
smaller. Though the Red Button is available, we do 
not need to vectorize or trace this fragment at all in 
order to obtain the vector analogue of the circle, to 
change the diameter and then to convert it back to 
raster because our approach is simpler. 
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Click on the point on the circle that is not crossed by 
any line. 

The circle is recognized; we can see its centre, and 
four grips. The grips are used to change circle 
geometry. 

 

Drag one of the grips towards to centre of the circle. 
Click on any blank place on this raster fragment to 
finish the operation… 

 

…Done….. 

…… with ONE mouse click and ONE mouse drag. 
The mechanisms of RxSpotlight have left raster lines 
intact, even preserving their jagged edges! The circle 
is drawn with its native line style and colour. All this 
and other boring intermediate steps are hidden from 
our eyes.  

This Guide describes the variety of techniques and procedures for the transformation 
of raster objects and images, using operations that are usually applied only to vector 
objects. 

You will also learn now to: 

1. Change properties (lengths, colours, geometry, etc) or raster lines, arcs and 
circles without performing a separate vectorization operation. 

2. Treat the raster entities as if they are vector objects and create images from 
selected objects of a different nature. 

3. Recognize hatches, arrows, characters, and symbols. 

4. Search raster objects with vector objects of similar shape and vice versa. 
Replace raster and/or vector objects. 

5. Remove noise and speckles from the image or place tiny objects to a separate 
layer. 

6. Manipulate colours on colour images, perform complicated conversions and 
extract information from colour images directly or using layering procedures. 

7. Select objects in more than 40 different ways, including „intelligent‟ selection 
which recognizes the objects nature and type. 

8. Correct scanning distortions with a wide range of tools and significantly improve 
the quality of poor images. 

9. Create many copies of selected object(s) with a single command. 
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10. Create scripts and run them. 

 … and much more! 

Specifications 

Supported Raster Formats 
Raster formats: TIF, RLC, CIT, BMP, JPG/JPEG, JP2/J2K, PCX, CAL, ECW, C4, 
TG4, CT4, T4, MrSID (SID), CG4, GP4, MIL, PNG and PDF; 

WORLD and TAF geo-files support; 

Multipage TIFF and multipage CIT support; 

Georeferenced TIFF support. 

Import 
AutoCAD DWG, DXF files, Adobe Portable Document Format ( PDF ), Microstation 
DGN files, HPGL/2 plot files, ESRI Shape files ( SHP ). 

Export 
AutoCAD DWG, DWF, DXF files, Adobe Portable Document Format ( PDF ), 
Microstation DGN files, HPGL/2 plot files, ESRI Shape files ( SHP ), MapInfo. 

RxSpotlight Document 
Unlimited document workspace; 

Modelspace and plot layouts; 

Coordinate System options, UCS creating commands, UCS icon;  

Unlimited number of loaded monochrome, grayscale, and color raster images; 

Storing raster images in a document file as embedded and separate files; 

Rectangular and polygonal clip on raster images; 

Controlling the objects display order; 

Using document templates; 

Auto-saving and recovering, Black-box tool. 

User Interface 
Multi-document interface (MDI); 

Inspector window that shows and lets users to modify RxSpotlight object properties; 

Templates for saving the settings for all tools for further use; 

Various display modes, previews, named views, Full Screen Mode; 

Customizable menus and toolbars, Individual customization of any command 
environment; 

Libraries for vector, raster, and hybrid graphics; 

Command Line with interactive keywords and mathematical processor; 

Custom User Profiles to store and switch all Interface settings. 
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Scanning 
TWAIN scanners support, direct support for Contex, Graphtec and Colortrac SmartLF 
scanners. 

Printing 
Creating layouts with viewports; 

Printing with Preview. 

Automation 
Images Auto Correction – tuning and performing a customizable set of commands; 

RxSpotlight Open Architecture: Jscript, VBScript; 

COM interface; 

RxSpotlight Batch;  

RxSpotlight Script language. 

Raster Editing 
Automatic and manual deskewing; 

Image rotating by an arbitrary angle; mirroring; cropping; 

Changing an image size and resolution; 

Converting to RGB, grayscale, 8-bit indexed; 

A wide choice of filters to correct monochrome, grayscale, and color raster images; 

Tuning the brightness, contrast, and color balance of an image; automatic and manual 
correction by histogram; Gamma correction; 

Image palette editing; Color reduction; 

Drawing and erasing of raster lines with a specified width and color on monochrome, 
grayscale, and color raster images; flood filling of closed contours;  

Pixel drawing and flood filling;  

Binarization of color and grayscale images; Various Binarization methods; 

Layering of a color image by a specified number of monochrome raster layers. 

Calibrating 
Calibration of monochrome, greyscale, and colour raster images; 

Simultaneously calibration of multiple images; 

Calibration by grid and/or by a set of calibration pairs; 

10 calibration methods including affine, bilinear, spline, and polynomial with an 
automatic choice of optimal calibration method; 

Calibration accuracy pre-estimation; 

Four-point correction to eliminate trapezoid and projective distortions. 

Handling Symbols 
Tracing and selecting of raster symbols; 

Training the program to recognize raster symbols; 

Creating the libraries of symbols for recognition; 

Searching and replacing of raster and vector symbols. 
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Hybrid editing 
The use of vector techniques for selecting hybrid RxSpotlight objects; 

Selecting hybrid objects and areas within a window and polygon; crossing window 
and polygon; fence; selecting isolated raster objects; selection by brush and vector 
contour; various selection modes; wise selection of particular objects; 

The properties and geometry of raster objects; 

The use of vector techniques to edit raster lines, arcs, circles; 

Editing of object geometry using grips; 

Rasterizing vectors to monochrome, greyscale, and colour raster images; 

Merging monochrome, greyscale, and colour raster data; 

Objects moving, copying, duplicating, rotating, scaling, and mirroring; 

Objects aligning; 

Duplicating objects by vector line, arc and circle; 

Exploding complex vector objects; 

Breaking objects at specified points; 

Extending vectors to specified edges; 

Cropping vectors by specified edges; 

Correcting vectors intersection; 

Arranging polyline elevations with 3D view support; 

Polyline edit mode – closing, adding, removing, vertex moving, modifying a curve, 
joining polylines. 

Precise drawing tools  
Snapping to the characteristic points of raster and vector objects with display of snap 
type markers and tool tips; 

Object Snap Tracking mode to snap relative to directions and object nodes;  

Polar snap; orthogonal snap; snapping to grid; fixed moving step. 

Orthogonal drawing. 

Selection 
27 area and object selection methods; 

WiseObject selection; 

Selection by filter; 

Brush selection; 

Selection by Contour. 

Vector Objects 
Drawing points, Lines, Circles, Ellipses, Polylines, Splines, Rectangles; Dimensions, 
Texts and Multiline texts; 

Named blocks with attributes; 

Custom Object attributes 

Custom arrows (markers) and flood fill shapes; 

Custom Line Styles; 
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Text Styles. 

Raster-to-Vector Conversion 

Tracing 

Tracing on color and monochrome raster images; 

Converting raster data to vector objects with automatic recognition of object type and 
by specified templates; 

Tracing arbitrary raster curves by polylines; 

Recognizing a raster hatch; 

Tracing modes with preserving, erasing, or smoothing of an original raster image; 

Auto defining of the most probable polyline tracing direction; 

Orthogonalization of polyline segments with specified or auto defined basic direction; 

Line orthogonalization when tracing; 

Auto defining of a raster entity width with assigning the resulted vectors width; 

Distribution of obtained vector objects by layer and colour; 

Autoextend option when tracing lines and arcs; 

Outline tracing. 

Automatic Raster-to-Vector conversion 

Recognizing raster lines, arcs, circles, polylines, contour objects, hatches; 

Recognizing the type of raster objects, arrows on lines and arc ends; 

Auto defining of raster entities width with assigning the widths of resulting vectors; 

Recognizing raster polylines on colour images; 

Aligning vector segments to the orthogonal direction; 

Recognizing raster symbols on bitonal images and converting them to their vector 
representations; 

Distribution of vector objects by layer and color. 

Text recognition 

Recognizing the text in any orientation; 

Training the program to recognize new symbols; 

Reviewing and editing recognized texts; 

External OCR support. 

Vector Correction 
Auto correction of vector objects obtained after recognizing, lines conjugation, angle 
alignment; 

Polyline autocorrection; 

Joining selected objects to a line, arc, circle, or polyline. Auto defining the type of an 
object that is the closest to the selected objects; 

Collecting polylines. 

Rasterization 
Rasterization of vector objects to monochrome, grayscale or color images; 
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Raster Draw mode for creating raster objects. 

Installation 
For detailed information on installation RxSpotlight refer to “RxSpotlight Installation 
Guide”. 

System Requirements 
To work with the program you need the following: 

 Computer with Pentium IV based processor and higher. 

 512 Mb RAM and more 

 Microsoft Windows XP (SP2) / Vista (32b or 64b) / 7 (32b or 64b) / 
Microsoft Windows Server 2003. 

 Hard disk with 500 MB of free space. 

Running RxSpotlight 
To start the program choose RxSpotlight icon on the desktop then double click or on 
the taskbar click the Start button>All Programs>Rasterex>RxSpotlight (Pro) 
14>RxSpotlight (Pro) 14. 

RxSpotlight interface 
After the RxSpotlight document has been opened you can see menu, toolbars, 
document window with layout tabs, UCS icon, cursor, status bar, command line and 
etc. 
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Document window 

Document window shows opened document. If it is necessary, this window can be 
splitted on several parts. Different modes for image display can be set in each pane, 
in particular different scales. It may be useful, for example, when working on small 
details in large documents without losing the whole image. 

You can open several documents in RxSpotlight and arrange them in the working 
area using the cascade, tile vertically and tile horizontally commands. 

Layout tabs 

 

These tabs switch document layouts. 
Every document has at least one tab – 
Model Space. This is the space where 
plan creation is performed. A document 
that was prepared for printing contains 
other layout tabs. 

Cursor 

Displayed as crosshair with square aperture box. Cursor size and color can be altered 
in the Preferences dialog (see page 389). 
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Menu Bar 

Placed below the caption of an application window and includes drop-down lists of 
RxSpotlight commands. 

User Coordinate System icon (UCS icon) 

 

Displayed at a point 0,0 of current coordinate system. Can be 
turned OFF by using the Show UCS icon. command. 

Command Line  

 
The Command Line is the interactive text window from where RxSpotlight commands 
can be called and processed. It uses for commands entering and for command 
prompts displaying. To hide or show Command Line use the Show Command Line 
command from the View menu. 

Status Bar 

  
Status bar is the lowest panel in RxSpotlight application window. It displays command 
tips (the left part), indicator of program activity, cursor coordinates (the right part), and 
following buttons: 

 Raster (RSNAP), vector (VSNAP), object tracking (OSNAP) and polar 
(POLAR) snap modes. 

 Grid and snap to grid mode (GRID). 

 Ortho mode (ORTHO) to draw lines with fixed angles. 

 Raster Draw mode (RDRAW) that automatically rasterizes created object 
on underlying raster image. 

 Show width of lines of all objects in the document (SW). 

 Show hatches and filling of all objects in the document (SH). 

 “Life” indicator shows the program activity. It is useful when starting a long operation 
and to see if it is being performed. 

Snap buttons that set snap modes and grid usage are described on page 298. 

The ORTHO and RDRAW buttons toggle special drawing modes that are described 
on page 253 and 297 respectively. 
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To show/hide the Status Bar use the Show Status Bar command. 

Toolbars 

The toolbars can be moved with the mouse anywhere on the screen with the 
capability of transparency control. 

Every button on the toolbars is intended to start the certain command. If you move 
cursor to the icon, the name of a command will appear. 

 

On some toolbars the commands are joined 
into the groups. You can see only one 
button from each group. Such buttons have 
small black arrow in the lower right corner. 

To unfold enclosed toolbar it is necessary to 
click toolbar button and hold the mouse 
button pressed. Holding the left mouse 
button, move the cursor to another 
command of this group and then release the 
mouse button. As a result the chosen 
command will be started. 

To show / hide toolbars choose the appropriate item from the View menu > Show 
Toolbar or right-click on any toolbar, or use keywords, which are shown in the View > 
Show Toolbar menu. 

The toolbars are customised in the Tools > Customise dialog. Show or hide the 
toolbars in the list opened by right clicking on tool buttons or by choosing Show 
Toolbars from the View menu. 

To make a toolbar or dialog transparent, move the cursor onto the desired one and 
then right-click with the CTRL pressed. When the Window Transparency  dialog is 
displayed, use the slider to set this parameter. 
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The Object Properties toolbar contains buttons and edit boxes. There are four buttons 
on the left of the toolbar - these open the most important RxSpotlight dialogs: Layer 
Manager, Image Manager, Block Manager and Inspector. Layer Manager controls 
layers and their properties. Image Manager controls image visibility and accessibility. 
The Block Manager controls block usage. The Inspector window lets the user see and 
modify the properties of commands and objects. 

In the middle of the toolbar there are tools that allow fast modification of selected 
objects. The list and two buttons on the right are the components of Named Views. 

 RxSpotlight shows the Inspector window and some other dialogs in a 
docked position. These can be changed to floating if needed by double 
clicking on the title bar or by dragging window with the Ctrl button 
pressed. 

RxSpotlight document  
A RxSpotlight document contains both vector objects and raster images, located on 
an unlimited workspace. Any number of colour, greyscale, and monochrome raster 
images can be loaded in a RxSpotlight document; vector objects can be created and 
documents which contain vectors can be loaded and new images created.  

RxSpotlight document can contain several workspaces: a model space and a paper 
space that is represented by a number of layouts. The most of work is performed in 
the model space, while the paper space is used for realizing created drawing on the 
paper. 

 For more information on RxSpotlight layouts see page 86. 
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The RxSpotlight document extension is .CWS; this format can store both raster and 
vector data. 

When working with RxSpotlight a coordinate system is used, this can be specified 
according to the document requirements. 

To create a new RxSpotlight; document choose New from the File menu. To save a 
document; use the Save As or Save command in the File menu. When saving a 
document, all currently loaded RxSpotlight objects will be saved. RxSpotlight also 
saves all program settings. 

Raster images inserted in a RxSpotlight document can be stored in two different 
ways: 

1. as a linked image file. In this case raster images are stored as separate files. 

2. as an embedded image inside a RxSpotlight document. 

RxSpotlight documents can be opened with the Open command of the File menu. 

RxSpotlight document properties can be set which will be inherited by all newly 
created objects.  

A RxSpotlight document has layers on which RxSpotlight objects are distributed. An 
object can assume properties “by layer” on which it is drawn or moved to. 

 For more information on RxSpotlight layers see “Layers” section on page 45. 

RxSpotlight allows the visibility of layers, transparency of raster images. Birds Eye, 
predefined scale or named view can be used for convenient information display. 

There is also an option to use file templates. This allows new documents to be 
created with raster or vector objects already inserted. 

Creating a new Document 

1. From the File menu, click New or press the  button on the Main toolbar. 

Check the current settings of the RxSpotlight document in the main Inspector window 

by choosing Inspector from the Tools menu or clicking the  button on the Image 

toolbar. The current settings of RxSpotlight documents can be changed in the 
Inspector window. 

To obtain information on the current settings of a RxSpotlight document, be sure that 

no selection is made or any commands started. Press the Unselect All button  on 

the Select toolbar and check the contents of the Inspector window. 
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 For more information on Inspector window see “Inspector” on page 40. 

Predefined raster or vector objects can be inserted in a newly created document. 
These objects are stored in file templates and their usage is controlled by settings in 
the Template Usage section of Tools > Preferences dialog (see page 393). For 
example, if there is a document called BORDERS.CWS which contains a drawing 
frame and title block, then it is possible to set this as a default template in the For New 
documents section, so that every new document automatically opens with a frame 
and title block. 

Document Template  
Document template is a RxSpotlight document with CWT extension, which is used as 
base for a new documents creating. A document that is created from a template 
(based on template) inherits template settings (coordinate system, layers, line styles, 
text styles, snap settings and etc.) and content (raster images, vector and raster 
objects). 

For example, it is convenient to use templates when working with engineering 
drawings. You create a standard frame with title block, save it in template format and 
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switch on the usage of this template for new documents. Hereafter all newly created 
documents will contain these frame and title block. 

 The program supply includes a set of standard (ANSI and JIS) templates 
for engineering drawings. 

 

To create document template: 

1. Prepare document properly: adjust all document settings such as coordinate 
system, layers, line styles, text styles, snap settings and etc.; delete unwanted 
objects; create drawing frame and title block; draw any other objects if it is 
necessary. 

2. Save the document in CWT format. 

To use templates 

Templates can be used for: 

 Creating a new document with the New command; 

 Creating a new document during file Export operation; 

 Creating a new document during opening a raster image. 

The use of template is turned on separately for each of these operations. The 
template usage is off by default. 

There are several ways to work with templates. Adjust settings in the Template Usage 
section of the Preferences dialog to specify the way of template usage: 

 

 If the same template is used frequently, then choose the Use default 
option and specify template file name in the Default Template File Name 
text box. 
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 If you use different templates each time, then choose the Ask for file 

option. Then the file selection dialog will open each time, for a template 
file specifying. 

 To select template file from a predefined list set the Choose from list 
option and specify template files in the Default Template File Name text 
box. Hereafter you can choose appropriate template from a list in the 
displayed Choose template dialog, which includes preview window and 

description field. 

 To switch off usage of templates set the None option in the corresponding 

subsection. 

 For more information on adjusting settings in the Template Usage section 
Preferences dialog see page 393 

If the template files are not available or the path to them is specified incorrectly, the 
message appears: "File not found" and a new document will be created without 
template. 

 Warning: Do not open a template file and a document based on this 
template at the same time. 

 

Opening a Document 
The File Open command loads a document from an existing file. If working with 
another document, then RxSpotlight opens the required document in a new window. 

Load a RxSpotlight document through an Open command: 

 Previous versions of RxSpotlight documents (.cws, .vc4, vc5); 

 AutoCAD (*.dwg, *.dxf) files including hybrid ones that contain raster images; 

 Raster images of TIF (also multipage and georeferenced), RLC, CIT (also 
multipage), BMP, JPG, JPEG, JP2, J2K, PCX, CAL, ECW, C4, TG4, CT4, T4, 
MrSID (SID), CG4, GP4, MIL and PNG formats. 

Opening a document loads all its previously saved settings.  

To open an existing document 

1 From the File menu, choose Open. The Open File dialog appears. 

2 In the File Name box, type or select a file to open. Note that only one file can be 
opened at a time. 

3 Click Open. 

To open multiple documents at once 

The Explore tool is intended for loading files a RxSpotlight document. 

This tool provides all capabilities of working with Windows Explorer files. It allows for 
opening multiple images at once or inserting several raster images at once, sorting 
files by type, size, etc. 
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Choose Explore from the File menu. 

Select a file format from the combo-box at the bottom of the dialog. 

In the dialog pane select files (for continuous selection keep the SHIFT key pressed) 
and move them with the mouse somewhere in the screen. Raster files will be inserted 
into an open document. 

Saving a Document 
When starting working with a new unnamed document, RxSpotlight gives it the name 
Untitled N, where N is the document ordinal number. RxSpotlight prompts to save this 
document before closing. It is possible to save an existing document with a different 
name. 

 When saving a document, all RxSpotlight settings are saved. 

Before saving a RxSpotlight document, define the way of storing raster images 
contained within as linked or as embedded. Note that all created raster images are 
stored as embedded. To store them as linked, save them in the Image Manager 
window. Use this window to change the status of stored as linked images to stored as 
embedded. 

 For more information on Image Manager see “Managing Images ” on page 52 
of this guide. 

The RxSpotlight document can be saved through a Save command to: 

 Previous versions of RxSpotlight document; 

 AutoCAD (*.dwg, *.dxf, *.dwf); 

 Raster formats of multipage TIF, multipage geo-referenced TIF and multipage 
CIT (only raster images). 
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To save a new document 

Define in Image Manager the way of storing raster images included in the workspace. 

From the File menu, choose Save as or press the  button on the Main toolbar. 

In the Save Document File dialog box, enter the document name. Click Save. 

Set additional information on the saved document in the CWS comments dialog, 
which appears by pressing the Options button. View this information when opening 

the document by pressing the View Menu button  on the Open File dialog or in 

the viewing object properties mode (comments) with the appropriate Windows tools, 
including Explorer. 

To save an existing document 

From the File menu, choose Save or press the  button on the Main toolbar. 

To save a document with another name: 

1. From the File menu, choose Save As. 

2. In the Save Document File dialog, type a new name for the current document. 
Click Save. 

Autosaving and backup documents 
RxSpotlight performs 
automatically saving for opened 
documents. Time interval 
between savings is specified in 
the SavingParams > Autosaving 
every <XX> min item of the 
Preferences dialog.  

 

To switch OFF the autosaving set 0 for this parameter. 

Documents recovering 

If RxSpotlight session was unexpectedly terminated, then the Recover documents 

dialog will appear on next application starting. The table in this dialog contains original 
states of documents, which were opened during program terminating and their backup 
versions that were created by autosaving utility. 
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Click left field (the Action column) for each table record to specify action for this 
document: 

 Recover from autosaved file – recover document from automatically saved 

version. 

 Open original file – ignore automatically saved version and open original 

document (if exists). 

 Open both files – open both documents. Besides, this automatically saved 

document gets file name postfix "Recovered". 

 Delete autosaved file – delete automatically saved versions. 

Click OK button after performing all actions. All records in the Recover documents 
dialog and temporary files will be deleted. 

Backup documents 

RxSpotlight generates backup copy of current document right before save to a file. 
Backup copy is a complete copy of a document with BAK extension. BAK file can be 
renamed back to CWS an opened at any time. 

To switch this feature OFF turn the SavingParams > Generate backup copies item in 
the Preferences dialog. 

 
 

Navigating in RxSpotlight document 

Zoom, Pan and Named views 
There are many commands that can help navigation in the RxSpotlight screen and 
indicate the current position relative to the images being processed. 

To zoom and pan, use the buttons on the Main toolbar. There are more zoom 
commands in the View menu. The most frequently used zoom and pan commands 
are available in the cursor menu, which opens with a right-click. 

Zooming 

The View menu contains the following zoom commands: 

 
Zoom All Displays a whole document. 
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Zoom Previous Displays a document at a scale set with the previous 

zoom command. The number of steps for this 
command is unlimited. 

 
Zoom Next Displays a document at a scale that was previously 

undone by Zoom Previous command. Inactive if Zoom 
Previous command hasn‟t been used during current 
session. 

 
Zoom Selected Displays selected objects. 

 
Zoom Window Selects an area in the screen.  

 
Zoom In Doubles an image size. 

 
Zoom Out Decreases an image size by half. 

   
 

Zoom 1:1 An image is scaled so that one pixel on the screen 
corresponds to one image point when DPI is 
specified. 

 
Zoom Dynamic Turns on the mode which can be used to enlarge an 

object on the screen by moving the mouse up, and 
decrease it by moving it down. 

Some of these commands are available in the cursor menu. 

Pan 

The Pan operation is represented with one command in the View menu, with the  

button on the Main and View toolbars, and it is also included in the contents of the 
cursor menu commands.  

A document workspace can be panned with a hand-shaped cursor.  A pan is used 
often to centre a desired object or feature. 

The Pan function is also included in many RxSpotlight tools, for example, Birds eye, 
Preview, linefollow tracing, and others. 

Birds eye 

Using this tool, any document part can be seen in close-up. It combines the zoom and 
pan functions, allowing any part of the document to be seen at any magnification. 

To launch the Birds Eye window, choose Birds Eye  command from the View menu or 

click the  button on the View toolbar. 
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The Birds Eye window contains a view of the document, a red rectangle that 

represents the part of document shown on the screen, and zoom buttons. Moving the 
red rectangle pans the document. The selected area fits to the screen boundaries. At 
the lower right of the window are three buttons. The two zoom buttons allow the 
details within the red rectangle to be seen without zooming the image. The Fit 

button pans the image to fit the Birds Eye window. The red frame can be resized 

by clicking and dragging the right mouse button. 

The Zoom Window command (  button on Main toolbar) can be used with the 

Birds Eye window open. 

 The easiest way to see the entire document is to Click ALT+0.  

Splitting window 

The View menu contains the commands to split the window into two or four panes. 

Different modes for image display can be set in each pane, in particular different 
scales. It may be useful, for example, when working on small details in large 
documents without losing the whole image. 

There are 4 options to split a document window: 

 
Split 4 Makes four panes. 

 
Split 
Horizontal 

Makes two horizontal panes. 

 
Split Vertical Makes two vertical panes. 

 
Single View Displays a document in one window. 
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Named views 

 

The mechanism of named views consists of one list box of 
predefined views and two buttons on the right of the Object 
Properties toolbar. A new view can be created just by typing 

its name in the edit box or pressing the  button. 

The program keeps the documents‟ window position and 
scale. Further, choosing the name of the view from the list 
automatically restores the saved configuration. 

To delete a view, select it from the list and press the  

button. 

Predefined view names can be neither edited nor deleted. 

Full Screen mode 

This enlarges the workspace to the screen‟s maximum size at the expense of hiding 
the RxSpotlight window caption and cropping outermost toolbars and status bar. See 
the Customise dialog > Options tab > Misc items group> Full Screen Application 
Window checkbox. 

 This mode can be turned on for one of the custom profiles and switched 
momentary. For information about Profiles see page 385. 

Grips 
Grips are small handles that denote selected objects on the screen. The form and 
colour of grips show the selection type and editing capabilities. If the grips are green, 
for example, then the object can be edited. To learn about grips and their options, 
refer to the Grip section in the Preferences dialog from the Tools menu. 

 A description of the information that can be extracted from a grids 
appearance and the editing procedures using grips can be seen in the 
appropriate sections of this Guide and in “Tuning the application” section 
on page 389. 

Undoing and redoing 
The undo and redo functions can be applied once or repeatedly to all operations that 
modify an image. RxSpotlight distinguishes the limits of operations and their steps. 
For example, during tracing it is possible to undo or redo tracing steps and segments; 
then redo the result of the whole tracing session. 

The only limitations are the computer‟s capabilities (most importantly, memory size) 
and the user‟s imagination and persistence. 

Finishing and cycling commands 
By default, after launching a command and getting the results another can be 
launched by choosing it from a menu or clicking on the toolbar button. 
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Most commands are cycled; and do not need to be re-launched to repeat an action. 
For example, when drawing circles, any number of them can be drawn without 
pressing the corresponding button – it stays “pressed”. 

To exit this (and any other command) press ESC or choose another command. 

Command cycling is controlled by settings in Command Setup dialog, see page 376. 

Cursor Menu 
Clicking the right mouse button opens a context-sensitive cursor menu. It contains the 
commands that may be needed in the current operation mode and also the Last 
commands list. 

Preview window 
Most RxSpotlight dialogs intended for enhancing and correcting images are equipped 
with a preview window, where the result of an operation on a selected image part can 
be observed while tuning its parameters.  

Preview window controls 

 – This button turns on/off viewing of the results in the preview window. 

 – Zoom in doubles a preview scale in the preview window. 

 

The effects of tuning parameters are shown 
in the Preview window. Several preview 

windows can be opened, which allows the 
user to observe changes on several image 
fragments simultaneously. 

 

The image part displayed in the left pane of 
the dialog is called a preview area. A colour 
frame on the image indicates the preview 
area margins. The preview area can be 
managed using the Preview Dragger toolbar, 
which appears when opening the dialog. 

 



RxSpotlight User Guide 
 

35 

 – Zoom 1:1 – displays an image on the screen so that 1 dot in the preview 

window corresponds to 1 dot on an image. 

  – Zoom out halves a preview scale in the preview window. 

 – Opens/closes a detached preview window. Pressing this button repeatedly 

opens several preview windows for different parts of the image. 

Preview area managing buttons 

The Preview Dragger toolbar 

 – Moves a preview area in the image. The cursor becomes hand-shaped. 

 – Moves an image to place the preview area in the screen centre. 

 – Matches the current scale of a preview area with that of the preview window 

1:1. 

 –Turns off the viewing of results in the preview window. 

The user can change, if necessary, the position of a preview area in the image without 
changing its size. To do so, put the cursor in the preview window (the cursor becomes 
hand-shaped) and drag the cursor to the required part of the image. 

Display View details 
To adjust display options go to the Preferences dialog (Tools menu) and find the 
Display View item. 

 

Halftone Raster Painting 

When Halftone Raster Painting mode is on, RxSpotlight displays the items of a 

monochrome raster so that the line colour changes according to its width if the scale 
is decreased. 

So if the scale is equal or over 100%, the image is shown with black (or the chosen) 
colour, and if the scale is decreased, thin lines are shown less crisp and are blurred. 
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Halftone Raster Painting is OFF, zoomed 
to 12%. Note that the left lower part of 
image is a mess. 

Halftone Raster Painting is ON, zoomed to 
12%. The left lower part of image is easier 
for the user to understand. 

This mode affects colour images in the same way: the images displayed with a small 
zoom factor are smoothed thus preserving the overall look. 

Raster Image Frame Visibility Control 

The frame of a raster image is a RxSpotlight vector object that shows the image 
boundary, which can be controlled. The Draw Raster Frame option allows for a frame 
to be hidden, which is useful when, for example, composing a document from several 
raster images, or when working with multipage raster images etc. 

Fit Dashed Lines 

When drawing objects with a dashed line style, RxSpotlight tries to display a view of a 
dashed contour by slightly changing the dashed and spaced size lengths. This 
method does not affect the objects geometry, but makes the dashed contour view 
easier to see. For example, in this mode RxSpotlight guarantees that the endpoints of 
lines, polylines, and arcs will be started and ended with a dash. 

This mode can be switched off to view a contour as it is, without changing the length 
of dashes and spaces. See the Display View / Fit Dashed Lines item in the 
Preferences dialog. 

  

Fit Dashed Lines is ON. Fit Dashed Lines is OFF. 
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Use Screen Width for Lines  

The Use Screen Width for Lines checkbox in the Preferences dialog shows width of 

lines in screen pixels. Switch OFF this checkbox to display it in millimeters 
(RxSpotlight units) to scale line width during zoom operations. 

Use Screen Line Types  

The Use Screen Line Types checkbox in the Preferences dialog fixes size of 
displayed fill shapes, end markers, hatches, line types and etc. without dependence 
on the document scale. When this mode is switched on, the Use Screen Width for 
Lines becomes active automatically. 

Example: 

While the Use Screen Line Types parameter is ON: 

1. Original zoom of a document which contains dashed line: 

 
2. After zooming out of the document: 

 
Thus visual size of Line Type dashes and spaces and End Markers is the same. 

 

Controlling the display of an object’s line width 
The Show Width command from the View menu toggles displaying/hiding of objects‟ 
line widths. When Show Width is off, the objects are shown as “wireframes”, thus 

revealing tiny details and unnecessary garbage. This command is also placed on 

the RxSpotlight status bar and its status is shown in the View toolbar 

. 

Show/Hide vector and raster objects 
These two commands from the View menu are especially useful for navigation on the 
RxSpotlight screen. For example, one click hides the raster data, allowing the user to 
examine the results of vectorization. 

The Show/Hide vector and raster objects commands are represented by the  and 

 buttons on the Main and the View toolbars. 

Show/Hide hatches 
The Show Hatches command shows or hides hatch/fill of all objects in the document. 
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Start the command from the View menu or from the status bar (SH button). 

 

Show/Hide markup 
Generally, markup technique uses to redline drawings during reviewing. A vector, 
raster and hybrid drawings can be marked using the CSView application. RxSpotlight 

allows you to view markup objects in drawing. To show markup objects click the  
Show/Hide Markup button on the Main toolbar. 
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A typical markup object consists of the leader line, contour shape and text. A leader 
line is a line with an arrowhead at one end and a multiline text and/or contour shape 
at the other. A text consists of any number of text lines or paragraphs. 

Markup Storing 

Markup objects are stored in *.CSRL (Rasterex Red Lining) markup files, which 
should be named equally to the edited drawing file (except for extension) and placed 
in the folder of the corresponding drawing file. When this drawing is opened with 
RxSpotlight, then the appropriate markup file is automatically loaded. 

Markup Options 

Expand the Markup section in the Preferences dialog to setup markup parameters. To 
open the Preferences dialog, choose the Preferences in the Tools menu. 

 

 Show automatically – shows markup automatically on document open if 

markup file is exists. 

 Show semitransparent – shows markup using semitransparent fill. 

 Alert – shows warning message in case of unknown markup. 

Display Order 
The order of displaying the objects can be controlled if they obscure each other. 

Four commands from the Display Order submenu of the View menu help you 
rearrange an object “stack”. 

 
Bring to Front Brings selected object(s) on top. 

 
Send to Back Puts selected object(s) to bottom. 

 
Bring Forward Brings selected object(s) one step up. 

 
Send Backward Brings selected object(s) one step down. 

Cursors 
When performing some of the RxSpotlight procedures, the mouse cursor changes to 
reflect the current operation and its options. 

Examples: 

 
Tracing polyline (linefollowing). 

 

Create arc by centre, start point and angle. 
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Select raster in Remove mode. 

Cursors can be switched off in Tools > Command Setup dialog (see page 376) 

Dialog templates 
RxSpotlight dialog templates are used to save and restore the parameters of different 
operations. The command dialog that controls such operations contains the Template 
button. A pull-down menu is opened when this button is pressed, containing the Load 
and Save commands; the user can save current parameters in the template, as well 
as to restore the parameters of the current dialog box by loading an existing template. 

 Template files are stored in the corresponding subfolders of the 
TEMPLATE folder. Settings for Binarization, Colour Separation, Colour 
Reduction operations and also options set in the Conversion Options 

dialog that influences the tracing, vectorization and selection algorithms 
are stored in these folders. 

Inspector 
The Inspector window is used to display the information on a current command or 
selected object(s), as well as for tuning commands and editing objects. 

If there is no Inspector on the screen, then it can be opened using the Inspector 

command from the Tools menu, pressing the  button on the Object Properties 
toolbar. The keys ALT+ENTER or ALT+F1 can also be used. 

The Inspector window is usually docked; but it can be made floating by using the 
standard Windows techniques. 

Using Inspector to adjust properties of objects 
Each RxSpotlight command has properties. By changing these properties in the 
Inspector window the command‟s performance can be tuned. 

Usually in the Windows environment the commands that require supplementary 
information are performed in the following order: 

1. Start a command; 

2. The dialog appears to tune the command; 

3. After pressing OK the command runs with specified modes. 

The Inspector window can be considered as the common dialog for tuning those 
RxSpotlight commands, which start operations of modifying objects or their condition: 
moving, changing properties, scaling, rotating, etc. and also creating new objects. 

If a command has properties and modes that can be tuned, then the Inspector window 
usually opens automatically. 

The Inspector window during the Rotate command execution is shown below: 
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To rotate a vector object, specify its centre, angle, and how many times the command 
is to be performed (Copy property). 

The Inspector window list begins with the General group, which contains current 
command name and general information on the command or selected object. The 
remaining part of the list contains the command properties or the properties of any 
selected objects. The list contents may change depending on the commands‟ nature. 

Default document settings 

If there is no selection, then the list shows the current (default) document settings to 
be applied to created objects. 
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Using Inspector to adjust properties of objects 

 

Since selection is also a command, the 
commands from the Select family are also 
presented in the Inspector window; after 

the properties of these commands the 
properties of selected object(s) are 
displayed. Thus, the Inspector is used as 
an additional editing tool. Modify an object 
on the screen with the mouse, or type 
precise values in the Inspector boxes. 

 

If nothing is selected in the document, 
then the Inspector window displays the 
current document settings, which will 
define the properties of created objects: 
for example, if the Line Width field 
contains the value “1mm”, then all new 
lines, polylines, arcs, circles, ellipses, 
rectangles and splines will be drawn with 
this width. 

 

 

The Inspector window is 
shown when a part of a 
raster object is selected. The 
selection can be moved, 
Base Point changed, resized 

by modifying values in the 
Size box, and rotated by 
defining them an angle in the 
Angle field. 

While reading information in the Inspector window, consider the following rules: 

 Black is used to indicate changeable properties. Modify the value of these 
properties by entering new values to the appropriate field. The Inspector does not 
allow alterations to properties that do not fit the selected property type. 
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 Grey is used to indicate the properties that cannot be changed in the Inspector 

window, as well as the properties that depend on another properties‟ value (for 
example, when selecting a circle in Length property contains the circle length, 
which can only be changed by modifying the circle radius). 

 If several objects are selected, then the list includes all properties of all selected 
objects. These can easily be modified, based on common sense; for example, if a 
circle and a line are selected, modifying the Radius value will only modify the 
selected circle; and modifying the Angle value will only rotate the line. 

 If the property value is not specified (the box is empty), then among the selected 
objects the value of this property is different. By entering a new value in the 
empty property box, it is possible to define the same value for the properties of all 
selected objects if applicable. 

 Some settings become current after modifying whilst being processed; in this 
case they are also shown in the relevant lists of properties. For example, if the 
hatch style for an object is changed, this style remains current and, by examining 
the Inspector window with no selection, the hatch style to be applied to the next 
created object is shown. 

 Some complicated operations can only be performed with the mouse while using 
the Inspector as an information tool. For precision, use both the mouse and the 
Inspector in the correct sequence (see for example Array command description 
on page 253). 

 The overall behaviour of the Inspector is controlled by settings in the Inspector 

section of the Preferences dialog (see page 389). 

Groups 
To fold or unfold a group of properties in the Inspector window, click the button with 
small arrow on the right of group name. 

To adjust group displaying go to the Group View tab. The upper window of this tab 
shows group names and display status. 
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Selected Group State 

This section tunes visibility of chosen group. Select a group in the upper window and 
choose an appropriate option in this section: 

 Folded – To fold selected group. The result is equal to group folding with 

the  button. 

 Unfolded – To unfold selected group. The result is equal to group 

unfolding with the  button. 

 Invisible – Do not show selected group in the Object View tab of the 
Inspector window. 

New Group State 

The upper window of the Group View tab contains only those groups which properties 

ever been shown in the Inspector window. At first, after the program has been 
installed, this window contains only a few of them, but later, with use of new groups 
they will be included in this list. For example, the Viewport group will be included after 
creating a first viewport or after it‟s selecting for the first time. 

So the New Group State section specifies visibility state of newly included groups. 

 Show Folded – To show new groups folded. 

 Show Unfolded – To show new groups unfolded. 

 Do not Show – Do not show new groups in the Object View tab of the 
Inspector window. 

Note that you can adjust a visibility of any new group in the Selected Group State 
section at any moment. 

Inspector functioning modes 
Two variants of Inspector functioning can be set: Document Transparent (by default) 
or Command sensitive. 

When the Document Transparent mode is ON, then properties which were changed in 
the Inspector window during any command execution becomes default document 
properties. For example, if the text size has been changed from 5 mm to 10 mm 
during text creation, then after the drawing command is completed, the Text Height 
property remains 10 mm. 

If the Command sensitive mode is ON, then all properties changes during command 
execution do not affect default document settings. 

These modes toggle in the Properties mode section of the Preferences dialog. (for 
more information on Preferences dialog see page 389) 

Custom Properties 
To add new custom properties to RxSpotlight objects, right click on the Inspector 
window and choose the Add Property item in the appeared context menu. Text, 
Integer Number, Float number, Yes/No (Boolean) data can be added as a value for 
the new property. Creation of new properties is available from WIOA script. 

Custom properties may be useful in WIOA scripts. Additional information can be 
stored in any object in the document for script purposes. 
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 See RxSpotlight Open Architecture chapter on a page 371 for additional 
information about WIOA script.  

There is also an ability to import/export additional properties to other formats where 
these properties exist. For example in Mapinfo and ESRI shape formats. 

Inspector shows custom property name with point sign at its beginning. For example if 
custom property name is “ID number”, the Inspector shows “.ID number”. 

To delete or rename custom property, right click on it and choose appropriate item in 
the appeared right-button menu. 

Dragging Inspector properties onto toolbars 
There is also a possibility to add properties from Inspector to any toolbar using the 
standard Windows techniques: drag-and-drop with ALT button pressed or direct drag-
and-drop when the Customize dialog is open. For example, using this method you can 
create your own toolbar similar to Properties toolbar. 

Object Properties toolbar 
The Object Properties toolbar boxes repeat the contents of the corresponding boxes 
in the Inspector window. Add properties from the Inspector to this toolbar (or any 
other) using the standard Windows techniques: drag-and-drop with ALT button 
pressed or direct drag-and-drop when the Customise dialog is open. 

The Object Properties toolbar also includes the list Named Views and the tools for 
editing it. Named Views are described in details on page 33. 

Common object properties 
Most items in the Inspector window are self-explanatory. Below, some of the less-
obvious items are explained. 

By Block The block display options are used. Object inherits the colour, 
line type and other properties of the block containing it. 

By Layer The layer display options are used. The object inherits the 
colour, line type and other properties associated with its layer. 

Elevation Field for elevation value. Use it when preparing information for 
GIS systems. 

Extended Data Field for arbitrary information. Use it when preparing 
information for GIS systems. 

Hyperlink This option allows the user to assign a hyperlink to any object. 

Layers 
A RxSpotlight document consists of layers on which RxSpotlight objects can be 
organized. By placing objects on layers, their visibility can be controlled and changes 
easily made.  The properties of every RxSpotlight object include the layer the object 
belongs to. The objects created can have either the default properties of a RxSpotlight 
document or assume some of them from the layer they belong to.  
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Thus, by specifying By layer in the corresponding boxes of the RxSpotlight document 
properties, the properties of created objects can inherit the properties of the layer they 
belong to. Otherwise, the properties of created objects will inherit the properties of a 
RxSpotlight document.  

Layers can be created, named, and properties assigned to them. Each layer has a set 
of properties, such as its unique name, display colour, line type, line weight, and 
more. A layer can be visible or hidden, locked or unlocked, selectable or unselectable. 
One of the document layers is a current layer on which all drawn objects are placed 
by default. 

When beginning a new document, it always contains a layer named Default with the 
properties that coincide with those of the RxSpotlight document. An unlimited number 
of layers can be created. A new layer inherits the properties of the layer that was 
selected when created. A newly created layer is always visible, unlocked, and 
selectable. The program assigns the name New Layer (N) to it, where N is ordinal 
number. 

Layers can be created and deleted; the information on their properties viewed and 
changed using the Layers dialog. 

To open the Layers Manager dialog 

Choose Layers from the Tools menu or click  button on the Properties toolbar. 

The Layers dialog appears: 

 
The Layers window can be expanded by pressing the Details button to display the full 
list of the layer properties to be inherited by the objects created on it and inserted in it. 

Creating a new Layer 

To create a new layer, press the  button on the Layers dialog. 

A new layer with the name New Layer (N) appears in the list. This layer is always 
visible, unlocked, and selectable.  

If the newly created layer is to inherit the properties of another layer present in Layers, 
then select that layer before creating the new layer.  
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Deleting Layers 
A layer which is not current and does not contain any objects can be deleted at any 
time during the working session. To delete a layer which contains objects delete these 
objects first. 

Select an empty layer to delete from the Layers dialog list and press the  button. 

Renaming Layers 
A layer may be renamed to better define how it is used in the document. A layer can 
be renamed at any time during the working session. 

To rename a layer: 

Select a layer to rename from the Layers dialog box list, and then: 

Click its active name and enter the new name to Name or select Name in the full 
Layers window and enter the new name. 

Making a Layer active 

An object is always created on the active (current) layer. This object can assume 
properties from the layer it belongs to, if By layer value is set in the corresponding 
boxes of RxSpotlight document properties. The active layer should be always visible. 

To make a layer current: 

Select a layer to make it current in the Layers dialog, and then: 

Click the Active icon  or turn on the Active checkbox in the full Layers window. 

Controlling Layer visibility 
RxSpotlight does not display or plot the objects that are placed in an invisible layer. 
The current layer is always visible. An invisible layer cannot be current. 

To turn a layer on or off: 

Select a layer to turn it on or off in the Layers dialog, and then: 

Turn on or off the visibility icon 
 
or turn the Visible checkbox on or off in the full 

Layers window. 

To toggle visibility off on all the layers, click on the 
 
button on top of the layers list. 

This toggles the visibility of all layers, except the active one. 

Locking or unlocking layers to edit 

Locking layers is useful when editing objects associated with particular layers whilst 
viewing but not editing objects on other layers. Objects on a locked layer cannot be 
edited. However, the objects are still visible and can be selected and their properties 
viewed. A locked layer can be made current, and objects can be created and inserted 
in it. 
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Commands that do not change the properties of objects located on a locked layer can 
also used (for example, select required vectors and convert them to a raster image 
which is inserted in another unlocked layer). Object snaps can applied to objects on 
locked layers. The visibility of locked layers can also be turned off as well as their 
properties changed. 

To lock or unlock layers: 

Select a layer to lock or unlock, and then: 

Click the Lock icon 
 
on or off or turn the Locked checkbox on or off in the full 

Layers window. 

To toggle locking for all layers click on the 
 
button on top of the layers list. 

Controlling object selection 
A layer can be made selectable or unselectable.  

For example, if there are multiple layers and objects that belong to certain layers need 
to be selected, the other layers must be made unselectable (and/or invisible). 

To make a layer selectable (unselectable): 

Select a layer to make it selectable or unselectable: 

Turn on or off the Selectable icon 
 
or turn on or off the Selectable checkbox in the 

full Layers window. 

To toggle selectability for all layers click on the 
 
button on top of the layers list. 

Controlling Layer printability 

RxSpotlight displays but does not or plot the objects that are placed in an unplottable 
layer. 

To turn layer printability on or off: 

Select a layer in the Layers dialog, and then: 

Turn on or off the visibility icon 
 
or turn the Printable checkbox on or off in the full 

Layers window. 

To toggle visibility off on all the layers, click on the 
 
button on top of the layers list. 

Specifying Colours 

A colour can be assigned to layers so that all objects belonging to these layers are 
displayed in this colour. The colour of objects is set by choosing a colour from the list 
in the Properties toolbar or in the Inspector. If the By Layer attribute is set, then the 
colour of objects is determined by the layer on which the object resides. 

The colour of objects that are components of blocks is set on block creation and 
controlled with the By Block attribute. 

To change the colour of layer, first select the layer, then choose a colour from the 
drop-down list or from the Choose Colour dialog. 
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Specifying other layer properties  
In Layers it is possible to specify all properties that can be inherited by the objects 
created on it. Ensure the By layer value is set in the corresponding boxes of the 
RxSpotlight object properties.  

Select a layer to change the properties. Define the required values for this layer. To 
set the layer properties, except Line Width and Line Type, expand the Layers window 
by pressing the Details button. 

 For more information on controlling of object properties see “Inspector” on 
page 40. 

Access on the fly 
Layers properties can be easily managed in corresponding sections of the Inspector 
window and Preperties toolbar. 

 
 

Images 
With RxSpotlight raster images can be opened or inserted and combined with vector 
objects.  

Raster object selection in RxSpotlight makes raster editing as easy as vector editing. 

Using RxSpotlight, transformation of raster objects into vector objects is simple. Pick a 
raster object on the image, and then RxSpotlight automatically recognizes its shape 
and creates the approximating vector. There is an option to delete the original raster. 
Deleting an original raster object does not leave breaks and gaps in intersecting raster 
lines. 

A raster image inserted into a drawing is either externally referenced ( linked images ) 
or embedded to RxSpotlight document. When inserting an image from an existing file, 
the RxSpotlight object raster image insertion is created which contains a path to the 
image file, scale, rotation angle, insertion point, and other properties. The reference or 
link to the raster image can be modified or deleted at any time. Raster images can 
also be stored inside a RxSpotlight document as embedded (note that it increases the 
size of the RxSpotlight document file). 

Raster images, as other RxSpotlight objects, can be rotated, scaled, copied, moved, 
and cropped.  

RxSpotlight supports almost every standard image file formats used in computer 
graphics, document management, mapping and geographic information systems 
(GIS). Images can be bitonal (monochrome), 8-bit greyscale, 8-bit colour, or 24-bit 
colour.  In the case of bitonal images, the background pixels are treated as 
transparent. 
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Each image inserted in a RxSpotlight document has a border. Select an image by 
specifying a point on its border; if a point inside an image is specified, the image will 
not be selected. Images can also be selected using the Select Image dialog. 

A raster image properties can be changed, including: 

 image layer, boundary colour; 

 image visibility on the screen, border visibility on the screen; 

 image transparency in percentage; 

 switching on/off background transparency of bitonal images; 

 image clipping; 

 read-only status; 

 scale, rotation angle, insertion point. 

Multiple raster images can be inserted in the document. 

Any existing image may be loaded and placed in the workspace at the selected 
location. Images can be edited, saved, and closed. New raster images can also be 
created in RxSpotlight. 

To open a raster image 

To open an image, choose Open from File menu and select an image from the list. 
RxSpotlight will open a new document that will contain only one object – an image. 

The loaded image will be inserted at point 0,0 with scale 1 and rotation angle 0. 

The image can be changed and saved. RxSpotlight saves images in their native 
format by default. If, during working, some other objects are added in the document, 
then it may not be possible to save all document contents in the image file. In this 
case, either save an image loosing some data, or save the document in .CWS file. 

Predefined raster or vector objects can be inserted into newly opened images. These 
objects are stored in file templates and their usage is controlled by settings in the 
Template Usage section of the Tools > Preferences dialog (see page 393). For 

example, if there is a document called BORDERS.CWS with a drawing frame and title 
block, this can be set as a template in the For New documents section, so that every 
new image automatically opens with a frame and title block. 

To insert an image into a current RxSpotlight document 

Choose From file from the Insert menu. After selecting an image in the dialog, it 
needs to be placed in the document workspace. When moving a dashed rectangle 
representing the image border to the appropriate position, click to finish the insertion. 

When inserting, specify an insertion point and/or scale or rotation angle in the 
Inspector window. 

An insertion point can be specified when initially inserting an object (the left bottom 
corner of the image). In this case the image is inserted with a zero rotation angle and 
at a scale of 1:1. For example, choosing A4 format with Portrait orientation, and 
millimetres as measurement units, an image of 297 mm in height and 210 mm in 
width will be inserted. 

To change an image scale, specify a scale factor in the Inspector window. 

The Angle field in the Inspector window allows the rotation angle of the inserted image 
to be entered. 
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To load very wide monochrome raster images 

RxSpotlight can open bitonal raster images not higher than 16 million pixels and not 
more widely than 64500 pixels. 

There is, however, an ability to open very wide bitonal images. Those images will be 
inserted visually as is but with the Angle property equal to 90 degrees. 

 A wide bitonal image will be saved to a raster file rotated by 90 degrees. 

Options for this feature can be set with the Large format images control item of the 
Preferences dialog. 

 

To create a new raster image 

1. Choose New Image from the Insert menu. 

 
2. Enter the image size in Width and Height or from the Standard Paper Sizes list, 

select the image size. 

 This list only contains the sheet formats included in the Paper Formats list of 
the RxSpotlight Options dialog box. This list can either be added to or 
reduced. See “Tuning the application” on page 389. 

3. Select an orientation required for the specified sheet format in the Orientation 
box. 

4. Select the required image resolution in DPI, and the measurement units that will 
be used when image scaling in Units. 

5. Click OK. 

Specify an insertion point, and/or scale or rotation angle in the Inspector. 
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An insertion point can be specified when initially inserting an object (the lower-left 
corner of the image). In this case the image is inserted with a zero rotation angle and 
at a scale of 1:1. For example, choosing A4 format with Portrait orientation, and 
millimetres as measurement units, an image of 297 mm in height and 210 mm in 
width will be inserted. 

To change an image scale, switch to the Inspector and specify a scale factor. 

The Angle box in the Inspector allows the rotation angle of the inserted image to be 
entered.  

 An image that only contains selected objects can be created. The procedure 
is described on page 292. The newly created object will have embedded 
status. See the description of embedded images below in this section. A new 
image can also be inserted directly from a scanner (see page on page 86). 

To change image properties 

Image properties can be changed with the Inspector window and in the Images dialog. 

Managing Images  
The Images dialog lists the names of all raster images loaded into the RxSpotlight 
document.  

To open the Images dialog 

Choose Images from the Tools menu or click  button on the Properties toolbar. 

 
To change the properties of an image, select it from the list. 
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Name 

In this box type in the logical name of the image.  

File Name 

Displays the selected image‟s filename. 

Read-Only and Visible attributes 

These attributes control the ability to change the images. They are represented by 

Visible and Locked (
 
and 

 
icons) and two checkboxes in the Details section of 

the dialog. TRUE and FALSE values can also be set for these attributes in the Details 
list or in the Inspector window. 

 Visibility of images can also be toggled on/off with the Show/Hide Rasters 
command, see page 37. This operation does not change the visibility attribute 
of images. 

References 

Images are created or opened once but can be inserted (and displayed) many times. 
Reference shows the number of times the image has been inserted in the document. 
For example, if an image is selected, copied, and pasted, then the Reference field will 
contain 2. 

If the image is not inserted anywhere in the document, then Reference will contain 0. 
It means that image data still exists in the document and is ready to be shown again; 

to purge it, you must press the Delete button . 

Colour 

Displays the colour of an image (for monochrome images). A colour can be chosen to 
distinguish between images in the Inspector window or Properties toolbar. The By 
layer option assigns the layer colour to images that belong to this particular layer; and 
By block assigns the colour of the block to an image that is part of the block. 

Layer 

the layer to which an image belongs can be seen and the image moved from one 
layer to another (actually the image does not “move”; but the Layer attribute of the 
image changes). 

Details 

This button opens the full list of image properties. For example, rotate an image by 
specifying a non-zero value in Angle or make it opaque by setting FALSE in 
Transparent Color (for monochrome images). the same properties list can be seen in 
the Inspector window for a selected image. 

Preview 

This is the standard RxSpotlight Preview window. It can display the entire image or 
zoom to an area. Buttons and options are described on page 34. 

Buttons 

 
New Creates a new image. 
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Delete Purges an image from the document. 

 
Save Saves an image. 

 
Save As Saves an image to a new file. 

 
Embed Embeds the selected image. The image is not linked to the file 

and exists only in the document. See the description of 
embedded images below. 

 Up Moves the selected image or page of multipage TIFF up. For 
multipage TIFF this is a way to rearrange pages before saving. 

 Down Moves the selected image or page of multipage TIFF down. 
Moves selected image or page of multipage TIFF up. For 
multipage TIFF this is a way to rearrange pages before saving. 

Embedded vs. Linked images 

There is a possibility to insert an image in document from a file, process and save it. 
During its work, RxSpotlight keeps image file name and allows to save raster image at 
any time with the the Save button from the Images dialog. 

RxSpotlight can also process images, which are actually located in the document. Any 
linked image can be embedded in RxSpotlight document. To embed a linked image, 

select this one in the Images dialog and press Embed button
 

. The <Embedded> 

word appears in File Name. 

Embedded images can be created by applying the RxSpotlight commands New 
Image (see description on page 50), New Image from Selection (see description on 
page 292), New Image from Scanner. They are also generated by RxSpotlight 
procedures that create images such as binarization and colour separation. 

To change embedded image to linked 

1. Select an embedded image and press  button. 

2. Select a filename and an image format in Save As dialog. 

3. Press OK. 

Setting Raster Formats for Saving 
RxSpotlight allows you to manage raster formats, which used in: 

 Save As command of Images dialog, 

 Open command, 

 Insert Image command. 

To set format parameters 

1. Press the Options button in the dialog of the Save As command of the Images 
Manager. 
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2. Set the necessary parameters of the selected format. 

To compose a format list to be applied in the Save as command 

1. Choose Preferences from the Tools menu. 

2. In the Preferences dialog pane open the list of Raster file formats. 

3. Select checkboxes for the desired formats. 

To create a custom format based on an existing one 

1. Select a base format in the Preferences dialog, the Raster file formats section. 

 

2. Press the Add button. Set 

the name and description 
for a new format. Press 
the Options button. 
 

 

3. Set the necessary options 
in the displayed dialog. 
The dialog is different 
depending on the base 
format selected. 

4. Press OK. 

The format created will appear 
in the Files of type list of the 
Save and Open commands. 
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TIFF Format Options 

 
 

Compression Sets compression and compression options: 

 No Compression (All) 

 CCITT modified Huffman RLE (Bitonal) 

 CCITT Group 3 fax encoding (Bitonal) 

 CCITT Group 4 fax encoding (Bitonal) 

 Macintosh RLE (All) 

 ZIP (All) 

 JPEG DCT (Greyscale and True Colour) 

Organization Raw - No organization 

Striped - Sets striped organization 

Tiled - Sets tiled organization 

Byte Order Sets byte order: Intel (little-endian) or Motorola (big-
endian) 

Save Thumbnail Saves the thumbnail of the image to preview 

JPEG Format Options 

JPEG format allows specifying the image compression level; but this operation can 
result in irreversible information loss. To decrease the visual effect of the information 
loss, apply a compression level not lower than 80%. Saving an image in this format 
allows for a considerably reduced file size,.   Note that when saving in JPEG format 
the image is resaved with the new information; this, however, means that the image 
quality is lowered with each saving.  . If the image quality is critical, then it is 
preferable to use a TIFF format. This format also allows compressing an image with 
no information loss. 
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Low - Low quality, high compression level. 

High - High quality, low compression level. 

Clipping 
Clipping is an operation that defines the subregion on the image for displaying, 
plotting or processing. If an image is saved with a clipped area in CWS file and later 
reopened, then only the clipped part will be loaded thus reducing load time and saving 
computer memory. Operations such as filtering and tracing can only be applied inside 
the clipping boundary that protects the rest of the image from unwanted changes. The 
clipped area can also be used for cropping (see next section). 

The Image Clip submenu contains the following commands: 

 
Reset Resets the clipping boundary 

 
Rectangular Sets the rectangular clipping boundary 

 
Polygonal Sets the polygonal clipping boundary 

Clipping is the image property that can be viewed and changed in the Inspector 
window. 

More on images 
Image border 

When an image is selected or inserted into a document, a dashed border and three grips 
can be seen. These interface elements help to move, rotate and scale the image on the 
screen. They are described in the section “Entire Image selection” on page 104. 

Image selector dialog 

Several images can be selected and apply many RxSpotlight operations to them. 

Pressing a 
 
button opens the Image Selection dialog and images can be selected 

by clicking them on screen. See the section “To select several raster images” on 
page 105 for more information. 
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Background of a document and image 
To setup the background colour for the RxSpotlight

 
document, open the 

Tools > Preferences dialog and click on Colours. 

 
The checkmark next to Background means that the default colour is being used. To 
change the colour choose the Background option, press the Modify button and 
choose a colour from the open Category Name and Colour dialog and turn off the Use 
default colour checkbox. Press OK twice. All RxSpotlight documents will be displayed 
on the background of the chosen colour. 

A background colour can be deleted by setting the Use default colour checkbox in the 
Category Name and Colour dialog. In this case the default Windows colour is used. 

The background colour of an image can be changed in the Inspector window since it 
is a property of all monochrome images. 

To change the image background colour 

1. Select an image in Vector selection mode (  button pressed) by clicking on 

its border.  

2. Open Inspector window. 

3. Set Transparent Color to FALSE (for monochrome images). 
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4. Select new background colour in Background list. 
The new background colour shows immediately on monochrome images.  

On colour images the background colour shows when raster information erased from 
the raster image. 

Command Line 
The Command Line is the interactive text window from where RxSpotlight commands 
can be called and processed. 

To show the Command Line window choose the View > Show Command Line in 
menu. 

 

The standard way of interaction with RxSpotlight is performed by using dialog 
windows, Inspector, toolbars, and right-button menus. The Command Line can be 
used jointly with all set forth ways of interaction to speed the user‟s interaction with 
the program. The new interface is especially convenient for those users who know the 
AutoCAD interface well. 

RxSpotlight Command Line is not case sensitive so both uppercase or lowercase can 
be used. 

Commands, aliases and shortcuts 

To enter a command from the keyboard, type the full command name in the command 
line and press ENTER or SPACEBAR to execute it. 

A Command Line alias is an abbreviation that entered on the Command Line instead 

of typing the entire command name. For example you can enter HATCH alias instead 

of HatchCmd command name to run drawing hatch command. A number of aliases 

could launch the same command. RxSpotlight uses AutoCAD compatible aliases. 

Command Line shortcuts are similar to aliases but launch a group of commands 

grouped by certain criterion, for example the S shortcut initiated launching group of 

selection commands: 

 

The complete list of registered command names, aliases and shortcuts can be viewed 

in Command Line window by entering the ‘ (apostrophe) sign followed by the space 

or Enter key. 

Command Line prompt 

By default the RxSpotlight Command Line prompt looks like 
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but It varies depending on the current command or program state. 

The command prompt can include descriptive messages that are displayed on the 
status line when command is running: 

 

Also it can include interactive keywords in square brackets separated by one or more 
slashed when a choice should be made: 

 
The user can type any keyword or just click on it. 

The keyword specified in angle brackets is the keyword “by default”. To choose it 
press the ENTER key. 

In addition to choose a keyword, enter the letters capitalized in one of the keywords in 

the brackets (in uppercase or lowercase). For example, to choose the aRc keyword, 

just enter the R or the r letter. 

Some prompts demand various data as arguments: text, numbers, coordinates, etc. 
The format of input of such data is similar to a format of data entered in Inspector 
window.  

To use coordinate values to specify a point, enter an X value and a Y value separated 

by a comma <X,Y>. The X value is the positive or negative distance, in units, along 

the horizontal axis. The Y value is the positive or negative distance, in units, along the 
vertical axis. 

For example, to enter coordinates of the point during drawing line command, type the 
x-coordinate and y-coordinate divided with comma: 

23.45,-6.98 

or just click a point on the screen using the mouse. 

Absolute coordinate values are based on the origin <0,0>, where the X and Y axes 

intersect. Use absolute coordinates when you know the precise X and Y values of the 

point. For example, the 3,4 specifies point 3 units along the X axis and 4 units along 

the Y axis from the origin. 

For example, to draw a line beginning at an X value of –2, a Y value of 1, and an 
endpoint at 3,4, make the following entries on the command line: 

Command: line 

Specify start point for line or [Continue/]: -2,1 

Specify end point for line or [Continue/]: 3,4 

RxSpotlight locates the line as follows: 
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Relative coordinates are based on the last point entered. Use relative coordinates 
when you know the location of a point in relation to the previous point. To specify 
relative coordinates, precede the coordinate values with an @ sign. For example, 

@3,4 specifies a point 3 units along the X axis and 4 units along the Y axis from the 

last point specified. 

The following example draws a line whose endpoint is 5 units in the X direction and 0 
units in the Y direction from the start point at the absolute coordinate location -2,1. 

Command: line 

Specify start point for line or [Continue/]: -2,1 

Specify end point for line or [Continue/]: @5,0 

 
To enter polar coordinates, enter a distance and an angle separated by an angle 

bracket <. For example, to specify a point that is at a distance of 1 unit from the 

previous point and at an angle of 45 degrees, enter: 

@1<45 

By default, angles increase in the counterclockwise direction and decrease in the 
clockwise direction. To move clockwise, enter a negative value for the angle. For 

example, entering 1<315 is the same as entering 1<-45. 

Polar coordinates are either absolute (measured from the origin) or relative to the 
previous point. To specify relative coordinates, precede the coordinate with an @ 
sign. 
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The following example shows a line drawn with polar coordinates. 

Command: line 

Specify start point for line or [Continue/]: 0,0 

Specify end point for line or [Continue/]: 4<120 

The following example shows a line drawn with relative polar coordinates. 

Command: line 

Specify start point for line or [Continue/]: 0,0 

Specify end point for line or [Continue/]: @3<45 

Transparent commands execution 

Many commands can be used transparently: that is, they can be entered on the 
command line while you use another command. Transparent commands frequently 

change drawing settings or display options, for example, ZOOM, or GRIDSETUP. 

To use a command transparently, click its toolbar button or enter an apostrophe (') 

before entering the command at any prompt. After you complete the transparent 
command, the original command resumes. In the following example, you perform on 
zoom window command while you draw a line, and then you continue drawing the 
line. 

 
Commands that do not select objects, create new objects, or end the drawing session 
usually can be used transparently. Changes made in dialog boxes that you have 
opened transparently cannot take effect until the interrupted command has been 
executed. 

Navigating 

To navigate and edit text and to correct or repeat commands use the standard keys: 

 UP, DOWN, LEFT ARROW, and RIGHT ARROW 

 INS, DEL 

 PAGE UP, PAGE DOWN 

 HOME, END 

 BACKSPACE 

Repeat any command used in the current session by cycling through the commands 
with UP ARROW and DOWN ARROW and pressing ENTER. By default, pressing 
CTRL+C copies highlighted text to the Clipboard. Pressing CTRL+V pastes text from 
the Clipboard. 
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For most commands, the Command Line with five or six lines of previous prompts, 
called the command history, is sufficient for viewing and editing. To see more lines of 
command history, you can scroll through the history or resize the command window 
by dragging its border. 

Mathematical Processor 

The command line allows input of not only commands, numbers and points, but also 
of mathematical expressions. This is convenient, when the coordinate or number is 
not known beforehand but should be calculated proceeding from some conditions. 

For example, instead of calculating beforehand coordinate of a point, and only then to 
type it in a command line, like there: 

 
you can use math expression: 

 
The complete list of registered operations, functions and constants can be viewed in 

Command Line window by entering the ? sign followed by the space or Enter key. 

 

The Mathematical Processor supports the following arithmetical operations: 

( ) Groups expressions 

+ - Adds, subtracts 

* / Multiplies, divides 

% Remainder 

** Power 

 

constants: 

E The constant e, the base of natural logarithms. 

PI The constant pi. It represents the ratio of the circumference of 
a circle to its diameter. 

 

functions: 

COS Returns the cosine of a number. 

SIN Returns the sine of a number. 

TAN Returns the tangent of a number. 

ACOS Returns the arccosine of a number. 

ASIN Returns the arcsine of a number. 

ATAN Returns the arctangent of a number. 

ABS Returns the absolute value of a number. 
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EXP Returns e (the base of natural logarithms) 
raised to a power. 

LN Returns the natural logarithm of a number. 

LOG Returns the base-10 logarithm of a 
number. 

SQRT Returns the square root of a non-negative 
number.  

FLOOR Returns the largest integer less than or 
equal to the given numeric expression 

CEIL Returns the smallest integer greater than 
or equal to the given numeric expression. 

FRAC Returns a locale-specific count of the 
number of digits to display to the right of 
any decimal point. 

TRUNC Returns the integral digits of the specified 
number. Any fractional digits are 
discarded. 

ROUND 

(x,precision) 

Returns a number rounded to a specified 
number of decimal places (precision). The 

precision variable value indicates how 

many places to the right of the decimal are 
included in the rounding. 

NEG Returns the negative value of a number. 

SGN Returns an integer that indicates the sign 
of a number: 1 - Greater than zero; 0 - 
Equal to zero; -1 - Less than zero. 

 

The user defined variables can be used in calculation expressions. The variable is 
created using the following syntax: 

?<variable>=<value> 

For example: 

?base=10 

Specify a point: base+10.1,base+20.2 

Coordinate System of a RxSpotlight 
Document 
By default a new RxSpotlight document opens in the World coordinate system 
(parameters: origin 0.0, 0.0/angle 0/scale1:1, direction - counter clockwise). 
Measurement units specified by default depend on the geographical region which is 
established in the options of the operational system. 
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It is possible to work in the World Coordinate System or set a user defined one. 

 You can set and modify coordinate system for the model space only, 
because the paper space coordinate system is the World Coordinate 
System. 

To set the Coordinate System  

From the Tools menu choose Coordinate System; or press the button 
 
located on 

the Settings toolbar. 

Set a coordinate system in the Coordinate System tab of the Coordinate System 
dialog. 

If the World Coordinate System is selected, then the parameters Origin, On Page, 
Angle, Scale, Actual and To are disabled. 

Creating and modifying a Coordinate System 

Press the button  New Coordinate System, located next to the World Coordinate 

System field, set a name for the desired coordinate system, and then ENTER. 

 
1. Choose the mutual axis orientation of the coordinate system in the Base box 

2. Change the origin by either specifying it in the input box or by measuring it on 

the screen, having pressed the button with the ruler . 

3. Change the X-axis angle by either specifying it in input box or by measuring it on 

the screen, having pressed the button with the ruler . 

4. It is possible change the scale in two ways: 

 by specifying it in the Scale box, 
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 - or - 

 by measuring the distance On Page (either by specifying it in input box or by 
measuring it on the screen) and entering the matching value in Actual. The 
Custom value will appear in Scale. 

Buttons with arrows  near the boxes reset the default values for corresponding 

boxes. The Reset dialog button resets all parameters of the Coordinate System tab to 
their World coordinate system values. 

The Apply button applies the current settings of the coordinate system to the 
document and  the dialog on the screen stays open. (Pressing OK does the same, but 
the dialog is closed.). 

Select the values and precision for both linear and angle units for the coordinate 
system from the appropriate boxes of the Units tab. The Example boxes show a way 
to display the set values with the current settings (units and precision). 

 
The Advanced tab helps set a coordinate system on the basis of a few (two at least) 
control points with known coordinates. This method snaps the image to the coordinate 
system needed for a current work session. 
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 Press the Add Point button , pick a point in the image, the coordinates of 

this point will appear in the Source field. 

 Enter the real (known) coordinates of this point in the Destination box. 

 To change a control point, select it in the table and press  Move Point; 

then specify a new location in the image. 

 To delete a point press the button  Delete Point. 

UCS defining commands 
RxSpotlight has three commands for change coordinate system origin and orientation 
on the fly. 

Set UCS by Point 

This command allows you to shift UCS origin. 

1. From the Tools menu choose Coordinate System and then Set UCS by Point 
command; 

2. Specify location of new UCS origin. 

Set UCS by Point and Angle 

This command allows you to change UCS origin and UCS orientation. 

1. From the Tools menu choose Coordinate System and then Set UCS by Point 
and Angle command. 

2. Specify location of new UCS origin. 

3. Specify UCS rotation angle. 

Set UCS by Object 

Sets UCS origin and UCS orientation based on a selected object. 

While the cursor has been moved to an object, UCS origin is placed close to object 
contour. Generally, UCS X axis is placed along straight edge or tangentially to curved 
edge of object. Y axis is placed dependently of an object type and of X axis 
orientation. 

 To place UCS origin exactly on contour of an object, switch on 
appropriated snap mode. 
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The following table shows dependence between UCS axes orientation and type of an 
object. 

Object type Axes orientation 

Line X axis – passes along the line in a direction of its longest part. 

Y axis – changes direction to keep UCS counter clockwise. 

Rectangle Equal to line for each rectangle side. 

Arc Y axis – draws in a counter direction to the arc centre point. 

X axis – passes tangentially to arc edge in such a manner to 
keep UCS counter clockwise. 

Polyline Equal to line for each linear segment. Equal to arc for each 
curved segment. 

Circle Equal to arc. 

Ellipse X axis – passes tangentially to ellipse edge in this or that 
direction. 

Y axis – draws in such a manner to keep UCS counter 
clockwise. 

Spline Equal to ellipse. 

Point X and Y axes keep their previous orientation. 

Dimension Depends on dimension type and part. 

Hatch Snaps to hatch contour. X and Y axes orientation depends on 
hatch container object. 
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Block Snaps to objects in block. X and Y axes orientation depends on 
type of object. 

Ray and Xline X and Y axes orientation equal to World Coordinate System. 

Text Snaps to text base point. X and Y axes keep their previous 
orientation. 

Multiline text Snaps to multiline text nodes and text. In addition, UCS origin 
can be placed inside multiline text field. X and Y axes keep their 
previous orientation. 

Raster image 
object 

Equal to rectangle and line objects. 

 

 After the Set UCS by Point, Set UCS by Point and Angle or Set UCS by 
Object command has been performed, the new User Coordinate System 
is created and became current. It is named as Current Coordinate 
System. It is based on previous UCS and newly specified settings. If the 
Current Coordinate System already exists, then only update of UCS 
settings is performed. 

UCS icon 

 

The Coordinate System icon is displayed at a point 0,0 of current coordinate system 
and shows UCS origin and axes orientation. This sign can be turned OFF or ON by 
using the Show UCS icon command from the View menu. 

To change UCS icon color refer to Colors section of the Preferences dialog. 

Measure window 
The Measure command from the Tools menu opens a window with a rich set of tools 
for measuring lengths, angles, perimeters and areas on the screen. 

Use the measure tools to measure objects on the image, edit the results as text and 
then save to a separate file. 

To measure on the screen: 

1. Open the Measure dialog and choose the appropriate measuring mode (one of 

the six right buttons; using the 
 
button adds the coordinates of points to the 

measurement results).  
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2. Move to the document window and by pointing with the mouse; draw a 
measuring contour over a measured object. It is drawn with «rubber line». When 
creating a measuring contour use the standard RxSpotlight

 
operations used for 

creating entities (e.g., a polyline can contain arc segments; they are drawn as 
arcs with SHIFT pressed).  

 After creation the measuring contour disappears and the results of measuring 
are viewed in the protocol window. 

3. It is possible to edit the text of the protocol and add text. By pressing the buttons 
on the left of the button bar, the text of the protocol can be deleted, saved and 
printed. 

 

 

Automatically recorded protocol Edited protocol text 
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Buttons in Measure window 

  
Measure Distance 

 
Measure Angle 

 
Measure Arc 

 
Measure Polyline 
Measures the length of a polyline, consisting of line or arc segments. 

 
Measure Polygon  
Measures the area and perimeter of the figure enclosed by the polyline. 

 
Measure Selected objects 

Pressing this button with one or more objects selected gives the string 
Multiple selections, the number of objects in the selection and their overall 

area and perimeter in the protocol. 
If only one object is selected, then this button also determines the type of 
object. 

 
Add point coordinates 

If this button is pressed, then the coordinates of points are added to the 
measurement protocol. 

 
New Log 

Clears the window of the measurement protocol (previous content is 
removed). 

 
Save Log 
Saves the protocol in a file with the extension .TXT. 

 
Print Log 
Prints the protocol. 

 Measure protocol window 
Contains the results of measuring. These results can be scrolled and edited. 
The picture shows the edited log. 
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Clipbooks 
The RxSpotlight Clipbook is a container for raster, vector or hybrid graphics. 

Any number of selections can be stored in the RxSpotlight Clipbook. It is also possible 
to name and save the contents of any RxSpotlight Clipbook window in a file with CLB 
extension. Therefore, Clipbook files can be used as libraries of raster, vector or hybrid 
graphics. 

To create a new RxSpotlight Clipbook window 

From the Tools menu, choose Clipbook. 

The following window appears. 

 
RxSpotlight Clipbook window 

Moving Graphics into the Clipbook 
To move graphics from the RxSpotlight document to the Clipbook, cut or copy a 
selection with the Cut or Copy command, and then paste the data to the Clipbook. 
The user cans also drag-and-drop selected items into the open Clipbook window. 

To move graphics into a Clipbook 

1. Select graphics to move. 

2. From the Edit or right-click and from cursor menu choose Cut or Copy. 

Cut erases the selection and places the erased data in the data storage. Copy 
places graphics in the data storage but does not remove the selection. 

3. Activate the Clipbook window. 

Right-click anywhere in the Clipbook window. From the cursor menu, choose 
Paste. 

The previously copied or cut selection appears in the Clipbook Window. It 
appears as “Item N” where N is integer. 



RxSpotlight User Guide 
 

73 

 
Previously copied or cut selection appears in the Clipbook window 

Managing Clipbook Contents 
Using the Clipbook toolbar or cursor menu the contents of a Clipbook can be saved in 
a disk file, and then restored from file.  

To save the Clipbook 

1. Activate the Clipbook window to be saved. 

2. From the Clipbook toolbar click the  button. 

- or - 

 Right-click anywhere in the Clipbook window. Choose Save from the cursor 
menu. 

To save the Clipbook as 

1. Activate the Clipbook box to be saved. 

From the Clipbook toolbar, click the  Save As button. 

- or - 

Right-click anywhere in the Clipbook box. Choose Save As from the cursor menu. 
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The following dialog box appears. 

  
Save Clipbook dialog box 

2. Choose the folder to save the Clipbook. 

3. If necessary, then press the Option button and write the comments for this 
Clipbook in the displayed Comments window. 

4. Type a new name in the File Name box or select an existing file to replace. 

5. Click Save. 

To load previously saved contents of the Clipbook 

1. Activate the Clipbook window where you want to load previously saved Clipbook 
contents. 

2. From the Clipbook toolbar click the  button. 

- or - 

Right-click anywhere in the Clipbook window. Choose Open from the cursor 
menu 

The Open Clipbook dialog box appears. 

3. Select the name of a file to open and click Open. 

Managing Clipbook Items 
Use the cursor menu to rename, delete, cut, copy, and paste any Clipbook item. 

The user can drag items from the Clipbook and drop them on a RxSpotlight document 
or on another Clipbook.  
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To operate with a Clipbook item 

Select an item with the left mouse button, then from the right button cursor menu. 

Choose: 

 
Cut  To erase the selected item and place it in the RxSpotlight data 

storage. 

 
Copy To place the selected item in the RxSpotlight data storage but 

not to remove the item from the Clipbook 

 
Rename To change the name of the selected item. 

 
Delete To remove the selected item from the Clipbook. 

Pasting Graphics from the Clipbook 
A Clipbook item can be pasted to a RxSpotlight document or to another opened 
Clipbook window. 

Any item can be moved, scaled and rotated in a RxSpotlight document. 

To paste a Clipbook item 

1. In the Clipbook window, select an item to paste. 

2. Cut or copy the selected item to the RxSpotlight document using the Cut or Copy 
command from the right mouse cursor menu. 

3. From the RxSpotlight Edit menu, choose Paste. 

- or - 

Place cursor on the RxSpotlight document or on another Clipbook window and 
choose Paste from the cursor menu. 

- or - 

Drag the item from the Clipbook to the RxSpotlight document or to another 
Clipbook window. 

The item appears in the RxSpotlight document or in another Clipbook window. 

 Clipbook items preserve layer structure. If multilayered items are pasted 
into the document, then the number of layers may increase, if the layer 
names of the Clipbook item are different from those of the document. 

Purging 
Frequently modified documents often contain many unused named objects such as 

block definitions without block insertions, image definitions without image insertions, 

layers which do not contain objects, not used text styles. To easily detect and remove 

all unused objects, use the Purge dialog. To start dialog choose Purge from the Tools 

menu 
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This dialog shows only those objects which can be safely removed from the 
document. For example, a block definition cannot be purged if it is nested inside 
another block. 

Use the Confirm each item to be purged checkbox to prevent casual removals. 

Turn it on to receive an object removing confirm message after every Purge button 
click. To remove all the objects of a certain category select this category and purge it. 

The following objects will not be visible in this dialog: 

A block definition cannot be purged if 

 It is nested inside another block definition. 

 It is inserted in the drawing. 

An image definition cannot be purged if 

 It is nested inside the block definition. 

 It is inserted in the drawing. 

A layer cannot be purged if 

 It is the current layer. 

 It contains objects. 

A text style cannot be purged if 

 It is the current text style. 
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 It is used by a text in the drawing. 

Exporting and Importing 

Exporting 
It is possible to export an entire RxSpotlight document or selected objects to 
AutoCAD, MapInfo format, HPGL/2 formats, ESRI Shape-format as well as to select 
desired objects from a current document and export them to a new RxSpotlight 
document, and also export raster images to PDF, multipage TIF and multipage CIT 
files. 

To export a RxSpotlight document or selected objects 

1. Select desired RxSpotlight objects if you need to export particular objects. 

2. From the File menu, choose Export or click the  button on the 

Miscellaneous toolbar. The Save/Export document File dialog appears. 

3. Select a folder to save the file in and file format from the list of Save as type 
box. 

4. The Options button offers the optional settings for the selected file format. 

5. Type a new name in the File Name box or select it from the list. 

6. Switch on the Selection Only checkbox to export selected objects only. 

7. Click Save. 

Export formats Exported objects 

RxSpotlight (5.х – 7.х) (*.cws) 

AutoCAD (*.dwg, *.dxf, *.dwf) of 
version R14 (AutoCAD LT 97) and 
higher 

Vector objects and/or raster 
images 

Adobe (*pdf) 

Multipage *.tif 

Multipage *.cit 

Raster images 

AutoCAD (*.dwg, *.dxf, ) of version 
R13 (AutoCAD LT95) and lower 

MapInfo (*.mid) 

HPGL/2 (*.plt, *hp, *hpg) 

ESRI (*.shp) 

Vector objects 

Export to AutoCAD DWG/DXF format 
Start the Export or Save As command, choose the AutoCAD DWG (*.dwg) or 
AutoCAD DXF (*.dxf) from the format list and click Options button. 

Use the displayed dialog to select the desired properties. 
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When exporting to DXF format specify the Dxf decimal precision parameter. It defines 
the maximal decimal precision for the exported document so it can be decreased to 
the appropriate value. 

The Convert to UCS parameter is used when saving and exporting. If it is set to on 

when saving objects in DWG format, then the coordinates and sizes of objects 
specified with user‟s measurement units (for example, centimetres) will be 
recalculated to the corresponding ones in the DWG file. This result is achieved 
through scaling objects and recalculating coordinates. 

The method of dimension text conversion can be chosen in the Save dimension text 

combo-box. Unfortunately, there is no foolproof method to convert RxSpotlight 
dimension text to AutoCAD dimension text and vice versa, because the dimension 
text of one application has its specific properties and document concatenations, which 
is missing in another application. 

Text – This method allows conversion of a RxSpotlight dimension text field (the text 
with its numeric part (%N)) to a plain (word-for-word) AutoCAD text, i.e. a text without 
a numeric part. Such text will not be changed by a dimensional transformation, but 
visually it will be identical to the source. This method may useful if DWG format uses 
as archive format for finished drawings. 

Auto – This method allows conversion of a text in dimension text. But if there is no 
reasonable way to do this, then a text will be converted in the same way as in the first 
method (a plain word-for-word text). 

For example, AutoCAD has no such UCS property as scale. So if a RxSpotlight 
document has UCS scale unequal to 1 and Convert to UCS checkbox is OFF, then 
there is no ability to convert dimension text as it is – the dimensions values of in  the 
RxSpotlight document and in the AutoCAD document would be different. 

Click OK. 

Enter the file name in the Export dialog and click OK to execute exporting. 

The UCS scale can be applied, or not, to geometrical object properties, such as text 
height and line width while exporting or saving to DWG/DXF. Use the Apply UCS 
scale to geometrical object properties checkbox in the DWG Export section of the 
Preferences dialog. 
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Export to MapInfo format 
1. Start the Export command, choose the Mapinfo file (MID) from the format list 

and click Options button. 

2. Use the displayed dialog to select desired coordinate system and properties. 
Click OK. 

 
3. Enter the file name in the Export dialog and click OK to execute exporting. 

Two files with MID and MIF extensions are created. When exported, some objects are 
broken to their constituent parts (see the table below). When exported raster images 
contained in a RxSpotlight document are ignored.  

RxSpotlight objects Mapinfo objects 

Line 

Point 

Arc 

Circle 

Polyline 

Rectangle 

Text 

Multiline text 

Raster image 

Line 

Point 

Arc 

Circle 

Polyline 

Frame/Region 

Text 

Text 

Ignored 

To export object properties which are not native to RxSpotlight but are specific for 
Mapinfo do the following steps: 

1. Add custom properties to the objects that are identical to Mapinfo object 
properties 

2. Turn on the Custom data checkbox in the Mapinfo Export Options dialog 
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Export to ESRI Shape-format 
1. Start the Export command, choose the ESRI Shape file from the format list and 
click Options button. 

2. Select the appropriate checkboxes (Layer, Height, Attributes) to export all attributes 
you need. The export settings should be saved between work sessions. 

To export object properties which are not native for RxSpotlight, but are specific for 
ESRI Shape format do the following steps: 

1. Add custom properties to the objects, which are identical to ESRI 
Shape format object properties 

2. Turn on the Custom data checkbox in Export Options dialog 

RxSpotlight objects ESRI Shape format objects 

Point Points 

Line Polylines 

Rectangle Polylines and Polygons 

Arc Polylines 

Circle Polygons 

Ellipse Polygons 

Polyline Polylines (and Polygons if closed) 

Spline Polylines 

Text Ignored 

Multi-string text Ignored 

Hatch Ignored 

When being exported, complex objects such as dimensions and blocks are exploded 
into simple objects; hatches and texts are ignored. 
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Importing 
RxSpotlight allows importing of AutoCAD, Microstation Design, ESRI Shape, HPGL/2 
Plot files, raster images from PDF files as well as vector data and Workspace files 
that were created with the previous version of RxSpotlight (3.Х-7.Х) or Vectory. 

It is possible to add more import file filters by adding the path in the External format 
filters location entry (Tools > Preferences dialog box, Standard directories section). 
Import filters can be obtained from your RxSpotlight dealer. 

To import a file 

1. From the File menu, choose Import. The Open Vector File dialog appears. 

2. Select a file format from the list of Files of Type. 

3. Enter a file name in File Name or select it from the list of files.  

4. Click Open. 

Import formats Imported objects 

Microstation (*.dgn) 

AutoCAD (*.dwf) 

HPGL/2 (*.plt, *hp, *hpg) 

ESRI (*.shp) 

Vector objects 

Adobe (*pdf) Raster images 

Multipage TIFF and CIT support 
Multipage TIFF and CIT are image storage formats that make it possible to keep 
several images (pages) in one TIFF or CIT-file. It is possible to save a set of raster 
images as a multipage-TIFF/CIT raster file, and also load multipage files, created with 
RxSpotlight and other applications. Raster images of any type can be united in 
multipage-TIFF files. Multipage CIT file supports only bitonal raster images. 

Multipage file can be opened using the RxSpotlight Insert > Image dialog. The Load 
Page dialog will appear. 
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To select the pages to be opened, check the boxes next to the appropriate pages (a 
preview of each page contents is shown in the Preview tab and information in the 
Properties tab). 

Multipage file can also be opened with the File > Open command. In this case the 
Load File dialog is skipped. Rearrange pages in the Images dialog window (see page 
52). 

To rearrange pages 

1. Open a multipage TIFF file. 

2. Open the Images dialog and rearrange pages with Up and Down buttons (see 
page 52). 

3. Close Images dialog. 

4. Save raster file using the Save or Save As commands. 

Multipage document mode 

The Multipage document mode allows to switch between pages in multipage file and 

view only one page at a time. All newly created and inserted raster images regarded 
as pages of single multipage file. 

To automatically switch to this mode; turn on the Multipage Raster Files > Enter 
Multipage Mode Automatically option in the Preferences dialog when opening 
Multipage file by the File > Open command. 

 For addition information about Preferences dialog see page 389 

To turn on Multipage document mode manually, use the  button on the Multipage 
toolbar. Use the Next/Previous buttons on this toolbar to switch between pages. 
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World file and TAF file support 
World file support and TAF file support can be enabled in the Preferences dialog. 

 
When saving a raster file an additional file with world coordinates is created. The 
World File contains the world coordinates of the lower left corner of the raster image, 
its angle and scale. The additional file name is the same as the source file and the 
extension is made of first letter of the source file extension, last letter and the letter 
“W”, e.g. saving BMP file creates BMP and BWF files, saving TIF creates TIF and 
TFW files, etc. If the file extension consists of 4 or more letters, then the letter “W” is 
simply added, e.g. saving JPEG file creates JPEG and JPEGW files.  The TAF 
additional file name is the same as the source file and the extension is .taf. 

Raster files can be automatic placed an image in RxSpotlight environment and other 
applications that support World File feature (mostly mapping programs). When 
opening files with an accompanying World file, the image is placed using coordinates 
and other information obtained from the World file. If the raster position, then the scale 
or angle is changed the World file will be rewritten with new data when saved. 
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The World and TAF files are the ASCII files, which can be viewed using any text 
editor. 

Scanning 
Scanning creates a new image and inserts it into the RxSpotlight document. 
RxSpotlight uses the WiseScan LE tool. WiseScan, an advanced module designed to 
work with large-format monochrome and colour scanners. With the practical scan 
control dialog that presents compactly all WiseScan LE settings the user can quickly 
and easily define settings and start scanning. 

Working with Directly Supported Scanners 

In the Direct Support Mode WiseScan LE performs scanning with the use of the built-
in scanner functionality (dynamic threshold, background suppression, half-tone 
transfer, etc.), and are executed in real-time. WiseScan LE controls the scanner on 
the hardware level – this method is the most efficient when producing high quality 
images. Gamma curves editing and manipulation helps to scan images of poor quality 
with colour reproduction defects or change colour profile of these images. The user 
selects modes and parameters, and the scanner processor executes processing 
runtime and transfers the results to a workstation. 

Direct support helps to improve the quality of scanning images and speeds up the 
scanning process. It is highly suitable for difficult sepias and blueprints and other 
kinds of similar drawings with background defects. Support for a linear and adapting 
palette and palette classification speeds up the process of scanning and preparing 
GIS maps and plans. 

Working with TWAIN Scanners 

WiseScan LE scan supports TWAIN API for working with TWAIN compatible 
scanners. In this mode WiseScan LE simply carries out fast image output and post 
processing; it has none of the advanced features as in the direct support mode. 

Begin scanning with WiseScan LE 

Select the Acquire in the File menu. If WiseScan LE is launched for the first time, then 
the Select Source dialog will appear. 
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The user can choose a source of scanning in the Select Source dialog. The dialog 
opens with the Select Source command of the File menu. 

Process scanning 

WiseScan LE works in Scan to View mode. In this mode a scanned image is 

automatically loaded into the main program. It allows processing of an image right 
after it is scanned using the batch instruments of the main program. 

This mode provides additional image processing. 

 
If the Save To checkbox is selected then the location where the acquired image will 
be saved after processing must be given. The file mask must also be specified. 

The Output folder list shows the current naming scheme for folders with the use of 

macros. The  button opens the standard Windows Browser for folder dialog in 

which the folder name can be combined with macros. This is available only when the 
Save To checkbox is switched on. Optionally an FTP address can be the destination 
folder. 

In the Mask list the list of characters to be appended to the filename is specified. This 
is available only when the Output checkbox is switched on. 

 Refer to Ws_[Scanner Vendor] manual for information on scanning modes 
and WiseScan controls. 

To exit from WiseScan LE 

1. Press the Stop button to stop scanning. 

2. Select the File > Acquire command or press the button in the host application‟s File 
toolbar (when WiseScan LE is active the Acquire command in the File menu is 
checked and the button is pressed). 
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Inserting a scanned image into an existing 
document 
Scanned images can be inserted directly into a working document, using New Image 
from Scanner from the Insert menu. This command operates in the same way as 
Acquire. 

Printing 
Document workspaces 

To prepare drawing for printing use the paper space. RxSpotlight document consists 
of two spaces: the model space and the paper space. While the drafting, vectorization 
and model creation is performed in the model space, the paper space is used for 
realizing created models on the paper. The paper space consists of a number of 
layouts. 

To prepare drawing for printing 

1. Create a new layout or switch to an existing one using drop-down list on the 
Layout and the Properties toolbars; 

2. Create and adjust viewports; 

3. Create other paper space objects (for example drawing frame and title block); 

4. Tune layers printability using the Printable parameter; 

5. Adjust print options; 

6. Start the Print dialog to print drawing. 

To print directly from the model space begin from the step 4. This can be suitable for 
simple and draft printing. 

Layouts 
Paper space 

Working in paper space, you create objects just on certain layout. These objects are 
printed on paper but not displayed in the model space. You should create such an 
object as layout viewport, to see predefined part of model space in paper space 
layout. Viewport is a "window to model space" actually. It is convenient to place those 
objects in paper space, which are used only for print output (drawing border and title 
block). 

Layouts 

Each document can contain a number of layouts. Use layout tabs in the bottom part of 
a document window to switch between the model space and layouts. 
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All layout commands are accessible from the Insert menu, the Layouts toolbar and 
context menu (right click on any layout tab): 

 
To create new layout use the New Layout command from the Insert menu or click the 

 button on the Layouts toolbar. 

To delete current layout run the Delete Current Layout command from the Insert 

menu or click the  button on the Layouts toolbar. 

To rename current layout run the Rename Current Layout command from the Insert 
menu or from the context menu after right click on the appropriated layout tab. 

Inserting layout from a template file 

To insert layout from external RxSpotlight document (CWS), from document template 
(CWT) or from AutoCAD drawing (DWG) use the Insert Layout from Template 
command. 

1. Choose Insert Layout from Template from the Insert menu; 

2. In the Open Document Template File dialog that appears, select document 
(template) and click Open. If chosen file contains layouts the Insert Layout dialog 
will appears; 

 

3. Select layouts to export in current document. Use SHIFT and CTRL during 
selection to chose more than on layout. Click OK button. 
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Layout displaying 

Each layout can be displayed as unlimited space (like model space displaying) or as 
paper sheet. 

 

In the second case, paper format is got from settings of that printer, which is specified 
in the Print Options dialog. Such paper representation is useful when drawing should 
be printed on the single paper sheet. 

 A dashed frame on a paper sheet defines actual paper size. Paper fields 
outside dashed frame shows only for better visualization. 

It is convenient to switch OFF paper sheet displaying if drawing should be printed on 
several pages (see Print Options). 

Use the Show Current Paper command from the View menu to show or hide layout 
paper sheet. 

Layout color can be changed by Layout Paper parameter of Color section in the 
Preferences dialog. 

Viewports 

Viewports are "windows" to model space. They are used for showing specified parts 
of the model space in certain place of paper space layout. 

There are rectangular and polygonal viewports in RxSpotlight. 

Since viewports are document objects, they can be edited with their grips like other 
objects. The central grip defines viewport position in layout, while other grips define 
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viewport border size and form. 

 

Viewport (like any other RxSpotlight object) has its own specific properties, which can 
be viewed and modified in the Inspector window. For example, a Border property 
allows you toggle ON or OFF visibility of viewport border. 

Application has three commands to create viewports: 

 Rectangular Viewport 

 Polygonal Viewport 

 Current Viewport 

Creating rectangular viewport 

This command is available if at least one layout exists in a document. 

To create rectangular viewport: 

1. Start Rectangular Viewport command from the Insert menu or click the  

button on the Layout toolbar. 

2. In opened model space, specify an area that should be visible in created 
viewport, using rectangular frame. 

3. In paper space layout that opens, choose appropriate layout name from list. The 
selected one will open. 

4. Set a point that will be a central point of created viewport. Specify viewport scale 
in the Command Line or by moving a mouse. 

Creating polygonal viewport 

This command is available if at least one layout exists in a document. 

To create rectangular viewport: 
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1. Start Polygonal Viewport command from the Insert menu or click the  button 

on the Viewport toolbar. 

2. In opened model space, specify vertices of polygonal area that should be visible 
in created viewport. 

3. In paper space layout that opens, choose appropriate layout name from list. The 
selected one will open. 

4. Set a point that will be a central point of created viewport. Specify viewport scale 
in the Command Line or by moving a mouse. 

Current viewport 

The Current Viewport command creates rectangular viewport, which shows current 
model space view. 

This command is available from model space only and if at least one layout exists in a 
document. 

To create rectangular viewport: 

1. Make sure that the document has at least one layout. 

2. Switch to model space using drop-down list on the Layout and the Properties 
toolbars. 

3. Zoom, pan and stretch workspace window to contain all data that should be 
showed in a new viewport. 

4. Start Current Viewport command from the Insert menu or click the  button 

on the Viewport toolbar. 

5. If document has more then one layout, then choose an appropriated one from 
list. The selected one will open. 

6. Set a point that will be a central point of created viewport. Specify viewport scale 
by moving a mouse or type scale value in the Command Line. 

Printing 
An entire document, its visible part, or a specified rectangular area can be printed. A 
scaled image can be printed or fit it to current paper size. The layout of a printed area 
on the paper sheet can also be set by setting page margins. During print preparation 
the screen displays the current printing area and its layout on the page. In case of 
multiple pages, the screen displays the distribution of the printed image on pages. 

Before printing a RxSpotlight document, decide which existing layers to plot. If some 

of them are not wanted, then turn off their printability  in the Layers dialog. Also 

note that RxSpotlight objects are printed in the same colour and in the same order as 
they are displayed in the screen. The order of object display can be changed, using 
commands from the Display Order submenu of the Draw menu. 

 For more information about Display Order toolbar and submenu see the 
“Display Order” section on page 39. 
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Setting Printing Parameters 

From the File menu, click Print Options or press the  button on the Main toolbar. 

The Printer Setup dialog appears. 

When this dialog is shown the blue and red frames are displayed in the document 
window. 

 The red frame – document printing area, which size can be adjusted in 
this dialog. 

 The dashed blue frame – paper printable area (depends on specified 
printer), 

 The solid blue frame – extents of specified paper format. 

Frame colors can be changed in sections Colors > Print Area and Colors > Print Grid 
of the Preferences dialog. 

 For more information on Preferences dialog see page 389. 

Dialog options 

List of available 
printers 

If several printers are installed on the system, then choose one 
from this list. 

 Setup 
button 

Shows setup dialog of chosen printer. In this dialog, set the 
printer parameters, such as page size, a mode of page supply, 
etc. 

   

Area section Specifies a printing area. 

 Extents – prints all objects in the current space 
(model space or certain layout). 

 View – prints an area visible on screen. 

Use zoom and pan commands to get desired view 
in document window. Change window size if it is 
necessary. 

 Window – prints an area, which should be specified 

by using following buttons:  

 By rectangle – click this button and specify 

two corner points that defines printing area. 

 By paper – click this button and specify 

printing area location. The size of this area will be 
equal to the current paper size. 

 Paper size should be defined in the setup dialog 
of chosen printer. 
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Scale section Sets a printing scale. 

 Fit to paper – automatically scales a printing area 
to fit current paper format. 

 Scaled – allows you to set the precise scale factor 
and enter the image increase/decrease factor in 
percent. 
To set one of predefined scales use the left combo 

box . The 1:1 value prints document 

in true size i.e. one unit of displayed document 
corresponds to one unit of a printed image. 2:1 – 
double increasing of printing area relative to paper 
sheet. 1:2 – half size. 

Use right combo box  to specify 

custom scale by entering value with decimal 
precision. 

   

Standard Paper 
Size section 

Sets a page format and orientation. 

All changes in this section takes effect on preview window and 
color frames in the drawing. 

 

   

Position, Margins 
and Units section 

Sets location of printing area on paper sheet. 

To set paper margins, enter their sizes in the input boxes. The 
margin value allowed is 0 or greater. Choose measurement 
units in the Units list box. 

 

 Specify If it is not convenient to specify custom margins from extents of 
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 Margins 
by Paper 
Size 
checkbox 

a paper printable area (dashed blue frame), then switch this 
checkbox ON to set margins direct from the paper sheet 
extents (solid blue frame). This parameter adds paper 
nonprintable margins (which depends on specified printer) to 
values of user defined margins in input boxes. 

 

If the printing area fits to one page of the current format, then 
the alignment can be set. To set type of alignment, press one 
of nine Alignment buttons with white arrows. 

The following example demonstrates printing area, which is 
larger than specified paper format because of 1:2 scale factor. 
Printing area is aligned to the central left paper side. Left 
margin is set to 1cm. 

 

  To resolve this problem it is necessary to decrease printing 
scale or to switch Pages checkbox for multipage printing. 

   

B/W printing 
checkbox 

To print document in monochrome (bitonal) mode. 
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Scale Width 
checkbox 

Scales line width according to specified scale (in the Scale 
section of this dialog) while printing from the paper space. 

   

Multipage print If a printing area does not fit to one page of the current format, 
it is possible to divide it into parts according to the size of the 
current format and specified margins. 

 

 If the multipage print is ON, then blue frames 
shows only pages printable areas, i.e. areas 
without user defined margins and nonprintable 
paper margins. 

 Pages 
checkbox 

Initiates multiply pages print. 

Leave this textbox empty to print all pages. To print certain 
pages enter it‟s numbers separated by commas. To specify 
range of pages enter the first page number, then a dash 
character, then the final page number. For example: 1,3,5-9 

 Copies 
field 

Sets the desired number of copies. 
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Plot style table Sets width and color for printed objects. 

Use the Plot style table (pen assigments) dropdown list to set, 
edit and create plot styles. 

 

 To create a style table choose New Default Palette 
from the dropdown list. 

 To create a style table for a current document 
choose New Document Palette. The created table 
will contain colors of the objects which are present 
in the document.  

 To edit the current palette choose Edit. 

 

In Plot Style Table Editor window that opens, set a width and a 
color for each object color in the document. 
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 To finish the command press the Save and Close or Save as 
buttons and specify a style name. 

 Save as – to save the settings in a file with *.CMT 
extension. 

 Save and close – to save with previous name and 
to close the Plot Style Table Editor dialog. 

 Close – to close the editor dialog. You can save or 

not the results of the settings. 

   

Template button Uses for saving parameters of this dialog in a template file for 
future loading. 

   

Close button Saves settings and closes dialog. 

   

Cancel button Discards all changes and closes dialog. 

   

Print button Saves settings, closes dialog and launches printing. 

 

Print dialog 

From the File menu choose Print or press the  button on the Main toolbar. The 

Print dialog will appear. 

 
If you are satisfied with the current printing options displayed in the Print dialog, then 
press ОК. 
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To change the current values press the Options button. Then the Print Setup dialog 
will be displayed, so you can make necessary alterations. 

Show Print Preview 
Use the Show print preview command from the View menu to display the print 
preview of the document. The document will be shown depending on the settings in 
the Print Options dialog (for example, B/W printing mode, the applied print style, etc. 
will be considered). 
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Selection 

Selection set 
In RxSpotlight the user can select raster objects and areas, vectors, and entire 
images. Selected Items are called a selection set. 

Since items have different natures and may belong to different layers, a procedure of 
selection set composition needs to be performed to collect both raster and vector data 
together before applying a wide range of RxSpotlight commands to it. Keep in mind 
that there are no limits on the contents of the selection set. The flexible and powerful 
selection set composing procedure, using the intellectual recognition techniques in 
more than 30 selection methods, allows a selection set of unlimited complexity to be 
created. The graphics selected are placed in the selection set and highlighted on the 
screen. Selected vector and raster objects, and entire images are highlighted with 
grips; the fragments of raster images are highlighted with a different colour and 
dashed border. 

 The terms selection and selection set are similar in this Guide. 

This chapter describes the methods of selecting on monochrome images. Most of 
them are applicable to colour and greyscale images. Selection on these kinds of 
images is also affected by settings in the Colour Accuracy toolbar (see page 311). 

Selection buttons  and methods 
There are two toolbars that can be used to define selection method – Select, More 
Select and the additional toolbar - WiseObject selection. To choose a selection 
method, press these buttons in appropriate combination.  

 

First row: 3 Selection style 

buttons, 5 Forced selection 
buttons and two special raster 
area selection buttons; 

Second row: 5 Selection by 

Object Type Recognition 
buttons, Image Selector, 
Select with Filter, and Node 
Selection buttons. 

Third row: 3 Selection target buttons, Disable Hybrid Objects toggle, 3 selection 
mode buttons and Select/Unselect All buttons. 

 

 

First row: Selection by Linefollowing buttons; 

Second row: Selection by Floodfilling buttons. 
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There are no strict rules that govern which selection set to use for a particular 
procedure. The same result can be obtained by applying different selection methods. 
This section provides information on the major selection techniques, so the most 
appropriate combinations can be selected. 

 The Polyline edit tool is described on page 227. 
The Disable Hybrid Selection button is described on page 295. 
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Example of selection 
To get used to selections techniques in RxSpotlight, consider the example shown 
below of a document containing two raster images (one occupying left bottom left 
corner and the other the right-hand side of the picture below) and two vector objects: 
a circle and line.  

 
 

Upper left corner of first raster   Right side of second raster 
   Vector objects 

Click the following buttons to set a selection method: 

 
Auto button – sets the selection style that is most versatile. 

 
Hybrid selection – sets the selection target, the kind of objects that are supposed to 
be selected. 

 
Single button – sets composition mode. The selection composition procedure ends 
when the first selection is made. New selection cancels previous selection. 

A selection can now be made. Draw a rectangle that encompasses both vector 
objects and captures areas on both rasters. The following figure shows the result. 
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The selection set contains vector data that is highlighted with grips, and raster fragments 
from both raster images – they are highlighted in colour and bordered with dashed line. 

Now apply RxSpotlight commands to the selection. 

Comments: 

1. The selection procedure used in the example above is applied to all visible and 
selectable layers. 

If data is to be preserved on a different layer from the selection, then turn off the 
visibility or selectability attributes of that layer. 

2. Three buttons, , , and  define a selection composition method. This is 

not only selection method in RxSpotlight.  

3. Hybrid selection is a selection that is composed from both vector and raster data.  
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To select only raster data in the above example, the Raster selection button must be 
used instead of Hybrid selection when defining a selection composition method. 

 

The result of selection when the buttons , , and
 

 pressed 
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To select only vector data in the above example, use the Vector selection button 
instead of Hybrid selection when defining a selection composition method. 

 

The result of selection when the buttons ,
 

, and
  

pressed 

Selection Set Composing Procedure 
The RxSpotlight operations used to process data located on unlocked and visible 
layers can be applied to selection sets composed of the following kinds of data. 

1. Vector objects. 

2. Raster images. 

3. One or several raster areas selected from various raster images. 

4. Raster objects. 

A selection set is composed of steps. A selection step is a single selection operation 
that uses one of the selection methods. To specify a method, choose what to select, 
how the selection is performed and how the recognition algorithms would work (if 
applied) by pressing the appropriate buttons on the Select and More Select toolbars. 
In the example above the selection set was composed by one step and the method 
was specified by pressing three buttons. 
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Vector object selection 

To select a vector object, press the  button and click on the object border. Grips 

on the object indicate that it has been selected. 

Entire Image selection 
The image frame and grips of a raster image allows user to move, scale and rotate it 
in a similar way to processing a vector object. The frame shows also extensions of the 
raster image. 

In Vector selection mode (the  button) the user can select an image by picking its 

border with the mouse. The border becomes dashed and grips are shown; the user 
can move, rotate, and scale an image using these grips. 

The border is a special object created by RxSpotlight to facilitate image handling; it is 
created when opening but not saved with the image in file. 

 

 
 Scale grips 

 

 

 

 You can move the image by its 
border. 

Rotation centre   Rotation grip  

To select several images, use the Image Selector dialog. 

To select a raster image 

1.  Turn on the Vector selection mode. 

2.   Click on the image border. The grips will indicate that an image is selected. 

 If an image is selected entirely in the Raster selection mode, then all its 

contents will be highlighted in colour and with a dasher border. For many 
operations both methods give the same result, however it is 
recommended for a beginner to use the first of the described methods.  
Selecting an area on the document in Vector selection mode selects 
vector objects, but not images, encompassed by selection. 
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To select several raster images 

Open the Image selection dialog, pressing the  button. 

 

Moving the mouse on the screen, click on the images to be included in the selection 
set. Checkmarks will appear next to their names; these can also be turned on or off in 
the dialog manually. The Image Name field contains the logical name of image (or 
automatically created identifier if the image was created by RxSpotlight) and the Layer 
shows which layer the image belongs to. 

Raster objects selection 

To make raster selection tools active, click the Raster Selection button 
 
on the 

Select toolbar. 

There are two kinds of raster data that RxSpotlight can select. 

First, select raster objects – the sets of raster dots that look like typical vector objects 
such as lines, circles, arcs, hatches, symbols, and texts. The intellectual object 
technology for raster object selection implemented in RxSpotlight makes it possible to 
edit a raster image using the methods similar to those used when handling vector 
objects in applications that process vector drawings.  

Secondly, select of areas on images. 

To select one or several areas on raster images: 

1. Make the images, from which a selection is to be made, visible. 

2. Turn on the Raster selection mode , and select a method of selection set 

creation: by adding  or single . 

3. To select a rectangular area, set the Window selection style, pressing the  

button. To select a polygonal area, set Polygon selection style, pressing the  

button. 

4. Select the area(s) with the mouse. 
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5. In the adding mode 
 
repeat step 4 until all areas needed are chosen. The 

styles of selection can be changed from Window to Polygon and vice versa 
during any step of selection. 

Selection by brush 

This additional raster areas selection method uses the “brush to select” ideology. It is 

useful for intricate areas. Just brush the raster area to be selected. 

 

To select with the Brush Selection method: 

1. Turn on the Raster selection mode , and select a method of selection 

set creation: by adding  or single . 

2. Click the  button. 

3. Open the Inspector window and specify the Brush Style and Brush Size 
parameters. 

4. Brush what to select. 

5. In the adding mode 
 
repeat step 4 until all areas needed are chosen. 

Selection by vector contour 
Select raster area inside closed vector contour. 

To select with the Selection by vector contour method: 

1. Select closed vector contour. 

2. Click the  button to select raster area inside vector contour. 

3. Open the Inspector window and specify the Brush Style and Brush Size 

Selection Set Composing Modes 
There are three modes of composing a selection set: Add, Remove and Single.  
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Single 

Selecting data in Single mode deselects all previously selected data in the current 
image. With Single turned on, the selection set in the current document consists of the 
data selected during the latest selecting step or nothing. 

 
To turn Single mode on, click the button on the Raster Selection toolbar. 
With the SHIFT button pressed, Single mode turns to Add mode. 

In this mode objects can also be selected automatically when drawing. 
Selecting is controlled by settings in Command Setup dialog, see page 376. 

Add 

 
Raster data selected in Add mode is added to the current selection set. To 
turn Add Mode on, click the button on the Selection toolbar.  

In Add mode, composition of the selection set can consist of several steps, 
every step being a single selection operation. On every step the selection 
methods can be varied. 

With the SHIFT button pressed, Add mode turns to Remove mode. 

Use this mode to automatically select objects when drawing. Selecting is 
controlled by settings in Command Setup dialog, see page 376. 

Remove 

 
Use Remove mode to remove selected data from the selection set. To turn 
Remove mode on, click the button on the Raster Selection toolbar. 

With the SHIFT button pressed, Remove mode turns to Add mode. 

Usually a single object is first selected, and then more objects added to the selection 
set, and after that some of the previously selected data is removed from the selection. 
Data can be removed from the selection set using the same methods as when 
selecting it. When data is removed from the selection set it is no longer highlighted. 

Selecting/Unselecting all 

  
Two further operations add convenience and flexibility to usage of 
selection modes: Select All and Unselect All. Both operations are 
represented by commands in the Edit menu and buttons on Select 
toolbar. 
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In Vector selection mode pressing Select All yields all vector objects, but not images. 

In Raster selection mode pressing Select All yields all rasters. 

In Hybrid selection mode pressing Select All selects all vector objects and all rasters, 
not supplied with borders. Hybrid and other modes of selection are also influenced by 
Disable Hybrid Objects On/Off toggle (see page 295). 

Selection Targets 
The following buttons define, what kind of data is supposed to be added to a 
selection: 

 
Vector selection – only vector objects are included in the selection 

 
Raster selection – only raster objects are included in the selection 

 
Hybrid selection – objects of both types are included in the selection 

Selection Styles 
Auto, Window, Polygon and Image selection styles can be used.  

 
Auto – RxSpotlight automatically interprets the mouse actions and selects a 
vector object if its border is clicked or raster areas if a rubber band rectangle 
is drawn over the raster image. Command equivalent Edit > Select Auto. 

 
Window – selection is made in rectangular area. 

 
Polygon – selection is made in polygon area. 

Selection Types 
Selection types are the algorithms used in selection procedure. 

Object raster selection methods are based on algorithms that analyze raster objects. 
The raster object may be interpreted in different ways: 

 Isolated raster object – raster area (contiguous set of raster dots); 

 Raster polyline segment – a part of raster line limited by endpoints or intersections 
with other objects; 

 Raster entity – a raster analogue of a vector entity: raster line, arc, and circle. 

Most intellectual selection methods can manage all types of raster objects. When 
using those methods, specify the type of raster objects to be processed. The current 
selection type determines it.  

There are three raster selection types.  

Selection type Raster object type 

Floodfilling Isolated area on the raster image 

Line Following raster polyline segments 
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Object Type Recognition raster entities 

Selecting Raster Object by Picking 

The Object Type Recognition or Object method selects raster objects by picking. 

When selecting by picking, specify a point on image, and the program selects one 
raster object.  

Object method is a basic one for all other object selection methods. Further, all of 
those methods can be represented as a combination of the standard selection method 
and the Object method.  

 

This figure illustrates the result of 
selection by picking with the use of 
various selection types. 

The raster objects selected are shown as 
outlines. In each of these three cases the 
picking point is defined in the centre of 
the horizontal raster line as shown in the 
figure on the left. 

 

 

       

          Picking point 

Selecting Isolated Raster Object 

Picking on the raster using the Floodfilling type selects isolated raster areas. The 

program selects all raster dots connected to the point specified - these dots form 
contiguous set. 

This method can be also treated as forced selection, since the type of selected object 
is predefined. See other methods of forced selection below in this chapter. 

A set of raster dots is contiguous only if any dot belonging to the set is only adjacent 
to the dots of the same set. A contiguous set of image dots is surrounded by 
background dots that separates it from other objects in the image and makes it an 
isolated raster object. 
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In this case the entire object is selected, as 
all its dots are contiguous. 

This method is convenient when selecting 
standalone objects of arbitrary shape: 
characters, symbols, etc. 

 

To select an area on the raster 

 
1. Click the button on the Select toolbar. 

2. Click any point of the raster object. 

 

Selecting Raster Polyline Segments  

Picking on the raster using the Line Following type selects an object called a raster 
polyline segment – sets of dots that look like line or arcs of approximately constant 
width, and with the length much greater than its width. The length of a raster object is 
the length of its centreline. The raster line shape is arbitrary.  

After picking, the selection extends along the raster line from the specified point to a 
node of the raster line. A node of the raster line is either its endpoint, or a point where 
the line intersects with another raster object. So, using this method, a part of an 
arbitrary raster line bounded by two nodes of raster line can be selected – a raster 
polyline segment. 

 To distinguish raster lines from other raster objects the program uses the value of 
the maximal accepted raster line width. Objects of greater widths are not recognized 
as raster lines. A raster line may have breaks that should not be taken as endpoints. 
Define the value of the maximum break to be ignored. For description of Max Width 
and Max Break see “Tuning Selection” on page 122. 

 

The figure shows that the program has 
selected part of the raster line until it meets 
the intersection with the other raster objects. 
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Selecting Raster Entities  

Raster entities are raster objects shaped as basic vector objects – vector image 
entities. From here on we shall use the terms raster circle, raster arc, and raster line 
to imply raster objects that have a shape of a circle, arc, or line. However, note that 
real raster entities might have defects that hamper their identification by the program 
such as breaks, elliptical arcs and circles, varying width, etc. 

If the Type Recognition selection is set, then the Object method can handle both 
raster lines and arbitrary raster objects with approximately equal width and length. 

When a raster line is picked, the program identifies the type of a raster entity (line, arc 
or circle) and then tries to select the object of the most likely size. It ignores the points 
of intersection with other objects, and the selection extends until the symbol of the 
selected object becomes identical to the entity recognized. Since real raster objects 
may differ from ideal raster entities, the recognition tool uses the Approximation 
Accuracy parameter. This parameter defines the accepted level to which the real 
raster objects may differ from the ideal ones.  

Selecting a raster entity preserves its intersections with other objects. Therefore, 
transforming and deleting raster data selected when Object Type Recognition is on 

does not create breaks in remaining raster objects. This allows the user to process 
raster data in the same manner as processing vector objects. For example, deleting a 
raster line that crosses the circle leaves the circle intact in the image, exactly as it 
happens when deleting a vector line that lies over a vector circle. 

In case the raster object selected is not a raster line, the program detects its boundary 
and selects the object. An arbitrary raster object width should be greater than the 
maximum allowed width of a raster line. 

 To distinguish raster lines from other raster objects the program uses the 
reference value of the maximum accepted raster line width.  For description of 
Approximation Accuracy, Max Width and Max Break see “Tuning Selection” on page 
122. 

 

If selecting by picking with object recognition is 
on, then the program selects the entire raster line 
as shown with outlines on the left figure. Note 
that, when selecting, intersections of the selected 
line with other raster objects are not removed. 

To select a raster entity 

 
1. Click the Auto button on the Raster Select toolbar. 

2. Click a point on the raster image. 
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Forced Selection 
There are 5 buttons that define forced methods of selection: Line, Circle, Arc, Floodfill, 
and Symbol. 

 The Floodfill method is described in the “Selection Types” section on page 108. 
There are also 5 “violet-styled” buttons in More Select toolbar that use the floodfilling 
selection method described in “Selection with Window and Polygon” section beginning 
on page 113. 

The Line, Arc, and Circle methods select raster entities of a specified type. These 
selection methods require drawing a reference rubber line of an appropriate type over 
a raster object to be selected. The program selects the specified raster object if it is 
recognized as a raster entity of the specified type. 

These methods work in the similar way to the Object method (in Entity Recognition 
mode). Transforming and deleting raster entities selected with these methods do not 
break raster objects they cross, since intersections are preserved. The Approximation 
Accuracy, Max Width and Max Break parameters influence these methods. For 
description of these parameters see “Tuning Selection” on page 122. 

Forced selection is also influenced by the Auto Extend Vectors mode, which is 
toggled in the Trace tab of Conversion Options dialog (see page 175). 

Unlike the Object method, Line, Arc, and Circle allow users to select a part of a raster 
entity, as well as considerably deformed entities. These methods only select raster 
lines. 

While selecting with the Line or Arc method the endpoints (one or both) of reference 
rubber lines or rubber arcs can be picked outside the raster objects being selected - 
on their imaginary extension. In this case the raster object is selected up to its 
endpoints. If the reference rubber line endpoints lie on a raster object, then the 
program selects the part of the raster object underneath the reference rubber line.  

To select a raster entity underneath the reference rubberline 

From the Raster Select toolbar, click the appropriate button to the reference 

rubberline: , ,
 
or : 

Line Specify the endpoints of the reference rubber line. They can be either on a 

raster line or on its extension. 

Arc Specify three points of the reference rubber arc. The end points can be either 

on the arc or on its extension. 

Circle Specify two opposite points of a rubber circle over a raster circle. 

The reference rubber line is removed, and the raster data underneath is selected. 

Raster Symbol Selection 
The Symbol selection method allows selecting by picking raster objects, which have 
matching predefined templates.  

The procedure of symbol sample defining is described in “Setting Up Symbol 
Recognizing Options” on page 85 of this guide. 
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To select a raster symbol  

 
1. Click the button on the Raster Select toolbar. 

2. Pick a point on the raster symbol. 

 

   
These figures illustrate raster symbol selection. Using this method the user can 
choose notation conventions in scanned electrical, hydraulic schematics, maps, and 
similar images. 

Selection with Window and Polygon 
One of the ways to select raster objects is to enclose them in a selection window or a 
selection polygon. A selection window is defined by picking two opposite points, and a 
selection polygon is defined by sequential picking of its vertices. 

These methods are divided in two groups. The first group includes methods that 
select raster data inside a specified area excluding raster objects crossing the area 
boundary - Within Window and Within Polygon methods. The second group selects 

raster data inside a specified area including raster objects crossing the area 
boundary. These methods are called Crossing Window and Crossing Polygon. 

These methods are object modifications of the standard Window and Polygon 
selection methods that select all raster data inside a specified area up to its boundary. 

The work of Within Window and Within Polygon methods can be represented as a 
combination of two other selection methods. At first, with the appropriate standard 
method (Window or Polygon) all raster data inside the area is selected. Then all raster 

objects crossed by the area boundary are selected by the Object method and 
subtracted from the data obtained from the first stage. Picking points are the 
intersection points of the area boundary with raster objects. 

With Crossing Window and Crossing Polygon operating the data selected at the 
second stage (objects crossing the boundary) is added to the raster data selected on 
the first stage. 
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The current raster selection type determines the type of raster objects selected by the 
Object method, and thus affects the type of subtracted or added raster data. 

Style Selection type Button and 
Toolbar 

Within Window Object Type Recognition 
 green 

Raster Select 

 Floodfilling 
 red 

Raster Select-2 

 Line Following 
 violet 

Raster Select-2 

Crossing Window Object Type Recognition 
 green 

Raster Select 

 Floodfilling 
 red 

Raster Select-2 

 Line Following 
 violet 

Raster Select-2 

Within Polygon Object Type Recognition 
 green 

Raster Select 

 Floodfilling 
 red 

Raster Select-2 

 Line Following 
 violet 

Raster Select-2 

Crossing Polygon Object Type Recognition 
 green 

Raster Select 

 Floodfilling 
 red 

Raster Select-2 

 Line Following 
 violet 

Raster Select-2 

Comparing the Crossing Window selection methods 

Let us consider several examples that illustrate the difference between raster 
selection types that apply to the same selection methods. In the first example we 
select a raster using the Crossing Window method with different raster selection 
types. Note that when selecting a raster with Crossing Window, click on two opposite 
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corners of a rectangular area. Once the area is defined, the program selects all raster 
data that lie entirely inside the area and adds the raster objects crossing the area 
boundary. 

 

 

In the examples below we select objects and 
then delete the selection in order to see which 
raster objects have been selected. 

In all three cases the selection window is 
defined in the same manner. The dimension 
line and the text lie inside the window, the 
extension lines cross the selection window. 
The selection window boundary is shown as a 
dashed rectangle. 

 

 

Entity Type Recognition 
In this case the program selects the entire 
dimensional object including the extension 
lines up to their intersections with the third 
circle, endpoints of the crossed raster entities. 
After deletion of raster graphics (see the 
figure) the raster circles that were crossed by 
the deleted extension lines are not broken. 

 

Line Following 
In this case the program selects the entire 
dimensional object as well, but extension lines 
are selected only to their intersections with the 
first circle. Parts of the crossed raster lines 
limited by nodes are added to the selection 
set. This shows in the figure that represents 
the deletion result. 
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Floodfilling 
Here the selection window is defined by the 
same points as in the two previous cases. 
However, using the Floodfilling selection type, 
selects all raster object parts - the entire raster, 
as shown in the figure, and deletes everything. 

 

Comparing Within Window selection methods  

As in the first example, in this example we will select a raster using the Within Window 
method with different raster selection types. 

When selecting a raster with the Within Window method, click on two opposite 

corners of a rectangular area. The program selects all raster data that lie entirely 
inside the area, and then finds those raster objects that cross the area boundary and 
removes them from the selection set. 

The figures below show selected raster objects as outlines. The selection window is 
displayed as a dashed rectangle. 

Object Type Recognition 

 

The program selects a character, circle, and 
rectangle that lie inside the selection window.  

Note that the entire raster lines crossing the 
selection window boundary are excluded from the 
selection. 

Line Following 

 

When using the Within Window method based on 
the Line Following algorithm, the selection includes 
raster character “A”, circle, rectangle and the parts 
of raster lines between the raster rectangle and the 
circle.  

The program does not select the parts of raster 
lines from the window boundary up to their first 
nodes - where lines intersect the raster rectangle. 
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Floodfilling 

 

The figure shows the result of using the Within 
Window selection method based on Floodfilling. 
The program only selects an isolated raster object 
(character “A”), and excludes all the other raster 
objects because they are contiguous. 

Selecting by Fence 
To select with the Fence method, specify a set of points, which determine vertices of 

an open polygon. All raster objects crossed by the open polygon become selected. 
Raster data selected using this method can be represented as the integration of data 
obtained as a result of applying the Object method to every object crossed. The 
picked  points are intersection points of a specified open polygon with raster objects. 
The current selection type determines the type of raster objects selected by the 
Object method, and thus affects the raster data selected. 

To select raster objects by fence  

 
1. Click a coloured button on the Raster Select or More Raster Select 
toolbar: 

 Green,  to select several raster entities (lines, arcs or circles). 

 Violet, to select several segments of raster polylines. 

 Red,  to select several isolated objects 

2. Specify the vertices of an open polygon, crossing the selected objects. Press 
ENTER or right-click to complete the selection. 

The following figure illustrates an example of isolated object selection by fence (the 
red-styled button on the More Raster Select toolbar). 
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The figure on the left shows the open polygon that is used to select the text, in the 
figure on the right the selected raster objects are shown. 

The following figures illustrate the difference between selection by fence with raster 
objects recognition and selection of raster segments by fence. The first figure shows a 
table grid. We cross two vertical lines by fence, as shown in the figure. 

 
  Fence 

 

In the following figures the selected raster objects are indicated with outlines. In the 
first figure there are two vertical lines, selected entirely after the use of the Object type 
recognition method (the green-styled button in the Raster Select toolbar). 
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     Selected lines 

In the second figure there are two segments of these lines, located within the table 
adjacent horizontal lines. In the second case the Fence method with the Line 
Following type was applied.   

     Polyline segments 
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Selection by Filter 
This tool allows you to select objects according their type and properties (color, layer 
and etc.) or geometrical parameters (length, width, scale and etc.). Selection by filter 
can be applied to entire document or to existing selection set. 

To run it – choose Edit > Select by Filter or press  button on the Select toolbar. 

 
 

Apply to Applying filter to: 
Entire drawing or Current selection. 

Object type Choosing object type to add to the filter. Shows a 
list of the objects, which are in the document or in 
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the current selection. The Multiple means that the 
selection will be applied to all types objects which 
suit to the parameters of the selection. 

Properties Choosing objects property, which should match 
filter conditions. This list contains properties of an 
object that specified in the Object type field. 

Operator Setting a range of filter for the selected property: Equals / 
Non equal / Select all. 

 
Value 

 

Setting the value for the 
object property. Enter 
value manually or 
choose from the list. 

The list of available 
items in the Value box 
depends on the 
parameter in the 
Properties field. 

 
How to apply  Include in new selection set – includes filtered 

objects to selection set. 

 Exclude from new selection set – excludes filtered 
objects out from selection set. 

Append to 
current 
selection set 

Switch this checkbox on to append selection that matches 
filter conditions to previous selection set. Otherwise previous 
selection will be replaced with new selection set. 

To select objects with different values of a single parameter 
(for example: BLUE + RED objects; or ARCS + CIRCLES + 
RECTANGLES) use the Select by Filter dialog several times 
with this checkbox selected. 

 

Objects, hidden by  or  buttons are not selected. 
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Automatic selection of certain object types  
The WiseObject selection tool allows selection of such types as hatch, text, „speckle‟, 
linear objects, in the whole image or a specified area. 

1. Open the WiseObject selection  toolbar. 

 
2. Choose an object type to select from the combo-box. 

3. Press one of the following buttons: 

 
WiseObject selection – to select from the whole image;  

 

Select by WiseObject selection Rectangle – to select from 
an area specified by a frame; 

 

Select by WiseObject selection Polygon – to select from 
an area specified by a polygon. 

Tuning Selection 
Tuning selection is performed in the Options tab of the Conversion Options dialog 
box. The user can control the raster object selection methods, based on Object 
Recognition and Line Following algorithms. 

To set raster selection parameters 

 
1. Click the Conversion Options button on the Raster to Vector toolbar. 
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2. Shift to the Options tab. 

3. Specify new parameters, and then click OK. 

Raster Selection Parameters 

Raster selection is only affected by three parameters in the Options tab: Max Width, 
Max Break and Approximation Accuracy. 

Max Width Defines the maximum width of raster objects that can be 
selected with the methods based on Object Type 
Recognition and Line Following. The program does not 
select lines with widths larger than the specified value.  

Max Break Defines the length of the largest break to be ignored in a 
raster line. If raster line breaks are less than the specified 
value, then when selecting the line breaks will be 
eliminated and the line will be chosen as an entire raster 
object. 
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Approximation 
Accuracy 

When selecting raster, using the methods based on the 
Object Type Recognition, Approximation Accuracy defines 
the accepted deviation of raster object symbols from their 
vector prototypes. 

If the original raster lines are distorted  (for instance, raster 
circles are elliptical),  then selection accuracy can be 
improved by moving the Approximation Accuracy slider to 
the left (Low). If the original raster image is of a good 
quality, then move the slider to the right (High). 

 Forced selection is also influenced by Auto Extend Vectors mode, which is 
toggled in Trace tab of Conversion Options dialog (see page 175). 

The Max Width and Max Break values can be measured on a raster image. 

To measure Max Width on an image 

1. Click the button at Max Width.  

2. Specify two points in the raster image so that the line connecting these points 
crosses the thickest part of the raster line. 

  The program defines the Max Width value equal to the length of the line part that 
covers the raster object. 

To measure the Max Break on an image 

1. Click the button at Max Break. 

2. Specify two points in the raster image so that the line connecting these points 
crosses the largest break in the raster line. 

 The program defines the Max Break value equal to the length of the line part that 
covers the raster background. 

Raster Selection Transparency 

 

Raster selection on monochrome images 
can be switched to semi-transparent mode 
for convenience.  This is often done for 
operations requiring a higher precision. 

See Colours > Raster Selection > 
Semitransparent checkbox in Preferences 
dialog. 
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Transforming raster images 

RxSpotlight supports a wide range of operations that change, transform, edit and 
modify images. 

These operations can be roughly divided into 3 groups: correcting, filtering and 
editing. 

This chapter describes the means of image correction that can help to prepare an 
image for vectorization, tracing and more complex procedures that involve intellectual 
object recognition. 

This chapter also contains descriptions of monochrome filtering operations since they 
are usually performed in a workflow together with corrections. 

Descriptions of colour filters can be found in the DETAILS section (see page 324). 

Operations that edit images are described in DRAWING AND EDITING. 

Correcting Geometric Distortions 
This chapter describes the procedures that allow the user to correct various geometric 
distortions of monochrome, colour and greyscale raster images. Such operations are 
recommended, and even necessary, before applying more complicated procedures 
such as layering or vectorization. For example, if an original raster image is distorted, 
after vectorization a vector drawing is produced that may be impossible to correct. 
The calibration procedure can be used to eliminate deformations before applying 
vectorization. 

This chapter describes the procedures that process an entire image. 

Use them to: 

 Change an image size (this command modifies an image geometry by 
adding or cropping margins, its contents and resolution are left intact); 

 Resample an image (this command modifies an image geometry by 
changing its resolution or size in pixels);  

 Crop an image; 

 Mirror an image about vertical or horizontal axis; 

 Rotate an image by an arbitrary angle; 

 Deskew image manually or automatically; 

 Correct trapezoid, parallelogram, and projective image distortions using 
four-point correction; 

 Eliminate arbitrary (both linear and non-linear) deformation using 
calibration.  

The table below shows the more valid targets for raster correcting operations.  

 Clipped images Multiple images 
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Auto Correct     

Change Size   

Resample   

Image Clip     

Crop by Clip     

Crop    

Mirror    

Rotate    

Deskew    

Four Point Correction     

Calibration     

Change Image Size 
This operation is used to resize an image in order to adjust its size to specified values. 
It may be necessary after deskewing or image cropping, and also when obtaining an 
image of non-standard size after scanning. If the new image size is less that the 
original one, then the image is cropped. If the new image size is more that the original 
one, then margins are added to the image. All changes can be observed in the 
preview window. 

The operation can only be applied to one image at a time. So if there is more than one 
image in the document, select the one you need to process.  

To resize an image 

Select an image and start the operation by choosing the Change Size command from 
the Image menu. 

The following dialog box appears: 
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1. Choose measurement units in the Units box. 

2. Specify the required image size by one of the following ways:  

To choose (from the Standard Paper list) the nearest one, which can be more 
than or equal to the image size, press the Find Closest button on the Standard 
Paper Size box. 

Select one of the standard sheet formats from the list of Standard Paper Size 
box. Select the orientation: Landscape or Portrait. 
Customise the list of Standard Paper Size in the Papers folder of the RxSpotlight 
Preferences dialog box. 

Set the required width and height of the image in the Image Size box. 

For a colour or greyscale image, the colour of the image margins added is 
specified by the Fill Colour parameter in the Colours folder of the RxSpotlight 
Preferences dialog box. 

 For more information on the RxSpotlight Preferences dialog box see “Tuning 

the application” on page 389. 

3. Align the image using one of the buttons in the Alignment/Margins box. 
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For example, align the image to the 
upper-left side by choosing the upper-left 
corner button. To put the image in the 
centre, choose the central button. 

4. Determine image margins by one of the following ways: 

Resize the image size by increasing or decreasing the margin value: 

To do so, clear the Fixed Size checkbox and using the appropriate boxes in the 
Alignment/Margins box, increase or decrease the margins size in desired 
directions by entering positive or negative values to the appropriate boxes. 

Align the fixed size image by changing its margin values: 

Set the Fixed Size checkbox. It makes the size of the image unchangeable. 

Then change the values of desired margins by entering required values to the 
appropriate boxes. 

Resampling image 
Resampling is used to resize an image by modifying its resolution or size in pixels.  

An image can be resampled in the three following ways: by changing the image size 
in pixels, by changing the actual image size with fixing size in pixels, and by changing 
the actual image size without fixing size in pixels. 

 Note that an image resolution cannot be modified without appropriately 
changing its size. An image file size is proportional to its squared 
resolution. For example, an image file with resolution of 200 pixels per 
inch is four times larger, than file containing an image of the same size 
(in inches, for example) and a resolution of 100 pixels per inch. 

The operation can only be applied to one image at a time.  

To resample an image 

Select an image and start the operation by choosing the Resample command from 
the Image menu. 
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The following dialog box appears: 

  
1. Set the Fixed size in pixels checkbox to save the original image size in pixels, 

- or - 

Clear the Fixed size in pixels checkbox to modify the image size by adding or 
deleting the image pixels. 

2. Choose measurement units from the list: 

3. Type in the Width or Height boxes the new image width or height. (If pixels are 
chosen as the measurement units and the Fixed Size in Pixels option is on, then 
these values cannot be entered into Width and Height). When entering any value 
in one box, the value in the other box is changed automatically in order to 
maintain the image proportion. 

- or - 

Type a scale factor in percent based on the current image size in Scale. 
If the Fixed Size in Pixels option is on, then the setting of a new actual size 
influences the resolution value. The image size in pixels is constant. 
If the Fixed Size in Pixels is off, then the setting of a new actual size influences 
the size in pixels. The image resolution is constant. 

4. Change the image resolution by entering a desired value in dots per inch (DPI) 
in Resolution. 
If the Fixed Size in Pixels option is on, then the actual size is changed and the 
size in pixels remains the same. 
If the Fixed Size in Pixels is off, then the actual size remains the same and the 
size in pixels is changed.  

5. Click OK. 
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Cropping 
Cropping can reduce an image size to a specified rectangular area size. Define this 
area by specifying a rectangle on the image or by specifying a clipping boundary. 
Applying a procedure can also crop an image, which automatically finds “empty” 
image margins and crops them.  

This operation can be applied to several raster images at once. For example, to crop 
a “pile” of images placed one over another. 

To crop an image by clipping boundary 

1. Select the images to crop (visible and located on unlocked layers) with clip. If no 
image is selected, then this command processes all visible images located on 
unlocked layers, which have a clipping boundary. 

2. Run the operation using one of the following methods: 

Choose Crop > by Clipping from the Image menu or click the  button on the 

Image toolbar. 

 For more information on clipping see page 57. 

To crop an image to a specified rectangle 

1. Select the images to crop. If no image is selected, then the command processes all 
visible images on unlocked layers that are inside a cropping rectangle. 

2. Specify two opposite corners of rectangular area with the mouse. 

The selected image parts allocated outside the specified boundary will be 
cropped. 

3. Run the operation using one of the following methods: 

Choose Crop > by Rectangle from the Image menu or click the  button on 

the Image toolbar. 

To crop an image automatically 

1. Select the images to crop. If no image is selected, then this command processes 
all visible images located on unlocked layers. 

2. Run the operation using one of the following methods: 

Choose Crop > Auto from the Image menu or click the  button on the Image 

toolbar. 
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Before Crop > Auto on the image 
without a frame 

After Crop > Auto, the Cropping tool 
does its best to reduce image width 
and height size to those of the 
minimal bounding rectangle 
covering all raster objects on the 
image 

Cropping by Frame 

If the image has a frame, then this command automatically resizes document to the 
frame size, ignoring insignificant speckle and sometimes even small objects and texts. 

Note that since autocropping by frame is completely automatic, the skewed frame 
and/or too many speckles on the image can spoil the results. It would be a good idea 
to apply Image > Deskew and/or Filters > Speckle Remover to the image before 
autocropping by frame. 

To autocrop image by Frame 

1. Select the image or images to be cropped. If no image is selected, then this 
command processes all visible images located on unlocked layers.  

2. Choose Image > Crop > AutoCrop by Frame or press 
 
on the Image toolbar. 

If there is no frame, then this command works like Crop > Auto. 

Mirroring 
Use this operation to mirror an image about either vertical or horizontal axis crossing 
the image centre. 

This operation can be applied to several raster images at once.  

To mirror an image 

1. Select images to mirror. If no image is selected, then this command processes 
all visible images located on unlocked layers. 

2. Run the operation by Mirror > By X Axis (mirror about horizontal direction) or By 
Y Axis (mirror about vertical direction) from the Image menu. 
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Rotation 
By applying this operation an image can be rotated about its central point using three 
fixed rotation angles (90, 180 and 270 degrees) or an arbitrary angle. When rotating 
by an arbitrary angle, the new image size automatically expands to fit the rotated 
image. 

 For a colour or greyscale image, the colour of added “empty” image areas is 
specified by the Fill Colour parameter in the Colours folder of the RxSpotlight 
Preferences dialog box described on page 389. 

This operation can be applied to several images at once.  

To rotate an image by 90, 180, 270 degrees 

1. Select the images to rotate. If no image is selected, then this command 
processes all visible images located on unlocked layers. 

2. Run the operation by choosing Rotate > 90-ccw, 180 or 90-cw from the Image 
menu. 

To rotate an image by an arbitrary angle 

1. Select the images to rotate. If no image is selected, then this command 
processes all visible images located on unlocked layers. 

2. Run the operation by choosing Rotate – Custom Angle from the Image menu. 
The following dialog box is displayed: 

 
3. Type the desired rotation angle in Angle or click the angle measurement button 

 and specify the start and end points of the segment that defines the rotation 

angle. The measured value will be automatically entered in the Angle box. The 
angle between the specified segment and X-axis is measured. 

4. Click OK. 

Deskewing 
This operation enables an image skew resulting from scanning to be corrected. The 
whole image is rotated about its central point in order to eliminate either horizontal or 
vertical skew. When deskewing, the new image size automatically expands to fit the 
deskewed image. 
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 If you have a colour or greyscale image, then the colour of added “empty” 
image areas is specified by the Fill Colour parameter in the Colours folder of 
the RxSpotlight Preferences dialog box on page 389. 

There are three ways to deskew an image. The user can define a deskew line by 

specifying two points in the image. This line deviation from either horizontal or vertical 
axis determines the skew angle. The user can also deskew image by typing a skew 
angle in the appropriate editing box. Also, the automatic procedure of skew angle 
calculation can be applied.  

This operation can be applied to several images at once.  

To deskew raster images manually 

1. Select the images to deskew. If no image is selected, then this command 
processes all visible images located on unlocked layers. 

2. Run the operation by choosing Deskew > Manual from the Image menu. 
The following dialog box is displayed: 

  

3. Type the skew angle value in Angle or click the angle-measuring button  

and specify the start and end points of the line that defines the rotation angle – 
the deskew line. The measured value is automatically entered the in Angle box. 

4. Click OK. 

To deskew raster images automatically 

1. Select the images to deskew. If no image is selected, then  this command 
processes all visible images located on unlocked layers. 

2. Run the operation by choosing Deskew > Auto from the Image menu. 

If RxSpotlight is able to estimate the rotation angle, then raster images will be 
deskewed. Otherwise, use the manual deskewing procedure. 

Auto Correction 
This operation processes an image, using a predefined set of standard operations. 

The set of applied operations is specified in the Autocorrect section of the RxSpotlight 
Preferences dialog box. 

 For more information on the RxSpotlight Preferences dialog box see 
description on page 389. 

When performing auto correction the specified operations are applied step-by-step in 
the order they are arranged in the Autocorrect section. 
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If any of the specified operations cannot be performed, then it is ignored and the next 
operation starts. 

To perform autocorrection 

1. Specify a set of operations in the Autocorrect section of the RxSpotlight 
Preferences dialog box. 

  
2. Select the images to auto correct. If no image is selected, then  this command 

processes all visible images located on unlocked layers. 

3. Run the operation using one of the following methods: 

Choose AutoCorrect from the Image menu or click the  button on the Image 

toolbar. 

Four-Point Correction 
Four-point correction is a simple way to eliminate trapezoid, parallelogram or 
projective distortions in images (technical drawings mainly). This procedure is based 
on the assumption that an image frame and its contents are distorted in the same 
way. This procedure can be used to correct image geometry if its frame has a 
trapezium or parallelogram shape, rather than a rectangular. 

This operation can be applied to several images at once. For example, correct a “pile” 
of images placed one over another. 

To perform this procedure, specify the desired frame size – its height and width, and 
the appropriate current position of the frame corner dots on the image. After 
correction the image is transformed so that the frame corner dots are moved to the 
rectangular frame corners of the specified size. 
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To perform four-point correction 

1. Select the images to correct by four-point correction. If no image is selected, 
then  this command processes all visible images located on unlocked layers. 

2. Run the operation using one of the following methods: 

Choose 4-point correction from the Image menu or click the  button on the 

Image toolbar. 

The following dialog box is displayed:  

   

3. Press the  – Find frame button. If RxSpotlight is able to find the drawing 

frame, then you will see a colour polygon over the image close to the raster 
lines. The frame is shown in the document window. 

 If RxSpotlight can not find the drawing frame, then specify these points 
manually.  

4. To specify the frame corners manually, press the 
 
button and click the frame 

corners on the image. These points can be specified in an arbitrary order 
because the program always sorts them so they form the frame without 
intersections. Watch the rubberline to control, press BACKSPACE to go to 
previous frame corner if necessary. 

5. Type the desired frame size in Width and Height. 

6. Select the orientation – Portrait or Landscape. 

7. Click OK. 

The  button, the Paper size list box and Use Internal Page Frame checkbox 

control the automatic paper size adjustment. Use these controls to adjust the image to 
fit a standard paper size. 

The Paper size contains standard paper formats. 

Use Internal Page Frame lets the user use the corresponding drawing frame size that 
is stored for a particular format (internal page frame size is set in Tools > 
Preferences > Papers > Modify dialog, in Internal Frame section).  
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If Internal Frame is not checked in this dialog, then the Use Internal Page Frame 
checkbox in the 4-point correction dialog is unavailable. 

If Internal Frame is checked, then settings in Portrait and Landscape sections are 
automatically reflected in the Width and Heights fields of 4-point correction dialog. 

Calibration 
Calibrating (also known as “rubbersheeting”) is designed to eliminate arbitrary (both 
linear and non-linear) distortions in monochrome, greyscale, and colour raster 
images: scanned graphic documents, geodetic plans, maps in raster format, etc. 

To carry out calibration original documents must include points with known 
coordinates. These points can have a different position in the scanned image, caused 
by the deformation in original materials or scanning errors. By applying calibration, 
raster images are transformed so that the current coordinates of such points coincide 
with their known values. 

Calibration can be applied to a selection set consisting of image fragments and also to 
a clipped area on the image. If several images have been selected, then the 
command will be applied to those that are visible and located on unlocked layers. If an 
image is not selected, then this command processes all visible images located on 
unlocked layers. The calibration procedure needs to be applied before running the 
procedures of layering and vectorization. If there is non-linear distortion in the original 
image, then after vectorization a vector drawing is obtained, which is impossible to 
correct. To obtain a correct vector drawing, eliminate distortion before vectorization. 

Terms 
The calibration procedure transforms a raster image in such a way that the given set 
of image points moves to another set of points with pre-defined coordinates. The 
number of points and their locations are arbitrary. 

The calibrating transformation is defined by the set of calibration pairs and the 
calibration method used. 
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Calibration Pairs 
To prepare calibration, specify vectors of point movements. This can be done by 
specifying a set of calibration pairs. Each pair represents two locations of the point - 
its current location on the image (measured point), and its required location (real 
point). 

Calibration Methods 
A calibration method is a parametric transformation function used for calibrating. The 
program offers a number of calibration methods: affine, bilinear, polynomial, surface 
splines, etc. 

With some sets of calibration pairs and some calibration method, the program cannot 
make a transformation of the given type that where all measured points move to 
appropriate real points. This produces calibration deviation distances between the 
points obtained as a result of transformation and their appropriate real points. When 
choosing a calibration method, use the minimizing of the square error value for all 
calibration pairs as criteria. 

Calibration Pairs types 
Every calibration pair has one of the follow types: 

Grid – if a pair is a part of a calibration Grid, used in calculation of calibration 
parameters and estimating calibration accuracy.  

Control – if a pair is used in calculation of calibration parameters and estimating 
calibration accuracy. 

Check – if a pair is used only for estimating the calibration accuracy and does not 
affect the calibration parameters. 

Unused – if a pair is not used in calculation of calibration parameters and estimating 
calibration accuracy. 

The main steps of Calibration 
1. Open the Calibration dialog box. 

2. Create a set of calibration pairs. 

3. Specify the measured point‟s positions. 

4. Choose an appropriate calibration method. 

5. Run calibration. 

Note: it may be useful to define the coordinate system, the coordinate system origin 
and scale before the calibration 

 For more information on defining the coordinate system see “Coordinate System 
of a RxSpotlight Document “on page 64. 

Calibration Dialog Box 
An image is calibrated using the Calibration dialog box. 
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To open the Calibration dialog box 

From the Image menu, choose Calibrate or on the Image toolbar, click the  

button. 

 
Calibration dialog box 

Calibration dialog box buttons 

Button Description 

 
Define Grid  

Creates a set of calibration pairs placed in the 
nodes of rectangular grid. 

 
Add Pair 

Creates a calibration pair using the dialog box. 

 
Modify Pair 

Allows changing the locations of measured and 
real points and the type of selected calibration 
pair. 

 
Reset Pair 

Places the measured points to real point positions 
for the selected calibration pairs. 
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Button Description 

 
Delete Pair 

Removes all selected calibration pairs from the list 
and appropriate points from the drawing. 

 
View 
Previous 

Pans the drawing to display the previous 
calibration pair. 

 
Zoom To  

Zooms the drawing to display calibration pairs 
selected. 

 
View Next  

Pans the drawing to display the next calibration 
pair. 

 
Estimate 

Estimates calibration accuracy. 

Calibration method 

Shows the method that will be used for calibrating. 

Mean error 

Displays the root-mean-square deviation for all calibration pairs. 

Max error 

Displays the maximum deviation for all calibration pairs. 

Min error 

Displays the minimum deviation for all calibration pairs. 

Calibration pair list 

Displays information about all calibration pairs in the following format: 

Point Name Displays the calibration pair names. To select a calibration pair, click 
its name. 

Type Displays the calibration pair types - Control, Grid, Check, or Unused. 

Xreal Displays the X coordinate of real points. 

Yreal Displays the Y coordinate of real points. 

Xmeas Displays the X coordinate of measured points. 

Ymeas Displays the Y coordinate of measured points. 

Xadj Displays the X coordinate of estimated points. 

Yadj Displays the Y coordinate of estimated points. 

Xerr Displays the X projections of distances between real and estimated 
points. 

Yerr Displays the Y projections of distances between real and estimated 
points. 
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Sort any column by clicking buttons with column names. The first click on the button 
sorts the list in ascending order, the second click, in descending order. 

Creating a set of Calibration Pairs 
Creating calibration pairs adds their definitions to the list of the Calibration dialog box.  

To create calibration pairs: 

1. Specify the known theoretical point coordinates (real points). There are two ways 
to do this – define a calibration grid or add them one by one. Both methods may 
be used simultaneously. Upon creation, each calibration pair has the same 
measured and real point coordinates. 

2. Specify the appropriate measured points for all real points by picking them on 
the image or entering the point coordinates from the keyboard.  

Defining Calibration Grid 

A calibration grid is helpful when calibrating images covered with the raster grid with 
nodes that must have known coordinates. Such images are, for example, scanned 
images of maps or geodetic plans. 

Defining a calibration grid creates a set of calibration pairs placed in the nodes of a 
rectangular grid. These calibration pairs have the Grid type. 

The position of grid nodes is determined by the origin, angle, cell size and the number 
of cells in the vertical and horizontal directions. 

 There can only be one grid defined on the image. Redefining a 
calibration grid removes all calibration pairs of the present grid from the 
image. 

To define a calibration grid 

1. Open the Calibration dialog box. 

2. Click the  button in the Calibration dialog box. 

The Calibration Grid dialog box appears: 

  
Calibration Grid dialog box 
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3. Specify the grid origin. 

Enter its coordinates into Origin, or press the Measure button and click the origin 
location on the image. 

The grid origin is assumed to be in the lower-left corner, and the grid is 
generated along the positive direction of the X and Y axis. To set a different 
corner and grid direction, set negative values in Size and Cell boxes. 

4. Specify X Size and Y Size of the grid cell. 

If it is necessary, then add grid columns in the negative direction of the X or Y 
axis by specifying a negative value for the X or Y size. 

5. Specify numbers of grid cells along the X and Y axis using X Cell and Y Cell, 
accordingly. 

6. To prevent mistakes, choose the Preview button to view the grid defined. Correct 
any mistakes if necessary. 

7. Choose OK to create calibration grid and return to the Calibrate dialog box. 

8. It is possible to construct a rectangular grid rotated by the defined angle. 
Otherwise, the grid rows and columns will be orthogonal to the X and Y axis. 

Adding calibration pairs one by one 
This method creates calibration pairs one by one. The created pairs may be of the 
Control, Check, or Unused type. The procedure is designed so that pairs can be 
created by indicating only the real point coordinates. The measured point coordinates 
can be defined later.  

To add calibration pairs one by one 

1. Open the Calibration dialog box. 

2. From the cursor menu, choose Add or click the  button in the Calibration 

dialog box. 

The following dialog box appears: 

 
Add Point dialog box 

3. Type the real point coordinates in Real. 
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4. Type the name for the pair in Label. Otherwise the default name of this pair is 
“PointNN”. 

5. Type the measured points‟ coordinates in Measured or pick the measured point 

coordinates in the screen by  button. Otherwise their coordinates will be 

equal to the real ones and can be modified later.  

6. If necessary, then change the pair type in Use as from Control to Check or 
define the pair as Unused. 

7. Press ENTER or choose Add to create the pair and continue the process. 

8. Choose Close to return to the Calibration dialog box. 

Selecting Calibration Pairs 
To view, modify, or delete a calibration pair, first select it from the list in the Calibration 
dialog box.  

To select a calibration pair from the list 

Click on the name of the pair.  

To select several calibration pairs from the list 

Click on the name of a pair to select it from the list in the Calibration dialog box. 
Use the CTRL and SHIFT keys to select several pairs at a time. 

- or - 

Click and drag in the list of pairs to draw the selecting rectangle around the 
names of pairs to be selected. 

Defining the Measured Points on the screen 
The measured points can be defined on the screen using the mouse. 

To change position of a measured point on the screen 

1. Select the calibration pair to be modified from the list of the Calibration dialog or 
in the screen. RxSpotlight highlights the selected point with grips. 

2. Zoom to the selected pair by 
 
 button on the Calibration toolbar or Zoom to 

command from cursor menu. 

RxSpotlight pans the image to show the measured point of the selected pair in 
the centre of the image window. 

3. Change the current measured point location. 

Place the mouse cursor over the grip and click. Move the cursor and click again 
to specify its new location. 

4. Go to the next or previous calibration pair. 

Press N or Tab hot key or the  button on the toolbar in the Calibration dialog 

box for moving to next calibration pair. 

- or - 
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Press P hot key or the  button on the toolbar in the Calibration dialog box for 

moving to previous calibration pair. 

RxSpotlight pans the image to show the next (previous) measured point in the 
centre of the image window. The measured point will be highlighted with grips. 

5. Repeat steps 3-4 for all calibration pairs you need. 

Modifying Calibration Pairs with Dialog 
The location of any calibration point and the type of any calibration pair can be 
changed using the Change Point dialog box. 

To modify a calibration pair with dialog 

1. Select a required pair from the list in the Calibration dialog box. 

2. Zoom to selected pair by 
 
 button on the Calibration toolbar or Zoom to 

command from cursor menu. 

3. From the cursor menu, choose Modify or click the  button in the Calibration 

dialog box. 

The following dialog box appears: 

 
Change Point dialog box 

4. Type the coordinates of the real and measured points. The measured point 

coordinates can be picked on the screen by using the  button.  

5. Select the pair type in Use as. Remove the check from Use as, and the defined 
pair will not be used for calibration.  

6. Type the name for the pair in Label. 

7. Click OK. 
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Deleting Calibration Pairs 

Delete the selected calibration pairs from the list in the Calibrate dialog. Note that this 
action can't be undone. 

To delete calibration pairs 

1. Select the required pairs from the list in the Calibration dialog box. 

2. From the cursor menu, choose Delete or click the  button in the Calibration 

dialog box. 

Resetting Calibration Pairs 

This operation resets the measured coordinates of the selected calibration pairs to 
appropriate real ones. Note that this action can't be undone. To reset calibration pairs: 

1. Select the required pairs from the list in the Calibration dialog box. 

2. From the cursor menu, choose Reset or click the  button in the Calibration 

dialog box. 

Choosing Calibration Method 
The choice of calibration method is based on the nature of image distortion and the 
quantity and location of calibration pairs. 

If the type of image distortion is unknown, then choose a calibration method 
automatically. In this case the program automatically chooses the optimal calibration 
method for the set of calibration pairs. 

The following table describes possible distortions and calibration methods, used to 
correct them. 

Method Distortion 

Linear conformal For linear transformation - moving, rotating, and 
proportional scaling.  

Affine For linear transformation - moving, rotating, and 
non-proportional scaling. Raster ellipses can be 
transformed to circles. 

Bilinear For parallelogram or trapezoid distortions on 
map or mechanical drawings. 

Grid adaptive bilinear Useful for relatively small raster grid distortions 
if the grid sells are convex. 

Can only be used if the calibration grid is 
defined. 

Polynomial Nonlinear deformations caused by either three-
dimensional expansion of the original graphic 
document or by an image type itself. For 
example, aerial photos of the Earth‟s surface. 
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Surface Splines For distortions of all kinds, it is more accurate, 
and works on an arbitrary set of pairs. 

For every calibration method there is a minimum number of calibration pairs that 
enables the use of this model. If the number of calibration pairs exceeds a certain 
value, then all models, except Surface Splines, produce a non-zero deviation. 

The following table describes the restrictions on the number of calibration pairs for 
each calibration method. 

Method 
name 

Number of calibration 
pairs required 

Number of calibration pairs 
producing non-zero error 

Linear 
conformal 

2 3 

Affine 3 4 

Bilinear 4 5 

Grid 
adaptive 
bilinear 

the calibration grid must be 
defined. 

Non-Grid points are defined 

Polynomial 
2 degree 

6 7 

Polynomial 
3 degree 

10 11 

Polynomial 
4 degree 

15 16 

Polynomial 
5 degree 

21 22 

Polynomial 
6 degree 

28 29 

Surface 
Splines 

3 not applicable 

To choose a calibration method 

Select a calibration method from the Calibration method list of the Calibration dialog 
box. 

Estimating Calibration Accuracy 
Calibrating transforms the entire raster image by means of the calculated 
transformation. All image points, not only those defined in calibration pairs, generally 
move. Accuracy estimation allows for the expected displacement of every raster point 
to be found for the calibration method chosen, without having to run the calibration 
procedure. 

For every calibration pair, estimating creates one more point called estimated. It 
shows the position of a measured point after running the chosen calibration method. 
Markers of such points are coloured yellow. (The markers of real points are blue; the 
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markers of measured points are red. Change these default colours in the Preferences 
Dialog Box). The program then calculates and displays the distances between each 
estimated point and its appropriate real point. These distances define calibration 
deviations for each pair. 

RxSpotlight calculates the parameters of the chosen method so after transformation, 
each measured point is placed as close to its appropriate real point as possible. 
RxSpotlight only uses Control and Grid calibration pairs for these calculations.  

To estimate the displacement of a certain image point after calibration, create a 
calibration pair with the measured and real points that have coordinates of the desired 
image point, and assign the Check type to this pair. The pair will not be considered 
when defining transformation parameters, but the program will find the estimated point 
for the pair and calculate deviation relative to its real point location. 

To estimate the calibration accuracy 

1. Create the calibration pairs needed to eliminate the distortion of your image. 

2. Specify the locations of the measured point. 

3. If needed, then create Check pairs to decide on the arbitrary points‟ movements. 

4. Select the required method from the Calibration method list.  

Base the choice on recommendations given above in "Choosing Calibration 
Method” on page 144. Note that RxSpotlight only allows the use of those models 
applicable to the specified set of calibration pairs. Estimation cannot be run if 
these requirements are not met. 

5. Press the  button in the Calibration dialog box. 

Mean error indicates the average error of the method chosen. Also, pay attention 
to the Xerr and Yerr values to estimate the error of the chosen method for every 
point. 

Example of Image Calibration 

This example shows the calibration of a colour image from the UTRECHT.TIF file of 
the SAMPLES subfolder of the program root folder. 

Image loading 

Choose Open from the File menu or click the Open button in the Main toolbar.  

In the dialog box go to the SAMPLES folder and double-click the UTRECHT.TIF 
file name. 

- or - 

Select the UTRECHT.TIF file and press the Open button in the dialog box. 

Note that this image sample has raster grid with a X-axis of 2 cells and an Y-axis 
of 2 cells. The size of cells in this grid is known to be 32x32 mm, and in the 
original scanned image the grid cells are distorted. We assume that the whole 
image distortion corresponds to the grid distortion. 

Use calibration procedure to eliminate distortion. 
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Open the Calibration dialog box 

From the Image menu, choose Calibrate or on the Image toolbar, click the  

button. 

Creating a set of calibration pairs using calibration grid  

1. Press   in the Calibration toolbar. The Calibration Grid dialog box appears.  

2. Zoom to the image lower-left corner. 

3. Enter the exact coordinates of the lower-left grid node to Origin the UCS is 

defined or press the Measure button  and click a point at the raster lower-left 

grid node, as shown in the figure below. 

 

  
     

 Click here 

4. Specify X Size and Y Size of the grid cell. 

Enter 32 to X Size and Y Size. 

5. Specify numbers of grid cells along the X-axis and Y-axis entering 2 to X Cell 
and Y Cell, respectively.  

6. Choose OK to create a calibration grid and return to the Calibrate dialog box. 

A grid of calibration pairs is displayed. 

The real and measured points of each calibration pair have the same 
coordinates. They represent the known position of raster grid nodes. 

Define the measured points 

1. Select the first calibration pair Grid (01,01) from the list in the Calibration dialog 
box. RxSpotlight highlights the selected point with grips. 
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2. Zoom to the selected pair by clicking the 
 
 button on the toolbar of the 

Calibration window. RxSpotlight pans the image so that the pair is shown in the 

centre of the screen. Use the standard 
 
button to view the required point 

more exactly.  

3. Change the current measured point location. 

Place the mouse cursor over the grip and click. Move the cursor and click again 
to specify its new location. 

 

 

1 2 

The figure above shows the real (1) and the measured (2) points positions. The 

real point of the calibration pair sets the known position of the raster grid node, 
and the measured point shows the position of the raster grid node on the original 
(distorted) image. 

4. Go to the next calibration pair by pressing N or Tab hot key or press the  

button in Calibration dialog box. 

RxSpotlight pans the image so that the measured point of the next calibration 
pair is shown in the screen centre. 

To go to the previous calibration pair, press P hot key or press the  button in 

the Calibration dialog box. 

5. Repeat steps 3 and 4 for all calibration pairs to specify the measured point‟s 
position. 

Transformation method selection 

As follows from the table on the page 144, the Grid adaptive bilinear method is 
the most appropriate method to correct grid distortions. 

From the Calibration Method list, select Grid adaptive bilinear. 

- or - 
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Select Choose automatically from the same list. 

To estimate the calibration transformation precision 

Click the  button in the Calibration toolbar. 

The program will find the calculated points‟ coordinates –the points for the 
measured points of all calibration pairs to be moved to, and their position will be 
shown with yellow cross marks on the image. Also, the program calculates the 
distances between the calculated points and the real points of the calibration 
pairs in order to estimate the mean, maximal and minimal transformation errors. 
The values of these errors are shown in the boxes: Mean error, Min error and 
Max Error respectively. 

In this case all these values are zeros. It means that all the raster grid nodes will 
get the required positions after calibration. 

To start the calibration procedure 

Start the image calibration procedure by clicking the Apply button in the 
Calibration toolbar. 

  

Filters 
Monochrome filters are used to process bitonal images. Filter application can 
considerably increase image quality and reduce the size of raster image files. 

Data Selection for Monochrome Filtration 
The filtration operations can be applied to images that are located on unlocked layers, 
visible and with the read-only attribute off. Filtration can be applied to four kinds of 
selection sets. 

1. One or several raster images (no explicit selection made).  

2. Selection set than can contain images and raster areas.  

3. Clipped areas. 

 For more detailed information on selecting raster images see page 108. 

Speckle Remover 
The Speckle Remover filter removes raster objects (isolated pixel groups) that are 
smaller than those of the specified value. This filter can automatically estimate the 
speckle size in the image. 

The filter can be used after such procedures as binarization and layering to remove 
low-sized raster objects in the obtained monochrome images‟ layers. 
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Monochrome raster fragment, obtained 
after binarization 

After speckle removing 

To remove raster speckle 

 
1. Define the selection set to be processed and choose Speckle Remover 

from Filters menu or press the button on the Filters toolbar. 

 

2. Specify the maximum size of raster objects to be removed in the current units 
(left box) or in dots (right box). 

- or - 

Set the Auto Estimating option so that the filter automatically estimates raster 
speckle size before filtration. 

 
To measure the size of a raster object on the screen, click on pixel inside the 
object. 

- or - 

 
Click the button and pick two pixels on the screen. The program will estimate 
the speckle size equal to the distance between these points. 

3. Choose Apply. 

Hole Remover 
This filter removes low-sized holes in raster objects. Only holes with size less than the 
specified value are removed. The filter can automatically estimate the hole size on 
image objects. 

The filter can be used after such procedures as binarization and layering to fill 
undesirable holes in raster images. 
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Original image After hole removing 

To remove low-sized holes 

 
1. Define the selection set to process and choose Hole Remover from the 

Filters menu or press the button on the Filters toolbar. 

 

2. Specify the maximum size of raster holes to be removed in the current units (left 
box) or in dots (right box). 

- or - 

Set the Auto Estimating option so that the filter automatically estimates raster 
hole size before filtration.  

 
To measure raster hole size on the screen, click on a pixel inside the object. 

- or - 

 
Click the button and pick two pixels on the screen. The program will estimate 
hole size equal to the distance between these pixels. 

3. Choose Apply. 

Smoothing 
This filter smoothes raster object edges, fills inner background droplets, and partially 
removes raster speckles. 
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Original image fragment After smoothing 

This filter processes images in two steps. During the first step a median operation on 
a greyscale image (see description on page 327) is performed. This function analyses 
the area of a specified radius of each pixel and moderates the extremes of brightness. 
As a result, the outline seems blurred and the raster object edges are converted to 
stripes of different brightness value. As Medianing value increases, gray stripes 
widen. 

     

First step – edge blur          Second step - binarization 

On the second step the filter turns the pixels with a brightness value less than the 
Threshold value black. The wide black lines in the figure above show the boundary 
within which the pixels turn black and outside of which pixels turn white. If the 
Threshold value increases, then it causes the object to thicken, and if the Threshold 
value reduces, it makes them thinner. 
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To smooth raster objects 

 
1. Define the selection set to process and choose Smoothing from Filters menu 

or press the button on Filters toolbar. 

 
2. Specify Medianning – averaging level in percent.  

3. Specify Threshold – level from 0 to 255. This value determines clipping level of 

blurred outlines. As this value increases, smoothing effect increases but raster 
lines widen. 

Use the preview window to adjust optimal parameter values. 

  For more information on preview window see page 34. 

4. Click OK. 

Thinning 
The Thinning filter makes raster fragments thinner by a specified number of pixels in 
specified directions – horizontal, vertical, and diagonal. This filter has a 
supplementary parameter that allows thinning raster objects up to skeleton (only 
pixels in the middle are left). 

  
After thinning up to skeleton 

To thin an image 

 
1. Define the selection set to process and choose Thinning from Filters 

menu or press the button on Filters toolbar. 
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2. Specify the desired number of thinning filtration passes. 

- or - 

Select Thin image up to skeleton to convert all the objects to one-pixel lines. 

3. Choose Apply. 

Thickening 
The Thickening filter makes raster objects thicker by specified number of pixels. A 
combination of thickening directions can be chosen. 

The following figure below shows the Thickening filtration effect if all directions are 
chosen. The left picture shows the original raster image, and the picture on the right 
shows the result of Thickening filtration after three passes. 

  
Thickening filtration in all directions 

The figure below shows the Thickening filtration effect if only the Vertical thickening 
direction is chosen. The picture on the left shows the original raster image, and the 
picture on the right shows the result of Thickening filtration after three passes. 
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Thickening filtration in vertical direction  

To thicken an object 

 
1. Define the selection set to process and choose Thickening from Filters 

menu or press the button on Filters toolbar. 

 
2. Select a desired thickening direction: Horizontal – by horizontal, Vertical – by 

vertical, All – horizontal, vertical and diagonal. 

3. Choose Apply. 

Contour 
Contour filters convert filled raster areas of the image to one-pixel outlines. The 4-
coupling filter creates 4-coupling contour; the 8-coupling filter creates 8-coupling 
contour. In the 4-coupling filter the contiguous areas can only be coupled with their 
sides; the 8-coupling filter analyses corner contiguity, so such images look thinner.  
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The figure shows the result of Contour filtration. 

  

  
 

Fragments of outlines, obtained after 4-coupling and 8-coupling filtration 

To convert raster objects to outlines 

  
Select part(s) of the raster or image(s) and click the 4-coupling or 8-
coupling from Contour submenu of Filters menu or press the button on 
Filters toolbar. 

Inversion 
The Inversion filter reverses the colour of a monochrome image for each dot. 
Background dots become image dots; image dots become background dots. The 
following illustration shows the inversion filtration result. 

 
 Effect of the Inversion filter 

This filter applies only to entire image. 

To invert a selected image 

 
Choose Inversion from Filters menu or press the button on the Filters 
toolbar. 

Filling Raster Line Breaks 
To eliminate the breaks in raster lines use Line Breaks Filling command. 
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This operation can be performed only with monochrome raster images. To perform 
the command, set up the Max line width and max Gap Jump.  These values can be 
obtained by measuring directly from the raster image by using the appropriate 
buttons. The accuracy slider allows the user to tune the image, this process is manual 
and the results must be viewed to determine which will be the most suitable setting. 

 

This command is useful for correction of images processed by binarization or 
scanning of colour images in monochrome mode. Decreasing the number of gaps 
positively affects the raster to vector conversion performed using Trace Polyline 
command and Raster2Vector Conversion. 

To start this command, choose Filters from the Image menu and then Line Breaks 

Filling. Or click the  button on the Filters toolbar. 

To perform segmentation do following: 

1. Open the monochrome raster image. 

2. Run the Line Breaks Filling command. 

3. Measure the width of a line. Define the gap sizes to eliminate. Measure 
the biggest of them. 

4. If satisfied with the results in the preview window, then move on to step 
5 below. If not, then reset the wrong value for Max Width of Max Gap to 
Jump. Repeat the measurement of required parameters. 

5. Play around with the accuracy slider to fine tune the image, if needed. 
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6. Decreasing the accuracy (slider moves left) causes more holes to be 
filled and vice-versa. 

7. After finding the optimal position, press the Apply button. 

8. To save the setting for further use, press the Template button and define 
a file name for the settings to be stored as. 

Objects Separation by Type and Size  
This operation allows separating raster objects of various values into different raster 
layers. Hatch, text, linear objects and objects by size (isolated groups of adjacent 
points) can be separated from an original image. 

During this operation the program searches for objects in a monochrome image and 
moves them to a new raster image. The resulting image has the same parameters 
(size, insertion point, resolution, and scale) as the original image; however it is placed 
on a user-specified layer.  No image objects are lost since they are only moved to a 
separate raster layer. 

This operation can be used: 

 instead of speckle remover filter, to keep small-size objects which the program 
may remove as a „speckle‟.  

 to apply tools to the objects of a specified type (for example, editing texts and 
hatches). 

If the objects are not to be removed from the original image, then erase the entire 
raster layer obtained. If any important objects are transferred to this layer, then select 
them and transfer them back to the original image, and then remove an unnecessary 
raster layer. 

To separate objects 

Select objects to separate. With no object selected, the operation will be applied to all 
visible images located on un-locked layers. 

Choose command from the Image menu; alternatively press the appropriate button on 
the Image toolbar:  

 
In the opened dialog set the parameters by which the objects should be separated.  

The dialog and settings depend on a type of a selected object. The buttons in the 

dialog located next to the measurement fields    can be used to measure 

parameters from the image. For this, press an appropriate button and specify what is 
needed on the screen. A measured value will appear in the appropriate field. 

To fill in the Output Layer field you need to make the same actions for all the dialogs: 

 Enter a name of the layer to place an image containing selected objects; 
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 Set a colour for this layer – click on the colour sample located next to the 
field and select a colour from the dialog. 

Observe the result in the preview window. When satisfied, press the Apply button. 

Setting parameters in the object separation dialogs: 

1 Separation by size 

Set the minimum and maximum object size in the appropriate fields. 

2 Separation Linear Objects 

In the Max Width field specify the maximum width value for a raster line of the objects 
to separate. 

In the Gap Jump field specify the maximum gap value to ignore in the raster lines. 

3 Separate Text Areas 

In the Max.width field specify the maximum width value for a raster text line. 

In the Text Height field specify the maximum size of the upper case letters. 

 
Select the Text Orientation – Horizontal, Horizontal and Vertical or Arbitrary Oriented 

from the combo-box. If needed, then select the „Overlapped Text‟, and/or „Single 
Letters‟ checkboxes to improve the text recognition quality. 

4 Separate Hatches 

In the Max Width field specify the maximum width value for a raster hatch line. 

In the Gap Jump field specify the maximum gap value to ignore in the raster lines. 

In the Hatch Angle field specify the hatch angle. 
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To save or delete a created raster image 

A created raster image containing separated objects becomes embedded in the 
RxSpotlight document automatically; it gets the name of the layer set in the Output 
Layer field. To save this image to a separate file: 

 From the Tools menu choose Image; or press the button , on the 

Properties toolbar; 

 In the Image dialog select the created image, press the Save As button , 

set a file name and format.  

To delete a raster image containing separated objects press the Delete button in the 

Image dialog . 

To bring objects back to the original image 

Select objects to bring back to the initial image using one of the selection methods. If 
all the objects are to be brought back, then select the created raster image by its 

vector frame or use the Select Image dialog  . 

Choose Merge (Rasterize) in the Modify menu. 
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Tracing and vectorizing 

Tracing 
This chapter describes the means and tools of tracing – an interactive procedure that 
allows extraction of vectors from a raster image, and also to smooth or to delete 
objects of a monochrome raster image. 

Tracing is based on the technology of local recognition of geometrical raster entities. 
Using this technology, the program identifies raster lines as a line, arc or circle, and 
generates the appropriate vector objects. Pick raster objects on the image, and the 
program creates vector objects that approximate the objects chosen. 

This method adds power and flexibility to the automatic conversion process. When 
tracing, it is possible to classify line widths of raster image objects, transform only the 
necessary ones and transfer the results to separate layers. 

Tracing can work on colour or grey-scale, and monochrome images. It is possible to 
vectorize raster lines, arcs, circles, arbitrary curves (polylines) and also outlines of 
vector areas. 

When processing images; tracing can be used to convert raster objects to vector 
objects. It can also be used for smoothing, and deleting objects. Depending on the 
specified tracing mode, the raster object is either deleted, or left intact on the image. 
Thus, it is possible to transform a raster line to vector object, or only to create a vector 
copy of a raster line. It is also possible to set a mode in which tracing does not create 
any replacement vector objects thus deleting them. There is one more mode that 
automatically replaces a raster line by the rasterized vector object. 

On monochrome images lines, arcs, circles, hatches, symbols, and arbitrary curves 
(raster polylines) and area objects as closed polylines can be traced. On colour and 
greyscale images all types of objects can be traced, except for hatches and symbols. 

Tracing Methods 
Various methods are used to trace raster objects. The tracing method sets a user‟s 
sequence of operations and defines the type of vector object used for approximating a 
raster line. 

The operation to be applied to the results of raster object tracing (vectorization, 
converting, erasing, smoothing) is set by the current tracing mode. For detailed 
information see “Tracing modes“, page 170. 

Tracing involves local recognition of vector objects on the raster image. For the 
correct identification of objects the program always uses two numerical parameters 
defining the maximum width and the ignored break value of a raster line, and also a 
parameter that specifies the level of accepted deviations of the raster objects from 
their vector prototypes. Set these parameters in the Options tab of Conversion 
Options dialog. To trace raster symbols, create recognition templates or use the 
existing samples and specify additional parameters of symbol recognition. During 
tracing, apply the Orthogonalization mode and the program will align obtained vector 
objects parallel and perpendicular to the Base Angle. The base angle can be defined 
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automatically or set in the Options tab. This mode can be used, for example, to trace 
urban maps with buildings. 

Detailed information on the parameters defining tracing operation is provided in the 
section “Tuning Tracing” on page 172. 

This chapter describes the tracing techniques on monochrome images. Tracing on 
colour images is described on page 180. 

Tracing with automatic object type recognition (Trace Auto) 
This method is used for tracing raster entities of the following types: line, arc, outline 
and circle. 

When tracing in the automatic mode, specify a point on a raster line, and the program 
automatically selects the type of vector object (line, arc or circle) that is most suitable 
for a specified raster line and victories the specified raster object. If the indicated 
object cannot be approximated with one of the above objects, and its width exceeds 
the value specified in Max Width, then the program creates closed polygon that 
outlines this object. 

Raster entities are raster objects of the same form as base vector objects – lines, 
arcs, and circles. We shall use the terms raster circle, raster arc and raster line, 

implying raster objects having the form of a circle, arc and line. Raster entities can be 
also defined as raster analogues of vector objects, for example when printing a vector 
drawing we obtain a raster representation of the vectors. Note that real raster entities 
can have defects, which complicate their identification by the program, for example, 
breaks, ellipticity of circles and arcs, line with deviations, etc.  

When tracing a raster line by picking, the program determines its type (line, arc or 
circle) and tries to trace the object to the greatest possible extent. The intersections of 
an entity with other objects are ignored, and the set of points representing the object 
is extended as long as the form of the raster object matches the recognized entity. 
Since real raster objects differ from ideal raster entities, the recognition tool uses the 
parameter Approximation Accuracy that sets the accepted level of deviation of the 
real raster object forms from the ideal ones. See the description of this parameter in 
section "The Options tab", page 172. 

When tracing a raster entity, its intersections with other crossing objects are 
preserved. If the raster data selected during tracing is deleted, then the remaining 
raster objects are not broken. This allows the user to replace raster objects with 
vectors without changing the form of other crossing also allowing raster objects to be 
deleted as if they were vectors. For example, if a raster line intersecting a circle is 
deleted, the circle remains unbroken in the same way as deleting a vector line lying 
over a vector circle. 

To trace an object with automatic type recognition 

 
Choose Trace Auto from Convert menu or click the button on the Raster to 
Vector toolbar. 

Click on a raster object to start automatic tracing. 

For the best results, pick a point on the least distorted and longest segment of the 
raster object, far from its intersections with other objects. 
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If the program recognizes a raster entity, then the object will be traced using the most 
appropriate object type. If recognition fails, then the program beeps. 

If the specified object is not a raster line arc or circle, then an approximating vector 
outline will be created. To distinguish raster lines from other objects RxSpotlight uses 
the Max Width parameter (see page 172). 

Forced Tracing 
Forced tracing allows the user to replace raster objects with vector ones of a specified 
type. Select one of three object types to be used as reference objects for tracing (line, 

arc or circle), and then specify points on a raster object, drawing a vector entity above 
the raster entity. The tracing of hatch and symbol can also be interpreted as forced 
tracing. The program tries to trace the specified object with a vector figure of the 
selected type. If possible, then the raster object is traced. Unlike the Auto method, this 
method allows you to trace a selected part of a raster entity as well as entities with 
significant distortion. 

If during forced tracing the raster entities are deleted (tracing modes Convert to vector 
and Erase raster), then the raster objects intersected by them are not broken. The 
parameters Approximation, Max width and Max break affect these methods. If the 
object width is greater than the Max width parameter value or its form cannot be 
approximated by an object of the specified type, then the tracing is not performed. 

When tracing by the Line and Arc methods the ends (one or both of them) of 
reference lines and arcs can be extended beyond the limits of the raster objects to be 
traced - on their imaginary extension. In this case a raster object is traced up to its 
end points. If the ends of the reference object lay within the raster object, then only a 
part of the raster object covered by the reference object is traced. To extend the 
recognized line to its natural limits, turn on Auto Extend vectors checkbox in Trace tab 
of Conversion options menu (see more information on page 175).  

To trace a line 

 
1. Choose Trace Line from Convert menu or click the button on the 

Raster to Vector toolbar. 

 2. By specifying two points, draw a line covering the raster object to be 
traced. 

If the program cannot recognize an object under the vector line, then it beeps. 

To trace an arc 

 
1. Choose Trace Arc from Convert menu or click the button on the Raster 

to Vector toolbar. 

2. Specify the start, middle and end points of an arc lying over the raster 
object to be traced. 

3. To trace another raster arc, repeat steps 1-2. 

To trace a circle 

 
1. Choose Trace Circle from Convert menu or click the button on the 

Raster to Vector toolbar. 

2. Specify two points - the opposite sides of a raster circle to be traced. 
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3. To trace the next circle, repeat steps 1-2. 

Trace Outline 
This type of tracing creates an outline polygon with black line and cross-hatched fill 
around the specified contiguous area.  

To trace an outline 

 
1. Choose Trace Outline from Convert menu or click the button on the 

Raster to Vector toolbar. 

2. Click a raster point in the area to outlined. 

This command performance is influenced by Export single contour checkbox in Trace 
tab of Conversion options dialog (see page 175). 

  

The black figure was traced with Export 
single contour checkbox off. The result 
was selected, exploded and then Fill 
attribute was set to FALSE. Note that 
tiny black square was not affected. 

The black figure was traced with Export 
single contour checkbox on. The result 
was exploded and Fill attribute was set 
to FALSE. The result is outer contour. 

Trace Hatch 

This type of tracing enables the user to trace a raster hatch consisting of straight 
raster lines with the same angle, enclosed in a raster outline. 

To trace a hatch, draw a polyline crossing all the lines which form the raster hatch. 
The program automatically detects the boundary of the hatched area and creates a 
hatch. 

The hatch recognition of this type can be only used on monochrome images. 

To trace hatch 

 
1. Choose Trace Hatch from Convert menu or click the button on the 

Raster to Vector toolbar. 

2. Specify the vertices of the polyline, crossing all raster hatch lines. 

3. Double-click to trace hatch. 
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This figure illustrates the original polyline hatch and the result of tracing (right part). 
The Create vector and erase raster tracing mode was applied. 

 
You draw a polyline (fence)  Tracing result 

Tracing polylines (Line follow) 
This method allows the user to trace arbitrary raster lines with an approximating 
vector polyline. When tracing, specify a point on the raster line, and the program 
automatically tracks this line (direction of the line follow can be specified) up to the 
nearest node or intersection point, and creates an approximating vector polyline that 
consists of line segments. The node of a raster line is either its end point, or a point 
where the raster line crosses the other raster object. During a single tracing session 
between two mouse clicks (it is called tracing step) you trace a set of polyline 
segments. One tracing step can take an arbitrary number of segments, depending on 
the line complexity and trace settings. 

After each tracing step, choose the direction for further tracing, or complete the 
procedure. If the traced polyline crosses itself, then the tracing will be automatically 
completed. The direction can be chosen by specifying a point on the next adjacent 
part of the raster line. There are options to redo the latest tracing step (except the first 
one), and the last polyline segment within a step. 

The autodetection mode of tracing extension direction can be turned on (see Trace 
tab in Conversion Options dialog). In this mode the program offers a possible 
direction, showing a special marker on the part that is selected as an extension. 
another direction can be selected during the given period (by default the waiting mode 
is off – waiting pause is 0), or accept the automatic trace extension. If no direction is 
chosen, then after the waiting period expires, the program will automatically continue 
tracing in the selected direction. 

When tracing raster polylines the orthogonalization mode can also be used. It allows 
users to align obtained line segments by the base angle. 

 More detailed information on polyline orthogonalization mode is provided in 
section “Trace Tab” on page 174. 

Tracing raster polylines is also influenced by the parameters Max Width, Max Break 
and Approximation Accuracy which specify maximum width of a raster line, value of 
ignored break and accuracy of a raster line approximation.   
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 More detailed information on these parameters is provided in section “The 
Options tab", page 172. 

When tracing polylines several options are available; these are found in the cursor 
menu when working in Line Following mode. 

Option Description 

Cancel Cancels the current tracing session; all the polyline 
created is deleted. After the end of tracing users can 
undo the result applying Undo command from Edit menu. 

Users can also cancel the tracing session by pressing 
ESC. 

Start in Direction Can be used just after activation of Line Following 
method. If selected, then this option forces the program to 
treat the first two clicks on the raster line being traced as 
the direction of the polyline to be created. 

End Ends the tracing; to trace more, activate the Line 
Following method again. 

Back Step Cancels the last tracing step. 

Back Segment Cancels the last polyline segment. 

Force Segment Enables a linear segment to polyline to be added without 
tracing. Several segments can be added with SHIFT 
pressed. 

Change Direction Inverts the tracing direction.  

Pan to Centre  Zooms the image to show the last added polyline vertex 
in the screen centre.  

Now we will describe in details the procedure of polyline tracing without autodetection 
of tracing direction (the fragment of the map used in this example you can find on 
CS_MAP.TIF in SAMPLES subfolder). 

To trace a polyline 

1. Choose Line follow from Convert menu or press 
 
button on Raster to Vector 

toolbar. 

 To have complete control over the tracing procedure and so that tracing 
results are clearly visible, be sure to choose contrast Colour in the 
Inspector window for a polyline created. Also make sure that in the 
AutoDetect Direction checkbox in the Trace tab of Conversion Options 
dialog is off. 

2. Pick any point on the raster line. 

 Starting from this point, RxSpotlight traces the selected raster line in both 
directions until in meets the two nearest intersections or breaks. 

 The program automatically determines the tracing direction. The rubber line is 
stretched out from the mouse cursor indicating the current tracing direction. 
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 An example of starting the tracing procedure by picking of one point (used by 
default) is shown in the figure below. 

     
Indicated point     Traced part of polyline 

 

 Suppose that we need to trace in the opposite direction. To change the direction, 
press the right mouse button and choose Change Direction. Then specify a point 
on the raster line. 

 When specifying a tracing direction in which to start, RxSpotlight starts tracing 
the raster line at the first of the indicated points and proceeds to the node 
nearest to the second indicated point. 

 An example of tracing start with the tracing direction indicated (Change Direction 
option) is shown in the figure below.    

  
First and second points Traced part of polyline if Start in Direction is 

applied 

 

3. To trace the next part of the raster line in the current direction, indicate a point 
on it. RxSpotlight traces a raster line up to the nearest node. 

- or - 

To change the tracing direction, select the Change Direction from the cursor 
menu and indicate any point on the traced polyline near the opposite vertex. 

- or - 
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To create one linear polyline segment manually (without tracing); select the 
Force Segment option. Then indicate a point. The line section will link the 
indicated point with the last trace point. 

This option allows you to eliminate breaks of a raster line, drawing a straight 
segment of the polyline. 

 

The example shows an isoline on a 
raster map broken with text. We 
draw a rubberline over the gap. 

 

Specifying the raster line extension 
without using the Force Segment 
option results in one linear segment 
filling the gap.  

 

 Use the Force Segment option to 

draw the missing parts, consisting of 
many linear segments, as the figure 
illustrates. 

 

4. Repeat step 3 until tracing a raster line is complete. 

If the results are not satisfactory, then use the Back Step and Back Segment 
options. The first option cancels all polyline segments obtained at the last tracing 
step, and the second option enables the polyline segments obtained within one 
step to be cancelled.. These options can be applied several times to cancel any 
number of steps or segments.  

RxSpotlight automatically stops tracing a polyline, if the latest created polyline 
segment crosses any other segment of the same polyline, or if the latest 
segment vertex is located close to the first vertex of the same polyline. In the 
latter case a closed polyline is created, and tracing is completed. 
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5. To stop tracing press ENTER. 

When tracing polylines with autodetection of direction, the program on reaching 
a node tries to determine the trace direction, and draws a marker on the 
suggested raster line extension (cross of the current colour). 

Pressing SPACE accepts the tracing direction, suggested by the program. You 
can also select another tracing direction by specifying a point on the required 
part of the raster line. A choice of direction must be made in the given time 
period. This interval is set by the Pause parameter in the Trace tab of 
Conversion Options dialog. 

If the program fails to determine a direction automatically, then a prompt to 
indicate a direction manually will appear, and once selected, tracing will continue 
operating in the automatic detection mode. 

 When tracing polylines, it may be useful to split the document window to two or 
four panes, setting different zoom values in them; both the entire picture and small 
details can be viewed in the window. The Split commands are described in details on 
page 32. 

Several images can be grouped using the Group command from the Modify menu. 
The linefollowing tool ”jumps” from the end of line on one image to its continuation on 
another one, creating a single polyline based on several raster sources. This “jump” 
can be implemented only if the images in the group have the same DPI value. 

 For information on grouping see page 257. 

If the image is clipped, then linefollowing stops at clipping boundary.  

If monochrome images overlap each other, then tracing begins and continues on the 
image raster line of which was clicked first. The polyline is only traced on that image, 
ignoring visual intersections with raster objects on other images. If the overlapping 
images are grouped by Modify > Group command, then tracing is performed as if the 
images were merged. The polyline is traced considering all the visible intersections. 

Tracing Raster Symbols 
The Symbol method of tracing allows you to trace by picking raster objects similar to 
previously defined samples. Symbol recognition can be only used on monochrome 
images. 

 The procedure of symbol recognition is described in the Section “Tuning Symbol 
Recognition Template Library” on page 198. 

To trace a raster symbol 

1. Choose Symbol from Convert menu or on the Raster to vector toolbar click  

button. 

2. Indicate a point on the raster symbol. 
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The raster symbol 
tracing is illustrated in 
these figures. 

The original raster 
symbol and the 
indication point are 
shown on the left. 

On the right there is a 
vector block that has 
replaced the raster 
symbol. 

  

Use this method to vectorize the conventional notations on scanned electrical, 
hydraulic schemes, maps and similar images. 

Tracing modes 
The tracing mode defines an operation made on the original raster object and the 
produced vector object. 

Tracing can be used to create vector objects (Create vector and keep raster), to 
delete raster objects while creating vector ones (Create vector and erase raster), to 
delete raster objects (Erase raster without producing vector), and also for smoothing 
(Smooth raster without producing vector). The selected mode remains active until 
another mode is selected. 

Create Vector and Keep Raster  
The Create vector and keep raster mode creates vector objects and does not delete 
the original raster. This mode is used by default. 

To turn on Create Vector and Keep Raster mode 

 
Click the button on the Raster to Vector toolbar or from the Convert menu 
select Vector (keep raster). 

Create Vector and Erase Raster  

This mode creates approximating vector objects and removes traced parts of raster 
lines. 

To turn on Create Vector and Erase Raster 

 
Click the button on the Raster to Vector toolbar or from the Convert menu 
select Vector (erase raster). 
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Results of hatch tracing when the Create vector and erase raster mode is on 

Erase Raster without Producing Vector  

This mode removes traced parts of a raster line and does not create vectors. The 
intersections or the parts of other raster objects under the traced data are left intact. 

To turn on Erase Raster without Producing Vector  

 

Click the button on the Raster to Vector toolbar or from the Convert menu 
select Erase raster. 

   
Tracing a line when the Erase Raster without producing vector mode is on 

Smooth Raster 

This mode removes traced parts of a raster line, creates an approximating vector, and 
then automatically rasterizes it. Thus the Smooth raster mode allows users to correct 
raster lines. 

To turn on Smooth Raster  

 
Click the button on the Raster to Vector toolbar or from the Convert menu 
select Smooth raster. 

   
Tracing effect in Smooth Raster mode 
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Tuning Tracing 
Users can control tuning tracing procedure using the Conversion Options dialog box.  

Tuning is performed in the Options and Trace tabs of the Conversion Options dialog 
box. Tracing is also influenced by parameters of the Separate and Symbols tabs, 

which are described in the section "Setting up Symbol Recognition Options” on page 
196. 

To setup tracing parameters 

1. Choose Conversion Options form Convert menu or click the button  on the 

Raster to Vector toolbar 

2. Choose Options tab. 

 
The Options tab of Conversion Options dialog. 

3. Specify the new parameters by entering values or measuring with a ruler on the 
image, and then click OK. 

Tracing Parameters Description 

The Options tab 

Parameter Description 

Min Length This parameter defines the minimum size of a raster object 
that can be recognized. 
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Parameter Description 

Max Width This parameter defines the maximum width of raster lines that 
can be approximated by lines, arcs, circles, and polylines.  

If the width of a raster line exceeds Max Width, then the only 
possible mode is Auto tracing and approximating with an 
outline object. 

Max Break Sets the length of the maximum ignored breaking raster lines. 

If a raster line is broken into parts it should be traced as an 
entire object, then the value of Max break should be set to the 
largest gap between the raster line parts. The program will 
ignore the breaks and create single vector object, 
approximating the whole raster line. By setting a 
comparatively large value of the parameter, users can, for 
example, trace dash-dotted raster lines, and arcs as single 
entities. 

Enter the values of Min Length, Max width and Max break 
from the keyboard or measure them on the screen. 

Approximation 
Accuracy 

This parameter determines the accuracy of approximation of 
the original raster object with a vector one. If the original 
image is distorted (,For example, circles have the form of 
ellipses.), then reduce the value of the Approximation 
Accuracy parameter. However, this leads to inaccuracies in 
recognition, for example the program might take a short arc for 
a line. When the quality of a raster image is high, increase the 
value of the Approximation Accuracy parameter. 

Sometimes before tracing the quality of the raster image can 
be improved by application of a smoothing filter. 

Custom Hatch This parameter defines an angle of raster lines which will be 
recognized as hatch during tracing. 

Orthogonalization If this option is on, then the tracing in Auto and Line modes 

aligns created segments either perpendicular to or parallel 
with the base direction if the deviation of the original object 
from these directions is insignificant. The base direction is set 
in Base angle. The accepted deviation is determined 
automatically by the Approximation Accuracy parameter value. 

 Enter an angle specifying the base direction of 
orthogonalization. 

- or – 

 Click the button at the box name and specify two points on 
the image. The angle value between the line connecting these 
points and the axis X will be shown in the Base angle. 
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Trace Tab 

This tab represents parameters controlling the procedure of tracing polylines, 
described on page 165.  

 

Parameter Description 

Line Follow 
Orthogonalization  

If this option is on, then the line following tracing automatically 
aligns segments of created polylines perpendicular to each 
other. Segments become either perpendicular or parallel with 
the base angle; if they are not too skewed from the main 
direction. The base angle is set in the Base angle box of the 
Options tab. If the Auto checkbox is on, then the program 
automatically defines the base angle by the direction of the 
polylines longest segment. The Approximation Accuracy 
setting in the Options tab controls the maximum angle of 
deviation that segments can have in relation to the Base angle 
and still fall under orthogonalization. 

Use this option when tracing raster objects consisting of 
perpendicular segments, for example when tracing buildings 
on plans. 

Auto estimate base 
angle 

Sets the mode which automatically defines the base direction 
of polyline segments orthogonalization. The base angle for 
each traced polyline is defined separately. 
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Parameter Description 

Base Angle  Enter an angle specifying the base direction of 
orthogonalization. 

- or – 

   Click the button at the box name and specify two points on 
the image. The angle value between the line connecting these 
points and the axis X will be shown in the Base angle. 

Setting on Auto estimate base angle has priority over this 
option. 

Auto Detect 
Direction 

Sets the mechanism by which the program will automatically 
define the direction of tracing. After the program reaches a 
node, it tries to find the following raster line part, which is an 
extension of the traced object. 

Pause Sets a period in seconds, during which a segment to extent 
tracing should be chosen when the Auto Detect Direction 
mode of tracing is on. Unless the user manually specifies 
another extension during this time interval, the program will 
continue tracing in the automatically selected direction. Setting 
Pause to 0 disables this option. 

Place vertex on 
nodes 

When this checkbox is on, the program when tracing polylines 
inserts vertices at intersections of a generated vector polyline 
with raster objects (nodes).  

Auto Extend 
vectors 

This feature simplifies forced selection and tracing of arcs and 
lines. 

While recognizing a line, click two arbitrary points on it and 
RxSpotlight automatically extends the resulting line to its 
endpoints. 

While recognizing an arc you can click three arbitrary points 
on it; and RxSpotlight automatically extends the resulting arc 
to its endpoints. 

Export single 
contour 

This checkbox tunes the performance of outline tracing (see 
page 164). If the checkmark is present, then tracing creates 
the outer contour of the object. If the checkmark is absent, 
then tracing yields the outer contour and the inner one, if there 
are “holes” in the raster object. 
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Controlling Properties of Created Objects 
Using the Separate tab of the Conversion Options dialog box, users can control the 
properties of created vector objects, calibrate the widths of obtained vector objects, 
place vector objects corresponding to raster lines from the specified ranges of width 
on new layers and/or assign various colours to created objects. 

 

Separate Tab 

Parameter Description 

Use table If this checkbox is on, then the program places objects on 
specified layer, the width of lines is set by the table values. 

New interval  

  

Allows users to create and delete intervals of widths in the table.  

Width table  Allows users to edit the intervals of objects widths, and to assign 
colour and layer of the line to an interval. 

Width table 

To tune the width table correctly, define width interval boundaries so that the objects 
obtained after vectorization of raster lines with the same width fit in the same width 
interval. 

The width table can contain any number of width intervals. Each interval is defined by 
two values – a lower and high width boundary which recognized objects must fall into 
the specified interval. Width, colour and layer are defined to each interval, and these 
properties are assigned to the objects that fall into each interval according to its width. 
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Real raster lines widths vary around the true value. For example, if vectorizing raster 
lines with a width of 0.25 mm, objects with widths from 0.18 to 0.33 mm can be 
obtained, and lines with width of 0.5 mm turning into vector objects with width from 
0.35 up to 0.7 mm. Users can set widths, colours and layers for the created intervals 
and check out the operation of vectorization or tracing tools with the use of the 
obtained width table (with the Use the table checkbox on). All intervals are set within a 
width range from zero to the value of the parameter Max Width specified in the 
Options tab of the Conversion Options dialog box.  

 

To create a new interval in the width table 

 
Enter a value for the upper boundary of the width interval into New interval, 
press the Create interval button. 

Users can also create an interval by clicking on the appropriate position in the width 
table ruler. 

 

An arrow appears on the ruler indicating the upper boundary of the created interval. 
The existing interval is divided into two intervals. The properties of a new interval are 
inherited from the existing one. 
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Users can modify boundaries of all intervals except the highest and the lowest, which 
always have the values Max Width and 0 respectively. Changing the boundary of one 
interval affects boundary of an adjacent interval. If the upper value of a boundary is 
set to be greater than the upper value of an adjacent interval, then this interval will be 
deleted. Intervals can also be deleted using the Delete button. 

Boundaries and delete intervals can be changed by moving the arrow symbols on the 
ruler. 

 

To change the interval boundary 

Click in the width table on the line corresponding to the required interval, click on the 
box in the Start or End columns in the highlighted line and change the value of upper 
or lower interval boundary.  

-or- 

Drag the corresponding arrow symbol on width ruler. 

All intervals except the default one can be deleted. 

To delete an interval from the width table 

Select an interval in the width ruler or from the list, and then click  - Delete 

interval button. 

-or- 

Indicate the left (lower) interval boundary on the width ruler and drag it to the left 

across the boundary of the nearest interval – the adjacent interval will be merged, and 
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the created interval will obtain a new bottom boundary. If it is dragged across the right 
(upper) interval boundary, then the interval will also be deleted. 

Modifying interval properties 

The following properties are set to each interval: source width boundaries, width of 
created lines, colour and layer. These properties are assigned to objects with widths 
within this interval. 

 
The width table line: Start, End, checkbox, width, layer and colour. 

To keep widths unmodified 

The value of Width will be assigned to all vector objects with width within the specified 
interval if the checkbox of width assignment is on. 

To avoid the lines within the interval being rounded to a predefined width, specified in 
the Width box, remove the checkmark in the corresponding row of table. 

To assign width to an interval 

Click on a width table line appropriate to the required interval, click on the Width 
column and enter width value. 

To assign layer to an interval 

Users can assign any name of layer to an interval or select the Current value. All 

vector objects, with width falling into the specified interval, will be created on the 
specified layer. If there is no layer with the specified name, then such a layer will be 
created during tracing (vectorization). On choosing Current, the objects will be created 
on the current layer. 

Click on the width table line corresponding to the required interval; click the Layer 
column in the list. Select existing layer from the list or enter a name of a new layer, 
which will be created during vectorization. 

To assign colour to an interval 

Click on the width table line corresponding to the required interval; click the Colour 

column in the list. Select colour from the list or specify in the dialog box opening by 
clicking Other. Users can assign any colour to an interval, including the values 
Current, By Layer and By Block. All vector objects with widths within the specified 
interval will inherit the specified colour. If Current is chosen, then the objects of the 
specified interval will be created with the current colour. 
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Saving Width Table Settings 
Width table settings can be saved in a template file for further use (along with other 
settings of Conversion Options dialog). 

To save width table settings 

1. Click on the Template button; choose Save from the list. 

2. A dialog box for saving the template file will open. 

3. Specify the file name and click OK. By default the file will be saved to the 
Recognition parameters subfolder of the RxSpotlight root folder. 

To load width table settings 

1. Click on the Template button and choose Load from the list. 

2. A dialog box for loading template files will open. 

3. Choose the required file and click OK. 

Colour tracing 
All tracing techniques and methods can be used on colour images, including tracing in 
Erase and Smooth modes. Colour tracing is supported by additional options: colour 
accuracy slider and adaptive raster erasing switching button, both placed on the 
Colour Accuracy toolbar. 

 
The leftmost position of Colour accuracy slider (0%) corresponds to the coarsest 
recognition; the rightmost (100%) corresponds to the finest possible. 

When the adaptive raster erasing switching button is on, tracing in Erase and Smooth 
modes ends by adjusting background colours and filling the erased raster fragment 
with the most appropriate colour, from the point of view of the program; otherwise the 
default image background colour is used to replace erased raster areas. 

More detailed information about the Colour Accuracy toolbar can be found on page 
311 where the raster Colour Flood Filling procedure is described. 

Vectorization 
Automatic vectorization is a procedure of generating vector objects from original 
raster images. There are two types of vectorization: recognition of raster entities and 
approximation of raster objects. 

The vectorization algorithms of the first type search for raster image fragments, which 
can be represented as basic geometry such as lines, arcs, circles and hatches, and 
create appropriate vector objects. These algorithms recognize raster analogues of 
vector entities. RxSpotlight uses a set of independent recognition algorithms, which 
can be used in various combinations, thus enabling users to obtain a vector image of 
optimal structure. 
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RxSpotlight recognizes objects of the following types: points, lines, circles, arcs, 
polylines, hatches, texts and symbols. The program can be trained to recognize new 
texts and symbols. 

When vectorizing lines, circles, arcs and polylines, the program can recognize the line 
style of objects, and also arrows on lines and arcs. Orthogonal alignment of lines 
which have a small deviation from either the horizontal or vertical axis can be forced. 

The approximating algorithms are used to vectorize arbitrary raster objects. Users can 
also approximate raster objects by outlines if they cannot be recognized as lines, arcs 
or circles. 

Vector objects corresponding to raster lines of various widths on different layers can 
be placed or different colours assigned to them. 

Users can also tune recognition manually or use one of the standard sets of 
predefined parameters – recognition templates. 

Running vectorization  

Vectorization can work on raster selection, or on a group of images. If a raster 
selection is created, then the vectorization once started will affect this selection alone. 

If raster selection has not been made and several images are inserted in the current 
drawing and they are available (visible, located on unlocked layers), then all of them 
will be vectorized. 

Vectorization also works on images with a clipping boundary. Using this feature, the 
vectorization area on any image can be limited by setting its clipping boundary. 

 For information on clipping boundary see page 130.  

To perform vectorization 

1. Tune vectorization options and parameters, if necessary (the rest of this chapter 
describes this tuning; recognition parameters tuning is described on page 182). 

2. Specify images to be processed. 

3. Run vectorization using one of the following methods: 

 Choose Raster2Vector from Convert menu or press the  button on the 

Raster to Vector toolbar.  

 The vector objects will appear over of the original raster. 

4. To interrupt vectorization, press ESC or Cancel button. 

Setting Up Vectorization   
Tune vectorization using the Conversion Options dialog box. The main vectorization 
parameters are set in the Recognition and Options tabs. If the search and recognition 
of the texts and symbols algorithms are used, then also set up parameters in the 
Texts and Symbols tabs, described further in this chapter. 

The widths of objects obtained after vectorization can be approximated to specified 
values, and also be placed on various layers and various colours assigned. These 
operations are made with the Separate tab. The procedure of setting up the 
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parameters of this tab is described in “Controlling Properties of Created Objects” on 
page 176. 

To set up vectorization parameters 

1. Open the Conversion Options dialog box using one of the following methods: 

 Choose Conversion Options item from the Convert menu or click 
 
button on 

the Raster to Vector toolbar.  

2. Specify the required parameters, browsing through dialog tabs if necessary, then 
click OK. 

 
 

Recognition  Tab 

In this tab, users can select a set of algorithms to be used for raster image 
vectorization.  

To vectorize raster images of different type, various sets of geometric entities need to 
be used. For example, to vectorize maps or schemes the use of polylines would be 
suitable, approximating raster curves of arbitrary form; to vectorize engineering 
drawings algorithms that create lines, circles, arcs should be used – in this case a 
vector figure obtained will correspond exactly to the original drawing. 

To make recognition of different image structures more versatile, RxSpotlight supports 
a set of vectorization algorithms that recognize raster analogues of vector entities and 
generate approximate vector objects of the corresponding types. One or more 
algorithms can be used in one operation. 
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On the right side of the Recognition tab there is the Entities 
tree. On the first level there are recognition algorithms. To 

turn on the necessary algorithm, on a checkmark near its 
name. On the second level of the tree there are additional 
functions and parameters of corresponding algorithms. 
Algorithms that have such extra parameters of recognition 
are marked with “+”/”-“ symbols: if the second level is hidden 
"+", otherwise "-". 

To get access to the hidden additional parameters of the 
algorithm, click on the "+" to the left of its name. 

The vectorization process is directly influenced by setting of the geometrical 
parameters of recognition, which are located in the Options tab of this dialog box. 

Points 

This tool is intended for recognizing elevations marks on geodesic plans and similar 
images. 
RxSpotlight will recognize a raster point with a size not less than 2x2 pixels (objects 
smaller than this are considered as speckle and ignored), and which maximum 
vertical and horizontal extents are not greater than Max Width value.  
A point-object can be only recognized in automatic mode. 
Do not switch this mode on when recognizing images of poor quality or images 
containing many speckles, since speckles can be recognized as points. 

Lines 

Turns on the tool for line recognition, the result is that line entities are created. 

  

The figure shows vectorization results 
when only the Lines tool is on. The 
original raster fragment is shown on the 
left; the figure on the right represents the 
vectorization results when objects width 
display option is off. 

There are the following additional parameters: 

Arrows If this option is on, then RxSpotlight searches for raster analogues 
of dimension lines (lines with one or two arrows at the end points) 
and, if the arrows are found, then RxSpotlight stores them as Start 
or End Marker property of the line. 

Line Types If this option is on, then RxSpotlight recognizes dashed and dash-
dotted straight lines, creating vector lines with the corresponding 
line type. 
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This tool is influenced by the following options of the Options tab: 

It recognizes raster objects with a length greater than the value of the Min length 
parameter and with a width less than the value of the Max width parameter.  

The Max break parameter sets the maximum length of ignored raster line breaks.  

The Approximation parameter sets the accuracy of raster lines approximated by 
vector objects. If the raster quality is bad, then reduce the parameter value so that the 
tool can recognize raster objects with significant distortions of form. 

If the Orthogonalization option is on, then recognized segments are aligned both 
parallel with and perpendicular to the direction specified in the Base angle field. The 
segments with small angles of deviation from appropriate directions are aligned. The 
accepted value of deviations, at which the orthogonalization is performed, is 
determined by the Approximating parameter. The closer this parameter is to the Low 
value, the larger the deviation can be. 

Arcs and Circles 

Sets the tool for raster circles and arcs recognition. 

 

The figure shows the results of vectorization with 
the help of Lines and Arcs and Circles. The 
original raster fragment is shown on the left; the 
figure on the right represents vectorization 
results when object width display is off. 

There are the following additional parameters: 

Arrows If this option is on, then RxSpotlight Pro searches for raster 
analogues of dimension arcs (arcs with one or two arrows at 
endpoints) and, if the arrows are found, creates arc with arrows. 

Line Types If this option is on, then RxSpotlight Pro recognizes dashed and 
dash-dotted lines, creating vector objects with the corresponding line 
type. 

This tool is influenced by the following options of the Options tab: 

It recognizes raster circles and arcs with lengths greater than the value of the Min 
length parameter and with widths less than the value of the Max width parameter. 

The Max break parameter sets the maximum length of ignored raster segment 

breaks.  

The Approximation parameter sets the accuracy of raster segments approximated by 
vector objects. If the raster quality is poor, then reduce the parameter value so that 
the tool can recognize raster objects with significant distortions of form. 
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Polylines 

This tool approximates central lines of raster objects by polylines. The tool creates 
polylines consisting of linear segments only. This can be used individually (or with the 
tool Outlines) for vectorization of maps and other images consisting of arbitrary lines 
(curves drawn by hand). 

There are the following additional parameters: 

Line Types If this option is on, then RxSpotlight Pro recognizes dashed and 
dash-dotted lines, creating polylines with corresponding line 
types. 

Create vertices 
on intersections  

If this option is on, then the tool creates vertices on polylines 
intersections. 

This tool is influenced by the following options of the Options tab: 

Max length defines the maximum length of a recognized segment that will be added to 
the polyline. The longer segments are not added to the polyline. This allows users, for 
example, to trace on maps curved isolines that are crossed by coordinate lines; the 
tool automatically stops on the intersection of traced isolines with the long straight line 
of grid. 

The tool approximates raster lines with a width less than the value of the Max width 
parameter. 

The Max break parameter sets the maximum length of ignored raster segments 
breaks.  

The Approximation parameter sets the accuracy of approximating raster segments by 
vector polyline. 

Outlines 

This tool is used to approximate outlines of flooded areas by polylines. It creates 
closed polylines, approximating boundaries of raster objects. The boundary polylines 
consist only of straight segments. 

 

The figure shows the results of vectorization with 
the Outlines tool only. The original raster 
fragment is on the left; the right figure illustrates 
vectorization result. 

This tool is influenced by the following options of the Options tab: 

The tool approximates raster lines with a width greater than the value of the Min width 
parameter. To obtain outlines of all raster objects, set the Max Width parameter to 0. 

The Approximation parameter sets the accuracy of raster segments approximated by 
vector outlines. 
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Hatches 

Set the tool for hatch recognition. RxSpotlight Pro recognizes simple raster hatches 
and creates blocks, consisting of lines. A simple raster hatch is a set of parallel raster 
lines. The Hatches tool searches for hatches only if the Lines tool is on. 

The additional parameters are accepted angles of raster lines forming raster hatches. 

Text Areas 

Set the tool for text recognition. RxSpotlight Pro distinguishes areas on the image with 
raster texts and applies to the retrieved texts the operation set as the additional tool 
parameter. 

Setting up of raster texts search options and the OCR module is made in the Texts 

tab of the same dialog box, the setting up procedure is described further in this 
chapter. 

 

None - do not produce raster text vectorization. Areas, 
containing found raster texts are ignored. 

Text Areas - creates rectangles bounding raster texts. 
These areas are not vectorized. Vector texts can be 
entered manually with the help of the review and 
correction procedure of recognized texts described below 
in this chapter. 

Polylines - approximates central lines of the raster texts 
with polylines. 

Outlines - approximates boundaries of the raster texts by 

polylines. 

OCR - recognizes raster texts and creates text objects. 

Raster – find raster texts and creates raster image with 
this text. 

Inflate Size (%) – increases the found text area size in 
percent relative to the original. 

The tool uses the values of the Height Table list of the Options tab as maximum 
height of uppercase raster text characters. See more information on this and other 
parameters that influence text recognition on page 189. 

Symbols 

Set the tool for raster symbol recognition with specified samples. The tool only works 
if the tool Lines and Arcs and Circles are on. Setting up of the tool operation is made 
in the Symbols tab of the same dialog box as described on page 196. 
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Options Tab 

 
RxSpotlight Pro uses information on the sizes of raster objects, which is set in the 
Options tab, to define the optimal performance of algorithms that should vectorize a 

given raster object. 

Parameter values can be entered from the keyboard or their values measured on the 
screen. 

To measure parameters value on the screen 

1. Click on the button near the appropriate input box in dialog (  or ). 

2. Specify two points on the image. 

During measurement the program draws a rubber line connecting the indicated 
points. When the measurement is completed, the value shows in the box. 

Min Length Sets the minimum length of a raster fragment, which should be 
recognized as a line, circle or arc in the vectorization process. 

Specify the value of this parameter equal to the length of the 
shortest raster line or diameter of the smallest raster circle (arc). 

To the measure on the image draw a rubberline along the smallest 
raster line, arc or circle. The value of Min Length will be equal to 
the length of the line covering black (foreground) dots on the raster 
line. 
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Max Width Sets maximum width of the raster object, which should be 
recognized as a line, arc or polyline. 

Specify the value of this parameter slightly greater than the 
maximum width of a raster line to be vectorized using the 
algorithms: Lines, Arc and Circles or Polylines. 

If the program does not vectorize raster segments, circles or arcs 
on the image, then increase this value. If the program does not 
approximate flooded raster areas with outlines, then reduce this 
value. 

During measurement on the image draw a rubberline 
perpendicular to the widest raster line to be recognized using the 
tool Lines or Arcs, or to approximate with the Polyline tool. This 
value will be equal to the length of the drawn part of the line which 
crosses the raster line. 

Max Break  Sets the maximum accepted length of ignored breaks of raster 
lines. 

If a segment (arc) on the image that is broken into several parts  
should be  recognized as one vector object, then specify this value 
as greater than the largest distance between any two adjacent 
parts. The break will be eliminated, and the parts of the vector 
segment (arc) will be connected. 

When measuring on the image draw a rubberline along the largest 
break of the raster segment (arc). This value will be equal to the 
length of that part of the line covering white (or background) dots 
on the raster line. 

Arrow Size Width and length of objects to be recognized as an arrowhead at 
the end of line object. To specify dimensions of arrowhead enter the 
values separated by comma or press the Measure button and draw 
bounding rectangle around the arrow. 

Text Height Specify this value equal to the maximum height of raster text 
symbol of the upper case. 

To measure on the image, draw a rubberline above the raster text. 
The Text Height value will be equal to the distance between the 
first and the last points of the image within the drawn line. 
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Texts Tab 

Setting up the options of RxSpotlight Pro OCR module is performed in the Texts tab.  

 

The processing of raster texts takes two steps. First, RxSpotlight Pro searches for 
raster fragments containing raster texts. These fragments are named Text Areas. 

Then RxSpotlight Pro applies the operation that is set as additional parameter of the 
tool Text Areas in the Recognition tab to the found raster texts. 

The most complicated operation is the raster text recognition using either the built-in 
module of texts recognition (OCR) or an additional module from a third-party. 

The RxSpotlight Pro OCR module recognizes raster texts and creates RxSpotlight Pro 
text objects. In addition height and rotation angle of the created texts are calculated. 

Standard shipment contains two files of OCR characters templates (DEFAULT.OCR 
and CYRILLIC.OCR), using which the program recognizes the characters of the 
English alphabet, digits, punctuation marks and special characters (the first half of 
ASCII table). the OCR module can also be trained to recognize any other text 
characters. 

If the OCR cannot recognize a character, then it is substituted by the "~" (tilde) in the 
text line. If none of the word characters are recognized, then the OCR does not 
generate a text object. 
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Text Recognition Options 

Orientation – defines the accepted raster text operation. 

Horizontal only Searches for horizontal text lines. The text areas will only be 
horizontal. 

Horizontal and 
Vertical 

Searches for horizontal and vertical text lines. The text areas 
will only be horizontal and vertical. 

Arbitrary Searches for skewed text lines. The choice of this option can 
lower the speed of text areas searches. 

Overlapped by Graphic 

If this option is on, then RxSpotlight Pro searches for raster texts crossing other raster 
objects. The choice of this option can lower the speed of text areas searches. 

Standalone Letters 

Allow searching for standalone text characters. If this option is off, then RxSpotlight 
Pro will not find single text characters, and will not identify graphics objects as text, 
such as markers, dash, etc. 

Patterns 

To customise the OCR, specify a set of word patterns. A pattern is a rule specifying 
an allowed sequence of characters within one recognized word. This list contains 
definitions of accepted word patterns. RxSpotlight Pro OCR can generate only words 
which correspond to one of the specified patterns (if Patterns is checked in Texts tab 
of Conversion Options dialog). 

The Add and Delete buttons 

  
Used to edit the list of definitions of word patterns. 

Here is a formal description of word pattern definition: 

" [% [length] character type] || [letter]] … " 

 [%] Beginning of character sequence definition 

[length] Any decimal number; absent if length is variable 

[type] Character type (D,E,e,N,n,S) 

[letter] Standalone letter 

Character type is specified in the following way: 

D Digits 

E The upper case letters of English Alphabet 

e The lower case letters of English Alphabet 

N Capital letters of national alphabets 

n Small letters of national alphabets 

S Special characters (signs plus and minus, sign of equality and etc.) 



RxSpotlight User Guide 
 

191 

%% Standalone characters "%" 

[characters] Standalone characters  

For example: 

 The pattern "Rz%D" generates words, which start with "Rz", followed by any 
sequence of digits, for example, "Rz40", "Rz2.5", "Rz5000". 

 The pattern "%1N%n" generates words of the national alphabet with the capital 
first letter. 

 " %D %% " generates percent numbers of the following pattern: 
“20 % ", " 1100 % ", " 12.50 % ", etc. 

 "%DV" allows the generation voltage numbers of the following pattern:  
"5V", "220V", "13.8V", etc. 

Height Table 

Possible text heights can be specified in this box. If the checkbox is on, then during 
the generating of the recognized texts the OCR module will create text objects with 
heights from this list, rounding the recognized height to the nearest value specified in 
the list. 

Character template libraries 

Specifies the character template libraries that will be used during recognition. 

Character templates are topological models of text characters (letters, special 
symbols etc.), with which raster text characters are recognized. 

The list contains DEFAULT.OCR and CYRILLIC.OCR files, included in the standard 
shipment. Using the "default" file, the OCR module can recognize characters of the 
English alphabet, digits, signs, punctuation marks and special symbols (the first half of 
ASCII table). CYRILLIC file enables recognition of all the above mentioned plus 
Russian characters. 

 Users can also train the OCR to recognize other text characters. See 
“Training OCR” on page 191. 

During the training process, the OCR creates character templates and writes them in 
the library. These can be saved as character templates in a new or existing library file. 

 If using a user created file of character template libraries, then the OCR 
will recognize characters described in this file only. 

To place on layer 

Use this box to set the name of a layer, on which the texts obtained as a result of the 
OCR operation will be placed. 

Training OCR 

Using the standard RxSpotlight OCR features, the characters of the English alphabet, 
digits, punctuation marks and special symbols (first half of ASCII table) can be 
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recognized. These character templates (topological models) are stored in special files 
of character template libraries. These files are by default allocated in the OCR folder 

of the RxSpotlight Pro root folder. 

The RxSpotlight OCR module can be trained to recognize any character. For this 
purpose users can add new character templates to one of the available libraries or to 
create their own library. 

During training RxSpotlight creates templates (topological models) of text characters 
and places them in the open library of character templates. These can be replaced by 
any template in the existing library. Several templates can correspond to one text 
character. 

To create a new or to change the existing character template library 

 
1. Choose Train OCR from the Convert menu or press the button on the 

Raster to Vector toolbar. 

The following dialog box appears:  

 

 

2. To create a new library of characters, press the New button. 

- or – 

 
To add new templates to the existing library, press the Open button, select 
from the dialog box the desired library file and press OK. 

3. Create new, replace or delete character templates. 

 
4. Save the library in its own file, or in a new one, using the Save button. 

 Click OK. 
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The creation, replacement and deletion of the library templates are made with the 
help of the buttons of the dialog box toolbar and the Character input box. 

   Tools for raster character selection 

  Add and Delete buttons 

Before beginning the training open the Train OCR dialog box and load the existing 
library or open a new one. 

To create a new character template 

1. Enter a character into Character box. 

2 Select the raster symbols relating to the specified character with one of the 
selection tools. 

  Select by picking. Click on the standalone raster character. 

 Select by frame. Draw a frame around the raster character. 

 Select by polygon. Specify the vertices that encompass the raster 

character; press ENTER to complete the selection. 

3. Click the Add button. 

The program will create a topological template of the character and add it to the 
appropriate place of the template library. 

The left part of the dialog box displays the contents of the current template library. 
This box shows the sections of the template library: digits, English capital (uppercase) 
letters, English small, special symbols, national capital and national small. Closed and 
nonblank sections are marked with "+". 

 

By putting a checkmark to the left of the section name, all 
templates located in this section will be on-line. Removing 
checkbox cancels the link to all templates of this section. 
Any section can be opened by clicking on "+" and set on/off 
necessary templates located in this subfolder, 
setting/removing the checkmark at the left of the template 
name. 
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Several templates can be set for each character. The example for “a” is shown in the 
figure below. In this case the character is marked with "+". Open a set of templates 
related to this character by clicking on "+" then select a template by clicking on it. After 
a template is chosen, its pictogram is shown on the right part of the dialog box. 

 

Templates can be turned off – in this case they will not be used for recognition - or 
deleted. 

To delete a character template 

1. Select a template. 

2. Click the Delete button.  

Editing recognized text   

The RxSpotlight OCR checks and highlights by bounding rectangles all created vector 
texts to enable users to review and edit the texts using a special procedure. The 
edited (or entering a new) text object can be accepted. The acceptance of the 
recognized text removes the checkmark and excludes it from texts that require 
editing. 

The recognized texts are edited using the special dialog box with the toolbar. 
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The Text Correction toolbar contains a text edit box and the buttons: 

 
Finds first text; 

 
Finds previous text; 

 
Finds next text; 

 
Hides / Shows OCR text; 

 
Deletes OCR text; 

 
Accepts text; 

 
Selects all recognized text. 

To edit recognized texts  

1. From the Convert menu select Edit OCR Texts. 

If the program has not detected any recognized text, then a message to that 
effect is displayed. The command‟s execution is done. 

Otherwise the program selects the first of the recognized texts and pans the 
image so that this text is shown in the screen centre and opens the dialog box, 
which shows the first text. 

2. To modify a text line, enter a new value in the edit box. 

Using the Inspector window size, font and other properties of text objects can be 
changed. 

 

To accept the edited text, press the Accept button. The program will exclude 
this text from the recognized text set and will automatically proceed to the 
following recognized text. 

 
Use Delete button to delete text. 

   Use the navigation buttons to make the text current. 

 
Use the Hide Text button to hide or unhide recognized text to 
better seeing underlying raster text. 

3. Repeat step 2 for all recognized texts. 

To change or delete properties of all recognized texts  

 
Choose Selects all to select all recognized texts. Use the Inspector window to 
change size, font and other properties of all text objects. Pressing Delete 
button will delete all texts. 
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Using OCR external modules 
RxSpotlight allows for using OCR modules produced by third party companies. The 
procedures of installing these modules as well as working with them are described in 
the special manual. 

Setting up Symbol Recognition Options  

The procedures of selection, tracing, and automatic vectorization of raster characters 
are based on the algorithms of raster character recognition by vector templates. 

Raster symbols can be rotated and scaled in relation to the sample symbol saved in 
the template; the set of parts with which a sample is composed and saved in the 
template may differ from the set comprising the recognized object. The basic 
comparison criterion is the resemblance of the symbol and template geometric 
characteristics - relations between composing object size, link types, angle value, and 
so on. 

 

The Symbols tab of the Conversion Options dialog box 

Vector templates need to be created and saved for raster symbol recognition. Also 
before applying any of the procedures that involve recognition, the necessary 
templates should be attached in the Symbols tab of the Conversion Options dialog 
box. In the same tab specify other parameters for symbol recognition. 

 The procedure for symbol template creation is described in “Tuning Symbol 
Recognition Template Library” chapter on page 198. 
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Symbols tab 

The table provides a description of the symbol recognition parameters. 

Parameter Description 

Srtl path Defines the path to Symbol Recognition Template Library file 
which stores symbol templates and the information on what 
symbols should be found and with what they should be replaced. 

Strategy Defines the strategy used for symbol recognition. The choice of 
strategy influences the balance of speed/accuracy of the 
algorithm. There are three strategies: Fast, Standard and Smart. 
The Fast strategy has the highest speed of the raster symbol 

analysis, but it may not find symbols even very similar to the 
template. The Smart strategy operates at the lowest speed, but 
yields the most correct results. The Standard strategy is used by 
default. 

Fixed scale  This parameter sets the tolerance for recognizing symbols of 
various sizes. If the checkbox is on, then only the symbols 
whose sizes are proportional to templates with the factors set in 
the numerical box will be recognized. When replacing the 
recognized raster symbols, this factor will be used for scaling the 
inserted vector symbol. If the checkbox is off, then all raster 
symbols will be checked on tolerance, and the scaling factor on 
replacing will be calculated automatically. In this case the 
program operation may be slowed down. 

Accuracy This parameter defines the accepted deviation of raster symbol 
geometry compared with to the sample. At High values, the 

program will only recognize symbols that are very close in form, 
scale and orientation to the sample. At Low values more 
symbols will be recognized but the probability of erratic 
recognition increases. 

Orientation Sets possible angular deviations of raster symbols from the 
specified templates. If the value Horizontal is selected, then only 
the symbols having the same orientation as the specified 
templates will be recognized; if Horizontal and Vertical is 

selected, the symbols rotated by an angle 90° will also be 
recognized; if Arbitrary is selected, the symbols rotated by 
arbitrary angles will be recognized. Note that the last option 
considerably slows down the operation of recognition algorithms. 
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Parameter Description 

Standalone 
Symbols  

This checkbox defines whether the symbol containing raster 
objects excluded from the template will be recognized. If the 
checkbox is empty, then all symbols matching the template will 
be recognized, even if they are crossed by raster objects that do 
not match objects, set in the template. Otherwise only symbols 
that are not crossed by other objects will be retrieved. 

 

Tuning Symbol Recognition Template Library 

The Symbol Recognition Template Library (SRTL) – is a library of symbol templates 
that used for symbol recognition and replacing in tracing, automatic vectorization, 
object selecting and also in Search and Replace as alternative method. 

The procedures of selection, tracing and automatic vectorization of raster symbols are 
based on algorithms of raster symbol recognition by vector patterns. These vector 
patterns should be created before performing recognition activities. 

 

The SRTL is intended for storing the information on 
what symbols should be found and with what are 
replaced. Every SRTL represents a collection of vector 
and raster Replace and Search items. To every 
Replace item in library put in conformity one or the 
several Search items. 

The Search item is a vector or raster template that   
should be recognized. The Replace item is a vector or 
raster template, which should replace the 
corresponding to it Search item. 

 

Every RxSpotlight command that uses SRTL tries to find a regular Search template in 
the document or on the raster image. In case of success, command replaces 
recognized symbol with the corresponding Replace template. 

Symbol Recognition Template Library editor overview 

The SRTL can be trained to recognize any raster or vector symbol. For this purpose 
users can add new symbol templates to one of the available libraries or create an 
entire new library. 

Using the Symbol Recognition Template Library editor you can create, save in *.SRT 
file for future use, open and edit these libraries. The user can select to exclude 
symbol templates from recognition process by simply deactivating them. You can 
import obsolete symbol template formats such as *.SST. 

To open SRTL editor choose Edit Symbol Recognition Template Library:  from the 

Convert menu or press the  button on the Raster to Vector toolbar. 
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The left part of the dialog box displays the contents of the current template library. 
This box shows the topological tree of Replace and Search templates. Collapsed 
Replace items are marked with "+". Open a set of Search items related to the Replace 
item by clicking on "+". Select an item by clicking on it. After an item is chosen, its 
content is shown on right part of the dialog box. 

 

To include a template in recognize process set a 
checkmark to the left of the item name. Removing 
checkmark excludes templates and all sub-templates 
from this process. 

 The Replace item will be ignored during 
symbol recognition if all its Search items are 
excluded. 

On the left there is an example part of the SRTL, which 
included only Replace_2 with Search_1 items. The 
Replace_4 item will be ignored because of excluded 
Search_1 item. 

SRTL basic operations 

Choose Edit Symbol Recognition Template Library from the Convert menu or press 

the  button of the Raster to Vector toolbar to open SRTL editor. The current 

library will be shown in SRTL editor dialog that appears. 
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Any SRTL could be saved to or opened from *.SRT file. To save current library into a 

file click the  Save button and specify name for .SRT file in the appeared Save 

dialog. Use the  Open button to open existing library and the  New button to 

create a new one. 

 Since libraries are stored in separate files, these can be deleted and 
copied, using standard operating system tools. 

To insert a symbol template saved in an obsolete format, click the  Import button 

and choose the *.SST file. The new one Replace item with corresponded to it Search 
item will be included into the current library. 

Vector symbol template 

Vector symbol templates are marked with  sign inside SRTL tree. Vector symbol 

templates are used for recognizing raster symbols in such commands as symbol 
automatic vectorization, symbol tracing, symbol selecting and Search and Replace. In 
Search and Replace vector template can be used not only for finding raster symbols, 
but for vector too. 

Before defining such a template for raster symbols recognition, create vector objects 
resembling the raster symbols. This can be done through vectorization, tracing or 
simply by drawing vector objects. 

The set of such vector objects is used as a vector template. The template can consist 

of any set of objects, but for recognition only objects like line, arc, circle and polyline 
are used. The objects of a template can also be united in the block. 

New vector template could be added to SRTL as Replace item or as Search item. 
When “Add Replace item” was performed, SRTL create new Replace item and 
associated new Search item with the same topological structure. The Search item 
could be added only to existing and selected Replace item. 

Search item can have connecting lines. The setting of connecting lines increases the 
accuracy of symbols recognition, due to more exact and flexible description of the 
symbol geometry. 

The connecting line is a vector object included in the template. One end of the 
connecting line joins the other objects in the template; the other end is free. The 
length of symbol parts corresponding to connection lines can be arbitrary. What 
matters are the position of points at which these objects join other symbol objects and 
contiguity angles. 
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The figure illustrates a symbol template where the connecting lines are worth adding 

An arbitrary number of connecting lines can be specified. If the connecting lines are 
set in the symbol template, then only those symbols will be retrieved which have 
raster straight lines similar to the symbol‟s, with the same points and at the same 
angles, as on the template; their lengths can differ from the length of the connecting 
line set in the template. 

To create new vector symbol template 

1 Draw vector objects, approximating raster symbols, or create them using 
vectorization or tracing procedures. Because of SRTL editor window is 
modeless, these operations can be done even this dialog is open. 

 It is recommended to unite objects of a vector template in a block. After 
vectorization with symbol recognition or after the Search and Replace 
operations all named blocks can easily be replaced with other graphic 
symbols, for example, by applying the standard procedure of block 
redefinition. 

2 Select created objects, using standard vector selection tools. 

3 To add selected vector objects as Replace item click the  Add Replace Item 

button. The selected objects will be included as new symbol template into SRTL. 
The new one Replace item with corresponded to it Search item will be included 
into the current library. 
To add selected vector objects as Search item select appropriate vector Replace 
item in the left dialog window, because the Search item could be added only to 
existing Replace item. It is not possible to add vector symbol template as a 

Search item for a raster Replace item. Click the  Add Search Item button. 

The selected objects will be included as new symbol template into SRTL. The 
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new one Search item corresponding to the specified Replace item will be 
appeared in the left dialog window. 

4 Select the newly added Search item in the left dialog window. 

5 Click the  Select Connection Lines button. Click in the right dialog window 

on those symbol template objects, which should be the connecting lines. The 
connecting line is highlighted with red colour. If the object is assigned by a line of 
connection by mistake, then click on it once more to deselect. The object colour 
will be changed to the original one. 

 Note that the line of connection should be a segment with one end 
adjoining to template objects, and another being free. Otherwise, the 
program will not assign the object to the connecting line. 

Raster symbol template 

Raster symbol templates are marked with  sign. These templates are used by the 

Search and Replace tool as Search or Replace items. 

When raster symbol template is added to the library as Replace item, SRTL does not 
automatically create a corresponding to it Search item. This should be done manually. 

A raster symbol template could be added as Search item for raster or vector Replace 
item. However, it is not possible to add a vector symbol template as a Search item for 
a raster Replace item. 

To create new raster symbol template 

1 Open a raster image and select some raster objects, using standard raster 
selection procedures. Because of SRTL editor window is modeless, these 
operations can be done even while this dialog is open. 

2 To add selection as Replace template click the  Add Replace Item button. 

The raster selection pattern will be included into SRTL. 
To add raster selection as Search template select appropriate vector or raster 
Replace item in the left dialog window, because the Search item could be added 

only to existing Replace item. Click the  Add Search Item button. The raster 

selection will be included as new template into SRTL. The new one raster 
Search item corresponded to specified Replace item will be appeared in the left 
dialog window. 

SRTL editor dialog buttons and controls 

Left dialog window (topological tree window) 

Shows structure of current Symbol Recognition Template Library (SRTL). 

Right dialog window (template window) 

Shows content (template) of selected library item. 

 
New 

Creates a new empty SRTL. 

 
Open 

Load a library from *.SRT file into SRTL editor dialog. 
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Import 

Import an old symbol template format (*.SST) in current library. 

 
Save 

Saves the active (current) library in current *.SRT file. 

 
Save As 

Saves the library in a new *.SRT file. 

 
Select Connection Lines 

Allows to select connecting lines in the symbol template window of the 
dialog (useful only for vector template of Search item). 

 
Add Search Item 

Attaches Search item to the specified Replace item. The Replace item 
must be selected beforehand in the search-replace topological tree of the 
dialog. 

 
Add Replace Item 

Adds Replace item to the SRTL. 

 
Delete 

Deletes selected item from library. 

 To exclude an item from recognition process, just remove 
checkmark on the left of the item‟s name without deleting it 
from the library. The item is deactivated. 

 

Automatic Raster to Contours conversion 
Performs a Raster to Contours conversion by polylines which duplicates selected 
closed areas on the image. At the same time, if an area has a mutual border (example 
shown below), every area (parcel) of polylines will have its own segment. 

Setting up the Raster to Contours parameters can be performed in R2V Conversion 
Options.

 
Increasing the Radius parameter causes more places to be treated as area borders 

To start this command; choose Raster to Contours from the Convert menu or click the 

 button on the Raster to Vector toolbar. 

To perform conversion to contours do following: 



RxSpotlight User Guide 

204 

1. Open the monochrome raster image. 

2. Run this command. 

3. If the Raster to Contours conversion is not suitable, then try changing 
the parameters in Conversion Options and re-running the command. 

Automatic Color Vectorization 
Color Conversion is intended for recognition of linear objects on color schematic 
raster images (plans, schemes, topographical maps). It combines such operations as 
binarization, vector color separation and color vectorization. . As a result, you get 
polylines broken in places of mutual crossings. 

This command works on greyscale and colour images. 

To start the Color Conversion command; choose Color Conversion Options from the 

Convert menu or click the  button on the Raster to Vector toolbar. 

 

To tune the colour conversion parameters do following steps: 

Step1 

Adjust the binarization parameters (similarly to Adaptive Binarization): 

Switch on the Hide Vectors button  of this dialog, switch off the Hide Raster button 

 and the Hide Source Raster button . 
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Move the Radius slider to its minimum position (equal to 4). 

Gradually increase the Threshold value until the required objects appear. 

Use the Smoothing filter if the objects have rough borders.  

 At the same time, closely positioned lines might conglutinate and small 
objects might disappear. 

 
 

related buttons and controls: 

 Hide 
Source Raster 
button  

Turns off the display of source raster image in the Color 
Conversion preview area. 

 Hide 
Vectors button 

Turns off the display of vector objects in the Color 
Conversion preview area. 

 Hide 
Raster button  

Turns off the display of raster information in the Color 
Conversion preview area. Click the arrow to the right of 
the button to change colour of binorized raster data. 

Radius slider Sets the radius value, which determines the depth (in 
pixel) of the filter effect on the colour area. Set it to the 
minimum position. 

Threshold 
slider 

Sets the threshold value of binarization. 
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Smoothing Select this checkbox to smooth the image. The Smoothing 
slider controls the smooth level. Moving this slider right 
makes the smooth level higher while moving left makes it 
lower. 

  

Step2 

Set the Recognition parameters: Max Width, Min Length and Accuracy. 

These parameters are equal to those for monochrome images in the raster to vector 
Conversion Options dialog and the Raster Properties toolbar. 

related buttons and controls: 

Min Length Sets the minimum length of a raster fragment which 
should be recognized as a polyline in the vectorization 
process. 

- Specify the length of the shortest raster line. 

- In order to measure directly from the image, click the 

 button and draw a line along the smallest raster line. 

Max Width Sets the maximum width of a raster linear object which 
should be recognized as a polyline. 

- Specify the value of this parameter slightly greater than 
the maximum width of the raster line to vectorize. 

- If the program does not vectorize raster segments, then 
increase the value of this parameter. If the program does 
not approximate flooded raster areas by boundary 
objects, then reduce the value of this parameter. 

- In order to measure directly from the image click the  
button and draw a perpendicular line to the widest raster 
line you want to recognize. 

Accuracy slider Sets the accuracy of raster lines approximated by vector 
objects. If the quality of the raster image is poor, then 
reduce the parameter value so that the function will be 
able to recognize raster objects with significant form 
distortions. 

Step3 

Switch off the Separate by Color checkbox and define a preview area so that all the 
objects of all the colours present in the raster image can be seen. 
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Visually check the quality of the recognized objects, their colour and degree of 
conformity to the raster image. Re-customise parameters if necessary. 

To see lines of different colours on separate layers, switch on the Separate by Colour 
checkbox. 

Set the Colour Number value (usually 1-2 colours more than the real number). The 
program automatically defines the table of colours and casts the colour of an object to 
the nearest one. By switching on/off the Export to Layer checkbox located at the 

beginning of every colour table string, all objects of this colour can be checked 
visually. 

After defining the correct number of colours it is possible to define another target 
colour and a layer for each real colour. 

If there is no need to export a line of a certain color, then switch off the Export 
checkbox at the beginning of this string. 

related buttons and controls: 

Colour Number 
slider 

The Separate by Color section tries to automatically 
reduce the colours of all raster lines to a fixed number 
(Real Color column). Only the number of the colors to 

reduce to need to be set (usually, 1-2 colours more than 
the real number). Because the color of a raster line can 
slightly vary from its beginning to its end after vectorizing 
vector polylines of two different colours are produced 
whereas the actual color is the same. 

Check box 
column 

Turn it off to exclude polylines of a specified color from the 
vectorization process. 

Real Colour 
column 

A fixed number of colors that is generated automatically 
by the Color Conversion tool on the basis of the Color 
Number value. 
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Layer column Set a layer for the vector set of a specified color. 

Output Colour 
column 

Specify a color for the vectorized polyline set. 

Step4 

Click the Apply button to start vectorization or save the parameters to a file for further 
use. 

 Vectorization can also be launched with current settings through the 
Raster2Vector command (chose the Raster2Vector from Convert menu or click 

the  button on the Raster to Vector toolbar). 

related buttons and controls: 

Apply button Launches the color conversion process. 

Close button Closes the R2V Color Conversion dialog keeping all its 
parameters. 

Template 
button 

Allows users to save current settings to a file for future 
use. 

Raster to Vector Toolbars 
The Raster Properties  toolbar allows tune up conversion options on-the fly without 
digging in Conversion Options dialog. This gives an ability to manage main R2V 

settings immediately. Vectorization results can also be previewed using the  

button from this toolbar. Press this button and specify the rectangle preview area. 

 
The Quick Launch Conversion tool  toolbar allows the Automatic Vectorization to start 
with a specified template. 
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Drawing and editing 

The drawing capabilities of RxSpotlight include tools for the creation and editing of 
entities and objects, composed of entities, drawing and erasing pixels on 
monochrome and colour raster images and operations that create or modify vector or 
raster images. 

The simplest drawing operations are represented by buttons in the Main toolbar (they 
occupy the second row on the picture below).  

 1  2 3 4  5  6    

 

 

 

9 

 Main drawing buttons  8  

The first row contains buttons for opening, saving (1), printing (2), undoing and 
redoing (3), manipulating layers (4) and zooming operations (5). At the right of the first 
row there are two buttons (6) that toggle viewing/hiding raster and vector objects (see 
page 37) and the pan button (7). 
The second row contains main drawing tools, a button (8) that switches raster/vector 
drawing mode (see page 297) and coordinate system setup button (9). 

Using these buttons entities, insert texts and images, can be drawn and blocks 
created and inserted. 

A more versatile set of drawing buttons is located in the Draw toolbar and menu. 

Pixel drawing tools   

 

 

Entities drawing buttons 

 

 10 11  12   

Pixel drawing buttons, a complete set of tools for drawing entities, two buttons that 
control blocks (10), four buttons that insert images (11) and two buttons that create 
end markers and fill shapes (12) are available. 

This is not all. This chapter describes all the RxSpotlight drawing and editing means 
and modes. 
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Before drawing 

Visibility 

Make sure that  and  buttons that control objects visibility are not pressed. 

Pressing  button allows newly drawn objects to be added to the selection 

automatically,  selects only the last drawn object and  removes drawn 

objects from the selection.  

The View > Show width commands and commands from submenu View > Display 
Order can be of great assistance for drawing or editing a large number of objects. 

The drawn objects can be placed on a specified layer. Any combination of vector 
objects and raster are allowed on a layer.  

The Inspector window adds flexibility and precision to drawing operations. 

 See more information about composing selection sets on page 106; on layers on 
page 45; on viewing commands on page 30; on Inspector on page 40. 

Ortho mode 
With orthogonalization mode set to on, vector lines and rubberlines for editing can 
only be drawn in parallel directions to the coordinate axis. 

Turn on orthogonalization by pressing the ORTHO button in the right-lower part of the 
screen (see the picture below). 

To draw perpendicular skewed lines (as in the picture below) perform the following 
procedure: 

To draw perpendicular lines with a skew angle to the coordinate axis: 

1. Open the Coordinate System tab in the Tools > Coordinate System dialog. 

2. Enter the skew angle value in Angle, or measure the angle directly on the image 

having pressed the button . 

3. Press Apply. 

4. Draw the desired objects. Note that the cursor lines are now skewed by the 
specified angle. 
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5. If necessary, then open the Coordinate System dialog again and reset the 

previous value in Angle. 

Drawing arcs in ORTHO mode is limited by the fact that «rubber lines» are also drawn 
parallel to coordinate axis. 

 See more information on Coordinate system setup on page 64. 

Other modes and options that affect drawing 
When drawing – it is possible to create rasterized copies of vector entities. The effects 
of toggling the Switch drawing raster entity and RDRAW buttons are described on 
page 297. 

Created text objects can also be rasterized (see description on page 298). 

When drawing and editing – snaps and grids can be used to add precision to the 
operations (see description on page 298).  

Drawn objects can be automatically selected. Selection is controlled by settings in 
Command Setup dialog, see page 376. 

Line Style management 
Every RxSpotlight vector object has a line style associated with it (see Line Type 
property in the Inspector). The line style is a definition that determines a visual 
representation of lines of drawing entity. It includes particular dash-gap-marker 
sequence, the relative lengths of dashes and gaps, styles combination and etc. Any of 
the standard line styles provided by RxSpotlight can be used, or new line styles can 
be created and combined. 
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A wide spectrum of line types can be created: 

 
Line style that uses arrow markers 

 
Combined line style 
 

All standard RxSpotlight line styles cannot be deleted or renamed, however they can 
be freely modified. 

To set line type 

You can set line type on the Properties toolbar or in the Inspector window. 

 
 

The Line Style Manager 

It‟s used to create, delete, modify and combine line styles. 



RxSpotlight User Guide 
 

213 

To start Line Style Manager , click the Style from the Tools menu. 

 

The Pen Styles list box shows all line styles in the document. It supports 
multiply selection (with SHIFT or CTRL keys), and drag and drop capability. 

Locked field Mark desired line styles with a  sign to make them 

available in the drawing (in the Inspector dialog and 
Properties toolbar). 

RxSpotlight has a number of standard line styles, which 
can be modified but not renamed or deleted. These line 

styles are marked with a  sign shown in this field. 

All marked ( ) line styles are placed inside saved CWS. 

Thus they can be distributed with a document. 

Name field Displays a line style name. 

Pattern field Shows a line style visual representation. 

Description Shows full information about a selected line style: name, 
number of pattern pairs, interval pairs separated by 
comma. 

New button Shows the Pattern Style dialog to create a new line style. 
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Combine button Shows the Combined Style dialog with included selected 

line style to create a new combined line style. If line style 
was not selected or selected style was already combined 
one, then this button shows empty Combined Style dialog. 

New Copy button Shows the Pattern Style dialog window filled with 

parameters of selected line style to create a copy of this 
line style. The line style name for the new line style by 
default is: “Copy of CopiedLineStyleName”, where the 
CopiedLineStyleName is the name of a copied line style. 

If selected style is a combined one, then this button shows 
Combined Style dialog. 

Modify button Shows the Pattern Style dialog to modify a selected line 
style. 

If selected style is a combined one, then this button shows 
Combined Style dialog. 

 All standard RxSpotlight line styles, are 
marked with the key symbol and cannot be 
deleted or renamed, but can be freely 
modified. 

 

Delete button Deletes selected line style(s). 

 All standard RxSpotlight line styles, are 
marked with the key symbol and cannot be 
deleted or renamed, but can be freely 
modified. 

 Be careful not to delete a line style that is 
used by some document objects. If a line 
style used is removed, then after the 
document is reopened, the name of this 
deleted style will be displayed in angle 
brackets for all objects that use this style, 
but actually these objects will be displayed in 
a solid line style. 
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Import button Import line style(s) from the AutoCAD line type definition 
file (.LIN file). A LIN file can contain definitions of many 
simple and complex line styles. This file has an ASCII 
format. 

Select  desired line styles in the Line type import dialog 

that appears: 

 
RxSpotlight converts shapes and text symbols into 
markers during line style import: 

 
You can also ignore such line styles: 

 
 

Close button Closes the Line Style Manager dialog. 

The Pattern Style dialog 

This dialog is called from the Line Style Manager and used for creation, modifying and 
copying line styles. 
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The format of the line style definition includes a number of patterns consisting of three 
parts: Dash part length value - Gap part length value – Marker (optionally) 

The Marker – is the same marker that is stored in .MRK file and used to place at the 
entity ends.  

It is placed in the middle of the Gap of a current pattern. The user can assign various 
markers to different patterns of the modified line style. 

For example, a standard RxSpotlight line style, called DotDotDashedLine, includes 
three patterns defined as: 

Dash Gap Marker 
8mm 2mm <none> 
1mm 2mm <none> 
1mm 2mm <none> 

This indicates a repeating pattern starting with a dash 8mm long, a gap 2mm long, a 
dot, a gap 2mm long, a dot and another gap 2mm long. This pattern continues for the 
length of the line. The line style would be displayed as shown below: 

 

To create a new line style  

Press the New button in the Style dialog: 

Set the style name and select measurement units from the Default unit combo-box. 

Press the  New Item button, enter one by one the size of dash and gap. Specify 

marker. Observe the process in the Preview field. 

Edit elements with the buttons  Delete Item and  Move Item Up / Down. 

Press OK. 
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To modify an existing line style  

From the Style dialog pane choose a style to modify. 

Press the Modify button, and then make necessary changes (see 2, 3 of the previous 
section).  

Press OK. The style name will remain the same. 

To create a new line style on the base of an existing one  

Choose a line style from the Style dialog. 

Press the New Copy button, make necessary changes. 

Enter the name in Style Name the field. 

Press OK. 

Pattern Style dialog buttons and controls 

The  button 
Creates another pattern. 

The  button 
Deletes a selected pattern from the list 

The  

buttons 

Moves patterns up and down along the list. 

The upper patterns are drawn before the lower patterns in 
the line style. 

Dash field Specify the length of the dash part of the pattern. 

Gap field Specify the length of the gap part of the pattern. 

Marker field Specify the Marker that will be placed in the middle of the 
gap of a current pattern. 

Various markers can be assigned to different patterns of a 
modified line style. 

Style name Represents a line style name. 

A line style belonging to RxSpotlight standard line styles 
cannot be modified. 

Default Unit Specifies the measurement units for dashed and spaced 
parts length of the line type. 

The Combined styles 

A combined line style consists of several simple ones. An offset, line width and colour 
can be specified for each included style. 

The Offset sets a displacement value of a line relative to the central axis of a 
combined style. Positive values mean displacement to the right, negative - to the left. 
The lines with the same Offset value will be placed one over another. 
The Line Width sets a width value for a specified style. 

By default, the line color corresponds to the color of the included style, it can be 
changed though. 
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Using combined styles makes it possible to create line styles that can virtually 
represent any kind of an entity in a drawing such as a state border, railroad and more. 

To create combined style 

A Combined style can be created using a set of simple (not combined before) line 
styles. This can be done in the Combined Style sub-dialog. 

Select all simple line styles which you need to combine in the Line Style dialog and 
click the Combine button to create a new combined style. 

The Combined Style sub-dialog with all the preselected styles included will appears. 

 
There you can edit Offset, Width and Color parameters for each combined style. 

To add a new style to a set or include an instance of an existing one, use the  

New item button. Click the  Delete item button to delete any style. Use the 

 buttons to change an item order in the set. The Style Name box specifies the 

name of a combined style and the Default Unit box specifies the measurement units 
for the Offset and Width parameters. 
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Example: Creation of a railway line style 

To create a railway line style follow the steps: 

Open the Line Style dialog. 

Choose the native RxSpotlight SolidLine and DashedTriangleLine styles in the list by 
selecting them with the Ctrl button pressed. 

Click the Combine button. 

In the appeared Combined Style dialog type the “railway” style name and specify 
millimetres as default units. 

Click the  New item button twice to add two style items to the list. Click on the 

Style field of every newly added item and choose the SolidLine style name. Now there 
are three instances of the SolidLine style and one instance of the DashedTriangleLine 
style in the list. 

 

This set represents a thin solid line. 

Set a width value equal to 6mm and yellow color for the first SolidLine style instance. 

 

A wide yellow line appears. 

Set an offset value equal to 3mm for the second SolidLine style instance 
and an offset value equal to – 3mm for the third one. 

 

Now we have a wide yellow line with a 
thin black DashedTriangleLine in the 
middle bounded with two thin black 
solid lines. 

Set a width value for DashedTriangleLine equal to 6mm. 

 

The line of yellow color and the line of 
DashedTriangleLine style have the 
same width and offset values so they 
are imposed one over another. 

Text Style management 
Every text in a RxSpotlight document has a text style associated with it. A text style 
defines such text characteristics as: Font, Height, Width Factor, and Obliquity. To 
inherit any text property from the associated text style, this property value must be set 
to By Style. 

Using text styles, text properties for a number of objects can be changed on the fly. 
Just modify any parameter of the required text style, and every RxSpotlight text in this 
document which inherits the value for this property from the modified text style will be 
changed immediately. 

A text style for the following can be changed: Text, Multiline text, Dimension text, 
Block, by changing a value of the Text Style property in Inspector. 
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Text Style Manager 

The Text Style Manager is used for managing text styles. 

 
Use a combo box in the upper-left corner to switch between text styles of this 
document. 

The  button 
Creates a new text style. 

The  button 
Deletes a text style. Select a name from the list, and then 
choose Delete. The document current text style or text 
style used by any object can not be deleted. 

  It is quick and easily to delete all unused 
text styles from the document using the 
Purge command. 

The Preview Displays a sample text that changes dynamically when 
you change any text style parameters. To change a 
sample text, enter characters in the box above the 
character preview image. 

 The preview image does not reflect the text 
height. 

The Close button Closes the dialog and applies the changes. 
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Text style properties 

Name Displays a text style name to be edited. Change it if it is 
necessary. 

Text Font Changes a style's font. 

Text Height Sets a text height based on the value the entered or chose 
from the list. 

Text Width 
Factor 

Sets the character spacing. Entering a value less than 1.0 
condenses the text. Entering a value greater than 1.0 
expands it. 

Text Oblique Sets an oblique angle of the text, which defines the 
forward or backward slant of the text. This angle 
represents an offset from 90 degrees. 

To start Text Style Manager; click the Text Style from the Tools menu. 

Drawing entities 
Drawing simple objects is easy. 

Select a drawing tool (or command in the corresponding submenu of Draw menu) and 

draw intuitively. Any drawing mode can be exited by releasing the button on the 
Drawing toolbar, or by changing the drawing mode, or by pressing ESC. 

To become acquainted with drawing vector objects, open a blank document and the 
Drawing toolbar and spend a few minutes trying the drawing tools. 

It is useful to keep the Inspector window open while drawing. Spend some time 
experimenting with different properties and options of the selected drawing tool. 
Inspector allows drawing with precision and control of many properties of the created 
objects. 

Line 
There are two ways to draw a line: 

1. By pressing  and specifying two endpoints… 
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2. …or by pressing  and specifying three points: two for direction and one for 

length. 

 
 

In the latter case the rubberline, after specifying the line direction by two clicks, 
follows the perpendicular from the cursor on the line, rather than the cursor, until 
clicked for the third time.  

Arc 
There are three ways to draw an arc. 

1. By three points with  button pressed: 
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2. By centre, starting direction, and angle (  pressed): 

 
Until the creation of an arc is confirmed by clicking, the rubberlines show its expected 
shape and angle.  

3. By centre, angle, and radius (  pressed): 

This method allows two arcs to be drawn: “large” and “small”; it depends on the place 
clicked after specifying the first corner. RxSpotlight will draw an arc in the direction of 
the other side of the specified corner. 

 

 

First point of arc 

 

Second point of arc 

 

 

Second point of arc 

 

First point of arc 

The pictures show how arcs are drawn 
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The “direction” in which RxSpotlight draws an arc is set by the current coordinate 
system. An arc is drawn in the direction of the Y-axis positive direction to the X-axis 
positive direction; i.e. when the coordinate axis are set in a standard fashion, arcs are 
drawn counter clockwise from the first point. 

Circle 

There are three ways to draw a circle:  - by centre and radius, 
 
- by diameter, 

and 
 
- by three points. 

No tricks – just choose a tool, click and watch the rubberline to control. 

Rectangle 
A rectangle can be drawn specifying either three or two points. 

To draw a rectangle by three points, press , click one corner, then click “height” 

and “width”. 

 

To draw a rectangle by two points, press , click and drag. This drawing mode 

produces rectangles skewed by the same angle. To change this angle press SHIFT 
after specifying the first corner, place the rubberline to fit the new angle and click the 
opposite corner of the rectangle. 

Closed Polygon 
This command draws closed polyline with specified number of sides. 

Drawing methods 

  

Circumscribed Inscribed 
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Edge 

 

 

 

To create Closed Polygon 

1. Start Closed Polygon command from the Draw menu. 

2. Enter a number of polygon sides in the command line or press Enter to agree with 
previous value; 

3. Choose drawing method in the Command Line: 
Inscribed/Circumscribed/Edge 

or press Enter to agree with previous one; 

4. 

– In case of inscribed polygon specify center and radius of circumscribed circle 
   (for the Command Line use the following format: Distance<Angle). 

or 

– In case of circumscribed polygon specify center and radius of inscribed circle 
   (for the Command Line use the following format: Distance<Angle). 

or 

– In case of drawing by edge specify first and end point of polygon edge. 

Ellipse and elliptic arc 
An ellipse can be drawn using two different methods. Select Ellipse by from the Draw 
menu and a drawing method from the sub-menu: 

1. To draw an ellipse by Centre and Radiuses press the button . Specify the 

centre point for an ellipse; moving the cursor, select the first radius on the screen 
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(or set in the Inspector) and a slope angle for the ellipse axis; click to confirm, 
and then select the second radius.  

2. To draw an ellipse by Diameter and Radius press the button   Specify the 

centre, diameter and a slope angle for the ellipse axis, and then the second 
radius. 

To draw an Elliptic Arc press the button . Specify a centre, radius and slope angle 

for the ellipse axis, and then the second radius; click to confirm. After that specify a 
start angle for the arc (relative to the ellipse axis) and an end angle for the arc. 

Point 

Draw points (  button) to snap objects to them later in snapping mode. From the 

Preferences dialog (Tools menu), choose (in Points section) the most appropriate way 
to display points; note that it is just a representation, RxSpotlight saves the screen 
image of a point apart from its coordinates. 

Hatch 
Hatching creates a hatched or filled block in a region of the drawing enclosed by a 
boundary made up of lines, arcs, circles, polylines, and/or rectangle entities. 

A hatch boundary is a set of closed contours. RxSpotlight defines the boundary by 
analyzing all selected vectors. It tries to find all entities that define the closed 
contours, generates these contours, and adds them to the selected closed region. 

RxSpotlight creates a hatch using a style known as the Normal AutoCAD hatch style. 
Islands remain un-hatched, while islands within islands are hatched, as in the figure 
below. 

  
Hatching: Selected vectors and the result 

To create a hatched (filled) block 

1. Select objects that define the hatch boundary. 

The selection must be composed of lines, arcs, circles, rectangles, or polylines. 

2. From the Draw menu choose Hatch. 

- or – 
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on the Main or Draw toolbar, click the  button. 

RxSpotlight creates a hatch block. The hatch or fill style can be defined in the 
Inspector window. 

 For more information on blocks see page 235. 

Polylines 
A Polyline is a chain of line and arc segments. The connecting points of these 
segments are called vertices. 

To begin drawing a polyline press  button on Draw toolbar or choose the Draw > 

Polyline from menu. 

Drawing polylines consists of drawing segments of lines (by two points) and arcs (by 
three points). The arc segments are drawn with the SHIFT key pressed. 

Complete drawing by double-clicking. 

During polyline drawing using the context sensitive menu, which appears on right-
clicking, to undo the latest drawn segment, and two methods to complete drawing: 
with or without closing a polyline can be chosen. 

 
The user can also choose between linear or arc segments to draw. 

If the polyline is not closed immediately, then it can be closed later. 

To cancel drawing a polyline press ESC. 

The polyline can be exploded to separate arcs and lines. 

The mechanism of editing polylines is represented by buttons in the Polyline Edit  
toolbar.  

Polylines can be edited by closing and breaking them and also by moving, adding, or 
deleting individual vertices. Line segments can be converted to arcs and vice versa, 
modify polyline properties such as width and line type, its belonging to a certain layer, 
colour and elevation. 

A polyline can be edited by moving its vertices with the mouse, using the Polyline Edit 
toolbar or the cursor menu. 

A line needs to be selected before editing. In RxSpotlight there are two modes of 
modifying a polyline: Vector editing mode and Segment editing mode. 
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Operations in the Vector editing mode 

To enter Vector editing mode press  button on the Select toolbar and select a 

polyline with one of the standard vector selection methods. 

In this mode, users can close a polyline, break it at specified points, move its vertices, 
and add new vertices.  

The polyline grips will be highlighted with green or blue if more than one object is 
selected. Grip colours can be changed in Grip section of the Preferences dialog. 

 For more information about the Preferences dialog see “Tuning the application” 

on page 389. 

To close a polyline:  

A polyline can be closed and opened in two ways – by joining two extreme vertices or 
adding a supplementary linear segment.  

1. Select a polyline in the Vector editing mode.  

Choose Close polyline from the cursor menu – the polyline will be closed by the 
addition of a linear segment 

- or – 

2. Select a polyline in the Vector editing mode or the Segment editing mode (see 
description of this mode below). 

Open the Polyline Edit toolbar and press the Close polyline button  - to close 

the polyline by joining two extreme vertices; or the Extend to Close button  – 

to close the polyline by adding a linear segment. 

To add vertex to polyline:  

1. Select a polyline in the Vector editing mode or the Segment editing mode and 

press the Add vertex button  on the Polyline Edit toolbar. 

2. Specify a point on the polyline to insert new vertex in. 

To break a polyline:  

1. Select a polyline in the Vector editing mode or the Segment editing mode. 

2. Press the Break button  on the Polyline Edit toolbar. 

3. Specify the vertices on the polyline to break it. 

To explode a polyline:  

1, Select a polyline in the Vector editing mode. 

2. Choose Explode Polyline from the cursor menu or Explode from the Modify 
menu– the polyline will be exploded into constituent parts. 

Operations in the Segment editing mode 
As regards the polylines, the Segment editing mode allows work with polyline 
segments and multiple vertex selections. In this mode, all operations described above 
for Vector editing mode are available, plus these additional functions: deleting 



RxSpotlight User Guide 
 

229 

specified segments and vertices, converting linear segments to arcs and vice versa, 
joining polylines, separating linear or arc segments to a single object, and dragging 
selected parts of a polyline. 

Enter the Segment editing mode in the following ways: 

Choose Polyline from the Modify menu and select a polyline 

- or – 

Choose Segment edit mode on the Select toolbar by pressing  button and click 

on the polyline.  

In this mode the polyline grips are highlighted with yellow and the selected vertices 
with green. Grip colours can be changed in Grip section of the Preferences dialog. 

There are two simple rules for vertices and segments selection in this mode: 

1. If segment is selected, then its adjacent vertices are selected too. 

2. If two adjacent vertices are selected, then segment that connected them is 
selected too. 

All standard selection methods are useful in this mode. Dragging of specified vertices 
and segments stretches the polyline entity. Next example illustrates one polyline 
vertex and one polyline segment drugging. 

 

To delete polyline segments and vertices:  

1. Select a polyline in the Segment editing mode. 

2. Select the vertices and segments to delete. The specified vertices and the 
segments will be highlighted. 

3. Press the Delete Vertex button  on the Polyline Edit toolbar or choose 

Delete Vertex from the cursor menu. 
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The result of two vertices deleting 

 

The result of polyline segment deleting 

 

To convert segment to line:  

1. Select a polyline in the Segment editing mode. 

2. Select one or the several arc segments to be converted to linear segments. The 
specified segments and their vertices will be highlighted. 

3. Press the Convert To Line button  on the Polyline Edit toolbar or choose 

Convert To Line from the cursor button. 

 

The result of arc segment to linear segment conversion 

To convert segment to arc: 

1. Select a polyline in the Segment editing mode. 

2. Select one or the several linear segments to be converted to arc segments. The 
specified segments and their vertices will be highlighted. 

3. Press the Convert To Arc button  on the Polyline Edit toolbar or choose 

Convert To Arc from the cursor menu. 
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The result of linear segment to arc segment conversion 

Joining polylines: 

Polylines can be joined with arcs and linear segments. Selected objects can be joined 
by adding a supplementary linear or arc segment, as well as by connecting their two 
extreme vertices. 

1. Select the objects to join (polylines, arcs, lines) in the Segment editing mode. 

2. Specify the vertices to join the objects with. 

The selected vertices will be highlighted in green. 

3. Press the Join button  on the Polyline Edit toolbar or choose Join from the 

cursor menu to join objects by connecting their specified vertices. 

 -or - 

 Press the Join by line button  on the Polyline Edit toolbar or choose Join by 

line from the cursor menu to join objects with a linear segment. 

 -or - 

 Press the Join by Arc button  on the Polyline Edit toolbar or choose Join by 

Arc from the cursor menu to join objects with a linear segment. 

 

The result of Join method 
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The result of Join by Line method 

 

The result of Join by Arc method 

Splines 
A spline is a smooth curve passing through a given set of points. RxSpotlight works 
with a particular type of spline known as a non-uniform rational B-spline (NURBS). 
Applying NURBS assures sufficient smoothness of the curves passing through 
specified fit points. Splines are useful for creating irregular-shaped curves, for 
example, drawing contour lines on maps or complex curves on mechanical drawing. 

The Spline can be used command to create a spline with a given set of points. 

Besides the Spline command, splines can be created by converting polylines to 
splines with the Convert to Spline command from the Correct menu.  

A spline can be converted to an approximating polyline using the MergeVectors to 
Polyline command from the Correct menu. 

The advantages of splines as compared with polylines 

Splines have the following advantages as compared with polylines: 



RxSpotlight User Guide 
 

233 

1. They are created on the 
base of the same number 
of points, but they are 
much more precise in 
comparison with polylines;  

2. A drawing containing 
splines uses less disc 
space and memory than a 
drawing with smoothed 
polylines with the same 
number points. 

 
1 - spline 

2 - polyline 

To draw a spline 

To run the command; choose the Spline from the Draw menu or press the  button 
on the Draw toolbar. 

Specify points for drawing spline shape. Press BACKSPACE to cancel the latest 
specified point. 

Double-click to complete or choose Complete from the mouse right-button menu. To 
close the spline and continue drawing, choose Close from the mouse right-button 
menu. 

Spline drawing is influenced by ORTHO mode and polar snap. 

When drawing vector objects, vector snap, to snap to spline end points and start 

points, can be used. (End point and Intersection ) 

A Hatch object can be created on the base of a closed spline. If this hatch is 
exploded, then a closed polyline is obtained. 

To edit a spline 

To edit a spline, the grips of fit points are used. Fit points can be deleted and added to 
modify spline accuracy. For this, press CTRL, and then move the nearest existing 
point to the place to add a point. To delete a point, move this point to the nearest one, 
and then release the mouse button. The point will be deleted. Use vector snap 
(Intersection type) to match points precisely. 
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All RxSpotlight splines have start 
and end tangents (tangent vectors), 
which specify the tangency of a 
spline curve at its start and end 
points. The end points of the 
tangent vectors have triangular 
grips, which are used for specifying 
tangent‟s direction and length.  

Use the Start Tangent and End 
Tangent Inspector items to edit 
tangents properties. Edit vector 

coordinates there or click the  
button to set tangents into the 
default position. 

 

  

To change the position of control 
points, turn on the Node Selection 
mode (Polyline Selection mode) on 
the Select toolbar. The spline 
control points will be displayed. 

 Modifying control 
points is an 
irreversible operation 
during which start 
points are lost, and 
their grips are not 
displayed. 

 

Spline properties 

Like any other vector object, a spline has a set of properties. 

Closed: 
YES/NO 

Defines spline status. Using this property, you can either 
"close" or "open" splines. 

Start 
points: N 

A number of fit points a spline is created. 

Control 
points: N 

A number of control points. This property is displayed 
after control points have been edited in Polyline edit 
mode. 

Order: N A spline order. 

Start 
Tangent 
and End 
Tangent 

Coordinates of spline tangent vectors whose direction 
and length defines the curvature of last segments in the 
start and end points. 

The  button sets tangents into the default position. 
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Construction objects 
Construction objects cannot be used for a number of operations such as vector 
editing, merging and etc. 

Xline 
This command creates an infinite construction line. 

To create Xline 

 From the Draw menu, choose Xline to start this command. 

 Specify the first line point 

 Specify the second line point. 

Ray 
This command creates a ray – a semi-infinity construction line. 

To create Ray 

 From the Draw menu, choose Ray to start this command. 

 Specify the base point of the ray. 

 Specify the second point that should lies on the ray. 

Blocks 
A block is a collection of objects that can be associated together to form a single 
object named block definition. A block can be inserted in a drawing as many times as 
you need.  

A block definition can contain other (nested) blocks. The only restriction on nested 
blocks is that you cannot insert blocks that reference themselves. 

Existing blocks can be modified only by redefining it, i.e. by creating a new block 
under the name of an existing one. After modification, all instances of the modified 
block inserted in the document are automatically converted to the new block. 

View and control blocks in the Blocks window (menu Tools). Modify block insertion 
properties in the Inspector dialog. 

Exploding a block breaks it into its component objects. 

To create a block 

1. Select objects for the block. 

2. From the Draw menu, choose Create Block or from the Main toolbar, click the 

 button. 

3. To assign a specific name to a block, type the name in the Inspector window or  

select an automatically generated name such as “Block_<Number>”. 

4. Select the mode of block creation: Remove, Replace or Leave in the Inspector 
window. Set the other block properties if necessary. 

5. Select the insertion base point. 
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When a block is created in Replace mode, objects that make a block are replaced by 
the block. In Remove mode objects that form a block are deleted from the document. 
In Leave mode all constituent objects are left intact. 

To insert a block  

1. From the Insert menu, choose Insert Block or from the Main toolbar, click the 

 button. 

2. Select the name of the block in the dialog that appears. Then click on the 
location of the insertion point or to insert an instance of the last inserted block, 
simply click on the location of the insertion point. 

To replace definition of a block 

1. Select the objects for the block. 

2. From the Draw menu, choose Create Block or from the Main toolbar, click the 

 button. 

3. In the Inspector window select the name of the block that you want to modify. 

4. Choose the Yes button in the confirmation dialog box. 

5. Select the insertion base point. 

All other instances of the block will change automatically. 

To explode a block 

1. Select a block. 

2. From the Modify menu, choose Explode or click the  button from Modify 

toolbar. 

Block attributes 

Users can also set attributes to a block to create. A block attribute is a text included in 
the block, whose value can be re-defined for each block insertion. 

To create an attribute, include a multiline text in the block. After being inserted in the 
block, the following set of symbols in the multiline text will be defined by the block as 
an attribute: </attribute name>, where attribute name represents the name of the 
block attribute displayed in Inspector while the block parameters are being edited. 

For example, insert the following multiline text in the block displaying a workstation: 

Employee: </last name> </first name> 

Position: </position> 

Then set in the Inspector the values of the attributes for each block insertion: </ first 
name>, </ last name> and </position> 

On the screen something like this will appear: 

Employee: Smith John 

Position: designer 

Block manager 

The Blocks window is opened by pressing the button  on the Properties toolbar or 

by choosing Blocks from the Tools menu. 
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This dialog first appears in a reduced form. Clicking on Details opens the block 
properties list and Preview window. 

The Refs field contains the number of block insertions in the document. The value 0 in 
Refs means that the block definition is stored, but the block has not been inserted in 

the document. To delete a definition, allocated for block storage, press the button . 

If the number of block insertions in the document is not equal to 1, then all the 
property fields are empty and you can only see the block image in Preview window. 

The Name, Colour and Layer fields and also properties in the Details list are enabled 
when a block is inserted only once. 

Text objects 
A line of text can be typed from the keyboard or a multiline text object inserted. 

To add a line of text, choose Text command from Draw menu (or press  button on 

Main or Draw toolbar), click to define an insertion point, type the text and complete it 

by pressing ENTER. The text object appears inside a bounding box with selection grip 
in the document. Before creating text its Style, Font, Height, Oblique and other 
properties can be set in the Inspector window. 

Multiline text 
A multiline text object can be inserted in the document using the Multiline Text 
command from the Draw menu. 

Use the Edit multiline text . dialog to type and edit text or extract text from an existing 
text file. 
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There are five buttons in this dialog: 

 
opens file with text; 

 
saves text to file; 

 
deletes text. 

 
Inserts the following special 
symbols. in the text: 

 

 
Insert special data from the list: 

 Current Date (Short) 

 Current Date (Long) 

 Current Time 

 User Name 

After the text is typed and edited, press OK and click on the image at desired insertion 
point of the multiline text object. 

Change text font, size, colour and other properties in the Inspector window. 

The text is aligned by its base point (see Base Point property in Inspector). To align 
the text horizontal use Horizontal property. There are variants: Left, Centre and Right. 
To align the text vertically, use Vertical property. After being entered the text 
alignment is set by the left lower corner. 
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In the figure 
all possible 
alignment 
variants are 
indicated by 
grey. 

The multiline text object can be exploded to regular RxSpotlight lines of text. 

  
Multiline text inserted… …and Exploded to separate lines 

Dimensions 
Dimensions are the objects that represent distances, angles, diameters and radiuses. 
A dimension object usually consists of dimension and extension lines, text and 
arrowheads. 

The dimension object is created using current settings shown in Inspector window. 
Using grips some of the properties of the dimension object can be edited. 

 

 

Draw menu contains four 
measurement options in Dimension 
submenu. If choosing Linear, then the 
Inspector window offers Horizontal, 
Vertical and Aligned methods to 

create dimension objects in 
Dimension type list. 

One of the dimension measurement 
options can also be chosen from 
Dimension toolbar. 

To create linear dimension  

1. Select Linear from Draw > Dimension submenu. 

2. Select Horizontal, Vertical and Aligned from Dimension type list in Inspector 
window. Set other options in Inspector window if necessary. 

 - or -  
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 Press one of the three buttons  in the left of Dimension toolbar. 

3. Click on end points of measured object. Watch the dashed contours of 
dimension text.  

4. Move the mouse pointer until the desired position for the dimension text is 
reached and click again.  

   
Distance dimensions examples 

If the vector line is already selected, then there is no need to specify the dimension 
object. Choose Horizontal, Vertical and Aligned from Dimension type list in Inspector 
window and click to specify the dimension object position. 

To create angular dimension 

1. Select Angular  from Draw > Dimension submenu. Set options in Inspector 
window if necessary. 

2. Specify the angle by three mouse clicks: first for angle vertex, others for 
directions. Watch the dashed contours of dimension text. 

 If the arc is already selected, then there is no need to specify the dimension of 
the object. Click once to specify the dimension. 

3. Move the mouse pointer until the desired position of the dimension text is 
reached and click again. Note that if the mouse pointer is too close to the angle 
vertex and the dimension text does not fit in, then it is placed outside the 
measured sector. If the mouse pointer crosses the inner side of angle, then the 
outer angle is measured and vice versa. 

   
Angular dimensions examples 
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To create radial or diametral dimension 

1. Select Radial  or Diametral  from Draw > Dimension submenu. Set 
options in Inspector window if necessary. 

2. Click on the centre and on a point on the circle (both for radius and diameter). 
Watch the dashed contours of dimension text. 

 If the circle or arc is already selected, then there is no need to specify the 
dimension object. Click once to specify the dimension. 

3. Move the mouse pointer until the desired position of the dimension text is 
reached and click again. Note that the text that does not fit into the circle is 
placed outside. 

  

Radius and diameter dimensions examples 

Editing dimension objects 

The dimension object can be edited using grips and changing properties in the 
Inspector window. 

To edit dimension object using grips 

1. Select the dimension object. The grips appear. Square and diamond-shaped 
grips allow the dimension lines to be edited. The position of text can be changed 
by moving the grip next to it and also the vertex of the angle by moving the 
round grip of the angular or circular dimension objects. 

  
The examples of dimension objects with grips  

Some properties of dimension objects 

Edit dimension properties in the Inspector window. 
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Line Type 

Scale 

Width 

Type 

Sets line properties. 

Start Marker 

End Marker 

Start and End Marker Scale 

Defines the shape and scale of makers at the 
ends of dimension lines. 

Text Style 

Style Select text style. 

Font 

Height 

Width Factor 

Oblique 

Text properties. 

Dimension Style 

Text Color  Sets color for text of dimension object. 

Text Orientation  Text can Split Dimension Line or can be placed 

Above Dimension Line. 

Inside Text Orientation Defines orientation of the dimension text when it 
is situated inside extension lines. Text can have 
Horizontal or Parallel Dimension Line orientation. 

Outside Text Orientation Defines orientation of the dimension text when it 
is situated outside extension lines. Text can have 
Horizontal or Parallel Dimension Line orientation. 

Text Precision Defines the number of digits after decimal. The 
text precision value can be set to the Default 
value, which means that the text precision will be 
inherited from the current coordinate system 
precision. For more information about coordinate 
system see page 64. 

Number Decimal Symbol Specifies a symbol between integral and 
fractional part of dimension value (period, 
comma or space). 

Text Gap  Defines the gap when text splits dimension line. 

Text Offset  Defines how far text is shown above a dimension 
line.  

Extend Line Break Length  Extension lines begin next to measured object. 

Extend Line Over Distance  Extension lines end further than dimension line. 
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Dimension Lines Shows dimension lines of dimension object: 
None, First, Second, Both. 

Extension Lines Shows extension lines of dimension object: 
None, First, Second, Both. 

Markers Position  Defines the position of markers related to 
extension lines. 

Markers Leadering The length of dimension lines when Markers 
Position is set to Outside Extension Lines. (note 
that there are two Outside options) 

Text Position Text can be placed anywhere. There are several 
predefined positions (inside or outside dimension 
lines) and also the User Defined option, which 

can be used to precisely set the text position. 
The On Shelf option draws a connecting line 
between text and the dimension line.  

Number Scale Scales (increases or decreases) value of 
dimension object. (Suitable if the drawing isn't at 

a scale of 1:1). 

Scale Overall Sets scale of displaying graphic elements (text, 
arrows) of dimension object on the screen. 

Brackets Encloses dimension text in brackets of specified 
shape: [Square], (Round), {Braces}, <Angle>, 
None. 

Dimension 

Style  Sets dimension style for dimension object. 

Orientation This parameter is available only for linear 
dimension objects and specifies orientation 
(type) of linear dimension object in the drawing: 
Aligned, Horizontal,. Vertical.  

Text 

 

Contains text and special symbols that are 
interpreted when creating and editing the 
dimension object in the document 

Special symbols are the following: %N for linear 
dimensions, %R for radial, %D for diametric and 
%NU for radial. They are inserted automatically 
into the Text field when choosing dimension 
type. They can be combined with other text 
symbols, for example, the string “This line %N 
cm” in Text field becomes “This line 12 cm”, 
“This line 15 cm”, etc in the document, 
depending of measured object‟s length. 
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Underline Text  Specifies additional text under dimension line. 

Geometry 

Centre 
Radius 
First 
Second 

Precise coordinates of dimension object 
components. 

Shift Angle The dimension object is skewed (if applicable). 

 

To explode a dimension object 

1. Select a dimension object. 

2. Choose Explode form Modify menu. 

The dimension object is exploded to separate lines and text. 

Dimension styles 
Dimension objects inherit values of their parameters from dimension styles. A 
dimension style for a dimension objects defines in the Style item of the Dimension 
section in the Inspector dialog. 

 
If parameters of dimension style are change, the parameters of all dimension objects 
using this style are also change. 

The Dimension Styles dialog uses for creating and editing dimension styles in the 
program. 
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The preview window displays dimension objects, which edited dimension style is 
applied to. 

To make a style current 

New dimension objects are created on a base of a current dimension style. A 
dimension style can be made current by selecting it from the Style list and pressing 

the Set current button. Current dimension style is marked with a tag  . 

To create a new dimension style 

Press the New button to create a new dimension style. The Create New Dimension 
Style dialog will appear. 

1. Enter a name of a new style. 

2. From the dropdown Start With list specify a base style to create a new style. A new 
style will inherit the values of base style parameters. 
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3. In the Use For field choose All dimensions. 

4. Press OK. A new style will be displayed in the list of styles. 

 

Substyles of dimension styles 

A dimension style can includes substyles for the certain dimension type: 

 linear dimensions; 

 angular dimensions;  

 radius dimensions; 

 diameter dimensions. 

For example, if the ISO-25 style is created and contain a substyle for linear 
dimensions – Linear, then any linear dimension object based on the ISO-25 style will 
inherite parameters from the Linear substyle. If a base style does not have a substyle, 
then settings of a base style are used. 

To create a substyle 

Press the New button to create a substyle. The Create New Dimension Style dialog 
will appear.  

1. The program specifies a name of a substyle automatically. The name of a substyle 
will have a name of a base style and a dimension type for which the substyle is 
created. For example, New style: Linear. A style name in the top field of the dialog will 
be blocked.  

2. In the Start With field specify the style which the substyle will be created for. 

3. From the Use For dropdown list specify type of dimension objects which the 
substyle will be created for. 
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4. Press OK. Substyle will be displayed in the list of styles under the name of a base 
style. 

 

To delete a dimension style 

A dimension style can be deleted in case it is not set current or not appointed for one 
dimension object in the document. To delete dimension style select it from the list and 
press Delete button. 

Editing basics 
RxSpotlight offers a wide range of tools for editing vector and raster (hybrid) objects. 

Raster objects that look like lines, arcs, or circles are treated by many editing 
operations as if they were vector objects. They can be considered as raster objects: 
raster lines, raster arcs and raster circles.  

Separate RxSpotlight objects or groups of objects can be edited, object properties 
modified in the Inspector window or by using grips. They can also be moved, copied, 
duplicated, rotated, scaled, mirrored, flipped in horizontal and vertical directions, align 
to other objects, and vector objects or images can be duplicated by such vector 
objects as lines, arcs, and circles. In many of these operations the Copy feature can 
be used to create multiple copies of edited objects. Such operations as breaking, 
extending and trimming objects, correcting to intersection, creating fillets and 
chamfers, exploding to constituent parts and many others can be applied. The 
selection set can include both raster and vector objects.  After editing operations the  
nature of objects does not change: That is, raster objects remain rasters and vector 
objects remain vectors.  

RxSpotlight supports a separate set of tools to edit polylines. 

There is also a set of Autocorrection tools and manual correction tools that can be 
applied to vector objects resulting from automatic vectorization. 
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 For more information about auto correction of vectors see page 275. 

The Paste Special and Paste Separate commands in the Edit menu add flexibility to 
operations that copy and paste raster data. 

Editing with grips and object border 
When RxSpotlight objects are selected (vectors, raster images, and raster objects), 
the form of selection highlighting depends on the nature of the selected object and the 
combination of selection methods and modes applied. 

The grips mark the controls of a selected object. For example, when selecting a line, 
grips appear on its end points. When selecting a group, each member of the group is 
marked with its own grips. If selecting a block or special object like multiline text, then 
grips appear at its insertion point. Using grips, the geometric properties of a selected 
object can be modified with the mouse.  The grip‟s size and colour can be changed in 
the Grips section of the Preferences dialog. The grips are also used to mark a 
selected image and to scale, move and rotate it. The selected image is also 
highlighted with a dashed border. The selected fragments of images are highlighted in 
colour and with a dashed border. 

Drag-and-drop can be used on selected RxSpotlight objects to move them inside the 
document or between loaded documents. Objects can also be dragged in or out the 
RxSpotlight Clipbook and selections saved for future use. Selected objects can be 
copied, cut, and pasted inside the document or between loaded documents using 
commands from the Edit menu.  

 For more information about the selection modes and methods see page 103. 

Editing Object Properties  
All properties of RxSpotlight objects can be viewed in the Inspector window. They can 
be edited as the layer an object belongs to, colour, type, and line width in the 
Properties toolbar. 

 For more information about the Inspector window and Properties toolbar see 

“Inspector” on page 40. 

Universal objects editing operations 
These commands can be applied to such RxSpotlight objects as raster or vector 
objects, raster images, and raster selection.  

The Inspector window can be used to display the parameters of a current command 
or selection.  

Before running these commands, select some RxSpotlight objects. 

Move 

1. Choose Move from the Modify menu or press the  button on the Modify 

toolbar. 

2. Specify the start and end points for moving. 
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Selected objects can also be moved by steps in vertical or horizontal directions 
pressing the arrow keys on the keyboard. The step size and grid usage are specified 
in the Grid setup dialog, described on page 306. 

Copy  

1. Choose Copy from the Modify menu or press the  button on the Modify 

toolbar. 

2. If necessary, then specify the number of copies in Copy of the Inspector toolbar.  

3. Specify the start and end points of moving. 

Duplicate 

Choose Duplicate from the Modify menu or press the  button on the Modify 

toolbar. The shift distance of newly created object equal to one RxSpotlight grid 
step. 

Rotate  

 

1. Choose Rotate from the Modify menu 

or press the  button on the Modify 

toolbar. 

2. If necessary, then specify the number 
of repetitions of rotation in the Copy 
field of the Inspector toolbar. Setting 
Copy to 0 removes the original object 
and creates one rotated copy. 

 

3. Specify a point around which objects 
are to be rotated: enter its coordinates 
in Centre of the Inspector toolbar or 
specify it on the screen, using the tool 

, which is displayed when this box 

is activated.  

  

 

4. Enter a rotation angle in Angle of the 
Inspector toolbar or specify it on the 

screen with two points. In the latter 
case, the result of the Rotate 
command is displayed on the screen 
with rubber lines until the command is 
completed by pressing the mouse 
button. 
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 The result. 

 If the rotation centre coordinates is 
not specified in step 3, then object(s) 
are rotated around the geometrical 
centre of selection. 
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Scale  

 

1. Choose Scale from the Modify menu 

press the  button on the Modify 

toolbar. 

2. If necessary, then specify the number 
of copies in Copy of the Inspector 
toolbar. Setting Copy to 0 removes 
the original object and creates one 
scaled copy. 

 

3. Specify a point by which objects are 
to be scaled: enter its coordinates in 
Centre of the Inspector toolbar or 
specify it on the screen using the tool  

, which is displayed when this box 

is activated. 

 

4. Scale field contains a multiplier of 

dimensions of the selection applied on 
each scaling step. This can be set by 
controlling rubber-lines in the screen 
with the mouse. 

 

 The result. 

 If the scaling centre coordinates is not 
specified on step 3, then object(s) are 
scaled from the geometrical centre of 
selection. 

 

Mirror 

1. Choose Mirror from the Modify menu or press the  button on the Modify 

toolbar. 

2. To erase the original object, choose 0 from Copy of the Inspector toolbar; 
choose 1 to leave the original object intact. 

3. Enter the coordinates of mirror axis start point in Start of the Inspector toolbar or 
specify its position on the screen. 

4. Enter a rotation angle of the mirror axis relative to the  positive X-axis in Angle of 
the Inspector toolbar or specify the second point of mirror axis on the screen. 
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Flip Horizontal or Vertical: 

These commands are similar to Mirror. The selected objects are mirrored by the 
central horizontal or vertical axis of the selection without keeping initial objects. 

Choose Flip Horizontal or Flip Vertical from the Modify menu or press the  or 

 button on the Modify toolbar. 

Aligning  

Selected RxSpotlight objects can be aligned to other objects. 

 
This figure presents two fragments of different scales, which can be joined using Align. The 
result of the operation is shown on the next figure. 
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To align RxSpotlight objects: 

1. Select a RxSpotlight object to be aligned. 

2. Choose Align from the Modify menu or press the  button on the Modify 

toolbar. 

3. Specify the first point (point 1) on the aligned object; this point must be pulled to 
the corresponding point of the object (point 2) - the first object is to be aligned to 
the second one.  

Specify point 2. 

Specify the second point (point 3) on the aligned object; this point must be pulled 
to the corresponding point of the object (point 4) - the first object is to be aligned 
to the second one. 

Specify point 4. 

Creating an Array 
This command is used to create a two-dimensional array of selected objects with a 
specified number of rows and columns.  

To create an array: 

1. Select an object or objects to be multiplied.  

2. Choose Modify > Array or press the  button on the Modify toolbar. The 

Inspector window shows Rows, Columns and Angle fields. 

 Type in the number of rows and columns in the array; the angle value can be 
typed in or specified by mouse click in the document. 
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3. After specifying the angle the dashed contours of the multiplied objects are 

shown and a new field shows in the Inspector window: Row offset. The distance 

between objects in a row can be specified by typing it in or clicking the mouse 
button when the dashed contours fall into the desired position. 
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4. Finally the Column offset field must be filled or click the mouse button when 
dashed contours of multiplied objects form the columns of the array. 

  
 The result – array of flowers. 

  

Duplicate by vector 

Use this command to copy selected RxSpotlight objects along such vector objects as 
lines, arcs, and circles. 

A vector object, along which RxSpotlight objects are duplicated, is proportionally 
divided in accordance with the specified number of copies for the duplicated object. 
The duplicated object insertion point can be specified, were the duplication is to be 
performed. Otherwise the insertion point will be the selection geometric centre.  

The copies are rotated when copying an object by arc or circle. 
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This figure shows the result of applying Duplicate by vector to object 1 by vector line 2 

To Duplicate by vector 

1. Select the RxSpotlight object or objects to be duplicated by vector. 

2. Start the Duplicate by vector command: 

Choose Duplicate by vector from the Modify menu or press the  button on 

the Modify toolbar. 

3. Specify the number of copies in Copy of the Inspector toolbar. 

4. Specify the insertion point for the duplicated objects: enter its coordinates in 

Origin of the Inspector toolbar or specify it on the screen using the  tool, 

which is displayed when this box is activated.  

If the centre coordinates have not been specified, then Duplicate by vector will 
be performed by the central point of the selection. 

5. Using the pointing device specify an object (line, arc, or circle), by which 
Duplicate by vector will be performed. 

Composing complex objects  
To insert a complex object composed of several objects in the document, use one of 
the following methods: 

1. Create a block (see page 235). The advantage of using this method is that a block 
definition is saved with the document and an unlimited number of blocks can be 
inserted. All block insertions in the document can also be changed automatically by 
changing the original block definition. 

2. Create a group of objects (see page 257). A group is a unity that can be copied and 
multiplied using the Paste command in the Edit menu. When closing the document, 
the information relating to the objects‟ grouping is saved. 

RxSpotlight can also create and save Markers in separate files to indicate line ends 
(see page 258) and Fill Shapes to fill closed areas (see page 261).  

Complex objects can also be used in the search-replace procedure, as well as in the 
training symbol recognition procedure (see page 198). 
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Note that the RxSpotlight Clipbook feature can also be used (see page 72) to facilitate 
working with complex objects. 

Groups 
A group is made up of multiple RxSpotlight objects united in order to apply various 
commands to them. Commands can be applied to several selected objects without 
grouping them, but in this case the next selection will replace the previous. Forming a 
group allows the selection to be saved for use at a later time and also allows other 
objects to be selected without changing the group contents.  

A group can be set with the Group command, which is applied to selected objects, 
and ungrouped with Ungroup. 

An object that belongs to a group is selected, the Inspector window displays the 
message that more than one object is selected. All the grouped objects on the screen 
can be seen by selecting any of the objects that belong to the group, and then running 
Zoom Selected from the View menu. 

To set Group 

1. Select the required RxSpotlight objects. 

2. Choose Group from the Modify menu or press the  button on the Modify 

toolbar. 

To ungroup 

1. Select one of the grouped objects. 

2. Choose UnGroup from the Modify menu or press the  button on the Modify 

toolbar. 

Exploding blocks and complex objects 
Exploding objects converts composite objects back to their constituent parts. For 
example, exploding such objects as polylines or rectangles reverts them to simple 
lines and arcs. A block is exploded to a set of constituent objects. 

One operation of the Explode command explodes composite objects by one level 

only. When exploding a block that contains a polyline, the polyline needs to be 
exploded separately. 

To explode objects 

1. Select block or vector object to explode. 

2. Choose Explode from the Modify menu or press the  button on the Modify 

toolbar. 
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End Markers 

 
Polyline decorated with markers of arrow and 
filled circle shapes 

End Markers are special objects that 
can be added to the end points on 
linear objects: lines, arcs, and 
polylines during drawing. The most 
common example of an End Marker is 
an arrow.  

Several predefined markers can be 
used, replaced, and new ones created 
and saved for future use. 

 

To add a marker to the end of the line 

1.  Draw an object or select an existing one. 

2. Open the Inspector window (  button). 

3. From Line Type select any option other than By Layer or By Block. The list will 
change and new fields will appear:  

  
4. Choose Start and End Markers and specify Scale values – the multipliers of the 

marker objects size. 

New drawn objects can be decorated with chosen markers. . 

 

To create End Marker 

1. Select one or several vector objects. 

  
This selected closed polyline is ready to be converted into a marker; 
it may be filled, and may also be composed of several objects. 
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2.  From the Tools menu select Create Marker command or press  button on 

Draw toolbar. 

3. The selected objects will appear in the Create Marker dialog box: 
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4. To create a marker, click the  button and specify a marker origin as the 

centre of the square-shaped cursor. Note that end markers must be prepared so 
that they fit to the horizontal line coming out of the marker origin using the 
Create Marker dialog. 

  

5. Click  button to save the marker. The MARKERS subfolder is used to save 

marker definitions; all markers saved in *.MRK files of this folder are 
automatically loaded during a RxSpotlight session. 

Buttons in Create Marker dialog box 

 
Create marker from 
selection 

Places a selected object from the document 
workspace to Create Marker window 

 Load marker from file Opens *.MRK file and loads marker to Create Marker 
window 

 
Save Saves a marker in *.MRK file 

 
Save As Saves a new or changed marker in a new *.MRK file 

 

Pick Marker Origin Allows users to specify the origin point to which a 
line end would be attached 

Zoom buttons in the window bottom allow the details to be seen. The Fit button (with 
letter “f”) scales the marker to fit the Create Marker window. 
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Fill Shape symbols 
Custom shapes can be created to fill closed objects. In RxSpotlight you several 
predefined shapes can be used, replaced, and new shapes created and saved for 
future use. All shape definitions are located in the FILLSHAPES subfolder of the 
RxSpotlight program folder as *.SHF files. They are automatically loaded at the start 
of each RxSpotlight session. 

To fill a closed area with shapes 

1. Select a closed object – circle, closed polygon, rectangle, etc. 

2. Open the Inspector window (  button). 

3. Select TRUE in Filled, then ShapeFill in Hatch Type and then select a Hatch 
Shape. 

The selected object will be filled with shapes placed on the vertices of an 
invisible rectangular grid. 

4. Specify Hatch Step and Hatch Angle to modify the size and orientation of this 
invisible rectangular grid. 

  

The filling shape specification in the 
Inspector window 

Result 

To create a fill shape symbol 

1. Select one or several vector objects. 

2. From the Tools menu select the Create Fill Shape command or press  

button on the Draw toolbar. 

3. The selected objects will appear in the Create Shape dialog box 

4. Click  button to save the shape. The FILLSHAPES subfolder is used to save 

shape definitions; all shapes saved as *.SHF files of this folder are automatically 
loaded during a RxSpotlight session and their names appear in the Hatch Shape 
list. 

 
Buttons in Create Shape dialog box 

 
Create a shape from 
a selection 

Places selected object from the document 
workspace to the Create Shape window 

 Load shape from file Opens *.SHF file and loads a shape to the Create 
Shape window 

 
Save Saves a shape as a *.SHF file 
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Save As Saves existing or changed shape in a new *. SHF 

file 

Zoom buttons in the window bottom allow the details to be seen. The Fit button (with 
letter “f”) scales a shape to fit the Create Shape window. 

Editing vector objects 
The operations described in this section can be applied only to vector and raster lines, 
arcs and circles, polylines, and polygons. 

Offsetting 
Offsetting creates a new RxSpotlight vector object similar to that which is specified. 

To offset an object (or objects) 

1. Select object(s). 

2. Choose Correct>Offset or press the  button on Vector Correction toolbar. 

Select one of the proposed positions for offset copy. Specify Offset distance in 
the Inspector window or click to confirm. 

The lines are duplicated. Polylines, polygons, arcs, rectangles and circles are 
supplied with enlarged or reduced copies. 

  
Offsetting outside creates a larger 
object. 

Offsetting inside creates a smaller object, 
or nothing, if the Offset distance is too 
large. 

Merging with converting vector types 
Due to the poor quality of some raster objects, vector objects obtained from automatic 
vectorization sometimes need to be corrected. Such correction is needed when after 
recognizing such objects as lines, circles, arcs, and polylines, a number of separate 
vector fragments are obtained. For example, several line segments are obtained 
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instead of a single continuous vector line, a raster circle was recognized as a number 
of arcs, a polyline as a number of arcs and segments, etc. 

The commands described in this section allow users to merge selected vector 
fragments to a single object. The type of object can also be changed. For example, if 
a raster circle was incorrectly recognized as a polyline. 

Though the merging commands are called Merging vectors to… and the descriptions 
of other commands in this section instruct how to edit vectors, these commands can 
also be applied to raster objects. 

Merging Vectors to Polyline 

This command will merge arbitrary vector fragments to a polyline. 

 
Vector objects in the upper part of the drawing were converted to a polyline 

To Merge Vectors to Polyline 

1. Select the vectors to merge to a polyline. 

2. Choose Merge Vectors to > Polyline from the Correct menu or press the  

button on the Vector Correction toolbar. 

Merging Vectors to Circle 

This command will merge arbitrary vector fragments to a circle. 
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Vector objects in the left part of the drawing were converted to a circle 

To Merge Vectors to Circle 

1. Select the vectors to merge to a circle. 

2. Choose Merge Vectors to > Circle from the Correct menu or press the  

button on the Vector Correction toolbar. 

Merging Vectors to Arc 
This command will merge arbitrary vector fragments to an arc. 

 
Vector objects on the left of the drawing were converted to an arc 

To Merge Vectors to Arc 

1. Select the vectors to merge to an arc. 

2. Choose Merge Vectors to > Arc from the Correct menu or press the  button 

on the Vector Correction toolbar. 
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Merging Vectors to Line 
This command will merge arbitrary vector fragments to a line. 

 
Vector objects in the upper part of the drawing were converted to a line 

To Merge Vectors to Line 

1. Select the vectors to merge to a line. 

2. Choose Merge Vectors to > Line from the Correct menu or press the  button 

on the Vector Correction toolbar. 

Merging Vectors with auto defining of the resulting object type 

RxSpotlight can automatically define the type of vector object obtained via merging. 
The set of selected fragments is analyzed and converted to the object that is the 
closest in geometry to the selected set. 

To Merge Vectors Auto 

1. Select the vectors to merge. 

2. Choose Merge Vectors to > Auto from the Correct menu or press the  button 

on the Vector Correction toolbar. 

Converting polyline to spline 
The Convert to Spline command from the Correct menu converts a selected polyline 
to a spline; the polyline nodes are used as fit points. A spline can be also draw with 
the Spline command from the Draw menu. 

The conversion of a closed polyline results in a closed spline. 

A spline can be converted to a polyline using the MergeVectors to Polyline command 
from the Correct menu or the Explode command from the Modify menu. 

To convert a polyline to a spline 

1. Select polyline(s) to convert. 

2. Run the Convert to Spline command from the Correct menu. 

The polyline properties that are typical of a spline will be inherited (for example, end 
markers, fill type and others) by the created spline. 

Creating chamfers 
A chamfer is a line object that connects two nonparallel lines or polylines. The 
connected lines or polylines are trimmed or extended if necessary. 
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There are two methods to create a chamfer: by specifying two distances and by 
distance and angle. 

   
Original objects Chamfer by two distances  Chamfer by distance and angle  

To create a chamfer: 

1. Select two vector lines. 

2. Choose Correct > Create Chamfer or press  button on the Vector Correction 

toolbar. 

3. Choose chamfer creation method in the Chamfer method field of the Inspector 
window. Specify two distances or an angle and distance. 

4. Using the mouse, select one of the chamfers. 

    
Following the mouse, RxSpotlight

 

offers several positions for the chamfer 

 

5.  Set Correct vectors to FALSE if lines are not to be extended or trimmed; 
otherwise set TRUE. 

  

Correct vectors is FALSE Correct vectors is TRUE 

6.  Click ESC to finish chamfer creation or choose Exit from the right button menu. 

Creating fillets 
A fillet connects two objects with a smooth fillet arc of a specified radius. A fillet can 
be applied to lines, arcs, and circles. The radius of an arc that connects filleted object 
is called a fillet radius. The radius value of a fillet arc, when doubled, cannot be less 
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than the minimum distance between the two filleted objects. When filleting objects, 
specify a fillet radius and choose to trim or not to trim the filleted vectors.  

 
Objects selected for filleting Results (Correct Vectors is TRUE) 

To fillet Vectors 

1. Select two or more vector objects to fillet. 

2. Choose Create Fillet from the Correct menu or press the button  on the 

Vector Correction toolbar. 

An auxiliary arc appears on the screen. Its radius is equal to the last fillet value 
applied. 

3. Open the Inspector window to redefine the fillet radius and choose the mode to 
trim or not to trim filleted vectors. 

Enter the fillet radius in the corresponding box of the Inspector toolbar. 

In Correct Vectors set TRUE to trim the filleted vectors, or FALSE if the filleted 
vectors are to remain untrimmed. 

4. Move the auxiliary arc to the pair of objects to be filled and choose the right 
position of the fillet. 

5. Click to accept changes. 
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The two lines filleted with   The two lines filleted with 
Correct Vectors set to TRUE  Correct Vectors set to FALSE 

Correcting to intersection 
This command is applied to correct vector objects which are supposed to be joined at 
an intersection by trimming or expanding accordingly. Correct to intersection can be 
used on a pair of lines, arcs, and circles as well as different combinations of these 
objects. 

 
The objects selected for   Results 
Correction to Intersection 

To correct to Intersection 

1. Select one or more vector objects to correct to Intersection. 

2. Choose Correct To Intersection from the Correct menu or press the  button 

on the Vector Correction toolbar. 

3. If the object is expanded, then the screen displays an auxiliary line, which 
indicates the expected position of the vector object.  

4. Move the cursor to the appropriate pair. The expected position of the objects is 
highlighted on the screen. 

5. Click to accept changes. 
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Correcting by Edge 
Edge is a temporary set of vector objects with a special function. The vector objects 
included in Edge are a contour, which can be used with the commands 
Break/Expand/Trim from the Modify menu. Use Edge to trim vector image parts that 
are outside the Edge, trim vector objects by the Edge, and also expand vector lines 
up to the Edge. Objects that compose an Edge are highlighted with specific 
highlighting; the number of objects that compose Edge can be seen in the Inspector 
window. 

Only one Edge can be set in the document; if a new one is set, the previous is 
automatically ungrouped. The Edge contents are not saved when closing the 
document unlike the contents of a group or a block. 

Tune the parameters of Edge display, as well as colour and width by highlighting в the 
Preferences dialog box. 

 For more information about Preferences see “Tuning the application” on page 

389. 

To set an Edge 

1. Select objects to compose an Edge that can be defined by one or more objects. 

2. Choose Group/Ungroup Edge from the Correct menu or press the  button 

on the Vector Correction toolbar. 

Breaking vectors 
Vector objects, such as lines, arcs, circles, polylines and others can be broken into 
smaller parts using the Break command. It is possible to specify points on the vector 

object at which to break it, and also a break boundary by which the selected vector 
objects are supposed to break. Edge can be used as a break boundary.  

To Break vectors 

In the following example the raster line is broken into three segments. The break 
points are specified on the object. 

 
Break points   Result 

1. Choose Break vectors from the Correct menu or press the  button on the 

Vector Correction toolbar. 
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2. Specify the points on the vector object at which to break it.  

To Break vectors by break boundary 

In the following example, first select a line, which will be a break boundary, then 
specify the objects to be broken. The boundary can be defined by one or more 
objects. 

 
Selected break boundary Result (selected objects above 

the break boundary) 

1. Select the vector object or objects to break by boundary. 

2. Choose Break vectors from the Correct menu or press the  button on the 

Vector Correction toolbar. 

The vector objects that were defined as the cutting edge will be highlighted. 

3. Specify one by one the vector objects to be broken. 

To Break vectors by Edge 

In the following example, first specify an Edge, and then select the objects to be 
broken by this Edge. 

 
Before applying Break by Edge  Result 

1. Set an Edge. 

 For more information on setting of the Edge see page 269. 

2. Select vectors to break. 
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3. Choose Break vectors from the Correct menu or press the  button on the 

Vector Correction toolbar. 

Extending vectors 
Vector objects can be extended so that they end precisely at the boundary defined by 
other objects. One or several selected objects can be used, and also Edge as a 
boundary. 

To Extend vectors by boundary 

In the following example, first select a line that will be a boundary, and then specify 
the objects to be extended to the boundary. 

 
Selected extend boundary   Result 

1. Select the vector object or objects to specify a boundary. 

2. Choose Extend Vectors By Edge from the Correct menu or press the  button 

on the Vector Correction toolbar. 

3. Select vector objects to be extended one by one. 



RxSpotlight User Guide 

272 

To Extend vectors by Edge 

In the following example first specify an Edge, and then select the objects to be 
extended to this Edge. 

 
 Before applying Extend by Edge  Result 

1. Set the Edge. 

 For more information on setting of the Edge see page 269. 

2. Select the vectors to expand. 

Note: this command can only be applied to non-closed vector objects. 

3. Choose Expand vectors By Edge from the Correct menu or press the  

button on the Vector Correction toolbar. 

Trimming vectors 
An object can be trimmed precisely to the boundary defined by one or more objects. A 
trimming boundary can be composed of lines, arcs, circles, polylines, and others. If a 
trimming boundary has any width, then the objects to be trimmed are trimmed along 
the centreline of this boundary. An Edge can be used as a boundary. 
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To Trim vectors by boundary 

In the following example, first select a line that will be a trimming boundary, then 
specify one by one the objects to be trimmed. 

 
Selected trimming boundary   Result 

1. Select a vector object to be used as a trimming boundary. 

2. Choose Trim Vectors By Edge from the Correct menu or press the  button 

on the Vector Correction toolbar. 

3. Specify a part of the vector object to be trimmed. 

To Trim vectors by Edge 

In the following example, first specify as Edge, then select the objects to be trimmed 
by this Edge. All parts of the selected vector objects located outside the Edge are 
trimmed. 

 
Before applying Trim by Edge  Result 

1. Set an Edge.  

 For more information on setting of the Edge see page 269. 

2. Select the vectors to trim. 

 This command can only be applied to non-closed vector objects. 
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3. Choose Trim vectors By Edge from the Correct menu or press the  button 

on the Vector Correction toolbar. 

Aligning angle and distance 
This command can be very useful to align lines, arcs and circles. Lines are aligned by 
one of the lines so that the resulting lines are parallel; arcs and circles become 
concentric after alignment. 

To align objects' angle and distances: 

1. Select the objects to be aligned and choose Correct > Align angle and distance 

or press the  button on the Vector Correction toolbar. 

2. Place the mouse cursor near the aligning object. RxSpotlight will suggest various 
positions for the aligned objects. 

3. Set aligning options in the Inspector window (see description below). 

 

RxSpotlight suggests one of 
two possible positions for the 
created object (thin lines), 
depending on the position of 
the mouse pointer (cross), 
The resulting arcs are 
concentric. 

 

4. Press ENTER to confirm aligning. 

The command has two options that can be controlled in the Inspector window. 

If Auto resizing is set to FALSE, then the distance between aligned lines or radiuses 
of aligned arcs and circles can be set in the Distance field. A zero value in the 
Distance field means that no resizing is applied – lines preserve their native positions 
and only angles are changed; circles and arcs preserve native radiuses. If Auto 
resizing is set to TRUE, then RxSpotlight aligns objects automatically, spreading them 
at even distances to each other across the selection. 
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The pictures represent the 
suggested result of 
alignment of lines by the 
third one from left (note 
cross cursor near it). 

The Auto resizing is TRUE 
and the Distance is 
calculated automatically. 

 

The Auto resizing is 
FALSE and the Distance is 

set to a relatively small 
value. 

 

 

Now the Auto resizing is 
FALSE and the Distance is 
set to 0. 

The lines are only rotated 
around their centre points 
to align angles with the 
third line from the left. 

When aligning circles and arcs with Align Angle and Distance the centres of aligned 
circles must fall inside the aligning circle. 

The most common usage (but not the only one) of Align Angle and Distance 
correcting vector objects created during automatic vectorization. If the selection 
contains objects of different types, then RxSpotlight will do its best to perform aligning. 
If confused with the operation of these commands, then try simple examples first. 

Vector auto correction  
This procedure is intended for automatic correction of automatic and semi-automatic 
vectorization (tracing) results. It processes such vector objects as lines, arcs, and 
circles. After applying Auto correction it is also recommended to apply manual vector 
correction, if needed. 

The results of Auto correction performance depends on the width of corrected vectors. 

Autocorrection allows users: 

 To restore the contact of lines with arcs and circles 

 To “stick together” vector fragments in entire objects 
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 To delete vector objects if their size is smaller than specified. A line size is 
defined by its length, a circle size – by diameter, an arc size – by its largest 
projection onto the X and Y-axis. 

 To align lines to regular directions (angle 0°, 30°, 45°, 60°, 90°, etc.) if their 
deviations from the specified values do not exceed the specified value. 

 

To tune the Auto correction parameters 

1. Choose Vector Correction Options from the Convert menu or press the  

button on the Vector Correction toolbar. 

The following dialog appears: 

 

2. Turn on the Restore Tangents checkbox to restore the contact of lines with arcs. 
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Before applying Restore Tangents  Result of the Autocorrect command 

3. Turn on the Merge Vectors checkbox to “stick together” vector fragments into 
one object. 

 
The lower figure shows the result of applying Merge for these three lines. 

4. Turn on the Remove Small checkbox if automatic vectorization created some 
vector speckles – i.e. small vector objects that are not required.  

The size of a vector speckle is defined in one of following ways: for a line – by its 
length, for a circle – by its diameter, for an arc – by its largest projection onto the 
X and Y-axis. 

Specify the maximum size of speckle – all speckles with a size less or equal to 
this value will be removed. 

Enter the maximum value for vector speckle in Remove Small. The 

measurement tool can also be used. Click on  and specify two points on the 

document, which define the size of a vector speckle. 
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Before applying Remove Small Result of the Auto correct command 

5. Enter the required value of Correction Accuracy in the corresponding box. Use 
high Accuracy for images of good quality, low for images of poor quality. 

6. Turn on the Align Lines checkbox to use the feature of line alignment to regular 
angles. 
Enter the deviation angle value in Align Lines – the command will align regular 

angles to those lines who‟s deviations from the regular directions are equal to or 
smaller than the specified angle. 

7. Choose Vector Autocorrect from the Convert menu or press the  button on 

the Vector Correction toolbar. 

Example of auto correction of vectorization results 

In this example the Autocorrection command expands and trims selected vectors by 
correcting their intersections. 
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Polylines collecting 
The Collect Polylines command is designed for assembling vector polylines obtained 

as a result of the trace or automatic vectorization. When checking the results it is best 
to use the raster image as a substrate. 

Choose the Collect Polylines from the Correct menu to start this command 

Click the first polyline. 

While the cursor is moving, which polyline will be added to the current one, and the 
result, can be seen. Choose the next polyline by clicking on it. Click the next polyline. 
The program automatically pans to the end point of the resulting object. 

Use right-button menu during command running: 

Back step Cancels the latest step. 

Cancel Cancels the command and current polyline creation. 

Continue Continues the command. 

End Finishes current polyline collecting. 

Close Closes the current polyline. 

Change 
Direction 

Changes the current collecting direction. 

Centralize 
View 

Pans an image to show the last added polyline nodes at 
the screen centre. 

This command adds a new item into the Inspector window Auto Properties. 

If the Auto Properties item is off (No), then the properties of the resulting polyline 

(such as its colour, thickness, markers) can be changed in the Inspector during the 

command execution. Otherwise the resulting polyline will inherit the current document 

properties. 

Collect Polylines special modes 

There are special modes for modifying the resulting object during the polyline 
assembling process: 
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Case 1: polyline 1 has a stray tail, and you need to attach it to 
polyline 2 

Press CTRL and click a 
point on the current 
polyline 1 in which it 
must be broken. 
Polyline assembling will 
continue from this point. 

 

Case 2: polyline 2, which you want to append, has a stray head 

Press CTRL and specify 
a point on polyline 2 to 
which it must be 
attached. It will be 
broken at this point and 
added to polyline 1. 
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Case 3: to close a current polyline 

Press CTRL and click 
on one of the current 
polyline end points. The 
polyline will close and 
the command will be 
finished. The closed 
polylines are highlighted 
with round, instead of 
square, grips. 

 

Case 4: to draw a segment of a polyline manually 

Press SHIFT and draw 
as many segments as 
necessary. 
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Case 5: to add some vertices to a current polyline 

Press CTRL+SHIFT 
and add as many 
vertices as necessary. 

 

Elevations arranging 
The Arrange Elevation command assigns the Elevation property to polylines with a 
specified step. It is used to assign elevation values for vectorized contour lines on 
topographical maps. When working with vector data in AutoCAD, the Elevation 
property for 2D-polylines is used as the Z-coordinate. Open the 3D View window 
during arranging elevations to see all changes in 3D projection. 

To perform the Arrange Elevation 

If polylines are selected before running the command, the command will be only 
applied to these objects. 

Start the Arrange Elevation command: click the Arrange Elevation from the Correct 

menu or click the  button on the Vector Correction toolbar. 

Set a Begin Value and a Step in Inspector. Elevations are assigned starting from 
the first object to the last one. If a step has a negative value, the elevation will go 
down from the start value. 

 

Draw a rubber line so that it will intersect 
the polylines to be assigned elevations. 
Thus, the order of intersecting objects is 
important – the first object will be 
assigned the value entered in the Begin 
Value property. The other objects will be 

assigned the values depending on the 
order and the Step parameter. 

Dynamically calculated elevation values 
for every intersected polyline will be seen 
on the screen. 

 



RxSpotlight User Guide 
 

283 

 

Calculate an elevation 
that will be assigned to 
an object according to 
this simple formula: 
Resulting value = Begin 
Value +/- order * Step. 
For example, 1000 
(starting value) + 100 
(step) * 5 (order) = 1500  

 

The Begin Value and the Step properties 

are needed only for the first polylines 
intersection step. The command 
automatically calculates the elevation of 
the newly specified polylines basing on 
the elevation of the polylines whose 
elevation value has been specified. These 
polylines are highlighted with a colour 
specified in the Highlight Colour property 

of the Inspector. There is no need to 
recalculate and re-enter Begin Value and 
Steep for every new logical group of 
isolines – they are calculated 
automatically. 

 

 

If the first polyline intersected with a rubber line has 
been processed, then the command uses its 
Elevation value as the Begin Value. If two or more 

polylines with assigned elevations have been 
intersected at the beginning, then the command 
automatically calculates the Step parameter too. 
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When working with Arrange Elevations only intersect 
polylines whose elevations are either increasing or 
decreasing, but not both together. Use two or more 
steps to process all polylines.  

 

 

To distinguish polylines with assigned Elevation values from polylines with 
unassigned Elevation values this command uses the Undefined Value property of 
the Inspector. It is equal to zero by default. The Undefined Value specifies a single 
Elevation value which will mean an unassigned elevation. All other elevation values 
mean assigned elevations. For example: 

Change the Undefined Value parameter specified as an unassigned elevation value 
to an assigned one. For example, the drawing has a ground (zero) elevation value 
is an assigned value. Then just set Undefined Value to any other (–30 for example). 

3D View 

This window shows a drawing in 3D projection where the Z coordinates represent 
elevation values. Zoom, pan and rotate a drawing in this view using the mouse and/or 
buttons. It is useful for viewing vector topographic maps. 

Various view projections and surface view styles can be specified. 
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Open the 3D View window during Arrange Elevation to trace errors as all document 
changes are dynamically reflected in this view. 

 

 The 3D view window does not show polylines whose elevations are 
equal to the Unsigned elevation value during the Arrange Elevation command 
execution. 

3D View buttons and controls: 

Rotate 

Use  buttons to rotate the 
window content. Rotate a 3D drawing using the mouse to 
drag the 3D drawing in any direction. 

Zoom 

Use  buttons to zoom in, out and zoom all. 
This can also be implemented by scrolling the mouse 
wheel. 

Pan Use the third (middle) mouse button for panning. 

View 

Use  button to change the view. Isometric, Front, 
Backward, Right, Left, Top, or Bottom can be set. 

Perspective 

Use  button to change 3D perspective. The 
perspective slider works like a zoom slider on a camera – 
it changes perspective and zoom distance simultaneously. 
To change zoom only use the zoom buttons. Switch on 
the Ortho checkbox to set orthogonal projection. 

Surface Type 

Use the  button to change 3D surface type. 

It can be represented by Isolines, Triangles or Surface. 
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To open 3D View window choose Show 3D View from the View menu. 

Automatic polylines correction 
This command is designed to correct polylines mainly produced as a result of 
automatic vectorization or tracing. Depending on the settings, it can perform merging, 
removing or the combining of polylines. Other types of objects will also be 
automatically converted into polylines.  

This command can be performed only while vector objects are selected. 

Set up the command options in Polyline Correction Options dialog. To launch this 

dialog choose Polyline Correction Options from the Correct menu or click the  
button on the VectorCorrection toolbar. 

 

Remove Small Segments 

Consolidates polyline nodes connected with a segment which is smaller or equal to 
the parameter value shown in Minimal Size to remove. A larger value causes the 
more distant nodes to consolidate into one. This type of correction allows elimination 
of overlapped and surplus segments. To achieve the best result the Minimal Size 
need to be correctly set to the remove value. This can be measured this directly from 
the document. 
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 Minimal size of the polyline segment produced as a result of automatic 
vectorization or tracing depends on the Precision parameter. The higher the 
Precision produces a smaller size of polyline segment and vice versa. 

 

Remove Small Objects 

Removes Objects smaller than the set value.  

This type of correction can be used for removal of small vector trash that has 
appeared as a result of automatic vectorization 

 

Kill Internal Objects 

If this checkbox is set, then during the correction the objects located inside the 
uncrossed closed polylines will be deleted. 

 

Merge Nearest Polylines 

Merges the nearest polylines into one by adding new segments between the 
endpoints of polylines. Minimal Distance to merge can be set up using an appropriate 
parameter. 
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Snap Nearest Polylines 

Snaps polylines located near each other. The size and location of one line changes 
when it is connected to another. This is different to the Combine Closest Polygons 
operation, where the „combination‟ does not appear as the two become one. 

 

Combine Closest Polygons 

Combines closed polylines (polygons), located closer to each other than the 
maximum size parameter value, into one object. 

 

Make Orthogonal Segment 
This changes a polyline segment to be orthogonal to another segment.  

Set the angle value directly in the „base angle‟ parameter or allow the application to 
calculate the angle automatically. 
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To start polylines automatically corrections choose Polylines Autocorrect from the 

Correct menu or click the  button on the VectorCorrection toolbar. 

To perform polylines corrections do the following: 

1. Open the file with the vector objects needing to be corrected. 

2. Estimate the correction and activate the required algorithms. Almost all 
of them require the setting up of the parameters, so do not forget to 
measure the values in the document using designated tools (ruler 
button). Setting up the parameters can be performed from the Polyline 
Correction Options dialog box. 

3. Select the vector objects that need to be corrected. 

4. Run the Polylines Autocorrect command. 

Raster Drawing and Editing 

Merge (Rasterize) 
The merging operation adds selected objects (selection) to destination raster images.  

A selection can be composed of: 

1. Raster images; 

2. Raster selection; 

3. Vector and hybrid objects to be rasterized with the Merge command. 

Destination raster images – one or several images to which the selection will be 
added. The Merge command adds the selection to all visible images located on 
unlocked layers under the selection. 

Data from the source images or raster selection with less colour depth can be merged 
onto destination images with greater colour depth, but not the other way around: 
monochrome onto greyscale and colour, greyscale onto colour (not on monochrome) 
colour onto colour only. 

When merging colour vector images on a monochrome raster image; their rasterized 
representations take the foreground colour. When merging colour vector images on a 
colour raster image; their rasterized representations keep the colour of the original 
vector objects. 

During the Merge operation only the part of the selection placed within the boundary 
of the destination images is transferred. The part of the selection placed outside the 
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boundary of the destination images is ignored. All the objects included in the selection 
disappear after the Merge is completed. 

Choose the destination raster image in Select Image For Merge combo-box on 

Modify toolbar  

- or - 

Turn off raster images visibility or place them on locked layers. 

To merge data 

1. Make the selection. Select the desired images, raster selections, and vector or 
raster objects. 

2. Specify the destination raster in the combo-box on the Modify toolbar. 

3. Choose Merge (Rasterize) from the Modify menu or press the  button on the 

Modify toolbar. 

Merge a Copy (Rasterize) 
Merging a Copy (i.e. duplication) works in a similar way to merging except it does not 
erase the source selection from the document.  

To perform duplication, use the same procedure as when merging except the 

command is called Merge a Copy and the button looks like . 

Paste, Paste Special and Paste Separate 
commands 
Two commands from the Edit menu add options to the standard Windows Cut-Copy-
Paste mechanism when handling raster fragments. 

A selection set can be composed of fragments taken from different raster images. 
Note that RxSpotlight

 
always retains information about which image was the source of 

each fragment.  

The Edit > Paste command is used to paste a copied selection set. This command 

preserves internal information of the raster fragments‟ source and every raster 
component of the selection set is pasted onto the image where it came from. 

If the image from which a fragment had been copied was removed and later the Paste 
command was performed, then this fragment is converted to a separate embedded 
image that is placed on the active layer. 

Paste Separate does not care about fragments‟ sources. It creates separate 
embedded images for every raster selection fragment and puts them on the active 
layer. Perform this command to create new images from a selection quickly.  

 For more information on embedded images see page 54. 

Paste Special merges a temporary image that unites all raster fragments of a 
selection set with the image that is chosen from the box (if there is only one image to 
paste the selection to, Select Image dialog does not show). 
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Select Image dialog that supports Paste Special command 

This command is useful to cut or copy a fragment from one image and merge it with 
another. 

Pixel Drawing and Floodfilling 
By using pixel drawing tools, raster lines can be drawn and erased on monochrome, 
greyscale, and colour images. 

When working with monochrome images, these tools allow users to draw with the 
foreground colour or erase with the background colour. When working with colour or 
greyscale images, a colour (or grey tone) can be selected to use for drawing. 

Floodfilling tools work on both monochrome and colour images. They allow the filling 
of closed raster outlines with the raster object colour (foreground) and also to erase 
isolated raster objects by filling them with the raster background colour. 

 For more information on floodfilling on colour images see page 311. 

 Note: Select the images to be processed with the above commands. 

Otherwise the commands will be applied to all raster images located 
under the cursor, if they are visible and reside on unlocked layers. 

To draw on raster images 

1. Choose the Raster > Pencil command from the Draw menu or press the  

button on the Draw toolbar. 

2. Open the Inspector to set Pen Width and colour. Type the width value in the 
corresponding box. Select the required colour from the list of Pen Colour. 

3. The raster line will be displayed as follows: with foreground colour on 
monochrome images; with one of grey tones corresponding to the brightness of 
the selected colour on greyscale images; with the selected colour on colour 
images. 

To erase on raster images 

1. Choose the Raster > Eraser command from the Draw menu or press the  

button on the Draw toolbar. 

2. Open the Inspector to set Pen Width colour. Type the width value in the 
corresponding box. Select the required colour from the dropping down list of Pen 
Colour.  
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3. The raster line will be displayed as follows: with foreground colour on 
monochrome images; with one of grey tones corresponding to the brightness of 
the selected colour on greyscale images; with the selected colour on colour 
images. 

To floodfill closed outlines  

1. Choose the Raster > Flood Fill command from the Draw menu or press the  

button on the Draw toolbar. 

2. Specify a point within a closed outline on a monochrome raster image. 

To erase by floodfilling  

1. Choose the Raster > Flood Erase command from the Draw menu or press the 

 button on the Draw toolbar. 

2. Specify any point in the isolated raster area to be erased. 

Creating new image from vector and raster 
selection 
Rasterization converts vector objects to raster objects, and the obtained raster is 
inserted into raster images. 

There are two ways to rasterized data in RxSpotlight: 

The first is to rasterized vectors by Merge or Merge a Copy commands from the 
Modify menu – see page 289. 

The second is to make a new image using New Raster from Selection command from 
the Draw menu. This way is more powerful. A newly created image includes all the 
objects included in the selection.  

The selection may include: 

1. raster images; 

2. raster selection; 

3. vector objects. 

To insert a new image from a selection 

1. Create a set of objects to rasterize. If pre-selection is absent, this command applies 
to all data in the document. 

 Selection can be performed during the New Image from Selection dialog 

is opened 

 

2. Choose New Image from Selection command from the Insert menu or press the 

 button on the Draw toolbar. 

 

3. If source images are exist and have different colors or resolution, then properties of 
destination image have to be specified: 

Color Space – choose destination image color space from the list; 
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DPI – select resolution; 

 
Width and Height – set a value for a new image or select a standard format in the By 
Paper field; 

Initial color – define a background color for a color image; 

Portrait or Landscape – select orientation of destination image. 

 

4. Set the scale: 

 
Fit Image to Selection – scales the image to fit the paper of specified format; 

Nearest Image Scale – scales source selection to the gratest possible size that fits 
specified paper format;  

Image Scale – enter scale index for destination image or select it from the list. 

To place the image relative to format boundaries, enter margin value in the fields of 
Position, Margins and Scale section. The margin value can be more or equal to 0. 

If the image is smaller than a page of the specified format, you can set alignment to a 
paper side. Click an arrow displaying required alignment type. 

If the scale is set manually, rasterization can be processed on several papers.  
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The results will be saved in separate files with adding page numbers to the tail of the 
file name. 

 
Plot style table allows you to change a color and line width of objects on destination 
image. 

 For more information on Plot style table see description of the Print Options 
dialog (chapter “Setting Printing Parameters” on page 91). 

 

5. Set saving parameters for destination image(s): 

 
Name – Set file name for destination raster image(s). 

You can use macros to set mask for the raster image name. To insert macros in the 

Name field select an appropriate one from the drop-down list and click the  

button. You can also type it mannually. The decripted name is displayed in the caption 
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of the Save As section: 

 

Macros are very useful for batch rasterization through scripts when several raster 
images should be created. 

Format – set the way of storing the image: 

 Embedded Image – store destination image in a document file. 

 Otherwise destination image will be saved in a separate file(s) of a 
selected format. 

Folder – set the folder to save the image. If Current Document Folder is selected, 
image(s) is saved in the folder of the current document. A drop-down box contains 
five previously specified folders. 

 
Mode – define a way of saving and removing vector data after rasterization. 

Insert Image – this checkbox inserts destination image, stored in a separate file, in 
current document. If Embedded Image file format is selected, this checkbox is blocked 
and switched on by default. 

To process rasterization without changing current document, switch off this checkbox 
and choose Keep Vectors after Rasterizing. 

Press OK. 

If a name for a new raster has not been specified, it will be New_(N), where N – an 
index number. 

Disabling hybrid objects for selection  
Selection of raster objects in RxSpotlight can yield two types of result: hybrid or pure 

raster. The type of selection can be switched by the  button on the Select toolbar. 

When this button is not pressed, the raster objects selected are supplied with grips 
and can be treated as vector objects. 
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Buttons , ,  are pressed and 
 

is not pressed. Three circles are clicked with 
the mouse. Raster objects are selected as 
hybrid.  

 

Use grips to resize or move them separately. 
When dragging any circle, the whole group of 
circles is moved. 

When the Disable hybrid objects for selection button is pressed, the raster objects 

selected are pure rasters and more complicated operations can be used to change 
the selection set. 

 

Buttons , ,  are pressed and 

also  button on Select toolbar is 

pressed. Three circles are added to selection 
set that is raster area. Pixels selected are 
highlighted with colour and the selection set 
is encompassed with a dashed rectangle. 
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Reconfigure the selected area by cutting it 
with other areas i.e. selecting the fragment in 

the centre with  button pressed (note 

that all pixels inside the dashed area drawn 
around rectangle are subtracted from the 
selection). 

 

Pressing DEL removes the parts of three 
circles outside the rectangle. 

When composing a selection set, you the mode of hybrid objects can be changed in 
add to selection raster and vector objects in any combination. 

Switch drawing raster mode on/off (RDRAW 
button) 
This mode controls rasterization of vector objects during drawing and is switched on 

by pressing the  button on Main toolbar or RDRAW button in the lower right 

corner of the RxSpotlight status-bar. 

When this mode is on, any vector objects drawn are automatically converted to raster 
objects, i.e. this mode combines creation of vector objects (lines, arcs, circles, texts, 
dimensions) and immediate rasterization. 
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Vector object drawn over an image Drawing when RDRAW is ON. Vector circle is 
drawn and immediately rasterized (note clipping 
by image boundary) 

Edit raster text 
This operation is used to modify a raster text directly in the raster image. During this 
operation users can recognize a raster text within a specified area, edit this text, and 
then either delete or keep the image beneath the original text. 

A raster text can be inserted in the image as either a raster object or a text object 
(single-line text). 
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To edit a raster text 

1. To enter a raster text, press the RDRAW button (raster drawing mode). Turn off 

this mode to obtain a text object. 

2. From the Draw menu choose Raster > Edit Raster Text. 

 

3. In the Inspector, set values for the 
parameters Recognize text and 
Erase raster. Set values for the 
parameters in the fields Layer, 
Colour, Font, Text, Height. 

Specify a rectangular area 
encompassing a text to edit in the 
image: 

Specify a first (base) point for the 
area. The values for the parameters 
Base Point and Corner (the 

coordinates of a second point) can 
be set in the appropriate fields of the 
Inspector, and a text angle in the 
Angle field.  

      The arrow indicates a 
direction to enter a  text  

Specify a second point. 

4. Use the Text field to edit a recognized raster text or enter a new one from the 
keyboard correcting the text parameters in the appropriate fields of the Inspector. 

Press ENTER. Depending on the value set in the Delete raster field, the original 
image beneath will be deleted or kept. 

Snaps and Grids 
Snap and grid settings help to create and align objects. Snap automatically finds a 
specific point on the object in the vicinity of the mouse cursor and allows selection 
without precise clicking. The grid is a visual guide which displays snappable points at 
user-specified intervals. 

In RxSpotlight vector, raster and polar snaps and snapable points of a grid are 
available.  

The buttons that control snapping are at the bottom of the RxSpotlight window on the 
status bar. 
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RSNAP controls snap to raster object snaps; VSNAP controls snap to vector object 
snaps; POLAR controls snap to predefined angle; GRID allows use of a grid 

Snaps are active only when drawing or editing objects. 

Vector and Polar snaps 
The simplest way to see how snaps and grid work is to try drawing vector objects on a 
blank document with VSNAP and/or POLAR and/or GRID buttons pressed.  

 

RxSpotlight analyses the area enclosed in 
the aperture box or snap pickbox (square) 
and displays the appropriate snap. 

The type of snap and its coordinates are 
shown in a tool tip. 

Snaps of different types are shown with 
their specific markers. 

 

The Polar snap offers the direction and the 
point on it to accept.  

Snaps of different types can be switched 
on and off in the Snap Setup dialog (menu 
Tools). This dialog can be open from the 
cursor menu by right-clicking on the snap 
control buttons. 

Sizes of snap markers and aperture are set in the Preferences dialog (see page 389). 

To change sizes of snap markers and other snap settings 

1.  Press CTRL+ENTER or from the Tools menu choose Preferences. 

2.  Open Snap Settings section. 

 The size of the aperture box, sizes and colours of snap markers can be changed 
and also tool tips switched on and off. 

Raster snap 
Raster snap allows creating and editing objects, based on the geometry of other 
raster objects. For example, draw a line, the end point of which coincides with another 
raster line end point, or stretch an arc so that its end point is placed on a 
characteristic point of raster line. 

Raster snap can only be performed on monochrome image. The raster snap 
operation looks the same as with vectors. When selecting points on the image with 
raster snap mode on, a square raster snap pickbox appears on the cursor cross. 

When placing this pickbox on the object, the program finds an appropriate point on 
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the object for the specified snap mode, and transfers the calculated coordinates to the 
current command. If there are several possible snap points, then the closest one to 
the point specified is chosen.  

The program highlights the point to which the snap is supposed to be made with a 
colour marker. Holding the cursor over the object displays a tooltip with the current 
snap mode name at the point. For each snap type a special marker is used. If there is 
any problem with precise snapping, then zoom the image on the screen. 

 Note that the snapping function only operates effectively in the 
neighbourhood of the rubberline end, hence if it fails to recognize a 
raster entity, it considers it as a part of a polyline and tries to snap to the 
endpoints and midpoints of “polyline segments”. 

Snap on Demand 
To snap to a specific point of raster or vector object, the snap cursor menu is used. To 
open the snap cursor menu, right-click with the CTRL pressed. Choose the snap type 
needed from the menu. To snap to the object, move the cursor to a position close to 
the required snap point. A highlight marker and tooltip will be seen. Click to accept the 
snap point. 

Use the cursor menu to change snap modes and change the combination of snap 
buttons “on the fly” until ESC is pressed, or drawing/editing mode is exited, or the 
snap buttons are released. 

Running Snaps 
Both raster and vector snaps can be used simultaneously; both the points of vector 
objects and those of raster objects are snapped. The snap to raster has lower priority. 
First an attempt is made to snap to a point on a vector object, and then to a raster 
object. 

 Snaps are also controlled by settings in Command Setup dialog, see page 376. 

 

To switch on both raster and vector snaps, set the checkboxes in the Tools > Snap 
Settings dialog or press both corresponding buttons on the screen. 

 Polar snap has a higher priority then vector and raster snaps. 

Object Snap Tracking mode 
Using Object Snap Tracking you can specify point position relative to position of 
object snap points and points which lies in specified directions. 

Working in this mode, firstly, you must specify temporary tracking points and 
secondarily, choose appropriate point, which lies on temporary alignment paths or its 
intersections that appear during cursor movement. 
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To use Object Snap Tracking mode 

1. This mode is available while the Snap to raster or Snap to vector modes is ON, so 
switch ON Object Track mode simultaneously with any of object (raster or vector) 
snap modes. 

2. Then you should acquire temporary 
tracking points. Acquired points are marked 

with thick sign . To acquire tracking point 
move cursor to any snap point (i.e. perform 
snapping to any point). To remove acquired 
point move cursor to its location again. 

  

Some tracking points are acquired simultaneously with subsidiary tracking points, 
which appear at endpoints of an object or objects segment. These points are marked 

with thin sign  and define possible tracking directions in extension of an object or its 
segment. 

             

3. After tracking points has been acquired temporary alignment paths appear during 
cursor movement. Such a path displays as dotted line, which follows through acquired 
point in direction defined by types of object snap. 
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 The more object snap types are switched on in the Snap Setup dialog, 

the more types of temporary tracking points you can acquire and the 
more tracking paths are available. 

4. Snap to any point on temporary alignment paths or to point of their intersection. 

 

Points on raster object could also be acquired: 

 
After panning or zooming a document all temporary tracking points disappear. 

To acquire points manually 

While the Object Snap Tracking mode is running, tracking points are acquired 
automatically during cursor movement that is not always suitable. To acquire points 
by pressing a SHIFT key only, switch on the By Shift Key checkbox in the Object 
Tracking section of the Snap Setup dialog. 
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Snap Modes 
Snap modes can be viewed and changed in the Snap Setup dialog box (menu Tools). 
This dialog can be also opened from the cursor menu that appears when right-clicking 
on any of the snap buttons. 

 
This table provides the names of raster snap modes, which can be used to snap to 
points of raster objects. 

Name Description 

Endpoint Snap to the objects endpoints (lines, arcs etc.). 

Midpoint Snap to the middle of objects (lines, arcs etc.). 

Centre Snap to the centre of an arc, circle. 

Quadrant Snap to the nearest quadrant (the point located under an angle 
0, 90, 180 or 270 degrees from centre) of arc, circle. 

Nearest Snap to the point of the object located close to the curser 
position. 

Intersection Snap to the intersections of objects (lines, circles, arcs etc.). 

Perpendicular Snap to the point of the object lying perpendicular to another 
object or to its imaginary extension. 

Tangent Snap to the point on an arc or circle belonging to the tangent of 
another object. 
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In some cases when using snap tools, many Nearest points are revealed (since they 

are the easiest type to find) and these frequently obscure other points. To see more 
point types (if any) just turn off Nearest. 

The RxSpotlight snapping algorithms can find the Intersection between raster and 
vector lines as shown in the figure below. 

 

 

The raster circle is 
intersected by a vector 
line. RxSpotlight finds the 
Intersection snap (thin 
cross). 

Note that to run this 
feature both RSNAP and 
VSNAP must be pressed. 

Setting Snap Accuracy 
The raster snap operation is based on algorithms for raster objects recognition. The 
program calculates vector objects, approximating the specified raster lines and makes 
a snap to the characteristic points of these vector objects. That is why the operation of 
raster snap tools depends on the parameters which are set in the Options tab of the 
Conversion Options dialog box. 

Raster snaps are only influenced by three parameters of the Options tab: Max Width, 
Max Break and Approximation Accuracy. 

See the description of the Options tab of the Conversion Options dialog on page 122. 
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Grid Settings 
When the GRID button is pressed, a new set of snapable points is introduced. 
Snapping to a grid has the highest priority over the other snaps. The grid activity and 
options are set in the Grid Setup dialog from the Tools menu.  

 
 

Name Description 

Grid Spacing Grid cells size. 

Show Grid Shows the grid. 

Snap to Grid Turns on/off grid snapping mode, the same as pressing GRID 
button. 

Searching and Replacing Raster and Vector 
Objects 
The search and replace operation can find vector or raster (monochrome and colour) 
objects and replace them with any other vector or raster item. The operation can be 
applied to sets of vector objects. 

The search and replace operation is performed using the following dialog box. 
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First it is necessary to specify, what templates should be found and with what they will 
be replaced. For searching and replacing templates of single type the Classic tab is 
used. If it is necessary to operate with a complicated set of different types, then the 
SRTL tab should be used. 

To specify a single template switch to Classic tab. Place a raster selection or vector 
data in the Find What box – to define a sample for searching – and setup searching 
parameters. To replace found objects, also place the replacing vector or raster 
selection in the Replace With box. 

Raster selections can be replaced with raster or vector samples. Vector selections 
can only be replaced with vector samples. 

The command also allows sets of vector objects to be found, which in combination 
resemble the vector sample. Lines, arcs, circles, and polylines can be used as a 
sample sets. Vector objects to be found by this command must be composed of line 
segments, arcs, and circles only. 

The SRTL tab allows to set and tune Symbol Recognition Template Library for current 
Search and Replace operation. 
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 Work with SRTL tab is similar to work with SRTL editor tool and is described in 
chapter "Tuning Symbol Recognition Template Library” on page 198.  

To specify single search and replace pattern 

1. From the Edit menu choose the Search and Replace or click  button on Edit 

toolbar. 

2. Go to the Classic tab. 

3. Place a search sample in the Find What box: 

Select raster area on one of raster images or vector data in the drawing. 
Click the Find What button above the left dialog window. 
In the drop-down menu that appear choose the Search raster item for raster data 
placing, or the Search selection item for vector pattern placing. 

4. Place a replace sample in the Replace With box: 
Select raster area on one of raster images or vector data in the drawing. 
Click the Replace With button above the right dialog window. 
In the drop-down menu that appears choose the Search raster item for raster 
data placing, or the Search selection item for vector pattern placing. 

 To erase found patterns keep the Replace With checkbox clear and turn 
on the Erase checkbox. 

 To clear data from Find What box and Replace With box click the button 
above the appropriate box and choose Clear item in drop-down menu 

that appears. 

To define the search and replace parameters 

1. Set the Accuracy  parameter with the slider to  the allowable level of difference 
between a searched for object with a found one. 

2. Turn on the Erase option to erase the found objects in the process of replacing. 
The color or greyscale raster symbols are erased with the colour specified in 
Background Color property of the current raster image. 

3. Turn on Only Standalone Letters  to search for isolated raster objects only or 
vector symbols, which do not overlap other objects. 
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To search and replace raster and vector objects 

1. If a raster selection is used as the basis for a search and there are several 
available (visible, placed on unlocked layers) raster images in the drawing, then 
select for the search operation the appropriate raster image with standard 
selection methods. 

2. Click the Replace All button to start the automatic search and replace procedure 

for the raster images found 
or 
Click the Find button; the program will start the first character searching 
procedure.  
The Search and Replace toolbar is displayed.  

 
Using its buttons, the user can control search and replace. 

3. When the program finds an object, it centres that found object in display screen. 
This object is highlighted with a color and dotted frame. If a replacement object 
is specified, it is redrawn over the found object. The base points of the found and 
replacement objects coincide.

  
4. To not make the proposed replacement, simply click the Find Next button and 

the found object will be skipped. 
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Find Next 

Click this button and the found item will be skipped. 

 
Replace 

If the replacement sample has been specified, it will be inserted. 
Depending on the Erase checkbox setting,  the found item can be 
either erased or left intact. After replacement, the program continues 
searching for the next item. 

 
Replace All 

Continues the operation in automatic mode. 

 
Cancel Search 

Cancels the current search-replace operation.  

 
Close 

Stops the search-replace procedure.  

5. If the program finds the next object, then the user can perform any operation 
described in step 4. When no more objects can be found, the procedure is 
completed. 

  

Document fragment before and after replacement procedure. 

  
Finding raster objects on an RGB map and placing a semitransparent vector circle on them. 
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Color processing 

General notes 
Monochrome images also referred to as black-and-white or bitonal use one bit to 
represent each pixel color (black or white). Greyscale images, also referred to as 
grey-level, consist of different grey tone pixels. Grey levels vary from 0 (black) to 255 
(white). Thus, one byte is sufficient to store information on each pixel color in 
greyscale images. 

 
Depending on the color information number of bits a color image can require 4, 8, 16, 
24 or 32 bits per pixel to represent a color. Colors can be made by mixing of three 
basic colour components in different proportions. These components are known as 
the primary colors: red, green and blue (RGB model). Each component has 256 levels 

(from 0 to 255).  The RGB color image is an image that requires three bytes (24 bits 
per pixel) to store color information of each pixel; one byte (256 brightnesses) is 
required for each of the primary colours.  

The HSV model is based on color perception by the human eye. In the HSV model all 

colors are described in terms of three basic characteristics: 

 Hue is the wavelength of light reflected from or transmitted through an 

object. More commonly, hue is identified by the name of the color, such as 
red, orange, or green. Hue is measured as a location on the standard 
color wheel and expressed as a specific angle between 0° and 360°. 

 Saturation is an analogue of the intensity or purity of a color. Saturation 

represents the amount of grey in relation to the hue and is measured as a 
percentage from 0 percent (grey) to 100 percent (fully saturated). 

 Value (or brightness) is the relative lightness or darkness of the color and 

is usually measured as a percentage from 0 percent (black) to 100 
percent (white). 

Note that scaling an image implies the distortion of colour since the colours of dots on 
the image can be mixed in one pixel (scale less then 1:1) or, in the opposite case, 
several pixels on the screen represent one dot (scale greater then 1:1). Hence for the 
most precise color match on the screen, set the scale to 1:1 (one dot on the image 
corresponds to 1 pixel on the screen). 

Color editing 

Color Flood Fill  
Use the Draw > Raster > Color Flood Fill command to fill areas on color images with 
the selected color. This operation can be tuned to clean the floodfilled area by 
eliminating the speckles and small areas of close colors. 
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To fill the area with autodetection of color 

1. Choose Draw > Raster > Color Flood Fill. 

2. Set Autodetect color to TRUE in the Inspector toolbar. 

3. Click on a pixel of the filling color. 

To fill the area with selected color 

1. Choose Draw > Raster > Color Flood Fill. 

2. Set Autodetect color to FALSE in the Inspector toolbar and select Fill color. 

3. Click on the pixel where floodfilling is to begin. 

The performance of the color floodfilling operation is controlled by settings of the 
slider in the Color Accuracy toolbar. 

The leftmost position of the Color accuracy slider (0%) corresponds to floodfilling 

areas with a range of colors close to chosen one, thus eliminating speckles and small 
areas (and maybe useful details) of close colors; the rightmost (100%) corresponds to 
the narrowest range of colors close to chosen one and leaves many details 
untouched. 

On the pictures below results of color filling of the same area with opposite values of 
Color accuracy can be seen. Note that 0% of accuracy yields more readable text 
(left), while 100% of accuracy preserves vertical lines. 

  
Colour Accuracy is low.  Colour Accuracy is high 

The other option is the default color of filling areas, which can be set in the Colors 
section of the Preferences dialog. 
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Colors treated as close in the above text are “close” in terms of current color model 
but may not seem “close” in human perception. 

Color Correction and Color Filtration 
The color filtration and color correction tools can be used to prepare an image for 
further, more complicated operations, such as binarization, layering, raster editing and 
vectorization. The color filters are also used for image enhancing after operations that 
move image objects or change the resolution, such as scaling, aligning, rotation, 
calibration or four-point correction. 

Selecting Images for Color Correction and 
Filtration 

The color filtration and color correction tools can be applied to a group of color raster 
images. The colour filter commands work on images that have a clipping boundary. 
Restrict a filtration area for any image using this feature by specifying its clipping 
boundary. 

 For information on the use of clipping boundary see page 130. 

The colour filters are not applicable to greyscale (grey-level) images. Nevertheless 
these can be applied to such images after having converted them to colour. Use the 
Convert to RGB command from the Image menu. 

Conversion to RGB, greyscale and 8-bit indexed  

Every image in RxSpotlight can be converted to greyscale, RGB (24 bits per colour) 
and 8-bit indexed image.  

Conversion operations can be applied to several images of an appropriate type at 
once. So, if several images are inserted in the current drawing and they are available 
(visible, allocated on unlocked layers), select a group of raster images before running 
this operation. 
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By converting monochrome images to greyscale or RGB it is possible to apply colour 
filters to the image (Blur, Unsharp and Median). 

Conversation colour image to 8-bit indexed is the tool facilitating colour management. 

 This operation is not applicable for images with a clipping boundary. 

To convert an image to RGB 
Select images to be processed. Choose Convert to RGB from the Image menu. 

To convert an image to Greyscale 
Select images to be processed. Choose Convert to Greyscale from the Image 
menu. 

Converting to 8-bit indexed 

This command supplies the user with a way of to reducing the file size of an image by 
changing its colour depth (number of bits that store colour information) from 24 bits 
per pixel to 8 bits per pixel. This is also a way to tune colours precisely. 

When applying this command to an RGB colour image, the number of colours used 
reduces to 256 (or less). Further reduce this number by deleting selected colour or 
colours or by merging several colours into one. 

Selected colours can also be replaced and add them to the palette. 

Note that colour filtering (blurring, Unsharp mask and medianning) can be applied 
only to colour images. Hence it would be a good idea to apply colour filters to a RGB 
image before converting it to an image of indexed colours. 

Choosing the Image > Convert to > Convert to 8-bit indexed produces a dialog box 
with tools for manipulating with palette and the individual colours and preview window. 

To convert an image to 8-bit 
Select the images to be processed. Choose Convert to 8-bit indexed from the 
Image menu. 
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The buttons and controls in Convert to 8-bit indexed dialog window 

 Colour samples table Contains the samples of colours of 
the current palette, i.e. the palette that 
will be applied by pressing OK. 

 Colour counter This control is used to show the 
number of colours in the current 
palette. This number can be enlarged 
or reduced. 

 Set auto palette button Pressing this button forces 
RxSpotlight to automatically create 
the palette. RXSPOTLIGHT 
determines the set of colours that 
most truly represents the image and 
places them into the colour samples 
table. Their number is reflected it the 
colour counter spinbox. 

 Reset palette button Restores the native palette of the 
image. 
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 Preview and Light paint  The Preview window is supplied with 
its usual set of buttons described on 
page 34. The Light paint is the 
additional tool consisting of colour 
selector and Light paint checkbox. 

The Light paint tool lets the user see 

where the pixels of selected colour 
reside in the Preview window. 

To preview pixels of selected colour 

1. Select colour sample (samples). 

2. Click on the coloured box near the 
Light paint checkbox and choose an 
appropriate colour in the colour 
selection dialog. Press OK. 

3. Check the Light paint box. 

For better previewing select a colour 
for light painting contrasting to those 
in the colour samples table. 

4. Pan the image in the preview 
window and see the pixels and areas 
of colour selected on step 3. 

 

 Eyedropper This tool is used to obtain a colour by 
clicking on the pixel in the Preview 
window or in document window. 

 RGB button Opens a dialog of colour selection, 
lets new colour to be chosen and 
changes the colour selected in the 
colour samples table with the new 
one. The image is repainted with the 
new palette. 

 Merger button Merges the colours selected in the 
colour samples table to the mean 
colour. The image is repainted with 
the new palette. 

 Delete button Deletes the colours selected in the 
colour samples table from the palette. 
The image is repainted with the new 
palette. 
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 Template This button provides options to save 
and load colour and palette 
information to and from template files. 
See more information on template 
files on page 40. 

To create a palette automatically 

 Press Set auto palette button . 

 - or -  

 Reduce the number of colours in the Colour counter spinbox. 

 The palette will be automatically recalculated and the image repainted to reflect 
changes. 

To reset a palette 

 Press Reset palette button . 

 The palette will be recalculated to best fit the number of colours set in the Colour 
counter spinbox. 

To delete colour from a palette 

1. Select colour(s) to be deleted in the colour samples table by clicking on them 
with SHIFT pressed. 

2. Press delete button . Watch as the image is repainted. 

 The number of colours can also be reduced by setting the number of colours in 
Colour counter spinbox and pressing the  button. 

To add colour to a palette or replace existing one 

1. Click on the colour sample to be replaced or on a box in the colour samples 
table that is not occupied. 

2. Press RGB button  and choose a new colour in the colour selection dialog. 

 - or -  

 Pick the colour from the image with the eyedropper tool . 

To merge colours 

1. Select colours to be merged in the colour samples table by clicking on them with 
SHIFT pressed. 

2. Press merge colours button . Watch as the image is repainted. 

Modifying image brightness, contrast, hue, and 
saturation 
The brightness, contrast, hue, and saturation can be adjusted for a single or several 
colour and greyscale images. For each image a clipping boundary can be defined. In 
this case first define a clipping boundary where the operation is to be applied. 

Brightness sets the relative colour lightness or darkness. It is usually measured in 
percent ranging from 0% (black) to 100% (white). 
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Modifying contrast enables the image brightness range to be increased or reduced. 
An image with the same brightness value has zero contrast value. If the contrast 
value increases, then it causes an increase of the brightness range, i.e. darkening 
dark colors and lightening light ones. Image contrast is measured in percent ranging 
from 0% (fully grey) to 100%. Color hue usually means a colour, and saturation 
means colour purity. There is the ability to fully modify an image colour. 

Hue is a light wavelength reflected from or transmitted through an object. Usually hue 
is identified by the name of a color, such as red, orange, or green. Each hue has a 
specific position in the standard colour wheel and is characterized by a specific angle 
between -180° and +180°. 

Saturation is a degree of color purity. Saturation defines the ratio of grey and the 
specific hue and is measured as a percentage from 0 percent (grey) to 100 percent 
(fully saturated). 

To modify an image brightness, contrast, hue and saturation 

1. Select the image to be processed.  

2. Start the operation by one of the following methods: click the 
 
button on the 

Image toolbar or choose Brightness/Contrast from the Image menu. 

 The following dialog box is displayed: 

  
3. Use the appropriate boxes or slides to modify the value of the following 

parameters: Brightness, Contrast, Hue, and Saturation. 

 The preview window displays the effect of modifying parameters. 

4. Click Apply to run the operation. 
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Correction by Histogram 
This operation is applied for precise adjustment of the image brightness, hue, and 
contrast. The tool of correction by histogram requires the specification of two 
threshold brightness levels – the brightest and darkest pixels, and image gamma that 
defines the position of the middle brightness value relative to the current threshold 
values. 

The gamma defines a ratio of the brightness range length between the average and 
the brightest value to the length of brightness range between the dark threshold and 
the average value. As a result, the pixels with a brightness value below the dark 
threshold gain zero brightness value; the pixels with a brightness value above the 
brightest one gain maximum brightness value (255), and the brightness values of the 
pixels between the darkest and the middle values as well as between the middle and 
the brightest ones are relocated evenly in conformance with their range lengths 
determined by image gamma. 

An increase in gamma value causes the range for brightness value in the dark range 
to reduce, and therefore it increases the contrast, at the same time reducing the 
contrast in the light hue area, and vice versa. 

The command enables users to redistribute both image pixels average brightness and 
brightness by separate colour pixel components (Red, Green, and Blue). It enables 
image pixel colour to be corrected, for example, to turn a pink background to pure 
white. 

To correct an image by histogram 

1. Select an image to be processed. 

2. Click the 
 
button on the Image toolbar or choose Equalize from the Image 

menu. 

 The following dialog box appears: 

 

 This dialog box represents the image histogram, displaying the averaged number 
of pixels, corresponding to each brightness value. The left part of histogram 
corresponds to low brightness value, and the right one corresponds to high 
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brightness value (the lightest tones). The sliders in the bottom part of histogram 
indicate threshold values: the left black one is for the darkest value, the grey 
middle one is for the middle value, and the right white one is for the brightest pixel. 
The Levels box provides the numerical expression of current threshold values. 
One of four histograms can be selected: Master displays summary pixel 
brightness distribution, Red, Green, and Blue display distribution of the 
corresponding pixels colour components. Use the Master histogram slides to 
proportionally modify the threshold value for all components at once. The 
histogram sliders Red, Green, and Blue modify brightness threshold values 
separately for the corresponding colour component. 

 The eyedroppers are used to select threshold values and gamma for an image. 

When selecting a colour sample with the  (or ) eyedropper, it defines the 

threshold value for the darkest (or the lightest) for all components equal to the 
corresponding components values of the selected colour. When selecting a colour 

sample with the  eyedropper, it defines the position of the middle tone, and 

hence defines the image gamma. 

3. Select a histogram corresponding to the colour component to be corrected. 

4. Specify the brightness value for the darkest and the brightest pixels, and for the 
image gamma. Use Levels or eyedroppers. Use histogram slides for precise 

adjustment. 

 The preview window displays part of the image. Use the preview management 
tools to adjust optimal correction parameters.  

 Use the Auto button to automatically specify the light and dark threshold values so 

that the brightness values of each colour component not found in the image are 
cut off. Automatic correction tries to increase image contrast as much as possible, 
slightly modifying brightness values. 

 Suppose we want to make the background tone of a map image pure white. To do 
so, select a background sample with the white eyedropper. The white triangle in 
the Master histogram moves to the position corresponding to the selected colour 
brightness. All the pixels with a brightness value above the defined one become 
white. Then suppose we want to turn outlines, which are not pure black after 
scanning, black. Select a colour outline sample with the black eyedropper, all 
pixels with a brightness value below the defined one become black.  

 The brightness value of the remaining pixels will be proportionally redistributed 
within the new tone range. As a result, the image contrast increases. Move the 
grey slider (modifying gamma value) to redistribute the contrast between the light 
and dark image parts. 

5. Click Apply to run the operation. 

This operation can be applied several times, consistently modifying an image pixel 
brightness distribution. 
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Gamma Correction 
This tool is used to enhance the overall quality of an image by changing its so-called 
“color profile” - i.e. it applies an “algorithm” to change the distribution of brightness. 

Every image has its brightest point (a “white” point) and its darkest point (a “black” 
point). The points having intermediate values of colour intensity are usually distributed 
unevenly, forming a curve of an arbitrary shape. The Gamma value defines the slope 
of the curve halfway between the black and white. Using the Gamma Correction tool, 
the points that fall within in a specified range of brightness can be made either 
brighter or darker. The brightness of Red, Blue or Green colours can also be 
changed. 

To change colour profile 

Choose Gamma Correction  from the Image menu. 

 
The Gamma Correction dialog is displayed. Do the following: 

 Specify white and black points using the relevant eyedropper tools; 

 Choose Master or specify a colour in the Channel list; 

 Create Gamma curve automatically or adjust it manually; 

 See the results in the preview window. Press Apply. 

Specifying black and white points 

Use the  buttons to pick the black or white point values directly from the 

image. Select an appropriate tool and draw an area on the screen. 

The Color point section of the Gamma Correction dialog allows for precise adjustment 

of colour values. If any values are set different from (0,0,0) for a black point and/or 
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(255,255,255) for a white point, then the points located outside this range will not be 
affected by the Gamma correction procedure. 

The Auto Set button  calculates the black and white point values automatically for 

every colour channel. The histogram in the middle of the dialog window reflects colour 
brightness distribution. The curve for every channel can be changed separately. 

Click  to reset the gamma curve. 

Changing the gamma curve 

There are three interrelated methods of changing the shape of the Master gamma 
curve and the curves for individual channels. 

1. Select or clear the S-Curve checkbox. S-curve is a form of a gamma curve 
that is always symmetrical around the central point of a distribution range. 
This implies that when adding brightness to dark areas we automatically 
darken bright areas to the same extent creating a more balanced brightness 
for the human eye. If the S-Curve checkbox is off, then a gamma curve can 
be created by shifting the overall balance of brightness in the resulting 
image. 

2. Enter a value in the Gamma box. This changes the curve slope. 

3. Drag the Master curve or the curves for individual channels in the histogram 
window. 

When Master is selected in the Channel list, all the curves are shown (at first you see 
them as a single white curve since the curves for colour channels overlay). 

When placing the mouse pointer over the curve a bold point will be seen that can be 
dragged to change the shape of the curve. While keeping the mouse pointer over the 
curve, the real distribution of colour brightness on the image can be seen.  

To change the shape of the curves for the Red, Blue or Green channels, select the 
corresponding colour name from the Channel list. 

For some images the Master curve Red, Blue or Green components can also be split 

by pressing the Auto Set button . 

Modifying a Color Palette 
The editing operations allow the color palette to be calculated automatically or 
modified based on the user-defined colours. 

Manage the colours in the image using the Color Classifier dialog of the Image menu. 
The following operations are available:  

 Reducing the palette by deleting the selected colour or colours or by 
merging several colours into one; 

 Changing selected colours;  

 Adding new colour(s) to the palette; and 

 Saving the palette for further use when processing a set of similar colour 
images. 
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To edit a palette 

Choose Image Classifier from the Image menu. 

The buttons and controls in the Image Classifier dialog 

Colour samples table This table contains colour samples of the current 
palette.  

 
Colour counter 

This control is used to show the number of colours in 
the current palette (from 2 to 256). 

 
Set auto 
palette  

Pressing this button forces the program to automatically 
determine a set of colours that represents the image 
most closely.  

 
Reset palette  This button is used to recalculate the palette based on 

the number of colours set in the Colour Counter. 

 
View Selection 

When this checkbox is checked, the points of selected 
colours are highlighted with a specified colour in the 
image. 

 
Choose colour 
from the image 

This tool is used to choose a colour by clicking on a 
pixel in the document window. The colour of a selected 
pixel will be highlighted in the Colour samples table. 

 
Select colours 
from the image 

This tool is used to select colours by drawing a polygon 
around an area in the document window. Press ENTER 
or right-click to close the polygon.  

 
Choose colour 
from dialog 

Opens the Colour Selection dialog which allows the 

replacement of the currently selected colour with a new 
one. 

 
Merge colours Merges colours selected from the colour samples table 

to the mean colour.  

 
Delete colours Deletes colours selected in the colour samples table 

from the palette 

 
Load LUT Loads the current palette from a LUT-file (Look-Up 

Table). 

 
Save LUT Saves the current palette in a LUT-file (Look-Up Table). 

 

Use this button to save and load colour palette 
information to and from a template file. 

To calculate a palette automatically 

Press the button . 

The palette will be recalculated automatically, and the image will be regenerated to 
reflect the changes. The colour samples will appear in the Colour Sample table, and 
the number of colours will appear in the Colour Counter. 
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To create a new palette 

Set a number of colour in the Colour Counter  

- or -  

edit the palette in the Colour Sample table. 

Press the button  

Observe the changes in the Preview window. When the best result are achieved 
press OK. 

To select colour(s) 

Pick a colour in the Colour Sample table; hold SHIFT for continuous selection; 

- or -  

press the button , pick a point in the image; the selected colour will be selected in 

the Colour Samples table;  

- or - 

press the button , draw a polygon around the desired area in the image. The 

colours within the polygon will be selected in the Colour Samples table. 

Observe selected colours in the image using the View Selection tool. 

Select the checkbox ; a colour located next to the checkbox is 

used as a highlight colour. Pressing on this colour invokes the dialog for highlight 
colour selection. 

To delete a colour from a palette 

Select colour(s) to delete. 

Press the button . 

Reduce the number of colours by setting the number in the Colour counter and 

pressing the  button. 

To add or replace a colour in the palette 

To replace a colour, click on the colour sample to replace, or to add a colour select an 
unoccupied space in the colour table. 

Press the RGB button  in the Colour Correction dialog and choose a new colour 

to add or replace an existing colour with. 

To merge colours 

Select colours to merge from the Colour Samples table with the SHIFT key pressed or 

pick them in the image using the tool . 

Press the button . 

Blur Filter 

This filter produces image blur effect, giving the impression that the image is slightly 
“out of focus”. Blur filtration reduces image clearness, but makes image areas with 
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texture fills more even. This procedure can have a positive effect on further 
binarization or image colour separation. 

To calculate a pixel‟s new color the program replaces its color value by the spatial 
average. The averaging of pixels in the area around the pixel is done with the 
weighting function being a two-dimensional Gaussian distribution with its centre at the 
current pixel.. 

Radius is the only filter parameter. Increasing its value produces a stronger blur 
effect. 

To blur an image 

1. Select an image to process. 

2. Click 
 
on the Filter toolbar or choose Blur from the Filters menu. 

 The following dialog box is displayed: 

 

3. Type values from 0.1 to 10.0 in the Radius box to specify the image blur level. 

Increasing its value produces a stronger blur effect. 

4. Choose Apply to run filtration. 

On the one hand, blurring with a large Radius yields a coarse image and removes 
details. On the other hand, setting a small Radius applies the minimum blur effect of 
the filter application. To better control the result of  blurring, apply this filter with a 
small Radius value several times, using the Apply button of the dialog box. 

Adaptive Blur 
This tool is designed for blurring none uniform colour areas inside the colour transition 
boundaries in the image. It works on greyscale and colour images. 

The blurring gives the impression that an image is slightly «out of focus». 

The Adaptive Blur filter, in contrast to the Blur filter, tries to recognize the colour 
transition boundaries in the image and leave them unchanged, without smoothing. 
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The setting of the radius value determines the depth (in pixels) of the filter effect on 
the colour area. 

To implement the Adaptive Blur 

1. Start the command Adaptive Blur from the Filters menu. 

2. Type values from 0.1 to 10.0 in the Radius to specify the image adaptive 
blurring degree. The bigger the radius, the stronger the blurring effect. 

3. Click Apply. 

Unsharp Mask Filter 

This filter looks for colour transition boundaries in the image and improves their 
sharpness. 

The filter modifies pixel contrast on colour transition boundaries, producing an overall 
increase of image sharpness. This filter can be used for correction of images that 
became blurred after interpolation, for example, after such operations as scale, 
resolution modification or calibration. 

To increase outline sharpness 

1. Select an image to process on the screen and start the operation using one of 
the following methods: 

2. Click the 
 
button on the Filter toolbar or choose Unsharp Mask from the 

Filters menu. 
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 The following dialog box is displayed: 

  
3. Enter a value in the Sensitivity box or use the appropriate slider to specify the 

desired effect of the filter application in percent from 0 to 100. The effect of the 
filter application becomes stronger as this value is increased. 

4. Enter the Radius value.  

 The higher the Radius value specified, the more pixels surrounding the colour 
transition boundary will be processed. Low radius values only increase the 
sharpness on the boundaries.  

 To adjust optimal parameter value for the entire image, first try out some settings 
on a typical area in the preview window. 

5. Choose Apply to run filtration. 

Median Filter 

Median filtration reduces an image noise, by analyzing all pixels within the specified 
radius and giving the central pixel the averaged value of the reviewed pixel 
characteristics. As a result, the extremes of pixel colour and brightness are depressed 
and the image looks slightly blurred. 

To perform median filtration 

1. Select an image to process.  

2. Click  on the Filter toolbar or choose Median from the Filters menu 

 The following dialog box is displayed: 
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3. Specify the Radius value from 1 to 5. This value determines in pixels the area 
within which the filter is to review colour values. 

4. Choose Apply to run filtration. 

Find raster borders 
The Segmentation filter finds and highlights the borders on colour raster image. The 
bigger the difference, the brighter the border segmentation. 

 
Increasing the Radius parameter causes more places to be treated as area borders 

To launch the Segmentation dialog choose Filters from the Image menu and then 

Segmentation. Or click the  button on the Filters toolbar. 

To perform segmentation do following: 

1. Open a colour raster image. 

2. Run the Segmentation command. 

3. Tune it with the Radius slider until satisfied with the result in the preview 
window. Click the OK button 

Binarization and Colour Separation 
This section describes the procedures of converting colour and greyscale images to 
monochrome raster images (raster layers). 

The original image is a raster file, obtained after colour or greyscale scanning. 
Binarization creates monochrome raster images, containing black-and-white 
representations of colour objects. For example, from one image of a scanned map it is 
possible to extract and place objects of different colours (e.g. isolines, roads, rivers, 
and other objects) to separate monochrome layers.  

Another method to obtain a monochrome image from a colour one is colour 
separation. RxSpotlight can convert a colour image to a set of monochrome raster 
layers. This method guarantees that the black-and-white (or monochrome) 
representation of each pixel of the original image will be placed on a certain layer. 

Vectorization or tracing can further convert the resulting monochrome images to 
vectors. Vectorization of a layered raster image is considerably more effective than 
vectorization of a raster obtained by scanning of colour originals. 
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Running Binarization 

Binarization creates a new monochrome image of a specified colour, which is placed on 
the specified layer. Using the specific criterion the program defines which pixels of the 
original (colour or greyscale) image should become black (foreground pixels), and 
which ones should become white (background pixels), and then generates a 
monochrome image and places it on a new raster layer. The criterion for division of 
pixels into two sets is defined by the selected binarization method and its parameters 
(threshold values or a set of colour range). The selection of pixels is ruled by the 
settings, specified in the Binarization dialog box. A new monochrome image is named 
<Original image name>_N; N is an integer. 

This operation can be applied to several images at once. If no images are selected, 
then the command will be applied to all images (that are visible and located on 
unlocked layers). If several images are selected, then the command will be applied to 
those that are visible and located on unlocked layers. 

Binarization is applicable for images with clipping boundary. Using this feature, users 
can restrict the binarization area on any image. 

 For information on clipping boundary application see page 130. 

To binarize an image 

1. Choose the images to process (visible, on unlocked layers). Otherwise, the 
command will be applied to all appropriate images. 

2. Click the  button on the Image toolbar or choose Binarization from the 

Image menu. 

3 In the dialog window (see picture and description on page 331) select a method 
and adjust its parameters. 

4. Click Apply. 

Binarization creates a monochrome image from a colour raster image.  

Binarization methods 

To convert colour and greyscale images to monochrome ones, various conversion 
algorithms are used, which are called binarization methods. It is recommended to 
choose a conversion method appropriate to the image type.  

Threshold by Grey  

Threshold by Grey converts colour pixels with a brightness values above the specified 
level to background dots, and pixels below this level to image dots. 

This method may be used for converting both colour and greyscale images. When 
converting a greyscale image, RxSpotlight uses its grey levels. When converting a 
colour image, the grey levels are defined by the brightness value of colour dot. 

Threshold by RGB 

When using Threshold by RGB, define three threshold levels for the Red, Green, and 

Blue components. RxSpotlight converts colour dots with Red, Green and Blue values 
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below the appropriate threshold levels to black dots (image dots) of the monochrome 
image. 

Range by Grey 

Range by Grey allows conversion of colour pixels, with any brightness value, to image 
dots. Using this method, first specify a number of basic levels of grey. These levels 
are used as midpoints for ranges. For each of the specified levels, define a range half-
length. A range half-length is a number of grey levels below and above the specified 

grey level. 

Range by Grey converts pixels that have grey values within all specified ranges to 
foreground dots. Other pixels are converted to background dots. 

This method may also be used for converting colour and greyscale images. Grey 
levels for colour dots are calculated as described in Threshold by Grey. 

Range by RGB 

This method can convert colour pixels of the specified RGB ranges to image dots.  

To specify an RGB range, first select a central range colour. The Red, Green, and 

Blue components of this colour define the position of the RGB range central point. For 
each of the colour components (R, G, and B) specify the appropriate range half-
lengths. The range half-length for R, G, or B component is a number of R, G, or B 
levels below and above the selected R, G, or B level. For example, if the R level of the 
selected colour is equal to 50 and its range half-length for R component is equal to 10, 
then the RGB range includes colours with the R components from 40 to 60. 

Range by HSV 

This method allows the conversion of pixels of analogous colours to image dots. 
Analogous colours are closely related colours in the human perception of colour, e.g. 
red - orange, dark green - light green, etc. 

To convert an image using Range by HSV, specify one or more HSV ranges. The 
HSV range is defined by a selected colour and H, S, V range half-lengths. The HSV 
range is similar in design to the RGB range described above. Note that Hue is 
expressed as an angle between 0° and 360°, Saturation and Value are measured as a 
percentage from 0 to 100. 

 Using this method for converting greyscale images provides a low-
quality result. 
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Binarization dialog box 

To open the Binarization dialog box 

Choose Binarization from the Image menu or  click the  button on the Image 

toolbar. 

  
The Binarization dialog with the Range tab open 

The controls and buttons described below are the same of the Threshold and Ranges 
tabs of the Binarization dialog box. 

Preview window 

This window dynamically displays the binarization results of an image part. Note that if 
a colour sample in the image is chosen with an eyedropper, the preview window 
marks the position of a selected pixel with a cross. This only happens if colour 
selection is performed in the preview area, the position of which is shown with a 
coloured frame (red by default) on the image. 

 For more information on Preview window and Preview Area toolbar see page 34. 

Noise Reduction 

This slide sets the sensitivity of the binarization tool to small details in the image. If the 
maximum level of noise reduction is set, then the quantity of raster noise and holes in 
the obtained monochrome raster objects is reduced. However, the high level of noise 
reduction decreases the binarization quality of small and thin details, such as texts, 
thin lines, etc, since small details can be taken for noise. If  a low level of noise 
reduction is applied, then the quality of small detail binarization improves, but the 
quantity of raster noise increases. 
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By 

Depending on the chosen tab, this list allows users to select a binarization method. 
For example, if the Range tab is chosen, the choice is Range by Grey, Range by RGB 
or Range by HSV. 

Channel 

A colour information channel type can be chosen from this list. The term colour 
information channels stands for the information on the colour components of the 
image pixels by a certain colour representation model. 

The number of available channels depends on the image type. Every colour image 
has five channels: Red to store information on the red colour, Green to store 
information on the green colour, Blue to store information on the blue colour, Hue to 
store information on hue, and Grey to store information on the grey colour 
components (brightness) for each colour. For greyscale images the Grey channel is 
used only. 

Channel histogram window 

The histogram of the selected channel is displayed in the Channel list. Histogram is a 
graphic representation of a colour component value distribution by image pixels, 
defined by a selected channel. A component value is measured along the histogram 
horizontal axis (low values are on the left, high values are on the right). Along the 
vertical axis are placed a normalized number of pixels with the specified colour 
component value. Thus, the histogram extremes correspond to the most frequent 
component values, and the minimums correspond to the least frequent values. 

Depending on a selected binarization method, either one or three triangular sliders 
can appear in the bottom histogram part. These sliders allow the adjustment 
parameters of the current binarization method, i.e. to specify range parameters and 
threshold level value. 

Layer 

Allows the specification of a layer name, on which a monochrome image will be 
placed after binarization, and a raster image colour. 

Apply 

Starts the binarization procedure. 

Template 

Used to store and load all the parameters for all binarization methods. 

Dialog box tabs 

There are two tabs in the Binarization dialog box: Range and Threshold. The first one 

is used to specify the binarization range methods parameters; the second is used to 
specify threshold methods parameters. 
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Range tab 

This is applied to tune the following range methods: Range by Grey, Range by RGB or 
Range by HSV. 

Colours  

This list shows information on central colours of specified ranges and allows to 
selection of a range for correction and deletion. The left part of the list shows a 
sample of a selected colour (or grey tone), and the right part shows colour component 
values in the current colour model (grey level for greyscale images). To select a 
range, click its appropriate colour in the Colours list. 

Above there are three buttons with eyedropper pictograms, these allow the creation of 
new ranges. 

 
Colour selection allows the creation of a new range by selecting a colour in 

the image.  

RxSpotlight creates a new range, using the colour of the specified pixel as the range 
central colour. 

 
Averaged colour selection allows the creation of a new range by choosing 
an averaged colour in the area around the pixel clicked. 

RxSpotlight calculates the average colour value in the area of the specified pixel and 
creates a new range, using the calculated colour as the range central colour. The half-
lengths of the created range are automatically adjusted to take close colours, found in 
the specified pixel area. 

 
Area averaged colour selection allows the creation of a new image by 

calculating the averaged colour of an arbitrary area in the image. 

Click the button and specify vertices of a polygonal area or drag the cursor, outlining 
the boundary of the image polygonal area. Complete the selection of the area with a 
double-click. RxSpotlight calculates the average colour value in the specified area and 
creates a new range, using the calculated colour as the range central colour. The half-
lengths of the created range are automatically adjusted to close colours, found in the 
specified pixel area. 

 

Ranges 

Use this box to change the half-lengths of a range, selected from the Colours list. The 

type, name and a number of sliders and boxes depend on the current conversion 
method. For example, when choosing Range by HSV, the following sliders and boxes 
to modify the range half-lengths are displayed: hue– H, saturation – S and brightness 
– V. 

When Range by Grey is chosen, there is only one slider and one box to enter the half-

length of brightness range. 
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Sliders of channel histograms 

This tab has three triangular sliders on the histogram channels corresponding to the 
selected binarization method. These sliders allow changes to the central colour 
components (grey central level) and the half-length of the range selected from the 
Colours list. 

When Range by HSV is chosen, the sliders at the channel Hue histogram appear, the 
selection of Range by RGB causes the appearance of sliders at the Red, Green and 
Blue histograms. When Range by Grey is chosen, the sliders appear at the histogram 
of the Grey channel. 

Threshold tab 

This is used for binarization with Threshold by Grey or Threshold by RGB. 

Threshold 

This command displays the specified algorithmic threshold values of the current 
method of threshold binarization. To modify a value, move the corresponding slider.  

 
Threshold tab of the Binarization dialog  

Sliders of channel histograms 

One triangular slider appears on the channels histogram corresponding to a certain 
binarization method. This slider allows the modification of the threshold value of a 
colour component or grey level. 

When Threshold by HSV is chosen, the sliders appear at the Red, Green and Blue 
histograms. When Range by Grey is chosen , the slider only appears at the histogram 
of the Grey channel. 
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Tuning Binarization  

To fine-tune the binarization procedure, choose an appropriate method. The selected 
method type defines a customizing method. For each of two threshold methods 
specify one or three threshold values at the histogram. Also specify a set of ranges of 
the corresponding types that contain the extracted colours. 

 For information on binarization methods see "Binarization methods" on page 329. 

For any method specify a layer to place an image, obtained after binarization. 

To tune threshold binarization 

1. Choose the Threshold tab from the Binarization dialog box. 

2. From the By list choose an appropriate method. 

3. Tune the threshold values for the selected method. 

When tuning, use the preview window of the Binarization dialog box to observe the 
results of parameters‟ modification. Note that an image preview at the scale 1:1 
provides the most reliable results. For more information on preview tools see page 
34.  

 
Binarization dialog with Threshold by Grey  

If the Threshold by Grey method is selected, then choose Grey in the Channel list 

to see the grey level histogram. Specify a threshold value with triangular or G 
sliders. 

If the Threshold by RGB method is selected, then adjust the R, G, B threshold 
values. For this purpose the sliders on histograms of Red, Green, and Blue 

channels can be used. 

4. Use the Noise Reduction slider to adjust noise reduction and improve binarization 
quality. 
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 By default this parameter is specified as an average value. If binarizing large filled 
areas, then decrease this parameter value (close to Lo mark) to reduce the 

quantity of raster speckles and non-filled holes when binarizing objects. 

 When trying to get a monochrome layer containing images of small or thin objects 
(texts, characters, isolines, or grid), increase this parameter value to prevent these 
small objects, caused by noise reduction, from being thinned and distorted. This 
will increase the noise level of the obtained object. 

5. Define a monochrome image colour and a name of the layer to place the 
binarization results on. 

 Enter a name in Layer. To define a colour, click on a colour pattern and choose a 
colour from the box, click OK.  

To tune the binarization using the range method 

1. From the Binarization dialog box, choose Range. 

2. From the By list, choose a required type of range method. 

 Set the parameters of the chosen method. 

When tuning use the preview window of the Binarization dialog box to observe the 
result of changing parameters. Note that the most reliable results are obtained on 
viewing the image at a scale of 1:1. For more information on preview tools see 
page 34. 

3. Specify a set of ranges capturing the colours (grey levels) of the colour image 
objects to be moved to a separate monochrome level. 

 To do so, create a required number of ranges, using the eyedropper buttons and 
control the result of adding each range in the preview window. If the range addition 
results with unwanted image pixels being captured, then try to modify the range 
parameters using the Ranges box or the channel histogram sliders. If an 
acceptable result cannot obtain for a range, then delete it using the Remove 
Colours button. 

 Note that during selection of a colour pattern on the image with the 
eyedropper, when selecting a colour in the image preview area, the 
position of the chosen pixel is marked with a cross in the preview 
window. It enables a pixel lacking colour to be chosen. 

To add a range 

Click  or  buttons and point on the image a pixel to binarize. 

- or - 

Click  button and choose an area on the object to binarize. 

An element related to the created range appears in the Colours list. 

To change the created range parameters 

Use sliders and boxes of Ranges, or channel histogram sliders.  
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To delete a range 

 Click an element corresponding to the range to be deleted in the Colours list, 

press the Remove Colour  button. 

Binarization example 

In this example we create two monochrome images, containing isolines and rivers of 
a colour map image, which is in the MAP.TIF file, found in the SAMPLES subfolder of 
the program root folder. In the end of this example we shall save one of the obtained 
layers to a separate file. 

 When performing the instructions below control the binarization procedure 
through the zoom buttons, preview window and with the buttons on the Preview Area 

toolbar: , , and . For more information on preview tools see page 34. 

Image loading 

1. Choose Open from the File menu.  

2. In the displayed dialog open the SAMPLES folder and open the MAP.TIF file. 

Binarization 

 Open the Binarization dialog box.  

 
Click Binarization on the Image toolbar or choose Binarization from the 
Image menu. 

When the dialog opens, the preview window displays the central part of the image 
at a scale of 1:1. 

The position of the preview area is indicated with a red frame in the image. 

 

Change the position of the preview area using the Preview Area buttons. 
(The Preview Area toolbar is shown automatically after the Binarization 

dialog box is opened).  

 Unless parameters of Binarization not specified, the original image is displayed in 
the preview window. This window will automatically display the results of tuning 
the parameters. Moving the preview area, shows the binarization results of any 
image part. 

Binarize isolines that are brown in the original image. 

1. Name a layer and image colour for the binarization results to be placed on. 

 Enter “Isolines” in the Layer box, click the colour sample, and from the dialog 
box select an appropriate colour - brown for example. Click OK. 

2. Choose the Range by HSV binarization method.  

 Choose the Range tab, then choose HSV from the By list. 

 The Channel list will automatically shift to the Hue channel, and the window will 
display the colour hue histogram. 

 To perform binarization with Range by HSV, specify a set of colour ranges. 
Image pixels within these ranges will form objects on the resulting monochrome 
layer. 
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 The ranges are created by selecting a pixel or an area on the image using the 
eyedropper buttons, located in Colours. The selected pixel colour (averaged 

area colour) becomes the range central colour, and the range sizes are adjusted 
so that close colours are captured. 

 The program defines range sizes either by default or by automatically analyzing 
the area around the specified pixel. The range sizes can be manually adjusted 
the in the Binarization dialog box. 

3. Create a range using the middle eyedropper button, which automatically adjusts 
the created range sizes. 

 
To make colour selection and tuning parameters easier, zoom the preview 
area, using the Synchronize View to 1:1 button on the Preview Area toolbar. 

 
In Colours click the button and indicate a point in the middle of the isoline. 

In the Colours list there is a colour sample, corresponding to the created range. 
The created range parameters are shown in Ranges. These parameters are range 
half-lengths – deviation by H (hue), S (saturation), and V (brightness) from the 
range central colour. The image pixels, which colour characteristics get into the 
specified limits, will be transferred to a monochrome layer. 

 

If a mistake is made when selecting a colour, then delete the created range, 
clicking the Remove Colour button in Colours and repeat the colour selection 
procedure. 

The preview window displays the results of the preview area binarization. If some 
of isoline dots are not binarized, then create one or more ranges, specifying the 
isoline pixels that do not get into the available ranges. 

 

For precise pixel picking use the eyedropper button. When colour selecting 
with the use of this button, the selected pixel colour is not averaged. 

 When selecting a colour in the preview area, the preview window indicates the 
selected pixel position with a cross. It enables selection of a pixel lacking a 
colour. 

 After making sure that all the pixels of the isolines in the current view area are 
enclosed in the defined ranges, review the binarization results of other image 
parts. 

 If during a preview an image fragment has unsatisfactory binarization, then, try 
to improve the binarization quality by adding a range containing the missing 
colours. 

4. When satisfied with the previewed binarization result, start the procedure by 
clicking the Apply button. 

 During binarization the screen displays a dialog box where the progress of the 
task being performed is shown  in percent. Click the  Cancel button present 
there  to interrupt the task. 

 As a result of binarization a new layer named “Isolines” is created where the 
MAP(1) monochrome image is located.  

 If not satisfied with the binarization result, then use the Undo command to cancel 
it. 

Binarize the rivers that are light and dark blue in the original image. 
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 Firstly delete the ranges used for isolines binarization. For this purpose right-
click on the Colours list, and choose Remove All from the cursor menu. 

1. Specify a layer name where the binarization result should be placed and an 
image colour. 

 Enter “Rivers” in the Layer box, click the colour sample and select an 
appropriate colour from the box, blue, for example. Click OK. 

2. Using the  button, place the preview area in the central part of the image is 

shown in the figure below. Click the button 
 
in the Colours box and specify a 

point in the middle of the top circle (1 in the figure below). Then specify a point 
on the circle edge (2 in the figure below).  

 
The preview area position in the image 

4. When satisfied with the binarization results, repeat the procedure described 
above.  

 As a result of binarization a new layer named “Rivers” is CREATED, where the 
monochrome image MAP(2) is placed. 

5. Close the Binarization dialog box by clicking the Close button. 

Save the image from the “Rivers” layer to a separate file.  

1. Open the Images dialog box. 

 Choose Images from the Tools menu or click  on the Properties toolbar. 

2. Choose Map(2) from the list of images. 

3. Click the Save or Save as button. 

  For information on the Images dialog box see page 52. 

1 
 

2 
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Adaptive Binarization  
This command is designed for correcting raster images that have been acquired by 
scanning blueprint and sepias in Greyscale mode. 

 
This command enhances those images by improving the binarization in order to make 
the images readable. Because binarizing images on which the background has a 
different brightness and the noise and speckles are spread unevenly produces poor 
results, the Adaptive Binarization tool combines binarization with cleaning of the 
image. The program estimates the level of noise in the area being processed and 
does its best to extract the useful data. 

 
The command is applicable only to greyscale images. 

To run Adaptive Binarization 

Choose Adaptive Binarization  from the Image menu. 
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All the parameters of this dialog are set using the sliders or by typing appropriate 
values in corresponding fields. 

1. Set the Radius value –the radius within which the program will be analysing 

the level of noise to be cleaned. The greater this value, the more pixels 
surrounding the colour transition boundary will be analyzed.   

2. Select the Smooth checkbox. Using smoothing with the Binarize checkbox 
set to off produces a cleaner image with the background evened and line 
objects revealed. 

3. Set the Binarize checkbox to create a monochrome image. 

4. Click Ok after achieving satisfactory results in the preview window. 

Color Separation  

A real map or colour diagram is usually made up of a small number of colours. 
However, as a result of scanning a paper original we can get a colour raster image 
having tens or even hundreds of thousand of colours. 

Two similar procedures are described in this section that make possible to separate 
colour image dots in non-overlapping sets, i.e. categories. These procedures are used 
to extract the colours the original image was created with. The objects of the same 
type are usually marked with the same colour; therefore we are able to separate the 
necessary image objects.  

Each category is based on a set of basic colours. A set of basic colours that belong to 
all categories defines the separation of the original image dots in non-overlapping 
basic subsets. 

To distribute colours into subsets RxSpotlight performs the following procedure. The 
colour difference between each dot of a colour image and all specified basic colours is 
calculated. This dot is put in a subset of basic colour that has the minimum colour 
difference from the colour of this dot in the RGB area. Thus, all the original image dots 
are split to basic subsets, related to the specified basic colours. 
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The dots belonging to basic subsets, which correspond to colours of one category, 
form this category. 

For example, consider an image with a blue line passing across yellow and white 
background. Actually, this line consists of blue and green dots. Thus to classify the 
image dots correctly, we need to define three categories: the first one with yellow 
basic colour where all dots of yellow background will be put, the second one with 
white basic colour where all dots of white background will be put, and the third one 
with green and blue basic colours where all dots of blue line will be put. 

On layering, the program places the dots of each category in a separate monochrome 
image. The original colour image is not changed.  

As a result of this procedure the program assigns the same colour to the dots 
belonging to the same category. It causes colour reduction in the original image. 

Separation to several monochrome layers 

The first step to specify separation parameters is to define a set of object categories 
in the original image. For example, a category set may be the following: background, 
isolines, roads, railways, buildings, vegetation, rivers, etc. Up to 255 categories can 
be specified. Each category has two properties: name and symbolic colour. 

A symbolic colour is used to display dots, belonging to a certain category, in the 
preview window during the adjusting of separation parameters. It is also assigned to 
the monochrome layer to which the dots of this category are transferred. A symbolic 
colour does not need to correlate with the colour of extracted objects. 

To enable the program to extract the points, belonging to different categories, at least 
one basic colour needs to be specified for each category. As described above, the 
dots with the colour close to the category basic colours are placed into the appropriate 
category. The number and set of basic colours are defined manually when tuning the 
procedure. 

Image layering is performed with the Colour Separation dialog box. 

Running color separation 

When performing the separation procedure, the program creates a separate 
monochrome image for each category and places the object points, belonging to this 
category on this image. The new layers are created in the document, on which new 
raster images are placed. The layer‟s names are the same as the categories names. 
Images colours are defined according to the symbolic colours of appropriate 
categories. New monochrome images get the names <Original image name>N, where 
N is an integer. 

Several color raster images can be separated into layers at once. If no images are 
selected, then the command will be applied to all images (that are visible and located 
on unlocked layers). If several images are selected, then the command will be applied 
to those that are visible and located on unlocked layers. 

Layering can be applied to images with clipping boundary. Using this feature, the 
layered area in any image can be restricted by specifying its clipping boundary. 
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 For information on clipping boundary refer to page 130. 

To tune and run Colour Separation 

1. Select images to process. 

2. Click the  button on the Image toolbar or choose Colour Separation from the 

Image menu. 

 
 

 
Create a category set, using the Create Category button as described below 
in this section. 

 

To modify a category definition or delete a category created by mistake use 
the Delete or Modify buttons in Categories. 

 Use the preview tools of the color separation dialog box to view the results of 
modifying parameters. Note that an image review at a scale of 1:1 provides the 
most reliable results.  

 For more information on preview tools see page 34. 

3. If not satisfied with separation results, then try one of these methods: 

 Modify the category basic colours or add new basic ones, using the buttons of 
Colours. Note that a sufficient number of basic colours, describing each category 
should be specified. Colour samples both in the middle and closer to the object 
boundary should be selected. 

 - or -  

 Use the Noise Reduction slider and Despeckle option to redistribute dots by 
categories. 

 Deleting and modifying definition and a set of category basic colours are 
irreversible operations. So, if the option of returning to the current dialog 
box parameters adjustment is wanted, save the current adjustment to a 
template using the Template button before starting to change 
parameters or category set. The adjustment saved in the template can 
be restored later. 
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4. When satisfied with the quality of separation, click the Apply button. 

Tuning color separation  

Specify category attributes and basic colours in Categories and Colors of the Color 
Separation dialog box. Categories contain a list of specified categories, and buttons 
that allow creating, modifying, and deleting category definitions. Colors displays a list 
of basic colors of a category selected from the Categories list box and buttons that 

allow the basic colors of a selected category to be added or deleted. 

To add a new category 

1. Click  – Create category button in Categories. 

2. Specify with the eyedropper tool the object in the image, the dots of which 
should fall in the created category. 

 The Layer Name and Color dialog box will be displayed. 

 A category‟s symbolic color and name can be specified. By default the box 
specifies the color corresponding to the specified pixel color and the category 
name “LayerN”, where N is an automatically generated number. 

 To modify these default parameters, enter the category name to Name and 
select a color from the palette. 

3. Click OK. 

 In the Categories list a new category appears, and in the Colors list the colour 
pointed to in the pixel image is shown. 

 If a mistake is made when specifying a category, then delete its definition or 
modify its symbolic color and name. 

To delete a category definition 

 
1. Select a category from the list of Categories. 

2. Click Delete. 

To modify a category symbolic colour and name 

 
1. Select a category from the Categories list. 

2. Click the Edit Category button on Categories. 

 The Layer Name and Color dialog box will be displayed. 

3. Enter a new category name in Name and/or select a symbolic color from the 
palette. 

4. Click OK. 

 Note that the category set of basic colors is not changed when its definition is 
modified. 

To add a category basic color 

1. Select the required category from the Categories list. 

The current set of the selected category basic colours will appear in Colors. 

 
2. Click the button with eyedropper on Colors and specify a point on the 

image. 

The indicated point colour will be added to Colors. 
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If a mistake is made when selecting the basic color, then delete it. The mistake 
in color selection is detected by examining the separation results that are shown 
in the preview window. 

To delete a category basic colour 

1. Select the required category from the list of Categories. 

2. Select a required basic colour from the list of Colors.  

 
3. Click Delete in Colors. 

To adjust separation sensitivity to small objects 

Use the Noise Reduction slider and Despeckle option. 

Setting Despeckle on eliminates the influence of noise and small objects on the colour 
analyzing procedures. 

The Noise Reduction  slider allows the redistribution of pixels by categories by 
modifying the sensitivity of separation to small objects. This parameter modifies the 
degree of colour averaging when calculating pixel colour. If the averaging value is 
high, then small-sized droplets of unwanted colours (speckles) in large image objects 
will be classified as pixels of the categories to which relatively large objects belong. 
Due to high averaging value, the categories, containing small objects are distorted 
because the object edge dots are classified as objects of other categories. If 
averaging value is low, then the opposite effect is observed - the quality of small 
objects increases, the quantity of noise rises. 

By default the slider is set to an average value. If categories containing large filled 
areas are the most important, then reduce the value of this parameter (move to Low) 

to reduce raster speckles and holes in these category objects. 

If to get monochrome layers containing of small or thin objects, such as texts, 
characters, level lines or grids, then increase the value of this parameter, to prevent 
the small object shapes from being thinned and distorted by noise reduction. Of 
course, this increases the noise level on all layers. 
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Color Reduction 

This procedure is similar to that of color separation, described in the previous section. 
The only difference is that we do not have to specify categories names, since color 
reduction does not create of additional layers. 

To open the Color Reduction dialog box 

Click the  button on the Image toolbar or choose Color Reduction from the Image 

menu. 

 
The Colour Reduction dialog box 

The adjusting procedure is performed the same way as the color separation 
procedure. Functions of this dialog box dialog controls are the same as those of the 
color separation dialog controls described on page 340.  
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Details 

OCR Professional Support 
Besides the standard tools used for RxSpotlight text recognition, the additional OCR 
module from ABBY Software can be installed; this module is intended to recognize 
texts on raster images. The OCR Professional option is best used to extract large 
amounts of text from drawings. 

After installation the OCR Pro tab is added to the Conversion options dialog, and Use 
OCR Professional appears in the Recognition tab in the list of text recognition options. 

 
  

 

New tab OCR Pro Changes in Recognition tab 

Choosing the Convert > Fine OCR command opens the following dialog window. 
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Options Auto, Matrix Printer, Typewriter 
and Handprint represent different 
algorithms of text recognition.  

Turning on Analyze Layout adds the 
ability to recognize text strings that are 

not oriented horizontally. Buttons  

and  are used to select raster 

areas that contain text in a window or 
polygon boundary respectively. The 
recognized text is shown in Output 
where it can be edited and saved or 
placed on a specified layer. 

Option As Text to Layer places the 
recognized text to a specified layer, 
and To File – to a specified file. 

The information on OCR Professional 
module can be found in the 
documentation of ABBY Software. 

Work automation and custom user’s 
command creation 
There are several ways to automate work with RxSpotlight and/or create user‟s 
custom commands. Each of them requires some programming knowledge and skills. 

Let's start from the simplest. 

Autocorrect command 

When starting this command a set of commands is applied to the raster image(s) in 
the current document. 

For example,  suppose a user wants to rotate all raster images by 90 degrees and 
remove holes, and then deskew the image in auto mode. These three commands 
(Autocorrect command setting) can be activated; the three operations are executed by 
one click on Autocorrect. The list of commands is defined and commands turned on 
(or off) with the Autocorrection section of the Preferences dialog. 

The commands used with autocorrection which are executed with no parameters 
mainly refer to processing the whole raster image. The following commands are 
available: monochrome filters - Remove Speckles, Remove Holes, processing raster 
commands - Deskew, Crop, Fit to paper, Rotate 90CCW, Rotate 180, Rotate 90 CW, 
and also Equalize for auto correcting of colour image brightness. 

 For more information on the Autocorrect command see description on page 

134. 
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RxSpotlight Script 

A RxSpotlight script lists RxSpotlight commands in specified order. It is written to a 
text file (with CSF extension). 

When executing such script, RxSpotlight opens raster images included in the script, 
applies the commands to them and saves the changes made. 

A special visual tool Script Studio is designed for creating, tuning and starting scripts. 
To launch RxSpotlight script, use the Run Script command or create a custom user 
command button or menu item. 

 For detailed information about custom command buttons see page 381. 

The script can be started from the Windows command line, i.e. use Windows batch 
file to start RxSpotlight and execute script. If starting from the command line, then the 
program window might not be displayed (hidden mode). 

Scanning commands used in scripts can work with devices designed for auto-supply 
of scanned originals (reproscan devices). 

There is no need to attend the RxSpotlight script execution - the computer can 
process data on its own, which saves operator time. 

RxSpotlight Batch 

RxSpotlight batch operates with several RxSpotlight scripts applied in sequence to a 
specified group of raster images. Batch is convenient to apply RxSpotlight scripts to a 
great number of raster images, located in different folders. 

A RxSpotlight batch file is composed with the Batch Studio command. 

Using the batch mode allows users to avoid changing paths in prepared scripts and 
create scripts with image processing commands only (without Open, Insert). 

RxSpotlight Open Architecture (WIOA) 

RxSpotlight has an open architecture (WIOA), which is used to create custom user 
commands using Java Script and Visual Basic Script languages. 

WIOA creates scripts for more flexible tasks than those of RxSpotlight scripts (which 
are more oriented to batch processing of raster images). WIOA provides a powerful 
mechanism for customizing RxSpotlight, creating custom commands and close 
integration with other applications which are accessible through ActiveX (for example 
with Microsoft Office applications). Programming in JScript and VBScript requires a 
fundamental understanding of ActiveX Automation. 

The Active Script Studio tool is used to create, edit and start WIOA scripts. To launch 
a WIOA script, use the Run Script command or create a custom user command 
button or menu item. 

DDE 

The DDE-interface of RxSpotlight represents the server and allows other applications 
to use its functions .With DDE it is possible to interact with 16-bit applications which 
can't support OLE Automation. 

RxSpotlight script 
A RxSpotlight script is a text file with one command on each line. 
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A script file can be created for standard processing of a loaded image and this file 
used to handle a number of images. To do so, create a script file containing the 
sequence of commands that load an image, invoke the standard processing scenario, 
and then save the resulting image or document for every image. 

 RxSpotlight script files can be created in RxSpotlight
 
using the dialog window Tools > 

Script Studio. It is the easiest way to create scripts – there is no need to know the 
syntax of a RxSpotlight script to create it when using Script Studio. 

Script files can be created externally using a text editor (such as Microsoft Windows 
Notepad) or a word processor (such as Microsoft Word) that can save the file in ASCII 
format. The file extension must be .SCF. 

RxSpotlight also creates a log file for each script execution that contains the script 
execution date and all error messages that occur. The log filename is defined in the 
script file otherwise the default log filename that is set in RxSpotlight Preferences 
dialog is used. If a script file contains syntax errors, then it will not be executed and 
the description of errors will be written into the log file. 

RxSpotlight script launching 

There are four ways to run a RxSpotlight script. 

1) It can be done from RxSpotlight using Run Script command in the Tools menu. 

2) Also a script can be started from the command line using a special program call. 

A program call consists of three parts separated with space symbols. 

Syntax: 

RxSpotlight_executable_file { -K | -C } [ -L ] RxSpotlight_script_file 

Parameters: 

RxSpotlight_executable_file  - The name of the RxSpotlight executable file (WI7.EXE 
by default). The second part is a special parameter: 

-K – Starting the application and executing the RxSpotlight script. 

-C – Indicates that the application must execute the script file in background mode 
(the application window is not displayed while the script is executing). 

-L – Defines the log file. 

RxSpotlight_script_file - The path to and the name of the script file that is to be 
executed. 

Example: 

WI7.EXE -C -L /Script/ColourRaster.csf 

3) A script can also be started directly from the Script Studio dialog. 

4) The last way to is to unite several scripts in the batch in the Tools > Batch studio 
dialog and apply it to selected images. 

Script examples 

RxSpotlight script examples can be found in the SCRIPTS subfolder of the 
RxSpotlight program folder. 
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Syntax of RxSpotlight script 
RxSpotlight script files consist of one or more lines, each of which is either a comment 
or a command. Any line that begins with a semicolon (;) is considered a comment, 
and RxSpotlight ignores it while processing the script file. 

The command in the script contains the command name and, if necessary, one or 
more parameters. All command names start with the slash symbol (“/”). Command or 
parameter names are entered in either upper or lower case. Command or parameter 
names are separated with the standard separators – space symbols, tab symbols, 
etc. 

If a script command parameter has any value, then it is entered after the parameter‟s 
name separated by a colon. For example: 

/ROTATE ANGLE:30 

If a command has only one parameter, then its name can be omitted. In such a case 
the command name is followed by a colon, after which goes a parameter value. 
Applying this rule the example above may look as follows: 

/ROTATE:30 

Note that a command name, a colon and a parameter value must not be separated by 
any separator symbol. 

All references to names (names of files or layers) must be enclosed in double quotes. 
For example, to open the image MYHOUSE.TIF from a script, use the following 
syntax: 

/OPEN:”myhouse.tif" 

Some numerical parameters may be specified in different units. For example, an 
image height can be either in millimetres or in inches. These units are set in the Script 
item of the Preferences dialog box. Type “mm” (millimetres) or “inch” (inches) for 
linear units and “deg” (decimal degrees) or “rad” (radians) for angle units. 

The batch commands described below are divided into groups based on their 
functionality, such as file processing commands, filtration commands, etc. 

File selection wildcards 

The wildcard symbols * and ? can be used in Open, Export, InsertImage, 
SaveImageAs, and SaveAs commands to open a group of files, process them one by 
one in a loop and save changes.  

If using wildcards, then it is recommended to use the Close command to stop 
processing the list. 

In this example we open all TIF files in the SAMPLES folder, process and save 
them in the NEWSAMPLES folder in BMP format: 

… 

; Batch operators 

… 

/OPEN: "SAMPLES\*.TIF" 

;opens TIF files from the SAMPLES folder 
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… 

;Batch operators processing TIFs 

… 

/SaveAs FNAME: “NEWSAMPLES\*. *” FTYPE: “BMP” 

; saves the BMP file in the NEWSAMPLES folder 

… 

/CLOSE 

; Closes the loop 

 

The RxSpotlight batch processor treats them according to following rules (the same 
as in DOS environment): 

1. Asterisk stands for any number of characters. 

2.  Question sign stands for a single character. 

For example, the following command syntax is valid: 

/OPEN: "SAMPLES\*.TIF" 

as is the next example: 

/OPEN: "..\\R?F.TIF" – it would open REF.TIF, RIF.TIF, RRF.TIF and so on (but 
not RREF.TIF) in the upper folder. 

as is the next example: 

/OPEN: "REF.* " – it would open REF.TIF, REF.CWS, RRF.BMP and so on 

3. If opening a number of files using wildcards, then save them using wildcard 
techniques: 

For example, if opening REF1.TIF, REF2.CWS, and RRF3.BMP files with the 
command: 

/OPEN: "REF*.*; *.BMP” 

process them in a batch and close with the help of 

/SAVEAS: "..\\*.* " FTYPE: “CWS” 

the upper folder will contain REF1.CWS, REF2.CWS, and RRF3.CWS files. 

4.  Use the ";" symbol in the <filename> parameter of the Open command. 

Example: 

/OPEN: "REF*.*; DETAILS.BMP; MYHOUSE*.TIF" 

 This list of files will contain all files who‟s names begin with "REF", 
DETAILS.BMP file, and MYHOUSE1.TIF, MYHOUSE2.TIF, MYHOUSE2.TIF, 
etc. 

5.  Every item of the list is processed in a loop until the Close command is executed 
or the next Open occurs. The Close command is a valid way to close the list and 
dismiss the list of processed files. 

To get more information on using wildcards, see command line reference in the 

operational system manual. Do not use this feature until conversant with command 
line manipulation. 
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Script Studio 
RxSpotlight has a Visual Editor to create RxSpotlight scripts quickly and conveniently. 

 
The left hand side of its dialog contains a list of all available commands. The current 
script window is located to the right. 

Compose script by dragging commands from the list to the script window. With the up 
and down arrows control the order of execution of commands can changed. 

After a script is started, view the occurred errors in the report field. 

Script commands can come with parameters. Most commands have similar 
parameters to those of RxSpotlight commands; the other commands have the 
parameter – command template name(TEMPL), which contains a set of parameters 
needed to execute the command. 

To create a RxSpotlight script 

1. Choose Tools > Script Studio. The script editing and running dialog window 
opens. 

2. Using standard drag and drop techniques; populate the Script window in the 
dialog with the desired operations from the list in the left hand side. Press the 
key with the first letter of command name to speed up this process. To work with 
a list of commands, use the Category list in which commands are grouped by 
menu items (File, Edit..) 

3. Set the command execution order by dragging them or using the  
buttons. To set order precisely by dragging, hold the command over the other 
until a strip appears either under or over the command - this strip displays the 
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expected command position – choose the desired position and release the 
mouse button. 

4. Set the commands parameters (if needed). Those commands which require 
setting parameters for execution are marked with a cross to the left of their 
names. Some commands can be used in automatic mode or without setting 
parameters (e.g., Speckle remover). 

5. Save the created script using the Save button. 

To check created script 

When starting a script from the Script Studio dialog, view the process of the script 
execution (i.e. view occurred errors and progress). 

 
To write the results of the commands execution to a text file, use command Set log 
file. 

If the file name and path are omitted, then the program uses the name specified in the 
section Script > Default Log File of Preferences dialog. 

To change RxSpotlight script 

Change a prepared script using the Script Studio dialog or manually using a text 
editor. Batch Studio avoids the need to modify file paths and names in the prepared 

script. To delete a command from script, use the  button or the DELETE key on 

the keyboard. 

 

Dialog buttons and controls 

Button Description 

 
Makes a copy of the selected 
command. 

 
Deletes the selected 
command. 

 
Moves the selected command 
up in the script. (It will be 
executed earlier.) 

 
Moves the selected command 
down in the script. (It will be 
executed later.) 

 
Clicking on the plus sign 
reveals the command‟s options  
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Button Description 

 

By clicking on “+” the 
command options tree is 
opened.  Clicking on the 
command options values 
enters editing mode and 
appropriate values or options 
can be entered.

 

Run Launch a RxSpotlight script 
and watch the program‟s 
progress messages in the

 
lower right section of the 
dialog. Press Cancel to stop 
execution of the script. 

New Clears the Script window and 
begins the new script. 

Open Opens saved script. 

Save/Save As Saves a script.  

RxSpotlight script commands (Reference) 
Exit 

Closes application 

Format: 

/Exit 

SetLogFile 

Creates a log file with the script execution date and all error messages that occurred 
during executing. 

Format: 

/SetLogFile[ FNAME]:”<filename>” 

Example: 

/SetLogFile:”C:\RXSPOTLIGHT5\MyScript.log” 

File processing commands 

Open 

Opens an existing document. 

Format: 

/Open[  FNAME]:"<filename>" 

Example: 
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/Open:"C:\RXSPOTLIGHT5\Samples\map.tif" 

New 

This creates a new document. 

Format: 

/New 

Close 

This closes the current document. 

Format: 

/Close 

Save 

This saves the current document to a file. If the current document cannot be saved in 
the current file, then this command will be ignored. This might happen, for example, 
when trying to save several images or vector objects in image format. 

Format: 

/Save 

SaveAs 

This saves the current document to a new file. It can be saved in Colour Workspace 
format (CWS) or AutoCAD file format (DXF, DWG). 

Format: 

/SaveAs[ FNAME]:"<filename>” FTYPE:”<ext>" 

Example: 

/SaveAs FNAME:"C:\RXSPOTLIGHT5\Samples\test.cws" FTYPE:”cws” 

Export 

This exports current document in as a Colour Workspace file (CWS) or AutoCAD file 
(DXF, DWG). 

Format: 

/EXPORT[ FNAME]:"<filename>” FTYPE:”<ext>” 

Example: 

/EXPORT:"C:\RXSPOTLIGHT5\Samples\MyWorspace.cws” FTYPE:”cws” 

InsertImage 

This inserts an image from a file into the existing document. 

Format: 

/InsertImage[  FNAME]:"<filename>" 

Example: 

/Insert:"C:\RXSPOTLIGHT5\Samples\map.tif" 
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SaveImageAs 

This saves an image in a new image format. 

Format: 

/SaveImageAs[ INAME]:"<imagename>” FNAME:”<filename>” FTYPE:”<ext>" 

Example: 

/SaveImageAs:”electr” FNAME:"C:\RXSPOTLIGHT5\Samples\test.tif" FTYPE:”tif” 

Print 

This prints the specified area of the current document to the selected printer with the 
scale specified. 

Format: 

/PRINT [FIT | SCALE: <scale>] [LEFT:<offset> TOP: <offset> RIGHT: <offset>  
BOTTOM: <offset>] [NUMCOP:<copies>] [PNAME:”<printer name>”] 

Description of Parameters: 

FIT and SCALE 

This specifies the print scale. With both parameters omitted, the command prints the 
image without scaling so that 1 image millimetre (or inch) represents 1 millimetre (or 
inch) on the paper. 

FIT 

This scales the print so that the portion of the document to be printed is made as large 
as possible for the specified paper size. 

SCALE 

Multiplies the print dimensions to the specified scale factor. For example, /PRINT 
SCALE:0.5 reduces the image by half before printing it. 

LEFT, TOP, RIGHT, and BOTTOM 

This defines the portion of the document to be printed. Each of these parameters 
defines the offset of the print area boundary. If the parameter value is positive, then 
the margin will be added to the appropriate boundary side. If it is negative, then the 
stripe of the defined width will be cut from the print area boundary. If some of these 
parameters are omitted, then the offsets will be equal to 0. 

NUMCOP 

This specifies the number of copies to print. If it is omitted, then the command prints 
one copy. 

PNAME 

This specifies the name of a printer. If it is omitted, then the command sends the 
output to the default Windows printer. The printer name should be typed as it appears 
in the Printer Name list box of the Print dialog. 

Example: 

/PRINT SCALE:2.5 LEFT:17.5 BOTTOM:10 NUMCOP:2 
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Acquire 

Acquires the image using the specified TWAIN source, creates a new document 
consisting of one raster image, and places the result of acquiring on this image. 

Format: 

/Acquire DPI:<dpi_value> BPP:<bpp_value> [GREYSCALE] [SOURCE:”<source 
name>”] 

Description of Parameters: 

DPI 

This specifies the scanner resolution in dots per inch. 

BPP 

This defines the number of colours to be used as colour depth in bits per pixel. Colour 
depth determines the number of bits used for colour representation when an image is 
being scanned. It may take the following values: 1, 4, 8, 16, and 24. For example, 
BPP: 1 value defines the bitonal scanning and BPP:24 value defines the TrueColour 
(RGB) scanning. 

GREYSCALE 

This forces the program into greyscale scanning mode. If this parameter is set, then 
define BPP = 8, or else the greyscale parameter will be ignored. 

SOURCE 

This specifies the name of the TWAIN source that will be used for acquiring the 
image. If it is omitted, then the program uses the default source. 

Example: 

/Acquire DPI:150 BPP:24  

AcquireRaster 

The image is acquired using the specified TWAIN source, creates a new raster image  
in the existing document, and places the result of acquiring on this image. 

Format: 

/AcquireRaster [RN:”<raster_name>”] DPI:<dpi_value> BPP:<bpp_value> 
[GREYSCALE] [SOURCE:”<source name>”] 

Description of Parameters: 

RN 

This specifies the name of the raster that is used for the results of scanning. 

DPI, BPP, GREYSCALE, SOURCE are described above in “Acquire” 

Example: 

/AcquireRaster DPI:300 BPP:8 GREYSCALE  

Entire Image Processing Commands 

MirrorX 

This flips the images about the X axis. 

Format: 
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/MirrorX 

MirrorY 

This flips the images about the Y axis. 

Format: 

/MirrorY 

Rotate90_CCW 

This rotates the images 90 degrees counter clockwise about its centre point-. 

Format: 

/Rotate90_CCW 

Rotate180 

This rotates the images 180 degrees about its centre point. 

Format: 

/Rotate180 

Rotate90_CW 

This rotates the images 90 degrees clockwise about its centre point. 

Format: 

/Rotate90_CW 

Rotate 

This rotates the images by a user-defined angle about its centre point. 

Format: 

/Rotate[ ANGLE]:<angle> 

Example: 

/Rotate:45 

AutoCrop 

Automatically detects margins for the specified raster image and removes them. 

Format: 

/AutoCrop [[ERN]:”<raster name>”] 

Description of Parameters: 

ERN – name of the raster for margins detecting. It may be omitted if the document 
consists of one raster image. 

Example: 

/AutoCrop:”map” 

Auto correct 

Applies a sequence of operations specified in the Autocorrect item of the Preferences 
dialog box to the raster image. 
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Format: 

/AutoCorrect[[ ERN]:”<raster name>”] 

Description of Parameters: 

ERN – name of the raster for automatic estimation and detection. It may be omitted if 
the document consists of one raster image. 

Example: 

/AutoCorrect:”cs_cam” 

Deskew 

Automatically estimates the raster image deviations from the horizontal and vertical 
and rotates the image about its centre point to align it vertically or horizontally. 

Format: 

/AutoDeskew[[ ERN]:”<raster name>”] 

Description of Parameters: 

ERN – name of the raster for automatic deskew angle estimation. It may be omitted if 
the document consists of one raster image. 

Example: 

/AutoDeskew:”vp_city” 

Entire Image Processing Commands (resample family) 

ChangeDPI 

Scales the image dimensions in pixels by changing its resolution in dot-per-inch. The 
image dimensions in millimetres or inches will not be changed. 

Format 

/ChangeDPI[ DPI]:<dpi_value> 

Example: 

; The current image resolution is 150 dpi and it has dimensions 
; 1500x1500 pixels or 10x10 inches 

/ChangeDPI:300 

; The image resolution is 300 dpi and it has dimensions 
; 3000x3000 pixels or 10x10 inches 

SetDPI 

Scales the image dimensions in millimetres or inches by setting the new resolution 
value in dot-per-inch. The image dimensions in pixels will not be changed. 

Format: 

/SetDPI[ DPI]:<dpi_value> 

Example: 

; The current image resolution is 150 dpi and it has dimensions of 
; 1500X1500 pixels or 10X10 inches 

/SetDPI:300 
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; The image resolution is 300 dpi and its dimensions in pixels don‟t  
; scale (1500x1500 pixels)  
; but its dimensions in inches are now equal to 5x5 inches 

Resize 

Scales the image so that its height (or width) in current linear units becomes equal to 
the specified value. If the RESAMPLE parameter is present, then the command 
scales the image dimensions in pixels. If it is omitted, then the command scales the 
image by changing the new resolution value. 

Format: 

/Resize  WIDTH:<distance>| HEIGHT:<distance> [RESAMPLE] 

Description of Parameters: 

WIDTH and HEIGHT 

Specify the new width or height for the image. 

RESAMPLE 

Defines whether the image dimensions in pixels will be changed or not. 

Example:  

; Scale the image by changing its dimensions in /SetLinearUnits:  

/Resize  WIDTH:84 RESAMPLE 

Scale 

Scales the image. If the RESAMPLE parameter is present, then the command scales 
the image dimensions in pixels. If it is omitted, then the command scales the image by 
changing the resolution value. 

Format: 

/Scale[ SCFACT]:<scale factor> [RESAMPLE] 

Description of Parameters: 

SCFACT – scale factor. 

Example:  

; Enlarge the image twice by changing its dimensions in current  
; linear units; (millimetres or inches) dimensions in pixels will not  
; be changed. It means that the image 
; DPI value will be decreased by half. 

/Scale:2  

ChangeSizeInPixels 

Scales the image so that its height (or width) in pixels becomes equal to the specified 
value. 

Format: 

/ChangeSizeInPixels PWIDTH:<distance in pixels> | PHEIGHT:<distance in pixels> 

Example:  
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; Scale the image by changing its dimensions in pixels so that  
; the image height will be equal 1200 pixels  

/ChangeSizeInPixels PHEIGHT:1200 

Entire Image Processing Commands (image size family) 

ChangeImageSize 

Takes the original image and places it unchanged on a new image of the specified 
dimensions with the specified alignment. 

Format: 

/ChangeImageSize WIDTH:<distance> HEIGHT:<distance> [ALIGN:”<align_type>”] 
[LEFT:<offset>] [TOP:<offset>] [RIGHT:<offset>]  [BOTTOM:<offset>] 

Description of Parameters: 

WIDTH 

Width of the new image in the current linear units. 

HEIGHT 

Height of the new image in the current linear units. 

ALIGN 

Defines the type of alignment and specifies the available sequence of the LEFT, TOP, 
RIGHT, BOTTOM additional parameters. It may take the following values: LeftTop, 
Top, RightTop, Left, Centre, Right, LeftBottom, Bottom, or RightBottom. If this 
parameter value is Centre, then the original image centre point is always placed to the 
centre point of the new image and LEFT, TOP, RIGHT, BOTTOM are ignored. If one 
of the Top, Left, Right, Bottom values is used, then the image is aligned so that the 
centre point of the appropriate original image side is placed to the centre of the new 
image side. In such a case only one of the additional parameters is available. For 
example, if Top is used, the TOP parameter is available. When you use LeftTop, 
RightTop, LeftBottom, or RightBottom, the two appropriate additional parameters are 
available. For example, the LeftTop value indicates that the TOP and LEFT 
parameters are available and the RIGHT and BOTTOM parameters will be ignored. 

LEFT, RIGHT 

This defines the offset of the left or right original image side relative to the appropriate 
side of the new image. Only one of these parameters can be used at one time. 

TOP, BOTTOM 

This defines the offset of the top or bottom original image side in relation to the 
appropriate side of the new image. Only one of these parameters can be used at one 
time. 

Example:  

/ChangeImageSize WIDTH:85.27 HEIGHT:61 ALIGN:"LeftTop" LEFT:-20.3 TOP:12.4 

FitToClosestPaper 

This finds the standard paper format closest to the original image format and places 
the original image on a new image with the specified alignment. 
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The list of standard paper formats may be changed using the Papers item of the 
Preferences dialog box.  

Format: 

/FitToClosestPaper [ALIGN:”<align_type>”] [LEFT:<offset>] [TOP:<offset>] 
[RIGHT:<offset>]  [BOTTOM:<offset>] 

Description of Parameters: 

ALIGN, LEFT, RIGHT, TOP, BOTTOM are described above in “ChangeImageSize” 
command description. 

Example:  

/FitToClosestPaper WIDTH:120 HEIGHT:80.5 ALIGN:"Bottom"  BOTTOM:10 

FitToPaper 

Takes the original image and places it unchanged on a new image of the specified 
standard size with the specified alignment. 

The list of standard paper formats may be changed using the Papers item of the 
Preferences dialog box.  

Format: 

/FitToPaper [PN]:"<paper name>" [O:<orient_type>] 
[ALIGN:”<align_type>”] [LEFT:<offset>] [TOP:<offset>] [RIGHT:<offset>]  
[BOTTOM:<offset>] 

Description of Parameters: 

PN – Name of the standard paper format. 

O – Orientation type (must have a numeric value):  

1 - portrait orientation, 

2 – landscape orientation. 

ALIGN, LEFT, RIGHT, TOP, BOTTOM are described above in “ChangeImageSize”. 

Example: 

/FitToPaper PN:"ISO A2" O:2 ALIGN:”RightTop” RIGHT:20 TOP:10 

ChangeMargins 

Changes image size by adding or cutting specified margins. 

Format: 

/ChangeMargins [LEFT:<marg>] [TOP:<marg>] [RIGHT:<marg>] [BOTTOM:<marg>] 

Description of Parameters: 

LEFT, TOP, RIGHT, and BOTTOM 

Each of these parameters defines the margin value for the appropriate image side. If 
the parameter value is positive, then the margin will be added to the appropriate 
image side. If it is negative, then the strip of the defined width will be cut from the 
image. If some of these parameters are omitted, the appropriate margin values for 
these will be set  to 0. 

Example: 



RxSpotlight User Guide 

364 

/ChangeMargins LEFT:12.5 RIGHT:20 BOTTOM:12.5 

Tools 

Calibrate 

This calibrates the image using the current calibration parameters or parameters 
defined by the specified template. If the template file is not stored in the default 
template directory, then a path must be defined for it. 

Format: 

/Calibrate[[ TEMPL]:”<template file>”] 

Example: 

/Calibrate:"My_calibration.tpl" 

Binarize 

This binarizes the image using the current binarization parameters or parameters 
defined by the specified template. If the template file is not stored in the default 
template directory, then a path must be defined for it. 

Format: 

/Binarize[[ TEMPL]:”<template file>”] 

Example: 

/Binarize:"map-rivers.tpl" 

Colour Reduction 

Performs colour reduction in the image using the current parameters or parameters 
defined by the specified template. If the template file is not stored in the default 
template directory, then a path must be defined for it. 

Format: 

/ReduceColours[[ TEMPL]:”<template file>”] 

Example: 

;Template file is not situated in default template directory: 

/ReduceColours TEMPL:"C:\MyTPLs\My_ColourReduction.tpl" 

Colour Separation 

Performs colour separation of the image using the current parameters or parameters 
defined by the specified template. If the template file is not stored in the default 
template directory, then a path must be defined for it. 

Format: 

/SeparateByColours[[TEMPL]:”<template name>”] 

Example: 

/SeparateByColours:"map.tpl” 
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Separate By Size 

Finds raster objects of the given size on the specified monochrome images and then 
moves the found objects onto a new layer. 

Format: 

/SeparateBySize RNS:"<raster_name1>"+["<raster_name2>"+...] 

OLN:"<layer_name>" MIN:<dim> MAX:<dim> 

Description of Parameters: 

RNS – Names of monochrome raster images to find raster objects on 

OLN –Name of new layer to place raster objects on  

MIN, MAX – minimum and maximum sizes of objects to find. 

Example: 

; Moves raster objects that are more than 2 mm and less then  
;3.5 mm from the "Texts" and ”Symbols” images of one layer to “Small Symbols” layer. 

/SeparateBySize RNS:"Texts"+”Simbols” OLN:"Small Symbols" MIN:2 MAX:3.5 

Colour Correction Tools 

Convert to 24 bit 

Converts monochrome, greyscale, and 8 and 16 bit colour images to RGB colour 
images (24 bpp). 

Format: 

/ConvertToTrueColour 

Equalize 

Automatically redistributes the brightness values of the pixels in the images. 

Format: 

/AutoEqualize 

Brightness/Contrast 

This changes brightness, contrast, hue, and saturation values of the pixels in the 
images. 

Format: 

/ChangeLevels [B:<brightness>] [C:<contrast>] [H:<hue>] [S:<saturation>] 

B – The change of the brightness value from –100 to +100 

C - The change of the contrast value from –100 to +100 

H - The change of the hue value from –180 to +180 

S - The change of the saturation value from –100 to +100 

Example: 

/ChangeLevels B: 10 C:-10 
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Colour Filters 

 Colour filters are described from page 324. 

Blur 

Format: 

/Blur[ RAD]:<radius> 

RAD – The change of the blur radius from 0.0 to 10.0 pixels 

Example: 

/Blur:3.7 

Median 

Format: 

/Median[ RAD]:<radius> 

RAD – The change of the median radius from 0 to 5 pixels 

Example: 

/Median:3 

UnSharpMask 

Format: 

/UnSharpMask SENS:<sens_value> RAD:<radius> 

SENS – The change of the sensitiveness value from 0% to 100% 

RAD – The change of the unsharp radius from 0.0 to 10.0 pixels 

Example: 

/UnSharpMask SENS:35 RAD:6 

Mono Filters 

 Monochrome filters are described from page 149. 

Invert 

Format: 

/Invert[[ RNS]:”<raster_name1>”[+”<raster_name2>”+...]] 

RNS – Names of monochrome raster images to invert. 

Example: 

/Invert RNS:”cs_cam”+”vp_city” 

Contour4 

Format: 

/Contour4[[ RNS]:”<raster_name1>”[+”<raster_name2>”+...]] 

RNS – Names of monochrome raster images to create 4-coupling contours on. 
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Example: 

/Contour4:”cs_mech” 

Contour8 

Format: 

/Contour8[[ RNS]:”<raster_name1>”[+”<raster_name2>”+...]] 

RNS – Names of monochrome raster images to create 8-coupling contours on. 

Example: 

/Contour8 RNS:”cs_map” 

RemoveSpeckles 

Format: 

/RemoveSpeckles[ RNS:”<raster_name1>”+[”<raster_name2>”+...] [E I MIN:<dim> 
MAX:<dim>] 

Description of Parameters: 

RNS – Names of monochrome raster images to remove speckles from. 

E – Estimates dimension of speckles to remove them automatically. 

MIN, MAX – Minimal and maximal sizes of speckles to remove in default units. 

Example: 

/RemoveSpeckles RNS:”cs_plan” MIN:0.5 MAX:11.58 

RemoveHoles 

Format: 

/RemoveHoles[ RNS:”<raster_name1>”+[”<raster_name2>”+...] [E I MIN:<dim> 
MAX:<dim>] 

Description of Parameters: 

RNS – Names of monochrome raster images to remove holes from. 

E – Estimates dimension of holes to remove them automatically. 

MIN, MAX – Minimal and maximal sizes of holes to remove in default units. 

Example: 

/RemoveHoles MIN:0.5 MAX:6.32 

Smooth 

Format: 

/Smooth[ RNS:”<raster_name1>”[+”<raster_name2>”+...] M:<degree> T:<threshhold> 

Description of Parameters: 

RNS – Names of monochrome raster images to smooth. 

M – Medianing degree from 0% to 100%. 

T – Smoothing threshold from 0 to 255 

Example: 
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/Smooth RNS:”cs_plan” M:50 T:120 

Thin 

Format: 

/Thin[ RNS:”<raster_name1>”[+”<raster_name2>”+...] [S I NP:<num>] 

Description of Parameters: 

RNS – Names of monochrome raster images to thinning. 

S – Thin images up to skeleton. 

NP – Number of thinning filter passes from 1 to 100. 

Example: 

/Thin NP:5 

Thick 

Format: 

/Thick [RNS:”<raster_name1>”[+”<raster_name2>”+...] [DIR:<direction>] [NP:<num>] 

Description of Parameters: 

RNS – Names of monochrome raster images to thicken. 

DIR – Thickening direction: 

0 – horizontal thickening, 

1 – vertical thickening. 

If the DIR parameter is omitted, then the thickening filter uses default directions. 

NP – Number of thickening filter passes from 1 to 100. 

If the NP parameter is omitted, then thickening filter uses one pass as default. 

Example: 

/Thick RNS:”cs_cam” DIR:0 NP:3 

RxSpotlight Batch 
Prepared RxSpotlight scripts can be used for composing RxSpotlight batch-scenarios. 
The batch scenario makes it possible to apply unattended a sequence of operations 
to a number of images. Batch mode is convenient for using RxSpotlight scripts to 
process a large number of raster images located in different folders. It avoids 
changing paths in prepared scripts, i.e. creating scripts with handling image 
commands only, without Open, Insert, Save commands. 

Batch Studio 

RxSpotlight batches are created and started using the Batch Studio. 

To create a batch, specify input images, RxSpotlight script file(s) which contain a 
processing scenario, and output images. Save the processed images to the same or 

different files, different file formats can also be selected for the destination files. More 
than one script may be applied to selected images in the batch. 

1. Choose Tools > Batch Studio. The script tuning dialog window opens. 
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2. The Select File or Directory tree shows existing files and folders; use format list 

to show appropriate files. 

3. To specify images to be processed, select the input files or the entire folder and 
move them to Input files or directories using the standard mouse-dragging 
technique. Multiple files can be selected with the CTRL key pressed or, with a 
window by drawing a frame over the files to select. 

4. Select one or more RxSpotlight script files and place them to the Script Files list. 
It specifies the processing scenario when running batch. Clicking on a script list 
item it opens the Script Studio dialog described above; allowing the processing 
scenario contents to be checked or edited.  

5. Switch on the Process Subfolders checkbox to include all subfolders of the 
specified directories in the batch to be processed. 

6. Switch on the Rebuild input list checkbox to see the list of unprocessed files and 
files processed with errors instead of the Input files/directories list after batch 
processing. 

7. Switch on the Ignore Open/Save in scripts checkbox to ignore all Open, Insert 
and Save commands in scripts during batch processing. 

8. Press Run to launch the batch. The input files are processed with the scripts 
from Scripts… and the results are put into the Output… folder. The error or 
progress messages are shown in the lower right of the dialog. Press Cancel to 
stop executing the batch. To save the images in different folder and format 
select the output folder and file type. If this is omitted, then the images will be 
saved with their current names.  

Batch execution errors 

Some errors may occur during the automatic processing a group of raster images. 
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If the Rebuild input list checkbox is turned on, then the names of the files which 
caused mistakes during batch processing and also unprocessed files and directories 
will be left in the Files or folders to process field. The names of the commands, which 
were executed with errors, are logged in the Name field (see the picture). By double-
clicking on the image name the image can be opened in the program in order to, for 
example, process this raster manually. 

Batch execution report 

An entire step-by-step report on batch execution can be seen by viewing the 
messages that appear in the report output field.  

 
A full report (DEFAULT.LOG) can be found in the folder where the program is 
installed. The report file name is set in the Scripts > Default Log File item of the 
Preferences dialog. 

Dialog buttons and controls 

The buttons and controls in Batch Studio dialog have the following meaning:  

Control/Button Description 

Select File or Directory  

 
Opens a list of the directory shortcuts (to 
see the list place the mouse pointer on 
this icon and wait a bit) 

 

Add selected directory to the directory 
shortcuts list 

 

Refresh the folder tree 

 
Folder tree files filter 

Input files or directories
 

 

 
Creates a new file name or folder 

 Removes the selected item 

 Moves the selected item up 

 Moves the selected item down 
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Control/Button Description 

 
Switch on the Process Subfolders 

checkbox to include all subfolders of 
specified directories to batch processing. 

 
Switch on the Rebuild input list checkbox 
to see the list of unprocessed files and 
files processed with errors instead of the 
Input files/directories list after batch 
processing. 

 
Switch on the Ignore Open/Save in 
scripts checkbox to ignore all Open, 
Insert and Save commands in scripts 
during batch processing. 

Script files list
 

 

 
Create a new item 

 Remove the selected item 

 Move the selected item up 

 Move the selected item down 

 

Switch on the Use output checkbox and 

specify the place for redirecting 
processed files. 

 

Selects the format of output files. Click 

the  button to edit chosen format 

properties. 

Dialog buttons
 

 

Reset Clear all batch content. 

Run Launch batch processing and watch the 
output results in the lower right section of 
dialog. Press the Cancel button to stop 
execution of the batch. 

Close Close the dialog and keep all settings of 
Batch Studio. 

RxSpotlight Open Architecture 
RxSpotlight has an open architecture for creating custom user commands using Java 
Script and Visual Basic Script languages. Use WIOA to create scripts to execute 
much more flexible tasks than those of RxSpotlight scripts (which are more oriented to 
batch processing raster images). 
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 To install or update Microsoft Scripting Runtime Component and to get 
information on Java Script and VBScript languages‟ syntax and the runtime 
components description refer to http://www.msdn.microsoft.com/scripting or to 
Microsoft Developer Network (MSDN) documentation. 

 For information about the RxSpotlight Object Model refer to RxSpotlight Open 
Architecture reference. The RxSpotlight Script Toolkit demonstrates WIOA 
capabilities. 

Active Script Studio. 
The built-in code editor can be used for creating custom script commands. There is 
also a visual HTML-form editor designed for integration of user‟s forms and 
commands in the code.  

 For information about creating custom user buttons and assigning scripts see 
page 381. 

To create a custom user command 

Choose Tools > Active Script Studio. This command invokes a dialog where 
command files can be created, edited, saved and run. 

 
The buttons in the Active Script Studio dialog execute the following functions: 

Button Function 
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Clear the pane to create new Java Script, VBScript or HTML-
form 

 

Open a script file 

 

 

Save a current script file (with the SHIFT key pressed – save 
with a different name) 

 
Run a script 

 

Undo / Redo 

 
Cut / Copy / Paste 

 

Search for text 

  

 

Setting parameters to create Java Script, VBScript or HTML-
from 

 
Creates a master of the dialog  

 

Reference for RxSpotlight Open Architecture 

 

Drag this icon onto any toolbar or menu to create custom user 
command invocation button. For additional information about 
creating custom command buttons see page 381. 

In the editing mode of the HTML-form the Master ActiveX has three tabs. 

 The Code tab contains the initial text of HTML-form. 



RxSpotlight User Guide 

374 

 The Form tab – visual form editor.  

 
 
The tools for form creation and editing:  

 
Insert Label 

 
Insert Text box 

 
Insert Frame 

 
Insert Image 

 
Insert Button 

 
Insert Checkbox 

 
Insert radio button 

 
Insert Dropdown list 

 
Insert List 

 
Insert Text area 

 
Insert File browse 

 

Insert ActiveX element 

 
Align Left 

 
Align Right 

 
Align Top 
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Align Bottom 

 
Make Same Width 

 
Make Same Height 

 
Make Same Size 

 The Form view tab – preview of HTML-form 

User command (script) Arguments 

User custom commands (scripts) can use additional individual parameters 
(arguments) for different launch sessions. (Such scripts must implement the 
ScriptSetup function). The script must define a type and a number of arguments. For 
example, assign different arguments to the buttons that run the same script. 

This feature means the same for a script as the Preferences dialog for RxSpotlight. It 
is used to specify those script custom settings that will be rarely changed. 

To assign arguments values - create a toolbar button for the script and right-click on it. 
Click the Arguments button in the Tool Setup dialog that appears and then assign 
arguments values for this button (launch session). 

DDE 
RxSpotlight supports interaction with other programs through its DDE interface 
(Dynamic Data Exchanging). Using DDE give access to the commands listed in the 
RxSpotlight script. The syntax of the commands is the same as in RxSpotlight script. 

An example of DDE usage 

This is an example of DDE usage for MS Excel VBA: 

Sub Main() 

Dim channelNumber As Long 

‘ Connect to application 

channelNumber = Application.DDEInitiate("csapp", 

"System") 

‘ Ask user for file 

cmd = "[OpenDocument|FNAME|" & Chr(37) & "1]" 

Application.DDEExecute channelNumber, cmd 

‘ Save document with another name 

cmd = "[SaveAsDocument|FileName|С:\Program 

Files\Rasterex\RxSpotlight Pro 

11\samples\ResavedThroughDDE.cws]" 

Application.DDEExecute channelNumber, cmd 

‘ Print document with current settings and closes 

RxSpotlight 

cmd = "[RunPrinting|""|""][Exit]" 
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Application.DDEExecute channelNumber, cmd 

‘ Close DDE connection 

DDETerminate channelNumber 

End Sub 

Command setup 
Use this dialogue to set up the commands‟ performance. 

 
The left hand pane shows the commands grouped in categories; the right hand one, 
Settings, contains the available options. 

To set up options for command: 

1. Click on the “+” sign at the appropriate category to open the list of commands. 
Select the command. 

2. Check boxes in the Settings pane. 

3. Click OK to apply options. The changes take effect immediately. 

 

Dialog controls Description 

 

Defines if snap is active during command operation. The 
snap is set in Tools > Snap Setup dialog. See description 
of snaps on page 298 for more information. 

 

In checked, the Wise cursors are shown. They help with 
learning RxSpotlight as they show the current command 
and its mode.  

 

In checked, the corresponding command remains active 
after finishing its previous action. This can be used again 
and again until ESC is pressed or another command is 
chosen.  
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If checked, then the object created by the command is 
added to the selection if Add composition mode is on or, in 
Single mode, only the last created object is selected. If this 
option is unchecked, then created objects are not selected. 

Reset button  Cancels changes made by the user and restores the 
default settings. To reset all changes, select All 
Commands and click Reset. 

Customizing menus and toolbars 
New menus and toolbars can be created and populated with RxSpotlight commands, 
buttons and fields from the Inspector window. To enter the customizing mode choose 
Customize from the Tools menu. 

While this dialog is opened (on any tab) the next operations can be performed with 
RxSpotlight interface: 

To move an existing toolbar button or menu item to other toolbar or 
menu: 

Drag a button or menu item to another toolbar or menu with the mouse. 

 Use this method to copy items in the Inspector to any toolbar or menu. 

To copy an existing toolbar button or menu item to other toolbar or 
menu: 

Drag a copy of the button or menu item to another toolbar with CTRL pressed. 

To remove a button from toolbar or an item from menu: 

Drag a button or menu item out from the toolbar or menu so that it will not fall onto 
any other toolbar or menu. 

or 

Right click on the toolbar button or menu item and choose Delete item from the popup 
menu. 

To create drop-down toolbar: 

Right-click appropriate button on the toolbar and choose FlyOut in the context menu: 
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Then the small black arrow in the lower-right corner of this button will appear: 

 
Click this arrow. The drop-down toolbar will appear: 

 
Use standard drag-and-drop technique to fill this toolbar with buttons: 

 

To create/remove a separator line in toolbar or menu: 

1. Place the cursor over a toolbar button or menu item and right click. 

2. Click Begin Group item in the popup menu. 

 The separator line will be shown or deleted. 

To rename a toolbar button or menu item: 

1. Right click on a toolbar button or a menu item. 

2. Click Rename item in the popup menu. 

3. Change the name specified in the dialog and press OK. 
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 Customizing operations that involve dragging items from one command 
or toolbar to another can be implemented without the Customize dialog 
open. Items can be dragged with the ALT button pressed. 

 

Switch to the appropriate tab to perform other customization operations such as: 

 New toolbar creation. 

 New menu creation. 

 Specifying any command as a toolbar button or menu item. 

 Modifying right-button menus. 

 Assigning shortcuts to commands. 

 Reset ALL custom changes of the RxSpotlight interface. 

The Toolbars tab 

 
This is a list of all the toolbars available within the RxSpotlight environment. The Show 
text labels checkbox controls the display of inscriptions below the icons. 

The New button creates a new empty toolbar, which can be filled with any 
combination of buttons. 

The Rename button renames and the Delete button deletes only custom toolbars. 

The Reset button resets the standard contents of a chosen toolbar. 

The Reset All button undoes ALL the changes made by the user to the standard 
system of RxSpotlight menus, toolbars and shortcuts. 

To create a new toolbar: 

1. Open the Toolbars tab and click the New button. 

2. In the intermediate Toolbar Name dialog enter the toolbar name and press 
OK. 
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To reset ALL the changes made by the user to the standard system of 
RxSpotlight menus, toolbars and shortcuts: 

1. Open the Toolbars tab and click the Reset All button. 

2. In the intermediate dialog window click OK. 

3. Restart the application. 

The Commands tab 

  
When this tab is open, RxSpotlight commands can be dragged and dropped into 
toolbars and menus. 

The Description field shows the description of the chosen command. 

To create a new menu: 

1. Open the Customize dialog on the Commands tab and select New Menu. 

  
2. Drag a New Menu item from the Commands list to a toolbar or menu. 

3. Place the cursor over the created New Menu and right click on the mouse. 
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4. Select Rename to rename or Delete to delete 
the new menu. 

5. Select Begin Group to create a separator on the 
left of the new menu. 

6. Select All Commands in the Categories list of Customize > Commands dialog. 
Drag commands from the Commands list to the new menu. Use the right mouse 
button to create or remove separator lines. 

7. A New Menu item (see step 2) can also dragged to any toolbar. 

To specify any RxSpotlight command as a toolbar button or menu item: 

1. Open the Customize dialog on the Commands tab. 

2. Drag a command from the list to any toolbar or menu with the mouse. 

Custom user buttons 
Use RxSpotlight to create custom user buttons for custom user commands (scripts). 
Such commands are created using the RxSpotlight script or the WIOA script 

 For detailed information about work automation and creating custom commands 
see the page 348. 

To create a custom command button or menu item 

1. Choose Customize from the Tools menu, and then go to the Commands tab. 

2. Drag the  icon onto any toolbar or menu to create a script invocation button. 
Close the Customize dialog. 

3. Click on the new button. The Tool Setup dialog appears. 

 
4. Chose an image for the button or create a new one by clicking the Add button in 

the Tool Setup dialog. 
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5. In the Edit Image dialog create a new image using the tools located at the top of  
the dialog. 

 
6. Press ОК. A new image will appear in the Image section of the Tool Setup dialog. 

This can be edited in the Image section: select the button and press Edit. To 
delete the created image click Reset. 

7. To assign a custom user command to this button, select the script file previously 
created in the Script File box. 

User’s command Arguments 

Custom user commands (scripts) can use additional individual parameters 
(arguments) for different launch sessions. (Such scripts must implement the 
ScriptSetup function). The script must define a type and a number of arguments. So, 
for example, assign different arguments to the buttons that run the same script. 

This feature means the same for a script as the Preferences dialog for RxSpotlight. It 
is used to specify those script custom settings that will be rarely changed. 

Create a toolbar button for the script and right-click on it. Click the Arguments… 
button in the Tool Setup dialog and then specify arguments for this button (launch 
session). 

Right-click menu 

After creating the custom button and assigning the script, call the Tool Setup or the 
Arguments or edit an assigned script by the right click on the button and choose 
appropriate menu item. 
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The Edit item calls the Active Script Studio for WIOA script or the Script Studio for 
RxSpotlight script. 

The Keyboard tab 
Use this tab to assign keyboard shortcuts (accelerators) to every RxSpotlight 
command. 

To assign a shortcut to a command: 

1. Choose a command from the Commands list, move to Press new acceleration 
key field and press buttons on the keyboard that are intended to become a 
shortcut. They will be shown in the upper right field. Usually keyboard shortcuts 
are produced by simultaneously pressing a letter button with CTRL, SHIFT 
and/or ALT. For example, CTRL+A, ALT+SHIFT+Q, etc. 

2. If the shortcut is not assigned to any other command, then the Assigned to field 
will show “Unassigned”. 

3. Press Assign to finish the operation. 

  

This figure illustrates a situation of conflict: the shortcut offered for the chosen 
command (8 coupling Contour) has been used by another command (Trace Auto); so 
it will not be assigned. 

If a command also has an accelerator, then it will be shown in the Current keys field. 
More than one accelerator can be assigned to a command. Unnecessary accelerators 
are removed from the list by choosing them and pressing Remove. 

Reset All removes all custom shortcuts. 
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Description field shows the description of the chosen command. 

Category list contains “All commands” category and the names of custom menus if 
any. 

The Menu tab 
Partly customizes right-button menus. 

  

 

Customize button opens the selected menu for editing. 

Use techniques described in this section to add 
commands and separators to a menu. 

Close applies changes. 

Reset button deletes all customization changes. 

The Options tab 
Controls the representation of buttons and commands. 
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Option Description 

Full screen application 
window checkbox 

Enlarges useful workspace to maximum 
screen size at the expense of hiding the 
RxSpotlight window caption and cropping 
outermost toolbars and status bar. 

Show tooltips checkbox Show tooltips next to the buttons 

Show shortcut in tooltips 
checkbox 

Show shortcuts next to the buttons (the 
procedure is described above). 

Toolbar button size slider Changes the size of toolbar items (buttons 
and combo-boxes). 

Old Style Interface 
checkbox 

Sets old interface style (needs application 
restart). 

Use collapsing menus 
checkbox 

Use menus with a reduced list of 
commands. 

Expand menus after 
delay checkbox 

Shows the full menu contents if the user 
does not leave the menu after a delay. 

Use italic font in menus 
for non loaded 
components checkbox 

Shows program components names for 
which dll‟s have not been dynamically 
loaded in this RxSpotlight session with 
italic font. 

Reset menu usage 
counters button 

Resets the original menu structure, i.e. 
cancel the order of commands in a menu 
list depending on the frequency of their 
usage. 

Profiles 
Use profiles to switch document options on the fly and import/export document 
settings between different documents and/or workstations. 

Every RxSpotlight profile can store: 

 Interface settings (customize options, preference options). 

 File format settings. 

 Paper settings. 

Although many  profiles can be created, only one of them can be a current one. By 
default, RxSpotlight stores the current options in a profile named <<Unnamed>>. 

The profile information is stored in the system registry. When modifying interface 
settings, file formats and paper settings, the current profile is automatically changed. 

 Export a profile to a file once and import it every time it is needed, to 
prevent unwanted current profile modification. 
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To manage profiles in RxSpotlight: 

Use the Switch to Profile dialog (Menu: Tools / Switch Profile) to switch profiles or 
choose a required profile in the Profiles tab in the Customize dialog box and click the 
Set Current button to make this profile current (applies all profile settings to the 
application). 

While the Switch to Profile dialog is used for rapidly switching and creating profiles, 
the Profiles tab is used for creation, removing, switching, exporting and importing 
profiles. 

Profile creation 

The newly created profile inherits the current profile settings. 

Every RxSpotlight profile contains three parts (the interface settings, the file format 
settings and the paper settings). However, during new profile creation which part to 
read from the profile each time it is loaded can be specified (making it current). 

For example, create a new profile “Interface5” and specify that it must contain only the 
interface settings. The next time this profile is made current, only the interface settings 
will be changed, while file formats and papers settings will remain unchanged. 

Profile import / export 

The current profile can be saved (exported) into a file with a .WIP extension. 

Once a profile is saved, it can be exported as a WIP file to different computers. So, for 
example, predefined settings can be transferred to all workstations in a department in 
a moment. 

If after making changes to the current profile during a RxSpotlight session one wants 
to revert to a previous profile, then simply import the corresponding WIP file. 

During profile exporting specify which of its three parts must be written into a file. 
Importing of WIP file modifies only those parts of a current profile which were saved 
into this file. Other settings will remain unmodified. 

For example, export only the paper settings. 

If an imported profile (a WIP file) includes the interface settings part, then RxSpotlight 
creates a new profile which has the name of the imported profile. This newly created 
profile automatically becomes the current one. 

Otherwise, if an imported profile does not include the interface settings part, then the 
remaining part(s) adjust the current profile settings and the current profile name 
becomes: 

Current Profile Name+Imported Profile Name 

For example: Vector recognition profile+Corporate paper formats 

The Profiles tab 
This manages such operations as profile switching, creation, deleting, making current, 
exporting, importing and others. The current profile name will be seen at the top of the 
dialog. All existing profiles are listed below in the profiles list. 
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The Add 
button 

Shows the Add Profile dialog window to create a new profile. 

In the dialog enter a new profile name and specify settings to 
be read from the profile every time it is made current. 

Click the Ok button to add the new profile. 

See Profile creation and Profile import / export in the 
previous section for additional information. 

The Remove 
button 

Deletes a selected profile. 

The Set 
Current 
button 

Makes a selected profile current (applies all profile settings to 
the application). 

The Load 
button 

Export a profile from a WIP file. See Profile import / export in 
the previous section for additional information. 

The Save 
button 

Shows the Add Profile dialog window to import the current 
profile to a WIP file. See Profile import / export in the 
previous section for additional information. 

In the dialog type a name of the newly created profile for a 
WIP file. 

Specify settings which will be exported to a WIP file and click 
the OK button. 

Specify a name for the exported file and click the Save 
button in the dialog window. 
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The Reset 
All button 

Deletes all profiles and sets the default one. Actually this 
operation removes all the custom profiles from the registry 
and restores the default one from the .CFG file. These 
changes will take effect after reloading the application. 

The Add Profile sub-dialog 

This sub-dialog may be called from the Profiles tab or the Switch to Profile dialog. 

 

Specify here a new profile name and which settings you want to include into your new 
profile. 

 Interface settings – settings that are located in the Customize dialog and 
Preferences dialog (except for the Raster File formats and paper settings). 

 File Format settings – settings which are located in Preferences / Raster File 
Formats tree. 

 Paper settings – settings which are located in Preferences / Papers tree. 

Rapid profiles switching 
The Switch to Profile dialog is used for rapidly switching and creating profiles. 

To start the dialog click the Switch Profile from the Tools menu 

 
Click the button with a profile name to make it current. 
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Click Add button to create a new profile. In the Add Profile dialog enter a new profile 
name and specify settings to be read from profile every time it is made current. Click 
the Ok button to add the new profile. 

Tuning the application 
Use the Preferences dialog, to define the general settings of the program. To open 

this dialog, choose Preferences from the Tools menu or click the  button on the 

Settings toolbar  

 
 
New values can be added, deleted and existing ones modified, or items set active. If a 
value can be modified, then the Add, Modify, and Delete buttons are active.  

The settings are arranged by sections; to work with them do the following: first select 
a section, and then select the desired subsections and settings. 

The Settings box contains the following items: 

 

 
Cursor Changes the appearance and size of the 

graphic cursor. 
 Crosshair Sets the size of Crosshair.  

 Full Screen Sets the size of Crosshair to the full screen 
size. 

 Size Sets the size of Crosshair as a percentage 
of the screen size. 

 Pickbox The Pickbox size. 
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 Show Crosshair Turns off Crosshair in the Selecting mode. 

 PickBox size  The pickbox size in pixels.  

 Colour Cursor colour. 

   

 
Grip Changes the size and colour of Grips. 

 Grip size Grips size. 

 Grip max objects count The maximum number of objects selected 
which have the Grips displayed. 

 Single object grip colour The Grips colour of a single selected 
object. 

 Multiple objects grip 
colour 

The Grips colour of multiple selected 
object or grouped objects. 

 Inactive objects grip 
colour 

The Grips colour of an inactive selected 
object.  

 Node edit mode grip 
colour 

The Grips colour in the Node edit mode. 

 Node edit mode selected 
grip colour 

The selected Grips colour in the Node edit 
mode. 

   

 
Colours Sets the program colours. 

 Raster Selection Sets raster selection parameters 

 Raster Selection The colour of a selected raster object. 

 Semitransparent Sets the semitransparent view mode for 
monochrome raster selections 

 Preview frame The frame colour that indicates an image 
preview area inside the preview window. 

 Background The colour of the program window 
background. 

 Found raster symbol The colour of a found raster symbol when 
working with the Search and Replace 
command. 

 Print Area The frame colour that indicates a print 
area. 

 Print Grid The frame colour that indicates the paper 
format edges. 

 Grid Colour The colour of Grid points. 

 Layout Paper The color of document paperspace 
(Layouts). 
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Preview style Sets the display mode of an obtained 

monochrome image in the preview 
window.  

 Opaque Displays an obtained monochrome image 
on a white background. 

 Semitransparent Shadows an original image and displays 
an obtained image. 

 Transparent Puts an obtained image over an original 
one without shadowing.  

   

 
Scroll setting Defines the scroll parameters of a 

document in the program window. 
 Scroll step A step of document movement when using 

the Scrollbar. 

 Arrow step A step of document movement as a 
percentage of the window size when using 
the ALT+ keyboard arrows.  

 Mouse Wheel scale factor Scale factor used to scale with the Mouse 
Wheel. 

 Drag&Drop scroll area The width of the invisible viewport borders 
used for scrolling a current view during a 
drag process. 

   

 
Snap Setting Defines Snap settings. 

 Hold Aperture Size The size of a cursor frame in snap mode. 

 Snap Marker size Snap marker size. 

 Show Tooltips Turns on the display of a snap name.  

 Vector Marker Colour The colour of the snap marker when 
snapping to a vector object. 

 Raster Marker Colour The colour of the snap marker when 
snapping to a raster object. 

   

 
Inspector Defines the Inspector settings. 

 Properties mode Defines an operation mode of the 
command properties 

 Document Transparent Changed properties during command 
running also change default document 
settings 

 Command sensitive Changed properties during command 
running do not affect default document 
settings 

 Multiple selection Inspector properties behaviour on multiple 
selections 
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 Max count of controlled 
objects 

The maximum count of selected objects 
which have properties displayed 

 No limit Properties of objects are displayed 
regardless to selection contents 

   

 
Papers Contains standard paper formats. Allows 

the modification of an existing format or 
adding a new one. The formats contained 
in this section are applied to the Change 
Size, Print, New Image commands.  

   

 
Autocorrect Sets the command to be performed during 

Autocorrection.  

   

 
Raster file formats Allows a list of raster formats for the Open 

and Save commands to be specified, the 
creation of default format settings for file 
saving as well as a new format based on 
an existing one. 

   

 
Printing Control Defines print settings. 

 Disable print optimization Turn on this checkbox if there is a problem 
with printed output. 

 Enable printing by stripes Enable printing by stripes. 

   

 
Default raster properties Sets the parameters of a raster image 

used by the program if they are not set by 
the user. For example, when opening an 
image with no resolution information.  

 DPI Resolution in DPI. 

 Transparent Color Defines a Transparent Color property 
for monochrome images.  

   

 
New image from 
selection 

Defines the New Image From Selection 
settings.  

 Keep Selection Creates a new image without erasing 
selected objects.  

 Erase Selection Erases the selected objects of a raster 
image. 

   

 
Multipage raster files Setting options to work with multipage 

files. 
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 Enter multipage mode 
automatically 

When loading multipage raster files always 
switch to multipage mode automatically. 

   

 
Point Allows the appearance of all points in a 

document and the sizes of their markers to 
be changed.  

 Size Sets the size of a marker in pixels. 

 Point style Sets the type of a point marker. Allows 
users to turn on a rectangular or round 
frame for a point. When the Dot type is 
chosen, an element of 1 screen pixel is 
displayed. 

   

 
Template Usage Controls the actions of RxSpotlight

 
on 

opening new documents and images. 
 For new documents Actions on the File > New command 

  None No action taken 
  Use default Opens file specified in Default Template 

File Name 
  Ask for file Opens dialog File > Open 

 Default Template File 
Name 

Shows and lets change Default Template 
File Name 

 For opened raster Actions on File > Open command for 
raster image 

  None No action taken 
  Use default Opens the file specified in Default 

Template File Name 
  Ask for file Opens File > Open dialog 

 Default Template File 
Name 

Shows and allows change Default 
Template File Name 

   

 
Script Defines the settings for Script operation. 

 Linear Units Sets measurement units. If this value is 
not specified, then the units set in UCS 
Setup are used. 

 Angular Units Sets angle measurement units. If this 
value is not specified, then the units set in 
UCS Setup are used. 

 Default Log file The name of a text file to which the results 
of Script performance are placed. 

   

 
Display View Effect of displaying zoomed images. 

 Half tone paint Turns ON/OFF monochrome raster high 
quality paint. 
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 Draw Raster Frame Turns ON/OFF display of a raster image 
frame. 

 Fit Dashed Lines Adapts the view of dashed contours of 
vector lines at the expense of slightly 
changing dashed and spaced size lengths. 
This mode guarantees that the endpoints 
of lines, polylines and arcs will be started 
and ended with a dash. 

 Use Screen Width for 
Lines 

Shows width of lines in screen pixels. 
Switch OFF this checkbox to display it in 
millimeters (RxSpotlight units) to scale line 
width during zoom operations. 

 Use Screen Line Types Set this parameter to view and print 
symbols, markers, hatches and etc. with 
constant size independently from a 
document scale. 

 When this item is selected, 
the Use Screen Width for 
Lines item is selected 
automatically. 

   

 
GIS GIS option 

 Use World File Writing the raster coordinates in a special 
text file (world file) when saving. To make 
this world file readable when opening a 
raster file this parameter must be on. 

 Use TAF file Writing the raster coordinates in a special 
text file (TAF file) when saving. To make a 
TAF file readable when opening a raster 
file this parameter must be on. 

   

 Conversion parameters Parameters of R2V and V2R conversions. 

 Scale independent Applies unified R2V conversion 
parameters to raster images with different 
insertion scale. Affects R2V, V2R, Raster 
selection, Tracing commands. 

   

 Text Text parameters. 

 Text Tab size Multitext tab size. 

   

 DWG Export Export to DWG file options. 
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 Apply UCS scale to 
geometrical object 
properties 

Switches to apply or not to apply the UCS 
scale to geometrical object properties, 
such as Text Height and Line Width during 
DWG export. 

   

 
Standard directories Sets a folder in which the miscellaneous 

system files, the OCR templates‟ folder 
and the SHX fonts‟ folder are stored.  

   

 Saving Parameters Sets parameters for backup and 
recovering operations. 

 Generate backup copies Generates backup copy of current 
document right before save to a file. 
Backup copy is a complete copy of a 
document with BAK extension. It can be 
renamed back to CWS an opened at any 
time. 

 Autosaving every <XX> 
min 

Specifies time interval between 
automatically savings of opened 
documents. To switch OFF automatic 
saving set 0 for this parameter. 

   

 
Vector correction edge Sets the appearance of an edge, which is 

made with the Group/Ungroup by Edge 
command. 

 Width Sets an edge width in pixels. 

 Color Sets an edge color. 

   

 Markup Sets parameters for Markup objects 
showing. 

 Show automatically Shows markup automatically on document 
open if markup file is exists. 

 Show semitransparent Shows markup using semitransparent fill. 

 Alert Shows warning message in case of 
unknown markup. 

   

 
After making changes, press OK to complete. 
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Appendix A. Command directory 

Command Function See page(s) 

File File opening, saving and printing  

New Create a new document  

Open Open a document from a file 27 

Close Close the current document  

Save / Save As Save the current document to a file 28 

Import Importing files 81 

Export Export to raster, vector and hybrid 
(such as DWG) formats 

77 

Explore Opens the Explore window 27 

Select source Select a scanner 85 

Acquire Get image from a scanner 84 

Print Options Opens the Printer Setup dialog 91 

Print Opens the Print dialog 96 

Files LRU list Last 5 opened files  

Directories LRU list Last 5 opened directories  

Edit 
General edit and selection 
operations 

 

Undo/Redo Undoing and redoing 33 

Paste Paste a selection set. 290 

Paste Special Paste a selection set onto the 
chosen image. 

290 

Paste Separate Creates a separate embedded 
image from a selection set. 

290 

Hyperlink Allows editing and assigning a 
hyperlink to a document or any 
object. 

45 

Select Auto Automatic selection of a clicked 
object or area enclosed in a 
rubberband rectangle. 

108 

Select by Filter Selection of objects by type, layer or 
colour. 

120 

Select/Unselect all Select all objects and Unselect all 107 
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Command Function See page(s) 

Search and replace Search and replace of vector and 
raster objects 

306 

WiseObject selection Selection of certain types of objects, 
such as hatch, text, „speckle‟, linear 
objects, in the whole image or a 
specified area 

122 

View View, pan and zoom  

Birds Eye The tool with combined zoom and 
pan functionality 

31 

Zoom… Group of zooming options 30 

Pan Pan the image 31 

Zoom Dynamic Zooming by moving mouse up/down 31 

Show Width Toggles displaying/hiding of object 
line widths 

37 

Hide Vectors Toggles displaying/hiding vectors in 
the drawing 

37 

Hide Raster Toggles displaying/hiding of raster 
data in the drawing 

37 

Display Order Control for displaying stacked 
objects  

39 

Show Toolbar Show/Hide toolbars 22 

Show Command Line Show/Hide Command Line 59 

Draw Drawing and editing graphics  

Line By Line drawing (2 methods) 221 

Arc By Arc drawing (3 methods) 222 

Circle By Circle drawing (3 methods) 224 

Ellipse By Ellipse drawing (2 methods) and 
elliptic arc drawing. 

225 

Rectangle By Rectangle drawing (2 methods) 224 

Point Drawing a point 226 

Polyline Polyline drawing  227 

Spline Spline drawing  232 

Hatch Creating a hatch 226 

Text Inserting a text line 237 

Multiline text Inserting multiline text 237 
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Command Function See page(s) 

Create Block Block creation 235 

Dimension Dimension object creation (3 
methods) 

239 

Raster Raster editing tools  

Pencil Pixel drawing tool 291 

Eraser Erasing tool 291 

Flood Fill Flood filling tool 292 

Flood Erase Flood erasing tool 292 

Colour Flood Fill Colour flood filling tool 311 

Edit Raster Text Replace raster text with new text 298 

Block Inserts block 235 

Insert Inserting images and blocks  

New image Create a new image with specified 
size, type, resolution and so on 

50 

From file Inserts an image from file 50 

New Image form 
Selection 

Converts a selection set into a new 
image 

292 

New Image form 
Scanner 

Acquires image from a scanner 86 

Block Inserts block 235 

Modify Object modification commands  

Group/Ungroup Create and dismiss a group 257 

Polyline Enter polyline editing mode 227 

Move Move a selection set 248 

Copy Copy a selection set 249 

Duplicate Duplicate a selection set 249 

Rotate Rotate a selection set 249 

Scale Scale a selection set 251 

Mirror/Flip H/Flip V Mirror and flip selection set 251 

Align Align objects to a predefined 
position and size 

252 

Array Create an array of selection set 253 

Duplicate by vector Create multiple copies along the 
path 

255 
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Command Function See page(s) 

Merge (Rasterize) Rasterize a selection set onto the 
destination image 

290 

Merge a Copy 
(Rasterize) 

Rasterize a copy of a selection set 
onto the destination image 

290 

Explode Break complex objects to simpler 
objects. 

257 

Correct 
Vector corrections and 
transformations 

 

Offset object Create an offset copy of the 
selected object 

262 

Merge vectors to 
<object type> 

Convert selected vectors to an 
object of a specified type 

263 

Auto Create vectors from selected ones 
with automatic definition of the 
created object 

265 

Convert to Spline Convert polyline to spline 265 

Group/Ungroup Edge Create/dismiss cutting contour 269 

Trim vectors by Edge Trim selected vectors using edge 273 

Extend vectors by 
Edge 

Extend selected vectors using edge 271 

Break Vectors  Break selected vectors using edge 269 

Correct To Intersection Extend/trim objects to their 
intersections 

268 

Create Chamfer Creates chamfers connecting two 
lines or arcs 

265 

Create Fillet Creates fillets connecting two lines 
or arcs 

266 

Align Angle and 
Distance  

Aligns vector objects by position of 
one of them 

274 

Polyline Correction 
Options 

Settings for polylines correction 
mainly produced as a result of 
automatic vectorization or tracing. 
Dependently on the settings it will 
perform merging, removing or the 
combining of polylines. 

286 

Polylines Autocorrect Launches polylines correction 
procedure 

289 

Tools General tools and tuning  
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Command Function See page(s) 

Inspector Show/hide list of properties of 
selected object(s) 

40 

Layers List of layers and their properties 45 

Images List of images and their properties 52 

Blocks List of blocks and their properties 235 

Coordinate system Define custom coordinate system 
settings 

65 

Style List of line styles and their 
properties 

211 

Text Style List of text styles and their 
properties 

219 

Clipbook Open the Clipbook window 72 

Measure Measure lengths, perimeters, areas 
and a create log 

69 

Create Marker Create arrow heads and end 
markers of arbitrary shape 

258 

Create Fill Shape Create symbols to fill a closed area 261 

Snap Setup Tuning of snap options and 
performance  

298 

Grid Setup Grid options and usage tuning 306 

Run Script Run a WI script in background 
mode 

350 

Script Studio Edit and run a WI script 353 

Batch Studio Edit and run a batch of WI scripts 368 

Command Setup Setting up general performance of 
some commands  

376 

Customize Create and rearrange menus, 
accelerators and toolbars 

377 

Preferences Tune operations and procedures 389 

Switch Profile Rapid profile switching 388 

Purge Dialog for removing unused block 
definitions, image definitions, layers, 
and Text Styles from a Document 

75 

Active Script Studio Built-in code editor for creation 
custom script commands using 
WIOA script (Jscript, VBScript); and 
a visual HTML-form editor. 

372 
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Command Function See page(s) 

Convert 
Raster to vector conversion and 
vectorizing commands 

 

Vector Autocorrect Automatic correction of vector 
objects 

278 

Auto Automatic tracing mode 162 

Line/Arc/Circle Forced tracing modes 163 

Hatch Tracing a hatch 164 

Line Following Tracing a polyline 165 

Outline Tracing an outline contour 164 

Symbol Tracing a symbol 169 

Vector (Keep Raster) Tracing mode in which a vector 
object is created 

170 

Vector (Erase Raster) Tracing mode in which a vector 
object is created and corresponding 
raster one is removed 

170 

Erase Raster Tracing mode in which a vector 
object is not created and 
corresponding raster one is 
removed 

171 

Smooth Raster  Tracing mode in which a raster 
object is replaced with rasterized 
vector one 

171 

Raster2Vector Apply automatic vectorization 181 

Raster2Contours Apply automatic vectorization of 
closed contours 

203 

Edit OCR Text Edit recognized text  195 

Train OCR Train character recognition 192 

Edit Symbol 
Recognition Template 
Library 

Symbol Recognition Template 
Library management 

198 

Conversion Options General conversion options tuning 182 

Colour Conversion 
Options 

Conversion tuning options for 
automatic vectorization of colour 
and greyscale raster images 

204 

Vector Correction 
Options 

Tuning vector correction 276 

Fine OCR Optional OCR feature 347 
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Command Function See page(s) 

Image Operations with a image  

Convert to Convert to colour, greyscale and 8-
bit indexed 

313 

Brightness/Contrast Tune brightness, contrast, hue and 
saturation by changing their numeric 
values 

318 

Equalize Tune brightness, contrast, hue and 
saturation by changing the 
histogram 

319 

Autocorrect Apply sequence of image 
autocorrection operations 

134 

Change Size, 
Resample 

Change size and/or resolution of an 
image 

126,128 

Image Clip Defines a subregion on an image to 
apply operations to. 

57 

Crop Cut out a piece of raster  130 

Mirror Mirroring of an image 251 

Rotate Rotation of an image 249 

Deskew Automatic or manual deskewing of 
an image 

132 

4-point Correction Correct projective distortions 135 

Calibration Correct arbitrary distortions of 
images 

137 

Binarization Copy coloured areas to a separate 
layer(s) 

329 

Adaptive Binarization Binarize and correct blueprint and 
sepias in Greyscale mode 

340 

Gamma Correction Enhance the overall quality of an 
image by changing its “colour 
profile” (distribution of brightness) 

321 

Colour Classifier Modify the raster image colour 
palette 

322 

Colour Reduction Used to reduce colour set 346 

Colour Separation Separate to layers by colours 343 

Separation by Size, 
Separation Linear 
Objects, Separate Text 
Areas, Separate 

Extract objects of defined sizes and 
types to a separate layer 

158 
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Command Function See page(s) 

Hatches 

Filters 
Filters for colour, greyscale and 
monochrome images 

 

Unsharp Mask Unsharp Mask 326 

Blur Blurring filter 324 

Median Median filter 327 

Adaptive Blur Blurring none uniform colour areas 
inside the colour transition 
boundaries in the image 

325 

Line Breaks Filling Eliminate the breaks in raster lines 
(monochrome) 

156 

Speckle Remover Remove speckles and small-sized 
objects (monochrome) 

149 

Hole Remover Remove small-sized holes 
(monochrome) 

150 

Smoothing Used to smooth outlines of raster 
objects (monochrome) 

151 

Inversion  Invert each pixel‟s colour 
(monochrome) 

156 

Thinning Used to thin line objects 
(monochrome) 

153 

Thickening Thickens line objects (monochrome) 154 

Segmentation Finds and highlights the borders on 
colour raster image 

328 

Contour Used to create 4-coupling and 8-
coupling outline (monochrome) 

155 
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Appendix B. Glossary 

Accuracy 

The precision of RxSpotlight operations and function performance. 

Aligning 

An operation that makes objects change with respect to selected objects or their 
properties.  

Array 

An operation that creates multiple copies of selected objects and places them in 
columns and rows. 

Background colour 

On monochrome image; the colour that is used to show blank areas. 

On a colour image; the colour that fills cut-outs and newly created areas. 

Base point 

The point that is used when inserting an image or block. 

Batch (RxSpotlight batch) 

A sequence of RxSpotlight scripts executed in a row. 

Binarization 

An operation that creates monochrome image from a coloured one using specific 
criteria of a pixel‟s brightness and colour. 

Birds Eye 

A tool that combines pan and zoom functionality. Used to navigate in the document 
and examine details. 

Block 

A combination of one or more objects that create a single object. 

Blur 

A filter that produces blur effect, making an image slightly “out of focus”. 

Border 

1. The dashed rectangle around the image that is created by RxSpotlight to 
facilitate scaling, rotating and moving. It is not saved with the image. 

2. Clipping border. 

Breaking 

The splitting of vector objects into smaller parts by edge or other objects. 

Breaks 

Gaps on raster objects – lines, arcs, circles, polylines, hatches, symbols, etc. 
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Calibration 

A correction of a raster image using mathematical methods and pairs of characteristic 
points. 

Calibration pairs 

Pairs of points that define the transformation parameters during calibration. 

Chamfer 

A line of specified length and/or angle connecting two vector lines. 

Clipbook 

The storage area to keep arbitrary fragments of RxSpotlight documents for exchange 
and reuse between sessions. 

Clipping 

The clip region may be defined on the image to restrict viewing area and the operation 
usage. Clipping also decreases loading time. 

Colour model 

A system of assigning numerical values to colours. 

Composition of Selection (set) 

A procedure of one or more steps with each step being a single selection operation. 

Contour 

An outline created around contiguous sets of pixels. 

Coordinate system 

A system for measuring distances and angles in the document and also for inputing 
coordinates of all objects in all dialogs. 

Corrections 

Operations that prepares row data (raster and vector) for further more precise 
processing. 

Cropping 

An operation that cuts off blank margins or parts of a document outside the clipping 
border. 

Crossing polygon 

A polygonal area drawn to select objects fully or partly within its borders. 

Crossing window 

A rectangular area drawn to select objects fully or partly within its borders. 

Cursor menu 

See ”Right-Button menu”. 

Customizing 

The rearranging menus, accelerators and toolbars, creating new ones and tuning of 
their performance. 
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Deskewing 

Operation that turns the whole image by a small angle. 

Dimensions 

Objects that can be created to show the linear dimensions or angles. 

Display order 

The order in which the stacked objects are drawn on the screen and printed. 

Duplicating 

An operation that creates a new version of the existing object by copying. 

Edge 

A temporary boundary used to define where the vector correcting operations must be 
applied. 

Elevation 

An optional property of an object of general usage that can be also treated as the 
Z-variable in other applications after exporting objects with attributes. 

Embedding 

A method of storing raster images in a document. Embedding is a property of the 
image which determines whether image data is stored inside the RxSpotlight 
document. 

End Marker and Start Marker 

Objects that are placed at the ends of vector line, arc or polyline. 

Equalizing 

An operation that selectively adjusts brightness, contrast, hue and saturation of the 
image pixels. 

Exploding 

An operation that disassembles a complex object into simpler objects. 

Extending 

The changing the length of vector line or arc to reach edge or another vector object. 

Fence 

A multi-segmental line specified to select objects it passes through. 

Fill Shape Symbol 

A symbol made of vector objects that are used to fill closed areas. 

Fillet 

An arc connecting two lines. 

Filter 

1. A logical condition used to select an object. 

2. A condition restricting the set of properties shown in the Inspector window. 
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Flip 

Operation that creates a new version of an existing object by reflecting it 
symmetrically with respect to horizontal or vertical axis. 

Floodfilling 

1.  Selection type (algorithm) used to select contiguous raster areas and all 
intersecting objects. 

2.  An operation on a raster image. 

Forced operation 

An operation that yields a predefined result. 

Grid 

Regularly spaced dots on the screen used to aid drawing and precisely move objects. 
The space between grid dots is adjustable. Grid dots are not plotted. 

Grip 

Small coloured squares that appear on selected object(s). After selecting a grip, edit 
the object by dragging it with mouse. 

Hatch 

An object consisting of lines that form a pattern. 

Highlighting 

Method of indicating the raster selection by colour. 

Holes 

Small-sized spots on the coloured parts of monochrome raster image.  

Hybrid object 

An intermediate object generic to RxSpotlight to with both raster and vector 
operations can be applied.  

Insertion 

An operation of placing the object into the document. 

Insertion point 

The point in the document where the base point of an image or block is placed. 

Inspector 

A dialog window containing the list of selected object(s) and command properties. 
Can be used to control operations and change properties of objects by entering 
precise values to the appropriate fields in this window. 

Interval of width 

The lines with widths that fall between certain maximum and minimum values can be 
transferred to separate layers or coloured uniformly.  

Isolated raster object 

A contiguous set of pixels. 
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Layer 

A logical grouping of data that are like transparent windowed overlays on a drawing. 
Layers can be viewed individually or in combination. 

Layering 

An operation that results in creating layers and distribution of data on them according 
to specified criteria. 

Life indicator 

An indicator on the status bar that shows the memory usage and program activity 
during time-consuming operations. 

Linefollowing 

1. Polyline tracing method. 

2. Selection type (algorithm) used to select raster polyline segments. 

Linked image 

A method of referencing raster images in a document. When raster image is linked, 
any changes to it in the source file are automatically updated in any document, 
containing a link. 

Measuring 

The process of getting the dimension and angle values of raster and vector objects 
using the mouse or through the Measure window. 

Medianing 

A filter that eliminates extremes in pixel colour and brightness. 

Merging 

An operation that creates one object from two or more source objects. 

Method of binarization  

A rule that defines which point must become black (foreground) and which white 
(background) during a binarization operation. 

Method of calibration  

A mathematical algorithm that transforms the entire image such that  specified 
(measured) points are move to predefined positions 

Method of selection 

A set of modes that define the selecting algorithm, type of selected object, and other 
selection options that are to be applied to the next selection operation. 

Mirroring 

An operation that creates a new version of an existing object by reflecting it 
symmetrically with respect to a prescribed line. 

Mode 

The software setting of a operations‟ performance. 

Node 

An end of the segment of a polyline. 
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Noise 

Speckles, holes and all unnecessary and excess pixels. 

Object 

An item that can be created or processed by RxSpotlight commands and tools. 

Object type recognition 

A tool  that is used in tracing and selection operations that automatically determines 
the arcs, lines and circles. 

Offsetting 

The operation that creates a offset version of a vector object. 

Operation 

The process started by a command or button that changes or creates data and/or 
properties of objects. 

Orthogonalization 

Drawing mode in which new and existing lines are aligned to the coordinate axis or 
specified angle. 

Palette 

The set of colours used in the colour image. 

Pan 

To shift the view of a document without changing magnification often done to centre a 
certain object or feature. 

Pixel 

A coloured dot on the image. 

Point 

An object consisting of a single coordinate location. 

Polar snap 

Snap to direction. 

Polygon 

1. A geometrical multisided figure. 

2. A temporary multisided area specified for select objects.  

Polyline 

An object consisting of one or more connected line and arc segments treated as 
single object. 

Preview window 

A tool to show details of document and preview operation results. 

Procedure 

A sequence of operations that achieve predefined goal. 

Raster image 

An image consisting of coloured dots (pixels). 



RxSpotlight User Guide 

410 

Raster entity 

A group of pixels on a raster image that look like geometrical objects or symbols. 

Raster object 

A contiguous set of pixels that look like lines, arcs, circles or another objects. 

Raster2Vector button 

The button that launches automatic vectorization. 

Rasterization 

The process of converting vector objects to raster. 

Recognition 

An operation that determines the type of raster object and optionally creates 
corresponding vector or raster object. 

Reference 

Information kept by the program on the image‟s origin. 

Resampling 

The changing the size of an image by changing the number of pixels.  The resolution 
is thus also changed.. 

Resolution 

The number of pixels in a specified unit length (usually, one inch). 

Right-Button menu 

The menu that is displayed when the right mouse button is pressed. The contents of 
the menu depends on the selected object on which the mouse pointer rests and the 
current operating modes. 

Rotating 

An operation that creates a rotated version of the existing object(s). 

Rubberline 

A line that dynamically follows the movements of the cursor to show the drawing, 
selection or editing operations‟ intentions. 

Scaling 

An operation that creates enlarged or reduced version of existing object(s). 

Script 

A sequence of a command executed in a row. Script files can be created and edited 
inside or outside RxSpotlight and saved in text format. 

Segment 

Line or arc in the polyline. 

Selection (set) 

One or more objects specified for processing as a unit. 

Separation 

Operation that separates raster data by colour or by size of objects. 
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Smoothing 

Filter that smoothes raster objects outlines. 

Speckle 

Small-sized spots on the non-coloured parts of a monochrome raster image and 
pixels that make raster lines look jagged.  

Symbols recognition 

Procedure of recognizing symbols on the image for (optionally) deleting or replacing 
them with vector representations. 

Template file 

A file that stores parameters of commands. 

Tracing 

An interactive procedure converting raster lines and arcs to vector polylines, arcs. 
lines, circles, outlines, symbols, hatches. 

Training 

The creating of samples for text recognition. 

Trimming 

The changing the length of vector line or arc to fit an edge or another vector object. 

Tuning 

The setting modes and options for commands and operations. 

Unsharp mask 

Filter that improves sharpness of colour transition boundaries. 

Vector object 

A mathematical expression that defines the object geometry. 

Vectorisation 

A conversion of raster objects to their vector analogues. 

Vertex 

A location where polyline segments meet or the end of polyline. 

Width table 

A table that defines layering and colouring of line objects of different widths during 
vectorization. 

Zoom 

To reduce or increase the apparent magnification of the graphics display. 

 



Index 

3D View, 284 
4-coupling filter, 155 
4-point correction, 134 
8-bit indexed, 313 
8-coupling filter, 155 
Accuracy, 197 

approximation, 124 
calibration, 145 
estimation, 139 
searching, 308 
snap, 305 
tracing, 172 

Acquire, 84 
Adaptive Binarization, 340 
Adaptive Blur filter, 325 
Add mode of selection, 107 
Adding vertices of polyline, 228 
Affine method, 144 
Algorithm tree, 183 
Alias, 59 
Aligning objects, 252 
Alignment, 128 
Angle, 132 
Aperture, 300, 391 
Approximation, 180 
Approximation accuracy, 124 
Arbitrary orientation, 190 
Arc 

conversions, 230 
drawing, 222 
merging, 264 
recognition, 112 
tracing, 163 

Arrange elevation, 282 
Arrows 

adding, 258 
creation, 258 
recognition, 183, 184 

ASCII table, 189 

Auto Detect Direction, 175 
Auto selection style, 108 
AutoCAD Normal hatch style, 226 
Autocorrection, 133, 275 
Automatic color vectorization, 204 
Automatic deskewing, 133 
Automatic objects creation, 255 
Automatic vectorization, 180 
Automerging, 265 
Autotracing, 162 
Background colour, 390 
Backsegment, 166 
Bilinear method, 144 
Binarization 

adaptive, 340 
Binarization, 328, 329 

example, 337 
methods, 329 
tuning, 335 

Birds eye, 31 
Birds Eye, 31 
Bitonal images, 311 
Block attributes, 236 
Block manager, 236 
Blocks, 235 
Blur filter, 324 
Border of Image, 57 
Boundary, 130, 270, 271, 273 
Break 

ignoring, 123, 168, 173, 188 
measuring, 124 

Breaking of polyline, 228 
Breaking vectors, 269 
Brightest pixel, 319 
Brightness, 317, 319 
Bring Forward, 39 
Bring to Front, 39 
By Block, 45 
By Layer, 45 
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Calculated points, 149 
Calibration, 136 

example, 146 
Calibration grid, 140, 147 
Calibration methods, 137, 144 
Calibration pairs, 137 
Centre, linefollowing tracing, 166 
Centre, snap mode, 304 
Chamfers, 265 
Changing image size, 126 
Channel, 332 
Channel histogram, 332 
Character edit box, 194 
Character recognition, 194 
Character recognition template, 

193 
Character template libraries, 191, 

192 
Check calibration points, 137 
Circle 

drawing, 224 
merging, 263 
recognition, 112 
tracing, 163 

Clipbooks, 72 
Clipping boundary, 130 
Close colours, 333 
Closed polygon, drawing, 224 
Closing 

polyline, 228 
Collect Polylines, 279 
Color correction, 313 
Color depth 

in color images, 311 
Color filters, 313 
Color images 

general notes, 311 
Color reduction, 346 
Colour filters, 324 
Colour information channel, 332 
Colour selection, 333 
Colour separation, 328, 341 
Colour, specifying on layers, 48 
Command Line, 59 

Aliases, 59 
command list, 59 
Mathematical Processor, 63 
navigation, 62 
operations and functions, 63 
Shortcuts, 59 
transperent commands, 62 

Command list, 59 
Complex objects, 256 
Connecting lines, 200 
Construction objects, drawing, 235 
Contour filter, 155 
Contrast, 317 
Control calibration points, 137 
Conversion to RGB, greyscale, 8-

bit, 313 
Convert Raster to Contours, 203 
Converting segments, 230 
Coordinate Systems, 64 
Copying objects, 249 
Correct 

polylines automatically, 286 
Correction 

4-Point, 134 
auto, 133, 275 
by Edge, 269 
by histogram, 319 
by histogram (gamma), 321 
image, 313 
recognized text, 194 
to intersection, 268 

Creating 
block, 235 
calibration grid, 140 
calibration pairs, 140 
chamfers, 265 
complex objects, 256 
custom properties, 44 
document, 24, 25, 50 
end marker, 258 
fill shapes, 261 
fillets, 266 
new image of selection, 292 
new layer, 46 
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objects automatically, 255 
text, 237 
user‟s custom buttons, 381 
user‟s custom command, 372 

Cropping, 130 
Crossing Polygon selection, 113 
Crossing Window selection, 113 
Cursor 

toggling Wise Cursors, 376 
Cursor Menu, 34 
Customize 

commands, 380 
fundamentals, 377 
interface, 384 
profiles, 386 
right-button menus, 384 
shortcuts, 383 
toolbars, 379 

CWS files, 24 
Cycling commands, 33 
Cyrillic OCR, 189 
Darkest pixel, 319 
DDE, 375 
Delete Current Layout Layout, 87 
Deleting 

layers, 47 
polyline vertices and segments, 

229 
Deskewing, 132 
Dialog 

4-point correction, 135 
Active Script Studio, 372 
Adaptive Binarization, 340 
Batch Studio, 368 
Binarization, 331, 334, 335 
Blocks, 236 
Brightness/Contrast, 318 
Calibration, 138 
Change Size, 126 
Color Classifier, 322 
Color Reduction, 346 
Color Separation, 344 
Command Setup, 376 

Conversion Options, 123, 172, 
174, 172, 189, 196 

Edit Multiline Text, 237 
Equalize, 319 
Gamma Correction, 321 
Grid Setup, 306 
Images, 52 
Layers, 46 
Measure window, 70 
Polyline Correction Options, 286 
Preferences, 134, 389 
Preview window, 34 
Resample, 129 
Script Studio, 353 
Search and Replace, 306 
Select Image, 105 
Snap Setup, 304 
Style, 212 
Switch to Profile, 388 
Symbol Recognition Template 

Library, 198 
Text Style, 220 
Train OCR, 192 
Vector Correction Options, 276 
Window Transparency, 22 

Direction of linefollowing tracing, 
166 

Display Order, 39 
Document, 23 

creating new, 24 
opening, 27 
printing, 90 
purging, 75 
saving, 28 
templates, 25 

DPI, 129 
Draw toolbar, 209 
Drawing 

arc, 222 
circle, 224 
closed polygon, 224 
construction objects, 235 
ellipse and elliptic arc, 225 
entities, 221 
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hatch, 226 
line, 210, 211, 221 
pixels, 291 
point, 226 
polylines, 227 
precise, 299 
Ray, 235 
rectangle, 224 
splines, 232 
with selection, 377 
Xline, 235 

Duplicating by vector, 255 
Duplicating objects, 249 
Edge, 269, 270, 272, 273 
Editing 

block, 236 
calibration pairs, 143 
palette, 322 
polylines, 228 
recognized text, 194 
universal operations, 248 
vector objects, 247 

Elevation, 45 
Ellipse drawing, 225 
Embedded vs Linked images, 54 
End Markers, 258 
Endpoint, snap mode, 304 
Entities 

converting to, 262 
drawing, 221 
forced selection, 112 
forced tracing, 163 

Entity type recognition, 115 
Equalizing, 319 
Eraser tool, 291 
Errors 

of calibration, 139, 145 
Estimated points, 139 
Example of 

autocorrection of vectorization 
results, 278 

binarization, 337 
calibration, 146 
recognition templates, 191 

selection, 100 
selection by crossing window, 

114 
selection by fence, 117 
selection within window, 116 
tracing a polyline, 166 
using RxSpotlight, 13 

Exploding 
block, 236 
multiline text, 239 
polyline, 228 
vector objects, 257 

Export, 77 
to AutoCAD DWG/DXF, 77 
to ESRI Shape-format, 80 
to MapInfo, 79 

Extended Data, 45 
Extending vectors, 271 
Fast strategy, 197 
Fence, 117 
File formats, 12, 27, 28, 49 
Fill Shape symbols, 261 
Fillets, 266 
Filling area with shapes, 261 
Filter 

4-coupling contour, 155 
8-coupling contour, 155 
adaptive blur, 325 
blur, 324 
colour, 324 
contour, 155 
hole remover, 150 
inversion, 156 
line breaks fill, 156 
median, 327 
monochrome, 149 
Segmentation, 328 
smoothing, 151 
speckle remover, 149 
thickening, 154 
thinning, 153 
unsharp mask, 326 

Finding, 306 
Fit 
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in previews, 32, 35, 260 
Fitting Dashed Lines, 36 
Flipping objects, 252 
Floodfilling, 108, 109, 116, 291 

pixel drawing, 292 
Forced selection, 112 
Forced tracing, 163 
Foreign characters recognition, 

191 
Formats of paper, 51 
Four-Point Correction, 134 
Framing, 134 
Freehand pixel drawing, 291 
Gamma, 319 
Gamma Correction, 321 
Greyscale 

conversion to, 313 
images, 311 

Grid, 299, 306 
defining for calibration, 140 

Grid adaptive bilinear method, 144 
Grid calibration points, 137 
Grips, 33, 248 
Groups, 257 
Hatch 

drawing, 226 
recognition, 186 
tracing, 164 

Hide markup, 38 
Hide Raster Frame, 36 
Hide raster/vectors, 37 
Histogram, 319, 321 
Hole Remover filter, 150 
Horizontal flip, 252 
Horizontal orientation, 190 
HSV model, 311 
Hue, 311, 317 
Hybrid selection, 108 
Hyperlink, 45 
Ignored Break. See Break 
Image 

autocorrection, 133 
border, 57 
correction tools, 313 

creating from selection, 292 
cropping, 130 
deskewing, 132 
managing, 52 
measuring widths and breaks, 

124 
merging, 289 
mirroring, 131 
opening with template, 50 
resampling, 128 
resizing, 126 
rotating, 132 
selection, 104 
wide monochrome images 

loading, 51 
Images dialog, 52 
Import, 81 
Insertion of block, 236 
Insertion point, 49, 50, 52, 236 
Inspector, 24, 40 

common properties, 45 
custom properties, 44 

Intersection, snap mode, 304 
Intersections, 268 
Interval. See Width interval 
Inversion filter, 156 
Isolated raster object selection, 

109 
Joining polylines, 231 
JPEG 2000, 12 
Landscape, 127 
Layering, 46, 176, 189, 332, 342 
Layers, 45 

creating, 46 
deleting, 47 
dialog, 46 
renaming, 47 

Layers Manager, 46 
Layouts, 86 
Libraries of character template, 

191 
Life indicator, 21 
Line 

conversions, 230 
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drawing, 210, 211, 221 
linefollowing tracing, 166 
merging, 265 
recognition, 112, 183 
tracing, 163 
visibility, 37 
width table, 176 
widths rounding, 179 

Line Breaks Filling filter, 156 
Line Style Manager, 212 
Line Styles, 211 
Line Types 

recogonition, 184 
Linear conformal method, 144 
Linefollowing, 108, 110, 115, 165 
Linked vs. Embedded images, 54 
Locking layers, 47 
Main toolbar, 209 
Margins, 128 
Marker in the end of the line, 258 
Master, 320 
Measured calibration points, 142 
Measuring on the screen, 69, 124, 

150, 151, 187 
Measuring with log, 69 
Median filter, 327 
Merging 

auto, 265 
images, 289 
vectors, 262, 276 

Methods 
binarization, 329 
calibration, 137, 144 
selection, 98, 113 
tracing, 161 

Midpoint, snap mode, 304 
Mirroring 

images, 131 
objects, 251 

Modes 
creating block, 236 
of selection composition, 106 
polyline editing, 228 
snap, 304 

tracing, 170 
Monochrome filters, 149 
Monochrome images, 311 
Moving objects, 248 
Multiline text, 237 
Multipage, 81 

CIT, 81 
multipage document mode, 82 
TIFF, 81 

Multi-page print, 94 
Named views, 33 
Nearest, snap mode, 304 
New Layout, 87 
Node of a raster line, 165 
Noise reduction, 149, 331, 345 
Object border, 248 
Object Properties toolbar, 23, 45 
Objects 

aligning, 252 
copying, 249 
duplicating, 249 
flipping, 252 
mirroring, 251 
moving, 248 
rotation, 249 
scaling, 251 

OCR 
character templates, 189 
external modules, 196 
training, 191 

OCR Professional, 347 
OCR Text Corrector, 195 
Opacity, 391 
Opening document, 27 

Multipage TIFF and CIT, 81 
templates, 25, 50 

Operations 
binarization, 329 
calibration, 137 
correcting blueprint and sepias, 

340 
merging, 289 
merging vectors, 262 
palette editing, 322 
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separation of colours, 341 
Options. See Tuning 
Orientation, 50, 197 
Orthogonalization, 173, 174 
Outlines 

creation, 155 
recognition, 185 
tracing, 164 

Pan, 31 
Paper orientation, 50 
Paper Size, 51, 127 
Paste Separate, 290 
Paste Special, 290 
Patterns, 190 
Pause when tracing, 175 
Pencil tool, 291 
Perpendicular, snap mode, 304 
Pickbox, 300 
Pixel drawing, 291 
Plot style table, 95 
Points, 226 

recognition, 183 
Polygon selection style, 108 
Polyline 

adding vertices, 228 
backstep, 227 
breaking, 228 
closing, 228 
collecting, 279 
cursor menu, 227 
deleting vertices and segments, 

229 
drawing, 227 
editing, 228 
elevations arranging, 282 
exploding, 228 
joining, 231 
merging, 263 
modes of editing, 227 
recognition, 185 
selection on ratser, 110 
tracing, 165 

Polylines 
automatic correction, 286 

Polynomial method, 144 
Portrait, 127 
Precise drawing, 299 
Preview 

window, 34, 331 
Printing document, 90 
Printing multiple pages, 94 
Profiles, 385 
Profiles rapid switching, 388 
Prompt, 59 
Properties toolbar, 23, 45 
Purging document, 75 
Quadrant, snap mode, 304 
R2V Color Conversion Options, 

204 
Radius 

of blurring, 325 
of Median, 328 
of Unsharp Mask, 327 

Range by Grey, 330 
Range by HSV, 330 
Range by RGB, 330 
Range half-length, 330 
Range tab, 332 
Ranges of colours, 333 
Raster entity 

selection, 108 
snap to, 300 
symbol selection, 112 
symbol tracing, 169 

Raster Formats 
JPEG format options, 56 
TIFF format options, 56 
tuning, 54 

Raster text editing, 298 
Rasterization, 289, 292 
Ray, drawing, 235 
Recognition, 180 

arcs, 112 
circles, 112 
lines, 112 
Options, 187 
points, 183 
Shapes, 196 
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Templates, 190 
text editing, 194 
training shapes, 198 
tuning, 182 

Rectangle, drawing, 224 
Redoing, 33 
Redraw Centre, 166 
Reduction of colors, 346 
Remove mode of selection, 107 
Removing 

holes, 150 
polyline vertices and segments, 

229 
speckle, 149 

Renaming layers, 47 
Replacing, 306 
Resampling, 128 
Resizing image, 126 
Resolution 

vs Size, 129 
RGB, 320 
RGB model, 311 
Rotating 

images, 132 
objects, 249 

Rounding line widths, 179 
Rubbersheeting, 136 
Running snaps, 301 
Saturation, 311, 317 
Saving Document, 28 
Scaling 

objects, 251 
resampling image, 129 
resizing image, 126 

Scanning, 84 
Scripts, 348 

DDE, 375 
Overview, 348 
Script Studio, 353 
RxSpotlight batch, 368 
RxSpotlight script, 349 
RxSpotlight script commands 

(reference), 355 

RxSpotlight script launching, 
350 

RxSpotlight script syntax, 351 
Searching, 306 

isolated symbols, 308 
Segment editing mode for 

polylines, 227 
Segmentation filter, 328 
Segments of polylines, 228 
Select Source, 85 
Selection 

all, 107 
by brush, 106 
by Fence, 117 
by picking, 108 
by vector contour, 106 
colours, 333 
composing modes, 106 
creating new image of, 292 
Crossing Polygon, 113 
Crossing Window, 113 
hybrid, 108 
isolated raster object, 109 
methods, 98, 113 
of drawn objects, 377 
of image, 104 
of several images, 105 
of vector object, 104 
raster polyline segments, 110 
styles, 108 
targets, 108 
types, 108 
wise (automatic of certain type 

objects), 122 
Selection composition, 103 
Selection set, 98 
Selection toolbars, 98 
Send Backward, 39 
Send to Back, 39 
Sensitivity, 327 
Separation 

by colour, 328 
by type and size, 158 
of colours, 341 
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Shape recognizing options, 196 
Show markup, 38 
Show Width command, 37 
Single mode of selection, 107 
Skeleton thinning, 153 
Smart strategy, 197 
Smoothing filter, 151 
Smoothing raster lines, 171 
Snap 

toggling activity, 376 
Snap modes, 304 
Snap on Demand, 301 
Snap on raster, 299 
Snap priorities, 301 
Specifications, 15 
Specifying Colours, 48 
Speckle removing, 277, 345 

filter, 149 
Spline 

drawing, 232 
Splitting window, 32 
SRT file format, 200 
SST file format, 200 
Standard strategy, 197 
Strategy of shape recognition, 197 
Styles of selection, 108 
Surface Splines method, 145 
Symbol Recognition Template 

Library (SRTL), 198 
Symbols (shapes) 

Fill Shape, 261 
recognition, 186 
recognition, 196 
recognition template, 200, 202 
selection, 112 
tracing, 169 
training, 198 

System requirements, 19 
Tables of widths, 176 
TAF file support, 83 
Tangent, snap mode, 304 
Targets of selection, 108 
Template 

file, applied on creating, 25, 50 

for character recognition, 189, 
193 

for symbol recognition, 196, 
200, 202 

libraries, 191, 192 
saving widths, 180 
settings, 40 

Templates of a document, 25 
Text 

areas, 186 
creating, 237 
height, 188 
raster text editing, 298 
recognition, 189, 194 
special symbols, 238 

Text on the image, 186, 189, 191, 
194, 237 

Text Style Manager, 220 
Text styles, 219 
Thickening filter, 154 
Thinning filter, 153 
Threshold, 153 
Threshold by Grey, 329 
Threshold by RGB, 329 
Threshold tab, 334 
TIFF, 12, 146, 337 

multipage, 81 
Toolbars 

customization, 379 
Draw, 209 
Main, 209 
More select, 98 
Polyline editing, 228 
Properties, 23, 45 
Quick Launch Conversion tool, 

208 
Raster Properties, 208 
Select, 98 
Text Correction, 194 
WiseObject selection, 122 

Tracing 
auto, 162 
colour, 180 
direction, 166, 175 
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forced, 163 
hatches, 164 
linefollowing, 165 
methods, 161 
modes, 170 
outline, 164 
polylines, 165 
raster symbols (shapes), 169 
tuning, 172 

Training 
OCR, 191 
shapes recognition, 198 

Transparency, 391 
Trimming vectors, 272 
Tuning 

application, 389 
binarization, 335 
command performance, 376 
dialog transparency, 22 
grid, 306 
recognition, 182 
selection, 110, 111, 112, 122 
snap, 305 
text recognition, 189 
tracing, 172 
vectorization, 181 
width table, 176 

Two-points tracing method, 163 
Types of selection, 108 
Undoing, 33 
Ungrouping, 257, 269 
Unlocking layers, 47 
Unselecting all, 107 
Unsharp Mask filter, 326 
Unused calibration points, 137 
User preferences, 389 
Using Screen Width for Lines, 37 
Value (brightness of color), 311 
Vector editing mode for polylines, 

227 
Vector objects 

autocorrection, 275 
breaking, 269 
editing, 247 

exploding, 257 
extending, 271 
merging, 262, 276 
rasterization, 292 
selection, 104 
trimming, 272 

Vector template of the raster 
shape, 200 

Vectorization, 180 
automatic color vectorization, 

204 
automatic vs manual, 13 
raster to contours, 203 
running, 181 
toolbars, 208 
tuning, 181 

Vertical flip, 252 
Vertical orientation, 190 
Vertices, 175, 185 

deleting, 229 
Viewports, 88 
Visibility 

dialog transparency, 22 
full screen mode, 33 
layers, 47, 48 
lines, 37 
Show Width command, 37 

Width interval, 176 
Width measuring, 124 
Width table, 176 

saving, 180 
tuning, 176 

Window panes, 32 
Window preview, 34 
Window selection style, 108 
RxSpotlight Batch, 368 
RxSpotlight document, 23 
RxSpotlight Open Architecture, 

371 
RxSpotlight script, 349 
WiseObject selection, 122 
World file support, 83 
Xline, drawing, 235 
Zoom, 30, 32, 34, 260, 262 



 
 
 


