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SOFTWARE COPYRIGHT AND LICENSE AGREEMENT 
 

Grant of Limited License  
 

softelec gmbh (hereafter called softelec) grants a limited, non-exclusive right to use the software installed on computers (PC's) - workstations or a 
network server. In addition, softelec grants the right to only one (1) user or - in the event of network licenses - to the number of user stated in the 
network license agreement to activate and use the software at any one time once the user of the software has registered with softelec and thereafter 
received the corresponding authorization code. The license(s) and thereby the value of the purchased software product(s) is personified in the 
delivered hardlock. If a hardlock gets lost or stolen softelec will only deliver a new hardlock at full cost of the initially purchased software. softelec 
strongly recommends to insure the hardlock with the value of the purchase software to protect the investment. This limited, non-exclusive license 
agreement supercedes any other previous released agreement unless granted in writing and signed by softelec. 
 

For the demonstration version of the software, unlimited multiple installations are permissible. 
 

Copyright 
 

The contents of the software (recorded on CD's) and the associated manuals are the sole property of softelec and are protected by applicable 
copyright laws. This software may not be multiplied, copied, altered, decrypted, decompiled, changed, or disassembled in any manner without written 
authorization from softelec. A single backup copy is authorized. The user agrees not to transfer title of this software at any one time without first 
notifying softelec. All rights are reserved. No part of the manuals may be reproduced, transmitted, transcribed, stored on a retrieval system or 
translated into any language or computer language, in any form or means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise 
without the express written consent of softelec as punishable by applicable copyright laws. softelec is registered licensee of SZKI Recognita AG 
(OCR) for the use exclusively with VP products.  
 

The use of this software constitutes agreement to the terms said herein. If you do not agree with the terms of this agreement - DO NOT OPEN AND 
INSTALL THE SOFTWARE, promptly return the software, including manuals, binders, hardware lock key, written material, and containers to the 
location from which you obtained them for refund. 
 

Terms 
 

This license agreement becomes effective on the day of purchase and remains in full force until termination. softelec may terminate the license in the 
case the purchaser fails to comply with any of the terms and conditions of this agreement. The purchaser may terminate the license agreement at any 
time by returning the complete software (recorded on diskettes and/or CD's), including manuals, binders, hardlock key, written material, and containers. 
 

Disclaimer 
 

softelec reserves the right to modify the hardlock key, the manuals and/or the associated software at any time, particularly with the intent of further 
development, and undertakes no guarantee to issue notification of modifications, additions, or further developments; nor does the company obligate 
itself to implement such modifications, additions, or further developments in earlier versions of the manual or the software. Any such modifications are 
considered upgrades in which the registered license holder shall have the option to purchase. The license holder is granted the right to obtain license 
upgrades at no extra costs which become available within a maximum of 90 days after the date of his written purchase order. 
 
 

Limited Warranty 
 

softelec warrants that the media containing the software is free from defects in material and workmanship. This limited warranty is valid for a period of 
ninety (90) days from the date of delivery as evidenced by a copy of receipt, provided any faults or defects that may, in spite of the care taken in 
manufacture, become apparent are reported to softelec within thirty (30) days of their occurrence. The only entitlement granted by this warranty is 
repair or replacement of the supplied product at the sole discretion of softelec. Regardless of the nature of any damage or loss in any way connected 
with the software, sole and exclusive liability to be borne by softelec shall not exceed the purchase price of the product.  
 

This program is provided "as is". softelec specifically disclaims all other warranties, expressed or implied, including but not limited to 
implied warranties for merchantability and fitness for a particular purpose with respect to defects in the CD, diskette, hardlock, or 
documentation, and the software license granted herein in particular, and without limiting operation of the software license with respect to 
any particular application, use or purpose. In no event shall softelec be liable for any loss of profit or any other commercial damage, 
including but not limited to special, incidental, consequential or other damages.  
 

Legal Action 
 

This agreement shall be construed, interpreted, and governed by the laws of the Federal Republic of Germany. Venue for any cause of legal 
actions shall be in the city of Munich.  
 

Trademarks 
 

Windows and its derivations are registered trademarks of Microsoft Corporation. AutoCAD and RasterDWG are registered trademarks of Autodesk, 
Inc. Other registered product names are proprietary to their respective owners.  
 

softelec logo, Greek head design, VPHybridCAD, VPstudio, VPmap, VPmax, VPlite, VPraster, VPindex, and VPview, are registered trademarks 
of softelec gmbh.  
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SECTION 1   
INTRODUCTION 

 

Welcome  
 
Congratulations on your VPview software purchase from softelec, a specialist and market leader 
in raster-to-vector conversion and hybrid editing software. Since its first introduction in 1990, 
VPview, VPindex, VPHybridCAD, and VPmap Series software products have constantly been 
improved for quality and productivity. softelec’s technology assures that you are obtaining the 
finest in professional products for your scanning, archiving, viewing, raster and vector editing, or 
conversion applications.  
 
VPview is a powerful “hybrid” viewing application for CAD files, raster images of drawings or 
maps in  black/white, color, or gray scale. For these documents fast display, zoom, pan, and print 
functions allow for detailed document inspection, easy distribution and reproduction. 
 
 

What are VP products and who needs them? 
 
The importance of raster data processing has seen notable growth especially in the fields of CAD 
and GIS where legacy information such as "old" drawings, manually created maps, and other 
technical documents often found as b/w paper (copies, blueprints, transparencies) or gray scale 
and color images (photographs, films, color prints). Redrawing them manually with CAD (using 
CAD functions or a digitizer) is time consuming, inaccurate, and involves high costs. To overcome 
these drawbacks, b/w and color scanners for small and large formats are used to generate raster 
data (digital photographs) which can be easily edited or, when necessary, converted to vector 
entities for further use in CAD and GIS applications. 

 
VPview, VPindex, VPHybridCAD and VPmap Series products are designed for: 

• Architects and civil engineers, facility planning departments, and maintenance support 
• Mechanical design, process engineering, and production equipment design 
• GIS applications and cartography 
• Land Survey engineers and Cadastral documents 
• EDM applications such as archiving, indexing, revising of documents, etc. 
 
Everyone using a CAD system will inevitably face this question: "How do I capture paper 
information for use in my CAD system in a manner that saves time and money?" At softelec, we 
firmly believe that VPview, VPHybridCAD and VPmap Series products clearly respond to this 
question in many ways offering the optimal solution for any application on hand. 
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Concept of this Manual   
 
This manual has been organized to help you to quickly find operation terms, commands, and 
description of functions and to supply you with brief, but sufficient explanations. This manual 
applies to the following VP products:  

VPview. 
 
At the top of each page the listed product name(s) indicate(s) the product(s) the information 
and/or commands apply to. If specific commands on a page are limited to other products or 
product groups this is marked with a corresponding icon at the corresponding command 
description. Great efforts have been made to define each function and each setting of a 
parameter only once in detail. Therefore, an alphabetic index provides quick access to finding 
these descriptions. 
 
Keys and key combinations are represented by [ ] enclosing the keys' designation. For example, 
the  "Enter" or "Return" key is shown as [Enter] whereas a key combination (short-cut) opens as 
[Ctrl + C]. 
 
Functions that can be mouse-clicked for activation/deactivation in a check box are represented as 
{on/off}. 
 
Command line commands – if available for a particular function – are indicated with "CMD:" 
followed by the command term.  
 
The given value ranges do not necessarily define an internal limitation, but specify a meaningful 
range – be aware that using values outside of the "normal" range can cause unexpected results. 
Default values represent values either set up during installation or values to be used, e.g. when 
parameter values are reset. 
 
 

Conclusion 
 
This manual is intended to familiarize you with all the functions of VPview. It is meant to be a 
source of reference and a guideline.  
 
As a reminder, please register VPview with softelec (by mail, fax, or online) within 30 days after 
installation to receive an unlimited license.  
 
Visit our website at http://www.softelec.com for the latest product information, for technical 
support, for available updates, upgrades, and service packs.  
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SECTION 2  
INSTALLATION 

 

Introduction 
 
VPview software requires for operation Microsoft Windows 7 or higher. Depending on the 
configuration of your computer network you may install the software using local licensing or 
network licensing. 
 
The purchased VPview software product is delivered with a 30 days time limited operation 
license. The user is required to register the software within that time frame with softelec using 
either the online registration accessible from within the software, or sending the completed 
registration form to softelec by mail or fax. Softelec will then return a code to the user which 
extends the license for unlimited use. 
 
 

Software License Control (Hardlock)  
 
Any VPview Full Version product requires a hardlock (dongle) controlling the product license. 
Without a proper installed hardlock any product will only operate in the Demo Mode (no hardlock 
for the license control required). 
 
The hardlock may contain one or more product licenses. Regardless of the installation mode and 
the number of licenses controlled by the hardlock there are two methods of operation: 
1. Local Licensing: you need to attach the USB hardlock to one of the USB ports of the 

computer where the VP software is installed. Typically, this method of operation is used if the 
hardlock contains a single license only. Then, for every additional VP software installation an 
additional single license hardlock is required. 
 

2. Network Licensing: this method of operation is preferable if two or more VP software 
licenses are to be controlled by one hardlock, but may also be used for a single license 
("floating" license), where you can access the VP software license on any network computer, 
but only operate one license at a time. You need to attach the hardlock to a workstation 
serving as "VP network server" or "dongle server" (usually your network server) executing 
the VPLicenseManager so that the license(s) is/are accessible by other workstations. 

 The VPLicenseManager has to be installed on the workgroup server and can only operate 
under Windows XP or higher.  

 
Local Licensing does not require the installation of the VPLicenseManager. 
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Hardlock Driver  

 
The workstation or server controlling the hardlock needs a system driver for proper operation. 
This driver is provided with your package and is installed together with the VPview software. You 
may also install it manually by following the instructions found in the file README.TXT on the CD. 

 In order to install the hardlock driver during the standard installation or manually, you need 
administrative rights. 

 The installation routine will not install the hardlock driver(s) if the selected software is 
installed as a Demo Version! If, at a later state, you want to use the software as a full 
version (together with the purchased hardlock), you need to manually install the hardlock 
driver.  

 
 

Attaching the Hardlock (Dongle) 
 
The driver software will be installed automatically with the VP software program (full version). If 
required, it can also be installed separately later. Installation files can be found on the VP 
software CD or are available at www.softelec.com – downloads – utilities/drivers. 
 

 Attach the hardlock only after a successful software installation to one of your 
computer's/server's USB-Ports. 

 
 

Package Contents  
 
Your VPview package contains the following: 
 

• 1 VP Software CD 
• 1 Hardlock (dongle) 
• 1 Registration form 

http://www.softelec.com/
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Installing VPview Software  
 

General 
 
The install program SETUP_VP.EXE guides you through each step to successfully install and 
configure the software of your choice and the required hardlock driver on your computer. If your 
CD function autorun is enabled, the initial screen will pop up automatically upon insertion of the 
VP Series CD offering you several choices. Select VPview and follow the advice: 
 

 
 
All required hardlock drivers (Sentinel and/or HASP) will be installed or updated automatically if a 
VPview Full Version product is installed. 
 
The installation setup allows you to specify several options. These include the target location and 
the required components of the VPview software.  
 
Prior to starting the setup routine please terminate any running application and read the file 
README.TXT if available on the VP Series CD. 

 Administrator rights are necessary to install the hardlock driver. 
 
After a successful installation of the software or the hardlock driver it is often necessary to reboot 
the computer in order to allow the operating system to update the DLLs. A dialog box will appear, 
asking the user to restart the computer now or at a later stage. 
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Performing the Installation 
 
The setup starts automatically after inserting the CD into the CD-ROM drive (AutoRun). Only if 
your Operating System (OS) does not support this feature or AutoRun is disabled you have to 
start the setup program SETUP_VP.EXE manually from the root directory of the CD.  
 
In the initial setup window click the item "VPHybridCAD" or "VPmap Series", select "Full 
Version" or "Demo Version" (as desired) and select the desired program language from the 
appearing dialog. In the sequel you are guided through the setup dialogs allowing user defined 
settings. We recommend to choose "typical" as the setup type. 
 
On a 64-bit operating system another selection shows up to choose between 32-bit and 64-bit 
program installation.  
 
 

Local Licensing 
 
During setup you will be asked whether your hardlock resides locally or on the VP network server. 
Choose "Local". 
 
 

Network Licensing 
 
If you want to operate the software on a network (you have either multiple licenses purchased or 
you want to use a single license floating) you need to install your hardlock on the server. 
Therefore, choose "Network Server". The next dialog prompts you for the name of the server 
bearing the hardlock ("dongle server").  

 Enter the name, not the IP-address of the server!  
 
There are different ways to specify the server: 
 
COMPUTERNAME 

Name of the computer as entered during the installation of the Windows OS. Leading 
backslashes ("\\") are not required! 

 
COMPUTERNAME:192.168.0.1 

The IP-Address can be enter after the computer name separated by ':'. This is useful in 
larger networks and can speed up the rooting to the server and thus the license. 

 
COMPUTERNAME:COMPUTERNAME.DOMAINNAME 

In some 'heterogeneous' networks with different Windows versions it might be necessary 
to use this combination to clearly resolve the server name (e.g. DHCP) 

 
When working with multiple dongles on different servers please use the following syntax: 
 
COMPUTERNAME1; COMPUTERNAME2 

The computer names of the servers must be separated by semicolon. 
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If you don't know the name of the "dongle server" (= "VP network server") you may leave the 
entry empty and proceed with the installation. You may change the dongle server name in the 
VPview software (Options->Settings->License) later. 

 In order to use Network Licensing, the VPLicenseManager (see below), the hardlock driver, 
and the hardlock (dongle) must be installed on the same computer (server). 

 
 

First Start after Installation and Registration  
 
Unless you have purchased special VPview licenses such as Multi Licenses or Educational 
Licenses, which require a pre-registration, your software operates on a 30 days time limit allowing 
for execution of the required registration with softelec. At any start of the VPview software a 
dialog opens remembering you to register and displaying the expiration date of the license. After 
the expiration date the software will only run in demo mode, unless the code for unlimited use has 
been entered. This code will be send to you as soon as you have registered with softelec. 
 
You can register online from within the VPview software (press button "Register On-line" in the 
dialog box or select menu Help  Register VPview on the Internet) or fill out the attached 
registration form completely and legibly and send or fax it back to softelec. After checking the 
registration contents softelec returns a code to be entered with the next software start. 
 

 

 You will receive technical support and update/upgrade notices from softelec only if 
you have properly registered your VPview software. Registration of VPview products 
with your dealer does not constitute a proper registration. 

 All user data received will only be used for internal expenditure within the softelec sales and 
support cycle and will not passed over to third parties! 
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Uninstalling  

 
To remove a VPview software from your computer click on the icon Uninstall and follow the 
instructions.  
 
The hardlock driver(s) will NOT be removed. If the driver is not required by any other program, 
you can uninstall those using "Add/Remove Programs" from the Control Panel. 
 
 

Updating / Service Pack  
 
Software upgrades (to a higher VP software product level) or updates (to a new release of the 
same VP software product) may require a code that is issued to you upon purchase. After 
installing the upgrade or update and starting it for the first time you will be asked to enter the 
code. With a successful entry the code can be discarded.  

 For updating a VP network license hardlock (the lock is attached to the VP network 
server) use the program UPDATELOCK.EXE residing in the CD directory VPHardlock for 
entering the update code. For more information please read the text file ReadMe.TXT in the 
root directory of the CD. 

 
Service packs are released from time to time for bug fixes and smaller software improvements. 
They can be downloaded from our website and are usually self-installing. 
 
You may install and use the new VPview release together with a previous release although this is 
not recommended. However, do not install the new version into the same directory!  
 
 

System Requirements  
 
Proper operation requires a specific configuration of hardware and software to guarantee overall 
functionality. The fastest CPU in your PC is the most desirable! The software requires at least 
4 GB of RAM, but this is not recommended and today's PCs often have higher memory 
installations. Drawing formats of DIN A0 (E size) and larger, gray scale or color images of any 
size require a minimum of 8 GB. More is recommended for large size color images. File size and 
entity contents of a drawing define the actual amount of RAM required.  
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Installing the VPLicenseManager   
 
The VPLicenseManager needs to be installed only if you have a computer network and the 
hardlock is attached to a remote computer ("dongle server"). This software controls and manages 
the VP software licenses in the network. 
 
 

Requirements 
 
The VPLicenseManager may be installed as a service only on computers (server or workstation) 
operating under Windows XP or higher. 

 As a maximum number, ten concurrent users are allowed to connect to a license server 
running with Windows XP prof.! This is a restriction of the operating system, not of the 
VPLicenseManager. More users can connect using a newer version of Windows or a server 
operating system like Windows Server 2003. 

 

The software clients may run under Windows 7 or higher. It is necessary that the clients have 
access to the "dongle server" (an account must exist for each user). We strongly recommend 
installing the VPLicenseManager on the Domain Controller Server! 
 

An alternative solution is to create a share with a default user name and a respective password. 
Every user that needs to access the "dongle server" has to connect this share with this specific 
name and the specific password. This can be done by either using the Windows Explorer, with a 
special logon script, or by using the VPNetManager.  
 
 

Installation 
 For the following steps you have to be logged on to the dongle server as "Administrator"! 

 Attach the hardlock (dongle) only after a successful software installation. 
 
1. Install the VPLicenseManager software either  

- by choosing Network / Hardlock - VPLicenseManager in the installation’s main window, or 
- by running VPLicenseManagerSetup.exe from the VPLicenseManager folder on the VP 

software CD. 
2. Apply the dongle to a USB server port. 
 
The VPLicenseManager files are copied to the System32 (32-bit Windows) or SysWOW64 (64-
bit Windows) subdirectory of your Windows directory. 
 
In general, a reboot of the server is not required! In some cases it might happen that the 
VPLicenseManager service is not started automatically after installation. In this case you can 
start the service manually through the computer administrative console. To check whether the 
VPLicenseManager has been installed and is running, please use the VPNetManager 
(described below) for checking. 
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The VPLicenseManager service is installed with the startup option 'automatic'. That means the 
service will be automatically restarted after any reboot of the computer. 
 
If the VPLicenseManager is installed and running, you can find out with the program 
VPNetManager (see below). 
 
 

Uninstallation 
 For the following steps you have to be logged on to the dongle server as "Administrator"! 

 
Variant 1: 

Remove the license manager using the Windows Control Panel. 
 

Variant 2: 
Start the Windows command prompt. Change to the installation directory of the license manager 
(e.g. \Windows\System32 or \Windows\SysWOW64) and execute the following command: 

VPLicenseManager.exe -remove 

The VPLicenseManager service is removed. 
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Monitoring the VPLicenseManager   
 

VPNetManager - Introduction 
 
The VPNetManager allows monitoring the VPLicenseManager servers in your network. The 
number of the available licenses, the licenses in use, and the users accessing the 
VPLicenseManager servers can easily be overlooked. 
 
The VPNetManager.EXE application is located in the CD directory VPNetManager. It can be 
started from the installation menu (Network / Hardlock ► Run VPNetManager) or it can be 
installed (by copying) on any computer (Windows XP or higher) in the network. 
 
After the first start of the application the following dialog appears: 
 

 
 

Manage License Servers 
 
If started for the first time or if no server is listed to be monitored the application will automatically 
search the entire network for VPLicenseManager servers (see Search Servers).  
 

Search Servers 

 Menu: Servers ► Search Servers  

The application will search the network for any VPLicenseManager servers. The search may be 
stopped by clicking the icon again. 
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 Depending on the size of your computer network the search may take a long time. You can 
speed up this process by adding the server name manually (see below). 

 If you don't have an account on a computer that is currently being checked a dialog opens 
asking you to logon with a different user name and password. See also VPLicenseManager 
- Requirements. 

 

When the search has been completed the left window frame displays the symbols for the found 
VPLicenseManager server(s) (green screen) and those for the connected hardlock(s). 
 

Add Server 

 Menu: Servers ► Add Server  

Enter the name of a VPLicenseManager server: 
 

 

 If you don't have an account on the computer a dialog opens asking you to logon with a 
different user name and password. See also VPLicenseManager - Requirements. 

 
When successfully completed, the server and the attached hardlock(s) will be displayed in the left 
window frame: 

 
 

 The green screen indicates that the VPLicenseManager server is working in normal mode. 

 A red screen indicates that the computer could not be found in the network, i.e. the net path 
may be wrong or the computer is not operating. 

 The blue screen indicates that the computer is not a VPLicenseManager server, i.e. the 
VPLicenseManager has not been installed or the program was stopped. 

 A yellow screen indicates that the computer is operating, but another error has occurred. 
An additional error message is displayed in the status bar of the VPNetManager. 

 If the hardlock is not attached to the VPLicenseManager server the symbol for the hardlock 
will not be displayed. 
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Remove Server 

 Menu: Servers ► Remove Server  

The currently selected server will be removed from the list and will not be monitored any more. 
 

Default Server 

 Menu: Servers ► Default Server  

A dialog opens displaying a list of all VP applications installed on the local computer and the 
respective license server settings: 
 

 
 
Instead of checking and changing the server settings in each program you can easily do this with 
this function. Double-click on the program you want to modify and choose a new server: 
 

 
 
You can also assign the setting (No Server) meaning that a locally attached hardlock will be used 
by the selected program. 
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Sample 

 
The following sample dialog shows an active VPLicenseManager on the computer 
LICENSESERVER with two hardlocks containing 9 product categories, each marked by a key 
symbol. Each category may contain several licenses of that product.  
 

 
 
In this sample one license of VPstudio is currently in use by the user VPuser.  
 
 

Manage Users 
 
A user has to be a member of a user group (user type). There are two types of user groups: 
group Administrator or group Monitor. Monitor users have the right to monitor the license 
servers, the available licenses, and the licenses in use. Administrator users have additional rights 
to create or delete users. 
 
After the installation of the VPLicenseManager only two users are defined:  

Name Password User group 
Administrator Administrator Administrator 
MonitorUser no password required Monitor 

 With the first logon the Administrator's password should be changed immediately! 
 
When starting the VPNetManager you are automatically logged on as the default user 
MonitorUser. If this default user is deleted on a license server, only the server name and the 
status of the VPLicenseManager is displayed, however there will be no information on licenses. 
This way administrators can control the access to any license information: delete the standard 
user MonitorUser and create new individual user accounts. 
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Logon 

 Menu: General ► Logon  
 

 
 
The user will be logged on to the selected server. Note that the user name and the password 
entry are case sensitive! Additionally, the VPNetManager will try to log on the user to any listed 
VPLicenseManager server. If this fails for a server the user will be prompted again to enter a 
username and a password for this server. With Cancel the process is aborted. 
 

Change Password 

 Menu: User ► Change Password  

This function is available for all users except for the default user MonitorUser. Users of the group 
Monitor may only change their own passwords while users of the group Administrator may 
change the passwords of all users.  
 

 
 

Create 

 Menu: User ► Create  

This function is available only for users who are members of the user group Administrator. A 
new user can be created either on the selected server or on all listed servers: 
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Depending on the selected option a new user of the selected group, either of type Administrator 
or MonitorUser will be created. With the activated option On All Servers the system will try to 
register the user on all listed servers. The password default is the user name 
 

Delete 

 Menu: User ► Delete  

This function is available only for users who are members of the user group Administrator. A 
dialog appears to delete users from the user list. All registered users of the selected server are 
displayed.  
 

 

 The user will be deleted without a warning message. 
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SECTION 3   
SYSTEM SETTINGS, GENERAL FUNCTIONS 

 

General Information 
 
VPview products are in full compliance with the graphic user interface conventions of Windows. 
 
VPview has a Multi Document Interface (MDI) allowing for opening an unlimited number of 
documents at the same time and edit/process the contents of the documents simultaneously. You 
can open raster files, vector drawings, or hybrid files containing raster and vector entities.  
 
Anyone document can contain one or more raster images and/or vector data. The data maybe 
organized all in one page or in different pages of the same document (Multi Page Document), 
whereby the Page Control function controls the pages. In a multi page document only one page 
can be displayed at anyone time. For Multi Page TIFF Files the page control function also allows 
to select a particular raster image for editing/processing the contained data.  
 
Most functions and routines can be activated through graphic symbols (icons), by selecting the 
appropriate command from the menus and submenus, or by invoking the adequate commands at 
the command line. Using [F1] offers access to an extensive online help at any time.  

 
 
Program Start  

 

 Start your VPview software with this icon. 
 

 
Main Menu Sample: VPview showing all Toolbars 
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Start from command prompt 

 
For normal operation you should start VPview using the shortcut listed above. In some cases, 
however, you may want to start it directly from a Windows command prompt. The application you 
have to start is main.exe in the VPview installation directory. 
 

CMD: MAIN.EXE [/?] [FILENAME] [/DDE] [/AUTOMATION] [/EMBEDDING] [/P <FILENAME>] 
 [/PT <FILENAME> <PRINTER> <DRIVER> <PORT>] [/B <SCRIPT>] 
 [/T <TEMPLATENAME>] 

/? Show dialog with usage 
FILENAME File to open on start 
/DDE Start up and await DDE command 
/DDENOSHOW Start up and await DDE command, hide window 
/AUTOMATION Start up as an OLE automation server 
/EMBEDDING Start up to edit an embedded OLE item 
/P <FILENAME> Print file to default printer 
/PT <FILENAME> <PRINTER> <DRIVER> <PORT> 
 Print file to specific printer 
/B <SCRIPT> Script file to execute (only for products which support the script command) 
/T <TEMPLATE> Template file to load 
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General Operation   
 

Manual, Online Help  
 
VPview is delivered with an extensive product documentation. An Online Help system is also 
included and provides retrieval of specific function descriptions. 

 

Menu: Help ► Help Topics 
 

CMD: VPHELP 

The Online Help is provided in various manners: 
 

Help Menu 
You will find Online Help in the menu item Help - Help Topics.  
 

Command Line 
Enter  vphelp at the command line.  
 

F1 Key 
Using the the [F1] key. When a dialog has been opened specific information regarding this dialog 
will be displayed. 
 

Help Button 

 Click on this button first, then on any other button in the program for obtaining related 
information. 

 
Toolbars  

 
Upon the first start of VP Software a selection set of the available toolbars is displayed. All 
toolbars can be switched on/off according to individual user preferences. They can also be 
positioned and configured by following the Windows conventions. Additional custom toolbars with 
arbitrary commands can be added. 
 
Icon and pull-down menu commands that cannot be activated in the program's current status 
(e.g. no raster loaded) appear "grayed".  
 
Each toolbar can be customized individually by removing or adding icons as they are needed. 
 
A specific  positioning of toolbars can be saved as permanent and will be available at any time 
when it is needed. 
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Show/Hide Toolbars (only Windows)  

• Context menu: A right click with the mouse on any docked toolbar opens the context menu 
for toolbars. The toolbar state show or hide can be changed here. 

• System dialog "Customize": In this dialog (call up see below) multiple toolbars can be 
showed or hided. 

• Button "Close": Floating (non-docked) toolbars can be closed (hidden) by clicking the close 
button. 

 
 

Customize Toolbars (only Windows)  
With the system dialog Customize the toolbar state show/hide may be changed. Further toolbars 
can be modified and new toolbars can be created. The dialog can be opened in two different 
ways: 

• Click on the Customize-button of any docked tollbar... 

 
 ...and select Add or Remove Buttons ► Customize...  

• or open the dialog Toolbars (Menu Options ► Toolbars) and click on Customize. 
 
The dialog initially opens with the Toolbars tab.: 
 

 
 

Show/Hide 
Click the checkbox of the toolbar to show or hide it. 
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Create a new Toolbar 

With New... a new, empty toolbar is created. The name may be choosen freely. 
 

Add Icons 
Change to the tab Commands:  
 

 
 
In the column Categories the main menu items of the VP software are listed. The column 
Commands list all available commands from the selected menu.  
 
To add a command click and drag with pressed mouse button the selected command to the 
desired toolbar. 
 

Move/Copy Icons 
Select an icon and drag it with pressed mouse button to the new position within the current or to 
another toolbar. Holding down the [Ctrl] key while dragging will copy the icon. For this operation 
the Customize dialog must be opened. 
 

Delete Icons 
Click with the right mouse button on an icon and select Delete  from the context menu. For this 
operation the Customize dialog must be opened. 
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Customize Toolbars (Quick Access) (only Windows)  

 
Move Icons 

Keep the [Alt] key pressed, click on an icon in a toolbar and drag it with pressed mouse button to 
the new position within the current or to another toolbar. For this action the customize dialog is 
not required. 
 

Copy Icons 
Keep the [Ctrl] + [Alt] key pressed, click on an icon in a toolbar and drag it with pressed mouse 
button to the new position within the current or to another toolbar. For this action the customize 
dialog is not required. 
 

Remove Icons 
Keep the [Alt] key pressed, click on an icon in a toolbar and drag it out of the toolbar (not to 
another toolbar). For this action the customize dialog is not required. 
 
 

Organize Toolbars 
 

Menü: Options ► Toolbars 
CMD:  VPTOOLBARS 

 

 
 

Show Customize Buttons 
When active each docked toolbar is extended with the Customize button.  

 
 

Arrange Toolbars automatically 
When active the toolbars will be automatically rearranged to ensure an optimal view if the 
program window is resized. 
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Profile 

The arrangement of the toolbats can be saved either to the registry or to a file and thus can be 
restored any time.  
 

Scaling 
Toolbars and Menus are scaled according to the selected scale factor.  

 The size of dialogs is not affected by this setting. To enlarge the entire program including 
the dialogs and subwindows, use the scaling function of your Windows operating system. 

Large Icons: The size of toolbar icons (bitmaps) is doubled.  
 

Customize... 
Opens the system dialog Customize (see above). 
 

Reset to Default 
Reset toolbars to the initial state. All modifications and custom toolbars will be deleted. 
 
 

Dockable Windows 
Windows like the project bar or the symbol library can be docked to the edge of the program 
window. When dragging such a window the position marker appears.  

 
Dragging a window with pressed mouse key onto one of the markers the docking position of the 
window will be displayed. Releasing the mouse will please the window on the selected position. 
Releasing the mouse without this preview will keep the window in an non docked state. 
 
To dock windows on top of each other creating tabbed windows drag the window over another 
window and select the center marker: 

 
When the mouse is release the window docks on top of the other window. Tabs will appear on the 
lower edge of the window with the names of the windows. To release a window right click on the 
tab and select floating from the context menu.  
 
Dockable windows are: 

• Command Line 
• Project Bar 
• Browser 
• Birds Eye 
• Attribute Barr 

 



 VPview 

24   Section 3     System Settings, General Functions V16 / E 
 

 

Dialog Boxes  
 
VPview uses fixed size and re-sizeable dialog boxes. Once you have set up the size of a variable 
dialog box this size will be saved and re-used the next time you call this dialog.  
 
If a dialog box uses columns for displaying matching information, the width of each column will be 
adjusted. You may use keyboard commands according to Windows conventions to modify the 
arrangement of columns. However, these individual arrangements will not be saved: 

 
 

Status Display  
 
There is a comment box at the lower left screen margin showing: 

• Activated function, or 
• Required activities to proceed, or 
• Messages, or  
• Progress during execution. 

On the right there are 2 boxes for: 
• Count for selected elements 
• The local RGB color value if the cursor is positioned on a colored or gray scale 

image. 
When no function has been activated the comment box remains empty, while a 'For Help, press 
F1' indication appears on the left. 
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Display Control Functions    

 
Raster [F4] {on/off} 

 

 Toolbar: View Bar 
 

Menu: View ► Show Raster 
 

CMD: VPRDISPLAY ► {on/off} 

This function toggles the display of raster data on and off. When you load a raster file, the display 
of raster data is enabled automatically. The item in the menu will be indicated accordingly.  
 
 

Vector [F5] {on/off}  
 

 Toolbar: View Bar 
 

Menu: View ► Show Vector 
 

CMD: VPVDISPLAY ► {on/off} 

This function toggles the display of vector data on and off. When you load a vector file the display 
of vector data is enabled automatically. The item in the menu will be indicated accordingly.  

 
 

Plot Style View {on/off} (only Windows)  
 

 Toolbar: View Bar 
 

Menu: View ► Plot Style View 
 

CMD: VPPLOTSTYLEVIEW ► {on/off} 

Vector data will be displayed according to the colors and widths from the current plot style 
settings. In case that no plot style file is defined, this function is not available. See 
Plot Style Settings for further information. 
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Bird's Eye {on/off} 

 

 Toolbar: View Bar 
 

Menu: View ► Bird's Eye 
 

CMD: VPBIRDEYE ► {on/off} 

This function toggles the display of a separate window showing the whole drawing. Your actual 
zoom position is indicated by a green frame. Clicking and dragging inside this bird's eye window 
performs a dynamic pan of your current view. Clicking the right mouse button and drawing a 
rectangle will zoom to the rectangle area. Using the mouse wheel zooms into or out of the view’s 
center. 
 

Zoom Functions 
 

Zoom Extents [NUM x] 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Extents 
 

CMD: VPZOOMX 

The drawing is displayed to its full extents. The drawing's center is mapped to the center of the 
display. 
 

Zoom Selection 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Selection 
 

CMD: VPZOOMSEL 

This function is only available when objects are selected. After selecting objects the function sets 
a new zoom window, so that all selected objects are displayed in the drawing area. 
 

Zoom Window 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Window 
 

CMD: VPZOOMW 

Define a window in your document to enlarge a section. 
You can also use the Fast Zoom Window function by holding down [Ctrl+Space] and then 
defining a zoom window. 
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Zoom Pixel [NUM ÷] 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Pixel 
 

CMD: VPZOOMPIXEL  

Enlarges the display to show each pixel, i.e. each raster pixel is represented by one dot on the 
screen. 
 

Zoom In 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom In 
 

CMD: VPZOOMIN 

This function zooms in incrementally to the maximum pixel viewing level while maintaining the 
viewing center point. 
 

Zoom Out 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Out 
 

CMD: VPZOOMOUT  

This function zooms out incrementally maintaining the screen center point in view, if possible. 
 
Zoom Previous 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Previous 
 

CMD: VPZOOMPREV  

This function lets you work your way back through previous zoomed views. The program 
remembers a maximum of 32 views. It does not recall pan operations. 
 

Zoom Dynamic 

 Toolbar: Zoom 
 

Menu: View ► Zoom ► Zoom Dynamic 
 

CMD: VPDYNZOOM  

This function lets you zoom dynamically by clicking with the left mouse button onto the screen and 
move the mouse up (zoom in) or down (zoom out). 



 VPview 

28   Section 3     System Settings, General Functions V16 / E 
 

 
Pan Functions  

 
Pan [Cursor Keys]  

Menu: View ► Pan ► Pan Right, Pan Left, Pan Up, Pan Down 
 

CMD: VPPANRIGHT, VPPANLEFT, VPPANUP, VPPANDOWN 

You can pan using the scroll bars at the bottom and right of the active window, or using the pan 
keys on the keyboard. 
 

Pan Page [Shift]+ [Cursor Keys] 

Menu: View ► Pan ► [Shift]+Pan Right, Pan Left, Pan Up, Pan Down 
 

CMD: VPPAGERIGHT, VPPAGELEFT, VPPAGEUP, VPPAGEDOWN 

You can pan using the scroll bars at the bottom and right of the active window, or using the pan 
keys + [Shift] on the keyboard. 
 

Dynamic Pan 

 Toolbar: Zoom 
 

Menu: View ► Pan ► Pan Dynamic  
 

CMD: VPDYNPAN  

Click with the left mouse button onto your document and move (pan) as required. Release the 
mouse button to stop panning. You can also initiate the Dynamic Pan function by holding down 
[Space] or the center mouse button. The function is active as long as you are holding the key or 
button. 
 
 

Using the Mouse  
 

Display Modes of Mouse Position 
Within the work area the mouse position is displayed as a Cross cursor by default. When moving 
to toolbars, menus or to the status area it will be displayed as a standard Windows Arrow cursor. 
At the command line it will be displayed as a standard Text cursor. 

 A triple white frame box (instead of the standard crosshair) indicates that with the next mouse 
click this area will be zoomed in to allow for a precise positioning with the then following click. To 
configure the zoom size use the General tab in the System Settings dialog. 
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Using the Mouse to Select Elements 

 
Use the left mouse button to pick for Selection. 

 Elements to select can be in raster or vector format. When vector elements are overlaying 
raster elements only vector elements will be selected initially, while  raster elements need to 
be selected again.  

 
Selecting entities in an image can be done in four different ways: 
 

Clicking 
Click on the respective element within the cursor's snapping range. Only one element will be 
selected per click. 
 

Window 
You specify a rectangle by holding down the left mouse button and dragging the mouse from left 
(1) to right (2). All elements completely enclosed by the rectangle will be selected. The 
rectangle will be displayed with a full frame. 

  
 

Crossing 
You specify a rectangle by holding down the left mouse button and dragging the mouse from 
right (1) to left (2). All elements touched or enclosed by the rectangle will be selected. The 
rectangle will be displayed with a dashed frame. 

  
 

Polygon Selection 
Via context menu you can start the polygon selection mode. A clockwise drawn polygon selects 
only elements completely enclosed by the polygon. The polygon will be displayed with a full 
frame. 
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A counterclockwise drawn polygon makes a crossing selection: all elements touched or 
enclosed by the polygon will be selected. The polygon will be displayed with a dashed frame  

  
 
 
Deselection of selected Elements 

To deselect elements from a previous selection hold the [SHIFT] key and repeat your  selection 
(see above for selection modes).  

To cancel a selection or to deselect all selected elements, press the right mouse button for the 
context menu, or press [ESC]. 
 
 

Context Menus 
Use the right mouse button to open context menus. There is a general context menu defined in 
the software registry. Other menus depend on active functions or commands. 
 
 

Zoom 
You can use the mouse center wheel to  

• zoom in/ zoom out . 
• move up/move down (scroll) when holding the [Ctrl] key. 
• move left/move right when holding the [SHIFT] key. 
• move the display arbitrary when holding down (pan dynamic). 
• zoom all by double clicking. 
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Command Line    
 
VPview offers a command line input and execution via keyboard.  
 
The command line window is sizeable, dockable/undockable, and can be switched off when not 
needed. The window is split into two parts: The upper part shows the command history, while new 
commands are entered to the lower part. It automatically appears on keyboard input. To activate 
the command line simply press [Shift]+[Return]. Command line inputs may look like this: 
 

 
 
All VPview functions can be initiated by command line input. Commands are only available 
(executable) if a document has been opened, except for specific commands like Open, Help, etc. 
 
The available commands are listed with the corresponding functions in this manual.  
 
A command string consists of the command header and can be extended by 
options/parameters. Any command starts with the two letters "VP" followed by the command 
name. The command header is the main command for any particular function or operation. For 
entering you may use upper and/or lower case letters. Enter [Return] for execution. 
 
The command syntax is as follows: 
 

VPXXXX  <X1>,<X2>  <X3> [/P|Parameter <X1>, <X2>] 
 
The preceding characters VP may be omitted.  
 

Options <X1> <X2>,<X3> 
Options are command supplements which may be required to execute the command. Some 
commands do not allow options at all, some may have options, and some always require options. 
The values X1, X2 etc. can be separated by either comma(s) or space(s). This delimiter strategy 
allows for entering an extended command string prior to executing the complete command with 
[Return].  
 

Parameter [/P|Parameter <X1>] 
Parameters are always optional. Therefore, they are listed in this manual in brackets. A 
parameter starts with a "/" (slash) followed by the parameter name. Possible abbreviations are 
also listed, they are separated by a "|", i.e. you may use the word Parameter or only P. A 
parameter can require options, which are demanding if the parameter is used at all. These 
parameters are shown within the brackets enclosing the parameter and the required options. 
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Delimiter 

Options and parameters have to be separated with a delimiter. As delimiters either a comma or a 
space character are available. Multiple spaces and/or commas between two option values are 
interpreted as one delimiter. 
 
If a parameter uses either a space or a comma as part of the parameter – e.g. if you use a file 
name as the parameter to the command VPOPEN /P which carries space(s) – you need to enter 
this parameter in quotations marks: VPOPEN /"C:\VP SAMPLE.TIF".  
 

Command Query 
If you enter any command followed by a slash and a question mark, e.g. VPOPEN /?, the system 
will display all options/parameters for this command. 
 

Repeating Commands 
Entered commands can be repeated by using [ ] and [ ] cursor keys. 
 

Completing Commands 
You may use the [TAB] key to complete a command. A repeated pressing on [TAB] will prompt 
the next command option in alphabetical order. Using [SHIFT] + [TAB] reverses this order.  

Example:  "VPRO" and [TAB] will prompt "VPROT90". 
 "VPRO" and [SHIFT] + [TAB] will prompt "VPROT270". 
 

Alias Names 
The command header of a command string may be replaced by an alias name, usually a short 
abbreviation being especially useful with commands which are often used. The file 
ALIASES.PGB located in the SUPPORT subdirectory contains alias names which may be 
modified or extended at user’s discretion. The default alias names are listed in the APPENDIX. 
 

Command Line {on/off} 
 

Menu: View ► Command Line 
 

CMD: VPCMDLINE 
 
Switches the command line on and off.  
 
 

Activate Command Line 
 

Menu: View ► Command Line 
 

CMD: VPACTCMDLINE 
 
Activates the command line at any program state. 
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User Coordinate System    
 

 Toolbar: Coordinates 
 

Menu: Options ► User Coordinate System 
 

CMD: VPUSERCOORDS [/uc <value>] [/s <value>] [/up <value>][/d <value>] [/t <value>]  
 

Command line: 
/uc <value> User Unit Code (see dialog) 
/s <value> Drawing Scale 
/up <value> Precision of Coordinate Display (0-8) (default = 2) 
/d <value> Coordinate Display: 0: User Units / 1: Unprojected (Degrees) (Default=0) 
/t Coordinate Transform: 0: Keep Values / 1: Keep Values in Degrees / 2: 

Adjust Coordinates 
 
 
Without parameters or using the icon a dialog box opens for setting up the user coordinate 
system: 
 

 
 
By entering values for  

• User Units 
• Drawing Scale 

the coordinate system can be adjusted to specific requirements of the active document.  
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Coordinate System / Projection 

This field always appears greyed and contains Standard (Cartesian). However, when a file is 
opened containing Coordinate System information (e.g. GeoTIFF) a Coordinate System with a 
specific projection can be displayed. In this case Parameter becomes available to check on 
projection parameters. However, these cannot be changed.  

 To set up and edit a specific Coordinate System with projections you will need to apply  
softelec’s VPmap Series products.  

 
User Units / Drawing Scale 

The User Units and the Drawing Scale should be set to a value which corresponds to the 
document data. This information may either be part of the legend/drawing header in a raster 
image or it needs to be known due to other information. This allows for measurements (using 
function [F2]) in the document. 

 
Display 

Choose between Display Coords. in User Units and Display Coords. Unprojected (in 
Degrees). The second option is only available when a coordinate system with projection has 
been selected. When selected all coordinate input requiring coordinate values in User Units must 
be entered as degree-minutes-seconds (DMS). Possible formats are: 
 

Input Format Sample Input Value 
<d>°<m>'<s.nn>" -48°15'30" -48°15'30" 
<d>°<m.nnnn>' -48°15.5' -48°15'30" 
<d.nnnnn>  -48.2583333 -48°15'30" 
<d>°<m>'<s.nn>" [EWNS] 48°15'30" S -48°15'30" 

 
Instead of using signed values the post-fix East/West and North/South can be used to specify the 
direction. 

 Instead of using the degrees (°), minutes ('), or seconds (") signs you can also separate the 
values by a double point (:) (<d>:<m>:<s.nn>). This may especially be necessary for 
complex command line input to differ the coordinate values from e.g. long file names with 
("). 

 
Precision defines the number of decimal places. 

Default: Display Coords. in User Units 
Precision: 0.00 
 

Place Raster and/or Vector Data on OK {on/off} 
If set to on after confirming the User Coordinate System settings with OK a dialog pops up to 
specify a new origin for the existing raster and/or vector data. See the following command. 
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OK 

If the coordinate system has been modified another dialog pops up on OK to specify whether 
existing document data should be transformed to the new coordinate system or not: 
 

 
 

Keep actual Coordinate Values 
Use this option when the coordinate values in the document are already displayed correctly. 
Typically, this is the case when a vector drawing with no or wrong coordinate system information, 
but real coordinate values has been imported. AutoCAD drawings may be  examples (*.DWG) 
when they have been created in an English (inch) environment, but were drawn with Metric 
(millimeter or meter) coordinates. Also, ESRI shape files (*.SHP) may be another example when 
no corresponding projection file (*.PRJ) is available. Especially, typical GIS formats like MapInfo 
MIF files and ESRI SHP files may contain vector data with coordinate values in degrees. In these 
cases the Values are in Degrees option needs to be applied. 
 

Adjust Coordinate Values to the new Coordinate System 
Use this option when the coordinate values displayed for the document are “paper“ units. 
Typically, this is the case when a raster image without any placing and coordinate system 
information has been imported. 
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System Settings    
 
The system settings define the general operation environment of your program.  
 

Menu: Options ► System Settings 
 

CMD: VPSYSTEMSETTINGS ► Dialog 
 
A dialog box opens to define the system's general setting values: 
 
 

General Tab 

 
 

Drawing Units  
Choose either mm or inches. The drawing units you select determine how the raster image will 
be interpreted in terms of units of measure. The units have an effect on the X/Y coordinate 
system and on all depending values and parameter settings. 

Default: mm 
 

Pick Box Size  
This setting controls the size of the cursor square box (in pixels of the monitor screen) used when 
elements are selected (pick area). It also defines the grip size of the selected entities. 

Default: 8 [pixels] 
 
Default Text Font  

Selection of the default text fonts for text style creation. All existing and scaleable True Type 
Fonts in your Windows system are available. 

Default Font: Arial 
 

Cmd Echo {on/off}  
Set to on the command name is displayed in the command line window whenever the command 
is started via menu or toolbar button. 

Default: on 
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Zoom-In on First Click 

This option controls the automatic zoom for commands that use the “triple frame” cursor, e.g. the 
VPDESKEW command. 

Default: 1:16 
 

Display Info 
Show Context Menus  
When set to on, the default context menu appears when clicking with the right mouse key. The 
default context menu will be replaced by other special menus, depending on the active function. 

Default: on 
 
Show Status Tooltips  
When set on status messages will be displayed as tooltips next to the mouse cursor.  

Default: on 
 

Show Warnings 
Current Layer off  
When set on a warning will come up upon switching off a current layer setting. 

Default: on 
 
Current Raster off  
When set on a warning will come up upon switching off a current raster setting. 

Default: on 
 
 

Colors Tab 
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Some of the screen colors can be defined individually: 

Category: Screen color: Screen color: 
 white on black black on white 

• Window Background (black) (white) 
• Cursor (green)  (black) 
• Active Image Border (red)  (red) 
• Raster Selection (red) (red) 
• Speckles (green) (green) 
• Raster Holes (red) (red) 
• Move Grip (black) (white) 
• Other Grips (black) (white) 

The System Default values (in brackets) can be reactivated when clicking on the white on black 
or black on white buttons. 
 
 

Files/Paths Tab 
 

 
 
Auto Save {on/off}  

While working with the program an automatic save of open documents will occur at selectable 
intervals. You can specify the Interval and the Drive and the Path for the Auto Save individually.  

Default: on 
Default Directory: no entry = document's current directory  
 
For the auto save operation the system uses the filename of each document extended by "_" 
(underscore) + numbering. The extension is RVD. Sample: ARCH.TIF will be auto saved as 
ARCH_0157.RVD 

Default interval: 60 [minutes] 
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Purge Auto Save Files on Close 

If you set purge auto save files on close to on the system will delete all auto save files on closing 
a session. 

Default: off 

 We strongly recommend not to switch off Auto Save.  
 
Prototype Drawing  

With a Prototype Drawing you can create documents according to your needs.  
 
The prototype drawing is a RVD file, which is preloaded with every new document (Open or 
New). The prototype drawing may contain predefined objects like layers, line types, text styles, or 
block definitions. It may also contain visible entities like a drawing frame. For different kind of 
projects you may use different prototype drawings. 
 
A new prototype drawing is created in two steps:  
1. Create an empty document or open an existing prototype drawing. Then adjust/create layers, 

line types, user units, etc. to your need. Save this document in the internal RVD file format. 
2. Specify this RVD file in the according edit field or use the Browse button to search for it. 

Default: \<VP directory>\SUPPORT\PROTO.RVD 

 By default the prototype drawing is only preloaded on New  or on Open  of a pure raster file 
or with a PDF file. With file formats that contain also layers, line types, etc. the prototype 
drawing is not preloaded, unless you have explicitly activated the switch below. 

 
Always use Prototype Drawing: If on the prototype drawing is preloaded with every Open, 
regardless of the file format. 

Standard: off 
 
Show selection dialog: If on the New command will show a dialog to select a specific prototype 
drawing.  

Standard: on 
 
Support Path  

The directory of files containing parameters, prototypes, and other auxiliary information. 

Default directory: \VPxx directory\SUPPORT 
 

SHX-Font File Search Paths  
These directories are used by the software to search for SHX font files. The AutoCAD system 
paths (if existent) are registered here upon installation of the software. 

Standard: If existent: AutoCAD system paths; else: Empty 



 VPview 

40   Section 3     System Settings, General Functions V16 / E 
 

 
Raster Image Tab  

 

 
 

Default Resolution 
If a loaded/imported raster image does not contain a valid resolution (DPI) a standard value will 
be set. 
Default: 300 DPI 
 

Move Raster Images to active Layer {on|off} 
The currently active layer will be assigned automatically to a new loaded/imported raster image. 
Default: off 
 

Move Raster Images to this Layer {on|off} 
The named layer will be assigned automatically to a new loaded/imported raster image. The layer 
will be created automatically when it has not been created before. 
Default: on, Raster 
 

Highlight active image {on|off} 
The active raster image will be highlighted with a colored frame. The frame color can be defined 
in the Colors tab. 
Default: on 

 
Black and White Draw Mode 

The options are Draft and Enhanced. With Enhanced a B&W image is displayed on the screen 
as gray scale image. Depending on the zoom state thinner lines are faded out. Single pixels and 
small objects might disappear at all. In Draft mode a "black wins" algorithm is used ensuring that 
almost all pixels and thin lines are displayed. Enlarging to 1:1 or more will always display all pixels 
from the raster image. 
Default: Draft 
 

Color Image Draw Mode 
The options are Draft, Enhanced and Proof. These display methods differ in speed (Draft = 
quick, Proof = slow) and a better visibility of details in small scaled views or zoom extends 
(Enhanced and  Proof). 
Default: Enhanced 
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License Tab  

 

 
 

Enable Full Version {on/off} 
Activates a VPview full version product permanently. Otherwise, the software operates in demo 
mode and will not search for a license (hardlock). 
 
If you have your VPview software installed as Network License(s), enter the Server name to 
search for an available license or browse for the server computer.  
 

Get a Trial License 
Opens a dialog that either prepares an e-mail to apply for a Trial License or to activate the 
returned license. With this Trial License your Demo Version runs temporarily as a full version. 
 

Enable Network Search {on/off} 
If set to on, the whole network will be scanned for a valid VPview Network License, if no license 
can be found at the predefined location. This operation may take some time. 
 

Install Hardlock Driver 
If the proper driver for the hardlock (Sentinel or Hasp) is not yet installed, the button Install 
hardware lock driver is active. Click on the button for driver installation. 

 To modify these settings administrative rights are required! To start VP in administrative 
mode use right mouse click on the VP start icon and select the "Run as Administrator" 
option. Installation of the hardlock driver always requires administrative rights. 
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Shortcuts Tab  

 

 
 

For frequent insertions you can define up to 35 ASCII character strings as character shortcuts, 
especially those which are not available from a direct keyboard entry. Use the Windows character 
map (CHARMAP.EXE) for selection. While entering or correcting text strings use [Alt + 1] – [Alt + 
9] and [Alt+A] – [Alt+Z] to insert them.  
 
Also, shortcuts are helpful for supporting quick insertion of repeatedly used text strings, prefixes, 
suffixes, etc.  

Default shortcuts: see Dialog Box above 
 

 
Redlining Configuration Tab 

 

 
 
Enable or disable access restrictions. 
 

Enable Access Restrictions 
If Enable Access Restrictions is activated the path to the redlining configuration file is required. 
Then, a logon to the redlining session using user name and password is required. 



VPview  

V16 / E Section 3     System Settings, General Functions   43
 

 
Change Password 

Clicking Change Password opens a dialog box to modify the password for redlining. 
 

 
 
 

User Interface Look Tab  
 

 
 

Select Scheme 
Here you can change the look of the User Interface. Several designs are offered for selection. 
Depending on your Windows version the User Interface may look slightly different from the 
displayed preview. 
 

Reset Dialogs 
All dialogs will be reset to their default size and position. Use this function if some dialogs do not 
appear on the screen e.g. in case of a monitor switch. 
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File Extensions (Windows only)  

 
Here you can specify which file types will be associated with VP. If checked, the Windows 
Explorer shows these kinds of files with a VP- Icon and starts VP to load the file when double-
clicked. 
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Page Control  
 

 
 

Next Page [Page Up] 

 Toolbar: Page Control 
 

Menu: Page ► View ► Next 
 

CMD: VPNEXTPAGE  

Displays the next page. 
 

Previous Page [Page Down] 

 Toolbar: Page Control 
 

Menu: Page ► View ► Previous 
 

CMD: VPPREVPAGE  

Displays the previous page. 
 

Last Page [End] 

 Toolbar: Page Control 
 

Menu: Page ► View ► Last 
 

CMD: VPLASTPAGE  

Displays the last page. 
 

First Page [Pos1] 

 Toolbar: Page Control 
 

Menu: Page ► View ► First 
 

CMD: VPFIRSTPAGE  
 
Displays the first page. 

 
Select Page  

The selection box displays the actual page no. out of the total number of pages in this document.  

 
You can select any other page. 
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Entity Selection and Handling    
 

Vector Entity Selection 
 
The selection mode is CAD-like. Pick any vector entity. The selected entities are displayed in a 
highlight mode (dashed) and contain grips (handles). The base point grip is marked with a cross. 
 
 

Quick Selection [Ctrl + F]  
 

 Toolbar: Propterties/Editing 
 

Menu: Edit ► Quick Selection...  
 

CMD: VPQSELECT ► Dialog 
CMD: VPQSELECT <Command> [/p|Pick p|a|l|f] [/t|Type <value>] [/prop|Property <value>] 
 [/o|Operator <value>] [/v|Value <value>] [/m|Modify 0|1] [/nor|NoRaster] [/nov|NoVector] 
  [/rdl|Redlining] 
 

ACAD: _qselect 
 
This function allows for selecting entities through user defined rules. The result is a specific entity 
selection that can be used for further operations. Also, an existing selection of entities can be 
reduced or expanded. 
 
A Command can be specified for immediate execution after the selection is finished. This option 
is especially useful for script processing. 
 
When the dialog is suppressed using the p (Pick) option you have the choice between three 
different selection modes: 
 
/p a: Pick all elements in the drawing. 
/p p: Pick elements using the mouse. 
/p l: Pick last element that has been modified/created. A special registry key 

(..\Selection\SelCount) controls how many elements from the history are selected when 
using this option. 

/p f: Depending on the following filter parameters /T (Type) and/or /prop (properties) with /O 
(operator) and /V (value) one or more elements will be selected. When a selection list has 
already been set up this will serve as a base. 

/p w Window selection. The window is specified with these subsequent coordinates: <x1> <y1> 
<x2> <y2>  

/p c Cross selection. The window is specified with these subsequent coordinates: <x1> <y1> 
<x2> <y2> 

/t Selection according to type of element, such as Line, Arc, Circle, etc. 
/prop Selection according to a specific property of one or more elements. All element properties 

that are available in the properties dialog are acceptable; e.g. Layer and Linetype, but 
also geometric properties such as Xm (= x-value of circle centerpoint, Ym (= y-value of 
circle centerpoint), R (= radius). 
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/o Relational operator. Available are: "=" (equals), "<>" (not equal), "<" (less than) und ">" 

(more than), "*" (name or text comparison with wildcards), and "%" (text comparison for 
numbers only). Operators are available depending on the individual filter property. 

/v Comparative value. Depending on the parameters above this can e.g. be a layer name or 
a number value. When filtering text content you can also use these wildcards: * (arbitrary 
number of arbitrary characters) and ? (single arbitrary character). When the "% Only 
Numbers" operator is selected, the value specifies the number of digits before and after 
the decimal point (e.g.: /v 4.2 selects all numbers with 4 digits before and 2 digits after the 
decimal point). 0 selects all texts representing numbers. 

/m 0: a new selection list will be generated. 1: the existing selection list will be changed.. 
Default value is 0. 

 
The three additional options /nor (NoRaster), /nov (NoVector) and /rdl (Redlining) control 
which basic entity types (raster, vector, redlining) are selected when using the p option. 
 
Example: Selection of all circle elements with a radius of less than 5 drawing units: 

VPQSELECT /p f /t Circle /prop R /o > /v 5 

 
 
Apply to The filter criteria can be applied to the Whole drawing or the Current 

selection. Current selection is only available if entities were selected before 
starting the command. 

Pick Object Temporarily closes the dialog for selecting entities from the document by 
using the mouse. 
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Object type Shows the types of the entities in the selection or in the drawing and (if there 

are different types) All.  

Properties Determines the criteria for filtering. The property list changes according to the 
selected Object Type. Selecting a property changes the available options for 
Operator and Value. In order to select a property the Operator must not be 
set to Select All! 

Operator Controls the value range for the filter. Depending on the selected property the 
following operators are offered: Select All, = Equals, <> Not Equal, 
> Greater Than, < Less Than, and * Wildcard Match. Possible wildcards 
are: 

*  a sequence of arbitrary characters 
?  a single arbitrary character 
#  a arbitrary digit.  

Not all operators are available for each property. 

Value The property value for the criterion. If known values exist for the selected 
property they are provided in a selection list. Otherwise type in a Value. 

Filtered entities meet the filter criteria 
 Those entities that meet the filter criteria are selected. 

Filtered entities do NOT meet the filter criteria 
 Those entities that do NOT meet the criteria are selected. 

Selection (Modify existing set) 
An existing selection set is reduced or expanded according to the filter criteria. 

Selection (Create new set)  
 A new selection set is generated from the result of the filtering. 
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Undo [Ctrl+Z] [Alt+Backspace]  

 

 Toolbar: Standard 
 

Menu: Edit ► Undo  
 

CMD: VPUNDO 
 
This function will Undo a previous command or function. The command can be repeated for a 
maximum of 32 steps per page or 50 steps per document. The icon (and menu command) is 
grayed if to be undone. 
 
 

Redo [Ctrl+A] [Ctrl+Y]  
 

 Toolbar: Standard 
 

Menu: Edit ► Redo  
 

CMD: VPREDO 
 
Repeats the last command or function which has been undone. The icon (and menu command) is 
grayed if there are no commands in memory. 
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Measure Distance [F2]  

 

Menu: View ► Distance  
 

CMD: VPMEASURE  
 

Pressing the [F2] key opens the Measure Distance Dialog. The white area shows the current 
cursor position and the values are permanently updated when moving the cursor in the work 
space. The upper section shows the values in base units, either [mm] or [inch] depending on the 
system settings (Options - Settings). The lower section displays the same values according to 
the settings in the user coordinate system. 
 
Measurement results will be displayed in the lower gray area (pane).  
 

 
 

Three basic operation types are available which can be set with the left three buttons in the 
dialog’s far upper section: 
 

 Accumulate the measurement results indicated by (+) in the result pane. 

 Subtract the measurement results, indicated by (-) in the result pane. 
 

 Take one measurement at a time. 
 

Different values can be measured using the buttons on the dialog’s right hand side: 

 Measure the length and angle of a line by clicking two points in the drawing. 

 Measure an angle by clicking three points in the drawing. The center point is the intersection of 
the two lines forming the angle you want to measure. 

 Measure an angle by clicking four points in the drawing. 
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 Measure the length of a polyline by clicking its vertices. Complete the measurement with a 
double-click or press ENTER. 

 Measure the circumference and area of a rectangle by clicking two points in the drawing. 

 Measure the circumference and area of a closed polyline through clicking its vertices. Finish the 
measurement using a double-click, or using ENTER. 

 Click an element. Different properties are displayed depending on the element type. 
 
This function is very helpful for measuring parameter values that rely on information from a 
drawing. You can click the parameter field and select [F2]. The result will be inserted directly into 
the parameter field. 

 
 

Redraw [Ctrl + R]  
 

 Toolbar: Standard 
 

CMD: VPREDRAW  
 
This option redraws the current display. 
 
 

Properties [F3] 
 

 Toolbar: Propterties/Editing 
 

Menu: Edit ► Properties  
 

CMD: VPPROPSHOW ► Dialog 
 
The properties dialog opens and displays the properties of the selected entity or the common 
properties of entities: 
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SECTION 4   
DOCUMENT SETTINGS, DOCUMENT FUNCTIONS 
  

Project Bar    
 

 Toolbar: Layers 
 

Menu: Options ► Project Bar  
 

CMD: VPPROJECTBAR  
 
This command opens the dialog window Project Bar: 
 

 
 
It displays the tree structure of all currently available layers and - as sub-entries to each layer - all 
loaded raster images. 
 
The Check Box in front of each layer or entry indicates the display status: visible or non-visible. 
Clicking on a check box toggles the display status of this entry. 
 

 The Color of each layer/entry is indicated by an according colored square.  
 This icon indicates the Color 7, which is black on a white background and white on a black 

background. 
 
The Draw Order can be changed by dragging (left click+move) a layer to a new position in the 
tree. On drop (release left mouse button) the layer will be inserted below the actual (highlighted) 
layer and the draw order will be re-arranged accordingly. The entities of the layer on top position 
of the tree will be drawn first, the entities of the layer on bottom position of the tree will be drawn 
last (its entities will be drawn above all other entities). 

 Raster Images will always be drawn first (below the vector entities). All new created entities 
will always be drawn on top, regardless of their layer position in the tree. 

 
Pressing the [Ctrl] key on drop will assign the dragged layer as sub-layer to the actual 
(highlighted) entry. This way families of layers can be arranged and then easily switched on and 
off together by clicking the checkbox of the main layer. 
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Dragging the name of a raster image changes the layer of this image. The [Ctrl] key has no 
function. 
 
On right mouse click inside the project bar dialog the following menu appears: 
 

 
 

Expand All Items 
Expands the view to display all sub-entries of each layer. 
 

Redraw 
The draw order of all entities will be re-arranged according to the actual tree structure and the 
document will be redrawn. 
 

All Layers On/Off 
All layers become visible/ invisible. 
 
 

Plot Style Settings  
 

Menu: Options ► Plots Style Settings... 
 

CMD: VPPLOTSTYLE ► Dialog 

 This command may also be started by the Plot Style View-Icon while the [Ctrl] is pressed. 

Plot style files are used to adjust colors and line width for printing and plotting. With Options 
Plot Style Settings the usage of plot style files can be configured. The following dialog will open: 

 
A general plot style file for all documents can be selected, created, or modified in the General 
Settings section. Valid plot style files are AutoCAD CTB files or VP generic RTB files. In case of 
CTB files the VP software will only interpret the color and line width information. 

Default: None 
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The Current Document Settings section shows the settings for the active document. When 
opening a DWG file which is linked to a CTB file, this CTB file (if found) is automatically loaded. 

 In case that the CTB file is not found in the directory of the DWG file or in the path for 
Support and SHX Font File as specified in the Systems Settings (see further down in this 
chapter) and Current File is set to Use default file, the default file is automatically loaded.  

When Show warning if plot style file is missing is activated a corresponding message 
will be displayed. 

Default: Use default file 
 

Create a new plotstyle file 

 Click this button to create a new plot style file. The Color Data dialog will open that allows to 
define for each color a Width and Print Color (see also chapter 4: Color Manager). The defined 
width values from the current document will be used. 

 
 
View / modify plot style file 

 The Color Data dialog will open with the specified Valued (Width and Print Color) from the 
selected plot style file (see also Chapter 4: Color Manager).  

 Changes can only be saved to the VP generic RTB format.  

When choosing a new file name for saving, the Default file or Current file is automatically 
updated.  
 
 

Modify Plot Style  
 

 
 

The dialog displays the colors from the loaded plot style file. A Width and a Print Color is 
assigned to each color. The settings may be modified for single or multiple selections of colors. 
With the width By Entity all entities of this color are displayed with their original width (width 
either from entity or the one specified in the layer settings)  
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Width and Print Colors can be loaded from and saved to plot style files. Use Load to import 
these values from a CTB or RTB file. With Save As… the current settings can be saved to a RTB 
file. 
 
With Save & Close the changes will be confirmed and saved to the selected plot style file. 

 In case the original plot style file is an AutoCAD CTB file, the Save as... dialog will open, 
since only the RTB format is supported for writing.  

 
 

Rotate View    
 

Rotate 90° 

 Toolbar: Rotate Views 
 

Menu: View ► Rotate View ► 90°  
 

CMD: VPROT90  
 
Rotates the overall view (raster, vector, and redlining entities) counter-clockwise by 90°. 
 

Rotate 180° 

 Toolbar: Rotate Views 
 

Menu: View ► Rotate View ► 180°  
 

CMD: VPROT180  
 
Rotates the overall view (raster, vector, and redlining entities) counter-clockwise by 180°. 
 

Rotate 270° 

  Toolbar: Rotate Views 
 

Menu: View ► Rotate View ► 270°  
 

CMD: VPROT270  
 
Rotates the overall view (raster, vector, and redlining entities) counter-clockwise by 270°. 
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Compare Revisions   
 

 Toolbar: Properties/Editing 
 

Menu: Edit ► Compare Revisions  
 

CMD: VPCOMPARE ► Dialog  

Compares the loaded file with a saved file and highlights the differences in content. The original 
file will not be modified by this. 
 
This function is only available when a file has already been loaded.  
 
On first start, the import dialog opens to load the second file (reference file) for comparison with 
the loaded file (original file). Content differences are displayed in different colors: 

 Background color Equal Only in original Only in reference 
 White Black Green Magenta 
 Black White Cyan Red 

While the Compare-View is active you can operate all other functions, but any action will only 
affect the original drawing. For example you can use the redlining functions to mark the 
differences or use the print command to plot the compare view. 

Right-click to open the context menu (left: reference file contains raster data, right: reference file 
contains vector data):  

   
Finish 

The program returns to the view of the original file. 
 

Load State 
Load a previously saved compare state (reference file and adjustments made, see below). 
 

Save State 
Save the current state (original file, reference file, and adjustments made) to continue at a later 
time. See also Load Compare State below.  
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Load new File to Compare 

The import dialog opens to select a new reference file. 
 

Move 
Move the reference file by selecting a source and target point. 

 
Adjust (2 Points) 

Move and scale the reference file by selecting two source and  target points. 
 

Adjust (3 Points) 
Move, scale, and rotate the reference file by selecting three source and target points. 
 

Adjust Vector Linewidth (only available if the reference file contains vector data) 
A dialog pops-up to set the display line width for all vector entities of the reference file: 
 

 
If the original drawing contains raster data, you can pick the new line width form the original 
drawing. 

 
Adjust Raster Width + (only available if the reference file contains raster data) 

Perform a one step dilatation (thickening) on the reference file. 
 

Adjust Raster Width - (only available if the reference file contains raster data) 
Perform a one step erosion (thinning) on the reference file. 
 
 
On closing the function, all information about the reference file and adjustment settings are stored. 
On restart, the previously specified file will be loaded and adjusted - the compare view is active. 
To compare the original file with a new file use the context menu. 
 
 

Load Compare State   
 

  Toolbar: Properties/Editing 
 

Menu: Edit ► Load Compare State  
 

CMD: VPCOMPLOAD ► Dialog  

Load a saved compare state. The original file and the reference file are loaded and all 
adjustments are made. If a file is already loaded, only the reference file is loaded.  

 Make sure that the original file and the reference file exist. 
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Attributes - General Information 
 
Attributes contain additional information directly linked to geometrical entities (raster and/or 
vector). This data can be used for certain information about the entity. For example, the attributes 
of a polygon representing a house placed on a piece of land may contain information about the 
address, the owner, the size, etc. The list of Attribute Fields assigned to the Layer of the entity 
defines the quantity and kinds of attributes. Attributes are compatible to other Geographical 
Information System (GIS) software packages; they can also be used for other purposes like 
Facility Management (FM).  
 
 

Attribute Bar  
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Show Attributes 
 

CMD: VPSHOWATTRIBS ► (Toolbar) 
 

The Attribute Bar allows to view the attribute data of an entity. If no entity is selected then the 
Attribute Bar displays the list of the attribute fields of the Active Layer.  
 

When several elements are selected their attribute values can be viewed simultaneously.  When 
selected elements contain different values in one or more attribute fields this will be indicated with 
the term “*VARIES*“  
 
 

Attribute Inspector  
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Inspector 
 

CMD: VPINSPECTOR ► (Select Entity)  

After starting the Inspector command, the Arrow and Question Mark Cursor appears. Move 
the cursor over an entity and remain there (for about half a second) until a tool tip with the 
attribute data of this entity appears.  
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Query Attributes (only Windows) 
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Query Attributes 
 

CMD: VPQUERYATTRIBUTES ► Dialog 
CMD: VPQUERYATTRIBUTES <QUERY> 

 
Query 

A complete SQL query to send to the database. If the query contains quotes like " or ' the query 
has to be quoted using `or ´ characters! 
 
Example: 
 

VPQUERYATTRIBUTES `SELECT * FROM "A Table" WHERE "Attr." LIKE '%Test'` 
 
The dialog Create/Run Query opens; depending on the last used tab – Simple Query or 
Advanced Query – this tab opens again: 
 
 

Simple Query 
 
This tab presents an easy way to find elements using standard queries. No knowledge of SQL is 
necessary to build a valid query which will be executed when pressing OK. 
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Search Attributes of Layer 

Specifies the layer where to search for attributes. 

Default: Active Layer  
 

Search Field 
A field can be specified using a combo box. All attributes of the selected layer are available as 
search fields. To show all values without filtering use the option Select All. A filter operator can 
be specified with Using Operator. Depending on the type of field there may be different 
operators in the combo box. Available operators are: 
 

LIKE (Text only) Equal text using % as a wildcard character. 
NOT LIKE (Text only) Unequal text using % as a wildcard character. 
< Less than 
<= Less than or equal 
> Greater than 
>= Greater than or equal 
= Equal 
!= Unequal 

Compare with Value is the operator’s parameter. 
 

Sorting 
Specifies how results will be sorted. You can choose no sorting with None, and Ascending or 
Descending for a specific attribute. 

Default: Ascending, First attribute of the layer 
 

SQL Query 
The generated SQL query is displayed as a reference here. 
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Advanced Query 

 
This tab presents a way for the experienced user to make arbitrary SQL queries which are 
supported by the underlaying SQLite database. For a complete description of the available SQL 
commands and the referring syntax please refer to http://www.sqlite.org/lang.html 
 

 
 

Query History 
The last 20 queries used. Double-click a query or select it and use the From History button to 
transfer it to the edit field SQL Query. With the latter it can be modified or reused. 
 

SQL Query 
The SQL query that shall be executed when clicking on OK. You can transfer a query from the 
Simple Query tab by pressing From Simple Query. Queries can be loaded and saved to text 
files using Load and Save. 

http://www.sqlite.org/lang.html
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To show the results, the dialog Attributes shows up: 
 

 
 
When clicking into a field - or selecting elements (rows or columns) - the zoom window is adjusted 
to display the corresponding elements. OK and Cancel close the dialog and keep elements with 
selected fields as the active selection. Print opens a print dialog to print attributes. 
 
 

Review Attributes 
 

 Toolbar: Attributes 
 

Menu: Vector ► Attributes ► Review Attributes 
 

CMD: VPREVIEWATTRIBUTES ► Dialog 

All attributes of the active layer are displayed in a dialog. When clicking into a field or selecting 
elements (rows or columns) the zoom window is adjusted to show the corresponding elements. . 
OK closes the dialog and keeps elements with selected fields as the active selection.  Print 
opens a print dialog to print attributes. 
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Snap Functions  
 

Drawing Aids [Shift]+[F8] 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Drawing Aids  
 

CMD: VPSNAPSETT ► Dialog 

A dialog box opens to specify settings for Grid, Snap to Coordinates, Ortho and Polar Snap, 
Vector Snap, Raster Snap and the Snap Modes. 
 

 
 
 

Raster Snap [F11] {on/off} 
 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Raster Snap  
 

CMD: VPSNAPR ► {on/off} 

Clicking this icon or using [F11] allows for switching the snap on or off. The raster snap operates 
on b/w, gray scale, and color images, where snapping occurs to the active color defined in 
Image Settings. The Snap Mode toolbar allows for activating snap modes. 

Default: off 
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Vector Snap [F12] {on/off} 

 

 Toolbar: Snap 
 

Menu: Options ► Snap ► Vector Snap  
 

CMD: VPSNAPV ► {on/off} 
 
Clicking this icon or using [F8] switches the snap on or off. The Snap Mode toolbar allows for 
activating snap modes. 

Default: off 
 

Snap Modes 
Whenever the Snap function (Raster Snap and Vector Snap) is activated, a toolbar opens for 
snap mode selection: 

 
Any of the eight available snap modes can be activated, even simultaneously: 

 Nearest snaps to the nearest point of an element 

 Intersection snaps to the nearest intersection of elements 

 End Point  snaps to the nearest end point of an element 

 Center  snaps to the center of the nearest circle or arc 

 Quadrant  snaps to a quadrant (0°, 90°, 180°, 270°) of the nearest circle or arc 

 Midpoint snaps to the nearest midpoint of an element 

 Perpendicular snaps to an element perpendicularly 

 Tangent snaps to an element tangentially 
 
The active mode can be changed clockwise to a different snap mode with [TAB]. The different 
snap modes are displayed with their symbols as listed in the dialog box.  
 
Use the selection boxes Marker Size and Marker Color to modify the symbols' display. 

Default: Marker Size : 6 pixels 
 Marker Color: Yellow 
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SECTION 5   
FILE MENU 

  

File Menu   
 
This menu manages the loading of raster and vector files. You can also print/plot hybrid (raster 
and/or vector) data and exit the program. 
 
All functions are in compliance with standard Windows conventions. Hence, descriptions will only 
be given in detail regarding differing functions or on those which are of high importance. 
 
 

Open [Ctrl + O]  
 

 Toolbar: Standard 
 

Menu: File ► Open 
 

CMD: VPOPEN ► Dialog  
 

CMD: VPOPEN <File Name> [P|Page <value>] 
 
When clicking this command a dialog box opens to select a file (raster, vector, or hybrid) for 
loading into a new document.  
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All supported files are displayed. When selecting a file the file information and a preview is 
shown if the function Preview is switched on and this file format provides a preview.  
 
The list of supported formats can be found in the Appendix.  
 
The selected file will be opened in a new document. Depending on the settings, a prototype 
drawing will be preloaded (see below). 

 
Multi Page Documents [P|Page <value>] 

For multi page files you can select to either open all pages or only a particular page (page no.).  

Default All pages 
 

Keep Document [k|Keep <0|1>] 
No new document is created when loading a file. Instead the content of the current document is 
cleared. Using this options with scripting or batch jobs can reduce memory consumption or 
overload. 

Default  0 
 

Prototype Drawing 
Shows the current prototype drawing. You may select a previous used prototype drawing from the 
drop-down list. The default prototype drawing is preselected. The drop-down list is disabled if the 
selected file format is a vector format. 
 
Use always allows to specify a prototype drawing for vector formats as well. This switch is equal 
to the one in Options ► System Settings..., Tab Files/Paths. 
Off:  Depending on the file format of the selected file the drop-down list is enabled or not. If 

enabled the selected prototype drawing will be preloaded. 
On:  The selected prototype drawing will always be preloaded. 
 
For more information about the prototype drawing see in Options ► System Settings..., Tab 
Files/Paths. 
 

Options 
Some file formats offer additional settings through the Options button. For more information see 
File Format Options below in this section.  

 The native VP format RVD replaces the formats VCF and VCI used in earlier VP products. 
However, input filters still allow for loading or importing those formats. 

 CGM: the import of raster is limited to uncompressed 1bit (b/w), 8bit (indexed color), 24bit 
(true color), and RLE compressed 1bit data. 
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Multiple File Selection  

 
When more than one file has been selected the following dialog appears to control how the 
individual files are going to be opened: 
 

 
 

• All files into one document  
All selected files are loaded as separate raster objects in one document 

• All files into one document, but to individual pages (Multipage)  
Creates a multi page document 

• One document for each file  
Opens each selected file as separate document 

 When operating under AutoCAD only the first option is available! 
 

Update Coordinate System  
 
When opening a raster file containing coordinate settings and placing information (e.g. TFW or 
GeoTIFF) a dialog will ask how to handle this information. 
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Update Coordinate System (UCS): The data of a TIFF file is used to update the coordinate 
system; the image is placed accordingly. 

Transform Data to current UCS Settings: The existing coordinate system remains unchanged; 
the insertion point’s coordinates of the image are transformed accordingly. 

Ignore Placing and UCS Information: The existing coordinate system remains unchanged - no 
transformation is performed; the image is inserted at the position (0,0). 

Default: Update Coordinate System (UCS) 

 
 

Browser  
 

 Toolbar: Browser 
 

Menu: File ► Browser 
 

CMD: VPBROWSER  

The following dialog opens: 

 
 

The Browser allows an easy way to open a new document by Drag & Drop or double click. 
Multipage documents display a folder symbol in the upper left corner. Double click will create a 
preview with all pages from the document.  
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The context menu command Browser Configuration offers additional settings for the Browser: 
 

 
 
 

Close 
 

Menu: File ► Close 
 

CMD: VPCLOSE 

Closes the active document. If the document has been modified a message will ask, if the 
modified file should be saved or not. 
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File Format Options 

 
Some file formats allow for setting additional parameters. The dialogs can be opened with the 
Options button in the Open dialog.  
 
The available options for file formats are described below. 
 

RVD Export Options  
For compatibility with older VP products the appropriate RVD file version can be selected. 

 
Default: VPHybridCAD V13/VPmap V6 

 Any RVD file version that is not the actual one may lead to a loss of data: e.g. the new 
Leader entity cannot be saved in any RVD-Version older than V13/V6. 

 
PDF Import Options  

PDF files can be imported as is on an object basis or as a single raster image. 

 
 

Read PDF Objects {on/off} 
The file is read on an object basis. 
 

Convert each page to a single raster image {on/off} 
The content of each page is read as a single raster image. With Resolution and the image type 
settings (Truecolor, Indexed, Gray Scale or B&W) the image can be further specified. 
 

Extract text objects {on/off} 
In case the file contains texts it will be preserved as individual objects.  
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DWG/DXF Import Options  

 

 
 

Layout Mode 
Determines which layout of the DWG / DXF file is to be loaded. You can either select the saved 
active layout or the standard model space. Alternatively, and prior to opening, a dialog can be 
displayed for individual layout selection (Show list with all available layouts), or to load all 
available layouts (Load all layouts (multipage mode). 

Default: Open drawing in saved layout 
 

Password Protected Files 
• Ask for the password on open  

On opening a password protected file the password has to be entered in a dialog. 

• Always use this password  
If many files use the same password it can be entered here for usage with all 
protected files. For safety it is saved in encrypted form. On opening a file no dialog 
is displayed. 

• Do not open password protected files 
Password protected files are not loaded. No dialogs or messages are displayed. 

Default: Ask for the password on open. 
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Convert drawing 

The display of DXF / DWG drawings may differ from the display in AutoCAD. This may occur e.g. 
with line types, text styles, or polylines with assigned widths and bulges. For a display more true 
to the original all entities may be converted into basic entities like lines, polylines, and splines on 
import.  

 The conversion is only advised if the drawing shall be rasterized. Since the conversion 
produces a large number of entities the import may take a very long time. 

Default: No conversion 
 

Line widths 
VPview uses absolute line widths, i.e. the display is independent of the zoom scale factor. With 
some drawings this may result in disproportionately thick entities. In this case use the option Set 
all line widths to 0.0. Alternatively, line widths may be adapted in the Layer Manager after 
loading. 

Default: Do not convert line widths 
 

Hatches 
Specify a directory where you want to search for hatch pattern styles. 

Default: \softelec\VPview V10\SUPPORT\ 
 

Character Set 
You can determine which character set should be applied on import of non-unicode text. Chose 
between Determine character set automatically (character set saved in the imported file) and 
Always use this character set (pre-defined character set). 

Default: Determine character set automatically 
 

Measurement 
You can determine which measuring unit will be used in the imported file. Automatic will assign 
the unit according to a previously imported file. 

Default: From file 
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DGN Import Options  

 

 
 

Model Mode 
Determines which DGN file model will be loaded. You can chose between the saved  active 
model and a permanent default model. You can also chose to display all available models for an 
individual model selection prior to opening (Show list with all available models). 

Default: Always load active model  
 

Linewidth 
VP Software uses absolute linewidth values, i.e. their display depends on the zoom stage. In 
some drawings this may lead to displaying disproportionate thick elements. In these cases you 
can use the option Set all linewidths to 0.0. All linewidth values can also be adjusted individually 
in the Layer Manager. 

Default: Scale linewidths by  10.0 
 

Scaling 
VP Software uses absolute length values for linetypes, i.e. their display depends on the zoom 
stage. In some drawings this may cause details to disappear from the display. In these cases you 
can change the scaling value accordingly. 

Default: Scale linetypes by 1.0 
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Convert Drawing 

The display of DGN files in VP software may differ from their display in MicroStation©. This may 
occur e.g. for linetypes, textstyles, or polylines with specific widths or curves. To ensure a proper 
display these elements can be converted to basic element structures, such as lines, polygons and 
arcs. 

 The conversion is only recommended if you want to rasterize the loaded DGN file. The 
conversion may also cause to generate very many basic elements. Thus, loading the file 
may take considerable more time. 

Default: No Conversion 
 
 

Save [Ctrl + S]  
 

 Toolbar: Standard 
 

Menu: File ► Save 
 

CMD: VPSAVE ► Dialog 
 

CMD: VPSAVE <File Name(s)>  
 
Saves the current drawing in VP's native format RVD. If you use this command the first time after 
loading a document, the Export dialog pops-up to ask for a file name. As Default the name of the 
opened file will be offered. Any future save of this file will automatically overwrite the previous 
save without any message.  
 

Preview 
You can switch the preview on or off. The preview displays the data which will be saved. 
 

Multi Page Document 
If your document is a multi page document you can save all pages into a multi page document or 
all pages into single files (i.e. each page into a separate file). The options All as multi page file 
is only available for specific file formats (e.g. TIFF + PDF). 
 
When saving multi page documents with the option As single files the software will prompt for a 
filename for each page. When using "%d" as part of the filename it will be replaced by the page 
count automatically. 
 
If you select Page No. "n", only this page will be saved into a separate file. 

 If you select/specify an already existing file (name) and this format supports multi page 
(e.g. TIFF + PDF), on Save you will be asked whether you want to override the existing file 
or append your current document as new page to the existing file. When Overwrite is 
selected only the modified pages will be replaced in the file. This happens only if no pages 
have been added, removed, or less than 30% have been modified. In all other cases the 
whole file will be written. Overwriting individual pages will increase the file size. To compact 
the file it is recommended to save it once in a while to a new filename.  
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Save As  

 

 Toolbar: Standard 
 

Menu: File ► Save as 
 

CMD: VPSAVEAS ► Dialog 
 
Similar function as Save, except that the dialog always opens for assigning a file name. 

 
 
Print [Ctrl + P]  

 

 Toolbar: Standard 
 

Menu: File ► Print 
 

CMD: VPPRINT ► Dialog 
CMD: VPPRINT [/VPP <VALUE>] [/P <VALUE>] [/FT|FROMTO <FROM PAGE> <TO PAGE>] 
 [/BW] [/MP] [/MR]  [/SLW] [/CW <VALUE>]  
 [/S|SCALING <SCALING><X-OFFSET><Y-OFFSET>] [/V|VIEW] 
 [/W] [/WIN|WINDOW <STARTX><STARTY><ENDX><ENDY>] [/C|COPIES <VALUE>] 

Any printer or plotter device installed under the operating system may be used for printing raster 
and/or vector data. However, the capability of processing raster data not only depends on the 
printer/plotter model, but also on the installed Windows drivers. A dialog box opens to determine 
scale, offset, paper format, and printing area. Raster and/or vector data can be selected for 
printing according to the monitor screen display. 
 

Using the command line: 
/vpp <value> Settings file (if set, all other values will be ignored) 
/p <value> Printer Name 
/f <value> Output Path 
/ft <value> Page Range to Print (negative values for active page) 
/bw  Print as Black&White 
/mp  Use Printer Driver 
/mr  Print as Image (Rasterize) 
/slw  Scale Line Widths 
/cw <value> Width Table File 
/s <value> Scaling and Offset 
/v  Print View 
/w  Whole Drawing 
/win <value> Window 
/c <value> Number of Copies 
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Without command line parameters, the printer dialog opens for selection and specification. When 
the command line is used the last used printer is selected: 
 

 
 
Select the Print Range and the number of Copies. Other options are: 
 

Extents 
Choose between Whole Drawing, Current View, or Window. For the latter check the button 
right to the Window option and set a window with two click points in the preview area. The 
selected window area will be displayed with a red frame. 

 
Printing Options 

Choose between Use Printer Driver (default setting) or Print as Image. If you encounter 
problems when printing hybrid data (i.e.. a mix of raster and vector data) or with large formats due 
to limitations of the standard printer driver use the option Print as Image. Then, VPview 
rasterizes all entities into a temporary plot file and sends this file to the printer/plotter. Use the 
option Print as Black&White to print color vector data on black&white printer with a better 
quality.  
 

Plot Style Definitions 
To control printing colors and line widths either the Layersettings for printing or a Plotstylefile 
may be specified. Supported plot style files are AutoCAD CTB or user generated RTB files. The 
settings can be reviewed and changed using the modify button. 
 
With the option Scale Linewidths vector linewidths will be printed with a scaling factor set in 
Scaling. Without this option linewidths will always be printed according to their settings. 
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Scaling 

Allows for arranging the image size according to user demands in terms of scaling and offset. 
With Fit Paper Size the selected Extents will be scaled to fill the entire paper space. Drawing 
Scale and Fixed Scaling will scale elements in the selected extents with the given factor or 
percentage. 
 

Preview Area 
The preview area’s display can be adjusted with the buttons on top of the dialog. A green frame 
display the printer’s current paper settings. The outer frame refers to the paper extents while the 
inner frame refers to the print space. When Fit Paper Size is switched off the paper extents 
position can be moved with the mouse. When releasing the mouse button the move values will be 
updated. The zoom factor can be changed with the mouse wheel. 
 

Save Settings 
Save the actual printing settings including the printer and its properties. The file format for print 
settings is VPP. 
 

Load Settings 
Load a previous saved print settings file (VPP). 
 
 

Print Preview 
 

Menu: File ► Print Preview 

The Preview option allows for previewing print results to support an accurate positioning. 
 
 

Print Setup 
 

 

CMD: VPPRINTSETUP ► Dialog 

A printer/plotter can be selected and activated. 
 
 

Exit  
 

Menu: File ► Exit 
 

CMD: VPEXIT 
 
Exits the program. 
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SECTION 6   
REDLINING 
  

General Information 
 
Redlining is a powerful feature to insert mark-ups into an existing drawing. These mark-ups can 
be used to highlight inaccuracies of the drawing, required modifications, or just any kind of 
information for other viewers, e.g. production process handling information, design remarks, etc. 
The redlining entities may be visible to all viewers or hidden at any time.  

In addition to the general redlining functions, VP software offers the possibility to restrict the 
access (view, modify, etc.) to these entities on a user/password basis (see Section 3 System 
Settings - Redlining Tab). 
 
 

 Redlining Functions 
 
The Redlining toolbar offers the following functions: 

• Activate/Deactivate Redlining Mode 
• Import Redlining Data 
• Export Redlining Data 
• Redlining Settings 
• Review Redlining Data 
• Delete Redlining Data 
• Insert Ellipse 
• Insert Cloud 
• Insert Arrow 
• Insert Transparent Rectangle 
• Pick Entity 

 
 

Activate Redlining 
 

 Toolbar: Redlining 
 

Menu: Redlining ► View Redlining 
 

CMD: VPRDLON 

Use this command to activate or close the Redlining functionality. Depending on the access 
rights (see Section 3 System Settings - Redlining Tab), a user will see all the redlining entities of 
that document, or some, or none. When access restrictions are set-up, the user will be prompted 
to enter a user name and a password for logon. 
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Redlining will be activated automatically by loading a drawing which contains redlining 
information. 
 
 

Import  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Import 
 

CMD: VPRDLIMPORT ► Dialog 
 

CMD: VPRDLIMPORT <File Name> 

Allows for importing redlining data from an RLF file. 
 
 

Export  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Export 
 

CMD: VPRDLEXPORT ► Dialog 
  

CMD: VPRDLEXPORT <File Name> 

Redlining data may be exported to RLF, RVD, DWG, DXF, DGN, or CGM file formats. Except for 
the native RVD format, only the redlining data will be exported! RLF is VP software's internal 
format for redlining data with access restriction information. 
Use the native RVD format if access restrictions have been set-up and the whole drawing, 
including redlining information, should be saved to an unrestricted file (e.g. to send the data to 
another party for reviewing). All other export formats will only contain the currently visible (see 
below) redlining entities. These are treated as blocks with attributes, separated on different layers 
depending on the way they have been created. 
 
 

Settings  
 

 Toolbar: Redlining 
 

Menu: Redlining ► Settings 
 

CMD: VPRDLSETTINGS ► Dialog 

Specifies the standard settings for the creation of redlining entities. A dialog opens containing two 
tabs. 
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General Tab 

 

 
 
Define Text Height, Arrow Size, Arc Radius (for cloud entities), and Opacity of the color for the 
redlining entities. Select the Color. These settings apply to the creation of new entities. 
 
Text Height and Color can be modified individually for each entity. 
 
 

Drawing Mode 
 

 
 

Cloud 
Select whether a rectangle or a polygon is to be drawn when drawing a cloud entity. 
 

Transparent Entity 
Select whether a rectangle or a polygon is to be drawn when drawing a transparent entity. 
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Pick Entities 

Select whether a picked polyline or polygon is converted to a cloud entity or a transparent entity.  

Specify, if the picked entity is to be deleted. 
 
 
 

Filter Tab 
 

 
 
Defines which redlining entities are displayed in the document depending on the user restrictions.  
 

Filter 
By Owner allows for displaying either the redlining mark-ups of: 

• All or  
• From: Selected creators.  

 
By Type allows the selection of the entities according to their status:  

• all entities,  
• revised entities,  
• not revised entities,  
• approved entities,  
• not approved entities. 
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Redlining Review  

 

 Toolbar: Redlining 
 

Menu: Redlining ► Review Redlining 
 

CMD: VPRDLREVIEW ► Moves to 1st redlining entity and opens redlining properties. 
 
Starts or continues the review of the redlining mark-ups. The program zooms in automatically on 
each redlining entity and displays the properties in a dialog box. Depending on the access rights 
the user may edit the text of each entity or revise/ approve the mark-up. 
 

 
 

Next, Previous 
Use Next to review the next redlining item and Previous to go back to the last entity reviewed.  
 

Stop 
Stop closes the dialog box. If the review function is called again it will start at the last item 
reviewed. The next entity of the list will be displayed. 

 
 
Delete Redlining Entities  

 

 Toolbar: Redlining 
 

Menu: Redlining ► Delete Redlining Entities 
 

CMD: VPRDLDELETE ► Select Entities. 
 
Deletes the selected redlining entities.  
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Insert Ellipse  

 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Ellipse 
 

CMD: VPRDLELLIPSE ► Requires 2 mouse clicks to define the position and size of the ellipse. 

Inserts a redlining entity with the shape of an ellipse. The size of the ellipse is adjustable in both 
directions by moving the mouse.  
 

Short Text, Comment 
On the second mouse click a dialog box opens to enter a Short Text (headline, which is 
permanently displayed with the entity) and a Comment for the entity. Text Height and Color for 
this entity may be modified from their default values (defined by the Redlining Settings). 
 

 
 
After pressing OK the Short Text can be placed on the drawing. 
 

 
Insert Cloud 

 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Cloud 
 

CMD: VPRDLCLOUD ► Draw a rectangle or polygon 

Inserts a cloud redlining entity. Depending on the drawing mode, a rectangle or a polygon entity 
will be drawn. Change the drawing mode in the settings or via the context menu. 

Same handling as Insert Ellipse. 
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Insert Arrow 

 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Arrow 
 

CMD: VPRDLARROW ► Requires one mouse clicks to define the position of the top of the arrow.  

Inserts a redlining entity with the shape of a pointing arrow. Same handling as Insert Ellipse. 
 
 

Insert Transparent Rectangle 
 

 Toolbar: Redlining 
 

Menu: Redlining ► Insert Transp. Rectangle 
 

CMD: VPRDLTRECT ► Draw a rectangle or polygon 
 
Inserts a transparent redlining entity. Depending on the drawing mode, a rectangle or a polygon 
entity will be drawn. Change the drawing mode in the settings or via the context menu. 
 
Same handling as Insert Ellipse. If required, use the Properties to modify the transparency. 
 
 

Pick Entity 
 

 Toolbar: Redlining 
 

Menu: Redlining ► Pick Entity 
 

CMD: VPRDLPICK ► Click on a vector entity (closed polylines/polygons or circles/ellipses only). 
 
Converts selected vector entities to redlining entities.  
 
Closed polylines and polygons will be converted to transparent entities or cloud entities, 
depending on the current settings (see also Settings - Drawing Mode). The drawing mode can 
also be changed via the context menu. Circles and Ellipses will be converted to ellipse entities. 
 
The picked entity will be deleted, if specified in the settings (default: on).  
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Redlining Configuration   
 
In some applications it may be of interest to limit the access of users with redlining.  
 
Imagine the following situation: A company has a support center which creates redlining mark-
ups (e.g. modification demands or improvement requests from customers) into an existing 
drawing. The support staff should only insert new entities, but not remove or modify items 
inserted by other employees. At a higher level a manager reviews these entities, and marks those 
as Revised which should actually go into re-design etc. Then, the "revised entities" are disabled 
from any modification. The draftsman in charge may modify the drawing according to the redlining 
mark-ups and their comments, but he may not modify the redlining or even remove the entities. At 
a final supervision level another manager checks the document modifications and compares them 
with the redlining mark-ups. He then approves the modifications checking Approved or he may 
erase these entities from the drawing if no further check or approval is necessary. 
 
To achieve this structure, restrictions can be set up for each user depending on his function 
inside the company hierarchy. Use the program RLCFG.EXE located on the CD in the directory 
\Redlining. Copy the program to any location on your hard disk. 
 
If the program is called the first time it will show the following dialog: 
 

 
 
Specify a path for the configuration file and press New to create a new configuration setting. If a 
configuration file has already been set up, just enter the path where it is located and press OK.  

 For proper operation of the Redlining Configuration file it is demanding that the 
administrator and all added users have read/write access rights to the location of the 
configuration file! 

 
After generation of a new configuration file only one user is available by default: the 
ADMINISTRATOR (no password). You can start to add and/or modify users and/or groups. On 
Exit the configuration file will be updated and saved.  

 When calling the program again a Logon and Administrator Rights are required to open 
the program. 
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Configure Redlining Users/User Groups 

 
The user management is similar to the one used with Windows NT/2000/XP. User Groups 
having specified rights may be created and Users may be assigned to the groups. A user can 
only be a member of one group and has the rights specified for that group! 
 
The following rights can be specified: 

• Admin All rights are assigned to an Administrator.  
This user can also create, modify, and delete users and groups. 

• View The user can only view (look at) the redlining entities and their properties. 

• Print The user can print the redlining entities. If this right is switched off, the 
redlining entities will not be printed even though the entities are displayed. 

• Export The user can export the redlining data to an unrestricted vector or hybrid 
file. 

• Create The user can create/add new entities. He is allow-ed to modify, edit, or 
erase these entities created by himself (he is the owner) until they are 
revised. 

• Modify The user can modify (move, change) any redlining entity which is not 
revised. 

• Edit The user can edit the text/comment of any redlining entity which is not 
revised. 

• Erase The user can erase any redlining entity. 

• Revise The user can set the 'revised' flag to an entity. 

• Approve The user can set the 'approved' flag to an entity. 

• No Rights User has no redlining rights at all.  
He will not even see redlining entities on a document. 

 
 

List Users 
 

 
 
Displays a list of all users, their groups, and access rights. 
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New User 

 

 
 
Creates a new user. Enter the user name and the password. Assign the user to any available 
group as a new member.  
 
 

Edit User 
 

 
 
Edits an existing user. You can modify his password or the group assignment. 
 
 

Delete User 
 

 
 

Deletes an existing user. 

 An error message appears if the last user or the ADMINISTRATOR should be deleted! This 
is not possible. 
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New Group 

 

 
 
Creates a new group. Specify a group name and the access rights for this group. 
 
 

Edit Group 
 

 
 
Edits an existing group. Modify the rights of that group. Any changes apply to all users of the 
group. 
 
 

Delete Group 
 

 
 
Deletes a group. A group can only be deleted if there are no users assigned to it! 
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SPECIFICATIONS    
 

Import Formats Raster See Appendix 
 Vector See Appendix 

Hybrid (Raster + Vector) See Appendix 
 
Raster Image Formats 

 
No real limitation: 16 million x 16 million pixels max 

 
General Functions 

 
Multi document interface 
Multi page documents 
Command line interface 
User coordinate system (user units, scale, origin) 
Measure: distance, angle 
Undo, redo, Redraw 
Properties 
Rotate view (90°, 180°, 270°) 
Compare Revisions 
View Attributes 

Graphical User Interface Command input via mouse, keyboard (command line) 
DDE/OLE interface 
Toolbars moveable and customizable 
Online help 

Graphical Display 
 

Graphical resolution according to OS and hardware 
ZOOM and PAN function 
Overlay of raster data and vectors 
Modification of presentation colors (foreground, cursor, 
background, grips, etc.) 

Plot, Print Whole drawing, current view, paper format 
Scaling: fit paper/custom scaling factor 
Raster data and/or vector data, selectable through layer 
settings. 
Preview 

Operating Systems Windows 7 or higher (32bit + 64bit) 

Recommended Hardware Windows 7 compatible PC (8 GB) or better 
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APPENDIX   
 

Supported Raster Formats 
 

Extension Format Name Black & White Color Multipage 
BIL GeoSPOT  ●  
BMP Windows Bitmap ● ●  
B4 Boeing EDMICS ●   
C4 EDMICS ●   
CAL, CG4, RST Cals Raster ●   
CIT, RLE, TG4 Intergraph ●   
CRL, COT Intergraph  ●  
DCX DCX Raster ● ● ● 
ECW, ERS ER Mapper ● ●  
FST, FF7, HD Landsat  ●  
G3, G4, RNL GTX Raster ●   
GIF Internet GIF ● ●  
GIS, LAN Erdas Raster  ●  
GOE NOAA GOES  ●  
GP4 Cals Raster ●   
GR4 ABB Group 4 ●   
HRF Hitachi Raster ●   
IDC Core IDC  ●  
IFF, ILBN Amiga IFF ● ●  
IG4, IGS Image Systems ● ●  
IM1 Sun Raster ●   
IM8 Sun Raster  ●  
JP2, J2K, J2C JPEG 2000  ●  
JPG, JPEG JPEG  ●  
MIL Cals ●   
NIF Navy TIFF ● ●  
OPT Optigraphics ●   
PDF Adobe PDF ● ● ● 
PNG PNG Raster ● ●  
PCX PCX Raster ● ●  
RAS Sun Raster ● ●  
RLC Image Systems ●   
RLC Xerox RLC ●   
RLN M.O.S.S. RLN ●   
SID LizardTech MrSID ● ●  
SUN Sun Raster ● ●  
TGA Targa Graphics ● ●  
TIF, TIFF TIFF Raster ● ● ● 
VIF ABB Raster ●   
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 Supported Vector Formats 
 

Extension Format Name Vector Hybrid (Raster + Vector) 
CGM Computer Graphics Metafile ● ● 
DGN Microstation Design File ● ● 
DWG AutoCAD ●  
DWG Raster-DWG ● ● 
DWT AutoCAD ●  
DXF AutoCAD ●  
E00 ESRI ●  
HP2, PLT, PRN HPGL/2 Plot File ●  
IGES 2-D IGES ●  
MIF MapInfo ●  
RVD Softelec Native Format ● ● 
SHP, GEN ESRI ●  
VCF Old Softelec Native Format ●  ● 
VCI Old Softelec Native Format ●  ● 

 
 
Individual Extensions for File Formats (Alias Extensions)  

 
VPview allows you to load and process files which were saved in one of the above file formats, 
however, with other extensions (e.g. files in the TIFF Raster format with the extension *.TR). In 
order to load and process these files you have to create a text file named VP.INI in your Windows 
directory (e.g. c:\windows) with the following content: 
 

[Import] 
<Alias Extension> = <File Description> (*.<Alias Extension>), 

*.<VP Extension> 
 
"Alias Extension" specifies the individual extension of a saved file. "VP Extension" specifies one 
of the standard VP file formats.  
Example: 
 

TR = My TIFF File (*.TR),*.TIF 
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Keyboard Shortcuts   

 
All keyboard shortcuts are listed in the menu next to their commands, too 
 

Function keys 
[F1] Help 
[Shift] + [F1]  Context Help  
[F2] Measure 
[F3] Properties 
[F4] Show / hide Raster 
[F5] Show / hide Vectors 
[Shift] + [F8]  Drawing Aids  
[F11] Vector Snap on/off 
[F12] Raster Snap on/off 
 

Cursor control keys 
[ ] Scroll up 
[ ] Scroll down 
[←] Scroll left 
[→] Scroll right 
[Shift] + [ ]  Page up 
[Shift] + [ ]  Page down 
[Shift] + [←]  Page left 
[Shift] + [→]  Page right 
 

Zoom functions 
[Mult] (Numeric keypad)  Zoom all 
[Div] (Numeric keypad) Zoom pixel 
[5] (Numeric keypad) Zoom window 
[Space] + left mouse button pressed  Pan dynamic 
 

Multipage functions 
[Pg Up] Previous page 
[Pg Dn] Next page 
[Home] First page 
[End] Last page 
 

Various functions 
[Ctrl] + [F] Quick select 
[Ctrl] + [N] New 
[Ctrl] + [O] Open 
[Ctrl] + [P] Print 
[Ctrl] + [R] Redraw 
[Ctrl] + [S] Save 
[Ctrl] + [Y] Redo 
[Ctrl] + [Z] Undo 
[Shift] + [Enter] Show / activate command line 
[Esc] Cancel 
[Alt] + [Backspace] Undo 
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Toolbars (overview) 
 

 Attributes 

 Browser 

 Coordinates 

 Layers 

 Page Control 

 Properties/Editing 

 Redlining 

 Rotate Views 

 Snap 

 Standard 

 View Bar 

 Zoom 
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DDE and OLE   
 
VPview features a Windows compliant DDE and OLE interface that allows other applications to 
communicate with it. This may be useful in conjunction with, for example, a database application, 
which manages files that can be viewed with VPview. Specifically, you can: 

1. Create a VPview object via OLE automation and execute commands on it.  
2. Establish a DDE link to VPview software to execute commands via DDE.  

 Note: You can not link or embed a VPview object in an OLE container application (OLE 
compound file)! 

 
To 1: OLE Automation capable programs (like Microsoft Excel) may create and operate 

on a 'VP.Document' object (OLE short name). The available automation functions 
are (written in C):  

 
long    GetProcessID (); 
short   Execute (BSTR pszCommand); 
long    GetDocumentCount (); 
BSTR    GetDocumentName (long lDocumentNumber); 
boolean CloseDocument (BSTR lpszDocument); 
long    ShowWindow (BSTR lpszDocument, long iShow); 
long    GetLastError (BSTR* pszErrorString, long lErrorLength); 

 
There's a type library called VP.TLB installed in the VPview directory, which can be read by 
software development tools (like Microsoft Visual C++). In this case, the function prototypes listed 
above will be automatically generated in your target language. 
 

To 2: The VPview software is a DDE server that accepts the start of a conversation with 
the following data:  

Application: VPview 
Topic: System 

 
The DDE interface can handle WM_DDE_EXECUTE commands with the following syntax: 
 

[command1][command2][command3]... 
 
Do not omit the brackets ('[...]')! This way, you can execute an unlimited number of commands at 
once. 
 
The commands that are available for DDE execution are all commands you can use from the 
command line of VPview. 
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Example, OLE via Visual Basic: 

 
Sub LoadWithVPOLE(strFile) 
 
    Dim strImp As String 
    Dim strExp As String 
    Dim VP As Object 
    Set VP = CreateObject("VP.Document") 
 
    strImp = "open " & Chr(34) & strFile & Chr(34) 
 
    VP.Execute (strImp) 
    VP.Execute ("exit") 
 
    MsgBox "File has been loaded with OLE!" 
 
End Sub 
 
The above Visual Basic program uses OLE to load a drawing. Only the most important command 
you can use with VPview and OLE has been used in this example: Execute. With Execute you 
can start all commands that are available via the command line. 
 
OLE generally works on invisible documents. There are two posssible scenarios: 1) The 
application is already started: OLE opens an new, but invisible document. 2) The application is 
not yet started: The application is started completely invisible. Thus OLE is restricted to batch 
processing. For interactive task you can use DDE. 
 

Example, DDE via Visual Basic: 
 
Private Sub LoadWithVPDDE(strFile) 
    Dim intChan 
    Dim strImp As String 
    Dim strExp As String 
 
    'Use System Topic to connect to VP 
    'VP must be running in order to connect 
 
    intChan = DDEInitiate("VPview", "System") 
 
    strImp = "[open " & Chr(34) & strFile & Chr(34) & "]" 
 
    DDEExecute intChan, strImp 
 
    MsgBox "File has been loaded with DDE!" 
 
    'Terminate DDE conversation 
    DDETerminate intChan 
 
End Sub 
 
The above Visual Basic program uses DDE to load a drawing. Note the square brackets, that 
must be used to encapsulate all commands. All commands you can start from the command line 
can be used. 
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