“Photo Editing for Beginners”

Using Paint.NET (for Windows)
Instructions for a two-session class taught by Dorothy Fitch
You will need to supply your own images for practice.
For a clean download of Paint.NET, go to www.ninite.com (it is listed under Imaging).
Session 1 of 2
About Paint.NET (from www.getpaint.net )
Paint.NET is free image and photo editing software for PCs that run Windows. It features an intuitive and innovative user
interface with support for layers, unlimited undo, special effects, and a wide variety of useful and powerful tools. An
active and growing online community provides friendly help, tutorials, and plugins. (Index available).
It started development as an undergraduate college senior design project mentored by Microsoft, and is currently being
maintained by some of the alumni that originally worked on it. Originally intended as a free replacement for the
Microsoft Paint software that comes with Windows, it has grown into a powerful yet simple image and photo editor
tool. It has been compared to other digital photo editing software packages such as Adobe® Photoshop®, Corel Paint
Shop Pro, Microsoft Photo Editor, and The GIMP.

Starting up Paint.NET
Tour of Paint.NET software: floating windows and menus
Opening a picture file
SAMPLE EXERCISES
1. Rotating an image – Paint.NET 1.jpg
Sometimes you need to rotate your camera (or phone)
to get the shot you want. The resulting saved image
needs to be rotated.

To rotate this image in Paint.NET, go to the Image menu and choose
‘Rotate 90° Counter-Clockwise’.
You can also flip an image horizontally or vertically.
Note that in Windows 10, you can rotate an image in File Explorer by
right-clicking the image and choosing ‘Rotate left’ or ‘Rotate right’. (See
image at right.)
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2. Resizing and changing resolution of an image – Paint.NET 2.jpg
How large are your pictures? Depending on your
camera’s settings, they may be very large in file size,
measured in megabytes (MB). You don’t want to
work with photos that size if you are just looking at
them on your computer or sending them to friends. If
you want to print a photo, then you will want its file
size to be as large as possible to give you the best
resolution (number of pixels or DPI, dots per inch).
To find out how large an image is, right-click the image in File Explorer
and choose Properties.

If you look at the lower left of the Paint.NET window, you can see how much of
the photo you are looking at. (Changing this value does not reduce the file size,
just how much of the image you see on the screen.)

To change the file size, choose ‘Resize…’ from the Image menu. You can
adjust the size by percentage, at the top, by pixel size and resolution, or
by print size.
You need a resolution of at least 300 DPI for printing. For viewing on a
computer, you need about 150 DPI. (The guideline used to be 72 DPI,
but monitors are now larger and have better resolution.) You’ll want to
reduce the size of your photos unless you are printing them.
To get a good size for this image for emailing, try reducing the ‘By
percentage’ to 12.

3. Cropping an image – Paint.NET 3.jpg
If you want to save just a portion of an
image, use the Rectangle Select tool (upper
left in the Tools window) to draw a
rectangle around the part of the picture
you want. Then choose ‘Crop to Selection’
from the Image menu.
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4. Straightening a picture – Paint.NET 4.jpg
Paint.NET has a Rotate tool that you can use to straighten
out an image that is crooked.
Choose ‘Rotate/Zoom…’ from the Layers menu. Drag the line
at the right of the circles to rotate the image until it is
straightened out.
You can also type in values in the text boxes.

You can then fill in the background by clicking the ‘Preserve background’
checkbox. Or, you can select a region for the picture to keep and choose
‘Crop to Selection’ from the Image menu. (Otherwise the checkerboard at
the corners will be white in the resulting image.)

5. Selecting a different shape – Paint.NET 6.jpg

There may be times when you want to crop someone out of a group picture, or make an
oval portrait. You can use the ‘Ellipse Select’ tool to do that.
After selecting the tool, move the mouse to the upper right of where you want to start
the ellipse, and drag to the lower right corner. Then choose ‘Crop to Selection’ from the
Image menu.
page 3

6. Sharpening a photo – Paint.NET 6.jpg
Sharpening a photo increases the contrast between light and dark along the edges.
To experiment with sharpness, choose
‘Sharpen…’ from the Effects>Photo menu.
Experiment with moving the slider to get the
result you want. You can also rotate the

keyboard and select just the keyboard portion of the photo.

7. Adjusting colors – Paint.NET images 7, 8, and 9

You may need to adjust the color of a photo to your liking. There are
several tools in Paint.NET for doing this.
The first way to try is to let Paint.NET suggest the best settings for the
image. Simply choose ‘Auto-Level’ from the Adjustments menu.
If you do not like those adjustments, choose ‘Brightness / Contrast…’ or
‘Hue / Saturation…’ from the same Adjustments menu. Change the
sliders in these options to experiment with color settings.
Another interesting effect is Vignette, in the Effects>Photo menu.
Use it to create a darkened “halo” around the edges of an image.
After using Auto-Level on the photo with the slice
of pie, use the Radius slider to adjust how big the
halo is, and the Center sliders to move the halo
area.

page 4

8. Coloring Fun – Paint.NET 10.jpg
When the grandkids come to visit, you can sit them down at
the computer and let them color using Paint.NET. You can find
lots of appropriate images online by googling “coloring book
pictures”. (Kids love to color pictures on the computer!)
The Colors window allows you to change the color that you
draw with the Paintbrush or fill with the Paint Bucket tools.
You can set a Primary color that is used when you leftclick an area and a Secondary color, which is used
when you right-click.
Select a color from the
standard colors at the
bottom of the Colors
window, or click a color
in the color wheel. If you want to get more
precise, click the More>> button.
Use the Paint Bucket tool to fill an area. Note the
small crosshair that indicates exactly what will be
filled when you click. Increase the Magnification to
see the location of the crosshair more clearly.
Have fun coloring!

9. Installing the software
On your DVD is the Paint.NET software, downloaded at the end of December 2017 from
Ninite.com. Ninite.com offers safe, clean downloads of software without extraneous add-ons
that you don’t want or need. Double click the icon for the installer on your DVD and it will
install Paint.NET on your computer.
The Computer Club recommends using Ninite.com to get software you want. There is a link
to Ninite from the Club’s Utilities page. Visit www.ninite.com for more information.
If you would like more information on how to install the software on your computer, I can walk you through
the process at the end of class.
About Session 2
In Session 2, in addition to exploring more ways to use Paint.NET with the sample photos and images, you can
bring in your own photo on a disc or memory stick, if you want help modifying it. No guarantees! You may also
bring in questions about Paint.NET after exploring the software on your own.
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“Photo Editing for Beginners”
Using Paint.NET (for Windows)
Instructions for a two-session class taught by Dorothy Fitch
Session 2 of 2
10. Saving a modified image
Open up any image on the disc. To save it with a new name, select ‘Save as…’ from the File menu.
Type a name of the file, replacing Untitled.
Browse to where you want to save the fike.
Choose a file format, then click the Save
button.
You can use the same filename, but I always
like to choose a different name, in case I
ever want to go back to the original photo.

11. Different graphics types
What are all those file types?
Each type of graphics file types has its purpose and there are pros and cons to each one. The spreadsheet on
the disc explains them in more detail. Here is the summary.
Type

Pros

Cons

JPG

-- most popular format used on the web
-- 24-bit color, with up to 16 million colors

-- discards data
-- after compression, JPEG tends to create artifacts
-- does not support transparency

PNG

-- no loss of quality and detail
-- small file sizes
-- supports transparency

-- cannot be animated

TIFF

-- high quality image format
-- no data loss

-- very large file size

GIF

-- supports transparency
-- can do small animation effects
-- no data loss

-- supports only 256 colors
-- oldest format, having existed since 1989; not updated
-- file size can be larger than PNG

BMP

-- works well with most Windows programs

-- does not scale or compress well
-- very huge image files, not web friendly
-- no real advantage over other image formats
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12. Making Paint.NET your default program for opening images
Depending on how much you want to use Paint.NET, you may wish to make it your default application for
image files. That means that whenever you double-click on a file, it automatically opens in Paint.NET. You can
change that setting at any time. To set Paint.NET as the default application, right-click the image, and select
‘Open with’. Then click ‘Choose another app’ and navigate to find Paint.NET and select it. In Windows 10, a list
of available graphics applications will appear and you can select Paint.NET.

13. Paint Tools
14. Removing the background with Magic Wand – Paint.NET 11.jpg

In some photos, it is possible to remove the background color. This cannot be done with all
photos. however.
To remove the background in the photo of the boy, first click ‘Magic Wand’ in the Tools
window. A Tolerance slider will appear at the top of the screen. (It is only available with
certain functions.) Use your mouse to set it to 25%.
Tolerance determines Paint.NET's sensitivity to differences in color. If you set the tolerance
level to 0, then Paint.NET selects only pixels that are exactly the same color as the one you
click on. As you increase the tolerance, Paint.NET selects colors that differ more significantly
from the selected pixels.
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Click in the gray area with the Magic Wand. It will outline the area that it selects. Then choose Cut from the
File menu (or press Ctrl+X or use the Delete key on the keyboard).

The checkerboard is not part of the image. It indicates a transparent background. If you save the image as a
.png, the transparent area will be retained, as shown below.

The first two images of the boy are both pngs. The last one is a jpg. As you can see, transparency is retained in
the pngs, but lost in the jpg. In the jpg, the background is not transparent; it is white.
Lesson: If you want to retain transparency, save the file as a .png
Another example: Paint.NET 12.jpg
Open the portrait of Abraham Lincoln. Even though this is a .png, it has a white background.
To remove the white background, do the following:
Click on the Magic Wand tool. Set the Tolerance to 34%
Click on the white background and press the Delete key (or Ctrl+X or Cut from File menu.)
You will have to select all three different areas of the white background to remove the color.
We’ll keep this image around to use later.
15. Layers – resizing the canvas and adding text: Images 11, 11b
Open the original image of the boy again. This time we are going to
add a caption.
To do this, we don’t want to tamper with the original photo. Instead
we will place the caption in a new layer.
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To add a caption, we will want to make the image larger, to make room for the text, fill in the background, and
them add text. Here’s how:
After opening the image of the boy, choose ‘Canvas Size…’
from the Image menu.

Change the picture height from 180 to 300.
Don’t check the box called ‘Maintain aspect ratio’.
That will make the picture area wider in addition to taller.
Move the image to the bottom of the new canvas:
To do this, choose ‘Select All’ from the Edit menu.
Click on the Move Selected Pixels tool (top arrow on right side).
Drag the image to the bottom of the canvas area.
Click the Rectangle Select tool (upper left in the Tools toolbar) and click anywhere in the gray
background to deselect everything.
Click the Color Picker tool.
Then select anywhere in the gray area of the photo,
above the boy’s head.
Click the Paint Bucket tool.
Then click in the “checkerboard” (transparent) area
above the boy’s head.
Next, choose ‘Add New Layer’ from the Layers menu.

You will see two layers in the Layers floating window. The check marks mean that
they are both visible. You can uncheck each one to hide it at any time. The layer with
the blue background is the one you are currently working with. Click another layer
to switch to a different one.
Click the Text button in the Tools window.
Make sure that Layer 2 is the active layer.
When the Text tool is selected, you can change the font, size,
and other text attributes. If you want to change the color of the text, click a color in
the Colors window.
Click anywhere in it and type the text you want.
To move the text, choose the Move Selected Pixels tool and drag the text to where you want it.
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When you are happy with the image, other than the fact that the canvas is too
large (we’ll fix that in a minute), select Layer 2. Click the ‘Merge Layer Down’
button at the bottom of the Layers window. (You can also choose ‘Flatten’ from
the Image menu to merge the layers.)
Now the text is part of the image.
To make the canvas area smaller, you can use the Select tool to select the area
you want. Click ‘Crop to Selection’ from the Image menu.
16. Pasting an image into a new layer – Paint.NET images 12 and 12b

You can use layers to combine two images. Click on the portrait of Lincoln. We removed the background from
that image earlier and it should still be open in Paint.NET. If not, open Paint.NET 12.jpg and remove the white
background (click the Magic Wand tool, click in a white area and press the Delete key).
Now, open the Paint.NET 12b, the Lincoln Memorial.
Return to the image of Lincoln. From the Edit menu, choose ‘Select All’ (or
press Ctrl+A), then ‘Copy’ (or press Ctrl+C). Click on the image of the Lincoln
Memorial. Choose ‘Paste into New Layer’ from the Edit menu. Choose to
expand the canvas, if asked.
Now Lincoln appears in the same image as his Memorial. However, the two
images are in two different layers. This makes it easy to manipulate them
separately.
The floating ‘Layers’ window at the lower right of the screen shows that Lincoln is in Layer 2; the Memorial is
in the Background Layer. To hide either layer, click the checkmark next to the Layer. To delete a Layer click the
red X. (Note that the Layer highlighted in blue is the one that will be deleted if you do that! To switch the
order of the layers, click the down arrow. To add a new Layer, click the first icon in the row. You can also copy
a layer, or flatten the layers (more about that in a minute).
If you want to move the portrait to a different location, click on
the portrait’s layer. Then select the area of the portrait. Click
the ‘Move Selected Pixels’ tool, the icon at the upper right of
the Tools window.
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Now you can move Lincoln
wherever you want
without disturbing the
Memorial background. You
can even resize or rotate
the portrait of Lincoln.

If you save the combined image, the file format with have a .pdn extension.
This is a special Paint.NET format for files that have layers. It is not a jpg or
png.
After you save a .pdn file, you can open it later and the layers will still be intact.
If you want a regular file format to work with, you can merge the layers. You
merge a layer down into the one below it. This allows you to merge layers
independently, as opposed to merging them all at once. To merge a layer
down, click the fourth icon at the bottom of the Layers window, or choose
‘Merge Layer Down’ from the Layers menu.

After merging, or flattening, the image, you can save it in any regular graphics format. However, when you
reopen that file, the layers will be lost. You can save the file in both .pdn and a .jpg formats.
17. Layers – annotating images: Paint.NET 5 and 14

Sometimes you might want to add marks or text on photos to explain them. You can do this by editing a
photograph or a map, for example. We’ll start with the Paint.NET 5 and add names of the people.
1. Open the image Paint.NET 5.
2. Add a layer so you can put the labels there. (That allows you to move them
around without disturbing the rest of the picture.) Click the first icon at the
bottom of the Layers window to add a layer.
3. Let’s start by adding a circle and arrow to point out the tour director (this was taken on a trip to Thailand).
page 11

4. To add your own marks, choose the Shapes tool, at the bottom of the Tools window.
5. Choose the shape you want to draw from the shapes drop-down
menu. (This screenshot shows Rectangle; your screen may show a
different shape.)
Note that you can also choose whether to fill in the shape, set the
Brush width, or how “fat” the line is for the shape outline, choose a
Style (dotted, dashed, or regular line), and pick a color for the filling
action.

Choose the color for the line as the Primary color in the Colors window.
6. Draw a mark in the new layer. You can see where it will appear. If you want to move it, select the area with the

Select tool. Then choose the ‘Move Selected Pixels’ tool, to the right of Rectangle Select. Use the mouse or the
arrow keys to move the selected areas. Because you are in a new layer, you are not affecting the background layer.

7. If you want to draw an arrow, choose the Line/Curve tool.

You can then change the width of the line and choose an
arrow from the Style dropdown at the top. When you draw
the arrow, start with the end of the line with the point.

As you can see, the Shape and Line tools have many options. Using Layers allows you to experiment with positioning
without modifying the map image.
To add text, use the Text tool, set the formatting (font, size, color, etc.) of the text, click where you want the text to go,
and type. If you want to move the text, follow the instructions in 6 above.

18. Using an image in another application (for example, Word)
There are a couple of ways to insert an image into Word.
1. Select the entire image in Paint.NET, copy it, and then paste it into a Word
document.
2. Insert a picture file into a Word document (in Word,
choose ‘Picture’ from the Insert menu).

Once the picture is in Word, regardless of how you
placed it there, you can resize it, move it around the document, wrap text
around it, add a border, etc. Right-click the image to see all the choices (see
image at right).
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19. Emailing an image
Similar options are available for sending an image by email. Remember that you don’t want to send someone
a large-sized file. Reduce the resolution and/or number of pixels in Paint.NET (see 2. Resizing and changing
resolution of an image).
Depending on your email program, you may be able to paste a copied image into the body of the email. You
can always add it as an attachment. After clicking that option, navigate to where you saved the image and
double-click it.
Now when you send the email, the recipient will have your image.
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