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1. Introduction 
 

Cloud PLC 4.0 series defines a new way of transforming factories into smart/intelligent factories 
for efficient and easy remote monitoring and controlling the operational status of facilities such 
as on/off status, pressure and temperature. Cloud PLC 4.0 supporting for custom programming 
and wide range of industrial protocols like Modbus, MQTT, JSON, RESTful, TCP/UDP, SNMP 
protocol, which makes the monitoring and solution integration, easier than ever for IT engineers 
through open source APIs. 

 

 

 
 

 

Cloud PLC 4.0 can used to build the custom industrial solution for monitoring and controlling PLC 

and SCADA, HMI, VFD, Motors, servo, Valves, energy meter, actuators, relays, encoder, RFID and 

fingerprint readers, and industrial sensors. 
 
 

 
 
 
 
 
 
 
 
 



    Cloud PLC 4.0                                                                                                                                          Document Version: Cloud PLC 4.0_V1.4 

 
 

                                                                                                                             5                                                  www.researchdesignlab.com 
 

 

2. Features 
 

o Digital IO 

o 24v 3x Isolated Digital output 

o 24v 3x Isolated Digital Input 

o Isolation: 3750VRMS  

o Analog IO 

o 8x ADC 0-10V/ 4-20mA max.  

o 10 / 16 bit ADC resolution 

o 3xDAC 0-10V 

o 1x 4-20ma TX 

o 3xADC 0-5v 

o Wired Connectivity 

o RS485 MODBUS, RS232 & USB  

o Ethernet 10/100Mbps, RDL 
Expansion Bus  

o Memory 

o FRAM 25KB, SD CARD 16GB  

o Wireless connectivity 

o Wi-Fi: 802.11 b/g/n/e/i (802.11n @ up to 150 Mbit/s) 

Bluetooth: v4.2 Bluetooth Low Energy (BLE) LoRa / Xbee, 
GPRS/GPS 

o RTC 

o Built-in RTC for stamped data logging   

o Protocol  

o TCP-IP, UDP, MODBUS, FTP, RESTFULL, JSON & MQTT  

o Security: SSL  

o Power supply 

o DC 12 - 24v 

o Enclouser 

o IP 20  

o mounting: Wall / DIN Rail  

o Dimension (LxWxH): 155x82x58.5   
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3. Benefits 
 

Cloud PLC 4.0 can used to build the custom industrial solution for monitoring and 

controlling PLC and SCADA, HMI, VFD, Motors, Servo, Valves, Energy meter, Actuators, 

relays, encoder , RFID and fingerprint readers, industrial sensors and many more with below 

mentioned operational benefits. 

 

o Simplified logging network as RDL Data Logger supports multiple features 

o Paper-less Production environment 

o Production count, rejections 

o Machine availability and Downtimes 

o Preventive maintenance 

o Performance Forecasting 

o Enable Management by IT 

 
4. Applications 

 
o Production and process monitoring. 

o Utilities monitoring. 

o Condition monitoring. 

o Environment monitoring. 

o Industrial Smart grid 

o Leakage detection. 

o Cold storage monitoring. 

o District metering. 

o Water treatment. 

o Generator monitoring. 

o Green House. 

o Warning message in case of calamities. 

o Standard SCADA Applications 
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5. Block Diagram 
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6. Pin-out 
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6.1 Pin Mapping: 
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7. Programming IDE 
 

The hardware supports various Open Source Programming IDE including Arduino IDE, Atmel 

Studio and Arduino Compatible Compiler for Lab View. For more information on this  follow 

“Open Source Programming IDE” section of the following link. 

 https://rdltech.in/cloud-plc-4-0 
 

 

8. Product Specification 

8.1. Digital Input 

 
Specification 

 
o Channels: 8 

o Input Voltage: 0-24V 

- Logic High: >11V 

- Logic Low: <3V 

o Isolation : 3750 VRMS 

o Supports Inverted DI Status 

o Supported Connection: Dry and Wet both 

o Maximum Frequency : 200Hz-38KHz 
 

Functional Diagram 
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Application Wiring 
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Use Case 
 

1. Measuring Frequency 
 

 

 

 

 

 

Example Code 
 

You may look into the following link for example on reading a digital pin. 

https://www.arduino.cc/reference/en/language/functions/digital-io/digitalread/ 

8.2. Digital Output 

 
Specification 

 
o Channels: 3 

o Open Collector 

o Isolation : 3750 VRMS 

o Absolute maximum voltage - 35V, Current - 100mA 

o Cut-Off Frequency : 10KHz 
 

Functional Diagram 
 

 

 
 
 

 
 

 
 

 
 

 

https://www.arduino.cc/reference/en/language/functions/digital-io/digitalwrite/
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Application Wiring 
 
 

 

 

Example Code 

 
You may look into the following link for more details on writing to digital pin 

 

https://www.arduino.cc/en/Reference.digitalWrite 
 

8.3. Analog Input 

 
Specification 

 
o Channels: 8+3 

Group 1: 

o Channel : 4 

o Input : Voltage(0-10V) / Current(4-20mA) 

o Resolution : 16 bits 

o Sampling Rate – 860 sample/sec 

https://www.arduino.cc/en/Reference.digitalWrite
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Group 2: 

o Channel : 4 
o Input : Voltage(0-10V) / Current(4-20mA) 

o Resolution : 10 bits 

o Sampling Rate – 9.6KHz [13 clocks] 
 
 

 
 

Group 3: 

o Channel : 3 

o Input : Voltage(0-5V) 

o Resolution : 10 bits 

o Sampling Rate – 9.6KHz (13 clocks) 
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Application Wiring 

 
1.  Interfacing ADC with Sensor 

 

 

 
 

 

 

 

 
 
 

Example Code 
 

You may look into the following link for more details on reading analog pin.   

https://www.arduino.cc/en/Tutorial/ReadAnalogVoltage#toc5

ATTENTION: When an ADC Channel is configured for measuring loop 

current, voltage source should never be given to the 

channel. If given, damage could happen to the internal 

circuitry or external device connected to it. 

 

https://www.arduino.cc/en/Tutorial/ReadAnalogVoltage%23toc5
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8.4. SD Card 

 
Specification 

 

o SPI Serial Interface 
o Supports Fat File system 

 
Functional Diagram 

 

 
Example Code 

 
You may look into the following link for example on SD Card. 

https://www.arduino.cc/en/Reference/SD 

 

8.5. RTC 
 
Specification 

 

o DS1307 with I2C Serial Interface 

o Counts Seconds, Minutes, Hours, Date, Month, Day, and Year with Leap-Year 

Compensation. 

o 56-Byte, Battery-Backed, NV RAM for Data Storage 

o Consumes <500nA in Battery Backup Mode with Oscillator Running 
 

Functional Diagram 
 
 

https://www.arduino.cc/en/Reference/SD
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Example Code 

 
You may look into the following link for example code on RTC. 

 

https://www.arduino.cc/en/Reference/RTC 
 

 

8.6. FRAM 

 
FRAM is specifically used for applications such as production counting, 

production rejection where variable subjected to continuous write cycle 

 

Specification 
 

o MB85RC256V, I2C compatible with Bit configuration : 32,768 words × 8 bits 

o Operating frequency : 1 MHz (Max) 

o Read/write endurance : 1012 times / byte 

o Number of write cycles: 100 Trillion times 

o Operating power supply voltage : 2.7V to 5.5V, current 200 μA 

o Data Retention: 10 years (+85°C), 95 years (+55°C), over 200 years  (+35°C). 
 

Functional Diagram 
 
 

 
Example Code 

 
You may look into the following link for example on RTC 

 
                                 https://github.com/adafruit/Adafruit_FRAM_I2C/blob/master/examples/MB85RC256 V/MB85RC256V.ino

https://www.arduino.cc/en/Reference/RTC
https://github.com/adafruit/Adafruit_FRAM_I2C/blob/master/examples/MB85RC256V/MB85RC256V.ino
https://github.com/adafruit/Adafruit_FRAM_I2C/blob/master/examples/MB85RC256V/MB85RC256V.ino
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8.7. PWDT (Physical Watch Dog Timer) 

 
External physical watchdog is connected along with inbuilt watchdog timer. There 

are many instances where we need to set watch dog time for more than 8 seconds 

(typically bulk file upload takes in minutes). As inbuilt WDT is limited to maximum 

of 8Sec, we have gone a step further to support watch dog time up to 3 minutes. 

 

 
 

Specification 

 
o PWDT supports up to 3minutes. 

o PIC12F1840 used for PWDT 

o Refresh time : 1 pulse in every 3 minutes 

o Operating temperature range: –40 to 125 °C 

 

Functional Diagram 
 

 

 

 
Example Code 

 
You may look into the following link for examples on watchdog timer. 

https://folk.uio.no/jeanra/Microelectronics/ArduinoWatchdog.html 

ATTENTION: User must program PWDT to refresh before the timer (3 min) 
expires. 

 

https://folk.uio.no/jeanra/Microelectronics/ArduinoWatchdog.html
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8.8. Flash 

 
Flash is specifically used for embedded server. 

 
Specification 

 

o SST25VF080B - SPI Compatible: Mode 0 and Mode 3 

o Memory: 8MBit 

o High Speed Clock Frequency – 50 MHz 

o Single Voltage Read and Write Operations – 2.7-3.6V 

o Endurance: 100,000 Cycles (typical) – >100 years Data Retention 

o Low Power Consumption: – Active Read Current: 10 mA (typical) 
o Flexible Erase Capability – Uniform 4KB, 32KB overlay blocks and 64KB 

overlay blocks 

o Software Write Protection 
 

Functional Diagram 
 
 

 

 
Example Code 

 
You may look into the following link for example on how to use flash.  

 

https://github.com/nullboundary/SST25VF 

https://github.com/nullboundary/SST25VF
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8.9. Ethernet 

 
Ethernet is specifically used for establishing secured physical network 

connectivity with local network infrastructure 

 

Specification 
 

o W5500 IC with SPI serial interface 

o IEEE 802.3 Gigabit Ethernet Compliant 

o Communication protocols: TCP/IP, HTTP, FTP, MQTT, UDP,JSON…. 

o 3.3V operation with 5V I/O signal tolerance 

o Low Power Consumption <200mW at 1.25Gbps. 
 

Functional Diagram 

 

 
 

Use Case 
 

 

 
 
 

 
 

 
 

 
 

 

 
Example Code 

 
You may look into the following link for examples on Ethernet. 

https://www.arduino.cc/en/Reference/Ethernet 

https://www.arduino.cc/en/Reference/Ethernet
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8.10. ESP32/XBEE/LoRA/RS485 

 
This is Add-On pluggable module. One among ESP32, XBEE, LoRA or RS485 is 
comes with the product. For more details on this, look into Order Information 

Table. 
 

This is specifically used for wireless connectivity with existing infrastructure. 
 

Functional Diagram 
 

 

 
Use Case 

 

1. Interfacing Industrial Cloud PLC with Bluetooth 
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2. Interfacing Industrial Cloud PLC with LoRA 
 

 

 
 

 

3. Interfacing Industrial Cloud PLC with Xbee 
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4. Interfacing Industrial Cloud PLC with Wi-Fi (ESP32) 
 

 

 
 

 
 
 

 
 
 
 
 
 
 

 
 

 
 

Example Code 

 
You may look into the following link for examples on esp8266. 

https://www.arduino.cc/en/Reference/WiFiServer 

 

8.11. GSM/GPRS 
 

This is specifically used for M2M and remote data logging and control 

applications. 
 

Specification 
 

o Quectel M95, Quad-Band 850/900/1800/1900MHz. 
o Serial interface for direct communication with PC or MCU. 
o Configurable baud rate. 
o Power controlled using 29302WU IC. 
o ESD Compliance. 
o Enabled with Audio jack. 
o With push pull SIM card holder. 
o With Stub antenna and SMA connector. 

https://www.arduino.cc/en/Reference/WiFiServer


    Cloud PLC 4.0                                                                                                                                          Document Version: Cloud PLC 4.0_V1.4 

 
 

                                                                                                                              27                                                www.researchdesignlab.com 
 

 

Functional Diagram 
 
 

 
Use Case 

 
 

 

 
 
 

 
 
 
 
 
 
 
 
 

 
Example Code 

 
You may look into the following link for examples on GSM. 

https://www.arduino.cc/en/Tutorial/GSMExamplesSendSMS 

https://www.arduino.cc/en/Tutorial/GSMExamplesSendSMS
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8.12. RS485 Modbus 

 
o Modbus is an Industrial standard serial communication protocol. 

o Open protocol 

o Information is stored in the Slave device in four different tables. 
Two tables store on/off discrete values (coils) and two store numerical 

values (registers). The coils and registers each have a read-only table and 
read-write table. 

o Each table has 9999 values. 
Each coil or contact is 1 bit and assigned a data address between 0000-270E. 
Each register is 1 word = 16 bits = 2 bytes and also has data address between 
0000 and 270E. 

o Supported Functions are 

- Coils 

- Discrete inputs 

- Input Registers 

- Holding Registers. 
 

Specification 
 

o LTC485 IC. 

o Supports slave address up to 32. 

o Supports Modbus protocol with RTU and ASCII formats. 

o Configurable baud rate from 4800 to 115200. 

o Configurable packet format (data bits, parity bit, stop bits) 

 
Functional Diagram 
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Use Case 
 

 

 
 
 

 
 
 
 
 
 
 

 
 

 
 

 
 

 
 

 
 
 

 

Example Code 
 

You may look into the following link for examples on Modbus examples. 

https://playground.arduino.cc/Code/ModbusMaster 

https://playground.arduino.cc/Code/ModbusMaster
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8.13. RS232/FT232/Program 

 
Used for programming the board. When in user mode, the port could be used for data 

communication. 

 

Functional Diagram 
 

 

 

 

 

 

Example Code 

 
You may look into the following link for examples on FT232/MAX232 serial 

communication. 

https://www.arduino.cc/reference/en/language/functions/communication/serial/  

https://www.arduino.cc/en/Tutorial/SoftwareSerialExample 

ATTENTION: When programming the board, it is recommended to remove any 

connection made to the RS232 serial pins in order to ensure 

proper functioning of the system. 

 

https://www.arduino.cc/reference/en/language/functions/communication/serial/
https://www.arduino.cc/en/Tutorial/SoftwareSerialExample
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8.14. DAC 

 
Specification 

 

o MCP4768 with I2C serial interface 

o Quad, 12-bit voltage output 

o Channel: 4 (buffered outputs) 

o Internal Voltage Reference 

o Output Voltage Range using 0-10V 

 
Functional Diagram 

 

 

 
 
 
 
Application Wiring 

1. Interfacing DAC with Motor Speed Control Module 
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2. Interfacing DAC with Motor Speed Control Module using Loop Current 
 

 

 
 
 

Use Case 
 

1.  Motion Control 2. Acceleration and Deceleration 
 

 

3. Jog Operation and Trapezoidal Control Operation 

 
Example Code 

 
You may look into the following link for the Arduino library and example on DAC. 

 
https://github.com/hideakitai/MCP4728 

https://github.com/hideakitai/MCP4728
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8.15. Status LED Display 

 
Status LED’s can be programmed as per used needs for visual indication of an event.  

Refer Digital Output Section 

Functional Diagram 
 

 

 

Example Code 

 
You may look into the following link for more details on programming LED pins.  

 

https://www.arduino.cc/en/Reference.digitalWrite 
 

8.16.  Membrane Keypad 

 

 
                                              Example Code 

 
You may look into the following link for example on reading a digital pin. 

https://www.arduino.cc/reference/en/language/functions/digital-io/digitalread/

https://www.arduino.cc/en/Reference.digitalWrite
https://www.arduino.cc/reference/en/language/functions/digital-io/digitalread/
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8.17. RDL Bus 

 
Specification 

 

o Extend I/O pins for communicating with external devices. 

o Extends SPI pins, I2C pins, UART pins and Digital I/O pins. 
 

Functional Diagram 
 

 

 
Application Wiring 
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9. Boot Load Instructions: 

Cloud PLC supports multiple open source IDE for programming , you can choose any one of the 
below given method to build the custom programming/solution. 

9.1  Using USBASP AVR Programmer  
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Burn Bootloader into Cloud PLC 

STEP 1: Open SinaProg 2.1 Software, Click on Search command, you get searching OK  

 

 

STEP 2: Click on Advanced to  set the fuse bits  Lock bits 3F High Fuse D8 Low Fuse FF Ext Fuse 
FD 

 
STEP 3: Click on Write 

STEP 4: Go to Tools > Board and choose “Arduino/Genuino Mega or Mega2560 ” as the 
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board of the target  

 

 

 

STEP 5: firstly we select “USBasp” from the Programmer 

 

 
STEP 6: After that, click on “Burn Bootloader” from the Tools menu 



    Cloud PLC 4.0                                                                                                                                          Document Version: Cloud PLC 4.0_V1.4 

 
 

                                                                                                                                    38                                        www.researchdesignlab.com 
 

 

 

 

Arduino IDE will display “Done burning bootloader” when it is done.  
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9.2 Using Atmega328 

 

 

 

Burn Bootloader into Cloud PLC 

STEP 1: An ISP (In-system programming) programmer is needed to burn bootloader. In this we 
will use a Cloud PLC  as an ISP programmer. To prepare Cloud PLC   as ISP programmer, firstly 

we select “ArduinoISP” from the File > Examples menu.  
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STEP 2: Select the Board Arduino/GenuinoUno 
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STEP 3: the Port 

 

 

STEP 4: Verify and upload the code 
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STEP 5:Once the code is uploaded, do the wiring up, go to Tools > Board and choose 
“Arduino/Genuino Mega or Mega2560 ” as the board of the target . 

 

 

 

 

STEP 6: After that, click on “Burn Bootloader” from the Tools menu, the ISP programmer 
will start to burn the bootloader into the target Arduino. It usually takes few minute to 
complete burning bootloader. 
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STEP 7: Arduino IDE will display “Done burning bootloader” when it is done.  
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9.3 Writing the Code-Atmel Studio 

 

 

 

 

 

 

 

 

 

 

                 Step 1: Open Atmel Studio, go to file  new project.  
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                                         Step 2: In new project, type the desired file name and click on browse.  
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

     

             Step 3: Go to desktop Create new folder Select Folder, press OK. 
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                                        Step 4: Select the device as ATmega 2560 and click on OK. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 
Step 5: Copy and paste the program and save, go to build  build solution, to check for       
errors in program 
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    Step 6: If your program has no errors it will show the build window as shown below.  
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10. Power Supply 

 
Model Input Voltage Vmin Vmax 

7000 - 7009 12V - 36V 12V 30V 

                                    
 
 

                                      ATTENTION: Recommended to use Meanwell power supplies of  24V 2A  
 
 
 
 

11. Order Information Table 
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12. Mounting and Mechanical Dimensions 
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