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SOFTWARE COPYRIGHT AND LICENSE AGREEMENT 
 

Grant of Limited License  
 

softelec gmbh (hereafter called softelec) grants a limited, non-exclusive right to use the software installed on computers (PC's) - workstations or a 
network server. In addition, softelec grants the right to only one (1) user or - in the event of network licenses - to the number of user stated in the 
network license agreement to activate and use the software at any one time once the user of the software has registered with softelec and thereafter 
received the corresponding authorization code. The license(s) and thereby the value of the purchased software product(s) is personified in the 
delivered hardlock. If a hardlock gets lost or stolen softelec will only deliver a new hardlock at full cost of the initially purchased software. softelec 
strongly recommends to insure the hardlock with the value of the purchase software to protect the investment. This limited, non-exclusive license 
agreement supercedes any other previous released agreement unless granted in writing and signed by softelec. 
 

For the demonstration version of the software, unlimited multiple installations are permissible. 
 

Copyright 
 

The contents of the software (recorded on CD's) and the associated manuals are the sole property of softelec and are protected by applicable 
copyright laws. This software may not be multiplied, copied, altered, decrypted, decompiled, changed, or disassembled in any manner without written 
authorization from softelec. A single backup copy is authorized. The user agrees not to transfer title of this software at any one time without first 
notifying softelec. All rights are reserved. No part of the manuals may be reproduced, transmitted, transcribed, stored on a retrieval system or 
translated into any language or computer language, in any form or means, electronic, mechanical, magnetic, optical, chemical, manual, or otherwise 
without the express written consent of softelec as punishable by applicable copyright laws. softelec is registered licensee of SZKI Recognita AG 
(OCR) for the use exclusively with VP products.  
 

The use of this software constitutes agreement to the terms said herein. If you do not agree with the terms of this agreement - DO NOT OPEN AND 
INSTALL THE SOFTWARE, promptly return the software, including manuals, binders, hardware lock key, written material, and containers to the 
location from which you obtained them for refund. 
 

Terms 
 

This license agreement becomes effective on the day of purchase and remains in full force until termination. softelec may terminate the license in the 
case the purchaser fails to comply with any of the terms and conditions of this agreement. The purchaser may terminate the license agreement at any 
time by returning the complete software (recorded on diskettes and/or CD's), including manuals, binders, hardlock key, written material, and containers. 
 

Disclaimer 
 

softelec reserves the right to modify the hardlock key, the manuals and/or the associated software at any time, particularly with the intent of further 
development, and undertakes no guarantee to issue notification of modifications, additions, or further developments; nor does the company obligate 
itself to implement such modifications, additions, or further developments in earlier versions of the manual or the software. Any such modifications are 
considered upgrades in which the registered license holder shall have the option to purchase. The license holder is granted the right to obtain license 
upgrades at no extra costs which become available within a maximum of 90 days after the date of his written purchase order. 
 
 

Limited Warranty 
 

softelec warrants that the media containing the software is free from defects in material and workmanship. This limited warranty is valid for a period of 
ninety (90) days from the date of delivery as evidenced by a copy of receipt, provided any faults or defects that may, in spite of the care taken in 
manufacture, become apparent are reported to softelec within thirty (30) days of their occurrence. The only entitlement granted by this warranty is 
repair or replacement of the supplied product at the sole discretion of softelec. Regardless of the nature of any damage or loss in any way connected 
with the software, sole and exclusive liability to be borne by softelec shall not exceed the purchase price of the product.  
 

This program is provided "as is". softelec specifically disclaims all other warranties, expressed or implied, including but not limited to 
implied warranties for merchantability and fitness for a particular purpose with respect to defects in the CD, diskette, hardlock, or 
documentation, and the software license granted herein in particular, and without limiting operation of the software license with respect to 
any particular application, use or purpose. In no event shall softelec be liable for any loss of profit or any other commercial damage, 
including but not limited to special, incidental, consequential or other damages.  
 

Legal Action 
 

This agreement shall be construed, interpreted, and governed by the laws of the Federal Republic of Germany. Venue for any cause of legal 
actions shall be in the city of Munich.  
 

Trademarks 
 

Windows and its derivations are registered trademarks of Microsoft Corporation. AutoCAD and RasterDWG are registered trademarks of Autodesk, 
Inc. Other registered product names are proprietary to their respective owners.  
 

softelec logo, Greek head design, VPHybridCAD, VPstudio, VPmap, VPmax, VPlite, VPraster, VPindex, VPview are registered trademarks of 
softelec gmbh.  
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INTRODUCTION 
 

Welcome 
 
Congratulations to your purchase of a VP software product from softelec, the leading 
specialist in hybrid (raster and vector) editing, color management, and raster-to-vector 
conversion! For a better orientation you will find your specific VP software product listed 
below. It is part of one of the major product lines: 
 
VPHybridCAD V16: VPstudio, VPstudio mono, VPlite, VPraster, VPraster edit 
 

VPmap Series V9: VPmap pro, VPmap 
 

VPindex V9: VPindex, VPindex lite 
 
For simplification the term VP software is used in this Tutorial when general references apply 
to any product of the product lines. 
 
Since its introduction in 1990, VP software products have been constantly improved on quality 
and productivity. New algorithms and programming techniques have resulted in extraordinary 
quality improvements, outstanding features, unique functions, needle pegging conversion 
speeds, and convincing user friendliness. softelec’s own VP software technology guarantees 
that you are obtaining the finest in professional products for your scanning, archiving, raster 
and vector editing, or conversion tasks for all applications in CAD/CAM, AEC, FM, or GIS.  
 
The latest VP software versions again enclose significant improvements and enhancements. 
These are designed to further extend application ranges and productivity in your CAD, GIS, or 
archiving system environment. We hope to meet your requirements in the best way, and we 
do wish you a successful work with your VP software! 
 
 

How to Get Started with the Tutorial 
 
This Tutorial has been designed to guide and teach you how to use the numerous functions 
of VP software. We also refer you to the Reference Manual (VPHybridCAD / VPmap Series 
or VPindex) for detailed descriptions of all available functions. Also, the content of the Tutorial 
and the Reference Manual are available online in the software (help and tutorial). 
 
Information on how to install a VP software product on your PC locally or for network 
operation can be found in the Reference Manual and in this volume in the section 
Installation. 
 
We recommend that you complete all of the Tutorial's exercises relevant to you. Otherwise 
you may not be able to appreciate the whole range of capabilities of your VP software product. 
In each lesson it is indicated for which VP software products the described functions are 
available.  
 



 VP Software Tutorial 

2   Introduction Tutorial V16 - V9 / E
 

 
Please review the product matrix at the beginning of each lesson. When filled, the marks in 
front of a product name indicate the availability of the described function for a specific product. 
When not filled or greyed (Online Help), the described function is not available in the 
respective product: 
 

 
 
Start with the first lesson where general basics on handling and editing of image files are 
explained. All other lessons often may assume a general knowledge of these basics and are 
meant to guide you step by step through all major functions and applicational details. Also. 
there is more information on all functions in the Reference Manual. 
 
For latest information on updates and product news visit the softelec website at: 

www.softelec.com. 
 

Using VP Software with or without AutoCAD/BricsCAD/ZWCAD 
Descriptions referring to using VP software in "stand-alone" mode (Windows) or to using it 
with AutoCAD, BricsCAD, or ZWCAD are marked accordingly, e.g. VP-WIN, VP-CAD, CAD. 

 Other than VPHybridCAD and VPmap Series products, VPindex products are not available 
as applications inside a CAD program. Thus, only those descriptions marked with „VP-WIN“ 
are valid for VPindex or VPindex lite while all references to CAD can be ignored. 

 
Demo Version 

With the default Demo Version of VP software you cannot Save or Export your results. 
However, all lessons can be completed. This has no influence on the lessons themselves. If 
you need to export some results for a compatibility check with other software, please ask for a 
14-day Trial-License (see Options ► System Settings… ► Tab License). 
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The Lessons - an Overview 
 

Lesson 1 Editing Raster Files 
 

 1.1 Basic Functions 
A raster file is going to be cleaned up. Use the following methods: 

• Load Raster Files 
• Deskew/Align 
• Despeckle 
• Mirror 
• Save/Export Raster Files 

 
 1.2 Enhanced Functions 

The quality of a raster file should be improved with the morphology method, after 
that the file is going to be scaled. Functions used in this lesson: 

• Morphology 
• Scaling 

 
Lesson 2 Raster Entities and Raster Objects 

 

 2.1 Raster Entity Editing 
Edit parts of a raster file using the following methods: 

• Raster Selection 
• Pick Selection of Raster Entities 
• Rasterization 
• Rasterize online 

 
 2.2 Raster Object Handling 

The select raster functions provide adequate tools for editing even complex raster 
images. They enable copy and cut functions for parts of the raster, which can be 
edited later (using the move, rotate, scale, and delete commands). During this 
lesson you will learn how to 

• Cut and Copy Raster Objects, 
• Paste Raster Objects from Files 

 
 2.3 Dimensions (VP-WIN only) 

During this lesson you will learn how to 

• Create dimensions in an automatic and in a manual mode 
• Modify dimension text 

 
 2.4 Complex Raster Object Handling / Editing (VP-WIN only) 

During this lesson you will learn how to 

• Edit Complex Raster Structures 
• Modify Raster Text 
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Lesson 3 Color Processing 

 

 3.1 Color Reduction / Separation 
Reduce the number of colors in a colored raster image, separate the colors.  
Functions you will learn in this lesson: 

• Combine Colors 
• Change Colors 
• Export Raster Data Separated by Colors 
• Helpful Functions for Better Color Manipulation Results 

  
 3.2 Color Classification 

Reduce the number of colors in a colored raster image with classification methods. 
You will learn how to 

• analyze colored raster with classes 
• define the classes 
• perform the classification 

 
Lesson 4 Rubber Sheeting 

 

 4.1 Rubber Sheeting - Grid Snap and Manual Input 
Rubber sheet a raster image with given reference points. Use the following 
methods: 
• Multi Point Rubber Sheeting 
• Enter Reference Points with Grid and with Manually Input 

 
 4.2 Rubber Sheeting - Reference Points in a Vector File -  
  Automatic Input 

Rubber sheet a raster image with reference points from a vector file. Use the 
following methods: 
• Multi Point Rubber Sheeting 
• Enter Reference Points via Intersections of Vectors 

 
 4.3 Rubber Sheeting - Reference Points in a Vector File -  
  Manual Input 

Rubber sheet a raster image with reference points from a vector file. Use the 
following methods: 
• Multi Point Rubber Sheeting 
• Enter Reference Points Manually with Vector Snap 

 
 4.4 Rubber Sheeting - Reference Points from a Text File 

Rubber sheet a raster image with given reference points. Use the following 
methods: 
• Multi Point Rubber Sheeting 
• Enter Reference Points from a Text File 



VP Software Tutorial  

Tutorial V16 - V9 / E Introduction   5
 

 
 4.5 Rubber Sheeting (Map )- Reference Points from a Text File 

Rubber sheet a raster image with given reference points. Use the following 
methods: 
• Multi Point Rubber Sheeting 
• Enter Reference Points from a Text File 

 
 4.6 Calibrate to Drawing Format 

Calibrate a raster image to a defined drawing format. Use the following method: 
• Calibrate to Drawing Format 

 
Lesson 5 Merging / Montage 

 

 5.1 Merge Two Raster Files 
Merge two raster images into one. The overlapping region should be erased. 

 
Lesson 6 Tracing 

 

 6.1 Tracing Monochrome Raster 
In a mechanical raster drawing, only certain shapes and entities are going to be 
vectorized and exported afterwards. The following steps are necessary: 

• Tracing of certain contours 
• Tracing of certain CAD elements  
• Export of these traced vector entities 

 
 6.2 Tracing Colored Raster 

In a color GIS raster drawing, the rivers, streets, and altitude lines will be 
vectorized, by using the contour trace function on a active color. 

 
Lesson 7 Elevation Assignment 

 

 7.1 Assign Elevation 
In this lesson you will learn to assign elevations to vector polylines. Use the 
following method: 

• Assign Elevation 
 

 7.2 Assign Elevation while Tracing 
Trace the contour lines in a raster file and assign elevations in the same process. 
Use the following method:  

• Trace Contour with Elevation. 
 

Lesson 8 Vectorization 
 

 8.1 Vectorizing a Raster File using the Vectorization Wizard 
Convert a b/w raster into a vector file. Use the Vectorization Wizard to create a 
parameter set that matches the characteristic of this drawing.  
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 8.2 Preparing, Vectorizing, and Post Processing a B/W Image 

Convert a b/w raster into a vector file. Use the following methods 
• Auto Cleanup 
• Rasterize online 
• Vectorization Using Pre-defined Settings 
• Combine to Ortholine / Combine to Text 
• Review Text 
• Assign Current Layer / Assign Current Linetype 
• Draw Text / Draw Arrow Head 

 
 8.3 Color Image Vectorization 1 

Vectorizing of color images by using the Image Settings dialog. Functions you will 
learn in this lesson: 

• Define Different Color Patterns in one Raster File  
• Vectorize with Respect to the Color Patterns 

 
 8.4 Color Image Vectorization 2 

Vectorize the elevation lines of a map. Follow these steps: 

• Define the Colors of Elevation Lines (Image Settings) 
• Modify Vectorization Settings 
• Automatic Vectorization 
• Review and Correct Results 
• Post-Processing 

 
 8.5 Contour Vectorization 

Vectorize the elevation lines of a map. Follow these steps: 

• Automatic Contour Vectorization 
• Review and Correct Results 
• Post-Processing 

 
Lesson 9 Polygon Tracing and Attribute Assigment 

 

 9.1 Digitizing a Scanned Map and Creating Attributes (Map) 
A scanned map will to be digitized and exported in ESRI-Format.  
The following steps are required: 

• Georeferencing of the map  
• Creation/import of a layer structure with attributes 
• Generation of vector entities with various tools 
• Export in ESRI .shp Format 
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Lesson 10 Block Processing 

 

 10.1 Defining / Inserting Blocks (VP-WIN only) 
Replace the vector images of the resistor symbols in the drawing by blocks. Use 
the following methods: 

• Define Blocks with and without Attributes, 
• Insert these Blocks into the Drawing, 
• Combine Vectors to an Existing Block, 
• Exchange Blocks through Others. 

 
Lesson 11 Symbols 

 

 11.1 Symbol Recognition (VPHybridCAD) 
Vectors which form a specific pattern will be replaced by blocks. Use the following 
functions: 

• Create Symbols (define Search Patterns and Replacement Blocks)  
• Modify Symbols (add Search Patterns, modify Replacement Block) 
• Symbol Search  

 
 11.2 Symbol Recognition (VPmap) 

Vectors which form a specific pattern will be replaced by blocks. Use the following 
functions: 

• Create Symbols (define Search Patterns and Replacement Blocks)  
• Modify Symbols (add Search Patterns, modify Replacement Block) 
• Symbol Search  

 
Lesson 12 Redlining 

 

 12.1 Redlining/Mark-up (VP-WIN only) 
A raster file is found incorrect and must be edited. The editing information will be 
added using redlining elements for mark-up. In this lesson you will learn how to: 

• Create Redlining Symbols 
• Review Redlining Information 
• Save Redlining Files 

 
Lesson 13 Batch Processing and Scripts 

 

 13.1 Batch Processing 
In this lesson, some raster files will be cleaned and vectorized in an automated 
process using the BatchManager and the BatchExecuter. 
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 13.2 Script Processing 

This lesson shows how scripting can be used to interactively repeat routine tasks. 
The command sequence of this script will load a scanned drawing, auto clean up 
the raster data, and stamp it with a drawing header in vector format to be rasterized 
into the drawing. 
• Loading a Raster File  
• Despeckling 
• Stamping the File with a Vector Mark 
• Rasterizing the Mark 
• Exporting the File 
• Loading next File..... 

 
Lesson 14 Indexing 

 
In this lesson you will learn how to 
• set up and perform an interactive indexing process using a title block layout 

template 
• set up and perform an automatic indexing process 
• set up and perform an interactive indexing process using a template with 

isolated cells 
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Concept of this Tutorial 
 
This tutorial has been organized to help you to quickly find operation terms, commands, and 
description of functions and to supply you with brief, but sufficient explanations. The tutorial 
applies to the following VP products:  
 
VPHybridCAD V16: VPstudio, VPstudio mono, VPlite, VPraster, VPraster edit 
 

VPmap Series V9: VPmap pro, VPmap 
 

VPindex V9: VPindex, VPindex lite 
 
The icon at the beginning of each lesson indicates the product(s) to which the information 
and/or commands apply. If specific commands on a page are limited to other products or 
product groups this is marked with a corresponding icon at the corresponding command. 
Keys and key combinations are represented by [ ] enclosing the keys' designation. For 
example, the "Enter" or "Return" key is shown as [Enter] whereas a key combination (short-
cut) opens as [Ctrl + C]. 
 
Functions that can be mouse-clicked for activation/deactivation in a check box are 
represented as {on/off}. 
 
Available commands for command line entries are quoted in {  }. They only refer to the 
basic command syntax, excluding optional or mandatory command parameters (see 
Reference Manual). All commands are valid at any time when VP products are operated in 
stand-alone mode (Windows). When using VP products inside AutoCAD, BricsCAD, or 
ZWCAD they may have to be replaced with the respective CAD commands. 
 
As an example, the File Open command is quoted as {VPOPEN}. It must be entered without 
the brackets. Small or capital letters are permitted. 

 The command line option is not available in VPindex lite. Any respective references can be 
ignored for this product.  
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INSTALLATION 
 

Introduction 
 
VP software requires for operation Microsoft Windows 7 or higher. Depending on the 
configuration of your computer network you may install the software using local licensing or 
network licensing. 
 
The purchased VP software product is delivered with a 30 days time limited operation license. 
The user is required to register the software within that time frame with softelec using either 
the online registration accessible from within the software, or sending the completed 
registration form to softelec by mail or fax. Softelec will then return a code to the user which 
extends the license for unlimited use. 
 
 

Software License Control (Hardlock)  
 
Any VP software Full Version product requires a hardlock (dongle) controlling the product 
license. Without a proper installed hardlock any product will only operate in the Demo Mode 
(no hardlock for the license control required). 
 
The hardlock may contain one or more product licenses. Regardless of the installation mode 
and the number of licenses controlled by the hardlock there are two methods of operation: 
1. Local Licensing: you need to attach the USB hardlock to one of the USB ports of the 

computer where the VP software is installed. Typically, this method of operation is used if 
the hardlock contains a single license only. Then, for every additional VP software 
installation an additional single license hardlock is required. 

 

2. Network Licensing: this method of operation is preferable if two or more VP software 
licenses are to be controlled by one hardlock, but may also be used for a single license 
("floating" license), where you can access the VP software license on any network 
computer, but only operate one license at a time. You need to attach the hardlock to a 
workstation serving as "VP network server" or "dongle server" (usually your network 
server) executing the VPLicenseManager so that the license(s) is/are accessible by other 
workstations. 

 The VPLicenseManager has to be installed on the workgroup server and can only operate 
under Windows XP or higher.  
 
Local Licensing does not require the installation of the VPLicenseManager. 
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Hardlock Driver  

 
The workstation or server controlling the hardlock needs a system driver for proper operation. 
This driver is provided with your package and is installed together with the VP software. You 
may also install it manually by following the instructions found in the file README.TXT on the 
CD. 

 In order to install the hardlock driver during the standard installation or manually, you need 
administrative rights. 

 The installation routine will not install the hardlock driver(s) if the selected software is installed 
as a Demo Version! If, at a later state, you want to use the software as a full version 
(together with the purchased hardlock), you need to manually install the hardlock driver.  
 
 

Attaching the Hardlock (Dongle) 
 
The driver software will be installed automatically with the VP software program (full version). 
If required, it can also be installed separately later. Installation files can be found on the VP 
software CD or are available at www.softelec.com – downloads – utilities/drivers. 
 

 Attach the hardlock only after a successful software installation to one of your 
computer's/server's USB-Ports. 
 
 

Package Contents  
 
Your VP software package contains the following: 
 

• 1 VP Software CD 
• 1 Hardlock (dongle) 
• 1 Registration form 

http://www.softelec.com/
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Installing VP Software  
 

General 
 
The install program SETUP_VP.EXE guides you through each step to successfully install and 
configure the software of your choice and the required hardlock driver on your computer. If 
your CD function autorun is enabled, the initial screen will pop up automatically upon 
insertion of the VP software CD offering you several choices. Select VPHybridCAD or 
VPmap Series and follow the advice: 
 

  
 

 
The required hardlock drivers (Sentinel) will be installed or updated automatically if a VP 
software Full Version product is installed. 
 
The installation setup allows you to specify several options. These include the target location 
and the required components of the VP software.  
 
Prior to starting the setup routine please terminate any running application and read the file 
README.TXT if available on the VP software CD. 

 Administrator rights are necessary to install the hardlock driver. 
 
After a successful installation of the software or the hardlock driver it is often necessary to 
reboot the computer in order to allow the operating system to update the DLLs. A dialog box 
will appear, asking the user to restart the computer now or at a later stage. 
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Performing the Installation 

 
The setup starts automatically after inserting the CD into the CD-ROM drive (AutoRun). Only 
if your Operating System (OS) does not support this feature or AutoRun is disabled you have 
to start the setup program SETUP_VP.EXE manually from the root directory of the CD.  
 
In the initial setup window click the item "VPHybridCAD" or "VPmap Series", select "Full 
Version" or "Demo Version" (as desired) and select the desired program language from the 
appearing dialog. In the sequel you are guided through the setup dialogs allowing user 
defined settings. We recommend to choose "typical" as the setup type. 
 
On a 64-bit operating system (Windows 7 or higher) another selection shows up to choose 
between 32-bit and 64-bit program installation 
 

Local Licensing 
 
During setup you will be asked whether your hardlock resides locally or on the VP network 
server. Choose "Local". 
 
 

Network Licensing 
 
If you want to operate the software on a network (you have either multiple licenses purchased 
or you want to use a single license floating) you need to install your hardlock on the server. 
Therefore, choose "Network Server". The next dialog prompts you for the name of the server 
bearing the hardlock ("dongle server").  

 Enter the name, not the IP-address of the server!  
 
There are different ways to specify the server: 
 
COMPUTERNAME 

Name of the computer as entered during the installation of the Windows OS. Leading 
backslashes ("\\") are not required! 
 
COMPUTERNAME:192.168.0.1 

The IP-Address can be enter after the computer name separated by ':'. This is useful in larger 
networks and can speed up the rooting to the server and thus the license. 
 
COMPUTERNAME:COMPUTERNAME.DOMAINNAME 

In some 'heterogeneous' networks it might be necessary to use this combination to clearly 
resolve the server name (e.g. DHCP). 
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When working with multiple dongles on different servers please use the following syntax: 
 

COMPUTERNAME1; COMPUTERNAME2 

The computer names of the servers must be separated by semicolon. 
 

If you don't know the name of the "dongle server" (= "VP network server") you may leave the 
entry empty and proceed with the installation. You may change the dongle server name in the 
VP software (Options->Settings->License) later. 

 In order to use Network Licensing, the VPLicenseManager (see below), the hardlock driver, 
and the hardlock (dongle) must be installed on the same computer (server). 
 
 

First Start after Installation and Registration  
 
Unless you have purchased special VP software licenses such as Multi Licenses or 
Educational Licenses, which require a pre-registration, your software operates on a 30 days 
time limit allowing for execution of the required registration with softelec. At any start of the VP 
software a dialog opens remembering you to register and displaying the expiration date of the 
license. After the expiration date the software will only run in demo mode, unless the code for 
unlimited use has been entered. This code will be send to you as soon as you have registered 
with softelec. 
 
You can register online from within the VP software (press button "Register On-line" in the 
dialog box or select menu Help ► Register VPxx on the Internet) or fill out the attached 
registration form completely and legibly and send or fax it back to softelec. After checking 
the registration contents softelec returns a code to be entered with the next software start. 
 

 

 You will receive technical support and update/upgrade notices from softelec only if 
you have properly registered your VP software. Registration of VP software products 
with your dealer does not constitute a proper registration. 

 All user data received will only be used for internal expenditure within the softelec sales and 
support cycle and will not passed over to third parties! 
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Uninstalling  

 
To remove a VP software product from your computer click on the icon Uninstall and follow 
the instructions.  
 
The hardlock driver(s) will NOT be removed. If the driver is not required by any other program, 
you can uninstall those using "Add/Remove Programs" from the Control Panel. 
 
 

Updating / Upgrading / Service Pack  
 
Software upgrades (to a higher VP software product level) or updates (to a new release of 
the same VP software product) may require a code that is issued to you upon purchase. After 
installing the upgrade or update and starting it for the first time you will be asked to enter the 
code. With a successful entry the code can be discarded.  

 For updating a VP network license hardlock (the lock is attached to the VP network server) 
use the program UPDATELOCK.EXE residing in the CD directory VPHardlock for entering 
the update code. For more information please read the text file ReadMe.TXT in the root 
directory of the CD. 
 
Service packs are released from time to time for bug fixes and smaller software 
improvements. They can be downloaded from our website and are usually self-installing. 
 
You may install and use the new VP software release together with a previous release 
although this is not recommended. However, do not install the new version into the same 
directory!  
 
 

System Requirements  
 
Proper operation requires a specific configuration of hardware and software to guarantee 
overall functionality. The fastest CPU in your PC is the most desirable! The software requires 
at least 4 GB of RAM, but this is not recommended and today's PCs often have higher 
memory installations. Drawing formats of DIN A0 (E size) and larger, gray scale or color 
images of any size require a minimum of 8 GB. More is recommended for large size color 
images. File size and entity contents of a drawing define the actual amount of RAM required.  
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Installing the VPLicenseManager   
 
The VPLicenseManager needs to be installed only if you have a computer network and the 
hardlock is attached to a remote computer ("dongle server"). This software controls and 
manages the VP software licenses in the network. 
 
 

Requirements 
 
The VPLicenseManager may be installed as a service only on computers (server or 
workstation) operating under Windows XP or higher. 

 As a maximum number, ten concurrent users are allowed to connect to a license server 
running with Windows XP prof.! This is a restriction of the operating system, not of the 
VPLicenseManager. More users can connect using a newer version of Windows or a server 
operating system like Windows Server 2003. 
 
The software clients may run under Windows 7 or higher. It is necessary that the clients have 
access to the "dongle server" (an account must exist for each user). We strongly recommend 
installing the VPLicenseManager on the Domain Controller Server! 
 
An alternative solution is to create a share with a default user name and a respective 
password. Every user that needs to access the "dongle server" has to connect this share with 
this specific name and the specific password. This can be done by either using the Windows 
Explorer, with a special logon script, or by using the VPNetManager.  
 
 

Installation 
 For the following steps you have to be logged on to the dongle server as "Administrator"! 

 Attach the hardlock (dongle) only after a successful software installation. 
 

1. Install the VPLicenseManager software either  
- by choosing Network / Hardlock - VPLicenseManager in the installation’s main window, or 
- by running VPLicenseManagerSetup.exe from the VPLicenseManager folder on the VP 

software CD. 
2. Apply the dongle to a USB server port. 

 
In general, a reboot of the server is not required! In some cases it might happen that the 
VPLicenseManager service is not started automatically after installation. In this case you can 
start the service manually through the computer administrative console. To check whether the 
VPLicenseManager has been installed and is running, please use the VPNetManager 
(described below) for checking. 
 
The VPLicenseManager service is installed with the startup option 'automatic'. That means 
the service will be automatically restarted after any reboot of the computer. 
 
If the VPLicenseManager is installed and running, you can find out with the program 
VPNetManager (see below). 
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Uninstallation 

 For the following steps you have to be logged on to the dongle server as "Administrator"! 
 

Variant 1: 
Remove the license manager using the Windows Control Panel. 
 

Variant 2: 
Start the Windows command prompt. Change to the installation directory of the license 
manager (e.g. \Windows\System32 or \Windows\SysWOW64) and execute the following 
command: 

VPLicenseManager.exe -remove 

The VPLicenseManager service is removed. 
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GETTING STARTED  
 
If you have not yet installed the software, please read the section Installation in this manual 
first. We also refer to the section Installation in the Reference Manual. These sections provide 
important information for the installation (local and network) and for the hardlock handling (full 
version only). For trouble shooting a FAQ section is included. 
 
After a completed installation of your VP Software product, you will find the VPsoftware icons  
within the VP program group (softelec ► <Productname>). 

VPHybridCAD:  ( VP-WIN),  (VP-CAD, if installed) 

VPmap Series:  ( VP-WIN),  (VP-CAD, if installed) 

VPindex:  ( VP-WIN) 
 

VP Software as Full Version 

 Any VP Software full version needs a valid license for execution. If a valid license cannot be 
found during startup, the following message will appear (sample: VPmap pro) and the 
software will operate only in demo mode: 
 

 
 

VP Software as Demo Version 

A valid license is not required but the message below will appear. 
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The Demo Version has some limitations. These restrictions depend on the kind of Demo 
Version you are running: 
• VP Software as CAD application 

Raster images a limited to 1800 x 1200 Pixel; lager images can be loaded, but must be cut 
down to this size. Importing of vector data other than the CAD software support’s itself, is 
not possible. 

• VP Software as Windows application (stand-alone version) 
All formats VP supports can be loaded and edited/converted, but you can not save/export 
anything. 

 For a temporary Trail-License without any limitations please see Options ► System 
Settings…, Tab License. 
 

 
Starting VP Software under Windows 

   This icon starts the stand-alone version of your VPHybridCAD or VPmap Series 
product (VP-WIN). 

 

 
Sample: VPmap pro showing all toolbars 

 

The title bar contains the name of the current file. Since no document has been opened yet, 
the title bar shows VP Document 1.  
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  This icon starts AutoCAD/BricsCAD/ZWCAD (if installed) together with your 
VPHybridCAD or VPmap Series product (VP-CAD). 
 

 
Sample: AutoCAD with VPmap pro 

General Operation 
 

Toolbars 
 
Upon the first start of VP Software a selection set of the available toolbars is displayed. All 
toolbars can be switched on/off according to individual user preferences. They can also be 
positioned and configured by following the Windows conventions. Additional custom toolbars 
with arbitrary commands can be added. 
 
Icon and pull-down menu commands that cannot be activated in the program's current status 
(e.g. no raster loaded) appear "grayed".  
 
Each toolbar can be customized individually by removing or adding icons as they are needed. 
 
A specific positioning of toolbars can be saved as permanent and will be available at any time 
when it is needed. 
 
For a detailed description please refer to the Reference Manual or the help file Section 3: 
System Settings, General Functions – General Handling - Toolbars. 
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Using the Mouse  

 

Display Modes of Mouse Position 
Within the work area the mouse position is displayed as a Cross cursor. It appears as the 
default Windows arrow cursor in toolbars, menus, or the status area. At the command line it 
will be displayed as a standard Text cursor. 

 A triple white frame box (instead of the standard crosshair) indicates that with the next 
mouse click this area will be zoomed in to allow for a precise positioning with the then 
following click. To configure the zoom size use the General tab in the System Settings 
dialog. 

 
 

Using the Mouse to Select Elements 
Use the left mouse button to pick for Selection. 

 Elements to select can be in raster or vector format (Direct Raster Selection mode 
“Vector/Raster Selection“ or “Vector/Raster Selection incl. Stop at Intersections“); all other 
Direct Raster Selection modes will only work on raster data. (See Reference Manual, 
Section 4).  

 In case that the selection mode does not support vector selection the cursor is 
changed to the rasterselectioncursor: 

 
When vector elements are overlaying raster elements only vector elements will be selected 
initially, while raster elements need to be selected again. Selected elements are displayed in a 
different way than not-selected elements. They bear grips for individual modification and 
colors or line types may change to highlight the selection. 
 

Selecting entities in an image can be done in three different ways: 
 

Clicking 
Click on the respective element within the cursor's snapping range. Only one element will be 
selected per click. 
 

Window 
You specify a rectangle by holding down the left mouse button and dragging the mouse from 
left (1) to right (2). All elements completely enclosed by the rectangle will be selected. The 
rectangle will be displayed with a full frame. 
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Crossing 

You specify a rectangle by holding down the left mouse button and dragging the mouse from 
right (1) to left (2). All elements touched or enclosed by the rectangle will be selected. The 
rectangle will be displayed with a dashed frame. 

  
 

Polygon Selection 
Via context menu you can start the polygon selection mode. A clockwise drawn polygon 
selects only elements completely enclosed by the polygon. The polygon will be displayed 
with a full frame. 

  
 
A counterclockwise drawn polygon makes a crossing selection: all elements touched or 
enclosed by the polygon will be selected. The polygon will be displayed with a dashed frame  

  
 
 

Deselection of selected Elements 
To deselect elements from a previous selection hold the [SHIFT] key and repeat your  
selection (see above for selection modes).  

To cancel a selection or to deselect all selected elements, press the right mouse button for 
the context menu, or press [ESC]. 

 
 

Context Menus 
Use the right mouse button to open context menus. There is a general context menu 
defined in the software registry. Other menus depend on active functions or commands. 
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Zoom 

You can use the mouse center wheel to  
• zoom in/ zoom out . 
• move up/move down (scroll) when holding the [Ctrl] key. 
• move left/move right when holding the [SHIFT] key. 
• move the display arbitrary when holding down (pan dynamic). 
• zoom all by double clicking 

 
 

Combined Mouse Keyboard Operation 
 

Angle Snap (only Windows) 
Pressing [Shift] while moving the mouse limits the angle of the following movement: 

• With 2 point lines including positioning or other help lines (such as text direction etc.) only 
n x 45° directions are possible. 

• With polylines the drawing direction of the second and all further segments is limited to 
only follow a multiple rectangle (n x 45°) with reference to the first segment. This allows for 
drawing rectangle polygons having a base (1st segment) at any angle.  

 
 

Create a Raster Object 
By holding the [Ctrl] key and by dragging a rectangle with the left mouse key a raster object 
can be simply created from an existing raster structure. It can be processed by using the 
available functions from the context menu. 
 

  
Command Line 

 
VP software offers command line input and execution via keyboard or remote input via a script 
file etc.  

Under Windows VP software has a sizeable and dockable/undockable command line area 
which can be switched off when not needed. It automatically reappears on keyboard input. To 
activate and display a switched off command line press [Shift]+[Return].  

 
As an CAD application VP software shares the CAD command line. For details refer to your 
CAD manual.  
 
All VP software functions can be initiated by command line input. Commands are only 
available (executable) if a document has been opened; except for specific commands, like 
Open, New, Help, etc. 
 
A command consists of the command string and can be extended by options/parameters. 
Any command starts with the two letters "VP" followed by the command name.  
 
For a detailed description please refer to the Reference Manual or the help file Section 3: 
System Settings, General Functions – General Handling – Command Line. 



 VP Software Tutorial 

24   Getting Started Tutorial V16 - V9 / E
 

  
 

Status Display (only VP-WIN) 
 
There is a comment box at the lower left screen margin showing 

• Activated functions, or 
• Required activities to proceed, or 
• Messages, or  
• Progress during execution.  
 
On the right there are 2 boxes displaying 

• Number of currently selected elements 
• Local RGB color value if the cursor is positioned on a color or gray scale image. 
 
If no function has been activated the comment box remains empty while a 'For Help, press 
F1' indication appears at the left. 
 
 

Help Menu 
 
Help information is available at any time by pressing [F1] on your keyboard. This help is 
context sensitive and allows for page scrolling and section selection. 
 
Clicking Help ► Help Topics from the menu activates the help file and you can search for the 
item of interest. 
 
 

System Settings 
 

Auto Save (only VP-WIN) 
 
The function Auto Save is very important to avoid losing editing/modification results in the 
event of a system crash! In the System Settings dialog ({VPSYSTEMSETTINGS} or 
Options ► System Settings, tab Files) you can set the time interval to your needs.  

 We strongly recommend not to switch off Auto Save.  
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FIRST STEPS  
 
This section intends to make you familiar with some basic functions of VP software, like 
loading and saving files, creating and/or modifying layers, linetypes, colors, etc. Moreover, you 
will be guided through the creation process of a prototype drawing which then will be added to 
the system settings. 
 
 

New Documents (Drawings) 
 

VP-WIN: 

 To create a new document (drawing) with the stand-alone version of VP software click the 
New icon or select New from the File menu. Alternatively, you can enter the command 
{VPNEW} in the command line. This opens a new document named VP Document with the 
settings defined in the active prototype drawing.  

VP-CAD: 

 If you are working with the CAD based version of VP software you need to use the CAD 
command to create a new drawing. The new drawing will contain the initial settings defined in 
the CAD software - there is no additional VP prototype drawing with predefined settings. 
Instead, the CAD prototype drawing will be used. 
 
 

Loading Files 
 

Open 
 
Each time you open a file, a new document (drawing) will be created first. Then, the content 
of the file is loaded into the new document. With files previously saved to the native VP format 
RVD and with other vector files the settings (e.g. layers, linetypes, etc.) are read from that file. 
If you open a raster file the prototype settings will be used. 

VP-WIN: 

 Click the Open icon or select Open from the menu File or enter {VPOPEN} in the command 
line. 

VP-CAD: 

  There is no Open command in the CAD based version of VP software. To achieve the 
same results (new document created plus content of the file read) you need first to create a 
new drawing with the respective CAD command. Then, either click the Import icon of the VP 
software Import/Export toolbar or select File ► Import from the VP software menu or just 
enter {VPIMPORT} in the command line. 
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The Open dialog opens allowing you to browse and select the files you want to load: 

 
A preview window displays a thumbnail of the selected file. In the lower part you can read 
detailed information about the selected file. If this file is a multipage file you have the option to 
load either All Pages or only One (particular) Page. Use the spin wheel to select the desired 
page - the preview will show the selected page. 
 
If you are opening a raster file the raster will be inserted at the origin of the new document, 
unless the file contains placing information. In this case you are prompted whether the raster 
should be inserted according to the placing information or at the origin. 
 
 

Import 
 
There are two main differences between opening and importing a file. First, import does not 
create a new document. Therefore, prior to importing a file you need to have already opened a 
file or to create a new one. Second, the settings of the opened file or document and those of 
the file to be imported will be merged. If, for example, both files have a layer with the same 
name, then only the layer specifications of the already opened file will be used. If the two 
layers are not identical this can result in different representations of the imported entities (e.g. 
different colors, linetypes, etc.). All non-identical settings are loaded without modification and 
extend the settings accordingly. 

To open more than one raster in a single drawing you need to use the import command. 
 

VP-WIN: 

Select the menu item Import in the menu File or enter {VPIMPORT} in the command line. 
 

VP-CAD: 

 Click the Import icon of the VP software Import/Export toolbar or select File ► Import from 
the VP software menu or enter in the command line: {VPIMPORT}. 
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The Import dialog opens: 
 

 
 
In addition to all options of the Open dialog the Import dialog provides the option Specify 
Insertion Point for raster files. Use this option if you want the raster to be inserted at a 
different position than the origin of the document. 
 
 

Open and Import Raster Files 
 

VP-WIN: 

 Click the Open icon (menu File ► Open or {VPOPEN}). 
 

VP-CAD: 

  Start a new drawing and click on the Import icon (VP software menu: File ► Import. 
 Command line: {VPIMPORT}). 

Browse to VP's subdirectory TUTORIAL, select the file VP1.TIF and open it. 

Next, import the file VP2.TIF. 
 
VP-WIN: 

Select the menu item Import in the File menu or enter {VPIMPORT} in the command line. 
 

VP-CAD: 

 Click the Import icon of the VP software Import/Export toolbar or select File ► Import from 
the VP software menu or enter in the command line: {VPIMPORT}. 
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The results of these two operations should look like this: 
 

 
 
 

Saving Files (Full Version only) 
 
For saving your drawing to a file you have the choice between the native format RVD and 
several other raster or vector formats.  

 Only the VP native format RVD is able to save all raster and vector data, document settings, 
and additional program specific data. E.g. some vector formats like SHP etc. are not able to 
save raster images, and most raster formats are not able to handle more then one image. 
Hybrid formats like DWG or CGM will lose some document settings or VP specific data. 
 
 

Save / Save As 
 
Use this command to save drawings. By default the software offers you the format of the 
opened file. If this format is not capable to save all raster and vector information of the 
drawing, a warning will appear. 
 

VP-WIN: 

 Click the Save icon (menu File ► Save As {VPSAVEAS} or File ► Save {VPSAVE}). The 
Export dialog opens allowing to specify a file type and a name for the new file. Save the file 
as VPHybridCAD.RVD: 
 

 
 

VP-CAD: 

VP software's native format RVD is only available in the stand-alone version. However, you 
can save your drawings to the AutoCAD DWG or DXF file format with attached raster file(s). 
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Export 

 
Use this command to save parts of the drawing (e.g. a single raster file or a set of vector 
entities). 

 Depending on the file format of your you choice not all information in a drawing may be saved. 
A raster format cannot save vector data and some vector formats do not allow to also save 
raster data. Therefore, if exporting drawing data always be aware of file format limitations. 
 

VP-WIN: 

Select the Export from the menu File or enter {VPEXPORT} in the command line. 
 

VP-CAD: 

 Click on the CAD Export icon (VP software menu: File ► Export or {VPEXPORT}). 
 
Similar to the Save command the Export dialog opens. Additional settings for special formats 
can be defined when clicking the Options button. Options are only available for some 
formats. 
 
 

RasterDWG 
 
This format allows you to save raster and vector data to one single DWG file. The vector part 
of that file can be read with any program that is capable of reading DWG files, especially 
AutoCAD. To also load and display the raster part, use either a VP software product or install 
the RasterDWG driver (freeware) to your CAD software. 
 

VP-WIN: 

Select Export from the File menu or enter {VPEXPORT} in the command line. Choose the 
DWG format. In the export options activate the RasterDWG mode. 
 

VP-CAD: 

 Click on the Save As RasterDWG icon or select File ► Save As RasterDWG from the VP 
software menu or enter {VPSAVERDWG} in the command line. 
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Document Settings / Generating a Prototype Drawing  
(VP-WIN only)  

 
This part describes how to modify the document settings in the stand-alone version of VP 
software. For the CAD based version, please refer to the according CAD commands for 
creating and modifying system / document settings. 
 
 

Preparation 
 

 Start a New drawing by clicking the respective icon (menu File ► New {VPNEW}). 
 
 

Layer Manager 
 

The layer manager is used to create and modify the layers of the active document. 

 Click on the Layer Manager icon (menu Options ► Layer Manager {VPLAYERS}). The 
respective dialog opens showing the default layer settings: 
 

 
 

To modify an existing layer click on that layer name and proceed with your changes. Select 
the Layer3 and modify the Linetype to Continuous. 
 
Click on New to create an additional layer with the name: Tutorial Test. Modify the layer color 
to Magenta. 
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Close the New Layer dialog with OK - the layer appears highlighted in the layer list of the 
layer manager dialog. Close the layer manager. 
 
 

Linetype Manager 
 
Use the linetype manager to create and modify linetypes for the active document. First, switch 
on the Linetypes toolbar (right click over any toolbar or menu Options ► Toolbars). 

 Click the Linetype Manager icon (menu Options ► Linetype Manager {VPLINTYPES}). 
The respective dialog opens: 
 

 
 
Create a dotted linetype. Select Linetype2 and press the New button. A new linetype 
Linetype3 will be created with the settings of the previously selected Linetype2. 
 
The new linetype is dash-dotted. To modify this linetype to dotted, first reduce the number of 
Segments to 1: use the spin wheel or edit the number value directly. Thereafter, click into the 
Length field of Dash 1 and change the value to 0.0, which is the definition for a dot. Finally, 
change the Gap Length to 4.0.  
 
Press the Active button and close the dialog with OK. Now, the new Linetype3 is displayed in 
the Current Linetype window in the toolbar as the active linetype.  

 Click the Draw Line icon and draw a line. The line appears dotted (e.g. used the active 
linetype). End the draw mode by clicking the Draw Line icon once again. Erase the line. 
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Text Style Manager 

 

 Click the Text Style Manager icon (menu Options ► Text Style Manager or enter in the 
command line: {VPTEXTSTYLES}) to open the dialog: 
 

 
 
Select the text style Text and press the New button - like the linetype manager a new style 
Text1 is created with the settings of the selected style. 
 
Change the Height of the new text style to 10.0 and close the dialog with OK. 
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Prototype Drawing (Full Version only) 

The settings of the prototype file are read on program start and while executing the File Open 
or File New functions. They contain document settings that override default settings. Creating 
a specific prototype drawing file allows customizing your VP software setup to your individual 
needs, e.g. metric or English measurement dimensions, special layers, linetypes, a default 
drawing header, etc. 
 
 

How to create a Prototype Drawing? 
 
The prototype drawing is a file saved in VP software's native format RVD. For this example we 
will use the drawing with the modifications completed during the previous sections.  
 
In addition to the modified document settings the file should contain some vectors. Therefore 
import (menu File ► Import, {VPIMPORT}) the file VP3.RVD from the TUTORIAL directory. 

 Save the file (menu File ► Save As {VPSAVEAS}) to VP software's subdirectory SUPPORT 
using a different name: TUTORIALPROTO.RVD. 
 
Now, to make this file serving as the prototype drawing open the System Settings dialog 
({VPSYSTEMSETTINGS} or Options ► System Settings, tab Files) and change the name 
in the field Prototype Drawing to TUTORIALPROTO.RVD by keying in the name or browsing 
and selecting the file. Close the dialog. 

 Click on New - the new document contains the new settings we have created above, plus the 
imported vectors. At any subsequent start of your VP software or on executing the File Open 
or File New functions the prototype drawing will be read and the document settings will be 
adjusted accordingly. 
 
For the following lessons we need the environment of the default prototype Therefore, go back 
to the System Settings dialog and change the prototype back to the original file 
PROTO.RVD. 
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LESSON 1   
 

EDITING RASTER FILES 
 

1.1 Basic Functions  
 
A raster file is going to be cleaned up. Use the following methods: 

• Load Raster Files 
• Deskew/Align 
• Despeckle 
• Mirror 
• Save/Export Raster Files 

 
 

Loading, Viewing, and Saving the Raster File MECH4.TIF 
 

Loading a Raster File 
 

VP-WIN: 

 Click on the menu item File followed by Open {VPOPEN}. In the dialog box browse to VP's 
subdirectory TUTORIAL and select the file MECH4.TIF. 

 
VP-CAD: 

  Start with a new document, click in the VP Software menu File and Import 
{VPIMPORT}, and select the raster file MECH4.TIF from the TUTORIAL directory. 
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The name of any imported file will not be indicated in the title bar. It still reads 
VP Document1. If you have used the Open command the title bar shows MECH4.TIF (VP-
WIN only). 
 
 

Zoom Functions (VP-WIN only) 
 
Various zoom options allow a closer view to a particular area of the drawing. 

 Click on the Zoom Window icon {VPZOOMW} and drag a window frame around the lower 
view of this object (see below) in the drawing. The selected area is enlarged to the workspace 
size: 

 

 
 

 To inspect the surrounding area, click on the Dynamic Pan icon - the mouse cursor changes 
to a hand symbol. Click into the drawing and move the mouse around while holding the left 
mouse button pressed. 
 

  Return to the overall view by either clicking once on the icon Zoom Extents 
{VPZOOMX}, or click on the Zoom Out icon {VPZOOMOUT} consecutively to step-wise 
restore the overall view. 
 
 

Saving 
 
VP-WIN: 

We will save this file under a new name. The save or save as command saves all drawing 
data exclusively in the native VP Software format RVD; both raster and vector data are saved 
in a single file. 

 In the menu File select the function Save As {VPSAVEAS}, modify the file name to 
MECH4_1, and choose the file type RVD. Click on OK; the new file name MECH4_1.RVD 
appears in the title bar. 
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VP-CAD: 

VP Software with CAD offers 3 different ways to save a raster image: 

 1. CAD Save: the CAD command Save or SaveAs creates a DWG-file (or saves changes to 
an existing file) which includes one or several links to the raster files in use. The CAD 
menu command Insert ►  Raster Images displays a list of all raster images used with the 
active CAD drawing, including name and path of the corresponding raster file. If you have 
created a new raster image or modified an existing raster file with VP Software you will be 
asked for a file name which will also export (save) the new modified image to a file. 

 2. VP Software Export: this command allows you to select the raster image you want to 
export. The raster data is saved to a raster file specified in the Export dialog. You can 
select different raster file formats. 

 3. RasterDWG: this command creates a hybrid DWG file containing all vector entities and all 
raster data inside one file. The path of any previously inserted raster image will be deleted. 

 We will use the RasterDWG format. From the VP Software menu select Save as RasterDWG 
{VPSAVERDWG} or click this icon. Save the file to MECH4_1.DWG. 
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Raster File Editor 

 
Now, the entire raster file is going to be mirrored horizontally, deskewed, and cleaned 
(despeckled). 
 
 

Editing the Raster File - Method 1 
 

 Click on the All Raster Operations icon {VPRFE}. The dialog box Raster File Edit appears 
offering several editing options: 
 

 
 
Please mark 

Deskew (with Manual), Horizontal Mirror, Speckles (with User Defined, and Review 
results before rasterizing) 

Enter the value 20 in the field Max. Dirt Size. 
 
You can also click the field Pick from instead and select a reference speckle from the image 
with the appearing pipette cursor. Then, the dialog reappears and the value field displays the 
measured size in pixels; it can be rounded up or down manually. For this exercise, please set 
the value to 20 and click OK.  
 
Before the editing process can start, you are prompted (see the lower left status field) to 
specify a reference line for the deskewing angle. In the workspace the mouse cursor changes 
to a triple frame box. This indicates that your first mouse click will zoom into the drawing 
before your second mouse click specifies the coordinates. 
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 Click on the left end of the drawing's uppermost horizontal dimension line. The area around 
the frame box will be zoomed in. The Raster Snap must be disabled - click on the 
appropriate icon, if active (VP-WIN only). Now mark the starting point of the reference line by 
picking the end of the dimension line. The frame box reappears with the reference line's free 
end attached to it. The program automatically zooms out to the general view. Click on the 
dimension line's right end to zoom into this part of the drawing, and mark the end point of the 
reference line at the dimension line's opposite end. 
 

 VP-CAD: Switch off Polar Snap. Otherwise, the reference line may be snapped to 0° and a 
Deskew operation cannot be performed.  
 
Now the edit process (deskewing, mirroring, and despeckling) starts. The image will be 
mirrored, deskewed according to the dimension line, and all found speckles (smaller than or 
equal to the specified limit of 20 pixels) appear covered in green color.  
 
Using the Zoom / Pan functions, you can inspect the speckles, for example, to check if 
decimal points of dimensioning numbers, points, dashes of dashed or dash-dotted lines have 
been marked as speckles for removal. If so, you can select the respective green elements and 
remove such items from the speckle list, using the window selection (they now appear 
highlighted in magenta). 
 
To delete the remaining green speckles press the [RETURN] key.  
 
Except for some speckles which exceed the limit of 20 pixels the entire file now has been 
deskewed, despeckled, and mirrored.  
 
 

Editing the Raster File - Method 2 
 
For cleaning the raster file (despeckling) and deskewing, you may also use the function Auto 
Cleanup {VPCLEAN} instead. 
 

  Again, Open the file MECH4.TIF and click on Auto Cleanup. The raster data are 
automatically despeckled and deskewed. Speckled dots, such as dots used in text characters 
or dots between dashed lines remain unerased. 
 

 To mirror the image, call the function Horizontal Mirror {VPHMIRROR} in the menu Raster 
►  Raster Operations. 
 
 

Export Raster File 
 
Export the current raster image to a TIF file, using the Export {VPEXPORT} function in the 
menu File. Select TIF as file format and enter MECH4_1 as file name. Click on OK to create 
the raster file. 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 1: Editing Raster Files - Enhanced Functions   39
 

LESSON 1  
 

EDITING RASTER FILES 
 

1.2 Enhanced Functions  
 
The quality of a raster file should be improved with the morphology method. Next, the file is 
going to be scaled. Functions used in this lesson: 

• Morphology 
• Scaling 

 
 

Preparation 
 

VP-WIN: 

 Click on the menu item File followed by Open {VPOPEN}. In the dialog box browse to VP's 
subdirectory TUTORIAL and select the file THIN.TIF. 

 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file THIN.TIF from the 
TUTORIAL directory. 
 

 
 
The raster lines are very thin and the (down) scaling process could result in a loss of data. 
Therefore, we will use the morphology function first to thicken the raster lines. 
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Edit Raster with the Morphology Function 

 

 From the menu Raster ► Filter call the function Morphology {VPMORPHO}. The 
Morphology dialog box opens: 
 

 
 

The position of the clipping preview shown in this dialog is marked in the drawing with a 
rectangle. You can move the clipping either with the scrollbars in the dialog or by clicking to a 
different position in the drawing.  
 
Select the area in the lower center of the drawing (near 27°) as preview and activate the 
Dilatation ( = thickening) method. Move the Intensity slider to see the thickening result in the 
preview. Use 3 pixel as Intensity and start the process with OK. 
 

 
Original Raster                After Thickening 
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Zoom in to the center of the drawing. The lines of the drilling are disconnected because of 
small gaps/holes. To close these holes, the Morphology function can be used, too. 
 

 Start the Morphology function again and select the Closing method. Set the preview on the 
drilling in the center of the drawing and move the Intensity slider. At a value of 3 pixels the 
lines are closed; use this value and click OK. 
 

 
Before Closing                                 After Closing 

 
 

Scaling a Raster File 
 
Use the [F2] key to see that the drawing needs to be scaled down because measurements do 
not correspond with the actual dimensions. After the raster structure of the image has been 
"thickened" (increased line width), there is no risk of losing data when scaling down the raster.  

 Click on the Scale {VPSCALE} icon or select from the menu Raster the function Scale. The 
dialog box Scale Drawing opens: 
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For achieving the correct scaling values two steps are required: 

1. Actual Value: use [F2] to measure a distance in the drawing 
2. Target Value: read the dimensioning information directly from the drawing  

 
Use the dimension line 41.5 in the lower left part of the drawing as a reference: choose the 
Isotropic method (i.e. the same scaling in X and Y direction), set the cursor in the Actual 
Value field, and press [F2]. Zoom to the dimension line and measure its length. 

 

 Using the Raster Snap function makes the measuring of a reference length much easier. 
Click on the icon Raster Snap to open the following toolbar for selecting the snap mode: 

 
Activate the snap mode Intersection (X) and draw a two point line from the top of the 
dimension line (the cursor snaps because of the intersection mode) to the bottom of line.  
 
After the second click the dialog box reappears. The measured length of the dimension line is 
shown in the Actual Value edit field. Enter 41.5 in the Target Value edit field. Close the 
dialog and start the scaling with OK.  

 Disable the Raster Snap. Export the edited image as THIN_1.TIF. The raster is now prepared 
for further processing. 
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LESSON 2   
 

RASTER ENTITIES AND RASTER OBJECTS 
 

2.1 Raster Entity Editing  
 
Edit parts of a raster file using the following methods: 

• Raster Selection 
• Pick Selection of Raster Entities 
• Rasterization 
• Rasterize Online 

 
Preparation 

 
VP-WIN: 

 Open {VPOPEN} the raster file MECH4_CLEAN.TIF from the TUTORIAL directory. 

 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file MECH4_CLEAN.TIF 
from the TUTORIAL directory. 
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 Zoom in to the upper left part on the image: 
 

 
 
 

Deleting Raster 
 
The dirt near the dimension line 22 will be deleted. 
 

  Click on the Raster Select icon to open the Raster Selection Mode toolbar and choose 
the Select Dirt mode. This mode recognizes regular forms, like lines and arcs and excludes 
them from the selection (if they are not completely inside the selection rectangle). 
 
Draw a rectangle around the dirt for selection. First, mark the dirt area below the dimension 
line "22", than the dirt area to the right of the vertical line. Draw the second rectangle around 
the dirt and part of the arc. Note that the arc is not selected although the dirt is attached to it! 

 Click on this icon in the toolbar or press the [ENTER] key to Confirm the Raster Selection. 
The toolbar disappears and the selected raster (dirt) appears highlighted.  
 

 
 
To delete the selection from the image press the [Del] key.  
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Editing Raster with Pick Selection 

 
Close the arc near the dimension line 22. 
 
Click on the raster arc - it will be highlighted and receives modification handles. 
 

 
 
As long as this object is in process it can be handled like a vector entity. Click on the lower 
handle and close the arc. To bring the object back into the raster, press the right mouse 
button and click on End Command. The result should look like this: 
 

 
 
 

Edit Raster with Vector Tools 
 
Extend the left construction line of the dimension "22" and adjust its width. 
 
Click to select the line and extend the lower end of the line to the work piece. The line is not 
absolutely vertical, so click on its upper handle and move it to a vertical position. 
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 The width of the construction line should be reduced. Open the Properties dialog for the line 
({VPPROPSHOW} or Edit ►  Properties) and change the Linewidth to 0.30: 
 

 
 

 Since we used the Properties function, the selected raster line is transformed to a vector line. 
To transfer it back to the raster we have to Rasterize the line. 

 Start the Rasterize function ({VPRASTERIZE} or Raster ► Rasterize); the dialog box 
Rasterize opens: 

 

 
 

Activate Delete Entities after Rasterization and accept all other settings. Start the 
Rasterization with OK. After this process, the line becomes part of the raster image again. 
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Close the gaps in the thread. 
 
Start with the lines on the right. Select the part of the line above the gap and then below the 
gap as shown in the following screen shot: 
 

 

 Use the Combine to Line function ({VPCOMBINETOLINE} or Vector ► Combine to ► 
Line) to create a continuous line out of the two parts. After the command is completed the 
resulting new line is rasterized automatically back to the drawing. Proceed the same way with 
the two lines to the left. 

 
 

Rasterize Online 
 
Another method for repairing broken raster lines is the Rasterize Online function. Vector lines 
are rasterized directly after drawing with a given width. 

  Select Raster as Current Layer and start the function Pick Width (VPPICKWIDTH). 
The cursor changes to indicate that the width can now be picked directly in the drawing. Click 
on one of the raster lines - the measured width will be displayed. Repeat the function a few 
times to be sure to get the average value. It should read about 0.50: 

 

 Depending on where you click, the width value changes, especially at intersections. 
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  Switch on the function Rasterize Online {VPRASTERIZEONLINE} and Draw a line that 
closes the gap of the line left to the already repaired lines (VP-WIN only: use the [Shift] key to 
draw horizontal or vertical lines). With the second click the line is set. It is automatically 
rasterized with the predefined width. Continue closing the gaps of the other two lines in the 
same way: 
 

 
 
To finish this part of the drawing, go to the opposite side of the thread and close the remaining 
line gaps accordingly. Use the Rasterize Online function and check the widths of the lines 
and construction lines. The result should look like this: 
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LESSON 2  
 

RASTER ENTITIES AND RASTER OBJECTS 
 

2.2 Raster Object Handling  
 

I. VP-WIN 
 
The select raster functions provide adequate tools for editing even complex raster images. 
They enable copy and cut functions for parts of the raster which can be edited later (using the 
move, rotate, scale, and delete commands). During this lesson you will learn how to 

• Cut and Copy Raster Objects, 
• Paste Raster Objects from Files 

 
Preparation 

 

 Open {VPOPEN} the raster file FLANGE.TIF from the TUTORIAL directory: 
 

 
 
The raster drawing will be edited in two steps: first, the drillings will be corrected followed by 
adding another raster object and rasterizing/merging the two.  

 
Drawing Construction Lines 

 
First, we are going to draw some vector construction lines which will help us for a precise 
positioning of the drillings.  

 To draw the constructions lines, switch off the Erase Raster Background Mode 
({VPERASERASTER} or Edit ► Erase Raster Background) if it is still active.  

 Activate the Raster Snap ({VPSNAPR} or Options ► Snap ► Raster Snap) and the snap 
mode Intersections: 
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 Select Layer1 as Current layer and start the Draw Line {VPDRAWLINE} function. Move the 
cursor towards the center of the drawing - the raster snap marks the intersection of the two 
raster construction lines with a cross. Click to set the first point of the line. Keep the [Shift] 
key pressed to snap the line at a 45 degree angle and draw the line to the upper right corner 
of the drawing. Draw another line from the center to the lower right corner (-45 degrees).  
 
End the draw mode and pick one of the lines you have just drawn. Press the [Shift] key first 
and then click on the line's handle in the center of the drawing. Keep the [Shift] key pressed 
and drag the line end to the opposite corner of the drawing. Extend the other line in the same 
way. 

 Start the Draw Circle {VPDRAWCIRCLECENTRAD} function (Center, Radius Mode). Set the 
circle's center point to the drawing's center (raster snap to intersection) and increase the 
radius until the circle runs through the center of the upper right drilling.  
 

 
 
Stop the Draw Circle command using [ESC]. 

 Switch off the Raster Snap. 
 
 
Moving and Rotating Raster Objects 

 
The upper left drilling will be deskewed to fit to the construction lines. 
 

 Activate the Select Raster mode ({VPSELRASTER} or Edit ► Select Raster). The toolbar 
Raster Selection appears inside the workspace. 

 Zoom into the left upper drilling. Since this drilling consists of an isolated raster structure 
without connections to the rest of the drawing, you can use the Pick Area function for 
selection. Click on the respective icon - the cursor changes to a pipette. 

 Click with the pipette cursor anywhere on the drilling element - it changes to the selection 
color. The drilling is selected completely - confirm the selection (click either the respective 
icon or press [Enter]). The Raster Selection toolbar closes and the selected raster element 
(the drilling) appears with handles: 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 2: Raster Object Handling   51
 

 

 
 
There are two ways to position the selected Raster: you can use the handles to move and 
rotate the object. Then End the command (context menu). 
 
The other way uses additional commands to ease rotation and positioning. Press the right 
mouse button to open the context menu: 
 

 
 

 Select the Move function - the context menu closes and you are prompted to specify a base 
point. Click in the center of the drilling. The drilling is now attached to the cursor.  

 Activate the Vector Snap (Mode: Snap Intersections) and move the drilling to the crossing 
of the construction lines until you see the snap cross: 
 

 

 Do not press the left mouse button, otherwise the object would be immediately inserted into 
the image.  
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Instead, press the right mouse button again and select the command Rotate from the context 
menu. Rotate the object, so it will fit to the construction lines and press the left mouse button. 
This ends the Rotate command and the Move command is active again. End this command, 
too, by pressing the left mouse button again. The selected raster will be inserted in the 
drawing: 
 

 
 
Now, the lower left drilling will be deskewed to the construction lines. 

 

 Zoom in to this area. Since the drilling is connected to the outer circle a different selection 
method has to be used. Select Inside Window is the appropriate selection method. Start it 
and drag a window around the drilling in a way that all raster parts of the drilling are inside the 
window.  

 

 Since the outer circle exceeds the window it will not be selected. If not all of the drilling has 
been selected Undo the selection and try again. 

 If the drilling is fully selected (all highlighted), confirm the selection. 
 

 
 
Position the drilling on the construction lines as described above.  
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Deleting Raster Objects 

 
The lower right drilling indicates a wrong diameter. It will be deleted and replaced by a raster 
object. 
 

 Zoom into the lower right drilling. Use either Pick Area or Select Inside Window for 
selection. If all of the drilling to be removed has been selected confirm the selection and 
delete the selected raster by using the delete button ({VPDELETE} or Edit ► Delete ► 
Delete Entitie(s)) or press [Del]. 
 
 

Copying Raster Objects 
 
The upper right drilling is to be copied, rotated, and placed at the correct position in the lower 
right sector. 
 
Zoom to the upper right drilling, start the Raster Selection, select the drilling using the Pick 
Area mode, and confirm the selection.  

 To copy the selected raster click on Copy ({VPCOPY} or Edit ► Edit Object(s) ► Copy). 
You are prompted to pick a base point - click in the center of the drilling: the raster will be 
attached to the cursor. Move the raster to the lower right quarter of the drawing and adjust it to 
the construction lines as described above. 
 
The copy command remains active (multi copy command) after the entity has been 
positioned, so abort the function with [ESC] or use the context menu. 
 
 

Delete Construction Lines 
 

 The construction lines are no longer needed. Select these vector elements and delete them. 
When completed successfully, the raster drawing should look like this: 
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Pasting Raster Objects from a File 

 
Activate the Import function ({VPIMPORT} or File ► Import). The dialog box Import opens - 
select the file FLANGE_A.TIF from the TUTORIAL directory, switch off the option Specify 
Insertion Point, and click on OK. This file provides a raster object that will be added to the 
bottom and top of the current drawing. It appears at the origin position in the workspace. 
 

 

 Select the imported raster image by clicking on its frame, move it to the bottom edge of the 
component, and adjust it to the center line. You may simplify the positioning process by using 
the Move function. 
 
 

Drag'n Drop 
 
Open the file FLANGE_A.TIF from the TUTORIAL directory - a new document with this raster 
image will be created. To arrange both documents side by side on the screen tile the windows 
vertically (Window ► Tile Vertical).  
 
For the drag & drop operation select the new loaded raster. Then, click once again on the 
edge of the raster (not on the handles) and keep the left mouse button pressed: a small 
rectangle will be attached to the cursor indicating that the drag & drop function is active. Move 
the cursor into the other window to the upper part of the drawing and release the left mouse 
button. The raster will be inserted in this document as a new raster object. 
 
Maximize the window which includes your processed raster (double-click on the title bar). 
Select the imported raster object and rotate it by 180 degrees - keep the [Shift] key pressed 
for an accurate rotation. Position the object at the top edge of the component. 
 
 

Rasterization 
 

 Merge the two raster objects into the Active Image: click on the Rasterize icon 
({VPRASTERIZE} or Raster ► Rasterize) to open the respective dialog, and start the 
rasterization with OK.If the option Delete Entities after Rasterization had been switched off 
in the rasterization dialog you have to delete the two raster objects manually (select and 
[DEL]). The result should look like this: 
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 Save {VPSAVEAS} the raster as FLANGE_COMPLETE.RVD to the directory TUTORIAL. 
 
 

II. VP-CAD 
 

Preparation 
 

 Import {VPIMPORT} the raster file FLANGE.TIF from the TUTORIAL directory: 
 

 
 
The raster drawing will be edited in two steps: first, the drillings will be corrected followed by 
adding another raster object and rasterizing/merging the two.  
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Construction Lines 

 
First we are going to draw some vector construction lines which will help us for a precise 
positioning of the drillings.  
 
Draw two lines with an angle of 45 degrees (-45 degrees) and a circle according to the picture 
below: 
 

 
 
 

Moving and Rotating Raster Objects 
 
The upper left drilling will be deskewed to fit to the construction lines. 
 

 Activate the Select Raster mode ({VPSELRASTER} or Edit ► Select Raster). The toolbar 
Raster Selection appears inside the workspace. 

 Zoom in to the left upper drilling. Since this drilling consists of an isolated raster structure 
without connections to the rest of the drawing, you can use the Pick Area function for 
selection. Click on the respective icon - the cursor changes to a pipette. 

 Click with the pipette cursor anywhere on the drilling element - it turns to the selection color. 
The drilling is selected completely - confirm the selection (click either the respective icon or 
press [Enter]). The Raster Selection toolbar closes and the selected raster element (the 
drilling) appears with handles: 
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For the moving and rotation operation we are going to transform this selection into a raster 
object. Press the right mouse button to open the context menu and choose the command 
Make Entity(s) (Erase RasterBk).  
 

  Move and rotate this raster object using the corresponding CAD functions until the object 
is adjusted to the construction lines: 
 

 
 
 
Now, the lower left drilling will be deskewed to the construction lines. 

 

 Zoom in to this area. Since the drilling is connected to the outer circle a different selection 
method has to be used. Select Inside Window is the appropriate selection method. Start it 
and drag a window around the drilling in a way that all raster parts of the drilling are inside the 
window.  

 Since the outer circle exceeds the window it will not be selected. If not all of the drilling has 
been selected Undo the selection and try again. 

 If the drilling is selected completely (all highlighted), confirm the selection. Press the right 
mouse button to open the context menu and choose the command Make Entity(s) (Erase 
RasterBk). 
 
Position the drilling on the construction lines as described above.  
 
 

Deleting Raster Objects 
 
The lower right drilling indicates a wrong diameter. It will be deleted and replaced by a raster 
object. 
 
Zoom in to the lower right drilling. Use either Pick Area or Select Inside Window for 
selection. If all of the drilling to be removed has been selected confirm the selection and 
delete the selected raster. 
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Copying Raster Objects 

 
The upper right drilling is to be copied, rotated, and placed at the correct position in the lower 
right sector. 
 
Zoom to the upper right drilling, start the Raster Selection, select the drilling using the Pick 
Area mode, and confirm the selection. To copy the selection press the right mouse button to 
open the context menu and choose the command Make Entity(s) (Keep RasterBk). 
 
Move the raster to the lower right quarter of the drawing and adjust it to the construction lines 
as described above. 
 
 

Delete Construction Lines 
 
The construction lines are no longer needed. Select these vector elements and delete them.  
 

Rasterization 
 

 Rasterize the raster objects created above into the Active Image: click on the Rasterize icon 
({VPRASTERIZE} or VP Software ► Raster ► Rasterize) to open the respective dialog. 
Activate Delete Entities after Rasterization and start the rasterization with OK. The result 
should look like this: 
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Raster from a File 

 

 Import the raster file FLANGE_A.TIF from the TUTORIAL directory. This file provides a raster 
object that will be added to the bottom and top of the current drawing. 
 

 
 

 Copy the raster image with the CAD copy command and place the copy in the upper part of 
the drawing. Rotate the raster by 180 degrees, position it at the top edge of the component, 
and adjust it to the center line.  
 
Select the lower raster image and move it to the bottom edge of the component just the way 
you did with the first object.  
 

 Execute the rasterization process with the default settings and Delete Entities after 
Rasterization switched on. In its final design the edited component should look like this: 
 

 
 

 Export the raster as FLANGE_COMPLETE.TIF to the directory TUTORIAL. 
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LESSON 2  
 

RASTER ENTITIES AND RASTER OBJECTS 
 

2.3 Dimensions (VP-WIN only)  
 
During this lesson you will learn how to 

• create dimensions in an automatic and in a manual mode, 
• modify dimension text. 

 
 

Preparation 
 

 Open {VPOPEN} the raster file FLANGE_COMPLETE.TIF from the TUTORIAL directory. 
This file has been created in the previous lesson. 
 

 
 
 

Creating Dimensions 
 
Some parts of the drawing are going to be assigned dimensioning information. 
 

Diameter Dimension 
 
Dimension the external diameter of the component. 

 Start the Diameter Dimension function {VPDIMDIAMETER} and click on the large raster 
circle as the reference entity to be dimensioned. The dimension will be created instantly with 
the values of the reference entity, in this case the diameter of the circle. It can be rotated 
around the center of the circle, and you can also change the position of the dimension text by 
moving the mouse. With a mouse click the dimension will be added to the drawing. 
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Place the dimension on the lower right side of the drawing with the text outside of the circle: 
 

 
 
 

Linear Dimension 
 

 Choose Linear Dimension {VPDIMLINEAR} and click on the raster line on the top of the 
component. The dimension will be created directly. The distance to the reference object can 
be adjusted with the mouse. Place the dimension above the component, but inside the raster 
image. 

 
 
 

Move Dimension Text 
 
Move the created dimension text from the construction line. 
 
Select the dimension to display the belonging grips for modification. Click on the grip below 
the text and move it to the left. Press [Enter] or [Esc] to end the modification. 
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Manual Mode, Baseline Dimension 

 
The lower part of the component should be dimensioned with two baseline dimensions. Use 
the manual mode to create the dimensions with arbitrary length. 
 

  Activate the Manual Mode {VPDIMMANUAL} and start the Linear Dimension function. 
If the manual mode is active, no reference entity has to be selected. Instead, you need to 
specify the length of the dimension by clicking two points. These will result in two respective 
extension lines.  

 

   For easier placing switch on the Raster Snap and activate the two snapmodes 
Intersection and End Point. 
 
To specify the start point of the first extension line, please click on the intersection of the 
center construction line and the lower edge line of the component. For the second start point 
of the dimension take the intersection of the construction line on the right and the lower edge 
line. Place the dimension as shown below: 
 

 
 
 

Base Line Dimension 
 

 Next, insert a Baseline Dimension taking the distance between the center line and the 
component’s edge. Start the function {VPDIMBASELINE} and select the dimension you have 
just inserted as a base. Now, place the dimension on the lower right corner of the component. 
The dimension will be created and inserted in a predefined distance to the first dimension.  
 

 
 

  Switch off the Manual Mode and the Raster Snap. 
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Text Mode - Create Dimension Text manually 

 
Create two dimensions displaying the thickness of the two plates on the component’s top and 
bottom. Use the Text Mode to create two identical dimension text elements. 
 

  Switch on the Text Mode {VPDIMTEXT} and start the Linear Dimension function. Click 
on the right edge line of the top plate as the reference object. A dialog opens showing the 
actual length of the selected edge. The text in the edit field reads < >, i.e. the actual length of 
the dimension will be used as the dimension text. Change this text to 5.00 and close the 
dialog. Insert the dimension as shown below: 
 

 

 Insert the second dimension for the lower plate. When clicking on the respective line the 
actual length now is about 5.17. The difference between the two values depends on how the 
drawing was generated in the lesson before. Change this text to 5.00 and finish this 
dimensioning step. 

 
 

Modify Dimensions 
 

Edit Dimension Text 
 
The values of the dimensions should relate to each other. Based on the value of the lower 
dimension (26.25) change the diameter dimension and the upper linear dimension to 52.50. 
 

 Select the diameter dimension and open the properties dialog ({VPPROPERTIES} or context 
menu). Scroll down to the chapter Text and click on Advanced / Text Replacement to 
change the dimension text. The MText dialog opens showing the text < >. Change the text to 
Ø52.50 and close both dialogs. The diameter character is available as a predefined shortcut 
with [Alt+0] (see VP Software Manual Section 3, System Settings, Shortcut Tab). 
 
Modify the upper linear dimension in the same way. 
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Rasterization 

 

 Click on Rasterize {VPRASTERIZE} to transfer all entities into the raster image. The result 
should look like this: 

 
 

 Save {VPSAVEAS} the raster as FLANGE_DIM.TIF to the directory TUTORIAL. 
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LESSON 2  
 

RASTER ENTITIES AND RASTER OBJECTS 
 

2.4 Complex Raster Object Handling / Editing (VP-WIN only)  
 
During this lesson you will learn how to 

• Edit Complex Raster Structures 
• Modify Raster Text 

 
 

Preparation 
 

 Open {VPOPEN} the new raster file BEARING.TIF from the TUTORIAL directory: 
 

 

 Activate the Select Raster toolbar ({VPSELRASTER} or Edit ► Select Raster). 
 
Selections using the commands of this toolbar will be joined to one object, which thereafter 
can be handled (edited, moved, copied, scaled, etc.) as one entity. Using pick selection 
commands will bring up every picked item as a separate entity. Depending on the task both 
methods may be considered - but usually one method is favorable. 
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Erase Raster 

 
Select Raster  

 
The hatch and the lines of the cutout section at the lower right of the drawing will be erased. 
The center lines of the circle should remain.  
 
Zoom in to the lower right section. 
 

 
 

 Choose the Select Polygon function. Draw a polygon around the area to be modified: 
 

 
 
Close the polygon (right mouse menu: Close). All raster structures inside the polygon are 
selected.  
 
 

Deselect Selected Raster Structures 
 
Since not all of the selected raster should be erased, some raster entities must be deselected.  
 

+  Click on Select Line and push the minus button additionally whenever you want to 
deselect previously selected raster entities. Draw a horizontal line on top of the horizontal 
circle centerline. Start and stop inside the polygon and near the border to cover all parts of the 
line.  
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The horizontal circle center line is no longer highlighted, i.e. it is deselected. Deselect the 
vertical circle centerline in the same way. 
 

 +  Now, deselect the outer contour line of the component. Use the selection modes 
Select Arc and Select Line. Since the deselection cannot be completed in one step, repeat 
the selection until all parts of the contour are deselected. 
 

+  For deselecting the arrow use the Select Polygon command.  
 

 To accept the remaining selection click on the icon Confirm Raster Selection. 
 
Delete the selection with [Del]. The area should now look like this:  
 

 
 
 

Move Raster 
 
The drilling at the lower left including the dimensioning will be aligned to fit to the circle center 
lines. A copy of this part will then be placed on the previously edited area (see above). 
 
Zoom into the following area: 
 

 
 
 
Select Raster 

 
Select with the appropriate selection commands the circle, the arc, and both vertical 
dimension help lines (Select Circle, Select Arc, Select Line). 
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 For the dimensioning section (line, arrows, and text) use Select Rectangle for selecting. Drag 
a window around these entities and everything inside the window will be selected. Keep the 
window select area as small as possible. 

 End the selection with Confirm Raster Selection. 
 
 

Create Raster Object  
 
Right-click the mouse to open the context menu. Choose the function Make Entity(s) (Erase 
RasterBk).  
 
 

Move Raster Object  
 

 We will use the raster snap for an accurate positioning of the raster object. Activate the 
Raster Snap and select the snap modes Center and Intersections: 
 

 

 Select the raster object and activate the Move function. You are asked to define a base point 
for moving. For an optimum positioning we will set this base point in the center of the drilling 
circle. Move the cursor on the edge of the drilling circle - as soon as the raster snap reacts a 
symbol (small circle) will be shown in the center of the circle. Click (without moving the 
mouse) to place the base point. 
 
The raster object is now attached to the mouse. Move it towards the intersection of the two 
constructions lines in the center of the drilling. Due to the raster snap the object will jump 
exactly on this intersection. Click once again to end the move function and position the entity. 
 
 

Copy Raster Object  
 

 Select the raster object once again and start the Copy Objects function. Similar to the move 
function you are asked to specify a base point: Place it into the center of the drilling circle 
(assisted by the raster snap). With the base point specified a copy of the selected object is 
created and attached to the cursor. Move the copy towards the right drilling and place it on the 
intersection of the two construction lines (as described above). Abort the Copy function using 
[ESC]. 

 Disable the Raster Snap. 
 

  The dimensioning text is crossed by a vertical line. Erase the part of that line interfering 
with the text using the Select Line and Delete functions. 
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Rasterization 

 

 Rasterize the two raster objects created above into the Active Image: click on the Rasterize 
icon ({VPRASTERIZE} or Raster ► Rasterize) to open the respective dialog. Ensure that the 
option Delete Entities after Rasterization is set on and start the rasterization with OK. The 
edited part should look like this: 
 

 
 
 

Edit Raster Text  
 
We will modify some of the dimensioning numbers. 
 
Zoom in to the dimension text 56 at the lower area of the drawing and select the text by 
dragging a window. Keep the [Ctrl] key pressed when clicking the second point to make use 
of a quick window selection. 
 

 Start the Combine to Text function ({VPCOMBINETOTEXT} or Vector ► Combine to ► 
Text). 
 
The dialog Combine Text opens displaying the window selection area containing the raster 
text (rotated if necessary, so that the text appears in horizontal orientation) and its OCR 
interpretation. Modify the text to 74. and the height to 4.50. By clicking the lock symbol you 
can predefine this value for all following text.  

 
 
The new text replaces the original raster text. 
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In the same manner, modify the following dimensioning numbers: 
 

Original No. New No. 
 56  74 
 64  84 
 144  190 
 37  50 

 
With some of the text strings you may need to correct the angle and/or the text height. You 
can do this in the dialog box by assigning a different text angle and/or text style, or you may 
click the text and use the handles after closing the dialog box for adjustment. 
 

 Press the Rasterize button and confirm the settings of the Rasterize dialog to rasterize all of 
the new text into your drawing. 
 
The completed drawing looks like this: 
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LESSON 3   
 

COLOR PROCESSING 
 

3.1 Color Reduction / Separation  
 
Reduce the number of colors in a colored raster image, separate the colors.  
Functions you will learn in this lesson: 

• Combine Colors 
• Change Colors 
• Export Raster Data Separated by Colors 
• Helpful Functions for Better Color Manipulation Results 

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file BERLIN.TIF from the TUTORIAL directory. 
 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file BERLIN.TIF from 
the TUTORIAL directory. 
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While scanning the basic colors of the original image were recognized by differently colored 
pixels, i.e. there are color pattern generated from the basic colors. To reduce the number of 
colors back to the basic ones use the function Color Reduction. This lesson should give you 
an overview of the different methods of this function.  
 
We recommend executing the color reduction in two steps: 
1. Automatic reduction: as a preparation for the next step, this function reduces the amount 

of colors to a handy number. 
2. Manual reduction: this is the main step - depending on the drawing you select similar 

colors and combine them to one. 
 
 

Color Reduction 
 

 Open the Color Reduction dialog (menu Raster ► Color ► Color Reduction, 
{VPREDUCE}): 
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Automatic Reduction 

 
The amount of colors (221 colors in this sample) is far to high to start with the manual 
reduction. Therefore, we are first going to reduce the colors to a handy, useful number. 

 Click the icon Automatic Reduction to open the respective dialog: 
 

 
 
The dialog shows the current number of colors used in the image (221). Reduce the number 
to 24 colors by entering 24 in the dialog. Set the Reduction Method to Median Cut 
Algorithm and press OK to start the automatic reduction. 
 
Now, the appearance of the Histogram in the Color Reduction dialog changes - the 
remaining colors are displayed as frequency bars showing the proportionate share of each 
color in the image: 
 

 

 An automatic reducing of the original colors to a smaller number can lead to a loss of 
information separation through different colors, i.e. colors presenting different information may 
be merged together. We recommend reducing the colors down to 16 through 32 colors, 
depending on the drawing content. 
 
 

Manual Reduction 
 
Proceed like this: 

• Select a Target Color, i.e. the first color selected (all other selected colors will be 
merged to this color), 

• Select the different tones of this color 
• Check that not too many colors have been selected 
• Combine them to one color 
• If necessary, change the color value of the combined color 
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Selecting Colors 

First, start with editing the different tones of the basic color green:  

  Click the Zoom Window icon of the Color Reduction dialog and zoom to the small forest in 
the left part of the drawing. 
 

 
 

 The first selected color will become the target color - click with the pipette cursor into the 
green area of the forest. After clicking, the bar of the selected color in the histogram appears 
highlighted, its label is recessed, and all pixels of that color in the drawing change to the 
colors inverse value. For a better preview, switch on the Flash option.  
 
Not the whole forest has been selected. To select the remaining colors, click in the forest and 
draw a rectangle: 
 

 
 
Zoom in closer and click on all color pixels (mostly at the border of the forest) which should be 
also modified to the target color. Now, a total of 8 colors have been selected and the whole 
forest area appears in false color. 
 

 
 
 

Deselecting Colors 
Prior to combining the selected colors to the target color check, if not too many colors have 
been selected:  

  Zoom out to the extents of the drawing. You see that not only the forest areas are blinking but 
also the powerlines, some roads, coordinate lines, and other structures. These colors have to 
be deselected first. 
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  Zoom in to the powerline at the upper left part of the drawing, press the [Shift] key and 
window select some parts of the structures in false color: 
 

 
 
All selected colors will be removed from the selection. 
 
Zoom back to the forest. You see that this time we have deselected too many colors. Window 
select the colors in the inside of the forest. It seems that the colors of the border cannot be 
assigned clearly to the color green so, at this time, we leave off the selection. 
 
The histogram with the selected colors should look like this: 
 

 
 

  Click on Combine - all selected colors are combined to the target color. Alternatively, you can 
activate the command from the context sensitive popup menu (click on the right mouse 
button in the Preview or the Histogram field).  
 
 

Adding New Colors 

 The blue color tones of the lakes and creeks will be combined to a new color. To add a new 
target color, click the Add new Color icon. The dialog box Colors opens - select the color 
blue from Basic Colors (red=0, green=0, blue=255) and close the dialog box. 
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Since the new color should be the Target Color, select this color by clicking its color label in 
the Histogram before continuing. Now, select the colors to be combined to the target color: 
zoom to the little lake in the center of the upper part of the drawing and window select the lake 
as shown below: 
 

 
 
Other entity colors including the white background have been selected; nearly the whole 
drawing is blinking. Deselect the white background color by clicking on its label in the 
histogram. Now, you can see that the borders of the road and the elevation lines are still 
selected. Deselect them by pressing the [Shift] key and window selecting parts of the these 
structures: 

 

 

  After that, only the blue color tones of the lake remain selected. Check, if no other structures 
in the drawing have been selected. If that is not the case, combine the colors.  
 
 

Unassignable Colors  
Click on the label of the third color from the left in the histogram: 
 

 
 

This color has been selected every time in our previous steps. In the drawing you see that this 
color is part of almost all borders. That means, it cannot be assigned to anyone of the 
foreground colors.  
 
The best solution is to combine this color with the background color white. Therefore, deselect 
the third color first by clicking its label. Now, select the background color and then the third 
color. Combine the two colors to white. 
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Next, we are going to process the color black. Zoom to the building on the left part of the 
drawing. Since the target color should be black click on that label in the histogram first. Then 
select all color tones in the text, the coordinate lines, and the border of the road 
(Predominantly gray tones): 
 

 
 
Your color selection should look like this: 
 

 
 

  Combine the selected colors.  
 
Last, the red tones will be combined to one color red. Zoom to the right of the drawing where 
the road enters the forest. To select the target color, click on one of the elevation lines. Then 
select the other colors of this line, the color in the road, and the dark elevation lines in the 
forest: 

 
 

  Combine the selected colors.  
 
 

Remaining Colors 
 
Five dominant colors are now apparent along with two other random colors not having any 
correlation to the dominant colors. You can determine or compare the pixel number of these 
colors in Percent and Absolute by clicking on the respective color bars. Another way to view 
the minor colors is by using the sliding Scale bar to the right of the Histogram. When moving 
the slider up, you will see the color bars increase in height. This enlarged view helps to note 
the differential intensities of the remaining colors compared to the dominant colors.  
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These remaining low level colors, generally just a few pixels, can now be combined with any 
of the remaining major color of your choice and should not affect the character of the image. It 
may be best to combine them with the background color.  
 

Select white, either from the Preview or the Histogram, then click on the furthermost left 
color label of the two remaining colors with the right mouse button. Keep the button pressed 
and move the cursor to the right until both colors are selected (window selection) and 
Combine them. Review the raster image to ensure you will not lose any important information 
in this reduction operation. 
 
 

Modifying Colors 
 

 The background color white is to be modified to a true white. Click on the color label of the 
background in the Histogram dialog box and select the Modify Color(s) function. In the 
Colors dialog box you can modify the color deliberately. Select white as the Basic Color 
(red=255, green=255, blue=255) and close the dialog box. Just like all color operations these 
modifications can be undone and redone at any time.  
 

You can also modify other colors by selecting them subsequently and then clicking on Modify 
Color(s). 

 You cannot modify any color to a new color which is already in use. Instead, use the combine 
method. 
 
 

Save Reduction 
 
The color reduction is now completed. The color reduction and modification process can be 
saved for re-use on other similar images scanned to the same palette (important). Click the 
Save button of the Histogram dialog and save the file as BERLIN.RPL. 
 
 

Color Export 
 

 Our raster image has now been reduced to five colors. The raster structures of each of these 
colors can be exported and saved as an individual black & white raster file. Click on the labels 
of the 4 foreground colors and open the Export Colors dialog by clicking the respective icon: 
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Select the Add to Active Document option with Automatic Layer Definition set to on, 
select the option All selected Colors in one Image with Create Colored Image set to on, 
and press OK. Now, for each selected color a new b/w image will be generated and assigned 
to a new layer with the same Layer Color as the original selected color. The name for each 
raster image will be BERLIN extended by Color RGB[r g b] containing the RGB values of the 
colors. 
 
 

Removing Speckles 
 
All raster images are positioned one upon the other. Move them so that they are side by side. 

 To see the black layer you must have set your system to a white background. You can 
change your background color in Options ► System Settings... ► Tab Colors. 
 

  Select the raster images successively as Active Raster and clean them using Remove 
Speckles with the automatic mode. 
 
The following pictures show the separated raster before and after the editing (despeckling): 
 

    
 

Color Black 
 

    
 

Color Red 
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Color Green 
 

    
 

Color Blue 
 
The re-arranged raster images should look like this: 
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Other Options for Color Reduction 

 
It may be helpful to use the functions Remove Minor Color or Color Filling in the Color 
Reduction dialog prior to starting the Combining process. 

 Reload BERLIN.TIF once again. Open the Color Reduction dialog (Raster ► Color ► 
Color Reduction or {VPREDUCE}). 
 
 

Remove Minor Colors 
 

 This function provides an Automatic Color Reduction of Minor Colors of the raster image 
by combining then to their nearest colors. The process is controlled by the percentage of the 
colors with respect to the whole image. Open the Remove Minor Colors dialog by clicking on 
the icon. 
 

 
 
Use the Accumulated for All Colors option which calculates and displays the total 
percentage of all selected minor colors with respect to the image pixels. Move the slider to 
the maximum value (10%) While moving the slider you can see the colors being selected in 
the Color Reduction dialog in the background. When you have reached the maximum value, 
there are only 31 colors not selected. Note that there are all blue color tones selected in the 
histogram area. Press OK for starting the reduction. 
 
Now you can see that the blue colors will be totally lost and combined to a gray tone. To 
resolve this problem you should be aware that every main color tone should at least have 
one color in the histogram area of the Color Reduction dialog not selected, to which then 
minor colors can be automatically combined to. Press the Reset Button and retry the Remove 
Minor Color function with a smaller percentage to get a feeling for the best value. Main color 
tones should not be lost while all minor colors not bearing any significant information should 
be removed. 
 
We recommend to use values up to 1 or 2% in the mode Accumulated for All Colors. Then, 
there is little risk in losing main color information. 
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Color Filling 

 
After reducing the image with the Remove Minor Colors function, there are still many green 
tones which have a high percentage with respect to the image. 
 
There is another useful tool for an easier unification of these green colors: the Color Filling 
function. 

 Activate this function by pressing the bucket icon in the Color Reduction dialog. Your cursor 
changes accordingly. 
 
Zoom again to the small forest area in the center of your image and start color filling by 
clicking with the left mouse button into the forest area. The function fills the small forest with 
a medium green color tone generated as the mean value from the different green tones. This 
can be quite handy to generate locally coherent areas in the image. The filling will stop at the 
border lines of the clicked area, where other color patterns start. 
 
If you like to fill the forest with another color than the medium color, switch off the Color 
Filling function by clicking the bucket icon again. Select one color which you would like to use 
for filling or Add a new color green (red=0, green=255, blue=0) as described above. Then 
click the new green color button for activating this color. Now, start the Color Filling operation 
again and fill the forest on the right hand side of the image with this color. 
 
After using these functions you can start again combining the remaining colors as described 
above. 
 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 3: Color Classification   83
 

LESSON 3  
 

COLOR PROCESSING  
 

3.2 Color Classification  
 
Another approach to reduce the number of colors is the classification method. While color 
reduction is a palette based process, i.e. the entries of the color palette are modified and each 
modification changes all pixels with this color, the classification uses additional information 
from the position and the environment of each pixel. This way pixels of the same color can be 
matched with different associative color blends. 
 

A classification of colors is preferable for raster images where pixels of similar colors relate to 
a specific meaning.  
 

During this lesson you will learn how to  

• analyze colored raster with classes, 
• define the classes, 
• perform the classification. 

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file CITY.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new drawing and Import {VPIMPORT} the raster file CITY.TIF from the 
TUTORIAL directory. 
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Classification 

 

 Open the Classification dialog box with Raster ► Color ► Classification or click on the 
Classification icon in the corresponding toolbar. 

 

 
 
 

Analyzing the Raster 
 

The first step is to determine how many regions/classes the raster consists of. In this raster 
image there are 7 classes: 

• water, 
• black text, 
• red text, 
• buildings, 
• streets, 
• parks, 
• and, as a special class, the foreign trade zone (ftz). 

 
To define the class Water, select the first class from the list box Classes and click on 
New/Modify Class. Enter in the Class dialog box Water as class name and choose the color 
Blue. Close the dialog box and define all classes the same way according to this table:  
 

Name Color 
Water Blue 
Text Black 

Red Text Dark Red 
Buildings Yellow 
Streets White 
Parks Green 

FTZ (Foreign Trade Zone) Red 
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Classifying Colors  

 
The next (and main) step is to define probes for each class. A probe consists of pixels 
selected from the raster that later ought to be part of this class. By defining probes the class 
gets information about what color tones it should contain. It is not necessary to select all color 
tones of a class (selecting color tones means selecting pixels with the desired color tone), this 
will be done later automatically.  
 
However, it is important to select color tones that cover the range of the class color. For 
instance, the water region has color tones ranging from bright blue to dark blue. In this case 
the bright and the dark blue tone must be selected with one or more probes in addition to 
some (but not all) color tones in between.  
 

Picking Area Probes 

  Start with the class Water: Select Water as the Active Class and switch the Pick Probe 
mode to Area. The cursor appears as a bucket indicating that you can pick rather large 
areas. 
 
Zoom to the second water region on the top of the raster image and click in the lower half of 
this region (below the red line). The selected part of the image will appear as a blue area 
overlaying the blue part of the image. All pixels in this area become part of the probe. The 
Active Class window shows Water (1) Probes indicating that one probe has been picked for 
the class Water.  
 
As you will notice, the dark blue edge of the water region has not been covered, although it 
should be part of the class. There are two ways to go on now: You may either pick another 
probe containing these pixels, or you remove the last probe and try to find a new one which 
includes all important color tones of this class. We will go the second way. 
 
Click on Remove Probe or use the right mouse button to remove the last selected probe – 
the area will disappear. For the new probe click on one of the dark blue pixels on the edge. 
The new area will cover a large area of the blue and of the yellow region: this probe cannot be 
used. Remove it (click on Remove Probe or on the right mouse button) and try to pick one of 
the less dark blue pixels.  

  The goal is not to find a probe that includes all pixels of the region/class but to find a probe 
that bears all major color tones of the region. 
 
The area of the probe does not have to cover all pixels of the class, since it already contains 
most of the dark blue pixels on the edge, most of the lighter ones in the center, and no yellow 
pixels. To get a good probe click as shown below - the new area should look like this:  
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Since all major color tones are included in this probe, no additional probes are necessary for 
this class.  
 
Change the active class to Buildings and zoom to the block between "Battery" and 
"Sansome" street. Click right into the block's center. Depending on which pixels you hit, only a 
small area is selected or almost the whole block is covered. Try to find a probe that includes 
most of the block's interior and most of the darker yellow pixels on the edge. Do not hit any 
black/dark gray pixels from the edge.  

  In case edges should be part of a class probes have to include pixels of these edges. If you 
do not want to include edges in a class make sure that no edge pixels will be selected in the 
probe. 
 
As different probes alter the classification results it is essential that you use probes from 
regions with the following coordinates: 
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 Class Pick Position Pick Probe Mode 

1 Water 

 

 

2 Streets 

 

 

3 Buildings 

 

 

4 FTZ 

 

 

5 Parks 

 

 

 
Picking Line/Text Probes 

  Select Text as the active class. Change the Pick Probe mode to Line/Text. With this mode 
rather small areas will be selected. 
 
Zoom to the text TELEGRAPH HILL and click on the letter R. Try to find a probe that covers 
most of the letter but does not touch the yellow region. Again, it is important to be aware of the 
edges.  
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Change to the Red Text class and zoom to the red number 200.Click exactly where the two 
“0” characters are joined. 
 

 Class Pick Position Pick Probe Mode 

6 Text 

 

 

7 Red Text 

 

 

 
 

Testing the Classification 
 

All previously defined classes have been assigned probes. Now we are going to test the 
probes whether they contain enough information for a working classification. 
 
Before testing the classification the probes have to be processed – click on Process Probes. 
The dialog Classification disappears and a progress bar shows up. Depending on the 
processing speed of your computer this will take some time.  
 
When the processing is completed click on Test Classification. Choose the center area of 
the raster image as test area with a window frame. The classification for this area will take 
some time. 
 

 
 
Compare the results with the original image by switching the test area off and on (click the 
checkbox Show in the Test Areas field). The quality of the probes is displayed in the fields 
Active Class and Probes of Active Class. Probes with a low percentage should be revised 
and replaced by more suitable one. In the test area you will see some errors: 

• the black street names are in blue, 
• the black text in the water region is almost erased, 
• the red text COIT TOWER is in black, 
• there are white spots in the building region. 
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Obviously, there were too few color tones included in the probes, especially for the black text. 
To get better classification probes additional colors have to be picked.  
 

 
 
For the black text we only looked at black text on yellow background. For improvement we 
also have to consider black text on green, on white, and on blue background. Take the probes 
from the areas that were assigned to the wrong class: 
 

 Class Pick Position Pick Probe Mode 

8 Text 

 

 

10 Text 

 

 

11 Text 
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For the classes Red Text and Buildings click probes at the following coordinates: 
 

 Class Pick Position Pick Probe Mode 

12 Red Text 

 

 

13 Buildings 

 

 

14 Buildings 

 

 

 
Clear the test area and test the new probes. Don't forget to process the probes first! Now the 
results look much better than before, however it can still be improved: The black text on the 
yellow background is too thick. Some color tones belonging to the buildings class were 
assigned to the text class. They have to be picked with a probe of the Streets class: 
 

 Class Pick Position Pick Probe Mode 

9 Streets 

 

 

 
Once again, test the classification (Process Probes and Test Classification). Now the text 
reads better. 
 
 

Saving Probes and Classification 
 
Click on Save Probes and save your classes with the assigned probes to CITY_1.VPS. If you 
have similar raster images you can create a VPS file containing classes and belonging probes 
that are likely to apply to these images as well. Then, for each raster image load your VPS file 
and just add the classes and probes which are unique in this image. 
 
Save the processed classification values with Save Classification to CITY_1.VCS. With this 
file you can classify raster images with the same regional structure.  
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Click on OK, and the image will be converted to seven colors corresponding with the seven 
generated classes. 
 
The sample image should now look like this: 
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LESSON 4   
 

RUBBER SHEETING 
 

4.1 Grid Snap and Manual Input  
 
Rubber Sheet a raster image with given reference points. Use the following methods: 

• Multi Point Rubber Sheeting 
• Enter Reference Points with Grid and with Manually Input 

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file MAP.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file MAP.TIF from the 
TUTORIAL directory. 
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Settings 

 
The map will be rubber sheeted so that the coordinates of the reference points correspond 
with the map's details. 

 In the menu Raster call the sub menu Rubber Sheeting and select the function Multi Point 
Rubber Sheeting or {VPRUBMULTI}. You are requested to set up the coordinate system. In 
the User Coordinate System dialog box set the User Units to Meter since this map has 
been assigned Gauss-Krueger coordinates. Set the Drawing Scale to 1:1000 as indicated on 
the map (bottom). Further, make sure that the Display option is set to Display Coords. In 
User Units, and that the checkmark is set for the option Place Raster and/or Vector Data 
on OK. 

 
 
Proceed by confirming the settings with OK. The Transform Data dialog box opens. 
 

 
 

Please, make sure to set the option Adjust Coordinate Values to the new Coordinate 
System and click on OK to proceed.  
 

The dialog Place/Adjust Drawing opens. The function provides to position, rotate or scale 
your document. In our lesson we will only assign a new position to the raster image. We will 
use the lower left reference point on the map as the new Origin (in parcel 142/2). 
 

Click on Select Point. Now the dialog fades and you can define a reference point in the 
document. Zoom in to the the lower left reference point and click on the center of the cross 
mark. The dialog Placing Reference opens – type in the new point coordinates (4485500, 
5382500) and confirm with OK. The dialog Place/Adjust Drawing re-appears to display your 
entries. 
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Confirm with OK. 
 

 VP-CAD: After setting up the coordinate system it may be possible that AutoCAD cannot 
display the full view, since a REGEN is needed. With an active command, however, this is 
impossible. In this case terminate the rubber sheeting with Abort and start it again while 
confirming the coordinate settings with OK. 

 
 

Entering of Reference Points 
 
Next, you are requested to enter the rubber sheet settings. The current raster map contains 
reference points which are structured in a grid. The distance between each point is 100 m.  
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Entering with Grid Snap 

 
The grid structure of the points in our sample prompts for using the 'From Grid’ method first. 
In the Rubber Sheet Settings dialog box... 
 

 
 
...mark the options From Grid (set the grid distance to 100.00) and Automatic Zoom Factor 
(set the factor to 1:2). Select the calculation mode Polynomial (calculation method Helmert, 
Affine, etc.). Click on OK. 
 
The main dialog box Rubber Sheeting opens. 
 

 
 
Since the Grid Snap option has been chosen, a grid will be overlaying the whole raster image 
with the specified spacing. This grid correlates with the origin. At the grid's line intersections 
the reference points are expected. At this stage of processing the grid is visible and can easily 
be modified, e.g. if you see that the grid distance does not match with the raster image's 
target reference points just click on Grid/UCS and adjust the grid settings. 
 
Now press the button Input Points to start entering reference points.  
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The program will zoom to the first grid point on the lower left. Click on the center of the cross 
point. 

 
 
After clicking the first reference point VPHybridCAD moves automatically to the next grid point 
and zooms in. The grid points are addressed from left to right and from bottom to top. 
Proceed the same way for all remaining reference points. The points you enter will be 
numbered. The target values (grid points) will be indicated as green cross marks while the 
entered actual values will be displayed as red cross marks (they should reside on top of the 
reference cross marks in the image). The deviation between both values is shown by a green 
line. In case that a residual error will remain after executing the rubber sheeting process the 
actual value's final position will be indicated with a yellow cross mark. In detail, this will look 
like this, e.g. for reference point no. 6: 
 

 
 
Depending on the number and position of reference points the highest possible transformation 
function (rubber sheeting function) will be selected automatically - in our example the 
Quadratic function is chosen. 
 
 

Entering Points Manually (Edit Target Points) 
 
Maps which do not contain reference points on a grid structure require to enter points without 
the grid snap option. We will demonstrate this method with our sample map. First, delete all 
points you have already entered. Click on Delete repeatedly until no points are displayed any 
more. 
 
Click on the button Grid/UCS to open the Rubber Sheet Settings dialog. Now, select the 
Manually (Edit Target Points) function and confirm with OK. The cursor changes to a frame 
box. Click the button Input Points in the dialog Rubber Sheeting. 
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Now, click on the upper right reference point. The point will be zoomed in according to the 
previous zoom settings. Place the cursor to the center of that point (Cross) and click. The Edit 
Point dialog box opens: 
 

 
 
It shows the point's actual value and the target value. For the target value enter 4485700 as 
x value and 5382700 as y value. Confirm with OK. Proceed with entering more reference 
points: 

upper left: x = 4485500 y = 5382700 
lower left: x = 4485500 y = 5382500 
lower right: x = 4485700 y = 5382500 
center: x = 4485600 y = 5382600 

 
Just like working with a grid snap the transformation function will change depending on the 
number of points you have entered - since we have now entered fewer points (5), the Linear 
function is selected.  
 
 

Editing Reference Points 
 
You can edit individual points by highlighting the respective point in the selection listing and 
clicking on Edit Point. The point will be zoomed in and you can modify the target value in the 
Edit Point dialog box. 
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Rubber Sheeting 

 
Click on OK to start the rubber sheeting process - this will take a few seconds. After rubber 
sheeting is completed you can review the reference points in the image: the values displayed 
now correspond with the map's coordinates. 
 

 
 
Close the Rubber Sheeting dialog box with OK and Export {VPEXPORT} the raster as 
MAP_RUB_1.TIF. 
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LESSON 4  
 

RUBBER SHEETING 
 

4.2 Reference Points from a Vector File - Automatic Input  
 
Rubber sheet a raster image with reference points from a vector file. Use the following 
methods: 

• Multi Point Rubber Sheeting 
• Reference Points are Corner Points of Polylines or Centers of Circles 

 
 

Preparation 
To rubbersheet a raster file, always open the raster file first, adjust the coordinate system, 
and then import the vector file. 
 
 

Loading the Raster File 
 

VP-WIN: 

 Open {VPOPEN} the raster file RS1812C.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file RS1812C.TIF from 
the TUTORIAL directory. 
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Adjusting the Coordinate System 

 

 Open the User Coordinate System dialog (menu Options ► User Coordinate System or 
{VPUSERCOORDS}). Change the User Units to Meter (the example map has been assigned 
Gauss-Krueger coordinates), and set the Drawing Scale to 1:500 as indicated on the map. 
Activate the options Display Coords. In User Units and Place Raster and/or Vector Data 
and proceed with OK. 
 
In the Transform Data dialog activate Adjust Coordinate Values to the new Coordinate 
System and continue with OK. 
 
The dialog Place/Adjust Drawing opens. The lower left reference point on the map will serve 
as the Origin. Click on Select Point, zoom in and click on the circle symbol’s center.  
 

 
 
Enter the new coordinate 119.35, 79.89, and confirm the entry. Close the dialog Place/Adjust 
Drawing with OK. 
 
 

Importing the Vector File 
 

VP-WIN: 

Select from the File menu the submenu Import ({VPIMPORT}) to open the import dialog. 
Switch off the option Specify Insertion Point, choose from the TUTORIAL directory the file 
RS1812C_SEL.RVD and click OK.  
 

VP-CAD: 

To import the vector file use the Insert Block function ({_insert}). Browse to the TUTORIAL 
directory and select the file RS1812C_SEL.RVD. De-select the option Specify On-screen, 
activate the option Explode, and click OK. 
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The file contains a frame indicating the approximate position of the raster. Inside this frame 
you will notice circles and a polyline - these entities are used for the rubber sheeting process. 
 

  
 
 

Rubber Sheet Settings 
 

 Click on the Rubber Sheeting icon (menu Raster ► Rubber Sheeting or {VPRUBMULTI}). 
First, the User Coordinate System dialog opens showing the settings entered above. Close 
the dialog with OK to proceed. 
 
In the Rubber Sheet Settings dialog mark the options Use Intersections of Vector Entities 
and Automatic Zoom Factor (set factor to 1:2). Select the calculation mode Polynomial 
(Helmert, Affine, etc.) and press OK. 
 
A dialog opens prompting you to select the vector entities for the specification of the reference 
points. 
 

 Switch off the raster display and Window Select the circles and the polyline in the frame, 
however, not the frame itself. Complete the selection with [ENTER]. A message box shows 
the amount of points found in the selection (14 points = 8 circles (center points) + 6 corners of 
the polyline). 

 Close the message box and switch on the raster display again. 
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Rubber Sheeting 

 
The main dialog box Rubber Sheeting opens. The selected vector reference points are 
displayed in the dialog: 
 

 
 
Press the button Input Points to start entering the reference points. 
 
The program zooms to the first point. A 'rubber band' is attached to this point and to the 
cursor indicating the target position of the reference point. To specify its actual position click in 
the center of the raster circle.  
 

 
 

The next reference point will be zoomed in. Proceed with this and all other points in the same 
way. 
 
The target values will be indicated as green cross marks while the entered actual values will 
be displayed as red cross marks. The deviation between both values is represented by a 
green line. If a residual error remains after the rubber sheeting process the final position of the 
reference point will be indicated as a yellow cross mark.  
 
After entering the 14 points the Quadratic function is selected automatically. Click OK to start 
the rubber sheeting process. The values displayed now correspond with the map coordinates. 
Close the Rubber Sheeting dialog box with OK. 
 
The map is prepared for further operations. Export the raster as RS1812C_RUB_2.TIF. 
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LESSON 4  
 

RUBBER SHEETING 
 

4.3 Reference Points in a Vector File - Manual Input  
 
Rubber sheet a raster image with reference points from a vector file. Use the following 
methods: 

• Multi Point Rubber Sheeting 
• Enter Reference Points Manually with Vector Snap 

 
 

Preparation 
 
See lesson 4b to load the raster file RS1812C.TIF, to adjust the coordinate system and to 
import the file RS1812C_SEL.RVD. 
 
 

Rubber Sheeting  
 

 Start the Multipoint Rubber Sheeting. Switch off the option Place Raster and/or Vector 
Data  and accept the coordinate settings with OK. 
 
In the Rubber Sheet Settings dialog mark the options Manually (Pick from Vector 
Drawing) and Automatic zoom Factor (set factor to 1:2). Select the calculation mode 
Polynomial (Helmert, Affine, etc.) and click on OK to open the main dialog. 
 
 

Entering of Reference Points 
 

VP-WIN: 

 Switch on the Vector Snap and activate the modes: Snap Intersections and Snap Center. 
 

VP-CAD: 

Switch on the object snap (OSNAP). 
 
In the rubber sheeting dialog press the button Input Points to start entering the reference 
points. Note that the Vector Snap / OSNAP switches off automatically, because you first need 
to click the raster points. 
 
Enter the data of a reference point in three steps (mouseclicks): 

First click: Zoom into the drawing. 
Second click: Get the original position from the raster. 
Third click: Get the target position from the vector entity. 
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Click on the reference point on the lower left of the drawing - the point will be zoomed in. Click 
in the center of the raster circle to set the actual position of this reference point. After clicking 
the point the Vector Snap / OSNAP will be activated again and a 'rubber band' is attached to 
the cursor. Move the cursor towards the vector circle - the end of the rubber line snaps on the 
center point.  
 

 
 
Click again to set the target position and continue with the remaining reference points. 
 
After entering all points the Quadratic function will be selected automatically. Click on OK to 
start the rubber sheeting process - this will take a few seconds. After the rubber sheeting 
process is completed you can review the reference points: now, the values displayed 
correspond with the map's coordinates. 
 
Close the Rubber Sheeting dialog with OK, disable the Vector Snap, and Export the raster 
as RS1812C_RUB_3.TIF. 
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LESSON 4  
 

RUBBER SHEETING 
 

4.4 Reference Points from a Text File (VPHybridCAD)  
 
Rubber sheet a raster image with given reference points. Use the following methods: 

• Multi Point Rubber Sheeting 
• Enter Reference Points from a Text File 

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file RS1812C.TIF from the TUTORIAL directory. 
 

VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file RS1812C.TIF from 
the TUTORIAL directory. 

 

 Start the Multipoint Rubber Sheeting. In the User Coordinate System dialog set the User 
Units to Meter since this map has been drawn in Gauss-Krueger coordinates. Set the 
Drawing Scale to 1:500 as indicated on the map. Activate the options Display Coords. In 
User Units and Place Raster and/or Vector Data and proceed with OK. 
In the Transform Data dialog activate Adjust Coordinate Values to the new Coordinate 
System and continue with OK. 
 
The dialog Place/Adjust Drawing opens. The lower left reference point on the map will serve 
as the Origin. Click on Select Point, zoom in and click on the circle symbol’s center.  
 

 
 

Now, enter the new coordinates (119.35, 79.89) in the command line and confirm your entries 
with [Enter]. Close the dialog box with OK.  
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Entering of Reference Points 

 
Next, define the Rubber Sheet Settings. Mark the options Input From File and Automatic 
Zoom Factor (set factor to 1:2), and select the calculation mode Polynomial (Helmert, 
Affine, etc.). Click on OK - an Open dialog requests you to specify the file with the reference 
points. Load the file RS1812C.TXT from the TUTORIAL directory. 
 
The File Settings dialog box opens where you need to specify the formatting of the text file. 
Disable all Separator types, set Begin Coordinate with Row to 4, and press Set Rows: only 
the rows containing reference points remain. Enable the separator type Tabulator to divide 
the values into 4 rows (this sample only; other text files may have different formatting): 
 

 
 

The X, Y, and Z coordinates of the reference points are listed in the columns 2, 3, and 4. This 
function only requires the X and Y coordinates, so type in the numbers of the X and Y rows in 
the respective fields on the lower left of the dialog. Close the dialog with OK. A message box 
indicates that 14 reference points have been loaded. Close the message box with OK to open 
the main rubber sheeting dialog. 
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Rubber Sheeting 

 
The main dialog Rubber Sheeting displays the coordinates of the loaded points: 
 

 
 
The reference points are also displayed as cross marks on the raster - this allows you to 
check whether the points have been imported correctly. 
 

 
 
Press the button Input Points to start entering the reference points. VPHybridCAD zooms 
into the first reference point area. Similar to lesson 4b, a rubber band is attached between the 
cursor and the target coordinates of the reference point. Click on the center point of the raster 
circle which defines the actual coordinates of this reference point. Then, the program 
continues with the next point. Click all actual points.  
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The 9th reference point is not available in the raster, so you need to skip this point. Press the 
right mouse button to open the context menu... 
 

 
 
...and select Skip Point - the program continues with the next point. After entering all points 
the Quadratic function is selected automatically. Click OK to start the rubber sheeting 
process. The values displayed now correspond with the map coordinates. Close the Rubber 
Sheeting dialog box with OK. 

 

 
 
Export the raster as RS1812C_RUB_4.TIF. 
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LESSON 4  
 

RUBBER SHEETING 
 

4.5 Reference Points from a Text File (VPmap Series)  
 
Rubber sheet a raster image with given reference points. Use the following methods: 

• Multi Point Rubber Sheeting 
• Enter Reference Points from a Text File 

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file MAPGeo.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file MapGeo.TIF from 
the TUTORIAL directory. 
 
As the selected file is in GeoTIFF format and thus, contains a complete coordinate system 
accordingly, a dialog opens: 
 

 
 
The coordinate system in the file is correct, so the option Update Coordinate System (UCS) 
should be selected before proceeding with OK. 

 Start the Multipoint Rubber Sheeting. In the User Coordinate System dialog the 
coordinate settings from the loaded file are already set. This includes the Coordinate 
System/ Projection, the User Units, and the Drawing Scale. The reference points for this 
map have been collected using a GPS receiver and thus you have to set the option Display 
Coords. unprojected (in Degrees).  

 
Accept all other settings in this dialog box with OK.  
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Entering of Reference Points 

 
Next, define the Rubber Sheet Settings. Mark the options Input From File and Automatic 
Zoom Factor (set factor to 1:2), and select the calculation mode Polynomial (Helmert, 
Affine, etc.). Click on OK - an Open dialog requests you to specify the file with the reference 
points. Load the file MAPGeo.txt from the TUTORIAL directory. 
 
The File Settings dialog box opens where you need to specify the formatting of the text file. 
Disable all Separator types, set Begin Coordinate with Row to 4, and press Set Rows: only 
the rows containing reference points remain. Enable the separator type Tabulator to divide 
the values into 4 rows (this sample only; other text files may have different formatting): 
 

 
 

The X, Y, and Z coordinates of the reference points are listed in the columns 2, 3, and 4. This 
function only requires the X and Y coordinates, so type in the numbers of the X and Y rows in 
the respective fields on the lower left of the dialog. Close the dialog with OK. A message box 
indicates that 11 reference points have been loaded. Close the message box with OK to open 
the main rubber sheeting dialog. 
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Rubber Sheeting 

 
The main dialog Rubber Sheeting displays the coordinates of the loaded points: 
 

 
 
The reference points are also displayed as cross marks on the raster - this allows you to 
check whether the points have been imported correctly. 
 

  
 
Press the button Input Points to start entering the reference points. VPmap (pro) zooms into 
the first reference point area. Similar to lesson 4b, a rubber band is attached between the 
cursor and the target coordinates of the reference point. Click on the center point of the raster 
circle which defines the actual coordinates of this reference point. Then, the program 
continues with the next point. Click all actual points.  
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The 5th reference point is not available in the raster, so you need to skip this point. Press the 
right mouse button to open the context menu... 
 

 
 
...and select Skip Point - the program continues with the next point. After entering all points 
the Linear function is selected automatically. Click OK to start the rubber sheeting process. 
The values displayed now correspond with the map coordinates. Close the Rubber Sheeting 
dialog box with OK. 

 

 
 
Export the raster as MAPGeo_RUB.TIF. 
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LESSON 4  
 

RUBBER SHEETING 
 

4.6 Calibrate to Drawing Format  
 

Calibrate a raster image to a defined drawing format. Use the following method: 

• Calibrate to Drawing Format 
 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file SCAN2156.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file SCAN2156.TIF from 
the TUTORIAL directory. 
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 From the menu Raster call the sub menu Rubber Sheeting and select the function Calibrate 
to Drawing Format or {VPRUB4POINT}. The Calibrate to Drawing Format dialog box 
opens: 
 

 
 

The original drawing has a DIN A3 size with margins of 5.0 mm. Set the Paper Format to 
DIN/ISO A3 (420 x 297 mm) and the Layout Orientation to Landscape. Enter 5 for Margins 
and disable Different Margins and Crop/Trim to Margins. 
 
Accept these settings with OK.  
 
 

Calibration 
 
A double rectangle is placed on the raster drawing representing the selected paper format (the 
outer frame marks the cutting size of the paper, the inner frame the standard DIN format). The 
cursor appears with a frame box linked (rubber band) on the upper left corner of the template 
format's inner rectangle (green). Click into the upper left corner of the raster to zoom in. Then, 
click precisely on the corner of the inner raster rectangle (you may use the raster snap). 
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After clicking this first corner point the program zooms out and the cursor is linked to the next 
point. Specify this point and the next points as described above. After specifying the fourth 
corner the calibration process starts and adjusts the raster to the chosen paper format: 
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LESSON 5   
 

MERGING / MONTAGE 
 

5.1 Merge Two Raster Files  
 
Merge two raster images into one. The overlapping region should be erased. 
 
 

Loading the First Raster File 
 

VP-WIN: 

 Open {VPOPEN} the raster file VERMGR_1.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file VERMGR_1.TIF 
from the TUTORIAL directory. 
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Loading and Editing the Second Raster File 

 

 From the menu Raster select the function Merge {VPMERGE}. The dialog box File to Merge 
opens - choose the file VERMGR_2.TIF from the TUTORIAL directory. 

 

 
 

The new raster if monochrome will be inserted next to the first raster file to the right - with b/w 
files shown in the color Raster Selection (default: red). The Merge File dialog box opens 
offering several methods to adjust/scale the second raster to the first one: 
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Select the Cut Edge method, meaning that the second raster will be moved, rotated, and 
scaled according to your definitions, and that the overlapping parts will be erased. Start this 
process with OK. 
 

 
 

First, specify the two points required for the move operation: click with the frame box cursor 
on the left side of the small lake area in the upper left part of the second raster. The function 
zooms in, allowing you to click precisely on the reference cross (no. 1). With your second click 
the functions zooms out and the frame box cursor reappears with a "rubber band" attached to 
it. To pick the second point (no. 2 in the main raster), proceed the same way as for the first 
point. With the points set the second raster is moved so that the two points fit upon each 
other.  
 
Now, you are prompted to enter the next two points for the rotation and scaling. Use the two 
reference points in the lower part of the overlapping area (zoom in for a better view). Proceed 
as described above: first, pick the point in the second raster (no. 3) then, click on the 
corresponding point in the main raster (no. 4). 
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After you have specified these points the Switch Image Parts dialog box opens: 
 

 
 
In this dialog you can specify the parts of the images to be erased. Click on Switch Parts to 
see the alternative possibility. Choose the first (default) method (as shown in the picture 
above) and click OK. This will start the merge process which takes a few seconds. The result 
should look like this: 
 

 
 

Export {VPEXPORT} the drawing as VERMGR_NEW.TIF to the SAMPLES/GIS directory. 
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LESSON 6   
 

TRACING 
 

6.1 Monochrome Raster  
 
After loading a raster image some elements will be traced and exported. The following steps 
are necessary: 

• Tracing of contours (free forms) 
• Tracing of CAD elements (circles, lines etc.) 
• Export of the traced vector entities  

 
Preparation 

 
VP-WIN: 

 Open {VPOPEN} the raster file BEARING.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file BEARING.TIF from 
the TUTORIAL directory. 
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Contour Trace Settings 

 

 Click on the Trace Settings icon ({VPTRACESETTINGS} or Vectorize ► Trace Settings) to 
open the respective dialog box. In the General tab set the Straightening option to Weak. 
You can experiment with these values later. Stronger straightening will reduce the number of 
vertices and therefore will produce straighter lines, such as found in construction drawings. 
However, a weak setting is advised to achieve more accurate contour representations.  
 

   
 
In the tab Contour / Interactive Trace switch off all settings in the upper two sections of the 
dialog. Settings in the lower dialog section are only relevant when tracing in interactive mode. 
 
Keep all other settings and leave the dialog box with OK. 
 

VP-WIN: 

 For better entity distinction we choose layer Layer1 as Active Layer {VPLAYERS}. Here, the 
traced contours appear in red color. Click on the indicated icon to open the Layer Manager. 
Select the layer Layer1 and click Activate to change the active Layer to Layer1. Close the 
dialog with OK. 
 

VP-CAD: 

For better entity distinction create a new layer Layer1 with the color red and select this layer 
for the Active Layer. 
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Contour Tracing 

 
We are going to vectorize (trace) only the outline contour of the bearing. 

 To start the contour tracing click the Trace Contours icon ({VPCONTOURTRACE} or 
Vectorize ► Contour Trace). The cursor changes to a Nail Cursor indicating that the 
contour tracing is activated. Click on the component's upper outline next to the vertical axis. 
The outline will be recognized up to two line interruptions. It will be marked in the current layer 
color (red). 
 
We want to attach the next fraction of the outline to the traced polyline. Keep the [Shift] key 
pressed - a plus sign (+) will be added to the cursor: 

 

 
 

Click on the next line fraction: the outline will continue up to the next interruption. 
 
Continue tracing the entire outline the same way. The remaining gap between both ends of 
the resulting polyline will not be closed automatically. Click the right mouse button to open the 
context menu and select Edit Contour. The contour is now drawn with grips allowing for 
adjustment and editing of its vertices and a toolbar appears showing the available editing 
functions. 

 Select Close Polyline. Exit the Edit Contour function by clicking the green check mark or 
by selecting End Command in the context menu. End the Trace Contour command by 
clicking its icon once again or by hitting [ESC] or by selecting End Command from the 
context menu. 
 
Now, the outline is vectorized as a single closed polyline: 

 

 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 6: Tracing Monochrome Raster   123
 

 
CAD Tracing 

 
CAD elements lines, circles, and arcs can be vectorized interactively (traced) to individual 
entities using the CAD Trace function.  
 
Select Layer1 as the active layer. 

 Click this icon to activate the CAD Trace function ({VPCADTRACE} or Vectorize ► CAD 
Trace). The Needle and Thread Cursor appears. 

 Click the contour of the drilling hole at the lower left side. The circle will be recognized and 
converted automatically. Now click the upper drilling hole. Only an arc element will be 
recognized, since the raster of that drilling contains some gaps. To add the remaining 
fractions keep the [Shift] key pressed and pick the two remaining circle fractions 
successively. At the end, a circle entity will be generated automatically. With the Undo 
function or with VP-WIN {VPUNDO} you can undo your pickings. Proceed the same way with 
the other drilling hole and with the circles in the center section and the one on the lower right 
side. 
 
 

Exporting Vectors 
 

  Switch off the Raster Display {VPRDISPLAY} for only viewing the vector data.  
 
Now, the drawing should look like this: 
 

 
 
Activate the Export function from the File menu. Set the file type to DXF and export the 
drawing as BEARING_1.DXF. 
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LESSON 6   
 

TRACING 
 

6.2 Colored Raster  
 

I. VP-WIN: 
 
The lines of a colored raster drawing will be vectorized using Contour Trace. A Color 
Cleanup using a filter will be done to improve the image quality and the Automatic 
Foreground/ Background Definition will be used. 
 

Preparation 
 

 Open {VPOPEN} the raster file CONTOURS.TIF from the TUTORIAL directory. 
 

 
 

Layer 
 

 Open the Layer Manager {VPLAYERS} and create the following layers for the traced lines: 
 

Name Color Width 
River Blue 0.15 mm 
Roads Red 0.30 mm 
Elevation1 Cyan 0.15 mm 
Elevation2 Magenta 0.30 mm 

 
Set Layer River active and close the dialog. 
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Image Settings 

 

 Click on the Image Settings icon ({VPIMAGESETTINGS} or Options ► Image Settings) to 
open the respective dialog box. Since we want the polylines to follow the raster with highest 
precision set the Exact option of the Image Characteristics to on.Also, make sure that the 
option Foreground/ Background Definition is set to Automatic. This allows for a tracing of 
structures withdifferent colors without changing the active color of the image. Close the dialog 
with OK. 

 
 
Trace Settings 

 

  Open the Trace Settings in the General tab. Switch the Straightening to None to achieve a 
precise polyline representation; enable Remove Artifacts and enter a value between 0.6 and 
1.0. The other options should also be switched off. Close the dialog with OK. 
 
 

Color Cleanup 
 
The raster quality is not very good, since this image has been scaled. We will use a filter to 
improve the image quality for the tracing process. 
 

 Click on the Color Filter Operations icon ({VPFILTER} or Raster ► Filter ► Color Filter 
Operations). A dialog opens: 
 

 
 
In the Blur filter section select the Fast Median filter. Take a size of 3 and use the Apply 
button. 
 

Contour Trace 
 

 Activate Contour Trace {VPCONTOURTRACE} and click on the blue river branch in the 
upper left area of the drawing. Be careful to click on a blue pixel, otherwise another color will 
be traced. In this case, just right-click and choose Undo from the context menu to delete the 
wrong polyline and try again. 
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The path is traced up to the first intersection or the first interruption of the contour - depending 
on the click position. 
 
Use the [Shift] key to add the next branch of the river. Continue to do this until the branch is 
traced to the lower right area of the drawing. Now, trace the other branches of the river into 
separate polylines. For larger drawings and also when you need to append frequently it is 
useful to change two trace settings: open the trace settings dialog on the Contour / 
Interactive Trace tab. Now, set the options Append Mode and Pan to Entity End. This 
switches automatically to the append mode after a tracing stops due to an intersection or a 
color change. Hold down the [Shift] key when clicking to start tracing a new entity. 
 
Change the active layer to Roads and trace the roads of the drawing. The number of the road 
cannot be traced - it will be drawn later in the post edit step. Now, activate layer Elevation1 
and trace the thin contour lines. Click on the green pixels of the lines for a good tracing result.  
 
Thereafter, set layer Elevation2 active and trace the thick contour lines.  
 
Some lines cannot be traced. Skip them - they will be drawn manually in the post edit step. 
 
 

Post Edit 
 

 End the contour tracing and start drawing all lines that couldn't be traced. Click on Draw 
Polyline {VPDRAWPOLY} and draw along these lines. Do not forget to activate the 
accordingly layer. 
 
Some polylines need to be modified because they have too many or too few vertices. 

 Start the Edit Polyline/Spline function {VPPEDIT} and select one of the road polylines that 
were traced too long - a toolbar appears offering various edit modes. 

 Activate the Edit Vertices mode and zoom to the number of the road. Here, we want to 
separate the number from the road. Hold down [CTRL] and click on the vertices to be 
removed.  
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  Remove all vertices on the number or the ellipse around the number. End the command 
and draw the number manually. 
 
Polylines can also be edited during the trace operation by using Edit Contour in the context 
menu. 

 
Continue editing the whole drawing the same way. After that, the drawing should look like this: 
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II. VP-CAD: 

 
Some lines of a colored raster drawing will be vectorized using Contour Trace. The Active 
Color will be set to define the raster structure for tracing. 
 

Preparation 
 

  Start with a new document and Import {VPIMPORT} the raster file CONTOURS.TIF 
from the TUTORIAL directory. 
 
 

Color Cleanup 
 
The raster quality is not very good, since this image has been scaled. We will try to improve 
the quality for the tracing process by using a filter. 

 Click on the Color Filter Operations icon ({VPFILTER} or Raster ► Filter ► Color Filter 
Operations). A dialog opens: 
 

 
 

In the Blur filter section select the Fast Median filter. Take a size of 3 and use the Apply 
button.  
 
 

Image Settings 
 

  The blue colored paths of the river will be traced. Click on the Image Settings icon 
({VPIMAGESETTINGS} or Options ► Image Settings) to open the respective dialog box. 
Switch to Define Foreground and click on Advanced Settings.  

  In the Active Color Palette Calculation click on PickActive Color from the dialog image 
and select a representative blue color of the river (use the Window Zoom function). Adjust 
the Variation slider so that all pixels of the color pattern of the river are selected (use the B/W 
View for checking). The value should be around 38. Close the Advanced Image Settings 
dialog with OK. 
 
In the Color Definition choose a color from the river using the Pick Color button. 
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Since we want the polylines to follow the raster with highest precision set the Exact option of 
the Image Characteristics to on. Close the dialog with OK. 

  To achieve a precise polyline representation set the Straightening to None in the Contour 
Trace Settings of the General tab {VPCONTOURTRACESETTINGS}. Leave all other 
options switched off. 
 
Set active color (Color Control) to blue. 

 
 
Contour Trace 

 

 Activate Contour Trace {VPCONTOURTRACE} and click on the blue river branch in the 
middle left area of the drawing. The path is traced up to an intersection or a color change. 

 
Use the [Shift] key to add the southward branch of the river. Continue tracing all other 
branches. 
 
Now, the drawing should look like this: 
 

 
 
Try for yourself to trace the red lines (roads) and the altitude contour lines. 
 
 

Post Edit 
 

 End the contour tracing and start drawing all lines that couldn't be traced. Do not forget to 
activate the accordingly layer. 
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Some polylines need to be modified because they have too many or too few vertices. 

 Start the Edit Polyline/Spline function {VPPEDIT} and select one of the road polylines that 
were traced too long - a toolbar appears offering various edit modes. 

 

 Activate the Edit Vertices mode and zoom to the number of the road. Here, we want to 
separate the number from the road. Hold down the [CTRL] and click on the vertices to be 
removed.  
 

  Remove all vertices on the number or the ellipse around the number. End the command 
and draw the number manually. 
 
Polylines can also be edited during the trace operation by using Edit Contour in the context 
menu 
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LESSON 7   
 

ELEVATION ASSIGNMENT 
 

7.1 Assign Elevation  
 
In this lesson you will learn to assign elevations to vector polylines.  
 

Preparation 
 
VP-WIN: 

 Open {VPOPEN} the raster file GEO.TIF (only VPmap pro) or the hybrid file GEO.RVD from 
the TUTORIAL directory. 

 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file GEO.TIF (only 
VPmap pro) or the hybrid file GEO.RVD from the TUTORIAL directory. 

 

 
 

Only VPmap pro: 

 First, we need to vectorize the raster file with settings fitting this drawing type. Open the 
Vectorize Parameters dialog {VPVECTORIZE} and load the parameter file GEO.PCF. In the 
General Tab you will see that Straightening is set to Weak. Also, the text recognition is 
switched off. Press OK to start the vectorization process. 
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Assign Elevation 

 

 The vectorization process has generated polylines having the elevation 0.0 (Z value in the 
properties). Now, we are going to assign elevations. For easier handling/picking switch off the 
raster display. 

 Start the Assign Elevation function {VPASSIGNELEVATION} to open the main dialog: 
 

 
 

To easily distinguish processed vectors from non processed ones, this functions displays the 
processed vectors in a different color. To review the color matching table, click on Change 
Color Settings to open the Color Correlation dialog. 
 

 
 

You may want to alter the colors corresponding with your requirements. Thereafter, close the 
dialog with OK and return to the previous dialog. Here, you may click the check box to keep 
the colors of the modified polylines after finishing this process. As default, all processed colors 
are reset to their original colors once the Assign Elevation function is closed. 
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Now, we will start the altitude assignment process. First, enter the Step Size – you get this 
information from the drawing (the step size of this sample is 40.00 m).  
 
To process several lines one after another use the Automatic mode. Press the Select button 
– the dialog disappears and you are asked (see the status line) to select multiple polylines by 
drawing a crossing line for selection. Set the line as shown in the sketch below – start from the 
left side of the 1000 m contour line in the upper left part of the drawing and finish the line 
inside the closed 1400 m contour line. 
 

 
 
On the second click, the dialog reappears with the Elevation of the first line of the selection. 
Since we did not assign an elevation to this line the value reads 0.0. Enter 1000 and press the 
Assign button. The color of each processed vector changes as defined in the Color 
Correlation dialog indicating that these lines received altitude values. 
 
To check the elevation of lines in the drawing, just place the cursor over a line – a tooltip pops 
up showing the assigned elevation. 
 
The elevation of the next lines decrease from 1400; switch on Decreasing and select the 
lines as shown below: 
 

 
 
This time, the first line selected already has an elevation assigned. Therefore the Elevation 
field reads the elevation of this line: 1400.00. Press Assign to execute the assignment to all 
selected lines. 
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For single lines, like the ones in the upper left of the drawing, use the manual assignment 
mode.  
 
Press the Start Manual Mode button – the dialog disappears and you are prompted to pick a 
polyline. Zoom to the upper left part of the drawing and click on the short part of the 1000 
contour line that has not been processed, yet. A context menu opens showing the current 
elevation of the selected line: 
 

 
 
Click on Edit and Assign Elevation to open a dialog box to edit the elevation of the selected 
line: 

 
 
Type in 1000 and press Assign. The dialog closes and the line color changes to indicate that 
the line has been processed.  
 
Click on the non processed line left of the number 1000. In the context menu select Pick 
Reference Elevation and click on the processed contour line with elevation 1000. The 
Current Elevation now shows the elevation of this last clicked line (1000.00), and the 
Add/Subtract Step Size values are adjusted accordingly for selecting the new elevation: 

 

 
 

The elevation of the selected line is one step lower than that of the reference line. So, click on 
Subtract Step Size: Assign 960.00.  
 
Go on and finish the drawing: use the automatic mode to process several lines at once and 
the manual mode to process single lines. 
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Save the file. If you have a program with 3-D display capabilities you can export the file to this 
program and create a 3-D view: 
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LESSON 7  
 

ELEVATION ASSIGNMENT 
 

7.2 Assign Elevation while Tracing  
 
Trace the contour lines of a raster file and assign elevations in the same process.  
 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the raster file GEO.TIF from the TUTORIAL directory. 
 

VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file GEO.TIF from the 
TUTORIAL directory. 
 
 

Trace Settings 
 

  Click the Trace Settings icon {VPTRACESETTINGS} to open the respective dialog. Set the 
Straightening parameter to Weak. Check on Assign Elevation.  
 

  
 

Confirm the settings with OK. 
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Contour Trace with Elevation 
 

Change the Current Color to red. This way it is easier to recognize the traced vectors. 

 Click the Contour Trace icon {VPCONTOURTRACE} to start the tracing process. Zoom into 
the upper left area of the drawing (near the number 1000). Click on the thick line below this 
number. The Assign Elevation dialog box opens which prompts you for a few settings. Enter 
1000.00 for the elevation (according to the information in the raster drawing) and switch on 
the Automatic mode. Insert 40.00 for the Step Size (distance between two lines). Check the 
Increasing option.  
 

 
 
Close the dialog with OK – the first line will be traced. Go on tracing the lines to the right one 
by one. Click the next line: the dialog box Assign Elevation opens again and shows 1040.00 
this time as Elevation (Increasing mode). Confirm the settings with OK and continue tracing 
the next lines. 
 
For tracing contour lines having decreasing elevations proceed like this: click on the first 
contour line with a decreasing elevation. Once the Assign Elevation dialog opens switch 
from Increasing to Decreasing mode and adjust the Elevation value accordingly. 
 
For tracing single lines use the Manual mode: zoom into the upper left area of the drawing 
and click the line that has not yet been traced. In the Assign Elevation dialog change the 
mode to Manual and enter 960.00 as Elevation. 
 
Disable the Contour Trace function and save the file. 
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LESSON 8   
 

VECTORIZATION 
 

8.1 Vectorizing a Raster File using the Vectorization Wizard  
 
Convert a b/w raster into a vector file. Use the Vectorization Wizard to create a parameter set 
which matches the characteristics of this drawing.  
 
Depending on the type of your drawings you need to adjust the vectorization parameters in 
order to achieve the best results. The Vectorization Wizard will guide you step by step to 
define or select the optimum parameter settings. 

 
Preparing the Raster 

 
VP-WIN: 

 Open {VPOPEN} the raster file TUTOR.TIF from the TUTORIAL directory. 

 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file TUTOR.TIF from the 
TUTORIAL directory. 

 

 

  Prior to starting the vectorization process the raster file needs to be cleaned up. Use 
Auto Cleanup to despeckle and deskew the raster. To mirror the file use Horizontal Mirror. 

The emphases of this lesson are the vectorization settings, so we refer to lessons 1 and 2 for 
the required raster file edit functions. 
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Setting the Parameters for a Vectorization 
 

 Press this icon or select the function Vectorize Wizard from the menu Vectorize 
{VPVECWIZARD} to start the Vectorization Wizard: 
 

 
 
The first page offers an introduction to the Wizard and the option to enter/modify parameters 
directly. Since we want to use the Wizard, keep the default setting and click on Next. 
 

This page allows for selecting the Vectorization Method. The sample pictures will help you to 
find the best fitting method fits for your drawing. In this case, Predominantly Lines 
(Centerline Vectorization) is the method to be used. 
 

 
Click Next to proceed to the next page.  
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You are requested to select the specific style of your drawing. Again, sample pictures will help 
you to determine your style: click on the Architectural, Mechanical, GIS/MAP, and 
Cadastral buttons to see the different pictures. In our example, the style Mechanical / 
Electrical corresponds best to the drawing; choose this style and click on Next. 
 
The drawing contains horizontal and vertical constructions lines. The Angle Correction 
settings enable to align these lines to exactly 0 or 90 degrees. 
 

 
 
Keep the default settings and press Next.  
 
The Page Text Recognition Parameters appears.  
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The drawing contains only Horizontal and Vertical text strings, therefore enable this option. 
Before you can proceed with the next page, you need to specify the maximum text height in 
your drawing. To retrieve the text height from the drawing, click in the edit field Max. Text 
Height and press [F2]. Zoom to the text string ∅ 29,2 in the lower part of the drawing and 
click first on top of the text and then on the bottom. Your measured text height should be 
around 3.8 mm or 0.13 Inch. With the text height being specified you can now click on Next to 
open the Hatch Recognition page: 
 

 
 
Since the drawing contains no hatches, click the hatch recognition function off and proceed 
with the next page. 
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The Arrow Recognition function can be activated for recognizing dimension arrows. To 
Determine the Arrow Head Size click into the edit field and press [F2]. Zoom to the text 
string ∅33 and measure the arrow head left of this text. The measured size should be around 
4.3 mm or 0.17 inch. 
 

 
 
Click on Next to open the Donut Recognition Parameters page.  
 

 
 
Since there are no donuts are contained in the drawing, do not activate this function but 
proceed with the next page.  
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To specify the parameters of Linetypes use the vertical dash-dotted construction line (the 
center line) in the middle of the drawing. Measure the dash and gap length with [F2]. 
 

 
 
Press Next to proceed with the Line Thickness Classification page. 
 

 
 
Depending on the thickness of a raster line its respective vector will be assigned to one of the 
three "line width classification" layers. In our drawing the vectors of the construction and 
dimension lines should be assigned to layer L1, the other vectors to layer L2.  
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To adjust the classification Thresholds for each line class press the Preview button to open 
the Layer Preview dialog (note: the yellow color has been replaced for printing by the blue 
color): 
 

 
 

 You can now adjust your Line Thickness classification dynamically. Switch off the raster 
display if set to on. Adjust the bar between red and yellow so that you will get a good 
separation of the dimension lines (red) and object geometry (yellow). The first threshold 
should be around 

0.40 [mm] or 0.016 [inch]. 
Press on OK to close the Layer Preview dialog. 
 
Activate the Sublayer creation for Dashed vectors, Circles, and Arcs. This means that these 
vectors will be assigned to special sub layers of layer L1, L2, or L3 with different colors, so 
they can be checked easily after the vectorization. 
 
Press Next and the last page of the Wizard appears. You have set up your Vectorize 
Parameters successfully! 
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Press the button Finish which will open the Vectorize Settings dialog: 
 

 
 
This dialog shows you all the settings you have just created with the Wizard. Save these 
settings as Tutor_1.pcf in the Support directory. It will be used in the following part of this 
lesson. Once the parameter settings are saved the title of the dialog box changes from 
Untitled to Tutor_1. 
 
To finally start the vectorization click on OK. The vectorization process will take a few 
seconds. At the end you will have the raster image vectorized according to the settings you 
have defined or selected in this lesson.  
 
You can improve the results of a vectorization process with extensive the raster editing and 
cleaning prior to vectorizing. Also, VP software provides many tools for post editing the 
vectorization results. 
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LESSON 8   
 

VECTORIZATION 
 

8.2 Preparing, Vectorizing, and Post Processing a B/W 
Image  

 
Convert a b/w raster into a vector file. Use the following methods 

• Auto Cleanup 
• Rasterize Online 
• Vectorization Using Pre-defined Settings 
• Combine to Ortholine / Combine to Text 
• Review Text 
• Assign Current Layer / Assign Current Linetype 
• Draw text / Draw Arrow Head 

 

Preparing the Raster 
 The quality of vectorization depends to a great extend on the quality of the raster. 

Unremoved speckles will be converted to waste vectors and holes in the raster lines 
can lead to interrupted vectors. It is therefore important to improve the raster prior to 
executing the vectorization process! 
 

Editing the Raster File  
 

VP-WIN: 

 Open {VPOPEN} the raster file TUTOR.TIF from the TUTORIAL directory. 
 

VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file TUTOR.TIF from the 
TUTORIAL directory. 
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 Call the function Auto Cleanup ({VPCLEAN} or Raster ► Raster Operations ► Auto 
Cleanup).The raster file is automatically despeckled and deskewed. 
 

 To mirror the file click on the Horizontal Mirror icon. 
 
 

Erasing Raster Elements 
 
The remaining speckles are to be removed.  
 
The Auto Cleanup function did not erase some of the larger speckles, for example next to the 
circle left on the upper part of the drawing. Zoom into this area.  
 

  Click the Raster Select icon to open the Raster Selection Mode toolbar and activate 
the Select Dirt mode. This mode recognizes regular forms like lines and arcs and excludes 
them from the selection unless they are completely inside the selection rectangle. Draw a 
rectangle around the dirt for selection.  

 Click this icon in the toolbar or press the [ENTER] key to Confirm the Raster Selection. The 
toolbar disappears and the selected raster (the dirt) appears highlighted. To delete the 
selection press the [Del] key.  
 
 

Drawing a Raster Line 
 
Interrupted raster lines are to be closed by drawing new raster lines over them. 

  Activate the Layer Raster and zoom to the area around the upper horizontal 
dimensioning line (ø33). This line is interrupted several times. 

 Start Pick Width and measure the width of the dimension line by clicking on it - the value 
should be 0.2. 

 In order to draw entities directly into the raster, activate the Rasterize Online modus 
{VPRASTERIZEONLINE}. 

 Use the Line function to draw a raster line on the layer Raster. Set the new line's start point to 
the right end of the left dimension arrow onto the raster line. Draw the line by clicking close to 
the dimension arrow on the right. When pressing the [Shift] key simultaneously the line will 
have an accurate horizontal orientation (VP-WIN only, for VP-CAD use the corresponding 
CAD commands for drawing an ortholine).  
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Replace / Insert Text 

 
The vertical dimensioning string 55 will be placed on the left side of the dimension line. 
 

VP-WIN: 

 Zoom into this area with Zoom Window. Click the icon Text and place the starting point of 
the text base line left of the measuring line (1st click). The text should be written in vertical 
direction from bottom upwards. So, drag the text base line vertically. If you keep pressing the 
[Shift] key simultaneously the base line will have an accurate vertical orientation. A dialog box 
opens to enter a text string - enter the 55 and click on OK.  

 
VP-CAD: 

Draw a vertical text 55 left of the dimension line using CAD functions. 

  Select the “old” raster text with the function Raster Select; Use the Select Rectangle 
mode. Erase the raster text with [Del]. 

 Switch off the Rasterize Online mode after you have finished editing the raster. 

 Click on the Zoom Extents button to inspect the whole drawing. 
 
 

Vectorizing 
 

 Click the Vectorization icon or select from the menu Vectorize the function Vectorize 
{VPVECTORIZE}. The Vectorize Parameters dialog opens. 
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 If you start the vectorization for the first time the vectorization wizard opens. In this case click 
on Use Parameter Set to switch to the dialog shown above. 

 
Now, you need parameter settings that will match the characteristics of this drawing. Click on 
the Load button and select the parameter file TUTOR_1.PCF from the TUTORIAL 
subdirectory. This is the file you have created with the help of the Vectorization Wizard 
earlier in this lesson. If you have not completed this exercise, load the parameter file 
TUTOR_ORG.PCF from the same directory. The pre-configured settings become available. 

Confirm your settings with OK to start the Vectorization process. After a few seconds the 
image will be vectorized and you can review the vector results. 

 Ensure that Show Vector is activated (VP-WIN only). For better viewing of vector details you 
may switch off the raster display. 

 
Post Process Editing 

 
Some of the vectors are incorrect. They have to be post edited manually. 
 

Properties of the Created Vectors 
 
Click on one of the two blue circles in the upper center of the drawing for selection.  

 
VP-WIN: 

 Click the Properties button, or select Properties from the menu Edit to open the properties 
dialog. {VPPROPSHOW}. 

 
The selected circle resides in layer L2-C (C for circles) as defined for layer L2. Adequately, 
you will see that the spring's arc elements displayed in green color are assigned to layer L2-A 
(A for arcs). 

 
 

Close the dialog with OK or Cancel. 
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VP-CAD: 

To view the properties of vectors use the respective CAD function. 

Please notice that most of the vector lines of the spring object are yellow, while most of the 
dimension lines are red. 

Some of the dimension lines, however, are displayed yellow instead of red. This means that 
they are assigned to the wrong layer. Obviously, the arrowhead thickness affected the 
average line width value. These lines will be transferred into layer L1.  
 
 

Changing Layers 
 

VP-WIN: 

Method 1: 

• Select all dimensioning lines that are yellow instead of red by clicking them consecutively. 
• The selected lines appear dashed for highlighting. 
• If you have selected a wrong line you can de-select it by pressing the [Shift] key and 

clicking on the line again. 

 Call again the Properties dialog. Click into the edit field Layer This field changes now to a list 
box where all available Layers are listed. 
 

.  
 
Select the layer “L1”. Close the dialog with OK. All previously selected lines will now be 
transferred to layer L1 appearing red. 
 

Method 2: 

 Press Undo {VPUNDO} to reject the last step (method 1). 
 

 Select Layer L1 for the active layer.  
 

 Select all dimensioning lines again that are yellow instead of red and click on Transfer to 
Current Layer: all previously selected lines will now be transferred to layer L1 (red). 
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VP-CAD: 

Select all dimensioning lines that are yellow instead of red and change the layer of the 
selected entities to L1. 
 
 

Reviewing Text 
 

 From the menu Vector click on the sub menu Edit and choose the function Review Text or 
{VPREVIEWTEXT}, or press this icon. A dialog box appears. It displays the raster section of 
the first text string found along with the recognition result. Also, the program zooms into the 
text position in the drawing and the selected text vectors are displayed and highlighted. If the 
recognition is incorrect, mark the respective character(s) with your mouse and enter the 
correction from your keyboard or from within the box's menu item Shortcuts. Enter the ø sign 
via [Alt + 0] (Shortcut function). In the menu Shortcuts this special character has been 
defined by default. Text Style (text height), Text Angle, and Start Point may be also edited 
when required. 
 
Sometimes unrecognized text entities (lines, circles arcs forming text characters) may appear 
together with a recognized text string. These vectors can be combined with the partially 
recognized text to a new text string. First, select the unrecognized vectors then, type in the 
desired text manually, or correct/extend the text in the text filed of the dialog box. You can 
also deselect vectors not belonging to the text string by pressing the [Shift] key and clicking 
on the desired vector (i.e. a crossing line, etc.). 
 

 
 

 Clicking Next allows you to inspect the next text sequence for further editing as described. 
 
 

Interactive Text Recognition 
 
The lower left dimensioning string ø7,3 may not be recognized at all (here, the raster has 
been distorted on purpose). Therefore, it does not appear during the process Review Text. 
Drawings with very poor raster text are best modified using the interactive text recognition 
command. 
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 Zoom into this area and window select all vectors belonging to this text string (the selected 
vectors turn into dashed lines for highlighting). Click this icon or select the function Combine 
to Text from the menu Vector ► Combine to. {VPCOMBINETOTEXT}. The dialog Combine 
Text opens: 
 

 
 

The raster area and the recognized text string are displayed in the dialog window. If it shows 
correctly ø7,3, click OK, otherwise edit the text appropriately: Change the text in the edit field 
and adjust the height and the angle directly in the preview window. Now, all text strings are 
reviewed and - where necessary - corrected. 
 
 

Combining Line Fragments 
 

 The vertical dimension line next to the 55 text string consists of several line fragments due to 
poor raster quality which occurs quite frequently in many documents. Select the three line 
fragments (you can also use window crossing) and click on the Combine to Ortho Line icon 
{VPCOMBINETOORTHOLINE}. The line fragments are instantly combined to a single line. 
When combining lines in the non-ortho mode the new line will be placed (coordinates and 
angle) with reference to the mathematical sum difference(s).  

 Two or more vectors are required in order to be combined for arcs and circles. Refer to your 
reference manual for more information. 
 
 

Changing Line Types 
 
The dashed lines that lead to the arrow with the text 13 are not recognized as dashed lines, 
but as three single lines. They have to be converted to dashed lines. 
 

 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 8: Vectorizing a B/W Raster File    153
 

 

 Select the three lines that should form one line and combine them by using the Combine to 
Ortho Line function. 
 
Now, the three lines are replaced by one line having the linetype solid. 

 
 

The solid linetype can be changed to a dashed linetype. 
 
VP-WIN: 

  Select D1 for the active linetype.  
 

Click again the line for selection. 
 

 Click on the Assign Current Linetype button. 
 

Now the line appears dashed. 

 
 
VP-CAD: 

Select the line and change the linetype to D1. 
 
 
Deleting Vectors 

 
Some entities of the raster structure have not been converted or recognized correctly (i.e. a 
vector line was generated from the comma in the text string ∅29,2, etc.). Also, there might be 
some superfluous arrowheads. These waste vectors can be deleted. 
 
Select the line pieces and the arrowheads - zoom in to the drawing to find all other short lines 
- and click on the Delete icon (VP-WIN) or press the [Del] key. All selected vectors will be 
deleted. Use the Redraw function to refresh the display if necessary.  
 
Use the Undo function to restore vectors that have been deleted by mistake. 



 VP Software Tutorial 

154   Lesson 8: Vectorizing a B/W Raster File Tutorial V16 - V9 / E
 

 
CAD Tools 

 
Set Dimension Arrows 

 

 Call the CAD Options Dialog ({VPDRAWOPTIONS} or Options ► CAD Options). 
 

Click on the tab Special and set the Dimension Head Length to 4.5 [mm] or 0.18 [inch]. 
 

 Arrowheads are missing at the lower horizontal dimension line, since there were none in the 
raster image. Click on the Dimension Arrow icon, then first on the dimension line and next 
on the extension line. The arrowhead is set. Repeat this procedure on the opposite dimension 
line end. 
 
Exit this function by clicking on the arrowhead icon again. 
 
The final conversion result should now look like this: 
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LESSON 8   
 

VECTORIZATION 
 

8.3 Color Image Vectorization 1  
 
Vectorizing of color images by using the Image Settings dialog. Functions you will learn in this 
lesson: 

• Define Different Color Patterns in one Raster File  
• Vectorize with Respect to the Color Patterns 

 
Preparation 

 
VP-WIN: 

 Open {VPOPEN} the raster file CONNECTION.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file CONNECTION.TIF 
from the TUTORIAL directory. 

 

 
 

VP-CAD: 

Create a new blue continuous layer and name it "Water". 

 
Vectorization of Colored Images 

 
Our aim in this lesson is the vectorization of the blue color structures, representing the water 
connections, the red color structures, representing the water channel system and the realty 
borders, and finally the black color structures for houses and plot numbers. It is necessary to 
execute the vectorization separately for each color tone, since we want to assign the vector 
results to three different layers, each for one color tone. 
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 We will start with the vectorization of the water connections (the blue color tones). Click the 
Vectorization icon or select from the menu Vectorize the function Vectorize 
{VPVECTORIZE}. The Vectorize Parameters dialog opens. In this dialog, click on Advanced 
Color Settings. The Image Settings dialog box opens: 
 

 
 

You can see the Image Characteristics in the upper left section of this dialog, similar to the 
Parameters Settings dialog. Ensure that Predominantly Lines is active, since the water 
connections have line characteristics only. Information about the raster file is displayed in the 
upper right section of the dialog. The important part for vectorizing colored images is the 
lower area of the Image Settings dialog. We need to define a color pattern as “active or 
foreground pixels” to run the vectorization on those patterns. It can be accurately defined by 
selecting Define Foreground and calling the Advanced Settings of the Image Settings 
dialog. Click the Advanced Settings button to open the Advanced Image Settings dialog 
box. 
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 Zoom with the window zoom function very close onto the blue number 20016 to see the blue 
pixels' structure:  
 

 
 

 Ensure that the checkbox Region around Active Color is on and use the active pipette 
button at the left for picking the Active Color directly from this area. Choose the main blue 
tone by clicking with the left mouse button on a blue pixel. All pixels of this color will be 
highlighted immediately. You can see that this Active Color is representing the water 
connections very well. The small gaps at the crossing between the blue and the red lines can 
be eliminated with Gap Jump in the Vectorization Parameters. Now, we have done all 
necessary color definitions and can start the vectorization of the blue color entities.  
 
Leave this dialog and the Image Settings dialog with OK. Now, we can set-up the 
vectorization parameters in the dialog Vectorization Parameters: 
 
Switch to the General Tab and set the straightening to strong. Disable Angle Correction and 
Polylining and enable Connect Fragmented Lines over a Gap. Use <F2> to measure a 
gap at one of the blue and red line crossing or enter 0.80 [mm] or 0.03 [inch]. 
 
In the Basic Tab enable the Text option and measure the maximum Text Height of the large 
number 20016 using <F2> or enter 2.66 [mm] or 0.10 [inch]. Leave the ASCII Format (OCR) 
and Only Horizontal Orientation options on. The options Dash Linetypes and Circles 
should be disabled, since we do not find these entities in the blue raster part of the image. 

Switch off all options in the tabs Advanced and Hatches/Symbols.  

We want to have all vectors representing the blue water connections assigned to one single 
layer. In the Layers Tab move the two Threshold sliders to 0.00 meaning that all vectors will 
be shifted into the third layer Thick Line.  
 
 

VP-WIN: 

Also, we want to create a new layer for these vectors. Therefore, open the Thick Line layer 
combo box and select Other…. The Layer Manager opens and we can define the new Layer 
"Water", with the Color "blue", and the Linetype "Continuous". 
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VP-CAD: 

Open the Thick Line layer combo box and select the previously defined layer "Water". 

Press OK for starting the Vectorization of the blue water connections.  

 Now, we go on vectorizing the red channel system and the realty borders. Start again the 
vectorization process click the button Advanced Color Settings to open the dialog Image 
Settings. There, select Define Foreground and press the Advanced Settings button.  
 
Push the Load Map button (at the bottom) and load the CONNECTION_RED.MAP file from 
the TUTORIAL directory. After loading this file, you can see that the Active Color has 
changed to a red tone and the variation is now set to 51. If you extend the Advanced Image 
Settings by pressing the Color Map button, a palette opens, sorted by the red Active Color, 
which is the first entry and three color buttons are selected. This selection originates from the 
variation around the Active Color. 
 

 
 
Use the Zoom functions for reviewing the red pixels and check the B/W View to see how the 
color pattern of red will be interpreted in the vectorizing process. Note, that the selected color 
pattern is only temporarily converted to a b/w raster file. Close the Image Settings dialogs by 
confirming them with OK. 
 
The Vectorize Parameters Settings dialog opens. Load the vectorize parameters file 
CONNECTION_RED.PCF from the Tutorial sub-directory (default is the Support sub-
directory). Switch through the tabs and review the settings for your own training. In the Layer 
Tab you can see that we are going to assign all generated vectors to the Layer "Canal" with 
color "Red" and linetype "Continuous". Press OK to start the second vectorization. 
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Switch to the option Don’t Delete Anything in the appearing dialog, since we don’t want to 
delete the blue water connection vectors that are already present. Press OK to continue. You 
will see the added red vectors of the channel system and realty borders. 

 For the final step of this lesson we will vectorize the black color tones for houses and claim 
numbers. Open the Advanced Image Settings dialog again and move the Variation Slider 
to the left (0.0).  

 Use the zoom functions to zoom to the black claim number 3892 at the top right section of the 
raster file and select with the pipette cursor - after pressing the Pipette Button at the right 
side of the Active Color - the most black color tone. Now zoom to the building at the top left 
section of the image. You will see that the lines of that building are predominantly of a gray 
color tone. To receive better results when using the Variation Slider switch to the option 
Range defined by Active/Second Color. Set the Second Color to this gray color tone by 
activating the pipette cursor for the Second Color.  
 
Open the Color Map by pressing its button, and notice that the palette is now sorted by these 
two black color tones, which are the first two entries. By moving the Variation Slider you now 
have an overview on the colors you may select in the right part of the dialog and on the pixels, 
which will be selected in the image on the left hand side. Move the slider to a value which 
includes all black and gray tones needed for vectorization. The Variation value should be 
around 100. 

 Zoom again to the claim number 3892 and add the missing olive tone to the color pattern by 
clicking with the pipette plus cursor on an olive colored pixel.  

 
Confirm the Image Settings dialogs. Then, go back to the Vectorization Parameters dialog 
and load the CONNECTION_BLACK.PCF from the TUTORIAL directory. Review the loaded 
settings, this time with Hatch Recognition on and all vectors assigned to the layer "House", 
which is green for better distinction. Start the vectorization again. Remember to check Don’t 
Delete Anything in the following dialog. 

 We now have completely vectorized all three color patterns of the raster image. Switch off the 
Raster View and use the vector editing tools (Combine, Review text, …) for correcting 
minor errors. 
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LESSON 8  
 

VECTORIZATION 
 

8.4 Color Image Vectorization 2  
 
Vectorize the elevation lines of a map. Follow these steps: 

• Define the Colors of Elevation Lines (Image Settings) 
• Modify Vectorization Settings 
• Automatic Vectorization 
• Review and Correct Results  
• Post-Processing 

 
Preparation 

 

 Open {VPOPEN} the raster file ELEVATION.TIF from the TUTORIAL directory. 
 

 
 
 

Image Settings 
 
At first, the color range of the elevation lines needs to be defined as the active color. Later, 
only structures with this defined color range will be vectorized. 
 
Depending on the background the elevation lines consist of different colors. We will now try to 
capture these colors by using the advanced color settings.  

 Open the dialog Image Settings (Menu Options ► Image Settings  or 
{VPIMAGESETTINGS}) and choose Advanced Settings in the section Active Color 
Definition. In the dialog window zoom to the upper center region of the sample map: 
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The elevation lines’ colors cover a wide color range. Thus, activate the option Range defined 
by Active Color/Second Color. To cover the widest color range the values of the active color 
and of the second color should be considerably divergent. 
 

First (active) Color  
 

 Activate the pipette icon next to the Active Color box and zoom to the thicker elevation line on 
the green background. Click into a darker region of the line with the pipette cursor. All pixel of 
this color will be highlighted: 
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Second Color  
 

 Now, activate the pipette icon next to the Second Color box. Zoom up to a thinner line on a 
light-colored background and click to a most possible light pixel of the line: 
 

 
 

Color Variation  
 
By defining active and second colors the color range is set. However, the entire color value 
range of the lines has not been covered, yet. Now, the variation factor needs to be defined for 
both colors. 
 
Zoom out a few steps to get a better view of the map. Now, move the Variation slider bar. 
Gradually, all occurring colors in the lines will be highlighted, but also those of other structures 
which are not meant for a vectorization. 
 
For a better survey change to B/W View. You can now see how the slider movement covers 
the elevation lines by increasing the variation factor. However, other and unwanted structures 
will also be included quickly.  
 
Try to set the variation value in a way that most of the lines’ colors are covered while only a 
few unwanted colors are included. Best value settings will probably be between 25 and 30 
depending on the colors you have previously defined (click positions of Active Color and 
Second Color). 
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Close this dialog and the Image Settings dialog with OK.  
 
 

Vectorize Parameters 
 

 Open the dialog Vectorize Parameters (Menu Vectorize ► Vectorize Parameters or 
{VPVECPARAMETERS}) and enter the settings as follows: 

Tab Image Characteristics 
• Predominantly Lines 

Tab General 
• Weak Straightening 
• Polylining; Running through Intersections 
• Connect Fragmented Lines over a Gap of 1.00 mm 
• No Angle Correction 

Tabs Standard, Advanced, Hatches/Symbols 
• Switch off all options 

Tab Layers 
• In the preview set the threshold in a way that thin lines will reside in the layer 

L1 while thicker lines will reside in the layer L2 (approx. 0.4). 
 

Save the settings as ELEVATION.PCF and close the dialog with OK. 
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Automatic Vectorization 

 

 Start Vectorization by clicking on the respective icon (Menu Vectorize ► Vectorize or 
{VPVECTORIZE}) and on OK in the following dialog. 
 
The vectorization result will look like this (Raster display off; here, for a better distinction the 
layer L2 has been printed in blue color): 
 

 
 
 

Analyze and Improve Results 
 
In the region of the river bend in the map’s lower section parts of streets and text have also 
been vectorized. These contain the same colors as the elevation lines. 
  

 Re-open the advanced image settings dialog and zoom to the river bend using the b/w view 
display:  
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Apart from the well-covered elevation lines there are also parts of the street structure 
selected. Try to reduce the color variation value so that the colors of the street will be 
excluded from the selection (approx. 6). You will realize that most of the elevation lines will 
disappear. Thus, in this case this not an appropriate way to improve on recognition results. 
Close both dialogs with Cancel. 
 
 

Remove Speckles 
 
Since there are only a few “wrong” pixel in the selection they can be deleted by using the 
function Remove Speckles. 

 Open the image settings dialog and define the Background Color: click on Pick Color, then 
into a light-colored region in the sample map. Close the dialog with OK. 
 

 Remove Speckles (Menu Raster ► Raster Operations, Function Remove Speckles or 
{VPSPECKLES}) from the map in User Defined Mode. Use Pick From to measure the Max. 
Dirt Size (approx. 10) from the drawing. If you have Review results before rasterizing 
enabled you can check the selected speckles before finally removing them. 
 

 Now, start the vectorization again (delete the existing vector data). Below on the right you can 
review the results. Compare them to the previous results on the left where no despeckling had 
been used: 
 

  
no despeckling                                 with despeckling 
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Post-Processing 

 
Delete all those vector elements that do not belong to any of the elevation lines. 

 Start the function Combine to Polyline and use it to close the occurring gaps in the elevation 
lines. 

 Use the function Combine to Text to generate text strings representing elevation values.  
 
The final result of the processed map should look like this: 
 

 
 
Save the results as ELEVATION.RVD.  
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LESSON 8  
 

VECTORIZATION 
 

8.5 Contour Vectorization (VPmap Series)  
 
Vectorize the contour lines of a map. Follow these steps: 

• Automatic Contour Vectorization 
• Review and Correct Results  
• Post-Processing 

 
Preparation 

 
VP-WIN: 

 Open {VPOPEN} the raster file CONTOURLINES.TIF from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the raster file 
CONTOURLINES.TIF from the TUTORIAL directory. 
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Vectorize Parameters 

 

 Open the dialog Vectorize Contour (Menu Vectorize ► Vectorize Contour or 
{VPVECCONTOUR}) and enter the settings as follows: 
 
Tab Vectorize Contour 

• Weak Straightening 
• Run through Intersection 
• Predominantly Lines 
• Dashed Polylines 
• Max. Dash Length 5mm 
• Max. Gap Length 3mm 
• Automatic Linetype 
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Tab Layers 

• Threshold 1: 0.351 
• Threshold 2: 2.700 
• Create Sublayers for Dashed Polylines 

 
 
In the Text Tab leave options for text recognition on off.  

Click on OK to start the Contour Vectorization. 

Now, check the results, e.g. in the upper right corner; the dashed polyline is not recognized 
correctly. Instead, of one dashed polyline, two dashed polylines, and one continuous polyline 
have been recognized. This is due to the Max. Dash Length from the settings. In fact, the 
continuous polyline is longer than this value. To improve on the recognition quality restart the 
Vectorize Contour command, and change this value by clicking into the appropriate edit field 
and use the [F2] key to measure the length of the continuous polyline from the drawing (the 
return value should be around 6.3mm).  

Click on OK to restart the Contour Vectorization. A dialog pops up as there are already 
vectors present in the active vectorization area. Choose Delete the Vector Data  in the 
Current Vectorization Area and confirm with OK to avoid duplicate vectors. 

 Start the function Combine to Polyline and use it to close the remaining gaps in the 
polylines. 
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LESSON 9   
 

POLYGON TRACING AND ATTRIBUTE ASSIGNMENT 
 

9.1 Digitizing a Scanned Map and Creating Attributes  
 
A scanned map is going to be digitized and exported in ESRI-Format. The following steps are 
required: 

• Georeferencing of the map, 
• Creation/import of a layer structure with attributes, 
• Generation of vector entities with various tools, 
• Export in ESRI .shp Format 

 
Preparation 

 
In order to obtain a consistent structure in the resulting map document it is helpful to use 
prototype drawings for the digitizing process containing frequently used settings (layers, text 
styles, etc). 
  

Loading a Prototype Drawing 
 

VP-WIN: 

 Open {VPOPEN} the file CADASTER-PROTOTYPE.RVD in the directory TUTORIAL. This 
file is used as a prototype drawing and contains pre-defined layers with attribute definitions. 
More layers will be added later.  
 

VP-CAD: 

  Start with a new document and Import {VPIMPORT} the file CADASTER-
PROTOTYPE.RVD from the directory TUTORIAL. 
 

Loading a Scanned Map 
 
Import the map by clicking with the right mouse button in the Project window and selecting 
the item Import... from the context menu. Browse to the directory TUTORIAL and load the file 
CADASTER.TIF (disable the option Specify Insertion Point). Alternatively, you can also load 
the file using the menu File - Import...  or the command line {VPIMPORT}.  
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Georeferencing (Rubber Sheeting) 
 
This map will be rubber sheeted so that the coordinates of the reference points match the 
corresponding coordinate values given on the map. An extensive guideline to rubber sheeting 
is given in Lesson 4. 
 
 

Settings 
 

 Start Rubber Sheeting (Menu Raster - Rubber Sheeting - Multi Point Rubber Sheeting… 
or {VPRUBMULTI}). The dialog User Coordinate System is displayed - here, the coordinate 
system must be set-up. Set the Coordinate System / Project to Standard (Cartesian) and 
use Meters as User Units. Change the Drawing Scale according to the given value on the 
map to 1:1000. Further, make sure that the checkmark is set for the option Place Raster 
and/or Vector Data on OK.  
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Proceed by confirming the settings with OK. The Transform Data dialog box opens. Please 
make sure to set the option Adjust Coordinate Values to the new Coordinate System and 
click on OK to proceed. The dialog Place/Adjust Drawing opens to assign the origin.  
 
The lower left reference point will be used as the origin. Click on Select Point and zoom to the 
point in the map. Click in the point’s center. Now, enter x and y coordinate values in the 
command line: 4436600, 5325700 and confirm with [Enter]. Your entries are listed in the 
dialog. For a mere placing the assignment of one reference point is sufficient. Confirm with 
OK to set the new origin. 
Accepting all other settings in the dialog box with OK leads to the Rubber Sheeting Settings.  
 
 

Grid Snap 
 
The map contains reference points in a grid structure. The distance between the grid points is 
100 m. Accordingly, select From Grid in the dialog Rubber Sheet Settings ... 
 

 
 
... and enter the distance 100 for the x value. Check Automatic Zoom Factor and set the 
factor to 1:2. Select Polynomial (Helmert, Affine, etc.) for the Calculation Mode and click 
OK. 
 
The main dialog RubberSheeting opens: 
 

 
 
Since the From Grid option has been chosen, a grid will be overlaying the whole map with the 
specified spacing. This grid correlates with the origin. At the intersections of the grid lines the 
reference points are expected. Click on the button Input Points to start entering the reference 
points. 
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Entering Reference Points 

 
The program will automatically zoom to the first grid point on the lower left. Click on the center 
of the cross. After clicking the first reference point the next grid point is automatically zoomed 
in. The grid points are addressed from left to right and from bottom to top. Proceed the same 
way for all remaining reference points in the map. The grid points on the right lie outside of the 
map. These can’t be matched to a reference point and must be excluded from calculation: 
click the right mouse button and select Skip Point.  
 
 

Rubber Sheeting 
 
Click OK in the dialog to start the rubber sheeting process - this will take a few seconds. After 
rubber sheeting is completed you can review the reference points in the drawing: the  
displayed values of the cursor position now correspond with the map’s coordinates. 
 
End the function by clicking OK. 
 
 

Layer and Attribute Definitions 
 
The existing layers with their attributes must be modified and completed according to the 
content of the map. 
 
The Project window displays the layers contained in the drawing (VP-WIN only): 
 

 
 
Layers for parcels and streets on the map (Parcels, Streets) are already created. Additional 
layers must be created or imported for the buildings. 
 
 

Importing Layers 
 

VP-WIN: 

Click with the right mouse button in the Project window and select Import… from the context 
menu. Select the file CADASTER-LAYERDEF.RVD in the directory TUTORIAL and import 
this file (disable the option Specify On-screen in the Insert dialog, accept the default 
settings, and click OK). After importing the file the Project window contains the additional 
layer Garages for adjoining buildings. 
 

VP-CAD: 

 Import {VPIMPORT} the file CADASTER-LAYERDEF.RVD from the directory TUTORIAL 
(switch off Specify On-screen for the Insertion Point). You can now view the Layer Manager 
with the additional layer Garages listed. 
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Creating Layers 

 
VP-WIN: 

 For main buildings an additional layer is going to be created. Open the Layer Manager by 
clicking with the right mouse button in the Project window and select the item Layer 
Manager... from the context menu (alternatively: Menu Options - Layer Manager or 
{VPLAYERS}). In the dialog click on button New... and enter Houses for the layer name. Set 
the Color to Red: 

 
 
Close the dialog with OK. 
 

VP-CAD: 

Create a new layer Houses with the color Red. Close the layer dialog. 
 
 

Adding Attribute Definitions 
 
In order assign attributes containing information on street, house number, and parcel number 
to polygons in their respective layer we have to create attribute definitions first. 
 

VP-WIN: 

In the Layer Manager open the dialog Manage Attributes by clicking on the button 
Attributes… and select the layer Houses from the list: 
 

VP-CAD: 

 Start the function Attribute Manager {VPMANGEATTRIBS} or select Vector ► Attrributes 
► Attribute Manager... 
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 Click the Add new data field button to define the properties for the new attribute. Type in 
Street for the Name and restrict the attribute length to 255 characters. Set the data Type to 
VarChar for later  prompting a text input. Since on this map all street names end with "-weg" 
the Default value can be set to weg (to later limit the necessary input). Finally, check the 
option Required:  
 

 
 
OK adds the new attribute definition to the layer.  
 
Furthermore, create another attribute definition with the following properties:  
 

Name: HouseNumber 
Type: VarChar 
Required: Yes 
Length: 10 
Rule: Auto Increment / Decrement 

 
Since a rule has been chosen you have to specify this rule in more detail when clicking OK.  
House numbers on the map are arranged in a increasing (decreasing) order: even house 
numbers are found on one side of the street, odd numbers on the other. Accordingly, the rule 
must automatically increment in steps of 2. Enter this value for the Stepsize in the dialog Rule 
Setup: 

 
 
We don’t care about the Start value here since it can be changed manually later and the 
subsequent value is always based on the previous one. During input you can switch between 
even and odd numbers at all times without having to change the rule in the attribute definition. 
 
Add a third definition to the layer:  
 

Name: ParcelNumber 
Type: Integer 
Required: Yes 
Rule: None 

 
Close the dialogs New/Modify Attribute and Manage Attributes. 
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Changing the Layer Structure (VP-WIN only) 

 
In order to switch both new layers on and off at the same time they will be set as sub layers of 
a parent layer. 

 Create a new layer named Buildings with the Layer Manager and set its color to Blue. Keep 
the [Ctrl] key pressed and click on the layer Houses in the Project window. Drag it to the 
layer Buildings (keep the left mouse button and the [Ctrl] key pressed while dragging). 
Proceed in the same way with the layer Garages. The new relation is depicted as follows: 
 

 
 
The subordination of layers can easily be undone by dragging the layer (without holding the 
[Ctrl] key) to its original hierarchical level. 
 
 

Modifying Attribute Definitions 
 
The attribute definitions of the other layers are to be checked and modified. 
 

  Open the dialog Manage Attributes and select the layer Parcels from the list and select 
the attribute Number. Clicking the “hammer” icon opens the modification dialog. Change the 
data Type to Integer and choose the rule Restricted Range. Closing the dialog with OK 
prompts for details for this rule: Enter 0 for the Minimum and 2000 for the Maximum. 
 

 Create an additional attribute definition for the layer Parcels with the following properties:  
 

Name: Developed 
Type: Char 
Length: 5 
Default value: Y  
Required: Yes   

 
Close the dialog. The preparations for digitizing the sample map are now completed.  
 
 
All parcels, streets, and buildings in the map are going to be generated as vector polygons. 
The belonging information will be saved as “attributes”. Polygons are going to be generated 
automatically or manually. 
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Digitizing - Automatic Mode (Polygon Trace) 

 
This mode allows to generate a vector polygon with a single mouse click inside a closed 
raster area of the map. 
 
 

Settings 
 

 For a proper setting of the Polygon Trace mode some parameter need to be defined. Open 
the dialog for the tracing options ({VPTRACEOPTIONS}) or Vectorize - Contour Trace 
Settings). In the General tab set Straightening to Medium. For the Gap Jump value (it 
refers to the connection of fragmented lines) enter 0.2 [mm]. Now select the Polygon Trace 
tab.  
 
Select Polygons as the target entity; click on Setup, select the Hatch Style SOLID, and 
enter an opacity value of 50 %. This value may be modified later when necessary. Switch off 
the Draw Borderline option and close the Fill Settings dialog with OK. Switch to draw 
mode on failure: Change the option to Ask me. Activate the Post Processing settings and 
switch on the option Ignore Small Circles. To determine the diameter for small circles click 
into the value box and press [F2]. Zoom to a circle symbol which is attached to a borderline in 
the map and measure the circle's diameter. It should be around 1.4 [mm]. 
 

 
 
Close the dialog with OK. 
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Digitizing Parcels 

 
We will digitize the property parcels first. Select the layer Parcels in the Project Bar.  

 Digitizing will always be done in two steps:  
Step1: Generate a polygon (or any other object). 
Step 2: Enter belonging attributes. 

 

 Make sure that the Attribute bar is open. If not, open it by clicking the icon Show Attributes. 
The bar is necessary to enter the attribute values while the polygons are created. 
 

1. Generate Polygon 

 Start Polygon Trace by clicking on the respective icon. The cursor will change into a “nail” 
symbol indicating that the trace mode is set active. 

 Please note: when using Polygon Trace, structures that are located entirely inside the trace 
area and do not connect with the contour outline will be regarded as part of that area. Thus, 
they will be included in a generated polygon. If these structures do connect with the contour 
outline they will be excluded from a generated polygon. See the following examples. 
 

Zoom to the area in the map’s center region as displayed below:  
 

 
 

Click near and inside the parcel’s contour outline. A polygon will be generated automatically 
with borders matching the parcel’s contour outline: 
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2. Enter Attributes 

There are entries expected now in the Attribute window as defined earlier for this layer:  
 

 
 
Enter the number printed on the map (1613) for Number. While entering attributes a button 
containing „3 points“ appears. When clicking the button or with [F2] you will switch to the 
mode „Take value from drawing“. After activation draw a rectangle around the respective text 
region (raster or vector) to import the value into the active attribute field. Then confirm with 
[ENTER]. The cursor jumps automatically to the next attribute value. This value (Developed) 
is defaulted to Y (“yes”). Since there is a building on the parcel the default value is correct – 
confirm it with [ENTER]. 

  The value of each attribute has to be confirmed using the [ENTER] key.  
 
When all attributes are entered proceed with tracing the next parcel 
 
Continue with parcel no. 1614. Click near the contour outline to generate a new polygon. 
Since both buildings on the parcel are connected with the contour outline they are excluded 
from the parcel’s polygon area. To include them in the area press and hold the [SHIFT] key. A 
+ symbol will be attached to the “nail” cursor.  
 

 
 
Now, click near the contour outline of the main house, then the garage. The areas of both 
buildings will be added to the parcel’s polygon area. Release the [SHIFT] key and enter the 
attributes for this polygon: ParcelNumber = 1614, Developed = Y. 
 

Continue with all other parcels of the map in the same way. For parcels without buildings enter 
the parcel number, continue to the attribute Developed with [Return] or [Tab] and change 
the value to N ("No"). 
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Two different error messages may appear while tracing the parcels: 
 

 
 
In this case, just click closer to the border line of the area you are processing. 
 

 
 
If this message appears, you have probably clicked too close to a structure that doesn't 
enclose an area (e.g. a parcel or a house number). Close the message box with No and click 
near another element of the border line. 
 
 

Digitizing Buildings 
 
Set the layer Houses to Active. For this layer the belonging attribute HouseNumber contains 
the rule Autoincrement with a step size of 2. Thus, start with the house no. 10. Click near the 
contour outline of the house to create a polygon: 
 

 
 
Enter the belonging attribute values as you read them from the map: 
 

 
 
Now click into the outline of the neighbor house (no. 12). As attribute value for Street the 
previously entered value will be offered. According to the defined attribute rule HouseNumber 
will be incremented correctly. Only the last attribute needs to be changed: Move the cursor 
with [Tab] to this attribute and enter 1612 as ParcelNumber. 
 
Proceed in the same way with all houses in the upper row. 
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Areas with broken (interrupted) Borderlines 

 
Manual Draw Mode 

When completed with the upper row continue with the row of houses below. For the first house 
(no. 1) the previous attribute values will be offered. Now, they need to be changed: enter 
August-Knabe-Weg for StreetName, 1 for HouseNumber and 1609 for ParcelNumber. 
 
The next house contour (no. 3) contains a few gaps. When clicking into the area, a message 
will advise you that the program was unable to create a closed contour. This time close the 
dialog with Yes to switch to the manual draw mode. The cursor changes to a zoom rectangle - 
this is since the option Zoom-In on first click in the trace settings has been activated. You 
will also notice that an unfinished polygon is created. The program could only detect part of 
the contour.  
 

 
 
Click on the border line to zoom into the drawing. Then, click the corners of the border line to 
complete the polygon. To remove a vertex click right on the mouse and select Remove last 
vertex from the context menu. When completed end the draw mode by double-clicking or 
pressing [Return]. The cursor changes again into the 'nail' symbol indicating that the program 
is back in automatic trace mode. 
 
Continue with the remaining houses in this row. The house no. 5 can be traced automatically, 
but the house no. 7 needs again to be drawn manually. 
 
 

Gap Jump 

 Another way to deal with interrupted border lines is to increase the gap jump. In the polygon 
trace settings change the value of the Gap Jump to 2.0 [mm].  

 Delete the created house polygons (parcel 1606-1609) and trace the houses once again (do 
not forget to enter the correct attributes). This time the program will recognize all areas and 
will not switch into the manual draw mode.  

  A large gap jump value does not always improve the trace function. Depending on the size of 
the gaps and the structure of your drawing a large gap jump may also connect wrong line 
pieces! We recommend to first test different values in order to find out the optimum value for 
each map. 
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Digitizing Garages and Streets 

 
Now continue to digitize the garages next to the processed houses and the streets 
Bockelmannweg and August-Knabe-Weg. Do not forget to activate each respective layer 
(Garage or Street) and proceed in the same way as described above to generate polygons 
and to enter attribute values.  
 
End the function Polygon Trace. The results of your digitization should look like this: 
 

 
 
 

Digitizing Manually (VP-WIN only) 
 
Apart from the automatic mode, a number of drawing functions (here: Polygon) and drawing 
aid options are available to create entities with attributes. 
 
 

Pre-Settings 
 

 Open the dialog CAD Options (Menu Options - CAD Options or {VPDRAWOPTIONS}). In the 
Polygon tab choose Fixed with the previous settings. 
 
 

Draw Polygon 
 

 Activate the draw function Polygon (Menu Vector ► Draw ► Polygon or  
{VPDRAWPOLYGON}) and zoom to parcel no. 1611 in the map’s center region:  
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Set the layer Parcels to Active and draw a polygon along the parcel’s contour outline by 
clicking into the center of the boundary points. Double-click on the last vertex set to finish the 
object or press [Return]. Then, enter the respective attribute values (ParcelNumber = 1611, 
Developed = Y). 
 
 

Draw with Raster Snap 
 

   Activate the Raster Snap (Menu Options ► Snap ► Raster Snap or  
{VPRASTERSNAP}) and choose the option Snap Center from the Snapmode toolbar. Move 
the mouse over the boundary points of parcel no. 1610. A colored circle symbol indicates the 
detection of the boundary point’s center. Click to set a polygon vertex at this position: 
 

 
 
Complete the polygon object in this way and enter the attribute values.  
 
 

Bird’s Eye, Draw in Pan Mode (VP-WIN only) 
 

 Change to the layer Street and zoom to the street Langer Graben in the map’s lower left 
section.  
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Due to the high zoom factor and to keep a better overview on the working area use the Bird’s 
Eye function (Menu View - Bird’s Eye). An overall view window is displayed with the current 
working area marked. 
 

 

 Start to draw by clicking on the street’s boundary points. Update your current working area by 
clicking in the Bird’s Eye window and move the marked area with the mouse to a new position.  

 When using the Pan function you may change your current working area directly - the fastest 
way to activate this mode is to press the center mouse button. The cursor will change to a 
“hand” symbol and you can move your working area with the mouse. 
 
Complete to draw the street area and enter the belonging attributes.  
 
End the draw function. 
 
 

Inspection and Correction of Attributes 
 
After digitizing a section of a map it may be useful to inspect the attributes of the generated 
objects.  
 

Attribute Inspector 
 

 The Attribute Inspector offers the fastest method to inspect attributes. Activate this function 
and simply move your mouse over the polygon you want to inspect. The attribute information 
will appear in a display box: 
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For attribute corrections click at the current position to select the respective polygon. Then, 
click in the Attributes window, select an attribute field, and enter your modifications.  
 
 

General Selection 
 
If no command is active, click on any polygon object to review the its assigned information. 
The corresponding attributes will be displayed in the Attributes window: 
 

 
 
To change a value of the attributes click into the respective value field and enter a new value 
or make corrections.  
 
 

Post-Editing 
 

 Now, check and possibly post-edit the generated polygons. Switch off the Show Raster 
display with [F4] for a better view. 
 
 

Regenerate 
 
The two previously generated parcel polygons may not adjoin accurately.:  
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 This can be corrected using the function Automatic Regeneration: Open the settings dialog 
for this function. Set the Match Borders option on and the Distance value to 0.2.  
 

 
 

 Now select both polygon objects and start the function Automatic Regeneration. The two 
polygons will adjoin accurately. 

 The function Automatic Regeneration will either operate on selected objects only or affect all 
objects in a document. 
 
 

Orthogonal Regeneration 
 

 Open the settings dialog again and activate the option Create Orthogonal 
Polylines/Polygons. Set the value to 10.0 degrees. This allows you to regenerate entities 
which should have orthogonal structures (such as buildings and garages) and make 
accordingly corrections. 

 Select the houses and garage of the parcels 1610 and 1611 and start the function - the 
corners of the selected elements will be adjusted to 90 degrees exactly. 
 
 

Edit Polygons 
 
Zoom to the parcel no. 1609. The garage building has not been traced accurately. For a better 
control view switch the Show Raster display on with [F4]: 
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 Start the function Edit Polyline/Spline and select the respective polygon. Zoom to the upper 
right corner: 
 

 
 
Press and hold the [CTRL] key and click on the vertex (1) to delete it. Do the same with the 
vertices (2), (3), and (4). Release the [CTRL] key and click on vertex 5. Now move this vertex 
with the mouse to the center of the boundary point (circle structure). After ending the edit 
function the garage polygon should look like this: 
 

 
 
The parcels adjoining the garage need to be edited as well: Their corners should match with 
the center of the boundary points. For a better overview turn off the display of layer Buildings 
by clicking on the check mark symbol next to the layer’s name in the project bar. The 
sublayers Houses and Garage will also be turned off.  
 
Edit the parcels’ vertices in the same way as described above using the functions Edit 
Polyline/Spline and Automatic Regeneration. 
 
 

Change Draw Order 
 
Turn on the display of layer Buildings. As the parcels have been edited the draw order has 
changed - the houses and garage polygon objects are now underlaying those of the parcels.  

 You can correct this by using the function Draw in Background. Select the parcel polygons 
you have edited previously and activate the function (menu Edit ► Draw Order ► Draw in 
Background). The selected polygons will now be underlaying those of the houses and 
garages. As an alternative you can right click into the project and choose Redraw. 
 
 

Attribute Search 
 
The objects generated in this lesson may be searched in the map according to their belonging 
attributes.  
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 Start Query Attributes (Menu Vector ► Attributes ► Query Attributes or 
{VPQUERYATTRIBUTES}). The dialog Create / Run Query is displayed  
 

 
 
As an example search for all houses that are on the street Bockelmannweg. First, activate 
the layer Houses in Search Attributes of Layer. The belonging attributes of this layer will be 
displayed as a list in the Search Field. Select the attribute Street. For text searches use the 
operator LIKE which can use the % symbol as a wildcard character. Type the value 
Bockelmannweg in the field Compare with Value. Choose Sorting; we want to sort the 
results as Ascending for the field ParcelNumber. 
 
Start the search with OK. As a result a matching attribute list will be displayed and all related 
objects appear marked in the map: 
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Click on single entries in the list to zoom to the belonging house objects, or use the standard 
Windows selection methods (including the [CTRL] and [SHIFT] key) to select multiple entities. 
The entity selection is still active after closing the dialog, so you will be able to change the 
properties or to export these entities easily. The results can be printed using the Print button. 
 
For changing attributes double-click a cell in the results and change the value. Clicking on OK 
confirms the changes, Cancel rejects them. 
 
 

Save and Export 
 
Save this document (menu File ► Save as...) as CADASTER1.RVD.  
 
Export the drawing in ESRI format: Start the Export function (menu File ► Export...) and  
select ESRI Shapefile (*.shp) as export format. In the Export dialog click on Options to view 
the settings of this export filter: 
 

 
 
Close the dialog and confirm the export. According to the export filter settings these files will 
be created: 
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LESSON 10   
 

BLOCK PROCESSING 
 

10.1 Defining / Inserting Blocks (VP-WIN only)  
 
In a drawing replace the vector symbols of resistors by blocks. Use the following methods: 

• Define Blocks with and without Attributes 
• Insert Blocks into the Drawing 
• Combine Vectors to an Existing Block 
• Exchange Blocks through Others 

 
Preparation 

 

 Open the file CIRCUIT.RVD from the TUTORIAL directory. This file has already been 
vectorized and post processed, and it contains the vector data necessary for this lesson. 
 

 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 10: Defining / Inserting Blocks   191
 

 
Creating new Block Definitions 

 
 

Block Definitions without Attributes 
 
First, create a block definition without attributes. Therefore, window select the vectors of the 
supply voltage symbol on the upper left of the drawing like this: 
 

 

 Click theCreate Block icon {VPMAKEBLOCK}. A dialog opens showing the selected vectors 
in the preview window: 
 

 
 
Change the Name to +5V and accept all other settings by clicking on OK. The selected 
vectors in the drawing will be replaced by the created block. 



 VP Software Tutorial 

192   Lesson 10: Defining / Inserting Blocks Tutorial V16 - V9 / E
 

 
Block Definitions with Attributes 

 
There are two ways to create a block definition with attributes (attribute definitions): 
 

Changing Text into Attributes 
Window select the resistor on the upper left including the assigned text strings as shown 
below: 

 
 

 Call theCreate Block function {VPMAKEBLOCK}. Enter the name RES1 for the block name. 
To convert the selected text elements into attribute definitions,click on the Attributes button. 
The dialog will appear in an enhanced view. 
 
First, the text R1 will be converted. Double click the text in the list on the upper right (or select 
the text in the list and activate the option Convert selected Text to Attribute Definition). A 
green checkmark ( ) indicates the intended action. Also, the entry fields for Attribute 
Definition Properties are now available. 
 
Enter Name for the Attribute Definition’s Name (your entry will also be set as Prompt) and R1 
as Default: 
 

 
 
Now, continue with the second text as described with these details:  

Name/Prompt Value  
Default 205K 
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Close the dialog with OK. The selected vectors will be replaced by this block. Since the block 
has attributes a query box will prompt you for the values. Confirm the  default values with OK: 
 

 
 
 

Add new Attributes 
Change the current layer to L1 and draw a rectangle (function: Rectangle) around the resistor 
R1 as shown below: 
 

 
 

 Select only this rectangle, call theCreate Block function, and enter RES2 for name.  

 Click on the button Add new attribute definition. A new Attribute Definition containing 
standard value details will be created and assigned to the Block Definition. 

 

 
 



 VP Software Tutorial 

194   Lesson 10: Defining / Inserting Blocks Tutorial V16 - V9 / E
 

 
Change value details of the new Attribute Definition as follows: 

Name: Name Textstyle: T1 
Prompt: Name Text Height: 1.8 mm (0.07 inches) 
Default: R1 Layer: Text 
  Align: Center 

Now, move the Attribute Definition over the rectangle in the preview window (see figure 
below). 
 
Add a second  Attribute Definition with these value details: 

Name: Value Textstyle: T1 
Prompt: Value Text Height: 1.8 mm (0.07 Zoll) 
Default: 205K Layer: Text 
  Align: Center 

Now, move the Attribute Definition to the rectangle center: 
 

 
 
Close the dialog box with OK. You will then be asked for the block's attribute values - confirm 
the displayed default values with OK.  

We want to keep only the block definition - not the block itself -in the document. So, delete the 
inserted block. 
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Inserting Blocks  

 

 Replace the resistors R2 through R5 by the block RES1. Therefore, delete these vectors first 
(best: window select since they consist of multiple vectors). Then start the function Insert 
Block {VPINSERTBLOCK} and select the block definition RES1 in the dialog box.  

 

 
 

 
Accept the other settings in this dialog and click on OK. The dialog box Attributes will ask for 
attribute values -fill in the appropriate name (R2) and close the dialog. 
 
The block is attached to the mouse cursor. Place it at the space of the previous R2 resistor 
position and click the left mouse button for inserting the block.  
 
The Attributes dialog box reappears. Enter R3 for Name and insert this block at the R3 
position. Proceed the same way by inserting for all of the deleted resistors' new blocks.  
 
Complete the insertion process by clicking Cancel in the Attributes dialog box or right-click to 
use the context menu. 
 
 

Combine to Existing Block  
 
Contrary to replacing vectors by blocks you may use the Combine to Block method. 

 Select the vectors of the resistor R6 and call the function Combine to Block 
{VPCOMBINEBLOCK}. This function opens a dialog which shows the last selected/created 
block definition.Select RES2 as Block Definition. 
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If suitable you can adjust the selected exchange block in the preview window by moving, 
rotating or scaling the selected elements. 

Change the attribute’s Name to R6 and close the dialog. The selected vectors are replaced by 
the chosen block. Repeat this until the remaining resistors (R7-R9) are replaced by blocks. 

Hint: Start the 'Combine to existing Block' function before you select elements -  the function 
will stay active when the dialog is closed with ‘OK‘. This way you can select new elements 
directly without the need to restart the function. 

Now, the document should look like this: 
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Exchanging Blocks 

 
The drawing now contains two different resistor symbols (blocks). We will replace the blocks 
showing the original design by the one with the new defined symbol design, i.e. block RES1 
will be replaced by block RES2. 

 Start the function Show Block Definitions {VPSHOWBLOCKDEFS} - a dialog opens listing 
all available block definitions of our document. 
 

 
 

 Click (highlight) the block definition you want to be replaced (RES1) and click the Exchange 
button to open the dialog Exchange Block Definition: 
 

 
 
Select the replacement block definition (RES2). Close the dialog box. All blocks consisting of 
the definition RES1 in the drawing will be exchanged by blocks RES 2.  
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Now, the document looks like this: 
 

 
 
While the resistors R20, R21, and R23 are still in their original representation all others are 
replaced by blocks with the new geometry. 
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LESSON 11   
 

SYMBOLS 
 

11.1 Symbol Recognition (VPHybridCAD)   
 
Vectors which form a specific pattern will be replaced by blocks. Use the following functions: 

• Create Symbols (define Search Patterns and Replacement Blocks) 
• Modify Symbols (add Search Patterns, modify Replacement Block)  
• Symbol Search  

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the file CIRCUIT.RVD from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the file CIRCUIT.RVD from the 
TUTORIAL directory. 
 

 
 
The symbol recognition consists of two parts:  
 
Generating the symbol: mark a pattern sample in the drawing save this structure in a special 
file, and select a block definition as a replacement block. to the prototype.  
 
Executing the Symbol Recognition: the symbol defined with the search pattern is searched 
and the found vector structures are replaced with the replacement block. 
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Symbol Recognition - First Run 

 

 Zoom into the supply voltage symbol at the upper left of the drawing – the vectors forming this 
pattern are to be replaced.  this will become our first symbol to search for. 
 

 
 

 Start the Symbol Recognition function ({VPSYMBREC} or menu Vectorize ► Symbol 
Recognition) - this opens the main dialog Search. The dialog is empty since no symbols 
have been defined, yet. 

 

 
 
 

Create a New Symbol 
 

 Click on New Symbol – the dialog Search Pattern appears. 
 
 

Marking a Search Pattern 
 
Now you can select vector structures in the drawing. Mark the electric symbol (circle and text) 
with a window selection. The sample  will be displayed in the dialog.  
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Click on Continue to define the replacement block. The dialog Replacement Block / Text 
Conversion opens.  
 
 

Define a Replacement Block 
 
Here, the name for the new symbol will be defined. Moreover, the definitions will determine 
which replacement block (new or existing) will be used, and how text as part of the search 
pattern is going to be treated,  
 
Assign VOLTAGE as symbol name and use the option Create new Block Definition. This 
name will be taken for the new symbol. The text, being part of the search pattern, shall not be 
converted – therefore, use the option Keep as Text. 
 

 
 
The dialog will close on Create and a new symbol file will be created and saved to the search 
path location.  
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The new symbol will be displayed in the main dialog. 
 

 
 
 

Executing the Symbol Search  
 

 Click the Search and Replace button - the whole drawing is searched for the symbol 
VOLTAGE. When the search is completed a message box informs you on how many symbols 
have been found and replaced by the defined block. For this drawing 3 symbols can be 
found. Leave the symbol recognition with Close. 
 
 

Symbols with Predefined Blocks 
 
Instead of generating an replacement block during the creation of the symbol, you can use an 
replacement block that already exists. 
 

Importing Replacement Blocks 
 
For this lesson, a DXF file with some block definitions has been prepared. You can generate a 
file like this with a variety of block definitions with any program that supports the DXF format. 
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VP-WIN: 

Import {VPIMPORT} the file Circuit.DXF (for Demo Version use Circuit.RVD instead) from 
the TUTORIAL directory (switch off the option Specify Insertion Point). 

 Open the Show Block Definitions dialog. It shows the now available block definitions RES1, 
RES2, and TEST1: 
 

   
 

VP-CAD: 

Import {VPIMPORT} the file CIRCUIT. DXF from the TUTORIAL directory. (e.g. Insert - 
Block…).  
 
 

Creating Symbols  
 

 Start the Symbol Recognition function, and click on the New Symbol button. Then, window-
select the resistor R1 as a sample pattern in the upper left part of the drawing. In order to 
increase on the recognition tolerance for this symbol and hereby to increase on the 
recognition quality, repeat this procedure for other resistor samples. Select more resistor 
samples from R2 to R5. 
 

 
 

  You can browse single search pattern samples forward and backward, or delete them. 
 
Click on Continue to select a replacement block. Assign the name RES2 for the new symbol.  
The previously imported block definition RES2 shall be used as a replacement block. Activate 
the option  Use existing Block Definition and select RES2 from the dropdown list. 
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Linking Text with Attribute Definition 

Text in the search pattern shall be linked with the attribute definitions of the replacement 
block.  
 
First, mark the text line R1 in the text table and activate the option Link to Attdef. In the list 
on the right all of the replacement block’s unlinked attribute definitions are displayed. Select 
the entry NUMBER. Selected options for this text are displayed in the table. Now, link the text 
205K with the attribute definition VALUE. 
 

 
 
Close the Create/Add dialog but do not execute the symbol search - this will be done later. 
 
 

One Symbol with different Search Patterns 
 
In the previous section we showed how to enhance the recognition quality by selecting more 
than one sample pattern for a symbol. Additionally, the software can search for different 
symbol designs by using different search patterns to replace them with the same block. 

 
In the main dialog click on New Symbol and zoom to the following pattern in the upper part of 
the drawing. 

 
 
Mark the text and the two lines of the arrow. In the dialog Replacement Block / Text-
Conversion name the symbol to Test1 and select the imported block definition TEST1. Link 
the text P1-B2 with the attribute Att1 and close the dialog with Create. 
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Add a Search Pattern Sample 

 In the main dialog mark the just created symbol Test1 and click on Modify Symbol – the 
respective dialog opens for modifications: 
 

 
 

 Click on this button to add another search pattern to the symbol. All open dialogs will be faded 
and the Search Pattern dialog appears. Zoom to the ground symbol in the lower part of the 
drawing and window mark its three horizontal lines. 
 

 
 
With Continue you will return to the previous dialogs. The new sample will be added to the 
symbol’s search pattern. Close the dialog with OK. 
 
 



 VP Software Tutorial 

206   Lesson 11: Symbol Recognition (VPHybridCAD) Tutorial V16 - V9 / E
 

 
Modifying Replacement Blocks 

 The replacement block of the symbol RES2 shall be replaced by another block. In the main 
dialog select the symbol RES2 and press the Modify Symbol button. The respective dialog 
opens showing you the search pattern and the replacement block of the prototype. Change 
the replacement block to RES1: 
 

 
 
Since all attribute definition names of the new and the old block are identical, the linkage with 
the search pattern’s text is still valid. 
 

  Close the dialog. You can use this mode also for checking or deleting the different 
samples of a symbol search pattern.. 
 
 

Multiple Search 
 
The Symbol Recognition function can be used for searching several symbols at the same 
time (multiple selection). Keep the [Ctrl] key pressed and select the symbols RES2 and 
TEST1.  
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Since you have selected several symbols the display will remain empty:  
 

 
 
Press the Search and Replace button to start the symbol search. The modified image should 
look like this: 

 

 
 
The symbol search is now completed. The four voltage symbols are replaced by blocks, 
though their appearance remains unchanged. Please note that the resistors have been 
swapped by the alternate replacement block as rectangular resistor symbols. Also note that 
the block attributes have replaced the symbols respective values automatically. Yet, the 
electrical test points (Test1 replacement block) remain to be positioned correctly. 
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LESSON 11  
 

SYMBOLS 
11.2 Symbol Recognition (VPmap Series)   

 
Vectors which form a specific pattern will be replaced by blocks. Use the following functions: 
 

• Create Symbols (define Search Patterns and Replacement Blocks) 
• Modify Symbols (add Search Patterns, modify Replacement Block)  
• Symbol Search  

 
 

Preparation 
 

VP-WIN: 

 Open {VPOPEN} the file VERMGR_2.RVD from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the file VERMGR_2.RVD from the 
TUTORIAL directory. 
 

 
 
The symbol recognition consists of two parts:  
 
Generating the symbol: mark a sample symbol in the drawing save this structure in a special 
file, and assign a block definition as an replacement block to the search pattern. to the 
prototype.  
 
Executing the Symbol Recognition: the symbol defined with the search pattern is searched 
and the found vector structures are replaced with the replacement block. 
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Symbol Recognition - First Run 

 

 Zoom into the greenwood symbol group in the center of the drawing (parcel no. 44) - this is  
the symbol pattern to search for. 
 

 
 

 Start the Symbol Recognition function ({VPSYMBREC} or menu Vectorize ► Symbol 
Recognition) - this opens the main dialog.  
 

 
 

Create a new Symbol 
 

 Click on New Symbol – the dialog Search Pattern appears. 
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Marking the Search Pattern 

 
Now you can select vector structures in the drawing. Mark the tree group symbol in the center 
of the drawing (parcel 44) with a window selection. The pattern will be displayed in the dialog.  
 

 
 
Click on Continue to define the replacement block. The dialog Replacement Block / Text 
Conversion opens.  

 
Define a Replacement Block 

Here, the name for the new symbol will be defined. Moreover, the definitions will determine 
which replacement block (new or existing) will be used, and how text as part of the search 
pattern is going to be treated,  
 
Assign FOREST as symbol name and use the option Create new Block Definition. This 
name will be taken for the new symbol. 
 

 
 
The dialog will close on Create and a new symbol file will be created and saved to the search 
path location.  
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The new symbol will be displayed in the main dialog. 
 

 
 

Executing the Symbol Search  
 

 Click the Search and Replace button - the whole drawing is searched for the symbol 
FOREST. When the search is completed a message box informs you on how many symbols 
have been found and replaced by the defined block. 
 
In our example document only one symbol can be found, i.e. the other symbols differ slightly 
from the created search pattern. 
 

Improving Search Results 
 
You can expand the search result by adding additional sample structures to the search 
pattern. 
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Add Search Pattern Samples 

 In the main dialog mark the just created symbol FOREST and click on Modify Symbol – the 
respective dialog opens for modifications: 
 

 
 

 Click on this button to add another sample to the symbol’s search pattern. All open dialogs will 
be faded and the Search Pattern dialog appears. Select the greenwood symbol in the parcel 
no. 49 (upper center of the drawing) and the greenwood symbol in parcel no. 196 (center of 
the drawing). After this, the counter for Samples will show 2. 
 

 
 

With Continue you will return to the previous dialogs. The new sample will be added to the 
symbol’s search pattern. Close the dialog with OK. 
 
Execute the symbol search again. This time all seven symbols should be found. 
 
Increasing the number of samples per search pattern can improve on the results of the 
symbol search. 
 
Close the drawing without saving any changes. 
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Search Patterns with Predefined Blocks 

 
Instead of generating the replacement block during the creation of the search pattern you can 
use an already existing replacement block. 

 
Preparation 

 
VP-WIN: 

 Open {VPOPEN} the file VERMGR_2.RVD from the TUTORIAL directory. 
 
VP-CAD: 

  Start with a new document and Import {VPIMPORT} the file VERMGR_2.RVD from the 
TUTORIAL directory. 
 
 

Importing Replacement Blocks 
 
For this lesson, the RVD file VERMGR.RVD with some block definitions has been prepared. 
You can generate a file like this with a variety of block definitions with any program, provided 
the file is saved in a vector format supported by VP software. 

 
VP-WIN: 

Import {VPIMPORT} the file VERMGR.RVD from the TUTORIAL directory (switch off the 
option Specify Insertion Point). 
 

VP-CAD: 

Import {VPIMPORT} the file VERMGR.RVD from the TUTORIAL directory. (e.g. Insert - 
Block…).  
 
 

Generating the Search Pattern  
 

 Start the Symbol Recognition function and click on the New Symbol button. In order to 
expand the recognition tolerance for this search pattern and thus, to increase the recognition 
quality, mark the greenwood symbols in the parcels no. 49, 44, and 196 as described above. 
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  You can browse single search pattern samples forward and backward, or delete them. 
 
Click on Continue to select a replacement block. Assign the name MIXEDFOREST for the 
new symbol.  
 
The previously imported block definition MIXEDFOREST shall be used as a replacement 
block. Activate the option  Use existing Block Definition and select MIXEDFOREST from 
the dropdown list. 
 
Close the dialog with Create. The new symbol is displayed showing the belonging search 
pattern and the replacement block: 
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Modifying Symbols 

 

 The replacement block of the symbol FOREST shall be changed. In the main dialog select the 
symbol FOREST and press the Modify Symbol button. The respective dialog opens showing 
you the search pattern and the replacement block.Change the replacement block to 
CONIFEROUSFOREST: 

 
 

  You can use this function also for checking or deleting the different symbol search 
patterns. Close the dialog with OK. 

 

 To run a symbol search process with the previous forest symbols see above: Excecuting the 
Symbol Search. 
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LESSON 12   
 

REDLINING 
 

12.1 Redlining / Mark-up (VP-WIN only)  
 
A raster file is going to be edited later. The editing information will be added now to the 
drawing using redlining elements. During this lesson you will learn how to 

• Create Redlining Symbols 
• Review Redlining Information 
• Save Redlining Files 

 
 

Preparation 
 

 Open the file ARCH.CG4 from the directory TUTORIAL. 
 

 
 
 

Activate Redlining 
 

 Click the icon Redlining {VPRDLON} or select from the menu Redlining ► View Redlining. 
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Redlining Settings 

 

 Then, click the icon Redlining Settings ({VPRDLSETTINGS} or Redlining ► Settings). The 
dialog box Redlining Settings opens:  
 

 
 
For this lesson we want to increase the size of text and arrows, and the color of the redlining 
elements should be red.  
 
In the General tab set the Text Height to 5.00 and the Arrow Size to 5.00. The Opacity 
factor should be 50%, Change the Color to Red. 
 
In the Filter Tab check that the ByOwner and ByType filter options are set to All. This 
ensures that all redlining elements of the drawing will we displayed. 
 

 
 
Confirm the settings with OK. 
 
 

Create Redlining Information 
 

 Click the icon Ellipse {VPRDLELLIPSE} of the redlining toolbar or select from the menu 
Redlining the function Insert Ellipse. Zoom in to the door of the living room in the center of 
the drawing and draw an ellipse around this door: first click on the upper left of the door and 
then on the lower right to define the size of the ellipse. The Redlining Properties dialog box 
appears: 
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Enter the information regarding the object (door) for the later editing process. Type in "door" 
as Short Text (the text on the leader will display permanently with the redlining mark-up 
entity). Enter for Comment the text "change the opening direction of the door". Accept 
with OK all other settings in the dialog. 
 
Now you need to position the leader with the Short Text. Click an insertion point for the 
leader. Enter this point on the lower right of the ellipse. 
 

 
 

 Next, use a Cloud element for mark-up. Click on the appropriate icon of the redlining toolbar 
{VPRDLCLOUD}. Zoom to the chairs in the kitchen at the upper left of the drawing. Draw a 
cloud around the chair (Drag a window). First click on the upper left of the chair, then on its 
lower right. Enter "chair" for Short Text and for Comment: "move the chair to the left side 
of the desk and insert a second chair on the right". Confirm the settings with OK. Place 
the insertion point of the Short Text on the upper right of the cloud. 
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 For the next mark-up click the icon Transparent Rectangle {VPRDLTRECT}. Zoom to the 
table in the living room in the center of the drawing and draw a rectangle around the table: 
enter "table" for Short Text and "use a larger table symbol" for Comment. Modify the color 
to Green. Confirm the settings with OK. Place the insertion point of the Short Text on the 
lower center of the rectangle. 

 

 
 

 At last switch on the Arrow function {VPRDLARROW} from the redlining toolbar (menu 
Redlining ► Insert Arrow). Zoom in to the right wall of the entrance hall at the upper right of 
the drawing and draw an arrow: click on the inner line of the right wall in the hall. Enter "hall" 
for Short Text and "insert a closet on the right side" for Comment. Change the Color to 
Blue and confirm the settings with OK. Place the insertion point of the Short Text on the 
lower left of the arrow. 
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The complete drawing should look like this: 
 

 
 
 

Review Redlining 
 
We will check the properties of the created redlining (mark-up) entities. 
 

 Click the icon Review Redlining from the redlining toolbar ({VPRDLREVIEW} or menu 
Redlining ► Review Redlining). The program zooms automatically to the first redlining 
entity , and displays its properties in a dialog box: 
 

 
 
Modify the Short Text to "door of living room". This entity has now been reviewed and 
modified, therefore check the option Revised. Proceed with the other entities: do not change 
the text, just mark the Revised option. The dialog box closes automatically after the last 
redlining entity has been reviewed. 
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Export Redlining Information 

 
Redlining information can be saved either together with the raster to one file using VP 
software's RVD format (File ► Save As), or you can Export the redlining information to a 
eparate file. For this lesson, use the Export function. 
 
Redlining data can be exported using VP software's native formats (RLF, RVD) or other 
vector formats (DWG, DXF, DGN, CGM, etc.).  

 If you use other formats than native VP software ones, you will lose any access restriction 
right settings for this file, e.g. everybody can open and/or modify the contents. 

 Click the icon Export Redlining ({VPRDLEXPORT} or menu Redlining ► Export 
Redlining). Select the RLF file format and export the data to the file ARCH1.RLF. Start this 
function once again, select this time the DXF format and export to the file ARCH1.DXF. 
 

  If you Import {VPRDLIMPORT} the file ARCH1.RLF into a new document the result 
should look like this: 
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LESSON 13   
 

BATCH PROCESSING AND SCRIPTS 
 

13.1 Batch Processing  
 
Batch Manager and Scripting are two possibilities to automate certain procedures. The 
BatchManager is a wizard to define files and jobs (clean/rubbersheet/vectorize/rasterize), 
which thereafter can be executed any time by the BatchExecutor.  
 
In this lesson, some raster files will be cleaned and vectorized in an automated process using 
the BatchManager and the BatchExecutor. 
 

 Click the icon BatchManager {VPBATCH} to open the respective dialog box: 
 

 
 
Define a new batch job by clicking Create Batch Job. The File selection dialog comes up for 
selecting the files to be added to a process: 
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 Use the Browse for Directory button and set the Base Path to the SAMPLES directory. In 
the left thumbnail preview area, select the drawings ARCH1.CG4, ARCH 2.TIF and ARCH 
3.TIF and click on the button Add to add them to the File List on the right. Click OK to 
confirm these three files for batch processing. 
 
The next dialog lets you define the tasks and set them into an order to perform the selected 
file set: 

 
 
The list Available Tasks contains the available operations for batch processing. In a first step 
we want to clean up the raster files. Select Raster Operations and click on the Add > button. 
A dialog for setting up the parameters comes up: 
 

 
 
We want the drawings to be automatically despeckled and deskewed. Switch on the option 
Auto Cleanup. For later use, name this Parameter Set “CleanUp” by entering this name into 
the respective edit field and click on OK. Now the parameter set “CleanUp” appears in the 
Available Tasks and the Task Sequence list. 
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Thereafter we want the drawings to be auto vectorized. Select the task Vectorization and 
click in Add >. 

 
 
Click the browse button to setup the Vectorization parameter file. Choose the file 
ARCH.PCF from the SUPPORT directory. Assign the name “Vectorize Arch” to the parameter 
set for later use and click on OK. 
 
Click Next > in the Task Setup dialog. 
 

 
 
Specify the directory for saving the results: C:\TEMP. As we want to save both, the cleaned 
raster data as well as the created vector data, select the File Format DWG. Check with 
Options … that the raster data are saved either to a separate file or within the DWG file 
(RasterDWG). 
 
Clicking Finish brings you back to the initial Batch Manager dialog, now with the created 
batch job Job 1 added to the list. 
 
Save the batch job to VECTORIZE ARCH.BJB in the output directory by clicking Save Job 
List. 
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The external program BatchExecutor executes the batch job. You can start this program 
from the Program Group or directly from the BatchManager by clicking Run BatchExecutor. 
 

 
 
If you start the BatchExecutor from the Program Group you need to first load the previously 
saved batch job VECTORIZE ARCH.BJB with the Load function. Now, execute the batch job 
clicking the Run! button. 
 
When you start the BatchExecutor from within the BatchManager the appropriate job is 
automatically loaded and started  
 
The Status for the first file changes from Ready to Running and the Output area displays 
the currently executed commands and error messages if there are any. After a file has been 
processed the Status of that file changes to Finished. 
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LESSON 13  
 

BATCH PROCESSING AND SCRIPTS 
 

13.2 Script Processing  
 
The Scripting function is an expert tool for advanced users allowing to combine any function 
to a workflow process by writing a script. A script may expect user interaction.  
 
This lesson shows how scripting can be used to interactively repeat routine tasks. The 
command sequence of this script will load a scanned drawing, auto clean the raster data, and 
stamp it with a drawing header in vector format to be rasterized into the drawing. 
 
 

Preparation 
 

 Open a text editor (e.g. Notepad) and enter the desired VP software commands with their 
options/parameters if necessary (we refer to the VP software Reference Manual) for executing 
from a script: 

VPOpen 
VPZoomx 
VPSpeckles /a 
VPAutoDeskew 
VPImport 
VPRasterize /r 1 /v 1 
VPExport 

 
You may omit the prefix "VP" - it may be needed with CAD for distinction to other commands. 
Also, lower and upper case letter are permitted with command line inputs. Save this text to the 
file STAMP.TXT. 
 
In detail the script executes the following: 

• Show the Open dialog to prompt the user for a file (here we will open a raster file) 
• Perform Zoom Extents 
• Despeckle the raster in the automatic mode 
• Deskew the raster in the automatic mode 
• Prompt the user for importing a file (here, we will import a vector file) 
• Rasterize everything into the Active Raster 
• Prompt the user for a name for exporting the raster data 
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Execution 

 
In the command line enter (type in) SCRIPT and hit [ENTER]. Select the created script file 
STAMP.TXT and click Open. 
 
 
The script immediately begins to be executed and prompts for a file to open. Browse to the 
SAMPLES directory and open the file ARCH 2.TIF. Upon clicking Open the file is loaded and 
cleaned.  
 
Now the scripts stops and asks for a file - in this example our stamp. Browse to STAMP.DXF 
(for Demo Version use STAMP.RVD instead) in the TUTORIAL directory and select Specify 
Insertion Point for a proper positioning of the stamp. 
 
The Insert dialog appears: 
 

 
 
Check the options Specify On-screen for the Insertion Point and the Scaling. Click OK. 
 
The stamp is now attached to the cursor for precise positioning. Move the cursor to the blank 
area in the upper right corner and use the left mouse button to drop the stamp. Now you can 
scale the stamp to meet your requirements by moving the cursor. Another click finalizes the 
positioning step.  
 
Then, the stamp will be rasterized and you are prompted to enter an export name for the 
raster file. Type in a new name and save it to a directory of your choice. 
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LESSON 14   
 

INDEXING 
 

Introduction  
 
In this lesson you will learn how to 

• set up and perform an interactive indexing process using a title block layout template  
• set up and perform an automatic indexing process 
• set up and perform an interactive indexing process using a template with isolated cells. 
 
To simplify the training workflow some of the settings are already pre-configured. Still, you will 
configure a new settings file named  IndexSettings1.VPI on your own. A copy of these 
settings is available in the VPindex SUPPORT folder: 

C:\Users\<user>\AppData\Roaming\softelec\VPindex V9\Support\ 
 
This Tutorial is valid for VPindex and VPindex lite. Suggested work steps which only refer to 
VPindex and not to VPindex lite are marked with VPindex only. At the beginning and end 
these paragraphs are also marked with the respective product symbol.  
 
 

Settings for an interactive process  
 

 Start the Indexing Wizard. When the Welcome page is displayed click on Next to proceed with 
Settings: 

 

 
 
New settings are to be created. Select Create new settings using the Wizard and click on 
Next.  
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General 

 
In this dialog you determine whether the indexing process should run in unattended mode in a 
batch or if you want to control the process manually, i.e. interactively. You can also specify 
whether your files shall be cleaned (cleanup, rotation, etc.) and saved as part of the indexing 
process.  
 

 
 
For the interactive mode you would have to review the process results for each drawing at 
the time of data extraction and the approved index data will then be exported directly to the 
preset database.  

  
VPindex only: 

In unattended mode, the indexing process runs through without interruptions saving the 
indexing information to a temporary folder. Afterwards, you will be requested to start the 
review of the process results by clicking on the Review button. After approving and/or 
correcting the index data they will be transferred to the preset database. 
 

  
For this training process you should select the interactive mode incl. Cleanup: Switch on 
Interactive processing and Cleanup and Indexing. Assign  IndexSettings1.VPI (or. 
IndexSettingsLite1.vpi for VPindex lite). Set the path to the VPindex Support folder: 

C:\Users\<user>\AppData\Roaming\softelec\VPindex V9\Support\ 
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 The Next button will be grayed as long as a new and valid file name and path are assigned.  
 
Click Next. The next dialog box appears. Here you can check-mark those tasks which the 
Wizard will support. 

 
For the setup of the following indexing batch process we will run through all available options. 
Therefore, please check all the tasks. 
 

 
 

 Remarks: 
1. After finishing the Wizard, the user always has the possibility to modify parameter sets in 

the parameter overview window. 
2. It is always possible to jump back and forth to modify parameters of the checked tasks. 

Jumping back does not discard the previously entered data. 
3. Even jumping back to this first dialog of the Wizard allows to uncheck all tasks and check 

only those tasks you want to modify. In this case all other settings remain untouched! 
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1. File Selection 

 
The first dialog is for choosing the drawings you want to process in a batch job. 
 

 
 

 Click the Wizard button to open the File Selection dialog.  
 

 
 

Please select the subfolder of your installation folder which contains the samples 
(C:\Program Files\softelec\VPindex V9\Samples). By clicking on "Add all", all drawings of the 
folder will be selected for this process. 
 
Also, the file selection procedure follows Windows Explorer conventions: you may click with 
the left mouse button, expand the selection by holding down the [Ctrl] or [Shift] key 
respectively while clicking other files. Selected files are marked with a green check mark. 
 
To enlarge the view of single files double click the file in the Preview window. A preview 
window opens. It can be closed with [Esc] or by clicking on the Close button. 
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 A Settings File can be generated even when no drawings are selected for process. When 
starting a process the File Selection dialog will open automatically. This method may be used 
for applying existing settings for an arbitrary number of processes. 
 
After clicking OK, you will come back to the "File Selection" dialog above. Your drawings are 
now selected. Click Next>. 
 
 

2. Load Sample Drawing 
 
The easiest way to setup a batch job for indexing is to run through the whole process with one 
of your drawings: 
 

 
 
Select the drawing DinA2-1.TIF to load and continue to define the settings of this batch job. 
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3. Raster Cleanup 

 
In the next dialog you can define all necessary raster cleanup tasks by clicking the sub-Wizard 
button: 
 

 
 

 Click on the Wizard button to specify Raster Cleanup functions. The first Raster Cleanup 
Wizard page opens.  
 

Mirror / Invert (VPindex only) 
These functions will not be used here  - click Next. 
 

Dirt Removal / Hole Filling 
Select the Automatic mode and click Next. 
 

Rotation 
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Select the option By Title Block and click Next. Rotation "By Title Block" provides an 
automatic rotation of the raster according to the orientation of the title block. Obviously, this 
can only be performed at a time when a title block template has been defined. Therefore, you 
are asked to perform this rotation manually now. 
 

 
 
Click OK. As the loaded sample drawing "Din-A2-1.TIF" doesn’t require a rotation (the title 
block is in the correct position at the lower right) just hit the [ESC] button on your keyboard. 
 

  
VPindex only: 

Paper Format Calibration 
Select the Automatic mode and click Next.  
 

 
 

Since "Automatic” Paper Format Calibration has been selected it is required to define all 
paper formats occurring with your drawings. These will be selected in one of the following 
dialogs. Therefore, a message for manual rubber-sheeting of the loaded raster will appear.  
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Select here DIN/ISO A2 (which will be offered), as this is the proper format of the loaded 
raster, and confirm with OK. The dialog closes and a green double frame is displayed 
representing the selected paper format with its extensions.  
 
You will be prompted to match the green frame with the according frame lines of the raster 
drawing. This is done by simply clicking the four corners of the raster drawing. You will see 
that a line coming from the upper left edge is attached to your cursor. As the cursor has a 
double-square shape, the software will zoom in at the first click and the target position is set 
with the second click: 

• First, click in the upper left edge to zoom in 

• Then, click to bring the green edge exactly over the edge of the drawing frame 
 

 
 

Please proceed like this for the other three corners in the same way. After finishing, the raster 
will be cut to this format and is displayed for a final control like this: 
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After clicking Finish you see the Raster Cleanup List again. However, it is now filled with a 
resume on the chosen tasks (automatic despeckling, automatic rubber-sheeting, rotation 
according to title block orientation): 
 

 
VPindex 

 

 
VPindex lite 

 
After clicking Next you will move on to Paper Format Selection  (VPindex) or to the definition 
of Indexing Templates (VPindex lite). 
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4. Paper Selection (VPindex only) 
 
In this list all existing paper formats of your drawings should be listed when the function 
"Automatic Calibration to Paper Format" or "Automatic Rotation by Paper Format" has been 
selected (or both, of course).  
 

 
 

The files of the current selection contain different paper formats. Click Add to assign 
additional paper formats. 
 

 
 
Select the following formats: 

• DIN/ISO A3 paper format with 90° vertical and 0° horizontal rotation 

• DIN/ISO A4 paper format with   0° vertical and 0° horizontal rotation 
 
The respective rotation details are pre-set. It is not necessary to enter them manually. 
 
Click Next. 
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5. Definition of Indexing Templates 
In this lesson relevant data is only contained in a title block. Thus, the indexing templates will 
be set up according to the title block layout. 
 
For the recognition process VPindex requires search patterns for title blocks. Once a title 
block is found in a drawing there is also an option to extract information from the cells of a title 
block for export to a database. 
 
Obviously, if you have different title block shapes among your drawings, you would need to 
define more than one title block template. In our example we have three different shapes - 
one for each paper format. 
 
In addition, VPindex offers you to store all ever defined title block templates in a separate 
folder as a template library. That makes it easy to pick those you need for a specific batch 
process. 
 
In the title block Templates dialog all selected tempIates are listed. In our case this list still 
needs to be filled. 
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 Click on the Wizard button to open a dialog which lists all created and currently selected title 
block templates. Verify the path to the path to the Template Library. It should be the VPindex 
Support Path: 

C:\Users\<user>\AppData\Roaming\softelec\VPindex V9\Support\ 

  If necessary change the path of the Template Library. 
 

 
 
Create a new title block template for the loaded sample drawing. Click on Create – the dialog 
to load a sample drawing appears: 
 

 
 
Select Use already loaded drawing and click Next. 
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The template definition dialog appears: 
 

 
 
After clicking the "Mark Title Block" button surround the title block in the loaded raster with a 
rectangle. This is the title block template to be recognized.  
 

 
 
The matching layout pattern for this title block will be generated and displayed in the dialog. 
Click Next to assign data cells. 
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 The Add Cell icon is already active. Now, those cells can be determined (by clicking into the 
cell area) which are relevant. Choose the following cells and name them: Name, ID-No., 
Drawing-No.. For the cell ID-No. assign the OCR option NumbersOnly.   

  Name 

  ID-No. 

  Drawing-No. 

 It is not necessary to individually separate the two text strings in a cell (e.g. the large Name 
"CASE" and the small identifier "Part Name"). VPindex does this for you! 
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Proceed with saving this template as TitleBlock-A2-new.tbt in the Support folder: 
 

 
 
By clicking Finish this new title block template will be added to the list with the three already 
existing templates on the left side of the dialog. On the right side you can see that this created 
title block template has already been activated for the batch job. Add the other two pre-defined 
templates from the library folder. 
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By clicking OK, you will finish the Sub-Wizard and get back to the previous overview of "Active 
Title Block Templates", showing now all title block templates with all defined cell names: 
 

 
 
The Next button brings you to the "Define Data Fields for Export". 
 
 

6. Data Field Definition and Linking 
 
In the following step you will define data fields.The definition includes the format specifications 
and the target database field for the recorded index data. Data field definitions can be 
imported from an existing database by ODBC (see Section 15: Import Fields from Existing 
Database). 

 A data field must carry the same name and the same format as the equivalent field in an 
existing database. 
 
 

New Data Field 
 

 Click this icon to open the dialog New Data Field and enter these values: 
 

Name Type Length/Scale 
DrawingName Text (VarChar) 50 
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Confirm your entries with OK and repeat the procedure with these entries: 
 

Name Typ Länge / Skalierung 
DrawingName Text (VarChar) 50 

Drawing-ID Number (Numeric) 16 
Drawing-Number Text (VarChar) 50 

Path Path+FileName (Out) - 
 

 
 
Click Next to link your data fields with the cells in your indexing template. 
 
 

Link Template Cells with Data Fields 
 
In this dialog you will link your template cells with data fields. In the left column cells of all 
currently selected indexing templates are listed. The active field links are displayed in the right 
column. When cells and fields carry identical names they will be linked automatically. 
Otherwise, Unused for Indexing Output will be displayed. 
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Click on the first cell in the (Name) and select the data field name Drawing-Name from the 
drop-down list in the right column. 

 

 
 

Continue in the same way for the remaining cell-field links. 
 

Cell Data Field 
Name DrawingName 
ID-No. Drawing-ID 

Drawing-No. Drawing-Number 
 
7. Export to Database 

 
In the next dialog you will need to define the database where index data will be exported to. 
We are going to export an HTML file (e.g. for CD creation) and a text file (CSV). 
 
 

HTML 
 
For HTML export, click Add… and choose HTML.  
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Enter C:\Indexing\Output\index.html as output file and C:\Indexing\Output as path for 
thumbnails (path and file will later be created automatically). Confirm your settings with OK. 
 
 

Text (CSV) 
 
Click Add again and choose Text. Mark the option Create CSV compatible file and enter 
C:\Indexing\Output\index.csv as output file name. 
 

 
 
All chosen export formats are listed with their settings. 
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Click Next to continue with the output settings. 
 
 

8. General Output Settings 
 
In the first dialog you can program to convert the processed raster files into another format 
(e.g. convert TIF to JPEG or to Multipage TIF). In our example we will not use this function. 
 

 
 
The second dialog asks for an output folder for the processed drawing files. Also, you can 
define a file name pattern for these drawings. You may use the content of a database field or 
other combinations. Here, we re-name the cleaned-up raster files by adding a suffix to 
"<INFILENAME>-cleaned ". The Sub-Wizard button helps you to define the filename. Your 
output folder should be: C:\Indexing\Output: 



 VP Software Tutorial 

248   Lesson 14     Indexing Tutorial V16 - V9 / E 
 

 

 
 
 
9. Logging 

 
Shows you the location where unprocessed files (in case of an error), the error log files, and 
info log files are stored. 
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Next will take you to the Wizard’s final page: 
 

 
 
Click Finish. All necessary indexing parameters have been defined. The Indexing Parameter 
Tableau dialog appears for reviewing and approving or modifying the settings.  

 

 
 
For this training the dialog shall now be closed to demonstrate how an indexing process can 
be started with existing settings. Thus, click now on Save & Close. Of course, in your own 
projects you can start a process from here immediately. 
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Run Interactive Indexing Process 
 

Load Settings 
 

 Start the Indexing Wizard, select the option Load/Modify existing settings and switch off the 
Wizard support (Use Wizard to review settings). Then, select the settings you have created 
in the previous training session. 
 

 
 

 If you want to start the process immediately, please load the pre-configured settings file from 
the VPindex / VPindex lite SUPPORT folder:  

C:\Users\<user>\AppData\Roaming\softelec\VPindex V9\Support\ 
 

Finish will take you to a tableau view with all settings contained. 
 
 

Change Settings (only for pre-configured Settings File) 
 
In the pre-configured settings file all settings referring to file paths have been omitted in order 
to keep them independent from your individual VPindex installation. Now, these settings need 
to be defined: 



VP Software Tutorial  

Tutorial V16 - V9 / E Lesson 14   Indexing   251
 

 
File Selection 

 Click on the Wizard button in the Files tab for file selection. Select all files in the VPindex 
subfolder Samples (see also 1. File Selection in the previous section). Then, close the 
dialog. 
 
Settings modifications are now completed. 
 
 

Start Indexing 
 
Clicking on Go will start the indexing process with the selected drawing files. 
 
During the process you can constantly monitor which drawing is currently processed and 
which tasks are performed for each drawing:  
 

 
 

 
Data Review 

 
Since you are in an interactive mode the program will halt with each file in the process for a 
review of the recorded indexing data.  
 

 
 
The first data field and the extracted content are highlighted for approval or correction. 
VPindex automatically highlights the cell you are currently editing in the title block image as 
well. Press [Enter] on your keyboard to move to the second data field. Correct the Drawing-ID 
manually if necessary, as the cell content may not be extracted completely and press [Enter] 
again and so on. When finished with all data fields, click OK/Next.  
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Edit files manually 

 
In case an error occurs during an automatic processing task you will be prompted to run the 
respective function manually. 
 

No matching paper format (Calibrate to Paper Format) (VPindex only) 
This error may occur in case no matching paper format has been specified. You can select 
the correct format in the dialog Calibrate to Paper Format and carry out a manual calibration. 
 

Rotation failed 
In this error case the Rotate Quadrantal mode will be started automatically. According to 
your cursor position you can rotate the document by 0, 90, 180 or 360 degrees. 
 

No matching template found 
The following dialog appears: 
 

 
 
You can select a matching template and move it to the title block area with Position 
Template. All templates defined for the current process are available. If there is no matching 
template available you can proceed to the data review/data retrieval with Continue without 
Template.  
 
 

Finish 
 
The following message appears when all files are processed: 
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Details on the indexing process are saved in the log file info.log.  
 

 
Example for a successful indexing process 
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Run Unattended Indexing Process (VPindex only)  
  

 
Load Settings 

 

 Start the Indexing Wizard, select the option Load/Modify existing settings, and switch off 
the Wizard support (Use Wizard to review settings). Then, select the settings you have 
created in the previous training session. 
 

 
 

 If you want to start the process immediately, please load the pre-configured settings file from 
the VPindex / VPindex lite SUPPORT folder:  

C:\Users\<user>\AppData\Roaming\softelec\VPindex V9\Support\IdxSettings-Auto.vpi 
 
Finish will take you the tableau view with all settings contained. 
 
 

Change Settings 
 
In the pre-configured settings file all settings referring to file paths have been omitted in order 
to keep them independent from your individual VPindex installation. Now, these settings need 
to be defined: 
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File Selection 

 Click on the Wizard button in the Files tab for file selection. Select all files in the VPindex 
subfolder Samples (see also 1. File Selection in the previous section). Then, close the 
dialog. 
 
Settings modifications are now completed. 
 
 

Start Indexing 
 
Clicking on Go will start the indexing process with the selected drawing files. 
 
During the process you can constantly monitor which drawing is currently processed and 
which tasks are performed for each drawing:  
 

 
 
This indexing process can run in unattended mode (e.g. overnight). After cleaning, 
processing, and indexing all selected drawings the following dialog will be displayed: 
 

 
 
 

Reviewing Indexed Data 
 
When the unattended indexing process has finished you may either start your review run 
immediately or at a later stage. Also, the review run may be interrupted and can be continued 
at a later stage (see below). 
 

 It is always necessary to verify the recognized data before exporting them to a database. A 
dialog opens where you need to enter the folder with the temporary reviewing data. In general, 
the system will remember the location, so just click OK: 
 
If files could not be processed in an automatic indexing process because of, e.g. mis-
matching paper formats or templates, a manual review of these files will start first (see above 
Edit Files Manually and Data Review) After this the actual data review will start. 
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Immediate Review 

 
Click Review in the Indexing Finished dialog to open this dialog: 
 

 
 
Start the review with OK. All drawings of the current process will now be reviewed. 
 
Step by step, all title blocks will be displayed together with the recognized data for verification: 
 

 
 

When necessary, correct the individual results and continue with OK / Next for the next title 
block. 

 You can quickly run through the data and move easily from cell to cell simply by using the 
[Return] key. 
 
The entire batch/indexing process is finished now.  
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Review at a later stage 

 With this icon you will start a review or continue with paused review. A dialog opens where 
you need to enter the folder with the temporary reviewing data. In general, the system will 
remember the location, so just click OK: 
 

 
 
As this routine finally exports the index data to a database, the content of the intermediate 
review folder will then become obsolete. You may check-mark the "Delete folder after 
successful review" option. 
 
Step by step, all title blocks will be displayed together with the recognized data for verification 
(see above). 
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Review Exported Data and Cleaned Files  
 

We can now review the two selected export format results  and the cleaned drawing files 
ready for final archiving. 
 
 

1. HTML 
 
Double-click on the index.htm file in the folder C:\Indexing\Output. or 
C:\Indexing\OutputAuto The browser opens the overview of all indexed/modified drawings, 
including thumbnails and extracted data: 
 

 
 
 

2. Import CSV File in MS Access 
 
Start MS Access and Open the file Sample2000.mdb in the VPindex installation sub-folder 
Samples. 

e.g. C:\Programs\softelec\VPindex V9\Samples\ Sample2000.mdb 
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 Attention: As we apply filters and work with databases we recommend to save a backup copy 
of Sample2000.mdb! 
 
Import the file index.csv in C:\Indexing\Output or in C:\Indexing\Output (Get external data 
– Import). Please mind the following import settings:  

• Delimiter: Semicolon 
• First Row Contains Field Names 
• In an Existing Table: Drawing 

 
 

When completed you can view the recorded indexing data in the table „Drawing“.  
 

 
 
 

3. Modified/Converted Drawings 
 
In the previously defined folder C:\Indexing\Output or C:\Indexing\OutputAuto, all cleaned 
files can be found. They are all renamed with the appendix "-cleaned". 
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Indexing Process Using Isolated Cells  
 
This part of the lesson refers to recording data from various positions in the drawing. 
 

Load Settings 
 

 Start the Indexing Wizard, select the option Load/Modify existing settings and switch off the 
Wizard support (Use Wizard to review settings). Select the pre-defined settings in the 
VPindex SUPPORT folder:  

C:\Users\<user>\AppData\Roaming\softelec\VPindex V9\Support\IdxSettings-IsolatedCells.vpi 
 
Click Next. - the Indexing Parameter Tableau is displayed containing all loaded settings.  
 
 

Change Settings 
 

File Selection 

 Click on the Wizard button in the Files tab for file selection. Select all files in the VPindex 
subfolder Samples\DataSheets (DataSheet01.tif - DataSheet04.TIF). Close the wizard. 
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Create Indexing Template 
 

 Switch to the Templates tab and click on the Wizard button. Click on Create in the Indexing 
Templates dialog. In the following dialog select From Selection Set and click on 
DataSheet01.tif as sample file. Click Next. 
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After the sample file is loaded the Raster Cleanup dialog opens.  

 
 
Click Start predefined cleanup to initiate the pre-defined functions as saved in the settings 
file. In our example it is the function AUTODESKEW (automatic deskewing) to align the 
drawing orthogonally. When completed Close the dialog. 

 
The following dialog allows for marking a title block area. Since the current files do not contain 
a title block you are going to create a template with isolated cells only. Therefore, skip this 
dialog with Next. 

 The function to define isolated cells will be active. Zoom into the drawing and drag a rectangle 
around the position of the ID value to create a template cell. The cell size should be adequate 
as in the example below: 

 
 
Assign ID as cell name. Continue as described to add more cells: 
 

Name OCR Options Settings 
ID Global OCR Settings Ignore cell title/small text 

Date Global OCR Settings Ignore cell title/small text 
CPU Global OCR Settings Ignore cell title/small text 
RAM Global OCR Settings Ignore cell title/small text 

For the  DVD cell you have two options: 
 
Version 1: No checkbox recognition 

 

Name OCR Options Settings 
DVD None - 

 
Version 2: Checkbox recognition 

 

Name OCR Options Settings 
DVD Checkbox Ignore cell title/small text 
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When completed the defined template cells should be displayed as follows: 

 
Version 1: Without checkbox recognition 

 
Click Next and name the template as Template-DataSheet-new.tbt to save it in the Support 
folder. 

 
 
Leave the Wizard with Finish and close the Indexing Templates dialog with OK. 
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Define and Link Data Fields 

 Switch to the Data Fields tab and click on the button Import Fields from Indexing template. 
Open the file Template-DataSheet-new.tbt, select all cells for import, and start the import 
with OK. Data fields will now be created from the defined cells. A dialog will prompt to define 
field types for each cell selected: 
 

 
 
Confirm the default values for all data fields.  
 

Version 1: No checkbox recognition - create default value list 
For the database field DVD define default values, which will be offered as values from a list 
during the review process.  

 Mark the file DVD and click the Modify button to open the appropriate dialog: 
 

 

 Switch the Type to From List( = Default Value) and click on the button to enter the desired 
values for this field: 

 
 
Enter Yes and No and close the List. Also set the Required checkbox: 
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Close the dialog with OK.  
 

Version 2: Checkbox recognition 
In this variant no further adjustments are necessary. 
 

Linkage checking 
After the import is completed you may click on the Cells-Fields tab to view the current 
assignments. Cell names and data field names are identical, thus, the active links have been 
inserted automatically. 

 

 
 
 

Export and Output 
 
In the current settings file the paths for data export (index.html), for log files and for copies of 
input files (C:\Indexing\OutputDataSheets) are pre-defined. If required, please select 
individual target folders.  
 
To change the options for the HTML file, switch to the DB-Export tab, select the HTML entry 
and click on Configure. 
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Output folder for HTML files. 

 
 
To change the root directory for output and log files, switch to the Output tab. 

 

 
Output folder for log files and for copies of input files. 

 
 
All changes to the settings are completed. 
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Perform Indexing Process 

 
Start the indexing process with Save & Go. A message appears indicating that files will be 
processed, but that document cleanup will be ignored. This message will always appear as a 
warning when cleanup functions are assigned to a process while the Only Indexing mode 
has been selected. For the current lesson files are going to be processed for indexing, but no 
cleanup shall be used. So, you can ignore the warning by confirming with Yes. 
 
All selected files will be loaded and deskewed consecutively. All data will be recorded 
according to the indexing template definitions and prompted for reviewing. 

 
Version 1: With default values, no checkbox recognition 

 
Version 1: No checkbox recognition 

The value for the field DVD has to be entered manually: Select Yes/No accordingly from the 
list.  
 

Version 2: Checkbox recognition 
The check mark were recognized and the Yes/No values are preset automatically  
 
If required you can correct the indexing results. Then confirm all with OK / Next. When the 
process is completed you can open the file Index.html in the 
C:\Indexing\OutputDataSheets folder. Your browser will display all processed drawings, 
including a preview with all data recorded. 
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