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About the eForms Designer Tutorial

Welcome to the FileNet® eForms Designer for Windows® application. eForms Designer is powerful, yet 
easy-to-use software designed for creating professional-looking forms for paper or electronic use. This 
tutorial is intended for form and form template policy authors looking for an introduction on how to 
integrate eForms with the FileNet Workplace.

This tutorial explains the basic techniques of creating forms with eForms Designer and how to create 
simple document and workflow policies that use eForms in Workplace. You’ll learn how to draw the graphic 
elements of a template and to configure many of the intelligence features commonly found in electronic 
forms. At the end of the tutorial, you will deploy the form to Workplace, create some form template policies, 
and test the features of the eForm.

The eForms Designer tutorial contains several sections that guide you through the process of creating an 
electronic purchase order form for a fictitious company called World Corporation. Each section is 
organized into lessons with specific tasks to complete in order to create and deploy your form.

The picture below gives you an idea of what your form will look like (as completed by a user) at the end of 
this Tutorial:
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NOTE  Included on your FileNet eForms Designer CD is a Tutorial folder that contains a graphic required 
for a design and graphics task, and a completed copy of the purchase order form template. You can use 
this template at the end of the design and intelligence portion of this tutorial to compare your results with. 
This template has been password protected. The password for the template is given at the end of the last 
intelligence task for this tutorial. If you do not have access to the eForms Designer CD, please contact your 
system administrator.

The eForms Designer Documentation

The eForms Designer documentation provides you with a complete reference to the features and 
capabilities of eForms Designer. The help files combine text and graphics to thoroughly document every 
aspect of the software. In addition to your eForms Designer tutorial, the set also contains the following:

• The eForms Designer Help provides a complete reference to eForms Designer’s design and graphics 
features. Instructions are given for every step in the form design process, including preparing the 
drawing area of the template, using the drawing tools, adding graphics, and printing. It also provides a 
detailed reference to eForms Designer’s forms automation features and Workplace integration 
features. You’ll learn about data handling capabilities, using digital signatures, linking forms to other 
data sources, using formulas and functions, how to deploy ITX form templates to the workplace, and 
how to set properties. It also provides guidelines for distributing both new templates and new revisions 
of templates in an organization.

NOTE  Refer to the FileNet eForms for Workplace Installation Guide for eForms Designer system 
requirements and installation instructions.
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Getting Started

This section explains how to get started with FileNet eForms Designer. It is assumed that you have already 
installed and registered eForms Designer on your computer. See your FileNet eForms for Workplace 
Installation Guide for complete installation instructions.

Overview

The desktop application eForms Designer is used to create a special file called a form template. A form 
template contains the layout, graphic elements, and intelligence features of an electronic form. Once the 
form design is complete, it can be deployed to the Workplace and configured within a form template policy 
so that users can fill out forms on-line.

Imagine that you’re the form author for a fictitious company called World Corporation. You’ve been 
assigned the task of creating a purchase requisition form. Most departments in the company will use the 
form on-line, but a few departments will use a paper version, so you need to create an intelligent electronic 
form that looks good on paper. Fortunately, you’ve got eForms Designer, the forms design tool that gives 
you the best of both worlds.

Starting eForms Designer

The first step in drawing your template is to start eForms Designer. 

1. Click Start; then select Programs > eForms Designer. A new, blank template appears.
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The Drawing Window

Before you start drawing, it’s helpful for you to understand exactly what is displayed in the drawing window. 
This section introduces and explains two of the most important elements contained in the drawing window: 
the drawing area and the print margins.

Drawing Area

The drawing area is the white rectangle that appears in the drawing window. It’s where you draw and 
modify the design of your form.

Print Margins

The red dotted lines in the drawing area are called print margins. Any object (or part of an object) drawn 
outside these lines will not print. These lines appear only if you have a printer configured (standalone or on 
a network) to your machine. If print margins do not appear on your template, choose Start > Settings > 
Printers and Faxes or Start > Settings > Control Panel (choose Printers and Faxes) and add a printer. 

Page Tabs

The page tabs at the top of the drawing window allow you to move between the pages of your form. To 
move to a specific page, click the appropriate page tab.

Drawing area

Print margins
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The Drawing Tools

You draw a template much as you would using other graphics applications: by typing text and drawing 
graphical objects such as lines, boxes, and shaded areas using a variety of drawing tools. The Drawing 
palette provides access to eForms Designer’s drawing tools.

The Drawing palette is initially displayed as a toolbar at the top of the drawing window. To display it as a 
palette, click the move handle at the far left hand side of the toolbar and drag it anywhere on your screen.

Each drawing tool in eForms Designer has a specialized purpose. Using these tools, you can create the 
graphic elements that are commonly found on most types of forms.

You’ll learn about the drawing tools in detail as you perform the tasks in this tutorial.

This is the end of the Getting Started section. The next section shows you how to prepare your template 
for drawing.

Page tabs
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Setting Up a Template

This section explains the basic procedures involved in setting up a template. After completing this section, 
you’ll know how to perform the following tasks:

1. The setup process:

• Specify a drawing size (Task 1a on page 15). 

• Choose a paper size (Task 1b on page 16).

2. Show drawing aids:

• Rulers (Task 2a on page 17).

• Specs palette (Task 2b on page 18).

• Guide lines (Task 2c on page 18).

• Grid (Task 2d on page 19).

The Setup Process

Setting up a template refers to the process of preparing a form for drawing. In this lesson, you’ll specify the 
size of the template, choose a paper size for printing, and display and configure the various drawing aids 
available in eForms Designer.

Task 1a: Set the Drawing Size

The actual size of a template is called the drawing size. Before you begin drawing, you should determine 
what the size of your finished template will be, and set the drawing size accordingly.

The World Corporation purchase order template is 8.5 inches wide by 9.5 inches high. For this task, you’ll 
use the Drawing Setup command to set these dimensions.

To set the drawing size of a template

1. Choose Layout > Drawing Setup to display the Drawing Setup dialog box.
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2. Enter 8.5 in the ‘Width’ field and press Tab.

3. Enter 9.5 in the ‘Height’ field and press Tab.

Notice how the drawing setup illustration on the left of the dialog box updates to show the new drawing 
area size.

4. Click OK to return to the drawing window.

Task 1b: Choose the Paper Size

If you’re going to print your template, you must specify the size of the sheet of paper that the template will 
be printed on. For example, a form that measures 8 inches by 10 inches would print on a standard 8.5 by 
11-inch letter-sized sheet of paper, while a form that measures 8 inches by 13 inches would print onto a 
standard 8.5 by 14-inch legal-sized sheet of paper.

Your template will be printed onto a standard 8.5 by 11-inch letter-sized sheet of paper. For this task, you’ll 
choose the appropriate paper size for printing.

To select a paper size for printing a template:

1. Choose File > Print Setup to display the appropriate dialog box for your printer. 
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Select the ‘Letter’ option (8.5 x 11) from the ‘Size’ drop-down list. 

2. Click OK to return to the drawing window.

Showing the Drawing Aids

eForms Designer provides a number of drawing aids that make it easier for you to draw and position 
objects on your form. You can show or hide each of these drawing aids as required. In this lesson, you’ll 
learn how to display rulers, the specs palette, and guide lines.

Task 2a: Display Rulers

The rulers help you measure and align objects on your form. Use the rulers to help draw, position, and 
resize objects accurately. When visible, the rulers appear at the top and left edges of the drawing window. 
You use the Show Ruler command to display the rulers in your drawing window.

To display the rulers

1. Choose Layout > Show Ruler or use the keystroke Ctrl-R.

Your drawing window should now look like the one that follows:
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2. To change your ruler settings, choose Edit > Preferences and click “Layout” or double-click the ruler.

Task 2b: Display the Specs Palette

The Specs (specifications) palette helps you resize and reposition objects on your template. It displays 
coordinate information pertaining to the pointer and any currently selected object. The Specs palette can 
be displayed, hidden, or dragged, but not resized.

You’ll see the current cursor (x,y) position located in the first set of coordinates at the footer of the eForms 
Designer screen. 

You use the Specs command to display the Specs palette in the drawing window.

To display the Specs palette

1. Choose Window > Toolbars > Specs. The Specs palette is now visible.

Task 2c: Display Guide Lines

Guide lines are alignment aids that run vertically and horizontally along the drawing area of your form 
template. You create and adjust each guide line independently and you can place a guide line at any 
position on the drawing area, allowing you to align objects to a specific position on your form.

Specs palette

Cursor coordinates
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For this task, you’ll create a guide line so you can align objects along the left side of your template.

To display guide lines

1. Click the left-side ruler, hold the mouse button down, and drag the pointer onto the drawing area. As 
you move the mouse, a thin line called a guide line follows the pointer.

2. Release the mouse button when the vertical guide line’s position is 0.5 inches from the left. Watch the 
coordinates at the bottom of the drawing window to get the proper coordinate.

You should now see a blue line along the left edge of the drawing area, inside the left print margin.

3. Click the top ruler and create a second (horizontal) guide line that lies 0.75 inches from the top. Again, 
watch the Specs palette to get the proper coordinate.

The Snap To Guides Feature

eForms Designer provides a feature called “Snap to Guides” to help you position objects on your form. 
With the Snap to Guides feature turned on, any object that you draw, drag, or resize will automatically align 
to the nearest guide line, provided that the object falls within 5 pixels of the guide.

By default, the Snap to Guides feature is turned on when you start eForms Designer. You can disable this 
feature by choosing Layout > Snap To Guides.

Task 2d: Display the Grid

A grid contains lines that run vertically and horizontally across the drawing area of your form template. You 
can adjust the density of the grid, allowing you to align objects to a specific horizontal and vertical co-
ordinate on the form. If you prefer to use just the guide lines, skip this task.

To display the grid

1. Choose Layout > Show > Grid.

2. (Optional) Double-click the ruler and decrease the “Draw every: 5 lines”  to 2 lines for the horizontal 
grid and the “Draw every: 6 lines”  to 2 lines for the vertical grid to create a more dense grid.

Click the ruler...

...drag

...and release.
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This is the end of the Setting Up section. The next section explains how to incorporate graphics and text 
objects into your template.
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Graphics and Text

This section explains how to draw and modify graphics and text objects on your template. At the end of this 
section, you’ll know how to:

1. Draw graphic objects:

• Draw a graphic object (Task 3a on page 21).

• Reposition the object (Task 3b on page 22).

2. Draw text objects:

• Draw a text object (Task 4a on page 23).

• Change the appearance of the object (Task 4b on page 23).

• Create the form title text (Task 4c on page 24).

• Move the text objects to their final position (Task 4d on page 24).

3. Import and resize artwork from other applications:

• Import the graphic (Task 5a on page 25).

• Resize the graphics object (Task 5b on page 26).

4. Lock the position of objects on your template (Task 7 on page 27).

5. Save the template (Task 8 on page 28).

Drawing Graphic Objects

The World Corporation art department is in the process of completing a new company logo for you to add 
to your purchase order form. Although the logo is not ready yet, you can draw a rectangle to use as a 
placeholder for the logo on your form. In this lesson, you’ll draw a graphic object and then reposition it on 
your template.

Task 3a: Draw a Graphic Object

To draw a rectangle

1. Select the Rectangle tool  by clicking it once on the Drawing palette.

2. Click in a clear area of the form and draw a rectangle 0.75 inches high by 1.125 inches wide. Watch 
the ‘Height’ and ‘Width’ portions of the Specs palette to get the proper dimensions.

3. Release the mouse button when the rectangle is the right size.

TIP  If you have difficulty getting the rectangle to the correct size, here’s a helpful hint:

a. Draw a rectangle approximately the size you want; then release the mouse button.

b. Double-click the pointer in the ‘Height’ field on the Specs palette.

c. Type the exact height dimension and press Tab to highlight the ‘Width’ field.

d. Type the exact width dimension and press Enter.
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The rectangle automatically adjusts to reflect the proper dimensions.

Task 3b: Reposition the Graphic Object

Once you’ve drawn the rectangle to the correct size, you’ll need to reposition it.

1. Select the Pointer tool by clicking it once on the Drawing palette.

2. Click in the middle of the rectangle and hold the mouse button down.

3. Drag the rectangle toward the point where your guide lines intersect. As you drag close to the guides, 
the Snap to Guides feature automatically aligns the rectangle to the guides at 0.75 inches from the top 
and 0.5 inches from the left.

 You can type values directly into
 the boxes on the Specs palette.
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Drawing Text Objects

Now that you know where the company logo will be positioned, you can add the company address and the 
title of the form. In this lesson, you’ll create the address and form title text objects, change their 
appearance, and move them into place on your template.

Task 4a: Draw a Text Object

1. Select the Text tool  by clicking it once on the Drawing palette.

2. Click the pointer to the right of the rectangle and type the following address, pressing Enter or Return 
at the end of each line:

World Corporation

115 N. Michigan Ave.

Chicago, IL 12345

3. Press Enter on the numeric keypad to select the new text object.

You can change the appearance of a text object by changing its font, font style, or size attributes.

Task 4b: Change the Appearance of the Text Object

1. Select the text object (if it’s not already selected).

2. Choose Style > Font. The Font dialog box appears.

3. Choose “Times New Roman” from the ‘Font’ drop-down list.

4. Choose “12” point from the ‘Size’ drop-down list.

5. Click OK.
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TIP  You can also use the ‘Font’ and ‘Font Size’ drop-down lists on the Formatting toolbar to change the 
selected text object.

Task 4c: Create the Form Title Text

Next, you’ll create another text object for the form’s title.

1. Select the Text tool by clicking it once on the Drawing palette.

2. Click to the right of the address text and type “PURCHASE ORDER” in upper case letters.

3. Press Enter on the numeric keypad to select the new text object.

4. Use the Font command or the Formatting toolbar to change the title text attributes to:

• Font - “Arial” (Windows)

• Size - “18”

• Style - “Bold”

Task 4d: Move the Text Objects to Their Final Positions

1. Select the Pointer tool.

Click and drag the address text to 1.042 inches from the top and 1.875 inches from the left.

You can also use the Arrow keys (Up, Down, Left, Right) to nudge a selected object to a new position.

2. Select the PURCHASE ORDER text with the Pointer tool.

3. Use the Arrow keys to nudge the text so that its top edge is at 0.75 inches and its left edge is at 5.5 
inches.
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Your template should now look like the one shown below.

Importing and Modifying Graphics

The art department has finished the new logo and sent it to you. In this lesson, you’ll import the logo into 
your template and resize the graphics object. If you prefer, you can also create your own logo for this task, 
provided that it fits within the dimensions given for the rectangle object.

Task 5a: Import the Graphic

1. Choose File > Import > Import from File 

The Import dialog box appears. 

2. Select “Windows Bitmap (*.bmp)” from the ‘Files of Type’ drop-down list.

3. Select the file named “Logo” from the Logo folder in the eForms Designer Tutorial folder.

4. Click Open.

The logo is imported at full size and needs to be resized to fit the template.
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Task 5b: Resize the Graphics Object

eForms Designer provides several methods of resizing objects. Since you already have a placeholder 
that’s the same size as the logo needs to be, you can use the ‘Resize by example’ method.

1. If it’s not already selected, use the Pointer tool to select the imported logo.

2. Choose Arrange > Resize to display the Resize Objects dialog box.

3. Select the ‘By example’ option; then click OK.

When you return to the drawing window, notice how the pointer has changed to a hand.

4. Click the rectangle placeholder with the “hand” pointer; the logo is automatically resized.
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5. Using the Pointer tool, click and drag the logo so that it sits directly on top of the rectangle placeholder 
at 0.75 inches from the top and 0.5 inches from the left. The logo will snap to the guide lines if you still 
have this option selected in the Layout menu.

Task 6: Move the Objects to the Master Page

So far, all of your work has been done on the template located on the Page 1 tab. If the form you are 
creating is going to have more than one page, you’ll want objects such as company logos and addresses 
to automatically appear on every page. To do this, place these objects on the Master Page.

1. To select all objects, with the Pointer tool click the logo and then press Ctrl + A.

2. Select Edit > Cut or press Ctrl + X to cut the objects.

3. Select the Master Page tab.

4. Press Ctrl + Alt + V to paste all the objects on the Master Page with their identical co-ordinates from 
the previous page. (If you press Ctrl + V, the objects will be moved to the incorrect co-ordinates.)

Task 7: Lock the Objects in Place

For this task, you’ll lock the position of the objects on your template to prevent them from being moved 
accidentally. It’s usually faster to select and modify multiple objects at once, so you’ll use the Select All 
command.

1. Choose Edit > Select All to select all the objects on your template.

2. Choose Settings > Object to display the Object Settings dialog box.

3. Select the ‘Position’ checkbox; then click OK.

If you select a locked object, the handles on the corners of the object appear in green. If you attempt to 
drag a locked object, the pointer changes to a lock. This indicates that the object cannot be moved 
unless the ‘Position’ checkbox on the Object Settings dialog box is cleared.
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Task 8: Save the Template

It’s practical to save your template frequently during the creation process. You can save the changes to 
your template at any time by using the Save command. Because you’re saving this template for the first 
time, you’ll be asked to name it and specify where it is to be saved.

1. Choose File > Save. 

2. Name the file “PurchaseOrder” and save the template as an ITX Form Template (*.itx). 

3. Specify a location to store the new template.

4. Click Save.

The title bar changes to reflect the saved file name. It is recommended that you save your template 
after each task for the remainder of the template design sections in this Tutorial.

This is the end of the Graphics and Text section. The next section explains Field creation.
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Fields

This section explains what a field is and shows you how to draw and modify field objects. At the end of this 
section, you’ll know how to perform the following tasks:

1. Draw fields:

• Draw three fields (Task 9a on page 30).

• Duplicate a field with the Duplicate command (Task 9b on page 31).

• Duplicate a field with the Command palette (Task 9c on page 31).

• Resize a field using the pointer tool (Task 9d on page 32).

• Draw four more fields (Task 9e on page 32).

2. Select and modify the individual parts of a field:

• Modify the title area of a field (Task 10a on page 33).

• Change the title alignment (Task 10b on page 35).

• Create titles for the fields (Task 10c on page 35).

• Fill an object with a color (Task 10d on page 36).

Overview

Fields are graphic objects that hold information. Each field contains a cell—a holding place for data. When 
a form is filled out, information is entered into the cell.

Unlike other graphic objects such as lines, rectangles, and ovals, fields are composed of different 
elements or parts. When you draw a field with eForms Designer’s Field tool, these various parts are 
created automatically. The following illustration shows the parts of a typical field.

The cell section of a field also has a variety of options that you can set. For example, you can specify what 
kind of information the cell will hold (text, date, number, and so on) and how that information will be 
displayed. See “Cells” on page 57 for more information.

Drawing Fields

In this lesson, you’ll draw, duplicate, and resize several fields on your template.

Title section

Title divider

Cell section



TUTORIAL
Draw Three Fields

30

Task 9a: Draw Three Fields

For this task, you’ll start drawing the fields where data will be entered on your template.

1. Select the Page 1 tab located above the top ruler.

2. Double-click the Field  tool from the Drawing toolbar and select the first option, or click it once to 
select the default style.

3. Click the mouse button in a clear area of the drawing window and drag the pointer diagonally to draw a 
field that’s 0.5 inches high by 2.25 inches wide. You can use the arrow buttons in the Specs palette to 
fine-tune the size of the field after you have drawn it with the mouse.

4. Select the Pointer tool; then click and drag the new field object to 1.611 inches from the top and 5.75 
inches from the left. Remember, you can use the arrow keys to nudge an object into position.

5. Select the Field tool again by clicking it once on the Drawing palette.

6. Draw a new field that’s 1.0 inch high and 3.0 inches wide. Click and drag the field so that it’s 2.111 
inches from the top and 0.5 inches from the left.

7. Draw a new field that’s 1.0 inch high and 2.25 inches wide. Click and drag the field so that it’s 2.111 
inches from the top and 3.5 inches from the left.
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Task 9b: Duplicate a Field Using the Duplicate Command

You need to draw another field that’s identical to the one you just created, but rather than draw another 
field, it’s often faster to duplicate it.

1. Select the last field; then choose Arrange > Duplicate or use the keystroke Ctrl-D.

2. A duplicate field appears to the right of the original field, and is the currently selected object.

Task 9c: Duplicate a Field Using the Command Palette

The Command palette provides shortcuts to many of eForms Designer’s object handling commands, 
including duplicating objects. It is initially displayed as a toolbar at the top of the drawing window. You can 
change it to palette mode by clicking and dragging its move handle onto the drawing area. 

1. Choose Window > Toolbars > Command to display the Command palette.

2. If it’s not already selected, select the last field using the Pointer tool.

3. Click the Duplicate Vertical button  to duplicate the fourth field.
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Task 9d: Resize a Field Using the Pointer Tool

In the “Graphics and Text” section, you learned how to resize an object by using the Resize command. 
You can also use the Pointer tool to quickly resize objects on your form.

Use the Pointer tool to change the height of the last field you created.

1. Select the Pointer tool.

2. Click the last field to select it.

3. Move the pointer to the bottom edge of the last field until the cursor changes to a pair of vertical arrows 
pointing towards each other. 

4. Click the bottom edge and drag it up until the height of the field is 0.5 inches.

NOTE  You can drag only the edges of field or table objects. To resize other types of objects with the 
Pointer tool, you must click and drag the handles at the corners of the selected object.

Task 9e: Draw Four More Fields

To finish off this section of the tutorial, you’ll draw four more fields and then learn how to modify individual 
parts of the fields.

1. Select the Field tool from the Drawing palette.

2. Draw a new field that’s 1.0 inch high and 7.5 inches wide. Click and drag the field so that it’s 3.611 
inches from the top and 0.5 inches from the left.

Select a field... ...drag the edge... ...release the mouse button.
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Now draw the final three fields.

1. Draw a field that’s 0.5 inches high and 3.5 inches wide. Position it 8.111 inches from the top and 0.5 
inches from the left, 

2. Make sure the new field is selected; then choose Arrange > Duplicate or the Duplicate Horizontal 
button on the Command palette to create a second field.

3. Use the Pointer tool to change the width of the second field to 1.75 inches.

4. Duplicate the second field.

5. Use the Pointer tool to change the width of the final field to 2.25 inches. You can get this exact amount 
by entering it in the Width box of the Specs palette.

Modifying Parts of a Field

In this next lesson, you’ll learn how to select and modify specific parts of the fields on your template.

Task 10a: Modify the Title Area of the Fields

You can change the title area of an individual field, or you can do a bulk change in all of the fields present.

1. Click once with the Pointer tool to select the first field that you created.

2. Click again in the title area to select only that specific region. The region will become highlighted with 
moving dashes.
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In this example, you’re going to modify the title area for each field on the template. The most efficient 
way to do this is to select all the title areas and modify them all at once.

3. With the title section of the first field selected, choose Edit > Select Same. The titles areas of the other 
fields are now selected as well.

4. Choose Style > Font to display the Font or Type Settings dialog box. 

5. Change the type settings to “Arial”, “9” point; then click OK.

Select the title section
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You can also use the ‘Font’ and ‘Font Size’ drop down menus from the Formatting toolbar to perform 
this task.

Task 10b: Change the Title Alignment (Optional)

In Task 9a, step 2, if you double-clicked the field tool and chose the first option, you’ll notice that in all the 
fields, the Title area is center aligned. You can change the alignment for the title and/or the cell data area 
by using the Alignment command.

1. Click any cell on the form.

2. Choose Edit > Select Same.

3. Choose Style > Alignment > Center. You can also use the keystroke Shift + Ctrl +C, or the Center 
Justify Text button on the Formatting toolbar. The title and cell data area are now centered.

Task 10c: Create Titles for the Fields

When you create a new field, the title area appears with the word “Title” in it. You can use the Text tool to 
replace this default entry with a meaningful title for each field. In this task, use the F3 key to quickly 
advance through the fields as you re-title them, rather than clicking each individual title area.

1. Select the Text tool and double-click the word “Title” in the top right field.

2. Type “Purchase Order Number.” Press F3 to highlight the next title area.

3. Type “Supplier Name and Address.” Press F3.

4. Type “Send Invoice To”; then press F3.

5. Type “Delver Goods To”; then press F3. (“Delver” is an intentional spelling error that you’ll correct later 
in the tutorial).

6. Type “Ship Via”; then press F3.

7. Type “Special Instructions”; then press F3.

8. Type “Authorizing Signature”; then press F3.

9. Type “Date Issued”; then press F3.

10. Type “Total” to re-title the last field, then double-click the Pointer tool button to de-select the last field 
and complete the task.
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NOTE  You can also use the Cell command to enter the display name of a field.

Task 10d: Add a Colored Fill

You can add a background color to the title area of a field in order to highlight the various sections of the 
form. In this example, you’ll add a colored fill to all of the title areas.

1. Using the Pointer tool, select the title area of the ‘Purchase Order Number’ field.

2. Choose Edit > Select Same to select all the field title areas.

3. Choose Style > Fill Color and select a color of your choice from the color palette.

4. Choose File > Save to save your changes.

Your template should now look like the one that follows:

Selected color
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This is the end of the Fields section. In the next section, you’ll learn about creating and formatting Table 
objects.
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Tables

This section explains how to draw and modify table objects. At the end of this section, you’ll know how to 
perform the following tasks:

1. Draw a table (Task 11 on page 39).

2. Modify parts of a table.

• Modify the final row height (Task 12a on page 40).

• Change the column width of a table (Task 12b on page 40).

• Modify the table row (Task 12c on page 41).

• Change the table and column title (Task 12d on page 41).

• Add a scroll bar (Task 12e on page 42).

Overview

Tables are graphic objects that hold information. Each table contains one or more columns and each 
column contains a cell—a holding place for data. When a form is filled out, information is entered into each 
cell.

It’s recommended that you use tables instead of multiple cells whenever possible. Tables are quicker to 
draw than multiple cells, they require less memory, and are easier to maintain. For example, it’s much 
easier to adjust the width of a single table column than it is to adjust the width of multiple cells.

Tables are composed of different elements or parts. When you draw a table with eForms Designer’s Table 
tool, these various parts are created automatically.

There are several options that you can use to change the general appearance of a table. For example, you 
can show or hide the title sections, or you can fill the alternating rows with a color.

Drawing Tables

In this lesson, you’ll select a table style and create a table with four columns.

Table title section Column title section

Title dividers

Column section

Row lines
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Task 11: Draw a Table

To select a table style

1. Double-click the Table tool on the Drawings palette to display the ‘Default Table Styles’ dialog 
box.

2. Select the “No Title” style from the left column list; then click OK.

To draw a table

1. Position the pointer in the drawing window, and draw a table that’s approximately 3.5 inches high and 
7.5 inches wide. When you release the mouse button, the ‘Add Columns’ dialog box will appear.

2. Enter 4 in the ‘Number of columns’ box; then click OK. The new table appears as the currently 
selected object.

3. If necessary, use the Specs palette to adjust the height and width of the table so that it’s exactly 3.5 
inches high and 7.5 inches wide.

4. Double-click on the Pointer tool button, and click on the table to select it. Move the table so that it’s 
4.611 inches from the top, and 0.5 inches from the left. You can move it into position by clicking and 
dragging it, or by using the arrow keys on your keyboard to nudge it into place.

 Select this style.
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Modifying Parts of a Table

In this lesson, you’ll change the appearance of a table by adding or removing columns, changing the 
column widths, and changing the number or color of the table rows. To select the individual parts of a 
table, click once with the Pointer tool to select the entire table; then click again to select only the part that 
you want to modify (table title, column title, table rows, etc.). 

Task 12a: Modify the Final Row Height

If the last row in the table appears lesser in height than the previous row, you can correct this by 
“snapping” the row out to one full row length.

To change the final row height

1. Click the table and hover the cursor over the last line of the table until it changes its appearance to a 
vertical double-headed arrow.

2. Click the last line and drag it up or down by one row length.

3. With the Pointer tool, click and drag (lasso) around the 3 fields below the table (Authorizing Signature, 
Date Issued, and Total) to select them, and move them so that they are aligned directly below the 
table. This will remove any spaces between the fields and the table or any overlapping. Choose a 
higher percentage view scale if necessary to help you with the alignment.

Task 12b: Change the Column Width of the Table

To adjust the widths of the individual columns

1. Using the Pointer tool, click and hold the divider line between the first and second columns. eForms 
Designer displays the width of the columns just below the bottom edge of the table. If you drag the 
pointer to the left or right, the measurement reflects the new column widths.

2. Drag the line so that the first column is 0.75 inches wide.
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3. Click and drag the line between the second and third columns to make the second column 4.5 inches 
wide. 

4. Make both the third and fourth columns approximately 1.125 inches wide.

TIP  To evenly distribute the width of the last two columns, click twice in the third column, and press 
Shift while clicking once on the last column. Both columns will be selected. Choose Arrange > 
Distribute Columns to make the columns equal in size.

Task 12c: Modify the Table Rows

You can change the pen setting of a table to alter the color of the lines in the table.

To change the pen setting for the rows in the table

1. Select the Pointer tool.

2. Click any one of the row divider lines. The row dividers “shimmer” to indicate that they’re selected.

3. Choose Style > Pen Color; then select the ‘None’ option on the color palette.

4. Double-click the Pointer tool on the Drawing palette to deselect the table. The row lines are now 
invisible. If you prefer to see row lines, change the color back to black.

Task 12d: Change the Table and Column Titles

In the same way that you changed the title sections of each field on your template, you can also change 
the titles of the table columns.

To change the titles of the table columns

1. Using the Pointer tool, select the title section of the first column; then choose Edit > Select Same.

2. Set the column title type settings to “Arial”, “9” point.

3. Press Tab to highlight the first column title.

4. Type “Qty.” Press F3 to highlight the next table column.

5. Type “Description.” Press F3.

6. Repeat this procedure to name the subsequent columns “Unit Cost” and “Extended Cost.”

7. Fill the column title sections with the same color as the field title sections (refer back to Task 10d if you 
need a reminder of how to do this).
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Task 12e: Add a Scroll Bar

You can add a scroll bar to a table that allows a user to scroll through a table’s contents when it is viewed 
in an electronic version of your form.

To add a scroll bar to a table

1. Click the table and choose Settings > Table. The Table Settings dialog box appears.

2. Select the ‘Include scroll bar’ option. If you want the scroll bar to appear even when there aren’t 
enough table entries to require one, select the ‘Show always’ option. Click OK to accept your choices.

3. Choose File > Save to save the changes to your template.

Your template should now look like the example that follows:
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This is the end of the Tables section. The next section explains how to add pages and change their default 
settings.
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Adding Pages

This section explains how to add pages to a form. At the end of this section, you’ll know how to perform the 
following tasks:

1. Add a page after Page 1 (Task 13 on page 44).

2. Page settings:

• Name a page (Task 14a on page 45).

• Print only option (Task 14b on page 45).

Overview

When you start eForms Designer, a blank template opens with 3 pages: Work Page, Master Page, and 
Page 1. You can add any number of numbered pages (as many as your PC’s system memory allows) 
before or after Page 1. When adding pages, be sure to consider the user’s potential machine limitations 
such as screen resolution and monitor size.

After you’ve added new pages, you can use the Page Settings command to rename pages from their 
defaults (Page 2, Page 3, etc.).

You can also restrict printing and/or tabbing for each page (except for the Master Page, which is never 
seen by the user).

Adding Pages

In this lesson, you’ll add a second page to your form.

Task 13: Add a page

To add a page

1. Choose Layout > Add Pages.

2. Type 1 in the ‘Number of Pages’ box, and leave the default of ‘Insert after page 1’ selected. Click OK. 
Page 2 now appears after Page 1. Notice that the logo and text objects contained on your Master 
Page also appear on the new page.

not printable

named pagesnot in the tab sequence
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Page Settings

In this lesson, you’ll enter new names for Page 1 and 2, and restrict printing on Page 2.

Task 14a: Name a page

To name a page

1. Click Page 1 and choose Layout > Page Settings.

2. In the ‘Optional page name’ field, type “Order” and click OK.

3. Click Page 2 and choose Layout > Page Settings.

4. In the ‘Optional page name’ field, type “History” and click OK.

Task 14b: Print only option

To restrict printing on a page

1. Select the “History” page and choose Layout > Page Settings.

2. Under ‘Page Options’ clear the “Print this page” option, and Click OK.

This is the end of the Adding Pages section. The next section explains how to draw and modify different 
styles of Field objects.
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Checkbox Fields and Presentation

This section explains how to draw, modify, and present checkbox fields, and draw a different field style. At 
the end of this section, you will have finished drawing your template and you’ll know how to perform the 
following tasks:

1. Display a guide line (Task 15 on page 47).

2. Draw checkbox fields:

• Choose the checkbox field style (Task 16a on page 47).

• Draw a checkbox field (Task 16b on page 47).

• Replicate the checkbox field (Task 16c on page 48).

3. Modify parts of a checkbox field:

• Change the size of the last checkbox (Task 17a on page 49).

• Modify the checkbox field titles (Task 17b on page 49).

4. Complete the checkbox layout:

• Change the view scale (Task 18a on page 49).

• Draw and place a line object (Task 18b on page 50).

• Add a filled rectangle (Task 18c on page 50).

• Add a text object (Task 18d on page 51).

5. Draw fields on the “History” page:

• Draw a text field without visible borders (Task 19a on page 51).

• Draw a field with the title above the cell data area (Task 19b on page 52)

6. Close the drawing aid (Task 20 on page 52).

Overview

Fields on a form can be as simple as a title with a line next to it...

...or they can be complex, depending on the type of information the form is designed to hold.
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As you’ve seen in the previous tasks, eForms Designer’s default field style is a field with the title section on 
top and the cell section at the bottom. By choosing a different field style, or by modifying the parts of the 
default style, you can easily create a field that best suits your needs.

Task 15: Display a Guide Line

To help you correctly place the objects on your template in this section of the tutorial, you should create a 
new guide line.

1. Select the Pointer tool, drag a new guide line down from the top ruler, and position it 3.0 inches from 
the top.

Drawing Checkbox Fields

You are going to add a number of checkbox fields to your existing form. 

Task 16a: Choose the Checkbox Field Style 

In order to draw checkboxes, you must first select the checkbox field style.

1. Double-click the Field tool on the Drawing palette to display the ‘Default Field Styles’ dialog box.

2. Select the checkbox/title style from the list, as illustrated above; then click OK.

Task 16b: Draw a Checkbox Field

1. With the checkbox field style selected, click in a clear area of the form and draw a field 0.222 inches 
high by 0.639 inches wide.

Select this field style
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2. Select the new field with the Pointer tool and drag it into position approximately 3.319 inches from the 
top and 0.611 inches from the left.

Task 16c: Replicate the Checkbox Field

For this task, you’ll create two more checkbox fields, but instead of drawing each field or duplicating 
multiple times, you will create multiple duplicates by using the Replicate command.

1. Make sure the first checkbox field is selected.

2. Choose Arrange > Replicate to display the Replicate dialog box.

3. Enter 2 in the ‘Number of duplicates’ field; then press Tab.

4. Enter 0.75 in the horizontal offset field and 0 in the vertical offset field.

5. Click OK.

Two new fields appear automatically to the right of the selected field.

Modifying Parts of a Checkbox Field

In this next lesson, you’ll modify the checkbox fields by changing their size and titles.



TUTORIAL
Change the Size of the Last Checkbox

49

Task 17a: Change the Size of the Last Checkbox

1. Double-click the Pointer tool on the Drawing palette to deselect all objects on the form.

2. Select the last checkbox field and drag its right edge until the width is 2.0 inches.

Task 17b: Modify the Checkbox Field Titles

1. Select the title areas of all three checkboxes.

2. Set the font and font size to “Arial”, “9” point.

3. Select the Text tool by clicking it once on the Drawing palette.

Starting with the first checkbox on the left, change the titles to the following:

“Yes”  “No”  “Call First (412) 456-7890”

Completing the Checkbox Layout

In this lesson, you’ll learn how to add graphics and text objects to complete the checkbox layout. 

Task 18a: Change the View Scale

For this task, you should enlarge the view scale to make it easier to align new graphic objects with the 
existing objects on your template.

1. Select the Zoom tool  by clicking it once on the Drawing palette.

2. Position the pointer to the left of the ‘Yes’ checkbox; then click the mouse button.

The view scale enlarges to 200 percent.



TUTORIAL
Draw and Place a Line Object

50

3. Click beside the ‘Yes’ checkbox until the view scale reaches 400 percent. (The view scale is displayed 
in the ‘View’ drop-down list at the lower left corner of the drawing window.)

Task 18b: Draw and Place a Line Object

To have the row of checkboxes appear to be in an enclosed section of the form, you can add a line object 
to the template.

1. Select the Line tool  by clicking it once on the Drawing palette.

2. Draw a vertical line 0.5 inches high, to the left of the ‘Yes’ checkbox. If you hold the Shift key while 
drawing, the line is drawn perfectly straight.

3. Select the Pointer tool from the Drawing palette.

4. Click and drag the new line object so that it connects the ‘Supplier Name’ field and the 
‘Special_Instructions’ field. The line’s position should be 3.111 inches from the top and 0.5 inches from 
the left.

5. Double-click the Zoom tool on the Drawing palette to return the view scale to 100 percent.

Task 18c: Add a Filled Rectangle

Now add a filled rectangle to the top of the checkbox section.
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1. Select the Rectangle tool.

2. Click in the clear space at the bottom of the Drawing Window, and draw a rectangle that’s 0.167 inches 
high by 5.25 inches wide. Select the Pointer tool, and drag the rectangle into position at 3.111 inches 
from the top and 0.5 inches from the left.

3. Fill the new rectangle with the same color you used for the field and table titles.

Task 18d: Add a Text Object

To complete the checkbox section, you’ll add text to the filled rectangle.

1. Select the Text tool.

2. Click in a clear area of the form and type: “Ship Partial Orders?”

3. Select the text object, and set the font and font size to “Arial”, “9” point.

4. Choose Layout > Snap to Guides to turn off the ‘Snap to Guides’ feature.

5. Reposition the new text object to 3.139 from the top and 0.528 from the left.

Task 19a: Draw a Text Field Without Visible Borders

Now, you’ll start work on the second page of the template by adding a text field that doesn’t have visible 
borders.

1. Select the ‘History’ page tab.

2. Double-click the Field tool and select the style as shown below.
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3. Draw the field anywhere on the page, 2.028 inches high and 7.5 inches wide. 

4. Using the Pointer tool, move the field into position 1.611 inches from the top and 0.5 inches from the 
left.

Task 19b: Draw a Field With the Title Above the Cell Data Area

You’ll add the final field to the History page of the template.

1. Double-click the Field tool and select the style as shown below.

2. Draw the field directly below the first cell, 0.528 inches high and 2.958 inches wide.

3. Use the Pointer tool to move the field 3.611 inches from the top, and 0.5 inches from the left.

Task 20: Close the Drawing Aids

Now that you’ve finished drawing the form, you no longer need to display the drawing aids.

1. Click the close buttons on the Specs and Command palettes.

2. Choose Layout > Show > Guides to clear this option and hide the guide lines.

3. Choose Layout > Show > Grid to clear this option and hide the grid.

NOTE  If you want to remove a single guide line, click it with the Pointer tool and drag it back to the 
ruler. 

The “Order” page of your template should now look like this:
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This is the end of the More Field Styles section. The next section shows you how to spell check your 
template.
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Spell Checking

This section explains how to spell check a template. At the end of this section, you’ll know how to perform 
the following tasks:

1. Set spell checking preferences:

• Choose a spell checking language dictionary (Task 21a on page 55).

• Specify the language options (Task 21b on page 55).

2. Spell check your template (Task 22 on page 56).

Overview

eForms Designer comes with a built in spell checker and the spell checking plug-in needed to use it. These 
items are installed automatically when you install eForms Designer.

You can check the spelling of text objects and the title sections of fields and tables on your template. Any 
questionable words on your template are flagged and displayed in the ‘Check Spelling’ dialog box. The 
‘Context’ field at the bottom of the dialog box displays the questionable word in context.

The language dictionaries that are built into eForms Designer allow you to check spelling in several 
different languages. You can also set various options for each of the dictionaries.

NOTE  For spell checking to be available in languages other than English, you must have the spelling 
dictionaries installed. For dictionaries other than English, eForms Designer requires the custom setup 
installation option. Please see your Getting Started guide for instructions.

Setting Spell Checking Preferences

Before you spell check your template, you must specify your spell checking preferences by selecting a 
dictionary and language options.
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Task 21a: Choose a Spell Checking Language Dictionary

1. Choose Edit > Preferences to display the Preferences dialog box.

2. Click the ‘Spelling’ icon in the list to display the Spelling Preferences panel.

3. Choose “English” from the ‘Language’ drop-down list.

If you leave the ‘Always Provide Alternative spellings” checkbox selected, the spell checker will provide a 
list of possible replacements when it identifies a misspelled word.

Task 21b: Specify the Language Options

1. Click the Language Options button in Spelling Preferences to display the ‘English Language Options’ 
dialog box.

2. Select the ‘Business’ checkbox; then click OK.

3. Click OK on the ‘Spell Checking Preferences’ panel to return to the drawing window.
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Task 22: Check Spelling

For this task, you’ll use eForms Designer’s spell checking feature to check your template for any spelling 
errors.

1. Choose Edit > Spelling > Check Template to display the ‘Check Spelling’ dialog box.

As eForms Designer begins checking the template, the word “Delver” will appear in the ‘Check 
Spelling’ dialog box.

2. Click Replace to replace “Delver” with the word “Deliver” from the ‘Suggestions’ list.

If no other spelling errors are found, the fields and the list in the Check Spelling dialog box are blank, 
and only the Done button is available.

3. Click Done to return to the drawing window.

This is the end of the Spell Checking section. The next section explains how to configure template cells to 
accept electronic data entry.
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Cells

This section explains how to configure the cells on your template for electronic data entry. You’ll also learn 
about the Cell palette—a convenient feature that provides quick access to cell settings. By the end of this 
section, you’ll know how to perform the following tasks:

1. Name cells:

• Name a cell using the Command palette (Task 23a on page 58).

• Name a cell using the Cell palette (Task 23b on page 58).

2. Set cell attributes:

• Set the cell type and format for a single cell (Task 24a on page 61).

• Set the cell type and format for multiple cells (Task 24b on page 61).

• Set the type attributes (Task 24c on page 62).

• Set the data entry status (Task 24d on page 63).

3. Create a help message (Task 25 on page 64).

Overview

When you draw a template with eForms Designer, you use the Field and Table tools to create the blanks 
where information is typed. These blanks are called cells.

When a template is used, the user fills out the form by entering information such as a name, number, date, 
or time into each cell. As the form author, you have a great deal of control over the type of information each 
cell will hold and how that information will be displayed.

Each cell has its own individual attributes including a cell name, a cell type, and various formatting options. 
You configure these attributes using eForms Designer’s Cell and Format commands.

Naming Cells

eForms Designer automatically names cells according to the sequence in which the cells are drawn. For 
example, the first cell you draw is named “Cell1.” The next cell you draw is named “Cell2” and so on.

You can give a cell a descriptive name to make it easier to find when adding intelligence to the form. For 
example, a cell named “Total” is much easier to recognize than a cell named “Cell25.”

Field Table

Cells
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NOTE  Naming a cell is not the same as changing the display name (text in the title area of the field). The 
field title is intended to be a visual clue to show the user what to enter in a particular field. The cell name is 
used to identify the cell in calculation formulas.

In this lesson, you’ll learn how to name a cell using the Cell command and the Cell palette.

Task 23a: Name a Cell with the Cell Command

1. Select ‘Cell 1’ by clicking it once with the Pointer tool.

2. Choose Settings > Cell to display the Cell Settings dialog box.

3. Type “PO_Number” in the ‘Cell Name’ field.

4. Select the ‘Publish cell’ checkbox, then click OK. The cell section of the ‘Purchase Order Number’ field 
now shows the new cell name.

NOTE  Cell names cannot contain spaces. Use the underscore character if you need to separate 
characters.

Task 23b: Name Cells with the Cell Palette

If you have to rename a number of cells, the Cell palette provides a quick alternative to using the Cell 
command.

1. Choose Window > Toolbars > Cell.

The Cell palette appears, showing the name of the currently selected cell.

The Cell palette is initially displayed as a toolbar at the top of the drawing window. To display it as a 
palette, click the move handle at the far left hand side of the toolbar; then drag it onto the drawing area.

 New cell name
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2. Select the ‘Cell 2’ field by clicking it with the Pointer tool.

3. Press F2 to activate the Cell palette’s ‘Name’ area. 

4. Type “Supplier” in the ‘Name’ field; then press F2.

Pressing F2 performs three actions:

• Updates the cell name on the template.

• Selects the next cell in the tab order* (Cell3).

• Automatically activates the ‘Name’ field again.

*The tab order is the order that the user tabs from one cell to the next when a form is filled out. 
SeeTask 26a on page 66 for more information.

5. Type “Bill_To” in the ‘Cell Name’ field; then press F2 to select Cell4.

6. Repeat this procedure to rename the cells as shown in the following table. Do not press F2 after 
changing the name of Cell9. You must use the Cell command or Text tool to change the display name.

Because of the current tab order of your form, pressing F2 after renaming Cell9 would take you to the 
Purchase Details table. The F2 feature is not available for table cells, so you’ll skip the table cells for 
the moment and rename all other cells first.

7. Select the ‘Yes’ checkbox field with the Pointer tool; then press F2 to activate the ‘Name’ field on the 
Cell palette.

8. Type “Yes.” Then press F2 to select Cell15.

Original Name New Cell Name Actual Display Name

Cell4 Ship_To Ship To

Cell5 Ship_Via Ship Via

Cell6 Instructions Instructions

Cell7 Signature Signature

Cell8 Date Date

Cell9 Total Total

Cell Name

  
   

Date
Cell

Checkbox
   Style

Entry is

 Cell
Settings

Required

 

Cell
Value

Cell
Check

     Tabbing

 

  Conditional
   Help
Message

Number 
Cell

Lookup
Data

Cell
Format

Publish
Cell

Display
Only

Text
Cell

Locate 
Cell
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9. Rename the cells as shown in the following table. Do not press F2 after changing the name of Cell16. 
Cells 17 and 18 are on the “History” page, or page 2.

NOTES  

• F_StepDescription is a special system data field that’s available for mapping to published form 
cells in a workflow policy.  It displays the description or instructions for the current step within a 
workflow process. Later in this tutorial, you will see how this field works in FileNet eForms for 
Workplace.

• If you prefer to have special form cells appear in a router region above or below the form instead of 
on the form itself, you can configure a special feature called “Regional Layout” in Task 39b on 
page 89.

Use the Pointer tool and the Cell command to rename the table cells on your template.

1. Click the table once to select the entire object.

2. Click again in the ‘Qty’ column to select its cell section (Cell10).

Choose Settings > Cell or click Cell Settings on the Cell palette to display the Cell Settings dialog 
box.

3. Type “Qty” in the ‘Cell Name’ field; then click OK.

4. Repeat this procedure to rename the remaining table cells and display names as shown in the 
following table:

Setting Cell Attributes

In this lesson, you’ll learn how to set a cell’s attributes such as type, format, text attributes, and data entry 
status. A cell’s type can be changed so that it matches the kind of information that the cell is intended to 
hold. For example, if a cell is intended to hold a number value, then its type should be Number. Setting a 
cell’s type ensures that only entries of the correct type are allowed.

Original Name New Cell Name Actual Display Name

Cell15 No No

Cell16 Phone Phone

Cell17 F_StepDescription (no display name required)

Cell18 Delivery_Schedule Requested Delivery Period

Original Name New Cell Name Actual Display Name

Cell11 Description Description

Cell12 Unit_Cost Unit Cost

Cell13 Extended Extended
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In addition to setting a cell’s type, you can also control the way that the information in the cell is displayed 
by specifying a particular format. For example, you can set the format of a Number cell so that entries are 
always displayed with a currency symbol and two decimal places.

Task 24a: Set the Cell Type and Format for a Single Cell

For this task, you’ll use the Format command to set the cell type and format for the ‘Date’ cell.

1. Click the ‘Date’ cell with the Pointer tool.

2. Choose Settings > Format or click Format  on the Cell palette.

3. Select “Date” from the ‘Type’ drop-down list; then double-click the “Mon D, YYYY” format in the 
‘Common Date Formats’ list.

Test the date format by typing “9/5/02” in the ‘Test Value’ field. The ‘Formatted Value’ shows how the 
date will look when displayed on your form.

4. Click OK to return to the drawing window.

Task 24b: Set the Cell Type, Data Option and Format for Multiple Cells

When several cells have the same type, data option, and format, you can format them all together. To do 
this, hold the Shift key and select the desired cells with the Pointer tool; then choose the Format 
command. The changes you make on the Format dialog box will affect all the selected cells.

TIP  To select multiple cells of the same type and format, click one cell. Then choose Edit > Select Same. 

Set the type and format (Settings > Format) and publish cell option (Settings > Cell) for each cell as 
shown in the table below. Where possible, select and format multiple cells.
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NOTE  Whenever you create a new field, the cell type is automatically set to “Text” with no formatting. Any 
cells not listed in the above table use this default type and format. You do not need to change their 
settings.

* The Signature cell can be configured for digital signing choosing the I-Sign or Microsoft® CSP signature 
service.

Task 24c: Set the Type Attributes

In addition to the formatting options available in the Format dialog box, you can also use a cell’s type 
settings to control the way data is displayed. Like field title sections, cells have font, font size, type style, 
and alignment attributes that can be set individually.

NOTE  When changing the type settings for a cell, make sure that you select only the cell section and not 
the entire field, otherwise, your changes will also affect the field title section.

1. Select the ‘PO_Number’ cell by clicking it twice with the Pointer tool. A shimmering border in the cell 
section indicates that it’s selected.

2. Choose Style > Font to set the cell’s type attributes to “Times New Roman,” “18” point, “Bold.” Then 
choose Style > Alignment and select “Center” (vertical and horizontal).

Using the same technique, set the type attributes for each cell shown in the following table.

Cell Name Cell Type Format/Display Options Publish Cell?

PO_Number Number General Yes

Instructions Text accept defaults Yes

Qty Number General No

Signature* Signature Sign all cells except Date and 
Total

No

Phone Boolean On/Off No

Yes Boolean On/Off No

No Boolean On/Off No

Unit_Cost Number #,##0.00 No

Extended Number #,##0.00 No

Total Number #,##0.00; select the ‘Show 
Currency’ option.

Yes

F_StepDescription Text accept defaults Yes

Delivery_Schedule Text accept defaults No
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Task 24d: Set the Data Entry Status

On a paper form, problems sometimes occur when the person filling out the form forgets to fill in crucial 
parts of the form. eForms Designer provides data entry controls to avoid these problems on your electronic 
template.

You can specify a cell’s entry status to be optional, recommended, or required. For this task, you’ll set the 
data entry status for the ‘Ship_Via’ cell.

1. Click the ‘Ship_Via’ cell by clicking it twice with the Pointer tool.

2. Choose Settings > Cell to display the Cell Settings dialog box.

3. Select “Required” from the ‘Data is’ drop-down list.

4. Click OK.

NOTE  When designing forms for your organization, exercise caution before using the “Required” entry 
setting for any cells on your template. Depending on how error handling has been configured for invalid 
data, this setting may prohibit further processing of the form until the “Required” cells are filled out. To 
review information on Error Handling, see your eForms Designer Help.

Cell Name Font Font Size Alignment

Supplier Times New Roman 12 point Left (horizontal), Top (vertical)

Bill_To Times New Roman 12 point Left (horizontal), Top (vertical)

Ship_To Times New Roman 12 point Left (horizontal), Top (vertical)

Ship_Via Times New Roman 12 point Left (horizontal), Top (vertical)

Instructions Times New Roman 12 point Left (horizontal), Top (vertical)

Qty Times New Roman 12 point Center (horizontal and vertical)

Description Times New Roman 12 point Left (horizontal), Center (vertical)

Unit_Cost Times New Roman 12 point Right (horizontal), Center (vertical)

Extended Times New Roman 12 point Right (horizontal), Center (vertical)

Signature Times New Roman 12 point Left (horizontal), Top (vertical)

Date Times New Roman 12 point Left (horizontal), Top (vertical)

Total Times New Roman 12 point Right (horizontal), Center (vertical)

F_StepDescription Times New Roman 12 point Left (horizontal), Top (vertical)

Delivery_Schedule Times New Roman 12 point Left (horizontal), Top (vertical)
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Task 25: Create a Help Message

Help messages can be very beneficial for users who are using a form for the first time. For example, users 
might not be familiar with certain terminology on the form and might require some clarification.

In Task 24d, you set the data entry status of the ‘Ship_Via’ cell to “Required.” Leaving that cell blank will 
cause a warning message to display. It’s possible that a new user might not understand what type of value 
they should enter in the ‘Ship_Via’ cell, so for this task, you’ll create a help message for that cell.

1. If it’s not already selected, select the ‘Ship_Via’ cell with the Pointer tool.

2. Choose Settings > Help Message or click the Help Message button  on the Cell palette to 
display the Help Message dialog box.

3. Type the following help message in the field in the Help Message dialog box (without quotation marks):

“This field contains a choice list. Click the Arrow indicator in the field title section and select an entry 
from the available choices.”

4. Click OK to return to the drawing window.

This is the end of the Cells section. The next section explains Tab Order features.
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Tab Order

This section explains how to set the tab order for each cell on your template. You’ll also learn about the 
Tab tool—a convenient feature that allows you to change the tab order of the cells on your template by 
clicking and dragging the pointer from one cell to another. At the end of this section, you’ll know how to 
perform the following tasks:

1. Set the tab order and options:

• Change the tab order of cells using the Cell command (Task 26a on page 66).

• Change the tab order of cells using the Tab tool (Task 26b on page 66).

2. Create conditional tab formulas:

• Write a conditional tab formula for the ‘Yes’ checkbox (Task 27a on page 67).

• Write a conditional tab formula for the ‘No’ checkbox (Task 27b on page 68).

3. Cluster a group of checkboxes (Task 28 on page 68).

Overview

Each time you create a new cell, eForms Designer assigns the next available tab position to that cell. The 
tab position of all the cells together determines the form’s tab order; that is, the order that the user tabs 
from one cell to the next when a form is filled out. The cell with tab position 1 is entered first, then the cell 
with tab position 2, and so on.

Setting Tab Order and Options

In this lesson, you’ll change your form’s tab order with the Cell command and the Tab tool. Changing the 
tab position of one cell automatically changes the tab position of other cells as well. It’s like removing the 
cell from the tab order list, then inserting it in a new position. You’ll also set tab options for your table.

                              
                             
                              

 The circled numbers
indicate the tab order
for the form.
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Task 26a: Change the Tab Order Using the Cell Command

Because of the order the fields were drawn in, the tab order on your template doesn’t follow a logical 
sequence. For this task, you’ll change the tab order of your template.

1. Select the ‘Yes’ checkbox; then choose Settings > Cell to display the Cell Settings dialog box.

2. Press Tab to move to the ‘Tab position’ field.

3. Type 5 in the field; then click OK.

The cell section of the ‘Yes’ field updates to show the new tab position.

4. Repeat the above steps to put the ‘No’ checkbox in tab position 6, and the ‘Phone’ checkbox in tab 
position 7.

Task 26b: Change the Tab Order Using the Tab Tool

You can also use the Tab tool to change the tab order of the cells on your template.

1. Select the Tab tool  by clicking it on the Drawing palette.

2. Position the hand pointer over the cell section of the ‘Instructions’ field.

3. Click the mouse button and drag the pointer to the ‘Qty’ table column.

4. Release the mouse button when a highlighted border appears inside the table.

TIP  Because all columns in the table share the same tab position, you don’t have to drag the hand 
pointer to the first column in the table. Dragging the pointer to any column in the table changes the tab 
position for the entire table.

The tab positions of the remaining fields update automatically, and the tab order of your template now 
follows a logical sequence—top to bottom, left to right.
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Creating Conditional Tab Formulas

The conditional tab formula feature allows the user to tab past sections of the form that are not relevant to 
the information being entered. For example, you could specify conditional tab formulas for ‘Local’ and ‘Out 
of Town’ checkboxes on a travel expense form. If the user selects the ‘Local’ checkbox and then tabs from 
that cell, they would tab past sections for claiming expenses such as ‘Hotel Accommodation’ and ‘Airline 
Travel,’ and go directly to sections for claiming expenses such as ‘Parking’ and ‘Fuel.’

In this next lesson, you’ll write conditional tab formulas for the checkbox cells.

Task 27a: Write a Conditional Tab Formula for the ‘Yes’ Checkbox

1. Select the Pointer tool from the Drawing palette; then select the ‘Yes’ checkbox.

2. Choose Settings > Conditional Tabbing or click Conditional Tab  on the Cell palette to display 
the Conditional Tabbing dialog box.

3. Type the following conditional tab formula in the ‘Conditional Tabbing’ field.

If Yes then CellRef(Ship_Via) Else CellRef(No) End

4. Click Chk  on the Conditional Tabbing dialog box. eForms Designer checks your formula for 

errors and formats it properly.

5. Click OK.

The formula above tells the application to skip the ‘No’ and ‘Phone’ cells and go directly to the ‘Ship_Via’ 
cell if ‘Yes’ is checked. If ‘Yes’ is not checked, go to ‘No.’

NOTE  In a conditional tabbing formula, the name of the cell to move to must be entered within the 
brackets of the CellRef ( ) function. For more information on the CellRef function, see your eForms 
Designer Help.
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Task 27b: Write a Conditional Tab Formula for the ‘No’ Checkbox

1. Select the ‘No’ checkbox.

2. Choose Settings > Conditional Tabbing.

3. Type the following conditional tab formula in the ‘Conditional Tabbing’ field.

If No then CellRef(Ship_Via) Else CellRef(Phone) End

4. Click Chk to make sure the formula is valid; then click OK.

This formula tells the application to go directly to the ‘Ship_Via’ cell if ‘No’ is checked.

Task 28: Cluster the Checkboxes

Clustering a group of checkboxes ensures that only one box can be checked. You might want to use this 
feature for situations such as choosing a payment method. For example, a form might show Visa, 
Mastercard, and Cash checkboxes. If these cells are clustered, turning one checkbox on automatically 
turns the other two off.

For this task, you’ll cluster the ‘Yes,’ ‘No,’ and ‘Phone’ checkboxes to ensure that only one can be selected 
at a time.

1. Select the three checkbox fields by holding the Shift key and clicking each one.

2. Choose Arrange > Cluster.

NOTE  In FileNet eForms for Workplace, clustered checkboxes always appear as radio buttons.

This is the end of the Tab Order section. The next section explains Choice List creation.
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Choice Lists and Scripts

This section explains how to create a choice list and assign that list to a specific cell, and how to add a 
script to a form template. At the end of this section, you’ll know how to perform the following tasks:

1. Create choice lists:

• Create a simple choice list (Task 29a on page 69).

• Create a dynamic choice list (Task 29b on page 71).

2. Use a script with a form:

• Add a script to a form template (Task 30a on page 71).

• Edit or remove a script (Task 30b on page 72).

Overview

Often a cell will take on a variety of common values. For example, the shipping method on an order form 
might be Mail, UPS, or Federal Express. Instead of typing the shipping method each time, the user can 
select an entry from a list of common choices.

Creating and Using Choice Lists

With eForms Designer, creating and using a choice list is a two-step process. First, you name the choice 
list and specify each of the choices. Second, you specify which cells the choice list is to be used with. By 
creating a choice list as a separate step, a single choice list can be used among several different cells. 
That way, when you need to change the items in a choice list, you can do so once and have the change 
take effect for multiple cells.

Task 29a: Create a Simple Choice List

For this task, you’ll create a new choice list to be used with the Ship_Via cell.

1. Choose Settings > Cell or right-click the Ship_Via cell, choose Cell, and click the Choice Lists button 
to display the Choice Lists dialog box.
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2. Click the New button on the Choice Lists dialog box to display the Edit Choices dialog box.

3. Type “Shipping Method” in the ‘List name’ field; then press Tab twice to move to the ‘Choice value’ 
field at the bottom of the dialog box.

4. Type the following entries, clicking the Add button after each entry: “Airmail,” “FedEx,” “UPS.”

5. Click OK to return to the Choice Lists dialog box; then click Done.

NOTE  If required, you can set your choice lists in alphanumeric order. Use Shift + Alt + Add when 
adding a new list item or select an existing item and use Shift + Alt + Change.

Notice that when you return to the Choice Lists dialog box, the name of your new choice list is 
displayed in the list.
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Now the user will be able to enter a value in the ‘Ship_Via’ cell by making a selection from the choices 
available.

Task 29b: Create a Dynamic Choice List

By using formulas, you can create dynamic choice lists that change based on other information that’s 
entered in the form. For this task, you’ll configure the Delivery_Schedule cell to display a specific choice list 
based on what’s entered in the Ship_Via cell.

1. Right-click the Instructions cell and choose Cell.

2. Click Choice Lists.

3. Click New on the Choice Lists dialog box to display the Edit Choices dialog box.

4. Type “Schedules” in the ‘List name’ field; then press Tab twice to move to the ‘Choice value’ field at the 
bottom of the dialog box.

5. Type the following formula into the ‘Choice value’ field and then click Add. To properly enter the 
formula, you should type in each line exactly as it appears below. Also, you should enter each line 
separately; type in the first line, click the Add button, then the second line, and so on until you have 
entered the entire formula:

<<If Ship_Via = "Airmail" Then

Tokenize("Overnight_24 hrs_Express overseas","_")

ElseIf Ship_Via = "FedEx" Then

Tokenize("Expedited ship_4 day delivery_7 day delivery","_")

ElseIf Ship_Via = "UPS" Then

Tokenize("24 hrs_2 day ship","_")

End>>

If you get a message that the calculation is invalid, check your formula for spelling errors and typos.

6. Click OK to return to the Choice Lists dialog box, click Done, and click OK.

Using Scripts with Form Templates

With JavaScript™, you can create scripts to customize solutions for your forms and improve interactions 
between the forms and their users. With a script, you can manipulate cells on the form, execute built-in 
commands (e.g., Launch, Complete), navigate forms, populate cell values from a company directory 
presented in a pop-up window, and reload pages. 

You won’t add a script to your form in this tutorial, but you will add and delete some placeholder text in 
order to see how the process works.

Task 30a: Add a Script to a Form

1. Choose Form > Template Settings > Scripts to open the Edit HTML eForms JavaScript dialog box.

2. Type a placeholder in the text window, like the following example: 
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<script> </script>

The text window is where you enter the full content of your script. You can type in a script, copy and 
paste the script text into the text window, or click the Import button to select a JavaScript file located 
on your workstation.

3. Click OK.

You can have only one script embedded in a form template. Once you have added a script to a form, you 
can edit it or remove it.

Task 30b: Edit or Remove a Script

1. Choose Form > Template Settings > Scripts to open the Edit HTML eForms JavaScript dialog box. 
The placeholder text that you entered in Task 30a will still be present in the text box. 

2. Select the placeholder text and press the Delete key.

3. Click OK.

This is the end of the Choice Lists and Scripts section. The next section explains how to develop simple 
Calculations.
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Calculations

This section explains how to create simple calculations for cells on your template, and how to add 
functioning buttons to a form. At the end of this section, you’ll know how to perform the following tasks:

1. Create simple calculations (Task 31 on page 73).

2. Create default values:

• Assign a default value to the ‘Bill_To’ cell (Task 32a on page 75).

• Assign a default value to the display-only ‘Date’ cell (Task 32b on page 75).

3. Create a check formula (Task 33 on page 75).

Overview

Often a cell gets its value by manipulating other information on a form. For example, the discount amount 
on a sales slip is calculated as the discount rate times the total purchase amount. You can use a 
calculation so that the value is filled in automatically for the user. 

eForms Designer provides a comprehensive set of operators and functions that make it easy to create 
sophisticated calculations. You can even use if-then-else logic to calculate different results under certain 
conditions. For detailed information on formulas and functions, see your eForms Designer Help.

Creating Calculations

In this lesson, you’ll create calculations for the ‘Extended’ and ‘Total’ cells

Task 31: Create Calculations for Two Cells

1. Select the ‘Extended’ table cell.

2. Choose Settings > Value or click Value  on the Cell palette. The Value dialog box appears.

3. Select “Calculation” from the ‘Type’ drop-down list.

Calculate the discount amount as
Sub Total * Discount Rate
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The dialog box changes to show a large field and three lists containing cell names, functions, and 
operators.

4. Type the following calculation formula (or select from the list of Cells and Operators) in the large field 
exactly as shown below:

Qty * Unit_Cost

5. Click Chk to check your formula; then click OK.

The formula above multiplies the number of items (‘Qty’) by the price (‘Unit_Cost’) and places the 
result in the corresponding row of the ‘Extended’ table cell.

6. Using the same method, enter the following formula for the ‘Total’ cell.

Sum (Extended)

The formula above gives the sum of all values in the ‘Extended’ table column cell.

Creating Default Values

A default value is a value that automatically fills in each time the user fills out a new form. However, unlike 
calculations, a default value doesn’t change unless the user types a different value. Use a default value 
whenever a cell often has the same value. For example, the default value for the date cell on an invoice 
could be today’s date.

There are three different types of default values:

• Creation date

• Creation time

• Constant value

‘Creation date’ and ‘Creation time’ default value types are used for automatic entry of the current date or 
time when the user fills out a new form. The ‘Constant value’ default type requires that you specify the 
default value itself.

In this lesson, you’ll assign a default value to the ‘Bill_To’ and ‘Date’ cells so that the billing address and 
current date are entered automatically when the user fills out a new record.
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Task 32a: Assign a Default Value to the ‘Bill_To’ Cell

1. Select the ‘Bill_To’ cell.

2. Choose Settings > Value or click Value  on the Cell palette.

3. Select “Constant Value” from the ‘Type’ drop-down list in the Value dialog box.

4. Enter the following address in the large field that appears:

World Corporation

Accounts Payable

115 N. Michigan Ave.

Chicago, IL 12345

5. Select the ‘Display only’ checkbox option; then click OK.

Task 32b: Assign a Default Value to the ‘Date’ Cell.

1. Select the ‘Date’ cell and choose Settings > Value.

2. Select “Creation date” from the ‘Type’ drop-down list in the Value dialog box.

3. Select the ‘Display only’ checkbox; then click OK.

Task 33: Create a Check Formula

A check formula tests for error or warning conditions. For this task, you’ll create a check formula to ensure 
that purchases worth over one thousand dollars are shipped via UPS.

1. Select the ‘Signature’ cell.

2. Choose Settings > Check or click Check  on the Cell palette to display the Check dialog box.

3. Type the following formula in the large field in the Check dialog box.

If Total >= 1000 And Ship_Via <> "UPS" then Return True with Alert "Orders worth $1000.00 or 
more must be shipped by UPS." End

4. Click Chk to make sure the formula is valid; then click OK.
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When the user enters a value and tabs out of the ‘Signature’ cell, the check formula will be triggered. If 
the amount in the ‘Total’ cell is one thousand dollars or more, a warning message displays.

NOTE  In the previous check formula, you specified that the formula would return “True.” This displays the 
alert message and allows the form user to finish processing the form. If you configure a check formula to 
return “False” instead, the form user might not be able to print, save, or submit the form until the value in 
question is corrected. The actions the user can take depend on how the form’s error handling is set up. 
See your eForms Designer Help for more information about error checking and error handling.

Using Buttons

You can place buttons on your form to make it easier to use. A button can be configured with one of the 
following functions:

• Built-in Command - assigns a command from a pre-configured list of options

• Hyperlink - opens a URL in a web browser window

• Go to Cell - moves the form’s entry point to a pre-specified cell

• Go to Cell via Calculation - moves the entry point to a cell based on the results of a calculation

Use the Button tool on the Drawing palette to draw a button on a form; then select Settings > Button to 
open the Button Settings dialog box. Select the function you want to assign to the button from the drop-
down list, and click OK.

For more information on using buttons, consult your eForms Designer Help.

This is the end of the Calculations section. The next section explains how to generate auto-incrementing 
numbers for your form.
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Auto-incrementing Numbers

This section explains how to configure a cell to hold an auto-incrementing number. At the end of this 
section, you’ll know how to perform the following tasks:

1. Setup JDBC connectivity for an auto-incrementing number and 

2. Configure a cell to hold an auto-incrementing number (Task 34 on page 77).

Overview

Forms such as invoices, expense claims, and purchase orders are often numbered uniquely for 
identification purposes. In organizations that use paper forms, these unique form numbers usually have to 
be pre-printed on the paper documents. With electronic forms, unique form numbers can be assigned 
automatically, each time a new form is filled out. A form number that’s generated automatically is called an 
auto-increment.

The next available number can be generated via JDBC connectivity.

Task 34: Configure an Auto-increment

For this task, you’ll configure an auto-increment for the ‘PO_Number’ cell on your template. You’ll need to 
create a  single table database in SQL (preferably) or Microsoft Access called “tblOrders” with a field called 
“PONumber.” Save the database with the name “Tutorial.” The first auto-increment value should begin at 
1000.

1. If you created the database with MS Access, then copy the Tutorial.mdb file to a system that is running 
Microsoft SQL Server 2000. This file must be converted to SQL. Please see the eForms Designer 
Sample > Templates folder for conversion instructions. Contact your system administrator if you need 
help with this task. Also, you must record the host name or IP address of the web server at this step.

2. Select the ‘PO_Number’ cell with the Pointer tool.

3. Choose Settings > Value; then select “Auto-increment” from the ‘Type’ drop-down list to display the 
Auto-increment panel of the Value dialog box.
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4. Select “JDBC” from the ‘Assign next value from’ drop-down list. You can also select ODBC or HTTP 
when designing your form, but use JDBC for this tutorial.

5. Click Configure.

6. Click Define Connection. The Define Connection dialog box appears.

7. In the ‘Connection string’ field, enter the following connection string: 

jdbc:microsoft:sqlserver://servername;DatabaseName=Tutorial

Change “servername” to the correct host name or IP address of the web server that contains the 
Tutorial database.

8. Enter the following SQL statement in the auto-increment text box:

Select PONumber from tblOrders;

Update tblOrders Set PONumber = "PONumber" + 1;

Select PONumber from tblOrders;

<<1@PO_Number>>

9. Click OK until all dialog boxes have closed.

You have now successfully completed some basic design and intelligence automation features for your 
first ITX form template. The next section explains how to deploy the template to an object store in P8 
Workplace. 

NOTE If you want to compare the design and intelligence features you’ve just created with a completed 
copy of this purchase order template, go to your FileNet eForms Designer CD, browse to the 
Documentation > Tutorial folder and open “PurchaseOrder.itx” in eForms Designer. The Open Document 
dialog box appears and prompts you for a password. Enter “mytutorial”.
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Deploying an ITX Form Template to an Object Store

This section explains how to deploy an ITX form template to a Workplace object store and then create two 
simple form template policies.

NOTE  You must have the appropriate Designer permissions for Workplace. If required, contact your 
system administrator for these access rights.

At the end of this section, you’ll know how to perform the following tasks:

1. Create folders in a Workplace Object Store that will contain your form templates, form data entry tem-
plates, form data, and workflow and document policies (Task 35 on page 79).

2. Deploy an ITX form template directly from eForms Designer to Workplace (Task 36 on page 80).

3. Create a simple workflow definition.

• Draw a workflow definition using Process Designer (Task 37a on page 81).

• Define conditional routing responses (Task 37b on page 83).

• Assign step participants and choose an appropriate step processor (Task 37c on page 84).

• Set General and Data Field Workflow Properties (Task 37d on page 84).

• Add Step Description Instructions (Task 37e on page 85).

• Validate the workflow and save it to Workplace (Task 37f on page 85).

• Transfer the workflow definition (Task 37g on page 86).

4. Create a form data entry template (Task 38 on page 86).

5. Create a workflow policy.

• Create a workflow policy (Task 39a on page 87).

• Set toolbar and router settings (Task 39b on page 89).

6. Create a document policy (Task 40 on page 90).

Overview

After you create templates in eForms Designer, you can deploy them to Workplace. When an ITX is 
deployed and attached to a form template policy, the user can open forms online in a browser window and 
save them to an object store.

Task 35: Setup Folders in an Object Store

The form policy author or form author can set up folders in Workplace to store form templates and form 
template policies.

1. Login to Workplace.

2. In Browse > Object Stores, click an Object Store that you can add folders to.

3. Click Add Folder.
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4. (Optional) Choose a Folder Class.

5. Click Next or Set Properties.

6. In the Folder Name field, enter “eForms Tutorial.”

7. Click Next or Set Security.

8. Click Finish and then click OK.

9. Browse to the eForms Tutorial folder and create the following 6 sub-folders: Form Templates, Form 
Data Entry Templates, Form Data, Workflow Definitions, Workflow Policies, and Document Policies.

Task 36: Deploy an ITX Form Template to P8 Workplace

Completed form templates can be deployed directly from eForms Designer to Workplace. 

1. In eForms Designer, choose File > FileNet P8 > Add. You may be prompted to login to the Workplace 
at this step.

2. In the Add dialog box, browse to the Object Store that contains the eForms Tutorial > Form Templates 
folder and then click Save.

3. Click Next on the FileNet P8 Add dialog box.

4. Click Next or Set Properties.

5. In the Document Title field, enter “Purchase Order.”

6. In the From Description field, enter “eForms Tutorial Form Template” and then click Next.

7. (Optional) Select the major version option. You can also leave this option and promote the form 
template version from minor to major at a later time.

8. Click Finish and then click OK to complete the form deployment.

In Workplace, if you have not promoted the form to a major version it will appear in display-only mode as 
shown next. The cells containing constant and creation date values will always display data:
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Task 37a: Draw a Workflow Definition

Before you create a workflow policy, you must design a workflow definition that includes the form as part of 
or as the whole presentation for the entire business process. if you are creating only document policies, 
skip these instructions and move on to Task 36.

1. Click Author > Advanced Tools.

2. Click Process Designer. An applet window opens and starts the Process Designer tool.
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NOTE You must have the appropriate access rights to use Process Designer. Please see your system 
administrator if you cannot view the Process Designer link.

3. Click and drag the General Step to the window containing the “LaunchStep.” Repeat this step 2 more 
times and you will then have a total of 3 new steps.

4. Click the first general step as shown below. In the “Name” field of the Properties pane, rename the 
step “Supervisor Approval.” As you click each step, the icon changes to indicate that it has been 
selected.

5. Rename the second general step (left side) to “PO Incomplete” and the last step to “Processing.”

6. Use a click and drag motion to draw routes between the steps as shown in the following image.
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7. To rename the routes, click the route and enter a name in the “Name” field of the Properties pane. You 
can use the name shown in the previous image or create your own.

Task 37b: Define Responses

You can define responses for a workflow where a decision must be made at a particular step that has two 
or more routes emerging from it.

1. Click the Supervisor Approval step and click the Routing tab in the Properties pane.

2. In the Responses section, double-click the empty field in the Name column, type “approved”, and then 
press Enter. Add another response called “rejected.”

3. Click the “reject request” route. In the properties panender “Conditional Routing,” choose “Condition.”

4. From the “response” field, choose “rejected” and then click Insert.
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5. Click the “send to finance” route. Under “Conditional Routing” in the properties pane, choose 
“Condition.”

6. From the “response” field, choose “accepted” and then click Insert.

Task 37c: Assign Step Participants and choose Step Processor

For each step, you can assign one or more intended recipients or an entire work queue. You must also 
determine the appropriate step processor to use for each step, including the LaunchStep.

1. Click the Supervisor Approval step and click the General tab.

2. In the Step Destination section, beside the Participants option click the Modify button (displays as 
pencil icon) and add “F_Originator” to the Selected Participants list.

3. In the Step Processor section, choose “Form HTML (FileNet)” from the drop-down list.

4. Repeat steps 1-3 for all other steps except the Launch Step.

5. Click “LaunchStep” and in the Step Processor section, choose “Form Launch HTML (FileNet).”

Task 37d: Set Workflow Properties

In the General tab of the Workflow Properties, you must enter a name for the workflow.

1. From the toolbar, click Workflow Properties or choose View > Workflow Properties. In the ‘Work-
flow Name’ field of the General tab, enter “Tutorial Purchase Order.”

 

2. In the ‘Subject’ field enter “Purchase Order Process.”

3. Click the Data Fields tab and enter the following data field Name, Type, and Expression as shown 
next. 

4. Click “PO_Number” and then select the Field Usage tool from the toolbar above the Description 
column. The Field Usage dialog box appears.

FileNet Add New Workflow Properties Validate Workflow
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5. Click “LaunchStep” from the list of Available Steps and then click  to add it to the list of Selected 
Steps. Repeat for “Total” and “Special_Instructions” (except add the Supervisor Approval Step instead 
of the LaunchStep for this data field). Click Close until all dialog boxes have closed.

Task 37e: Add Instructions

You can add instructions that can be mapped to the “F_StepDescription” field on your form.

NOTE If you prefer to have special fields like "Responses" and "Instructions" appear in a router region 
above or below the form instead of on the form itself, you can configure a special feature called “Regional 
Layout” in Task 39b on page 89.

1. Click LaunchStep.

2. In the Instruction field of the General tab, enter the following:

This Purchase Order form is used to request items such as office supplies and computer equipment. 
Please fill out the form and submit it to your supervisor or manager.

Task 37f: Validate Workflow and Check in to Workplace

1. Click Validate Workflow to ensure that your workflow definition does not contain errors.
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2. Click the FileNet Add New button on the toolbar to save your workflow definition to the Workplace. If 
necessary, browse to your Workflow Definitions folder; save the workflow with the name “PO Process.”

Task 37g: Transfer the Workflow

Before the user can launch a workflow definition from a workflow policy, the workflow definition must be 
transferred to the Process Engine. You can transfer the definition from the Process Designer or from the 
Information page for the workflow definition in Workplace.

1.  Browse to the Object Store folder containing your workflow definition.

2. Click the Information button  beside the title. Click Transfer Workflow as shown on the image 
below.

NOTE If you right-click the title of the workflow and select Transfer Workflow from the context menu, 
the next steps described in this guide are slightly different.

3. Click Apply and then Exit. 

Task 38: Create a Form Data Entry Template

Before you create a document policy or a workflow policy that requires a saved copy of form data, you can 
set up a form data entry template that specifies properties such as the form data document name, the 
folder that will store the form data, and security settings. When the user completes work on the form, these 
steps take place automatically when the document is saved or checked into Workplace.

1. Click Author > Advanced Tools.

2. Click Add Entry Template.
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3. Under Form Data Entry Template, click Select.

4. Browse to the Form Data folder in the Object Store.

5. Click Next or Select Class.

6. Click Next or Set Properties.

7. In the Document Title field, enter “Purchase Orders 2005.”

8. Click Next or Set Security.

9. Accept the defaults and click Next.

10. (Optional). If you wish to assign a workflow to this policy, you can choose from a list of existing 
workflow definitions; however, it is not required for this task.

11.  Click Select Folder.

12. Browse to the Form Data Entry Template folder in the Object Store.

13. Click Next or Set Properties.

14. In the Document Title field, enter “Purchase Order Entry Template.”

15. Click Next or Set Security.

16. Click Finish and OK to save your new Form Data Entry Template.

Task 39a: Create a Workflow Policy

The final step in setting up a form template for use in P8 Workplace is to associate it with a form template 
policy. You will create a simple workflow policy using the Workflow Manager wizard. if you are creating 
only document policies, skip these instructions and move on to Task 40.

1. Click Author > Advanced Tools.
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2. Click Add Form Template Policy.

3. Under Workflow Policy, click Select.

4. Click Browse/Search for Workflow Definition and browse to the Object Store folder that contains the 
PO Process workflow. From the Versions link, select the most recent version.

NOTE You can have only one workflow definition mapped to a given form template policy.

5. Click Next (the link located in the lower right corner of the Add Workflow Policy dialog box) or Define 
Step Map (the link located in the left side navigation menu called “Steps”).

6. Under Workflow Steps, click the checkboxes beside all the steps and then click Define Step Maps 
from the multi-select actions list. 

The Step Manager Wizard opens in a new window.

7. Click Browse/Search for Form Template, browse to the Object Store folder that contains the 
Purchase Order form template and select the most recent version.

8. Click Next and then click Finish.

9. Click Next or Select Folder.

10. Browse to your Workflow Policies folder and then click Next or Set Properties.

11. Under Options, choose “Yes” from the Add as a major version drop-down list.

12. In the Document Title field, enter “PO Workflow Policy.”

13. Click Next or Set Security.

14. Accept the defaults and click Finish.
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Task 39b: Change the Toolbar and Router Settings

You can also configure various customizable features that control the display of the form in the step 
processor window. For the launch step and post launch steps, you can show or hide optional toolbar 
commands, change the alias name, and provide a user-friendly tool tip to describe the command. For all 
steps, you can display a router region that contains workflow step information such as instructions, 
deadline, responses, subject, and comments.

Because you’ve just saved and completed the workflow policy, you’ll have to re-open it to make the 
changes.

1. Browse to the object store folder where you saved the workflow policy in step 9 of the previous task.

2. Right-click the policy and choose Modify Workflow Policy from the pop-up list. The Workflow 
Manager Wizard window displays.

3. Click Define Step Map.

4. Click the first checkbox beside Workflow Steps to select all steps. 

5. Click Display Settings.

6. Under the Show column beside the Toolbar Commands list, ensure that the checkboxes beside 
“Attachments” and “Workflow Groups” are selected.

7. In the Alias column beside the Save toolbar command, type “Save this order.”

8. In the tool tip column beside the Save toolbar command, type “A copy of your order will be saved to 
your forms folder.” The Save button will appear at the post-launch steps.

9. Click Settings beside Regional Layout.

10. Click Configure Default Regions.

11. Click the “Show Router Region” checkbox.

12. Click the “Show Subject” and “Show Responses” checkboxes. You can also click the “Show 
Instructions” checkbox if you did not create the F_StepDescription field at Task 37e on page 85.

NOTE If you have designed a form template with an F_Responses cell, do not chooose "Show 
Responses" when configuring the router region. If both response fields are present, a conflict can 
occur where one user chooses a response on the form while another user chooses a response from 
the router region. If responses are entered in both fields, the last response chosen by the user is the 
one that takes precedence.

13. Click “Show Comments” to clear the checkbox.

14. Change the location to “Top” from the drop-down list.

15. Click Continue.

16. In the Define Step Map window, click Continue.

17. Click Finish in the Modify Workflow Policy window.

18. Click OK.
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Task 40: Create a Document Policy

The final step in setting up a form template for use in Workplace is to associate it with a form template 
policy. You will create a simple document policy using the Document Manager wizard.

1. Click Author > Advanced Tools.

2. Click Add Form Template Policy.

3. Under Document Policy, click Select.

4. Click Browse/Search for Form Template, browse to the Object Store folder that contains the 
Purchase Order form template and select the most recent version.

5. Click Next (the link located in the lower right corner of the policy view) or Select Entry Template (the 
link located in the left side navigation menu called “Steps”).

6. Click Browse/Search for Entry Template browse to the Object Store folder that contains Purchase 
Order entry template and select the most recent version.

7. (Optional) You can map published template fields to document class properties; however, it is not 
required for the purposes of this tutorial.

8. Click Select Folder and browse to the Document Policy folder in the Object Store.

9. Under Options, choose “Yes” from the Add as a major version drop-down list.

10. Click Next or Set Properties.

11. In the Document Title field, enter “Purchase Orders Policy”.

12. Click Next or Set Security.

13. Click Finish and OK to save your new Document Policy.

Now that you have completed the design and deployment of the ITX form template, you can test all the 
form features in the final section of this tutorial.
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Testing Your ITX Form Template

This section explains how to test the intelligence features of your ITX form template. At the end of this 
section, you’ll know how to perform the following tasks:

1. Test various intelligence features of the eForm within a document policy:

• Test default values (Task 41a on page 92).

• Test the auto-increment (Task 41b on page 92).

• Test conditional tabbing (Task 41c on page 92).

• Test the ‘Entry is Required’ setting (Task 41d on page 92).

• Test the help message (Task 41e on page 92).

• Test the choice list (Task 41f on page 92).

• Test the dynamic choice list (Task 41g on page 93).

• Test the calculations (Task 41h on page 93).

• Test the digital signature (Task 41i on page 93).

• Test the check formula (Task 41j on page 94).

2. Test various intelligence features of the eForm (in addition to the items above) within a workflow policy:

• Launch the workflow (Task 42a on page 94).

• Open a new work item (Task 42b on page 94).

Overview

When you draw the graphic elements of a template, it’s easy to visually inspect the form and check for 
possible errors. Checking the form’s intelligence features can be just as easy with eForms Designer’s test 
mode. Test mode simulates the fill out environment and gives you an idea of what the user fill experience 
would be like. However, for best simulation of the user experience, always deploy your ITX form templates 
to Workplace and then test it.

You can fill out a form by typing or pasting information into each cell. You can move from one cell to 
another by pressing the Tab key or by clicking a different cell with the pointer. When you press Tab, the 
cursor moves to the next cell in tab position order. If you hold the Shift key while pressing Tab, the previous 
cell is selected instead. If you’ve configured any conditional tabs, you’ll see their effect while testing your 
form.

Testing Your ITX Form Template within a Document Policy

In the following tasks, you’ll test the intelligence features of your form to ensure that everything works 
smoothly for the user.
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Task 41a: Test Default Values

To test your form template, return to Workplace and browse to the Purchase Order form template, or the 
Purchase Orders Policy in your Document Policies folder. A blank instance of the form will open in a 
browser window. The ‘Send Invoice To’ and ‘Date Issued’ fields already contain data.

NOTE Ensure that your form template has been promoted to a major version before testing (see Task 35 
for details). 

Task 41b: Test the Auto-increment

The auto-increment number appears as soon as a blank instance of the form opens.

Task 41c: Test Conditional Tabbing

As you tab into the ‘Yes’ field, the border of the checkbox is outlined to indicate that it’s selected. Now you 
can test several intelligence features at once. You can test the ‘cluster’ setting for the ‘Yes,’ ‘No,’ and ‘Call 
first’ checkboxes to make sure that only one can be turned on at a time. You can also check the results of 
the conditional tab formula that you configured for the ‘Yes’ and ‘No’ checkboxes.

1. Select the ‘Yes’ field by clicking it with the pointer, or press any key on the keyboard.

2. Select the ‘No’ or ‘Call first’ checkbox. The ‘Yes’ checkbox should turn off automatically.

3. Select the ‘Yes’ checkbox; then press Tab. With ‘Yes’ selected, your conditional tab formula should 
skip the ‘No’ and ‘Phone’ checkboxes and move you directly to the ‘Ship_Via’ field.

Task 41d: Test the Entry is Required Setting

1. Tab out of the ‘Ship_Via’ field without making an entry to test the ‘Entry is Required’ setting.

The application checks to see if a value was entered in the field. Because no entry was made, a 
message is displayed.

2. Click OK to dismiss the message. If the form was being filled out, the user could continue filling out the 
form but might be unable to accept and save the record until the required cell value was entered, 
depending upon how the Error Handling was configured.

Task 41e: Test the Help Message

1. When you click the ‘Ship Via’ cell, the help message appears in the Footer area of the screen. 

Task 41f: Test the Simple Choice List

1. Click the Arrow indicator in the ‘Ship_Via’ field title section. The choice list appears.
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2. Select “Airmail” from the choice list and press Tab.

Task 41g: Test the Dynamic Choice List

1. Click the History page.

2. Click the arrow indictor in the ‘Requested Delivery Period’ drop-down list. “Overnight, 24 hrs, and 
Express overseas” should be your list of choices.

Task 41h: Test the Calculations

1. Click the Order Page.

2. Type 100 in the ‘Qty’ column; then press Tab.

3. Enter an item description in the ‘Description’ column; then press Tab.

4. Enter 15 in the ‘Unit Cost’ column; then press Tab.

Now two calculations are triggered at once and the resulting values are displayed in the ‘Extended 
Cost’ and ‘Total’ fields.

Task 41i: Test the Digital Signature

1. Click the Click Here To Sign link in the Authorizing Signature field.
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2. Enter your user name and password in the signing service dialog box. Click Sign. Your signature is 
displayed in the cell.

3. Try to change the information in the Ship Via field. Because you signed in the Authorizing Signature 
field, you cannot modify this data.

4. Click the Status button to the left of the signature. The Signature Verification window appears.

5. Click Delete. The Delete Signature dialog box appears.

6. Click Delete. The signature is removed and the field reverts to the link “Click Here To Sign.”

7. Try to change the information in the Ship Via field. Because you deleted the signature from the 
Authorizing Signature field, you can now modify this data.

Task 41j: Test the Check Formula

1. Enter your name and password in the ‘Signature’ field. Click Sign and then press  the Tab key.

As you tab out of the ‘Authorizing Signature’ field, the check formula you created is triggered. Because 
the value of the purchase is more than 1000 dollars, an alert message is displayed.

2. Click OK to dismiss the message.

3. Delete the signature as before.

4. Select “UPS” from the ‘Ship_Via’ choice list.

5. Print your form while in test mode to see how a paper copy looks with all the data fields filled out.

6. Close the form.

Testing Your ITX Form Template within a Workflow Policy

Repeat the same tasks that you used to test the document policy. In addition, you can test the following:

Task 42a: Launch the Workflow

1. Re-sign the form and then click the Launch button on the toolbar above the form. This will move the 
form to the next step in the workflow.

NOTE If a form data entry template has been configured for the workflow policy, you can save your 
data using the Add Document dialog box. 

Task 42b: Open the New Work Item

1. Click Tasks from the left side navigation menu.

2. Click My Inbox.
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3. Click the item named Purchase Order Process. The form will open with the data you saved at the 
LaunchStep.

4. Close the form.

This is the end of the Testing Your Form section. 

If you’ve completed all the tasks in this tutorial, you should have a working knowledge of eForms 
Designer’s basic design and intelligence capabilities, and how to create simple form template policies. For 
information about eForms Designer’s more advanced features, please consult your eForms Designer 
Help.
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Appendix A - Planning Your Form

A well-known expression is “People don’t plan to fail; they fail to plan.” This is especially true for the form 
author. The usability and success of your form is directly related to how well you research and plan the 
form before drawing. This section contains a list of ten steps designed to help you plan and implement a 
successful electronic form.

The following information was generously provided by Mr. Robert Barnett of Robert Barnett and 
Associates Pty. Ltd. 

Step 1 - Establish the primary purpose of the form

You’ll design a better form if you have a clear idea of the form’s purpose and understand what you are 
trying to achieve.

Step 2 - Find out who will use the form

Find out who will fill out the form, who will process the form when it’s received, and who will need to 
reference the form at a later date.

It’s also worthwhile to consider the following questions:

• Will the form be filled out internally, or will people outside your organization use it too?

• Will the users fill out the form regularly, or will they be “once only” form fillers?

• Have the intended users ever filled out an electronic form before?

• What equipment do the users have? What fonts do they use? This can be a significant problem if the 
forms are used across various platforms. You may need to conduct careful tests.

Step 3 - Analyze the data needs

The data entered on the form can come from the person filling out the form, or it might be “looked up” in an 
existing database file. Make sure you understand:

• What data does each user need? 

• Where does that data come from? Will all the users have access to the data they have to put on the 
form? For public-use forms and those filled out by people outside your organization, this can be a very 
important question. 

If the data from the completed form will be submitted to a database, here are some typical questions you 
should ask:

• Is it always numeric or could there be alpha characters? Is there a fixed or maximum size?

• Do some fields need special or consistent formatting? 

• How will you handle very long text fields such as descriptions? Will they need scroll bars or a 
maximum size? 
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Step 4 - Decide which intelligence features are needed

Electronic forms can eliminate many of the problems caused by user error. For example, one of the biggest 
problems form fillers have is their inability to carry out basic arithmetic functions such as addition and 
subtraction. By building automatic calculations into your form, you’ll greatly reduce errors of this type.

Make sure you understand the intelligence features that are available and use them to your advantage. 
Consider how you can implement features such as help messages, choice lists, conditional tabbing, and 
check formulas.

Step 5 - Determine the form filling process

If possible, try to determine how the users will process the form. This information can have an impact on 
the design and features of your form. For example, do users fill out the entire form at one sitting? If not, 
and your from contains mandatory fields, they won’t be able to save and close their work overnight.

Step 6 - Determine the form handling process

Filling out a form is just the beginning of a process.Think about what happens after the form is filled out.

• Do users need to print out a copy of the form? This can seriously affect the design style. If your 
organization has many users and different computer printers, you may have to design around the 
limitations of the poorest printer.

• Will the form fillers use email? Are there standard addresses that can be built in to the form?

• If email is used, do all the users have the email application installed on their computers?

• Will all users have access to the template?

Step 7 - Find out how the form interacts with other forms and systems

Electronic forms can be designed to stand alone or to link to other data sources for retrieval and 
submission of data.

• Does data come from other forms or databases?

• Do you need to update external databases automatically from within the form?

Step 8 - Find out about legal and other usage matters

• Will an electronic form satisfy legal requirements, or are paper copies needed?

• Are electronic signatures acceptable?

• How long do you need to store copies of the form (both template and data)? Does every user have to 
retain copies of the template and form data? If long term, what processes will you have to put in place 
to ensure that the forms can be read many years down the line? 
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Step 9 - Design the form

Once you’ve done your homework, you should draw the layout and add the intelligence features. In some 
cases this will be in two sequential steps while in others you will add the intelligence (and even work out 
the formulas) as you go.

Step 10 - Test the form

This is one of the most important steps and is much more important for electronic forms than it is for paper 
forms. You are not only dealing with issues of language and comprehension but with people's work 
methods.

Testing of electronic forms typically involves the following: 

• User comprehension: do people understand the form, its questions, instructions and purpose?

• User needs: does the form suit the way people work?

• Field intelligence: does it apply in all situations? Does it actually work? Does it have side effects? Be 
sure to check the following:

• Field formatting.

• Field calculations.

• Macros.

• Edit checks / field validations.

• Tabbing (including conditional tabbing).

• Database lookups.

• Help messages: are they correct and do people understand them? Do they provide the help that 
people need and want?

• Choice lists: are they comprehensive and appropriate for all users?

• Database updating: does it work as it is supposed to and does it work for all users?

• Buttons: are they appropriate and do they work for all users?

• Email and routing: is predetermined routing correct and does it cover all situations?

• Custom menus: do they cover all user needs and is the language clear?

• Form tracking: does it work and does it provide the information users need?

This is a summary of the more important issues.

Conclusion

In spite of all the preliminary planning and testing, there is nothing like the real world to find out how a form 
really behaves. Even modern testing methods such as observational usability studies provide information 
only about the form's potential success. Once it’s running live, you’ll need to carefully review the design 
and its usage.
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Robert Barnett is an internationally known expert on forms design and information management. 
Information about his books and courses on forms management and design can be found on his 
company’s website at http://www.rbainformationdesign.com.au. The site also has free papers available 
on various aspects of forms management and design. 

http://wwwrbainformationdesign.com.au
http://wwwrbainformationdesign.com.au
http://www.rbainformationdesign.com.au/
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Notices
This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other 
countries. Consult your local IBM representative for information on the products and services 
currently available in your area. Any reference to an IBM product, program, or service is not 
intended to state or imply that only that IBM product, program, or service may be used. Any 
functionally equivalent product, program, or service that does not infringe any IBM intellectual 
property right may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this 
document. The furnishing of this document does not grant you any license to these patents. You 
can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual 
Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES 
CORPORATION PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in 
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are 
periodically made to the information herein; these changes will be incorporated in new editions of 
the publication. IBM may make improvements and/or changes in the product(s) and/or the 
program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do 
not in any manner serve as an endorsement of those Web sites. The materials at those Web sites 
are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate 
without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose of enabling: (i) 
the exchange of information between independently created programs and other programs 
(including this one) and (ii) the mutual use of the information which has been exchanged, should 
contact:

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some 
cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are 
provided by IBM under terms of the IBM Customer Agreement, IBM International Program License 
Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, 
the results obtained in other operating environments may vary significantly. Some measurements 
may have been made on development-level systems and there is no guarantee that these 
measurements will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results may vary. Users of 
this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. IBM has not tested those products 
and cannot confirm the accuracy of performance, compatibility or any other claims related to non-
IBM products. Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal 
without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To 
illustrate them as completely as possible, the examples include the names of individuals, 
companies, brands, and products. All of these names are fictitious and any similarity to the names 
and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate 
programming techniques on various operating platforms. You may copy, modify, and distribute 
these sample programs in any form without payment to IBM, for the purposes of developing, 
using, marketing or distributing application programs conforming to the application programming 
interface for the operating platform for which the sample programs are written. These examples 
have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply 
reliability, serviceability, or function of these programs.
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Trademarks
IBM is a registered trademark of International Business Machines Corporation in the United 
States, other countries, or both.

FileNet is a registered trademark of FileNet Corporation, in the United States, other countries, or 
both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation 
in the United States, other countries, or both.

Other company, product, and service names may be trademarks or service marks of others.
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Index
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overview of 44
adding
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Auto-increments 77
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overview of 77
testing 92

C
Calculations 73
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overview of 73
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naming cells with 58
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setting the type 61
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creating 69
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testing 92
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simple 69
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Import 25
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G
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ITX Form Template 28

J
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L
language dictionary 55
LaunchStep 82
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M
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Preferences command 55
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Print this page 45

R
Replicate command 48
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by example 26
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