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Course Outline: 
Drawings in AutoCAD 

 
This webinar was created to provide an introduction to the SI Drawing features available in 

our AutoCAD integration. The session will include about 40-45 minutes of feature description 

and demonstration followed by a Q&A period. 

Session Topics 

• Documentation Overview and Related Data 

• AutoCAD Line Drawings 

• AutoCAD Elevation Drawings 

• AutoCAD Floor Plans 

• Importing Floor Plan Drawings 

• AutoCAD Schematics 

• Installation Reports 
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Design and Documentation Overview 
 

• AutoCAD Compatibility 

• D-Tools only supports full versions of AutoCAD (NOT AutoCAD LT) 

• Support includes AutoCAD 2010 SP2 – AutoCAD 2018 

• When running a 64-bit OS, AutoCAD 2018 must be 64-bit for schematic 

blocks to function 

• D-Tools supports two-way communication of data between D-Tools & 

AutoCAD 

• Build a BOM (project) then drag products to AutoCAD to create a drawing 

• Drag shapes to a drawing to build a BOM 

• D-Tools can create four types of drawings 

• Line Drawings – used for simple flow diagrams 

• Elevation – used for wall elevations and equipment racks 

• Plan – shows equipment locations and wire labels on floor plans  

• Schematics – I/O interconnect map of system connection details 

• In AutoCAD, each drawing type is created in a separate DWG file 
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Design and Documentation Overview (continued) 
 

• Data used in drawings 

• Images – line drawing – ONLY IN VISIO! 

• Dimensions (height, width, depth) – primarily for elevations 

• Weight – equipment rack reports 

• Rack Mounted? – equipment racks 

• Rack Units – equipment racks 
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Line Drawings 
 

• Signal Flow or “Block Diagram” 

• Line Drawings also work well for riser diagrams 

• So how do I make a line drawing? 

• Open a project in AutoCAD using the Line Drawing template 

• Drag and drop products from D-Tools to AutoCAD 

ACTIVITY 1 

Launch an SI Project in AutoCAD 

1. From the Project Explorer View, select your project file. 

2. On the Home Toolbar click the AutoCAD button and select “New AutoCAD.” 

Note: you can also use the right click menu or New under Files at the bottom of the screen. 

3. This brings up the New AutoCAD Drawing box. 

4. Select the template “Line.dwg.” 

5. You can change the file name if you wish.  Click OK 

6. Your drawing file will open in AutoCAD. 

7. In the future, you can open your drawing file one of three ways: 

a. From the AutoCAD button on the Home Tab, you can select your DWG files. 

b. From the Right-click AutoCAD menu. 

c. From the Files menu at the bottom of the Project Explorer. 
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ACTIVITY 2 

Creating a Line Diagram Drawing 

1. Select the Project Editor button from AutoCAD to switch to the project BOM. 

2. It is easier to filter the Project Editor before adding items to the page. 

3. Filter for the specific rooms or systems you will be including in the Line Diagram to make it 

easier to find the items and pull them out on the page.   

4. Using Ctrl/Shift + Left Click makes it easier by pulling out multiple items at a time.   

5. Select and drag items out on the page. 

Note: Think of signal flow from sources to switchers to amplifiers or extenders to outputs. 

Organizing Items on the Drawing Page 

• Use the block grips with Snap, Grid and Object Snap 

Connecting Blocks 

• There are two distinct methods of connecting blocks to show signal flow 

• Use wire blocks or standard AutoCAD leaders 

• To use a wire block, drag a wire item from the Project Editor to the drawing 

• These are limited to projecting in a straight line in any angle you rotate the block 

• Standard AutoCAD leader lines may be easier to work with 

Creating Custom Blocks 

• Search for “creating custom blocks” on our support wiki (support.d-tools.com) 

• Custom blocks can be created for Line, Elevation and Plan drawings but NOT Schematics 
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Elevation Drawings 
 

• Two kinds of dimensionally accurate Elevation Drawings are typical 

• Rack Elevations 

• Wall Elevations 

• Why Rack Elevations? They answer these questions… 

• Will the equipment fit in my rack? (also, is my rack large enough?) 

• In what order should the technician place products in the rack? 

• What are my ventilation and power requirements? 

• Will my rack fit in the available space? Like a cabinet or closet 

• Why Wall Elevations? 

• Will the gear fit in the space I have available? 

• Show where to locate TVs, Speakers, etc. with dimensions 

• Show the customer how the equipment will look in a room 
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ACTIVITY 3 

Creating a Rack Elevation Drawing 

1. Close the Line drawing. 

2. Repeat Activity 1 except in step 4, pick “Elevation.dwg”. 

3. Search your product catalog for ‘equipment rack’ and add a rack to your project. 

4. Add several rack components to your project and drag them onto the Elevation drawing page 

(rack shelves, vents, power conditioner, etc.) 

5. Now drag other equipment to the page. Try items like a receiver, amplifier or switcher 

6. Consider items that sit on a shelf versus items that are rack mounted. Verify these settings on 

the Specifications tab for each item. 

7. Snap equipment blocks into rack spaces within the rack 

 
ACTIVITY 4 

Creating a Rack Side View 

The SI Elevation page has tools to create rack side views.  The rack side view allows us to see the 

depth of equipment in a rack. 

1. Select the rack and all the other blocks by dragging a window around the them (from upper-

left to lower-right). 

2. Right-click and select D-Tools → Block → Generate Side View. 

3. The side view blocks of the rack and all the components will be generated.   

4. Notice that the side view blocks do not automatically align themselves with the parent 

component’s rack position so this will need to be completed. 

5. Use typical AutoCAD commands like MOVE with OBJECT SNAP to accomplish the alignment.  
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Floor Plans 
 

• Floor Plan Drawings serve two purposes 

• Prewire Documentation 

• Specify Device Locations 

• Plan View Shapes 

• General Shapes – include basic attributes 

• Scale Plan Shape – Not resizable, dimensionally accurate. Ideal for 

showing rack locations and other devices where placement details 

are important 

• Industry-specific blocks – J-STD-710, NECA, SIA 

Wire Shape – “Bulk Wire” is the default wire shape for the plan view 
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ACTIVITY 5 

Changing the Block that Drops 

SI includes standard behaviors to drop different blocks for different categories of items on the 

different drawing types. You can change the default block that drops for a specific product or a 

specific Category/Subcategory. 

6. To begin, create a Plan view drawing using the same method as in Activity 1 but use the 

“Plan.dwg” template. 

7. Drag a speaker onto the drawing from the Project Editor. 

8. Select the block that drops. 

9. Right-click → D-Tools → Block → Change Block. 

10. This brings up the Change Block window which allows you to select specific block. 

11. You can assign the block for this: 

a. Specific Product 

b. All items in this specific category 

c. All items within this specific subcategory 

12. Make choices and click Change. 
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Importing Floor Plan Drawings 
 

• Three methods for inserting a floor plan in AutoCAD 

• Insert an AutoCAD DWG file (as Xref) 

• Standard AutoCAD functionality 
• Easy to replace floor plan if the plan changes 

• Insert PDF file as Reference 

• Standard AutoCAD functionality 
• Easy to replace floor plan if the plan changes 

• AutoCAD “PDF Import” command 

• Standard AutoCAD functionality 
• Creates native AutoCAD entities form PDF data 
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ACTIVITY 6 
Insert a Floor Plan Drawing using different methods 

This is a standard feature of AutoCAD. With support for DWG, DWF, PDF, images and the new PDF 

Import tool, AutoCAD is flexible when it comes to getting a floor plan inserted into your drawing. 

Attach an Xref 

1. From the Insert menu, in the Reference section, click Attach. 

2. Browse to one of the supported formats including DWG, DWF and PDF. 

3. This creates a reference to the file. If you receive a new version of the file. Replace it and 

update the reference. These are generally to scale 

PDF Import (available in AutoCAD 2018 and newer) 

1. From the Insert menu, in the Import section, click PDF Import. 

2. Browse to a PDF file. Consider configuration options, make choices and click OK. 

3. This will read the PDF file and convert it to native AutoCAD geometry. 
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AutoCAD Schematics 
 

• Schematics document point to point connectivity between devices 

• Input / Output data is used to generate the blocks 

• Wire blocks are used to make the connections between the I/Os 

 

ACTIVITY 7 
Create a schematic drawing 

1. Close the last drawing. 

2. Repeat Activity 1 except in step 4, pick “Schematic.dwg”. 

3. Drag several components to your schematic drawing (amplifiers and speakers are a good start) 

4. Now drag in a wire product to drop a wire block 

5. Connect the wire between an output and an input of two different devices 

6. Repeat steps 3-5 to layout the drawing 
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Installation Reports 
 

• Shapes (devices) located on a page can be used as the source of report data 
• This includes wire connections  
• Typical Reports: 

• Equipment Checklist 
• Wire checklist 
• Wire Connection Reports 

• Wire termination count 

• Wire Labels 

• Provide matching wire labels to go with wire checklists 

• Brother Wire Labels – send label data to a Brother labeler 

• Laser Printer Labels – use a label template to make wire wraps 
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ACTIVITY 8 

Wire Checklist Report 

The Wire Checklist report is used for prewire connections.  It details From-To locations at the 

prewire connection level. It will show the Head End a wire is coming from as well as the Location 

and device to which it is attached. Also shown: the wire Mfr-Model, Wire Number and Type. 

7. Navigate to the Reports tab on the Project Editor. 

8. On the Options section select the filtering option Current Drawing Page. 

9. From the Installation Reports list, select the Wire Checklist report.  This report can be run with 

wires grouped by Head End, Location or Wire Number. 

10. Select by Location (this groups the wires in the report by Location.) 

11. Take notice that only the wires we used on this page are showing up in the report. 

Note: Standard filters could be used to specify criteria for this installation report. 

 

ACTIVITY 9 

Checklist Report (Product) 

The Checklist report gives you a field checklist for installing various items in the project. 

12. Navigate to the Reports tab in the Project Editor. 

13. On the Options section select the filtering option Current Drawing Page. 

14. From the Management Reports list, select the Checklist report. 

15. Select By Location as the grouping option. 
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ACTIVITY 10 

Wire Connections Report 

The Wire Connections report is run for terminated connections made on schematics.  It provides 

connection details from the output device to the input device, wire Mfr-Model, Wire Number and 

Type (Subcategory.) 

16. Navigate to the Reports tab on the Project Editor. 

17. On the Options section select the filtering option Current Drawing Page. 

18. From the Installation Reports list, select the Wire Connections report.  This report can be run 

with wires grouped by Manufacturer, then Wire Number or just Wire Number. 

19. Select by Wire Number (this sorts the connections by Wire Number). 

20. Take note that only the wires used on this page are showing up in the report. 

Note: Standard filters could be used to specify criteria for this installation report. 
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Training content complete 
 

• Questions? 
 
 
 

• Support Resources Available 

• D-Tools Application Home Page Links 

• Documentation – open the Support Wiki 

• Support Ticket – open the web page to create a support ticket 

• Chat With Us – Launches Chat Support 

• From any D-Tools software interface, click Learn More 

• Found in the upper-right corner 

• Launches the Support Wiki 

• Open the Support Wiki directly at support.d-tools.com 

• Send an email to support@d-toolshelp.com 

• Call 866.386.6571 

 

http://support.d-tools.com/001_SI_2017_Documentation
http://d-tools.com/open-a-support-ticket/
http://messenger.providesupport.com/messenger/dtools.html
http://support.d-tools.com/
mailto:support@d-toolshelp.com

