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Course Outline: 
Drawings in Visio 

 
This webinar was created to provide an introduction to the SI Drawing features available in 

our Visio integration. The session will include about 30 minutes of feature description and 

demonstration followed by a Q&A period. 

Session Topics 

• Documentation Overview and Related Data 

• Visio Line Drawings 

• Visio Elevation Drawings 

• Visio Floor Plans 

• Importing Floor Plan Drawings 

• Visio Schematics 

• Installation Reports 
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Documentation Overview and Related Data 
 

• D-Tools supports two-way communication of data between D-Tools & Visio 

• Build a BOM (project) then drag products to Visio to create a drawing 

• Drag shapes to a drawing to build a BOM 

• D-Tool can create four types of drawings 

• Line Drawings – used for simple flow diagrams (a great sales tool) 

• Elevation – used for wall elevations and equipment racks 

• Plan – shows equipment locations and wire labels on floor plans  

• Schematics – I/O interconnect map of system connection details 

• Data used in drawings 

• Images – line drawing 

• Dimensions (height, width, depth) – primarily for elevations 

• Weight – equipment rack reports 

• Rack Mounted? – equipment racks 

• Rack Units – equipment racks 

• Power and Heat (Amps, Volts, Watts, BTU/Hr.)  
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Visio Line Drawings 
 

• Great for Sales Documentation 

• Signal Flow or “Block Diagram” 

• Line Drawings are a great way to communicate with non-technical (or less 

technical) stakeholders about complex systems 

• So how do I make a line drawing? 

• Open a project in Visio 

• Select a Line Drawing Page 

• Drag and drop products from D-Tools to Visio 

• Key to success 

• Line Drawings will use the Large Image stored in products 

• This improves the appearance of Shapes on Line Drawings  
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ACTIVITY 1 

Launch an SI Project in Visio 

1. From the Project Explorer View, select your project file. 

2. On the Home Toolbar click the Visio button and select “New Visio.” 

Note: you can also add a Visio drawing on the right click menu or from Files at the bottom 

of the screen. 

3. This brings up the New Visio Drawing box.  SI supports the latest Visio file format and lets you 

choose between legacy templates (.vst) and the more robust .vstx format. 

 
4. Select the template “D-Tools SI 24x36 Template.” 

5. You can change the file name if you wish.   

6. Click “Populate company logo in title block”.  Click OK 

7. Your drawing file will open in Microsoft Visio. 

8. In the future, you can open your Visio file one of three ways: 

a. From the Visio button on the Home Tab, you can select your Visio files. 

b. From the Right-click Visio menu. 

c. From the Files menu at the bottom of the Project Explorer. 
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ACTIVITY 2 

Creating a Line Diagram Drawing 

1. Select the Line diagram page type in your Visio file. 

2. Open the Project Editor to add items to the page. 

3. It is easier to filter the Project Editor before adding items to the page.   

4. Filter for the specific rooms or systems you will be including in the Line Diagram to make it 

easier to find the items and pull them out on the page.   

5. Using Ctrl/Shift + Left Click makes it easier by pulling out multiple items at a time.   

6. Select and drag the items out on the page. 

a. Speakers 

b. Audio/Video sources 

c. Surround Processor/Amplifier or Surround Receiver 

Note: The items may seem very small on the page.  This can be corrected by changing the 

page scale so that the line shapes will be larger on the page.  Drag out all shapes before 

changing the page scale; otherwise it will not have the desired effect. 

7. Right Click on the Line Diagram tab at the bottom of your drawing page.  Choose “Page Setup”. 

8. Navigate to the Drawing Scale tab and set your scale to 1 ½” = 1’-0”.  This will cause the shapes 

to become much larger. 

9. The shapes have probably moved off of the page (upper right) so move them back on the page 

if necessary. 

Organizing Items on the Drawing Page 

• Using the Align Shapes tool (Found on the Align tool on the Home Tab) 

• Using the Distribute Shapes tool (Found on the Position tool on the Home Tab) 
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ACTIVITY 3 

Connecting Items 

It is recommended to use the Line Connector tool, not actual wires from the SI project for this 

purpose.  The Line diagram is not a SI wiring diagram or a schematic drawing. It is simply used as 

a signal flow drawing.  For Schematics; use actual wire shapes (and wire products). 

1. Select the Connector Tool, located on the Home Toolbar in the Tools section. 

2. Once you have selected the Connector Tool you will be able to draw lines on the drawing page. 

3. Anywhere on the drawing page left click (and hold), drag and let go of your mouse button.  A 

line should be drawn on the page. 

4. Use the Line Format tool to change the color of the line to be blue.  By clicking the arrow next 

the button, you can select from many colors. 

5. Now format the line to have an arrow line end on it. 

a. Select the Line Formatting tool from the Home Toolbar on the Shape section. 

b. Drop it down and at the bottom choose “Arrows” 

c. Select one with an arrow pointing to the right 

6. You can also format the line thickness here as well using the Weight sub-menu. 

7. Copy and paste your newly formatted line and format it to be red. 

8. Copy it again and leave it black. 

9. You should now have three lines on the page (blue, red and black). 

10. For our scenario, use blue for Analog Audio, red for Video and black for Speaker signal. 

11. Connect a red and a blue line from the DVD player into the Surround processor. 

12. Connect a blue line from the Surround processor to the Amplifier. 

13. Connect the remaining lines on the page.  
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Visio Elevation Drawings 
 

• Two kinds of dimensionally accurate Elevation Drawings are typical 

• Rack Elevations 

• Wall Elevations 

• Why Rack Elevations? They answer these questions… 

• Will the equipment fit in my rack? (also, is my rack large enough?) 

• In what order should the technician place products in the rack? 

• What are my ventilation and power requirements? 

• Will my rack fit in the available space? Like a cabinet or closet 

• Why Wall Elevations? 

• Will the gear fit in the space I have available? 

• Show where to locate TVs, Speakers, etc. with dimensions 

• Show the customer how the equipment will look in a room 
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ACTIVITY 4 

Creating a Rack Elevation Drawing 

1. Search your product catalog for ‘equipment rack’ and add a rack to your project. 

2. Add several rack components to your project and drag them onto the Elevation drawing page 

from the rack package shelves, vents, power conditioner, etc.) 

3. Place the rack and other parts in the middle of the page. 

4. Notice, the rack looks small compared to the size of the page?  This is due to the page scale. 

5. Let’s change the page scale so the rack appears larger on the page. 

6. Right Click on the Elevation tab and select “Page Setup”.   

7. Go to the Drawing Scale tab and select a scale of 3” = 1’0” (or try 1-1/2” = 1’-0”). 

8. Move the rack and parts to the left side of the page. 

9. Now drag other equipment onto the page from your project. Items like: 

a. Receiver 

b. Blu-Ray (with shelf) 

c. Cable Box (with shelf) 

10. Attach the rack shelf shape to the rack.  You will know it is connected when a red box appears 

in the upper left hand corner. 

11. Now attach the Blu-Ray player on top of the shelf. It will attach in the lower left hand corner.  

You will know it is attached when the red box appears. (Continued on next page.) 
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ACTIVITY 4 CONTINUED 

12. After you let go of your mouse, the Blu-Ray player may disappear behind the shelf shape.  

13. The reason this happens is due to the layering effect on the D-Tools drawing page.  Items 

dragged on the page first appear further back on the page.     

14. The Blu-Ray player needs to be “brought forward” so that it appears on top of the shelf. 

15. Slowly click two times on the shelf shape.  The first click will select the shelf. The second click 

should select the Blu-Ray player behind it. 

16. Now Right-click and select Bring to Front. 

17. The Blu-Ray player will now be moved in front of the shelf. 

Tip: You can avoid this from happening in the future by dragging the RSH shape out onto the 

page first, and then the piece of equipment. 

18. Complete the rack layout for the remaining components. 

19. In Your Stencil Tree, find the Custom category and open the DT Annotations stencil.  Find the 

shape ‘Rack Unit Tape Measure’ – you can attach this shape and it will count the rack units on 

the side of the rack! 
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ACTIVITY 5 

Creating a Rack Side View 

The SI Elevation page has tools to create rack side views.  The rack side view allows us to see the 

depth of equipment in a rack.  The side view shapes use Height and Depth from the product data 

to determine the size of the shape. 

1. Select the rack and all the shapes using Ctrl + Left-click (or drag a window around the items.) 

2. Avoid selecting the shelf shapes (holding Ctrl key you can ‘deselect’ items.) 

3. Select D-Tools → Shape → Generate Side View. 

4. The side view shape of the rack and all the components will be generated.   

5. Notice that the side view shapes do not automatically align themselves with the parent 

component’s rack position so this will need to be completed. It is quick to use the align tools. 

6. First, to align all the shapes with the front face of the rack (left side) 

a. Select the rack shape. 

b. Hold down the Ctrl key and select the remaining side view shapes. 

c. From the Home Tab, in the Arrange Section, click the Position tool and select the Align 

Left option (this will vertically-align the shapes on the left side of the rack – using the 

first selected shape, the rack, as the basis for the alignment). 

7. To align the side view shapes with the parent shapes you will want to follow these steps: 

a. Select the parent shape in the main rack. Hold the Ctrl key and select the side view 

shape. 

b. From the Home Tab, in the Arrange Section, click the Position tool and select the Align 

Middle option (this will horizontally align the shapes on the middle – using the first 

selected shape as the basis for the alignment).  
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Visio Floor Plans 
 

• Floor Plan Drawings serve two purposes 

• Prewire Documentation 

• Specify Device Locations 

• Plan View Shapes 

• New SI Plan Shapes – highly configurable and enable creation of 

customized iterations for different products/categories 

• Icon Shapes – resizable, used primarily for Trim items (keypads, 

speakers, wireless access points, etc.) 

• Scale Plan Shapes – Not resizable, dimensionally accurate. Ideal for 

showing rack locations and other devices where placement details 

are important 

• Wire Shape – “Bulk Wire” is the default wire shape for the plan view 

but other wire shapes are also available  
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ACTIVITY 6 

Configuring & Saving Shape Data: Speaker Shape 

The new SI plan view shapes allow the user to configure the shape, shape color and other 

information and save these settings for a specific product or a specific Category/Subcategory. 

1. To make this activity run as smooth as possible, start by cloning a speaker product in the 

Catalog. Use your initials in the name to make sure it is unique. Now use this unique speaker. 

2. Drag a speaker onto the plan view page from the Project Editor. 

3. On the Visio toolbar Select the VIEW tab. 

4. From the Task Panes button select Shape Data (with shape data window open, any shape you 

select, you will be able to view the configurable options for that shape.) 

5. Typically, you will have the following configurable options: 

a. Shape Type 

b. Mount Type 

c. Fill Color 

 

d. Smart Rotate Text 

e. Show Component ID 

f. Show Note 

 

g. Note Text 

h. Icon Size 

i. Icon Text

6. Change the settings for the speaker shape as you see fit. 

7. Once your changes are made, right-click → D-Tools → Shape → Assign Product & Category. 

8. This brings up the Shape Assignment window which allows you to assign the specific shape 

configuration (when this item is used on the plan view page type.) 

9. You can assign the shape settings for: 

a. Specific Product. 

b. All items in a specific category. 

c. All items with a specific subcategory. 
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Activity 7 

Configuring & Saving Shape Data: Wire Shape 

1. To make this activity run as smooth as possible, start by cloning a bulk wire product in the 

Catalog. Use your initials in the name to make sure it is unique. Now use this unique wire. 

2. Drag your cable onto the plan view page from the Project Editor. 

3. With Wire Shapes, you have a more limited range of shape data configuration available: 

a. Show Text 

b. Line Color 

c. Line Pattern 

d. Line Weight 

e. Arrow Style 

4. Change the settings for the wire shape as you see fit. 

5. Once your changes are made, right-click → D-Tools → Shape → Assign Product & Category. 

6. You can assign the shape settings for: 

a. Specific Product. 

b. All items in a specific category. 

c. All items with a specific subcategory. 

7. This allows you to configure the specific colors you want to use for specific types of wire!  

Your wiring drawings will always comply (automatically) with a designated color scheme for 

wiring! 
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Importing Floor Plan Drawings 
 

• Three Methods for inserting a floor plan in Visio 

• Insert a JPEG or Bitmap 

• Easy to use but limited fidelity without large image files (think 
bloated Visio file) 

• No scale or difficult to scale 
• PDF Snapshot tool is an option 

• Insert an AutoCAD DWG file 

• Great visual results and flexibility, and can be to scale 
• Occasional Visio bug that damages the CAD file forcing the 

user to insert again 
• May require AutoCAD software and CAD knowledge 
• Free optional CAD software (i.e. Draft Sight) provide access to 

edit CAD files 
• D-Tools Insert PDF Background Utility (I will demo today) 

• Great visual results, flexibility and can be to scale 
• Limited by the PDF source 
• Check out the new AutoCAD “PDF Import” command  
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ACTIVITY 8 
Using Insert PDF Background (Custom Insert from SI) 

There are several ways to insert CAD drawings into an SI project. Each has pluses and minuses. The 

PDF file format has emerged as a standard for sharing information. The Insert PDF Background 

tools help you take advantage of this great format. 

1. Right-click on a drawing page, select D-Tools → Insert PDF Background. 

2. The Insert PDF Background Instructions page opens. Read these steps and follow them for 

good results. 

3. Click Continue and then select a PDF file. 

4. The PDF file will be loaded into a preview window that appears on the screen. 

5. Make choices about which pages you would like to insert from the PDF, page size, scale, etc. 

6. Click Insert. 
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ACTIVITY 9 
Insert a Floor Plan using other formats 

Sometimes a CAD file is not available. An image file gives us another option. These options are 

generally not to scale but can still provide good results. 

JPEG or Bitmap Insertion 

1. From the Insert menu, select Picture. 

2. Browse to and select the sample jpeg provided with the course. 

3. Resize, reposition and crop as necessary. 

 

PDF Snapshot Insertion 

1. Open the sample PDF floor plan provided with the course in Adobe Reader. 

2. From the Edit Menu select Take a Snapshot or Snapshot Tool. 

3. This will take a copy of the floor plan. 

4. Paste the image into Visio. 

5. Resize, reposition and crop as necessary. 

Tip: The closer you zoom in to the floor pan in Acrobat, the more detail that will show after pasting 

in Visio. Keep in mind that this also means a larger file. 
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ACTIVITY 10 
Insert AutoCAD Drawing 

CAD files inserted into Visio need to be prepared in a specific format to be used effectively. There 

is a series of steps for file preparation, that will make CAD file insertion seamless. 

Quick Tips on CAD Prep 

There are a few basic rules for CAD files (the most common things that cause issues with 

importing) 

• X-Refs:  The biggest culprit is X-refs or external references.  Visio will not accept a CAD 

file that has X-refs attached.  X-refs must be bound to the main file or removed.   

• Layer Settings:  Make sure all layer properties are set to “By Layer”: This allows for CAD 

drawing layer visibility and colors to be manipulated inside Visio. 

• File Version: Older versions of CAD files tend to import best.  Save the file as R14 or 2000 

DWG. 

• CAD prep Tool: If you don’t own AutoCAD, you can sue a free software called Draft Sight 

to open the CAD files and manipulate them as needed for them to be imported to Visio. 

1. From the Insert Menu select “CAD Drawing” 

2. Now browse to the CAD file on your 

computer and select “Open.” 

3. This brings up the CAD Drawing Properties 

window.   

(Continued on next page.) 
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ACTIVITY 10 CONTINUED 
4. Set Scale to Pre-defined scale = Page Scale. (see picture on page 61.) 

5. Use the Apply button to test (allows you to see the size of the CAD file on the page.) 

6. Verify that CAD Drawing Units is set to Inches, not Feet. 

7. Unlock Size & Position. 

8. Unlock Against Deletion. 

9. Leave View Extents checked. 

10. Layers Tab: this is where you can turn on/off layers and set the color properties for the layers. 

11. Each Layer has a Name, a visibility status, a color and line weight.   

12. Click OK to insert CAD File. 

13. The CAD file should now appear on your drawing. 
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Visio Schematics 
 

• Schematics document point to point connectivity between devices 

• Input / Output data is used to generate the shapes 

• Wire shapes are used to make the connections between the I/Os 

• Some Schematic Layout Basics 

• Far Left: Sources 

• Middle Left: Switching 

• Middle Right: Amplification 

• Far Right: Outputs (speakers, keypads, displays, etc.) 

• What about power and control? 

• Above or below? 
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ACTIVITY 11 

Layout your Schematic Shapes 

Moving and aligning the shapes manually into their respective “quadrants” on the page. 

1. Drag several speakers on to the drawing page from your project (add if necessary.) 

2. Place one of the speakers at the top of the page and one of the speakers at the bottom of the 

page on the right side of the screen. 

3. Left-click and drag a large selection box from the top to the bottom of the page.  (It is 

important to do this top to bottom.) 

4. All the speakers should be selected. 

5. Use the Align on Center tool (located on the Position tool) to align all the speakers on center 

with the top speaker. 

6. Then you will want to use the Distribute Vertical Spacing tool (located on the Position → 

Space Shapes toolbar) to evenly space all the speakers along the right side of the page. 

7. This is the process you would continue to follow for manual layout of your shapes. 
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ACTIVITY 12 

Making Wire Connections 

When making connections on schematic drawings, work systematically, left to right across the 

page.  Also, make most connections before trying to clean up the wire routing and crossing. 

1. Select a product on the page, Right-click → D-Tools → Find in Project Explorer. 

2. Now that you have found the item, drag the item’s wire accessories onto the page. 

Note: It is easier when you know the intended purpose of wires in your project editor! 

3. Connect the wires to the output terminals (right side) on the device. 

4. Connect the same wires to the appropriate downstream device (to the right). 

1. Repeat this process for the remaining devices. 
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Installation Reports 
 

• Shapes (devices) located on a page can be used as the source of report data 
• This includes wire connections  
• Typical Reports: 

• Equipment Checklist 
• Wire checklist 
• Wire Connection Reports 

• Wire termination count 

• Wire Labels 

• Provide matching wire labels to go with wire checklists 

• Brother Wire Labels – send label data to a Brother labeler 

• Laser Printer Labels – use a label template to make wire wraps 
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ACTIVITY 13 

Wire Checklist Report 

The Wire Checklist report is used for prewire connections.  It details From-To locations at the 

prewire connection level. It will show the Head End a wire is coming from as well as the Location 

and device to which it is attached. Also shown: the wire Mfr-Model, Wire Number and Type. 

2. Navigate to the Reports tab on the Project Editor. 

1. On the Options section select the filtering option Current Drawing Page. 

2. From the Installation Reports list, select the Wire Checklist report.  This report can be run with 

wires grouped by Head End, Location or Wire Number. 

3. Select by Location (this groups the wires in the report by Location.) 

4. Take notice that only the wires we used on this page are showing up in the report. 

Note: Standard filters could be used to specify criteria for this installation report. 

 

ACTIVITY 14 

Checklist Report (Product) 

The Checklist report gives you a field checklist for installing various items in the project. 

5. Navigate to the Reports tab in the Project Editor. 

6. On the Options section select the filtering option Current Drawing Page. 

7. From the Management Reports list, select the Checklist report. 

8. Select By Location as the grouping option. 
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ACTIVITY 15 

Wire Connections Report 

The Wire Connections report is run for terminated connections made on schematics.  It provides 

connection details from the output device to the input device, wire Mfr-Model, Wire Number and 

Type (Subcategory.) 

1. Navigate to the Reports tab on the Project Editor. 

2. On the Options section select the filtering option Current Drawing Page. 

3. From the Installation Reports list, select the Wire Connections report.  This report can be run 

with wires grouped by Manufacturer, then Wire Number or just Wire Number. 

4. Select by Wire Number (this sorts the connections by Wire Number). 

5. Take note that only the wires used on this page are showing up in the report. 

Note: Standard filters could be used to specify criteria for this installation report. 
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Training content complete 
 

• Questions? 
 
 
 

• Support Resources Available 

• D-Tools Application Home Page Links 

• Documentation – open the Support Wiki 

• Support Ticket – open the web page to create a support ticket 

• Chat With Us – Launches Chat Support 

• From any D-Tools software interface, click Learn More 

• Found in the upper-right corner 

• Launches the Support Wiki 

• Open the Support Wiki directly at support.d-tools.com 

• Send an email to support@d-toolshelp.com 

• Call 866.386.6571 

 

http://support.d-tools.com/001_SI_2017_Documentation
http://d-tools.com/open-a-support-ticket/
http://messenger.providesupport.com/messenger/dtools.html
http://support.d-tools.com/
mailto:support@d-toolshelp.com

