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1. INTRODUCTION 

This document describes the installation and operating instructions for the PervideoTM software 

application. 

 

Background 

As the evolution of big data continues, gaps in data analysis capabilities continue to persist 

throughout multiple industries.  While many data analysis solutions exist, they tend to be either 

very specialized or very customizable; both requiring significant resources (labor hours and/or 

money) to take a user’s data from some packaged dataset (file or database) to something viewable 

and understandable. 

Existing solutions vary from specialized custom software, open-source data analysis software 

languages, and spreadsheet applications.  Specialized custom software have a significant cost 

associated with developing and maintaining the required software, defining the software needs to 

be, and reuse of the software within the same organization.  Generally specialized custom software 

is develop by larger organizations, with large and/or complex data to process, and the significant 

initial investment in a custom software solution is determine a god return on investment.  Open-

source data analysis software languages, provide significant power to the user and small business 

and organizations, by simplifying the solution development process so that a larger consumer 

community can benefit from.  The open-source approach has a similar initial investment obligation 

to it, though that initial investment is mainly in labor and reduced turn-around time, but is 

significantly limited in its scalability and reusability.  Finally spreadsheets are the most 

recognizable solution to viewing and analyzing data but have significant size and calculations, to 

operate efficiently. 

The PervideoTM software closes some of the gaps between spreadsheet style common solutions 

and the custom software solutions.  The software provide a simple solution to basic time series 

data analysis problems.  Built from Mathworks® Matlab® programming platform the software 

application provides numerical time series data analysis features including channel-to-channel 

math, signal filtering, and data set concatenation functions. 
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Features 

The software application includes several features for file conversion, waveform modeling, 

signal conditioning, multiple display options, meta-data correction, data reduction and 

management tools. 

File Conversion:  

• Development of new file, for modeling of waveforms 

• Saving as Continuous Numerical Time Series (NTSC) and Discrete Numerical Time 

Series (NTSD) files 

• Import from MS Excel® (XLSX), Mathworks Matlab® (MAT) files, and Astronova 

DCR Files 

• Export to XML file (file meta-data only), MS Excel® (XLSX), Mathworks Matlab® 

(MAT), and Comma Separated Value (CSV) files 

 

Waveform Modeling and Signal Conditioning 

• Modeling of sine waves, square waves, triangle waves, saw-tooth waves, and pulse trains 

• Math operation of distinct channels (signals): add, subtract, multiply, and divide 

• Polynomial conversion, conversion to Log base 10 and Log base 2 

• Channel masking (used to emphasize signal feature or events) 

• Event detection/identification on condition: greater than, less than, between range, 

outside of range 

• Compression and smoothing of individual or all channels  

• Channel ordering and meta-data editing: labels, units, channel names, etc. 

 

Multiple-Display Options 

• Up to 4 plot windows overlaid vertically 

• All channels displayable from any of the 4 plot windows 

• Line-style modification 

• Smoothing and waveform magnification options (for improved viewing) 

 

Data Reduction and Management Tools 

• Split file into smaller size files 
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• Concatenate files into single file 

• User control of application file size limits 

 

 

System Requirements 

The following are the minimum system requirements needed for the software to properly 

function: 

• Operating System: Microsoft Windows 10 or 11 

• Processor: 1.2 GHz or faster 

• System Type: 64-bit 

• RAM: 16 GB minimum, 32 GB or greater recommended (depending on size of user data) 

• Storage: 1 GB 

• Runtime Software: MATLAB® Runtime (included with software) 

 

 

Installation Instructions 

The following are the instructions to install PervideoTM software: 

1. Unzip the “Pervideo-Setup.zip” contents 

2. Run/Double-click on “PervideoAppInstaller.exe” 

3. When the Windows software installation warning appears, click “yes” 

4. In the “Pervideo Installer” prompt, click “Next” 
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5. In the “Installation Options” prompt check the “Add a shortcut to desktop” checkbox and 

click “Next” 

 

6. In the “Required Software” prompt click “Next” 
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7. In the “License Agreement” prompt click the “Yes” radial button then click “Next” 
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8. In the “Confirmation Prompt” click “Install” 

 

9. Wait for the installation to complete 
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10. When the “Installation Complete” prompt appears, click “Finish” 

 

11. Installation completed! 

 

12. As an additional step it is recommended the files contained in the “…\application\examples” 

folder be copied to your users folder “C:\Users\{User Name}\Documents\Pervideo”.  This 

step will allow for quick access of an example file to open in the application. 

 

13. Finally, depending on the product license purchased, save your temporary license as 

“license.txt” to the app’s license folder:   

“C:\Program Files\Byte Recon\Pervideo\application\license” 

 

14. If applicable, repeat the last step once you receive your full license. 
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Finding the MAC Address of Your Computer 

The following are the instructions on how to find the Media Access Control (MAC) address of 

your computer.  The MAC address is used for all yearly and multi-year licenses. 

1. Press the windows “Start” key on your computer and type “cmd” and press “Enter” in the 

search field. 

2. In the “Command Window” type “getmac” and press “Enter” 

3. The “Physical Address”, highlighted below with a transport name, is your device’s MAC 

address 

 

4. If the “getmac” command did not return the MAC address, in the “Command Window” type 

“ipconfig /all” and press “Enter” 

5. The “Physical Address”, highlighted below, is your device’s MAC address 
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2. QUICK START 

Starting up the Application 

1. On the desktop double-click the “Pervideo” icon 

2. Wait for the initial start-up screen to finish. 

 

3. Wait for the final start-up screen to finish.  Please note there may be up to a minute between 

the two start-up screens 

4. When completed you should the app open as shown below 
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Opening a File 

NOTE: Example file(s) are included with the software.  It is recommended that those files 

contained in the “C:\Program Files\Byte_Recon\Pervideo\application\examples” folder be copied 

to your users folder “C:\Users\{User Name}\Documents\Pervideo”.  This step will allow for 

quick access of an example file to open in the application 

 

1. In the app click → File → Open 

2. Navigate to the desired file location 

 

3. Select the desired file and click → Open 
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Displaying a Channel 

1. In the left panel, if needed, expand the Plot Selections → Plot 1 selection tree 

2. Expand the first Base Channel, i.e. “Base Ch 01…” 

3. Click on the Show/Hide icon 

 

  



QUICK START 

 

 

Pervideo SW Manual  (ed. 1 v. 4)  16 

Copyright © 2021 Byte Reconnaissance LLC 

 

 

Zooming and Adjusting Views 

1. At the bottom of the plot window, click the Horizontal Zoom In Button 

2. Place the mouse somewhere along the trace 

3. Depress and hold the mouse’s left click button → drag the mouse to the right → release the 

mouse’s left click button 

4. A zoomed in view of the trace should appear similar to the one below 

 

 

Saving and Closing a File 

1. In the app click → File → Close 

2. If the save changes prompt appears, click “Yes” or “No” as desired 

 

 

 

Exiting the Application  

In the app click → File → Exit or alternatively click the “X” at the top-right corner of the app 
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3. OVERVIEW & FEATURES 

Overview 

The Pervideo™ software application is composed of four major areas providing distinct file/data 

management operations. 

 

1) Menu Bar 

2) File Navigation Panel 

3) Channel Display Panel 

4) Channel Navigation Buttons  

5) Application Status Window 

 

The “Menu Bar” provides the major areas of operation including file type operations, file editing 

operations, channel viewing operations, and other special operations.  The file type operations 

contained in the “File” menu include features to create, save, import/export, and close files.  The 

file editing operations contained in the “Edit” menu include features to add, delete, smooth, 
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compress, and move channels.  The “View” menu include feature to arrange the channel/trace 

display window and refresh the window display.  The “Tools” menu include special features to 

manipulate files (merging/splitting) and arrange the application (preferences).  Finally, the 

“Help” menu includes feature that opens the help file (this document) and general information 

about the software application. 

 

The “File Navigation Panel” is the location where information of the file contents are displayed 

(“File Info” branch), where the channels contained in the file are added to the display window’s 

plots (“Plot Selection” branch) and where the individual channel manipulation features are 

contained (“Plot Selection → Plot N → Base Ch N” branch). 

 

The “Channel/Trace Display Panel” is the area where channels/traces are displayed in one more 

plots arranged vertically; up to 4 plots can be displayed. 

 

The “Channel/Trace Navigation Buttons” is where the buttons used to zoom in/out and traverse a 

file.  This area includes buttons to add and clear “data tips”, text box containing X-Y information 

about the selected data point. 

 

The “Application Status Window” is the area where text messages indicating the status of some 

operation are displayed.  Text is displayed in this area when the application is performing some 

operation requested by the user including saving, smoothing, adding a channel, etc.  When an 

operation is in progress a text message will be displayed and the background color will change to 

emphasize the operation is in progress. 
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Key Features 

The Pervideo™ software application is available in distinct product configurations, depending its 

product license, with the default configuration being the “Pervideo Viewer” configuration.  

Increasing features are available depending on product configuration licensed. 

Application Feature 

Pervideo 

Viewer 

Pervideo 

Lite Pervideo  
Opening, creating and saving NTS Files X X X 

Importing files from MAT,  XLSX and CSV X X X 

Importing files from other file types (AN-DCR)     X 

Exporting files to MAT, XLSX, and CSV   X X 

Data Compression   X X 

Channel Smoothing/Filtering   X X 

Base channel creation X X X 

Event channel creation   X X 

Math channel creation     X 

Channel Conversion to Other Units     X 

Up to dual (2x) plot layout X     

Up to quad (4x) plot layout   X X 

Up to 250K Sample limit X     

Up to 250M Sample limit   X X 

File conversion from other data types     X 

File splitting and concatenation     X 

Partial file loading     X 
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4. FILE MENU 

The File Menu is composed of several functions to open, close, or migrate to different file types.  

The menu items and corresponding functions are defined below: 

• New: creates a new NTSC file type 

• Open: opens an NTSC or NTSD file type 

• Save: saves the open file 

• Save As: saves the open file as a new file name.  Note the software will automatically 

apply the timestamp of the file’s start time to the end of the filename the user entered 

• Close: Closes the file 

• Import: Allows the user to import different supported file-types into the application.  

Supported file types include: MAT and XLSX 

• Export: Allows the user to export to different supported file-types.  Supported file types 

include: CSV, MAT and XLSX 

• Exit: Closes the software application. 

 

Create a New File 

1. In the menu bar click File → New 

 

2. When the “New File Header Info” prompt appears, modify the fields to define the file name, 

file’s start date and time, file’s sample rate, and number of samples (sample count) contained 

in the file then click “OK” 

3. When the new file is created the application will update similar to the figure below.  Please 

note that while the “Plot Selection” tree branch contains “Plot N” branches, there are no 

branches contained within the “Plot N” branches because no channels have been added yet. 
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4. In the menu bar, click Edit → Add Base Channel → select desired waveform simulation 

option (“Simulate Square Wave” shown in this section). 

Please note the following attributes updated in the application 

• Right Arrows (triangles) and nested branches are contained in the “Plot Selections  → 

Plot N” tree branch 

• The “Base Ch Count” field of the “File Info → Header” branch is incremented by one 

• A right arrow (triangle) and nested information is contained in the “File Info → Base 

Channels” branch 
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5. In the “Plot Selections → Plot 1 → Base Ch 01” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen. 
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Opening a File 

1. In the menu bar click File → Open 

 

2. In the “Select File to Open” window, navigate to the desired file, select the file and click 

“OK”.  Note: to open an NTSD file change the file type drop-down menu to “(.ntsd)”. 

3. Wait for the application to load the selected file.  When the file opens the application should 

update similar to the figure below 

 

 

Save a File 

1. In the menu bar click File → Save 

 

Save a File As 

1. In the menu bar click File → Save As 
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2. In the “Save File As” window, navigate to the desired folder, enter the desired name in the 

“File name” field, and click “OK” 

Note: the application will automatically append the entered file name with the timestamp of the 

file.  The file timestamp is the start date and time shown in the file’s header information in 

“yyyymmdd_HHMMSS” format. 

 

 

Close a File 

1. In the menu bar click File → Close 

2. When the “Do you want to save your changes” prompt appears click “Yes” or “No” 

 

Note: The “Do you want to save your changes” appears even if the file was recently saved. 
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Import a File 

1. In the menu bar click File → Import → From CSV (or …) 

 

2. In the “Select CSV File” window, navigate to the desired folder, select  the desired file name, 

and click “OK” 

 

NOTE:  

1. Though not required, to best import an XLSX or CSV file, the file should be formatted as 

shown in the following figure.  It is recommended that the user export an existing 

NTSC/NTSD file to XLSX to use as the basis for modifying an XLSX (or CSV) file that 

can be easily imported to Pervideo.  Similar conditions and recommendations exist for 

the MAT files. 

2. CSV and XLSX files formatted in a manner other than shown below, will be imported if 

a distinct contiguous numeric table/matrix is detected.  If header information is not 

detected, default header information will be applied which can be changed within the 

app, and your files header information will be saved to the app’s “File Notes”. 

3. To import Custom Instrument files, click File → Import → Other Files → {desired file 

type} 
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Export a File 

1. In the menu bar click File → Export → To XLSX (or …) 

 

1. In the “Save File As” window, navigate to the desired folder, enter the desired name in the 

“File name” field, and click “OK” 

 

Exit the Application 

1. In the menu bar click File → Exit 

2. If the “File Save Warning” prompt appears click “Continue” or “Cancel” 
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5. EDIT MENU 

The Edit Menu is composed of several functions to add, modify, and condition channel data.  

The menu items and corresponding functions are defined below: 

• Compress Data: compresses the open file’s data channels  

• Smooth Channels: smooths the open file’s data channels 

• Add Base Channel: adds a channel to the file by simulating a continuous waveform: sine 

wave, square wave, etc. 

• Add Event Channel: adds a channel to the file that indicates some stated of another 

channel: channel greater than a value, less than a value, etc. 

• Add Math Channel: adds a channel to the file that performs some mathematical operation 

on a single file or multiple files 

• Move Channel: moves a channel’s position within a channel group 

• Delete Channel(s): deletes one or more channels from a file 

• Rename Channel(s): renames one or more channels in a file 

• Edit Channel Info: modifies channel information within a file 

• Edit Start Time: modifies that files start date and time 

 

Compress Data 

The “Compress Data” function compresses all channels of the open file using the desired 

compression option 

1. In the menu bar click Edit → Compress Data 

2. Select the “Compression Factor” and “Compression Type” and click “OK” 
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Smooth Channels 

The “Smooth Channels” function all or select number of channels.  This smoothing functions is 

done on the underlying channel data in memory and cannot be undone (without closing the file 

without saving). 

1. In the menu bar click Edit → Smooth Channels → Select Channels (or All Channels) 

2. Select the “Channel Smoothing” prompt, select the “Filter Type”, “Sample Width” and 

desired “Channels” and click “OK”.   

 

Add Base Channel 

The “Add Base Channel” function adds a channel to the file’s base channels using the desired 

simulation or channel operation function. 

 

Mask Existing Channel 

The “Mask Existing Channel” function adds a channel to the “Base Channels” by copying an 

existing channel and hiding the portions of the channel that are not classified as an “event” based 

on the event channel selected or occur within the time range selected. 

1. In the menu bar click Edit → Add Base Channel → Mask Existing Channel 

2. Select the “Mask Channel” and “Event Channel” and click “OK” 
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Simulate Sine Wave 

The “Simulate Sine Wave” function adds a channel to the “Base Channels” by simulating a sine 

wave. 

1. In the menu bar click Edit → Add Base Channel → Simulate Sine Wave 

2. When the “Sine Waveform Selections” prompt appears, make the desired entries and 

selections and click “OK” 

 

3. In the “Plot Selections → Plot N → Base Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

Note: Sine wave, shown below, was added to Base Channel 2 and displayed on Plot 2. 
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Simulate Square Wave 

The “Simulate Square Wave” function adds a channel to the “Base Channels” by simulating a 

square wave. 

1. In the menu bar click Edit → Add Base Channel → Simulate Square Wave 

2. When the “Square Waveform Selections” prompt appears, make the desired entries and 

selections and click “OK” 

 

3. In the “Plot Selections → Plot N → Base Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  
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Note: Square wave, shown below, was added to Base Channel 1 and displayed on Plot 1. 

 

 

Simulate Triangle Wave 

The “Simulate Triangle Wave” function adds a channel to the “Base Channels” by simulating a 

square wave. 

1. In the menu bar click Edit → Add Base Channel → Simulate Triangle Wave 

2. When the “Triangle Waveform Selections” prompt appears, make the desired entries and 

selections and click “OK” 
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3. In the “Plot Selections → Plot N → Base Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

Note: Triangle wave, shown below, was added to Base Channel 3 and displayed on Plot 3. 

 

 

Simulate Sawtooth Wave 

The “Simulate Sawtooth Wave” function adds a channel to the “Base Channels” by simulating a 

square wave. 

1. In the menu bar click Edit → Add Base Channel → Simulate Sawtooth Wave 

2. When the “Sawtooth Waveform Selections” prompt appears, make the desired entries and 

selections and click “OK” 
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3. In the “Plot Selections → Plot N → Base Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

Note: Square wave, shown below, was added to Base Channel 4 and displayed on Plot 4. 

 

 

Simulate Pulse Train 

The “Simulate Pulse Train” function adds a channel to the “Base Channels” by simulating a 

square wave. 

1. In the menu bar click Edit → Add Base Channel → Simulate Pulse Train 
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2. When the “Pulse Train Selections” prompt appears, make the desired entries and selections 

and click “OK” 

 

3. In the “Plot Selections → Plot N → Base Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

Note: Pulse train, shown below, was added to Base Channel 5 and displayed on Plot 2. 
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Add Event Channel 

The “Add Event Channel” function adds a channel to the file’s event channels using the desired 

event flag triggering selections. 

 

Greater Than Value 

The “Greater Than Value” function adds a channel to the “Event Channels” by simulating an 

event waveform whose value equals “1” when the event is occurring and value equals “0” when 

it does not. 

1. In the menu bar click Edit → Add Event Channel → Greater Than Value 

2. When the “Greater Than Event Settings” prompt appears, make the desired entries and 

selections and click “OK” 

 

3. In the “Plot Selections → Plot N → Event Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  



EDIT MENU 

 

 

Pervideo SW Manual  (ed. 1 v. 4)  36 

Copyright © 2021 Byte Reconnaissance LLC 

 

Note: notice the event flag overlap created by the “Pre/Post Event Padding” this is helpful to 

prevent erroneous event identification due to noisy signals 

 

 

Less Than Value 

The “Less Than Value” function adds a channel to the “Event Channels” by simulating an event 

waveform whose value equals “1” when the event is occurring and value equals “0” when it does 

not. 

1. In the menu bar click Edit → Add Event Channel → Less Than Value 

2. When the “Less Than Event Settings” prompt appears, make the desired entries and 

selections and click “OK” 

 

3. In the “Plot Selections → Plot N → Event Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  
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Note: notice the event flag overlap created by the “Pre/Post Event Padding” this is helpful to 

prevent erroneous event identification due to noisy signals 

 

 

Between Values 

The “Between Values” function adds a channel to the “Event Channels” by simulating an event 

waveform whose value equals “1” when the event is occurring and value equals “0” when it does 

not. 

1. In the menu bar click Edit → Add Event Channel → Between Values 

2. When the “Between Values Event Settings” prompt appears, make the desired entries and 

selections and click “OK” 

 

3. In the “Plot Selections → Plot N → Event Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  
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Note: notice the event flag overlap created by the “Pre/Post Event Padding” this is helpful to 

prevent erroneous event identification due to noisy signals 

  

 

Outside of Values 

The “Outside of Values” function adds a channel to the “Event Channels” by simulating an event 

waveform whose value equals “1” when the event is occurring and value equals “0” when it does 

not. 

1. In the menu bar click Edit → Add Event Channel → Outside of Values 

2. When the “Outside Values Event Settings” prompt appears, make the desired entries and 

selections and click “OK” 

 

3. In the “Plot Selections → Plot N → Event Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  
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Note: notice the event flag overlap created by the “Pre/Post Event Padding” this is helpful to 

prevent erroneous event identification due to noisy signals 

 

 

 

Add Math Channel 

The “Add Math Channel” function adds a channel to the file’s math (or base) channels using the 

desired math calculation selections. 

 

Add Channels 

The “Add Channels” function adds a channel to the “Math Channels” group by adding two 

channels to each other. 

1. In the menu bar click Edit → Add Math Channel → Add Channels 

2. When the “Add Channel Settings” prompt appears, make the desired entries and selections 

and click “OK” 

Note: (1) a scaling factor can be applied to either channel; (2) the resulting channel can be 

applied to the “base” channels group or “math” channels group.  Channel math information is 

kept with the corresponding channel information in the “math” channel group.  If “base” 

channels is selected, this channel math information is lost, see FILE NAVIGATION  for more 

information. 



EDIT MENU 

 

 

Pervideo SW Manual  (ed. 1 v. 4)  40 

Copyright © 2021 Byte Reconnaissance LLC 

 

 

3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Subtract Channels 

The “Subtract Channels” function adds a channel to the “Math Channels” group by subtracting 

two channels from each other. 

1. In the menu bar click Edit → Add Math Channel → Subtract Channels 

2. When the “Subtract Channel Settings” prompt appears, make the desired entries and 

selections and click “OK” 

Note: (1) a scaling factor can be applied to either channel; (2) the resulting channel can be 

applied to the “base” channels group or “math” channels group.  Channel math information is 

kept with the corresponding channel information in the “math” channel group.  If “base” 

channels is selected, this channel math information is lost, see FILE NAVIGATION  for more 

information. 
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3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Multiply Channels 

The “Multiply Channels” function adds a channel to the “Math Channels” group by multiplying 

two channels to each other. 

1. In the menu bar click Edit → Add Math Channel → Multiply Channels 

2. When the “Multiply Channel Settings” prompt appears, make the desired entries and 

selections and click “OK” 

Note: (1) a scaling factor can be applied to either channel; (2) the resulting channel can be 

applied to the “base” channels group or “math” channels group.  Channel math information is 

kept with the corresponding channel information in the “math” channel group.  If “base” 

channels is selected, this channel math information is lost, see FILE NAVIGATION  for more 

information. 
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3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Divide Channels 

The “Divide Channels” function adds a channel to the “Math Channels” group by dividing two 

channels to each other.  Note: be mindful of divide zero responses; when dividing waveforms 

zero is defined as 1e-6. 

1. In the menu bar click Edit → Add Math Channel → Divide Channels 

2. When the “Divide Channel Settings” prompt appears, make the desired entries and selections 

and click “OK” 

Note: (1) a scaling factor can be applied to either channel; (2) the resulting channel can be 

applied to the “base” channels group or “math” channels group.  Channel math information is 

kept with the corresponding channel information in the “math” channel group.  If “base” 
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channels is selected, this channel math information is lost, see FILE NAVIGATION  for more 

information. 

 

3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Polynomial Convert Channels 

The “Poly Convert Ch” function adds a channel to the “Math Channels” group by performing 

polynomial conversion on the selected channel. 

1. In the menu bar click Edit → Add Math Channel → Poly Convert Ch → X Order Poly Conv 

2. When the “X Order Poly Coeff Selections” prompt appears, make the desired entries and 

selections and click “OK” 
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3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Convert to Log Base 10 Channel 

The “Convert to Log 10 Ch” function adds a channel to the “Math Channels” group by 

performing polynomial conversion on the selected channel. 

1. In the menu bar click Edit → Add Math Channel → Convert to Log 10 Ch 

2. When the “Log 10 Conv Coeff Selections” prompt appears, make the desired entries and 

selections and click “OK” 
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3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Convert to Log Base 2 Channel 

The “Convert to Log 2 Ch” function adds a channel to the “Math Channels” group by performing 

polynomial conversion on the selected channel. 

1. In the menu bar click Edit → Add Math Channel → Convert to Log 2 Ch 

2. When the “Log 2 Conv Coeff Selections” prompt appears, make the desired entries and 

selections and click “OK” 
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3. In the “Plot Selections → Plot N → Math Ch 0X” tree branch click the “Show/Hide” icon.  

Once clicked, the channels trace is shown on the screen.  

 

 

Move Channel 

The “Move Channel” function moves a channel to the within its channel group.  This allows for 

reordering of channels as desired by the user. 

1. In the menu bar click Edit → Move Channel → {Base, Event, or Math} Channel 

2. When the “Move Channel Selections” prompt appears, make the desired entries and 

selections and click “OK”.  Note: this step will clear the Channel Display Panel, but no data 

will be lost, other than what was selected to delete. 
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3. When the Channel Display Panel clears (shown below), change the desired plots and 

channels “Show/Hide” feature accordingly to show the desired channels in the Channel 

Display Window.  
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Delete Channel(s) 

The “Delete Channel(s)” function deletes a desired channel or channels 

1. In the menu bar click Edit → Delete Channel(s) 

2. When the “Delete Channel Selections” prompt appears, make the desired selections and click 

“OK”.  Note: this step will clear the Channel Display Panel, but no data will be lost, other 

than what was selected to delete. 

 

3. When the Channel Display Panel clears (shown below), change the desired plots and 

channels “Show/Hide” feature accordingly to show the desired channels in the Channel 

Display Window.  
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Rename Channel(s) 

The “Rename Channel(s)” function renames a desired channel or channels 

1. In the menu bar click Edit → Rename Channel(s) 

2. When the “Rename Channel Selections” prompt appears, make the desired selections and 

click “OK”.  Note: (1) multiple channels can be renamed at a time; (2) this step will clear the 

Channel Display Panel, but no data will be lost. 

 

3. When the Channel Display Panel clears (shown below), change the desired plots and 

channels “Show/Hide” feature accordingly to show the desired channels in the Channel 

Display Window.  

 

 

Edit Channel Info 

The “Edit Channel Info” function modifies the name, unit, and/or scale of the desired channel or 

channels 
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1. In the menu bar click Edit → Edit Channel Info 

2. When the “Channel Info Modifications” prompt appears, make the desired selections and 

click “OK”.  Note: (1) multiple channels can be edited at a time; (2) this step will clear the 

Channel Display Panel, but no data will be lost. 

 

3. When the Channel Display Panel clears (shown below), change the desired plots and 

channels “Show/Hide” feature accordingly to show the desired channels in the Channel 

Display Window.  

 

 

Edit Channel Comments 

The “Edit Channel Comments” function allows user to add/edit notes to individual channels.  

This is a useful feature that allows users to enter information about the respective channels in 

plain text. 

1. In the menu bar click Edit → Edit Channel Comments 
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2. When the “Channel Comment Updates” prompt appears, make the desired entries/edits and 

click OK.   

Note: multiple channels can be edited at a time, with no impact to displayed channels. 

 

 

Edit Start Time 

The “Edit Start Time” function modifies the start time of the file.  This is used to correct any 

absolute timing issues of the data source. 

1. In the menu bar click Edit → Edit Start Time 

2. When the “File Start Update” prompt appears, make the desired selections and click “OK”.  

Note: modifying the file start date/time requires the file to be saved as a new file. 

 

 

Edit File Notes 

The “Edit File Notes” function allows user to add/edit notes to the open file.  This is a useful 

feature that allows users to enter information about the file in plain text. 
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1. In the menu bar click Edit → Edit File Notes 

2. When the “Edit File Notes” prompt appears, make the desired entry/edit and click OK. 

 

 

6. VIEW MENU 

The View Menu is composed of functions to modify and refresh the channel display panel.  The 

menu items and corresponding functions are defined below: 

• Refresh Layout: refreshes the channel display panel  

• Arrange Layout: changes the number of plots shown in the channel display panel 

 

Refresh Layout 

The “Refresh Layout” function, refreshes the “Channel Display Panel”.  This function should be 

used if the window did not resize or refresh correctly after moving or resizing the application. 

1. In the menu bar click View → Refresh Layout 

 

Arrange Layout 

The “Arrange Layout” changes the number of plots shown in the “Channel/Trace Display 

Window”.  Up to 4 plots can be displayed at the same time. 

1. In the menu bar click View → Arrange Layout → desired layout (1x View, 2x View, 3x 

View, 4x View) 

2. The application window will update to show selected layout; “4x View” shown here. 
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7. TOOLS MENU 

The Tools Menu is composed of special application functions available to the user.  The menu 

items and corresponding functions are defined below: 

• Preferences: allows the user to modify special application settings 

• Split File(s): splits an individual file(s) into smaller files 

• Concatenate Files: concatenates multiple files into a single file; files must be of the same 

channels structure but sampled over non-overlapping time periods 

• Recalc Ch Stats: recalculates the channel statistics and updates the channel metadata 

information 

• Get App Logs: opens the log files folder in the windows file explorer 

 

Preferences 

The “Preferences” function allows the user to change the modifiable application defaults and 

constants.  The available items are default sample rate, default sample count, and min/max 

sample count.   

Note the “Maximum Sample Count” is the parameter the application uses to limit the file size 

that the application will open without requiring some level of compression.  When set correctly 

this feature prevents application instability due to large file sizes and available computing 

resources (RAM, virtual memory, etc.). 

1. In the menu bar click Tools → Preferences 

2. When the “Preferences” prompt appears, make the desired selections and click “OK”.   
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Split File(s) 

The “Split File(s)” function will split large files into smaller files to allow for reading into the 

application without the need of compression.  This feature can also be used to reduce the file 

down to a specific area of interest, to be used with other user applications by exporting to MS 

Excel®, Matlab®, and/or CSV. 

1. In the menu bar click Tools → Split File(s) 

2. When the “Select NTS Files” prompt appears, select the desired file(s) and click “Open”.   

 

3. When the “File Split Settings” prompt appears make the desired selections and click “OK” 

Warning: sample counts greater than the “App Max Sample Count” may cause 

application instability and unresponsiveness. 

 

4. Wait for the application to complete the file operations.  A progress bar will appear 

indicating the progress of the individual file split. 

Note: if more than one file is being split from a single operation, the progress bar will 

reappear; one per file to split. 

 

5. When completed the prompt will appear indicating the file operation is complete. 
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6. The new files will be located in the same directory as the original files, and will carry the 

same base file name, but will have a sequential number included in the file name along with 

update time stamps indicating the start of the individual files 

 

 

 

Concatenate Files 

The “Concatenate Files” function will concatenate files into a larger file to allow for reading 

multiple files as a single file.  This feature is typically used to see a data trend collected over 

multiple data files.  Additionally, compression may be needed to view the resulting file. 

1. In the menu bar click Tools → Concatenate Files 

2. When the “Select NTS Files” prompt appears, select the desired files and click “Open”.   

 

3. You will be prompted to export the files’ metadata.  When the “Export consolidated meta 

data?” prompt appears make the desired selection. 

Note: if the files to be concatenated are not of the same channel count, type, etc. a “File 

concatenation validation failed” error message will appear, indicating the file 

mismatch.  If this error is encountered you will be prompted to export the files’ 

metadata before this process is aborted. 
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4. If you select to export the metadata, you will be prompted to determine where to save the 

file.  When the “Save File As” prompt appears, select the desired directory and file name and 

click “Save” 

5. If the “Compression Factor Selections” prompt appears select the desired compression 

options and click “OK”. 

Note: If you determine you do not want to have the resulting file compressed, click 

cancel and update the application preferences accordingly (application maximum 

limitations apply, see preferences section for more information.) 

 

6. Wait for the file concatenation process to complete.  Multiple progress bars may appear 

depending on the data in the files. 

 

7. In the “Save File As” window, navigate to the desired folder, enter the desired name in the 

“File name” field, and click “OK” 

Note: the application will automatically append the entered file name with the timestamp of the 

file.  The file timestamp is the start date and time shown in the file’s header information in 

“yyyymmdd_HHMMSS” format.  Additionally concatenated files are saved as NTSD files, 

because the files selected may not represent a continuous time samples. 
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8. When completed a prompt will appear indicating the file operation is complete. 

 

 

 

Recalc Ch Stats 

The “Recalc Ch Stats” function recalculates the channel statistics and updates the channel 

metadata information contained in the file navigation tree’s file information branches.  Execute 

this function if you believe the channels statistics contained with the metadata are incorrect. 

1. In the menu bar click Tools → Recalc Ch Stats 

2. Depending on the file size and number of channels this process will complete very quickly.  

The application status window will show a change in status accordingly. 
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Get App Logs 

The “Get App Logs” function opens the log files folder in the windows file explorer application.   

Note there are 2 logs generated every time the application opens: a Pervideo Application Log 

(PAL) and Pervideo Error Log (PEL).  The activity log is to help the user track what the 

application was tasked to do.  The error log is to provide feedback to the developer on errors 

encountered.  Please note, the app only generates an error log and logs error messages; 

communicating the errors back to the developer is at the discretion of the application’s user. 

1. In the menu bar click Tools → Get App Logs 

2. A File Explorer window will appear, similar to the one below. 
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8. HELP MENU 

The Help Menu is composed of functions to provide application instructions and development 

information to the user.  The menu items and corresponding functions are defined below: 

• Help: opens this help file using the computer’s Portable Document Format (PDF) reader 

• About: opens a prompt showing the application’s version and legal information 

 

Help 

The “Help” function opens this help file using the computer’s Portable Document Format (PDF) 

reader. 

1. In the menu bar click Help → Help 

2. Wait for the PDF to open. 

 

About 

The “About” function opens a prompt showing the application’s version and legal information. 

1. In the menu bar click Help → About 

2. A prompt similar to the one below should appear. 

 

3. Click either of the available buttons to view their respective documents or click the “X” at 

the top right-hand corner to close the prompt. 
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9. FILE NAVIGATION PANEL 

The File Navigation Panel is an application navigation tree used to configure the channels to 

view and view the file and channel information.  The branches and corresponding functions are 

defined below: 

• Plot Selections Branch: configures the various plots with the channels to be viewed and 

modifies the viewed trace(s) and conditions the viewed channels 

• File Info Branch: provides basic file metadata and unique channel metadata 

 

Plot Selections Branch 

The “Plot Selections” branch provides the functionality to view and condition displayed 

channels.  The “Plot Selections” branch consists of four “Plot N” branches that consist of the 

branches of channels contained in the data. 

 

The individual “plot/channel” branches contain the following functions to show, modify, and 

condition individual channels. 

• Show/Hide: adds/removes the respective channel from the plot.  The function also 

updates the “Visible” state field accordingly. 

• Magnify: presents the user with the magnification prompt below to scale the respective 

channel accordingly.  This function does not affect the underlying data and allows the 

user to compare waveforms of dissimilar scales to each other to better compare waveform 
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similarities and differences.  The function also updates the “Magnification” state field 

accordingly. 

 

• Smooth: presents the user with the smoothing prompt below to smooth the respective 

channel accordingly.  This function does not affect the underlying data and allows the 

user to remove the noise from the channel without affecting the actual channel data.  The 

function also updates the “Smooth Window” state field accordingly. 

 

• Line Style: presents the user with the line selections prompt below to modify the 

respective channel accordingly.   
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• Plot Expand/Collapse Options: allows the user to expand/collapse individual plot 

branches.  To exercise them, right-click on “Plot Selections” or any of the “Plot N” 

branches and click on the desired option 
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File Info Branch 

The “File Info” branch provides the functionality to the file and channels’ metadata.  The “File 

Indo” branch consists of four sub-branches that contain the metadata of the respective file data. 

 

The individual sub-branches contain the following information about the file 

• Header: contains generic file metadata not specific to any channel: file name, file type, 

start data/time, sampling info, compression info, and channel counts 

• Base Channels: contains the metadata of individual base channels: channel name and 

number, units, scale, smoothing, event info, and waveform statistics 
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• Event Channels: contains the metadata of individual event channels: channel name and 

number, source channel info, and event characteristics and statistics 
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• Math Channels: contains the metadata of individual math channels: channel name and 

number, units, scale, smoothing, math info, and event info 

 

• File Info Expand/Collapse Options: allows the user to expand/collapse file information 

branches.  To exercise them, right-click on any of the file information branches: “File 

Info”, “Header”, “Base Channels”, “Event Channels”, or “Math Channels” 
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Plot Navigation Panel Resizing 

The “File Navigation Panel” can be resized to allow for increased visibility to the plot and file 

information.  To expand/reduce the panel simply click and drag the panel resizing handle (circled 

in the image below) and drag right or left to increase or decrease the panel width respectively. 
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10. CHANNEL DISPLAY PANEL 

The Channel Display Panel is the right side of the application where channel data is viewed and 

navigated through.  The major features of the Channel Display Panel are defined below: 

• Channel Display Area: the area where channels/traces are displayed in one more plots 

arranged vertically 

• Channel Navigation: the area where the buttons used to zoom in/out and traverse a file  

• Data Tips: the buttons that enable the displaying of text boxes containing X-Y 

information about a selected data point 
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Zooming In & Out 

The “Channel Navigation Buttons” allow the user to zoom in/out and traverse a file.   

1. To “zoom in” horizontally, click the “Horizontal Zoom In” button (in green below) 

2. Using your mouse, click and hold the left-click mouse button, drag the mouse to the right 

or left, and release the left-click button. 

Additionally you may place the mouse pointer over one of the plots and press the 

mouse’s left-click button one or more times to zoom in horizontally 

 

3. The “Channel Display” panel should now appear similar to the one shown below 
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4. To “zoom out” horizontally, place the mouse pointer over one of the plots and press the 

mouse’s left-click button one or more times to zoom out horizontally. 

5. To zoom in/out vertically, repeat these steps using the vertical zoom buttons 

6. To reset the displayed channels in all directions horizontally and vertically, click the 

“Zoom Reset” button: 

7. To move across the channels horizontally, click the “move left/right” button (         ), 

place the mouse pointer over one of the plots, and press and the mouse’s left-click button 

while moving the mouse to the left or right. 

 

Data Tips 

Data Tips enable the displaying of text boxes containing X-Y information about a selected data 

point. 

1. To enable a data tip, click the “Enable Data Tips” button (in green below) 

2. Using your mouse, left-click at a point along an individual channel.  A data tips 

containing the absolute and relative position of the data point selected should appear. 

 

3. To display more than on data tip, hold the {Shift} key and left-click at another point 

along an individual channel. 

4. To delete an individual data tip, left-click on the desired data tip and press the 

{DELETE} key 

5. To delete all data tips click the “Clear Data Tips” button:  
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Partial File Loading 

Partial File loading allows the user to load parts of very large files that will not load in the 

application without compressing them to reduce their sample size.  On-load compression and 

partial file loading work with user preferences and are essential for stable application 

performance for extremely large files.  The default user sample limit preferences are chosen for 

most efficient application performance. 

Note: users are strongly encouraged to modify the sample preferences and use the “on-load 

compression” and “partial file loading” to best enable them to best work within the constraints of 

their data sets.  Finally, it make take some experimentation to determine the sample limit 

preferences that works best with you and your machine. 

1. To enable partial file loading, click the “File Load Mode” button, such that the shortened 

trace view is shown:   

2. Click on the “File Reload” button:  

3. When the “Partial File Load Settings” prompt appears, make the desired file load 

start/stop settings and click “OK”. 

 



CHANNEL DISPLAY PANEL 

 

 

Pervideo SW Manual  (ed. 1 v. 4)  72 

Copyright © 2021 Byte Reconnaissance LLC 

 

4. Show/Hide the desired channels.  Notice samples loaded will be less than the total file 

length time, displayed in the Header information.   

 

 

5. To return to normal file loading (on-load compression), click the “File Load Mode” 

button, such that the long trace view is shown:   
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11. ACRONYMS & ABBREVIATIONS 

The following defines key acronyms used in this document: 

Acronym Definition 

CSV Comma Separated Variables 

HHMMSS Time of Day Time Stamp in hour, minute, seconds format 

hrs Hours 

MAT Mathworks MATLAB® File Type 

min Minutes 

NTSC Numeric Time Series, Continuous 

NTSD Numeric Time Series, Discrete 

msec Milli-seconds 

nsec Nano-seconds 

Sec Seconds 

usec Micro-seconds 

XLSX Microsoft® Excel File Type 

yyyymmdd Date Time Stamp in year, month, day format 
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12. DEFINITIONS 

The following defines key term used in this document: 

Term Definition 

Base Channel Channel/Trace the represents some recorded, simulated or 

acquired data. 

Compression Compression method where the file size is reduced by removing 

“N” number of samples and replacing the “Nth” sample with the 

average of the “N” samples removed; e.g. for a compression 

factor of 10, samples 1-10 are deleted and sample 10 is replaced 

with the average value of samples 1-10. 

Compression Factor The number of samples to reduce a file size by; e.g. for a 

compression factor of “10”, “9” samples are removed and “1” 

sample remains reducing the data set (and file size) by a factor 

of “10” 

Compression Method Method that reduces the file size by removing and replacing the 

sample data in some specified manner: compression or 

decimation 

Data Tip Text box containing X-Y information about a selected data 

point. 

Decimation Compression method where the file size is reduced by removing 

“N-1” number of samples and leaving the Nth sample behind; 

e.g. for a compression factor of 10 samples 1-9 are deleted and 

sample 10 is left behind. 

Event Channel Channel/Trace the represents some user defined condition 

occurring. The channel level is equal to “1” (true) during the 

time period when the event occurs, and is equal to “0” (false) all 

other times. 

Math Channel Channel/Trace created by an algebraic operation between one or 

more channels.  Channel may be made of nesting multiple math 

channel operations. 

NTSC File Continuous Numeric Time Series file type, whose samples are a 

continuous sequence of samples separated in time by a fixed 

sample rate/period.   

 

For these file types, the sample rate included in the “Header → 

Sample Rate” field is the sample rate of the data within the file. 

This file type does not contain a time axis vector included in the 

file. 
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Term Definition 

NTSD File Discrete Numeric Time Series file type, whose samples are a 

discrete sequence of samples separated in time by a one or more 

sample rates/periods, corresponding to distinct sampled data 

files.  

 

This file type is generally created when files are merged, and 

may include significant gaps in time samples corresponding to 

gaps in time between start and end of neighboring files. 

 

For these file types, the sample rate included in the “Header → 

Sample Rate” field is irrelevant.  

Smoothing Statistical/Mathematical method to reduce the noise contained in 

the channel/trace data 

Smoothing Factor The “N” number of samples to perform the smoothing operation 

on, e.g. for a smoothing factor of “10” every sample along the 

channel is replaced with the average (smoothing operation) 

value of the 10 points neighboring the sample 

Smoothing Filter Statistical/Mathematical method, sample weighting method, to 

apply the smoothing operation.  Smoothing Filter options 

include: rectangle, triangle, and Gaussian 

yyyymmdd_HHMMSS Time Stamp used in this application which follows the year, 

month, day, underscore (“_”), hour, minute, second format 
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13. ICONS 

The icons used in the software application are listed below 

Icon Icon Name Button Function 

 

Startup Shortcut PervideoTM Startup icon 

 

Taskbar Icon App taskbar icon 

 

Refresh Zoom Zooms out to view the entire trace/channels in both 

X and Y axes 

 

Horizontal Zoom In Enables/Disables the user to zoom in along the X-

axis 

 

Horizontal Zoom Out Enables/Disables the user to zoom out along the X-

axis 

 

Vertical Zoom In Enables/Disables the user to zoom in along the Y-

axis 

 

Vertical Zoom Out Enables/Disables the user to zoom out along the Y-

axis 

 

Move left/right Enables/Disables the user to move/drag the traces 

along the X-axis 

 

Enable data tips Enables/Disables the add data tip feature, which 

places an information block of the point along the 

trace that was clicked 

 

Clear data tips Clears all data tips 

 

Reload Open File Reloads open file to application 

 

File Load Mode Enables/Disables file load mode: full file or partial 

file 

 

Edit Channel Comments Allows user to apply plain text comments to 

channels.  Usually present when adding event and 

math channels 
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14. KEYBOARD SHORTCUTS 

The keyboard shortcuts available in the software application are listed below 

Keyboard Shortcut Action 

<CTRL> + <s> Save current file 

<CTRL> + <o> Open file 

<CTRL> + <r> Reload current file 

<CTRL> + <n> Create new file 

<CTRL> + <SHIFT> + 
<a> Save current file as new file 

<CTRL> + <w> Close current file 

 


