
Changed in release 2.41 (12th April 2021)
-----------------------------------------

Artwork validation:

  o The artwork validation tool may now be accessed from a button on the artwork
toolbar in addition to the
    normal menu entry.

  o An 'Revalidate Artwork' function has been added to the 'Check' submenu and 
the artwork toolbar.
    This allows the artwork to be revalidated using the existing configuration 
values.  The configuration
    and progress dialog is not displayed, and progress of the validation tool is
indicated by a progress
    bar within the artwork toolbar.

  o Artwork validation now writes all errors and warnings into the 
'artwork_validation' report file in the
    design's 'Log Files' folder.  Whenever errors or warnings occur, the report 
file is automatically opened
    for viewing.

  o The artwork validation report has been improved to add more information to 
aid in the identification of
    detected problems.

  o The artwork validation report file now contains clickable links throughout 
the various report sections.
    Clicking on these links will pan/zoom the artwork to the location identified
in the report.

  o BUGFIX: The artwork validation tool was showing erroneous short circuits 
near the edge of copper
    filled regions.

Artwork editor :

  o BUGFIX: The 'Tools->Network->Pin Swap' command was not ripping tracks 
associated with the second of
    the two pins selected for swapping. There was also the possibility that 
tracks would be ripped from
    other nets not associated with the selected pins, or that duplicate net 
nodes would appear in the
    net list.

  o BUGFIX: When loading a design that had originated from the earlier RangerXL 
product, incorrect style
    pads were being shown on some part pins where the "Amend->Replace Pad" had 
been used in the RangerXL
    system to restyle the pin.

General system :



  o BUGFIX: A design that had internal inconsistencies in its schematic was 
causing a program crash at
    design load time.  Error handling of schematic inconsistencies has now been 
improved and an error
    report will be displayed after loadup.

Schematic editor :

  o BUGFIX: If a schematic symbol contained a power pin that was also mentioned 
in the
    'Attributes->Symbol->Part Power Pins' table for the part (blind power pins),
then a duplicate net node
    would appear in the net list after schematic compilation.  The duplicated 
nodes were then reported as
    'unrouted' by the artwork validation tool.

  o Added display of the cursor X/Y position to the top status bar to assist in 
the location of errors that
    are reported by X/Y coordinate.  Also added 'Units' selection to the Edit 
menu to enable the X/Y display
    to be switched between inch and metric modes.

Design netlist :

  o Any duplicate nodes found within a net will now be deleted at design load 
time.

Electra / Specctra autorouter interface :

  o A program crash was occuring when importing the routing result.

Parts list editor :

  o The ability to save files in .CSV format has been added to the "File->Save 
Parts List as Text" dialog.
    Also added checkboxes to control the inclusion of a column headings row and 
the .PARTS / .ENDPARTS tags.

Changed in release 2.40 (15th February 2021)
--------------------------------------------

General system :

  o BUGFIX: If a schematic sheet was renamed, and the sheet then opened using 
the right-click popup menu,
    then a crash would occur.  The problem did not affect opening a renamed 
sheet by double-clicking
    on its name.

Artwork checker:

  o The artwork validation tool has been completely recoded to improve its 
checking speed and accuracy of



    short circuit location.  The short-circuit checking 'cancel' button has been
removed as this part of
    the verification process can no longer go into a deadlock state as could 
happen with the previous
    implementation.  Work is still ongoing to implement checking of 'slots' and 
'extra hole' data, and
    a warning will still be raised when validating a board that uses these 
features.

  o Track angle checking is now performed in the new artwork validation tool, 
and an option has been added
    to the tool dialog to allow configuration of the permitted track angles.

  o Angle errors will no longer be displayed for track segments that are 
completely covered by a part pad
    or via hole.

  o BUGFIX: Angle checking was showing track angle errors for 'partial unroute' 
features at the beginning
    and end of a track.

  o BUGFIX: The 'text in autoplace footprint bounds' check did not work in the 
previous artwork checker.

Artwork editor :

  o The artwork checking tool is now named 'Validation Tool' in the 'Check' 
submenu.

  o The angle check 0/90 and 0/45/90 commands have been removed from the 'Check'
menu and track angle checking
    is now performed by the artwork validation tool.

  o BUGFIX: Gap clearance markers did not display correctly when the artwork 
display was in flipped mode.

  o CRITICAL BUGFIX: If the usage of a layer was changed from copper to 
powerplane after a user defined via hole
    had been designed with a drill range spanning the new powerplane layer, then
no heat relief or antipad was
    being shown or generated by the powerplane tool.

  o BUGFIX: Unroutes were being shown on some boards even though the artwork 
checker indicated that the board
    routing was complete and correct.

CNC Drill output and drill sheet generation :

  o CRITICAL BUGFIX : If the drilling configuration for a user via hole 
definition was set as
    'Include in drill data set' and "[DS01] Through-plated drill holes", then 
the holes were not appearing in the
    CNC or drill sheet outputs.
    (The holes appeared correctly if the via was configured as 'Include in 



Through-Board' drill data).

  o A 'Reset all tool codes' button has been added to the 'CNC Tool Parameters' 
configuration dialog to allow
    all tool definitions to be returned to the 'Undefined' state.

Gerber artwork output :

  o BUGFIX: If the heat relief 'Track Width, Clearance & Channel Width' 
configuration parameters were all set to
    zero for a a drill size range, then a small square was appearing in the 
Gerber output around the drill hole.
   

Changed in release 2.30 (25th March 2020)
-----------------------------------------

Schematic editor:

  o BUGFIX: An 'improper argument' error was being displayed when trying to 
place a power symbol.
    (Problem inadvertantly introduced by associated code fix in release 2.29)

Outline editor:

  o BUGFIX: There was a possibility of data corruption to outline definitions 
while outline pin numbers
    were being assigned.

Changed in release 2.29 (24th March 2020)
-----------------------------------------

CNC drill outputs and Gerber artwork output alignment improvements:

  XLDesigner's Gerber output facility presents the user with a preview window 
displaying a white media area
  whose size represents the media dimensions configured in the 'Output device 
setup->Properties' dialog.
  The bottom left hand corner of the media area is represented by the location 
X=0/Y=0 in the generated
  Gerber file.  Because of this, the coordinates of features in the generated 
Gerber data will not correspond
  with the coordinates of those features in the artwork editor or in generated 
drill output data.
  However, the Gerber outputs have always operated in this way as in the past, 
customers needed to be able
  to exercise complete control over the photoplotting of their artworks and the 
positioning of the plot on
  the output media, which was normally film.

  To fit in better with modern workflows, the default behaviour in XLDesigner is
to now ensure that the



  coordinates in CNC drill data and Gerber artwork data are aligned, with the 
user being able to specify the
  location of the X=0/Y=0 common datum point for the drill & gerber outputs.

  The artwork and profile editors now display the CNC/Gerber output common datum
location as a small white
  square with an X inside.  The default position of this datum is at the system 
X0,Y0 location, and may be
  changed using the 'Tools->Set CNC Datum' command.  The CNC Datum mark may be 
hidden using the View menu.

Other changes:

General system :

  o BUGFIX: When opening a design created with XLDesigner version 2.21 or 
earlier, any CNC router paths
    that had been defined are automatically converted into 'slot' features.  
However, the slots should have
    been assigned to the 'DS2 Non-Plated' CNC dataset, but were being wrongly 
allocated to the DS1 Plated
    dataset.  Also, when such a conversion is performed at design open, then 
slot visibility is forced on
    in the artwork editor so that the imported router paths can be seen.

  o BUGFIX: The 'File->System Setup' dialog was allowing the same key to be 
assigned to more than one special
    function key action.  This would result in unexpected results.

  o BUGFIX: The 'Move part' special function key never worked regardless of 
which keyboard key was assigned
    to it.  It will now activate artwork part move mode, schematic symbol move 
or schematic split part
    subsymbol move depending on which type of editor window it is invoked from.

Artwork editor:

  o The 'Parts->Set Datum' command (which changed the X/Y display origin and the
origin when querying part
    locations) has been replaced by the 'Tools->Set XY Datum' command.

  o BUGFIX: The angle checker was incorrectly placing error flags on the dotted,
unrouted section at the
    start/end of a partially routed trace.

  o BUGFIX: If the angle checker found errors, it did not switch on the display 
of the error flags if they
    were switched off.

  o BUGFIX: In certain situations, the software became unresponsive when 
entering the split powerplane edit mode.

  o BUGFIX: In the silk screen generator dialog, it was possible to type 'V,T or
B' into the control that selects



    the destination layer for generated component outline or label features.
    If silk screen data was generated with such settings, then the V,T or B 
layer had its reserved layer
    type changed from Copper to Silk Screen, which resulted subsequent failure 
of many other facilities
    throughout the software.  Also, after the reserved layer type had been 
changed, there was no way for the
    user to return the layer type to the correct setting.
    It is still possible to type in V,T or B as a target layer, but the 
situation will now be trapped and no
    data generated or layer assignments disturbed.

Profile editor:

  o The 'Profile->Set X/Y Display Datum' command has been replaced by the 
'Tools->Set XY Datum' command.

Profile & Artwork editor common changes:

  o When the X/Y display datum has been moved away from the system origin, a 
*Datum moved* warning will always
    be shown to the right of the displayed X/Y coordinate.

  o When the X/Y display datum is at the system origin, the yellow datum mark 
will no longer be displayed.

Schematic editor:

  o BUGFIX: When 'Symbol->Power Place' is selected, an automatic check for 
duplicate part identities is performed
    before the part power symbol selection dialog is displayed.  The log file 
for displaying errors detected by
    this test was not being initialised correctly, so if you tried to place 
power symbols for a design having
    duplicate part identities, the software would crash.

Design/Masters Configuration section:

  o A new 'Gerber / CNC Output Options' category has been added.  This new 
configuration dialog currently
    contains just one setting, 'Lock CNC drill & Gerber outputs to CNC datum'.
    If this option is unticked, then the Tools->Set CNC Datum command will be 
greyed out, and the CNC drill
    and Gerber outputs will revert to their previous modes for choice of datum 
point.

CNC drill outputs:

  o BUGFIX: An invalid Y coordinate was sometimes being output for drill holes 
associated with used defined
    via holes.

Drill sheet generator:



  o User defined via holes had a symbol listed in the drill table, but the 
location of the user via holes was
    not being indicated on the drilling sheet.

Changed in release 2.28 (23rd January 2020)
-------------------------------------------

Artwork editor and artwork checker:

  o BUGFIX: If a split powerplane boundary was drawn over the centre of a drill 
hole associated with the
    split pane's net, then a short circuit could result between the two nets on 
either side of the split
    powerplane boundary line, but this was not detected by the artwork checker.
    Also, when designing the split powerplane boundaries, the 'flashing dot' at 
the centre of the drill hole
    would stop flashing suggesting that the pin was properly within the split 
powerplane polygon.

    To correct this situation, a new parameter 'Drill to split powerplane 
minimum clearance' has been added
    to the (Design)->Configuration->Manual Routing Parameters dialog.  This new 
parameter specifies the minimum
    clearance that must exist between the edge of a drill hole and the boundary 
of the split powerplane.

    Any drill hole that violates the configured minimum clearance will now be 
detected by the artwork checker,
    and a 'PP' error flag will be added to the artwork display. In the split 
powerplane designer, the
    'flashing dot' will also continue flashing for drill holes that violate the 
clearance setting.

    The initial default for this new parameter is 0.01 inches, and the default 
value for all new designs may
    also be set in the MASTERS->Configuration->Manual Routing Parameters dialog.

Changed in release 2.27 (17th January 2020)
-------------------------------------------

General system :

  o BUGFIX: It was possible for a design outline to be created with a placed pin
having no pad assigned to
    any pad layer.  This resulted in incorrect operation in the artwork checker 
and Part->Find function.

DXF profile/keepouts importer:

  o BUGFIX: The importer was not correctly handling DXF file LWPOLYLINE 
entities.



  o BUGFIX: The importer was incorrectly importing graphic features defined in 
DXF file sections other than
    the ENTITIES section.

Changed in release 2.26 (2nd December 2019)
-------------------------------------------

CNC drill and Rout data output changes:

  When zero diameter drill holes are detected, the log file 'cnc_drill_rout' is 
now created/updated with location
  information for the affected items.  Also, the zero drill diameter locations 
will not now be output to the
  data file.

  When overlapping drill holes are detected, their location information will now
be written to the 'cnc_drill_rout'
  log file instead of being displayed in the output summary window of the drill 
output dialog.

  Added new 'Output' selector to the output dialog to allow selection of 
outputting drill data only,
  router data only, or both drilling & routing to the output file.

  Added checkboxes to the CNC drill/rout data output dialog to allow control of 
comment insertion into
  the part program header and/or body sections.
  (Please note available Excellon specifications only mention that comments may 
be included in the part program
   header section, and do not mention that they are permitted in the program 
body.
   For this reason, the default setting for comments in the part program body is
now 'off'
  ).

  Added 'Tooling data section' checkbox to the output dialog.  This 
enables/disables the insertion of
  tooling data into the part program header (or at the file end for Sieb & Meyer
format).

  In Excellon output mode, it is now possible to select the mode of zeros 
suppression used in the output file,
  or to switch off zeros suppression entirely.

  Changed the default symbol used to mark the end of the part program header in 
Excellon format from 'M95' to '%',
  as the M95 code does not seem to be well supported on CNC drilling systems.

  When CNC data is output in metric mode, the data values in the output file are
limited to the range +/- 999.999 mm.
  (approx. 39 inches), and in inch mode to the range +/- 99.9999 inches.
  The data points output to the CNC file are always relative to the system 



datum, so if the artwork is shifted
  a long way right (or up) from the system datum point, it is possible for 
values to go outside the above ranges.
  The CNC drill/rout output tool will now display an error dialog if an attempt 
is made to create an output file
  when data is out of range. (It will not be possible to create the output file 
until data is brought within range).

  Added 'Advanced Options' button to the drill tape output dialog.  This button 
appears in Excellon output mode, and
  permits more fine grained control over commands that are included in the 
generated data file.  As 'Excellon' format
  is not a precisely defined standard, and its interpretation varies amongst 
various CNC drilling systems, these extra
  controls should give users the ability to adapt the drill data output to 
conform to their PCB manufacturers data
  requirements.
  Please note that there is a checkbox called 'Append % to the end of the file'.
 From customer feedback, it appears
  that certain Chinese manufacturers are now unable to read Excellon drill data 
files unless a percent mark appears
  at the end of the file.  No previous versions of XLDesigner (or earlier Ranger
products) have ever included this mark
  at the end of the data, and its requirement is not stated anywhere in 
available Excellon format documentation.
  Nevertheless, the option has been included for those customers who need it.

  To achieve Excellon drilling data output that is identical in format to that 
generated by pre 2.22 software releases,
  please set the following configuration :

    In the main drilling dialog, select Output = 'Drilling Only', Zeros Mode = 
'Include All' and untick the
    'Comments in Part Program Header' and 'Comments in Part Program Body' 
checkboxes.

    In the Advanced Options dialog, tick the 'Completely omit the Part Program 
header' and 
    'Omit G90 Absolute mode command' checkboxes.

  Please note that the resultant files have poor compatibility with most CNC 
drilling systems as they lack the required
  'M48' header start code, specification of the units used within the file, and 
no tooling data.

General system :

  o BUGFIX: A crash could occur when opening a design where artwork 'partial 
unroutes' had been eliminated
            by moving the end of the routed trace onto its corresponding part 
pad.

Artwork editor :



  o BUGFIX: A crash was occuring with designs that contained part outlines with 
standard pads placed within
            the pre-routed copper section of the outline.

  o BUGFIX: A crash occurred if you attempted to route an unrouted trace when no
layers were enabled for routing.

Changed in release 2.25 (8th August 2019)
----------------------------------------

Profile editor:

  o BUGFIX : changes made to the profile using the numeric editor were not being
saved.

General system :

  o BUGFIX : changes or additions to keepout areas were not being saved.

Changed in release 2.24 (28th June 2019)
----------------------------------------

  o BUGFIX : A crash was occuring when trying to open items in the master 
outline library.

  o BUGFIX : Gerber output was generating non-RS274X compliant macro definitions
when negative
             numbers were required in the output.  (the leading '0' was missing)

Changed in release 2.23 (26th June 2019)
----------------------------------------

2.23 is the same as 2.22, but fixes a serious artwork autorouter problem which 
was caused by
changed code optimiser behaviour in the C++ compiler used for the system build.

Changed in release 2.22 (25th June 2019)
----------------------------------------

============= New feature =====================================================

A new  'Slots & Extra Holes' tool has been added to the Artwork, Outline and 
Custom Pad editors.  

It allows insertion of slots (for CNC routing) into the artwork, or into an 
outline or custom 
pad definition.

It also allows arbitrary extra plated/non-plated drill locations to be inserted 
into the 
artwork/outlines/custom pad editor.



Long machined slots are often used to allow breaking out of a board from a 
larger panel, and to 
assist this, the slots tool can insert breakout tabs into any defined slots.  
The tabs may be 
solid or perforated  (a series of close spaced small holes),  defining the 
location where the 
board will break. 
The slots can be pre-drilled (to avoid damaging the router cutter) if required.

The CNC drill and router data outputs have been updated to accommodate these 
changes. 

The resultant CNC output files now include tool definition information embedded 
in the file.

A new configuration panel 'Configuration->CNC Tools & Datasets' has been added. 
It allows 
pre-definition of all drills and routing tools needed for the board manufacture.
 It optionally 
allows feed rates and RPM values to be specified, and if entered, these will 
appear in the CNC 
output file. 

The 'CNC Datasets' panel allows the naming of all the various CNC output files 
that will be needed
for the manufacture of the board.  Two datasets are pre-defined, DS1 which 
represents all normal 
through plated holes (passing all the way through the board), and DS2 which 
represents through 
board holes which should not be through plated.

Additional dataset positions may be used to represent drill strategies for 
boards with blind or 
buried via holes.  For each user defined dataset, the drilling start and end 
layers may be set, 
and a graphic representation of the drill hole in the board structure will be 
shown. 

Any drill dataset numbers that were previously defined to handle drilling of 
user defined 
via holes will be automatically imported into the new CNC Datasets table on 
design loadup.

Known limitations with this new feature:

  With this first release of the 'Slots & Extra Holes' tool, there are some 
limitations which will be addressed
  in the next release. These are :

    The artwork checker is currently blind to the presence of slotted features 
and extra holes added to
    the design, so this must be born in mind when added slots to your board.



    Once a breakout is added to a slot, it is not yet possible to edit its 
parameters without deleting and
    recreating it.

    Once an extra hole is added, it is not yet possible to alter its size or 
drill dataset without 
    deleting and recreating it.

    The 'Identify Feature' tool will not provide any information about slots and
extra drill holes.

    Undo/Redo does not work within the Slots & Extra Holes tool.

    If a slot is defined in a component outline, then the tool cutting direction
will be reversed if the 
    part is flipped to the other side of the board.

============= Other fixes =====================================================

Artwork editor :

  o BUGFIX: When using Identify->Pin then clicking the 'Find pin in schematic' 
button, the pin was not located
    if it was on a subsymbol of a schematic split part.

Schematic editor :

  o BUGFIX: If a schematic sheet contained a comma in its name, then the 
Find->Part command would not
    find any parts located on the sheet.  Also, sheets could not be opened by 
clicking on the
    associated block in the hierarchy view if the sheet name contained a comma.

  o BUGFIX: Find->Instance did not work correctly if the symbol instance was a 
subsymbol of a split part.

  o BUGFIX:  When given a part pin reference, the Find->Part function was 
locating the symbol instance
    instead of placing the popup balloon window on the requested pin.

  o Renamed the Find->Part menu entry to 'Find Part / Part Pin' to more 
correctly indicate its action.

Outline editor :

  o BUGFIX: Library pad drill holes were not showing in the outline editor.

General system :

  o The license activation dialog was enabling the activate button even if no 
free licenses were available
    for activation.



Changed in release 2.21 (27th February 2018)
--------------------------------------------

General system :

  o BUGFIX: A crash occurred on opening a schematic sheet that had been copied 
and pasted from
    another design.

Changed in release 2.20 (9th February 2018)
--------------------------------------------

New feature :

Added an artwork 'Logo' facility to the system.  This allows the insertion of 
company logos,
compliance and warning symbols etc. into PCB artwork layers.

Photos or scanned copies of logos may be loaded into the system's new logo 
editor, and then
converted into a vector based representation suitable for inclusion into the 
artwork.
Logo images may be imported in JPEG, GIF, BMP or PNG format.

A new folder 'Logos' will now appear within user designs and the 'masters' 
folder in the navigation pane.
Right clicking on the logos folder permits creation of a new logo.
Double-click on the logo name and the logo editor will open to allow loading of 
your desired image and
conversion into a vector based version.

Logos may be copied between designs and to/from the master logo folder by 
dragging them within the navigator
pane or right clicking and choosing Copy/Paste.

When you open the logo editor, you will see that it is divided into three 
sections selectable by tabs at
the top.
When you initialy create a logo, only the first 'Select Source Image' tab will 
be selectable until you have
loaded an image.
Click the 'Select Image File' button and choose an image file containing a logo 
that you would like to use
on your pcb.

After selecting an image file, your image should display in the window. Use the 
rotate and flip buttons
to put the image in the desired orientation. Near the edges of the image, you 
will see border lines with a
small selector square at their centre. Click and hold the left mouse button on 
these small squares to drag
the border lines inwards to select just the part of the image that you want to 



convert into a logo.
(The unselected parts of the image will go dim as you move the borders).

Once you have your image loaded and cropped down to the appropriate region, 
click on the 'Thresholding'
tab at the top of the dialog.  This page is divided into two sections.
The left hand window shows a monochrome rendering of the original image.  If the
original image is in
colour, you can use the R,G,B sliders to adjust the priority that each colour 
has in the conversion of
the colour image to monochrome.  With some images, this can be helpful to obtain
a suitably contrasty
image to threshold into pure black/white.

The right hand panel of the Thresholding page is where the monochrome image is 
converted to black/white only
representation.  The slider controls the brightness point in the image where the
changeover takes place.
The 'Invert Image' checkbox switches the sense of the resultant image. (White in
the right hand image gets
converted into copper on the PCB)

Once you have achieved a good image in the right hand pane, select the 'Vector 
Generation' tab.
This page will show you how the logo will look when it is split into individual 
vectors.
The 'pitch' control allows you to control the fineness of the resultant logo. 
The 'Minimum Vector Length'
control can be used to remove small unwanted spots that sometimes occur as a 
result of not being able to
find a perfect setting for the thresholding level.
In this final page of the dialog, the drab green colour represents the laminate 
colour of the pcb, and the
white is copper. The boundary of the drab green colour represents the bounds of 
the logo that has been
generated, and also the boundary that is used during artwork checking.  (artwork
checking only considers
logos to be rectangular boxes, it does not check for clearance to each 
individual vector within the logo)

Once you have an acceptable logo in the 'Vector Generation' page, you can close 
the Logo Editor.

Within the artwork editor, select Logo->Insert, then choose your logo from the 
navigator and drop it on the
board wherever you wish.  During placement, the logo's orientation and size can 
be adjusted using the controls
in the logo toolpane.  When checked, the 'Constrain Proportions' checkbox will 
ensure that the logo does not
change shape when changing its width or height.

When using Logo->Move/Copy/Edit, the destination layer may be changed, so you 
can move existing placed logos
to different layers.



Logos may be placed on powerplane layers, and will be visible within the 
powerplane edit mode.  When a power
plane is generated/regenerated, the logos will be preserved within the layer.
** Please note that logos placed in powerplane layers are currently invisible to
the artwork checker.
   No checks for violation with other powerplane features will be performed.
**
For customers installing XL Designer for the first time,a few example logos may 
be found in the MASTERS/Logos
library that will be installed automatically.

The example master logo library WILL NOT get installed for existing users as the
installer will never interfere
with the content of user library directories after first-time setup.
For those users, some example logos may be found in the "Logo Examples.rxl" 
design in the samples directory
(normally 'C:\Program Files (x86)\Seetrax\XL Designer\SampleDesigns') and 
dragged from that design into the
master logos folder if you wish to use them.

General system changes:

  o Because of internal database changes needed to implement this new facility, 
designs saved with this release
    will not load into earlier versions of XL Designer.

Changed in release 2.19 (27th February 2017)
--------------------------------------------

General system :

  o Revised the layout of the File->System Setup dialog to provide a more 
organised layout capable of supporting
    future setup options.

  o Reimplemented all text report file printing throughout the system. Printed 
text outputs now have a consistent
    appearance and include a page header, footer and page number/total page 
count.

    The content of the header/footer left,centre & right text fields may be 
configured by the user in the new
    'Text report formatting' section of the system setup dialog.

  o The File->System Setup dialog now contains a new section "Fonts" where the 
font used by printed text reports
    can be configured.  The are also additional entries in this setup section to
control the font in the schematic
    editor and various output tasks.  (See the schematic editor and output tasks
comments below.)



  o Printed text reports which have information organised into columns now 
automatically adjust column widths to
    obtain the best fit of the report for the paper size in use.  When a large 
font point size is selected for text
    printout, some columns will need truncation to fit the output onto the page.
    The column sizing algorithm will resize the columns such that the minimum 
number of text strings are truncated
    in the printout.  Truncated text will be marked with a small red bracket at 
the point where it is truncated.

  o The design autosave section of the setup dialog now contains a 'Autosave to 
alternate directory' checkbox.
    When checked, you may now choose to have autosaved designs stored in a 
different directory to the one in which
    the design file is located.  For data security in the event of filesystem 
corruption or hardware failure, it is
    advisable to store autosaved work on a different filesystem to the one that 
holds the design file.

  o BUGFIX: Corrected a display rendering error that could occur if a custom pad
was created with no boundary
    shape defined.

  o BUGFIX: Fixed a crash that could occur when loading designs originally 
created on very early versions of the
    Ranger3/RangerXL product series.

Schematic editor :

  o The schematic editor now displays all text using Windows text fonts.  The 
font used by the schematic editor is
    controlled by the "File->System Setup->Fonts->Editors & Output Tasks" 
setting.  Please note that as most
    Windows fonts use proportional spacing, text strings will be slightly 
shorter in overall length than with the
    previous fixed pitch vector font.  Text height remains the same and is still
controlled by the height properties
    on attributes, non-electrical text items etc.  Because text height is 
specified by attributes,
    the 'point size' selectable when choosing the font in System Setup is fixed 
at an arbitrary 16pt and has no
    bearing on the resultant text size.

    There is a checkbox in the fonts setup category that when selected causes 
the schematic to revert back to
    using the vector text font.

Artwork editor :

  o Added a new checkbox "Trk ID" to the artwork view control pane.  When 
checked, and when the artwork is zoomed
    in sufficiently close, net identities will be displayed on all tracks.

  o It is now possible to use the grid origin command to select a new grid datum



point while in the process of
    moving/copying/rotating a region.  After the new grid origin is selected, 
right click the mouse to return to the
    currently active region command. (This reinstates the former XLD V1 
behaviour).

  o BUGFIX: If the outline name for a part was changed to a non-existent outline
after the part had already been
    placed on the artwork or added to the part placement tray, then a crash 
would occur when trying to move
    or place the part.

  o BUGFIX: Fixed a problem where the wrong command was sometimes being 
activated after clicking a toolbar button.
    (problem since revision 2.11)

Parts list editor :

  o Improved the layout of the Bill of Materials "report" style output.

    Added a new checkbox "Include part references".  When unchecked, part 
references will not be included in the
    report.  This reduces total page count and assists in fitting the report to 
the available page width.

Output tasks :

  o Output tasks that target a Windows printer now use the "Editors & Output 
Tasks" font configured in the system
    setup dialog when appropriate for text output. With outputs such as 'PDF', 
this results in the text being
    searchable in the resultant document.

    The onscreen preview of an output automatically switches the display of text
between real font based and
    vector font determined by the capabilities of the output device.  (e.g. 
Gerber output can only render text
    as vectors).  Please note that "output to image file" continues to output 
all text as vectors and this will
    be corrected soon.  Also, artwork text is always vector based in the editor 
and outputs because of the strict
    requirements of dimensional control and clearance checking.

  o Added a 'Copy' button to the schematic plot setup dialog.  When clicked, 
this will copy the colour configuration
    from the current task into all other schematic output tasks.

Changed in release 2.18 (19th December 2016)
--------------------------------------------

General system :

  o BUGFIX: Fixed serious Direct2D graphic interface leak that caused resource 



starvation and program crash.

Changed in release 2.17 (13th December 2016)
--------------------------------------------

General system :

  o BUGFIX: Fixed a serious thread handle leak related to display rendering 
which could result in resource
    starvation after many display repaints had occurred.

  o BUGFIX: Improved thread termination event wait to minimise the potential of 
program hang during rendering.

  o BUGFIX: Fixed a crash that occurred when trying to delete custom pads from 
the master library.

  o Added 'Configure Crash Dumps' configuration tool to the System Setup dialog.
 This new facility allows the user
    to enable the local storage of user mode crash dumps which contain 
diagnostic information which can assist the
    product development team in the location of program errors.  To access this 
configuration tool, XLDesigner must
    be run as administrator, but once dumps are configured, the software can be 
restarted as a normal user and crash dumps
    will be stored in the user-selected directory if an application crash 
occurs.

  o Added extra internal checks to ensure that temporary file names are 
correctly created.

  o At design load time, the settings in the track sizes table will be checked 
for illegal values and an error
    report displayed of any incorrectly defined values.  (Solution for customer 
reported error where silk screen
    print was showing a large black filled area because a track width value was 
negative)

Artwork editor :

  o BUGFIX: SMD pads that must connect to a power plane are marked with an 
unroute dot. When power unroute display
    was enabled, the unroute dots were incorrectly being displayed on the bottom
left corner of the design for parts
    that had not yet been placed.

  o BUGFIX: A crash could occur if the mouse was double-clicked when placing 
parts.

Output Tasks :

  o Reimplemented the bitmap image output mode that was temporarily removed at 
the 2.14 release.



  o BUGFIX: If a design had definitions for user defined via holes and none of 
the definitions were referenced
    in the artwork, then a crash could occur in Windows printer outputs.

Changed in release 2.16  (14th October 2016)
-----------------------

General system :

  o BUGFIX: If space characters occurred at the start or the end of a license 
key when it was entered into the license
    management dialog, then the license code appeared to be stored correctly, 
but online activation attempts resulted in
    a license server error 3 being shown.

Output Tasks :

  o BUGFIX: Output tasks that targeted a Windows printer did work correctly when
run as part of a batch output.

  o BUGFIX: When a drill sheet was output to a DXF file, the drill symbols were 
not shown correctly.

  o It is now possible to specify an output filename for batch tasks that target
a Windows printer.  This is most useful
    when targeting Windows printers such as 'Print to PDF'.
    If the filename field is left blank, output is sent directly to the printer 
device.

  o BUGFIX: Changes to the settings of the 'Drilling Rules' in the User Via Hole
Definitions editor did not reflect through
    to the NC drill output tasks until the design had been saved, closed and 
reloaded.

  o BUGFIX: When the plotting scale "Fill Sheet" option was used, the resultant 
printout was being clipped on the right and
    top edges.

  o A new "Miscellaneous Line Widths" page has been added to the 
Configuration->SizesTable editor.  On this page it is
    possible to specify a width for the board profile and keepout region 
boundary lines when those features are selected
    for output in an output task.  An extra setting is also provided that sets 
the default output width for all other
    features that do not have a definable line width.
    Please note that the values specified here only influence the display of 
features in the output task preview window
    and in resultant outputs.  They do not currently influence the display 
within the artwork and board profile
    editor.

  o The "Width for No-width features" setting has been removed from the Gerber 



output setup dialog as its function has
    been superceded by the new width setting values described above.

  o The Artwork plot task setup dialog now includes an option to control how 
drill holes should be included in the
    resultant output.  The available options are "Off", "Include at true size" 
(which shows the drill holes at the correct
    drilling diameter) & "Include at fixed size".  In the fixed size mode, all 
drill holes are displayed at the diameter
    set in the "Fixed drill diameter" option value.

Artwork editor :

  o BUGFIX: Part auto renumber was not always setting part numbers correctly.

  o BUGFIX: When Amend->Replace Pad had been used to replace a partpin pad on a 
surface mount component, and the layer selector
    was set to 'V', then a pad was being incorrectly displayed on the 'V' (Vias)
layer.

  o BUGFIX: When Amend->Replace Pad had been used to replace a partpin pad on a 
board inner layer, the displayed drill hole
    size was not updating to the defined drill size for the replacement pad.
    N.B. If 'Replace Pad' is used to replace a pad on a drilled partpin, and the
pad replacement is made on the board top or
    bottom sides, the drill hole diameter will NOT be changed to that defined in
the replacement pad.  Drill hole dimensions
    are always taken from the definition of the pad used on board inner layers.

  o The Mroute toolbar 'Via Autoselect' checkbox default is now 'off', and the 
state of the control is remembered with the design.

  o The 'Parts->Swap' command has been enabled in the menu.

  o If a User Via definition contained pads on power plane layers, then 
arbitrary dimensioned pads were being displayed when the
    power plane layers were enabled for view.

Schematic editor :

  o BUGFIX: Changes made to EMC attribute definitions were not being saved with 
the design.

Changed in release 2.15  (9th September 2016)
-----------------------

Artwork editor :

  o BUGFIX: The net highlight functions were causing a crash in some situations.

Output Tasks :

  o BUGFIX: If non-electrical text was placed over the top of a symbol having 



background shading, then the symbol shading
    obscured the text in the output and screen preview.

  o Added a 'Swell method' option selector to the solder mask task setup dialog.

    When set to 'Square corners', square and rectangluar pads will be swollen by
a simple increase of their width and length
    and square corners will be maintained.
    This is the method that was used in XL Designer versions prior to 2.12.

    When 'Filleted (rounded) corners' is selected, swollen pads are created that
maintain a constant clearance from the
    original pad.
    For a pad with square corners, this constant clearance results in a radiused
corner to the swollen pad.

    The 'Swell method' selector has no effect on round/round-ended finger pads 
and does not affect user-defined library
    pads which are always swollen using the 'Filleted' method of maintaining 
constant clearance.

  o BUGFIX: Gerber output was creating duplicate points in AM 'Outline' 
primitives.  Although harmless, this caused a warning to
    be raised by some Gerber viewers.

  o BUGFIX: Gerber output was not always returning to linear interpolation mode 
after circular interpolation had been used.

  o BUGFIX: Generated Gerber files contained inconsistent "0D0D0A" line 
terminations.

  o Added a 'File Created' date/timestamp as a comment at the top of created 
Gerber files.

  o Added a "RS-274X Tuning" parameter to the Gerber setup page.

    With "May use any feature defined in standard" selected, XL Designer will 
not restict its utilisation of features described in
    the latest RS-274X specification document.  This will result in the most 
efficient Gerber output but may result in
    incompatibilities with some output devices/viewers.

    With "Simplify for marginally compliant devices" selected, XL Designer will 
avoid known pitfalls in popular output
    devices/viewers that have partial or weak implementation for various areas 
of the RS-274X standard.
    These are some of the problems we have identified in popular Gerber viewers,
and this mode will attempt to work around them :

    Within the implentation of the 'AM' (Aperture Macro) command :

      o Device requires an upper-case 'X' as the multiply sign in arithmetic 
expressions. The standard says it should be lower case.



      o Failure to rotate the x/y position of circle primitive (code 1).

      o Failure to rotate the x/y position of centre line primitive (code 21).

      o Failure to position the centre line primitive (code 21) at the corrent 
location, always placed at x=0,y=0

      o Failure to handle multiple arithmetic operations in one statement.

      o Failure to handle bracketing to control arithmetic precedence.

    Please note that the 'simplified' mode does not imply that the generated 
Gerber will be shorter.  It will in fact be longer
    and the AM definitions more difficult to read as various tactics are used to
work around the above problem areas.

Changed in release 2.14   (15th August 2016)
-----------------------

Output Tasks :

  o Gerber output has been reimplemented to conform to the new RS274-X standard.
 The previous photoplotter output modes
    with manually editable D-Code tables are no longer available.

    All pad styles regardless of shape or orientation will now be instantiated 
in the output with 'D03' flash commands.
    Parameterised macro definitions are included in the Gerber output to handle 
a design's various pad shapes.
    Rasterisation is no longer used for any pad output.

    The default file name extension for generated Gerber files has been changed 
to '.gbr' to comply with RS274-X.

  o The 'solder mask' and 'solder paste' output types are now correctly 
displayed on screen with the appropriate
    pad size expansion/shrinkage.

    Pad size swell/shrinkage is now applied to all relevant pads regardless of 
their shape or orientation.

    The solder paste output 'pad shrinkage' setting performs the same function 
as the previous 'pad swell' setting except
    that negative numbers are no longer permitted, and previously configured 
negative swell settings will automatically
    have their sign changed to give positive 'shrinkage' values.

    The solder mask output now only accepts positive values for the pad swell 
setting.

  o Output tasks are now displayed in the navigator with icons chosen to 
indicate if the task relates to artwork, schematic,
    ncdrill or idf output.



  o The output task viewer now always displays the full output that will be 
generated.  It is not necessary to click a
    'refresh' button to preview the output after each input setup parameter has 
been changed.

  o Support of pen plotters has been removed as a customer survey concluded that
it was no longer being used, and its
    retention was impeding product improvement.  If a design is loaded that has 
pen plotter output tasks
    defined, the tasks will be reconfigured to direct output to the default 
Windows printer.  A warning will be displayed
    if this happens.

  o To conserve pen plotter ink, the artwork plot modes previously permitted 
selection of pad/track output as 'outline
    only'/'thin line'.  All artwork modes will now always output tracks filled 
and at full width.  Pads will always be
    output filled with the option of including a drill hole where appropriate.

  o For plot configuration dialogs that previously had a 'pen number' box, this 
has been replaced with a colour selection
    box to allow direct selection of the display colour for various features.
    When loading old designs, previous pen number values will be replaced with 
colour selection boxes preset to the colour
    that was previously in the plot pen configuration table.
    The pen configuration editor has been removed from the plot tool 
'Configuration' menu.

  o Circuit schematics will now display and print symbols with their coloured 
infill. At the present time, the infill will be
    printed using the colour as configured in the symbol's attributes whereas 
the symbol outline colour can be controlled in
    the schematic print task configuration dialog.  This anomaly will be 
addressed soon.

* o The component outline editor View->Properties dialog now contains two 
additional checkboxes, "Omit pads from soldermask" and
    "Omit pads from solderpaste".  When selected, pads will not appear on any 
instance of the outline in solder mask/paste outputs.
    These new outline properties can also be edited by right-clicking on the 
navigator 'outlines' folder and choosing "Edit properties".

* o The solder paste output now includes pads which are placed on the selected 
'extra layer'.  Pad shrinkage is applied to the
    pads from the extra layer.

* o If layer 'V' is included when a powerplane layer is selected for output, via
holes that are connected to the power plane with
    heat reliefs become isolated. A warning will now be displayed when this 
conflicting layer selection state exists.

* o Added Edit->Units menu entry as it was not possible to change the working 
units from within the outputs task viewer.



* o Circuit schematic output tasks were becoming disassociated from their 
selected sheet when instance id numbers changed within
    the schematic.  Schematic output tasks are now linked using hierarchy paths 
within the schematic.  Existing designs that
    have valid schematic outputs will be updated to use the new hierarchy path 
linked method.
    Please note that schematic sheets will still become unlinked from their 
output task if the sheet is renamed or moved within
    the design hierarchy.

Artwork editor :

* o Added a 'hide' selection to the net highlight colour selection panel. When 
hide is chosen, selected nets will disappear from
    view rather than being displayed in a different colour.  Clearing all 
highlights will bring the hidden nets back into view.

  o BUGFIX: The clearance between smooth edged copper fill and the board 
profile/copper fill boundary polygons was incorrectly
    being influenced by the setting of the track sizes table size '0' setting.

  o BUGFIX: The length of the segments that make up a heat relief were being 
displayed too short. (Gerber and other outputs
    were outputting the segments at the correct length as calculated from the 
parameters in the heat relief configuration section
    of the sizes table)

* o BUGFIX: The autourouter was crashing in route by Part or Net mode.

  o Geometric algorithm changes to improve the reliability of the boundary 
generated for smooth-edged copper fill.

Schematic part editor :

* o Edit->Preferences was greyed out.

General system :

  o Because of internal database changes and improvements, designs saved with 
this release will not load into earlier versions of
    XL Designer.

Changed in release 2.12  (15th January 2016)
-----------------------

General system :

  o The license activation dialog will now remember the value entered into the 
login name field.
    If the 'Save password' check box is checked, the password will also be 
saved.



Custom pad & artwork editors :

  o CRITICAL BUGFIX: When defining a custom pad shape in the pad editor, the pad
becomes displayed as a filled shape
    as soon as the last vertex is entered close enough to the first vertex to 
form a closed boundary.
    When displaying custom pads in the pad editor and artwork editor, the method
used to coerce the pad boundary
    start and end points together was wrong and could result in the display of a
pad with a shape that was different
    to the pad boundary definition held within the design.
    (So it was possible for a custom pad to look the correct shape in the 
artwork editor, but be output with the wrong
     shape in the printing, gerber etc. output tools)

Artwork editor :

  o BUGFIX: When Amend->Replace Pad was used to replace the top or bottom layer 
pad on a part pin, the amended
    pad was shown on the wrong side of the board when the part was flipped.

  o BUGFIX: Library pads that had been inserted from outline free-copper data 
were sometimes shown at the wrong
    angle if their associated part was not at 0/90 degree orientation.

Changed in release 2.11  (22nd December 2015)
-----------------------

General system :

  o BUGFIX: Fixed problem opening Ranger3 design files when the design.idx file 
name was in uppercase.

Schematic editor :

  o BUGFIX: A crash could occur when a schematic had very long version dependent
attribute strings.

Artwork editor :

  o BUGFIX: If layers were switched to invisible after the Mroute->Corner 
command had been selected, then
    features on the switched off layers were still being picked up by the edit 
operation.

Changed in release 2.10  (17th November 2015)
-----------------------

General system :

  o The number of "most recent used" files displayed in the file open list has 
been increased from 8 to 16.



  o The navigator pane and file save dialog will now preserve upper case 
characters in design filenames.

  o Revised communication protocol with license activation server to reduce 
inteference from network caches and firewalls.

  o BUGFIX: Layer assignments were being all set to 'Copper' when loading a 
design that had been last saved with
    XLDesigner versions 1.72 through 1.113

  o BUGFIX: Arc segments in custom pads were being displayed as straight 
segments if the start and end X coordinate
    of the arc segment were the same.

  o BUGFIX: If the main application window was closed while a detached artwork 
view containing popup balloon windows
    was open and in a minimised state, then a crash or application hang would 
occur.

Parts list editor :

  o Added board side selector to the Bill of Materials report generator.

Artwork editor :

  o The Grid->Select Origin command will now snap the grid to pads and track 
nodes on any visible layer.  (Previously, it only
    snapped to pads on layer 0)

  o BUGFIX: After using "Tools->Generate Silkscreen" to insert outline free 
copper data, any square pads defined in an
    outline's free copper were not being displayed at the correct orientation if
the associated part was not at 0 or 90
    degree orientation.

  o BUGFIX: The net highlight functions were not working for unroutes.

  o BUGFIX: When the artwork and profile editors were both open at the same 
time, edits made to the profile or keepouts
    were not being displayed in the other editor view.

  o BUGFIX: When a part was moved, silk screen and label data associated with 
the part were not displayed at the new
    position until the display was zoomed.

  o BUGFIX: When a user defined via hole was moved, it was not shown at its new 
location until the displayed was zoomed.

  o BUGFIX: When a standard via hole was replaced with a user defined via hole, 
the new style was not shown until the displayed
    was zoomed.

  o BUGFIX: If you copied/pasted an outline from the master library into a 



design such that it replaced an existing outline, and
    the replaced outline was referenced by a part within the design, a crash 
could occur.

Schematic editor :

  o The visibility state of the 'fast parts' tray will now be remembered for 
each design sheet.

  o BUGFIX: If the 'Classic' colour scheme was in use, there was no 
rubber-banding line shown when inserting/editing
    non-electrical features.

Changed in release 2.9  (8th October 2015)
----------------------

General system :

  o Included support for licenses requiring online activation.

Changed in release 2.8  (25th September 2015)
----------------------

General system :

  o The "Display Options" values that were in the File->System Setup dialog have
been moved to a new
    "Edit->Display Adjustments" dialog.

  o The "Autogrid long axis maxdots" setting that was in the masters grid 
autopitch configuration dialog
    has been moved to the new Display Adjustments dialog and is now named 
"Autogrid pitch change threshold".

  o The Display Adjustments dialog contains two new settings :

      "Minimum Line Rendering Width" - this can be adjusted to achieve the best 
display of thin lines with the users
      graphic card/monitor combination.

      "Dotted grid intensity" - adjust this to obtain your desired level of grid
dot brightness.

  o All browser window contents were being displayed flipped around the X axis 
after you clicked on the navigator
    artwork icon with the artwork in 'Flipped' mode.

  o If the artwork and profile editors were both open at the same time, then 
redraw errors could occur when
    edit operations were performed on the board profile or keepouts.

Profile editor :



  o Added red shaded area to the display to indicate negative coordinate space. 
The board profile should not be
    drawn into the negative space as this can cause difficulties with artwork 
placement, routing and output.

  o Custom pads were not being shown when 'View->Part Pins' was selected.

Artwork editor :

  o When "display tracks at width" was selected, some tracks would appear to be 
missing from the display when the
    view was zoomed out because they were being displayed too narrow to be 
visible.  Tracks will now never be
    rendered narrower than the line width controlled by the "Minimum Line 
Rendering Width" setting.

  o Labels for parts on the board reverse were being hidden by part pads and 
tracks.  They are now rendered
    together with the topside part labels over the top of all layer features.

  o After using the Region->Delete command on a layer, features were not being 
rerendered on the layer during edit
    operations.

  o If you selected Amend->Enter Track/Arc/Circle then attempted to add a 
feature to a layer that was not visible, the
    "layer not visible" warning would continue to be shown even after the layer 
had been switched on in the view control
    toolbar.

  o The hilite tracks command did not update its layer search list when layer 
visibility was changed while the command
    was active.

  o Added 'Extended Opacity Control' button to the side of the layers opacity 
control slider.  This button displays
    a dialog that permits more fine grained control of the opacities of the 
various layers and features in the artwork.

  o Added red shaded area to the display to indicate negative coordinate space 
(as in the profile editor).
    This can be switch on/off with the 'View->Negative Space Shaded' command.

Schematic editor :

  o Text will no longer change to a dotted line when the display is zoomed out a
long way.

  o Added display of symbol 'Flipped' status to Identify->Instance popup 
balloon.

Outline editor :



  o When the outline datum position is changed, the grid origin will now be 
adjusted to ensure that the grid remains
    in the same position relative to the outline.

Changed in release 2.7  (19th June 2015)
----------------------

General system :

  o Fixed a display rendering issue that occurred when the Windows system 
display DPI value was not at the
    default 100% (96dpi) setting.

  o If a higher system DPI value was selected, then tool panes were not being 
displayed at their correct width
    until after a View->Restore Default layout action had been performed.

  o If XLDesigner was started by double-clicking on a .rxl design file, then the
Outputs section was missing from
    the design navigator entry for the design.

  o When performing cross-probing between schematic and artwork (by clicking on 
the schematic/artwork icons in
    the popup balloon windows), the window that was brought to the front did not
always rerender.  This gave the
    appearance that the information balloon windows were pointing at the wrong 
object.

  o Changed the "Autogrid Long Axis Maxdots" default value to 75.  N.B, the new 
default value will only been applied
    when the software is run on a new user account or an account with no 
XLDesigner "Configuration Data Directory".

  o In File->System Setup, reduced the Artwork grid dot size setting lower limit
to 10 as the minimum size appeared
    too large on some monitors.

Artwork editor :

  o The artwork view control toolpane has been made wider as insufficient space 
had been allowed for the scroll bar
    that appears when the window height is insufficient to display the entire 
pane.
    N.B. You must do "View->Restore Default Layout->Editor Layout" within the 
artwork editor to cause the toolpane
    to be displayed at its new size.

Schematic editor :

  o Non-electrical version controlled text was not being displayed correctly.

  o The display was not being updated after symbol attributes were moved.



  o Made the default ruled grid colour darker to improve visibility on some 
monitors.

  o If a symbol was placed onto an existing wire, then in some cases the wire 
would vanish and not reappear again
    until a move operation had been performed on another part.

Changed in release 2.6  (14th June 2015)
----------------------

General system :

  o CRITICAL BUGFIX: A Direct2D factory initialisation error caused the 
application to fail to start on
    some computers.

Changed in release 2.5  (14th June 2015)
----------------------

General system :

  o CRITICAL BUGFIX: There was a thread timing issue that caused the application
to crash on startup on
    some computers.

  o Fixed case sensitivity problem on the license key entry dialog.

Artwork editor :

  o When 'view part outlines' was unticked on the artwork view control toolbar, 
part labels were not displayed
    for parts that were flipped to the back of the board.

Changes between 2.4 and 1.116
-----------------------------

General system :

  o All graphical presentation within XL Designer has been recoded to use the 
Microsoft Direct2D API.  This now
    permits the product to take full speed advantage of the latest generation of
graphic cards and processors.

    Display rendering now uses multiple processor threads, so when working with 
artworks containing many complex
    layers, the workload will be distributed across all the available CPU cores.

    Most sections of the program now use 24 bit values to represent colours, so 
there is no longer any limitation
    on the colours that you can assign to design features.



    Direct2D has enabled us to apply transparency to displayed features. As an 
example, the artwork editor has a
    new 'opacity' control on the view control toolbar.  This allows the user to 
adjust the opacity of the topmost
    displayed layers and gain a clearer view of those lower down.

    The anti-aliasing feature of Direct2D means that the edges of displayed 
features are now much smoother.
    Anti-aliased display is on by default, but please note that it does cause 
some speed penalty.  If you
    want more performance when working with a very high density design on a 
computer of limited performance,
    anti-aliasing can be disabled in the File->System Setup dialog.  Changes to 
the setting only take place
    after a view is closed and reopened.  A display rendering speed increase of 
40% is typical when anti-aliasing
    is disabled.

  o If a change was made to the master configuration or master libraries, the 
'*' next to the MASTERS name in the
    browser was not being cleared on save when a design was also open in a 
modified state.

  o Added a 'Colours' subsection to the navigator 'Configuration' section.  The 
MASTERS colour configuration dialog
    permits the configuration of a set of artwork layer and highlight colours 
that are applied to all newly created
    designs.  The colours dialog in a design's configuration section allows the 
user to configure layer/highlight
    colours within a design, replace those colours with those from the master 
set, or replace the master colours
    with those from a design.

Outline editor :

  o Keepout lines,circles and free copper items did not get repositioned if the 
outline's datum position was moved.

  o When an attempt was made to drop a pad onto a location where a pad already 
existed, the resultant pop warning
    message became stuck on screen until a different command was selected.

  o Changed the pad insertion layer selector from 'radio' boxes to checkboxes, 
so it is now possible to select
    any combination of layers.  Previously, selection was limited to a single 
layer or all layers.

  o Added statistics line to the top of the window.  This displays the number of
unique pin assignments on the
    outline together with counts of the number of pads and number of unassigned 
pads on each pinstack layer.



  o The region commands have been simplified down to three basic menu actions : 
Move/Rotate, Copy & Delete.
    For all region functions, the first two left-mouse button clicks will define
the area to be operated on.
    For move/copy, a third mouse click will execute the action at the chosen 
position.  While positioning
    the target frame for move/copy, the 'Rotate' assigned keyboard key is 
enabled. Each press of the rotate key
    will rotate the target rectangle an extra 90 degrees.
    For region delete, a third mouse click confirms the delete action or right 
click cancels the action.

  o The region commands will display a warning message in the status bar if no 
features are enabled in the region
    section of the tool configuration pane.

Artwork editor :

  o In the powerplane setup dialog, the selection of the display colour for 
subnet polygons was not working correctly.

  o When adding or moving user-defined via holes, no animated pad was shown 
attached to the cursor.

  o For overall layer rendering efficiency, URL text markers are now always 
displayed in the colour of the layer
    on which they are inserted.  The alternate display colour option has been 
removed from the text URL entry/edit dialog.

  o The region commands have been reimplemented in a manner consistent with the 
changes to the outline editor region
    commands described above.

  o Reduced the number of menu entries in the 'Partfix' menu section. Single 
parts will now toggle their fix/unfixed state
    on each click.  Likewise, each selection of the fix/unfix 'all parts' action
will toggle the fix state of all parts
    on the enable sides.

  o Added layer opacity control slider to the view control toolbar.

  o Added unroutes opacity control slider to the view control toolbar.  A the 
left of the sliders travel, unroutes are
    displayed behind the copper layers, and at the right of its travel, they are
display over the top of the copper layers.
    Please be aware that if you choose to display unroutes behind the copper 
layers, SMD pad powerplane unroutes (which are
    shown as a small blob) may not be visible.

  o All the colours in the hilight toolbar are now user configurable.

  o If you right=click a net in the navigator 'Nets' section, you can now choose
to 'hide' the net's unroutes. The net



    will be marked in the navigator with '(h)' to indicate it is hidden.  Nets 
that are selected for exclusive viewing
    using the'Net' option in the artwork view control toolbar now are indicated 
with a '(s)' marker in the navigator
    (was '(u') formerly).

  o Configuration settings have been added to the File->System Setup dialog to 
enable the user to control the size of
    text displayed for part labels and pin numbers and also the diameter of grid
dots.  The controls take a value in the
    range 20-100 with larger numbers increasing the size of the corresponding 
feature.
    

Artwork checker :

  o A numeric overflow was causing incorrect reporting of shorts and clearance 
errors after smooth-edged
    copper fill had been used.

  o When a check had been performed on a board with multiple clearance values, 
the gap error flags were not being
    displayed with their clearance group information until the design was saved 
and reloaded.

Schematic editor :

  o When assigning pin numbers to split parts, the pin number dialog was 
sometimes displaying arbitrary values in the
    pin number and pin increment fields.

  o By default, the ruled grid is now displayed with much finer lines than were 
possible with the V1 series of XL Designer.
    If the ruled schematic grid is too faint, or not visible, the width of the 
grid lines can be controled from within
    the File->System Setup dialog.  The "Schematic ruled grid line width 
control" value can be set in the range 10-100
    where larger numbers result in thicker grid lines.  The default setting is 
'30'.  Changes to this setting only become
    visible in a view after the view is closed and reopened.

  o Connection crosses now disappear from symbol pins when the pins are 
connected.  Please note that the crosses will not
    currently be removed from symbol pins if two symbols are placed such there 
their pins overlap (i.e. no wire segment
    drawn between them).  A connection will however be formed in the netlist.

  o Symbols may now be displayed with a solid infill colour.  To show a symbol 
filled, open the associated part or
    design symbol definition, select Attributes->Symbol and check the 'Show 
Symbol Filled' box.  Choose the colour for
    the infill using the 'Infill Colour' box.  If an outline does not appear 
filled when this mode is activated, please



    edit the symbol outline shape to ensure that it forms a closed path.
    Please note that colour infill will not currently be shown in a schematic 
output task.  This will be implemented in
    the next release.

Custom pad editor :

  o Undo/Redo was not working for any of the drill hole commands.

  o Pad will now be shown infilled when the outline forms a closed shape.

Output tasks :

  o Artwork plot previews now show pads as filled shapes.

  o If artwork pads filled/drilled output mode was selected and the artwork 
contained a custom pad where no drill hole was
    defined, then a crash could occur.

=========================================== XL Designer Version 1 release notes 
========================================

Changed in release 116   (1st September 2014)
----------------------

Circuit schematic editor :

  o A crash was occuring when loading or saving a design where more than 254 
pins had been assigned on a
    schematic symbol.

Changed in release 115   (25th July 2014)
----------------------

Artwork checker :

  o Circular keepout regions defined in the profile and outlines were not being 
included in the checking.

Drill sheet output :

  o  The drill symbol key (normally a letter) on the left of each drill summary 
line was being drawn at the
     same size as the symbol was drawn on the board display.  For better 
appearance, it is now be drawn at
     the same size as the drill summary text.
     
  o  Metric drill sizes had 'MM.' (megametres) in the column header.  This has 
been changed to 'mm.'
  



Artwork editor :

  o When the artwork is displayed in 'flipped' mode, parts that are on the 
bottom of the board will now have
    their outline displayed in solid cyan colour and parts on the top will have 
a dotted yellow outline.
    
  o Many part related operations in the artwork editor require clicking the left
mouse button to select parts
    on the board top and the right button for flipped parts.  When the artwork 
is displayed in 'flipped' mode,
    the sense of the buttons now becomes reversed making it easier to position 
parts when working on the
    back of the board.
    
  o When using 'Text->Get Label' to add a label for a flipped part, the label is
now inserted in mirrored mode
    (so if viewing the back of the board with the display 'flipped' function, 
the label will appear the right
     way around).
     

Changed in release 114   (19th March 2014)
----------------------

General system :

  o Added "Title" field to the 'Configuration->Layer Assignments' dialog.  This 
extra field may be used to
    store arbitrary text to help describe the usage of a layer.

  o The 1.112 release inadvertently removed the 'thin line printwidth' and 
'reverse printed arc' settings
    in the system configuration dialog.  These have been reinstated.
    
  o Design was not being marked as modified after free copper setup had been 
performed in the outline editor.
  
  o Design was not being marked as modified after using the navigator options to
delete all parts/nets.
    
  o Design was not being marked as modified after a text parts/wiring list had 
been imported.

Artwork editor :

  o All boxes which display the colour associated with an artwork layer now have
a 'tooltip' associated with
    them which will be displayed when you hover over the box.  The displayed 
tooltip will include the content
    of the new layer "Title" field which can be defined in the Layer Assignments
dialog.
    



  o Layer colour boxes which have an associated edit/spin control to change 
layer selection are now sensitive
    to clicking.  Clicking on the layer colour box will now bring up a selection
list where the required
    layer can be quickly selected.
    
  o Extra space has been added underneath the layer selection controls in the 
AddPad, AddTrack, Text and CopperFill
    toolbars.  When a layer is selected that has the extra "Title" field defined
in the layer assignments dialog,
    the title text will be displayed below the layer selection control.
    
  o The Grid->Origin command now also includes component datums in the locations
where the origin may be snapped to.
  
  o The Parts->Align X/Y command will now snap the reference line to part 
datums.  If you do not click near a part,
    the reference line will be snapped onto grid.
    
  o When a region move or rotate operation was performed, copper fill boundary 
definitions were not being moved.
    A new "Fill Bounds" checkbox has been added to the region toolbar permitting
fill boundary definitions to be
    moved/rotated with other artwork features.
    
  o When silk screen text part id labels are being moved, a line will now be 
drawn from the cursor location to the
    datum point of the component that the text label is associated with.
        
Artwork and Solder Mask output setup pages :

  o An extra 'Description' column has been added to the layer setup pages for 
these two output modes.  This column
    displays the usage, point count and optional title for each layer.

Circuit schematic editor :

  o If you added a hidden signal name attribute to a connection, then other 
signal name attributes that were attached
    to other nodes on the connection were not having their names synchronised 
correctly to the newly added value.
    As the netlist extractor only ever utilises the first encountered signal 
name value on a connection segment, this
    could have resulted in unexpected interconnections within the extracted 
netlist.

  o The summary count of the number of errors and warnings found during 
compilation did not always match the number
    of actual errors/warnings recorded in the compilation logfile.
    
  o It is possible to hide signal name attributes attached to connections.  If 
no other visible name attribute is
    attached elsewhere on the connection, then unexpected net grouping will 
occur in the extracted netlist.



    To reduce this risk, the schematic compiler will now log a warning message 
for all hidden signal name attributes
    encountered during netlist extraction.
    

Changed in release 113   (7th October 2013)
----------------------

Artwork editor :

  o A crash was occuring if you tried to open the artwork editor in 'detached' 
mode.
  

Changed in release 112    (7th October 2013)
----------------------

Artwork editor :

  o Added 'View Artwork Flipped' entry to artwork View menu.  Also added 'Flip' 
checkbox to the view toolbar
    'Misc' section.  When selected, the artwork is displayed as if looking at 
the back of the board.
    
  o If custom pads were used on free copper layers within an outline, then the 
pads would sometimes not
    be inserted correctly into the artwork by the Tools->Generate SilkScreen 
utility.
    
Circuit schematic editor :

  o Added 'Symbol->Add to Artwork Tray' function.  When this mode is selected, 
clicking on schematic symbols
    that are related to parts list entries will cause those parts to be added to
the artwork placement tray.
    In this mode, all symbols related to parts already placed on the board, or 
already in the placement tray will
    be shown with a dotted outline.  Symbols for parts that can be placed in the
tray will be shown with
    a solid outline.
    
  o Added 'Region->Add to Artwork Tray' function.  All parts associated with 
symbols in the selected region
    will be added to the artwork placement tray.
    
  o The Symbol->Copy operation could cause a crash if more than one copy of a 
part was inserted.
  
  o Fixed problem where non-electrical text was sometimes being displayed 
dotted.
    

Changed in release 111  (22nd May 2013)
----------------------



(.exe only issued for emergency fix to power names table case sensitivity 
problem)

Artwork editor :

  o Smooth edged copper fill was not handling user defined via holes correctly.

Changed in release 110  (20th May 2013)
----------------------

General system :

   o Because of new features recently introduced, designs saved with this 
release will not load
     into versions of XL Designer earlier than 1.109.

  o Added IDF 3.0 file exporter.
  
    If is now possible to export an IDF version 3 file for use with MCAD 
modelling tools.
    Please note that this is a chargeable add on feature and not included with 
normal system licenses.
    Please contact Seetrax sales office for pricing and availability 
information.
    
    Note that licenses that are supplied with the IDF export feature enabled 
will not work with
    versions of XL Designer earlier than 1.110.  Non IDF-enabled licenses will 
continue to work as normal.
    
    To access IDF file export, right click on Outputs->Tasks in the navigator 
and create a
    "New IDF Output" task.
    
    ================================== IDF export usage notes 
==========================================
    
    IDF configuration options
    -------------------------
    
      Part library outline creation mode :
      
          "Generate from outline placement bounds box" mode will create a simple
rectangular block to
          represent each part in 3D.  The dimensions of the box are taken from 
the placement footprint
          definition in the outline library entry associated with the part.
          
          "Generate from outline silk screen data" mode will attempt to create 
the footprint shape used
          for the 3d figure by processing the data in the outline silk screen.  
If so suitable polygon



          can be created from the outline silk screen, then the placement bounds
is used as for the
          above option.
          
          "Use 3D solid mode setting on outlines" mode will generate the part 
outline according to the
          3D solid mode setting stored within each outline.
          
      IDF package name / part numbering method :
      
          "Outline name / (blank)" mode will create one part library entry for 
each component outline shape
          used in the design.  If several parts of different types share the 
same outline, then they
          will all be mapped to the same part library name.
          
          To define the height of components, right click on 'Component 
Outlines' in the navigator and
          select 'Edit Properties'.  (Please note that the "3d Enabled", and 
"Silk Screen Mode"
          outline properties are used by the Autocad DXF 3d exporter and not 
utilised by the IDF exporter).
          If a height is not specified (left at zero) for an outline, then the 
default component height
          as set in the IDF exporter configuration dialog will be used.
          
          "Outline name / component value" mode will create one part library 
entry for each unique
          combination of outline name and part description (component value) 
field.  This permits more
          fine grained control of the mapping of part references to 3D part 
models when using mapping
          files such as the 'ecad_hint.map' file in Pro Engineer.
          
          If the "Use parts list MCAD model name for package" check box is 
ticked, then any model name
          specified in the "MCAD Model" field in the parts list editor will be 
used as the IDF model
          name for the part instead of the outline name.  If no MCAD model value
is defined for a part,
          the component outline name is used.
          
    When run, the exporter will create two output files.  The ".emn" file 
contains the definition of the
    board outline and the placement information for all parts.  By selecting the
appropriate options in
    the configuration dialog, it can also optionally contain board drilling 
information.
    The ".emp" file is the part library which contains the outline definitions 
that the MCAD application
    'extrudes' by the component height along the Z axis to form the 3D 
representation of the part.
    
    When opening the .emn file in Pro Engineer, it should be opened as an 



'Assembly'.  You will then be
    prompted to also open the corresponding .emp file.
    
    IDF output tasks may also be added to an output batch definition.  The 
output filename should be
    specified without a trailing extension.  When the batch is executed, the IDF
exported will automatically
    append .emn and .emp to the output filename for the two files that it 
creates.

    =================================== (end of IDF notes) 
=============================================
    
  o Changed outline properties edit dialog to permit editing of component height
and 3d generation mode
    attributes without switching on DXF 3d output mode.
    
  o Rearranged outline global properties edit dialog to separate the component 
height attribute and 3d generation
    mode configuration values from the DXF 3d output settings.
    
  o Drag/drop may now be used in the navigator pane to copy output tasks between
designs.
  
  o A crash could occur if you attempted a drag operation on a non-library 
related member in the navigator.
    (e.g. trying to drag a part or a net)
    
Parts list editor :

  o Added "View->Show MCAD Modelname" option.  When switched on, values entered 
in this column can
    be used as the 3D model/geometry library name when exporting designs to MCAD
systems.

Changed in release 109  (2nd May 2013)
----------------------

  o Preliminary implementation of IDF export facility.
    Not made available as a general release.
    

Changed in release 108  (9th April 2013)
----------------------

General system :

  o The navigator in releases prior to 1.107 permitted the creation of 
library/design member
    objects which had leading spaces in their names. Other work carried out in 
the 1.107
    release prevented the correct handling of these illegally named entries.
    These illegal leading spaces will now be automatically removed at design 



load time.

Artwork editor :

  o Unroutes were not being drawn correctly when a part was being moved.
  

Changed in release 107  (4th April 2013)
----------------------

General system :

  o If you right-click on any schematic library folder in the navigator pane, 
you now have
    the option to create a new library folder at that level.
    This new feature has required changes to the file layout of the master 
schematic library.
    On program startup, if no restructured master library is found, a newly 
structured
    master library will be created from the contents of your old format library.
    The contents of your original master schematic library will not be altered 
in any way,
    and remains in place should you ever need to revert to using an earlier 
product version.
    
  o Added 'Rename' and 'Delete' options to the right-click menu associated with 
schematic
    library folders.
        
  o Drag-drop functionality is now available for moving schematic library parts 
between
    the various folders in the master library and between designs.
    Please note that parts that have dependencies on other library entries 
cannot be moved
    or copied by drag/drop.
    When dragging parts between the various schematic library folders, the 
default action
    is 'Move'.  Hold down the Ctrl key to change the action to 'Copy.
    When dragging parts from a design into another design or master library, the
default
    action is 'Copy'.  Hold down the Shift key to change the action to 'Move'.
    Drag/drop 'Move' functionality is not available when removal of the part 
from the drag
    source would break design dependencies.

  o Added drag-drop functionality to copy outlines between designs and the 
master outline
    library.
    
  o Removed the inoperative 'Schematic library manager' option from the 
right-click menu
    associated with the master schematic library folder.
    
  o Removed the redundant library container folder that was located under the 



top level
    master schematic library folder.
    Clicking on the top level schematic library folder now shows the schematic 
library folder
    path in the properties pane.
    
  o Clicking on schematic and outline library folders now displays the number of
library members
    in the property pane.
    
  o If you performed a cross-probing action to locate a net in the artwork view,
and the artwork
    view was not currently open, then a crash could occur.
    
  o Popup message boxes could sometimes go behind the XLDesigner main 
application window giving
    the impressions that the application had locked up. 
    
  o Popup 'balloon' windows could sometimes be shown over the top of the wrong 
window.
  
  o If you repeatedly clicked on the cross-probing buttons in a popup balloon 
window, then multiple
    overlapping ident balloons could be created in the target view.
    
Artwork editor :

  o The Identify->Pin popup balloon window now displays buttons which will 
locate the pin
    in the schematic and netlist editor views.  On initial display and 
subsequent clicks on
    the balloon window, the properties of any associated net will be displayed 
in the properties
    pane.
    
  o The Identify->Track popup balloon window now displays buttons which will 
locate the
    associated net in the schematic and netlist editor views.  Also, clicking on
the balloon
    window will cause the net properties to be displayed in the properties pane.
    
  o The highlight colour palette was incorrectly displaying the user-configured 
layer colours
    instead of a fixed system default set of colours.
    
  o When you minimised an artwork view that had been open 'detached', popup 
balloon windows were
    not always hidden.
    
  o When you maximised an artwork view that was already displaying popup balloon
windows, the
    balloon windows were not redrawn in the correct location.
    
  o When panning and zooming the artwork view, highlighted and fixed nets did 



not display
    correctly if 'View->Net Clearances' was switched on.
    
Circuit schematic editor :

  o Added "Identify->Part Pin" command.  Clicking on a symbol pin will display 
the associated
    part pin identify for the symbol if the part is allocated.  If the part pin 
can be located
    in the net list, then the popup balloon window will contains buttons that 
will located the
    part pin in the artwork and netlist editor views.
    
  o Added "Identify->Connection" command. If you click on a connection segment 
that connects to
    an allocated symbol that can be located in the netlist, then a popup balloon
window will
    display the net name.  Clicking on the balloon window will cause the net 
properties to be
    displayed in the properties pane.
    The balloon window also contains buttons which will locate the associated 
net in the artwork
    and netlist editor views.
  
  o If a terminal pin was added in the symbol view of a schematic sheet, and the
design
    was saved while still in the symbol view editor, then the resultant design 
file was
    saved with invalid terminal data and could not be reloaded.
    
    In addition to correcting the source of this corruption, a fix has been 
incorporated
    which will allow loading of corrupted designs.  A warning will be displayed 
showing
    the name of affected design symbols and the number of invalid terminal pins.
    The invalid terminal pins will be removed automatically, and will need to be
redefined
    by the user.
    
  o When a split part was copy/pasted into a design, the various part elements 
did not appear in
    the split part's folder until the design had been saved and reopened.
    
  o The "Tools->EMC Attribute Tags" parts mode did not correctly locate split 
part symbols.
  
  o If a power symbol was added to the definition of a part, then the power 
symbols could not
    be placed on the schematic until the design had been saved, closed and 
reopened.
    
  o If Region->Copy was used to copy and paste a section of schematic containing
split part elements,
    then the pasted split parts could not be allocated until the design had beed



saved, closed
    and reopened.
    
Outline editor :

  o Added "Copper->Describe Pad" command for identifying the dimensions of free 
copper pads on
    the currently selected free copper layer.
    
DXF profile import :

  o Circles were sometimes imported from the DXF file with the wrong diameter.
  
  o If the last segment of a closed polgon had curvature, then it was imported 
with the
    wrong radius.
    
Gerber Output :

  o When the 'Output used DCodes as' setting is 'RS274X (Extended Gerber)', then
the image
    polarity 'IPPOS' and 'IPNEG' directives will be output in accordance with 
the output
    mode setting.
    
        

Changed in release 106  (1st October 2012)
----------------------

Circuit schematic editor :

  o Corrected serious problem with automatic conversion of old flat circuit 
schematics
    to hierarchical editor format.  Flat schematics with > 1 page would 
sometimes have
    connectivity errors.
    

Changed in release 105  (11th July 2012)
----------------------

Outline editor :

  o Added 'View->Show Outline Filled' command.  This permits outline display to 
be
    toggled between normal and 'pads unfilled / tracks not at width'.
    
  o The outline editor now starts with pin number display switched on by 
default,
    and pads displayed unfilled / tracks not at width.

  o The 'Outline->Change Width' function now operates on outline text as well as
lines.



    
  o Added 'Copper->Add Keepout Circle' function.

  o Added 'Copper->Adjust Arc / Circle' function.  This permits straight line 
sections to
    be converted to arcs and also the moving and resizing of circle features.
  
  o In addition to selecting standard pad angles of 0/90/180/270 degrees, it is 
now possible
    to type other angle values into the pad angle selector box.  Angle values 
will be
    represented to a resolution of 0.01 degrees.
    Please note that it is not currently possible to enter square,rounded ended 
finger or
    square ended finger pads into the free copper section of an outline at 
angles other
    than 0/90/180/270 degrees.  This is an internal database restriction that 
will be
    lifted in a future release.  Custom pads may be entered into free copper at 
any angle
    Pads on pin padstacks are not affected by this limitation.

Artwork editor :

  o Smooth edged copper fill was sometimes omitting the edging line around a 
circular
    keepout area.
  
  o When pulling out via-stubs from SMD pins with 'via autoselect' active, it 
was possible to
    drop via holes on top of holes belonging to other nets.
    Also, if a stub was pulled out and dropped on top of a compatible user via 
from the same
    net, then a duplicate user via hole was inserted.
  

Changed in release 104  (5th May 2012)
----------------------

General system :

  o If a user's MyDocuments folder was located on a Windows server, and that 
user
    attempted to use a host computer that had been detached from the network, 
then
    a message saying 'Cannot locate MYDOCUMENTS' could be displayed and you 
would then
    be locked out of the software.
    
    This message has now been changed to a warning, and the software will 
proceed to
    run as normal.  However, the configuration paths in 'File->System Setup' 
should be



    verified to ensure that they point to locations that do exist on the network
    detached computer.

Changed in release 103  (2nd April 2012)
----------------------

Netlist editor :

  o The netlist can now be sorted by clicking on the column headers.
  
Power name table editor :

  o The power names can now be sorted by clicking on the column headers.
  
Output tasks :

  o When an output task is configured to target a Windows printer, the printer 
selection
    and any selected printer options will now be retained with the task.
    
    If the design is later loaded on a computer not configured with the 
originally selected
    printer, then a warning will be raised when the output task is opened, and 
printer
    selection will revert to the Windows default printer and settings.
    
    It to possible to return output task Windows printer selections to the 
default printer
    at any time.
    Right-click on the output tasks folder and select 'Restore Default Windows 
Printer'
    to restore the default Windows printer on all tasks.
    Right-click on individual tasks and select the 'Restore Default Windows 
Printer'
    option to restore the default Windows printer on the selected task only.
    NB: Output task windows must be closed in order for the restore command to 
operate.
    
General system :

  o If is now possible to restore a design's part prefixes, pad/track sizes and
    power plane feature dimensions to master default values.
    To access this function, right click on the design's 'Configuration' folder
    in the navigator tree and select the 'Restore Design Defaults' option.
    
  o When right clicking on a design's 'Documentation' folder, the 'New' submenu 
was blank.
    It now correctly shows blank document templates as configured in the
    <INSTALL_DIR>\UserTemplate\DocTemplates\index.txt file.
    
  o Because of internal database changes and improvements, designs saved with 
this release
    will not load into earlier versions of XL Designer.



Changed in release 102  (14th February 2012)
----------------------

General system :

  o The pad and track sizes editor has been re-coded to permit sorting of sizes 
by
    clicking on the column headers.  The editor now also uses "in place" 
editing.

  o The power names editor has been re-coded to use in place editing.

Circuit schematic editor :

  o If a symbol was placed on a schematic sheet, and the source library of the 
symbol
    was another design, then a crash could occur after the other design was 
closed.

  o When schematic parts are copied between designs (either by copying/pasting 
directly
    using the navigator pane, or by using symbol->place and using another 
design's
    schematic as the symbol source) the outlines required for the copied 
schematic
    parts will now be imported into the target designs outline library.
    
    (When symbols are placed from the schematic master libraries, the previous 
behaviour
     of not importing required outlines until parts/netlist extraction still 
applies).
     
  o Added a slider control to the parts edit view to enable rapidly moving 
between
    part equivalent symbols.
    
  
Changed in release 101  (10th January 2012)
----------------------

Artwork editor :

  o If any layer is selected as visible in the view control toolbar, then 
clicking the
    'all layers' visibility toggle button will cause all layers to be switched 
off.
    (Previously, they were all being switched on)
    
  o If the artwork top layer was visible, 'Identify->Pad' and 'Identify->Pin' 
would not
    work on visible bottom layer pads.
    



Parts and netlist editors :

  o When saving parts and netlists to a file, the File->Save Parts/Nets dialog 
now allows
    selection of saving the file with spaces or tab separated columns.  The tab 
separated
    output makes it easy to import into spreadsheets and other programs.
    
    When saving the net list with tab separation, the output is restructured 
slightly :
    
      The signal name column for unnamed nets will be blank.  (For space 
separated output, a
      full stop is shown)
      
      Nets nodes will not be continued onto multiple lines.  All net nodes will 
be output on
      a single line.
      
      The net UID values is included.
      
Foreign system import :

  o The Calay parts/net list importer that shipped with the previous Ranger XL 
product has now
    been included in XL Designer.
    
  o The text parts/net list importer could crash when re-importing the text file
if any part
    description or outline values had been changed.

General system :

  o A new entry 'Select Grid Origin' has been added to the 'File->System 
Setup->Special Function Keys'
    dialog.  The initial key definition for this item is blank, but the user may
define
    a key that can be used to activate the Grid->Select Origin action in any of 
the editors.

  O Updated version of reference guide included.

Changed in release 99  (28th November 2011)
---------------------

General system :

  o If the "Save Designs with File Compression" checkbox was unchecked in the 
File->System Setup
    dialog, then designs were still being saved with data compression.
    
Circuit schematic editor :



  o When a schematic was being compiled to parts/net list, artwork connectivity 
tracing and
    unroute generation was inadvertantly being performed for each processed net.
 When an
    artwork had a large number of tracks/nodes, this process can take a long 
time and the
    repeated artwork scanning resulted in the schematic compiler appearing to 
hang.
    The unroute update is now performed only once at the end of parts/nets 
extraction.

DXF profile import :

  o When a profile was imported from a .dxf file, the design modified flag was 
not set.
  
Artwork editor :

  o At the beginning of split power plane and copper fill operations, the board 
profile must
    be processed into a continuous unbroken outline.  When the profile had been 
built from
    multiple line/arc sections where the endpoints did not always exactly meet, 
then this
    profile analysis was failing because it had zero tolerance for endpoint 
mismatch.
    The problem was particularly noticible with profiles imported from .dxf 
files.
    
    The profile analyser now permits slight coordinate mismatch in line/arc 
coordinates.
    The maximum permitted coordinate misalignment is now 0.005".

Profile editor :

  o Added 'Profile->Transfer to Current Layer' function.
    When this mode is active, selected line/arc/circle features will be moved 
from their
    current layer onto the layer selected in the 'Mode' selector.
    This function can be useful to separate profile/keepout data has been 
imported from a
    .dxf file where all the data is on a single layer.

Outline editor :

  o When the grid origin had been snapped to an outline pad, it became 
impossible to escape
    from the Outline->Move point function when moving line endpoints.
    

Changed in release 98 (18th October 2011)
---------------------



Artwork editor smooth edged copper fill:

  o If keepout line/arc features did not form a closed polygon, they were being 
ignored.

  o If a keepout area was drawn with parallel edges that were closer together 
than twice
    the profile clearance value, then the keepout area was being ignored.
    
  o Holes were appearing in copper filled areas and in power planes at the 
location of
    user defined via holes even when the user via hole style did not define any 
pad or
    drilling on the layer.
    
  o Copper fill did not take account of clearance values applied to individual 
nets.
    
  o Added a 'Via Holes' configuration option to the copper fill toolbar.  This 
option provides
    control over how copper fill connects to via holes that are members of the 
fill net.
    Available options are :
      'No Connection' - no heat relief stubs are inserted
      'Heat Relief'   - heat relief stubs are inserted to connect the via to the
fill region.
      'Cover'         - the copper fill floods over the top of the via hole.
    
  o Added 'Component Pins' configuration option to the copper fill toolbar. This
option
    provides control over how copper fill connects to component pins that are 
members of the
    fill net.
    Available options are :
      'Heat Relief'   - heat relief stubs are inserted to connect the part pin 
to the fill region.
      'Cover SMD'     - drilled pins are connected with heat relief stubs.  SMD 
part pins
                        (undrilled pins on layers T/B) are covered over by the 
copper fill.
      'Cover All'     - copper fill covers all part pins.

  o Copper fill toolbar was not remembering the Fill Layer and Fill Size 
selections.
  

Changed in release 97 ( 14th September 2011)
---------------------

Artwork editor :

  o Re-coded the smooth edged copper fill function because of severe accuracy 
and performance
    problems with the previous implementation.



    
  o Added a new control to the copper fill toolbar to control the minimum number
of part pins
    that must be connectable to a copper fill region for the region to appear in
the fill result.
    NB: setting this value to zero will result in the creation of isolated 
copper areas.
    
Artwork checker :

  o When a clearance violation occurred to a keepout area, the error flags could
sometimes
    be displayed at an arbitrary position or not displayed at all.

Changed in release 96  (limited distribution release for new copper fill testing
only)
---------------------
   

Changed in release 95  (24th May 2011)
---------------------

Artwork editor :

   o If a layer swap operation was performed on a track feature that had been 
entered
     with the 'Amend->Enter Tracks' mode, then a crash could occur.
     
   o If layers 'T' or 'B' are selected as invisible, the Identify->Pin and 
Identify->Pad
     functions will ignore pin/pad features on those layers.
     

Changed in release 94  (14th March 2011)
---------------------

General system :

   o When XL Designer is installed on a computer with a 64 bit version of the 
Windows
     operating system, the software will now correctly see Sentinel Super Pro 
security
     keys (dongle) attached to the USB or parallel printer port.
     IMPORTANT: This change requires the Sentinel System Driver to be upgraded 
to version
     7.5.2 or later.  The version 7.5.2 driver is available for download from 
the XL Designer
     downloads web page.

   o The software installer creates an association of the .rxl file extension 
with
     an open action within XL Designer, and stores it in the HKEY_CLASSES_ROOT 
registry



     hive under the key 'XLDesigner.Document' (and also removes it on product 
uninstall)
     
     However, a much older file association registration was built into the 
software.
     This caused an unwanted duplicate association to be created in the registry
under
     the name 'xl_designert'.  This association was not removed on product 
uninstall,
     and could cause confusion if the product was reinstalled to a different 
install path.
     
     The 'xl_designert' association will not now be created.
     
   o In the File->System Setup dialog, the two browse buttons for 'Text I/O Dir'
and
     'Generic Extractors' were the wrong way around/crossed over.
     
   o When the main application window was moved or resized, information 
'balloon' windows
     did not reposition to the correct screen location.
     
   o When an artwork or circuit schematic view was minimised, a cross probing 
locate action
     did not cause the editor window to come out of its minimised state.
     
   o If a design containing schematic split-parts was opened, then closed, and 
another design
     then opened, subsequent schematic/artwork cross probing actions could 
result in a crash.

Circuit schematic :

   o A crash could occur when using any of the non-electrical edit commands when
undo-redo
     was disabled.
     
   o Fixed crash when compiling parts/net list after a component outline name 
change.
     (Customer report ref: DV CL599_A_temp1)
          
Artwork editor :

   o On low resolution displays, it was not possible to see all of the view 
control bar.
     A vertical scrollbar will now appear on tool bars when all of the bar 
cannot be seen.
     
     NB: The artwork view control toolbar has been made slightly wider to allow 
space for the
     scrollbar when displayed.  To ensure that the toolbar is displayed at its 
new width,
     it will be necessary to perform a 'View->Restore Default Layout->Editor 
Layout' action



     within the artwork editor.
     
   o When the boundary lines of a split powerplane polygon formed a closed 
shape, the size
     code of the boundary line was being set to zero. (Bug since release 1.91)
     
   o If a new user defined via hole style was created while the artwork editor 
amend/enter
     pads toolbar was displayed, the toolbar did not update to include the new 
style in the
     pulldown list of available user via styles.
     
   o A crash could occur if a new user defined via hole style was created while 
the artwork
     editor was open.
     
NC Drill output :

   o If a new user defined via hole style was created, and pads of that style 
added to the artwork,
     and then an NC drill output generated without first saving, closing and 
re-opening the design,
     the newly added via holes did not appear in the NC drill output.
     

Changed in release 93  (15th February 2011)
---------------------

General system :

   o The system was not handling UNC filepaths (server shares) correctly during 
the startup
     validation needed before seeding user directories from the UserTemplate 
files.
     This caused the system to abort with an error dialog referring to _mkdir 
failure.
         
   o There was a possiblity of complete lockout from the software requiring 
manual editing
     of the registry in situations where an incorrect configuration path 
existed.
     
     Any configuration path that now fails validation will cause the software to
drop you
     into the System Setup dialog where any errors can be corrected.

Changed in release 92  (14th February 2011)
---------------------

Artwork editor :

   o A crash was occuring when performing a track ripup operation.
   



Artwork checker :

   o The checker was not honouring the 'Include Keepouts' flag correctly, so 
whether
     keepouts were checked or not was indeterminate.
     

Changed in release 91  (14th February 2011)
---------------------

Product installer :

   o GDI+ library was not being installed on systems where it was absent 
(Windows 2000).
   
   o The software was packaged with an incorrect set of WinSXS assemblies 
resulting in
     an oversized installation image file.
   
   o The installer will now correctly register the .rxl file extension and 
create a
     default open action, so double clicking on a .rxl design file will start
     XL Designer and open the design.  (There is however still an issue where 
clicking
     on additional designs will result in an attempt to launch another copy of 
XL Designer
     rather that open the extra designs in the same program instance.  This will
be corrected
     in a future release)
   
   o There has been a rearrangement of how the installer lays out the product 
files within
     the installation target directory.
     
     Before performing an upgrade to this product version, existing users are 
advised to
     make a backup of their configuration data, PCB and Circuit schematic master
library
     directories.  Although we have taken great care to ensure that this upgrade
occurs
     without incident, a backup is good insurance should something unexpected 
occur.
     
     Previously, at install time, the user was given the choice of where to 
place the
     'Configuration Data' directory, 'PCB Masters' directory, and 'Hierarchical 
Circuit'
     library directory. The default was to place them in the following locations
:

       <TARGETDIR>/Data
       <TARGETDIR>/Masters/Pcb
       <TARGETDIR>/Masters/HierCir
       



     (where <TARGETDIR> is the product installation root directory,
      normally 'c:\ProgramFiles\Seetrax\XL Designer').
     
     This install time choice of library and configuration directory has been 
removed from
     the installer, and the supplied default libraries and configuration will be
installed
     into the following structure :
     
       <TARGETDIR>/UserTemplate/Data
       <TARGETDIR>/UserTemplate/Libraries/PCB
       <TARGETDIR>/UserTemplate/Libraries/Schematic
       
     Also, the 'DocTemplates' directory has been moved to the new 
<TARGETDIR>/UserTemplate
     directory.
     
     The configuration files and libraries in the new UserTemplate structure 
never get
     written to by XL Designer.  At startup of XL Designer, a personal 
configuration
     and libraries structure will be created in the user's 'MyDocuments' 
directory, and
     this will be seeded with files from the UserTemplate structure.
     The new personal files structure is layed out as follows :
     
       MyDocuments/Seetrax/XL Designer/Artmacros
       MyDocuments/Seetrax/XL Designer/Data
       MyDocuments/Seetrax/XL Designer/Libraries/PCB
       MyDocuments/Seetrax/XL Designer/Libraries/Schematic

     The seeding of any directory from the above structure will only occur if 
the directory
     is found to be missing, or is empty.  Pre-existing non-empty directories 
will never
     have their contents overwritten with files from the UserTemplate area.
     
     The 'Files->System Setup' dialog may be used to choose different locations 
for the
     various directories within the user's personal data and libraries.
     
     This file layout change overcomes the permissions problems that were 
associated when
     running the application without administrative priviledges on Microsoft 
Vista or
     Windows 7 systems.  When computers are shared between multiple users, it 
also allows
     individuals to edit/pollute their personal configurations and libraries 
without affecting
     other users of the system.  System managers will be able to produce their 
own sets
     of configurations and design libraries and copy them to UserTemplate area 
to be used
     as the initial defaults for all users.



     
     As in previous releases, it is possible to configure the system to continue
using
     master libraries/configurations shared amongst multiple users.  Just access
the
     'File->System Setup' dialog and ensure that the Configuration Data 
directory, PCB Masters
     and Schematic Masters directory paths point to your shared content.  As 
long as these
     directories are not empty, files from the UserTemplate area will never be 
copied over
     the top of your shared libraries and configuration.  Please note that when 
running on
     Vista/Windows 7, you will still need to take administrative action to 
ensure that all
     users have appropriate access permissions to the shared content.
     
     Apart from making the recommended backups, no special action needs to be 
taken before
     upgrading to this version of XL Designer.
     The new UserTemplate structure will be created and populated with the 
supplied libraries
     and configuration.  Previously configured paths to user's configuration and
library
     directories will be honoured, and never overwritten.
     
     When performing reinstalls or future upgrades, the custom install option 
permits the
     user to exclude installation of the default configuration and libraries.  
This would
     be desirable when the UserTemplate area had been customised.
     
     Product 'Uninstall' will never remove any files from the 
<TARGETDIR>UserTemplate structure.
     
Product license :

   o Prior to this release, the product license key was stored in the system 
registry in the
     <HKEY_LOCAL_USER> hive.  In a shared user environment, each individual user
had to install
     the product license key.
     
     The license key is now stored in the <HKEY_LOCAL_MACHINE> hive, so the key 
now needs to
     be installed just once, and will be available to all system users.
     
     On startup, if a key is found in the old location, but not in the new 
location, the key
     will be copied into the new registry location, so no special action need be
taken
     during upgrade.
     
Profile editor :



   o When keepout areas are entered which form a properly closed polygon, then 
the area is
     displayed cross-hatched.
   
Artwork editor :

   o NEW FEATURE: A new 'View Control' dialog bar has been added to the artwork 
editor.  This
     brings together all the visibility controls that were previously available 
from the
     artwork 'View->Set Colours' and 'View->Setup Visibility' dialogs (which 
have been removed).
     All buttons on the view bar have 'tooltips' enabled, so hover over any 
button to get a
     description of the button's action.  The layer on/off buttons have layer 
usage and point
     count information in their tooltips.
     
     The unroutes 'Net' button allows manual selection of which unroutes to 
display.  When this
     button is checked, right click on a net in the navigator, and choose 'Show 
net unroutes'.
     Multiple nets may be selected and switched on/off.
     
   o NEW FEATURE: When the artwork icon is selected in the navigator, the 
'Properties' pane will
     now display a layer type and point count summary for all the artwork 
layers.
     
   o After routing a board with the artwork built in autorouter, the 'design 
modified' flag
     was not set.
     
   o The 'Amend->Corner' mode was incorrectly allowing segments of copper fill 
to be selected
     for new node insertion.  This resulted in artwork corruption.
     Corner insertion is not currently supported on copper fill segments.  Only 
point move
     and segment delete is available.
     
   o When entering a boundary line for a split powerplane polygon, a crash could
occur if the
     line was terminated without the polygon being closed, and a new separate 
line segment then
     entered to complete the polygon.
     
   o When a split powerplane polygon line was entered without forming a closed 
polygon, and
     another edit action was selected, the 'Add Line' command became greyed out 
so no further
     line segments could be entered.
     
   o Keepout areas are now displayed cross-hatched.



Artwork checker :

   o NEW FEATURE: The artwork checker now tests for violation of keepout areas. 
These are
     flagged on the artwork with a letter 'K' marker.  This extra check can be 
enabled/disabled
     on the art checker run dialog.
     
Electra/Specctra optional autorouter interface :

   o Keepout areas defined within component outlines were not being included in 
the exported
     router design file.
     

Changed in release 90  (17th January 2011)
---------------------

General system :

   o Because if the new features introduced with this release, designs saved 
with this
     release will not load into earlier versions of XL Designer.

Outline editor :

   o It is now possible to define keepout areas within a part outline 
definition.
     Keepout zones should be defined using the 'Copper->Add Keepout Line' 
function.
     A closed shape should be drawn defining the required keepout area.  Keepout
areas
     may be defined for the board Top, Bottom or 'All' layers.  NB: to see these
new outline
     specific keepouts within the artwork editor, the 'Keepouts' checkbox must 
be ticked
     in the "Artwork View Properties" dialog.
     
   o A new 'Star Points' checkbox has been added to the Routing Constraints 
section of the
     outline properties dialog.  When this checkbox is set for a component 
outline, the
     outline takes on a special mode of behaviour used for star-connecting 
multiple nets
     at a single point.  Please read Star Points section below for a detailed 
overview of
     this new facility.
     
Artwork editor :

   o Gridded copper fill did not honour keepout areas.
   
Starpoints :



   o It is now possible to use star-connected nets within a design.
   
     A sample design (Starpoints Example.rxl) using this new facility is 
included with this
     product release and can be found in the 
<ProductInstallationDir>/SampleDesigns/PCB folder.
     The example also demonstrates the use of a keepout area placed within an 
outline definition.
     
     The first step in using star points is to create a special component 
outline that when
     placed on the artwork defines the track geometry for the location where the
nets meet.
     
     To begin creating a star point outline, create a new blank outline as 
normal, then before
     adding any other features to it, select View->Properties (within the 
outline editor)
     and check the 'Outline is a Routing Star Point' checkbox.
     
     Pads should now be added to the star point outline.  One pad is required 
for each net that
     will be connected at the star.  The pads may be placed on the Top, Bottom, 
or 'All' layers.
     Any pad style may be used.
     
     The pads should then be interconnected by inserting 'free copper' on the 
top, bottom or 'Any'
     layer.
     
     Keepout areas should then be added to the outline using the Copper->Add 
Keepout Line function.
     The keepout areas limit the scope of autorouters and the copper fill 
routines from placing
     copper through the centre of the star point outline. The areas must not 
enclose any of the
     connection points on the outline.  Please read the implementation section 
below for more detail
     on this.
     
     A schematic part symbol that references the star point outline should be 
created, and one
     terminal placed for each pin on the star point outline.  The pins should be
numbered as for
     any normal part.
   
     At the schematic level, each net that must meet at the star must be created
separately, and if
     named, each must have a unique name. Each net must then be connected to one
of the pins on the
     starpoint part symbol.
     
     Within the artwork, the star point part should be placed at the desired 



location, and the board
     may be routed, copper filled and checked as normal.
     
Starpoint implementation method :

   o The method chosen to provide star point capability is simple, but hopefully
effective.
   
     The free copper features that interconnect the various star outline pads is
never seen by
     the artwork autorouter, the copper fill routines or the artwork checker.  
The only time it is
     present is during screen display and when creating artwork outputs.
     
     To prevent the autorouter and copper fill routines from placing copper in 
the area of the
     star outline occupied by the interconnecting free copper traces, a keepout 
area must be defined
     within the star outline.  By using a keepout to prevent nets from violating
the star
     interconnections, there is no need for the artwork checker to process the 
star interconnections
     and shorts will not be detected between the nets.
     
     Because the artwork checker does not verify the copper connections between 
the star outline pins,
     you must manually verify that your outline does actually perform the 
desired interconnectivity
     between its various pads.
     
Starpoint implementation features not yet complete :

   o Outline based keepout areas do not get included in router files created for
the optional
     Electra/Specctra autorouters.
     
   o The artwork checker does not yet check for clearance errors or violation of
the keepout areas.
   
   o Both the above two ommisions will be corrected in the next release. (approx
7 days time)

      

Changed in release 89  (7th January 2011)
---------------------

Artwork editor :

   o CRITICAL BUGFIX:
     Every time that the artwork was repainted, one 'Graphics GDI' object was 
leaked.
     This resulted in redraw performance degrading each time that the artwork 
display was



     refreshed, and the process eventually running out of graphics resources 
causing the
     program to crash.

General system :

   o Behaviour change for 'partial unroutes'.
     If a trace is only partly routed from source to destination, then 'partial'
unroutes
     occur at the start and end of the trace.  These are shown dotted to 
discriminate them
     from normal unroutes which are shown solid.
     
     Internally, partial unroutes are handled very differently from normal 
unroutes, a partial
     unroute being nothing more than a continuation of the part routed track 
with a special
     dotted visibility mode for the start/end segment, and also made invisible 
to output tools
     and the artwork checker.
     
     Using 'Amend->Move Point', it is possible for a user to pick up mid points 
of a partially
     routed track, and attach them to part pins or via hole locations, thereby 
forming a
     connection, the netlist then being patched up later to match the manually 
contrived
     connection. However, the connected trace does not finish at the part pin as
it was only
     a mid point node that was moved.  The trace still continues on past the pin
and finishes
     at the end of the partial unroute which has been abandoned.
     
     These abandoned partial unroutes cannot then be easily removed, and 
unroutes regeneration
     and artwork checking will not remove them.
     
     To assist in cases where such routing action has been performed, the 
following changes have
     been made :
     
        When a design is loaded, the artwork is scanned for all tracks having 
partial unroutes.
        If any partial unroute is found where the 'inboard' node (ie. the 
partial unroute node
        farthest from the end of the trace) is connected to a part pin or a via 
hole, then that
        partial unroute segment will be removed.
        
        When the inboard node of a partial unroute is moved with 'Amend->Move 
Point' and attached
        to a part pin or via hole, the partial unroute will be removed.
        
     



Changed in release 88  (30th December 2010)
---------------------

Artwork checker :

   o If the type of a layer was switched from power plane type to copper type, 
and the
     layer had existing powerplane antipads/heat reliefs, then these unwanted 
pad
     features were not included during an artwork check, and undetected short 
circuits
     and gap errors could occur.
     
     The artwork checker will now test all 'copper' type layers to determine if 
any
     antipads or heat-reliefs are present, and will abort artwork checking if 
any
     are found.  A report of the unwanted pad locations will be displayed.
     (For an easy way to clean out these unwanted pads, please read next note)
     
General system :

   o The artwork delete tool (accessible by right-clicking the artwork icon in 
the navigator)
     has been updated.  A new delete option 'delete features that are invalid 
for layer type'
     has been added to the tool.  The new mode will remove antipads and heat 
reliefs which are
     found on a 'copper' type layer.

   o When the type of a non-empty artwork layer is switched between power plane 
and copper
     type, a warning will be displayed advising the need to delete existing 
layer contents.
     
   o The design modified '*' flag was not being set in the following situations 
:
       
       During any changes to the schematic when schematic 'undo/redo' was 
disabled as a
       temporary performance workaround.
       
       When an artwork power plane was generated.
       
       After making a board profile edit with the numeric editor.
     
   o The design modified '*' flag was incorrectly being set in the following 
situations :
   
       After opening and closing a plot batch, even if no changes were made.
       
       After highlighting tracks in the artwork editor.
       



       

Changed in release 87  (8th December 2010)
---------------------

Circuit schematic :

   o Added attributes import/export facility.  Import/export commands may be 
accessed by
     right clicking on the top 'Schematic' folder for a design, or the top 
folder of a
     master library (eg. schematic folder '74xx')
     
     Exported attributes may be saved into tab separated (.txt) or comma 
separated (.csv)
     files as selected in the save dialog.
     
     The first row in the created file will always contain the column names for 
the data
     in the following rows.  The first column is always the name of a 
block/part/symbol in
     the schematic or library.  Each additional column represents an attribute 
setting.
     
     To export a file suitable for editing in Microsoft Excel spreadsheet, it is
recommended
     to export attributes as a tab separated (.txt) file.  On loading, Excel 
will display
     an import Wizard where you may change the type of all imported columns to 
'text' type.
     If you do not do this, and try to load from a .csv format, Excel always 
treats strings
     of digits as numbers, which is a problem if some of your symbols/attributes
have all
     numeric names with leading zeros.
     
Artwork editor :

   o If the artwork did not contain any placed parts, then pads entered with 
'Amend' mode
     were always drawn unfilled even if filled drawing mode was selected.
     
     

Changed in release 86  (26th November 2010)
---------------------

Design outputs :

   o Bitmap image output was not creating arc features correctly.
   
   

Changed in release 85  (24th November 2010)



---------------------

Design outputs :

   o Added bitmap image output capability.  This filter may be found under the
     new output group category "Image file".
     Images may be saved in PNG, BMP, GIF or JPEG format.
     When adding image output tasks to batch outputs, you must append the 
appropriate
     .png, .bmp, .gif, or .jpg file name extension to each output file name in 
order for the
     appropriate output encoder to be selected.
     
   o Removed redundant "2D Drawing" category from the list of plot tasks that 
can be created.

   o Schematic non-electrical "Annotate" mode features were not being included 
in the
     calculation of the "Fill Sheet" view.
     
Artwork editor :

   o Added "All powerplanes" checkbox to the powerplane generator toolbar.  When
this is
     ticked, the "Generate" button will create all powerplanes in one operation.

Changed in release 84  (25th October 2010)
---------------------

Artwork editor :

   o When a component outline containing standard pad shapes was placed in the 
free copper
     section, and the part was rotated on the board to angles other than 
0/90/180/270
     degrees, then the copper insertion action of the mask generator tool was 
placing
     pads on the artwork layers at the wrong angle.

Changed in release 83   (28th September 2010)
---------------------

Circuit schematic editor :

   o Identify->Instance did not work correctly for block I/O symbols.
   
   o Symbol->Copy could sometimes crash when copying block I/O symbols.
   
Artwork editor :

   o Powerplane generation could crash on split power planes if no polygon was



     defined for a secondary signal.

   o Track ripup could crash if you ripped up a track that was not correctly
     associated with a net.
     
   o When ripping up tracks a segment at a time (with the LH mouse button), you
     must rip the tracks segment by segment starting at a component pad.
     When there were very tiny track segments at the start of a route to force a
     track onto the routing grid, it was not always possible to see that you 
were
     not clicking the first/last segment connecting the pad, and the ripup 
operation
     was ignored.
     During segment by segment ripup, all very short track segments (<0.01" 
long) that
     are adjacent to the selected segment will no longer inhibit ripup, and they
will
     be removed together with the selected segment.

  o Mroute->Move Track command was causing a crash.
  
  o The power plane generator was not honouring the "Use Heat-Relief when 
connecting
    to power planes" flag in user via hole definitions.

Changed in release 82   (8th September 2010)
---------------------

Circuit schematic editor :

   o If a schematic view was opened before any circuit view had been shown in 
the
     browser window, then display colours were not configured correctly.
     This wis normally seen as a wrong coloured grid after the schematic had 
been
     opened via an artwork 'Find' command.

Artwork editor :

   o Unroutes were not always correctly removed when user defined via holes were
     in a route.
     
Artwork checker :
     
   o The artwork checker was not always revalidating unroutes on completion.
     
General system :

   o Reference guide updated.



Changed in release 81   (6th September 2010)
---------------------

Outline Editor :

   o Pad->KeyMove command could cause a crash when moving a custom pad where the
     pad's name was longer than 11 characters.

Artwork editor :

   o If a user defined via hole did not have 'Allow in power nets' checked in 
the
     via hole definition, the hole style was still being selected automatically
     when manually routing power nets.
     
   o The powerplane generator was inserting an antipad on a powerplane layer for
     user defined via holes even if the hole definition defined the stack as not
     passing through that layer.
     
   o When dragging out power unroute stubs for smd power pins, user defined via 
holes
     were not being selected when the autoselect option was on. 
     
   o Equalised the width of all toolpanes to reduce unnecessary screen redraws 
when
     moving between various edit modes.
     
     
Gerber file generation :

   o Gerber output tasks were crashing if a used pad had zero dimensions in the
     sizes table.
     
General system :

   o When toggling between inch/metric units in the user defined via hole 
definition
     editor, the drill hole size value did not change.

Changed in release 80   (18th August 2010)
---------------------

General system :

   o Corrected incorrect display of lines that were partly out of the view 
window.
     (Bug only occurred in release 1.79)

   o Corrected a configuration problem where version 1.79 was compiled without 
code
     optimisation.

Artwork editor :



   o When layer colours were redefined, the layer colour indicator boxes in the 
manual
     routing, pad/track/text editing, region rules and copper fill toolbars did 
not
     update to show the new colours.
     
   o Changed the manual routing tool pane to display layer selection checkboxes 
for all
     copper layers.  To help with understanding the topology of multilayer 
boards, layers
     are presented in the tool pane in the assembly order defined for the board.
     Powerplane layers are also shown in the appropriate places.
     
   o Added a 'Via Autoselect' option to the manual routing tool pane.  When this
is checked
     and the system needs to insert a via hole while performing a layer swap or 
point
     insertion operation, then the via hole will be automatically selected from 
the
     user defined via hole set.  The system will attempt to locate a via hole 
that traverses
     the minimum number of board layers while still providing the correct 
connectivity.
     If 'Via Autoselect' is not checked, or auto mode can find no suitable via, 
then a normal
     through-board via is inserted.
    

Changed in release 79   (4th August 2010)
---------------------

General system :

   o When running on Windows 7 or Windows Vista with Data Execute Protection 
(DEP)
     enabled, a crash would occur when using any action that caused a popup
     'balloon' information window to appear.
     
   o A 'Colour table overflow' message would sometimes occur when browsing items
in
     the navigator window.
     
Circuit schematic editor :

   o Internal roundoff errors caused connections to sometimes not be correctly 
associated
     with symbol pins when metric grids were in use for symbol creation and 
schematic
     drawing.

   o Added a 'Disable Schematic Undo/Redo' checkbox to the 'Temporary fixes' 
area



     of the 'File->System Setup' dialog.
     The schematic editor Undo/Redo functionality currently has performance 
problems
     when working on large schematics.  As a temporary measure to help customers
speed
     up work on large schematics, it is now possible to switch off the undo/redo
code.
     

Changed in release 78   (14th June 2010)
---------------------

Artwork editor :

   o CRITICAL BUGFIX:
     When Amend->ReplacePad was used to change the style of a pad, the net 
identity
     of the modified pad was not always correctly retained.  The problem showed 
up
     most often when swapping standard via holes to a user defined via hole 
style.
     Once a pad's identity became lost or corrupted, this caused erratic 
behaviour
     in the correct selection of heat-reliefs/anti-pads when creating power 
planes,
     and also caused unroutes to be displayed where none were expected.
     
     Performing an artwork check will often correct the invalid net identity on 
the
     affected pads.  However, no connectivity problems must exist for the 
checker to
     be able to clean up incorrect net identities on artwork features.
     
   o Every time the amend pads mode was activated, custom library pad names and
     user defined via hole styles would be repeatedly added to the pad style and
     user via pulldown lists in the amend pads toolbar.

 General system :

   o The Via Hole Definitions editor was not remembering drill hole diameters 
correctly.

    

Changed in release 77  (8th June 2010)
---------------------

Artwork editor :

   o The state of the 'show filled pads' selection was not being preserved with 
the
     design.
     
   o When a track was ripped up from an SMD part pad that connected to a power 



plane
     via a stub and power via, the unroute 'blob' did not reappear on the part 
pad.

Circuit schematic editor :

   o Colour configuration was not being saved correctly with the design.
   
   o Colour configuration changed erratically when moving between designs and 
views
     with different colour setup.
     
          

Changed in release 76  (17th May 2010)
---------------------

General system :

    o When a circuit schematic was recompiled while the artwork editor was open,
      and the recompilation caused a part outline to be replaced, and the 
replacement
      outline had a different pre-routed copper arrangement, then a crash could 
occur.

    o When a circuit schematic was recompiled while the parts list editor was 
open,
      and the recompilation caused extra parts to be inserted, then a crash 
could occur.

    o If autosave was enabled and an unsaved job was open, the "Design Autosave 
reminder"
      dialog was posted to the screen every 10 seconds.

    o When performing a design "Save As", the original name is now displayed in 
the
      file save dialog.

    o Reordered some design icons in the navigator window to better reflect 
typical
      design flow.

    o Identify commands which displayed popup 'balloon' windows with no close 
button
      became stuck on the screen if their associated identify command was 
cancelled
      while the balloon was panned offscreen.
      
    o The navigator was automatically scrolling and expanding folders in order 
to show
      currently selected entities when working inside the various editors.
      This behaviour has now been changed.  Selected entities will now be shown 
in the
      browser/properties window but the navigator will not scroll and expand 



folders
      to show the item.
      The browser and properties window now contain a "Find" button.  Pressing 
this
      will cause the navigator to locate the item shown in the browser/property 
window.

Artwork editor :

    o Added a horizontal scrollbar to the net selector within the powerplane 
toolbar.
      The powerplane toolbar has also been increased in width to accommodate the
      display of longer powerplane subnet signal names.

    o The part placement tray was sometimes showing parts that were already 
placed.

    o Large time delays occurred when using undo/redo with a large number of 
parts in
      the part placement tray.

Circuit schematic editor :

    o When a block I/O port was duplicated using the Region->Copy and 
Region->Paste
      commands, then the resultant I/O port was forgetting its attribute values.

    o When multiple instances of a sheet occurred in the design hierarchy, the 
ident
      (suffix number) of the instance being edited was not displayed in the 
window
      title bar (or window tab when in maximised view mode).

      

Changed in release 75  (30th March 2010)
---------------------

Artwork checker :

    o When a power net was used simultaneously on more than one power plane 
layer, the
      artwork checker was reporting 'interplane shorts' for drill holes that 
correctly
      interconnected the layers.

    o The checker will now report parts that are unplaced or are placed outside 
of the
      board profile.



Changed in release 74  (1st March 2010)
---------------------

Artwork editor :

    o When a split powerplane was generated, the subnet boundary polygons were 
not
      being tagged with the correct net identity.  This caused them not to be 
recognised
      by the Specctra/Electra autorouter export function.
      (To correct this problem on affected designs, use the powerplane 
'Generate' button
      to recreate each power plane layer)

Changed in release 73  (22nd February 2010)
---------------------

Artwork editor :

    o A crash occurred on entering the powerplane generation mode if any net 
contained
      a reference to a non existent part pin.
      
Circuit schematic editor :

    o Fixup crash at schematic load time when allocation data was bad.
    

Changed in release 72  (17th February 2010)
---------------------

Artwork editor :

    o Reimplementation and simplification of the powerplane generation mode.
    
      It is now possible for a power net to be used simultaneously on more than
      one power plane layer.  However, the artwork checker currently reports 
such
      usage as 'interplane shorts'.  This problem will be fixed in the next 
release.
      
      Split power plane net selection is now performed in the Configuration->
      Layer Assignments and Ordering dialog in the Navigator pane.
      
      Split power plane subnet polygons are now retained with the design, so it
      is no longer necessary to import them from the powerplane layer to 
regenerate
      a powerplane.  The import function is retained for compatibility with 
existing
      design files.
      
      The user guide included with this release still refers to the previous 
powerplanes



      implementation.  An updated guide will be included in the next software 
release.
      
      NB: Designs saved with this version of XLDesigner are not compatible with,
and
      cannot be loaded into earlier releases of the software.
      

Changed in release 71  (3rd December 2009)
---------------------

Circuit schematic editor :

    o When old 'flat schematic editor' circuits were converted for use in the
      hierarchical schematic editor, some connections were not correctly
      processed.  The hierarchical editor has a strict rule that only 
'ednpoints'
      of connection wires are permitted to be attached to symbol terminals
      and connection 'blobs'.  Some converted schematics were not complying
      with this requirement, and after subsequent editing of the schematic,
      internal inconsistencies occurred which resulted in a program crash or
      incorrect netlist compilation results.

      This bugfix corrects the incorrect initial conversion, and also fixes
      up the inconsistencies that have resulted from editing of the affected
      schematics.

Changed in release 70  (9th November 2009)
---------------------

Artwork editor :

    o After a region delete operation had been performed, the Mroute->RipUp
      and Mroute->Corner operations would cause a crash.

    o A crash occured after using the silk screen generator to add outline
      free copper to the artwork.

    o Part renumbering and gate/pin swap history will now be logged into the
      'renumber' file in the design log files folder.

    o Network changes made with the Tools->Network commands will now be logged
      into the 'netmods' file in the design log files folder.

    o A crash could occur when you moved or flipped a part having pre-routed
      copper features defined in the outline.

Outline editor :

    o Added Copper->Key Move Pad command.

    o Added Copper->Change Pad Style/Size command.



    o When alternating between outline mask editing and free copper editing,
      the free copper functions became confused as to which layer to enter
      features into.

    o Pad style and size controls have been added to the toolbar.  When pad 
style/size
      is changed in the toolbar, the navigator and browser windows will update 
to
      display the selected pad.  Pads may also be selected directly from the 
navigator
      (as before) and the outline editor toolbar controls will update 
accordingly.

Circuit schematic editor :

    o When using the region commands, the region rectangle corners and move/copy
      destination will now always snap to grid/half grid even if "Snap to Grid"
      is disabled in the Grid menu.

    o When a flat schematic was converted, the associated parts did not have 
their
      pin swap rules imported.

    o When a flat schematic was converted, instantiated part symbols that were
      members of a part with >1 available instance were not tagged with the 
correct
      sub-instance reference if 'gate' (part element) swapping had been 
performed
      within the old flat circuit editor.

    o If two wires were butted end-to-end on a flat schematic with no junction 
blob
      or part terminal at their join point, then connectivity was not preserved
      through the wire in the converted schematic. (Lloyd research 'Nets not 
being
      joined by signal name' bug report)

General system :

    o Added "Edit Datasheet Addresses" to the navigator top level schematic 
folder
      right-click menu. This permits bulk assignment of datasheet addresses to 
each
      schematic part/split-part.

    o Enabled the "Show Datasheet" option in the right-click navigator menu 
associated
      with schematic parts.  Please note the command will only be active for
      parts that have the datasheet address attribute defined.

    o Added "Purge Unused Outlines" commands to the right-click navigator menu
      associated with outlines.



    o Enabled the "Purge Unused Blocks" commands in the navigator top level
      schematic folder right-click menu.

    o When trying to delete custom pads from the pad library, a "dependency 
checks
      not coded" error was displayed.

    o Reference guide updated.

Changed in release 69  (11th September 2009)
---------------------

Artwork editor :

    o If you generated a power plane, then left the power plane tools menu
      and selected 'Undo', a crash would occur.

    o After using 'Redo', all entries vanished from the part placement tray
      and you had to exit and restart the program to recover them.

    o When an 'Undo' operation caused a net or part of a net to return to
      an unrouted status, then all signal names vanished from the net list.

Circuit Schematic :

    o Added Undo/Redo capability.

Design Outputs :

    o Added HP-GL pen plotter output filters.

General system :

    o Reference guide updated.

Changed in release 68  (29th June 2009)
---------------------

Circuit Schematic :

    o If a block I/O symbol was deleted from a schematic sheet, and the 
corresponding
      symbol for the schematic was instantiated on other schematics in the 
design,
      and the pin being deleted was connected on those other schematics, then an
internal
      inconsistency occured which resulted in compilation errors.

      When you delete an I/O pin, the system will now warn you if that pin is 
connected
      elsewhere in the design hierarchy.  If you continue to delete the pin, the
attached



      connections will now become correctly deassociated with the pin.

    o When a schematic compilation caused part outlines to be fetched from the 
master
      outline library, the outline pad dimensions were not being correctly 
merged from
      the master library into the design library.

    o It is now possible to have block names with / in them.  eg. I/O
      Please note that designed created with such names will not load into 
earlier versions
      of XL Designer.

Changed in release 67   (12th June 2009)
---------------------

Circuit Schematic :

    o When entries were deleted from the schematic part folders within a design,
those
      deleted part names would appear as empty user blocks if the design were 
opened
      in RangerXL.  XL Designer was not affected by this problem.

    o When a schematic part or userblock was fetched into a design from a master
library
      or another design, the type of the block in the source library was 
inadvertantly
      set as 'split part'.  If the source library or design were subsequently 
edited
      and saved, then the block became stored as a split part regardless of its 
correct type.
      The part entered into the destination design received the correct block 
type.

      To assist in correcting the wrong block type on designs and libraries 
affected by
      this bug, a command "Change Block Type" menu has been added to the 
'right-click'
      context menu that is displayed when you right click on a schematic split 
part in
      the navigator.  Choose the appropriate submenu entry to alter the selected
split
      part to be a userblock, part, primitive or blockio symbol.
      After changing a block's type in this way, the design should be saved, 
closed and
      reopened in order for the parts to appear in their correct navigator 
folders.

      NB: The "Change Block Type" menu is not normally visible, as it is only 
intended
      for recovery of corrupted designs.  To enable the menu, enter the 
File->System Setup



      dialog and check the "Enable Schematic Block Type Change" box.  Please 
note that
      XL Designer always starts with this feature disabled. (ie. the enable 
checkbox state
      is not remembered)
      
    o Back compatibility note:  When a design containing schematic split parts 
is opened
      in Ranger XL, the split parts will appear in the 'parts' section of the 
parts selector
      together with all the normal parts.  Ranger XL does not differentiate 
between split/non-split
      parts in its parts browser.  XL Designer correctly separates them out into
their appropriate
      folders.  This has caused some users to believe that XL Designer is 
wrongly categorising
      normal parts as split parts.

Changed in release 66
---------------------

Artwork editor :

    o If you right-click on the artwork icon in the navigator, and choose
      'open detached', then the artwork will open in a separate window that
      may be dragged to a second monitor.

General system :

    o 'View->Restore Default Layout' command has been added.  This will restore
      the default visibility and positioning of the navigator, browser and
      status panes.

    o Reference manual updated.

    o IMPORTANT : This product update requires a version 2 license file.
      Previously issued licenses will require upgrading.
      (Not relevant for XL Designer Lite version)

Changed in release 65  (26th January 2009)
---------------------

Bath Scientific test point generator :

    o A crash was occuring when generating test data for some designs.

Artwork editor :

    o The autoplace, autoroute, copper fill and powerplane modes now
      contain a back arrow on the toolbar which will return you to
      manual place/route mode.



Netlist editor :

    o The displayed network 'MinClear' value was not being updated when
      you changed between inch/metric units.

General system :

    o When the inch/metric hotkeys (normally F9/F10) were used, values
      were shown incorrectly in certain system dialogs
      (eg. Artwork editor Parts->Keymove, Outline editor Text->Add,
       Manual routing parameters dialog, Schematic attribute edit height
       values)

    o A crash could occur if you had the artwork and parts list editors
      both open, and you deleted a part from the parts list when that
      same part was also in the artwork part placement tray.

    o Corrected a roundoff error when points were being snapped to a
      metric grid.  (This error had been observed when checking the
      coordinates of profile lines using the profile numeric editor)

    o The system should not have allowed an outline to be renamed when
      the outline is referenced in the parts list.

    o Added 'Delete all Parts & Nets' action to the right-click menu for
      the navigator Parts folder.

    o Added 'Delete all Nets' action to the right-click menu for the navigator
      Nets folder.

Changed in release 64 (11th December 2008)
---------------------

Artwork editor :

    o When a design uses library pads or buried vias, an internal hidden
      table is created to map drill sizes required for these pads into
      a size code that can be applied to power plane heat reliefs and
      anti pads.  An internal error in the management of this table
      resulted in power plane features being created with the wrong
      drill size associated with their size code.  This resulted in
      anti pads and heat reliefs around buried via and library pad
      drill holes begin generated with the wrong dimensions.
      
      Designs affected by this problem can be recovered by regenerating
      the power planes.
      

Changed in release 63 (5th December 2008)
---------------------

Circuit Schematic :



    o Find->Signal Name was displaying an 'Internal Error' dialog if a
      search was attempted on a signal name that did not exist on the
      schematics.
    
    o If you began entry of a connection, and terminated the insert mode
      by selecting another menu operation (instead of clicking on a symbol
      terminal,or dropping the connection with the right mouse button), then
      a crash would occur.

Outline Editor :

    o While a component outline was open for editing, every design save
      operation could cause a shift of the component outline and autoplacer
      footprint box positions if the 'Outline->Set Outline Datum' command
      had been used.

General system :

    o A crash could occur when a design was closed.
          

Changed in release 62 (24th November 2008)
---------------------

Circuit Schematic :

    o Circuit schematic undo/redo operations have been temporarily
      disabled.  They will be re-enabled as soon as their defective
      operation has been corrected.

    o Crash occurred if you used 'Terminals->Assign Names' and edited
      a terminal name that was > 16 characters long.

Outline Editor & Artwork Editor :

    o The Outline->Corner and SplitBoundary->Corner commands could cause
      a situation where the line endpoint could not be released.

Parts list editor :

    o When units were toggled between inch/metric, the displayed component
      position values were displayed incorrectly.

Artwork editor :

    o The artwork checker 'Include copper fill' box should have been checked
      automatically if the artwork contains copper fill features.
      Also, if copper fill had been created and then deleted, the artwork
      checker was warning that the 'Include copper fill' mode was not selected
      even though the artwork no longer contained filled areas.

Changed in release 61 (10th November 2008)
---------------------



Circuit Schematic :

    o When a schematic sheet containing placed power block symbols was
      open for editing, and the 'paste' operation was used to add extra
      parts to the schematic parts folder, then a crash could occur.

    o The 'Find->Signal Name' command did not work correctly. It should
      now function in a similar manner to the find part and find net commands
      which present 'previous/next' buttons in the popup balloon window
      to enable moving through all instances of the signal name.

Changed in release 60 (3rd November 2008)
---------------------

General system :

    o Includes updated version of the XL Designer Reference Guide.

    o Added 'Documentation' folder to design tree.
      It is now possible to create documentation files which are stored
      internally within a .rxl design file.

      To create a documentation file, right click on the 'Documentation'
      folder within a design, and choose the appropriate file type from
      the 'New' menu.
      It is possible for the user to customise the file types that are
      presented in the 'Documentation->New' menu :-
      In the \Program Files\Seetrax\XL Designer\ product installation
      directory, there is now a subdirectory named 'DocTemplates'.
      The DocTemplates\index.txt file defines all the file extensions
      and file descriptions that are to appear in the Documentation->New
      menu.  When editing this file, the extension and description fields
      must be separated by a single tab character.
      For each file type defined in the index.txt file, if a corresponding
      file named 'templates.{extension}' is created in the DocTemplates
      directory, then that file will be used as the initial file content
      for newly created documentation files.  If no template file is
      created for a file type, then the 'New' file action will create
      an empty (0 bytes long) file.
         
      The documentation file 'Import' action allows any existing file
      to be added to the documentation folder of the design.

Changed in release 59 (13th October 2008)
---------------------

Artwork editor :

    o If Active DRC was enabled, then a crash could occur when trying to
      insert a point into an unroute.



Circuit Schematic :

    o When Ranger XL designs containing flat schematics were opened, the
      converter was re-converting the flat schematic to hierarchical mode
      every time the design was saved and reopened, thereby destroying
      any subsequent editing of the schematic.

    o When a flat schematic is automatically converted to hierarchical mode
      on design opening, a report of the converted schematic pages will be
      displayed, and a 'flatcircuit_conversion' entry will be created
      in the design logfiles.

General system :

    o If you used keyboard up/down arrow keys to move through entries in
      the navigator, then the properties and browser panes were not updated.

Changed in release 58 (7th October 2008)
---------------------

Artwork editor :

    o If an unroute was picked up with the Mroute->Move Unroute command,
      and the operation then cancelled with the right hand mouse button,
      the unroute was not being redisplayed.  An artwork check, job
      close and reload was needed to make it come back.

Outline editor :

    o It was not possible to use auto pad assign on a bga outline having
      pads on a 0.5mm pitch as it was incorrectly assigning pads on
      adjacent rows/columns.

General system :

    o The navigator did not restrict the name length for custom pads, outlines,
      schematic parts, output tasks and batches, but when the design was
      saved, the names were truncated to the various internal system limits.
      (Custom pad and outline names were truncated at 16 characters.  Schematic
       parts, output tasks and batches were truncated at 20 characters).
      The navigator will now prevent the entry of element names longer than
      the internal system limits.
      
    o The maximum permitted name length for output tasks and output batches
      has been raised from 20 characters to 80 characters.
      NB: If designs are created with output task/batch names > 20 characters,
      and then loaded into earlier versions of XL Designer, the names will again
      be truncated to 20 characters.

    o The File->Print command in the sizes table editor did not work.

Changed in release 57 (2nd October 2008)



---------------------

Artwork editor :

    o If a design contained nets with single nodes, and any one of those
      nodes were shorted to another net, then the artwork checker was
      reporting all the single node nets as being shorted together.

General system :

    o Added preliminary reference manual (schematic editor only at the moment)
      to the help menu.

Electra router compatibility :

    o The electra router interface was incompatible with the command syntax
      requirements of the current series 2 routers.
      An option has been added to the Electra router installation configuration
      dialog to allow select of version 1 or version 2 routers.

Changed in release 56 (8th September 2008)
---------------------

General system :

    o After the 'ALT' key had been pressed, defined function keys stopped
      working in the graphical editors.  Please note that if ALT is pressed
      and no subsequent Windows menu action is selected by keystroke, then it
      will be necessary to hit ALT a second time to cancel its action and
      re-enable operation of the function keys in the editors.

    o If a design .rxl file was opened directly from a Windows Explorer window,
      then the Outputs folder did not appear.

Parts list editor :

    o Parts that were added to the list with "Repeat Part" could not be
      added to the artwork part placement tray.

    o Clicking on column headers will now sort the parts list by the
      selected column.

Artwork editor :

    o Pin numbers display did not take into account whether the associated
      component pad was visible.

Circuit Schematic :

    o The datum point of a bus ripper symbol could not be seen once a
      connection had been made to it.

    o If a part contained no terminals, then part allocation data was



      lost after the design had been saved and reloaded.

Design navigator :

    o Duplicate outline names were being created when using the 'Paste'
      operation.

Specctra & Electra optional autorouters :

    o Added browse buttons to the router installation configuration dialogs
      to assist in selection of the work directory and router executable file.

    o Work directory and router executable file paths were being limited to
      55 characters by the configuration dialog.

    o Circular board profiles were being incorrectly output as octagons.
      A circular profile will now be interpolated into 128 segments
      (2 degree steps)

Changed in release 55 (1st September 2008)
---------------------

General system :

    o It is now possible to load designs that were created with any previous
      Ranger product.
      In the file open dialog, select the appropriate "Files of type" value,
      and navigate to the appropriate design file or design index file.

Circuit Schematic :

    o If a design is loaded that has an old style flat schematic, then the
      schematic and its associated device library entries will be converted
      into design blocks within the hierarchical schematic editor.
      Please note that there are major differences in the way that "bus"
      signals were handled in the flat schematic editor and the hierarchical
      editor.  The hierarchical editor uses specially created bus ripper
      symbols to handle busses, whereas the flat schematic editor indicated
      busses by setting wires to "bus width".  The flat schematic compiler
      essentially ignored wires set at "bus width", leaving net node grouping
      by equivalent signal name tags to perform the required connections.
      The hierarchical editor compiler is unable to operate in this manner,
      so all imported "bus width" wires are converted to non-electrical
      features so they cannot be seen by the hierarchical schematic compiler.

      Some schematics with busses will need some manual editing after loading
      if it is desired to recompile the schematic to a parts and net list.
      If recompilation results in errors because multiple signal names are
      found on a net, then it may be necessary to convert more wire sections
      to non-electrical mode to hide them from the compiler.
      A new command :

        Wires->Flat Circuit Import Assist->Toggle Wire Section To Non Electrical



      has been added to the schematic editor.  This permits a section of a
      connection to be switched to non electrical mode thereby hiding its
      connectivity from the compiler.  Please note that this function only
      permits certain wire sections to be converted.  Wire sections connecting
      to component pins and sections which are not the first or last in a
      wire link cannot be changed.
      
    o The system crashed if you deleted a powerpin symbol from a part, or a
      subsymbol from a split part.
      

Design Outputs :

    o It was possible to delete an output task from the navigator while the
      task was open.  This resulted in an immediate crash.
    
    o The right and bottom print margin was incorrect for outputs to the
      MS Windows printer.
    
    o When an artwork layer was output with pads set as filled/drilled, tracks
      were being pulled back from the pad datum point.  This resulted in tracks
      not being picked up when parts were moved.
      

Changed in release 54 (18th August 2008)
---------------------

Gerber Output :

    o When the system output arc tracks to a gerber file, they are approximated
      by a series of straight line segments.  The individual segments were
      calculated to each subtend a fixed 6 degrees of arc around the line
      being plotted.  This worked well in most cases.  However, where an arc
      track is very shallow (huge radius of curvature) this resulted in only
      one straight line segment being output.
      The arc approximation algorithm will now generate as many segments as
      necessary in order that no point on a segment may be more than 0.001"
      away from the true arc position.
      
    o In the sizes table heat relief parameters page, it is possible to enter
      channel width values that cannot be achieved within the stated drill
      range for the entered track width and clearance values.  When a channel
      width is too large, it will be observed in the artwork (with pads 
displayed
      unfilled) that the heat relief segments appear to turn inside out
      (they look a bit like bow ties).  This does not affect artwork editing
      but is serious if the job is output to Gerber with this misconfiguration.
      Artwork output to Gerber (and other targets) will now check for this
      misconfiguration and raise a warning if detected.

General system :

    o If you created an outline with a comma in its name, the system was



      crashing when you tried to open the outline.
      

Changed in release 53 (11th August 2008)
----------------------------------------

    o The 'Print to File' option for Windows printer outputs did not work.

    o Copy & Paste were not available in the navigator for output tasks.

    o Implemented output batch functionality.

Artwork editor :

    o The artwork checker was giving incorrect results  for designs containing
      custom pads shapes.  (Customer supplied job "3004-07_11-03.rxl" was
      wrongly reporting short circuits)

Circuit Schematic :

    o Find->Part was crashing if you entered a part ident that did not exist.

    o Allocate->ShowFreelist was crashing.

    o When performing a region copy, bus connections were not being copied
      with the correct width applied.
      
    o Region->Paste command was shown as active even if nothing had been
      cut/copied.
      
    o Region Cut/Copy now works correctly between sheets within the same design.
      (Features cut/copied in one design cannot be pasted into another design
       as each design has its own private schematic cut/copy buffer)
       
    o Added 'Show Dependencies' action to navigator right-click menu for 
schematic
      items.

General system :

    o If a design having an old style flat schematic was saved from within
      XL Designer, then access to the flat schematic was lost if you attempted
      to reload the design in Ranger XL.
      As long as no hierarchical schematic blocks are created in a loaded 
design,
      any flat schematic will now remain accessible if the design is saved and
      reloaded in Ranger XL.  If heirarchical blocks are created, or schematic
      parts copied into the design, then deleting all of them will reinstate
      access to the flat schematic in Ranger XL.
      
    o Navigator Copy/Paste operations involving schematic design sheets or
      split parts did not work correctly.



Changed in release 52 (17th July 2008)
--------------------------------------

General system :

    o The licensing implementation has been improved to allow for the
      provision of 'schematic only' licenses.  Schematic only licenses
      will only work with this and newer releases of XL Designer.
      
    o Newly issued full system XL Designer licenses which are locked with
      a security key (dongle) will now allow operation of all program
      sections except artwork when the key is unplugged.  With the key
      unplugged, the artwork editor works in view-only mode.  Newly issued
      licenses having this feature will only work with this and newer
      releases of XL Designer.
      Previously issued licenses will continue to work with this version,
      but will not benefit from the ability to detach the key while
      retaining partial operation.

Profile editor :

    o "Grid->Select Origin" did not work.
    
Custom pad editor :

    o "Grid->Select Origin" did not work.
    
    o "Grid->Measure Distances" did not work.
    

Changed in release 51
---------------------

General system :

    o If you selected a net in the navigator pane, and the net had a
      large number of nodes, then the property pane would take a very
      long time to draw.  (A net with > 500 nodes was taking > 30 seconds)
      
    o Navigator "Find in Schematic" for nets was not finding net nodes
      that had alphanumeric pin references.
    
    o Right clicking on navigator standard pad folders now shows an
      "Open Sizes Table" action.  Previously, it was incorrectly showing
      a "New" which created a custom pad.
      
    o Properties pane will now display attributes and power pin information
      when browsing schematic parts in the navigator.
      
    o Clicking on a navigator design parts folder will now cause the properties
      pane to show a count of the number of placed and unplaced parts in
      the design.
      
    o Clicking on a navigator design nets folder will now cause the properties



      pane to show a count of the number of power and signal nets in the design.
      
    o The navigator Nets folder now uses a different icon for power nets.
    
    o Implemented design auto-save.  This must be switched on by ticking the
      option box in the 'File->System Setup' dialog.
      Please note that auto-save does not save changes that are in progress
      on master libraries.
      
    o The selected system inch/metric units mode now gets preserved across
      program sessions.
      
    o Grid snapping state now gets saved with the design.  Also, the state
      is now stored separately for the artwork/profile, outlines, custom pads
      and schematic views within the design.

Design outputs :

    o Plot preview was not being shown correctly for some plots (black screen)
    
    o When the N/C drill output encountered co-incident drill holes, invalid
      data was being placed in the drill data file.
      
Artwork editor:

    o If a directory named c:\temp existed, the artwork checker was creating
      a file called c:\temp\xldebug.txt

Outline editor :

    o 'Outline->Set Outline Datum' command did not work.
    
    o If a design was saved while a component outline was opened for editing,
      then changes/additions to the outline pins were not saved into the
      design file.
      
Parts list editor :

    o Enabled bill of materials output function in the 'View' menu.
      Bill of materials may now be output in the old "RangerXL" report
      style, or in a spreadsheet compatible style with selectable field
      separator.
      
    o Enabled 'File' menu 'Save Parts List as Text' action.
    o Enabled 'File' menu 'Print' action.
    
    o 'View->Show Part UIDs' setting will now get remembered between program 
sessions.
    
    o 'Edit->Find Part' has been made case insensitive.
    
Netlist editor :

    o Enabled 'File' menu 'Save Nets List as Text' action.



    o Enabled 'File' menu 'Print' action.
    
    o Enabled 'Edit->Find Signal Name' action.
    o Enabled 'Edit->Find Node' action.
    o Enabled 'Edit->Find Unconnected Pins' action.
    o Enabled 'View->Show NETUID Codes' and 'View->Show Minimum Clearances' 
actions.
    
Demonstration version only :

    o When you load a design that has too many parts or nets for the design
      size limits of the demonstration version, a warning dialog will be
      displayed if you attempt to save the truncated design over the original
      loaded design.
      

Changed in release 50
---------------------

General system :

    o Clicking parts and nets in the navigator pane did not show the correct
      properties information in the properties pane.
    
    o System can now display multiple popup windows for the navigator
      "Find in Artwork" and "Find in Schematic" operations.
      
    o Popup windows for the "Find in Artwork" and "Find in Schematic"
      operations for parts/nets now contain buttons that allow you to
      rapidy go to the identified feature in other views.
      Also, when an information popup is placed on a circuit schematic
      symbol, and the symbol is allocated to a part containing multiple
      elements, the popup will contain buttons to assist in finding
      other members of the same part.
      

Changed in release 49
---------------------

Circuit Schematic :

    o System was crashing when you dropped parts into the fast parts tray.

General system :

    o If you created a new circuit schematic, then compiled it, then opened
      the parts or net list editor, there was no correlation between the
      parts and nets displayed in the navigator pane and their entries in
      the parts/nets editors.  Also, if an artwork was produced, then the
      navigator "Find in artwork" options did not work.
      Normal operation was only obtained after saving, closing and reopening
      the design.
      
    o If you added a part to the parts list by using the artwork



      "Tools->Network->Add Part" function, and then tried to delete the part
      from the parts list editor, then the system would crash.
      
    o Added software reference manual to the Help menu.
    
    o Added online check for product updates to the Help menu.

    o A customer supplied design (BZ821_defekt.rxl) was failing to load because
      a net had a signal name tag that was missing from the signal name
      table. Invalid signal name tags now get cancelled on net loadup.
      The source of the invalid name has yet to be determined.
      

Changed in release 48
---------------------

General system :

    o Popup information windows (eg. identify part, x/y etc) have been
      restyled to be "Balloon" type windows.
      
    o Navigator "Find in Artwork" is now operational for parts and nets.
    
    o Initial implementation of navigator "Find in Schematic".
      This release only contains limited functionality for finding parts
      in the schematic, and does not yet work correctly for parts that
      have multiple elements.

Changed in release 47
---------------------

General system :

    o Added Cadence/CCT Specctra and Konekt Electra optional autorouter 
interface.
      (To access optional routers, right click on your artwork icon in the 
navigator.
       Optional routers must be enabled in the File->System Setup dialog in 
order to
       appear in the artwork icon context menu)

Outline Editor :

    o X/Y readout was not working.
     
Circuit Schematic :

    o The system was crashing if you tried to place a symbol from a split part
      that was located in a master library.
      
      
Changed in release 46
---------------------



General system :

    o Added profile import from AutoCAD DXF file.
    
    o Added artwork import from Gerber file.
    
    o Added parts/netlist import from text file.
    
    o GenCAD export tool was crashing on supplied customer designs.
      (The supplied designs had some pad table definitions where the dimensions
       displayed in the standard pad size editor appeared to be zero, but 
internally,
       roundoff error had resulted in a very small non-zero value, causing the 
pad
       output algorithm to fail)

Changed in release 45
---------------------

Outline Editor :

    o System was crashing when you closed an outline that had been opened
      from the master outlines collection.

General system :

    o Added GenCAD 1.4 export tool.
    
    o Added Bath Scientific Limited testpoint generator.

Changed in release 44
---------------------

Outputs Editor :

    o "RS 274X (Extended gerber)" text change was missing from the Gerber output
      non-auto job setup dialog.

    o Added DXF output filter.

    o Added output to artwork layer filter.

Changed in release 43
---------------------

Circuit Schematic :

    o Added wires 0/90 degree lock button to the toolbar, and entry to
      the wires submenu.



    o A horizontal scroll bar will now appear in the fast parts tray if
      the contained text is too wide for the window.

    o It should have only been possible to select "Bus Pin" type on the
      toolbar when editing "User Block" and "Block I/O" symbols.

Artwork editor :

    o When entering powerplane mode, the powerplane toolbar would display
      all powernames that were defined in the power names configuration table,
      even if the power name did not occur in the design netlist.
      After entering the powerplane setup dialog, and closing it again, the
      displayed powername table would reduce to just those power names that
      appeared in the netlist.  This was confusing.

    o In powerplane mode, if you selected a powername in the toolbar, then
      entered powerplane setup mode and switched the toolbar selected power
      name if 'Inactive', then the system would crash after the setup dialog
      was closed.

    o The powerplane preview mode did not repaint correctly.  (After panning/
      zooming, or using the setup dialog, it was necessary to switch preview
      mode off and on again to restore the correct preview display)

    o When using 'Text > Move' mode to move a 'URL' text item, the item was not
      undraw correctly when picked up.

Outputs Editor :

    o In the gerber output configuration dialogs, "Extended gerber" output
      mode has been renamed to "RS 274X (Extended gerber)"

Outline Editor :

    o If you added, deleted, or moved pads on an outline, then the change was
      not visible in the artwork until the design had been saved and reloaded.

Profile Editor :

    o The "View > Drill Holes" mode was only switching on/off the display
      of drill holes, and the part pins were always being displayed.  This was
      different to the behaviour in Ranger XL.
      Also, the menu entry has been renamed to "View > Part Pins" to agree
      with its actual functionality.

General system :

    o When new standard pad sizes were defined with the pad sizes editor,
      the newly entered sizes did not appear in the navigator until the
      software had been terminated and restarted.

    o When windows were resized to extreme aspect ratios, full use was not
      being made of the available drawing area.  (eg. Window > Tile Horizontal
      with several windows open would result in windows that only had partial



      grid coverage)

Changed in release 42
---------------------

Circuit Schematic :

    o Implementation of sheet editor Symbol->Power Place mode.

    o Implementation of 'Region' commands.

    o Implementation of user defined design extractor
      
    o Schematic compiler was causing an "Invalid Argument" error popup to
      appear.  Trying to continue would cause the system to crash.
      
    o Power symbols were vanishing from schematic sheets after a part
      had been placed from a master library.
      
    o If a userblock symbol was deleted from a schematic sheet while a view
      of the design hierarchy was open, the displayed hierarchy was not updated
      and could cause a crash.
      
    o It was not possible to delete parts and user blocks because of warning
      about "dependency checks not coded"

    o When a new part was added to the schematic, allocated, then the circuit
      compiled, artwork silk screen features that had been manually added were
      being deleted.

    o EMC attribute tags were not visible, and the system crashed if you tried
      to apply them.

    o F4(full) and View > Full was not working

    o The split part subsymbol swap rules dialog bar global/local selector
      had no default selection.

    o The RangerXL product uses a separate data section in the design database
      to hold gate and pin swapping rules extracted from library part and split
      parts.  XLDesigner derives its swap  rules directly from the library 
members,
      and does not require and was not generating this separate swap rules 
database.
      This resulted in a backward compatability problem when loading XLDesigner
      created designs in RangerXL.
      XLDesigner now generates this missing database.

    o Symbol and pin swap rules setting modes incorrectly showed rule 'circles'
      on placeable power blocks and power block pins.

    o Compiler did not correctly insert EMC attributes into extracted parts



      and nets data.

    o Reinstated the compilation result viewer.
    
    o When connections were inserted onto a blockio symbol pin, the connection
      would not attach correctly to the pin.  (if you picked up the symbol to 
move
      it, the connection would stay behind.
      
    o Symbol and pin swapping rules should only have been visible for part
      and split-part type symbols.
      
    o It was not possible to specify a typed pin reference to force allocation 
of
      a split part symbol to a specific subsymbol within the component.
      
    o Pin number assignment did not place a default value in the pin number box.
 

Artwork editor :

    o Corrected memory corruption in gate/pin swap rules handling.

    o Gate and pin swap rules were not being handled for schematic split parts.

    o Parts EMC hilighting mode was not working.

    o Region > Move/Rotate was not updating unroutes.

    o Region > Macro Generate and Region > Macro Add were disabled.

    o User defined via holes were not being displayed.

    o Amend > Enter Pads did not permit entry of user defined via holes.

Custom Pad Editor :

    o DrillHoles > Delete command did not work.

    o The drill size value in the toolbar did not work.

General system :

    o Schematic symbols, outlines etc. now get loaded into the navigator window
      sorted into alphanumeric order.
      
    o Component outline names in the navigator now get forced to upper case
      to be consistent with the parts list editor.

Changed in release 41
---------------------



    (Release not distributed)
    
Changed in release 40
---------------------
    (Release not distributed)
      
Changed in release 39
---------------------

Circuit Schematic :

    o Implementation of the fast-parts tray.

Artwork editor :

    o A design that had custom pads in the free copper section of an outline
      was crashing if the design was saved, then reopened, then attempted to
      open the artwork editor.

Changed in release 38
---------------------

Circuit Schematic :

    o Fixed compiler problem with signal names.
    
    o Fixed display problem with attribute positions on split part subsymbols.
    
    o When a design sheet was renamed, the corresponding symbol entry
      was not renamed.
      
    o Paste buffer was not being cleared at start of a new copy/cut operation.
    
    o When editing a symbol outline, line endpoints could not be released
      after the attributes move command had been used.
      
      

Changed in release 37
---------------------

Circuit Schematic :

    o Implementation of schematic parts & split parts editors.
    
    o Implementation of hierarchy navigator functions.
    

Changed in release 36
---------------------



Design Outputs :

    o Added the hierarchical schematic plot filter.
    
Circuit schematic :

    o Non electrical text strings containing version control markup
      was not being handled correctly.
      
    
Changed in release 35
---------------------

General system :

    o When outlines are imported into a design, and pad/track size code
      translation is required on import, size code 0 will no longer be
      allocated to translated features.

    o If you renamed a circuit schematic library entry, and then moved
      the main application window without first clicking again on a
      navigator entry, a crash occurred.

    o It was not possible to save changes made to the design master libraries.

Outline editor :

    o It was possible to place a pad on an outline when no pad style had
      been selected from the navigator.  A default round pad was being
      displayed, and it was possible to allocate a pin number to it.
      However, the resultant outline was unusable, and could cause a crash
      when trying to add it to the parts list.
      (System will now beep, and display a prompt on the status bar asking
       for the selection of a pad style)

    o When using Region > Copy with pads selected, the system would become
      unresponsive, and consume memory until a crash occurred.

    o Copper > Add/Move Corner would not move corners that had been added in 
      copper lines on copper layers.

    o Copper > Add/Move Corner would not move copper line end points that were
      not attached to a part pin.

Artwork editor :

    o Tools > Network > Add Part was causing a crash. (Problem introduced at
      version 1.34)

    o Tools > Generate Silk Screen caused a crash if you selected insertion
      of free copper features.



Changed in release 34
---------------------

Profile editor:

    o The system was crashing when trying to add a line feature to
      the profile in the master profile library.

General system :

    o It was possible to use "Paste" in the navigator window to overwrite
      a design custom pad, outline, schematic library entry or profile object
      when that object was open for editing.  This resulted in a crash.

Component outlines :

    o When using Copy/Paste to copy outlines between designs and the master
      outline library, required custom pads were not transferred with the
      copied outlines.
      
    o When outlines were imported to a design from the master library or
      another design, the size codes of imported pads and line features
      were not translated if there was a mismatch in the size table
      configurations between the source and destination.
      
    o Outline "families" are now available.  To configure families for the
      outlines in a design, or the master outlines, right click on the
      top level outline folder in the navigator, then choose "Manage Families"
      from the context menu.
      
    o Bulk editing of outline properties is now available.  To invoke the
      editor, right click on the top level outline folder in the navigator,
      then choose "Edit Properties"
      
Artwork editor :

    o "Parts -> Change Outline" command is now available.
    
Parts list editor :

    o Editing the outline name field for a part that is already placed on
      the artwork will now have the same editing effect on the artwork as
      using the artwork editor "Parts -> Change Outline" command.
    
      
Changed in release 33
---------------------

Outline editor :

    o System could crash when creating a new outline.
    
    o When an outline was opened, the autoplacement footprint was not being
      checked to ensure that it encircled the pin bounds.



      
    o Problems with outline corner/move point and free copper corner commands.
    
    o Pad angle control was not working when adding pads.
    
    

Changed in release 32
---------------------

Outline editor :

    o Initial release of component outline editor.
    

Changed in preview release 31
-----------------------------

General system :

    o Circuit schematic, design output tasks, and unreferenced outlines and
      custom pads would be lost from a design if a design was saved without
      any of the above data being first explored in the design navigator.

Changed in preview release 30
-----------------------------

Artwork editor :

    o Back annotation from gate/pin swap and renumbering operations will now
      be propagated to the circuit schematic.

    o The artwork checker did not see size changes made to the sizes table in
      the current artwork editing session.

Circuit schematic :

    o System was crashing if you tried to open a part that had a comma in its 
name.

Sizes table editor :

    o If you used the function keys to toggle between inch/metric units, the 
currently
      selected value got corrupted.

Changed in preview release 29
-----------------------------

Artwork editor :



    o System was crashing when you closed the artwork editor for a design
      where Amend->Replace Pad had been used on component pads.
      
    o Pads disappeared if you selected "filled" display mode.
    
    o "Named" unroutes view mode was not working.
    
      
Design Outputs :

    o NC Drill and Rout data output implemented.
    
    o System will now issue an audible beep and display "Plot Complete" on the
      status bar on completion of plot file creation.
      
    o Configure->Move Plot and Keymove Plot were not working.
    
    o Solder Paste setup dialog was failing.
    
    o Drill drawing output was failing.

Changed in preview release 28
-----------------------------

    o First release of Gerber plot implementation.
    

Changed in preview release 27
-----------------------------

Circuit schematic :

    o Symbol->Attribs->Move/Edit etc. was not picking up the correct
      attribute.

    o Wires->Attribs->Add was behaving in an erratic manner.

    o Allocate mode often required a deallocate action before it could
      be made to work.

Changed in preview release 26
-----------------------------

Circuit schematic :

 o It was not possible to make a connection to a block io pin.
   (This error was reported as "p/w list compiler is not joining nets up 
through
    the hierarchy".  A test job had been created, but because the 
connections
    would not attach to the block io pins, they had been released over 
the



    screen location where the io pin appeared, visually making a 
connection.
    However, because the io pin locator had not correctly located the pin
    as a valid connection target, the connection node was not tagged as
    connecting to the pin, with the resultant apparent compilation error)

Changed in preview release 25
-----------------------------

Circuit schematic :

    o Circuit schematic was not being saved.
    o Edit -> Preferences dialog now available.
    o Schematic compilation now correctly generates unroutes in the artwork.

Changed in preview release 24
-----------------------------

Artwork editor
    o  Artwork editor now picks up gate and pin swap rules from the
       schematic parts.  Please note that 'split' parts do not yet
       generate gate and pin swap information

    
Initial preview of circuit schematic capture.

Known problems :

    o  Symbol editing mode not yet available.
    o  Design navigation using the hierarchy tree not possible.
    o  When 'find' operations require the opening of another view,
       the find marker is not placed on the correct sheet.
    o  Many problems with 'split' parts and placeable power blocks.
    o  Gate and pin swapping in the artwork does not yet back
       annotate to the schematic.
    o  'Region' commands not yet available.
    o  Undo/Redo not yet available.
    o  Allocation sometimes does not work unless you first do a
       deallocation operation.
    o  Design compilation produces parts and net lists, but unroutes
       may not appear in the artwork editor.
    o  System will crash if you use 'Copy' and 'Paste' on the design
       navigator to copy a schematic design sheet from another design
       into the currently open design.  However, using part place mode
       to insert a design sheet from another open design will cause
       the design sheet and all required dependencies to be correctly
       imported.

  


