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Licensing Information 
Once XL Designer has been installed on a computer, a license key code is required to make it work. If you do 
not have the license key code, then please let us know. 
To use the license key code, you will need to be a registered user on the XL Designer website 
(http://www.xldesigner.com/downloads) and know your login name (email address) and password (of your own 
chhosing). 

The license key can be stored on multiple machines, then activated/deactivated on each one as required from 
the License Configuration window. 

Internet access is required during license activation/deactivation, but it is not required to Store the key or run XL 
Designer once it has been activated.  

The license key code contains your Customer ID, the Number of systems that have a maintenance contract, the 
Date the license expires and the Date the maintenance contract ends at which time future updates will not be 
available. 

The License Configuration window can be opened from the Help > License Configuration command (or the File 
> System Setup window, in which case select “Click to Configure” from underneath the Product License details).  
The license configuration window is shown in Figure 1. (On a new system, the license details will be empty.) 
 

 

Figure 1 

For security reasons, the license key code is never displayed. 

To use a License Key Code: 
Store the License (a one off per machine operation): 

Storing the license key code can be repeated, now or in the future, on any machines that will run the 
software. It only needs to be done once and does not require internet access.  

It does not “activate” the license key. 

Assuming XL Designer V2.10 or later is installed, run up XL Designer. A window will appear requesting the 
license key. (If it doesn’t, select Help > License Configuration.) 

Copy and then paste the License Key Code, into the “New License Key” area of the window.  

Select “Store License”. If the License Key is invalid an error message will appear, otherwise the license 
details will be shown in the window – ensure they match those in the license details that came with the 
license key code. 

Once the License Key Code has been Stored, an “Activate License” button will appear at the bottom of the 
window. 
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Activate the Licence: 
Assuming the license key has been stored as described above, open the License Configuration window if it 
isn’t already open, then select the “Activate License” button from the window. 

A new window appears. This should indicate that the “License Server Status” is “OK”. If it isn’t, then check 
there is an Internet connection established on your pc. 

The window also shows the “Number of activations available”. If 0 are available, it means all the licenses 
are in use and one will need to be deactivated before you can proceed. 

Enter the email address and password you used to register on the XL Designer web-site. (Links in the 
window allow you to register or obtain a new password if required.)  

Then select “Activate Now”. A message will indicate the license has been Activated. Select OK/Close to 
continue. The software can now be used without an Internet connection until it is required to deactivate the 
license, for example if you wanted to use the license on another machine. 

Updating to Windows 10: 
If updating from Windows 7 or 8 to Windows 10, it is important that you deactivate the license prior to 
the update. If you don’t, the license cannot be used and you will encounter delays and inconvenience whilst 
you contact us to request that the license is de-activated. 

De-activating a Licence: 
Once a License Key code has been activated, it has to be de-activated before it can be used elsewhere.  

Run up XL Designer, select Help > License Configuration.  

Ensure the “License Server Status” is “OK”. If it isn’t, then check there is an Internet connection established 
on your pc. 

Select the “De-activate License” button from the window. 

A new window appears, select the “Deactivate Now” button to proceed with the deactivation. A message 
will indicate the license has been De-activated. 

Select OK/Close to continue.  

Multiple License Counts: 
Activation of a license reduces the number of available licenses (as defined in your license details) by one 
on the Seetrax License Server. Once zero licenses are available, an activated license would have to be 
deactivated in order for it to be used elsewhere. 

Working in two or more locations: 
“Store” the license key (as described above) on the machines you are likely to use when you are ready – it 
remains dormant until it is activated. You do not need to Store it again. 

Once activated, it must be de-activated before it can be activated on another machine. 

What happens if my hard disk fails? 
You must de-activate the key in order to use it elsewhere, however hard-disk failures are difficult to predict! 
If the disk can be re-used, even if it has been re-formatted, you will be able to de-activate the license once 
XL Designer has been re-installed.  

If the disk is not recoverable, then please contact your local Seetrax Support Office and they will assist in 
the recovery of the license key.  

License Details: 
The license details will be provided in the following format: 

Customer:    Your Company Name 

Serial Number:   1 
Created:   08-19-2015 
License Key:   ABCDE-FGHIJ-KLMNO-PQR12-STU34-VWXY 
License Count:   1 
License Expires:  31-12-2099 
Maintenance Expires:  08-10-2016 

Product Options:  Schematic, Artwork, Output Tools,  

Import/Export Tools, File Save 



 

3 

 
Customer: This will be your name or company name. 

Serial Number: The serial number of your license key. 

Created: The date and time the license key code was generated. 

License Key:  This is the license key that has to be entered into XL Designer’s License 
Configuration window. In this example the following would be copied/pasted: 

ABCDE-FGHIJ-KLMNO-PQR12-STU34-VWXY 

License Count: indicates the number of systems that were purchased and is the maximum 
number of machines that the software can be activated on at any one time.  

License Expires: indicates when the software will stop working. For example a 30 day license 
may be supplied for evaluation purposes, or whilst an invoice is outstanding. A 
permanent license (til 31-12-2099) will be provided once a purchase has been 
completed. 

Maintenance Expires: all the updates that became available whilst the maintenance period is current 
can be used with the license. If the expiry date is reached and the 
maintenance has not been renewed, then all subsequent updates will not 
work. The last update will continue working until the license expiry date.  

When the maintenance is renewed a new license will be supplied and once 
stored/activated the software can be updated.  

The old license key should no longer be used and will be deleted from our 
servers after a grace “changeover” period from renewal. So please ensure 
license key codes are replaced in a timely fashion to avoid any inconvenience 
and down-time once they are deleted. 

Product Options: indicates which options are enabled with the license. Currently a fully 
functional XL Designer has 5 product options as shown in the example above. 
If the option is not listed, then it is not enabled. 

For example a “Schematic Only” license would just show “Schematic, Output 
Tools & File Save”. 
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Configuration Information 
When XL Designer was installed it came with a set of defaults for file locations, auto-saves, etc. This information 
can be viewed and changed if required. 

Initial Installation information 
The supplied configuration information & default libraries will be installed into the following structure: 

<TARGETDIR>/UserTemplate/Data 
<TARGETDIR>/UserTemplate/Libraries/PCB 
<TARGETDIR>/UserTemplate/Libraries/Schematic 
<TARGETDIR>/UserTemplate/DocTemplates 

 
After installation, XL Designer never writes to the configuration files and libraries in this UserTemplate structure.   
At initial startup of XL Designer, a personal configuration and libraries structure is created in the user's 
Documents directory, and this will be seeded with files from the UserTemplate structure.  
The new personal files structure is configured as follows: 
       MyDocuments/Seetrax/XL Designer/Artmacros 
       MyDocuments/Seetrax/XL Designer/Data 
       MyDocuments/Seetrax/XL Designer/Libraries/PCB 
       MyDocuments/Seetrax/XL Designer/Libraries/Schematic 
       MyDocuments/Seetrax/XL Designer/DocTemplates 
The seeding of any directory from the above structure will only occur if the directory is found to be missing, or is 
empty.  Pre-existing non-empty directories will never have their contents overwritten with files from the 
UserTemplate area. 
The File > System Setup window in XL Designer may be used to choose different locations for the various 
directories.     
When a computer is shared between multiple users, the setup window allows individuals to edit/pollute their 
personal configurations and libraries without affecting other users of the system.   
Alternatively, it’s possible to configure the system to allow the master libraries/configurations to be shared 
amongst multiple users.  
As long as these directories are not empty, files from the UserTemplate area will never be copied over the top of 
the shared libraries and configuration. 
System managers will be able to produce their own sets of configurations and design libraries and copy them to 
UserTemplate area to be used as the initial defaults for all users. 

Sharing configuration/master libraries 
With XL Designer running, select File > System Setup and ensure that the Configuration Data directory, PCB 
Masters and Schematic Masters directory paths point to the shared content.  As long as these directories are 
not empty, files from the UserTemplate area will never be copied over the top of the shared libraries and 
configuration files.   
Please note that when running on Vista/Windows 7, administrative action will need to be taken to ensure that all 
users have appropriate access permissions to the shared content. 

Future updates 
When performing reinstalls or future upgrades, the Custom Install option permits the user to exclude installation 
of the default configuration and libraries.  This would be desirable when the UserTemplate area had been 
customised. 
Product Uninstall will never remove any files from the <TARGETDIR>UserTemplate structure. 
Previously configured paths to user's configuration and library directories will be honoured, and never 
overwritten. 

To access the System Setup 
Select File > System Setup. A window similar to the one shown in Figure 2 appears. 
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Figure 2 

Each heading, like the Configuration Paths in Figure 2 can be expanded to display and allow editing of the 
values within. Each heading is described below. 
If a change is made, select the Save Changes button to implement the changes, or the Cancel to abandon the 
changes (all of them). Only changes to the Configuration Paths require XL Designer to be closed and restarted 
– as indicated in the window. 

Configuration Paths (validated at startup) 
These paths are validated when XL Designer is run to ensure they exist and the required files located. These 
paths can be changed provided the full implications of the change are understood. For example moving/copying 
associated files. 
If these paths are changed, then XL Designer has to be closed and restarted for the changes to take effect. 

The browser buttons ( ) will appear on the right-hand side of the entry whan a folder location is selected and 
can be used to navigate around the directory structure. 
Configuration Data Directory: indicates the path that should be used to locate the configuration files. If the path 

is changed then all the files that are found in the existing folder should be moved 
to the new folder. 

PCB Masters Directory: indicates the path that should be used to locate the PCB library files which are: 
outlines, datalib, profile and pads.  
If the path is changed, the files must be moved to the corresponding location (or 
the folder will be populated automatically from the user template).  
The path may point anywhere on a network. 

Schematic Library Dir: indicates the path that should be used to locate the schematic library files. There 
are 77 supplied library files with names reflecting the content of the files, such as 
74xx, Capacitors, Resistors,  etc., plus any files that have been created by the 
operator. 
If the path is changed, the files must be moved to the corresponding location (or 
the folder will be populated automatically from the user template).  
The path may point anywhere on a network. 

Artwork Macros Dir: indicates the default path that will be used when saving and retrieving artwork 
macros. (It is possible to specify different folders when actually saving/retrieving 
the macro if required.) 
Artwork macros are automatically given an extension to their name of .amf 
(artwork macro file).  
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Temporary Files: this indicates the place where temporary files are stored whilst XL Designer is 
running. 

Miscellaneous Configuration Paths 
These paths are NOT validated when XL Designer is run (so might not exist). You do not need to close/restart 
the program to make the change. 
Text I/O Directory: indicates the default path that will be used when importing or exporting files. (When 

importing/exporting files, the Windows browser is also available to locate other folders 
as required.) 

Generic Extractors: indicates the path that will be used to locate the generic extraction tools that are 
accessed from the schematic editor. If the path is set incorrectly, then the extraction 
tools will not appear and cannot be used. 

Installed Optional Products 
There are three products that can be used as integrated packages within XL Designer: the Cadence/CCT 
Specctra Autorouter, the Konekt Electra Autorouter and the Racal Redit Autorouter.  
If any of these products are available, tick the appropriate box to enable the interface to that product within XL 
Designer. The interfaces are located by right-clicking on the Artwork in the Navigator, then selecting Installed 
Optional Autorouters. 

Special Function keys 
When working in the graphical editors, keyboard keys can be used to perform certain commands to make the 
design process quicker. For instance when zooming in and out, switching the grid on/off, etc. 
Some of the keys were defined during installation and all of them can be changed. 
. 

 

Figure 3 

To change the key assigned to a command, select the current setting, then type in the new character. 
The keys are not case-sensitive so whether you work with CAPS LOCK On or Off makes no difference. 
Select Save Changes to close the window and implement all the changes. 

Design File Options 

 

Figure 4 

Save Designs With File Compression: Some designs can be too large to send via email, or take too long to save 
over a network, so it is possible to switch on file compression so that the 
design file is made smaller.  



 

7 

Tick the box to enable file compression. When the design is saved it will 
be compressed.  
Compressed and uncompressed designs can be opened, regardless of 
this setting. 

Enable Autosave: An auto-save feature can be switched on (recommended) to allow 
automatic backup saves of the design to be taken at specific time 
intervals.  

Autosave Time Interval (minutes): Length in minutes between auto-saves (if auto-save is enabled). 
Auto-saved design filename prefix: The user can choose to overwrite the open design with the autosave, or to 

save the design with a different name (recommended).  
If this field is left empty, the design will be auto-saved using the current 
design file name, so the file is over-written.  
If a prefix is specified (safe# by default), this will be inserted at the front of 
the design file name before saving, so a separate backup copy is created. 

Auto-save to alternate directory: When checked, autosaved designs can be stored in a different directory to 
the one in which the design file is located.   

 To select a destination folder, select the entry, then select the browse 
button (arrowed in Figure 4 above). Navigate to the folder required, or 
create a new folder. 
For data security in the event of file system corruption or hardware failure, it 
is advisable to store autosaved work on a different file system to the one 
that holds the design file.  

Fonts 
The font used in the schematic editor, associated output tasks and printed text reports can be configured.  
The schematic editor can display all text using either a fixed pitch vector font or a selected Windows text font. 
Most Windows fonts use proportional spacing, so text strings will be slightly shorter in overall length than with 
the fixed pitch vector font. Text height remains the same and is still controlled by the height properties on 
attributes, non-electrical text items etc.  
It is unadvisable to change between the two fonts due to the difference in text string length – so make a choice 
and stick with it. Older Ranger designs will have been designed with the vector font. 
 
Editors & Output Tasks: If the vector font setting is not in use (see below) then the schematic editor 

will display all text using the selected Windows text font. 
 To change the font, select the setting so it highlights as shown in Figure 5, 

then select the browser button that appears on the right-hand side of the 
window (arrowed in Figure 5), choose from the options given. 

 

Figure 5 

Because text height is specified by attributes within the editor, the 'point 
size' available when choosing the font is fixed at an arbitrary 16pt and has 
no bearing on the resultant text size. 
With outputs such as PDF, this results in the text being searchable in the 
resultant document. 
The onscreen preview of an output task automatically switches the display 
of text between Windows font  and vector font, as determined by the 
capabilities of the output device.  For example the Gerber output can only 
render text as vectors. 
The output to image files (bmp, jpeg, gif, png) continues to output all text as 
vectors. 
Artwork text is always vector based in the editor and outputs because of the 
strict requirements of dimensional control and clearance checking. 

 
Text report printing: All printed reports (parts lists, bom’s, extraction reports, etc.) will be output 

using the font and size selected. They have a consistent appearance and 
include a page header, footer and page number/total page count. 
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(The content of the header/footer left,centre & right text fields may be 
configured under the “Text report formatting” section of the system setup 
window.) 
Printed text reports which have information organised into columns (like the 
parts list) automatically adjust column widths to obtain the best fit of the 
report for the paper size in use.  When a large font point size is selected for 
text printout, some columns will need truncation to fit the output onto the 
page. The column sizing algorithm will resize the columns such that the 
minimum number of text strings are truncated in the printout.  
Truncated text will be marked with a small red bracket at the point where it 
is truncated. 

Use Vector font for schematic:  When ticked, causes the schematic editor to use the vector text font. 
 

Text report formatting 
Printed text outputs now have a consistent appearance and can include a page header, footer and the page 
numbers with a total page count.  
The content of the header & footer and its position can be configured from within the Text Report Formatting 
area of the System Setup window as shown in Figure 6: 

 

Figure 6 

To alter any of the entries, first select the item to be altered so that it highlights – left text is highlighted in Figure 
7, this will produce a selector for a pull down menu, shown arrowed in Figure 7 
 

 

Figure 7 

Select the pulldown menu and make your choice from the options given as shown in Figure 8. 

 

Figure 8 

If the user-defined option is chosen, type in the required text string in the empty field that opens up underneath 
the setting once selected, arrowed in Figure 9. 
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Figure 9 

Temporary fixes 
Reverse printed arc: when printing a schematic and using some Windows printer drivers, arcs 

can be printed the "wrong way round". If this happens, tick the box. Arcs 
will be reversed on output and printed the correct way round. 

Enable schematic block type change: On older versions of the software, under certain circumstances after 
fetching a part into a design, the type of the part in the source library 
was inadvertently set as a split part. To assist in correcting the wrong 
block type on designs and libraries affected by this bug, a command 
"Change Block Type" menu has been added to the “right-click” context 
menu of schematic split parts in the navigator.  This command is only 
available when this check box is ticked. 

 Note: the Change Block Type command is only intended for recovery of 
corrupted designs, so for this reason XL Designer always starts with this 
feature disabled. 
After changing a block's type in this way, the design should be saved, 
closed and reopened in order for the parts to appear in their correct 
navigator folders. 

Disable schematic Undo/Redo: The schematic editor Undo/Redo functionality currently has performance 
problems when working on very large schematics.  As a temporary 
measure to help customers’ speed up work on these large schematics, it 
is now possible to switch off the undo/redo code. 

Diagnostics 
Crash Dumps:  This allows the user to enable the local storage of diagnostic information 

or “crash dumps” which can assist the product development team in the 
location of program errors.   
To access this configuration tool, XLDesigner must be run as 
administrator.  
Once crash dumps are enabled, the software can be restarted as a 
normal user and the crash dump files will be stored in the user-selected 
directory if an application crash occurs. 
If the crash occurs again, then please send us the crash dump. 
It is useful to have the crash dumps enabled at all times, they add no 
overhead to the program and will provide useful information in the event 
of a repeatable problem. 
The window shown in Figure 10 controls the crash dump settings and 
should be configured as advised below. 
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Figure 10 

Status: shows the current setting for crash dumps, at the time the window was 
opened. This will not change until the setting is changed and the window 
closed/reopened. 

Action: Choose which option is required.  
If Enable/Reconfigure dumps is selected, then fill in the rest of the 
window as required. 

Dump folder: Type in the path to the folder that any crash dumps that are produced 
will be stored in.  

Dump Count: Specify the maximum number of crash dumps that will be stored.  
Limit this number to avoid using lots of disk space. We typically require 
one crash dump in order to locate a problem. However it can be useful 
to have a couple of files if the crash is caused by a random event.  
 

Dump Type: We typically require the Mini dump in order to locate a problem.  
The Full dump is very large and usually too big to transfer easily.  
We will request a full dump if required to help our investigations, but the 
mini dump should be sent in the first instance.  

Product License 
License Configuration: Refer to the heading “Licensing Information” within this guide (page 1). 
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Commands Common to All Editors 

View commands 
View > Pan 
Used to view areas just outside of the current view. 
Items that are being moved, added, etc. do not have to be released to allow this command to operate.  
Once selected, point at the area of interest and click the left-hand mouse button. The area is re-drawn centrally 
on the screen. 
Pan remains active until the right-hand mouse button is clicked to cancel the panning operation, when control 
returns to the previously active command. 

Alternative (quicker) methods of panning 
Press the user defined <pan to cursor > special function key (typically the spacebar) whilst the cursor is 
positioned over the item of interest.  
Or press the <pan left>, <pan right>, <pan up> and <pan down> user defined special function keys 
(typically up/down/left/right arrow keys). The display is moved in the direction indicated, by one screen 
width. 
If a mouse with a middle “scroll-wheel” button is in use the display may be panned by pressing and holding 
the middle mouse button, then moving the mouse in the direction required.  

View > Zoom In 
Used to increase the magnification of an area of interest. One level of magnification takes place about the 
cursor position. Once selected, point at and select with a click of the left-hand mouse button the item of interest. 
Zoom In remains active until the right-hand mouse button is clicked to cancel the operation, when control returns 
to the previously active command. 

Alternative (quicker) methods of zooming in 
Press the user defined <zoom up> special function key (typically F2) whilst the cursor is positioned over the 
item of interest. 
If a mouse with a middle “scroll-wheel” button is in use, by rotating the button, the display will zoom in or 
out, depending on the direction of rotation.  

View > Zoom Area 
Used to increase the magnification of an area of interest. A rectangle is defined around the area of interest, and 
that area is re-drawn to fill the screen. Items that are being moved, added, etc. do not have to be released to 
allow zoom area to operate. 
Once selected, point at and select with a click of the left-hand mouse button one corner of the area of interest. A 
rectangle appears with one corner fixed in the selected position and the opposite corner attached to the cursor. 
Move the cursor until the rectangle encloses the area of interest, and release it with a second click of the same 
button. The area is re-drawn. 
Zoom Area remains active until the right-hand mouse button is clicked to cancel the operation, when control 
returns to the previously active command. 

View > Zoom Out 
Used to reduce the magnification scale of the display. 
Items that are being moved, added, etc. do not have to be released to allow this command to be selected.  
Once selected, point at an area and click the left-hand mouse button. One level of reduction takes place about 
the cursor. 
Zoom out remains active until the right-hand mouse button is clicked to cancel the operation, when control 
returns to the previously active command. 

Alternative (quicker) methods of zooming out 
Press the user defined <zoom down> special function key (typically F3) whilst the cursor is positioned over 
the item of interest. 
If a mouse with a middle “scroll-wheel” button is in use, by rotating the button, the display will zoom in or 
out, depending on the direction of rotation.  

View > Full - used to view the complete item being edited, i.e. schematic sheet, part, profile, outline, artwork, 
etc. 
Items that are being moved, added, etc. do not have to be released to allow this command to be selected. Once 
selected, the display immediately re-draws to display the complete sheet.  
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Control returns to the previously active command once the screen has been re-drawn. 

Alternative (quicker) methods of selecting Full 
Press the user defined <full view> special function key (typically F4). 

View > Previous View 
Used to restore the previous picture to the screen. It can be used up to four times. 
Items that are being moved, added, etc. do not have to be released to allow this command to be selected. When 
selected, the previous picture is restored to the screen and control returns to the previously active command. 

View > Refresh 
The screen is not automatically refreshed, so this command can be used to to re-draw or refresh the screen.  
For instance, if a symbol that is overlapping other items is moved, it looks as though the items that were 
underneath have disappeared or broken up. They are still there and Refresh restores the picture. 
When selected the display is immediately refreshed, control returns to the previously active command. 

View > Toolbar 
The toolbar can be made invisible if required. This means that the icons will not be available for selection. 
(Large or small icons can be selected from the File > System setup window.) 

View > Status bar 
 The status bar (along the bottom of the XL designer window) can be made invisible if required. Warning This 
means that messages that normally appear in the status bar will be missed. 

View > Navigator/Browser/ Properties 
The Navigator, Browser & Properties windows can be made visible or switched off.  When ticked in the pull-
down menu, they are visible. 
An extra facility, called autohide, allows them to be visible, but only when required. Typically it is more useful to 
have them visible, but hidden so they can be easily accessed when required and they don’t clutter up the 
display. 

Autohide 
If the windows take up too much screen space, use the Autohide feature so they hide themselves when 
they are not used. They will shrink to the size of their tab, and will show themselves only when 
required.  
To activate Autohide on a pane, select the pin button in the title bar (Figure 11(a) - the window is now 
reduced to a tab bar Figure 11(b). The actual position of the tab is related to the position of the window 
on the screen and can vary. 

 

Figure 11 

Moving the cursor over the tab re-opens the window. The window remains open whilst the cursor 

remains in the window. The pin is displayed rotated by 90 degrees ( ) to indicate the window has 
been auto-hidden. The window closes as soon as the cursor is moved out-side of its area. This allows 
access to the window whilst achieving maximum editing area. 
To un-hide the window permanently, select the rotated pin from the title bar of the window whilst it’s 
open. 

Docking & Merging 
If the Navigator, Browser & Properties windows are visible and have not been auto-hidden (the pin 
should be upright in the title bar), they can be moved or “floated” around the screen as required, then 
released or “docked” in position.  
To move/dock a floating window 
Position the cursor over its title bar and hold down the left button. Drag the window to the location 
required.  
A rectangle shows you where the window will be docked.  It may try to snap to the edges of the screen 
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at a set size - the Ctrl key can be pressed when dragging the window to prevent it from trying to dock at 
these positions.   
Release the mouse button to release the window. 
The released windows can be moved as required, Figure 12.  

 

Figure 12 

These windows can be re-sized by dragging the sides/corners of the window in the usual way.  
To return them to their original positions without having to pick them up and move them, use the View 
> Restore Default Layout > Main Frame Layout command. 

View > Restore Default Layout > Main Frame Layout 
Used to restore the navigator, browser & properties panes to their original locations. 

View > Restore Default Layout > Editor Layout 
Used to restore the editor’s dialogue bars to their original locations. 

Grid commands 
The grid commands are used to control the grid. The grid can be made visible/invisible, items can be made to 
snap to the grid/half grid as required and there are 6 grid settings available to cater for any size of grid required.  
The grid dot size and intensity can be adjusted from the Edit > Display Adjustments window. 
The grid in the schematic/schematic parts editors may be displayed as lines or dots (Edit > Preferences, 
Miscellaneous window) and its colour can be altered (Edit > Preferences, Colours window). 
The colour of the grid in the other editors (artwork, profile, pad and outlines) is controlled from the Configuration 
> Colours folder.  

Grid > On/Off 
Used to toggle the grid display on and off. A tick indicates the grid is visible.  
At low  zoom levels the grid pitch may be too fine to be displayed, this is indicated in the information bar: 

 

Figure 13 

The current grid pitch is displayed in the status bar. The grid pitch is controlled by the selection made from the 
Grid menu. 
Whether the grid is visible or invisible, the Grid > Snap to Grid setting controls whether items snap to the 
nearest grid or half grid setting. 

Grid > Inch 
 Allows the user to specify a selection of grid pitches in inches, the most applicable one being chosen 
automatically for each level of zoom.  
The selection of grids is defined in the Configuration folder of the design, Grid Auto-pitch table. For instance, 
grids of 0.2", 0.1", 0.050", 0.025" and 0.005" could be specified. When viewing the complete board, one of the 
courser grids would be used as the finer grids would obliterate everything else on display. Likewise if a single 
item were filling up the screen, one of the finer grids would be used. 
The threshold at which the grid pitch changes is controlled from the Edit > Display Adjustments window. 
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Grid > Metric 
 As Grid > Inch but using metric pitches 

Grid > 0.1" 
Gives a 0.1" grid at all zoom levels. 

Grid > 1mm 
Gives a 1mm grid at all zoom levels. 

Grid > User Defined 
Allows a specific grid to be defined which can be different in the X and Y axis.  Once selected, type in the pitch 
required in both axes, select the units required then select OK.  

Grid > Snap to Grid 
Used to toggle grid snapping on and off. A tick indicates grid snapping is "on".  
With grid snapping on, items that are moved snap to the nearest grid, or half grid point when they are released, 
whether or not the grid is visible. If snapping is switched off items are released wherever the cursor is 
positioned. 
The current snap state gets saved with the design and the state is stored separately for the artwork, profile, 
outlines, custom pads and schematic views within the design. 
Note: when using the region commands in the schematic editor, the region rectangle corners and move/copy 
destination will always snap to grid/half grid irrespective of this setting. 

Grid > Select origin 
Used to force the grid to radiate from a selected point. If the grid origin has been moved, then the information 
bar contains the words "Grid-shift". 
In the component outline editor only a point (corner) of the outline or a pad datum can be selected. 
In the artwork editor, component datum’s can be selected as the origin, in addition to pads and track nodes on 
any visible layer. 
In the profile editor only a point (corner) of the current category (profile, keepout ot router) can be selected. 

Grid > Edit origin 
Used to force the grid to radiate from a specific position, using X-Y co-ordinates. If the grid origin has been 
moved, then the status bar contains the words "Grid-shift". 
When selected, a window appears containing the current position of the grid origin, with respect to the original 
datum point of the outline. New co-ordinates can be typed in. Select OK to implement the change. 

Grid > Clear origin 
Used to restore the grid to its original location, the word Gridshift will be removed from the status bar. 

Grid > Measure Distances 
Used to display the co-ordinates of cursor selected positions with respect to the datum of the outline, and also 
the last position selected. 
If grid snapping is switched on, the co-ordinates will refer to grid or half grid positions. The current grid is 
displayed in the information bar. 
Once selected, select a position with a click of the left-hand mouse button. A window appears containing the XY 
position of the selected location. If another position is selected, the window contains its XY position, plus the 
distance in the X and Y axis (DX and DY) between the two selected positions. The straight-line distance is also 
given (L). 

Window commands 
Window > Cascade 
Used to display the open windows in "cascading" mode from the top left of the SXLD window. 

Window > Tile Vertical 
Used to display the open windows in vertical columns in the SXLD window. 

Window > Tile Horizontal 
Used to display the open windows in horizontal rows in the SXLD window. 
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Edit commands 
Edit > Units 
Used used to change the selected units. Either metric or inch units can be selected.  
The units selected control the X-Y readout, they do not control the grid which is controlled from the Grid 
command menu.  
The selected units are used when displaying sizes or when sizes can be entered. Unless specified (“ or mm) the 
decimal point indicates whether Imperial or Metric values are in use a . (dot) is used in Imperial values and a , 
(comma) in metric values. 
The selected units mode gets preserved across program sessions. 

Edit > Display Adjustments 
Previous versions of Ranger and XL Designer had become very slow when refreshing the artwork display on 
Windows7 and later versions, which meant changes were necessary. XL Designer now uses the Microsoft 
Direct2D API for all graphical displays so that full speed advantage of the latest generation of graphic cards and 
processors can be utilised. This change has led to the loss of some features, such as colour mixing (when red 
and blue tracks overlapped they became purple) and the ability to control the thickness & height of items in 
terms of pixels when zooming in/out (so that labels/pin numbers didn’t alter their height dependant on zoom 
level). 
Because of these changes, there is no longer one setting that suits all hardware configurations or users, so new 
controls have been added to allow fine-tuning of the new-style display, for example to make lines and grid dots  
thinner/thicker/sharper, to make labels/pin numbers/grid dots bigger/smaller, etc. These will be found in the Edit 
> Dsiplay Adjustments window (also the Opacity control in the View Control dialogue bar). 
A combination of changes may be required and if the display is not to your liking, some time should be spent 
adjusting the settings to obtain the best display possible. For example, it may be necessary to adjust the grid dot 
size and intensity to obtain grid dots that are comfortable to look at. 
When making a change, it is a good idea to view the display with the minimum, then maximum values set – this 
provides a reference marker to allow finer-tuning to take place. 
When selected a window similar to that shown in Figure 14 appears.  
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Figure 14 

Pay particular attention to the note (arrowed in Figure 14) - if any adjustments are made to the settings, then the 
editor itself (schematic, outline, profile, artwork) MUST be closed and reopened for those changes to be 
implemented and therefore visible. 
The first settings are common to all graphical editors: 
Use Display Anti-aliasing: 

The anti-aliasing feature of Direct2D means that the edges of displayed features are now much smoother – 
for example arcs/circles no longer have a jagged look to them, nor do non 0/90 degree lines. However this 
can be a disadvantage when trying to ensure that all lines are at 0 or 90 degrees, so you may prefer to 
have anti-aliasing switched off (unticked).  
There is also some speed penalty with anti-aliasing switched on, though typically only noticeable on very 
dense artworks. A display rendering speed increase of 40% is typical when anti-aliasing is disabled. 

Minimum Line Rendering Width: 
Some lines can be too thin to be visible at some zoom levels (typically square/rectangular pads shown 
unfilled). This setting allows the thickness of the thinnest lines to be made visible at all zoom levels. 
Note: when "display tracks at width" is selected, the tracks will never be rendered narrower than the size 
specified here. 

Dotted grid dot size and Intensity: 
It can be difficult to see the grid dots due to their size or intensity/brightness, or they can be too over-
powering. 
Use these two controls to make adjustments to the grid dot diameter and brightness. 
Larger numbers increase the size of the grid dots and make them brighter.  

Autogrid pitch change threshold: 
By changing this value, the threshold at which the display switches from one autogrid pitch (Grid > 
Inch/Metric) to the next, can be controlled.  
The auto-grid pitches are defined in the Configuration > Grid Autopitch Table. 

Schematic Editor: 
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Ruled Grid Line Width: 
 The width of the ruled grid lines in the schematic editor can be set in the range 10 -100 where larger 
numbers result in thicker grid lines. 

Artwork Editor: 
Part Labels & Pin Number Text Sizes: 

The size of text displayed for part labels and pin numbers can be set in the range 20-100 with larger 
numbers increasing the size of the text.  
The size selected is a compromise as the actual height varies with zoom level, so adjust the size until a 
good compromise is selected. The more you zoom in, the smaller they appear. 
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Configuration Folder 
The configuration folder contains fundamental information about the design. The majority of this information will 
be common across all designs, but individual designs may need slight variations.  
For this reason, each design has its own configuration folder and settings. The information in the design’s 
configuration folder is initially copied from a master configuration folder. The master configuration folder was 
created when the software was installed and it contains the default values for these settings.  
The master configuration folder can be modified to suit individual company standards. It can be reviewed and 
altered as required, but bear in mind altering some values will affect other things. For example, altering the 
master pad sizes table will affect component outlines held in the master component outline library that use those 
pads. 
Altering the master configuration folder has no effect at all on designs that already exist. 
When a design is created it takes a copy of the master configuration folder contents, so the design’s 
configuration folder is initially the same as the master configuration folder. 
Once a design has been created, its configuration folder can be modified for the particular design rules in place 
for that design. Once created, each design’s configuration folder is totally independent of the master 
configuration folder and every other design’s configuration folder. 
A design’s settings can be restored to the values held in the master configuration folder by right-clicking on the 
design’s configuration folder (Figure 15), selecting Restore Design Defaults, then selecting which items to 
restore to the current master design default values. 

 

Figure 15 

 
The configuration folders are accessed from the navigator pane as shown in Figure 16, from within the 
expanded Masters folder or the design’s own folder. 

 

Figure 16 

When the folders are opened, the settings appear. The content of a design configuration folder is shown in 
Figure 17. Each setting can be selected and opened.  
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Figure 17 

The master configuration folder does not include the settings for Power names, Layer assignments & ordering or 
Via hole definitions, as these will always be defined locally within the design. 
Each of the settings is described in this chapter. 

Configuration folder – Colours 
When selected the window similar to that shown in Figure 18 appears. 

 
 

Figure 18 

This permits the configuration of a set of colours for the items/layers/categories listed, in the specified editors. 
To make a change, select the category so that it highlights, at which time the browser selection button will 
appear, as shown arrowed in Figure 19. 
Select this browser button to display the colour palette. Make a choice, then OK the window. 
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Figure 19 

Restore Factory Defaults:  only available when the master colours window is open. It is used to replace the 
existing colour set with those that were selected when the software was installed. 

Restore Defaults:  only available when the design’s colours window is open. It is used to replace the 
existing colour set with those colours defined in the master set. 

Copy to Masters: only available when the design’s colours window is open. It is used to copy the 
current design’s colour set to the Master set. 

Configuration folder - Part prefix codes 
Every part within a design must have a reference designator, which consists of a part prefix code and a number. 
For example: IC1, IC2, R1, R2, R3, C1, C2, etc.  
Upto 64 part prefix codes can be defined within a table, a sample part prefix code table is shown in Figure 20.  

 

Figure 20 
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Up to 4 upper-case characters are permitted in a part prefix code. (Lower case characters are automatically 
changed to upper-case.) 
An optional description can be assigned to each prefix, but the software does not refer to this data. 
To save typing in a part prefix code table each time a design is created, a master table is provided. This table 
should contain the standard part prefixes used by your company. For example, IC or U might be used for 
integrated circuits, TR for transistors, R for resistors, etc. 
When a design is created, a copy of the master part prefix code table is copied into the design, so the master 
table should contain all the prefixes commonly used by your company. Non-standard prefixes can be added to 
the design's part prefix code table as they are required. 

To view/change the part prefix codes: 
With the Masters or Design folder open, depending on which will be edited, double-select the Configuration 
folder, then either double-select Part Prefix Codes with the left mouse button, or right-click it, and then select 
edit. The part prefix table appears.  
To add or edit a part prefix or description, select the appropriate entry and type in the characters required. Use 
<tab> to move between entries. 
Select OK to close the window and implement the changes. 
Changes to the master part prefix code table only affect new designs, existing designs are not affected. 
Changes made to a design’s part prefix table do not affect other designs or the master part prefix table. 
The design’s part prefix table is automatically updated when a circuit schematic is compiled into a parts/wiring 
list or a parts/wiring list is imported, if new prefixes were used on the circuit. 
The prefixes can be restored to the values assigned in the master part prefix table by right-clicking on the 
Configuration folder and selecting Restore Design Defaults, then choosing the option(s) required – but see the 
notes below prior to making the change. 
Important Notes:  

• DO NOT alter the order of the part prefixes in this list once a parts and wiring list exists - the change 
will affect the parts and wiring list and artwork. See Effects of altering part prefix codes below. 

• New part codes should be added to the end of the existing entries. 
• If an existing prefix is modified and a parts and wiring list exists, then all occurrences of the changed 

prefix will also be changed in the parts/net lists. 

Effects of altering part prefix codes  
The following information is supplied for reference purposes and explains why the order of part code prefixes 
should not be changed once a parts/wiring list has been created. 
Internally, the software operates on a number it has assigned to part prefixes (from 0 to 63), not the prefix itself. 
So for example, if the prefix IC is in position 0 in the part prefix code table, IC1 will be referred to internally as 
01, IC2 will be 02, etc. If the prefix TR is in position 1, then TR1 is held as 11, TR2 as 12, TR3 as 13, etc.  
In the parts list, each part is shown with its prefix, IC1, IC2, TR1, TR2, etc. and once the parts are placed on the 
artwork, their X/Y co-ordinates are also shown/stored. For example: 

IC1 7400,74LS00 DIL14 1.0 2.0 0 (part held internally as 01) 
IC2 7404,74LS04 DIL14 1.0 3.0 0 (part held internally as 02) 
TR1 BC999,BC999 TO18 2.5 1.0 0 (part held internally as 11) 
TR2 XX123,XX123 TO3 2.5 1.5 0 (part held internally as 12) 

If the positions of the prefixes are reversed in the prefix code table, so that IC is now in position 1 and TR in 
position 0, the prefixes in the parts list also get reversed as shown below. 

TR1 7400,74LS00 DIL14 1.0 2.0 0 (part held internally as 
01) 
TR2 7404,74LS04 DIL14 1.0 3.0 0 (part held internally as 
02) 
IC1 BC999,BC999 TO18 2.5 1.0 0 (part held internally as 
11) 
IC2 XX123,XX123 TO3 2.5 1.5 0 (part held internally as 
12) 

This is obviously incorrect and will affect the artwork if designed as well - TR1 and IC1 have swapped positions, 
as have TR2 and IC2. The tracks on the artwork will remain in their original positions, which will cause 
connectivity problems (shorts and unroutes). 
If the prefix table is restored to its original settings, the parts/wiring list and artwork will also be restored 
correctly. 
If the prefix IC was changed to ZZ, then all the IC's in the parts list would become ZZ's. On a completed design 
this would mean the silk-screen labels would be incorrect. 
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To sum up: do not alter the order of prefixes in the design’s part prefix table unless the implications are fully 
understood. 
The order of part prefixes in the master table can be changed without any effects. 
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Configuration folder - Size Tables, Pad Sizes 
Four standard pad shapes are available, with up to 512 different pad sizes for each of those pad shapes.  
(Non-standard pad shapes are described in a separate chapter, entitled Custom Pads.) 
The four standard pad shapes are:  

Round 
Square 
Round-ended-rectangular 
Square-ended-rectangular 

(Heat-relief and anti-pads are also available for use on internal power planes and these are described 
separately later.) 
Standard pads can have up to one drilled hole that will always be in the centre of the pad.  
Connections/tracks are attached to the centre of standard pads. 
To help identify the pads, each pad is assigned a number for reference purposes, from 0 to 511, which is known 
as its pad code.  
When pads are used, they are called up by their pad code and the size of the pad is dependent on the 
dimension assigned to that pad code in the pad size table. This makes it easy to change the size of all the pads 
of a particular code within a design, by simply editing the pad size table – this also gives flexibility between 
designs. 

Master/Design Size Tables 
When the software was installed, a master pad sizes table was supplied. The pads used in the master 
component outline library use the pad sizes defined in the master sizes table.  
When a design is created, a copy of the master size tables is copied into the design. The design’s table can be 
edited without affecting the master sizes table or any other design. 
The master pad sizes table should contain all the pad sizes in common use.  
The design’s pad sizes table in addition to the pad sizes in common use, should also contain any non-standard 
pad sizes required by that design.  
Changes to the master sizes table only affects new designs, existing designs are not affected. 
Changes made to a design’s sizes table do not affect other designs or the master sizes table. 
All the pad codes from 0 to 15 in the master pad sizes table had sizes assigned to them, whilst pad codes from 
16 onwards were set to 0 unless they were in use by the master outline library.  
(Pad codes from 0 to 15 that are not used in the supplied master outline library are set to 0.049" diameter/wide 
or 0.049" x 0.019".) 

To view/change the sizes table: 
With the Masters or Design folder open, depending on which set of pad sizes will be edited, double-select the 
Configuration folder, then either double-select Sizes Table with the left mouse button, or right-click it, and then 
select edit. The sizes table appears, similar to the one shown in Figure 21. 

 

Figure 21 

If the design’s sizes table is opened, this table was initially copied from the master sizes table when the design 
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was created.  
This window has four tabs that can be selected, the Pad Sizes being one of them. 
The list of pads can be scrolled through by selecting the scroll bar or arrows on the right side of the window. 
The units in use can be set to inches or millimetres by selecting the Units command from the top of the window. 
The pad sizes table is made up from rows and columns. Each row represents one pad code. The columns are 
used for the drill size and the size of each pad shape (rectangular pads have a length and width column). 
The drill size relates to all pads with the same pad code.  
Even if a drill size is specified in the pad, it may not be drilled when used. (Holes are only drilled if the pad is 
added to the inner layer of a pad stack, or to layer V in the artwork editor.) 
Each column can be sorted in ascending/descending order by selecting the column headers. 
Any of the values may be edited, by selecting the value and retyping. Note: changing the value of any pad/drill 
sizes that are in use within component outlines of the associated library (master outline library if the master 
sizes table is open, or the job library if the job’s sizes table is open) will affect those outlines. Likewise if a job is 
open and the pad/drill size is changed, the change will affect those pad/drill sizes used in the artwork editor. 
Select OK to close the window and implement the changes. 
If the changes were made whilst the outline or artwork editors were open, the screen will need to be refreshed to 
update the displayed pads/drill sizes. 

To restore the design’s pad/track sizes table to the master settings: 
The design’s size table can be restored to the values assigned in the master sizes table by right-clicking on the 
Configuration folder and selecting Restore Design Defaults, then choosing the option(s) required. 

Notes about pad sizes: 
• round or square code 0 pads are always used for standard vias so this size code should not be used 

for anything else. If a component pad will require the same pad size as that assigned for code 0, then 
define another pad code with that same size.  
For example code 0 and 9 round pads are both assigned as 0.055" (different drill sizes though) in the 
master table. Code 0 will be used for vias, and code 9 should be used for component pads. If a 
different hole size is required, define a new round pad. 

• Pads that have been used on the artwork have an * (asterisk) next to them in the design’s pad sizes 
table. (The * does not appear in the table until the outlines containing the pads have actually been 
placed on the artwork and the artwork saved. 

• In the master pad sizes table, any pad sizes that have a size assigned (with the exception of those set 
to 0.049" or 0.049" x 0.019") are used in the master component outline library. If those sizes are 
changed, they will affect the supplied master component outline library. 

• round-ended or square-ended pads cannot have a pad width that is the same size or larger than the 
pad length defined – the width must always be smaller 
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Configuration folder - Size Tables, Heat-relief and anti-pads 
Heat-relief pads and anti-pads are only used if power planes or split-power planes are generated on an inner 
layer of a design. 
A power plane layer is an inner layer made from a solid sheet of copper. All holes that pass through the layer 
are connected to it, and therefore to each other, until they are isolated by anti-pads. 
Two types of pad are used on power planes, anti-pads and heat-relief pads and they are shown in Figure 22, 
the anti-pad is on the left. The red background represents copper.  

 

Figure 22 

Anti-pads are used to isolate the holes from the copper plane. Anti-pads are in fact "not copper", they are the 
negative/opposite of a copper pad as they remove copper from the plane. When placed over a hole (that can't 
be seen in Figure 22) on a plane of copper, they form a clearance area around the hole. The hole is therefore 
disconnected from the plane. 
Heat-relief pads are used around holes that should be connected to the plane; they are not strictly required as 
the hole is connected to the plane even if they are not used. However, problems with heat transfer could be 
experienced when soldering the board if they are not present. Figure 22 shows the heat-relief pad on the right, 
surrounding the hole which can be seen.  
The heat-relief pad maintains the connectivity to the hole. 
The sizes of these pads are related to the size of the hole passing through the board, and never related to the 
size of pads used on other layers of the board. 
Different anti-pad and heat relief pad sizes can be defined for different hole sizes.  
On the screen and during the plotting processes, a reverse image of the power plane is seen (except when 
using "Preview" mode in the power plane tools commands). For example, on the screen the anti-pads and heat-
relief pads will appear as copper, but in reality they are not copper, the rest of the layer is copper and they form 
clearance areas. 
Heat relief and anti-pads are defined in a table as shown below. 

 

Figure 23 

The sizes can be displayed/entered entered in imperial or metric after selecting the Units command from the top 
of the window. 
The sizes in each row can be changed by selecting the value to be changed and then typing in the new value. 
The <tab> moves the text entry cursor between fields. The window is divided into areas as follows: 
Drill size range - Min and Max Sixteen ranges of hole sizes can be defined. This allows different heat-relief 

and anti-pad sizes to be defined for different hole sizes. The ranges should not 
overlap, e.g. if the minimum and maximum values for one range of holes were 
set to 0.020" and 0.035" respectively, the previous maximum value should be 
0.019", and the next minimum value should be 0.036". 

Heat-relief pads Three parameters are defined for heat-relief pads, as shown in Figure 24 and 
they are: Track width, Clearance and Channel width. The sizes entered 
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relate to the range of hole sizes on the same horizontal line. 
Anti-pads One parameter is defined for anti-pads as shown in Figure 24. It is the isolation 

distance between the edge of the hole and the copper plane. 
 

 

Figure 24 

A master heat-relief & anti-pad table is provided. When a design is created, a copy of the master heat-relief & 
anti-pad table is copied into the design. Therefore, the master table should contain the standard requirements 
for heat-relief & anti-pads. Design specific requirements can be included in the design’s heat-relief & anti-pad 
table as they are required. 

To view/change the heat-relief and antipad sizes: 
With the Masters or Design folder open, depending on which will be edited, double-select the Configuration 
folder, then either double-select Size Table with the left mouse button, or right-click it, and then select edit. The 
sizes table appears, with the Pad sizes visible. Select the tab titled Heat-Relief & Anti-Pads to display the heat-
relief & anti-pad size table. A window similar to the one shown previously in Figure 23 appears. 
Changes to the master Heat-Relief & Anti-Pads table only affect new designs, existing designs are unaffected. 
Changes made to a design’s Heat-Relief & Anti-Pads table do not affect other designs or the master Heat-Relief 
& Anti-Pads table. 
Heat-relief pads and anti-pads are only used on layers defined as power plane layers.  
Selecting OK closes the window and implements the changes. 
If the changes were made whilst the artwork editor was open, the screen will need to be refreshed to update the 
displayed heat-relief and anti-pads. 

To restore the design’s pad/track sizes table to the master settings: 
The design’s size table can be restored to the values assigned in the master sizes table by right-clicking on the 
Configuration folder and selecting Restore Design Defaults, then choosing the option(s) required. 
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Configuration folder - Size Tables, Track sizes 
Each design within Seetrax XL Designer can use upto 512 different line thicknesses or track sizes. 
(For profile, keepout, etc. line sizes, refer to the Miscellaneous Line Widths tab in this same window.)  
Although referred to as the Track sizes table, any lines added to the artwork also use the sizes in this table, for 
example lines that form the silk-screen outline shapes. 
Each track size is assigned a number for reference purposes, from 0 to 511, which is known variously as its 
width code, track code or size code.  
A master track sizes table is supplied, with codes 0 to 15 having commonly used sizes assigned to them, the 
remainder being set to zero. 
Each time a design is created, the sizes from the master table are copied into the design, so the design starts 
off having the same sizes assigned. The master table should therefore contain the standard track sizes used by 
your company.  Non-standard track sizes can be added to the design's track size table as required. 
Changes to the master sizes table only affects new designs, existing designs are not affected. 
Changes made to a design’s sizes table do not affect other designs or the master sizes table. 
When tracks/lines are added, the size of the line is dependent on the size defined in the size table. This makes it 
easy to change the thickness of all the tracks/lines of a particular code within a design, by simply editing the 
track size table. It also allows flexibility between designs. 
Notes when changing sizes:  

• code 4 tracks are used extensively in the master outline library for silk screen outlines.  
• code 2 is the default size code used when silk-screen labels are added 
• codes 4 and 11 are the default sizes assigned for signal and power connections 
• track\line sizes that are used in the artwork editor of the design have an * (asterisk) next to them in the 

design sizes table. (The * does not appear in the table until the tracks/lines have actually been used on 
the artwork and the artwork closed.) 

To view/change the Track Sizes: 
With the Masters or Design folder open, depending on which will be edited, double-select the Configuration 
folder, then either double-select Size Tables with the left mouse button, or right-click it, and then select edit. The 
size tables appear, with the Pad sizes visible. Select the tab titled Track Sizes to display the track size table. A 
window similar to the one shown in Figure 25 appears 

.  

Figure 25 

The units in use can be set to inches or millimetres by selecting the Units command from the top of the window. 
To edit a track/line size, select the track size from the list, then type in the new size. 
Select OK to close the window and implement the changes. 
If the changes were made whilst the outline or artwork editor was open, the screen will need to be refreshed to 
update the displayed track/lines. 

To restore the design’s pad/track sizes table to the master settings: 
The design’s size table can be restored to the values assigned in the master sizes table by right-clicking on the 
Configuration folder and selecting Restore Design Defaults, then choosing the option(s) required. 
 



 

28 

Configuration folder - Size Tables, Miscellaneous Line Widths 
This window controls the size of board profile and keepout region boundary lines and any other features that do 
not have a specific thickness assigned. 
Please note that the values specified here only influence the display of features in the output task preview 
window and in resultant outputs. They do not influence the display within the outline, artwork or board profile 
editors. 

To view/change the Line widths: 
With the Masters or Design folder open, depending on which will be edited, double-select the Configuration 
folder, then either double-select Size Tables with the left mouse button, or right-click it, and then select edit.  
The size tables appear, with the Pad sizes visible. Select the tab titled Miscellaneous Line Widths to display the  
window similar to the one shown in Figure 26. 

.  

Figure 26 

 
The units in use can be set to inches or millimetres by selecting the Units command from the top of the window. 
To edit a size, select the size from the list, then type in the new value. 
Select OK to close the window and implement the changes. 
If the changes were made whilst the output task editor was open, the task will need to be closed/reopened to 
update the displayed lines. 
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Configuration folder - Manual routing parameters 
This window contains the settings that are used when manually routing connections or tracks in the artwork 
editor. 
A master set is stored and can be changed. The master set is copied into each design when it is created.  
Changes to the master set do not affect existing designs. 
The parameters within each design can be modified as required without affecting other designs or the master 
set. 

To view/change the Manual routing parameters 
With the Masters or Design folder open, depending on which will be edited, double-select the Configuration 
folder, then either double-select Manual Routing Parameters with the left mouse button, or right-click it, and then 
select edit. The manual routing parameters window appears.  
To edit a parameter: some have values that can be typed in, in which case select the entry and type in the value 
required. Use <tab> to move between entries. Other parameters have a pull down menu, from which an option 
can be selected. 
Select OK to close the window and implement the changes. 
When selected, a window similar to the one shown in Figure 27 appears. The parameters are described below. 

 

Figure 27 

Power & Signal Width  Used to specify the default width codes used for power and signal connections/tracks. 
The actual thickness assigned to the codes is displayed underneath the setting, which is 
controlled from the track sizes table. The codes can be changed by using the spin-
controls alongside. 
If the codes are changed and the artwork editor is open, the screen has to be refreshed 
to implement the change. The change does not affect existing tracks – only unroutes are 
affected. 
Note: the schematic/wiring list can be used to specify particular width codes for individual 
nets if required and these values will over-ride the default settings on those nets.  

DRC Clearance When manually routing tracks in the artwork editor, it is possible to switch on, on-line 
dimensional rule checking (DRC) (using the tick box in this window).  
If it is switched on, any gaps that are smaller than the sizes specified here when manually 
routing are flagged as clearance errors. Different minimum clearances can be specified 
for power and signal tracks. 
The artwork-checking window is automatically updated to reflect the values assigned in 
this window. 
Note: the schematic/wiring list can be used to specify particular minimum clearance 
requirements for individual nets if required and these values will over-ride these default 
settings on those nets. 
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The units (inches or millimetres) are defined before opening the window using the Edit > 
Units command.)  

Active DRC When manually routing tracks in the artwork editor with this setting ticked, clearance or 
short circuit errors are flagged as they occur. An error flag temporarily appears next to the 
offending clearance error or short circuit error, it doesn't stop the error occurring. The 
error can be left for later modification. 
The minimum clearance requirements for signal and power tracks are defined in this 
window (Default width codes and DRC clearance). 
It is important that the artwork checking routines are always performed on the finished 
artwork design in case flagged errors are forgotten. 
With Active DRC unticked, clearance or short circuit errors can be made when manually 
routing and no warning is given. 

Unroute reconnect This setting is only used if parts are mounted on both sides of the board. It specifies the 
order required when performing the reconnect function on signal connections. It can be 
set to Side-biased or Shortest. 
On layouts where all the parts are mounted on one side of the board, signal reconnection 
can only take place on that one side, irrespective of whether Side-biased or Shortest is 
selected. 
Where parts are mounted on both sides of the board, the shortest path between 
connected pads may well be through the board, but this could prove costly in terms of the 
number of vias required.  
The alternative would be for the reconnection to take place on each side of the board 
first, and then join through the board.  
The user chooses either Side-biased or Shortest. 
Example - There are eight surface mounted devices on the layout Z1 to Z8, and all pin 
one's are connected together. Z1 to Z8 are placed in a horizontal line across the top of 
the board. Then Z2, Z4, Z6 and Z8 are flipped on to the bottom of the board. 
If side-biased reconnection is used, the connections will connect all the parts on the top 
of the board, followed by those on the bottom of the board, with one connection joining 
the two sides, i.e. connections will appear between Z1, Z3, Z5, Z7, a connection will join 
the top and bottom parts together, i.e. Z7 to Z8 with connections between Z2, Z4, Z6 and 
Z8. This would result in one via being required between Z7 and Z8. 
If Shortest reconnection is used, then the connections will connect between Z1 to Z2 to 
Z3 to Z4 to Z5 to Z6 to Z7 to Z8, even though the parts are on different sides of the 
board. This means that 7 vias will be required to route the connections. 

Unrouted power bias Used to specify the default reconnection direction for power connections, as the shortest 
path is not always the most appropriate. It can be set to Horiz, Vert or None. 
Horizontal bias will bias the power connections, when they are reconnected, in the 
horizontal direction, even if the distance between connected pins is greater than taking 
the most direct route between connected pins, as shown in Figure 28 
 

 
Figure 28 

 
Vertical bias works in the same way as horizontal bias, except the direction is vertical, as 
shown in Figure 29. 
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Figure 29 

 
No-bias (none) results in the most direct path being chosen for power connections when 
they are reconnected. 

Via shape Selections are Round or Square. Standard vias are inserted with a code zero pad whose 
shape is defined here. Existing vias are unaffected by this setting, so an artwork could 
have both round and square code 0 vias in use. 

Segmove mode Selections are Free or Axis-locked. This setting applies when the Mroute > Move 
Segment command is used. Free allows track segments to move freely in any direction. 
Axis-locked restricts horizontal and vertical track segments to movement in one axis only. 
Note: angled track segments always move freely. 

Unroute convert Selections are Convert all or Convert partial. This parameter applies when using the 
Mroute > Corner command in the artwork editor to insert corners into unroutes, which 
subsequently turns the unroute into a routed track. It controls whether one or both 
segments on either side of the corner are converted into a track.  
With convert all selected, when a corner is inserted into the unroute, the unroute 
becomes a routed track on either side of the corner, i.e. both segments are routed.  
With convert partial selected, when a corner is inserted into the unroute, the shortest 
segment is converted to a routed track, whilst the longer segment remains as an unroute. 
Because the unroute is not complete (ie it has been partially routed) it is shown as a 
dashed line to distinguish it from complete unroutes that are shown as solid lines and 
stretch between pins.  
Note: if the "longer" segment is shorter than the value inserted in the Unroute Minimum 
Length parameter, the segment is also converted to a routed track. 
With convert partial selected, the track segment being added can be placed on any of the 
active manual routing layers by pressing the user defined "layer swap" key. Vias are 
inserted as required. The layer that the track will appear on is displayed in the Manual 
routing dialogue bar. 

Unroute min length If Unroute Convert is set to Convert Partial, this parameter is used, it is otherwise 
ignored. When a connection is released, if the length of the unrouted segment is less 
than the length specified here, it is converted into a track.  
Select the box and type in the value required. 

Corner insertion Selections are Select\drop or Multinode. This setting is used when the Mroute > Corner 
command is used in the artwork editor.  
If Select\Drop is selected, connections and tracks are released from the cursor once a 
corner has been inserted. If Multinode is selected, the connection or track remains 
attached to the cursor until the opposite mouse button is clicked, provided the connection 
or track segment selected is attached to a pad at one end. 

Select OK to close the window and implement the changes. 
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Configuration – Rip Retry Autorouter costs 
This window contains the settings that are used when auto-routing connections in the artwork editor. 
A master set is stored and can be changed. The master set is copied into each design when it is created.  
Changes to the master set do not affect existing designs. 
The parameters within each design can be modified as required without affecting other designs or the master 
set. 

To view/change the Rip Retry Autorouter costs 
With the Masters or Design folder open, depending on which will be edited, double-select the Configuration 
folder, then either double-select Rip Retry Autorouter Costs with the left mouse button, or right-click it, and then 
select edit. The rip retry autorouter setup window as shown in Figure 30 appears. The window is described 
below. 

 

Figure 30 

Select OK to close the window and implement the changes. 

Rip Retry Autorouter Setup Window  
The auto-router has 8 routing strategies available for use and they are numbered as steps from 1 to 8 in the 
setup window.  
The strategies can be selected or enabled for use by the auto-router as required, by ticking the boxes in the 
Enable column alongside the strategy. The enabled strategies are always used in numerical order, from step 1 
to 8.  
Each routing strategy has parameters that are accessed by selecting the box in the Setup column alongside the 
strategy. When the box is selected, a window appears containing the parameters for that routing strategy. 
Different types of layout may use different combinations of the strategies with different settings assigned to the 
parameters.  
The master set should be set to suit most designs (as supplied). Before starting the auto-router, select the 
settings you think most appropriate from the information given below. 
Any changes that are made are saved with the design. The master default settings can be restored at any time 
by selecting the "Restore Default Config" button from the setup window. 

Power pattern strategy and setup 
If enabled, this strategy will be the first to be used when auto-routing. It operates on the connections that have 
been defined as power rails in the configuration folder’s, power names table. 
This routing strategy has two objectives. First, to insert "stubs" (tracks with a via) from surface mounted 
component pins that should be connected to internal power planes 
Secondly, if the board does not have power planes defined, it attempts to route the power connections without 
inserting via holes. The strategy runs as follows: 
Power "buses" are placed horizontally and vertically across the board with "spurs" connecting to the appropriate 
pads. The minimum distance between buses connected to the same rail, and the maximum length of the spurs 
is defined in the setup window. 
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Power rails are routed one after the other, as listed in the wiring list. 
Often, there will be pads connected to the power rails that are  "out of reach" of the power buses because of the 
values assigned in the power pattern setup window. They will be attempted by the "costed power router", whose 
strategy and setup is described later.  
Minimum bus spacing This setting is used to reduce the number of power buses on the layout. For example, 

the power routing in Figure 31, would usually be preferred to that in Figure 32. 
 

 
Figure 31 

 

 
Figure 32 

Before routing the power connections, the router draws imaginary straight lines, across 
all pads on the same power connection, i.e. all pins connected to the GND signal as 
shown in Figure 33.  

 
Figure 33 

Lines that only pass through one pad are ignored. 
The direction chosen for the bus lines depends on the number of pads each bus line 
passes through. The ones passing through the most pads are chosen.   
The distance between these imaginary lines is the "bus spacing". If the lines are closer 
together than permitted by the minimum bus spacing, lines are removed one at a time 
until those that are left do not violate the spacing requirement. The lines that are left 
form the basis of the power buses. These lines obviously need to be adjusted to clear 
the pads that are not connected to the power rail, see: Bus to pin spacing 

Bus to pin spacing  This value defines the distance between the imaginary bus lines that were drawn and 
maintained as described for the Minimum bus spacing, and the centre of the actual 
routed power bus rails. Spurs are then used to join the bus and pads together, as 
shown in Figure 34. 

 
Figure 34 

Off-bus capture  The router scans either side of the imaginary bus lines, for the centre of any pads that 
are also connected to the same power rail. The scanning distance is defined by the Off-
bus capture. Any pads connected to the same power rail that are found within this 
scanning area will also be connected to the power bus with spurs. 
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Figure 35 

Increasing this value results in longer spurs. If a double sided board is being routed, 
with horizontal tracks on one layer and vertical tracks on the other, these longer spurs 
will block routing channels as they will be running at right angles to the preferred 
routing direction. 

DIL Preference in Figure 34 the power busses have been inserted under the dual-in-line components. 
This setting controls whether the power busses are placed underneath or outside the 
dual-in-line components.  
Note: the component outline’s autoplace footprint as defined in the component outline 
is used to define the boundary of the component outline for the purposes of the under 
or outside setting. 

Fix routes  Tracks that are routed using the power pattern router can be fixed in position if 
required. They will not then be ripped up by the power or signal rip-up routers if they 
are used.  
Typically power tracks routed with this strategy are fixed in position.  

Power cost strategy and setup 
This routing strategy is designed to route the remaining power connections after the power pattern routing 
strategy has been used. It will however attempt to route all the power connections if the power pattern strategy 
was not enabled. The shortest connections are routed first. 
This strategy evaluates all the possible paths that each track can be routed along. The path that is chosen is 
determined by its "cost". The costs are defined in the setup window and the lowest cost path is chosen.  
This routing strategy can be repeated up to 3 times automatically, with different settings assigned to each 
routing pass. Each connection is attempted once per pass. Typically each pass is less restrictive than the 
previous pass to achieve more routed connections. In the early restrictive passes, more direct routing will be 
achieved, but not all the connections will be routed.  
The settings for this strategy are described now. 
Direction change Due to obstacles (pads, tracks, vias, etc,) the track may need to change direction to 

reach its destination pad. Every time it does this, the cost assigned to this setting is 
added to the cost of the route. 
Note: only 90 degree direction changes are taken into account.  
A higher value will make it less likely that direction changes will be inserted. This may 
lead to lower completion levels as it is less likely that paths will be found around 
obstacles. However on early routing passes the cost could be higher to achieve more 
direct routing. 

Away from target  The strategy searches for a path between the source and destination pads using an 
iterative process. If at any time during a search for a solution, the distance from the 
current search point to the destination pad is greater than, or equal to, the distance from 
the previous search point to the destination pad, the router assumes it is straying away 
from the target and adds the "away from target" cost to the solution cost at that point. 
A higher cost will make it less likely for the router to find a way around obstacles, 
however on early routing passes the cost could be higher to achieve more direct routing. 

Wrong way for layer  Because of obstacles (pads, tracks, vias, etc,) the router may need to route horizontally 
on the side assigned for vertical tracks, or vice versa. Every time it does this, the cost 
assigned is added to the cost of the route. 
Note: tracks inserted at 45 degrees are not taken into account. 
A lower cost will result in more "wrong way routing" which will reduce the via count, but it 
may lead to lower completion levels. 

Via hole To achieve horizontal tracks on one side of the board and vertical tracks on the other, as 
required on most double-sided boards, a via should be inserted every time the track 
changes direction. 
Every time a via hole is added, the cost assigned is added to the cost of the route. A 
lower cost will result in more vias and less wrong way routing. 

Maximum route cost  If the total cost of a route between two pads exceeds the value entered here, the 
connection will not be routed. Subsequent routing passes will attempt to route it.  
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A lower maximum cost will make it less likely for the router to find a satisfactory way 
around obstacles. However on early routing passes the maximum cost could be set lower 
to achieve more direct routing. 

Gravity distance & Gravity strength - The router will normally find a minimum cost route between the source and 
destination pads. This will sometimes result in a layout where tracks are too far apart, 
consequently wasting routing channels. A higher completion rate would be achieved if the 
tracks had been forced to pack tightly together. The Gravity distance and Gravity strength 
parameters control this tendency for tracks to pack closer together. 
The Gravity distance parameter controls how close a route search must approach an 
existing route before it gets pulled and held close to the existing route's path. 
It is measured in routing grid units. Valid entries are 1 through to 10. For instance with a 
routing pitch of 0.025", an entry of 6 would be 0.150". If the routing pitch were 0.020" an 
entry of 6 would be 0.120". A higher number will pack tracks closer together than a lower 
number. 
The Gravity strength parameter is a measure of the difficulty of breaking away from an 
existing route's path, after having been drawn towards it. 
Valid units are from 1 through to 50. A higher number makes it more expensive for the 
track to move away from the existing route. 

Routing pitch  Defines the minimum grid over the board on which the centre line of tracks and vias can 
be placed. 
The grid radiates from the origin of the board which is defined via the Grid commands in 
the artwork editor. It is suggested that the position of the grid origin is maintained 
between part placement and routing.  
Finer grids will result in more success. Before assigning a very fine grid (0.001") bear in 
mind that finer grids require a lot more memory (RAM) (this will also be affected by board 
dimensions and layers) and that the resultant tracks will be placed on that grid. If 
manually adjusting tracks afterwards, this can prove frustrating when trying to maintain 
horizontal and vertical tracks. 

Major axis overshoot An imaginary rectangle is drawn to enclose the two connected pads that are currently 
being evaluated for routing. The chosen route path must lie completely within the 
rectangle, or the connection will be left unrouted. 
The rectangle can be made bigger by a specific amount as defined by this parameter. 
The longer side of this imaginary rectangle is defined as the "major axis". 
If an overshoot of 0.2" is entered the rectangle is increased by 0.1" at each end of the 
major axis. 
Typically no overshoot is permitted on the initial routing pass. The overshoot generally 
increases with each pass. The routing time will increase as this rectangle is made larger.  

Minor axis overshoot - This parameter operates in the same way as the Major axis overshoot as explained 
above, except it is the shorter side of the imaginary rectangle that is enlarged. 

Track neck and bend Selections are None or Neck. 
If Neck is selected, the router can neck tracks in order to find a path between obstacles, 
see Figure 36. The neck size code, and clearance requirements for necked tracks, are 
defined in the main setup window (Figure 30). 
The necked section of track extends for two routing pitches, either side of the obstacle. If 
a track is necked down, and the end of the necked segment of track coincides with a 
corner (direction change), the necked segment extends beyond the corner for one routing 
pitch. 
If None is selected, the strategy cannot use necking and the tracks have to routed at their 
specified size. 

 
Figure 36 

Pass number The values assigned to the settings in this window apply to the pass number shown here. 
Use the arrows to display the other pass settings. With this strategy, 3 sets of values can 
be applied for pass 1, 2 and 3.  

Start pass the number shown here determines which set of values is used for the first pass. 
N passes When this routing strategy is used, it attempts to route every power connection with the 

values assigned to the first pass as defined by the Start pass parameter. If some 
connections remain after the first routing pass has been completed, the router can 
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attempt the remaining connections with further passes. Enter the maximum number of 
passes permitted.  
Bear in mind that pass 3 will be repeated as many times as is necessary to reach the 
number of passes required (unless routing is complete when it will stop). Repeating pass 
3 with this strategy is not recommended - if the strategy cannot complete a connection 
the first time it uses pass 3, it won't manage it the second time because nothing will have 
changed. 

Power Rip-retry strategy and setup 
The Power Rip-retry routing strategy is designed to route the remaining power connections after the Power 
Pattern and Power Cost strategies have been used. It will however attempt to route all the power connections if 
the Power Pattern and Power Costs strategies are not enabled. 
Whilst attempting to route the remaining connections, this strategy can remove (or rip-up) existing unfixed tracks 
in order to complete remaining connections. Tracks that have been ripped-up are added to the list of remaining 
connections and will be attempted again. 
This strategy also has settings that can be "costed" by the user to force the router to use user-preferred routing 
options. 
Ripped up tracks are re-routed with the costs assigned to the current routing pass and not those they were 
originally routed with. If the track has to be replaced in its original position because a new path could not be 
found, the costs are not taken into account, i.e. it will always be allowed back to its original position, even if that 
position would not be valid with the current costs. 
This routing strategy can be repeated as many times as required. It uses the same parameters as the Power 
Cost strategy, plus the following:  
Ripsearch Max violate This parameter can be used to allow the auto-router to temporarily make violations (short 

circuits or clearance errors) on the board in order to route more successfully. 
For example, with this parameter set to 1, in order to route a remaining connection known 
as A, an existing track known as B, would be violated. The solution for connection A is 
stored, and track B is ripped out and reverts back to a connection. Connection B is added 
to the list of routes still to be completed. This list will be referred to as the "to-do" list. The 
top entry in the "to-do" list is taken and a solution is searched for that does not violate any 
other track. If no solution is possible, a solution is sought that will not violate more than 
the permitted number of rip-search violations. Any new solution is placed on the artwork, 
and violated tracks added to the "to-do" list. This process continues until one of the 
following conditions is met: 
a) The "to-do" list is empty. In this case, the original route and all ripped-up routes, were 
routed without violation.  
b) A route is taken from the "to-do" list and no solution can be found within the permitted 
"max violation depth" range. In this case the original routing is restored and the route 
attempt fails.  
c) Too many iterations have been attempted. This cut-off point is set at two times the max 
violation depth iterations. If the "to-do" list contains only one entry, the new situation is 
accepted as no worse than the original situation, otherwise the original routing is 
restored. In either case the route attempt fails.  

Maximum rip-up depth  The number inserted here determines the number of existing routed connections that 
can be removed in order to route one of the remaining connections. These "ripped-up" 
connections are added to the list of remaining connections, the "to-do" list. 

Rip-up fixed routes selections are Yes or No. Selecting Yes allows the strategy to rip-up any tracks that are 
fixed in order to find room for tracks. (Including tracks fixed manually in the artwork editor 
or automatically whilst the router was routing.) 

Pass number  The values assigned to the settings in this window apply to the pass number shown 
here. Use the arrows to display the other pass settings. With this strategy, 3 sets of 
values can be applied for pass 1, 2 and 3.  

Start pas the number shown here determines which set of values is used for the first pass. 
N passes When this routing strategy is used, it attempts to route every power connection with the 

values assigned to the first pass to be used. If some connections remain after the first 
routing pass has been completed, the router can attempt the remaining connections with 
further passes. Enter the maximum number of passes permitted.  
Pass 3 will be repeated as many times as is necessary to reach the number of passes 
required (unless routing is complete when it will stop). Repeating pass 3 may improve 
routing success - the strategy will be ripping-up and re-routing so the result of each pass 
will be different. 
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Signal Memory strategy and setup  
If all the strategies are enabled, the memory router is used after the power strategy but before the signal 
strategies. It should always be run before attempting to route the rest of the signal connections, and its results 
fixed in position.  
Memory type connections are routed efficiently, without vias and will cause the least obstruction to subsequent 
tracks. If the memory connections are left until later on, their optimum paths will probably be blocked and they 
will prove very difficult to fit in. Fixing them in position means that the rip-retry strategy will not waste time trying 
to find a better path for them. 
The Signal Memory strategy is designed to route any signal connections that fall within the "memory type 
connection" category. 

What is a "memory type connection"?  
Take any signal connection and enclose the two connected pads within a rectangle, as shown 
in Figure 37.  

 
Figure 37 

If the shorter side of the rectangle is equal to, or less than, two memory routing pitches, as 
defined in the setup window, the connection is regarded as being a memory type connection 
as far as the strategy is concerned. 

The memory routing strategy is so called because of the pattern formed by the routed tracks, as shown in Figure 
38. 

 
Figure 38 

The success of the memory router depends upon the routing pitch selected. On conventional boards, a pitch of 
0.050" will give the best results. 
When the memory router is enabled it assesses every signal connection on the board, from left to right, top to 
bottom, and any connections that fall within the "memory" category are attempted. 
The connections have to be routed using a maximum of five segments on one side of the board, vias are not 
permitted. 45 degree track segments are permitted. Tracks that are routed vertically are placed on the side 
designated for vertical tracks and horizontal tracks are placed on the side designated for horizontal tracks. 
Routing pitch Defines a grid over the board on which the centre line of tracks can be placed. To route 

memory type connections between the pins of dual-in-line components where the pin pitch is 
0.1", the routing pitch should be set to 0.050". If the pin pitch is halved, the routing pitch 
should also be halved. 
The grid radiates from the origin of the board, which is defined via the Grid command in the 
artwork editor. It is suggested that the position of the grid origin is maintained between part 
placement and routing.  

Fix routes It is suggested that memory tracks are fixed in position (box ticked) to save time on 
subsequent routing and optimising passes. 

Signal Cost strategy and setup 
This signal routing strategy is designed to route the remaining signal connections after the memory routing 
strategy has been used. It will however attempt to route all the signal connections if the memory routing strategy 
was not enabled. The shortest connections are routed first. 
This strategy evaluates all the possible paths that each track can be routed along. The path that is chosen is 
determined by its "cost". The costs are defined in the setup window and the lowest cost path is chosen.  
This routing strategy can be repeated up to 6 times automatically, with different settings assigned to each 
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routing pass. Each connection is attempted once per pass. Typically each pass is less restrictive than the 
previous pass to achieve more routed connections. In the early restrictive passes, more direct routing will be 
achieved, but not all the connections will be routed.  
This strategy uses the settings described previously for the Power Cost strategy, plus the following: 
Routing at 45 degrees In some situations the router may need to insert 45 degree tracks instead of using 

horizontal or vertical ones in order to move around obstacles. 
Every time a 45 degree track is inserted, the cost assigned by the user multiplied by the 
length of the segment, is added to the cost of the route.  
The length of a 45 degree segment is determined as follows: 
a rectangle is drawn around the 45 degree segment and the length of one side measured 
in increments of 0.005". The number obtained is multiplied by the cost assigned by the 
user, which is then added to the cost of the route.  
Longer 45 degree track segments act as bigger obstacles to subsequent routing, hence 
their increased cost. 
When working on double-sided boards, 45 degree tracks act as obstacles to both 
horizontal and vertical tracks so they should be avoided in the early stages of routing. 
However 45 degree tracks on single-sided boards tend to give higher completion rates. 
A higher cost will make it less likely that 45 degree tracks are used. 

Track neck and bend Two additional selections are available, Bend or Neck and Bend (N+B). 
If Bend is selected, the autorouter can locally change the selected routing pitch, in order 
to route two tracks between adjacent pads. This option is typically used when trying to 
find a path in or out of congested areas, i.e. when trying to route to the third row of a 96-
way connector. It still has to maintain the clearance requirements set by the user. 
Note: bending will only be used if a routing pitch of 0.025" is selected. 
If N+B (neck+bend) is selected, the autorouter can use either necking and\or bending as 
explained previously, to find ways through congested areas.  

Pass number  The values assigned to the settings in strategy window apply to the pass number shown 
here. Use the arrows to display the other pass settings. With this strategy, 6 sets of 
values can be applied.  

Start pass  the number shown here determines which set of values is used for the first pass. 
N passes  When this routing strategy is used, it attempts to route every signal connection with the 

values assigned to the first pass to be used. If some connections remain after the first 
routing pass has been completed, the router can attempt the remaining connections with 
further passes. Enter the maximum number of passes permitted.  
Bear in mind that pass 6 will be repeated as many times as is necessary to reach the 
number of passes required (unless routing is complete when it will stop). Repeating pass 
6 with this strategy is not recommended - if the router cannot complete a connection the 
first time it uses pass 6, it won't manage it the second time because nothing will have 
changed in between. 

Signal Rip-retry strategy and setup 
The Signal Rip-retry routing strategy is designed to route the remaining signal connections after the Memory 
and Signal Cost routing strategies have been used. It will however attempt to route all the signal connections if 
the Memory and Signal Cost strategies are not enabled. 
Whilst attempting to route the remaining connections, this strategy can remove (or rip-up)  existing unfixed 
tracks in order to complete remaining connections. Tracks that have been ripped-up are added to the list of 
remaining connections, the "to-do" list and will be attempted again. 
This strategy also has parameters that can be "costed" by the user to force the router to use user-preferred 
routing options. All these settings have been described above.  
Ripped up tracks are re-routed with the costs assigned to the current routing pass and not those they were 
originally routed with. If the track has to be replaced in its original position because a new path could not be 
found, the costs are not taken into account, i.e. it will always be allowed back to its original position, even if that 
position would not be valid with the current costs.  
This routing strategy can be repeated as many times as required. It has 3 sets of values and repeating pass 3 is 
worth while as during rip-up cycles, the existing tracking will change, so the results will be improved. 

Interim Optimise strategy and setup 
The Interim Optimising strategy can be used for two purposes: 

(i) to "tidy up" a partially routed layout in order to assist subsequent routing passes 
(ii) to restore vias on a completed layout to assist in the routing of modifications that have been made 

to the completed layout.  
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For example, once a layout is complete, it is usual to have reduced the number of vias used on the layout. If 
new connections are added to that layout, they will prove difficult to route because of the amount of "wrong way" 
routing, which acts as obstacles. Hence the need to restore vias. 
NB: The interim optimiser is only used if there are connections still waiting to be routed, in which case it is used 
after all the other enabled routing strategieshave been completed, but before step 6 is repeated. 
The Interim Optimiser assesses every routed track and removes "kinks" in tracks that were originally used to 
move around tracks that were subsequently ripped-up and routed elsewhere. 
The optimiser will restore vias to tracks if doing so decreases the total route cost. Once all the routed tracks 
have been assessed, the optimiser then attempts to route any remaining connections.  
The interim optimiser has one additional setting that is only used by the optimising strategies as follows: 
Optimisation order this setting controls the order in which tracks are evaluated for optimisation. Options are: 

S-L  short to long 
L-S  long to short 
S-L/L-S alternate between short to long and long to short on subsequent passes 
L-S/S-L alternate between long to short and short to long on subsequent passes 

Final Optimise strategy 
The final optimising pass is performed when all the other enabled routing strategies have been completed and 
repeated as many times as specified. All the connections will not necessarily have been routed. 
It may be wise not to enable this final optimisation pass until all the connections have been completed. 
Otherwise remaining connections could be difficult to route afterwards, as this pass is typically run to try and 
decrease the number of vias in use. 
The final optimisation pass evaluates each routed track and tries to re-route them with a lower routing cost. 
Typically vias are made expensive, so that it tries to re-route each track with fewer vias. If vias are removed, the 
amount of wrong way routing will be increased, i.e. horizontal tracks will appear on the side assigned for vertical 
tracks and vice versa. 
The number of optimising passes can be specified. Three optimisation passes should be sufficient to improve 
the design. More passes can be used but diminishing returns will be seen. 
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Configuration Folder -  CNC Tools & Data Sets 
The CNC Tools & Datasets table is used to define the routing and drilling tools that are needed to manufacture 
the board. The table is made up of two tables: 
CNC Tool Parameters 

If the CNC Tool Parameters table is not filled in within the job, then the NC Drill/Router output task will fill it 
in, by fetching all the required tool sizes from the pad sizes table and the slot definitions in the design.  
However, it is necessary to manually complete this table in order to use the pre-drilling facility in slots, 
which helps avoid breakage of the small routing tools used to produce the slots. 

Drilling & Routing Datasets  
This table is where names & descriptions can be assigned to the different sets of drilling data that will be 
required for a board with both plated and unplated holes, or such as one with blind/buried via holes.  
If a board has plated and non-plated holes, then at least two drilling output sets (files) will be required. 
Additional files are required for each blind/buried via stack. 

To view and or edit the tables, expand the Configuration folder, then select CNC Tools & Data Sets Figure 39. 

 

Figure 39 

The tabs at the top of the window provide access to both tables, Figure 40. 

 

Figure 40 

CNC Tool Parameters 
Each different drilled hole and slot has to be assigned a unique tool to produce the hole or slot. The tools are 
numbered from 1, ie T1, T2, T3, etc. 
Important Note: If a slot is pre-drilled, then two tools have to be defined, one for the slot and one for the pre-
drilled hole. 

Tool The tool number assigned to a particular tool, they are always shown in 
ascending order (the actual number is irrelevant at this stage). 

Type Whether the tool will be used by the router to produce a slot, or for drilling 
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holes - choose from the drop-down list. 
Diameter The diameter of the tool – in inches or mm (change units using the Units 

command from the top of the window). 
Pre-drill Diameter If the tool “Type” is set to Router and pre-drilling is required, specify the 

diameter of the pre-drilled hole. 
Note: it is also necessary to add a tool for the drill of  the pre-drilled hole, 
which should match the pre-drill size. 

Drill Infeed Rate & These will generally be left unassigned and controlled by the manufacturer. 
Routing worktable rate (ipm) 
Spindle RPM This will generally be left unassigned and controlled by the manufacturer. 

The table can be sorted in various orders, using the Reorder button, which helps identify sizes already defined 
in the list to avoid repetition, Figure 41. 

 

 

Figure 41 

 
Once this table has been filled in and saved, the slot diameter and drill diameter settings in the Slots dialogue 
bar (Artwork editor, Tools > Slots & Extra Holes) can be selected from a drop down list, Figure 42. 
 

 

Figure 42 

 

Drilling & Routing Datasets  
The Drilling & Routing Datasets table is where names & descriptions can be assigned to the different sets of 
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drilling data that will be required for a board, such as plated and unplated holes, and/or blind/buried via holes.  
If a board has plated and non-plated holes, then at least two drilling output files will be required. Additional files 
are required for each blind/buried via stack. 
Two pre-defined datasets exist, these are: 

DS1 for through plated drill holes/slots 
DS2 for Non-plated drill holes/slots 

Any slots or holes that should be output alone should have their own datasets. 
All the slots/drills in the same dataset will be output together. 
Figure 43 shows the table for a new design on the left and for a 6 layer design with blind and buried vias on the 
right. 
Most single/double-sided designs contain through the board holes, either plated or non-plated, so typically just 
two drill datasets are required, one for each type. 
 

  

Figure 43 

ID A unique number assigned to each dataset. 
DS1 and DS2 are pre-defined and cannot be changed. 

Plating Whether the holes/slots included in this dataset will be plated or unplated.  
Description A description to aid recognition of the dataset by the user. 
Board topology The board topology can only be displayed when there are less than 12 copper 

layers.  
Most designs generally have all unused layers defined as copper layers, so 
there are too many to display. (This can be changed from the Configuration 
folder, select Layer Assignments and Ordering, then select the Set empty 
copper layers to silkscreen button.) 
The topology of a double-sided design with a through-plated and non-plated 
through hole is shown in Figure 44.  

 

Figure 44 
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(Figure 43 shows the topology of a through plated hole in a 6 layer design.) 
If there are additional copper layers, and a dataset other than DS1 or DS2 is 
selected, the top and bottom of the drilled zone can be moved up and down in 
the board topology using the Layer Span buttons, identified in Figure 45.   
Figure 45 shows DS4 selected, which is being used for a blind via from the top 
of the board through to layer 2. 

 
Figure 45 

 
In version 2.25 this graphic is just an advisory to help the designer understand 
what the various drilling and routing sets of data are being used for, but 
eventually it will also guide the validation of the board. 
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Configuration folder - Power Names 
A list of power names is defined within each design so that the power connections can be differentiated from 
other connections/tracks. When a design is created this list is empty. 
Power connections (by default, though this can be changed by the user) are given a different track code to the 
signal connections, can be given a different minimum clearance requirement,  they have their own auto-routing 
strategy and can be converted into a power plane/split power plane. 
The power names list should include all the names of connections that should be treated as power connections 
by the artwork layout and checking routines. 
Up to 256 different power names can be entered. Upper or lower case characters, or a mixture of the two can be 
used in a power name. However, do not enter the same name more than once with different combinations of 
upper and lower case characters. i.e. do not add GND and Gnd, or GND and gnd, etc. 
If a circuit schematic has been drawn and a parts/wiring list extracted, the power names (as defined implicitly in 
used schematic parts) are automatically added to the power names list. 
Additional named connections can be added to the list as required, so that they are treated as power 
connections, even though they might not technically be considered as power connections. 
Power names can also be removed from the list if they should not be treated as power connections. (If the 
tracks have already been routed, de-classifying them will not affect their track sizes.) 
If a parts and wiring list has been or will be typed in or imported, the power names have to be entered manually 
into the list. (Some of the importers can add names to the power names list, but always check the list to ensure 
the correct names are present.)  

Viewing/Editing the Power Names List 
With the Design folder open, double-select the Configuration folder, then either double-select Power Names with 
the left mouse button, or right-click it, and then select edit. The power names list appears with any power names 
already defined, present, similar to the one shown in Figure 46. 

 

Figure 46 

Each power name is given a numerical reference number (from 1 to 256) that is used internally. 
Power rail names should be added one after the other, starting from the top of the list.  
The columns can be sorted in ascending/descending order by clicking on the column headers.  
To add a power name, select the next empty slot (alongside 3 in the example shown above), then type in the 
new power name. Select another slot or press <tab> to continue. Repeat for each different power name. 
To edit a power name, select the power rail name edit or replace the name as required. Select another slot or 
press <tab> to continue.  
Select OK to close the window. 
When the net list is open (from the design’s net list folder), power names appear highlighted. 
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Configuration – Layer Assignments & Ordering 
Each artwork design in Seetrax XL Designer has 63 layers in total available for copper (vias/pads/tracks), power 
planes, split-power planes, silk-screen and documentation layers - typically only a small number of them are 
actually used.  
The board profile, keepout information and router information are stored in their own categories and not stored 
as "layers", so do not appear in the layer assignments window. 
When a design is created, it has three pre-defined layers that cannot be changed, the two outer copper layers 
known as the Top & Bottom layers, and a layer reserved for holes, usually vias, known as the Via layer - even 
though these layers are always defined, they do not have to be used.   
The top and bottom layers must always be used as the outer layers of the board because the pads of surface 
mounted components will only appear on those layers.  
The remaining layers are defined as inner copper layers but they can be changed as required to become silk-
screen layers, power/split power planes or documentation layers. 
When a component is placed on the artwork, its pads will appear on the top, inner copper and bottom layers (as 
defined in the component outline).  
With these default settings, a single, double-sided or multi-layer artwork can be designed with no further 
adjustments to the layer assignments.  
Layers defined as silk-screen or documentation layers are ignored by the connectivity checking routines. 
When a design is started, it may not be known how many layers, or what type of layers will be required so the 
layer assignments can be changed at any time.  
It is recommended that all designs maintain the same layer definitions to aid compatibility between designs and 
multiple users. (For example, layers 1 & 2 for the top silkscreen labels and outlines, 3 & 4 for the bottom 
silkscreen labels and outlines, 5 - nn for internal power planes, and so on. Which layers are chosen is irrelevant 
- just try to maintain the same layer types between jobs. 
It is recommended that each layer is assigned a name or “title” to aid its recognition throughtout the design. 
When the layer assignments are changed, if data already exists on the changed layer, it will not be lost but it 
may be inappropriate. For example if a silk-screen layer with outlines and labels present were re-assigned as a 
copper layer, the silk-screen data would be regarded as copper and would probably cause short-circuits, 
therefore additional changes would be required. 
The assembly order of the inner layers in a multi-layer design that does not include blind or buried vias, is 
irrelevant as far as the design’s connectivity is concerned. (There may be practical reasons for specifying that 
particular layers such as ground planes are inserted in a particular position in the layer stack, but their position 
will not affect connectivity.)  
However, if blind/buried vias are used in a design, the order of the layers in the layer stack becomes critical for 
connectivity. It is therefore essential that the layers in the board layer stack are given a position in the board 
layer stack and this order is adhered to throughout the design and manufacturing process.  

To view and/or change the layer assignments and ordering for a design: 
With the Design folder open, double-select the Configuration folder, then either double-select Layer 
Assignments & Ordering with the left mouse button, or right-click it, and then select edit. The layer 
assignments/ordering window appears, as shown in Figure 47. 
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Figure 47 

This window lists the layers of the board with their user-defined titles (names), layer types, i.e. copper, silk-
screen, etc. and whether the layers are empty.   

Layer 
This lists the layers, starting with the the layer reserved for Vias, followed by the two outer board layers (T for 
Top and B for Bottom) then layers numbered from 1-63 which can be used for silkscreen, documentation, 
copper or power planes. These cannot be changed. 

Title 
To aid recognition and speed design work up, it is highly recommended that the layers are given names or 
“titles”, so that it isn’t necessary to keep cross-referncing which layer is used for what. 
Examples: Vias & Added Holes, Top Copper, Bottom Copper, Topsilk Labels, Topsilk Outlines, Btmsilk Labels, 
Btmsilk Outlines, GND Plane, Split (0V, -5v, Vbb), Innercopper 1, Innercopper2, etc.  
The titles will be displayed in dialogue boxes where appropriate, example shown arrowed in Figure 48, and 
tooltip balloons will also provide the information, shown in Figure 49. 

  

Figure 48 

 

 

Figure 49 

 

Type 
V - Via holes This layer is reserved for pads with holes - typically "vias", including blind and buried vias. 

Vias are pads that are drilled & plated and used purely to link tracks from one layer to 
another to maintain connectivity between copper layers. 
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Vias (including blind and buried vias) do not appear on any other layers.  So when 
producing output plots, the Via layer should be included with any other layers if the pads 
with holes/vias should be included.  
A pad added to the V layer in the artwork editor (using Amend > Enter Pads) will be 
drilled. 
Everything added to the via hole layer is checked by the artwork checking routines.  

T - Top copper This layer is reserved for use as the top, outer copper layer of the board. It is often 
referred to as the "top, component side". 
Component pads added to the top layer in the outline's pad stack will appear on this layer 
(unless the outline has been flipped, in which case they will appear on the Bottom layer). 
Everything added to the Top copper layer is checked by the artwork checking routines.  

B - Bottom copper This layer is reserved for use as the bottom, outer copper layer of the board. It is 
often referred to as the "bottom, solder side". 
Component pads added to the bottom layer in the outline's pad stack will appear on this 
layer (unless the outline has been flipped, in which case they will appear on the Top 
layer). 
Everything added to the Bottom copper layer is checked by the artwork checking 
routines.  

Layers1 to 61  These layers will be assigned as one of the following types: 
Copper:  these are the inner copper layers, used in a multi-layer design. They 

always contain the "inner pads", as defined by the component outline 
pad stacks. 
Typically tracks are added to inner copper layers to form the 
connectivity required between component pins when there is 
insufficient room on the outer layers.  
Copper layers can also contain text and extra pads. 
Everything (pads, tracks, text) added to a copper layer is regarded as 
being a conductor of electricity and checked by the artwork 
connectivity checking routines.  

Silk screen:  these layers are empty until data is specifically added to them.  
Anything added to silk-screen layers is assumed to be non-
conducting by the artwork connectivity checking routines.  
These layers typically contain everything for the silk-screen ident of 
the board.  
If parts are mounted on both sides of the board, separate silk-screen 
layers are required for the top and bottom silk-screen ident.  
Tracks and pads can be added to silk-screen layers but they will be 
considered as non-conducting by the artwork connectivity checking 
routines and ignored. 

Documentation:  these layers are empty until data is specifically added to them.  
Anything added to documentation layers is assumed to non-
conducting by the artwork connectivity checking routines.  
These layers are typically used for creating manufacturing drawings 
or for data that has no electrical significance.  
The output tasks can be used to send data to a documentation layer, 
for example the standard drill drawing. This allows extra data, for 
example manufacturing notes, to be added. 
Tracks and pads can be added to the documenation layers but they 
will be considered as non-conducting by the artwork connectivity 
checking routines and ignored. 

Named power:  Note: A layer can only be defined as a named power layer after the 
power rail has been added to the power names list in the design’s 
configuration folder.   
When a layer is assigned as a named-power layer, the layer 
becomes a solid sheet of copper (a plane) that will cause short-
circuits to all the holes that pass through the layer.  The power plane 
tools in the artwork editor are used to isolate the appropriate holes 
from the plane and when complete, the layer will contain heat-relief 
and anti-pads around the appropriate holes to ensure the 
connectivity of the named power net. 
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If the artwork checking routine is run before the power plane tools 
have been used, then every drilled hole through the plane will be 
reported as causing a short circuit to the plane. 
Any of the named power rails can be selected in order to define the 
layer as an individual power plane for that power rail.  
A power rail can be defined on multiple power plane/split plane 
layers if required. 
Auto-generated power plane layers are included by the artwork 
connectivity checking routine, with some exceptions, so refer to the 
artwork Check > Connectivity command for full details. 

Split power: When a layer is assigned as a split-power layer, the layer becomes a 
solid sheet of copper (a plane) that will cause short-circuits to all the 
holes that pass through the layer. One power rail is chosen as the 
primary power rail and this covers the entire layer. Other power rails 
are chosen as secondary signals and these (using the power plane 
tools in the artwork editor) will be embedded into the primary plane 
as islands of copper surrounded by an isolation gap to ensure correct 
connectivity. 
When complete, the layer will contain isolation lines and heat-relief 
and anti-pads around the appropriate holes to ensure the 
connectivity of the named power nets. 
The artwork checking routine cannot be run until the split-plane has 
been generated (using the power plane tools in the artwork editor). 
Auto-generated split power plane layers are included by the artwork 
connectivity checking routine, with some exceptions, so refer to the 
artwork Check > Connectivity command for full details. 

 

Figure 50 

Once the layer has been selected as a Split power plane (Figure 50), 
choose the power rail that will become the Primary Signal by 
selecting the arrow alongside the Primary Signal setting and 
selecting the power name from the list that appears. 
Note: the power names only appear after they have been added to 
the power names list in the design’s Configuration folder.   
Once the primary power rail has been selected for the layer, select 
the power signals that will be embedded in the primary plane, by 
ticking the check boxes alongside their names in the Secondary 
Signals list. 

Select OK to continue. 

Empty Layers 
An empty layer is one that has not had pads/copper/silk-screen added to it – component pads are not included, 
though they will be present on the top/inner/bottom copper layers as defined in the outline library shape.  
So for example once parts have been placed, the copper layers will be “empty” but they will have component 
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pads on them. 

Changing the layer titles/types 
Layers V, T and B are pre-defined layers and cannot be re-assigned, but they can be given titles.  
The remaining layers, 1 to 61 can be defined as inner copper, silk-screen, power/split-power plane or 
documentation layers. 
To change the type of layer for layers 1 to 61, or assign a Title to any of the layers, double-select the layer and a 
window similar to the one shown in Figure 51 appears.  The lower part of the window lists the power rails that 
have been assigned in the design and becomes active if the layer type is altered to a Split Power Plane. 
Type in the text to be assigned to the layer Title, then select the down-arrow alongside the current Type, then 
choose the new layer type required from the list that appears.  
Select OK. The layer type is changed. Repeat as required. 
Note: to re-assign all empty layers as silk-screen layers in one step, see the heading: Set empty copper layers 
to silk-screen below. 

 

Figure 51 

 

Layer Assembly Order 
This button is greyed out until at least one inner copper layer (1 to 61) is defined.  
For designs that do not use blind/buried vias, the layer assembly order is not important for connectivity purposes 
- provided the outer layers are on the outside of the board and inner layers are on the inside of the board when 
assembled, the connectivity will be correct provided the artwork checks reported no errors. It is not necessary to 
define the assembly order for this type of board.  
If the design uses blind/buried vias, then the order that the board layers are assembled in, becomes very 
important. If the board is assembled in a different order to that which it was designed and checked against, then 
it will be incorrect - tracks will become open-circuit or shorted. 
The artwork checking routines perform the connectivity checking on the artwork using the assembly order 
specified here. It is important that the layer assembly order is defined prior to routing and maintained through to 
board assembly. 
Note: once the artwork has been started, changing the order of the layers will affect connectivity if blind or 
buried vias are used, so it is not recommended. 

Defining the Layer Assembly Order 
From the Layer Assignments window, select Define Layer Assembly Order, a window similar to the one shown 
in Figure 52 appears. 
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Figure 52 

Only the copper and power plane layers defined in the design appear in this list, so more or less layers may 
appear. 
The order of the inner layers can be changed by selecting a layer, then moving it up or down, using the Move 
Up or Move Down buttons. The outer layers T and B remain fixed as the outer layers. 
It seems logical to define the layers in numerical order, but this is entirely at the designer’s discretion.  
Once the order has been defined, select OK to continue.  

Set empty copper layers to silk-screen 
This utility provides a quick method of assigning all unused copper layers to silk-screen layers. When using 
blind/buried vias and to avoid confusion, it is advisable to set all the unused layers to silk-screen layers so that 
they are not included in the artwork connectivity check.  
From the Layer Assignments window, select Set empty copper layers to silk-screen, all the inner copper layers 
that are empty will be set as silk-screen layers. 

Notes for users of all previous versions of Ranger 
• If the Ranger system you were using referred to layers 0 onwards, then the following will apply: 

Layer 0 is now referred to as V (Vias/added Holes) 
Layer 1 is now referred to as T (Top copper) 
Layer 2 is now referred to as B (Bottom copper) 
Layers 3 to 63 are now layers 1 to 61 (user-defined layers) 
This may initially cause confusion but the decision has been made deliberately in order to support 
blind/buried vias in a logical way. 
Old layers 3 to 63 will remain set to the same type, but their numbers will decrease by 2, for instance 
old layer 3 will become layer 1, old layer 12 will become layer 10, etc. 

• Users who defined their own component outline library with layer 1 as the bottom of the board and 
layer 2 as the top of the board will have to remember that their top and bottom layers will be reversed if 
they continue to use their own outline library.  

Additional notes for Ranger1/Ranger2 users 
The following differences should be taken into account when older designs are opened in Seetrax XL Designer: 

• Pad stacks:  
Surface mounted component pads were added to the outer layers of the board (layer 1 or layer 2), 
these are still added to the outer layers of the board, which are now called T and B.  
Drilled component pads were added to layer 0.  
However, drilled component pads in Seetrax XL Designer are made up from a "stack of pads". This 
allows different sizes/shapes of pads to be used on the top, inner copper and bottom layers of the 
board. 
Outlines that have been converted from Ranger1/2 with pads on layer 0, will have "padstacks" in 
Seetrax XL Designer instead of a pad on layer 0 (or new layer V). Each pad in the stack uses the same 
size/shape of pad as was previously used on layer 0. For instance if a code 6 square pad was placed 
on layer 0 in Ranger1/2, this will be replaced by a code 6 square pad on the top, inner and bottom 
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layers of the stack in Seetrax XL Designer. 
In Seetrax XL Designer, only vias and added pads appear on layer V (old layer 0) - there are no drilled 
component pads on this layer. Instead, the component pads appear on each individual copper layer. 
This means they are not always displayed in white - they will be displayed using the colours for the 
visible layers. So for instance with only layer T visible (red) the component pads will be red. With T and 
B visible (red and blue), if the top and bottom pads are the same size and shape they will be displayed 
in pink/purple (red and blue make pink/purple).  
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Configuration folder – Via Hole Definitions 
User-definable vias can be defined to allow the use of blind and/or buried vias and to allow different via sizes for 
power tracks.  
Code 0 round/square pads will continue to be used for vias unless user-defined vias are defined and used. 
User-defined via examples are given later in this description. 
The following information is supplied as a general guide but no liability is accepted for incorrect information - 
please talk to your board manufacturers for current advice and information.  

Points to Bear In Mind If Considering Using Blind/Buried Vias 
Cost of manufacture:  
For users that have never designed with blind/buried via types before, it is worthwhile investigating the cost of 
manufacturing these types of boards - they are more expensive than conventional multi-layer boards, although 
prices may start to come down as the technology improves. Blind vias seem to be in fairly common use, but 
buried vias are quite rarely used. Find out before incorporating either of them in your design. 

Manufacturing techniques: 
Find out how the actual boards will be assembled, as this will affect how the board is designed. It would be quite 
easy to design a board that can't be made with the current technology. 

What Seetrax XL Designer can do:  
Blind vias, buried vias and through-board power via stacks can be defined within Seetrax XL Designer. The 
design can be auto-routed using the Specctra or Electra auto-routers which will use these vias. The Seetrax 
auto-router will not use user-defined vias.  
The artwork checks take into account and fully check the user-defined via stack definitions.  
The resultant artwork can be output with the usual output tools. The drilling output routines (drill sheet drawing 
and NC Drill) have been designed to incorporate the separate output files required for the different drill datasets 
of the design. 
The manual routing facilities within the artwork editor allow user-defined vias to be moved (Mroute > Corner) or 
replaced with standard vias (Mroute > Layer Swap). User-defined via stacks can be entered, moved, replaced 
and deleted using the Amend commands.  

Board Manufacture for Boards with Blind/Buried Vias 
Before describing what goes on within the software, let's have a look at how the board layers can be assembled 
- there are other methods in common use and they may affect how the blind/buried vias and drill sets are 
defined within Seetrax XL Designer - discuss this with your board manufacturer.  

Four layer board 
In Figure 53 below, the cross-section view of a 4 layer board is shown.  

 
Figure 53 

The copper layers are called Top, Inner1, Inner2 and Bottom, with fibreglass/isolation between them, as shown.  
Inner layers 1 and 2 are made as a double-sided board, then the outer layers added and the final assembly 
etched as a double-sided board. In this board there are 4 via types: 

A is a conventional (standard code 0 pad) via that is drilled through all layers. 
B is a blind via. It is drilled after the board layers have been assembled, from the top of the board to 

a set depth so that the top copper and inner copper layer 1 are joined. 
C is also a blind via. It is drilled after the board layers have been assembled, from the bottom of the 

board to a set depth so that the bottom copper and inner copper layer 2 are joined. 
D is a buried via. It can only be drilled before all the board layers are assembled. 

Inner copper layers 1 and 2 have to be made as a double-sided board and the buried vias drilled/plated at that 
stage. All the layers are then assembled and the blind and conventional holes drilled. (It is this double-process 
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(effectively making two, double-sided boards) that makes boards with buried vias expensive to make. They also 
have higher failure rates.) 
From this information, it should become apparent that four sets of drill data outputs will be required.  

i) one for conventional via holes (this file would also include all conventional component holes as 
well) where the drill, drills straight through the board 

ii) one for buried holes between the two inner layers 
iii) one for blind holes drilled from the top of the board 
iv) one for blind holes drilled from the bottom of the board 

Six layer board 
In Figure 54 below, we see the cross-section view of a 6 layer board.  

 
Figure 54 

The copper layers are called Top, Inner1, Inner2, Inner3, Inner4 and Bottom, with fibreglass/isolation between 
them, as shown.  
Inner layers 1 and 2 are made as a double-sided board, as are inner layers 3 and 4. These two "boards" are 
sandwiched together then the outer layers added and the final assembly etched as a double-sided board.  In 
this board there are 6 via types: 

A is a conventional (standard code 0 pad) via that is drilled through all layers. 
B is a blind via. It is drilled after the board layers have been assembled, from the top of the board to 

a set depth so that the top copper and inner copper layer 1 are joined. 
C is a blind via. It is drilled after the board layers have been assembled, from the top of the board to 

a set depth so that the top copper and inner copper layers1 and 2 are joined. 
D is a blind via. It is drilled after the board layers have been assembled, from the bottom of the 

board to a set depth so that the bottom copper and inner copper layers 4 and 3 are joined. 
E is a blind via. It is drilled after the board layers have been assembled, from the bottom of the 

board to a set depth so that the bottom copper and inner copper layer 4 are joined. 
F & G are buried vias (between different layers). They can only be drilled before all the board layers are 

assembled.  
Inner copper layers 1 and 2 have to be made as a double-sided board and the buried via "F" drilled at that 
stage. Inner copper layers 3 and 4 are also made as a double-sided board and the buried via "G" drilled at that 
stage. These two "boards" and the remaining (outer) layers are then assembled and the blind and conventional 
holes drilled. (In this case, three double-sided boards are effectively made.) 
Seven sets of drill data outputs will be required for this board.  

i) one for conventional via holes (this file would also include all other conventional component holes 
as well). 

ii) one for buried holes between inner layers 1 and 2. 
iii) one for buried holes between inner layers 3 and 4. 
iv) one for blind holes drilled from the top of the board, to reach inner copper layer 1. 
v) one for blind holes drilled from the top of the board, to reach inner copper layer 2. 
vi) one for blind holes drilled from the bottom of the board, to reach inner copper layer 4. 
vii) one for blind holes drilled from the bottom of the board, to reach inner copper layer 3. 

It would be possible to define a buried via between inner layers 1, 2, 3 and 4 but this could add extra expense - 
talk to your board manufacturer. 

Eight layer boards, onwards 
Use the information for a 6 layer board, simply adding extra layer pairs as required and adjusting the names 
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accordingly. 
Note: there is a limit to the depth that blind via holes can be drilled, the hole diameters also tend to have to 
increase with increasing depth, so this should be discussed with the manufacturer before defining deep, blind 
vias. 

Drill set names 
The drill datasets are numbered from 1 to 18 which are listed as DS01 through to DS18.  
The first two datasets are reserved for through the board holes which are plated (DS01) and non-plated (DS02). 
To avoid confusion, it makes sense for the othere drill datasets to be given names in order to differentiate them 
from one another.   
Logical names should be assigned to assist recognition - upto 20 characters are permitted within Seetrax XL 
Designer for these names.  

Drill set names example: - Four layer board 
Blind T/1  for blind holes drilled from the top of the board to inner layer 1 (B in Figure 

53). 
Blind B/2  for blind holes drilled from the bottom of the board to the first inner layer 

(from this direction), inner layer 2 (C in Figure 53). 
Buried 1/2 for buried holes between inner layers 1 and 2 (D in Figure 53). 
Conventional via holes (through the board) are usually output in drill dataset one (DS01). 

Drill set names example: - Six layer board 
Blind T/1 for blind holes drilled from the top of the board to the first inner layer, inner 

layer 1 (B in Figure 54). 
Blind T/1/2  for blind holes drilled from the top of the board to the first and second inner 

layers, inner 1 and 2 (C in Figure 54). 
Blind B/4 for blind holes drilled from the bottom of the board to the first (from this 

direction) inner layer, inner 4 (E in Figure 54). 
Blind B/4/3 for blind holes drilled from the bottom of the board to the first and second 

inner layers (from this direction), inner layers 4 and 3 (D in Figure 54). 
Buried 1/2 for buried holes between inner layers 1 and 2 (F in Figure 54). 
Buried 3/4  for buried holes between inner layers 3 and 4 (G in Figure 54). 
Conventional via holes (through the board) are usually output in drill dataset one (DS01). 

Notice that the drill set names have changed for the holes drilled from the bottom of the board, when compared 
against the 4 layer board, because of the extra layers. 

Drill/pad sizes for blind/buried via 
The following sizes were supplied as minimum guidelines from one manufacturer, individual manufacturers 
may have different sizes that can be achieved - if slightly bigger holes/pads can be used then the costs may 
come down. 
Blind vias can be "drilled" up to 14 layers deep. The deeper the blind via, the larger the drilled hole has to be, 
this will obviously affect the pad size as well. As a rule of thumb, the hole size increases by approximately 50% 
for each extra layer (because of problems plating deep, narrow holes). 

Minimum drill/pad sizes from one manufacturer 
Blind via from an outer layer to 1 inner layer, 0.004" hole and 0.012" pad. 
Blind via from an outer layer to 2 inner layers, 0.006" hole and 0.012" pad. 
Blind via from an outer layer to 3 inner layers, 0.008" hole and 0.015" pad. 
Buried vias, 0.012" hole and 0.020" pad. 
Ranger's default blind vias have a 0.010" hole and 0.020" pad defined. 
Ranger's default buried vias have a 0.015" hole and 0.025" pad defined. 

Board layers - Assembly 
When the layers of the above boards are assembled, they MUST be assembled in the same order as they were 
designed, so it is essential that a system of naming/numbering the layers is maintained to avoid confusion and 
boards that don't work. 

Defining layer order within Seetrax XL Designer 
Layers Top and Bottom should always be the outer copper layers of the board, as surface mounted component 
pads appear on them. 
All the numbered copper layers within Seetrax XL Designer will be internal layers and the numbers start at 1. It 
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is therefore logical to use sequential layer numbers so the board will be assembled as T, 1, 2, 3, 4, 5 (etc.) B. 
On designs made with previous versions of Ranger, layers 3 to 63 will become layers 1 to 61 - they will maintain 
the same usage, ie silk-screen, power-plane, etc.  Users who defined their own outline library with layer 1 as the 
bottom of the board and layer 2 as the top of the board will have to remember that their top and bottom layers 
will be reversed. 
When designing a board without blind or buried vias, the order in which the layers are assembled is not crucial, 
provided the T(op) and B(ottom) layers are used as the outer layers and inner copper layers/power plane layers 
are in between them in any order - the electrical connectivity will be maintained/correct. 
However, when designing an artwork that includes blind or buried vias, the software has to know the order the 
board layers will be assembled in, in order to maintain connectivity when routing the tracks and then to check 
the artwork correctly.  
If they are assembled in a different order to the order in which they were designed and checked, then 
connectivity will be lost, the artwork checking routine results will be invalidated and the board will not be correct. 

Setting the layer order 
With the design open, double-select the Configuration folder, then either double-select Layer Assignments & 
ordering with the left mouse button, or right-click it, and then select edit.  The Define Layer Assembly Order 
button is used to define the order in which the layers will be designed and checked - it is inoperative until there 
are some inner copper/plane layers defined. This window is described under the heading: Configuration – Layer 
Assignments & Ordering 

Boards with power planes 
Depending on where the plane layer is positioned in the board assembly "sandwich", heat-relief or anti-pads (as 
appropriate) will be added to the hole on the plane layer, if the hole reaches the plane layer. (There is an option 
of not using heat-relief pads on the blind/buried hole definitions if preferred - the holes are usually quite small so 
shouldn't cause a problem with heat dissipation.) 

Defining Blind/Buried Via stacks - Examples 
Open the design where the blind/buried vias will be used. 
With the design open, double-select the Configuration folder, then either double-select Via Hole definitions with 
the left mouse button, or right-click it, and then select edit.  A window similar to the one in Figure 55 appears. 

 
Figure 55 

There are four steps to define a blind or buried via in this window, as follows: 
Step 1: Define the "Via Hole Styles" 
Step 2: Define the "Pad Stack" 
Step 3: Define the "Routing Control information for the Specctra/Elecctra auto-router 
Step 4: Define the "Drilling Rules" 

Examples follow, describing how to define a variety of blind and buried vias. Example 1 provides a full 
explanation; the other examples follow on from this information so less descriptive information is given.  
Note: All the examples assume that inner copper layers/power plane layers have been defined, the Via Hole 
Definitions window is open and the inner layer order is in numerical order starting from 1. 
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Example 1: Defining a blind via to be used from the top copper layer to the first inner layer, inner layer 1. 

 
Figure 56 

Figure 56 shows a cross-section of the via to be defined. This via could be used on 4, 6, 8, 10, etc. 
layer boards. 

Step 1: Via Hole Styles  
Select the New button from the "Available Via Hole Styles" area of the window, then enter a name for 
the blind via - as a suggestion for this example, use Blindvia T/1 (blind via from the top layer to layer 1) 
then select OK. 
(The via can be renamed if required - select the name then re-type it from within the box above the Pad 
stack information. Press the <tab> key to implement the change.) 

Step 2: Pad Stack  
Select the Blindvia T/1 from the "Via Hole Styles" list. This name now appears above the "Pad stack" 
information and the pad stack can be defined. 
Select the New button from the "Pad Stack" area of the window, the window shown in Figure 57 
appears.  

 
Figure 57 

The Insertion layer should be set to one of the layers the pad will appear on, T for the top copper layer 
in this example.  
Choose a Style (round or square) for the pad and change the size of the pad as required.  
Select Add Pad. The window closes and the details appear in the pad stack definition. (If a mistake 
was made and the details need to be changed, select them then press the Edit button and make the 
changes.) 
With Blindvia T/1 from the "Via Hole Styles" list still selected, select the New button from the "Pad 
Stack" area of the window again. 
This time, set the Insertion layer to 1 (the first inner layer), set the style/size as required, then select 
Add Pad.  
If layer 1 was defined as a power plane layer, then the Style and Size settings are greyed out - a heat-
relief or anti-pad will be used as appropriate. The "Use Heat-relief when connecting to power plane" 
check box becomes selectable. If ticked, a heat-relief pad will be placed over the hole on the power 
plane layer if the hole should be connected to it. If un-ticked, a heat-relief pad is not used. 
This completes the Pad stack for this blind via style Blindvia T/1, the pad stack information will look 
something like that shown in Figure 58. 
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Figure 58 

Step 3: Routing control 
For a blind (or buried) via, the Function should be set to Via Hole as shown in Figure 59. 

 
Figure 59 

The tick boxes should be set as required: 
Allow in power nets indicates whether the Specctra/Elecctra auto-routers are allowed to use the 

blind/buried via stack in power tracks. If the Enable for auto-routing setting 
is not selected, then this setting is ignored as the stack will not be used. 

Enable for auto-routing indicates whether the Specctra/Elecctra auto-routers are allowed to use this 
blind/buried via stack when auto-routing. If this is disabled, then the Allow in 
power nets and Allow in SMD settings are ignored. 

Use heat-relief when connected to power plane (inoperative unless a power plane is selected as 
the insertion layer) indicates whether a heat-relief pad should be used when 
the via is used to make a connection to the power plane. If unticked, a heat-
relief pad is not added around the hole. 

These design rules may vary with each design. 
Step 4: Drilling rules 

For blind or buried vias the Drilling Rules should be set to "Include in drill data set", as shown in Figure 
60. When selected, the other settings become editable. 

 
Figure 60 

Drill sets are defined so that individual drill output files can be produced for each different set of 
blind/buried holes as described above. For instance, drill information for blind vias between the top and 
first inner layers should not be included with the drill information for blind vias between the top, first and 
second inner layers. 
The drill set names are numbered from DS01 to DS18 (DS01 and 02 are reserved for through board 
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holes).  
It's suggested the names are changed to something easily recognisable, for instance Blind Top or Blind 
Top/1 for blind vias drilled from the top of the board to the first inner layer. Use the Change Set Name 
button to implement this. The number/name is not important but which drill set each blind/buried via 
hole is added to, is important - the boards will be drilled incorrectly if a mistake is made. 
Set the drill hole diameter as required for this pad stack - talk to your manufacturer regarding the 
diameter of blind vias that they can achieve. 
This completes the definition of this blind via stack. If there are more blind/buried vias to be defined, 
leave the Via Hole Definitions window open, if not, select OK to continue. 

Example 2: Defining a blind via to be used from the top copper layer to the first and second inner layers, 
inner layers 1 and 2. 

 
Figure 61 

Figure 61 shows a cross-section of the via to be defined. This via could be used on 6, 8, 10, etc. layer 
boards. 

Step 1: Via Hole Styles  
Select the New button from the "Available Via Hole Styles" area of the window, then enter a name for 
the blind via - as a suggestion for this example, use Blindvia T/1/2 (blind via from the top layer to layer 
1 and layer 2) then select OK. 

Step 2: Pad Stack  
Select the Blindvia T/1/2 from the " Available Via Hole Styles" list. This name now appears above the 
"Pad stack" information and the pad stack can be defined. 
Select the New button from the "Pad Stack" area of the window, the Add New Pad to Via Hole 
Padstack window appears.  
The Insertion layer should be set to one of the layers the pad will appear on, T for the top layer in this 
example.  
Choose a Style (round or square) for the pad and change the size of the pad as required. 
Select Add Pad. The window closes and the details appear in the pad stack definition. 
With Blindvia T/1/2 from the " Available Via Hole Styles" list still selected, select the New button from 
the "Pad Stack" area of the window again. 
This time, set the Insertion layer to 1 (the first inner layer, which could be a power plane layer), set the 
window as required, then select Add Pad.  
With Blindvia T/1/2 from the "Via Hole Styles" list still selected, select the New button from the "Pad 
Stack" area of the window again. 
This time, set the Insertion layer to 2 (the second inner layer, which could be a power plane layer), set 
the window as required, then select Add Pad. 
This completes the Pad stack for this blind via and the pad stack information will look something like 
Figure 62. 

 
Figure 62 

Step 3: Routing control 
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For a blind (or buried) via, the Function should be set to Via Hole as shown in Figure 63. 

 
Figure 63 

Set the tick boxes as described in example 1. 
Step 4: Drilling rules 

For blind or buried vias the Drilling Rules should be set to "Include in drill data set". When selected, the 
other settings become editable. 
It's suggested that this Drill data set name be changed to something easily recognisable, for instance 
Blind T/1/2 (blind via drilled from the top, through layer 1 and 2). Use the Change Set Name button to 
implement this. 
Set the drill hole diameter as required for this pad stack. 

 

 
Figure 64 

This completes the definition of this blind via stack. 

Example 3: Defining a blind via to be used from the bottom copper layer to the next two inner layers 
from the bottom of the board (inner layers 3 and 4 in a 6 layer board) 

 
Figure 65 

Figure 65 shows a cross-section of the via to be defined.  
When defining blind vias that are drilled from the bottom of the board, take care to use the correct inner 
layer numbers when defining the padstack - these will depend on the number of layers in the board.  
For example, on a 6 layer board as shown here, the pads are added to the bottom layer, layer 4 and 
layer 3, but on an 8 layer board they would be added to the bottom layer, layer 6 and layer 5. 

Step 1: Via Hole Styles  
Select the New button from the "Via Hole Styles" area of the window, then enter a name for the blind 
via - as a suggestion for this 6 layer design example, use Blindvia B/4/3 (blind via from the bottom layer 
to layer 4 and layer 3) then select OK. (On an 8 layer design the name could be Blindvia B/6/5 (blind 
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via from the bottom layer to layer 6 and layer 5) 
Step 2: Pad Stack  

Select the Blindvia B/4/3 from the "Via Hole Styles" list. This name now appears above the "Pad stack" 
information and the pad stack can be defined. 
Select the New button from the "Pad Stack" area of the window, the Add New Pad to Via Hole 
Padstack appears.  
The Insertion layer should be set to one of the layers the pad will appear on, B for the bottom layer in 
this example.  
Choose a Style (round or square) for the pad and change the size of the pad as required. 
Select Add Pad. The window closes and the details appear in the pad stack definition. 
With Blindvia B/4/3 from the "Via Hole Styles" list still selected, select the New button from the "Pad 
Stack" area of the window again. 
This time, set the Insertion layer to 4 (the first inner layer from the bottom of the 6 layer board, which 
could be a power plane layer), set the window as required, then select Add Pad. 
With Blindvia B/4/3 from the "Via Hole Styles" list still selected, select the New button from the "Pad 
Stack" area of the window again. 
This time, set the Insertion layer to 3 (the second inner layer from the bottom of the 6 layer board, 
which could be a power plane layer), set the window as required, then select Add Pad. 
This completes the Pad stack for this blind via and the pad stack information will look something like 
Figure 66. In this example the inner pads are smaller than the one used on the outer layer. 

 
Figure 66 

Step 3: Routing control 
For a blind (or buried) via, the Function should be set to Via Hole as shown in Figure 67. 

 
Figure 67 

Set the tick boxes as described in example 1. 
Step 4: Drilling rules 

For blind or buried vias the Drilling Rules should be set to "Include in drill set data". When selected, the 
other settings become editable. 
It's suggested that the Drill data set names be changed to something easily recognisable, for instance 
Blind Bottom/4/3 or Blind B/4/3 (blind via drilled from the bottom, through layer 4 and 3). Use the 
Change Set Name button to implement this. 
Set the drill hole diameter as required for this pad stack. 
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Figure 68 

 
This completes the definition of this blind via stack. 

Example 4: Defining a blind via to be drilled from the bottom copper layer to the next inner layer in from 
the bottom of the board, inner layer 4 in a 6 layer board 

The same procedure as in example 3 should be followed with the following differences: 
The Via hole style name could be Blindvia B/4. 
The padstack should only include pads on the bottom layer and inner layer 4. 
The Routing control should be set as required. 
The Drill rules should be set for a new drill data set, which could be called for instance Blind Bottom or 
Blind B/4. 

Example 5: Defining buried vias 
Buried vias are defined in a similar way to blind vias. Buried vias should be defined between pairs of 
internal layers. In theory a buried via could be defined between more than two layers however this 
would increase the board manufacturing costs so it is not recommended. 
In Figure 69, three buried vias are shown, between inner layers 1 and 2, inner layers 3 and 4 and inner 
layers 5 and 6. First a via between inner layers 1 and 2 will be defined. 
 

 
Figure 69 

Step 1: Via Hole Styles 
Select the New button from the "Via Hole Styles" area of the window, then enter a name for the buried 
via - as a suggestion for the via between layers 1 and 2, use Buriedvia 1/2 (buried via between inner 
layer 1 and 2) then select OK. 
Step 2: Pad Stack  
Select the Buriedvia 1/2 from the "Via Hole Styles" list. This name now appears above the "Pad stack" 
information and the pad stack can be defined. 
Select the New button from the "Pad Stack" area of the window, the window shown in Figure 70 
appears.  
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Figure 70 

The Insertion layer should be set to one of the inner layers the pad will appear on, 1 for the first inner 
layer in this example.  
Choose a Style (round or square) for the pad and change the size of the pad as required. Pad sizes for 
buried vias are usually quite small - talk to your board manufacturer about what they can achieve cost-
effectively. 
Select Add Pad. The window closes and the details appear in the pad stack definition. (If a mistake 
was made and the details need to be changed, select the pad then press the Edit button and make the 
changes.) 
With Buriedvia 1/2 from the "Via Hole Styles" list still selected, select the New button from the "Pad 
Stack" area of the window again. 
This time, set the Insertion layer to 2 (the second inner layer), set the style/size as required, then select 
Add Pad. 
This completes the Pad stack for this buried via style Buriedvia 1/2, the pad stack information will look 
something like that shown in Figure 71. 

 
Figure 71 

Step 3: Routing control 
For a buried via, the Function should be set to Via Hole as shown in Figure 72. 

 
Figure 72 

Set the tick boxes as described in example 1. 
Step 4: Drilling rules 

For blind or buried vias the Drilling Rules should be set to "Include in drill data set", as shown in Figure 
73. When selected, the other settings become editable. 
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Figure 73 

Drill sets are defined so that individual drill output files can be produced for each different set of 
blind/buried holes as described above. Each buried via layer pair has to be output separately from the 
others. 
The drill data set names are numbered from DS01 to DS18 (DS01 and 02 are reserved for through 
board holes).  
It's suggested the names are changed to something easily recognisable, for instance Blind Top or Blind 
Top/1 for blind vias drilled from the top of the board to the first inner layer. Use the Change Set Name 
button to implement this. The number/name is not important but which drill set each blind/buried via 
hole is added to, is important - the boards will be drilled incorrectly if a mistake is made. 
Set the drill hole diameter as required for this pad stack. Again, talk to your manufacturer about the 
diameter of buried vias that they can achieve. 
This completes the definition of this buried via stack. If there are more blind/buried vias to be defined, 
leave the Via Hole Definitions window open, if not, select OK to continue. 

Buried vias between inner layers 3 and 4  
Buried vias between inner layers 3 and 4 should be defined in the same way as above except the 
names and layers used would be adjusted each time. For example, the Via hole style name could be 
Buried 3/4. The padstack should only include pads on inner layer 3 and inner layer 4. The Routing 
control should be set as required. The Drill rules should be set for a new drill set, which could be called 
Buried 3/4. 
The same would apply for a buried via between layers 5 and 6, etc. (Buried 5/6). 
If all the examples have been created as described, then the Via Hole Definitions window will look 
similar to the one shown in Figure 74. 

 
Figure 74 

If each Via Hole Style is selected in turn, the settings for that via pad stack can be checked and 
changed if necessary. Select OK to complete the via hole definitions.  
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Example 6: Through board via stacks (for power tracks) – Power Via 
Typically code 0 round pads are used for all through-board vias. However, because of the higher 
current carrying requirements of power tracks when compared to signal tracks it is often a requirement 
to use larger vias for power tracks. They can be defined as follows: 

Step 1: Via Hole Style  
Select the New button from the "Via Hole Styles" area of the window, then enter a name for the power 
via - as a suggestion for this example, use Power via then select OK.  

Step 2: Pad Stack  
Select the Power via from the "Via Hole Styles" list. This name now appears above the "Pad stack" 
information and the pad stack can be defined. 
Select the New button from the "Pad Stack" area of the window, the Add New Pad to Via Hole 
Padstack appears.  
The Insertion layer should be set to All copper layers (layers can be defined individually, but this would 
be time-consuming).  
Choose a Style (round or square) for the pad and change the size of the pad as required. 
Select Add Pad. The window closes and the details appear in the pad stack definition. 

Step 3: Routing control 
For this via, the Function should be set to Via Hole. 
The Allow in power nets tickbox must be ticked to allow these vias to be used in power tracks. 

Step 4: Drilling rules 
For these vias the Drilling Rules should be set to "Include in "Through board" drill data".  
Set the drill hole diameter as required for this pad stack. 
This completes the definition of through board power via stack. 

Defining signal vias 
It is possible to create a via stack specifically for signal tracks, although code 0 is usually set to the size 
required.  
If an additional via stack is required, it can be defined in the same way as the power via, but do not 
enable it for use in power tracks. 
Code 0 vias can still be used by the auto-router, but they can be disabled if required (in the 
Specctra/Elecctra auto-router setup window).  

Saving via stacks for use on other designs 
Once via stacks have been defined they can be saved to a file and then loaded into other designs. This 
allows a set of blind/buried vias to be defined for each number of board layers, 4, 6, 8, etc. 
Saving via stacks 
From the Via Hole Definitions window, select File > Save Via Definitions. Use the explorer window that 
appears to locate the folder the file should be saved in, then supply a name for the file (the extension 
must be .uvd). 
Loading via stacks 
From the Via Hole Definitions window, select File > Load Via Definitions. Use the explorer window that 
appears to locate the folder the file has been saved in, then select the file required.  
A default set of blind/buried via stacks for a 6 layer board have been supplied in the file 
default_user_vias.uvd which will be found in the ..\XL Designer\masters\pcb folder. If used, the layer 
assignments will need to be adjusted accordingly. 

Routing with user-defined vias  
The parts should be placed in the normal way and any split power planes created. 
If vias are allowed in some surface mounted component pads, then edit the properties of those 
component outlines and enable the Allow via holes at SMD pads setting.  This will allow vias 
(blind/buried and through board) to be placed in the smd pad by the Specctra/Elecctra auto-router.  
Submit the design to the Specctra/Elecctra auto-router. Once the design has been routed, re-create 
any power planes and when complete, check the artwork. 
The artwork can be manually adjusted if required.  

Manually routing with user-defined vias 
When manually routing, user-defined vias will be inserted automatically if the “Via Autoselect” 
checkbox in the Mroute dialoge bar is ticked. The most appropriate user-defined via will be chosen, 
according to the layers the via has to connect through. If there isn’t a user-defined via available that 
would maintain connectivity between the layers, then a standard code 0 via will be used. 
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Blind/buried via colours and point count 
In the artwork editor, blind and buried vias are visible if the via layer and the layer they appear on, are 
visible. 
The point count for layer V includes blind and buried vias, they are not included in other layer point 
counts. 

Outputs 
All the output files should be generated in the usual way whilst taking into account the following 
information. 

Artwork layers output 
When outputting artwork layer information, user-defined via pads are output if the layer they are 
included on, has Pads included, along with pads on layer V. 
"Standard" vias (code 0 pads) are output if the pads on the V (via) layer are included. 
Figure 75 shows the typical selections for an inner layer 1 output which would include all standard vias 
(V layer), inner pads of through-hole components and blind/buried pads on layer 1 (pads on layer 1) 
and tracks/text on layer 1 (copper on layer 1). 

 
Figure 75 

Note: When outputting inner power plane/split plane layers, only the pads and copper from the power 
plane layer should be output. Layer V should NOT be included. 

NC Drill Output 
A separate NC drill file will be required for conventional through hole vias/component holes, for each 
set of blind vias and for each set of buried vias. 
When the NC Drill output task is opened, window similar to the one shown in Figure 76 appears. 
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Figure 76 

As the window is set at the moment, with CNC Dataset DS01 selected, the drill output file produced 
(when the Create File button is selected) will contain drilling information for drilled components and 
"standard vias" - vias that go all the way through the board.  
To output the blind or buried via hole information, change the CNC Dataset so that the drill dataset 
required is selected (by selecting the down-arrow alongside the CNC Dataset, then select from the list, 
for instance Blind T/1 (or whatever it was called)). The tooling/hole information changes accordingly 
and the drill file can be produced. Repeat this for each Drill dataset used. 
When the drill datasets are used for drilling buried vias, it is essential that the correct file is used for the 
correct buried via layer pairs. 
When the drill datasets are used for drilling blind vias, it is essential that the holes are drilled from the 
correct side of the board (top or bottom) and to the correct depth. Bear in mind that there could be 
more than one set of blind holes (drill datasets) drilled from the same side of the board, but to different 
depths. 

Drill sheet (drawing) output 
If drill sheet drawings are required, a separate drill sheet drawing output will be required for 
conventional through hole vias/component holes, for each set of blind vias and for each set of buried 
vias. 
Open the output task for the drill sheet, then open the drill sheet setup window, which is shown in 
Figure 77. 
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Figure 77 

As the window is set above, with the CNC Dataset set to “DS01 Through plated drill holes/slots”, the 
drill sheet output will contain hole information for drilled components and "standard vias" - vias that go 
all the way through the board.  
To output the blind or buried via hole information, change the CNC Dataset so that the drill dataset 
required is selected (by selecting the down-arrow alongside the CNC Dataset, then select from the list, 
for instance Blind T/1 (or whatever it was called)). Repeat this for each Drill dataset used. Figure 78. 
 

 
Figure 78 

Ensure that each drill drawing is associated with the correct layers and that the holes are drilled from 
the correct side of the board (top or bottom) and to the correct depth if buried vias are in use. Bear in 
mind that there could be more than one set of blind holes (drill datasets) drilled from the same side of 
the board, but to different depths. 
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Configuration folder – Grid Autopitch Table & Axis Dot Limit 
Grid autopitch table 
When working in the graphical editors a grid is used to help position items. On many occasions it is useful if the 
grid gets finer or courser automatically, depending on the level of zoom. This table allows the user to define the 
grid pitches that XL Designer can select from when an auto-grid is in use.  
When an auto-grid is in use, the most appropriate grid pitch is chosen automatically for each level of zoom.  The 
table, shown in Figure 79, contains two sets of values, one in mm and one in inches. 
When viewing the complete board, one of the courser grids would be used as the finer grids would obliterate 
everything else on display. Likewise if a single item were filling up the screen, one of the finer grids would be 
used. 
These grid pitches are only used when Grid > Inch or Grid > Metric grid is selected. 

 

Figure 79 

 
The pitch chosen is determined by how many grid dots would be drawn along the longest axis of the workarea 
window if that pitch were chosen. The grid pitch that fits the <= “Autogrid pitch change threshold” setting (in the 
Edit > Display Adjustments window) along the longest axis of the workarea is the grid pitch that is chosen. 
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Log Files Folder 
The Log Files folder is empty initially. It will contain auto-generated reports that contain information associated 
with specific processes or tasks. The information is supplied for future reference purposes. 
The names of the log files should be self-explanatory but if further information is required, open the file to view 
the log report itself.  
They can be opened by double-selecting them (or by a right-click/Open). 
They can be deleted by a right-click/Delete. Care should be exercised when deleting the log reports as the 
information may be relevant to future processes. 

Typical log files: 
flatcir_conversion report provided from the conversion of a circuit drawn using the old-style flat 

schematic editor to the hierarchical style editor. It is suggested that this report is not 
deleted as it may be useful for future reference in the event of a problem. 

compile report created by the extraction of a parts/wiring list from the schematic. 
circuit_plotfilter report created when the schematic was output. 
art_plotfilter report created when the artwork was output. 
electra_export.txt report created when the Run Interactively, Run Router or Export commands are used 

from the Electra interface window. 
electra_import.txt report created when an attempt has been made to import a routed file using the 

Electra interface window. 
specctra_export.txt report created when the Run Interactively, Run Router or Export commands are used 

from the Specctra interface window. 
specctra_import.txt report created when an attempt has been made to import a routed file using the 

Specctra interface window. 
renumber a history of the part renumbering and/or gate/pin swapping that have taken place. 
netmods a history of the changes made in the artwork editor using the Tools > Network 

commands. 
 
This is not a definitive list and there are many other log files that can be created. 
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Documentation Folder 
The documentation folder allows external file types, such as Spreadsheets, Word documents, etc., to be stored 
within the design. User-defined file types can be specified and templates created that load automatically when 
the file type is selected. 
The file is stored within the design and can only be opened from within the navigator. Note: if the application 
required to open the file is removed from the system, then it will not be possible to edit that file until the 
application is re-installed. 
Important Note: The target application (Excel, Word, etc.) should not be running when a new file is created or a 
file modified as the changes made from within XLD will not be saved. 

Creating a new documentation file 
From the Navigator, right click on the Documentation folder within a design, select New, and then choose the file 
type from the list that appears.  
The list of file types available is configured in the <INSTALL_DIR>\UserTemplate\DocTemplates\index.txt file 
(see Customising the file types available below). 
The file is added to the documentation folder with the name <Untitled.ext>, an opportunity is given for the file to 
be re-named when it’s created.  
Once created, it can be renamed/deleted by right-clicking the file and selecting Rename/Delete.  
Open the file by double-selecting it, or right-click/Open. Once opened, the Open, Rename & Delete commands 
are greyed out until the file is closed. 

Importing a documentation file 
Any existing file can be added to the documentation folder of the design. Right click on the Documentation folder 
within a design, select Import.  Use the browser window to locate and select the file required.  
Once imported, it is a copy of the original file that is held in the design, not the original itself. If the file is modified 
from with the design, the original file is unaffected. Likewise if the original file is edited, this does not affect the 
file held in the documentation folder. 

Customising the file types available 
The file types that are presented in the Documentation > New menu can be customised as required by editing 
the index.txt file in the <INSTALL_DIR>\UserTemplate\DocTemplates folder. This file should be edited whilst 
Seetrax XL Designer is closed. 
This file can be edited provided basic rules are obeyed. The file takes the following form: 
  Extension1 Description1 
  Extension2 Description2 
  Extension3 Description3 
An example is shown in Figure 80. 

txt Text Document 
doc Microsoft Word Document 
xls Microsoft EXcel Worksheet 

Figure 80 

The text string in the description field will appear in the Documentation > New menu as shown in Figure 81. 

 

Figure 81 

When editing this file, the file extension and description fields must be separated by a single tab character.  
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Creating a Template for the file type 
For each file type defined in the index.txt file, if a corresponding file named: templates.{extension} 
is created in the DocTemplates folder, then that file will be used as the initial file content for newly created 
documentation file.   
If a template file does not exist for a file type, then the New file action will create an empty (0 bytes long) file.  
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Standard Pads Folder 
This folder provides access to the four standard pad shapes and associated sizes. Each pad shape has its own 
folder. When the folders are opened, a list of the sizes for that shape is presented in the navigator, as shown in 
Figure 82.  

 

Figure 82 

The list only includes the pad codes that have a size assigned to them. The first dimension provided is the pad 
diameter, or length of the pad if a rectangular shape is selected, followed by the drill size. 
If an individual pad is selected, it is displayed in the Browser pane (if visible – View > Browser setting), Figure 
83. 

 

Figure 83 

If the Standard Pads folder or any of the pad shape folders, or a pad from the list is double-selected the sizes 
table appears and the complete list can be viewed and the sizes altered if required. 
The sizes table can also be accessed from the Configuration folder and it is described in the chapter titled 
Configuration Folder – Size Tables, Pad Sizes. 
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When adding pads to component outlines, the pad to be added can be dragged from the Standard Pads Folder 
(unless a Custom Pad is being added). 
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Custom Pad Folder 
The Custom Pad Folder contains pads that do not conform to the four standard pad shapes.  
Standard pads are defined as round pads, square pads, rectangular pads or round ended finger pads that have 
one hole (if required) in the centre and the connection point also in the centre.  
Custom pads are not supplied with the software so the master and design custom pad folders will initially be 
empty. 
Only pads that cannot be defined as standard pads should be added to the custom pad folder. It is inefficient to 
define standard pads using custom pads in terms of time and space. 
Each design has its own custom pad folder, which will contain the non-standard pads used on that particular 
design, plus any other pads the user may wish to include.  
Custom pads can be copied/pasted to/from other custom pad folders (other designs or the master folder), using 
the right-click Copy/Paste tools. Custom pads can also be created directly in the folder.  
Once custom pads have been copied into the design, changes to them do not affect the original pads, other 
designs or the master custom pad folder.  
Changes to custom pads in the master custom pad folder do not affect any other designs. 
The custom pad folder is automatically updated if outlines containing custom pads are copied to the 
design/master outline folder - providing the pads are available in the source file. 
It is suggested that custom pads are created within a design folder and verified before they are copied to the 
master folder. Once custom pads are in the master folder it is assumed they are correct. 

Opening/viewing the custom pads folder and its content 
Locate the custom pads folder required from the navigator window - the master custom pads folder is held 
inside the Masters folder, whilst each design’s custom pads folder is held inside the design folder. 
Once found, double-select select the Custom Pads folder (or select the + sign alongside it) to open it. If custom 
pads exist in the folder they will be listed below the open folder in the navigator pane. 
The custom pads folder of a new design will be empty. 
If custom pads are listed they can be selected in turn to browse through them. They are shown graphically in the 
Browser window and their properties are displayed in the Properties window (if those windows are open).  
A custom pad can be opened for editing by double-selecting it. 
To close the folder, either double-select the folder (or select the - sign alongside it). 

Custom Pad Information 
The pad MUST be defined as an enclosed area, with ONE continuous line. 
Corners in the line should only be added in order to change direction.  
The start point and end point of the line MUST be in the same position to ensure an enclosed polygon is formed. 
The line MUST start and stop at a corner in the pad, not in mid-segment.  
Areas within the pad should not be defined. 
Failure to follow the above will result in problems when creating the gerber photo-plotter files. 
When a custom pad is created, it does not "belong" to a particular layer of the board. It is added to the 
appropriate layer(s) when the component outline (footprint) is made, or the pad is added to a particular layer in 
the artwork editor. 
A hole or holes can be defined in the pad, but it is the layers the pad is used on that determine whether it will be 
drilled. 
The position of the pad's datum, the centre of the drilled hole(s) and the connection point can be selected. 
It is suggested that custom pads are created within the design custom pad folder and verified before they are 
transferred to the master folder. Once pads are in the master folder they are available to all users and expected 
to be correct. 
If custom pads in a design are modified, they are automatically updated on the associated artwork. 

Creating a custom pad, general guidelines 
With the design open, create a pad and give it a name by right-clicking the Custom Pad folder, then selecting 
New. Double-select (or right-click/Open) the pad to open it for editing. 
Check the grid is set to suit your requirements (Grid commands). 
Draw the shape of the pad using the Outline commands - take note of the information given above. 
Position the datum of the pad (Tools > Set Pad Datum), typically in the centre of the pad. 
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Position the connection point of the pad (Tools > Set Connection Point), typically in the centre of the pad. 
Add the drill hole(s) if one or more are being added (DrillHoles > Add), their size is defined in the toolbar. 
The pad is ready to be used in an outline or on the artwork. 

Individual commands in the custom pad editor  
An overview of the custom pad editor can be found in the Installation & Getting Started Guide. Here we describe 
each of the custom pad editor commands in detail.  

Right-click on custom pad folder 
Right-clicking on the Custom Pad folder in the navigator window introduces the following commands:  

New  Paste 
These commands are described below. 

New - Creating a new custom pad 
A new custom pad can be created by right-clicking the custom pad folder in the navigator window and selecting 
New from the options that appear. A new custom pad is added at the bottom of the list of custom pads in the 
folder, called Unnamed. It can be renamed at that point as it is highlighted ready for editing. However, if <enter> 
is pressed or the cursor is selected elsewhere, the original name (unnamed) will remain. It can be renamed by 
right-clicking on the outline and selecting Rename. 

Paste 
A custom pad that has been copied to the paste buffer can be pasted (copied) to the custom pad folder.  Right-
click the custom pad folder in the navigator window, then select Paste from the options that appear. The custom 
pad is added to the bottom of the list of custom pads in the folder, it will take its original name unless a custom 
pad with that name already exists in the folder, in which case it will be named “Copy of <original name>” 
It can be renamed by right-clicking on the outline and selecting Rename. 
(To copy a custom pad to the paste buffer, right-click on the custom pad, then select Copy.) 

Right-click on a custom pad 
Right-clicking on a custom pad in the navigator window introduces the following commands: 
 Open Cut Copy Delete Rename  
These commands are described below. 

Open 
When selected, the custom pad is opened for editing.  

Cut 
Currently (version 1.68) operates in the same way as Copy, though this may change in a future release – refer 
to the readme.txt in the ..\Seetrax\XL Designer folder for update information. 

Copy 
When selected, the custom pad is copied to the paste buffer, overwriting anything previously added to the paste 
buffer. (To paste the custom pad from the paste buffer to any custom pad folder, right-click on the appropriate 
custom pad folder (which might be the same design, another design or the master custom pad folder), then 
select Paste from the options that appear.) 

Delete 
When selected, the custom pad is deleted from the folder. 

Rename 
Used to alter the name of a custom pad.  Once selected, the name is highlighted and the usual editing keys 
(backspace, delete, left/right arrows, etc.) can be used to rename it. It is possible to rename a custom pad that is 
used in an outline or the artwork editor. 

Datums commands 
Tools > Set Pad Datum 
Used to define the datum of a custom pad. 
When a pad is selected in the outline or artwork editors, it must be selected on its datum position. 
The appearance of the datum is shown at the bottom left-hand corner of the screen to avoid confusion with the 
connection point, which is also displayed. 
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Once selected, point at the position required for the datum then click the left-hand mouse button. The datum 
moves. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The X-Y readout (shown in the information bar) of the cursor position is displayed with respect to the position of 
the datum point. 
The Set Pad Datum command remains active until the right button is clicked to cancel the operation, or another 
command is selected. 

Datums > Set Connection Point 
Used to define the point at which connections terminate on the pad. 
The appearance of the connection point is shown at the bottom left-hand corner of the screen to avoid confusion 
with the datum, which is also displayed. 
Once selected, point at the position required for the connection point and click the left-hand mouse button. The 
connection point moves. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The Set Connection Point command remains active until the right button is clicked to cancel the operation, or 
another command is selected.  

Tools > Outline Definition 
Once Tools > Slots & Extra Holes has been selected, use this command to revert back to the main Pad editor 
commands. 

Tools > Slots & Extra Holes 
This command provides access to the Slots and Extra Holes commands which allow routed slots and/or 
additional holes to be added to an individual custom pad.  
Their use is identical to the same commands in the Component Outline and Artwork editors. The commands are 
therefore described under the heading Slots & Extra Holes (Tools > Slots & Extra Holes commands) on page 
241 of this manual. 

Outline commands 
These commands are used to define the external shape of the pad. Only one line should be added and it should 
form an enclosed polygon shape. No other lines should be added. 
Tip: start off with a simple enclosed shape, then add corners and convert the segments to arcs as required. The 
starting point of the line should coincide with the end point of the line, there should not be a gap between the 
two. This point should also be on a change of direction in the line, not mid-segment. 

Outline > Add Line 
Used to add a line that will define the external shape of the pad.  
Point at the location where the line will start and click the left button. Move the cursor, a line appears attached to 
it. Click the left button to insert corners in the line. Release the line from the cursor by clicking the right-hand 
mouse button. The end of the line must be terminated where the line was started from, so that it forms an 
enclosed shape.  
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The line can be modified using the Outline > Corner/Adjust Arc/Delete point, etc. commands. 

Outline > Add Arc 
Used to define the external shape of the pad, typically when it is made from a series of curves. Only one line 
should be added and it should form an enclosed polygon shape. The end of the line must be terminated where 
the line was started from, so that it forms an enclosed shape. 
Point at the location where the curved line is to start and click the left button. Move the cursor and its attached 
line to the position where the curve should end, and click the left button again. A straight segment is produced 
that bends as the cursor is moved. The shape of the arc is dependent on the position of the cursor. Click the left 
button to release the curve in its current position. The line remains attached to the cursor, allowing a series of 
curves to be added. 
Once the arc has been released, clicking the right-hand mouse button releases the line from the end of the 
cursor. 
If the right-hand mouse button is clicked whilst the curve is being stretched, a straight-line segment is 
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introduced, thus allowing a mixture of curved and straight lines to be added. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Arcs can be modified with the Outline > Corner/Adjust Arc commands. 

Outline > Add Rectangle 
Used to add a rectangle. Once added it can be modified using the Outline > Corner/Adjust Arc commands. 
The size of the rectangle can be specified in either inches or millimetres. The units in use are controlled by the 
Edit > Units command.  
When selected, a window appears allowing the Width  and Height of the rectangle to be typed in. Select OK to 
add the rectangle. 
The rectangle appears attached to the cursor, move it into position and click the left button to release it. Another 
rectangle appears on the end of the cursor until either another command is selected, or the right-hand mouse 
button clicked when the window reappears, and Cancel should be selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Once in position, the rectangle is treated as a line, which can have corners added, deleted or moved or 
converted to arcs. 

Outline > Corner 
Used to add and move existing corners (points) in lines or arcs. 
Corners are added and released with clicks of the right-hand mouse button. Existing corners are moved with 
clicks of the left-hand mouse button. Once the corner has been selected, clicking the opposite mouse button 
cancels the operation. 
   right button  =   add corner 
   left button     =   move corner 
   (Opposite button cancels) 

Adding a corner to a line or arc: 
Point at the line or arc and click the right button. Move the new corner and release it with another click of the 
same (right) button. Clicking the opposite (left) button before the corner is released cancels the new corner. 

Moving an existing corner in a line or arc: 
Point at the corner in the line or arc and click the left button. Move the corner and release it with another click of 
the same (left) button. Clicking the opposite (right) button before the corner is released, cancels the move. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Outline > Adjust Arc 
Used to convert straight lines into curved lines, curved lines into straight lines, and to change the shape of 
existing curved lines. 

Straight lines into arcs:  
Point at a line segment and click the left-hand mouse button. Move the cursor, the segment is replaced with an 
arc attached to the cursor. Once the arc is in the required position, click the left-hand mouse button to release it. 

Arcs into straight line segments:  
Point at the arc and select it with a click of the left-hand mouse button. Follow this with a click on the right-hand 
mouse button to convert it to a straight-line segment. 

Changing the shape of an arc:  
Point at the arc and select it with a click the left-hand mouse button. Move the cursor with the arc attached, then 
click the left-hand mouse button when the arc is in the desired position. 
Clicking the right-hand mouse button toggles the last selected line or arc between a line and an arc. The shape 
of the arc is defined automatically and can be used to convert 45-degree lines into quadrants of a circle. The 
direction of the arc is determined by the position of the cursor about the line when the button is pressed. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Outline > Delete Feature 
Used to delete a line or an arc. 
A complete line is deleted between its start and end points, not just a segment between points. 
Point at the line or arc to be deleted and click the left-hand mouse button. 



 

78 

Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Outline > Delete Point 
Used to remove corners from lines or arcs. 
Move the cursor over a point (corner) in a line or arc and click the left-hand mouse button. The corner is 
removed. 
If the start or end point of a line is deleted, the segment is removed. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

DrillHoles commands 
These commands are used to define the position and size of the drilled holes. The layer(s) the pad is used on in 
the artwork editor control whether the holes are used. 
Drill diameter (in tool bar) - Used to specify the size of drilled holes before they are added. 
If the diameter of an existing hole is incorrect, the hole should be deleted and a new one added at the correct 
size. 
Hole sizes are usually specified as finished hole sizes, i.e. after plating. Drilled hole sizes are not usually given, 
as the thickness of copper in the hole, and consequently the finished hole size, is determined at the 
manufacturing stage. 
Hole sizes can be specified in either inches or millimetres if the appropriate units are selected (Edit > Units).  
Select the drill diameter dialogue in the toolbar, then type the hole size required. (Once the value has been 
selected for editing, keep the cursor in the dialogue or the value cannot be changed.)  
New holes will be added at the size specified. 

DrillHoles > Add 
Used to add a drilled hole to a pad. More than one drill hole can be added to a pad. 
Whether the pad is actually drilled is determined by which layer(s) the pad is used on in the outline or artwork 
editors. 
The diameter of the hole is specified before it is added, by the Drill diameter size setting in the tool bar. 
Select DrillHoles > Add, move the cursor and a "hole" appears attached to it. Position the hole as required and 
click the left-hand mouse button to release it. More holes appear on the end of the cursor until another 
command is selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

DrillHoles > Move 
Used to move an existing drilled hole. 
Select DrillHoles > Move, point at the centre of a hole and click the left-hand mouse button. Move the cursor 
taking the hole with it, to its new position, then release it with a click of the left-hand mouse button. 
Clicking the right-hand mouse button whilst the hole is being moved returns it to its original position. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

DrillHoles > Delete 
Used to delete a drilled hole from a pad. 
Select DrillHoles > Delete, point at the centre of a hole and click the left-hand mouse button. The hole is 
removed immediately. 
Refer to the grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Vias 
Unless other via types are specifically defined, code 0 round or square pads are always used for vias. 
Whether round or square code 0 pads are inserted in the artwork is controlled from the Manual Routing 
Parameters window, in the Configuration folder. 
Other via types, such as blind/buried vias, or different sizes of via for use in power tracks have to be defined by 
the user, using the Via Hole Definitions window in the Configuration folder. 
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Schematic Folder 
The schematic folder contains the tools to design circuit diagrams on a single sheet, or multiple sheets using a 
flattened or hierarchical structure. The tools are also used to create/edit the parts used on the circuit diagram 
and to extract a parts and wiring list from the circuit diagram. 
Typically designs start off with one sheet, then more sheets are added as required – these are referred to as flat 
or flattened schematics. 
Hierarchical structures are employed when the design is more complex and symbols can be used to represent 
sheets of circuitry in order to make the diagram easier to follow, or perhaps when there are multiple channels of 
similar circuitry. 
Flattened schematics are easier to design and there are important differences that should be taken into account 
when choosing which method to use – it is easier to convert a flat schematic into a hierarchical schematic than 
the other way round. 

Differences between Flattened & Hierarchical Schematics 
Once a design has more than one sheet, it can be drawn as a “flat” or “hierarchical” schematic. The main 
differences between a hierarchical & flattened schematic are: 

• appearance 
• connectivity - the way in which connections are linked between sheets 

Note: in older versions of Ranger a different schematic editor was supplied, this was known as the “old, flat-style 
schematic editor” which should not be confused with flat schematics designed in XL Designer. If a design with a 
schematic drawn using the “old flat-style schematics” is opened in Seetrax XL Designer the schematic is 
automatically converted to the new-style editor, in flattened mode – see Old flat style schematic to hierarchical 
schematic conversions below. 

Appearance 
In a flat schematic the circuitry is simply added to as many sheets as required.  
In a hierarchy, each schematic sheet can be represented by a symbol. This symbol can be used on other 
schematic sheets to represent the circuitry from its associated sheet. 

Connectivity 
Connections may be added from pin to pin on the sheet or they may be added to a pin and given a signal 
name. All connections with the same signal name on the same sheet (local connections) are automatically 
connected together in the resultant wiring list. 
When multiple sheets are used there is usually a requirement that some connections are connected 
between sheets.  
To cater for this, the wiring list can be extracted in one of two modes - either “flattened” or “hierarchical”. 

Flattened Mode 
In this mode, any connection with the same signal name, from any sheet is connected to ALL other 
like-named connections on any other sheet. 
Hierarchical Mode 
In this mode, connections with the same name, on different sheets are NOT connected together in the 
resultant wiring list. A conscious decision has to be made to make the connection between sheets. This 
is achieved through the use of ports.   
The only exception to this, are any implied power rails within schematic library parts – these 
automatically become “global” connections, i.e. they connect across all sheets without the use of ports. 
Note: this does not apply to Primitives that are used for signal names, they are not global connections. 
Ports are added to the sheet as required to act as a connection point between sheets and the levels in 
the hierarchy. The ports have to be connected through the hierarchy in order to make the connection 
between sheets. 

Old flat style schematic to hierarchical schematic conversions 
The first time a design is loaded that has an old style flat schematic (for example from a design created with 
Ranger1/2/3), then the schematic and its associated device library entries are converted into the 
hierarchical schematic editor format.  
Due to major differences in the way that "bus" signals were handled in the old flat schematic editor 
compared to the new editor, all imported "bus width" wires are converted to non-electrical features. 
Because of this, schematics with busses may need some manual editing after loading, if a parts/wiring list 
extraction results in errors because multiple signal names are found on a net. It will be necessary to edit the 
busses using the Wires > Flat Circuit Import Assist > Toggle Wire Section To Non Electrical command 



 

81 

which is described later in this manual. 

Accessing the schematic tools 
The master schematic library will be found under the Masters folder in the navigator. Its commands work in 
exactly the same way as those found in the desgn’s schematic folder.  
When a master schematic library folder is selected, its path/location is shown in the Properties pane, along with 
the number of parts held in the folder. 
When schematic parts are selected in the navigator, the Properties pane displays its attributes and power pin 
information. 
To open the design’s schematic library, assuming the design has been opened and expanded in the navigator 
pane, select the + sign from alongside the Schematic folder to open it and view the items making up the 
schematic part of the design, which includes parts and design sheets (circuit diagrams).  
Expand the appropriate folders depending on the task in hand - in a new design all the schematic folders will be 
empty to start with, they become populated with the parts used on the design – either by being placed on a 
sheet, copied from the master library or other jobs, or created within the design itself. 
To create a new item, right-click the appropriate folder and select New - an opportunity is provided to supply a 
name. Double-click on the item to open its editor. Right-clicking the item in the navigator pane produces other 
commands which are detailed below. 
(A worked example of the schematic editor can be found in the Seetrax XL Designer Manual, available from the 
Help command when the program is running.) 

Right-click on the Schematic Folder, or Items within Sub-Folders 
New Folder – applies to the Master Schematic folder only 

The master schematic library is divided into folders so that parts can be located easily, for example 
resistors in one folder, capacitors in another and so on. Each of those folders can contain sub-folders, or 
nested folders to allow further separation of the parts, for example, smd’s in one, through-plated parts in 
another. 
A selection of folders containing parts/sheets was provided when the software was installed and these 
folders can be added to, by either right-clicking on the master schematic folder to add a new top level 
folder, or one of its sub-folders to create a nested library within that folder. 

 New - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
Creates a new item of the type selected and places it in the appropriate schematic folder for the item 
selected. Each of the types is described below under the heading: Contents of the schematic folder 

Open - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
Opens the selected item for editing, see following pages for details on the commands within the individual 
editors. 

Copy - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
Copies the selected item(s) into the “paste” buffer for subsequent “pasting” (copying) to an appropriate 
folder. For example, a schematic part into a schematic part folder, primimitive into a primitive folder, etc., – 
items cannot be pasted into the wrong folder type. 
Items can be copied into folders within the same job, other jobs or the master library. 
If a schematic part is copy/pasted between jobs or the master library, then the component outline(s) 
required for the copied schematic part(s) will be imported into the target design’s component outline library 
at the same time, from the same source (job or master) library, provided it exists. 
Multiple items can be selected, using the Shift/Ctrl keys in unison with the right-click selection. 

Drag-drop functionality – for moving/copying 
In addition to the Copy command, “drag & drop” is available to move schematic library parts between the 
various folders in the master library and between designs. 
Parts that have dependencies on other library entries (like split parts and their dependent primitives) cannot 
be moved or copied by drag/drop. 
When dragging parts between the master schematic library folders, the default action is “Move”.  Hold down 
the Ctrl key to change the action to “Copy”. 
When dragging parts from a design into another design or master library, the default  action is “Copy”.  Hold 
down the Shift key to change the action to “Move”. 
Drag/drop “Move” functionality is not available when removal of the part from the drag source would break 
design dependencies. 
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Paste - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
Pastes the content of the Paste buffer into the selected folder, provided the items are compatible, for 
example. a primitive could not be pasted into a block i/o port folder, design sheet folder, etc. 
See details above, regarding the Copy tool.  

Delete - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
Deletes the selected item(s) from the folder.  
Items that are in use within the design cannot be deleted and an appropriate information message is 
displayed. 
Multiple items can be selected, using the Shift/Ctrl keys in unison with the right-click selection. 

Rename - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
Used to Rename the selected item. All occurrences of the item that are in use in the design are updated.  

Attributes – schematic folder only 
Each schematic part has a set of attributes associated with it. This command allows the attribute fields for 
all parts within the currently open job, or a selected master library folder, to be exported to a text file, edited 
off-line, then imported back to the design. 
This provides a simple way of editing the attribute fields within each part without having to open each part 
for editing, for example to update all the current price attributes.  

Attributes > Export 
Used to export attributes from the selected schematic or master schematic library file. 
Exported attributes may be saved into tab separated (.txt) or comma separated (.csv) files. 
To export a file suitable for editing in Microsoft Excel Spreadsheets, it is recommended that the attributes 
are output as a tab separated (.txt) file. On loading, Excel will display an import Wizard where the type of all 
imported columns should be changed to “text” type. If this is not done, the strings of digits will be treated as 
numbers, which is a problem if some of the attributes have all numeric names with leading zeros, for 
example “0805”.  
The first row in the created file will always contain the column names for the data in the subsequent rows.   
The first column is always the name of a part in library.  
Each additional column represents an attribute setting. The columns between rows may not neceassarily 
line up, as can be seen in the following samples, but there will always be a tab or comma between entries – 
including blank entries. 
Sample attribute output file (tab delimited): 

 
Name $3 (Outline) $2 (Value) 
7400 DIL14 7400 
7401 DIL14 7401 
7402 DIL14 7402 

Sample attribute output file (comma delimited): 
 

Name,$4 (Order code),$3 (Outline),$2 (Value) 
7400,DIL14,7400 
7401,DIL14,7401 
7402,DIL14,7402 

When editing the file, be sure to leave just one tab or comma between fields. 
When selected (right-click appropriate folder, then Attribs > Export), the window similar to the one shown in 
Figure 84 appears, with any user-defined attributes that are in use listed (none in this example). 
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Figure 84 

To exclude any of those attributes in the output file, untick the checkboxes alongside. 
If some/all of the system attributes are also required, then tick the Include system reserved attributes 
checkbox. This will produce the list as shown in Figure 85. 
 

 

Figure 85 

Any of the attributes that are not required in the output file should be unticked. Select OK to produce the 
output file, the Windows browser appears, allowing you to specify where the output file should be created 
and its name. 
Select the Type of file required – either Text (Tab delimited)(*.txt) or CSV (Comma delimited) (*.csv). 
Select Save to save the file.  A window indicating the export has taken place will appear. 
Once the file has been created, the values assigned to the attributes can be edited. The file can then be 
imported back using the Attributes > Import command.  

Attributes > Import 
This command is used to import a file containing the attribute value fields associated with a library file or job 
back into the library or job.  
When importing attributes, the schematic editors should not be open.  
The importer will be using commas or tabs to identify attributes – lines will be ignored where the incorrect 
number of tabs or commas exists.  
The first row in the created file will always contain the column names for the data in the subsequent rows.   
The first column is always the name of a part in the library which should exist in the library. 
Each additional column represents an attribute setting. The columns between rows may not neceassarily 
line up, but there will always be a tab or comma between entries. If some columns have a blank entry, 
ensure the tab or comma for the entry is present. 
Right-click the schematic folder, then select Attributes > Import. The Windows browser appears allowing the 
file to be imported to be located. Select the file and also the file type (csv or tab) required and the attributes 
will be imported.  
A report window will appear listing any problems. These should be investigated and appropriate action 
taken.  

Purge Unused Blocks – schematic folder only 
Used to delete unused items from the design's schematic library. 
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For example, parts may have been placed on the schematic and then every occurrence of them deleted from it. 
The parts are therefore no longer required in the library, but they will still be there.  
Note: there is no "undo" once the parts have been deleted.  
Once selected, a window appears listing all the unused parts and split parts. Select the parts that should be 
deleted by ticking the box alongside them, then select Delete. 
The Select All and Deselect All buttons in the window can be used to quickly select/deselect all the parts. 
Once the required parts have been selected, select Delete to purge the library of the selected parts. 
Note: once split parts have been deleted, there may be primitives in the primitive folder that are no longer used. 
Use the command a second time to identify and remove these items in the same way. 

Edit Outline Names – schematic folder only 
When selected, an editor opens that allows the modification of the outline attribute field within all the library parts 
or split library parts in the library.  
This command is used to quickly update the outline attribute fields in parts. 
When selected, a window appears, listing all the library parts or library split parts present in the design, along 
with their default outline name and number of pins.  
All the parts must have a valid outline name in order to extract a usable parts and wiring list suitable for board 
layout. 
Changes that are made to attribute fields from the schematic, using the Symbol > Attributes > Edit  command 
take precedence over changes made in the library parts. So for instance, any parts that have had their outline 
name attributes changed from the schematic sheet, prior to using this command will not be updated. As an 
example: one part appears on the schematic 10 times, called R1to R10. Its outline name is set to ???. R4's 
outline attribute has been manually changed using the Symbol > Attributes > Edit command to RESA10. When 
the OUTLINE window is opened, the outline name will be set to ??? as the actual part has not been modified, 
just one instance on the schematic. If an outline name is added to the OUTLINE window for the part and 
Proceed selected, the outline attributes within the part and consequently for R1 to R3 and R5 to R10 would be 
changed, but R4 would remain as it was. 

Edit Datasheet Addresses – Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O 
Symbol 
When selected, an editor opens that allows the modification of the Datasheet address attribute field within all the 
library parts or split library parts in the current design/library. 
The Datasheet address attribute field is typically used to define a web address (URL) or file path for parts. This 
allows access to data-sheets or information associated with the parts. 
Double clicking on a part type entry brings up another dialog where the web address or file path may be edited.  
The address window in the Datasheet Address edit dialog will accept a “drag and dropped” file, so you can for 
example drag a .pdf format datasheet from Windows Explorer into the address window, and the file path will be 
set. 
Once the attribute field has been defined, the datasheet/file can be viewed by right-clicking the part in the folder 
and selecting Show Datasheet (greyed out if the attribute has not been defined), or once on the sheet using the 
Symbol > Show Datasheet command. 

Show Datasheet - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
When selected, opens the file/web-page associated with the datasheet address of the selected item, provided a 
path has been defined in the Datasheet attribute of the item. 

Show Dependancies - Design Sheet/ Part/ Split Part/ Primitive Symbol/ Block I/O Symbol 
When selected, lists the items that are used by the selected item. 

Change Block Type – Split parts or Primitives 
This command is not normally visible, as it is only intended for the recovery of parts whose block type has 
become corrupted. The corruption occurred when a schematic part or userblock was fetched into a design from 
a master library or another design; during this process the type of the block in the source library was 
inadvertantly set as a split part.  If the source library or design were subsequently edited and saved, then the 
block became stored as a split part regardless of its correct type. The part entered into the destination design 
received the correct block type. 
To enable the command, open the File > System Setup window and tick the "Enable Schematic Block Type 
Change" setting under the Temporary Fixes section. The program always starts with this feature disabled, so 
the checkbox state is not remembered. 
Once the feature has been enabled, right-click on the split part or primitive to be recovered.  Choose the 
appropriate submenu type to alter the selected split part/primitive to be a userblock, part, slpit part, primitive or 
blockio symbol. 
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After changing a block's type in this way, the design should be saved, closed and reopened in order for the parts 
to appear in their correct navigator folders. 
 

Contents of the schematic folder 
Within the schematic folder will be found: 

Design sheets 
Design sheets are used to define a page of a schematic diagram. 
Each schematic page can be represented by a Design Symbol that is used in a hierarchical schematic to 
represent the contents of the sheet, on another sheet. Connectivity between sheets in a hierarchy is achieved 
through the use of ports. Each port on a sheet has a corresponding pin on the sheet’s associated symbol. Each 
port and its associated pin have the same name.  
Note: It is not possible to open the Design sheet and its associated Design symbol at the same time. 

Design Symbols 
Design Symbols are used to define the symbol associated with a design sheet, for use in a hierarchical 
schematic.   
This symbol can be used on other schematic pages to represent the circuitry from its associated sheet - this 
creates a hierarchical schematic. 
Pins can be added to the symbol, in which case an associated port with the same name is added automatically 
to the associated sheet.  
Note: It is not possible to open the Design sheet and its associated Design symbol at the same time. 
Note: If the symbol of a sheet is placed on a higher level sheet, and the pin name attribute is edited, the new 
name will appear against the block i/o pin when descending into the schematic sheet associated with the 
symbol. 
An iopin attribute that is overriden by an attribute on a higher level instantiation will always show the overridden 
value when the sheet is displayed. The value may still be edited on the sheet, but the override value will still be 
displayed. 
Switching to the symbol of the sheet will show the attribute value without the effect of any higher level override. 
The value displayed in this mode is the value displayed against the pin for any new instantiations of the symbol. 
Over-ridden attributes can be reset to their original values, using the Symbol > Attributes > Reset command. 
When re-setting the attributes of design symbols in a hierarchy, the attributes should be reset at the upper level. 

Parts 
Parts are used to define single element parts, or multi-element parts where all the elements are the same, for 
use on the schematic sheet.   
Examples of single element parts are diodes, resistors, capacitors and connectors that are shown as one 
component.  Examples of multi-element parts are 7400's, 7402's, resistor packs and connectors where the pins 
are added individually. 

Split Parts 
Split parts are used to define a multi-element part where the elements are not all the same. The elements that 
make up the part have to be made from primitives. 
Examples are a relay containing a coil and contacts, a part containing two nand gates and two inverters. 

Primitives 
Primitives are used to define the elements for a split part, a power symbol, or a symbol to show connectivity. 
Also used to define a simulation probe for use with the PSpice output. 
Examples are the coil and contact from a relay, logic gates from mixed logic parts, power symbols for logic 
packages, symbols used to show connectivity and probes for simulation. 

Block I/O Ports 
Block I/O Ports are used to define a port to ensure connectivity between sheets in a hierarchical schematic – 
they are not required in a flat schematic. 
Block I/O ports are not physical parts, they simply allow connections to be made from one hierarchical sheet to 
another.  
There are two types of port, each with a single pin. One type allows single connections to be attached, the other 
allows bus connections to be attached. The port type is detrmined by the pin that is added, it’s either a net-pin or 
a bus-pin – so the port is either a net-port or a bus-port. 
When block I/O ports are placed on the schematic design sheet, a pin is automatically added to the associated 
design symbol, with the same name.  The pin that is added is either a net-pin or a bus-pin, depending on the 



 

86 

type of port that was added to the sheet. Like-wise, if a pin is added to a design symbol, its type (net or bus) 
determines the type of port that is added to the associated sheet. 

Commands available when a design sheet or part is open: 
Edit > Preferences 
Used to control colours, line widths of items, sheet and symbol attributes, versions, function keys and default 
information within the editor. 
When selected, the window contains varying information depending on the type of block being edited. Tabs 
allow access to particular information, such as Colours, Part Attributes, etc.  
The decimal point in numeric values indicates whether the size is displayed in inches or millimetres. A dot (.)  is 
used in inches, and a comma (,) in millimetres. 
All the information the Edit > Preferences window can contain is described here. 

Edit > Preferences - Miscellaneous tab 
Junction blob diameter - controls the size of junction blobs which are used when connections are connected 

to one another.  Existing blobs are updated automatically, but the screen must be refreshed to see the 
change. 

Auto-symgen pin gridpitch - controls the pitch of pins that are added automatically to the symbol of a sheet 
when the Tools > Auto Symbol Generate command is used (or the design symbol is opened for the first 
time after ports have been added to a sheet). Existing symbols are unaffected. 

Extract pin-pin capture distance - determines whether a connection has to be physically added between 
pins in order for them to be connected in the wiring list. For example, some designers like to be able to 
place pins on top of one another to make a connection, whilst others prefer to add connections 
between pins.  
The distance specified indicates how close pins have to be to one another before they are connected. 
For instance with 0.005" set, any pins that are touching one another or within 0.005" of one another will 
be connected in the wiring list.  
To disable pin-pin connectivity, enter any negative value. For instance -0.001. This means that 
connections must be added between pins. 

Drawing grid display mode - controls how the grid is displayed when it is switched on.  
Ruled: the grid is shown as a solid lined grid.  

If the ruled schematic grid is too faint, or not visible, the width of the grid lines can be 
controled from within the Edit > Display Adjustments window.  

Dotted: only the intersection points of the grid are shown, by dots. The colour of the grid is controlled 
by the Edit > Properties, Colours tab window. 

Negation bar prefix - to obtain a negation bar over signal names, precede the signal name with the 
character specified here. The bar appears on the display and all plots. 
The negation bar is not used in the wiring list or in the artwork editors, when the negation bar prefix 
character appears in front of the signal name. 
Note: negation bars cannot be displayed or plotted if the Rotated text display mode is set to Vertical. In 
this mode, the signal names will be displayed and plotted with the prefix character, whether or not they 
have been rotated. 
To change the character, simply select the box and type a new one. Do not change this character once 
used as a negation prefix within the schematic, or existing negation bars will be lost. 

Version control character - used to define the character used within version control strings. Refer to the Edit 
> Preferences, Version tab for more details. 

Maximum window mode dynamic nodes - controls the maximum amount of data that can be dynamically 
moved using the Region commands.  Moving large amounts of data (nodes) dynamically can be slow 
and cumbersome on some machines, so experiment and choose a number that suits you and your 
machine. (The status bar indicates the number of nodes within a window when Region > Copy is 
used.) 

Outline default prefix (i.e. DIL) - used to define a default outline name prefix for use with the Block > Outline 
command.   
Upto 12 characters can be used in the outline prefix, or it can be left blank. This allows upto 4 extra 
characters to be added to the outline name by the Block > Outline command. 

Rotated text display mode - defines which way rotated attribute text is presented (not non-electrical text). 
The setting affects all rotated attribute strings in the schematic. Options are: 
Right edge rotated text strings appear vertically, the characters rotated anti-clockwise, so the first 

character appears at the bottom of the column. (Tilt head to the left to read.) 
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Left edge rotated text strings appear vertically, the characters rotated clockwise, so the first 
character appears at the top of the column. (Tilt head to the right to read.) 

Vertical rotated text strings appear vertically, the characters are not rotated, the first character 
appears at the top of the vertical column. Signal name negation bars cannot be displayed 
whilst in vertical mode, the negation bar prefix character will be displayed and plotted 
irrespective of whether the signal names have been rotated. 

Trap distance in 'absolute' mode  - providing the "Trap distance mode" parameter is set to "Absolute", this 
parameter specifies the maximum absolute distance the cursor can be from an item, in order to select 
it. Default value is 0.1000". 

Trap factor 'n' in width/n mode - providing the "Trap distance mode" parameter is set to "Screenwidth/n", 
this parameter specifies the maximum distance the cursor can be from an item as a proportion of 
screen width, in order to select it.  Default is 50. i.e. the cursor has to be within 1/50th of the screen 
width to select an item. The smaller the number, the further away the cursor can be. 

Trap distance mode - when items are selected, the cursor has to be within a certain distance of the item 
before it will select it. Options are Screenwidth/n and Absolute. 
With Absolute selected, the cursor has to be within a specific distance of the item in order to select it. 
The distance is defined by the parameter, Trap distance in absolute mode. 
With Screenwidth\n selected, the cursor has to be within an area of the item based on a proportion of 
the width of the screen. The actual area is defined by the parameter, Trap factor 'n' in width/n mode. 

Pickup wires during symbol move - determines whether pins connect to existing connections when they are 
released over the connection, when parts are moved, rotated, flipped, etc.  For instance, if a part pin is 
moved on top of a connection, this parameter controls whether the pin is connected to the connection 
or not.  When enabled, the connection connects to the pin otherwise the connection remains 
unconnected. 

Allow connection start in mid-air - determines whether connections are allowed to start in mid-air. When 
enabled the connection can start anywhere.  When disabled, the connection must start on a pin or 
existing connection.  
Specifying that connections must start on a pin or existing connection means there is never any doubt 
that the connection is attached to the pin or connection. 

Show symbol datum points - determines whether the datum points of symbols are visible. It is useful to be 
able to see the datum points of symbols so that you know where to select them when moving, rotating, 
etc. them.  

Edit > Preferences - Line Widths Tab 
Any of the values can be changed. The screen will need to be refreshed to see the changes. 

Normal connections - controls the width of connections as seen/printed on the schematic sheet (not the 
thickness of the corresponding tracks on the board which is controlled by the Wires > Attributes 
commands).  (Refer to the Edit > Preferences, Miscellaneous tab to control junction blob sizes.) 

Bus connections - controls the width of buses as seen/printed on the schematic sheet (not the thickness of 
the corresponding tracks on the board which is controlled by the Wires > Attributes commands). 

Symbol outlines - controls the width of lines used to draw symbols.  All symbols are updated. 
Attribute text - controls the width of line used to form characters in attribute strings. 
Non-electrical, drawing sheet lines - controls the width of lines used to draw the auto-generated drawing 

border. 
Non-electrical, drawing sheet text - controls the width of line used to form characters in the auto-generated  

drawing border. 
Non-electrical, annotation lines - controls the width of lines used to draw non-electrical items added in 

annotate mode. 
Non-electrical, annotation text - controls the width of line used to form characters in non-electrical text 

strings added in annotate mode. 

Edit > Preferences - Colours Tab 
This window controls the colours used to display the various items in the schematic. To change the colour 
associated with an item, select the coloured box alongside the item with a click of the left-hand mouse button.  
The Colour editor window appears. Select the new colour required, followed by OK. When the Properties 
window is closed the screen will be re-drawn to reflect the changes.  

Set classic scheme - when selected, the colours assigned to features will be the same as those assigned in 
the (old-style) flat style schematic editor – to make Ranger1, 2 or 3 users feel “at home”. 

Set modern scheme  - when selected, the colours assigned to features will be those assigned by default for 
the hierarchical schematic editor. 

Restore defaults -should be selected to restore the default colours as defined in the colours file.  
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Edit > Preferences - Version Control 
Used to define "versions" within the schematic. Up to 10 versions can be defined. Each version is given a name. 
Up to three upper or lower case characters can be used in the version name (case sensitive). For example: UK, 
USA, NZ, etc. 
One of the versions is the default or current selection as defined by the button alongside being enabled.  
"Versions" are used if: 

• specific sheets should be excluded when the schematic is compiled to a parts\wiring list.  
For example, the same schematic could be designed for UK or USA use. Because of the different 
mains voltages in use, you may require two mains input blocks, one for each version of mains input. 
The USA mains input sheet will need to be excluded when the UK version is compiled, and the UK 
sheet excluded from the USA version. 

• different value fields, outline fields, etc. are required on specific parts, connections or non-electrical text 
when the schematic is compiled to a parts\wiring list or plotted. 
In this example, the mains input sheet is essentially the same for the UK and USA version, but some or 
all parts may need to have different values assigned. In this case parts can be assigned a UK and USA 
value. When the UK version is selected, the schematic is displayed, compiled and plotted with the UK 
version attributes. When the USA version is selected, the schematic is displayed, compiled and plotted 
with the USA version attributes. 

• the same sheet will be repeated on an upper level in the hierarchy, but different values (or outlines, 
etc.) are required on parts in each instance. 
For example, the circuit may consist of three identical channels of circuitry, for three different frequency 
ranges Low, Mid and Hi. The only differences between each channel would be the values assigned to 
parts. The channel could be drawn once and placed three times on an upper level sheet. Three 
versions could be defined, called Low, Mid and Hi. Each instance of the channel would be assigned to 
a version (using the Structure > Set Version Override command), either Low, Mid or Hi. When viewing 
or plotting individual instances of the sheet, the values assigned will correspond to the values assigned 
for that particular version. 
For instance, if a resistor was assigned a value of 1K for the Low version, 10k for the Mid version and 
100k for the Hi version, when viewing or plotting the channel assigned as the Low version the resistor 
value will be set to 1k. When viewing or plotting the channel assigned as the Mid version the resistor 
value will be set to 10k, and when viewing or plotting the channel assigned as the Hi version the 
resistor value will be set to 100k. 

The Edit > Preferences, Compile Version Control window indicates whether each block is included or excluded 
from the compile process. The Symbol and Wires > Attributes > Edit commands or Non-Elect > Add Text 
commands are used to define different values for different versions of part, connection, non-electrical text, etc. 

Edit > Preferences  - Sheet size 
This window only appears if a sheet is being edited.   

Sheet size - used to select a sheet size for the circuit schematic.  Standard sheet sizes are listed, or a sheet 
size can be specified if User-defined is selected. 
A drawing border is automatically added to the sheet. It is made from non-electrical lines and text in 
Drawing sheet mode, which can be modified using the Non-Elec commands. If the border is removed, 
it is automatically re-generated the next time the circuit is modified. (The output routines use this border 
for scaling and selection purposes.) 
Sheets have been defined and added to the master library which contain additional border information. 
They can be copied to the design and the circuit diagram drawn on them, or the additional data pasted 
into the current block using the Region commands.  
Once the schematic has been started, the sheet size can be increased or decreased at any time. If the 
sheet is decreased, data may appear outside of the sheet.  This data cannot be selected until the sheet 
size is increased again.  

Edit > Preferences  - Compile Version Control 
Upto 10 versions of a schematic can be defined. This table indicates whether the current sheet should be 
included or excluded when the schematic is compiled to a parts\wiring list, depending on the version selected. 
The version names are defined via the Edit > Preferences, Version Control window. The names are "undefined" 
until a name is entered.  

Example: the same basic circuitry could be used in the UK and the USA, but the mains input circuit 
would have to be different to cater for the different power supplies in use. In this situation, a user block 
could be created for each of the input circuits, a UK input and a USA input.  
In the UK input SETUP, Sheet window, the block would be included in the UK version, but excluded 
from the USA version.  
Likewise in the USA input Setup, sheet window, the USA input would be included in the USA version, 



 

89 

but excluded from the UK version.  
When the schematic is compiled to a parts\wiring list, depending on which version is selected, only one 
of the input sheets will be used. (Refer to Edit > Preferences, Version Control to define which version is 
used when compiling.) 

View commands, schematic editor only 
View > Fast Part Tray 

Used to switch the fast part tray on/off. When switched on, the fast part tray appears to the left of the 
schematic editor window.  
It can contain a selection of parts chosen by the user for fast access during part placement. Parts do not 
have to be added to the fast part tray in order to be placed on the sheet, they can be placed directly from 
the library. 
When the fast part tray is switched on, four buttons at the top of the tray control what it contains as follows: 
Add Used to add parts to the fast part tray. Note: split parts cannot be added to the fast part tray.  

To add a part, drag it from the master or job library from the navigator pane, into the fast part tray. 
When a part is added to the tray from the master library it is copied into the design, even though it 
may not be added to the schematic. 

Delete Used to remove parts from the fast part tray. Select the part from the fast part tray, then select the 
Delete button. The part is removed from the tray.  
The part is not removed from the design library, it can be re-added to the tray using the Fast Part 
Tray, Add command. 

Empty Used to remove all the parts from the fast part tray. The parts are not removed from the design 
library. 

Sort Used to sort the parts in the fast part tray into numeric-alpha order. 
 

Using Parts from the Fast Part Tray 
Parts from the tray are selected when using the Symbol > Place command. The part appears attached to 
the cursor. Position and release it with a click of the left button. More parts appear until another part is 
selected from the tray, the right-hand mouse button is clicked or another command selected.   

Structure commands 
Used to control and view information relating to the overall schematic design. The commands available are 
context sensitive, so not all commands described will be available at the same time. 
The structure of the schematic can be displayed graphically by selecting Hierarchy from the schematic folder in 
the navigator window. A window opens showing a block diagram, where a block represents each schematic 
sheet. Any of the blocks can be selected to open them (or bring forward if already open). Note - if the design 
symbol is already open, then that will be brought forward as the symbol and its associated sheet cannot be open 
at the same time. 
In a “flat” schematic, the blocks are shown side by side, all on one level.  
Where a hierarchy has been created, the blocks are shown in their positions in the hierarchy. An example of a 
hierarchical design is shown in Figure 86.  

 

Figure 86 

Each box contains the name and identifier of the block it represents. For example if a block called amplifier 
occurred three times in the hierarchy, the first occurrence would be called amplifier.1, the second amplifier.2 and 
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the third amplifier.3.  
The boxes also contain the allocation offset for each block and the version override if assigned. By default the 
allocation offsets are set to zero (AO=0), refer to the Structure > Set Allocation offset command for details. A 
version override is only displayed if one has been assigned, refer to the Structure > Set Version override 
command for details. 

Structure > Traverse Up (not operational on current version) 
Used to travel up through the hierarchy one level at a time. (Greyed out unless a schematic sheet is being 
edited.)  
When selected the next level up in the hierarchy is opened/displayed and can be edited. (If the top level in the 
hierarchy is being displayed, nothing happens when selected.) 
When travelling up through the hierarchy there is only one possible path that will eventually return to the top 
level of the hierarchy.  
Use the Show Hierarchy icon to travel quickly up or down through many levels of the hierarchy. (Or select 
Hierarchy from the schematic folder in the navigator.) 

Structure > Traverse Down 
Used to travel down through the hierarchy one level at a time. (Greyed out unless a schematic sheet is being 
edited.) Because there are (or could be) many routes down through the hierarchy, the sheet to be viewed has to 
be selected. 
Once selected, select the symbol of the sheet you wish to view with a click of the left-hand mouse button.  
Use the Show Hierarchy icon to travel quickly up or down through many levels of the hierarchy. 

Structure > Locate in hierarchy tree (not operational on current version, select Hierarchy from the 
schematic folder in the navigator) 
Used to select and view/edit any sheet from the overall picture of the hierarchy. This method of travelling 
through more than one level in the hierarchy is quicker than using the Structure > Traverse Up/Down 
commands. 
Once selected, select the block that represents the sheet to be viewed/edited.  Note - if the design symbol of the 
selected sheet is already open, then that will be brought forward as the symbol and its associated sheet cannot 
be open at the same time. 
Structure > Set Version Override 
This command is only available when the hierarchy block diagram is open. It is used to control the versions of 
repeated instances of sheets, in order to allow variations for value fields, outline fields, etc., within each 
instance. 
For example, one design symbol might be placed many times on an upper level sheet. Although the actual 
circuitry is the same in each associated design sheet, the values assigned to certain parts may need to vary 
within each instance. The Set Version Override feature allows one sheet/symbol to be created, but multiple 
values to be assigned to parts within it. 
First a version name has to be assigned for each variant required (refer to Edit > Preferences, Version Control).  
Within the sheet, each part that requires a different value for each instance, should be assigned all the values, 
as described under the Symbol > Attribute > Edit command. Once this has been performed, proceed as follows: 
With the Hierarchy window open, select Structure > Set Version Override. A window appears listing all the 
versions that have been defined. Select the one required, followed by OK. A flag appears on the end of the 
cursor containing the selected version name. Point at and select the sheet that should be assigned this version 
name. The words VO=<versionname> will appear inside the sheet instance. 
Repeat this for each version required. When each of the sheet instances are viewed or plotted, they will display 
the values assigned according to their version name. 
Structure > Set Allocation Offset 
This command is only available when the hierarchy block diagram is open.  
Used to control the starting number for part references within a block, provided allocation has not already been 
performed. By default, parts are numbered or "allocated" sequentially from 1 upwards. 
There is sometimes a requirement to number parts within blocks from a specific number. For example, in a 
multi-channel design where each of the channels has been drawn in a separate sheet, part numbers in the first 
channel could start from 101, part numbers in the second channel from 201, part numbers in the third channel 
from 301, etc. This numbering system would help in part location, etc. Use the Alloc commands to actually 
allocate the part numbers. 
To set the allocation offsets, with the Hierarchy window open, select Structure > Allocation Offset. Fill in the 
values, using the following infromation to help you. 

Starting ident  the first part number required in the first block selected. 
Increment per block  the number to be added to the starting ident number for subsequent block 
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selections. 
To use the assigned values, select Auto-incrementing Assignemt - when selected a flag appears attached to the 
cursor containing the starting ident number. Select the block to be assigned that starting ident number. The 
allocation offset for that block is assigned and AO=0 is replaced by the appropriate number. The number in the 
flag on the end of the cursor is increased by the number specified in the increment per block parameter. 
Continue selecting blocks to assign the allocation offsets. Click the right-hand mouse button to cancel further 
allocation offsets.  
To use your own values, select Typed, a message along the bottom of the screen requests you to select the 
block that you want to set the allocation offsets for. Select one of the boxes. A window requests the Block 
allocation offset number. Type the starting number required followed by OK. The allocation offset for that block 
is assigned and AO=0 is replaced by the appropriate number. Continue selecting blocks and entering the 
numbers required.  

Identify commands 
Used to display an information balloon for selected items.  
Buttons within the balloon (where appropriate) allow the selected item to be located in the parts/wiring list or 
artwork editors. 

 

Figure 87 

Identify > X/Y 
Used to indicate the X and Y co-ordinates of a selected position. Once selected, move the cursor to the required 
position, then click the left-hand mouse button to display the X and Y co-ordinates of that position. (X = 
horizontal, Y = vertical.) Further positions can be selected, or the right-hand mouse button clicked to cancel the 
command. 

Identify > Instance  
Used to display information about selected parts or "instances". Once selected, select a part. A balloon appears 
pointing to the selected part, similar to that in Figure 87. 
If the instance has been allocated and also appears in the parts list and artwork editors, then a button in the 
balloon allows the part to be located in those editors.  
If the instance has been allocated and is an element from a multi-elementy part, arrow icon(s) appear in the 
balloon to allow other elements from that package to be located, including power symbols if used. 
The balloon is replaced by another, when another part is selected, or closed when the right mouse button is 
clicked to cancel the command, or another command is selected. 

IID  The internal identification number (or instance number) of the part. This number is assigned 
and used by Ranger in reports, in order to identify parts that may not have been allocated. 

Part ref If allocated, the part reference. 
EMC ID The EMC part group to which the part belongs if defined. 
Block The name of the block. 
X and Y The X and Y co-ordinates of the part's datum point on the sheet.  
Angle The part's rotation on the schematic sheet, with respect to its original library definition. 
Flipped Whether the part has been flipped on the schematic sheet, with respect to its original library 

definition. 
Type The type of schematic item (library part, primitive, etc.). 

Further parts can be selected, or the right-hand mouse button clicked to cancel the command. 
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Identify > Part Pin 
Clicking on a symbol pin will display the identity of the pin if the part is allocated and the net it is connected to.  
If the part pin can be located in the net list/artwork, then the popup balloon will contain buttons as shown in 
Figure 88, that allow the part pin to be located in the artwork and netlist editor views. 

 

Figure 88 

Identify > Connection 
Clicking on a connection segment that connects directly to an allocated symbol that can be located in the netlist 
(parts/netlist has to have been extracted), then a balloon window will display the net name and the net’s 
properties will be displayed in the properties pane as shown in Figure 89. 

 

Figure 89 

If the net can be located in the net list/artwork, then the popup balloon will contain buttons which will locate the 
associated net in the artwork and netlist editor views. 

Find commands 
Used to find specific items and X/Y positions.  

Find > X/Y 
Used to find a specific X and Y co-ordinate. When selected a window appears requesting the co-ordinates. Type 
them in, followed by OK. A balloon indicates the specified X and Y position. 
As soon as the left-hand mouse button is clicked, or the screen is re-drawn the balloon disappears. 

Find > Instance 
Used to find a specific part or "instance" by entering its internal identification number (IID). Instance numbers 
are typically used in parts/wiring list compilation report windows to identify un-allocated parts. 
When selected a window appears requesting the IID. Type it in followed by OK. The specified instance appears 
on the screen with a balloon to identify it.  
The balloon provides information about the instance – refer to the Identify > Instance command for details on 
the balloon. It remains open until closed by selecting the close X. 

Find > Part 
Used to find a specific part by its reference designator. Pin or gate references can be included in the name, in 
order to find a specific gate. 
For instance, if IC7 were a 7400, entering IC7 would find the first gate within IC7. Entering IC7c would find the 
third gate within IC7, whilst entering IC7.5 would find the gate containing pin 5 and its associated pins. 
A balloon identifies the specified part - refer to the Identify > Instance command for details on the balloon. It 
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remains open until closed by selecting the close X. 

Find > Signal Name 
Used to find a specific wire attribute with the name specified. The search is not case-sensitive, so entering 
CLOCK will find CLOCK, clock, Clock, etc.  
Note: this command finds wire attributes with the specified name on the schematic. This is different to the Find 
in schematic command that can be used by right-clicking on a net in the Nets folder from the navigator, which 
finds the nodes (IC1.5, etc.) in a particular net on the schematic. 
A balloon identifies the specified part - refer to the Identify > Instance command for details on the balloon. It 
remains open until closed by selecting the close X. 

Errorflag commands 
Used to find, describe and/or delete, error or warning flags posted by the electrical rules checking routine. 
(Electrical rule checking is accessed from the Tools > Electrical Rules Check command when a design sheet is 
open.)  

Errorflag > Next 
Used to locate the next occurrence of an error or warning flag. The flags are not necessarily found in the order 
listed in the electrical rule check report. 
When selected, the next error or warning flag is displayed on the screen and momentarily flashes. The flag 
remains highlighted until a mouse key is clicked or the screen refreshed. Each flag is highlighted in turn when 
Errorflag > Next is selected, until each one has been shown. If Errorflag > Next is selected again, the flags are 
highlighted in order again until they are removed. 
Use the Erroflag > Describe command to display the error/warning text.  

Errorflag > Delete 
Used to delete individual error or warning flags posted by the electrical rules checking routine. Deleting the flag 
does not clear the error it is indicating. 
When selected, point at the end of the stem of the flag and click the left-hand mouse button. The flag is deleted. 
Delete stays active allowing further flags to be deleted until the right-hand mouse button is clicked or another 
command is selected. Flags can only be restored by running the electrical rules checking routine again. 

Errorflag > Describe 
Used to display the error/warning the flag (posted by the electrical rules checking routine) is indicating. 
Once selected, point at the end of the stem of the flag and click the left-hand mouse button. The description of 
the error or warning appears in a window above the schematic. Describe stays active allowing further flags to be 
selected and described until the right-hand mouse button is clicked or another command is selected. 
The window containing the description is closed automatically when the right-hand mouse button is clicked or 
another command is selected. 

Errorflag > Delete All 
Used to delete all the error and warning flags posted by the electrical rules checking routine.  (Existing flags are 
automatically removed when the electrical rules checking routine is performed.) 
When selected, all the flags are deleted.  

Tools commands, schematic editor 
Tools > Electrical Rules Check 
Used to identify electrical rule violations on the active (open for editing) schematic sheet. If the check is 
performed on the top level sheet in a hierarchy then the check is performed on all sheets below it as well. 
When parts are made, each pin can be assigned one of thirteen logic types. The electrical rules checker is used 
to flag instances where pins with a certain logic type are connected to pins with the same, or a different logic 
type. 
An individual pin's logic type can be defined from within the schematic using the Symbol > Attributes > Edit 
command, but it is more efficient to define the logic types within the part itself. 
As one example of a check that can be performed, output pins connected to output pins can be flagged if 
required. The user chooses which checks are run as follows: 
Select Tools >Electrical Rules Check. A window appears, similar to the one in Figure 90, showing a table with 
the thirteen logic types listed down one side and along the top to form rows and columns. The box or "cell" that 
intersects the row and column indicates whether or not a check is performed according to its colour as follows: 

Yellow - Check, and flag a warning message  
Red - Check, and flag an error message 
Blue - Do not check 
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Figure 90 

For instance, the cell that intersects the output pin row and the output pin column is set to red by default. This 
means that when the check is run, if an output pin connected to another output pin is detected, an error 
message is given and an error flag placed on the offending connection. 
If the cell were changed to yellow, by selecting the cell, then a warning message and warning flag would be 
posted. If the cell were changed to blue, then the checker would not look for output pins connected together. 
By pointing at the cells and clicking the left-hand mouse button, the colours change. Set the colours of the cells 
according to the checks required. The original (or default) checking selections can be restored by selecting the 
Set Defaults button. 
Note: when checking for unconnected pins, Ranger is looking for a connection on the same sheet. This means 
that named connections that are only connected to a pin on another sheet will be flagged as unconnected, i.e. 
they are unconnected on the current sheet. 
When you are ready to run the checks, select the Run ERC Checker button. After a while, depending on the 
size and complexity of the circuitry on the sheet, a report appears on the screen listing details of the problems 
found. This list can be printed if required by selecting File > Print, or saved to a file by selecting File > Save As 
from the top of the window. Select File > Close to close the window. 
Use the ErrorFlag > Next command to locate the error or warning flags and the ErrorFlag > Describe command 
to display the actual error or warning message. 
Each time the check is performed, the previous error and warning flags are removed automatically. (They can 
be deleted manually if required using the ErrorFlag > Delete/Delete All commands.) 
To check for unused gates, use the Alloc > Show Freelist command.  
Unused pins can be listed from the wiring list editor. 

Tools > Parts/Netlist Extraction > Setup 
Used to define the rules that the Ranger Parts + Nets extraction routine (Tools > Parts/Netlist Extraction > 
Ranger Parts + Nets) uses.  
It is important that these options are set to suit your requirements or the resultant parts/wiring list may not be 
what is expected. When selected a window similar to that in Figure 91 appears. 
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Figure 91 

Signal name extraction mode: 
Flattened when the parts/wiring list is extracted, signal names assigned to connections will be treated as 

global connections, so all connections with the same signal name will be linked together, 
including across sheets. 

Hierarchical when the parts/wiring list is extracted, signal names assigned to connections will be treated as 
local to the sheet they are used within, unless block I/O ports have been attached to them and 
the corresponding symbol pins connected at the upper level in the hierarchy. 

Ranger parts list updating rules:  
When a parts list is produced from the schematic for the first time (or if the parts list has been deleted), then 
the parts list contains the outline and ordercode field attributes as assigned within each part on the 
schematic sheet. 
However, on subsequent extractions it is not always desirable that this happens. In order that the user 
controls what happens, the following choices are available. 

Update component outline  
Never with Never selected the component outline field is not updated when the parts list is extracted. 

This means the outline called up in the parts list may be different to that called up by the part 
on the schematic. If there is a difference a warning is posted when the parts list is extracted. 

On unplaced parts  with On unplaced parts selected the component outline field is not updated when the 
parts list is extracted if the part is already placed on the artwork (the part's X/Y co-ordinates in 
the parts list are not set to 0,0). However, if a part has not been placed on the artwork (X/Y 
co-ordinates are set to 0,0) then its outline field is updated. 

Always  the component outline field is always updated when the parts list is extracted. This means the 
outline called up in the parts list at parts list extraction time will be the same as that called up 
by the part on the schematic. (It is possible to change the outline in the parts list or artwork 
after the extraction, but it will always revert back to the outline defined by the schematic part 
when the parts list is extracted.)  

Update ordercode  
Never with Never selected the ordercode field is not updated when the parts list is extracted. This 

means the ordercode called up in the parts list may be different to that called up by the part on 
the schematic.  

On unplaced parts  with On unplaced parts selected the ordercode field is not updated when the parts 
list is extracted if the part is already placed on the artwork (the part's X/Y co-ordinates in the 
parts list are not set to 0,0). However, if a part has not been placed on the artwork (X/Y co-
ordinates are set to 0,0) then its ordercode field is updated. 

Always  the ordercode field is always updated when the parts list is extracted. This means the 
ordercode called up in the parts list at parts list extraction time will be the same as that called 
up by the part on the schematic.  

Tools > Parts/Netlist Extraction > Ranger Parts + Nets 
Used to extract a parts and wiring (net) list from the schematic for use by the Ranger layout routines. There is a 
setup window (Tools > Parts/Netlist Extraction > Setup, described above) that controls how the extraction 
routine works and this MUST be set to suit your requirements prior to using the extractor to ensure the extracted 
parts/wiring list meets your requirements. 
Note: Once the parts/wiring list has been extracted it is always worthwhile opening the parts and wiring lists from 
the Navigator, as this will highlight errors that must be corrected before starting the artwork layout. 
If versions have been defined for this design ensure the required version is selected before extracting the 
parts\wiring list (Edit > Preferences, Version Control window).  
Also ensure all the sheets are included or excluded as required (Edit > Preferences, Compile Version Control 
window).  
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Only the parts and connections from allocated parts are extracted. A warning is posted and added to the 
extraction report if unallocated parts are found.  (The extraction report will be found in the design’s Logfiles 
folder, it’s called compile. 
The Alloc > Unallocated Check command can be used to reveal unallocated parts prior to the extraction. 
The parts and connections lists are updated automatically, so there is never any need to delete the parts and 
wiring list. Note: once a layout has been started, the parts list contains the positional information of the parts on 
the layout, so NEVER delete the parts list unless it is intended to start part placement from scratch again.  
The parts and wiring lists produced from the schematic should always be checked to ensure they contain what 
you think they contain. 
When the parts/netlist is extracted, the required component outlines (that are not already in the job) are 
imported to the job from the master component outline library. 
To extract the parts/wiring list, select Tools > Parts/Netlist Extraction > Ranger Parts+Nets.  
If any of the following conditions occur, a report is posted but the parts/wiring list is still produced. It is up to the 
operator whether any remedial action is taken and a parts/wiring list extracted again.  

* Unallocated parts - the unallocated parts are not included in the parts/wiring list - investigate and 
correct if appropriate. 

* An outline that is called up for a part that is different to an outline already placed on the layout for that 
part. Typically caused when the layout has been started and an outline has been swapped on the 
layout. The Tools > Parts/Netlist Extraction > Setup window controls whether outlines are updated - 
investigate and correct if appropriate. 

* Pin numbers that appear more than once and are connected to different connections – investigate and 
correct. 

* A connection that has different signal names assigned to it – investigate and correct. 
* Signal names, outline fields or value fields that are too long for the Ranger layout facilities. The names 

are truncated - investigate and correct if appropriate. 
* Single node nets (connections that start, but do not become attached to another pin)  – investigate and 

correct. 
* Allocated parts that have a different pin number allocation to the parts defined in the library - de-

allocate, then re-allocate those parts. 
* Allocated parts that have a different number of pins or gates to the parts defined in the library use the 

Symbol > Replace command to update the part. 
* Excluded blocks - nothing from excluded blocks will appear in the parts\wiring list – check this is what 

is required. 
* Version - if versions have been defined, the version used is reported – check this is what is required. 
* Signal names that have been hidden (can cause connectivity issues that you may be unaware of), 

always best to keep them visible. 
If a warning window is posted, the warnings should be investigated and corrected where necessary, then the 
parts/wiring list extracted again.  
The parts and netlist (wiring list) can be viewed/edited from the navigator pane, select the Parts & Nets folders 
from the design. 

Tools > Parts/Netlist Extraction > User Defined Extraction 
Used to extract attribute information from the schematic in a user-defined format. 
A program must be written in the Seetrax generic design extraction language (Genex) that will extract the 
information from the schematic, for instance a list of the part names and order codes. This program must have a 
filename with a .GEX extension and exist in the sub-directory: ..\seetrax\XL Designer\genex 
 This program produces an ASCII output file. 
The programme can also be configured to call up a secondary program that can be written in any language 
familiar to the user, for instance 'C', BASIC, PASCAL, Assembler, etc. The secondary program will use the 
ASCII data produced and manipulate it into any format required and produce a second output file. The 
secondary program must also exist in the ..\seetrax\XL Designer\genex sub-directory. 
Some examples are provided, these are written in 'C'. These examples can be used as a guide when creating 
your own programs.  
Probes can be added to the schematic in order for simulation type outputs to include probe information. An 
example of probe construction is given in the worked example of the user guide. Only the PSPICE.GEX 
program that is supplied (not EXAMPLE3.GEX) uses the probe information. 
To use these examples, select Tools > Parts/Netlist Extraction > User Defined Extraction.  All the programs with 
a .GEX extension found in the genex folder are listed in this window. Select the program or "filter" required 
followed by Select. A window appears indicating which filter was selected and where the output files will be 
located. The View config button can be selected to view the program. 
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A name for the output file must be specified in this window and then Run selected. A window appears showing 
the data extracted. A file will also have been generated and placed in the folder indicated in the window. 

The Seetrax generic design extraction language 
The generic design extractor is an interpretative program module embedded within the hierarchical circuit 
schematic editor. The extractor allows the user to gain access to most design features and output them in any 
desired format. 
Selection and formatting of data for output is controlled by user written configuration files (.GEX file). As well as 
selecting and formatting output data, the extractor configuration files can also specify that a secondary output 
filtering program be executed. These secondary filter programs can be used to perform additional data 
processing, formatting, statistics generation etc., which cannot be performed by the built in low level interpreter. 
Configuration files - file names and location 

The generic design extractor configuration files must all end with a file name extension of  '.gex'. By default, 
the extractor expects to find configuration files in the MyDocuments/Seetrax/XL Designer/genex folder. By 
editing the .genex_path path directive in the circuit schematic configuration file (schema_attribs.txt), it is 
possible to relocate the generic extractor files to anywhere within the file system. 

Configuration files - file sections 
The configuration files consist of two main sections: 
Header This section contains directives for file path selection, secondary filter control, menu selection 

titles, etc. 
Code This section contains interpreted program code used for primary level access to the design 

data. 
Configuration files - file header directives 

The following directives may be included within the header section of a configuration file. 
.title  The text string that follows this directive is displayed within the filter selection window when 

the user selects the User Defined extraction routine. 
.scope The .scope directive is used to determine the application package that the .gex  file belongs 

to. Future releases of Seetrax XL Designer will contain generic extractor capability within 
other areas of the design system. The .scope directive enables an application to choose 
only the .gex files appropriate to itself. Currently, the only argument that may be given to the 
.scope directive is capture. If a configuration file does not have a .scope directive, the file is 
always made selectable. 

.filter By giving the name of an executable file as an argument to this directive, the  extracted 
data can be additionally filtered and formatted into the required final format. External filter 
programs can be written in any language familiar to the user. If the filter cannot be found 
using the given name then the extension .exe will be added. External filters are invoked 
with the following sequence of parameters:- 

 raw_inputdata_path, output_paths, user_defined_args. 
.targetdir This directive controls where the extracted design data should be stored. The file path 

argument may contain environment variable references ($xx) and by using @name 
notation, it is also possible to refer to entries in the file called filepath. 

.outprompt The user is normally prompted for the name of the file to be created by a standard prompt 
saying 'Output  filename:'. The .outprompt directive permits the user to  assign different 
prompt messages. Also, by including more than one .outprompt directive, the user will be 
prompted for multiple output file names. This may be needed by external filter programs 
requiring more than one target filename.  
No more than two output file names are permitted in the current release of the software. 

.userarg1(2)  These directives allow the user to pass up to two additional arguments to external filtering 
programs. 

.format This directive marks the start of the interpreted code section. The interpreted code 
language is described further on. 

.exdepth The .exdepth directive controls the type of  net extraction performed on the design. 
Permitted values are 'parts' and  'primitives'. The default value is parts. In parts mode, 
extracted nets will not contain nodes that are associated with library primitive symbols. 
primitives mode outputs all nodes regardless of type. 

.endformat This directive marks the end of the interpreted code section. 
 
Interpreted code - concepts 

Before the language of the interpreted code section can be described, the reader must understand some of 
the terminology that will be used. 
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context Within the generic design extractor, the term 'context' means a collection of data items of 
identical type. For example, in the schematic editor the 'instances' context means a list of all 
instances (symbols) within the design tree being extracted. 

context_converter A context converter takes data of one type and creates another context from it. 
Special keywords in the interpreted language cause data in the current context to be 
converted to a new context for further data extraction. 

iteration Because a context may contain many data items, when a context conversion is requested, 
the code interpreter will iterate on each data member of the source  context list converting 
the data item to the target context and executing the associated code block for each 
converted item. 

datavar  A datavar keyword is a reference to a data member within a context. Datavar keywords are 
encountered in data output statements and conditional skip statements. 

Interpreted code - language syntax 
The interpreted code has the following structure: 

{ outer_level_context_key 
                        { code_block 
                        } 
} 

A code block is formatted as follows: 
data_output_statements 
context_conversions 
skip conditions 
                            . 
                            . 
data_output_statements 
context_conversions 
skip conditions 

 
A data output statement is formatted as follows: 

output "format_string" datavar datavar .. datavar 
 
A context conversion is defined as follows: 

context_conversion_key 
              { code_block 
              } 

 
A skip condition is defined as follows: 

skipif datavar == "stringvalue"  
                               or 
skipif datavar != "stringvalue" 

 
A true skip condition causes execution to skip to the end of the currently executing code block. The == 
operator will cause a true skip condition on equivalent strings. The != operator will cause a true skip 
condition on differing strings. 
If you need to skip execution to a point before the end of  the currently executing code block, place a { 
character before the skipif  directive, and a } character just before the statement you wish to skip to. 
The C escape sequences are: 

\a alert (bell) \v vertical tab 
\b backspace \' single quotation mark 
\f formfeed \" double quotation mark 
\n newline \\ backslash 
\r carriage return \ddd ASCII character in octal notation 
\t horizontal tab \xdd ASCII character in hex notation 
%% a single % sign 



 

99 

 
A format specification has the following form: 

%[flags][width]type 
Each optional field of the format specification is a single character or a number signifying a format option. 
These fields control width and other aspects of formatting. 
Flags The flags determine justification of output and control the printing of signs, blanks, decimal 

points, and octal and hexadecimal prefixes, as shown in the following list. 
Flag Meaning 
- Left-justify numeric output. Default is right justification. 
+ Precede output value with sign (+ or -) if output is of signed type. By default, a 

sign appears only for negative signed values (-). 
0 Write zeroes until a minimum width is reached. If 0 and - appear, the 0 is 

ignored. If 0 is specified with an integer format (i, u, x, X, o, d), the 0 is ignored. 
The default is no padding. 

blank ('  ') Precede the output value with a blank if the output is signed and positive. The 
blank is ignored if both the blank and + flags appear. The default is no blanks. 

Width The width field contains a non-negative decimal integer that specifies the minimum number of 
characters printed.  
If the number of characters in the output is less than the specified width, blanks are added to 
the left or the right of the output value (depending on whether the - flag is used) until the 
minimum width is reached. If width is prefixed with a 0, zeroes are added until the minimum 
width is reached. (This is not useful for left-justified numbers.) 
The width specification never causes a value to be truncated. If the number of characters in 
the output value is greater than the specified width, or width is not given, all characters of the 
value are printed. 

 
Type The type character, which appears after the last optional format field, determines how the 

associated argument is converted: 
d,i = integer : signed decimal 
u = integer : unsigned decimal 
o = integer : unsigned octal 
x = integer : unsigned hexadecimal using lowercase for 'a' - 'f' 
X = integer : unsigned hexadecimal using uppercase for 'A' - 'F' 
s = string 

Interpreted code - reserved words 
The interpreter reserves only two keywords for special use. These are the data output keyword output, and 
the conditional skip function skipif. All context conversion and data reference key words are defined by the 
application from which data is being extracted. 

Interpreted code - data output directive 
The data format string for the output directive is formatted identically to the format strings used by the 'C' 
language printf function. Each datavar to be printed must have a corresponding format conversion 
character in the format string. The format conversion character must  correctly match the type of data being 
referenced. Unexpected results will occur if there is a  mismatch. The interpreter does not check for 
syntactically correct output format strings. The  user must refer to the data variables section of the context 
descriptions to ascertain the type of a data variable. 

Interpreted code - skip  directive 
The conditional skip  directive always compares data values as character strings. If a data variable is of 
integer type or double precision type, it is converted to a string before comparison  with the right-hand string 
argument. Because of round off errors etc. it may be difficult to achieve correct comparison of double 
precision data variables. 

Circuit schematic data extraction - contexts 
The following contexts are defined for the circuit schematic editor. 
design The 'design' context represents the entire schematic design hierarchy. The 'design' context  

keyword is the only keyword permitted in the outer_level_context_key position of  the 
interpreted code body. It defines the starting point for all subsequent context conversions and 
data extractions. 

instance The 'instance' context consists of all symbols instantiated within the design hierarchy. This 
includes library primitives, placed power blocks and library component symbols. In the current 
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version of the schematic capture program, user block symbols do not appear in this context. 
parts The 'part' context is a list of all library part/split part items formed into a physical parts list. 
net The 'net' context is all the net data for the design hierarchy. 
netnode The 'netnode' context is all the nodes that make up one connection within a 'nets' context. 
attrib The 'attrib' context is a list of attributes attached to another design context. Attribute lists may 

be extracted from most other contexts. 
Circuit schematic data extraction - context conversions 

The following context conversions are defined as valid by the schematic capture system. 
From-context To-context context_conversion_keyword 
design  instance  instances 
design  part  parts 
design  net  nets 
instance  attrib  attribs 
part  attrib  attribs 
net  attrib  attribs 
net  netnode  nodes 
netnode  attrib  attribs 
netnode  part  part 

 
Circuit schematic data extraction - data variables within each schematic context 

Instance context 
Name Type Function 
iid int Internal identifier for the instance. 
ident int Allocated part number. 
symtype int Symbol type code. 
powerblock_flag int Set to '1' if the symbol is a placed power block. 
npins int Number of pins on symbol. 
blockname string The block name for the symbol. 

 
Part context 

Name Type Function 
iid int (as for instance) 
ident int (as for instance) 
symtype int (as for instance) 
powerblock_flag int (as for instance) 
blockname string (as for instance) 
prefix string Part prefix code (e.g. IC, R etc.) 

 
Net context 

Name Type Function 
netref  int Internal net reference code. 
nnodes int Number of nodes on the net. 
nattribs int Number of attributes on the net. 

 
Netnode context 

Name Type Function 
iid int Instance identifier for netnode. 
pinref int Pin reference on the instance. 

 
If the 'iid' value for a netnode is -1,  then  the net node relates to a part power pin that does 
not appear on the schematic diagram. In this case, the 'pinref' value has no useful function. 
The netnode can however be context converted to 'attribs' type for extraction of  the outline 
pin reference attribute, and also converted to 'part' type for determining the associated part 
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prefix, ident, etc. 
Attrib context 

Name Type Function 
atrid int Attribute name code. 
atrname string Attribute name text. 
atrvalue string Attribute value text. 

 
All attributes within the schematic capture package have an integer code associated with the 
attribute name text. The schematic capture system reserves attribute codes 0-31 for attributes  
having special predefined meanings. The attribute codes currently assigned within the 
reserved area are: 
0 Part identifier. Only used to determine where the attribute text will be displayed on 

the schematic sheet. The actual value is calculated from the contents of the part  
prefix and allocated part ident attributes. 

1 Part code prefix. Holds the prefix text that forms the start of a part ident. 
2 Component value. Holds the assigned value for resistors etc. When a design is 

extracted for Ranger, this field is appended to the end of the component name text  
and the resultant string becomes the part description field in the extracted parts list. 

3 Component outline. 
4 Bill of materials / part order code. 
5 Symbol swapping rule. Syntax not yet defined. 
6 Block name. Place holder for the displayed identity text for user defined blocks only. 
7 Symbol pin name. 
8 Pin number on a component outline. 
9 Pin swapping rule. Syntax not yet defined. 
10 Pin logic type used by the electrical rules checker. 
11 Data bus signal subscript number (bus  member number) for bus ripper symbols. 
12 Signal name. 
13 Ranger signal routing width code. 
When using the skipif condition to extract specific attributes from an attribute block, the atrid 
reference should be used to access attributes with reserved functions. For user defined 
attributes, the atrname string format should be used. 

Circuit schematic data extraction - examples 
The circuit schematic package is supplied with several example generic extractor configuration files, 
together with the source and object code for their associated external filter programs. 
Example 1, a component package counter. 

This example simply extracts a list of component outline attributes for all parts in a design. The list 
is then passed to a small external filter program where the list is totalled according to package 
type. 
The related files are example1.gex and ex1filt.c in the genex directory. 

Example 2, a part ordering list. 
This example will extract a list of components together with their associated order codes. The list 
is then processed by an external filter to yield a part ordercode / quantity type list. 
The related files are example2.gex and ex2filt.c in the genex directory. 

Example 3, a Spice nodal format extractor. 
This example shows how a list of symbol instances and a net list can be extracted from a design. 
The data is subsequently passed to an external filter where it is reorganised into a symbol nodal 
type format similar to that used by a Spice simulator. 
 The related files are example3.gex and ex3filt.c in the genex directory. 

Example 4, a parts and wiring list extractor. 
This example extracts the design part and net data, and then formats it into a layout similar to that 
presented within the Ranger parts and wiring list editor. 
The related files are example4.gex and ex4filt.c in the genex directory. 

Tools > EMC Attribute Tags 
Used to add EMC type attributes to parts, part pins and connections on the schematic. 
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This allows part pins and nets to be tagged with groups of attributes that allow more precise control over the 
Specctra and Electra auto-routers with regard to routing order, lengths, widths, clearances etc.  
Also, parts may be tagged with an attribute to define whether they are susceptible to interference, produce 
interference or are quiet. They can then be shown in different colours in the artwork editor to assist manual part 
placement. 

The ascii file emcmemb.txt held in the ..\XL Designer\data folder lists all the attributes currently understood 
by the Specctra/Electra router interface.  The keyword names (in the left-hand column), and the declared 
variable type words (dimension, int, double, stringlist etc.) should not be edited by the user, but the attribute 
descriptive text and default values may be freely edited. The information in this file appears when defining 
emcgroups. 
The file emcgroup.txt held in the ..\XL Designer\data folder may be edited to contain default groups of 
attributes that are available to new jobs. The supplied file currently only contains definitions for part and 
partpin attribute groups. Each design receives its own copy of the emcgroup.txt file as soon as the 
hierarchical circuit editor is activated. This can be viewed from the navigator pane, right-click the design 
name, select Design File Content Browser. A list of files will appear, locate: /config/emcgroup.txt 
Only the emcgroup.txt file currently being accessed is updated, so a change made within a job is not 
reflected in any other jobs or the master library. Likewise, changes made to the master library are not made 
to existing jobs. 

Tools > EMC Attribute Tags > Select Attribute 
Used to select and edit the EMC rules that will be assigned to either Parts, Part pins or Nets. When selected, 
the EMC Attribute selection & editing window appears.  
The window contains varying information, depending on whether Parts mode, Part pins mode or Nets mode was 
active. The content of each window is explained later on in this description. 
Figure 92 shows the Parts window. 
 

 

Figure 92 

The window is always divided into two, the top part lists the Attribute Groups that have been defined. The lower 
window lists the Group Members assigned to the selected group.  
To select a group, point at the emc group required in the upper part of the window, then select it with a click of 
the left mouse button.  
Buttons in the window allow new groups to be created, edited, deleted, etc. as follows: 
Close Used to close the window. Any group\attribute changes will be saved, but the active group is not 

changed from when the window was opened. (Use Select to change the active group.) 
Select Used to select one of the groups as the active group.  

The active group is the group applied to parts, pins or nets when they are selected with the Tools > 
EMC Attribute Tags > Apply command. 
Select the group to be made the active group, followed by the Select button.  
Use the Tools > EMC Attribute Tags > Apply command to add the selected group to a part, pin or net. 

Parts mode selection/editing window 
There are three default groups defined for parts: 

1 = Quiet 
2 = Interference producer  
3 = Interference susceptible.  
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When one of these groups is selected, the lower part of the window lists the attributes associated with that 
group, for instance the Part placement hi-lite colour. Any parts assigned to this group will have the colour 
specified when placed on the artwork. 
This facility indicates to the board designer which parts (by their colour) are susceptible to noise, which 
ones produce noise and which are quiet. 
The groups can be selected, modified, renamed, copied, deleted, or new groups defined using the 
commands across the top of the upper window. (However, new parts groups will have no practical use at 
the current time as there are no other attributes available.) 

Part pins mode selection/editing window 
There are three default groups defined for pins, they are: 

1 = Load 
2 = Source 
3 = Terminator 

When a group is selected the lower part of the window lists the attributes associated with that group. 
In the case of the Part pins groups, there is only one attribute, Net node type. This is used by the Specctra 
auto-router, to control the order in which nodes on a net are routed. Refer to the Specctra Reference Guide 
for details on this feature (Rule, <reorder_descriptor>. 
The groups can be selected, modified, renamed, copied, deleted, or new groups defined using the 
commands across the top of the upper window. (However, new part pins groups will have no practical use 
at the current time as there are no other attributes available to be inserted into the groups.) 

Nets mode selection/editing window 
There are no default groups defined for nets because of the variety of attributes that can be defined, so they 
have to be user-defined. Use the New button to create a group. 

New Used to create a new emcrules group. Currently this command should only be used whilst in Nets 
Mode, as the other types (parts & part pins) do not have a variety of attributes available. 
When a group is created, it can have a variety of attributes that control things like minimum track 
length, maximum track length, routing width, clearance, etc. When the group is assigned to a 
connection, the Specctra auto-router will obey the rules defined by the attributes within the group. 
Creating a new group: 
With Nets Mode active, select Tools > EMC Attribute Tags > Select Attribute, then New from the 
window. A window appears requesting a name for the new group. Enter a name required, followed by 
Create. 
Select the new group from the upper part of the window, then select the Choose Member Attributes 
button, to add members (attributes) to the group. A list of all the members appears, a small selection is 
shown here: 

Name Description Man ref Active 
  cct_minclr Minimum clearance 6-138 (STD) No 
  cct_rwidth Routing width 6-150 (STD) No 
  cct_minrlen Min routed length 6-19 (FST) No 
  cct_maxrlen Max routed length 6-19 (FST) No 
  etc. 

All the attributes that you require to be part of the group should be "activated" by double-selecting 
them. Yes appears in the Active field. 
For instance the new group could be required to define minimum and maximum track lengths for 
connections, in which case the "Min routed length" & "Max routed length" attributes should be made 
active.  
Name  is the internal name used by Ranger when referring to the attribute. 
Description describes what the attribute is used to define. 
Man ref indicates which page in the Specctra User's Reference manual (Nov 1995) describes 

this command. It also indicates which version of Specctra is required to implement the 
command.  (STD=standard version, DFM=STD + design for manufacturability, 
FST=STD + fast circuit rules, ADV=STD + advanced rules) 

Active indicates whether the attribute should be included as part of the group – select as many 
as required. 

Select OK when all the required attributes have been selected. The lower part of the window lists the 
attributes selected and the values assigned to them. These values can be changed as required, by 
selecting the Edit Member Attribute Values button then typing in the values required for each member. 
Once the window is set as required, select Close.  
To apply an Attribute group to a connection, select the attribute group required, and once highlighted, 
select the Select button. The window closes, and you are ready to apply the selected group to a 
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connection. 
Choose Member Attribute - Used to select the attributes within a previously defined group. With Nets Mode 

active, select Tools > EMC Attribute Tags > Select Attribute. The list of groups appears. Select the 
group to be edited, followed by Choose Member Attribute. The list of attributes appears from which 
attributes can be made active or inactive. Select OK to implement the changes. 

Edit Member Attribute Values - Used to edit the values of attributes in a previously defined group. 
With Nets Mode active, select Tools > EMC Attribute Tags > Select Attribute. The list of groups 
appears. Select the group to be edited, followed by Edit Member Attribute Values. A window appears 
allowing the values to be changed. Select OK to implement the changes. 

Copy - Used to copy a previously defined group. 
With Nets Mode active, select Tools > EMC Attribute Tags > Select Attribute. The list of groups 
appears. Select the group to be copied, followed by Copy. A window appears requesting a name for 
the new group. Select Create to copy the group.  
The groups can be modified using the Edit Member Attribute Values and Choose Member Attribute 
commands. 

Delete - Used to delete a previously defined group.  
If the group has been assigned on the schematic, then a warning appears on the screen indicating that 
if you proceed with the deletion, all the occurrences of the group will be removed from the schematic. 
You are given the options whether to proceed, to replace all the effected instances with another 
attribute, or to cancel the deletion. 
Select Tools > EMC Attribute Tags > Select Attribute. The list of groups appears. Select the group to 
be deleted, followed by Delete. A window appears to confirm which group was selected. Select Yes to 
remove the group or No if you chose the wrong group.  
If the group is currently in use on the schematic, then a warning appears to this effect. Follow the 
instructions in the window to either, cancel the deletion, proceed with the deletion and remove all the 
instances of that group from the schematic, or to proceed with the deletion and replace all the 
instances of that group with another group. Close the window as required. 

Rename - Used to rename a previously defined group. All occurrences of the group name in use on the 
schematic are also changed on the schematic. 
Select Tools > EMC Attribute Tags > Select Attribute. The list of groups appears. Select the group to 
be renamed, followed by Rename. A window appears showing the old name and requesting a new 
name for the group. Select the empty box and type the new name. Select Rename to rename the 
group. (Select Cancel to cancel the rename.) 

Import - Used to import the groups from the master library or another job, to the current schematic. 
When a job is created, a copy of all the emc groups in the master library are copied into the job. If the 
master library is updated after a job has been created, the jobs are not updated. Likewise new groups 
can be defined within jobs, which will not appear in the master library. 
When importing groups, all the groups within the selected job or library are imported unless they 
contain the same members and values. If a group has the same name, but different members, or 
different values assigned to the same members, then the group is imported. It would be wise to rename 
one of the groups after the import to avoid confusion. 
Select Tools > EMC Attribute Tags > Select Attribute. The list of groups in the current schematic 
appears (if any have been defined). Select Import . A window appears listing all the jobs in the current 
jobs directory that have emcgroups defined, followed by the master library (unless the master library is 
being edited).  
Select the job, or master library whose emcgroups you wish to import, followed by Import. All the 
emcgroups associated with either Parts, Part Pins or Nets, depending on which is selected, will be 
imported to the current schematic. 

Tools > EMC Attribute Tags > Parts Mode 
When selected, indicates that you wish to define or edit EMC attributes associated with parts. Any emc 
attributes that have already been assigned to parts will appear as flags attached to those parts.  

Tools > EMC Attribute Tags > Part Pins Mode 
When selected, indicates that you wish to define or edit EMC attributes associated with pins. Any emc attributes 
that have already been assigned to pins will appear as flags attached to the pins.  
Note: the Part Pins attributes can only be used by the Specctra auto-router. 

Tools > EMC Attribute Tags > Nets Mode 
When selected, indicates that you wish to define or edit EMC attributes associated with nets (connections). Any 
emc attributes that have already been assigned to connections will appear as flags attached to the connections.  
Note: the NETS attributes can only be used by the Specctra auto-router, although the Check artwork routine 
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does take into account the minimum clearance parameter on individual nets when specified. 

Tools > EMC Attribute Tags > Copy 
 Used to copy an EMC rule flag currently visible on the screen, then apply it to another part, pin or net, 
depending on which mode is active. 
Ensure the appropriate emc rule mode is selected, i.e. Parts mode, Part pins mode or Nets mode, then select 
Tools > Copy. Locate and select the flag required (point at the end point of the tail extending from the flag). The 
Tools > EMC Attribute Tags > Apply command becomes active, so simply select, with another click of the left 
button, the part, pin or net that the copied attribute should be applied to. 
Tools > EMC Attribute Tags > Apply - Used to add the EMC attribute currently selected, to the selected part, 
pin or net. 
Ensure the appropriate emc attribute type is selected, i.e. Parts mode, Part pins mode or Nets mode. 
Ensure the correct emc attribute has been selected, using the Tools > EMC Attribute Tags > Select Attribute or 
Copy command. 
Point at the part, pin or net that should have the emc rule added, then select it with a click of the left-hand 
mouse button. A flag containing the emcrule appears, with a tail extending to the selected part, pin or net. 
A Ranger format parts\wiring list should be extracted from the schematic diagram in order for the emc rules to 
be passed through to the artwork and Specctra auto-router. 

Tools > EMC Attribute Tags > Delete 
 Used to delete an EMC rule currently visible on the screen.  
Ensure the appropriate emc attribute type is selected, i.e. Parts mode, Part pins mode or Nets mode then select 
Tools > EMC Attribute Tags > Delete. Point at the end point of the tail extending from the rule required, then 
select it with a click of the left mouse button. The rule is deleted. 

Tools > Auto Symbol Generate 
Used to automatically generate the design symbol that would represent the current sheet in a hierarchy. 
Note: it is unwise to use this command if a symbol already exists and it is connected to, on an upper level sheet. 
Regenerating the symbol will probably move existing pins and cause them to become disconnected on the 
upper level sheet. 
If a symbol already exists, a window will query whether or not you want the existing symbol overwritten. 
To view the symbol, close the design sheet, then open the design symbol that will be found in the navigator, in 
the design’s Schematic, Design Symbols folder. 
The sheet must contain at least one block I/O port, or a symbol will not be created. The auto-generated symbol 
will contain one pin for each block I/O port on the sheet. The Edit > Preferences, Miscellaneous window controls 
the initial pitch of the pins in the symbol. 
(A symbol is automatically generated when the design symbol is first opened if ports have been added to the 
design sheet. If extra ports have been added to the sheet since the symbol was initially generated, the extra 
pins are added alongside the symbol when the symbol is opened. Tools > Auto Symbol Generate will redefine 
the symbol if permitted, and place the ports appropriately.) 
If ports are deleted from the sheet, the corresponding pins are automatically removed from the symbol. 

Symbol commands  
The symbol commands are used to add symbols (parts) and their associated attributes to the schematic sheet 
and then manipulate them. 

Symbol > Attributes 
Attributes are the text strings associated with parts, pins and connections. Changes made to part or pin 
attributes using these commands do not alter the attributes within the library part itself, they only affect the 
selected instance on the sheet.  
An internal flag is assigned to the attribute on the selected instance, so that if the library part itself is 
subsequently altered, these changes are not overwritten. If you want the changes to be overwritten use the 
Symbol > Attributes > Reset command. This also means that if parts have been allocated on the schematic and 
pin numbers are changed within the library part, the part has to be de-allocated, then re-allocated for the 
changes to be implemented. 
Once a part has been placed on the schematic sheet, changes made to attributes on the schematic take 
precedence over changes made to the library parts themselves. 
When Symbol > Attributes is selected, the following commands appear. 

Symbol > Attributes > Edit 
Used to edit an attribute (or attributes) associated with a part or a part pin and the signal names within a bus. 
Once selected, prompts appear in the status bar to indicate how to select items and provide messages when 
appropriate. 
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Using the left button to select an attribute string allows just that string to be edited, whilst using the right-button 
to select a part by its datum or a part pin, introduces a window containing all the attributes associated with the 
selected part or pin.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
If changes are made within the window select OK to implement the changes, or Cancel to forget the changes. 

Part attribute window 
The part attribute window (Figure 93) lists the attributes that have been defined for the part, the values 
assigned to the attribute, whether they are visible and their height.  
If the field is optional, it may be deleted if required.  
Not all of the attributes have values assigned to them.  
If an asterisk (*) precedes a Name field entry (not the Value field), that attribute is a system attribute and 
should not be deleted as it is required by the program elsewhere. i.e. all the entries in Figure 93. 
If an asterisk (*) precedes a value field entry (not the Name field), that entry cannot be changed from the 
window. i.e. the Part ident in Figure 93. 
Changes made in this window do not affect any other parts. 

 

Figure 93 

Show Symbol Filled:  
Symbols can be displayed with a solid infill colour to make them standout on the sheet by ticking this box.  
(If an outline does not appear filled when this mode is activated, edit the symbol outline shape to ensure that it 
forms a closed path.) 
Infill Colour: 
If the symbol will be shown filled, choose the infill colour by selecting this box, then select the colour required 
from the colour palette window that appears. 
The infill will be displayed and output using this colour, whereas the symbol outline colour is controlled in the 
schematic output task configuration window. 
Attribute List Columns 

Name contains the reference name of the attribute. If a * precedes the name, this is a system attribute 
and used elsewhere in the program – removing it (if permitted) would have implications for other 
tools, such as the extracted parts list, gate swapping in artwork, etc. 

Value  contains the text string assigned to the attribute. The * in this field means it cannot be edited from 
this window – the values for part ident’s are controlled by the Prefix and Allocation commands. 
More than one version can be assigned to a value field. For instance, it may be required that a 
resistor has a value of 220k in UK designs, but 100k in USA designs. Alternatively different values 
may need to be assigned within each instance of a repeated sheet. 
The version names, and which version is currently active are defined in the Edit > Preferences, 
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Version Control window. The Structure > Set Version Override command is used to assign 
different values in repeated sheets. 
The value should take the following format when specifying multiple values: 
 versionname!attribute_value  versionname!attribute_value  versionname!attribute_value 
 where: 
 versionname is the version name assigned in the Edit > Preferences, Version Control window. 
 ! is the character defined for version control in the Edit > Preferences, Miscellaneous, window. 
 attribute_value is the value required for that version. 
Examples: 
 UK!220k  USA!100k 

This will give a value of 220k when displayed, plotted or compiled with the UK 
version selected and 100k with the USA version selected. 

Low!1k Mid!10k Hi!100k 
This will give a value of 1k when displayed, plotted or compiled with the Low version 
selected, 10k with the Mid version selected and 100k with the Hi version selected. 

It is possible to specify a default version value using the version name *. So for example: 
UK!220k  USA!100k  *!500k  

will produce 220k if the UK version was selected, 100k if the USA version was 
selected and 500k for all other versions. 

If the version control character is not used, then those attributes are unaffected by the version 
selection mechanism. 
If a normally visible attribute has no value for a selected version, i.e. it has no *! value then (null) 
will be displayed on screen where the value would normally be. The (null) string will not appear 
when the sheet is plotted. 
The version control character may be used in most part attributes (outline name, ordercode, value, 
etc.) in all user-defined attributes, in connection attributes (signal name) and in non-electrical text 
strings. 

Visibility this field controls whether the attribute is visible or not when the part is used on the sheet. 
Options are: 
Not visible  the attribute is not visible. 
Value only  the attribute's value field is visible 
Name +Value  the attribute's name and value field is visible 

Height controls the height of the attribute when it is visible. 
Deletable indicates whether the attribute is permitted to be removed from the part – this setting cannot 

be changed. 
Note: if a system attribute (indicated by a * - value, outline, order code, etc.) is deleted, adding 
a user-defined attribute with the same name does not make it a system attribute, so it will not 
be recognised as such. For example, the value assigned to a user-defined attribute named 
“Order code” will not appear in the parts list. To add a system attribute, use the export/import 
of attributes commands (right-click on the schematic folder). 

To edit any of the above fields (except Deletable) select the attribute then the Edit button. Change the 
details as required followed by OK. 
To delete any of the deletable attributes, select the attribute then the Delete button.  
Default part attributes 
The default settings for new parts are controlled from the schema_attribs.txt file, held in the Configuration 
Data Directory (MyDocuments/Seetrax/XL Designer/Data by default). 
Part ident refers to the reference designator (e.g. R1, R2, IC1, etc.). The actual characters are not 

displayed in this window as they are controlled from the Alloc menu. 
Prefix controls the letters in front of reference designators, for example IC, R, C, etc. A prefix must 

be supplied. Upto 16 alpha-numeric characters can be used, in any order. This field is not 
normally visible as the part ident is more useful. 

Outline controls the physical outline that is used for the part in board layout. An outline name must be 
given in order for a parts and wiring list to be produced in the correct format for board layout. 
Upto 16 alpha-numeric characters can be used, in any order. The outline can be created just 
prior to artwork design. 

Value this field is optional, but typically contains the part type, i.e. 74LS00, 100k, etc. When filled in, 
the gate and pin swapping routines use this field to determine equivalent parts. Upto 16 alpha-
numeric characters can be used, in any order. 
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Symswap this field is optional, but must be filled in if gate swapping will be required on the layout.  
Equivalent symbols are usually defined within the library part, using the Attributes > Symbol 
Swap Rule command - this field will therefore be filled in automatically.  However, the field is 
either left blank or set to: 
G0 gate swapping not permitted. 
G1 gate swapping permitted between equivalent symbols within the part. 
G2 gate swapping permitted between equivalent symbols within the part and with other 

identical parts. 
Order code this field is optional. It is inserted into the parts list if present. 
Any other attributes are user defined.  
User-defined attributes are added by selecting Add attribute button, then filling in the appropriate details.  
To force a user-defined attribute to appear in the part attribute window when a part is created, edit the file 
schema_attribs.txt, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data by 
default). This file also controls the default height, visibility and names for all attributes. 
Pin attribute window 
A pin attribute window (Figure 94) lists the attributes that have been defined for the pin, the values assigned 
to the attribute, whether they are visible and their height. If the field is optional, it may be deleted if required.  
If a * precedes the Name, this is a system attribute and used elsewhere in the program – removing it (if 
permitted) would have implications for other tools, such as the electrical rules checker. 
If an asterisk (*) precedes a Value field entry (not the Name field), that entry cannot be changed from the 
window. i.e. the Outline pinref value in Figure 94 which is controlled by the Allocation commands. 
Changes made in this window do affect any other parts. 

 

Figure 94 

 
Note: If the symbol of a sheet is placed on a higher level sheet, and the pin name attribute is edited, the new 
name will appear against the block i/o pin when descending into the schematic sheet associated with the 
symbol. 
An iopin attribute that is overriden by an attribute on a higher level instantiation will always show the overridden 
value when the sheet is displayed. The value may still be edited on the sheet, but the override value will still be 
displayed. 
Switching to the symbol of the sheet will show the attribute value without the effect of any higher level override. 
The value displayed in this mode is the value displayed against the pin for any new instantiations of the symbol. 
Over-ridden attributes can be reset to their original values, using the Symbol > Attributes > Reset command. 
When re-setting the attributes of design symbols in a hierarchy, the attributes should be reset at the upper level. 
Attribute List Columns 

Name contains the reference name of the attribute. If a * precedes the name, this is a system 
attribute and used elsewhere in the program – removing it (if permitted) would have 
implications for other tools, such as the electrical rules checker. 

Value contains the text string or value assigned to the attribute.  
Visibility controls whether the attribute is visible or not when the part is used on the sheet. Options are: 

Not visible - the attribute is not visible. 
Value only - the attribute's value field is visible 
Name +Value - the attribute's name and value field is visible 
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Height controls the height of the attribute when it is visible. 
Deletable indicates whether the attribute is permitted to be removed from the part – this setting cannot 

be changed. 
Note: if a system attribute (indicated by a *, i.e. Pin Name, Logic type) is subsequently 
deleted, adding a user-defined attribute with the same name does not make it a system 
attribute, so it will not be recognised as such. For example, the value assigned to a user-
defined attribute named “Logic type” would not be recognised by the electrical rules checker.  

To edit any of the above fields (except Deletable) select the attribute then the Edit button. Change the 
details as required followed by OK. 
To delete any of the deletable attributes, select the attribute then the Delete button.  
Default pin attributes 
The default settings for new pins are controlled from the schema_attribs.txt file, held in the Configuration 
Data Directory (MyDocuments/Seetrax/XL Designer/Data by default). 
Outline pinref indicates the pin number of the pin. This pin number is linked automatically to the 

physical pad with the same pin number. Pin numbers can only be changed from within 
the library part or by allocation. Where the pin selected is an element from a multi-
element part, then all the pin numbers for that pin are shown, separated with a | sign. 

Pin name indicates the optional name assigned to the pin, for instance WE, CS, DI, etc.  Upto 16 
alpha-numeric characters can be used, in any order. 

Logic type indicates the logic type of the pin. By default it is set to Unspecified port. The electrical 
rules checker refers to this information when checking the schematic for errors. Selection 
is made from the arrow alongside. 

Pin swap rule indicates the pin group the pin belongs to. On the layout connections can be swapped 
between any pins within a gate or part that belong to the same group.  Group numbers 
run from 0 to 6. Pins within group 0 are not swappable. Equivalent pins are typically 
defined within the library part, using the Termianls > Set Pin Swap Rule command.  

Any other attributes are user defined. User-defined attributes are added by selecting Add attribute button, 
then filling in the appropriate details.   
To force a user-defined attribute to appear in the pin attribute window when a part is created, edit the file 
schema_attribs.txt file, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data 
by default). 
This file also controls the default height, visibility and names for all attributes. 

Symbol > Attributes > Move 
Used to move an attribute associated with a part or a part pin. 
Once selected, point at the attribute to be moved, then click the left-hand mouse button. As the cursor is moved, 
the selected attribute is seen attached to it with a line extending to the part or pin it belongs to. Position the 
attribute and release it with a click of the left-hand mouse button. 
As the attribute is being moved, it can be rotated by 90 degrees by pressing the <rotate part> special function 
key. 
Clicking the right-hand mouse button whilst the attribute is being moved, restores it to its original location. 
Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out how close you have to be to an item to select it. 

Symbol > Attributes > Rotate 
Used to rotate an attribute associated with a part or a part pin. Attribute strings can either be placed horizontally 
or vertically.  
Once selected, point at the attribute to be rotated, then click the left-hand mouse button. The attribute string 
rotates by 90 degrees. If it is rotated again, it returns to its original orientation.  
Attribute strings can also be rotated as they are being moved, by pressing the <rotate part> special function key. 
The Edit > Preferences, Miscellaneous window, Rotated text display mode parameter controls the orientation of 
rotated characters. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it 

Symbol > Attributes > Hide 
Used to hide (make invisible) an attribute associated with a part or a part pin. 
Once selected, point at the attribute string to be hidden, then click the left-hand mouse button. The attribute is 
hidden. 
It can be restored to view if the Symbol > Attributes > Edit command is used on the part or pin, and the attribute 
made visible again. 
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The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Symbol > Attributes > Delete 
Used to delete an attribute associated with a part or part pin. 
Once selected, point at the attribute string to be deleted, then click the left-hand mouse button. The attribute is 
deleted. User-defined attributes can be added again using either the Symbol > Attributes > Add or Symbol > 
Attributes > Edit commands. System attributes can be restored using the Symbol > Attribute > Reset command. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Part references (part idents) or pin numbers (outline pinrefs) cannot be deleted.  

Symbol > Attributes > Add 
Used to add a user-defined attribute to a part or a part pin.  
More than one version can be assigned to the attribute. Refer to the Symbol > Attributes > Edit command for 
details. 
Once selected, point at and select the part or pin to which the attribute will be added. A window appears, enter 
the name of the attribute and the associated value field. Change the height and visibility of the attribute as 
required. (Refer to the Symbol > Attributes > Edit command for details on these attributes.) Select OK to close 
the window. As the cursor is moved, the new attribute is seen attached to it with a line extending to the part or 
pin it belongs to. Position the attribute and release it with a click of the left button.  
As the attribute is being moved, it can be rotated by 90 degrees by pressing the <rotate part> special function 
key. 
Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out how close you have to be to an item to select it. 

Symbol > Attributes > Reset 
Used to reset the attributes of the selected symbol to those found in the library part.  
When re-setting the attributes of sheet symbols, the reset command should be performed on the symbol in the 
upper level in the hierarchy, not on the block i/o ports in the schematic sheet. 
Part allocation information is not affected by this action. 

Symbol > Place 
Used to select parts from the current job, master library or other jobs ready for addition to the sheet.  
Once selected, scroll through the Navigator window, until the schematic folder containing the part required is 
located - this might be from the current job, the Masters folder or from another open job. 
If a part is selected with a click of the left button, it will be displayed in the Browser pane allowing it to be viewed 
and identified.  Once selected, moving the cursor across to the sheet will show the selected part and it can be 
released with a click of the left mouse button.  
Whilst being moved the part can be rotated in 90 degree increments or flipped by pressing the <rotate part> or 
<flip part> special function keys. 
After releasing the part, another part appears on the end of the cursor, which can be released in the same way, 
or the right hand mouse can be clicked to cancel it.  
If parts from the master library are placed on the sheet, copies of them are transferred into the job file 
automatically. 
The name of the part is displayed along the bottom of the screen. 
Commonly used parts can be added to the fast part tray for easy access. Refer to View > Fast Part Tray for 
details on the tray and its use. 
Once a part has been added to the sheet, it can be copied using the Symbol > Copy command.  
Refer to the Grid command menu to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out whether wire pick-up, etc. is enabled. 
When the part is placed on the sheet from the master library, its associated component outline is not imported to 
the job until the parts/netlist is extracted from the schematic. 

Symbol > Move 
Used to move parts that are on the sheet. Buses can also be moved using this command. 
Once selected, point at the datum of the part to be moved, then click the left-hand mouse button. As the cursor 
is moved, the selected part and its connections are seen attached to it. Position the part and release it with a 
click of the left-hand mouse button. Clicking the right-hand mouse button whilst the part is being moved restores 
it to its original location. 
As the part is being moved, it can be rotated in 90-degree increments or flipped by pressing the <rotate part> or 
<flip part> special function keys. 
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Note: connections can get scrambled if wire pickup is enabled when the part is released (use Undo, then disable 
wire pickup). 
To move a bus, point at its datum, which is displayed as a small circle or cross, and select it with a click of the 
left-hand mouse button. Move it as required, the adjoining connections stretch, then release it with a click of the 
same button. Clicking the right-hand mouse button before the bus is released cancels the move.  
Refer to the the Edit > Preferences, Miscellaneous window to find out whether wire pick-up is enabled, how 
close you have to be to an item to select it, etc. and the Grid menu command to find out whether grid snapping 
is active. 

Symbol > Rotate 
Used to rotate parts that are already on the sheet.  
Once selected, point at the datum of the part to be rotated, then click the left-hand mouse button. The part 
rotates by 90 degrees anti-clockwise each time it is selected. Note: connections can get scrambled if wire pickup 
is enabled during the rotation (use Undo, then disable wire pickup). 
Parts can also be rotated as they are moved, if the <rotate part> special function key is pressed. 
Refer to the Edit > Preferences, Miscellaneous window to find out whether wire pick-up is enabled and how 
close you have to be to an item to select it. 

Symbol > Flip 
Used to flip parts that are already on the sheet.  
Parts are flipped about their original y-axis, i.e. parts are turned left to right about their datum unless they have 
been rotated by 90 or 270 degrees first, in which case they are turned top to bottom about their datum. 
Once selected, point at the datum of the part to be flipped, then click the left-hand mouse button. The part flips 
each time it is selected. 
Parts can also be flipped as they are moved, if the <flip part> special function key is pressed. 
Refer to the Edit > Preferences, Miscellaneous window to find out whether wire pick-up, etc. is enabled and how 
close you have to be to an item to select it. 

Symbol > Delete 
 Used to delete parts from the sheet. 
If an allocated part is deleted, existing part allocations are unaffected. Subsequent automatic allocations will use 
the spare part names and gates in numerical order. 
The part's connections remain after it has been deleted from the sheet. Another part could be moved and 
released with its pins over the ends of the connections and joined if wire pick-up is enabled in the Edit > 
Preferences, Miscellaneous window.  
Once selected, point at the datum of the part to be deleted, then click the left-hand mouse button. The part is 
removed from the sheet. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Busses can also be deleted using this command, but only the signal names and angled section of the bus and 
connecting line are removed. Point at the bus datum, which is displayed as a small circle or cross, and select it 
with a click of the left-hand mouse button.  
Points to bear in mind when deleting parts from a design where the parts have been placed on the artwork 

When removing parts from the schematic, never de-allocate the remaining parts in order to re-allocate 
using consecutive numbers. This will have the effect of swapping parts around on the artwork without their 
tracks (if routed). Instead, use part renumbering from the artwork editor, which will back-annotate to the 
schematic. 
Once a part has been removed from the sheet and the parts/wiring list extracted, the part will be removed 
from the artwork but its tracks and silk screen data (if present) remain in position on the artwork. 
If a part is removed from the sheet and another part is inserted with the same reference designator and 
different connections, the new part's datum will appear in the same position on the artwork as the old part's 
datum, along with its new connections. The old part's tracks and silk screen data (if present) will remain on 
the artwork until they are manually deleted. 

Symbol > Copy 
Used to copy a part that is already on the sheet. 
If attributes have been added/changed on the selected part, they are transferred to the copied part, including 
any EMC rules that have been defined for the part or part pins. (They can be reset using the Symbol > Attibs > 
Reset command.) 
Once selected, point at the datum of the part to be copied, then click the left-hand mouse button. As the cursor 
is moved, a copy of the selected part is seen attached to it. Click the right-hand mouse button to cancel the 
copy, otherwise position the part and release it with a click of the left-hand mouse button. Another part appears 



 

112 

on the end of the cursor, release it in the same way if it is required.  
Once the first copy has been released, its name, and the library it came from is displayed along the bottom of 
the screen. 
As the part is being moved, it can be rotated in 90 degree increments or flipped by pressing the <rotate part> or 
<flip part> special function keys. 
Click the right-hand mouse button to stop further copies appearing on the end of the cursor. Copy remains 
active until another command is selected, so another part could be selected and copied if required. 
Refer to the Grid menu commands to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out whether wire pick-up, etc. is enabled and how close you have to be to an item 
to select it. 

Symbol > Power Place 
Used to add power symbols to the sheet. Power symbols are associated to packages and can only be added 
after the package has been allocated.   
Once selected, a selection window appears to allow specific categories of parts to be added. Once selected and 
as the cursor is moved, a power symbol is seen attached to it. The part to which it belongs is highlighted in the 
Part Powerblocks list on the left-hand side of the schematic window.  
If you do not want to use the power symbol for that particular part, move the cursor across to the list and select 
one of the other parts with a click of the left-hand mouse button. The power symbol for that part appears 
attached to the cursor.  
Position the power symbol and release it with a click of the left mouse button. The next power symbol in the list 
appears on the end of the cursor, release it in the same way if it is required, or select another from the list.  
Power symbols appear on the end of the cursor until another command is selected or there are no more parts in 
the list. 
As the power symbol is being moved, it can be rotated in 90 degree increments or flipped by pressing the 
<rotate part> or <flip part> special function keys. 
Refer to the Grid menu commands to find out whether grid snapping is active. 
Notes on power symbols 

By default power symbols are not required. Pins that are defined as power pins within the part's attribute 
window are automatically connected to the appropriate power rails when the parts and wiring list is 
extracted from the schematic, even if a power symbol is specified within the part. 
However, it is often useful to view the schematic and be able to see which part pins are connected to the 
power rails. There are also requirements to use the same part on a schematic but connected to different 
power rails, for example op amps, or to connect a power pin via a pull-up or down resistor to the power rail. 
In these situations power symbols are used. 
A power symbol is created as a library primitive and called up from within the library part. Refer to the 
worked example in the manual for details on creating and using power symbols. 
N.B. If a power symbol is shown on the schematic, its pins must be connected to something, or the pins will 
be unconnected in the wiring list and on the layout. 

Symbol > Add to Artwork Tray 
When this mode is selected, clicking on schematic symbols that are related to parts list entries will cause those 
parts to be added to the artwork placement tray, whether or not the artwork editor is open. 
In this mode, all symbols related to parts already placed on the board, or already in the placement tray will be 
shown with a dotted outline.  Symbols for parts that can be placed in the tray will be shown with a solid outline. 
Note: once added to the placement tray the parts can only be removed using the artwork editor tools. 

Symbol > Alignx/Aligny 
Used to align parts in either the X or Y axis by their datum. Each command operates in the same way, except 
for the axis of alignment; the X axis is the vertical axis, and the Y horizontal. 
Once selected, locate the cursor in a position suitable for aligning the required parts and click the left-hand 
mouse button. A dashed line appears that represents the axis of alignment. Select each part to be aligned with a 
click of the right-hand mouse button. The parts move so that their datum lies over the axis line. 
The alignment axis can be moved by selecting another position with a click of the left-hand mouse button. 
Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out whether wire pick-up, etc. is enabled and how close you have to be to an item 
to select it. 

Symbol > Replace 
Used to replace a part on the schematic for another. 
This command is typically used to update blocks (parts) on the sheet that have been modified since they were 
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added to the sheet. (Parts on the sheet are not automatically updated when the part is modified.) This command 
can also be used to replace one part for a different part. 
Connectivity is maintained provided the old and new pins are in the same location. If the new pin(s) lie on top of 
a connection then they will become attached, irrespective of the setting for "Pick up wires during symbol move" 
in the Edit > Preferences, Miscellaneous window. 
Part allocation information is lost. 
Attribute fields are reset to the values defined by the part in the library. 
Once selected, select the replacement part from the schematic folder in the navigator (from any design or the 
master library), it appears attached to the cursor. Move the part over the datum of the part to be replaced, then 
select it with a click of the left-hand mouse button. The part is replaced. 

Symbol > Logic Type 
Used to replace the symbol of a part with its DeMorgan graphical alternate - which is identical apart from its 
graphical representation. The alternative symbol is defined from within the part (Type setting in the toolbar).  
Once selected, point at the part whose symbol is to be replaced, then click the left-hand mouse button, the 
symbol of the part is changed. 
If a message No alternative symbol available appears in the status bar, then the part does not have an alternate 
outline defined.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Symbol > Show Datasheet 
Used to display the web-page or file associated with the Data-sheet Address attribute for the selected part. 
Once this command has been selected, select a part on the sheet, the associated page will appear (assuming 
an Internet connection is available for access to web-based pages). If a page has not been associated with the 
part, a message indicating this will appear in the status bar. 

Wires commands 
These commands are associated with adding connections to the schematic along with connection attributes 
such as signal names, track widths and minimum clearance values for the artwork. 
Wires (or connections) can be made by inserting a connection between pins, or by attaching a connection to a 
pin and then adding a signal name attribute to it (Wires > Attributes > Add).  
Connectivity can also be formed by laying pins on top of one another or close to one another. The Edit > 
Preferences, Miscellaneous window controls whether or not this method of making a connection is enabled, and 
how close pins have to be to one another before the "connection" is made. 
When wires are attached to symbol terminals, the terminal cross disappears to indicate the connection is “made” 
or attached. 
When the parts/wiring list is extracted or compiled from the schematic (Tools > Parts/Netlist Extraction), a list is 
created of all the connected pins. It can either be compiled as a flattened schematic or a hierarchical schematic 
– this setting controls connectivity between sheets. 
If compiled as a flat schematic, every connection with a signal name is automatically connected to every other 
connection with the same name on the same sheet and any other sheet within the design. 
If compiled as a hierarchical schematic, then connections with signal names are regarded as making "local" 
connections on that sheet. They connect all connections with the same name together, but only within a sheet. 
They do not maintain connectivity between sheets. To maintain connectivity between sheets, block I/O ports 
have to be added to the connections on the sheet, and a connection has to be made between the appropriate 
pins on the symbol representing that sheet on the upper level in the hierarchy. 
For example, take four different sheets that are used in a hierarchical schematic. Each sheet  contains 
connections with a signal name ABC. To link all the ABC‘s between sheets together, a block I/O port has to be 
added to one of the ABC connections within each sheet, and given a name, for instance ABC (its sensible to 
use the signal name to avoid confusion). A design symbol has to be made for each sheet, which will contain a 
pin called ABC automatically (or whatever name was given to the port).  
Another sheet should be created (the top level sheet), and the symbols representing the four sheets placed on 
it. The pins called ABC on the symbols should be connected together to complete the global connections. If 
these connections were not added, there would be four separate ABC connections in the wiring list. 
Implicit power connections defined within parts make global connections, providing the library part is used 
somewhere in the design. 
Negated signal names can be added by preceding the signal name with the negation bar prefix character as 
defined in the Edit > Preferences, Miscellaneous window. 

Wires > Attributes commands 
Connection attributes are the text strings associated with connections, such as signal names, width codes.  
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Note: signals names within a bus can only be modified with the Symbol > Attributes > Edit command. 

Wires > Attributes > Edit 
Used to edit an attribute, or attributes associated with a connection. (Bus signal names can only be modified 
using the Symbol > Attributes > Edit command.) 
Once selected, if the attribute string to be edited can be seen, point at it then select it with a click of the left-hand 
mouse button. 
If the attribute string can’t be seen, point at the end or a corner of the connection, then select it with a click of the 
right-hand mouse button. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
If an attribute string was selected with a click of the left-hand button, a window appears containing the attribute 
string that can be modified. 
If a connection was selected with a click of the right-hand mouse button, then a window appears with all the 
attribute information associated with the connection. If changes are made within the window select OK to 
implement the changes, or Cancel to forget the changes. 
Connection attributes window 
The connection attribute window (Figure 95) lists the attributes that have been added to the connection, the 
value assigned to them, whether they are visible, their height and whether they can be deleted. 

 

Figure 95 

Attribute Fields 
Name contains the reference name of the attribute. 

If an asterisk (*) precedes a Name field entry, that attribute is a system attribute and reserved for 
use by the software.  If deleted and then subsequently required, they should be restored using the 
Wires > Attributes > Add command (not the Add Attribute button from the Attributes window which 
is used to add user-defined attributes.) 

Value contains the text string or value assigned to the attribute.  More than one version can be assigned 
to a value field, for instance to assign a signal name of CLOCK in UK designs, but URE in German 
(GDR) designs.  
The version names, and which version is currently active are defined in the Edit > Preferences, 
Version Control window. The value should take the following format when specifying multiple 
values: 

versionname!attribute_value  versionname!attribute_value  versionname!attribute_value 
 where: 

versionname is the version name assigned in the Edit > Preferences, Version Control window. 
! is the character defined for version control in the Edit > Preferences, Miscellaneous window. 
attribute_value is the value required for that version. 

Example: 
 UK!CLOCK  GDR!URH 
This will give a value of CLOCK when displayed, plotted or compiled with the UK version selected 
and URH with the GDR version selected. 
It is possible to specify a default version value using the version name *. So for example: 
GDR!URH  *!CLOCK  
will produce URH if the GDR version was selected, but CLOCK for all other versions. 
If the version control character is not used, then those attributes are unaffected by the version 
selection mechanism. 
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If a normally visible attribute has no value for a selected version, i.e. it has no *! value then (null) 
will be displayed on screen where the value would normally be. The (null) text will not appear 
when the sheet is plotted. 
The version control character may be used in most part attributes (outline name, ordercode, value, 
etc.) in all user-defined attributes, in connection attributes (signal name) and in non-electrical text 
strings.  

Visibility controls whether the attribute is visible or not. Options are: 
Not visible - the attribute is not visible. Note: connection attributes are assigned to a segment 

of wire, for this reason they can be difficult to restore to visibility as the same 
segment has to be selected to change the setting. 

 Value only - the attribute's value field is visible 
 Name+Value - the attribute's name and value field is visible 
 

Height controls the height of the attribute when it is visible. 
Deletable indicates whether the attribute is permitted to be removed from the part – this setting cannot 

be changed. 
Note: if a system attribute (indicated by a *, i.e. Signal name) is subsequently deleted, adding 
a user-defined attribute with the same name does not make it a system attribute, so it will not 
be recognised as such. For example, the value assigned to a user-defined attribute named 
“Signal name” would not be recognised by the parts/wiring list extractor.  Use the Wires > 
Attributes > Add command instead. 

To edit any of the above fields (except Deletable) select the attribute then the Edit button. Change the 
details as required followed by OK. 
Default connection attributes 
Routing width allows a width code to be assigned to the connection. Only numbers from 0 to 511 

should be used. These numbers correspond to the track widths table for the artwork 
design, so track widths can be defined at the schematic stage.  
By default width code 4 is used for signal connections and width code 11 for power 
connections.  
Track widths can also be changed at the layout stage if required. 

Signal name allows a name to be given to a connection. All connections with the same signal 
name on the same sheet are automatically connected together in the wiring list and 
therefore the layout. This means that connections do not have to be drawn on the 
sheet, making a less cluttered drawing. Upto 16 alpha-numeric characters in any 
order can be used. 
When the circuit is compiled into a parts and wiring list, it is configured as a flat or 
hierarchical schematic. If flat is selected, then all connections with the same name on 
all sheets are linked together in the wiring list. If hierarchical is selected, then like-
named connections between sheets are only connected if block I/O ports have been 
attached to them and the corresponding symbol pins connected at the upper level. 
(Refer to the Tools > Parts/wiring list extraction > Setup command for more details.) 

Minimum clearance allows a minimum clearance to be applied to the connection. The online DRC tools in 
the artwork editor and the artwork checking routines will use this value instead of the 
default minimum clearance applied to the job. 
Note: when the attribute is added the units will be included, for example: “Minimum 
clearance = 1.25 mm” they should not be removed if the value is subsequently 
modified as the wiring list extractor requires them to ensure the correct value is 
passed to the artwork editor/checking routines. 

Any other attributes in the window have been user defined. More attributes can be added if Add attribute is 
selected, but only the user-defined extraction tools will use them. 

Wires > Attributes > Move 
Used to move an attribute associated with a connection.  
Once selected, point at the attribute to be moved, then click the left button. As the cursor is moved, the selected 
attribute is seen attached to it with a line extending to the wire it is associated with. Position the attribute and 
release it with a click of the left button. 
As the attribute is being moved, it can be rotated by 90 degrees by pressing the <rotate part> special function 
key. (The Edit > Preferences, Miscellaneous, Rotated text display mode parameter controls the orientation of 
rotated characters.) 
Clicking the right-hand mouse button whilst the attribute is being moved, restores it to its original location. 
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Refer to the Edit > Preferences, Miscellaneous window to find out how close you have to be to an item to select 
it and the Grid menu command to find out whether grid snapping is active. 

Wires > Attributes > Rotate 
Used to rotate an attribute associated with a connection. Attribute strings can either be placed horizontally or 
vertically. The Edit > Preferences, Miscellaneous window, Rotated text display mode parameter controls the 
orientation of rotated characters. 
Once selected, point at the attribute to be rotated, then click the left button. The attribute string rotates by 90 
degrees about the centre of the string. If it is rotated again, it returns to its original orientation.  
Attribute strings can also be rotated as they are being moved, by pressing the <rotate part> special function key. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it 

Wires > Attributes > Hide 
Used to hide (make invisible) an attribute associated with a connection. 
Note: these hidden attributes can be difficult to select in order to make them visible/edit them in the future, so 
hide them with caution. (They can be restored to view using the Wires > Attributes > Edit command, but the 
segment associated with the hidden attribute has to be selected.) 
Once selected, point at the attribute string to be hidden, then click the left-hand mouse button. The attribute is 
hidden.   
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Wires > Attributes > Delete 
Used to delete an attribute associated with a connection. 
Once selected, point at the attribute string to be deleted, then click the left button. The attribute is deleted.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Note: use the Wires > Attributes > Add command to restore any deleted System attributes. 

Wires > Attributes > Add 
Used to add a system or user-defined attribute to a connection.  
There are 3 system wire attributes, which are: signal name, routing width and minimum clearance. The values 
assigned will be applied to the wire(s) in the artwork and used by the artwork checking routines.  
User-defined attributes allow your own attributes to be applied to a wire, these attributes are only accessed by 
the user-defined output tools (Tools > Parts/Netlist Extraction > User Defined). 
Once the command has been selected, point at the connection to which the attribute will be added, then click 
the left button. A window appears.  
Select the Type of attribute required. (If the connection has already had an attribute applied, only the available 
attributes and User defined will appear in the window.) 
Type the value of the attribute in the value field. If a name has previously been added, then that name will 
appear in the value field of the window automatically. It may be retained or modified.  

Signal names – alpha-numeric characters, in any order can be used.  Note: the wiring list and artwork tools 
have a maximum signal name limit of 16 characters, if more characters are used, the signal name will 
be truncated in the wiring list when the wiring list is extracted – a warning message is given. 
Negated signal names can be added by preceding the signal name with the negation bar prefix 
character as defined in the Edit > Preferences, Miscellaneous window. A bar is drawn over the signal 
name on the screen and in plots, the prefix character is not displayed. Note however that the negation 
bar is not used in the wiring list or artwork editors, when the prefix character will appear in front of the 
signal name. 

routing width – a default track size of  4 & 11 are used for signals and power rails respectively. If a different 
track code should be used, it can be applied here, specify the track code (0 to 511), not the actual size 
of the track. 

minimum clearance – a default minimum clearance value for all tracks on the artwork is used unless a 
specific minimum clearance value is assigned to individual wires. (Signal and power rails each have 
their own default minimum clearance which is assigned when the artwork is checked.)   
Enter the value required, the current units (as set when entering the schematic editor) will be used and 
displayed when the attribute is positioned.  
Note: when the attribute is added the units will be included, for example: “Minimum clearance = 1.25 
mm”. The units should not be removed if the value is subsequently modified as the wiring list extractor 
requires them to ensure the correct value is passed to the artwork editor/checking routines. 
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user-defined – enter the name for your attribute and also the value to be assigned to it. Only the user-
defined output tools (Tools > Parts/Netlist Extraction > User Defined) will access this information. 

Change the height and visibility of the attribute as required.  
Select OK to close the window. (Select Cancel if you do not want to add the attribute.) As the cursor is moved, 
the new attribute is seen attached to it, with a line extending to the connection it belongs to. Position the 
attribute and release it with a click of the left-hand mouse button. 
As the attribute is being moved, it can be rotated by 90 degrees by pressing the <rotate part> special function 
key. (The Edit > Preferences, Miscellaneous, Rotated text display mode parameter controls the orientation of 
rotated characters.) 
More than one version can be assigned to the attribute. Refer to the Wires > Attributes > Edit command for 
details. 
Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out how close you have to be to an item to select it. 
Clicking the right-hand mouse button cancels the new attribute. 

Wires > Insert Connection 
Used to insert connections. 
A parameter within the Edit > Preferences, Miscellaneous window controls whether connections are allowed to 
start in free space, or whether they must start on a pin or an existing connection. One end of a connection must 
be attached to a pin. 
Once selected, point at the starting point, which is usually a pin or an existing connection, then click the left-
hand mouse button. As the cursor is moved, a connection is seen attached to it. 
The connection either stretches like a piece of elastic, or horizontal and vertical lines stretch as you move the 
cursor - this is controlled by the Wire 0/90 Lock setting, accessed from the Wires drop-down menu or an icon in 
the toolbar.  
As the connection is stretched, corners can be inserted with a click of the left-hand mouse button. The 
connection can be terminated on a connection or a pin with a click of the left-hand mouse button. To release the 
connection in mid-air, a double click of the left button is required. 
When the connection is released, the terminal crosses representing the symbol pins disappear to indicate a 
connection has been made - if they remain, then the wire is not attached to the pin. 
Connections left hanging in mid-air should be given a signal name to make a connection to another connection 
with the same name.  
The Wires > Attributes commands are used to add signal names and other connection attributes. Refer to the 
details given previously under the Wires description for further information on named signals. 
Once inserted, the connection can be modified using the other Wires commands. 
Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out how close you have to be to an item to select it. 

Wires > Insert Bus 
Used to add bus type connections to the sheet, similar to those shown in Figure 96.  

 

Figure 96 

Once selected a window appears, similar to the one in Figure 97. 
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Figure 97 

Fill in the parameters as follows: 
Bus name The name used to identify the bus, i.e. DATA or A or D, etc. Upto 16 alpha-numeric characters can 

be used in any order. Note: the total maximum length for a signal name is 16 characters. 
Additional characters will get truncated when converted to a Ranger format wiring list (a warning is 
given). 
(If the signal names within the bus are not similar, or numbered, perhaps you want to add CLOCK, 
RESET, etc. into the bus, add the bus then change the signal names individually using the Symbol 
> Attributes > Edit command.) 
More than one version can be assigned to the bus name. For instance, you may require the bus 
name to have a value of D in UK designs, but DATA in German (GDR) designs. The version 
names, and which version is currently active are defined in the Edit > Preferences, Version Control 
window. The value should take the following format when specifying multiple values: 
 versionname!attribute_value  versionname!attribute_value  versionname!attribute_value 
where: 

versionname is the version name assigned in the Edit > Preferences, Version Control 
window. 

!  is the character defined for version control in the Edit > Preferences, 
Miscellaneous window. 

attribute_value  is the value required for that version. 
Example: 
 UK!D GDR!DATA 
This will give a busname of D when displayed, plotted or compiled with the UK version selected 
and DATA with the GDR version selected. 
It is possible to specify a default version value using the version name *. So for example: 

GDR!DATA  *!D  
will produce DATA if the GDR version was selected, but D for all other versions. 
If the version control character is not used, then those attributes are unaffected by the version 
selection mechanism. 
The version control character may be used in most part attributes (outline name, ordercode, value, 
etc.) in all user-defined attributes, in connection attributes (signal name) and in non-electrical text 
strings.  

Separator Up to two characters can be entered. The first character is placed between the bus name and the 
bus signal name. If a second character is entered it will be placed after the signal name. 

Bus signal The name given to the first signal in the bus. Upto 3 numeric characters can be used. 
Increment The number added to the previous signal name. This number will be used as the signal name for 

the next connection in the bus. 
Text height  The height for the names used on the bus connections. 
Examples: 

Bus name : DATA Bus name : DATA  Bus name : DATA 
Separator : () Separator : :  Separator :  
Bus signal : 0 Bus signal : 0  Bus signal : 0 
results in : DATA(0) results in : DATA:0 results in : DATA0 
 

Once the details have been entered, either Add Auto or Add Manual can be selected to add the bus.  
Add Auto should be selected when a row or column of pins will be connected to the bus. The bus signal names 
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will increment along the row or column in numerical order as specified in the window.  
Add Manual should be selected when the pins connected to the bus are not in a straight line, or the signal 
names do not increment in a numerical order along the row or column of pins. 
Add Manual  when selected, a flag appears attached to the cursor containing the first bus signal number. 

Select the pin that you wish to add the connection to, with a click of the left-hand mouse button. 
The number specified in the increment field of the window increases the number in the flag on the 
end of the cursor. Continue selecting the pins that are to be connected to the bus in the correct 
order. Click the right-hand mouse button when no more numbers are required. Move the cursor, 
the bus appears and stretches as the cursor is moved. 
As the bus is moved up and down or from side to side, the 45 degree segments change direction. 
Click the left button to release the bus when you are happy with its position. 

Add Auto when selected, a flag appears attached to the cursor containing the word first. Select the first pin 
in the required bus with a click of the left-hand mouse button. The word in the flag on the end of 
the cursor changes to last. Select the last pin in the required bus. Move the cursor, the bus 
appears and stretches as the cursor is moved.  
As the bus is moved up and down or from side to side, the 45 degree segments change direction. 
Click the left button to release the bus when you are happy with its position. 

The crosses that represent the symbol pins disappear when the bus is released to indicate a connection has 
been made to the pin – if they remain, then the wire is not attached to the pin. 
Connections can be added to the end of the bus if required using the Wires > Insert Connection command. Bus 
connections are automatically added at the bus width, as defined in the Edit > Preferences, Line widths window. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Wires > Add/Move Corner 
Used to add, or move existing corners in connections. This command can also be used to move a bus.  Once 
selected:  
Adding a corner Point at the connection, then click the right-hand mouse button. Move the cursor, 

the new corner is attached to it and the adjacent segments stretch with it. Release 
the new corner with another click of the same mouse button. (Click the opposite 
mouse button (left) to cancel the new corner.) 

Moving an existing corner Point at the corner, then click the left-hand mouse button. Move the cursor to move 
the corner and stretch the adjacent segments.  
The Wires > 0/90 degree lock command controls whether the adjacent segments 
move orthogonally or freely.  
Release the corner with another click of the same mouse button. (Click the opposite 
mouse button (right) to cancel the move.) 

Moving a bus Point at the datum point of the bus which is displayed as a small circle or cross, and 
select it with a click of the left-hand mouse button. Move it as required, the adjoining 
connections stretch, then release it with a click of the same button. Click the 
opposite mouse button (right) before the bus is released to cancel the move. 

Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous window to find out whether wire pick-up is enabled, how close you have to be to an item to select 
it, etc. 

Wires > Delete Connection 
Used to delete connections and busses. If the selected connection contains many branches, the connection 
between junction blobs or pins, whichever is shortest is deleted. 
Once selected, point at the connection and click the left-hand mouse button. The connection is deleted.  
The crosses representing symbol pins reappear when the attached wires are deleted. 
 
If there is difficulty selecting the connection, select the connection on a corner or end point. The trap distance 
defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to an item to select 
it. 
To delete a bus, point at its datum, which is displayed as a small circle or cross, and select it with a click of the 
left-hand mouse button. A window appears, indicate what you would like deleted: 
Remove bus symbol only  to delete the bus and the signal names. The wires connecting the bus to the 

part pins remain.  
Remove bus symbol and wires to delete the bus, the signal names and the wires connecting the bus to the 

part pins.  
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Wires > Delete Corner 
Used to delete corners from connections.  
Once selected, point at the corner to be deleted, then click the left button. The corner is removed from the 
connection. 
Refer to the Edit > Preferences, Miscellaneous window to find out how close you have to be to an item to select 
it. 

Wires > Flat Circuit Import Assist > Toggle Wire Section To Non Electrical 
This command is intended to be used on schematics that were originally drawn in the old, flat-style schematic 
editor to allow a parts/wiring list to be extracted successfully. 
This command permits a section of a connection to be switched to non-electrical mode, thereby hiding its 
connectivity from the parts/wiring list extractor.   
Wire secments connecting to component pins, and segments which are not the first, or last in a wire link cannot 
be changed. 
Back-ground information: There are major differences in the way that "bus" signals were handled in the flat 
schematic editor compared with the current hierarchical editor. The hierarchical editor uses specially created 
bus symbols to handle busses, whereas the flat schematic editor indicated busses by setting wires to "bus 
width".  The old, flat style schematic parts/wiring list extractor essentially ignored wires set at "bus width" and 
maintained connectivity by using the signal names.  
The hierarchical editor parts/wiring list extractor is unable to operate in this manner, so all imported "bus width" 
wires are converted to non-electrical features so they cannot be seen by the extractor. 
Some schematics with busses may need some manual editing after loading if it is desired to extract a parts and 
net list. If parts/wiring list extraction results in errors because multiple signal names are found on a net, then it 
may be necessary to convert more wire sections to non-electrical mode to hide them from the compiler.  
Alternatively the old-busses/non-electrical representations could be removed and the busses re-added using the 
Wires > Insert Bus command. 

Alloc commands 
These commands are associated with part allocation and de-allocation - adding and removing part references 
and pin numbers.  
Individual parts, sheets, or the complete design can be allocated or de-allocated according to the selections 
made. A list of spare gates and unallocated gates can also be detected.  
Errors cannot be made during allocation; Ranger refers back to the library parts for packaging information and 
checks to see which parts and gates have already been allocated on the design. For example you won't find two 
R1's.  
Note well: if parts have been allocated and they are subsequently modified using the Block > Edit command, 
and their pin numbers changed, they will need to be de-allocated, then re-allocated to update the parts and pin 
numbers used on the schematic.  
Before deallocating parts that have already been placed on the artwork, refer to the Alloc > Deallocate 
command for important information. 

Alloc > Auto Allocate 
Used to allocate all parts not already allocated on a sheet or through the hierarchy. Already allocated parts are 
not changed. Only unused part numbers and gates are used during allocation. 
When allocation is used, the allocation offset (the starting number for parts within sheets) for each sheet is 
controlled from the Structure > Set Allocation Offset command. By default, parts are numbered from one 
upwards.  
Once selected a window appears, giving control over the parts to be allocated. Select one of the options from 
the window to perform allocation, or select Cancel from the top of the window to cancel the command. 

Allocate current sheet 
Used to allocate reference designators and pin numbers to all the unallocated parts on the sheet being 
edited.  

Allocate current sheet downwards through hierarchy 
Operates in the same way as Allocate current sheet, except the current sheet plus all levels within the 
hierarchy below the current sheet are also allocated. 
Allocation is performed starting from the bottom of one hierarchical branch up to the top, it then starts 
from the bottom of another branch up to the top and so on. Blocks on the same level within a branch 
are taken one after the other. 

Allocate everything  
Operates in the same way as Allocate current sheet, except all the sheets within the design are 
allocated.  Allocation is performed starting from the top of the hierarchy downwards. 
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Alloc > Allocate Single 
Used to allocate selected parts on the current sheet. 
Once selected, point at the part to be allocated and click the left button. The allocation takes place.  
Already allocated parts cannot be changed, they have to be de-allocated first. 
Allocation looks to the allocation offset to find out which should be the first reference number used on the 
current sheet. If that number is in use anywhere within the design, then the next available number (or gate) is 
used for the part. The Allocation Offset is controlled via the Structure > Set Allocation Offset command.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
the part’s datum to select it. 

Alloc > Allocate Typed 
Used to allocate a specific part number to the selected part. 
Once selected, point at the part to be allocated and click the left button. A window appears requesting the 
number for the part. The prefix is automatically obtained from the symbol's attributes. Type in a number and 
press <enter>. The allocation will take place providing the part number is not already in use – a message is 
given in the status bar if the allocation cannot be performed. 
Already allocated parts cannot be changed, they have to be de-allocated first. 
When multi-gate parts are being assigned, the first available gate of the correct type within the package is used. 
If required, the part number followed by a pin number or gate identifier can be entered in the window. This 
forces a specific element within the package to be used, providing it is valid and unused.  
For instance if a 7400 element is selected and 3.6 entered, the element will become IC3 gate 'b' because pin 6 
was specified (pins 4, 5 and 6). Likewise, 3c could be entered to use the third gate in the package. 
Ranger will not allow gates to be allocated to the same part reference if the Value field of the gates is different. 
This also applies to split parts – all the value fields of the primitives that make up a split part must be the same.if 
they will be allocated the same reference number. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
the part’s datum to select it. 

Alloc > Show Freelist 
Used to indicate free gates within allocated parts in the design, i.e. spare gates in a package.  
Gates that have been added to the design, allocated but not connected to, are not regarded as free gates so will 
not be listed. 
Unallocated parts are not included within this check. So always use the Alloc > Unallocated Check command 
first, to indicate any parts that have not been allocated. 
When selected a window appears similar to that in Figure 98, listing all the free gates within allocated parts, if 
there are any.  

 

Figure 98 

Alloc > Unallocated Check 
Used to flag any unallocated parts or gates within the design. 
All parts on the schematic should be allocated before the parts and wiring list and layout are created, otherwise 
parts and/or connections will be missing from the layout. 
When selected a window appears listing all the unallocated parts within the design, similar to that in Figure 99. 
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Figure 99 

The part's instance identifiers are used to indicate the unallocated parts because they do not have reference 
designators. Use the Find > Instance command to locate them. 

Alloc > Auto De-allocate 
Used to de-allocate all parts on a sheet or through the hierarchy.  See also Notes on de-allocation below. 
Once selected a window appears, giving control over the parts to be de-allocated.  

De-allocate current sheet 
Used to de-allocate reference designators and pin numbers from all the parts on the sheet being 
edited. 

De-allocate current sheet downwards through hierarchy 
Operates in the same way as De-allocate current sheet, except the current sheet plus all levels within 
the hierarchy below the current sheet are also de-allocated. 

De-allocate everything 
Operates in the same way as De-allocate current sheet, except all the sheets within the design are de-
allocated. 

Alloc > De-allocate Single 
Used to de-allocate a selected part. See also Notes on de-allocation below. 
Once selected, point at the part to be allocated and click the left button. The de-allocation takes place.  

Notes on de-allocation 
Once the parts have been placed on the artwork and tracks routed, it is generally unwise to de-allocate those 
parts on the schematic - unless they will be re-allocated with the same part reference/pin numbers before a 
parts/wiring list is re-extracted, or you have a good reason for doing so and understand what will happen as a 
result. 
Once parts are placed on the artwork design, the parts list contains the position/orientation of all those parts. 
Changing part reference numbers on the schematic, then extracting a parts/wiring list has the effect of moving 
the parts and unroutes on the artwork, whilst the tracking, silk-screen, etc. remain in situ – effectively causing 
chaos to the artwork.   
If a part is removed from the sheet and another part is inserted with the same reference designator and different 
connections, the new part's datum will appear in the same position on the artwork as the old part's datum, along 
with its new connections. The old part's tracks and silk screen data will remain on the artwork. 
If modifications to the design have resulted in gaps in a numbering sequence that you would prefer to be used, 
always use the part renumbering tools in the artwork editor to renumber them. The renumbering will be back-
annotated to the parts/wiring list and schematic automatically. 

Nonelec commands 
These commands are associated with non-electrical data. Non-electrical data is used to define drawing blanks, 
notes, etc. It is plotted, but Ranger otherwise ignores it.  
There are two categories of non-electrical data that can be added and modified, Drawing sheet and Annotation.  
Each has a specific line width assigned to it which is controlled from the Edit > Preferences, Line Widths 
window. 
Drawing sheet typically used to define the perimeter of the sheet and title blocks, etc. When a design sheet is 

created, a border made from non-electrical drawing sheet data is automatically added. 
Annotate typically used to add general notes, tables etc.  
The non-electrical commands operate on drawing sheet data and annotation data, irrespective of which mode is 
currently active. The only way drawing sheet data can be differentiated from annotation data by the user, is by 
the line widths assigned. (If both types are set to the same size, then a difference won’t be visible.) 
Version control also operates on non-electrical text strings, so that multiple versions of a text string may be 
added. The actual string used is dependent on the version setting in the Edit > Preferences, Version Control 
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window. Refer to the Nonelect > Add Text command for more details. 
To add drawing sheet data, select NonElec > Drawing Sheet Mode. To add annotation data select NonElec > 
Annotate Mode. 
If the sheet size is changed a prompt appears to allow the existing border to be retained, or a new auto-
generated border to be defined. 

NonElec > Add Line 
Used to add lines that have no electrical significance, for example when creating drawing sheets, adding tables 
of information, etc.  
Once selected, locate the cursor where the line is to start, then click the left-hand mouse key. Move the cursor, 
a line appears attached to it. Clicking the left button inserts corners in the line. Release the line with a click of 
the right button, the segment attached to the cursor is not added. 
Refer to the Grid command to find out whether grid snapping is active.  

NonElec > Corner 
Used to insert or move a corner in a non-electrical line or arc. 
Once selected:  

Adding a corner Point at the line/arc, then click the right-hand mouse button. Move the cursor, the new 
corner is attached to it and the adjacent segments stretch with it. Release the new corner 
with another click of the same mouse button. (Click the opposite mouse button (left) to 
cancel the new corner.) 

Moving a corner  Point at the corner, then click the left-hand mouse button. Move the cursor to move the 
corner and stretch the adjacent segments. Release the corner with another click of the 
same mouse button. (Click the opposite mouse button (right) to cancel the move.) 
add corner = right button 
move corner = left button 
(Opposite button cancels.) 

Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

NonElec > Move Point 
Used to move existing points (corners) in lines or arcs, to move circles, or to change the size of circles. 

Moving points in lines or arcs: 
Once selected, locate the cursor on the corner to be moved, then click the left button. Move the cursor, 
the corner appears attached to it and the existing lines or curves stretch. Position the corner as 
required, then click the left button to release it. Clicking the right button before the corner is released, 
returns the corner to its original position.   

Moving circles: 
Once selected, point at the centre of the circle, then click the left button. Move the cursor, the circle 
appears attached to it. Position the circle as required, then click the left button to release it. Clicking the 
right button before the circle is released, returns it to its original position.   

Changing the size of circles: 
Once selected, point at the circumference of the circle, then click the left button. As the cursor is 
moved, the diameter of the circle changes. Once the required circle size is achieved, click the mouse 
button to release it. Clicking the right button before the circle is released, returns it to its original size.  

Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

NonElec > Delete point 
Used to delete points (corners) from lines or arcs.  
Once selected, point at the corner to be deleted, then click the left-hand mouse button. The corner is removed 
from the line or arc. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

NonElec > Delete Line 
Used to delete non electrical lines, arcs or circles. 
Note: the complete line or curve between start and end points is deleted, not just a segment within a line or arc.  
Once selected, point at the line, arc or circle to be deleted, then click the left-hand mouse button. The line, arc or 
circle is removed. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
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an item to select it. 

NonElec > Add Text 
Used to add text strings to the sheet that have no electrical significance, for example when creating drawing 
sheets, adding tables of information, etc.  
(Use Symbol > Attributes to add part attributes, Alloc commands to define part references and pin numbers or 
Wires > Attributes to add signal names.) 
Refer to the Grid command menu to find out whether grid snapping is active.  

Special Syntax 
Ranger has special text strings that it recognises and will replace them with specific names on the screen 
and print-outs. 
%jobname% this text string will be replaced by the job's name. So for instance, the non-electrical text 

string This job is called %jobname%. will appear as This job is called A12345. if the 
job were called A12345. This ensures the string remains up to date if the job name is 
changed. 

%blockid%  this text string will be replaced by the block's name. Useful where blocks are used more 
than once in a design and need to be identified on print-outs. For instance if a block 
called Channel was used more than once in a hierarchy, then This is %blockid%. would 
be replaced with This is Channel.1., This is Channel.2., This is Channel.3., etc. 

%version% this text string will be replaced by the current version. So for instance if one sheet were 
used in USA and UK versions, then the string This is the %version% version. would be 
replaced with This is the USA version. or This is the UK version. depending on which 
was selected in the Edit > Preferences, Version Control window.  

Versions 
More than one version can be assigned to the text value field. For instance, it may be required to add a 
note in English or French, depending on who will be reading the schematic. The version names, and which 
version is currently active are defined in the Edit > Preferences, Version Control window. The text string 
should take the following format when specifying multiple values: 

versionname!text_string  versionname!text_string  versionname!text_string 
 where: 

versionname is the version name assigned in the Edit > Preferences, Version Control window. 
!  is the character defined for version control in the Edit > Preferences, Miscellaneous 

window. 
text_string is the text string required for that version. 

Example: 
UK!Static Sensitive  FRA!French Equivalent 

This will give a text string of Static Sensitive when displayed or plotted with the UK version selected and 
French Equivalent with the FRA version selected. 
It is possible to specify a default version value using the version name *.  
So for example, FRA!French Equivalent   *!Static Sensitive  will produce French Equivalent if the FRA 
version was selected, but Static Sensitive for all other versions. 
If the version control character is not used, then those strings are unaffected by the version selection 
mechanism. 
If a text string has no value for a selected version, i.e. it has no *! value then (null) will be displayed on 
screen where the value would normally be. The (null) text will not appear when the sheet is plotted. 
The version control character may be used in most part attributes (outline name, ordercode, value, etc.) in 
all user-defined attributes, in connection attributes (signal name) and in non-electrical text strings.  

Once NonElec > Add Text has been selected a window appears.  
Text: String to be entered. If text has already been added or modified, the previous text string 

appears in the window. It may be selected and modified, or a new text string entered.  
Height: The height of the text string can be entered (in inches or millimetres depending on which units 

are active (Edit > Units command).  
Angle: The orientation of the text can be specified in increments of one degree, anti-clockwise. 

0 degrees places text horizontally, reading from left to right.  Angles can be selected (0, 90, 
180 or 270) or the value selected and a new value typedwhich will replace the selected value. 

Mirrored: the string can be mirrored if required.  
Once all the information has been entered, select OK. The window closes and the text string represented by a 
rectangle, appears attached to the end of the cursor. Move the cursor into position and click the left button to 
release the text.  
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Clicking the right button before the text is released restores the window allowing the string to be modified or the 
operation cancelled. 
Whilst the text is being moved it can be rotated in 90-degree increments anti-clockwise by pressing the <rotate 
part> special function key. 
As the text string is released, another copy of it appears on the end of the cursor. It can be released in the same 
way or the right button clicked to cancel the text. The window re-appears, select Cancel to cancel further text 
addition, or the text in the window can be modified and OK selected again. 

NonElec > Move Text 
Used to move text strings that have already been added. 
Once selected, point at the text string and click the left button. A rectangle representing the text string appears 
attached to the cursor. Move the rectangle into the required position and click the left button to release it. 
Whilst the text is being moved it can be rotated in 90 degree increments anti-clockwise by pressing the <rotate 
part> special function key. 
Clicking the right button whilst moving the text releases it in its original position. 
Text can be selected anywhere along its length. Its datum is the lower left-hand corner of the rectangle that is 
displayed when it is moved. 
Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

NonElec > Delete Text 
Used to delete existing text strings.  
Once selected, point at the text string and click the left-hand mouse button. The text is removed.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

NonElec > Edit Text 
Used to edit existing text strings, change their height, angle of rotation or mirrored status. 
Once selected, point at the text string and click the left-hand mouse button. A window appears allowing the text 
string to be modified.  
Refer to the NonElec > Add Text command above for details on this window if required. 
Select OK to implement the changes. Select Cancel to restore the text to its original form. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

NonElec > Rotate Text 
Used to rotate text strings through 90 degree increments, anti-clockwise. For instance, text that has been 
rotated to 45 degrees will rotate to 135, 225, 315 and back to 45 degrees.  Text can be rotated in increments of 
1 degree using the NonElec > Add/Edit Text command. 
Text is rotated about its datum, which is the lower left-hand corner of the rectangle that is displayed when text is 
moved. 
Once selected, point at the text string and click the left button. The text rotates. If the text is selected on its 
datum, you don't have to move the cursor to rotate it again. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

NonElec > Add Arc 
Used to add curved lines (arcs) that have no electrical significance, for example when creating drawing sheets, 
adding tables of information, etc. A series of arcs and straight lines can be added using this command. 
Once selected, locate the cursor where the arc or line is to start, then click the left button. Move the cursor, a 
line appears attached to it. Move the cursor to the point where the arc or line is to end, then click the left button.  
Move the cursor. A curve stretches with the cursor, its size and shape being dependent on the cursor position. 
Click the left button to release the curve. If the right button is clicked, a straight line segment is introduced.  
The line remains attached to the cursor allowing more curves to be added, or the line released. To continue 
adding curves, move the line to the end point of the next arc, then click the left button, stretch the arc and 
release it with a click of the same button. To release the line, click the right button, the line attached to the 
cursor is not added. 
If the right button is clicked whilst the arc is being stretched, a straight segment is introduced. This allows a 
mixture of curved and straight segments to be drawn using the same command. 
The shape of the arcs can be adjusted using the NonElec > Move Point command. 
Refer to the Grid command to find out whether grid snapping is active.  
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NonElec > Adjust Arc 
Used to convert arcs to lines, lines to arcs and to adjust the size and shape of arcs. 
Select NonElec > Adjust Arc. 

Straight lines into arcs: 
Point at a line segment and click the left button. Move the cursor, the segment is replaced by an arc 
that stretches as the cursor is moved. Click the left button to release the arc. 

Arcs into a straight line: 
Point at an arc and click the left button. Follow this with a click of the right button to convert the arc into 
a straight line segment. 

Adjusting the size or shape of an arc: 
Point at the arc and click the left button. Move the cursor until the arc is in the required position, then 
click the left button. 
Clicking the right button toggles the last selected line or arc between a line and an arc. The shape of 
the arc is defined automatically, and can be used to convert 45 degree lines into quadrants of a circle.  
The direction of the arc is determined by the position of the cursor about the line when the button is 
pressed. 

Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

NonElec > Add Circle 
Used to add circles that have no electrical significance, for example when creating drawing sheets, adding 
tables of information, etc.  
Once selected, point at the centre of the required circle and click the left button. Move the cursor and a circle 
appears attached to it. The size of the circle is controlled by the cursor position. Click the left button to release 
the circle in its current position. Clicking the right button cancels the circle.  
Use the NonElec > Move Point command to move existing circles, or change the size of existing circles. 
Refer to the Grid command to find out whether grid snapping is active.  
NonElec > Annotate Mode or Drawing sheet mode 
Used to define which category non-electrical data, is added to. One or the other mode is ticked and therefore 
active. 
Annotation Mode should be selected when adding general notes, tables, etc.  
Drawing Sheet Mode should be selected when adding the drawing sheet borders and associated text. 
The Edit > Preferences, Line Widths window controls the line sizes of annotation and drawing sheet lines and 
text. 

To create user-defined borders for use on other sheets:  
The supplied master schematic library contains a folder called Sheets. This has various sizes of design sheets 
with borders. These could be modified to suit your own requirements. Alternatively, they can be copied and the 
copies modified.  
The Copy/Paste/Rename commands can be used to copy the sheets to the same library folder or to another 
design. Simply locate the design sheet to be copied, then right-click and Copy it. Navigate to the design sheets 
folder where it should be copied to, then right-click over the Design Sheets folder and Paste.  
Open the design sheet and delete/edit the existing border and define the new border as required, in Drawing 
Sheet Mode.  
Repeat for each different sheet size required.  

Using the border on a new sheet:  
If starting a new design sheet, use the right-click Copy/Paste commands to copy the pre-defined design 
sheet into the design being worked upon. Once copied, rename the sheet to something suitable, open the 
sheet and add parts, etc. to it. 
Example:  

From the navigator, navigate down through the Masters folders until the master schematic library, 
Design Sheets folder is open, then locate and open the folder Sheets. Right-click over the design sheet 
required and select Copy.  
Now navigate to the Design Sheets folder of the design being worked upon, then with the cursor over 
the Design Sheets folder, right-click and select Paste. The design sheet will appear in the folder. Right-
click/Rename the design sheet, and change its name to something suitable. Open the sheet and add 
the circuitry. 

Using the border on an existing sheet:  
If a design sheet has already been started and contains circuitry, first remove the border that’s not required 
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using the NonElec commands.  
Copy (as described in the example above) the design sheet with the border, from the master library to the 
design being worked upon. 
Open that design sheet, then use the Region > Copy command to copy the border. Open the sheet being 
worked upon, then use Region/Paste to paste the border onto the sheet. 

Region commands 
These commands are used to move, copy and delete rectangular areas of circuitry, within a design - not 
between designs. (To copy areas of circuitry between designs, first copy the design sheet to the design sheets 
folder, then use the Region commands. Delete the copied sheet when no longer required in the design.) 
Refer to the Grid menu command to find out whether grid snapping is active, and the Edit > Preferences, 
Miscellaneous to find out whether wire pick-up, etc. is enabled and to define the amount of data that can be 
moved dynamically. 

Region > Move 
Used to move a rectangular area of circuitry around the sheet.  
Once selected, point at and select with a click of the left button, one corner of the area to be moved. As the 
cursor is moved, a rectangle stretches with it. Click the same mouse button again to release the diagonally 
opposite corner of the area. Once the area has been defined, it will move with the cursor until it is released with 
a click of the left button. Click the right-hand mouse button to cancel the move. 
If the rectangle is blank when being moved, increase the value of the Max window mode, dynamic nodes setting 
in the Edit > Preferences, Miscellaneous window. 

Region > Copy 
Used to copy a rectangular area of circuitry to the paste buffer.  
The contents of the paste buffer can be added to other design sheets in the same design, using the Region  > 
Paste command (but not other designs). 
When data is copied or cut to the design sheet paste buffer, it overwrites anything previously added to the paste 
buffer.  
Each job has its own design sheet paste buffer, which remains intact until the job is closed, at which time it is 
cleared. 
Part allocation information is not maintained by the contents of the paste buffer. 
Once selected, point at and select with a click of the left-hand mouse button, one corner of the area to be 
copied. As the cursor is moved, a rectangle stretches with it. Click the same mouse button again to release the 
diagonally opposite corner of the area. The rectangle disappears and the content of the area has been copied to 
the paste buffer.  
A message appears along the bottom of the screen indicating how many nodes were selected in the area - 
knowing the number of nodes in the area allows the Max window mode, dynamic nodes setting in the Edit > 
Preferences, Miscellaneous window to be increased for dynamic movement if required (see Region > Move). 
Use the Region > Paste command to add the contents of the paste buffer to the sheet.  

Region > Cut 
Used to delete a rectangular area of circuitry. The area of circuitry is placed in the paste buffer, so it could be 
restored using the Region  > Paste command.  
The contents of the paste buffer can be added to other design sheets in the same design, using the Region  > 
Paste command (but not other designs). 
When data is copied or cut to the design sheet paste buffer, it overwrites anything previously added to the paste 
buffer.  
Each job has its own design sheet paste buffer, which remains intact until the job is closed, at which time it is 
cleared. 
Part allocation information is not maintained by the contents of the paste buffer. 
Once selected, point at and select with a click of the left-hand mouse button, one corner of the area to be 
deleted. As the cursor is moved, a rectangle stretches with it. Click the same mouse button again to release the 
diagonally opposite corner of the area.  
The area of circuitry is removed from the sheet and added to the paste buffer.  
A message appears along the bottom of the screen indicating how many nodes were selected in the area - 
knowing the number of nodes in the area allows the Max window mode, dynamic nodes setting in the Edit > 
Preferences, Miscellaneous window to be increased for dynamic movement if required (see Region > Move). 
Use the Region  > Paste command to add the contents of the paste buffer to a sheet if required.   

Region > Paste 
Used to add the contents of the paste buffer to the sheet. (Use the Region  > Copy or Cut commands to add 
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data to the paste buffer.) 
If the circuitry in the paste buffer includes any block I/O pins, then the appropriate number of block I/O pins are 
added to the corresponding symbol when the circuitry is pasted into the sheet. If a symbol had not previously 
existed, then it will be created. 
When data is copied or cut to the design sheet paste buffer, it overwrites anything previously added to the paste 
buffer.  
Each job has its own design sheet paste buffer, which remains intact until the job is closed, at which time it is 
cleared. 
Part allocation information is not maintained by the contents of the paste buffer. 
Assuming data has been added to the paste buffer select Region  > Paste. As the cursor is moved, the area of 
circuitry from the paste buffer is seen attached to it.  
An empty rectangle will be seen if there are too many nodes within it, according to the Max window mode, 
dynamic nodes setting in the Edit > Preferences, Miscellaneous window. Click the left button to release the 
circuitry, or the right button to cancel the operation. 
 

Region > Add to Artwork Tray 
All parts associated with symbols in the selected region will be added to the artwork placement tray, whether or 
not the artwork editor is open.  
In this mode, all symbols related to parts already placed on the board, or already in the placement tray will be 
shown with a dotted outline. 
The region can include parts already shown dotted, their status is unaffected by the selection. 
Select Region  > Add to artwork tray. Any parts already placed on the artwork or in the placement tray will be 
shown with dotted outlines. Point at and select with a click of the left button, one corner of the area to be 
selected. Move the cursor, a rectangle stretches with it, position the diagonally opposite corner of the area and 
click the same mouse button again. The parts will be added to the placement tray and appear as dotted symbols 
to indicate their status (whilst the command is active). 
A message in the status bar will indicate how many parts were added to the placement tray. 
Note: once added to the placement tray the parts can only be removed using the artwork editor tools. 

Commands available when a part, split part, primitive or block I/O is open 
Tool bar commands 
The toolbar contains icons that can be used as short-cuts to some commands. They are not user-definable. The 
icons/settings vary, depending upon which editor is open. The following settings may also appear. 

Instance setting 
Used to display each element of a multi-element part. Use the slider bar and/or arrows to the right of the setting 
to view each element, only the pin numbers between elements will be different.  
If 1 of 1 is shown, then the arrows alongside will be greyed out as the part has only one element.  
This setting is not present when split parts are edited. 
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Type setting 
Used to select whether the Normal or DeMorgan view of the part is active.  
A part can have two representations drawn for it. Its Normal symbol or a DeMorgan equivalent symbol. 
Everything remains the same about the part, apart from its graphical representation.  
The pins and attributes on both representations are in exactly the same position. If they are moved or deleted 
from one representation, they are also moved or deleted from the other. 
If the DeMorgan equivalent symbol is not required, then it could be used to draw the symbols to another 
standard. For instance the normal symbols could be drawn to the British Standard and the DeMorgan symbol to 
the ANSI standard. 
A part is initially drawn and used on the schematic sheet showing its normal graphic representation. Once on 
the sheet it can be toggled between the representations, using the Symbol > Logic Type command. 
Before an alternate representation of the part can be made, its original version must first be defined. When the 
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Type is set to DeMorgan, if the DeMorgan symbol has not previously been defined, all the graphics of the part 
will disappear, leaving behind the part attributes and pins. Use the Outline menu commands to draw the 
alternate graphic shape of the part. 
To return to the original version of the part, set the Type to Normal. 

I/O Pin type 

 

Figure 101 

This setting is only available when a block I/O port or a design symbol is being edited. It determines the type of 
pin that is added. One of two types of pin can be added, a net-pin or a bus-pin.  
Net-pins are displayed as a diagonal cross, bus-pins with a circle. 
If a net-pin is added only individual connections can be attached to it when it is used.  
If a bus-pin is added, only bus connections can be attached to it when it is used.  

Outline commands 
These commands are associated with drawing the schematic shape of the part/symbol, so they appear when 
editing design symbols, parts, primitives and block i/o ports. They do not appear when editing a design sheet or 
a split part. The thickness of lines is controlled from the Edit > Preferences, Line widths window. 

Outline > Add Line 
Used to add lines to define the shape of the symbol.  
Once selected, locate the cursor where the line is to start, then click the left button. Move the cursor, a line 
appears attached to it. Clicking the left button inserts corners in the line. Release the line with a click of the right 
button, the segment attached to the cursor is not added. 
Refer to the Grid command to find out whether grid snapping is active.  

Outline > Add Circle 
Used to add circles to the symbol. 
Once selected, point at the centre of the required circle and click the left button. Move the cursor and a circle 
appears attached to it. The size of the circle is controlled by the cursor position. Click the left button to release 
the circle in its current position. Clicking the right button cancels the circle.  
Use the Outline > Move Point command to move existing circles, or change the size of existing circles. 
Refer to the Grid command to find out whether grid snapping is active.  
 

Outline > Add Rectangle 
Used to add rectangular shapes to the symbol. 
Once a rectangle has been added, it is treated as a line so it can be modified using the Outline > Corner/Delete 
Point, etc., commands. 
Once selected, locate the cursor in the centre of the required rectangle, then click the left button. Move the 
cursor, a rectangle stretches as the cursor is moved; its size and shape is cursor dependent. Click the left button 
to release the rectangle in its current position. Clicking the right button before the rectangle has been released, 
cancels the rectangle, the Add Rectangle command stays active. 
Refer to the Grid command to find out whether grid snapping is active.  

Outline > Add Arc 
Used to add curved lines "arcs" to the symbol. A series of arcs and straight segments can be added using this 
command.  
Once selected, locate the cursor where the arc or line is to start, then click the left button. Move the cursor, a 
line appears attached to it. Move the cursor to the point where the arc or line is to end, then click the left button. 
Move the cursor. A curve stretches with the cursor, its size and shape being dependent on the cursor position. 
Click the left button to release the curve. If the right button is clicked a straight line segment is introduced.  
The line remains attached to the cursor, allowing more curves to be added or the line released. To continue 
adding curves, move the line to the end point of the next arc/line, then click the left button, stretch the arc and 
release it with a click of the same button. To release the line, click the right button, the segment attached to the 
cursor is not added. 
If the right button is clicked whilst the arc is being stretched, a straight segment is introduced. This allows a 
mixture of curved and straight segments to be drawn using the same command. 
The shape of the arcs can be adjusted using the Outline > Move Point command. 
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Refer to the Grid command to find out whether grid snapping is active.  

Outline > Corner 
Used to move, or insert a corner in a line or arc. This command is more flexible than the Outline > Move Point 
command, as it allows corners to be moved or added. Once selected:  

Adding a corner  
Point at the line, then click the right-hand mouse button. Move the cursor, the new corner is attached 
to it and the adjacent segments stretch with it. Release the new corner with another click of the same 
mouse button. (Click the opposite mouse button (left) to cancel the new corner.) 

Moving an existing corner  
Point at the corner, then click the left-hand mouse button. Move the cursor to move the corner and 
stretch the adjacent segments. Release the corner with another click of the same mouse button. (Click 
the opposite mouse button (right) to cancel the move.) 
 add corner = right button (Opposite button cancels.) 
 move corner = left button (Opposite button cancels.) 

Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

Outline > Move Point 
Primarily used to move, or change the size of circles. Can also be used to move points (corners) in lines or arcs. 
Once selected: 

Moving circles: 
Point at the centre of the circle, then click the left button. Move the cursor, the circle appears attached 
to it. Position the circle as required, then click the left button to release it. Clicking the right button 
before the circle is released returns it to its original position.   

Changing the size of circles: 
Point at the circumference of the circle, then click the left button. As the cursor is moved the diameter 
of the circle changes. Once the required circle size is achieved, click the left button to release it. 
Clicking the right button before the circle is released returns it to its original size.   

Moving points in lines or arcs: 
Locate the cursor on the corner to be moved, then click the left button. Move the cursor, the corner 
appears attached to it and the existing segments or curves stretch. Position the corner as required, 
then click the left button to release it. Clicking the right button before the corner is released, returns the 
corner to its original position.   

Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

Outline > Adjust Arc 
Used to convert arcs to lines, lines to arcs and to adjust the size or shape of arcs. 
Once selected:  

Straight lines into arcs: 
Point at a line segment and click the left button. Move the cursor, the segment is replaced by an arc 
that stretches as the cursor is moved. Click the left button to release the arc. 

Arcs into a straight line: 
Point at an arc and click the left button. Follow this with a click of the right button to convert the arc into 
a straight line segment. 

Adjusting the size or shape of an arc: 
Point at the arc and click the left button. Move the cursor until the arc is in the required position, then 
click the left button. 
Clicking the right button toggles the last selected line or arc between a line and an arc. The shape of 
the arc is defined automatically, and can be used to convert 45 degree lines into quadrants of a circle. 
The direction of the arc is determined by the position of the cursor about the line when the button is 
pressed. 

Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

Outline > Delete Feature 
Used to delete lines, circles or arcs from the symbol. 
Note: the complete line or curve between start and end points is deleted, not just a segment within a line or arc.  
Once selected, point at the line, arc or circle to be deleted, then click the left button. The line, arc or circle is 
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removed. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Outline > Delete Point 
Used to delete points (corners) from lines or arcs.  
Once selected, point at the corner to be deleted, then click the left button. The corner is removed from the line or 
arc. If there are only two points in the line/arc (start & end points), then the line is deleted when one of the points 
is removed. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Outline > Symbol Datum 
Used to define the datum of the part.  
The datum point is the reference point used when selecting items. 
Once selected, point at the position required for the datum point and click the left button. The cross that 
represents the datum, moves. 
Refer to the Grid command to find out whether grid snapping is active. 

Terminals commands  
These commands are used to add or edit the terminals or "pins" of a part. They appear when editing parts, split 
parts, primitives, block i/o ports and design symbols. The commands do not appear when editing design sheets. 
Terminals which are often referred to as pins (“terminals” and “pins” are used interchangeably) sometimes do 
not necessarily represent physical component pins, it depends on the type of schematic item the terminals are 
used in, as described below. 

Design symbols 
Terminals within the design symbol do not represent pins of a physical component. They are a means 
of making a connection between sheets in a hierarchical schematic. For every terminal used in the 
design symbol, a port is added to the associated design sheet. The terminals and ports take the same 
name. 
Note: If the design symbol is placed in a higher level design sheet, and the pin name (terminal) 
attribute is edited, the new name will appear against the block i/o pin when descending into the design 
sheet associated with the symbol. 
An iopin attribute that is overriden by an attribute on a higher level instantiation will always show the 
overridden value when the design sheet is displayed. The value may still be edited in this mode, but 
the override value will still be displayed. 
Switching to the design symbol will show the attribute value without the effect of any higher level 
override. The value displayed in this mode is the value displayed against the pin for any new 
instantiations of the design symbol. 

Parts 
Terminals within a library part always represent a pin of a physical component. To ensure connectivity 
between the schematic and artwork, the terminal must be given a number (combinations of alpha or 
numeric characters), which corresponds to a pad with the same number in the outline library. 

Primitives 
Terminals within a library primitive represent a pin of a physical component if the primitive is used 
within a split part (or part, in the case of power symbols). The terminals should not be given numbers 
until the primitive is used in the split part/part. 

Split parts  
Terminals cannot be added to split parts, they are added to the primitives used in the split part. When 
the primitive is used in a split part, its terminals do represent component pins and they should be 
assigned pin numbers in the split part. 

Block I/O ports  
Terminals within a block I/O port do not represent pins of a physical component. A block I/O port is 
used as a means of making a connection between sheets in a hierarchical schematic. There are two 
types of block i/o port terminal, a net-pin and a bus-pin. When block i/o ports are used on design 
sheets, only signal connections can be attached to net-pins and bus connections to bus-pins.  

Terminals > Add, Terminals > Add-Auto 
Both these commands are used to add terminals to the symbol. The Add command is used to add 
individual terminals, whilst Add-Auto is used to add rows or columns of terminals. Default attributes are 
assigned automatically when the terminals are added. These defaults are stored in the file called 
schema_attribs.txt, which is held in the Configuration Data Directory (MyDocuments/Seetrax/XL 
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Designer/Data by default).  
IO Pin type 

If a block I/O port or a design symbol is being edited, ensure the IO Pin Type setting in the toolbar is 
set to the appropriate type as one of two types of pin can be added, a bus pin or a net pin.  
If a bus pin is added, only bus connections can be attached to it.  
If a net pin is added only individual connections can be attached to it.  
Two ports are therefore required for hierarchical schematics, one containing a bus pin, and the other a 
net pin.  
If a bus pin port is used on the design sheet, a bus pin is automatically added to its associated symbol.  
If a net pin port is used on the design sheet, a net pin is automatically added to its associated symbol.  
Net pins are displayed as a diagonal cross, bus pins with a circle. 

Refer to the Grid command to find out whether grid snapping is active. 
Add 

Once selected, point at the location where the terminal is required, then click the left button. The 
terminal appears. More terminals can be added as required. 

Add-Auto 
Once selected, move the cursor and a flag containing the word first appears attached to it. Point at the 
location where the first terminal is required, then click the left button. The flag is replaced by another 
containing the word second. Point at the location where the second pin is required, then click the left 
button. A window appears requesting the total number of pins required. Type in the number followed 
by <enter>. The total number of terminals specified is added, at the same pitch and following on in the 
same direction as the first two terminals. 

The nn string indicates the position that the terminal's pin number will occupy when it is assigned.  
The terminals must be given pin numbers (Terminals > Assign Pin Numbers) if they are used within a part or 
split part. The pin numbers can be moved or hidden using the Attributes commands. 
The Name or NET string indicates the position that the terminal's name will occupy (providing it is visible). 
These attributes can be moved or hidden using the Attributes commands. 

Terminals > Move 
Used to move existing terminals. When terminals are moved, their associated attributes also move. 
Note: if pins are moved on a part that has already been placed and connected to on the schematic sheet, the 
connectivity will be lost as the connections will not move. 
Once selected, point at the terminal to be moved, then click the left button, the terminal disappears. Move the 
cursor to the location where the terminal is required and click the left button again. The terminal re-appears in its 
new position.  
Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

Terminals > Delete 
Used to delete terminals. The terminal and all its associated attributes are deleted. 
Note: if terminals are deleted from a part that has already been placed and connected to on the schematic 
sheet, the connections will remain on the sheet.  
Once selected, point at the terminal to be deleted, then click the left button, the terminal and its attributes are 
deleted. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Terminals > Assign Pin Numbers 
Used to assign a number to a terminal/pin. The number assigned is linked to the pad with the same number in 
the associated physical outline.  
Up to 8 alpha-numeric characters (letters or numbers) in any order can be used in a pin number – even if letters 
are used, it is still a pin “number”.  
Note: although it is impossible to assign the same pin number more than once with this command, it can be 
achieved (via an alternative method) but would not be valid. It is therefore advisable to use the Terminals > 
Check command before using the part, to ensure pin numbers have not been duplicated. 
Once a number has been assigned, it cannot be used again in that part.  
If pin numbers have been assigned incorrectly, they can be changed, by assigning another number to the 
terminal - the original number is over-written.  
However, because the same number cannot be used twice, even temporarily, you might need to temporarily 
assign numbers that haven’t/won’t be used to those pins (say 50, 51, etc.), before the correct numbers can be 
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assigned (this saves deleting the terminal and adding a new one).  
If pin numbers are being changed and the parts have already been used and allocated on the schematic, they 
will need to be de-allocated, then re-allocated on the schematic to implement the pin number changes. 
Pin numbers must be assigned to pins if the pins are used in a part or split part, but they do not have to be 
displayed. The Attributes > Pin command controls pin number visibility. 
Pin numbers should not be assigned to pins within library primitives; the pin numbers are assigned to the pins 
when they are used within the part or split part. 
There is no requirement to assign pin numbers to the pins within block I/O ports or design symbols, as these 
pins do not represent physical pins. 
If a part with more than one element/gate is being edited, each of the gates can be displayed in turn by selecting 
the arrows alongside the Instance setting in the toolbar. This allows the pin numbers from each gate to be 
assigned.  
Select Terminals > Assign Pin Numbers, a window appears, similar to Figure 102.  

 

Figure 102 

Three methods of numbering terminals are available, Auto(matic), Manual and Typed. 
When using the Auto or Manual methods, the pin number and increment values have to be supplied before 
the options become available. 

Pin number  enter the first number to be assigned to a terminal/pin. Up to 8 alpha-numeric characters in 
any order can be entered. 

Increment the number entered here is added to the previous assigned pin number and used for the next 
selected pin. 
For instance, if the pin number is set to 1 and the increment set to 3, pin numbers will be 
assigned in the following order, 1, 4, 7, 10, etc. 
If the pin number specified does not end with a number, subsequent pin numbers have a 
number added, according to the Increment specified.  
Use the Typed method if the last character should not be a number. 

Auto 
Used to automatically assign pin numbers in order, to a row or column of terminals/pins. 
Enter the first Pin Number and Increment as explained above, then select Auto. The window closes 
and a flag with the word First appears attached to the cursor. Select, with a click of the left button the 
first pin in the row or column to be assigned.  
The flag changes to Last. Select the last pin in the row or column with a click of the same mouse 
button. The pin numbers are assigned to each of the pins in the row or column in order, as specified. 

Manual 
Used to manually assign pin numbers in order to individual selected terminals/pins. 
Enter the first Pin Number and Increment as explained above, then select Manual. The window closes 
and a flag with the pin number appears attached to the cursor. Select, with a click of the left button the 
pin that should be assigned that pin number.  
The pin number in the flag changes according to the Increment specified. Select the next pin with the 
same mouse button, and so on. Click the right button to cancel further pin selections. The window re-
appears, either select Cancel or continue numbering pins as before. 

Typed 
Used to assign pin numbers to individual selected pins. This method is typically used when the last 
character of a pin number is a letter, or the numbers do not follow a pattern. 
Leave the Pin number and Increment boxes as they are, and select Typed. Select, with a click of the 
left button the terminal/pin to be assigned a number.  
A window appears requesting the pin number. As soon as <enter> is pressed, the pin number is 
assigned. Another pin can be selected and a number assigned in the same way. Up to 8 alpha-numeric 
characters, in any combination can be used as a pin number. 
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Terminals > Set Pin Swap Rule 
Used to define electrically equivalent pins in order to allow pin swapping on the board layout.  
Pin swapping is performed on the artwork layout in order to reduce connection crossovers and thus aid routing. 
For instance, the connections attached to the input pins of one nand gate can be swapped with one another 
without affecting the electrical function of the circuit (pin swapping). If pin swapping is performed in the artwork 
editor, the pin number changes are back-annotated to the wiring list and schematic. 
Only pins within the same symbol that are defined as equivalent to one another can be swapped with one 
another. 
Ranger uses colours to display which pins are equivalent to one another. Pins assigned the same colour are 
equivalent to other pins assigned the same colour within the same symbol.  
Up to six different sets of equivalent pins can be defined within one symbol. For instance if a part had 6 pins and 
three pins were assigned blue, and three green, then the three blue pins could be swapped one for another, as 
could the three green pins, but the blue and green pins could not be swapped with one another.  
Pins are unswappable by default. 
Note: when editing split parts, even though it’s possible to assign all the pins within the package to the same 
colour, only the pins within the same primitive are defined as being equivalent to one another. 
When selected, the PinSwap Rule dialogue bar appears on the left of the screen. Small circles replace the 
terminals/pins - the colour of the circles indicates which pins are equivalent to one another.  
Initially all the pins are clear and unswappable, they are not equivalent to any other pin, so cannot be swapped 
on the layout. 
To assign equivalent pins: select one of the colours from the Pin Swap Rules dialogue, then select the terminals 
that are electrically equivalent to one another. The terminal circles will change colour. 
To make a pin unswappable if it has been made equivalent to other pins, select U from the Pin Swap Rules 
dialogue, then select the terminal.  

Terminals > Assign Names 
Used to assign a name to a pin – if required. The name does not have any link to the physical outline. It is 
added for user information to aid recognition of pins and their type, i.e. clock, clear, preset, etc. 
The names can consist of alpha-numeric characters in any combination. The negation bar prefix character can 
be specified in front of the pin name if a negation bar is required over the pin name.  

When a pin is added a default pin name of Name is added, unless a design symbol or block i/o port is being 
edited in which case it is NET.  
(Defaults are defined in the schema_attribs.txt file, held in the Configuration Data Directory 
(MyDocuments/Seetrax/XL Designer/Data by default). 

The Attributes > Pin command controls pin name visibility. 
Once selected, select a pin with a click of the left button. A window appears requesting the pin name. As soon 
as <enter> is pressed, the name is assigned and replaces Name or NET. Another pin can be selected and a 
name assigned in the same way. 
If a design symbol is being edited, the pin name is linked to the port name on the associated sheet. Changing 
the pin name automatically changes the port name and vice versa. 
Note: If the symbol of a sheet is placed in a higher level sheet, and the pin name (terminal) attribute is edited, 
the new name will appear against the block i/o pin when descending into the schematic sheet associated with 
the symbol. 
An iopin attribute that is overriden by an attribute on a higher level instantiation will always show the overridden 
value when the sheet is displayed. The value may still be edited on the sheet, but the override value will still be 
displayed. 
Switching to the symbol of the sheet will show the attribute value without the effect of any higher level override. 
The value displayed in this mode is the value displayed against the pin for any new instantiations of the symbol. 
Over-ridden attributes can be reset to their original values, using the Symbol > Attributes > Reset command. 
When re-setting the attributes of design symbols in a hierarchy, the attributes should be reset at the upper level. 

Terminals > Check 
Used to obtain a report on the pins used within the part. If warnings are given they should be investigated and 
rectified. 
A common error is to assign the same pin number to multiple pins. If this is not detected when the part is 
created, this will lead to short-circuit error messages when the part is used and the artwork is checked. A 
connection will be listed as being shorted, but it will not indicate another net that it is shorted to. If this type of 
error occurs, ensure that the Terminals > Check command has been used on all the parts used on the 
schematic. 
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Powerpins commands 
These commands appear when editing parts and split parts, they are associated with the symbols that can be 
used to represent a part’s power pins. They do not appear, or should not be used, when editing primitives, block 
i/o ports, design symbols or sheets.  
Power symbols are used if required, to represent the power pins of parts or split parts. For example, a 7400 is 
usually represented on the schematic sheet by four, two i/p nand gates and the power connections implied, i.e. 
automatically added to the wiring list but not seen on the schematic.  
It is sometimes useful to see the power pins on the schematic, so power symbols should be used in these 
instances – see Figure 103. 

 

Figure 103 

Power symbols can be added to parts/split parts but they do not have to be used on the schematic. If they are 
not used, the power connections are implied. If they appear on the schematic, connections must be made to the 
pins or they will be unconnected.  
Refer to the Attributes > Symbol, Part Power Pins window in order to change implied power pin definitions (pin 
numbers & names). 

Power Pins > Add 
Used to add power symbols to parts or split parts. The power symbol must already have been created as a 
library primitive. (The worked example gives an example of creating and using a power symbol.) 
Power symbols can also be added via the Attributes > Symbol, Part Power Pins window.  
When the command is selected, if the part already has a power symbol defined, then another of the same power 
symbol is added, otherwise a prompt asks which power symbol is required. If the power symbol already used 
has to be changed, use the Attributes > Symbol, Part Power Pins window to change it, or delete the power 
symbol first and add a new one. 
The position of the power symbol relative to the library symbol is not important; the symbols are added to the 
schematic independently of one another. 
Refer to the Grid commands to find out whether grid snapping is active. 
Select Power Pins > Add - a window requests the name of the power symbol required (unless a power symbol 
has already been defined in the part, in which case that symbol is used). Type in the name of the power symbol 
followed by <enter>. The power symbol appears attached to the cursor. Move the power symbol and release it 
with a click of the left button. Another power symbol appears, it can be released in the same way or the right 
button clicked to cancel it. 
The power symbol primitive itself does not include pin numbers or power rail names, just text positions. These 
are automatically updated from the information held in the power pin definitions in the Attributes > Symbol, Part 
Power Pins window. 
They can can be modified using the Terminals > Assign Pin Numbers or Terminals > Assign Names commands, 
or using the Attributes > Symbol, Part Power Pins window.  

Power Pins > Move 
Used to move power symbols within parts and split parts. 
The position of the power symbol relative to the library symbol is not important; the symbols are added to the 
schematic independently of one another. 
The power symbol should be selected by its datum point. (This was defined in the library primitive when the 
symbol was made and is shown as a diagonal cross.)  
Once selected, point at the datum point of the power symbol and select it with a click of the left button. Move the 
cursor, the power symbol appears attached to it. Position the symbol as required, then click the left button to 
release it. Clicking the right button before the symbol is released, returns the symbol to its original position. 
Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 
Power Pins > Rotate 
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Used to rotate power symbols in 90 degree steps, anti-clockwise within parts and split parts. The power symbol 
is added to the schematic at the orientation shown in the library part. It can be rotated on the schematic as 
required. 
The position of the power symbol relative to the library symbol is not important; the symbols are added to the 
schematic independently of one another. 
The power symbol should be selected by its datum point.  
Once selected, point at the datum point of the power symbol and select it with a click of the left button. The 
symbol rotates by 90 degrees anti-clockwise each time the symbol is selected. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Power Pins > Flip 
Used to flip power symbols within parts and split parts.  
Symbols are flipped about their original y-axis, i.e. symbols are turned left to right about their datum unless they 
have been rotated by 90 or 270 degrees first, in which case they are turned top to bottom about their datum. 
The power symbol is added to the schematic at the orientation shown in the library part. It can be flipped on the 
schematic as required. 
The position of the power symbol relative to the library symbol is not important; the symbols are added to the 
schematic independently of one another. 
The power symbol should be selected by its datum point.   
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Once selected, point at the datum point of the power symbol (not shown) and select it with a click of the left 
button. The symbol flips each time the symbol is selected. 

Power Pins > Delete 
Used to delete power symbols from parts and split parts. The Edit > Preferences, Part Power Pins window is 
automatically updated so the parts power pin definitions are removed.  
The power symbol should be selected by its datum point. The trap distance defined in the Edit > Preferences, 
Miscellaneous window controls how close you have to be to an item to select it. 
Once selected, point at the datum point of the power symbol and select it with a click of the left button. The 
power symbol and its associated attributes are deleted.  

Power Pins > Datum 
Used to position the datum of the power symbol as it will be used when the symbol is positioned on a schematic 
sheet.  
Refer to the Grid command to find out whether grid snapping is active. 
Once selected, point at the position where the datum is required and click the left button. The diagonal cross 
moves to the selected position. 
(If a power symbol is moved, rotated, etc. from within a part or split part, it must be selected by its datum as 
defined in its library primitive.) 

Attributes 
The following commands are available except when editing a design sheet. 
(Attributes of individual parts and connections placed on the schematic sheet are accessed via the Symbols and 
Wires commands.) 
When selected, the commands associated with the part's attributes appear. The attributes include pin numbers, 
part references, gate and pin swapping rules, order codes, etc., plus any user defined attributes. 
The default position and visibility of these attributes plus any user-defined attributes that are always required 
can be defined within the schema_attribs.txt file, held in the Configuration Data Directory 
(MyDocuments/Seetrax/XL Designer/Data by default). 
If parts have already been placed on the schematic and their attributes have been changed using the Symbol > 
Attributes command, those attributes will not be altered by changes made using these commands because 
changes made on the schematic by the user take precedence.  
If parts have already been allocated on the schematic, it may be necessary to de-allocate, then allocate again 
those parts whose attributes have changed (for example when editing pin numbers). 
If a parts/wiring list has already been extracted from the schematic, it may be necessary to re-extract the 
parts/wiring list to implement the changes made to the part attributes.  

Attributes > Symbol 
Used to display, and edit if required the attributes associated with the symbol.  
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Symbol attribute window 
The symbol attribute window initially lists the default attributes and their values obtained from the file: 
schema_attribs.txt file, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data by 
default). 
If an asterisk (*) precedes a Name field entry (not the Value field), that attribute is a system attribute and should 
not be deleted (even though it could be), as it is required by the program elsewhere. i.e. all the entries in Figure 
104. 
Not all of the attributes have values assigned to them by default.  
If an asterisk (*) precedes a value field entry (not the Name field), that entry cannot be changed from the 
window. i.e. the Part ident in Figure 104. 
 

 

Figure 104 

Number of equivalent symbols within part - if a part is being edited, the number of equivalent symbols within 
the part is defined here and can be edited. 

Show part ident suffix - indicates whether a suffix should be added to the part's reference - applicable to 
parts with more than one symbol (gate) only. For instance IC1a, IC1b, IC1c, etc. 

Show Symbol Filled - Symbols can be displayed with a solid infill colour to make them standout on the 
sheet by ticking this box.  
(If an outline does not appear filled when this mode is activated, edit the symbol outline shape to 
ensure that it forms a closed path.) 

Infill Colour: If the symbol will be shown filled, choose the infill colour by selecting this box, then select the 
colour required from the colour palette window that appears. 
The infill will be displayed and output using this colour, whereas the symbol’s outline colour is 
controlled in the schematic output task configuration window. 

Attribute List - lists the attributes and their settings associated with the part. When the part is added to the 
schematic these values are used but each occurrence of the part on the schematic may be edited individually. If 
an attribute change is made to the part that has been placed on the schematic, changes to that attribute in the 
library part will not be reflected in the part already placed on the schematic.  

Attribute Columns: 
Name contains the reference name of the attribute. If a * precedes the name, this is a system 

attribute and used elsewhere in the program – removing it (if permitted) would have 
implications for other tools, such as the extracted parts list, gate swapping in artwork, etc. 

Value  contains the text string or value assigned to the attribute. The * in this field means it cannot be 
edited from this window – the values for part ident’s are controlled by the Allocation 
commands. 
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More than one version can be assigned to a value field. For instance, it may be required that a 
resistor has a value of 220k in UK designs, but 100k in USA designs. Alternatively different 
values may need to be assigned within each instance of a repeated sheet. 
The version names, and which version is currently active are defined in the Edit > 
Preferences, Version Control window. The Structure > Set Version Override command is used 
to assign different values in repeated sheets. 
The value should take the following format when specifying multiple values: 
 versionname!attribute_value  versionname!attribute_value  versionname!attribute_value 
 where: 

versionname  is the version name assigned in the Edit > Preferences, Version Control 
window. 

!  is the character defined for version control in the Edit > Preferences, 
Miscellaneous, window. 

attribute_value  is the value required for that version. 
Examples: 
 UK!220k  USA!100k 
This will give a value of 220k when displayed, plotted or compiled with the UK version 
selected and 100k with the USA version selected. 
Low!1k Mid!10k Hi!100k 
This will give a value of 1k when displayed, plotted or compiled with the Low version selected, 
10k with the Mid version selected and 100k with the Hi version selected. 
It is possible to specify a default version value using the version name *. So for example: 
UK!220k  USA!100k  *!500k 
will produce 220k if the UK version was selected, 100k if the USA version was selected and 
500k for all other versions. 
If the version control character is not used, then those attributes are unaffected by the version 
selection mechanism. 
If a normally visible attribute has no value for a selected version, i.e. it has no *! value then 
(null) will be displayed on screen where the value would normally be. The (null) string will not 
appear when the sheet is plotted. 
The version control character may be used in most part attributes (outline name, ordercode, 
value, etc.) in all user-defined attributes, in connection attributes (signal name) and in non-
electrical text strings. 

Visibility this field controls whether the attribute is visible or not when the part is used on the sheet. 
Options are: 
Not visible  the attribute is not visible. 
Value only  the attribute's value field is visible 
Name +Value  the attribute's name and value field is visible 

Height controls the height of the attribute when it is visible. 
Deletable indicates whether the attribute is permitted to be removed from the part – this setting cannot 

be changed. 
Note: if a system attribute (indicated by a * - value, outline, order code, etc.) is deleted, adding 
a user-defined attribute with the same name does not make it a system attribute, so it will not 
be recognised as such. For example, the value assigned to a user-defined attribute named 
“Order code” will not appear in the parts list. To add a system attribute, use the export/import 
of attributes commands (right-click on the schematic folder). 

To edit any of the above fields (except Deletable) select the attribute then the Edit button. Change the 
details as required followed by OK. 
To delete any of the deletable attributes, select the attribute then the Delete button (greyed out if a 
mandatory field is selected).  

If changes are made within the window select OK to implement the changes, or Cancel to forget the changes. 
 
Add attributes - Extra user-defined attributes can be added if necessary, by selecting the Add attribute button. 
A window requests information about the attribute. The extra attribute information can be extracted when the 
part is used on the schematic, providing a user-defined extraction program is written. Refer to the Tools > 
Parts/Netlist Extraction > User Defined Extraction command.  
Extra attributes are required for the PSpice output (Tools > Parts/Netlist Extraction > User Defined Extraction, 
Pspice Net Extraction) and these are described in the Seetrax XL Designer Installation & Getting Started Guide. 
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If a common attribute has to be added to all parts, then the attribute could be added to the schema_attribs.txt 
file, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data by default). 
Default symbol attributes 

The default settings for new parts are controlled from the schema_attribs.txt file. 
Part ident this field will be updated automatically when the part is used and allocated within a schematic. 

The asterisk will be replaced by the prefix and its parts identifier or reference designator, i.e. 
IC1, IC2, etc. Normally visible. 

Prefix controls the characters in front of reference designators, for example IC, R, C, etc. A prefix 
must be supplied. The first 4 alpha-numeric characters are used. This field is not normally 
visible as the part ident is more useful. 

Outline controls the physical outline that is used for the part in board layout. An outline name must be 
given in order for a parts and wiring list to be produced in the correct format for board layout. 
For this reason a default value of DIL? is supplied. This should be changed to a suitable 
name.  
The first 16 alpha-numeric characters (but not spaces) are inserted into the parts list.  
The outline can be created just prior to artwork design. 

Value this field is optional, but typically contains the part type, i.e. 74LS00, 100k, etc. When filled in, 
the gate and pin swapping routines use this field to determine equivalent parts.  
This field is inserted into the parts list Type field, which has a maximum of 33 characters. 
However the Type field is made up of the part name and value fields, separated by a comma, 
eg 7400,74LS00 so this should be taken into account when assigning values. 

Symswap this field is optional, but must be filled in if gate swapping will be required on the layout.  
Equivalent symbols are usually defined within the library part, using the Attributes > Symbol 
Swap Rule command - this field will therefore be filled in automatically.  However, the field is 
either left blank or set to: 
G0 gate swapping not permitted. 
G1 gate swapping permitted between equivalent symbols within the part. 
G2 gate swapping permitted between equivalent symbols within the part and with other 

identical parts. 
Order code this field is optional. The first 16 alpha-numeric characters are inserted into the parts list if 

present.  
Any other attributes are user defined.  
User-defined attributes are added by selecting Add attribute button, then filling in the appropriate details.  
To force a user-defined attribute to appear in the part attribute window when a part is created, the file 
schema_attribs.txt file, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data 
by default) can be edited. This file also controls the default height, visibility and names for all attributes. 
Part Power Pins tab 

When the Attributes > Symbol window is opened, the Part Power Pins tab can be selected to open the power 
pins definition window for the part. 
Power pins do not have to be defined in this way, they can simply be added as terminals and numbered and 
named in the way that other pins are added. However, defining a pin as a power pin has advantages - they don't 
have to be visible on the symbol or schematic, but the connection to the power rails will be made automatically. 
These connections are automatically assigned a different track code so that they can be assigned a different 
width on the artwork. 
Power pins defined in this way can also be assigned a separate power symbol (if required). This symbol can be 
placed on the sheet as required, allowing its pins to be connected through pull up/down resistors if required.   
If a pin is defined as a power pin, then a terminal should not be added to the library part. The Seetrax XL 
Designer Installation & Getting Started Guide gives examples of how to create and use parts with power pins 
and power pin symbols. 

Attributes > Pin 
Used to display, and edit if necessary the attributes associated with the pins (terminals). Most of the information 
can be entered graphically using the Terminals commands.  
Select Attribs > Pin, point at the pin (terminal), then select it with a click of the left button.  
 

Pin attribute window 
A pin attribute window (Figure 105), lists the attributes that have been defined for the pin, the values 
assigned to the attribute, whether they are visible and their height. If the field is optional, it may be deleted if 
required.  
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Figure 105 

Name contains the reference name of the attribute. If a * precedes the name, this is a system 
attribute and used elsewhere in the program – removing it (if permitted) would have 
implications for other tools, such as the electrical rules checker. 

Value contains the text string or value assigned to the attribute.  
If an asterisk (*) precedes a Value field entry, that entry cannot be changed from the window. 
i.e. the Outline pinref value in Figure 105 which is controlled by the Terminals > Assign Pin 
Numbers command. 

Visibility controls whether the attribute is visible or not when the part is used on the sheet. Options are: 
Not visible - the attribute is not visible. 
Value only - the attribute's value field is visible 
Name +Value - the attribute's name and value field is visible 

Height controls the height of the attribute when it is visible. 
Deletable indicates whether the attribute is permitted to be removed from the part – this setting cannot 

be changed. 
Note: if a system attribute (indicated by a *, i.e. Pin Name, Logic type) is subsequently 
deleted, adding a user-defined attribute with the same name does not make it a system 
attribute, so it will not be recognised as such. For example, the value assigned to a user-
defined attribute named “Logic type” would not be recognised by the electrical rules checker.  

To edit any of the above fields (except Deletable) select the attribute then the Edit button. Change the 
details as required followed by OK. 
To delete any of the deletable attributes, select the attribute then the Delete button.  
Extra user-defined attributes can be added if necessary, by selecting the Add attribute button. A new 
attribute line is created and can be filled in as required. The extra attribute information can be extracted 
when the part is used on the schematic, providing a user-defined extraction program is written. Refer to the 
Tools > Parts/Netlist Extraction > User Defined Extraction command.  
If a common attribute has to be added to all new part pins, then the attribute could be added to 
schema_attribs.txt file, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data 
by default). 
If changes are made within the window select OK to implement the changes, or Cancel to forget the 
changes. 
Default pin attributes 

The default settings for new pins are controlled from the schema_attribs.txt file, held in the Configuration Data 
Directory (MyDocuments/Seetrax/XL Designer/Data by default). 

Outline pinref indicates the pin number of the pin. This pin number is linked automatically to the 
physical pad with the same pin number.  
Pin numbers must be supplied for library parts and split parts.  
The pin numbers can only be changed using the Terminals >Assign Pin Numbers 
command. 
Where the pin selected is an element from a multi-element part, then all the pin numbers 
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for that pin are shown, separated with a | sign. 
Upto 16 alpha-numeric characters in any order can be used.  

Pin name indicates the optional name assigned to the pin, for instance WE, CS, DI, etc.  Upto 16 
alpha-numeric characters can be used, in any order. 

Logic type indicates the logic type of the pin. By default it is set to Unspecified port. The electrical 
rules checker refers to this information when checking the schematic for errors. Selection 
is made from the arrow alongside. 

Pin swap rule indicates the pin group the pin belongs to. On the layout connections can be swapped 
between any pins within a gate or part that belong to the same group.  Group numbers 
run from 0 to 6. Pins within group 0 are not swappable. Equivalent pins are typically 
defined within the library part, using the Termianls > Set Pin Swap Rule command.  

Any other attributes are user defined. User-defined attributes are added by selecting Add attribute button, 
then filling in the appropriate details.   
To force a user-defined attribute to appear in the pin attribute window when a new part is created, edit  the 
schema_attribs.txt file, held in the Configuration Data Directory (MyDocuments/Seetrax/XL Designer/Data 
by default). 
This file also controls the default height, visibility and names for all attributes. 

Attributes > Move 
Used to move a part or pin attribute. 
Once selected, point at the attribute to be moved and click the left button. As the cursor is moved, the selected 
attribute is seen attached to it with a line extending to the item it belongs to (the part or the pin). Position the 
attribute and release it with a click of the left button. 
As the attribute is being moved, it can be rotated by 90 degrees by pressing the <rotate part> special function 
key. (See Attributes > Rotate for details on attribute rotation.) Clicking the right-hand mouse button before it is 
released restores the attribute to its original location. 
Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 

Attributes > Hide 
Used to hide (make invisible) an attribute associated with the part or a pin. 
Once selected, point at the attribute (text string) that you want to hide, then click the left-hand mouse button. 
The attribute is hidden. 
It can be restored to view if the Attributes > Symbol/Pin command is used and the text string made visible again. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 

Attributes > Rotate 
Used to rotate an attribute associated with the part or a pin. Only two orientations are available, 0 degrees or 90 
degrees. 
Once selected, point at the attribute (text string) to be rotated, then click the left button. The attribute rotates by 
90 degrees. If the attribute is selected again, it rotates to its original orientation. 
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. The rotated text display mode in the Edit > Preferences, Miscellaneous window controls 
how/whether the characters within the string are rotated. 

Attributes > Symbol Swap Rules 
Used to define whether gate swapping is allowed. Gate swapping is not permitted by default. The number of 
gates within a part is defined in the symbol attributes window (Attributes > Symbol). 
Symbol swapping allows all of the connections attached to a symbol to be swapped with all the connections of 
another identical symbol. 
Gates within parts are always equivalent to one another, but by default swapping is not permitted. Local or 
global swapping can be enabled. 

No swapping indicates that gate swapping is not permitted. 
Global swapping indicates that gate swapping is permitted between gates within the package and also 

between other packages of the same type. For instance, if the gates of a 7400 were 
allowed to swap globally, and two 7400’s were used on the schematic, gate swapping 
could take place between all eight gates; each gate could be swapped with seven other 
gates (four gates per package). 

Local swapping indicates that gate swapping is permitted between gates within the same package only. 
For instance if the gates of a 7400 were allowed to swap locally, and two 7400’s were 
used on the schematic, gate swapping could take place within each of the packages, but 
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not between them; each gate could be swapped with the other three gates within the 
package. 

When selected a window appears from which one of the above choices should be made.  
If a split part is being edited, the gate swapping rules are accessed from the Subsymbol > Swap Rules 
command. 

Subsymbol commands 
Used to add, delete, or move the primitives associated with a split part. These commands only appear when a 
split part is being edited.  
Parts should be defined as split parts when the part is made up of symbols (or gates) that are different from one 
another and need to be spread around the schematic. For instance a relay is made from two different symbols 
(coil and contacts) that are not always positioned together. 
Parts that are made up of one or more symbols which are the same, should be made as a library part, for 
instance a 7400 which contains 4 x 2 input nand gates, unless you want to show the power pins on one of the 
gates (rather than as a separate power symbol). 

Subsymbol > Place 
Used to select the primitives required in the split part.  
Refer to the Grid command to find out whether grid snapping is active. 
Once the command is selected, use the Navigator pane to locate the primitive required. Once located, select it, 
then move the cursor and attached primitive into the split part window.  
The primitive can be rotated in 90-degree increments or flipped by pressing the <rotate part> or <flip part> 
special function keys. Position the primitive and release it with a click of the left button. Another primitive 
appears on the end of the cursor, release it in the same way if it is required. 
The position of sub-symbols with respect to one another in the split part is unimportant. The symbols are placed 
onto the schematic individually. 
To select and place a different primitive, move back to the navigator and select another primitive. Click the right-
hand mouse button when no more primitives are required. 

Subsymbol > Move 
Used to move subsymbols (or primitives) within split parts. 
The position of the primitives relative to one another is not important, as the primitives are added to the 
schematic independently of one another. 
The primitive is selected by its datum point, which is shown as a small cross. This was defined in the primitive 
when the symbol was made.  
Refer to the Grid command to find out whether grid snapping is active. The trap distance defined in the Edit > 
Preferences, Miscellaneous window controls how close you have to be to an item to select it. 
Once selected, point at the datum point of the primitive, then select it with a click of the left button. Move the 
cursor, the primitive appears attached to it. Position the primitive as required, then click the left button to release 
it. Clicking the right button before the primitive is released, returns the primitive to its original position. 

Subsymbol > Rotate 
Used to rotate subsymbols (primitives) in 90 degree steps, anti-clockwise within split parts. The primitive is 
added to the schematic at the orientation shown in the split part. It can be rotated on the schematic as required. 
The position of the primitive relative to the other primitives is not important, as the primitives are added to the 
schematic independently of one another. 
The primitive is selected by its datum point, which is shown as a small cross. This was defined in the primitive 
when the symbol was made.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Once selected, point at the datum point of the primitive, then select it with a click of the left button. The primitive 
rotates by 90 degrees anti-clockwise each time it is selected. 
Subsymbol > Flip - Used to flip subsymbols (or primitives) within split parts.  
Primitives are flipped about their original y-axis, i.e. primitives are turned left to right about their datum unless 
they have been rotated by 90 or 270 degrees first, in which case they are turned top to bottom about their 
datum. 
The primitive is added to the schematic at the orientation shown in the split part. It can be flipped on the 
schematic as required. 
The position of the primitive relative to the other primitives is not important, as the primitives are added to the 
schematic independently of one another. 
The primitive is selected by its datum point, which is shown by a small cross. This was defined in the library 
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primitive when the symbol was made.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Once selected, point at the datum point of the primitive, then select it with a click of the left button. The primitive 
flips each time it is selected. 

Subsymbol > Delete 
Used to delete subsymbols (or primitives) from split parts.  
The primitive is selected by its datum point, which is shown as a small cross. This was defined in the library 
primitive when the symbol was made.  
The trap distance defined in the Edit > Preferences, Miscellaneous window controls how close you have to be to 
an item to select it. 
Once selected, point at the datum point of the primitive, then select it with a click of the left-hand mouse button. 
The primitive and its associated attributes are deleted.  

Subsymbol > Swap Rules 
Used to define whether gate swapping is allowed. Gate swapping is not permitted by default. 
Symbol swapping allows all of the connections on the artwork attached to a symbol, to be swapped with all the 
connections of another identical symbol. 
By default swapping is not permitted. Local or global swapping can be enabled. 

Local swapping indicates that gate swapping is permitted between equivalent gates within the same 
package only.  

Global swapping indicates that gate swapping is permitted between equivalent gates within the package 
and also between other packages of the same type.  

When selected large circles appear on the datum of the individual primitives (gates) in the split part. These 
circles and their colour indicate which gates within the package are equivalent to one another, and whether local 
or global swapping is permitted.  
Initially all gates are unequal (clear circles), they are not equivalent to any other gate so cannot be swapped on 
the layout. 
Once the command is selected, use the buttons in the Split Part Swap Rule dialogue bar on the left of the 
screen, to select Local or Global swapping, then select one of the colours. Now select the gates that are to be 
equivalent to one another, their circle will change colour and contain the letter L for Local or G for Global 
swapping. 
To return the gates to unequal, select U from the dialogue bar on the left of the screen then select the gates that 
are unequivalent. 

Schematic configuration file – “schema_attribs.txt” 
The file schema_attribs.txt file exists in the Configuration Data Directory which, when the software was installed 
was set to the folder:   MyDocuments/Seetrax/XL Designer/Data 
The path can be verified from the File > System Setup window. 
(For Ranger2 XL and Ranger XL users, the schema_attribs.txt file replaces the capture.cfg file that they may 
have been familiar with, but it no longer holds library information.) 
The schema_attribs.txt file defines the default attributes of parts, pins and connections, and their default visibility 
and position.  
This file can be modified (carefully) using Notepad or a similar editor to change these defaults, to add new user-
defined attributes or to change library names/descriptions.  
If new attributes are added to this file, they are added to all new parts/pins. 
The complete content of schema_attribs.txt is listed below, followed by a description of the entries. 

Important! 
Always close Seetrax XL Designer before modifying schema_attribs.txt. 
Before editing it, take a backup copy of the file as a precautionary measure.  
Only alter the data as described below, do not alter anything else. 

Content of schema_attribs.txt 
# Circuit schematic configuration and default attributes dictionary 
# 
#--------- Reserved attribute code naming section ---------------------- 
# 
.dict_defaults 
    0    "Part ident"        # Allocated part ident (placeholder only) 
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    1    "Prefix"            # Part code prefix     (never visible) 
    2    "Value"             # Default component value 
    3    "Outline"           # Outline library entry 
    4    "Order code"        # Data for parts list bill-of-materials field 
    5    "Symswap rule"      # Swapping rule for equivalent symbol instances. 
    6    "Block name"        # Displayed name for instances of user blocks 
    7    "Pin name"          # Symbol i/o pin name 
    8    "Outline pinref"    # Pin reference on outline library entry. 
    9    "Pinswap rule"      # Swapping rule for equivalent symbol pins. 
   10    "Logic type"        # Pin logical type (eg.. tri-state, open-
collector) 
   11    "Bus subscript"     # Bus ripper signal subscript. 
   12    "Signal name"       # Signal name. 
   13    "Routing width"     # Ranger track routing width code. 
   14    "Minimum clearance" # Minimum permitted track clearance 
   15    "Datasheet Addr"    # URL or filepath to online datasheet 
.end 
# 
#--------------------- Miscellaneous attributes ----------------------------- 
# 
# Generic extractor configuration and tools path 
# .genex_path  ./genex 
# 
#------- Default symbol and pin attributes for each block type -------------- 
# 
# ins flag values : 'M' = mandatory, 'O' = optional. 
# ved   "    "    : 'Y' = value editable, 'N' = value non-editable 
# vis   "    "    : 'value' 'name+value' 'off' 
# 
.libprim_symbol 
   $0              ""      ins=M ved=N vis=value x=0 y=0.15 height=0.08 
   $2              ""      ins=O ved=Y vis=value x=0 y=-0.15 height=0.08 
.end 
 
.libprim_pin 
   $8              ""      ins=M ved=Y vis=value x=-0.2 y=-0.15 height=0.08 
   $7              "Name"  ins=O ved=Y vis=value x=-0.2 y=0.15 height=0.08 
   $10             ""      ins=O ved=Y vis=off height=0.08 
   $12             ""      ins=O ved=Y vis=off height=0.06 
.end 
 
.libpart_symbol 
   $0              ""      ins=M ved=N vis=value x=0 y=0.15 height=0.08 
   $1              "IC"    ins=M ved=Y 
   $3              "DIL?"  ins=M ved=Y 
   $2              ""      ins=O ved=Y vis=value x=0 y=-0.15 height=0.08 
   $4              ""      ins=O ved=Y 
   $5              ""      ins=O ved=Y 
   $15             ""      ins=O ved=Y 
.end 
 
.libpart_pin 
   $8              ""      ins=M vis=value x=-0.2 y=-0.15 height=0.08 
   $7              "Name"  ins=O vis=value x=-0.2 y=0.15 height=0.08 
   $10             ""      ins=O ved=Y vis=off height=0.08 
.end 
 
.libspart_symbol 
   $1              "IC"    ins=M ved=Y 
   $3              "DIL?"  ins=M 
   $4              ""      ins=O 
   $15             ""      ins=O ved=Y 
.end 
 
.libspart_pin 
   $8              ""      ins=M vis=value x=-0.2 y=-0.15 height=0.08 
   $7              "Name"  ins=O vis=value x=-0.2 y=0.15 height=0.08 
   $10             ""      ins=O ved=Y vis=off height=0.08 



 

145 

.end 
 
.userblock_symbol 
   $6              ""      ins=M ved=N vis=value x=0 y=0.15 height=0.08 
.end 
 
.userblock_pin 
   $7              "NET"   ins=M vis=value x=-0.2 y=0.15 height=0.08 
.end 
 
.blockio_symbol 
.end 
 
.blockio_pin 
   $7              "NET"   ins=M vis=value x=-0.2 y=0.15 height=0.08 
.end 
 
.connection_attribs 
   $12                 ""      ins=O vis=value       height=0.06 
   $13                 ""      ins=O vis=name+value  height=0.04    
   $14                 ""      ins=O vis=name+value  height=0.04    
.end 

Description of the entries within schema_attribs.txt 
Any line that starts with a #, or text after the # on a line is ignored. These are comments. 
The file is case sensitive, so do not replace uppercase characters with lowercase characters or vice-versa. 
The file is divided into sections, and these are now described. 

Reserved attribute code naming section  
The first section within the file lists the internal code numbers assigned to the system attributes, as follows:  
 

.dict_defaults 

   0 "Part ident" # Allocated part ident (placeholder only) 

   1 "Prefix" # Part code prefix     (never visible) 

   2 "Value" # Default component value 

   3 "Outline" # Outline library entry 

   4 "Order code" # Data for parts list bill-of-materials field 

   5 "Symswap rule" # Swapping rule for equivalent symbol instances. 

   6 "Block name" # Displayed name for instances of user blocks 

   7 "Pin name" # Symbol i/o pin name 

   8 "Outline pinref" # Pin reference on outline library entry. 

   9 "Pinswap rule" # Swapping rule for equivalent symbol pins. 
  10 "Logic type" # Pin logical type (eg.. tri-state, open-
collector) 

  11 "Bus subscript" # Bus ripper signal subscript. 

  12 "Signal name" # Signal name. 

  13 "Routing width" # Ranger track routing width code 

  14 "Minimum clearance" # Minimum permitted track clearance 

  15 "Datasheet Addr"    # URL or filepath to online datasheet 
.end 

 
These code numbers are referred to later on in the file. For instance part idents have an internal code of 0, 
prefixes code 1, values code 2, etc. These entries must not be changed or added to. 

Miscellaneous attributes  
As supplied this section is commented out, so has no effect.  
By default Seetrax XL Designer will locate the generic extractor files from the path specified for them in the 
File > System Setup window. 
 

#--------------------- Miscellaneous attributes ----------------------------
- 
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# 
# Generic extractor configuration and tools path 
# .genex_path  ./genex 
# 

 
However the user can choose to over-ride the default path with a path of his/her own choosing and 
therefore store the .gex files anywhere that can be accessed.  
If so required, uncomment the line as shown below and specify the path to the folder containing the generic 
extractor configuration files (these files all end with a file name extension of  '.gex'). 
 

# Generic extractor configuration and tools path 
.genex_path  <path to *.gex files> 

 

Default symbol and pin attributes for each block type 
This section determines which attributes are used within the different types of “part” on the schematic. Each 
“part” type has its own entry starting with a . (dot) and ending with a .end statement.  

Parts look for .libpart_symbol and .libpart_pin 
Split parts look for .libparts_symbol and .libparts_pin 
Primitives look for .libprim_symbol and .libprim_pin 
Design symbols look for .userblock_symbol and userblock_pin  
Block I/O ports look for .blockio_symbol and .blockio_pin 
 

For example, the following entries define the attributes associated with a primitive and its pins (the columns 
have been spread out for ease of identification. 
 

 .libprim_symbol 
   $0 "" ins=M ved=N vis=value x=0 y=0.15 height=0.08 

   $2 "" ins=O ved=Y vis=value x=0 y=-0.15 height=0.08 

.end 

.libprim_pin 

   $8 "" ins=M ved=Y vis=value x=-0.2 y=-0.15 height=0.08 

   $7 "Name" ins=O ved=Y vis=value x=-0.2 y=0.15 height=0.08 

   $10 "" ins=O ved=Y vis=off    height=0.08 

   $12 "" ins=O ved=Y vis=off    height=0.06 

.end 

 
In this example, the second and third lines define the attribute codes associated with the primitive symbol. 
(The code numbers are preceded by a $.) They are 0 and 2 (part ident and value as defined in the 
Reserved attribute code naming section of the file).  
Lines six through to nine define the attributes associated with the pins of a primitive, which are 8 (outline 
pinref), 7 (pin name), 10 (logic type) and 12 (signal name).  
The text string within the "" will appear everytime the symbol is created or a pin is added to the symbol.  
In this example, the string Name will appear alongside a pin when it is added to the primitive, the string 
corresponds to the pin name (code7).  No other values will be assigned. 
The remaining parameters on these lines are now described. 

ins flag values control whether the attribute is a mandatory one. 
It can either be set to M for mandatory or O for optional - do not change the 
mandatory values assigned to the supplied system attributes.  
If an attribute is set to mandatory, then it will always appear in the attribute window 
and cannot be deleted. If it is set to optional, then it will appear but can be deleted.  

ved flag values control whether the attribute can be edited.  
Can either be set to Y, for yes the value assigned to the attribute can be edited from 
the schematic editor or N for no the value cannot be edited. 

vis flag values control the default visibility of the attribute. It can either be set to: 
 value displays the value assigned to the attribute 
name+value displays the attribute name and the value assigned to it 
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off does not display the attribute or its value. 
 
Looking at the attributes for a part, which are shown now.  
 

.libpart_symbol 
   $0 "" ins=M ved=N vis=value x=0 y=0.15 height=0.08 
   $1 "IC" ins=M ved=Y 
   $3 "DIL?" ins=M ved=Y 
   $2 "" ins=O ved=Y vis=value x=0 y=-0.15 height=0.08 
   $4 "" ins=O ved=Y 
   $5 "" ins=O ved=Y 
   $15 "" ins=O ved=Y 
.end 
 
.libpart_pin 
   $8 "" ins=M vis=value x=-0.2 y=-0.15 height=0.08 
   $7 "Name" ins=O vis=value x=-0.2 y=0.15 height=0.08 
   $10 "" ins=O ved=Y vis=off    height=0.08 
.end 

 
As in the previous description, $ precedes the code munbers. Each code number refers back to the internal 
code obtained from the first section. $0 = part idents, $1 = prefixes, $2 = values, etc. 
After the internal code number are a pair of "". The text string within the "" will appear by default for that 
attribute.  For instance, the symbol's part prefix (code 1) will be set to IC and its outline name (code 3) to 
DIL?. When a pin is added to a library part, its pin name (code 7) is set to Name.  
Most attributes do not have a default entry. 
Each entry is followed by the three parameters described above.  So for instance, looking at the entry for 
code 2, the Value attribute.  
 

$2 "" ins=O ved=Y vis=value x=0 y=-0.15 height=0.08 

 
It doesn't have a default value assigned because the "" are empty.  
It's an optional entry (ins=O), it can be edited (ved=Y), and the value assigned to it will be displayed 
(vis=value). The position of the value field with respect to the datum of the symbol, is X=0 and Y=-0.15" 
and the attribute text will be 0.080" tall. 
When X and Y values are given for pin attributes, they are with respect to the pin itself. So for instance: 
 

$7 "Name" ins=O vis=value x=-0.2 y=0.15 height=0.08 

 
Code 7 the pin name, has a default value assigned of Name because Name is found within the "". It is an 
optional entry ins=O and its value is visible vis = value. It is positioned 0.2" to the left of the pin and 0.15" 
above the pin x=-0.2 y=0.15, the text height will be 0.08". 

Adding User-Defined attributes as defaults 
In the example below, new user-defined attributes Price and Supplier have been added to the part symbol.  
 

.libpart_symbol 
   $0 "" ins=M ved=N vis=value x=0 y=0.15 height=0.08 
   $ "IC" ins=M ved=Y 
   $3 "DIL?" ins=M ved=Y 
   $2 "" ins=O  ved=Y vis=value x=0 y=-0.15 height=0.08 
   $4 "" ins=O  ved=Y 
   $5 "" ins=O  ved=Y 
   $15 "" ins=O  ved=Y 
   "Price" "" ins=M  ved=Y vis=off 
   "Supplier" "" ins=M  ved=Y vis=off 
.end 
.libpart_pin 
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   $8              "" ins=M  vis=value x=-0.2 y=-0.15 height=0.08 
   $7              "Name" ins=O  vis=value  x=-0.2 y=0.15 height=0.08 
   $10             "" ins=O ved=Y vis=off   height=0.08 
.end 

 
User-defined attributes must not be preceded by a $ sign and the attribute names should appear in "" as 
shown. Apart from that, they are treated in the same way as supplied attributes.  
If these entries were added to the file, any parts edited from that point on, would contain the attribute names, 
Price and Supplier. 
Note: if a user-defined attribute is added to this file and values entered from the schematic editor, the values will 
be lost if the attribute is subsequently removed from this file. 
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Component Outline Folder 
Each design has its own component outline folder, which contains the component outlines used on that 
particular design, plus any others the user may choose to include.  
The component outline or "footprint" represents the physical size and shape of a component that is placed on 
the artwork. 
Component outlines that are required in the design are copied automatically from the master component outline 
folder (if they exist) as and when they are required. This typically happens when the parts/nets list is extracted 
from the schematic, the parts list is modified or component outlines are swapped on the artwork.  
Component outlines can also be copied/pasted to/from other component outline folders (other designs or the 
master folder). The component outlines can also be created directly in the folder. 
Once component outlines have been copied into the design, changes to them do not affect the original 
component outlines, other designs or the master component outline folder.  
Changes to component outlines in the master component outline folder do not affect any other designs. 
The master component outline folder is accessed from the Masters folder in the navigator window. It is 
suggested that component outlines are created within a design folder and verified before they are copied to the 
master folder. Once component outlines are in the master folder it is assumed they are correct. 

Opening/viewing the component outline folder and its content 
Locate the component outline folder required from the navigator window. The master component outline folder is 
held inside the Masters folder, whilst each design’s component outline folder is held inside the design folder. 
Once found, double-select select the Component Outlines folder (or select the + sign alongside it) to open it. If 
component outlines exist in the folder they will be listed below the open folder in the navigator pane. 
The component outline folder of a new design will be empty. 
To close the folder, either double-select the folder (or select the - sign alongside it). 
If outlines are listed they can be selected in turn to browse through them. They are shown graphically in the 
Browser window and their properties are displayed in the Properties window (if those windows are open). An 
outline can be opened for editing by double-selecting it. 
 
When the component outline folder is selected, the total number of outlines held within it are shown in the 
Properties pane. 

Component outline information 
Viewing direction (from top or bottom) 
It doesn't matter whether component outlines are viewed from the top or the bottom of the board, provided they 
are all viewed from the same direction. In practice, most companies view outlines from the top of the board.  
The supplied component outlines are viewed from the top of the board. If outlines will be added to this folder, 
then they should also be created as viewed from the top of the board. 
Parts can be flipped from the top of the board to the bottom, once they have been placed on the artwork. Silk 
screen part names are automatically mirrored if parts are flipped. (Text that is added to the outline using the 
Outline > Text commands is not mirrored when parts are flipped.   

Pads 
When a component outline is created, it should be designed so that it could be used on single, double or multi-
layer designs without further editing. To this end, the component pads are added as a "stack" of pads.  
The stack within SXLD comprises of a pad that is used on the top of the design, a pad that is used on all the 
inner layers of the design and a pad that is used on the bottom of the design. (These layers are described as 
Top, Inner & Bottom.) 
For instance, pin 1 of a component could be defined as a square pad on the bottom of the board, as a round-
ended rectangular pad on the top of the board and with small round pads on all the inner copper layers of the 
board, however many there are. 
(Layers defined as power planes have their own pad definition for the layer and this is described in the 
description of the standard pads folder.) 

Through-board components 
When creating component outlines that require a hole through the board, pads should be added to all the 
layers in the stack, even if the outline will only be used on single or double-sided boards – pads on unused 
layers are ignored. 
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The pad used on the inner pad determines the hole size of the pad stack, so it must be included if a drilled 
pad is required. A pad stack that only has a pad on the top or bottom, or top and bottom of the board will 
not be drilled. 

Surface mounted components  
Surface mounted component outlines should have their pads added to only the top, or only the bottom of 
the stack, depending on which side it will be mounted. Bear in mind that outlines can be flipped from side to 
side once in the artwork editor, so it is only necessary to create one outline that can be used on the top and 
bottom of the board.  
It is wise to always build outlines from one side of the board (usually top), then flip them if they are required 
on the other side of the board.  
This ensures that all flipped parts are on one side of the board (usually bottom) and un-flipped parts are on 
the other (usually top).  
When the silk-screens layers are generated, the silk-screen for flipped outlines and labels are placed on 
one side of the board and unflipped outlines and labels on the other. If the outlines were defined with some 
outlines defined on the bottom of the board and others on the top of the board, when these outlines are 
placed on the artwork, they will be on different sides even though they haven’t been flipped and this will 
cause confusion. 

How modifications to outlines in use on the artwork are implemented 
Changes made to outlines in the design outline folder do not affect other designs or the master folder. 
If pads are modified, moved or deleted using the Pad commands from within the design library and the outline is 
already used on the artwork, be aware that all occurrences of that outline in the artwork are automatically 
updated – but only when the outline has been closed. Whilst the outline’s editing window remains open, the 
artwork is not updated.  
Note: if individual pads in outlines have been changed in the artwork editor (using the Amend commands to 
change size/shape), then changes in the outline to the size/shape of those pads will not be implemented on 
those outlines in the artwork. Changes made on the artwork to individual pads in outlines take precedence over 
general changes to outlines. 
If silkscreen data or free layer information (i.e. data added using the Outline commands or Copper commands 
on the Free copper layers) is modified from within the design library and the outline is used on the artwork, all 
occurrences of that outline in the artwork are automatically updated. However, if the silk screen outlines and free 
layers have been generated on the artwork using the Tools > Generate silk-screen command, then that data is 
not updated. 
If data on the top, bottom or all layers is modified using the Copper commands from within the design library and 
the outline is used on the artwork, these changes are not updated on the artwork until the part is flipped 
(typically parts are flipped twice, once to update them, the second to restore them to their original side). 

Component outline families - introduction 
The outlines can be added to "families" (right-click on the component outline folder, then select Manage 
Families from the options that appear). Outlines within the same family can be swapped one for another in the 
artwork editor. For example an SO14 and DIL14 could be added to the same family. A DIL14 might be called up, 
but if there was insufficient space on the artwork it could be swapped for the SO14 easily and quickly (provided 
the part was available in both styles). There are no hard and fast rules on which outlines to add to a family, but a 
family of 2 pin outlines, 3 pin outlines, 14 pin outlines, 16 pin outlines, etc. might be useful. 

Additional "copper"/free copper - introduction 
Until now in this description, "pads" have been referred to and these have corresponded to the pads required for 
the part to be inserted into/soldered onto the board. Each of these pads will have a pin number that corresponds 
to the schematic device and "physical" part. They are added and numbered using the Pad commands. 
Within the component outline editor there is an additional type of pad that can be added. These are added using 
the Copper commands, but they may not always be "made" from copper. For instance they can represent solder 
paste or glue spot pads. 
An outline must always have at least one pad added from the Pad menu, but it does not have to contain any 
pads from the Copper menu. 
Copper pads on the top, inner or bottom layers are only used for particular applications such as stringers and 
dual outlines (both described below).  
"Copper pads" can also be placed on "free layers" in order to create the user-defined solder paste pads, solder 
mask pads, glue spots, etc. There are eight "free layers". They are called free layers because the data that is 
added to them can appear on any user-specified layer once the outline has been placed on the artwork. (The 
layers used can vary between designs.)  
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The free layers can be given user defined names, for instance, top paste, bottom paste, glue spot, etc. to assist 
in their recognition. These layers will be defined as silk screen layers; they do not form part of the electrical 
connectivity and are not checked during artwork checking.  
If a "copper pad" is added, it is never given a number. If it is added to the top, bottom or inner layers, it must be 
placed on the end of a piece of copper track on the same layer, which in turn has to start from a pad added 
using the Pad commands. 
The pads and tracks on the free layers do not appear automatically when the outlines are used in a layout. The 
layer is added as required via the artwork editor Tools > Generate silk-screen command. 
Note: Ranger will produce solder paste and solder mask output files automatically, which output the used pins 
with a uniform user-defined pad reduction/swell. It is therefore unnecessary to create these free layers unless 
you have specific requirements.   
Pads and tracks that are added to free layers can be placed anywhere, they do not have to be attached to a 
track or pin. 
Points to bear in mind when using outlines containing "copper" 

* If family swapping is used within the artwork (Parts > Change Outline command) and the new outline 
contains copper, it will need to be flipped twice to introduce the copper (the first flip introduces the 
copper as well as flipping the part, the second flips it back onto the correct layer). Alternatively, the part 
could be removed to the tray and placed again. 

* The stringers can be ripped up using the Mroute > Ripup command. The connections are displayed 
from the point where the stringer was. Use the Parts > Reconnect Power command to restore the 
connections to the pins. 

* Gate and pin swapping cannot be used on gates or pins whose connections have been pre-routed. 
This means that gate and pin swapping cannot be used on pins with stringers or dual outlines. (If gate 
and pin swapping has to be used, rip-up the copper using the Mroute > Ripup command. Use the Parts 
> Reconnect Power command to reconnect the connections back to the pins. Gate and pin swapping 
can then be used. Use the Parts > Flip  command (twice) to restore the copper to the part.) 

* None of the auto-routers can accept stringers, so do not submit boards containing stringers to the auto-
routers. 

Stringers 
These are tracks that lead from the pad of a surface mounted device to a via.  
Under normal circumstances, when routing to a surface mounted pad, the track has to terminate on the same 
layer as the pad, which can lead to congestion around the component.  
If stringers are used in a suitable pattern, the track to the via on the end of the stringer can appear on any layer, 
so there is less congestion. Stringers should therefore assist in the routing of the layout but the down-side can 
be the increase in the number of vias on the board that may not be required.  
The stringers can be built into the component outline. The stringer is treated as a via and track once the outline 
appears in the artwork editor so it can be modified or ripped up if it is not required. 
Note: it is not recommended that stringers are added to outlines within Ranger. The auto-routers add stringers 
as required and will not accept those defined in the outline. When manually routing, it is usual just to add the 
stringers as required. 

Dual outlines 
A dual outline consists of an outline with an extra set of pads linked to the original pads, with copper tracks.  
Dual outlines are typically used when a part can be supplied in different packages and it is unknown which type 
will be available when the board is assembled, for instance a dual-in-line or surface mount package. 

Saving an outline 
Individual outlines cannot be saved, all the changes within the design are held in memory until the design is 
saved. 

Creating an outline, general guidelines 
The commands referred to are described in detail later in this chapter. 
From the navigator, right-click over the component outline folder where the component outline will be created, 
then select New from the options that appear, supply an appropriate name. Double-select the outline to open it 
for editing. 
Check the Grid is set to suit the pad pitch requirements. 
Check the pad and line sizes available - double-select the Standard pads folder then double-select any of the 
pad shape folders to open the complete list of pad shapes/sizes & track sizes. Change them as necessary, but 
bear in mind that vias and existing outlines may be using the size codes with values assigned in the table (i.e. 
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those set to 0 are unused). 
If copper will be added to the free layers, define the free layer names and colours via the Copper > Free Copper 
Setup command. 
Add the pads using the Pad > Add/Auto Add command. 
Assign the pin numbers using the Pad > Assign/Auto-assign command. 
Position the datum of the outline, Outline > Set Outline Datum. 
Define the bounds of the outline using the Autoplace > Adjust Footprint command. 
Add the silk screen outline using the Outline commands, you may need to change the Grid. 
Add the stringers, dual outlines or free pads using the Copper commands. 
Define the component’s height details if the DXF 3D Solid model output tool will be used View > Properties. 
If the Specctra or Elecctra autorouter will be used, decide whether vias will be allowed in the smd pads in the 
outline (if applicable) View > Properties. 
The outline is ready to be used on the artwork once the outline editing window has been closed. 
If more outlines need to be created or modified, repeat the procedure. 

Individual commands in the component outline editor  
An overview of the outline editor can be found in the Installation & Getting Started Guide. Here we describe 
each of the outline editor commands in detail.  

Right-click on component outline folder 
Right-clicking on the Component Outline folder in the navigator window introduces the following commands:  

New  Paste Manage Families Edit Properties Purge Unused Outlines 
These commands are described below. 

New - Creating a new component outline 
A new outline can be created by right-clicking the component outline folder in the navigator window and 
selecting New from the options that appear. A new outline is added at the bottom of the list of outlines in the 
folder, called Unnamed. It can be renamed at that point as it is highlighted ready for editing. However, if <enter> 
is pressed or the cursor is selected elsewhere, the original name (unnamed) will remain. It can be renamed by 
right-clicking on the outline and selecting Rename. 

Paste 
A component outline that has been copied to the paste buffer can be pasted (copied) to the component outline 
folder.  Right-click the component outline folder in the navigator window, then select Paste from the options that 
appear. The outline is added to the bottom of the list of outlines in the folder, it will take its original name unless 
an outline with that name already exists in the folder, in which case it will be named “Copy of <original name>”. 
(Refer to “Right-click on a component outline” for details on copying and dragging/dropping outlines to the paste 
buffer.) 
It can be renamed by right-clicking on the outline and selecting Rename. 
When an outline is copy/pasted between designs or to/from the master library, the pad and track codes used in 
the imported outline may change, but the actual sizes will remain the same.  
For example, take an outline that was created with code 4 pads where code 4 was set to 0.060” diameter with a 
0.025” drill. If the outline were pasted into a library where code 4 pads were set to 0.080” diameter with a 0.040” 
drill, then the pads in the pasted outline would be wrong. To ensure this doesn’t happen, Ranger ignores the 
pad code from the pasted outline and only takes into account the actual sizes/shapes assigned during the paste. 
It looks for an exact match in the destination sizes table and uses that code in the outline. If an exact match 
cannot be found, then it looks for an empty value in the table (set to 0) and updates that value to the size 
required (including drill diameter, pad diameter/width/length), then uses that code in the outline.   

Manage Families 
This command is used manage the family groups in the component outline folder.  
A family contains a group of outlines that can be easily substituted one for another within the artwork editor 
using the Parts > Change Outline command. 
Typically, outlines with the same number of pins are added to one family. For instance, the outlines DIL14, 
DILS14 and SO14 could be added to one family called 14PINS. At the layout stage, the DIL14 could be 
replaced easily for an SO14 because of space considerations, etc. 
An outline can only belong to one family. Note: an outline could however belong to different families within the 
design and master libraries. If this outline were used on an artwork and the Parts > Change Outline command 
used, then the outlines from both families are listed. The letter M is placed alongside the outlines from the 
master family. 
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Once selected, the family management window appears, similar to the one shown in Figure 106.  

 

Figure 106 

The top pane shows the Family Membership list, which lists all the outlines in the library and the family group to 
which they belong. The bottom pane shows the Family Names. 
When all the changes required have been made, select OK to close the window and keep the changes or 
Cancel to discard the changes. 

Creating a family 
To create a family name, select the Add button from the window. Supply a name for the family when prompted, 
followed by <enter> or select Proceed. The name appears in the lower pane in the window. Repeat as required. 

Deleting a family 
To delete a family name, select the family name from the lower pane, then select the Delete button from the 
window. Confirm or Cancel the selection as required.  Deleting the family does not delete the outlines 
themselves from the library. 

Renaming a family 
To rename a family name, select the family name from the lower pane, then select the Rename button from the 
window. Provide a new name as required followed by <enter> or select Proceed. 

Adding an outline to a family 
(A family name must have been created and appear in the Family Names list.) Select the outline, then select the 
arrow from alongside the  “Reset Family” attribute. A drop down list appears showing all the family names 
available, plus (none)similar to the one shown in Figure 107. 

 

Figure 107 
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Select the family name and the Family Membership list is updated. 

Removing/Changing an outline from its family 
Select the outline, then select the arrow from alongside the  “Reset Family” attribute. A drop down list appears 
showing all the family names available, plus (none). None should be selected if the outline does/should not 
belong to a family. Select the family or (none) as required. The Family Membership list is updated. 

Edit Properties 
This command can be used to allow the bulk editing of component outline properties. It saves time when many 
outlines have to be updated as the individual outlines do not need to be opened. 
Some/all of the outlines can be selected and some/all of the properties edited. 
(If an outline is opened for editing and the View > Properties command is selected, then only the properties of 
that particular outline can be changed.)  
When selected, the window shown in Figure 108 appears. 
 

 

Figure 108 

The actual fields (or attributes) are described under the View > Properties heading. Here we describe how to 
select the outlines. 
Selecting an individual outline select the outline with a click of the left button, it is highlighted. 
Selecting a continuous group of outlines position the cursor over the first outline name, then hold down the left 

mouse button, move the mouse over the outlines to be selected, then 
release the left button, they are highlighted.  
Alternatively, select an outline, hold down the <shift> key, then select 
the last in the group of outlines, release the <shift> key, they are 
highlighted. 

Selecting randomly spread outlines hold down the <Ctrl> key on the keyboard whilst selecting individual 
outlines with a click of the left mouse button. Release the <Ctrl> key 
when all the outlines required are highlighted. 

Editing the selections 
Once the outline(s) have been selected, select the Edit Selections button from the window (greyed out until 
outlines have been selected). The Outline Properties window appears. Any changes to this window affects all 
the selected outlines. Select OK to update the properties list or Cancel to discard the changes.  
Repeat as required.  
Once all the outlines have been updated as required, select OK to implement the changes or Cancel to discard 
the changes. 

Purge Unused Outlines 
Used to delete all the unused outlines from the design’s outline library. 
Outlines are automatically added to the job as they are used. They can become redundant due to a design 
modification, or new outlines could have been created or copied by the user, which may not be required. 
The parts list is used to determine which outlines are used in a design. 
Once selected, a window appears listing all the unused outlines in the design. Select the outlines that should be 
deleted by ticking the box alongside them, then select Delete. 
The Select All & Deselect All buttons can be used to quickly select/deslect all the outlines in the list. 

Right-click on a component outline 
Right-clicking on a Component Outline in the navigator window introduces the following commands: 
 Open Cut Copy Delete Rename  
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These commands are described below. 

Open 
When selected, the component outline is opened for editing. Changes are not implemented in the artwork until 
the outline is closed. 

Cut 
Currently (version 1.68) operates in the same way as Copy, though this may change in a future release – refer 
to the readme.txt in the ..\Seetrax\XL Designer folder. 

Copy 
The component outline(s) is/are copied to the paste buffer, overwriting anything previously added to the paste 
buffer. Multiple outlines can be selected if the Shift/Ctrl keys are used in unison with the right-click. 
(To paste the outline from the paste buffer to any component outline folder, right-click on the appropriate 
component outline folder (which might be the same design, another design or the master component outline 
folder), then select Paste from the options that appear.) 

Drag-drop functionality 
In addition to the Copy/Paste command, “drag & drop” is available to copy component outlines between the 
master library and designs and/or from design to design. Select the outline(s) required, then drag them by 
holding down the left mouse key to the other component outline folder, releasing the button whilst hovering 
over the target component outline folder. 

Delete 
When selected, the component outline is deleted from the folder/library. It cannot be deleted if referred to in the 
parts list of the design. 

Rename 
Used to alter the name of a component outline.  Once selected, the name is highlighted and the usual editing 
keys (backspace, delete, left/right arrows, etc.) can be used to rename it.  
It is not possible to rename an outline that is referred to in the parts list editor. 

View commands, outline editor 
View > Show Outline Filled 
When selected, the display toggles between filled pads and wide lines and unfilled pads and lines shown as 
centre lines. The editor starts with unfilled pads and centre lines displayed. 

View > Show Pin Numbers 
When selected, the pin number assigned to each pad is visible at the datum position of the pad. If the pin 
numbers have not been assigned, a “? “ (questionmark) is displayed. The editor starts with pin numbers 
displayed. 

View > Show Connection Points 
When selected, a small mark appears for each pad indicating where tracks will be attached to the pad in the 
artwork editor. (This is always in the centre of the pad for standard pad shapes.) 

View > Properties 
Used to view and edit the properties of an individual component outline. The properties are used by the 3D 
output tools (DXF and IDF) and also the artwork editing and artwork solder mask/paste output tools. Each of the 
entries is described below. 
(It is also possible to open this window for multiple outline editing, by right-clicking on the component outline 
folder, then selecting Edit Properties.) 
When selected the window shown in Figure 109 appears. 
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Figure 109 

Outline name  if just one outline is selected, then its name is indicated. (The name can only be changed by 
right-clicking on the component outline in the navigator and selecting Rename. 
If more than one outline has been selected, then Multiple selections is shown.  

3D Output 
Component height: the height specified here will be used as the height for the outline if any of the 3D output 

tools are used.  
 It is suggested that the maximum height including tolerances is specified to ensure accuracy if 

the 3D solid models will be used to show clearances in enclosures, etc. 
3D solid mode: This setting controls how the solid model is generated. It can be set as follows: 

Generate from placement bounds box 
if selected, then a simple rectangular block is shown at the part location in the 3D solid 
model. The rectangle is defined by the the Autoplace > Adjust Footprint command in the 
outline editor. 

Generate from silk screen data 
if selected, an attempt is made to construct a solid shape from the silk screen data. Not 
all silk screens will successfully convert to a solid figure – for example silk-screens that 
are not made from a continuous polygon - like that in the supplied SOT23. In these 
cases, it would be advisable to use the placement bounds box for the solid model as 
nothing would be output in the DXF file for that part if the silk screen data was selected.   
In order for the silk screen mode to work, the silk-screen must have been generated in 
the artwork editor prior to the 3D file being output and the silk-screen layer must also be 
included in the 3D output. 

DXF 3D Out 
 Enable 3D shape generation: if this setting is enabled (ticked) and an artwork output is made to a DXF file, then 

the DXF output task will attempt to create data for 3D solid figures representing the placed 
components.  
The silk screen mode is greyed out until this setting is enabled (ticked),   

Silk screen mode: this setting controls how the silk screen labels (IC1, R1, D1, etc.) are drawn for the part in the 
DXF output files when a 3D solid shape is also drawn for the corresponding part. 
Draw raised to component height 

the silk screen part labels are drawn on the top of the 3D solid model. 
Draw on Board Surface 

the silk screen part labels are drawn on the board surface.   
Do not draw 

the silk screen part labels and outline shapes are never drawn for parts that have a 3D 
solid figure shown. 

Artwork constraints: 
Allow via holes at SMD pads: this setting indicates whether via holes are permitted within an smd pad in the 

outline. This setting is only used by the Specctra & Electra  auto-router and can be over-ruled 
when submitting the design for auto-routing. 
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Outline is a routing star point: when this checkbox is ticked, the outline takes on a special mode of behaviour 
that allows different nets to be connected at a single point with free copper, effectively causing 
a short-circuit or star-point. 
The star point outline defines the track geometry for the location where the nets meet. 
The check-box should be selected BEFORE editing the star point outline. 
One component pin should be added to the star point outline for each net that will be 
connected at the star point. 
The pads should then be connected together by inserting free copper on the top, bottom or all 
layers. 
The free copper features that connect the star outline pins is never seen by the artwork 
autorouter, the copper fill routines or the artwork checker. The only time it is present is during 
screen display and when creating artwork outputs.  
To prevent the autorouter and copper fill routines from placing copper in the area of the star 
outline occupied by the interconnecting free copper traces, a keepout area must be defined. 
The keepout areas must not enclose any of the component pins on the outline. 
Because the artwork checker does not verify the copper connections between the star outline 
pins, you must manually verify that your outline does actually perform the desired 
interconnectivity between its various pads. 
An example job is supplied showing the use of a starpoint outline. A step-by-step procedure is 
also given at the end of this chapter. 

Omit pads from solder mask output: if ticked, then the pads from this component outline will not be included 
when the automatic solder mask output task is used.  

Omit pads from solder paste output: if ticked, then the pads from this component outline will not be included 
when the automatic solder paste output task is used.  

 
Fill out the fields as required.  
Note: if multiple selections have been made, then the change made to each field will apply to all the selected 
outlines. If a field is untouched, then no changes will be made to that particular field and the settings for each 
outline will remain as they were. 
So for example, if all the outlines were selected, and only the Silk-screen mode were changed, then the various 
settings for height, 3D solid mode, etc. would remain unchanged, but all the silk-screen modes would be 
updated. Likewise if all the outlines were selected, and the height was altered, this height would apply to all the 
selected outlines. 
Select OK to continue. 

Dialogue bar settings, outline editor 
Before creating or modifying outlines, notice should be taken of the settings in the dialogue bar, as shown in 
Figure 110.  
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Figure 110 

These control the size, orientation and layers of the items being added or modified. The dialogue bar is divided 
into areas as follows: 

Pad Style 
This setting allows the pad shape to be selected. Selecting the arrow alongside produces a list of standard 
pad shapes plus any user-defined pads in the current pad library, from which one should be selected. If a 
rectangular shaped pad style is chosen the Angle setting should be set as required. If a standard pad shape 
is selected then the Size setting should also be updated as required. 

Pad Angle 
This setting controls the orientation of any pads that are added or updated. The angle is selected from the 
list that appears (0, 90, 180 or 270) when the arrow alongside the setting is selected, or a value may be 
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typed in to obtain non 90 degree angles. Resolution is 0.01 degrees. 
When typing a value, ensure the cursor remains in the dialogue bar area. 
Note: standard pad shapes added using the Copper commands can only be added at the standard 
0/90/180/270 degree angles, but custom pads may be rotated freely. 

Pad Size 
The Size setting corresponds to the size codes from the Pad Sizes table so it controls the size of the pad. 
The code can be changed by typing in a number (the cursor must remain in the dialogue bar whilst typing) 
or by selecting the spin controls alongside. The Browser window displays the sizes assigned to each pad 
code as they are selected. 

Pin Scope 
used to indicate the currently active layer(s). Pads can only be added to, or selected from, the currently 
active layer(s). 
Pads on each layer are displayed with different colours. 

Top pads red 
Inner pads green 
Bottom pads blue 

A complete pad "stack", where all the pads are the same size and shape, will result in the pads being 
displayed white. 
When pads are added to the outline, they are either added to the top, inner, bottom or all layers. This allows 
differently sized or shaped pads to be defined on different layers of the board. For example, pads on the 
inner layers of a board could be smaller than those on the outer layers, or pin 1 of a component could have 
a square pad on the solder side and round pads on the inner layers and component side of the board.  
It is quicker to add the pads to all layers, and then modify the ones that need to be different, rather than to 
add pads on top of one another to the individual layers. 
Only pad stacks with a pad on the inner layers are drilled, even though a drill size may be specified within 
the pads used on the top and bottom layers. This means that when defining component outlines with drilled 
pads, the pads must be added to all layers, even if the outline will only be used on single sided boards. The 
inner pad defines the drill size. 
When defining surface mounted devices, add the pads to either the top or bottom layer, depending on 
which side the component is to be mounted on.  
Tip: always define outlines from the same side, usually the top, then flip them if required in the artwork 
editor.  (Ranger stores outlines as flipped or unflipped on the artwork, not whether they are on the top or 
bottom of the board.) 
Pads only on the top, only on the bottom or only on the top and bottom of the board will not be drilled. 

Top refers to the top, component side of the board.  
Bottom refers to the solder side of the board, which is also the bottom component side if components 

are being mounted on both sides.  
Inner refers to all the other copper layers in the design. 
All includes all the copper layers (top, inner and bottom layers).  

Next Pin Number  
used to define the next pin number to be assigned to a pad. It is user definable. Up to eight alpha-numeric 
characters in any order can be used in a pin number.  
The pin number can be changed by typing it in (the cursor must remain in the dialogue bar whilst typing). 
Once the pin number has been assigned, the number in the box increments by one, unless 0 was entered, 
in which case it does not change. (This allows more than one pad to be re-numbered to 0, ready for 
subsequent re-numbering if incorrect pin numbers were assigned.) 
If the pin number ends in an alpha character, then a number is added to the end of the string after the first 
pin has been assigned, and increments by one each time another pin is selected unless the string is 
already eight characters long.  
If alpha-only strings are required, they have to be typed in individually. 

Outline/Copper Width 
This setting corresponds to the size codes from the Track Sizes table and it controls the width of any 
lines/characters/copper that are added/updated. The code can be changed by typing in a number (the 
cursor must remain in the dialogue bar whilst typing) or by selecting the spin controls alongside.  
The actual size assigned to the code is shown above the code. 
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Free copper layer 
Used to indicate the currently active layer(s) when adding/modifying pads/tracks/lines using the Copper 
commands.  
Items added using the copper commands can only be selected if they are on the currently active free 
copper layer(s). 
Items on these layers can be displayed with different colours and this is controlled by the Copper > Free 
Copper Setup command within this editor. 
The layer is chosen from a list that appears if the arrow alongside the setting is selected.  
If only the Top, Inner and Bottom layers are listed, then no free layers have been defined (Copper > Free 
Copper Setup). 
The coloured box below the layer setting indicates the colour assigned to the chosen layer to assist with 
recognition. 

Region Operations 
This indicates which categories of data will be included in the Region commands. 

Outlines when ticked will include any items added using the Outline commands (silk screen lines 
or text) in the window operations. 

Pins when ticked will include any items added using the Pads commands in the window 
operations.  

Free Copper when ticked will include any items added using the Copper commands in the window 
operations. 

Tools > Outline Definition 
Once Tools > Slots & Extra Holes has been selected, use this command to revert back to the main Outline 
editor commands. 

Tools > Slots & Extra Holes 
This command provides access to the Slots and Extra Holes commands which allow routed slots and/or 
additional holes to be added to an individual outline.  
Their use is identical to the same commands in the Custom Pad and Artwork editors. The commands are 
therefore described under the heading Slots & Extra Holes (Tools > Slots & Extra Holes commands) on page 
241 of this manual. 

Outline commands, outline editor 
These commands are used to add the silk-screen definition to the outline. Once the silk-screen has been 
generated on the artwork (added to a layer), changes to the silk-screen outline in the outline library have no 
effect on the silk-screen layer - unless the layer is re-generated. 

Outline > Add Line 
Used to add lines that will become the silk-screen shape of the outline.  
The thickness of the line is defined by the Outline/Copper Width setting in the dialogue bar on the left of the 
window. The number represents a line thickness taken from the track sizes table. Use the spin-controls to 
change the code number. The current size for the code number is shown above the code.  
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 
Once selected, locate the cursor where the line is to start then click the left button. Move the cursor, a line 
appears attached to it. Clicking the left button inserts corners in the line. Release the line with a click of the right 
button, the segment attached to the cursor is not added. 

Outline > Add Circle 
Used to add circles that will become the silk-screen shape of the outline. 
The thickness of the line used to draw the circle is defined by the Outline/Copper Width setting in the dialogue 
bar on the left of the window. The number represents a line thickness taken from the track sizes table. Use the 
spin-controls to change the code number. The current size for the code number is shown above the code.  
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 
Once selected, point at the centre of the required circle and click the left button. Move the cursor and a circle 
appears attached to it. The size of the circle is controlled by the cursor position. Click the left button to release 
the circle in its current position. Clicking the right button cancels the circle.  
Use the Outline > Move Point command to move or change the size of existing circles. 
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Outline > Add Arc 
Used to add curved lines "arcs" which will become the silk-screen shape of the outline. A series of arcs and 
straight lines can be added using this command.  
The thickness of the line used to draw the arcs is defined by the Outline/Copper Width setting in the dialogue 
bar on the left of the window. The number represents a line thickness taken from the track sizes table. Use the 
spin-controls to change the code number. The current size for the code number is shown above the code.  
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 
Once selected, locate the cursor where the arc or line is to start, then click the left button. Move the cursor, a 
line appears attached to it. Move the cursor to the point where the arc or line is to end, then click the left button. 
Move the cursor. A curve stretches with the cursor, its size and shape being dependent on the cursor position. 
Click the left button to release the curve. If the right button is clicked a straight line segment is introduced. The 
line remains attached to the cursor, allowing more curves to be added or the line released. To continue adding 
curves, move the line to the end point of the next arc, then click the left button, stretch the arc and release it with 
a click of the same button. To release the line, click the right button, the line attached to the cursor is not added. 
If the right button is clicked whilst the arc is being stretched, a straight segment is introduced. This allows a 
mixture of curved and straight segments to be drawn using the same command. 
The shape of the arcs can be adjusted using the Outline > Move Point command. 

Outline > Corner 
Used to move or insert a corner in a line or arc that has been added using the Outline commands (not those 
added with the Copper commands). 
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 
Once selected:  
Adding a corner Point at the line, then click the right-hand mouse button. Move the cursor, the 

new corner is attached to it and the adjacent segments stretch with it. Release 
the new corner with another click of the same mouse button. (Click the 
opposite mouse button (left) to cancel the new corner.) 

Moving an existing corner Point at the corner, then click the left-hand mouse button. Move the cursor to 
move the corner and stretch the adjacent segments. Release the corner with 
another click of the same mouse button. (Click the opposite mouse button 
(right) to cancel the move.) 

 add corner     =   right button 
 move corner  =   left button 
 (Opposite button cancels.) 

Outline > Move Point 
Used to move existing points (corners) in lines or arcs, to move circles, or to change the size of circles that have 
been added using the Outline commands (not those added with the Copper commands). 
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 
Once selected: 
Moving points in lines or arcs  Locate the cursor on the corner to be moved, then click the left button. Move 

the cursor, the corner appears attached to it and the existing lines or curves 
stretch. Position the corner as required, and then click the left button to release 
it. Clicking the right button before the corner is released returns the corner to its 
original position.   

Moving circles  Point at the centre of the circle, then click the left button. Move the cursor, the 
circle appears attached to it. Position the circle as required, and then click the 
left button to release it. Clicking the right button before the circle is released 
returns it to its original position.   

Changing the size of circles Point at the circumference of the circle, and then click the left button. As the 
cursor is moved, the diameter of the circle changes. Once the required circle 
size is achieved, click the left button to release it. Clicking the right button 
before the circle is released returns it to its original size.   

Outline > Adjust Arc 
Used to convert arcs to lines, lines to arcs and to adjust the size or shape of arcs that have been added using 
the Outline commands (not those added with the Copper commands). 
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
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information bar. 
Once selected:  
Straight lines into arcs Point at a line segment and click the left button. Move the cursor, the segment 

is replaced by an arc that stretches as the cursor is moved. Click the left button 
to release the arc. 

Arcs into a straight line Point at an arc and click the left button. Follow this with a click of the right 
button to convert the arc into a straight-line segment. 

Adjusting size/shape of arcs Point at the arc and click the left button. Move the cursor until the arc is in the 
required position, and then click the left button. 
Clicking the right button toggles the last selected line or arc between a line and 
an arc. The shape of the arc is defined automatically, and can be used to 
convert 45-degree lines into quadrants of a circle. The direction of the arc is 
determined by the position of the cursor about the line when the button is 
pressed. 

Outline > Delete Feature 
Used to delete lines, circles or arcs that have been added using the Outline commands (not those added with 
the Copper commands). 
Note: the complete line or curve between start and end points is deleted, not just a segment within a line or arc.  
Once selected, point at the line, arc or circle to be deleted, and then click the left button. The line, arc or circle is 
removed. 

Outline > Delete Point 
Used to delete points (corners) from lines or a series of arcs that have been added using the Outline commands 
(not those added with the Copper commands).  
Once selected, point at the corner to be deleted, and then click the left button. The corner is removed from the 
line or arc. 

Outline > Change Width 
Used to change the line thickness of an existing line, arc, circle or text string that has been added using the 
Outline commands (not those added with the Copper commands). 
Ensure the Outline/Copper Width setting in the dialogue bar on the left of the screen is set to the size code 
required. The number represents a line thickness taken from the track sizes table. Use the spin-controls to 
change the code number - the current size for the code is shown above the code. 
Once selected, move the cursor over the line, arc, circle or text string then click the left-hand mouse button. The 
line width is changed to the size determined by the Outline/Copper Width setting in the dialogue bar. 

Outline > Text 
The text commands should only be used for standard details, such as pin numbers at each end of a connector.  
Silk screen component references (R1, R2, etc.) are produced automatically for each part so should not be 
added, those references are placed on the datum of the outline. The references can be moved individually in the 
artwork editor.  
Once the silk-screen has been generated on the artwork (added to a layer), changes to the silk-screen outline 
text in the outline library have no effect on the silk-screen layer - unless the layer is re-generated. 

Outline > Text > Add 
Used to add text strings to the outline that will appear as silk-screen text on the artwork. Text that is added to 
the outline will appear every time it is used, so do not add text that is unique to one particular part, for instance 
its name R1, R2, etc. 
Text that is added to an outline is not mirrored when a part is flipped in the artwork editor. 
The thickness of line used to "draw" the characters is defined by the Outline/Copper Width setting in the 
dialogue bar on the left of the screen, so ensure it is set to the size code required. (The number represents a 
line thickness taken from the track sizes table - use the spin-controls to change the code number, the current 
size for the code number is shown above the code.) 
When adding small text characters, a thin line size should be used, otherwise the characters appear as blobs. 
Taller characters can be drawn with thicker lines. 
Once selected a window appears. If text has already been added or modified, the previous text string appears in 
the window. It may be selected and modified, or a new text string entered. 
The height of the text string is shown in the currently selected units (a decimal point is shown as a dot in 
imperial values and a comma in metric values) and can be changed as required.  
The angle of text is specified in degrees, anti-clockwise, 0 degrees places text horizontally, reading from left to 
right. The angle can be typed in (0 to 359), or a selection made from the list that appears when the arrow 
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alongside the setting is selected.  
Once all the settings have been filled in as required, select OK. The window closes and the text string, 
represented by a rectangle, appears attached to the end of the cursor.  
Whilst the text is being moved it can be rotated in 90 degree increments by pressing the user defined special 
function key for <part rotate>. 
Move the cursor into position and click the left-hand mouse button to release the text. Clicking the right-hand 
button before the text is released restores the window, allowing the string to be modified or the operation 
cancelled. 
As the text string is released, another copy of it appears on the end of the cursor. It can be released in the same 
way. To cancel the text, select another command or click the right-hand mouse button to restore the window. 
Cancel can be selected to cancel further text addition, or the values can be modified and OK selected again. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Outline > Text > Move 
Used to move text strings that have already been added. 
Whilst the text is being moved, it can be rotated in 90 degree increments by pressing the user defined special 
function key for <part rotate>. 
The text's datum is the lower left-hand corner of the rectangle that is displayed when it is moved, but it can be 
selected anywhere along its length. 
Once selected, point at the text string and click the left-hand mouse button. A rectangle appears attached to the 
cursor, representing the text string. Move the rectangle into the required position and click the left-hand mouse 
button to release it. 
Clicking the right-hand mouse button whilst moving the text returns it to its original position. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Outline > Text > Edit 
Used to edit existing text strings or change their height or angle of rotation. 
Once selected, point at the text string and click the left-hand mouse button. A window appears containing the 
text string, its height and angle of rotation. Refer to Outline > Text > Add for details of these entries.  
Select OK when you are ready to implement the changes. Selecting Cancel restores the text to its original form. 

Outline > Text > Mirror 
Used to mirror text strings about their centre. 
Text that is added to an outline is not mirrored when a part is flipped in the artwork editor. 
Once selected, point at the text string to be mirrored and click the left-hand mouse button. 

Outline > Text > Rotate 
Used to rotate text strings through 90 degree increments, anti-clockwise. For instance, text that was added at 45 
degrees rotates to 135, 225, 315 and back to 45 degrees. 
Text can be rotated in increments of 1 degree using the Outline > Text > Edit command. 
Text is selected anywhere along its length, but it rotates about its datum which is the lower left-hand corner of 
the rectangle that is displayed when the text is moved. 
Once selected, point at the text string and click the left-hand mouse button to rotate it. 

Outline > Text > Delete 
Used to delete text strings from the outline. 
Once selected, point at the text string you wish to delete and click the left-hand mouse button. 
Outline  > Set Outline Datum 
Used to define the datum of the outline. The datum is displayed as a small yellow cross with a circle around it. In 
the outline editor the X-Y readout is given with respect to the datum's position. 
When a part is moved or selected in the artwork editor, it must be selected by its datum. 
Note: if the datum of an outline is moved in the design library and the outline is already in use on the artwork, 
the part will be "moved" on the artwork. The datum retains its position on the artwork, but the pins etc. will adjust 
their position so they are in the correct position with respect to the outline's datum. Silk screen and free layer 
data already generated will be unaffected. 
Items that are being moved, added, etc. do not have to be released to allow the datum command to be selected.  
Once selected, point at the position required for the datum, then click the left-hand mouse button. The datum 
moves. The datum command remains active until the right-hand mouse button is clicked when control returns to 
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the previously active command, or another command is selected. 
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 

Pad commands, outline editor 
The Pad commands are used to add pads to the outline and assign their pin numbers. They can be manipulated 
as required. Pads can be added in any order.  
Information about the pads in an outline is given across the top of the open outline editor, as shown in Figure 
111. This indicates how many pin numbers have been assigned (unique pin idents), the number of pads on the 
top, inner and bottom layers and if any of those are unassigned. 

 

Figure 111 

Default pin numbers are not given to pads. Pin numbers must be assigned to ensure the connections defined 
on the circuit diagram are connected to the correct pads on the outline. If pin numbers are not assigned to pads, 
the pads cannot be referred to. 
Pin numbers can be omitted from an outline. As an example, one type of reed relay uses a 14-pin DIL package, 
but pins 3, 4, 5, 10, 11 and 12 do not exist. The outline can be made with 8 pads using pin numbers 1, 2, 6 to 9, 
13 and 14. 
Ensure the pin numbers are assigned to ALL the layers of each pad stack. 
These commands cannot be used to modify pads added using the Copper commands, which should be 
modified with the Copper commands. 

Pad > Add 
Used to add individual pads to an outline. When pads are added, they do not have pin numbers, so the order in 
which they are added is unimportant. 
The pad size/shape/layer can be controlled by the dialogue bar, so it should be set as required. As the pad 
shape/size/style is selected in the dialogue bar, the associated folder opens in the navigator. 
Once selected, move the cursor into the main drawing area and a pad appears attached to it. Move the cursor 
and the pad into position and click the left-hand mouse button to release it. A second pad appears attached to 
the cursor. Move it into position and release it. As one pad is released, another appears and can be released. 
To stop adding pads click the right-hand button. 
The datum point of a standard pad is its centre. The datum point of a library pad is indicated by a small pink 
circle and cross. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Alternative pad selection option 
The pad shape and size can also be selected from the navigator window - from the navigator, open the standard 
pads folder of the current job, then select the + sign of the pad shape folder, select the pad size required from 
the navigator (the dialogue bar is updated to correspond, automatically). 
The angle of the pad & layers it’s added to, is controlled from the dialogue bar which should be set as required. 

Pad > Auto Add 
Used to add a series of pads. The position of the first and second pad is indicated, the additional pads are 
added automatically on the same pitch and continuing in the same direction. The total number of pads is user 
defined. Automatic pad addition is very useful when creating outlines with a lot of pads in a line, as in a pin grid 
array. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar box. 
Refer to the Pad > Add command for details on selecting the pad size/shape. 
Once selected, move the cursor into the main drawing area, the first pad appears attached to it. Move the pad 
into position and click the left-hand mouse button to release it. A second pad appears attached to the cursor. 
Move it into the position of the second pad in the line and release it. A window appears requesting the total 
number of pads required. Type in the total number of pads required followed by <enter> or select OK. The pads 
appear one after the other at the same pitch and following on in the same direction as the first two pads were 
added.  
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Pad > Move 
Used to move existing pads interactively. This command cannot be used on pads added using the Copper 
commands.  
Pads can also be moved by typing in their new co-ordinates if required using the Pad > Key Move command. 
Only pads on the currently active layer as defined by the dialogue bar on the left of the screen are moved. All 
should be selected to move the complete pad stack. 
If pin numbers have been assigned to a pad stack and the pads from individual layers are moved, the pads still 
retain the pin numbers assigned. This situation should be avoided because of the confusion that will entail. 
Ensure the active layer is set as required. Refer to the GRID command for details on whether grid snapping is 
active. The current grid is shown in the information bar. 
The datum point of a standard pad is its centre. A small pink circle and cross indicate the datum point of a library 
pad. 
Once selected, point at the pad's datum and click the left-hand mouse button, the pad moves with the cursor. 
Move the pad into position and click the same button again to release it. 
Clicking the right-hand mouse button whilst the pad is attached to the cursor returns the pad to its original 
position. 

Pad > Key Move 
Used to move a pad/pad stack to a specific X and Y co-ordinate, or to find out the position of a pad stack.  
This command cannot be used on pads added using the Copper commands.  
The X and Y co-ordinates are given with respect to the datum of the outline, which can be moved using the 
Outline  > Set Outline Datum command. 
The complete padstack is moved, irrespective of the layer setting in the dialogue bar. 
Once selected, point at the datum of the pad stack and select it with a click of the left-hand mouse button. A 
window appears containing the current X and Y position of the pad. The title box of the window also displays the 
size code or name of the pad. The co-ordinates are shown in the current units. A dot is used as a decimal point 
in imperial values and a comma in metric values. Enter the new values required for the pad, then select OK to 
implement the move. Select Cancel to cancel the move. 

Pad > Rotate 
Used to rotate existing pads/pad stacks in 90-degree increments, anti-clockwise. 
This command cannot be used on pads added using the Copper commands.  
Only pads on the currently active layer as defined by the dialogue bar on the left of the screen can be rotated. 
For example, with the Pin Scope set to Inner, only the inner pads of the pad stack are rotated. 
Ensure the active layer is set as required. Once selected, point at the datum of the pad to be rotated and click 
the left-hand mouse button. The pad rotates 90 degrees anti-clockwise each time the pad is selected. 
The datum point of a standard pad is its centre. The datum point of a library pad is indicated by a small pink 
circle and cross. 

Pad > Change Style/Size 
Used to replace an existing pad for the currently active pad. (Refer to Pad > Add for how to select the pad 
size/shape.) 
This command cannot be used on pads added using the Copper commands.  
The datum of the new pad is positioned directly over the datum of the pad it is replacing. 
Only pads on the currently active layer as defined by the dialogue bar on the left of the screen are replaced. For 
example, with the Pin Scope set to Inner, only the inner pads of the pad stack are replaced. 
Pin numbers are maintained if pads are replaced. 
Ensure the active layer is set as required. Select Pad > Change Style/Size, as the cursor is moved into the main 
drawing area, the active pad appears attached to it. Move the cursor over the datum of the pad to be replaced 
and click the left-hand mouse. The pad is replaced. More pads can be replaced until another command, for 
instance Pad > Move/Rotate, etc. is selected. 
The datum point of a standard pad is its centre. The datum point of a library pad is indicated by a small pink 
circle and cross. 

Pad > Delete 
Used to delete pads from the outline. 
This command cannot be used on pads added using the Copper commands.  
Any pad from the currently active layer as defined by the dialogue bar on the left of the screen can be deleted, 
even if it has been assigned a pin number. The pin numbers of remaining pads are unaffected. For instance, 
with the Pin scope set to Bottom, only the bottom pad of the pad stack is deleted. 
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Ensure the active layer is set as required. Once selected, point at the datum of the pad to be deleted and click 
the left-hand mouse button. Confirmation is not required. 
The datum point of a standard pad is its centre. The datum point of a library pad is indicated by a small pink 
circle and cross. 

Pad > Assign 
Used to assign pin numbers individually to the pads. The pin number is controlled by the Next Pin Number 
setting from the dialogue bar on the left of the screen, which increments by one each time a number is assigned. 
This command cannot be used on pads added using the Copper commands. 
If the Next Pin Number is set to 0, there is no auto-increment of the pin number. This allows multiple pins to 
have their pin numbers removed if required. 
The same pin number cannot be used twice on the same layer. If a mistake is made and it is necessary to 
renumber the pins, the existing pin numbers will need to be reset to 0, using either this command or auto assign. 
Once selected, move the cursor and a flag appears attached to it, displaying the Next Pin Number as defined in 
the dialogue bar. Select a pad to assign that pin number to the pad. The flag increments by one to indicate the 
number has been assigned. (If the pin number doesn't change, the status bar may be displaying an error 
message or the pad may not be on the selected layer.  
More pads can be selected as required. If a pad is selected again, then its original number is updated. 
If the next pin number is not correct, type in the correct number in the Next Pin Number field and continue. 
Select another command to terminate manual assignment of pin numbers. 
Use the Pad > Describe command to obtain pin numbering information on a particular pad. 

Pad > Auto-Assign 
Used to assign sequential pin numbers automatically to a line of pads. This command cannot be used on pads 
added using the Copper commands. 
The first pin number is controlled by the Next Pin Number setting from the dialogue bar on the left of the screen.  
If the Next Pin Number is set to 0, there is no auto-increment of the pin number. This allows multiple pins to 
have their pin numbers removed if required. 
The first and last pads in a line are selected. Pin numbers are assigned sequentially from the first to the last 
pad.  
Only pads on the active layer(s) as defined by the dialogue bar on the left of the screen are assigned. 
Once selected, a "first" flag appears attached to the cursor. Select the first pad in the line to be assigned. A 
"last" flag appears attached to the cursor. Select the last pad in the line to be assigned. As soon as the first and 
last pads have been selected, the pin numbers are assigned - a flag indicates which pads and pin numbers 
have been assigned. 
Use the Pad > Describe command to obtain pin numbering information on a particular pad. 

Pad > Describe 
Used to obtain information about a pad stack. This command cannot be used on pads added using the Copper 
commands (use the Copper > Describe Pad command on those instead). 
Use the Pad > Key Move command to find out the X and Y co-ordinates of pads. 
Once selected, point at a pad and select it with a click of the left-hand mouse button. An information window 
appears. A line extends from one corner of the information window to the pad stack it is describing. 
A sample window is shown in Figure 112. 

 

Figure 112 

 
LYR: indicates the layers in the pad stack. 
ID: indicates the pin number of the pad on that layer. 
Size: indicates the size code and actual size of the pad on that layer. 
TYPE: indicates and shape of the pad on that layer. Pad shapes are listed as: 
  RO = round, RS = rectangular, square-ended     

 SQ = square, RR = rectangular, round-ended 
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DRILL: indicates the drill size used in the pad stack. If the pad stack is made from pads with different 
drill sizes, a warning "multiple drill sizes" is given. If the outline is used in the artwork editor, 
the drill size is defined by the drill size of the inner pad. 

Pads can be selected until the right-hand mouse button is clicked, which cancels the describe command. 

Copper commands, outline editor 
These commands are used to add additional copper to the outline in the form of tracks or pads. This allows 
stringers to be added to SMD's, dual outlines to be created, or specialist solder mask/solder paste layers to be 
defined. The dialogue bar on the left of the screen as described previously controls the size/shape of 
pads/tracks that are added. 
More information also appears at the beginning of this chapter under the heading “Additional "copper"/free 
copper - introduction”. 

Notes: 
An outline must contain one set of "pads" that were added and numbered using the Pad commands, which 
form the basic outline. 
If a pad is added using the Copper commands, it is never given a pin number.  
Copper pads (and tracks) can be placed on any of the following layers, Top, Bottom, All or on up to eight 
free layers. 
The "free layers" are generally used in order to create specialist solder paste pad layers, solder mask pad 
layers, glue spot layers, etc. (Standard solder paste and solder mask output files can be produced 
automatically, with a uniform, user-defined pad swell. It is therefore not necessary to create these free 
layers unless there are specific requirements.) 
They are called free layers because the data that is added to them can be added to any user-defined inner 
layer once the outline has been placed on the artwork, using the Tools > Generate Silkscreen command in 
the artwork editor. These layers are treated as silk-screen layers, they do not form part of the electrical 
connectivity and are not checked during artwork checking.  
Tracks and pads that are added to "free layers" can be placed anywhere.  
The pads and tracks on the free layers do not appear automatically when the outlines are used in a layout. 
Tracks added to the top, bottom or "all" layers can only be added if the track starts from a pad on the same 
layer, which was added using the Pad commands.  
Pads being added to the top, bottom or all layers can only be added on to the end of a piece of track that is 
also on the same layer. 
Only pads or tracks added to the top, bottom or all layers have electrical significance, i.e. they form part of 
the copper on the layout and are checked during artwork checking. 

Creating "dual" outlines: 
Dual outlines are created when components are available in different packages, and it is unknown at the 
layout stage which package will be available when the board is assembled. 
Here we describe how to add a surface mounted outline (SO14) to a conventional outline (DIL14). (Refer to 
individual commands for more details.) Copy the supplied DIL14. With the copied outline open, decide 
which layer the secondary pads have to be added to (typically top) and add a track to that layer, from one of 
the original numbered pads to the position where the secondary SMD pad will be added (Copper > Add 
Line). These tracks will form the link between the DIL14 pads and the SO14 pads. Repeat for each pad. 
Choose the size and shape of the secondary pad and place a pad on the end of each of the tracks (Copper 
> Add Pad) on the appropriate layer. The dual outline is complete. 
Note, rip-up, layer swap, etc. can be used on the tracks in the artwork editor, but the pad remains, as it is 
not regarded as a via, unless it was added as a size code 0 round or square pad. 

Adding "copper" to the "free layers" 
Select Copper  > Free Copper Setup. Assign names and different colours to the layers if this has not 
already been done. 
"Tracks" or "pads" can be added to the "free layers". If adding a pad, select the pad to be added, set the 
dialogue bar to suit the pad/track width to be added, the Free Copper Layer selection will list all the layers 
available. If a name was not entered in the Free Copper Setup window, then no extra layers will appear. 
Select the layer required and add the pads or tracks required. Remember that "copper" added to the free 
layers is not treated as copper by Ranger. 
When the outlines appear on the layout, their free layer copper is not automatically used or displayed. It can 
be added using the Tools > Generate Silkscreen command.  

Copper > Add Line 
Used to add lines to the outline (not silk-screen lines which are usually added using the Outline commands). 
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The line may or may not be copper, depending upon which layer it is added to. 
The Free Copper Layers setting in the dialogue bar on the left of the screen controls the layer the line is added 
to. Top refers to the top, component side of the board (T), bottom refers to the solder side of the board (B). ALL 
includes all the copper layers, i.e. top, inner copper and bottom layers. The other layers are "free" layers and are 
not defined as copper layers. 
Lines added to the free layers can be placed anywhere.  
If the line/track is added to the top, bottom or all layers, the line must start on a pad added using the Pad 
commands, which is also on the same layer. For instance, if the pad stack is on all layers, then the line can be 
added to any layer, but if the pad is on the top layer only, then the line must also be on the top layer. 
The Outline/Copper Width setting in the dialogue window on the left of the screen, controls the line size, which 
should be set as required.  
Ensure the line size and layer is set as required, then select Copper > Add Line. Point at: 

the pad where the track is to start if it is being added to the top, bottom or all layers, or  
the position required if it is being added to a free layer  

and click the left-hand mouse button.  
Move the cursor, and a track appears attached to it. Click the left-hand mouse button to release the track from 
the cursor. It is not possible to add corners to this track whilst it is being added. Use the Copper > Add/Move 
Corner command to modify the track. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
It is not possible to start more than one track from a pad.  

Copper > Add/Move Corner 
Used to add and move existing corners in lines added using the Copper commands.  
The Free Copper Layers setting in the dialogue bar on the left of the screen should be set to the layer the line is 
on. 
It is possible to disconnect tracks on the top, bottom or all layers from their pads, but this should be avoided. If 
the track is moved, the pin should also be moved. 
Corners are added and released with clicks of the right-hand mouse button. Corners are moved and released 
with clicks of the left-hand mouse button. Once the corner has been selected, clicking the opposite mouse 
button cancels the operation. 
   right button  =   add corner 
   left button     =   move corner 
   Opposite button cancels 

Adding a corner to a track: 
Select Copper > Add/Move Corner, then point at the track and click the right-hand mouse button. Move the 
new corner and release it with another click of the same (right) button. Clicking the opposite (left) hand 
button before the corner is released, cancels the new corner. 

Moving an existing corner in a track: 
Select Copper > Add/Move Corner, then point at the corner (or end of the track) and click the left-hand 
mouse button. Move the corner and release it with another click of the same (left) button. Clicking the 
opposite (right) hand button before the corner is released, cancels the move. 

Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Copper > Add Keepout Line 
Used to add keepout areas to the outline. The copper fill and auto-routers will avoid keepout areas. The 
checking routines will flag violations of the keepout lines/areas if requested. 
A closed shape should be drawn defining the required keepout area.   
The Free Copper Layers setting in the dialogue bar on the left of the screen controls which layer the keepout 
line operates on, but keepout lines/areas can only be added to the Top, Bottom or All (copper) layers.  
The command is greyed out if one of the free copper layers is selected. 
Ensure the Free Copper Layers setting is set to Top, Bottom or All as required, then select Copper > Add 
Keepout Line.  Locate the cursor where the line is to start then click the left button. Move the cursor, a line 
appears attached to it. Clicking the left button inserts corners in the line, which is displayed dotted when 
released. Release the line so that an enclosed shape is formed with a click of the right button, the segment 
attached to the cursor is not added. 
Use the Copper > Add/Move Corner command to modify the line. 
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Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Copper > Add Keepout Circle 
Used to add circular keepout areas to the outline. The copper fill and auto-routers will avoid keepout areas. The 
checking routines will flag violations of the keepout lines/areas if requested. 
The Free Copper Layers setting in the dialogue bar on the left of the screen controls which layer the keepout 
circle operates on, but keepout lines/areas can only be added to the Top, Bottom or All (copper) layers.  
The command is greyed out if one of the free copper layers is selected. 
Ensure the Free Copper Layers setting is set to Top, Bottom or All as required, then select Copper > Add 
Keepout Circle.  Locate the cursor on the centre of the new circle then click the left button. Move the cursor, a 
circle appears attached to it. Clicking the left button releases the circle, which is displayed dotted when 
released.  
Use the Copper > Adjust Arc/Circle command to move or resize the circle. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Copper > Delete Point 
Used to remove points (corners) from lines added using the Copper commands. 
The Free Copper Layers setting in the dialogue bar on the left of the screen should be set to the layer the line is 
on. 
Select Copper > Delete Point, move the cursor over a point (corner) in the track and click the left-hand mouse 
button. The point is removed. If the start or end point of a track is deleted, the segment is removed. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Copper > Delete Line 
Used to delete a line added using the Copper commands. 
The Free Copper Layers setting in the dialogue bar on the left of the screen should be set to the layer the line is 
on. 
A complete line is deleted between its start and end points, not just a segment between points. 
Pads on the top, bottom or all layers should not be left isolated if the track attached to them is removed. Either a 
new track should be added or the pad removed. 
Select Copper > Delete Line, point at the line to be deleted and click the left-hand mouse button. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Copper > Adjust Arc/Circle 
Used to convert keepout arcs to straight segments, keepout line segments to arcs, to adjust the size or shape of 
keepout arcs and to move or resize a keepout circle that have been added using the Outline commands (not 
those added with the Copper commands). 
Refer to the Grid command to find out whether grid snapping is active. The current grid is shown in the 
information bar. 
Once selected:  
Straight keepout lines to arcs Point at a keepout line segment and click the left button. Move the cursor, the 

segment is replaced by an arc that stretches as the cursor is moved. Click the 
left button to release the arc. 

Keepout Arcs to straight lines Point at a keepout arc and click the left button. Follow this with a click of the 
right button to convert the arc into a straight-line segment. 

Adjusting size/shape of ko arcs Point at the arc and click the left button. Move the cursor until the arc is in the 
required position, and then click the left button. 
Clicking the right button toggles the last selected line or arc between a line and 
an arc. The shape of the arc is defined automatically, and can be used to 
convert 45-degree lines into quadrants of a circle. The direction of the arc is 
determined by the position of the cursor about the line when the button is 
pressed. 

Moving/adjusting ko circles To move a keepout circle, select the centre of the circle with a click of the left 
mouse button, move the circle and release with a further click of the left button. 

 To resize the keepout circle, select the circumference of the circle with a click 
of the left mouse button, move the cursor and release with a further click of the 
left button. 
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 Once the circle is selected, clicking the right button cancels the change. 

Copper > Add Pad 
Used to add pads to an outline. 
The pad shape/size/angle is selected from the dialogue bar which should be set as required. (Refer to the Pad > 
Add command for more details on pad selection.) 
The Free Copper Layers setting in the dialogue bar controls the layer the pads are added to. Top refers to the 
top, component side of the board (T), bottom refers to the solder side of the board (B). ALL includes all the 
copper layers, i.e. top, inner copper and bottom layers. Other layers listed are user-defined free layers. 
Pads added to the top, bottom or all layers must be attached to a track on the same layer - the track has to be 
added first. If an empty space is selected, or a track from a different layer is selected, the pad is not released. 
Pads added to the free layers can be placed anywhere. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Ensure the pad shape/size and layer(s) are set as required.  
Select Copper > Add Pad. Move the cursor into the main drawing area and a pad appears attached to it. Move 
the cursor and the pad into position and click the left-hand mouse button to release it. 
A second pad appears attached to the cursor. Move it into position and release it. As one pad is released, 
another appears and can be released. Click the right-hand button to remove the pad from the cursor. A further 
click of the left button will restore the pad. 

Copper > Move Pad 
Used to move pads that were added using the Copper commands. 
Although it is possible to move pads away from their copper tracks on the layers top, all and bottom, they should 
become re-attached to the track before the outline is used. 
The Free Copper Layers setting in the dialogue bar on the left of the screen should be set to the layer the pad is 
on. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Ensure the layer is set as required.  
Select Copper > Move Pad. Point at the pad's datum and click the left-hand mouse button, the pad moves with 
the cursor. Move the pad into position and click the left-hand mouse button again to release it. 
Clicking the right-hand mouse button whilst the pad is attached to the cursor returns the pad to its original 
position. 

Copper > Key Move Pad 
Used to move a pad that was added using the Copper commands to a specific X and Y co-ordinate, or to find 
out the position of a pad.  
The X and Y co-ordinates are given with respect to the datum of the outline, which can be moved using the 
Outline  > Set Outline Datum command. 
Once selected, point at the datum of the pad and select it with a click of the left-hand mouse button. A window 
appears containing the current X and Y position of the pad. The co-ordinates are shown in the current units. A 
dot is used as a decimal point in imperial values and a comma in metric values. Enter the new values required 
for the pad, then select OK to implement the move. Select Cancel to cancel the move. 

Copper > Rotate Pad 
Used to rotate existing pads added using the Copper commands in 90 degree increments, anti-clockwise. 
The Free Copper Layers setting in the dialogue bar on the left of the screen should be set to the layer the pad is 
on. 
Ensure the layer is set as required. Select Copper > Rotate Pad, point at the datum of the pad to be rotated and 
click the left-hand mouse button. The pad rotates 90 degrees anti-clockwise each time it is selected. 
User-defined pads can be rotated in increments of one degree if required. Select a user-defined pad with a click 
of the right-hand mouse button. A window appears and the angle of rotation can be entered. Subsequent 
selections of that pad with the left-hand mouse button rotates it in 90 degree increments. 

Copper > Change Pad Style/Size 
Used to replace an existing pad added using the Copper commands, for the currently active pad. (Refer to Pad 
> Add for how to select the pad.) 
The datum of the new pad is positioned directly over the datum of the pad it is replacing. 
Only pads on the currently active layer as defined by the Free Copper Layer in the dialogue bar are replaced.  
Ensure the active layer is set as required. Select Copper > Change Pad Style/Size, as the cursor is moved into 
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the main drawing area, the active pad appears attached to it. Move the cursor over the datum of the pad to be 
replaced and click the left-hand mouse. The pad is replaced. More pads can be replaced until another 
command, for instance Pad > Move/Rotate, etc. is selected. 
The datum point of a standard pad is its centre. The datum point of a library pad is indicated by a small pink 
circle and cross. 

Copper > Describe Pad 
Used to identify the size/shape of free copper pads on the currently selected free copper layer.  
First, select the layer required from the Pads dialogue bar (circled in Figure 113), then select the Copper > Pad 
Describe command, then select the copper pad with a click of the left-hand mouse button. An information 
balloon appears pointing to the selected pad. 
 

 

Figure 113 

Type: indicates and shape of the pad on that layer. Pad shapes are listed as: 
  RO = round, RS = rectangular, square-ended     

 SQ = square, RR = rectangular, round-ended 
Size: indicates the size code and actual size of the pad on that layer. 
Drill: indicates the drill size defined in the pad (only copper pads on “All” layers actually get drilled) 

This command cannot be used on pads/padstacks added using the Pad commands (use the Pad > Describe 
command on those instead). 
Use the Copper > Key Move Pad command to find out the X and Y co-ordinates of copper pads. 

Copper > Delete Pad 
Used to delete pads from the outline that were added using the Copper commands. 
The Free Copper Layers setting in the dialogue bar on the left of the screen should be set to the layer the pad is 
on. 
Ensure the layer is set as required. Select Copper > Delete Pad, point at the datum of the pad to be deleted and 
click the left-hand mouse button. Confirmation is not required. 

Copper > Free Copper Setup 
Used to assign names and colours to the eight free layers that are available within the outline editor. The free 
layers are used to create user-defined solder paste footprints, solder mask footprints, glue spot footprints, etc., 
that can then be used in the artwork editor if required.  
(Ranger produces solder paste and solder mask output files automatically, which output the used pads with a 
uniform user-defined pad swell. It is therefore unnecessary to create these layers unless you have specific 
requirements.) 
Pads and/or tracks can be added to any of the eight free layers within the outline editor, using the Copper 
commands. The data is not automatically used in the layout. Once the outlines have been used on the layout, 
the data on the free layers can replace the inner pads on selected inner layers of the layout. These layers 
automatically become assigned as silkscreen layers, so they have no electrical significance to the layout.  
The eight  "free layers" do not have names assigned to them automatically and they are all set to the same 
colour. It is therefore sensible to assign a name and colour so that they can be differentiated from one another. 
Names can be typed in the vacant name fields or existing names changed. 
To select a colour for the layer, select the arrow alongside the existing colour and choose from the list. Select 
OK to close the window and implement the changes. 

Region commands, outline editor 
These commands are used to define a rectangular area around a group of items in order to move, copy, rotate 
or delete them. 
The Outlines, Pins & Free Copper settings in the Outline dialogue bar (shown in Figure 114) determine which 
categories of data are included in the area.  
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Figure 114 

If no features are included, then an error message will be displayed in the status bar if an attempt is made to 
move/rotate/copy/delete an area using the Region commands. 
When the rectangular area is defined, the first two left-mouse button clicks will define the area to be operated 
on. The second click determines the datum point of the area. 
Pads that are partially within the rectangle are only treated as being inside the rectangle, if their datum is within 
the rectangle. 
Lines (copper or silkscreen) that are not wholly within the rectangle are excluded from the Copy and Delete 
commands, but included in the Move and Rotate commands.  
Text that is not wholly within the rectangle is excluded from all the Region commands.  
The usual Grid snapping rules apply. 

Region > Move/Rotate 
Used to move and/or rotate data within a defined rectangular area. 
Ensure the required features are enabled as required, Figure 114 – a message will appear in the status bar if 
nothing is enabled within the defined area when the move/rotate is attempted.  
Select Region  > Move. Click the left mouse button to locate one corner of the recatular area to be 
moved/rotated. Move the cursor, stretching the attached rectangle to its desired shape, then click the left mouse 
button again to define the area. The area will change colour and move with the cursor.  
Each press of the rotate function key will rotate the rectangle anti-clockwise by 90 degrees. 
Click the left mouse button again to release the area in its new position. A right-click will cancel the move/rotate. 

Region > Copy 
Used to copy data within a defined rectangular area.  
The area can be rotated whilst being copied using the rotate function key. 
If pads with pin numbers are copied, then the copied pads have their pin number allocation re-set to 0. 
Ensure the required features are enabled as required, Figure 114 - a message will appear in the status bar if 
nothing is enabled within the defined area when the copy is attempted.  
Select Region > Copy. Click the left mouse button to locate one corner of the recatular area to be copied. Move 
the cursor, stretching the attached rectangle to its desired shape, then click the left mouse button again to define 
the area. The area will change colour and move with the cursor.  
Each press of the rotate function key will rotate the rectangle anti-clockwise by 90 degrees. 
Click the left mouse button again to copy and release the area in its new position. A right-click will cancel the 
move/rotate. 

Region > Delete 
Used to delete data within a defined rectangular area. 
Ensure the required features are enabled as required, Figure 114 – a message will appear in the status bar if 
nothing is enabled within the defined area when the delete is attempted.  
Select Region  > Delete, click the left mouse button to locate one corner of the recatular area to be deleted. 
Move the cursor, stretching the attached rectangle to its desired shape, then click the left mouse button again to 
define the area. The area will change colour and a prompt will indicate that a left click will delete the area or a 
right-click will cancel the operation.  

Autoplace commands, outline editor 
Autoplace > Adjust Footprint 
Used to define the space required by an outline when placed on the artwork. 
The automatic placement routine uses this boundary when determining how close to one another parts can be 
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placed. It will not overlap boundaries. 
The artwork checking routines can also be used to indicate any silk-screen text located within this boundary. 
The boundary can also be a useful manual placement aid to ensure parts are not positioned too close to one 
another, as quite often silk-screen outlines are smaller than the actual parts. 
When part EMC info is displayed in the artwork editor, the area defined by this command is shaded in with the 
colours assigned to that particular part type (noisy/quiet/susceptible). 
The boundary area is rectangular. Its minimum size is pad dependent and always encloses all the pads, but it 
can be made larger. 
The footprint can be displayed in the artwork editor, but it is never plotted.  
When pads are added to the outline, this boundary is automatically extended to enclose the pads being added. 
The corners of the bounds can be moved by selecting them with a click of the left-hand mouse button, moving 
the cursor, and then releasing them with a second click of the left-hand mouse button. The rectangle always 
encloses all the pads, even if the corners are released inside the pad area. 
Clicking the right-hand mouse button or selecting another command cancels the command. 

Creating and using Starpoints 
A sample design called Starpoints Example.rxl is included with the software and can be found in the 
..\XLDesigner\SampleDesigns\PCB folder. 
It’s recommended that the example be studied before/whilst creating a starpoint.  
It is assumed the user is familiar with the general use of XL Designer – refer to the Getting Started Guide for a 
worked example if required. 

What is a Star point? 
A star point is a common term used to indicate a location where multiple nets (usually power supplies) meet at a 
known location on the artwork.  
In order to allow this “short-circuit” to occur without errors being flagged, a special component outline has to be 
used. 
The special star-point outline has one component pin for each different net that will be joined together. These 
pins are then joined together within the outline, using free copper. In a standard outline this would be identified 
as a short-circuit but the “starpoint” outlines are handled differently. Because of this, the star-point outline has to 
be created carefully because it by-passes the usual automated checks.  
To ensure the auto-routers and copper fill routines do not violate the added free copper, a keepout area should 
surround it (but not the component pads). 
A typical star point component outline for a 3 net star-point is shown in Figure 115. (Silk-screen and 
autoplacement footprint are not shown to aid clarity. 
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Figure 115 

Creating a starpoint outline 
Create a new outline. 
Select View > Properties and tick the Outline is a Routing Star Point checkbox.  
One component pad should be added to the star point outline for each different net that will be connected at the 
star point (Pad > Add).  
The pads may be placed on the Top, Bottom or All layers and any pad style may be used.  
The pads should be numbered (Pad > Assign). 
The pads should be interconnected by inserting free copper on the Top, Bottom or All layers (Copper > Add 
Line). 
Because the artwork checker does not verify the copper connections between the star outline pins, you must 
manually verify that your outline does actually perform the desired interconnectivity between the pads. 
The autorouter, copper fill routine and the artwork checker never see the free copper features that interconnect 
the star point outline pads.  To prevent the autorouter and copper fill routines from placing copper in the area of 
the star outline occupied by the free copper, a keepout area must be defined within the starpoint outline.   
A keepout area should be added to the outline using the Copper > Add Keepout Line command.  The keepout 
area must not enclose the pads in the outline - see Figure 115. 
By using a keepout to prevent nets from violating the star interconnections, there is no need for the artwork 
checker to process the star interconnections and shorts will not be detected between those copper lines in the 
outline. 

Using the starpoint outline 
A schematic part that references the star point outline should be created, and one terminal placed for each pin 
on the star point outline. The terminal/pins should be numbered as for any normal part and correspond to the 
numbers in the starpoint outline. 
On the schematic, each net that must meet at the starpoint must be added separately, and if named, each must 
have a unique name. Each net must then be connected to one of the pins on the starpoint part symbol. 
Within the artwork, the star point part should be placed at the desired location, and the board may be routed, 
copper filled and checked as normal. 
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 Logos Folder 
 
This folder provides access to the logos editor which facilitates the insertion of symbols such as company logos, 
compliance and warning symbols etc. into PCB artwork layers. 
The symbol can be generated from a photo or scanned image. The image has to be loaded into the system's 
logo editor, and then converted into a vector based representation suitable for inclusion into the artwork. 
Images may be imported in JPEG, JPG, GIF, BMP or PNG format. 
 
Note:  For customers installing XL Designer for the first time, a few example logos may be found in the 

MASTERS/Logos library that was installed automatically.  
The example master logo library WILL NOT get installed for existing users who have updated 
their system from earlier versions as the installer will never interfere with the content of user 
library directories after first-time setup. For those users, some example logos may be found in 
the "Logo Examples.rxl" design in the samples directory (normally 'C:\Program Files 
(x86)\Seetrax\XL Designer\SampleDesigns') and dragged from that design into the master logos 
folder if you wish to use them. 

Important Notes: 
The boundary of each symbol is represented by a rectangular area. This rectangular area is used during artwork 
checking to identify the extents of the symbol. Artwork checking only considers logos to be rectangular boxes, it 
does not check for clearance to each individual vector within the logo. 
Logos may be placed on powerplane layers, and will be visible within the powerplane edit mode.  When a power 
plane is generated/regenerated, the logos will be preserved within the layer.  
Logos that are placed in powerplane layers are currently invisible to the artwork checker.  No checks for 
violation with other powerplane features will be performed. 

Creating the logo 
 Right-click on the Logos folder, then select New from the menu that appears.  

Copying logos 
Once a logo has been created, it/they may be copied between designs and to/from the master logo folder by 
dragging them within the navigator pane or right clicking and choosing Copy.  
To Paste the copied logo to another folder, right-click on the destination Logos folder, then select Paste.  

Deleting logos 
Right click the logo(s) and choose Delete. 

Renaming logos 
Right click the logo(s) and choose Rename. 

Selecting multiple Logos 
Multiple logos can be selected using the Shift or Ctrl keys, followed by a right-click/copy/delete/etc. 

Editing/opening a Logo 
Once a logo has been created, it should be opened for editing. Once the editor is open, the desired image can 
be imported and converted into a vector based version, ready for use on the artwork. 
Double-click on the logo name from the Logo folder and the logo editor will open. The editor is divided into three 
editing areas, each selectable by tabs at the top, as shown in Figure 116, where the Select Source Image tab is 
selected. 
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Figure 116 

When the logo is initially created, only the Select Source Image tab is selectable until an image has been 
imported. 
Use the Select Image File button to choose and import an image file containing a logo that will be used on a 
PCB artwork. 
After selecting an image file, the image should display in the window, as shown in Figure 117. 

 

Figure 117 

.  
Use the Flip and Rotate buttons (indicated in Figure 117) to obtain the desired orientation of the image.  
Near the edges of the image, border lines will be seen, with small selector squares at their centre, indicated by 
the red arrows in Figure 117.  
Use these small squares to adjust the image size/shape, by clicking and holding the left mouse button on them, 
then dragging the border lines to select just the part of the image that will be converted into a logo.  
The unselected parts of the image will go dim as you move the borders. 
Once the image has been flipped/rotated/cropped as required, click on the Thresholding tab at the top of the 
window. 
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Thresholding 
This page is divided into two areas as shown in Figure 118. 

 

Figure 118 

The left hand area shows a monochrome rendering of the original image.  
If the original image is in colour, the Colour Weightings slider bars for Red,Green and Blue can be used to 
adjust the priority that each colour has in the conversion of the colour image to monochrome.  With some 
images, this can be helpful to obtain a suitably contrasty image to threshold into pure black/white. 
The right hand area is where the monochrome image is converted to black & white only representation. 
The Threshold Level slider controls the brightness point in the image where the changeover takes place. 
The Invert Image checkbox switches the sense of the resultant image. White in the right hand image gets 
converted into copper on the PCB. 
Once a good image has been achieved in the right hand pane, select the Vector Generation tab which is shown 
in Figure 119. 

Vector Generation 

  

Figure 119 
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This window shows how the logo will look when it is split into individual vectors, the before and after adjustment 
views are shown side by side. 
The Pitch control provides control of the fineness of the resultant logo.  
The Minimum Vector Length control can be used to remove small unwanted spots that sometimes occur as a 
result of not being able to find a perfect setting for the thresholding level.  
In this window, the drab green colour represents the laminate colour of the pcb, and the white is copper.  
The boundary of the symbol is represented by the rectangular area shown. This rectangular area is used during 
artwork checking to identify the extents of the symbol. Artwork checking only considers logos to be rectangular 
boxes, it does not check for clearance to each individual vector within the logo. 
Once an acceptable logo is displayed in the Vector Generation page, the Logo editor can be closed and the 
Logo is ready for use within the artwork editor. Refer to the Logo commands in the artwork editor (page 286) for 
details on how to use the Logos. 
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Parts & Nets List Folders 
In order to design a PCB artwork, XL Designer requires a parts list and a net list. These lists can be generated 
automatically from a schematic diagram drawn in XLD, typed in using XLD’s own parts and nets list editor or 
imported from text files. 
It is also possible to create a parts/net list that has been back-annotated from the artwork editor using the Tools 
> Network commands. 
Once the artwork is complete, checking routines are supplied to ensure that the artwork connectivity matches 
the parts/nets list, however it was generated. 
Wherever they have come from, the parts/nets lists can be viewed, and edited if required, using the parts/nets 
list editing facilities. These facilities can also be used to access the cross-probing tools.  
In addition to being able to type in a parts/nets list, the parts/nets list editors are also a useful tool for checking 
parts and nets lists that have been extracted from a schematic or imported, prior to board design  
The editors will highlight outlines that do not exist or invalid nodes, supply a list of unconnected pins or identify 
"single-node nets" (connections that start but do not connect to anything else). 
Note: if the parts/nets list has been extracted from the schematic editor and it needs to be changed, then the 
changes should be made to the schematic and the parts/nets list re-extracted, otherwise the two will become out 
of step with one another. 
Any changes made to the parts/nets list using the parts/wiring list editors will be lost when the parts/nets list is 
extracted from the schematic.  

Viewing the list of parts or nets  
Expand a design’s folder in the navigator window, then expand the Parts or Nets folders to list the parts and 
nets for the design as shown in Figure 120.  
 

 

Figure 120 

When the Parts or Nets folders are selected in the navigator pane, the Properties pane shows a count of the 
placed/unplaced parts in the design, or the number of power and signal nets in the design, depending on which 
folder is selected. 
Double-clicking on any part or net from the navigator list opens the editing window – this displays the complete 
parts or net list – both windows are shown in Figure 121. These windows can be used to edit any of the entries if 
appropriate. 
(If the parts or net list is empty, then the selected editor is opened so that entries may be typed in if required.) 
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Figure 121 

 
If the windows contain invalid entries, they are highlighted in the window so they are easy to identify. Figure 122 
shows an outline that is highlighted in the parts list, caused by a typing mistake - the outline in the library is 
called DO41 whilst D041 has been called up. This results in problems in the associated net list – because the 
outline D041 doesn’t exist, neither do the pin numbers that it refers to. 
 

 

Figure 122 

Simply scroll/page through the parts and net list windows looking for invalid (highlighted) entries.  
Invalid entries should always be investigated and corrected or problems will occur later in the design. Typical 
invalid entries and solutions to them are given later in this chapter. 
The parts list, lists all the parts that have been added to the design, along with associated information in 
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columns. Each part appears on one line. 
The columns can be sorted in ascending/descending order by clicking on the column headers.  
The net list lists all the connections or “nets” that have been added between the parts in the design, along with 
associated information in columns.  
A net will have a minimum of two nodes, the start and end pins. There is no maximum number of nodes in a net, 
so nets may occupy more than one line, in which case the word Contd-> appears in the Name column to 
indicate the line has been continued from the previous line.  
Power rails can be treated differently by XLD on the artwork design - if a signal name has been defined as a 
power rail (Configuration > Power Names), the name is shown in a different colour in the net list to indicate it is 
a power rail – VCC & GND in Figure 122. 

Deleting the parts list 
 

Cross-probing tools 
Once the list of parts or nets is displayed in the navigator window, right-clicking the mouse over any of the parts 
or nets will introduce the Find in schematic or Find in artwork commands as shown in Figure 123. 
 

 

Figure 123 

When selected, the appropriate editor (schematic or artwork) is opened/popped forward and the item indicated 
by a balloon containing information about it., Figure 124.  
Icons within the balloon allow further selections to be made, for example if a multi-element schematic part is 
located, “arrow” icons in the balloon allow the next occurance of the part to be found on the schematic, or the 
item to be located in the other (artwork/schematic) editor. 

 

Figure 124 

Making Nets visible/invisible 
Whilst working in the artwork editor, it’s possible to make all signal and all power unroutes (connections) 
visible/invisible independently of one another (View Control dialogue bar). However, it can also be useful to hide 
or view specific nets within each of those general categories. 
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Displaying particular nets (unroutes) 
The View Control dialogue bar in the artwork editor has a setting that allows specific nets to be made visible 
(Figure 145),  
Which nets are specified is controlled from the expanded Nets list folder (Figure 125) - right-clicking any of the 
nets will introduce the commands, also shown in Figure 125. 

 
Figure 125 

Once Show net unroutes is selected, the net will have “(s)” inserted alongside it in the expanded Nets folder 
(Figure 126) to indicate it will be “shown” when the Nets unroutes are selected for display in the artwork editor. 

 

Figure 126 

 
To restore its status, right-click the net again and select “Show Net Unroutes” to toggle the setting off. 
Multiple nets can be selected using the Shift and Ctrl keys before right-clicking. 

Hiding nets (unroutes) 
Which nets are hidden is controlled from the expanded Nets list in the navigator window. Right-clicking any of 
the nets will introduce the commands shown in Figure 125. 
Multiple nets can be selected using the Shift and Ctrl keys before right-clicking. 
Select Hide Net Unroutes to hide the selected net when the general category of unroutes (signal or power) are 
made visible in the artwork editor (View Control dialogue bar).  
The net will have “(h)” inserted alongside it in the expanded Nets folder to indicate it is hidden - Figure 127. 
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Figure 127 

The hidden status is restored to visible when the design is closed so the net(s) are not forgotten! 
To restore its non-hidden status whilst working, right-click the net again and select “Hide Net Unroutes” to toggle 
the setting off. 

Typing in a parts list 
With the job folder open in the navigator, either double-select the Parts folder or select it with a right-click of the 
mouse, then select Open (Figure 128). 

 

Figure 128 

 
A window similar to the one shown in Figure 129 appears.  The parts that are required on the design must 
appear in this window. The window is divided into fields consisting of UID, Part, Type, Outline, Code, X, Y and 
Rotation fields. They are described later under the heading Parts list fields. 
 

 

Figure 129 

The Part and Outline fields must have an entry, the other fields are optional so can be left blank or at their 
default settings.  
Double-select a field to introduce the text-entry cursor. Once a value has been typed, use the <tab> key or the 
arrow keys to move between fields. 
Start by typing in a Part, for example IC1, then press <tab> to move to the next field. The X, Y and Rot fields are 
inserted automatically. 
The Type field is optional but it makes the link to the schematic parts that will be required if gate and pin 
swapping will be used in the artwork editor.  
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If a type is not required, press <tab> to skip to the Outline field.  
The Outline field must contain the name of the component outline that defines the physical representation of the 
part.  Press <tab> once the name has been typed. If the outline doesn’t exist in the design’s component outline 
library it is automatically copied into it from the master component outline library. 
If the outline cannot be found in either location, the field will get highlighted to indicate it must be changed or an 
outline with that name supplied in the design’s outline library. 

Dragging/dropping outline names 
Outline names can be dragged & dropped into the outline field to save typing. Ensure the Component 
Outline folder is open in the navigator (either the design’s own or the master outline folder), then scroll 
through the list until the outline required is located – each one can be displayed in the Properties & Browser 
windows (if visible) if selected with a click of the left-mouse button. Once the outline has been located, 
position the cursor over the outline in the folder, hold-down the left mouse button and drag the cursor over 
to the Outline field in the parts list. The name will be inserted. 

The Code and MCAD Model fields are optional (see below for details). 
The X, Y and Rotation fields are updated as parts are moved on the board. (The co-ordinates can only be 
entered or modified after selecting Edit > Allow Position Edit command from the command bar.) 
Continue to <tab> or use the arrow keys until the cursor appears in the parts field of the next line and type in the 
next part.   

Modifying the parts list 
If a spelling-type mistake is made, double-select the string to be edited, the text entry cursor appears and the 
changes required made.  
A field can be deleted by selecting the string so that it is highlighted, then pressing the <Delete> key. 
To delete the complete part (line), select the Part field and delete it, the complete entry (line) is removed. 
Multiple entries in columns can be selected by holding down the left mouse button and sliding the cursor over 
them - once highlighted they can be deleted using the <Delete> key.. 

Repeating parts 
Select the part name field or complete line of an existing part, then select Edit > Repeat part from the 
command bar. Enter the details required in the window that appears. The new parts are added. 

Parts list fields 
UID UID stands for unique identification number. This field is automatically assigned by SXLD 

when a part is added and cannot be edited. 
This column can be hidden/revealed using the View > Show Part UIDs command.  

Part This is the name the user allocates as a unique reference for each component in the design.  
It must comprise of a prefix and number, for instance IC1, R1, etc.  
The prefix used must be present in the part prefix table, if it isn’t, then a window will appear 
requesting that the prefix be added to the table. If it is not added, the part will be removed 
from the parts list. 
Maximum of 4 + 4 characters (four for the prefix and four for the ident). i.e. PLUG1 through to 
PLUG9999). 

Type This field is accessed by the gate and pin swapping routines. It is used as the link between 
the physical package (the outline), and its schematic library part.  
If gate/pin swapping will not be performed on the part in the artwork editor, this field could 
contain anything that would individually identify it, i.e. its stock number, a catalogue reference, 
or it could be left blank.  
Even if a schematic has not been drawn (the parts/net list has been typed in or imported), if 
gate or pin swapping will be performed on the part in the artwork, then the design must 
contain all the schematic parts representing each of the parts that will be swapped. The 
schematic part(s) must have the appropriate equivalent gates &/or pins defined. 
Gate or pin swapping cannot be performed in the artwork if the associated schematic parts do 
not exist. 
For gate swapping purposes the Type field must comprise the schematic library part name 
(maximum 16 characters) and the schematic library part value field (maximum 16 characters), 
separated by a comma. Maximum of 33 characters in total. 
For example the shematic part might be called: RPK100K whilst the value of the resistors 
might be 100k. The Type field in the parts list would be: RPK100K,100k 
Gate swapping between packages is only permitted if the Type fields of the packages are 
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identical. 
If the parts list has been extracted from a schematic, then the type field is made up from the 
schematic library part name and the value attribute field from the schematic part’s symbol 
attributes, separated by a comma. 

Outline This field identifies the physical package from the component outline library to be used for the 
part on the artwork. Maximum 16 characters. 
If the outline does not exist in the design’s component outline library, the outline is 
automatically copied from the master component outline library into the design’s component 
outline library. 
If the outline does not exist in either place, it will be highlighted to indicate the outline does not 
exist. The highlighting remains until a valid outline name is entered, or the outline is added to 
the design’s component outline library. 
If the parts list has been extracted from a schematic, then the outline name is initially obtained 
from the Outline attribute field in the schematic part’s symbol attributes. It is possible to 
change the outline used on the artwork from the parts list editor or from the artwork editor, so 
the outline name in the parts list and that defined in the schematic part may be different. 
(When the parts/net list is extracted from the schematic again, it depends on the extractor 
settings as to whether the outline is updated or not.) 
If an outline is changed in the parts list and the part has already been placed on the board, the 
change to the outline is immediate, but it does not affect routed tracks, silk-screen data, 
power-planes etc. which would have to be updated in the artwork editor. 

Code This field can be used as required, for a company's own stock record number, a specification 
reference, a catalogue reference, or anything which identifies it. Maximum 16 characters. 
The information is not currently used by SXLD, but may be accessed along with the rest of the 
parts list by external application programs, if it is sent to a file using the File > Save As Text 
command. 
If the parts list has been extracted from a schematic, then the code is obtained from the Order 
code attribute field in the schematic part’s symbol attributes. 

MCAD Model Values entered in this column can be used as the 3D model/geometry library name by the IDF 
Output Task. It can be left blank. 
If not used, this column can be hidden/revealed using the View > Show MCAD Model Name 
command.  

X and Y These columns contain the position of the part's datum on the artwork with respect to absolute 
0,0 (lower left corner of working area) in the artwork editor (which is not necessarily the 
position of the movable datum point). 
The units are shown in inches or millimetres, depending on the units selected (Edit > Units). 
Decimal points are shown as dots if inches are in use, and commas if mm's are in use. The 
special function keys for Inch/Metric mode can be used to toggle the units. 
It is usual to leave these columns set to 0 and position the parts interactively. These columns 
are updated automatically when parts are moved in the artwork editor.  
Some components such as connectors, switches, etc. have to positioned precisely, in which 
case their co-ordinates could be entered. 
To edit these fields, select Edit > Allow Position Edit from the command bar. 
If the parts and net lists were created from a schematic, re-extracting the schematic will not 
change these fields, unless the part has been removed. Do not delete the parts and net list 
before extracting the parts/net list, as all the X/Y values will be re-set to 0,0 which means all 
the parts will become unplaced on the artwork. 

Rot This column indicates the orientation and layer of the parts on the board. It is usual to leave 
this column set to 0 and rotate or flip the parts interactively. The column is updated 
automatically when parts are rotated or flipped in the artwork editor. 
To edit this field, Edit > Allow Position Edit should be enabled from the command bar. 
An entry of 0 represents the part as it was created in the component outline library. Rotation is 
specified in degrees, anti-clockwise. 
If F (for flipped) precedes the entry, the part is flipped (mirrored) about its original Y axis. 
When entering the data for flipped parts, enter it as one string, i.e. type F45 if the part is 
required flipped and rotated through 45 degrees; the entry will appear as F 45. 
If the parts and net lists were created from a schematic, re-extracting the schematic will not 
change these fields, unless the part has been removed. Do not delete the parts and net list 
before extracting the parts/net list, as all the Rot values will be re-set to 0. 
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Outlines are highlighted - typical causes of invalid entries in parts list editor 
Highlighted outlines will often result in highlighted entries in the net list as well - correcting the invalid outline 
may also clear up the net list, so always start with correcting the invalid outlines! 
This can be caused by a spelling mistake or because the outline does not yet exist in the component outline 
library.  

Correcting spelling mistakes 
Look at the outline that's highlighted - is it a spelling/typing mistake? The name must correspond to an outline 
held in the design’s outline library.  
If it’s simply that the outline hasn’t been created or copied to the design’s outline library yet, as soon as the 
outline is created/copied then the highlighting will disappear. 
If the spelling is incorrect, how it is corrected depends on where the parts list originated from. 

Parts list compiled from a schematic: 
For example IC’s1 to 6 which are all 7400’s, may call up DIL1, instead of DIL14. 
If so, return to the 7400 schematic part, and edit the part's symbol attributes and correct the outline name. 
This will affect all of the parts (IC’s 1 to 6) on the schematic sheet. To alter it so that only IC4 were affected, 
then open the schematic sheet containing IC4 and edit its attributes. 
In both cases, extract the parts/net list again, ensuring the extraction setup window is set to update outline 
fields.  
It is also possible to correct the name in the parts list editor by selecting it, then re-typing it, or 
dragging/dropping the outline from the outline folder. Be aware that the next time the parts list is extracted 
from the schamtic, this outline may revert back to that called up by the part – depending on the settings in 
the parts/netlist extractor. 

Typed in parts list:: 
Correct the name by selecting the entry and re-typing it, or drag an outline from the design or master outline 
library. 

Imported parts list: 
How this is corrected depends on what may happen in the future. The easiest and quickest way where only 
a couple of outlines are involved is to edit the entry as per the instructions for a typed in parts list.  
However, if many outlines are involved, or it's likely that modifications will be performed on the design in the 
future by importing an updated parts list, it would be sensible to return to the source of the parts list and 
correct it there, then import the corrected parts list. This means that if modifications are made to the 
“updated original” parts list in the future and the new file imported, the outline changes won't be lost. 

Once the spelling has been corrected (and the outline exists) the highlighting will disappear. 

Correcting non-existent outlines 
If it is believed that the outline name is spelt correctly in the parts list, then it's likely the outline doesn't exist in 
the component outline library (or the outline name itself has been mis-spelt).  
The outline will need to be created/copied/renamed in the design outline library at which time the highlighting in 
the parts list will disappear.  

Typing in a net list 
The net list cannot be typed in until a parts list exists. The inter-connections between the parts in the parts list 
should be entered in the net list. 
With the job folder open in the navigator, either double-select the Nets folder or select it with a right-click of the 
mouse, then select Open. The window shown in Figure 130 appears. The window is divided into columns 
entitled Name, UID code, Min clear, Size and some untitled columns - they are described later under the 
heading Net list fields. 
 

 

Figure 130 
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The columns will increase their width automatically as required. 
The Name, UID code, Min clear and Size fields may be left blank and a default value will be inserted 
automatically if one is required. The untitled columns are where the nodes in a net should be typed/appear. 
All the nodes in one row are connected together. If the net has more nodes than can be fitted in the row, they 
are continued on the next line and the word Contd-> appears in the Name field to indicate the net has been 
continued. 
Double-select a field to introduce the text-entry cursor. If a signal name, minimum clearance or size is not being 
specified, select the field in the first untitled column as shown in Figure 131. 

 

Figure 131 

Once a value has been typed, use the <tab> or the arrow keys to move between fields.  
If the net is not complete once the last column is reached, continue to use the <tab> key, this will create a new 
line with the word Contd-> in the Name column. 
The same pin number cannot be used more than once - the entry will have to be re-typed, but it will allow invalid 
entries, for instance referring to parts or pins that don’t exist. The invalid entry will remain highlighted until the 
entry is changed or the appropriate changes are made elsewhere. 

Modifying the wiring list 
If mistakes are made the entry can be edited or removed.  
To delete an entry, select the entry once, then press the <delete> key. If a mid-node is deleted, the remaining 
nodes move back so that an empty space does not remain. 
To edit an entry, double-select the entry, the text entry cursor appears and the string can be modified. 
If an extra node is required, select the next empty node field on the end of the net it will be added to. If there are 
no empty fields on the end of an existing row, double-select the last occupied node, then press the <tab> key so 
that a continued line is inserted. 
When entering signal names, if they are defined as power rails they will highlight so that they can be 
differentiated from the signal connections (see below).  

Net list fields 
Name This field is reserved for optional signal names, or continuation characters. (Do not enter the 

first node of a signal in this column, since it will be used as a signal name.) Maximum of 16 
characters. 
When a name is entered, a comparison is made against the names held in the power names 
table (case insensitive). If a match is detected, then the case of the entered name is changed 
to suit the case of the name in the power names table, and the net becomes a power rail.  
(Once a power name has been defined it is not possible to have a signal name with the same 
characters, but different case. This is to avoid confusion, for instance having a power 
connection called GND and a signal connection called gnd.) 
When signal names defined as power rails are entered, the signal name highlights. If the 
name does not highlight, it is not being recognised as a power rail. 

UID code UID stands for unique identification number. This field displays the unique identity number that 
is automatically assigned to the net - each net has its own code so that unnamed nets can be 
more easily identified in the reports that SXLD may produce, such as artwork checking 
results. This value cannot be edited. 
The .dsn file that is created by the Specctra interface uses the UID codes for identification of 
unnamed nets. 
This column can be hidden/revealed using the View > Show Net UID Codes command.  

MinClear This field can be used to assign a specific minimum clearance for a net. If a value is not 
entered, then the minimum clearance requirement for the net is as specified by the on-line 
DRC and artwork checking routines. 
The units are shown in inches or millimetres, depending on the units selected (Edit > Units). 
Decimal points are shown as dots if inches are in use, and commas if mm's are in use. The 
special function keys for Inch/Metric mode can be used to toggle the units. 
If the net list has been extracted from a schematic, the default minimum clearance sizes as 
specified by the on-line DRC and artwork checking routines is used unless a specific minimum 
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clearance was assigned to the connection on the schematic. 
This column can be hidden/revealed using the View > Show Minimum Clearances command.  

Size This field can be used to assign a specific track width code to a signal. Valid codes are 0 to 
511 and . (dot). If a size is not entered, then "." is inserted automatically. 
The . (dot) indicates the default track codes should be used for signal and power connections. 
The default codes are defined in the design’s Configuration folder in the Manual Routing 
Parameters window. The actual sizes are defined in the same folder in the Sizes table 
window.  
If the net list has been extracted from a schematic, the default track width codes are used 
unless a specific code was assigned to the connection on the schematic. 

Nodes The unnamed fields are used for nodes in a connection. Nodes should be typed in as: 
part reference.pin number 
For example:  IC3.3  R1.2  TR3.E 
The part reference must appear in the parts list.  
The pin number can have a maximum of 8 alpha-numeric characters in any order. They 
should correspond to the pin numbers in the associated component outline as defined in the 
parts list. 
When typing in part references that use the first entry in the Part Prefix Code table, it is not 
necessary to type in the prefix. For example, if IC is the first entry in the part prefix table, and 
IC4.2 has to be typed, simply type 4.2, the IC is added automatically. (The order of the part 
prefix code table should not be adjusted to take advantage of this facility once the parts list 
has been started or the existing part prefixes in the parts/net list will be altered as well.) 
Nodes on the same line are connected to one another, but not to nodes on the next line 
unless the word Contd-> appears in the signal name column of the next line. 

Nodes are highlighted - typical causes of invalid entries in net list editor 
Invalid entries are typically produced because the component outline has not yet been defined, is named 
incorrectly, pin numbers on the schematic part have not been assigned correctly, or some pins in an outline are 
missing or have not been numbered.  
To identify the cause: 
Look at the pin numbers that are highlighted. For example: IC7.16 Open the parts list and check that the outline 
for IC7 is not highlighted – if it is, correct this first as that may be what is causing the pin number(s) to highlight.  
If the outline isn’t highlighted, then the outline does exist so it’s a problem related to the pin number. 

Correcting Pin 0's 
For example IC1.0, R12.0, etc., should never appear in the net list. How this is corrected depends upon where 
the net list has come from, as follows: 

Net list extracted from a schematic: 
If the pin numbers are set to 0, then it's likely that the schematic part's pins will not have had pin numbers 
assigned. 
Take a note of the part name, for instance IC1, R12, etc., then open the parts list. Locate the part and take 
a note of the type field - the name before the comma in the type is the schematic part name, which is what 
you require. 
Open the schematic part, use the Terminals > Check command to help indicate any problems. Assign the 
pin numbers correctly. Use the Terminals > Check command again to ensure no further problems were 
introduced. 
The part(s) on the schematic will need to be de-allocated, then re-allocated for the change to be 
implemented. Extract the parts/net list again. Check the parts/net list for highlighted entries. 

Typed in wiring list: 
Correct the entry by selecting the entry and re-typing it. 

Imported wiring list: 
How this is corrected depends on what may happen in the future. The easiest and quickest way where only 
a couple of pins are involved is to edit the entry as per the instructions for a typed in wiring list.  
However, if many pins are involved, or it's likely that modifications will be performed on the design in the 
future by importing an updated net list, it would be wise to return to the source of the net list and correct it 
there, then import the corrected net list. This means that if modifications are made to the “updated original” 
net list in the future and the new file imported, the pin number changes won't be lost. 
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Correcting non-pin 0's 
If the pin numbers appear to be correct, then it's likely that the pads in the component outline have not had pin 
numbers assigned, are numbered incorrectly or there are not enough numbered pads in the outline for the pins 
used on the schematic part.  
If the associated outline in the parts list is also highlighted, then the outline doesn't correspond to one in the 
outline library. 
Take a note of the part name, for instance IC43, R56, etc., then open the parts list. Locate the part and take a 
note of its Outline name. 
Open the Component Outlines folder and open the outline noted above. Use the Pad > Describe command to 
identify the pin numbers assigned to pads. 
Are they correct? Does the outline have the correct number of pads? If the wiring list calls up IC1.20, but a 
DIL16 has been called up for the part, then either the incorrect outline was used (perhaps a DIL20 should have 
been called up) or the part should not have pin 20 assigned. Make the appropriate corrections depending on the 
reason for the error. 
If alpha-numeric pin numbers have been used, ensure the pin numbers in the outline correspond exactly. 
(The outlines in the supplied library only use numeric pin numbers.) 

Single node nets 
What is a single -node net? It's a connection that has been started but is not connected to anything else. 
Single-node nets are reported when a parts/net list is extracted from a schematic and when the artwork checks 
are run. However if the net list has been typed/imported, or extracted from the "old, flat" schematic editor, having 
them reported when the design is complete may be a little late in the day; especially if the connection should be 
attached to a pin on the other side of a tightly packed board.  
Single node nets occur because a connection has been attached to a part pin, then released in mid-air - 
probably with the intention of adding a signal name to it, to "make" a connection to another same-named 
connection, or a spelling mistake has been made. For example AO typed in instead of A0. Or, if a net list has 
been typed in, the phone may have rung and diverted attention from the net being typed. 

Single node nets can be located as follows: 
With the net list editor open,scroll through it, watching the second node column for an empty space.  
This can be made easier if the window is displayed & resized as shown in Figure 132, so that only the first two 
node columns visible. The UID and Minimum clearance columns have also been hidden using the View 
commands. 
 

 

Figure 132 

The only time the second node column could legitimately be empty is if the line has been continued from the 
previous line. 
In Figure 132, the connection with the signal name “R3” is a single node net – it starts at TP4.1 but isn’t 
connected to anything else.  
The node IC7.8 is not a single node net because it has been continued from the previous line. 
When single node nets are located, they should be investigated and a correction made by either making the 
correct connection on the schematic or removing the offending connection and re-extracting the parts/net list. If 
a schematic was not drawn, edit the net list. 
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Unused pins list 
Refer to the heading Edit > Find Unconnected Pins later in this chapter. 

BOM (Bill of Materials) output  
Refer to the heading View > Bill of Materials later in this chapter. 

Individual commands in parts/net list editor 
The following commands are available when either the parts or net list editors are active. If the commands are 
greyed out, these commands are not applicable to the active window. 

File commands 
File > Save Parts (or Nets) List As Text 
The information held in the parts and net list editors can be output to text files. These files can be used as a 
source for pick and place machines, wire wrap machines, etc. and can be modified using a standard text editor if 
required. When the output file is created, it contains the data from whichever list is active. 
When selected, the Windows browser appears, use it to locate the folder where you would like the file to be 
created in, and then supply a name for the file, including the .txt extension if required.  
The “Save as Type” setting, indicated in Figure 133, can be used to output the file with space or tab separated 
columns. The tab separated output makes it easier to import the resultant file into spreadsheets and other 
programs. 
When saving the net list with tab separation, the signal name column for unnamed nets will be blank, for space 
separated columns a full stop is output. 
Nets nodes will not be continued onto multiple lines.  All net nodes will be output on a single line. 
       
The net UID values is included. 
 

 

Figure 133 

Select Save to create the file. 
 
Note: A GenCAD ASCII format file containing more comprehensive information suitable for pick & place 
machines is also available.  (Right-click on the design name in the navigator, then Export > Gencad Format 
ASCII File Generation.) 

File > Print  
The parts and/or net list can be printed to the Windows printer as required using this command. When the 
printout is selected, it contains the data from whichever list (parts or wires) is active. 

File > Close Parts (or Nets) List 
When selected, the parts (or Nets list) editor window is closed.  

Edit commands  
Edit > Units 
Used to change the units in use between metric or inches.  The units in use can be recognised by the 
appearance of the decimal point  - a dot (.) is used in inch values and a comma (,) in metric values. 

Edit > Find Part 
Used to find a specific part in the parts list. When selected, the part reference should be typed in the window 
that appears, i.e. IC3 to locate IC3. Not case sensitive. 
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Edit > Repeat Part 
Used to repeat the selected part in the parts list, whilst automatically incrementing the part reference number. 
Useful when typing in a parts list with multiple copies of the same part. 
Select the part reference to be repeated, then Edit > Repeat Part, fill in the details in the window. The new parts 
will be added to the end of the existing entries. 

Edit > Allow Position Edit 
Activate  this command (by selecting it) if the X, Y or Rotation fields in the parts list have to be edited. Until this 
command is activated, these fields are not selectable. 

Edit > Find Node 
Used to find a particular node in the net list. When selected, the node should be typed in the window that 
appears, as they would appear in the net list, i.e. IC3.6 to locate IC3, pin 6. 

Edit > Find Signal Name 
Used to find a particular signal name in the net list. The search is not case-sensitive unless there are multiple 
occurrences of a signal name in use when the first name will be located. For example, if clock and CLOCK 
occur in the list, then searching for Clock will find whichever one occurs first in the list. 

Edit > Find Unconnected Pins 
A list of the unused/unconnected pins in a design can be obtained from the net list editor.  
When using this method to identify unused pins, they are defined as those pins that exist in component 
outlines, but are not referred to in the net list. 
A list of unconnected pins can also be obtained from the schematic editor. This may produce a different result, 
as the check is based on schematic parts (for instance a connector may have 9 pins on the schematic, but the 
component outline could have 11 pins that includes two mounting pins/holes). 

Obtaining the list 
With the net list editor open and active, select Edit > Find Unconnected Pins. The list is displayed on the 
screen automatically. It can be printed (File > Print), sent to a file (File > Save as) and closed (File > Close). 
If the Tools > Find Unconnected Pins command is not available, ensure the net list is popped 
forward/active.  

 

View commands 
View > Show Part UID’s 
Used to toggle the display of the part uid (unique identification) field on/off. (The part uid value cannot be 
edited.) 

View > Show Net UID Codes 
Used to toggle the display of the net’s uid (unique identification) code field on/off. (The net uid value cannot be 
edited.) 

View > Minimum Clearance 
Used to toggle the display of the minimum clearance field on/off.   

View > Bill of Materials 
A bill of materials (BOM) can be obtained from the parts list editor. This is a fixed format file and can include 
parts from both sides of the board, or either side of the board..  
More flexible, user-definable bill of materials files can be obtained from the schematic editor when it is open 
(Tools > Parts/Netlist Extraction > User Defined Extraction).  

Producing the Seetrax format BOM file 
With the Parts list window open/active, select View > Bill of Materials.  
The window shown in Figure 134 opens.  
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Figure 134 

Part selection: All the parts can be output or just the parts from one side of the board. 
If “Create Report Style” is selected, this will produce a standard output using spaces between fields.  
An option is given so that the part references (R1, R2, R3, etc.) can be included or excluded as required. 
Excluding the part references reduces total page count and assists in fitting the report to the available page 
width. 
If “Create Spreadsheet Style” is selected, this will produce an output using either Tabs, Commas or a user-
defined character between fields. 
The column headers can be included/excluded as required. 
When OK is selected, the output is produced and appears in a window.  
It can be printed (File > Print), sent to a file (File > Save as) and closed (File > Close). 

Right-clicking the Parts or Nets Folders 
Delete All Parts and Nets 
By right-clicking on the Parts folder, it is possible to delete the entire parts and net lists. This command should 
be used with extreme caution.  (Always save a backup copy of the design prior to its use so that you have 
something to return to.) The parts list stores all the placement information for the artwork, so deleting it will 
remove all the parts from the artwork (the artwork layers will remain). 
If a schematic has been created/modified it is never necessary to use this command. The parts/wiring list should 
be re-extracted and the parts/wiring list will be updated. 
However there are times when performing modifications to a design where you might want to re-start the 
artwork design, based upon an existing schematic, so this command does have its uses. 

Delete All nets 
Same as the Delete All Parts and Nets command, but only removes the nets list. Use with extreme caution and 
copy the design first! 
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Board Profile 
Before laying out the artwork, a board profile is required.  
The board profile is used as a guide for yourself when placing parts, and as a basic working area for the 
automatic routines such as copper fill, power plane generation and auto-routing.  
The View > Full command also uses the board profile as its guide when filling the screen with the layout. 
The board profile editor is used to define the board profile and can also be used to define keepout areas for the 
auto-router and copper fill routines. 
Data in the board profile editor can be imported from an AutoCAD DXF file if required/preferred. Once imported, 
the data can be modified as though it were originally defined using the board profile editor. 
The board profile and keepout definitions can also be modified or added from within the artwork editor, using 
either the Amend or Region command menus. Any changes made in the artwork editor are back-annotated to 
the board profile editor immediately. Changes made in the profile editor are also implemented in the artwork 
editor immediately. 
Changes made in the board profile editor do not affect the position of parts in the artwork or power planes, so 
they may need to be updated as a consequence of the change. 
Only one profile is held in the design. 
Board profiles can be copied to the master board profile library and used on other designs. Once in the master 
library, the profiles can be copied and modified. 

Opening the Board Profile Editor (design or master) 
To open the design’s board profile editor, with the design’s folder open in the navigator window, double select 
the Board Profile (or right-click/Open). The editor opens. 
The master board profiles are held in a folder inside the Masters folder, so first open the Masters folder by 
selecting the + sign alongside it, then open the Profile Library folder in the same way. If board profiles exist in 
the folder they will be listed below the open folder in the navigator pane. They can be selected in turn to browse 
through them. As the board profiles are selected, they are shown graphically in the Browser window and their 
properties displayed in the Properties window (if those windows are open).  
A board profile can be opened for editing by double-selecting it. New designs will not have a profile defined.  
Once the editor has been opened, if a profile has been defined it will appear.  
A grid may or may not be visible.  
A red shaded area around the bottom and left hand side of the working area indicates negative coordinate 
space.  The board profile should not be drawn touching or within the negative space as this can cause 
difficulties with artwork placement, routing and output. This red area cannot be switched off in the profile editor 
(though it can be made invisible in the artwork editor). 

Creating a board profile – general guidelines (incl. keepouts) 
Once the board profile editor has opened, the board profile and keepouts can be created/edited.  
The tool bar shows the current Edit Mode category, which is initially set to Profile. This indicates that any lines 
drawn will become part of the board profile. It can be changed to Keepouts by selecting the arrow alongside, 
then choosing from the list that appears. 
It is often convenient to have the grid switched on when defining the profile. If the grid is switched off or not set 
to a suitable pitch, it should be switched on/changed using the Grid commands.  
Once defined, the co-ordinates of the profile/keepout/router data can be viewed and edited using a text-style 
editor (Profile > Numeric Editor). 

Adding the board profile 
The board profile MUST be a completely enclosed polygon. It can be drawn with combinations of straight lines 
and arcs or a circle. 
Do NOT define more than one board profile polygon, as the auto-router, split power plane generator, copper fill, 
etc. routines use the board profile to define their working area and will become confused if there are two or more 
board profiles. (Tooling holes can be added as extra holes or created as outlines and placed on the board as 
parts. If you want to define a position for them in the profile editor, add the locations using keepouts ) 
The profile is typically drawn from the starting point indicated by the pink circle/cross, although it's not essential. 
This is because it is useful to have space around the sides of the board to allow parts to be placed off the board 
temporarily.  
The starting point is 1.0" in and up from the lower left corner of the working area. It cannot be moved. The co-
ordinate readout is given with respect to the datum of the editor, which can be moved.  
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Do not draw the profile along the edges of the working area - either touching or in the red-shaded negative area 
in order to avoid problems later on. 
Use the commands from the Profile pull-down menu as required to draw/modify the board profile. 
In the profile editor, the profile line is displayed in blue so that it can be differentiated from the yellow keepout 
lines. 
The board profile lines can also be modified from within the artwork editor, using the Amend commands. 

Adding the keepout outline(s) 
The keepout outline is drawn using the same commands as the board profile, except that the Edit Mode setting 
should be set to Keepouts. 
The keepout line should completely enclose an area if that area has to be kept free of tracks, etc. It can be 
made up of combinations of straight lines and arcs or a circle. As many keepout areas as required can be 
added.  
Enclosed keepout areas are shown cross-hatched in the board profile and artwork editors. 
Do not draw the keepout lines along the edges of the working area - either touching or in the red-shaded 
negative area in order to avoid problems later on. 
The auto-routers and copper fill routines stay inside or outside of the areas enclosed by keepout lines. If a single 
line is added, then the automated routines will go around the line, but will use the space either side of the line. 
Sometimes, keepout areas are related to the positions of certain parts. If this is the case, add the keepout areas 
after the parts have been placed on the board. The position of part pins can be seen by selecting the View > 
Drillholes command. 
Keepout lines can also be modified from within the artwork editor, using the Amend commands. 
In the profile editor, the keepout line is displayed in yellow so that it can be differentiated from the blue profile. 

Individual commands - board profile editor  
An overview of the board profile editor can be found in the Installation & Getting Started Guide. Here we 
describe each of the board profile editor commands in detail.  

Right-click on board profile/profile library in the navigator 
Right-clicking on the board profile or the master profile library in the navigator window introduces the following 
commands and these are described below:  

New  Open  Copy Paste Delete Rename 

New 
Only available when the Profile Library folder in the Masters folder is right-clicked. When selected, a new board 
profile is created and added at the bottom of the list of profiles already in the folder, called Unnamed. It can be 
renamed at that point as it is highlighted ready for editing. However, if <enter> is pressed or the cursor is 
selected elsewhere, the original name (unnamed) will remain. It can be renamed by right-clicking on the outline 
and selecting Rename. 

Open 
When selected, the board profile is opened for viewing/editing.  

Copy 
When selected, the board profile is copied to the paste buffer, overwriting anything previously added to the 
paste buffer. (See Paste command for using the contents of the Paste buffer.) 

Paste 
A board profile that has been copied to the paste buffer can be pasted (copied) to the design profile editor 
(overwriting an existing profile) or master profile folder.  
To paste to the design: in the navigator window right-click the Board Profile in the design’s folder, then select 
Paste from the options that appear. If a profile already exists an opportunity to proceed or cancel is given.  
To paste to the master profile folder: right-click the Profile Library folder from the Masters folder in the navigator 
window, then select Paste from the options that appear. The profile is added to the bottom of the list of profiles 
in the folder, it takes the name of the job it was copied from. If a profile with the same name already exists, the 
option to overwrite or cancel the paste command is given.  

Delete 
Only available when a profile from the Profile Library folder in the Masters folder is right-clicked. When selected, 
the board profile is deleted – there is no confirmation window, the profile is deleted immediately.  
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Rename 
Only available when a profile from the Profile Library folder in the Masters folder is right-clicked. When selected, 
the board profile can be renamed.  

View Commands – specific to Board profile editor 
View > Part Pins 
Used to toggle the display of component pins on and off. The pins can only be seen once parts have been 
placed on the board. 
The pin positions can be used as a guide when defining keepout areas. Pads and vias added to the artwork 
editor or outlines using the Copper commands are not displayed. 

Profile commands 
Using the Profile commands, lines, arcs, etc. can be added to form part of the board profile, router outline or 
keepout lines/areas. The data is added to the category or “layer” indicated by the Edit Mode setting in the tool 
bar, which can be set to Profile, Keepout or Router. 
Data can only be modified if it belongs to the active category. For instance, if a line was added as part of the 
Router outline, it can only be modified if the Edit Mode is set to Router. 
The colour of the drawn lines indicate which category they belong to: 

blue = board profile 
yellow = keepout 
pink = router 

If lines of different categories are placed over one another, the colours merge and a white line is displayed. 
Note: in the artwork editor, the profile is displayed in white and keepouts in purple. 

Toolbar “Edit Mode” setting 
Edit Mode, Profile 

Should be selected to define the external edges of the board. It's important that only one Profile polygon 
should be defined. Ranger's automatic routines (split power planes, copper fill, auto-placement/routing, etc.) 
operate within the area defined by the profile polygon and will become confused by additional board profile 
definitions. 
Mounting/tooling holes, cut-outs should not have their positions defined using profile mode. Use the Router 
mode and Keepout modes to identify the position of holes or cut-outs within the profile.  

Edit Mode, Keepout 
Should be selected to define areas that the auto-router and copper fill routines should not cross. For 
instance cut-outs within the profile. 

Profile > Add Line 
Used to add a line, the line is added to the current Edit Mode category. 
Once selected, point at the location where the line will start and click the left button. Move the cursor, a line 
appears attached to it. Click the left button to insert corners in the line. Release the line from the cursor by 
clicking the right-hand mouse button.  
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The line can be modified using the Profile > Corner/Adjust Arc/Delete point, etc. commands. 

Profile > Add Arc 
Used to add an arc(s), the arc is added to the current Edit Mode category. 
Once selected, point at the location where the curved line is to start and click the left button. Move the cursor 
and its attached line to the position where the curve should end, and click the left button again. A straight 
segment is produced that bends as the cursor is moved. The shape of the arc is dependent on the position of 
the cursor. Click the left button to release the curve in its current position. The line remains attached to the 
cursor, allowing a series of curves to be added. 
Once the arc has been released, clicking the right-hand mouse button releases the line from the end of the 
cursor. 
If the right-hand mouse button is clicked whilst the curve is being stretched, a straight-line segment is 
introduced, thus allowing a mixture of curved and straight lines to be added. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
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Arcs can be modified with the Outline > Corner/Adjust Arc commands. 

Profile > Add Circle 
Used to add circles, the circle is added to the current Edit Mode category. 
Once selected, point at the centre of the required circle and click the left-hand mouse button. As the cursor is 
moved, a circle appears attached to it. The size of the circle is controlled by the cursor position. Click the left-
hand mouse button to release the circle in its current position. Clicking the right-hand mouse button whilst 
adding the circle cancels the circle. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The circle can subsequently be moved or modified with the Outline > Move Point command. 

Profile > Add Rectangle 
Used to add a rectangle, the rectangle is added to the current Edit Mode category. 
Once added it can be modified using the Outline > Corner/Adjust Arc commands. 
The size of the rectangle can be specified in either inches or millimetres. The units in use are controlled by the 
Edit > Units command.  
Once selected, a window appears allowing the Width and Height of the rectangle to be typed in. Select OK to 
add the rectangle. 
The rectangle appears attached to the cursor (the screen magnification may change in order to display the 
complete rectangle), move it into position and click the left button to release it. Another rectangle appears on the 
end of the cursor until either another command is selected, or the right-hand mouse button clicked when the 
window reappears, and Cancel should be selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Once in position, the rectangle is treated as a line, which can have corners added, deleted or moved or 
converted to arcs. 

Profile > Corner 
Used to add and move existing corners in lines or arcs.  
Lines and arcs can only be selected if they belong to the current Edit Mode category.  
Corners are added and released with clicks of the right-hand mouse button. Corners are moved and released 
with clicks of the left-hand mouse button. Once the corner has been selected, clicking the opposite mouse 
button cancels the operation. 

right button = add corner 
left button = move corner 
Opposite button cancels 

Adding a corner to a line or arc: 
Once selected, point at the line or arc and click the right-hand mouse button. Move the new corner and 
release it with another click of the same (right) button. Clicking the opposite (left) hand button before the 
corner is released, cancels the new corner. 

Moving an existing corner in a line or arc: 
Once selected,point at the corner in the line or arc and click the left-hand mouse button. Move the corner 
and release it with another click of the same (left) button. Clicking the opposite (right) hand button before 
the corner is released, cancels the move. 

Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Profile > Move Point 
Used to move circles and to change the size of circles. (It can also be used to move an existing point (corner) in 
a line or arc, but the Profile > Corner command is more flexible.) 
Circles and points can only be selected if they belong to the current Edit Mode category.  
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Moving a circle: 
Once selected, move the cursor over the centre of the circle and click the left-hand mouse key. Move the 
cursor with the circle attached, into the required position and click the left-hand mouse button again to 
release it. 
Clicking the right-hand mouse button whilst the circle is attached to the cursor returns it to its original 
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position. 

Changing the size of a circle:  
Once selected, point at the circumference of the circle and click the left-hand mouse key. As the cursor is 
moved, the circle's size changes. Click the left-hand mouse button again to release the circle at its current 
size. 
Clicking the right-hand mouse button whilst circle is attached to the cursor returns it to its original size. 

Moving points on lines or arcs: 
Once selected, move the cursor over the point (corner) you want to move and click the left-hand mouse 
key. Move the cursor with the corner attached into the required position and click the left-hand mouse 
button again to release it. 
Clicking the right-hand mouse button whilst the corner is attached to the cursor returns it to its original 
position. 

Profile > Adjust Arc 
Used to convert straight lines into curved lines, curved lines into straight lines, and to change the shape of 
existing curved lines. 
Lines and arcs can only be selected if they belong to the current Edit Mode category.  

Straight lines into arcs:  
Once selected, point at a line segment and click the left-hand mouse button. Move the cursor, the segment 
is replaced with an arc on the end of the cursor. Once the arc is in the required position, click the left-hand 
mouse button to release it. 

Arcs into straight line segments: 
Once selected, point at the arc and select it with a click of the left-hand mouse button. Follow this with a 
click on the right-hand mouse button to convert it to a straight line segment. 

Changing the shape of an arc:  
Once selected, point at the arc and select it with a click the left-hand mouse button. Move the cursor with 
the arc attached, then click the left-hand mouse button when the arc is in the desired position. 
Clicking the right-hand mouse button toggles the last selected line or arc between a line and an arc. The 
shape of the arc is defined automatically and can be used to convert 45 degree lines into quadrants of a 
circle. The direction of the arc is determined by the position of the cursor about the line when the button is 
pressed. 

Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Profile > Transfer to current layer 
Used to transfer line/arc/circle features from their current layer onto the layer selected in the Edit Mode 
category. 
This command can be useful to separate profile and keepout data that has been imported in to a single layer, or 
added to the wrong layer. 
Set the Edit Mode category to the layer the data should be transferred to. 
Once selected, point at the line, arc or circle to be transferred and click the left-hand mouse button. The item will 
change colour to indicate the transfer has worked. 
Refer to the Grid command for details on whether grid snapping is active. 

Profile > Delete Point 
Used to remove corners (points) from lines or arcs. 
Points can only be selected if they belong to the current Edit Mode category.  
Once selected, move the cursor over a point (corner) in a line or arc and click the left-hand mouse button. The 
point is removed. 
If a start or end point of a line is deleted, the segment is removed. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Profile > Delete Feature 
Used to delete a line, an arc or circle. 
Items can only be selected if they belong to the current Edit Mode category.  
A complete line is deleted, between its start and end points, not just a segment between points. 
Once selected, point at the line, arc or circle to be deleted and click the left-hand mouse button. 
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Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Profile > Numeric Editor 
Used to edit or view the co-ordinates of the lines drawn in the profile editor.  This facility is useful to check the 
size/accuracy of the drawn lines or to locate lines that are difficult to see.  
Although possible, it is not recommended that the numeric editor be used to define a shape from scratch. 
Instead use the graphical tools to draw the basic shape of the profile, then use the numeric editor to fine-tune 
the co-ordinates if necessary. This is easier than trying to define the board numerically from nothing. 
Once selected, a window appears as shown in Figure 135 divided into three main areas.  

 
Figure 135 

The top left shows the overall picture of the profile, keep-out or router lines.  
The radio buttons along the bottom of the window control which category of data is visible and therefore can be 
edited, Profile is selected in this example. 
The bottom left area lists the Features (lines, lines with arc sections or circles) that make up the profile, keep-out 
or router lines. Each one can be selected with a click of the left button. This will turn the corresponding 
line/arc/circle in the upper left picture, green and show the X/Y co-ordinates that make up the line/arc/circle in 
the Feature Co-ordinate Edit area on the right hand side of the window. This is shown in Figure 135. 
Each feature that is added as a continuous entity is listed in the Feature list. For instance if a polygon shape 
were added graphically (Profile > Add Line) with one continuous line/arc, as shown in Figure 135, it would be 
one "feature". When the feature is selected, the complete polygon turns green as shown. However if the same 
polygon shape were made from separate lines, then each line would be listed separately as a feature and 
individual segments would turn green when selected. 

Co-ordinate definitions 
The co-ordinates in the Feature Co-ordinate Edit area can be selected and changed. The change will be 
reflected in the picture.  
Each pair of co-ordinates is given a reference number and if this number is selected (in Figure 135, ref no. 3 is 
selected), a cross appears on the picture of the profile at the location of the co-ordinate to assist with 
identification. 
Lines have an X and Y co-ordinate for their starting position and an X/Y co-ordinate for their end position (two 
sets of X/Y co-ordinates minimum). 
If there are corners between the start and end points then these X/Y co-ordinates will appear between the start 
and end points in order, as shown in Figure 135. 
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Arcs/Circles 
The Height field is only present if the line contains arc sections, it is used to define the height of the arc 
within the line. Arcs have two sets of X/Y co-ordinates (start and end points) plus a height for the arc. 
The height is entered alongside the starting X/Y co-ordinates of the arc. A height value will not be 
accepted alongside the end X/Y co-ordinates of the arc. 
A positive height value draws the arc in a clockwise direction from its starting point (first pair of co-
ordinates). A negative height draws the arc in an anti-clockwise direction from its starting point - see 
diagram below. 
 

 
Figure 136 

 
Typical co-ordinates for the arc on the left would be: 
X Y Height 
2.5 1.5 0.16 
3.0 2.0 0.0 
The co-ordinates for the arc on the right (if it were in the same position) would be identical except the 
height would be -0.16. 
Circles are defined by the X/Y position of their centre and a radius. 

Units 
Co-ordinates can be entered in inches or millimetres after choosing the appropriate units from the bottom of the 
window. 

Absolute/Incremental format 
By default, co-ordinates are entered/displayed in absolute mode, each co-ordinate is given with respect to 0,0 in 
the profile editor.  
If the radio button alongside Relative is selected, then the first pair of co-ordinates is given with respect to 0,0 in 
the profile editor, but subsequent co-ordinates are given with respect to the previous pair of co-ordinates. 

Co-ordinates for a rectangle with absolute selected: 
1.0 1.0 
4.0 1.0 
4.0 3.0 
1.0 3.0 
1.0 1.0 

Co-ordinates for the same rectangle with relative selected: 
1.0 1.0 
3.0 0.0 
0.0 2.0 
-3.0 0.0 
0.0 -2.0 

The position of the rectangle would be in the same location at 1.0,1.0 (first set of co-ordinates) in from the lower 
left corner (0,0) of the profile editor. 

Deleting features 
Features can be deleted if they are selected from the Features list, then the Delete button selected.  
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Adding features 
New lines, lines with arcs or circles can be added by selecting the New button from underneath the Features 
list. (It is usually easier to draw the new feature, then edit the co-ordinates afterwards.) A window appears 
requesting the type of feature that should be added and how many points (corners) it should contain (minimum 
of 2, the start and end points). (If Circle is selected, the points setting is greyed out.)  
When Create is selected, the feature is added to the end of the list and the co-ordinates for the feature (all set to 
0) appear in the Feature Co-ordinate Edit area of the window. The co-ordinates must be updated or there will be 
lines/circle/arcs at 0,0 with no size assigned and they may cause problems. 

Modifying features 
Additional corners can be added to existing lines/arcs if required. (It is usually easier to draw the new feature, 
then edit the co-ordinates afterwards.) Select the line/arc to be modified from the Features list, select the 
reference number where the co-ordinate should be inserted, from the Feature Co-ordinate Edit area, then select 
the Insert button. An additional pair of co-ordinates is inserted with the same X/Y positions as the selected pair. 
One set of co-ordinates should be modified.  
Corners can be deleted from existing lines/arcs if required. Select the line/arc to be modified from the Features 
list, select the reference number of the co-ordinate that will be removed from the Feature Co-ordinate Edit area, 
then select the Delete button. 

Leaving the numeric profile editor 
If OK is selected from the numeric editor window, the numeric editor window is closed, the changes are kept 
and the graphical editor updated. If Cancel is selected, the numeric editor window is closed and any changes 
made to the window are lost. The graphical editor is not changed. 

Profile > Set XY Display Datum 
Used to change the co-ordinate readout so that it is with respect to a selected point, rather than its default 
position which is located at the lower left corner of the working area.  
When the editor is closed the datum is returned to its default position. 
The display datum is displayed as a small yellow circle with an upright cross inside it. 
Once selected, point at the position required for the datum point. (Refer to the Grid command for details on 
whether grid snapping is active. The current grid setting is displayed in the information bar.) 
This command remains active until another command is selected. 
To restore the datum point to its default position, click the right-hand mouse button whilst the Profile  > Set XY 
Display Datum command is active. 
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Artwork Folder 

Artwork 
An overview of the artwork editor can be found in the Installation & Getting Started Guide. Here we describe 
each of the artwork editor editor commands in detail.  
When Artwork is selected from the navigator pane, the Properties pane displays a layer type and point count 
summary for all the artwork layers as shown in Figure 137. 
 
 

 

Figure 137 

When the artwork editor is opened, tooltips appear (when appropriate) when the cursor is hovered over boxes, 
as shown in the View Control dialogue bar in Figure 138. 
 

 

Figure 138 
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Layer colour boxes which have an associated edit/spin control to change layer selection, as shown in Figure 
139, can be selected to display the layer assignment list, to quickly aid identification and selection of layers. 

 

Figure 139 

Right-click on Artwork  
Right-clicking on Artwork in the navigator window introduces the following commands:  

Open Open Detached Delete Tool Optional Autorouters  

Open 
When selected, the artwork editor is opened for use.  

Open Detached 
When selected, the artwork editor is opened for use in a separate window so that it can be moved outside of the 
main Seetrax XL Designer program. This allows it to be viewed on a separate display if available. The window 
can be moved & resized using the standard Windows tools.  

Delete Tool 
Used to delete the complete artwork, i.e. tracks, vias, silk screen, power plane pads, text, etc., or individual 
layers with the option to retain fixed tracks. The parts remain in position irrespective of the choices made.  
When selected the window shown in Figure 140 appears. 

 

Figure 140 

This window has two areas of control, Layer Selection and Delete action for selected layers. Ensure both are set 
as required before proceeding - there is no undo! 

Layer Selection 
Delete data from ALL artwork layers when selected all the data added to all layers in the artwork 

editor is removed. This includes tracks, vias, copper fill, silk 
screen, power plane pads, text, etc.  
Parts (and therefore part pins) remain placed on the design. 

Delete data only from SELECTED layers when selected all the data added to specific layers in the 
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artwork editor is removed. This includes tracks, vias, copper 
fill, silk screen, power plane pads, text, etc. on the selected 
layers. 
When selected, the lower part of the Layer Selection pane 
becomes active and this is used to control which layers are 
included in the delete action – the selected (highlighted) layers 
are included in the deletion. 
Repeated clicks of the left mouse button over the layer, 
selects/deselects the layer. As many layers as required can 
be included. 

Delete action for selected layers 
Delete ALL features when selected all the data added to the selected layers (ALL 

or Selected) in the artwork editor is removed. 
Delete only UNFIXED features when selected only the unfixed data added to the selected 

layers (ALL or Selected) in the artwork editor is removed. 
This setting is useful as it allows pre-routing to be retained 
whilst removing everything else. 

Delete features that are invalid for layer type Heat-relief and anti pads should not be used on copper layers.  
The artwork checking routine checks all Copper layers to 
determine if any are present and they should be removed as 
they could cause short-circuits and/or gap errors. This utility 
provides a quick and easy method of removing them. 
When selected all antipads and heat reliefs pads on any 
layers defined as copper layers will be removed. 

Optional autorouters 
Seetrax XL Designer has interfaces to some third-party supplied auto-routers. The interface can be enabled 
from the File > System Setup window. When enabled, the auto-router appears in a pull-down list when this 
command is selected. Note: this is an interface, not the auto-router that has to be purchased and installed 
separately. 
When the interface is selected a window appears and this is described in a separate chapter, later in this guide. 

View commands 
These commands control what is seen on the screen in the artwork editor and how it is displayed. The zoom 
in/out, pan, etc. commands which are common to all editors have been described in the chapter Commands 
Common to All Editors.  

View > Artwork Flipped 
When selected, the artwork is displayed “flipped” or “mirrored” as if looking at the back of the board. 
When the artwork is displayed in “flipped” mode, flipped parts will have their outline displayed in solid (cyan) 
colour and unflipped parts will have a dotted (yellow) outline. 
Many part related operations in the artwork editor require clicking the left mouse button to select unflipped parts 
and the right button for flipped parts. When the artwork is displayed in “flipped” mode, the sense of the buttons 
becomes reversed. 
When using the Text > Get Label command to add a label for a flipped part, the label is now inserted in mirrored 
mode (so if viewing the back of the board with the display “flipped”, the label will appear the right way around). 

View > Part Labels 
Alternative (longer) way of toggling the Part labels setting. Refer to the View > View Control dialogue bar for 
quicker method.  

View > Lines At Width 
Alternative (longer) way of toggling the Wide tracks setting. Refer to the View > View Control dialogue bar for 
quicker method. 

View > Pads Filled 
Alternative (longer) way of toggling the Pads Filled setting. Refer to the View > View Control dialogue bar for 
quicker method. 

View > Drill holes 
Alternative (longer) way of toggling the Drill setting. Refer to the View > View Control dialogue bar for quicker 
method. 
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View > Isolated Copper 
Used to toggle the visibility of isolated copper filled areas that were identified by the artwork checking routines. 
Only visible layers are highlighted, in white. (Isolated copper fill can be deleted using the Tools > Copper Fill, 
Filled Copper > Delete All Isolated Copper command.) 

View > Net Clearances 
Alternative (longer) way of toggling the visibility of the minimum clearance requirement of tracks, on and off. 
Refer to the View > View Control dialogue bar for quicker method. 

View > Negative Space Shaded 
Used to toggle the display of the red, negative space that surrounds the working area, on and off.  
Although it can be made invisible (in response to user requests), under no circumstances should anything be 
placed touching or within the negative area. 

View > View Control Toolbar 
Used to toggle the visibility of the View Control dialogue bar, on and off. This bar provides control over what is 
displayed in the artwork editor at any one time.  It is shown in Figure 141. 
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Figure 141 

All the buttons on the bar have “tooltips” enabled, so hover over any button to get a description of the button, as 
shown in Figure 142. 
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Figure 142 

The bar is divided into sections and these are described below. 
 
Parts Section (Figure 143) 
When placing and moving parts, it is helpful if the silkscreen outline and/or autoplacement footprints, labels and 
EMC Information are visible. But this will clutter up the screen when routing for example. Control over this 
visibility is gained from this section. 

 

Figure 143 

Both sides/Top/Bottom This controls whether only the parts on the top of the board, only the parts on the 
bottom of the board, or parts on the top and bottom of the board are displayed.   
The silkscreen outlines/placebounds are shown in yellow for parts that are unflipped and in 
dashed cyan for flipped parts. 
Select the arrow alongside to obtain the list to choose from. What is displayed is selected by the 
checkboxes underneath. 

Outlines When selected (ticked) displays the silk screen outlines of the parts, as defined in the outline 
editor. Note: these are representative of the silkscreens only - to act as a guide when 
placing/moving parts. The actual silk-screen data has to be added to the artwork layers using the 
Tools > Generate Silkscreen command. 
Unflipped parts are shown in solid yellow, flipped parts in dotted cyan.  
If the artwork is displayed in “flipped” mode, then the colours remain the same but the flipped 
parts are shown with a solid (cyan) line and the unflipped ones with a dotted (yellow) line. 

Placebounds When selected (ticked) displays the autoplacement footprint of each part, as defined in the outline 
editor. The bounds are not shown when a part is moved. 

Labels When selected (ticked) displays the part labels (i.e. IC1, IC2, R1, etc.).  
Part labels are shown in yellow for parts that are mounted on the top of the board, and in cyan for 
parts that are mounted on the bottom of the board. 
(Use the Edit > Display settings to control the height of the labels.) 
Part labels should not be confused with the silk screen ident that is added to an artwork layer.  
The part labels can be used as a guide when moving and locating parts, etc. as they indicate the 
position of the part's datum. Parts that have been flipped, have their labels slightly offset and a 
tail extends to the datum point. This allows the labels to be read more easily when parts are 
mounted directly over the top of one another. 
Unlike the silk-screen ident, part labels are always read from left to right and they do not rotate or 
flip with the part. 

EMC info  When selected (ticked) displays the EMC information of parts. Any parts that have had a part 
placement hi-lite colour defined in the schematic editor (Tools > EMC Attribute Tags (Parts) 
command), will be displayed cross-hatched in that colour. The cross-hatching extends to the area 
occupied by the placement bounds of the outline. 
Typically, the hi-lite colours indicate whether the part is susceptible to noise, produces noise or is 
quiet. This allows more attention to be given to the positioning of parts, depending on their noise 
considerations.  
When parts are moved or placed, their emc group is displayed in the status bar. The Identify > 
Part window also gives this information. 
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Pads & Tracks Section (Figure 144) 

 

Figure 144 

 
Filled When selected (ticked), pads are displayed in solid colour. Otherwise, only the perimeter of 

the pads are visible. Re-draw speeds are faster when only the outlines are displayed. 
If Pin numbers is ticked, this setting is automatically switched off as the white pin numbers 
would not be seen. 

Drill When selected (ticked), the drilled holes in pads can be seen. 
Re-draw speeds are slightly faster when the drilled holes are not displayed. 

Pin ID When selected (ticked), at higher zoom levels pin ID’s (numbers) are displayed in the centre 
of component pins. When selected the Pads filled setting is automatically switched off as the 
white pin numbers would not be seen.  

Trk ID When selected (ticked), and when the artwork is zoomed in sufficiently close, net identities will 
be displayed on all tracks and the perimeter of copper filled areas. 

Wide Tracks When selected (ticked), tracks and lines (silk screen lines, text, etc.) are displayed at their true 
size. Otherwise only the centre lines of tracks and lines are displayed. Re-draw speeds are 
faster when only the centre lines are displayed. 
Note: tracks and lines will never be rendered narrower than the line width controlled by the 
"Minimum Line Rendering Width" setting in the Edit > Display adjustments window. 

 
Unroutes Section (Figure 145) 
This section controls which unrouted tracks (connections) are visible and their opacity.  
At various stages in a layout, different combinations of connections are important. This setting allows the user to 
concentrate on particular groups of connections, without having the others cluttering up the screen. For 
instance, on some boards the power supplies do not have a great effect on part placement, so just the signals 
can be viewed at the placement stage. Alternatively some critical connections might need to be routed first, so it 
helps not having the other connections as a distraction.  

 

Figure 145 

 
Sig When selected (ticked), all the unroutes that have not been defined as power rails will be 

visible, unless they have been “hidden” (right click a net from the the Nets folder of the 
navigator, then select Hide Net Unroutes - the net will be marked in the navigator with “(h)” to 
indicate it is hidden Figure 146). 
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Figure 146 

Pwr When selected (ticked), all the unroutes that have been defined as power rails will be visible, 
unless they have been “hidden” (right click a net from the the Nets folder of the navigator, then 
select Hide Net Unroutes - the net will be marked in the navigator with “(h)” to indicate it is 
hidden see Figure 146). 
Note: The unroutes for power nets that have been defined as a power plane, will not appear 
unless they are attached to the pin of a surface mounted component. In this case, a 
"connection blob" will appear over the pin - it can be moved using the Mroute > Corner 
command. The blobs are easier to see if the unroutes are being displayed at their full width. 

Wide When selected (ticked), all the unroutes will be displayed at their true size. Otherwise only the 
centre lines are displayed.  
Re-draw speeds are faster when only the centre lines are displayed. 
Unroutes will never be rendered narrower than the line width controlled by the "Minimum Line 
Rendering Width" setting in the Edit > Display adjustments window. 

Net When selected (ticked), only unroutes from selected nets are visible – the Sig and Pwr 
checkboxes are automatically deselected. 
To select the nets to be displayed, expand the Nets folder from the navigator, then right click 
on a net and select Show net unroutes. The status will be indicated by (S) appearing 
alongside the net name of the selected nets. 
Multiple nets may be selected using the shift or Ctrl keys with the mouse. 
Nets are de-selected in the same way, the (S) will disappear from alongside the net name. 
There is no need to de-select nets in order to display all the signal, or all the power unroutes 
as those controls will switch off the Net selection when they are checked.  
The show status of the nets is removed when the job is closed/reopened. 

Coloured box Controls the colour of unroutes when visible. The colour can be altered by selecting the box, 
then choosing an alternative colour from the palette that appears.  

Opacity Slider A the left of the sliders travel, unroutes are displayed behind the copper layers, and at the 
right of its travel, they are display over the top of the copper layers. 
Please be aware that if you choose to display unroutes behind the copper layers, SMD pad 
powerplane unroutes (which are shown as a small blob) may not be visible. 

Miscellaneous Section Figure 147 

 

Figure 147 

Flags When ticked, error flags are displayed if they exist. Error flags are produced when errors are found 
by the Check commands.  

M = silkscreen mask error 
K = keepout error 
U = unroute 
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G = gap errors 
If multiple minimum clearance values have been defined, the gap error flags are given a 
numeric suffix (G1, G2, G3, etc.) that indicates the minimum gap required in that location. 
The suffix is cross-referenced to a minimum gap size in a table at the bottom left of the 
screen. 

KO When selected (ticked), keepout lines/areas are made visible. Keepout areas are shown cross-
hatched. 
Whether visible or not, they are always active (unless a specific control is available, like for 
example in the copper fill dialogue bar).  

Slots Slots & Extra Holes have 3 visibility states: 
Off (unticked) Slots & Extra Holes are set as invisible 
On (ticked) Slots & Extra Holes are visible with the routing direction 

and pre-drilling details of slots visible. 
Half On (greyed tick) Slots & Extra Holes are shown, but without the routing 

direction and pre-drilling marks in slots. 
Clear When switched on, all tracks (not unroutes) will be drawn with a shadow, the size of which 

represents the required clearance for the net. Note: this function will not correctly display on 
monitors configured in the Windows setup for 256 colours or less. 

Fixed  Controls the colour of fixed tracks. The colour can be altered by selecting the box, then choosing 
an alternative colour from the palette that appears. 

Flipped When selected, the artwork is displayed “flipped” or “mirrored” as if looking at the back of the 
board. 
When the artwork is displayed in “flipped” mode, flipped parts will have their outline displayed in 
solid (cyan) colour and unflipped parts will have a dotted (yellow) outline. 
Many part related operations in the artwork editor require clicking the left mouse button to select 
parts on the board top and the right button for flipped parts. When the artwork is displayed in 
“flipped” mode, the sense of the buttons becomes reversed. 
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Layers Section (Figure 148) 
This section controls which layers are visible in the artwork and the colours assigned. Tooltips (hover mouse 
over item) also provide information relating to each layer, this information is described under the View > 
Properties command. 

 

  

Figure 148 

Copper Toggle switch used to add/remove the Copper layers to the list of layers below. 
Power Plane Toggle switch used to add/remove the Power and Split Power Plane layers to the list of layers 

below. 
Mask Toggle switch used to add/remove the Silkscreen mask layers to the list of layers below. 
Doc Toggle switch used to add/remove the Documentation layers to the list of layers below. 
 
Note: Layer definitions are controlled from the Configuration folder, Layer Assignments & Ordering window. 
 
Empty Layers  This toggle switch controls whether empty layers from the selected categories above are 

included in the list. This will help reduce the length of the layer list and provide easier access to 
the used layers. 

Layer list The layers of the board are listed down the left hand side. The slider bar, which appears when 
required, provides access to all the layers. 
The checkboxes alongside each layer allow that layer’s visibility to be toggled on/off. If the 
cursor is hovered over these checkboxes, a balloon appears providing layer usage and point 
count information for the layer. (This information is described under the View > Properties 
command.) 
All layers can be quickly made invisible or visible by selecting the check-box at the top of the 
check-box column. It’s quicker to turn all the layers off and then one or two on, than it is to 
selectively turn most of the layers off. 
Layers are made invisible to aid the design process. For instance, when modifying a completed 
board the silk screen layers can be switched off, or when working on a particular layer all other 
layers can be switched off.  
The colour box alongside each layer shows the colour assigned to the layer. A different colour 
can be chosen if the coloured box is selected - a palette of colours appears from which one can 
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be selected. 
The default set of colours is restored if the Restore Default Colours button (above the column of 
colour boxes) is selected. 
The letters alongside the layers indicate the layer type of the layer.  

“V” - Via layer 
“T” - Top component side 
“B” - Bottom component side (or solder side) of the board 
“C” – copper layers 
“M” – Mask (silk-screen)  
“PP” – power plane layers including split power plane layers 
 “D” – documentation layers 

Opacity Slider Figure 149. This setting alters the opacity and therefore the transparencyof all copper layers.  
At the left of its travel all the layers will be less opaque and more transparent. At the right of its 
travel they will be more opaque and less transparent. 
Finer tuning is available for individual layers using the Opacity Setup button indicated in 
Figure 149.  

 

   

Figure 149 

 
The slider toggles between a slider and an “Edit Opacity” button as shown in Figure 150, if the 
fine tuning has been selected.  

 

 

Figure 150 

Use the “Revert to single slider” button in the Extended Opacity Control window (Figure 151) 
to revert to the single slider control. 

Opacity Setup Button 
 This button introduces the Extended Opacity Control window as shown in Figure 151. 
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Figure 151 

It allows the adjustment of the opacity and therefore the transparency,of the individual layers 
(unused layers are not included), alongwith Part Outlines and Labels, Pin Numbers and Mask 
(silk screen) Layers.  
Only one adjustment is available for all silkscreen layers. 
The range is from 0 (transparent or invisible) to 100 (completely opaque or solid).  
By sliding the opacity of each layer/category, somewhere in between 0 and 100, it is possible 
to overlay multiple layers on top of each other with the ability to “see through” uppermost 
layers.  
The effect of the changes can be seen whilst the window is open, so it is helpful if it is moved 
to one side. 

View > Properties 
When the artwork editor is active this command is used to toggle the visibility of the artwork Properties window, 
on and off. A sample Properties window is shown in Figure 152. It contains information about the artwork that is 
useful at various times throughout the life of the design. 

 

Figure 152 

The window is divided into rows and columns, each row being a layer within the artwork. These columns are 
described now. 
Layer The layers of the board are listed. Use the scroll bar to view the complete list. 

Some layers have names, others numbers. “V” is short for Via, “T” for the top component side 
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and “B” for the bottom component side (or solder side) of the board. The other layers are 
numbered. 

Points This column indicates the number of points used on a particular layer. Every via, heat-relief pad, 
anti-pad or added pad is counted as one point. A track has a minimum of two points (start and 
end point), and each corner in the track is also added to the point count. The point count of text 
strings varies, depending on the number of characters used.  
Component pads are not included in the point count. The number of vias is only counted on 
layer V. 
If a layer has 0 points, then that layer is not in use. (If set as a copper layer, then inner pads 
from the component pad stacks will be present on that layer.) 

Type this column indicates the layer type, i.e. whether the layer is defined as a copper layer, silk 
screen layer, powerplane layer, etc. The layer type cannot be changed from this window.  
Some routines like the silk-screen generation tool automatically update the layer type setting, 
but generally speaking the layer type is controlled from the Configuration folder, Layer 
Assignments and Ordering window. 

View > Restore Default Layout > Main frame layout 
This will restore the default visibility and positioning of the navigator, browser and status panes. Typically used 
when these panes have been accicentally closed or moved off screen. 
 

View > Restore Default Layout > Editor layout 
This will restore the default visibility and positioning of the dialogue bars of the active editor. Typically used 
when these bars have been accicentally closed or moved off screen. 

Identify commands 
Identify > Part 
Used to obtain information about a part and also locate it in either the parts list or schematic editors. 
Select Identify > Part. Select a part on its datum point, which is indicated by the position of the part label (View > 
Part Labels). Once a part has been selected, an information window appears similar to that shown in Figure 
153.  A tail extends to the selected part to indicate which part was selected. 
The icons representing the schematic and parts list editors can be selected to open the appropriate editor and 
locate the selected part. 

 

Figure 153 

Ident Part's reference designator. 
Type Obtained from the type column in the parts list. If the parts list was extracted from the 

schematic, it is a combination of the schematic part name and its value field separated by a 
comma. 

Outline Part's current outline name. 
X and Y  Position of the part's datum in the X and Y axes, with respect to the artwork editor's current 

datum position. 
Angle Part's angle of rotation, anti-clockwise from its original orientation, as defined in the outline 

library.  
Flipped Whether the part has been flipped. 
UID Ranger's internal reference number for that part. Parts are numbered from 16 onwards, in the 

order they were originally entered in the Parts list. 
EMC Id If the part has been assigned to a part EMC group on the schematic, then the group to which it 
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belongs is specified here.  
Parts may be selected until the right hand mouse button is clicked, when the previously active command is 
restored. 

Identify > Pin 
Used to obtain information about a visible component pin and also locate it in either the parts list or schematic 
editors using the buttons in the balloon window. 
Select Identify > Pin. Select a component pin on its datum point. Once a pin has been selected, an information 
window appears similar to that shown in Figure 154, pointing to the selected pin. The properties of any 
associated net will also be displayed in the properties pane. 
If layers 'T' or 'B' are set as invisible, pin/pad features on those layers are ignored. 
 

 

Figure 154 

Pin no Such as IC1.4, R1.2, etc. 
X and Y Position of the pin's datum in the X and Y axes, with respect to the artwork editor's datum. 
Signal name The name of the connection to which the pin is connected.  

Pins may be selected until the right hand mouse button is clicked, when the previously active command is 
restored. 

Identify > Pad 
Used to obtain information about any pad or via. 
Select Identify > Pad. Select a pad on its datum point. Once a pad has been selected, an information window 
appears similar to that shown in Figure 155. A tail extends to the selected pad to indicate which pad was 
selected. 
If layers 'T' or 'B' are set as invisible, pin/pad features on those layers are ignored. 
 

 

Figure 155 

Pinstack 
Top  indicates which pad shape/size is used on the top layer of the artwork. 
Inner  indicates which pad shape/size is used on the inner layers of the artwork. The inner pad only 

appears on layers defined as copper layers. The pad shape/size is the same on all inner 
copper layers. 

Bottom - indicates which pad shape/size is used on the bottom layer of the artwork.  
Standard pads are described using the following format:  

shape, size code, size of the pad, drill size as defined in the sizes table.  
For example: 

SQ 4, 0.0600, 0.0350 
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The following shorthand is used for the shape:  
RO = round 
RS = rectangular, square ended 
SQ = square 
RR = rectangular, round ended 

If a user defined pad is selected, then its name is given. 
Drilled the inner pad determines the size of the stack's drilled hole. If the inner pad is not used, or 

does not have a drilled hole defined then the stack will not be drilled. 
X/Y Position of the pad's datum in the X and Y axes, with respect to the artwork editor's datum. 

Pins may be selected until the right hand mouse button is clicked, when the previously active command is 
restored. 

Identify > Track 
Used to obtain information about a routed track or an unrouted track (connection) and also locate it in either the 
parts list or schematic editors, using the buttons in the balloon window. 
Tracks that are added using the Amend menu commands will not be recognised as belonging to a particular 
signal until they have been validated by the artwork checking routine. 
Select Identify > Track. Select a track or connection on its centre line.  
Once a track/unroute has been selected, an information window appears similar to the ones shown in Figure 
156. A tail extends to the selected track/unroute to indicate which track/unroute was selected and the Properties 
pane provides information about the net.. 

               

Figure 156 

Unrouted track  Indicates whether the selected connection is either partially unrouted, or completely 
unrouted.  

Fixed item Indicates the selected track has been fixed in position, using the NetFix commands. 
Layer Indicates which layer the selected track segment is on. 
Width Indicates the size code and real size of the selected track segment or unroute. 
N nodes Indicates the number of nodes (points) along the complete length of track, including the 

start and end points. 
Node Indicates the segment number of this particular track segment. 
Signal Indicates the signal name of the selected track. Unnamed tracks have their internal id 

number given, i.e. R$0052. These numbers can be viewed from within the net list editor 
under the Net UID column.  

Min Clear Indicates the minimum clearance requirement of this particular track/unroute. 
Tracks may be selected until the right hand mouse button is clicked, when the previously active command is 
restored. 

Identify > Feature 
Used to display information about a selected item. It is typically used to identify text strings and data that has 
been imported onto a documentation layer, but tracks/unroutes can also be selected. 
Select Identify > Feature. Select an item. Once it has been selected, an information window appears similar to 
that shown in Figure 157. A tail extends to the selected item to indicate which item was selected. 
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Figure 157 

Layer Indicates which layer and the type of layer (i.e. silkscreen) the selected item is on. 
Width Indicates the size code and real size of the selected item. If text is selected, then this is 

the width of the line used to draw the characters. 
Text hgt Indicates the height of selected text. 
Angle Indicates whether the item has been rotated in degrees anti-clockwise. 
Mirrored Indicates whether the item has been mirrored. 
Part ID indicates whether the item is associated to a part. 

Items may be selected until the right hand mouse button is clicked, when the previously active command is 
restored. 

Identify > Track Measure 
Used to display information about track length in the status bar, similar to that shown in Figure 158.  

 

Figure 158 

Select Identify > Track Measure. Select a track for measurement using the left-hand mouse button. The 
selected track has a dotted centre-line added to show it is selected. 
Each time a new track is selected, its length is added to the displayed value. Selecting a track a second time 
causes it to be deselected and its length subtracted from the displayed value.  
Clicking the right hand mouse button causes all selected tracks to become deselected. Clicking again 
terminates the measurement mode. 
The measurement tool will not measure arc tracks. 

Tools > Placement & Routing command 
This command can be used to return to the main manual placement and routing commands after selecting one 
of the commands from the Tools menu which introduces a feature specific set of commands. Often a left-
pointing arrow icon is available to perform the same command. 

Autoplacement (Tools > Autoplace) 
The auto-placement commands are used to transfer parts automatically from the tray onto the board, using the 
interconnections and user defined settings as guides for optimum part positions. 
Before parts can be placed on the board, they must appear in the Tray. It is therefore possible to concentrate on 
areas of the layout by adding specific parts to the tray. 
Each outline must have its auto-placement "footprint" defined in the outline editor, as it is this outline that is used 
by the automatic placement routine. The silk screen outlines are not taken into account.  
Due to external requirements, some parts such as connectors, must be positioned in specific locations. These 
parts must be manually placed and fixed in position, before using the auto placement routine to ensure they are 
in the correct location. 
Parts are automatically positioned on the layout according to the "pull" of already placed parts. It is therefore a 
requirement to have at least one part placed on the board before commencing auto-placement. The pre-placed 
parts must be connected to parts in the tray. 
Parts can be added to the layout in the order in which they appear in the tray (sequential) or the most heavily 
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connected parts in the tray can be added first (costed). Both methods position the parts according to the "pull" of 
existing placed parts. The choice between the two methods is made in the Autoplace dialogue bar. 
During autoplacement, the part datums are placed on user-defined placement grid intersections. It is suggested 
that a coarse placement grid should be used when placing the larger parts so that they are spread uniformly 
across the layout, followed by a finer grid when placing the smaller parts. Placing the larger parts, such as ICs, 
resistor networks, etc. first is often a good idea, to ensure there is sufficient space for them. 
The parts can be placed at a specific user defined orientation or the automatic placement routine can be allowed 
to choose the orientation of each part from its list of permitted orientations, these are defined in the Autoplace > 
Control Orientation window. Giving the placement routine the freedom to rotate parts may improve the routability 
of the board, however some design rules insist that all parts lie in the same direction, so this would not be 
possible. 
The parts are placed on the board on a user defined grid or "placement cell". The cell size is defined in the 
Autoplace dialogue bar. The required clearance between the bounds of parts is also defined there. 
Keep-out areas are not recognised by the autoplacement tools. 
Once the parts have been placed on the board, the user can then use his or her skill and judgement to "fine 
tune" the part positions if necessary using the Parts commands, to achieve a layout that can be routed with 
confidence. 

Autoplacement dialogue bar 
When the Autoplacement tools are selected, a dialogue bar similar to the one shown in Figure 159 appears. 

 
Figure 159 

Cell size, X and Y The values entered here define a placement grid over the board. The placement cell size 
being the space between the grid lines.  
Part datums may be placed on any of the grid intersection points provided the 
autoplacement footprint of the part does not violate the clearance requirements also 
specified. 
The placement grid radiates from the grid origin, as does the routing grid. By default, this 
is the lower left hand corner of the working area, however it can be moved using the Grid 
commands.  
If a small placement cell size is selected, perhaps 0.05" by 0.05", the automatic 
placement routine has more placement positions to choose from, which increases the 
time taken to place all the parts. If a very large cell size is selected, the process speeds 
up, but there may be insufficient cell positions to place all the parts. 
If larger parts such as ICs are being placed, select a larger cell size in order to help align 
the parts. Routing (whether automatic or manual) will be made easier if the part pads are 
in rows and columns. For instance, when placing 14 and 16 pin DIL's horizontally, a 
placement grid of x=1" and y=0.5" could be used. If larger DIL's were being placed, the 
grid could be increased. If a mixture of DIL's were being placed, it might be sensible to 
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decrease the X grid to permit smaller DIL's to fit between the spaces left by the larger 
DIL's.  
When placing discrete parts, a smaller cell size should be used to allow the parts to fit 
into the spaces left by the larger parts. 
If a large clearance is required between parts, then a smaller cell size may be required in 
order to position all the parts on the layout. 
Values may be entered in inches or millimetres, depending on the current Edit > Units 
setting. The appearance of the decimal point indicates which units are being used. A dot 
is used in imperial values and a comma in metric values.  

Clearance, X and Y The values entered here define the minimum space that must be left between the auto-
placement footprints of adjacent parts. 
Values may be entered in inches or millimetres, depending on the current Edit > Units 
setting. The appearance of the decimal point indicates which units are being used.  

Next Part Choices are Sequenced and Costed. Parts are added to the layout from the tray in the 
order selected here – typically Costed is used. 
Sequenced selected when the parts must be placed on the board in the order or 

"sequence" that they appear in the tray. The automatic placement routine 
assesses the connections of parts that are already on the board, and places 
the next part from the tray in the best position possible, according to its 
connectivity and the rules laid down in the dialogue bar. Often used with a 
fine cell size to determine whether all the parts can physically fit on the 
board. 

Costed selected when the automatic placement routine can choose which part from 
the tray it will place next. The automatic placement routine assesses the 
connections of parts that are already on the board and those in the tray. 
The part from the tray that is most heavily connected to those already on 
the board is chosen next and placed in the best position possible, according 
to its connectivity and the rules laid down in the dialogue bar. 

Power nets Parts are placed on the board by the "pull" from signal connections of parts already 
placed on the board. This setting allows power connections to be included in the pull if 
required. Tick the box to include the power connections. 
For example, when placing digital type boards, generally speaking, the power supplies do 
not affect the positions chosen for parts. Power nets can therefore be excluded when the 
automatic placement routine is assessing the pull of connections on a part from the tray. 
When placing analogue type boards, the power supplies do affect the positions chosen 
for parts. It is therefore necessary to include the pull of power connections when 
assessing the pull of connections on a part in the tray. 

Graphics The automatic placement routine assesses every possible placement cell to determine 
the best position for each part. This setting allows the operator to see the cells which 
makes it easier to choose placement cell sizes. 
The placement cells are displayed with blue lines. As the cells are assessed during auto-
placement a red box representing the footprint of the part is displayed. 
Displaying the graphics slows down the placement process. However, it is useful to see 
the cells being assessed, as it may help your choice of cell sizes. It also shows that 
something is happening. The scanning process can take some time if parts are permitted 
at any angle, and a very small placement cell size has been selected. 
Tick the box to see the placement cells. 

Add, Sort, Delete, Empty these commands control the parts that appear in the tray and therefore assessed for 
auto-placement. Refer to the Parts > Place command for details on the tray. 

Autoplace > Control Orientation  
This command is used to control whether the autoplacement tools may rotate parts. When selected, a window 
similar to the one shown in Figure 160 appears. 
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Figure 160 

Parts are separated into groups by their prefix names. If Yes appears in the 0, 90, 180, 270 degree columns for 
a particular prefix, then the auto-placement routine is allowed to rotate parts with that prefix to those angles, to 
achieve a better placement result. 
Yes must be selected for at least one of the angles for each prefix, otherwise the parts cannot be added to the 
layout. 
No stops the auto-placement routine placing parts with that prefix at that angle. 
Outlines are created at 0 degrees. Rotation is anti-clockwise. 
To change a setting, select the prefix and the line is selected. Select the tick-boxes underneath the columns to 
toggle the settings between Yes and No. 

Autoplace > Replace Part 
This command is used to assess the position of a selected part on the layout. If a better position can be found 
for it, the part is moved. Existing parts are not moved out of the way. 
Parts that have been fixed in position with the PartsFix commands, or have routed tracks attached to them 
cannot be selected. 
Parts on the top of the board are selected with a click of the left hand mouse button, parts on the bottom with a 
click of the right hand mouse button. 
If the parts were placed automatically and nothing has changed on the board, this command will have no effect, 
as its decisions are based on the same strategies as the placement routine. However, if some parts have been 
moved manually, the placement cell size or clearance requirements changed, then the part may well move to a 
more appropriate position. 
Select Autoplace > Replace Part. Select the datum of the part with the appropriate mouse button. The board is 
scanned, and if a more appropriate position can be found for the part, the part moves. Displaying the graphics 
(Autoplace dialogue bar) indicates what is happening. 

Autoplace > Place Parts 
When selected, automatic placement starts. Parts from the tray are placed onto the board in the order controlled 
by the Autoplace dialogue bar. 
Each part is placed on the board according to the pull of connections from parts that have already been placed. 
It is therefore essential to pre-place at least one part before selecting this command. That part must of course 
be connected to parts in the tray. 
Typically, parts such as connectors are manually placed first as their placement is controlled by external 
hardware requirements. They are also usually heavily connected to other parts, so will influence part placement 
to a greater extent than for instance, discrete parts. 
Other parts whose positioning is critical should also be manually placed. For instance tooling holes, pots, 
switches, LEDs, etc. 
Once critical parts have been placed, the required parts added to the tray and the Autoplace dialogue bar 
defined, auto-placement can commence. Select Autoplace > Place Parts to start auto-placement. 
Once auto-placement has been started, the routine scans every placement cell on the board as a possible final 
position for the part it is placing. As parts are being placed, their name is displayed along the bottom of the 
screen. If more than one orientation is allowed for the part, the board is scanned again to determine whether a 
better position could be obtained if the part were rotated. This process is repeated for every permitted 
orientation of the part. The part is then positioned in the most appropriate position according to the rules laid 
down and connectivity. The next part is chosen from the tray and the process repeated. 

Autoplace > Replace All 
This command is used to assess the position of all the unfixed, unrouted parts on the layout. If better positions 
can be found for them, the parts are moved. 
Existing unfixed, unrouted parts are moved out of the way if necessary, and new positions found for those parts. 
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Parts that have been fixed in position, or have routed tracks attached to them are not moved out of the way. 
If the parts were placed automatically and nothing has changed on the board, this command will have no effect, 
as its decisions are based on the same strategies as the placement routine. However, if some parts have been 
moved manually, the placement cell size or clearance requirements changed, then some parts may well move 
to more appropriate positions. 
The parts are evaluated, starting with the most heavily connected, unfixed, unrouted parts on the board. 
Select Autoplace > Replace All. Each part is evaluated in turn and if more appropriate positions can be found for 
them, the parts are moved. Displaying the graphics (Autoplace dialogue bar) indicates what is happening. 

Auto-routing (Tools > Autorouter) 
The integrated auto-router is a "rip-up and re-try" auto-router. This means that if there are any connections 
remaining after it has attempted every connection, it will remove or "rip-up" tracks it has already routed in order 
to find space for those that are left. The tracks that have been ripped up are then subsequently routed 
elsewhere "re-tried". In theory this process continues until there are no connections left, however it is possible to 
design a board that is impossible to route completely. 
The auto-router works on a user-definable grid. However very fine routing grids increase the amount of time and 
memory required to route the board because more routing channels have to be assessed and held in memory. If 
possible, it is better to use a coarser routing grid, especially if the tracks will be manually adjusted at some later 
stage. 
Optimising passes can be performed which "tidy" up tracks that have already been routed.  
Automatic track necking can be used when permitted by the user, to improve routing success. 
Critical connections can be routed manually and fixed in position if required before running the auto-router. 
The router can be used to route all the connections on the board, one particular connection net or all the 
connections radiating from a selected part. 
The router has different strategies for power connections, memory type signal connections and orthogonal 
signal connections. These are described later.  

Preparations for auto-routing 
Before attempting to route a board, a great deal of thought and care should be exercised over the placement of 
parts. A good part placement is critical in order to achieve success when either manually or automatically 
routing a board. The sizes used for pads, tracks, gaps and routing grid will also affect the success rate of the 
auto-router. 

Placement 
The auto-router can be setup to work on any routing grid, though very fine grids will make subsequent manual 
adjustments less easy. 
Before the placement is finished, try to assess the auto-routing grid that will be used. The final position of parts, 
and consequently their pads, can then be adjusted to fall in line with this grid. If care is taken over the 
positioning of parts then the need for very fine routing grids can be avoided.  
If parts are placed so that their pads line up with the routing grid, more routing channels will be available for 
routing. Connections to pads that are off the routing grid will be routed, but the tracks may block adjacent routing 
channels. It is therefore sensible to minimise "off the routing grid" pads where ever possible. 

Pad, via, track, clearance and grid sizes 
The choices of pad, track, clearance requirements and routing grid also affects the success rate of the router. It 
is possible to choose sizes that will not allow for instance a single track between the legs of IC pins. Or you may 
have calculated the pad, track and clearance sizes correctly, but the minimum routing grid combined with the 
position of parts will not permit these things to happen. 
For instance, take a DIL package whose pins are on a 0.1" pitch with the following design rules: 
   Pad diameter = 0.062" 
   Track size = 0.015" 
   Min. clearance = 0.012" 
In this case, irrespective of the routing grid chosen and the position of the part, a track cannot pass between 
adjacent pads of the part because of insufficient space (a minimum pad pitch of 0.101" would be required). 
If the pad size were decreased to 0.060" (more typical than 0.061") a track could pass between the centre of 
adjacent pads. In practice this could be achieved provided the part were placed on a 0.1" grid and a 0.050" 
routing grid were used. 
Whether the router can route the track between the pads also depends on the position of the part in conjunction 
with the routing grid.  
The router can be allowed to neck tracks in order to travel between adjacent pads or obstacles. These functions 
should be used to assist the auto-router in congested areas of the layout. They should not be used as a reason 
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for not calculating sensible pad, track and clearance sizes. 

Pre-routing 
Because of some design requirements it can be necessary to pre-route some critical power or signal 
connections and then fix them in position so that the router cannot move them. 
If this is the case, manually route the connections using the Mroute commands and then fix them in position 
using the Netfix commands. If the tracks are not fixed in position, the router will work around the existing tracks 
to start with, but it may move them in order to complete other tracks during the rip-up stage. 
When manually routing the tracks, try to route them so that they do not lie on a finer grid than the auto-router will 
be setup to use. Also try to route them so that they run horizontally and vertically on the same sides that the 
router will be setup to use. 
Bearing these points in mind will help increase routing success. There will be less manual routing to complete 
after the router has finished. 
Too many fixed tracks can affect the success rate of the router as they act as obstacles to the router. 

Memory requirements 
A "large" board as far as memory requirements are concerned, is not only determined by its physical size. The 
size of the minimum routing grid chosen, the number of routing layers, the number of component pads, fixed 
tracks, obstacles, etc. all have to be stored in memory. Therefore halving the routing grid or increasing the 
number of layers makes the board "larger" in terms of memory requirements, even though the physical size has 
not changed.  

Keepout areas/lines 
Keepout areas/lines can be defined in the board profile or artwork editor to define areas in the board that the 
auto-router is not allowed to use or to act as obstacles that the auto-router has to go around. 
Too many keepout areas can affect the success rate of the router as they act as obstacles to the router. 

Summary for Routing Success 
Spend time on achieving a good placement 
Ensure as many component pads as possible lie on a coarse routing grid 
Choose optimum sizes for pads, tracks, vias, clearance and minimum routing grid 
Ensure any pre-routing matches the auto-router's rules 
Minimise fixed tracks wherever possible 

Pre-routing checklist 
Place all parts within the board profile 
Check sizes of pads, vias, tracks and clearance 
Fix all pre-routed tracks where required 
Add keep-out areas as required 

Accessing the auto-router 
With the artwork editor open, select Tools > Autoroute. A dialogue bar appears which contains all the auto-
routing commands - these command are also located in the Autoroute pull down menu. 

Router dialogue bar 
Setup button. 
When selected, a window appears similar to the one in Figure 161, listing the 8 different routing strategies 
available for use.  
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Figure 161 

Each routing strategy has its own user definable setup. These are all described in the chapter titled 
Configuration Folder and the heading Configuration – Rip Retry Autorouter costs.  
Different types of layout may use different combinations of the strategies with different settings. The setup for 
each strategy can be viewed by selecting the Setup button from alongside the strategy. 
Typically power/thicker/critical connections are routed first and completed prior to routing the other connections. 
This can be accomplished by just enabling the power strategies, or selecting named nets for routing. Once 
completed, the power strategies can be switched off and the other strategies enabled. 
Enable/disable the routing strategies required and check all the other settings in the window are set as required, 
then close the window. 
The routing settings are stored with the design. They were originally copied from the master router settings. The 
routing setup can be changed within the design without affecting other designs or the master set. 
If the master routing setup is modified, only new designs will be affected. Existing designs maintain their routing 
setup. 

Layers button 
Select the Layers button from the dialogue bar. The auto-router can route on up to six layers simultaneously. 
This window is used to control which layers are available for auto-routing and the preferred routing direction for 
each layer. The options being Horiz(ontal), Vert(ical) or Any. 
Select the routing layers to be used and the direction of routing on each layer. (Only copper layerscan be 
selected for routing.) For best results, take care that the chosen direction corresponds to any pre-routed fixed 
tracks on the layer. Typically horizontal tracks are placed on one layer, vertical tracks on the other, this is 
repeated for each pair of routing layers. (The final optimisation routine will remove excess vias that are 
introduced.) Close the window.  

Starting the router 
The router is now ready to be started. Select one of the following buttons to start the router: 

All when selected, the auto-router will attempt every connection on the board providing the 
appropriate strategies have been enabled from the Router setup window. The auto-router starts 
straight away. 

Signame when selected, the auto-router will attempt just the connections of a named signal. Type in the 
name of the net to be routed when requested. The auto-router starts as soon as the signal has 
been identified. 
If the selected signal is a power net, then the enabled power strategies are used, if it is a signal 
net then the enabled signal strategies are used. 

Part when selected, the auto-router will attempt just the connections radiating from a selected part. 
This is achieved by selecting the PART command followed by the part to be routed. The auto-
router starts as soon as the part has been identified, using the appropriate enabled strategies for 
each net. 

Net when selected, the auto-router will attempt just the connections of a selected signal. The auto-
router starts as soon as the signal has been identified. 
If the selected signal is a power signal, then the enabled power strategies are used, if it is a 
signal connection then the enabled signal strategies are used. 
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Whilst the router is running 
The router uses the enabled routing strategies from the setup window, in the order listed. It repeats each 
strategy until all the connections within that category have been completed or the specified number of passes 
has been completed even if all the connections have not been completed. 
As the router is running, information appears along the bottom of the screen to indicate what is currently 
happening. 

Mode Indicates which strategy is currently running. 
Power-P  Power pattern routing strategy 
Power-C  Power cost routing strategy 
Memory  Memory routing strategy 
Signal-C  Signal cost routing strategy 
Optim  Optimising routing strategy 

Pass Indicates which pass of the current strategy is being attempted. 
Nroutes Indicates the total number of routes that must be attempted. 
Ndone  Indicates the total number of routes completed by the auto-router. 
Nvias Indicates the total number of vias currently used on the board. 
Failed Indicates the number of connections that have not been routed. 
Vio Indicates the number of violations currently present on the board. A violation is either a short 

circuit or clearance error. The router is permitted to make violations whilst it is attempting to 
find a path for a connection. These violations will be rectified before routing is completed. 

Interrupting the auto-router 
The auto-router can be interrupted at any time by pressing the STOP button from the dialogue bar. After the 
router has completed the connection or route it is currently attempting, a window appears. This could take a few 
minutes, depending on the size of the net. 
The window contains choices to, stop routing, skip to the next pass or continue routing. 

Copper Fill (Tools > Copper Fill) 
The copper fill commands are used to add areas of copper to a copper (tracking layer) layer of the board. The 
areas of copper are attached to the tracks and component pads of a selected signal, whilst avoiding all other 
pads, vias and tracks. Copper fill is typically used for screening purposes. (Copper fill should not be confused 
with power planes which are discussed separately.)  
The filled area can either be a solid area of copper or a cross-hatched area of copper. It is made up of parallel 
horizontal and/or vertical lines that cross one another according to the settings in the Fill dialogue bar. 
Two types of filled area can be added, one with a smooth edge or one with a non-smooth edge. The smooth 
edge fill gives far superior results. The non-smooth edge option is present for historic reasons only. 
In "smooth edge" mode, a track is drawn around existing tracks and pads that are not part of the selected net, 
leaving a space (minimum clearance) away from those tracks and pads. This track will not necessarily be "on 
grid". The area inside this edge is filled with copper tracks which are placed on the grid as specified in the fill 
dialogue bar, but the end points of those tracks will butt up against the edge track, so will not necessarily be 
"on-grid" either.  
Note: the smooth edge assumes that user-defined pads are rectangular in shape, so it will not trace their outline 
precisely.  
If the "non smooth edge" mode is selected, the copper fill radiates from a point on the current grid, at the pitch 
specified. It is therefore possible for some pads on the selected net to be "missed" by the copper fill. It is 
therefore necessary to ensure that the current grid origin is in the position required and a suitable fill pitch is 
selected. The non-smooth edge will give a jagged edge around angled/curved tracks, and a jagged edge if the 
fill is added in only one direction. 
Whether a solid or cross hatched filled area is added, pads on the selected net are joined to the filled area 
according to the settings in the copper Fill dialogue bar.  
Copper fill should be added after all routing has been completed and checked, otherwise there will be no space 
to route the connections, or correct errors.  
The area to be filled is defined by the user, and can include keep-out areas if the smooth edged option is 
chosen. The copper forming the filled area can be modified using the Amend > Movepoint/Delete Track 
commands if required.  
The user first defines the settings that the filled area has to conform to, in the Fill dialogue bar. The perimeter of 
the required filled area should be defined using the Boundary > Add Line command, and modified if necessary 
with the Boundary > Corner/Delete Point, etc. commands. The StartFill commands are used to add the copper 
area. 
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The copper area connects to all the component pads and tracks that are connected to the selected/named 
signal. Vias on the selected/named net can be connected or exposed as defined in the Fill dialogue bar. 
Clearance is provided around all other pieces of copper.  
Notes: (i) any tracks that have been entered using the Amend menu commands will not be recognised as part 

of a specific net until they have been validated by the artwork checking routines. This means that the fill 
routine will leave a clearance around them until they have been validated. If the fill was supposed to be 
attached to the new tracks, the existing fill would have to be deleted and added again once the tracks 
had been validated. Short circuits can also cause the copper areas to avoid tracks – ensure there are 
no short-circuits before adding the copper fill to avoid this happening. 
(ii) if more than one area of fill is to be added to a layer, improved performance can be achieved if the 
existing fill is saved using the Filled Copper > Save Copper command, then deleted (Filled Copper > 
Delete All), before adding the next area of copper fill. Once the additional fill has been added, the 
saved fill can be merged back into the artwork, Filled Copper > Merge Copper.  
(iii) adding copper filled areas with the smooth-edge option enabled can result in areas of isolated 
copper fill, depending on the setting in the Fill dialogue bar. These isolated areas will be identified by 
the artwork checking routines and can subsequently be deleted automatically if required (using the 
Filled Copper > Delete All Isolated Copper command). 

The speed of the actual fill process varies depending on the fill pitch and type, the size of the filled area and the 
speed of the machine. Smooth edged fill, finer grids and/or larger areas take longer. The amount of memory 
installed on the machine governs the amount of copper fill that can be added in two ways. Finer fill pitches mean 
that more memory is required to map the data. If it isn't available the polygon areas have to be reduced in size. 
The amount of memory also governs the amount of data that can be added to a layout. The Artwork Properties 
tab indicates the number of points used on each layer.  
Fill dialogue bar 
When copper fill is selected, the copper fill dialogue bar, similar to that shown in Figure 162, appears. It is used 
to set the rules for the copper fill. 
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Figure 162 

Layer this determines which layer the copper fill will be added to, or deleted from. It is the 
"active" layer. All layers are available for selection. 
If a pad is selected as the datum, it must be on this layer.  
If the active layer has been assigned a title (Configuration > Layer Assignments window), 
this is also displayed. 
The colour of the box helps to identify and also select layers; it can be selected to 
produce the layer assignments list which aids layer selection when using the spin-
controls to change layers might be cumbersome. 

Size This setting defines the width of the copper lines that make up the filled area. The size 
code corresponds to the size codes in the Track Sizes table. The code can be changed 
by typing in a number (the cursor must remain in the dialogue bar whilst typing) or by 
selecting the spin controls alongside. 
The current size assigned to the size code number is shown underneath. The units in use 
(inches/mm) are those set when the dialogue bar was opened.  
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The filled area can either be a solid or cross hatched area of copper. Solid areas are 
created if the pitch and the thickness of the lines in the filled area are the same size. 
(Typically the track size is set to a few thou larger than the pitch to allow for inaccuracies 
during plotting.) Cross hatched areas are created if the fill pitch is larger than the track 
thickness. 

Boundary  A boundary must be defined that defines the area in which the copper fill will be added. 
When the boundary is added, it is assigned the number set here (from 1 to 99). The 
boundary is not saved with the copper fill. If it is required to delete then re-add the copper 
fill at some later stage, selecting the appropriate boundary number will restore the 
boundary. 

Edge clearance Specifies the minimum distance required between edges of the board profile and 
keepouts and the copper forming the filled area. 
If the non-smooth edged fill is used, the actual distance can sometimes be a little larger 
depending on the pitch and the thickness of the copper lines. 

Minimum clearance Specifies the minimum distance required between existing copper pads & tracks and the 
copper forming the filled area. 
The smooth-edged copper fill gives precedence to specific clearance requirements 
defined on the schematic or in the net list if they are greater than the minimum size 
specified here. 
If the non-smooth edged fill is used, no attention is paid to specific clearance 
requirements for individual nets and the actual distance can sometimes be a little larger 
depending on the fill pitch and the thickness of the copper lines. 

Pitch Specifies the distance required between centres of each parallel line of copper that forms 
the filled area.  
To achieve a cross-hatched fill the fill pitch should be larger than the selected fill track 
size (fill pitch>track width). 
To achieve a solid fill, the fill pitch should be equal or smaller than the selected fill track 
size (fill pitch=<track width). 
In order for a solid fill to obtain entry to areas within the board with a narrow entry 
channel, it may be necessary to use a fine fill pitch and track size.  

Direction The copper fill can be made up of parallel horizontal and vertical lines, or just horizontal, 
or just vertical parallel lines. Select the arrow alongside the setting and choose from the 
list that appears. 
Hatched the fill is made up of horizontal and vertical strips of copper.  

Only choose this option if a cross-hatched (not solid) effect is required, or 
an un-smooth edge is selected. Selecting hatched unnecessarily will 
increase the point count on the layer and increase the design size for no 
benefit. It will also increase the size of the output files. 
If Hatched is selected, the filled area is made up of horizontal and vertical 
copper lines. Jagged edges can be left around angled tracks, or perimeter 
lines, unless smooth edge is selected. 

Horizontal the filled area is made up of only horizontal strips. Use this option if a solid 
filled area with a smooth edge is required. 

Vertical the filled area is made up of only vertical strips. Use this option if a solid 
filled area with a smooth edge is required. 

Use keepouts This setting is only operational if the "Smooth edge" setting is also selected. 
When selected (ticked), the copper fill will not cross any keepout lines. If it's not selected 
then keepout lines are ignored.  

Smooth edge If smooth edge is selected (ticked) the copper fill is surrounded by a track that forms a 
smooth edge around the copper fill. This line clears other pads, tracks and vias by the 
distance specified as "minimum clearance".  
If unselected, the copper fill will just be made from horizontal and\or vertical lines, on the 
selected fill pitch. This will result in a ragged edge around angled\curved tracks and in 
some cases a slightly larger than specified minimum clearance.  
 

Min Connections/region Controls the minimum number of part pins that must be connectable to a copper fill 
region for the region to appear in the fill result. 
Note: setting this value to zero will result in the creation of isolated copper areas. 

Via Holes  This option provides control over how copper fill connects to via holes that are members 
of the fill net. Available options are: 
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No Connection No heat relief stubs are inserted so the vias remain exposed. 
Heat Relief Heat relief stubs are inserted to connect the via to the fill region. 

Providing the fill track size is smaller than the pads in use, the 
pads will not be completely covered. 

Cover  The copper fill floods over the top of the via. 
Heat-relief stubs are made from up to four track segments that connect to the via, using 
the track size assigned for the fill.  

 
Component Pins  This option provides control over how copper fill connects to component pins that are 

members of the fill net. Available options are: 
Heat Relief Heat relief stubs are inserted to connect the part pin to the fill 

region. 
Cover SMD Drilled component pins are connected with heat relief stubs. SMD 

part pins (undrilled pins on layers T or B) are covered over by the 
copper fill. 

Cover All Copper fill covers all part pins. 
Heat-relief stubs are made from up to four track segments that connect to the component 
pin, using the track size assigned for the fill.  

Boundary > Add Line 
Used to define the perimeter of the copper filled area.  
If an un-smooth edged fill will be added, any exclusion areas within the filled area can also be defined using this 
command.  
If smooth edged fill is being added, only one boundary can be defined - use keepout lines to stop the fill entering 
specific areas if required. 
Any enclosed straight-line polygon shape may be defined. Polygons within the outer polygon will act as keep-out 
areas for the copper fill if the un-smooth edged fill is being added, providing the datum point is selected within 
the main polygon area. 
The Boundary > Corner/Delete Point, etc. commands can be used to modify the line that is added. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Choose a boundary number from the dialogue bar on the left-side of the screen. This number will be stored with 
the boundary. To restore the boundary at some later stage (as it is not saved with the copper fill), select the 
boundary number that was current when the boundary was added. 
Select Boundary > Add Line. Position the cursor at a point on the desired perimeter outline and click the left 
hand mouse button. Move the cursor to stretch the line and insert corners in the line by clicking the left hand 
mouse button. Finish by inserting a corner at the starting point of the line to enclose the area, and then click the 
right hand mouse button to release the line. 
Keep-out areas within the main polygon outline are added in the same way if the unsmooth edge is selected. 
The area is then ready to be filled. 

Boundary > Delete Line 
Used to delete the perimeter lines added using the Boundary > Add Line command. 
A complete line, from its start and end points is deleted, not just one segment. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Boundary > Delete Line, then select the perimeter outline to delete it - select on a corner/endpoint if the 
line is difficult to select. 

Boundary > Corner 
Used to modify the copper fill perimeter outline by adding or moving existing corners in the line. 
Corners are added and released with clicks of the right hand mouse button. Corners are moved and released 
with clicks of the left hand mouse button. Once the corner has been selected, clicking the opposite mouse 
button cancels the operation. 
   right button   =     add corner 
   left  button     =    move corner 
   Opposite button cancels 

Adding a corner to a line 
Select Boundary > Corner, then point at the line and click the right hand mouse button. Move the new 
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corner and release it with another click of the same (right) button. Clicking the opposite (left) hand button 
before the corner is released, cancels the new corner. 

Moving an existing corner in a line 
Select Boundary > Corner, then point at the corner in the line and click the left hand mouse button. Move 
the corner and release it with another click of the same (left) button. Clicking the opposite (right) hand 
button before the corner is released, cancels the move. 

Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Boundary > Delete Point 
Used to delete points in a copper fill perimeter outline. 
Select Boundary > Delete Point, then select a corner in the perimeter outline. The corner disappears. 

StartFill > Set Datum 
Used to select a component pin on the signal that the copper fill will be joined to. The component’s pad must be 
on the same layer as the copper fill. 
If you cannot locate a pad easily and it is connected to a named signal, use the StartFill > Connect to Net 
command instead. 
Whether a solid or cross hatched filled area is added, pads on the selected net are joined to the filled area with 
a simple cross where possible. The cross is made using the track size assigned for the fill. Providing the fill track 
size is smaller than the pads in use, the pads will not be completely covered. 
Note: if tracks have been added using the Amend menu and have not been validated using the artwork checking 
routines, the tracks will be avoided even if they are connected to the same net as the selected pad. 
When the filled area is added, the fill may not fill the entire polygon area. For instance, if a track cuts the polygon 
area in two on the same side as the copper fill, the fill would fill the area from the datum pad up to the track, but 
it would not cross the track. This can lead to unfilled areas. It may be better to assign a signal name to the net 
(in the wiring list editor) and use the StartFill > Connect to Net command. 
To add multiple areas of copper fill to a layer, refer to the Filled Copper > Save Copper command. 
Check that a perimeter outline has been defined and the dialogue bar is set as required, then select StartFill > 
Set Datum. Select a component pad to which the copper fill will be connected. A message should appear in the 
status bar indicating that a valid datum point has been selected. Select the Start Fill > Connect To Datum 
command to start the copper fill. Messages appear along the bottom of the screen to indicate what is 
happening. 

Start Fill > Connect To Datum 
Used to start the filling process after a datum pad has been selected (StartFill > Set Datum). 
Copper fill should be added after all routing has been completed and checked, otherwise there will be no space 
to route the connections or correct errors. 
A perimeter outline must be defined and a valid datum point selected before this command can be actioned. 
Check that a perimeter outline has been defined, the dialogue bar is set as required and a valid datum point 
selected (StartFill > Set Datum). 
Select Start Fill > Connect To Datum. Messages appear along the bottom of the screen to indicate what is 
happening. 

StartFill > Connect to Net 
Used to add copper fill to the layout by entering the signal name of the tracks and pads that the copper should 
be attached to. 
This command can be used instead of the Start Fill > Set Datum/Connect To Datum commands to start the fill 
process, providing the pads are attached to a named signal.  
Pads on the selected net are joined to the filled area with a simple cross where possible. The cross is made 
using the track size assigned for the fill. Providing the fill track size is smaller than the pads in use, the pads will 
not be completely covered. 
When the filled area is added, the fill is added to the entire polygon area. For instance, if a track cuts the 
polygon area in two on the same side as the copper fill, the fill would fill the areas on either side of the track, 
providing there were tracks or pads on either side of the track belonging to the specified net. This can lead to 
many filled areas being added. 
Note: if tracks have been entered using the Amend menu, and have not been validated by the Artwork Checking 
routines, the tracks will be avoided even if they are connected to the specified net. 
Check that a perimeter outline has been defined, the dialogue bar is set as required and then select StartFill > 
Connect to Net. A window appears, requesting the name of the net that the copper fill should be connected to. 
Enter the signal name and the filled area is added.  
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FilledCopper > Delete All 
Used to delete all the copper fill from a particular layer, providing it was added using the copper fill commands.  
Ensure the layer setting in the dialogue bar is set to the layer containing the filled areas to be removed. Select 
FilledCopper > Delete All, the entire copper fill from the layer is removed. 

FilledCopper > Delete Area 
Used to delete one area of copper fill from a particular layer, providing it was added using the copper fill 
commands. 
Ensure the layer setting in the dialogue bar is set to the layer containing the filled area to be removed. Select 
FilledCopper > Delete Area, point at and select, with a click of the left hand mouse button, a point in the copper 
filled area that is to be deleted. The filled area is removed.  
Note: If the area has a smooth edge, the inner area and edges have to be deleted separately. Select the inner 
area and once deleted, select a point in the edge, bearing in mind that there may be many edges. 

FilledCopper > Delete Node 
Used to delete an individual segment from an area of copper fill from a particular layer, providing it was added 
using the copper fill commands. It is easier to identify the segments if the tracks are being shown as a centreline 
rather than filled (View > Lines at Width). 
Ensure the layer setting in the dialogue bar is set to the layer containing the segment of copper fill to be 
removed. Select FilledCopper > Delete Node, point at and select, with a click of the left hand mouse button, an 
end point of the segment to be deleted. The segment is removed. 

FilledCopper > Delete All Isolated Copper 
Used to delete all areas of isolated copper fill detected by the artwork checking routine, from all layers, whether 
visible or not. (Their visibility is controlled from the View > Isolated Copper command.) 

FilledCopper > Save Copper 
Used to improve the performance of the copper fill routines when adding more than one area of fill to a layer of 
the board. For instance, if there is to be more than one filled area of VCC on a layer, or many areas of fill 
connected to different signals on a layer.  
When adding more than one area of copper fill to a layer, after the first area has been filled, save the fill using 
this command, then delete the fill (using the FilledCopper > Delete All command). Then add the extra area of fill. 
If more fill is to be added to this layer, repeat this process until all the areas of fill have been added, saved and 
deleted. When all the filled areas have been added and deleted, restore all the deleted areas of fill using the 
FilledCopper > Merge Copper command. 
Ensure the layer setting in the dialogue bar is set to the layer containing the filled area to be saved. Select 
FilledCopper > Save Copper. A window appears requesting a name (without an extension) for the file that is to 
be created. When <enter> is pressed, the fill is saved within the design.  (These files can be removed if required 
using the FilledCopper > Delete Saved Copper command.) 
The fill can be restored as required using the FilledCopper > Merge Copper command. 
Note: all the copper fill from the artwork on the selected layer is saved.  

FilledCopper > Merge Copper 
Used to restore an area of copper fill to the selected layer, from a previously saved fill file.  
Ensure the layer setting in the dialogue bar is set to the layer that the fill will be merged to. Select FilledCopper 
> Merge Copper, a window appears listing all the copper files held in the design. 
Select the fill file required, followed by the Merge button to restore the area. Repeat for all the fill files required.  
Take care to only restore the fill file once, or there will be copper fill on top of copper fill (unless the fill was 
deleted before the second merge). 

FilledCopper > Delete Saved Copper 
Used to delete copper fill files that were created using the FilledCopper > Save Copper command. These files 
should be deleted once they are no longer required.  
Select FilledCopper > Delete Saved Copper, the list of fill files within the design appears. Select the file to be 
deleted, followed by the Delete button. Repeat for all the files to be deleted. 

Power planes (Tools > Powerplane) 
What is a power plane? 
A power plane is an internal layer of a multi-layer board. A power plane is shown in Figure 163. 
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Figure 163 

 
It is made from a solid sheet of copper (a plane) which connects all the plated through holes on the board 
together, unless they have a clearance area or "anti-pad" around them - the round areas in Figure 163.  
Heat-relief pads are added around holes that should be connected to the plane; they are added to aid the 
manufacturing process, they are not required as far as electrical connectivity is concerned. They are the "dotted" 
areas in Figure 163.  
Vias that are connected to the plane can have a heat-relief pad added or not as required – because the vias are 
not generally soldered to, the heat-relief pad is not essential – the heat-reliefs around vias can also cause 
problems by isolating other holes that should be connected to the plane. 
Generally speaking, the plane of copper is usually connected to a power rail, hence the name "power" plane, but 
any connection could be routed in this way. 
Power planes can be used when it is impossible to complete a layout on two layers. Removing the power tracks 
from the outer layers of the board can leave enough room to complete the signal tracking. Power planes are 
also used for various design reasons as, for instance they can reduce cross-talk between signals. 
A reverse image of the power plane is displayed except when the power plane tools are being used in the 
artwork editor.  
When producing output files, the pads are usually plotted and a reversed image subsequently produced by 
photographic techniques. However, some outputs, (Gerber photoplot and Postscript) can be produced as they 
are finally required, providing the plotter can accept the appropriate commands. 

What is a Split Power Plane? 
A split power plane is similar to the power plane described above, except that more than one net is connected 
using the copper plane, but they are isolated from each other as shown in Figure 164. 
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Figure 164 

Power plane layers 
When a layer is defined as a power plane (or split-powerplane) it is initially a solid sheet of copper (this is not 
visible in normal viewing mode) and every hole through the layer is connected to it. Anything that is added to 
that layer actually removes copper. So any tracks or pads or text that are added to the layer, are “not copper”.  
Once the power plane tool has been exited, the reverse image of the plane is displayed, so pads/tracks and text 
will be seen, but they are removing copper from the plane. 
Once a power plane has been generated, the Amend commands can be used to add/modify/delete the 
pads/tracks on the plane, but bear in mind they are “not copper”. 

Creating a power plane, or split power plane - basic procedure 
These notes assume the design is open, a parts/net list has been created, and the part placement is complete. 
Before power planes can be generated, the following items have to be defined and/or checked. 
The connection to be routed on the plane has to have a signal name (in the schematic or wiring list editor) and 
should also be defined as a power rail (Configuration folder, Power names). 
Ensure the heat-relief and anti-pad sizes have been set as required (Configuration folder, Sizes Table, Heat-
relief/Anti-pads tab). 
Ensure the layer assignments have been set as required (Configuration folder, Layer Assignments and 
Ordering). 

Routing the board 
Generally speaking, the power planes should always be generated AFTER all the other connections have been 
completely routed, otherwise errors will be introduced to the layout if vias are added, parts moved, etc.  
However, the planes can be created at any stage, provided the planes are created again at the end of further 
changes. 
If modifications are made to the layout, the power planes should always be re-created. Always run the artwork 
checks as a final check on the artwork. 
Surface mounted components cannot be connected to the power plane until a connected via is added to make 
the connection through to the plane. Once the plane has been defined in the layer assignments table, a 
connection “blob” is provided from these sm pads (see Figure 165, left) and it has to be moved into an 
appropriate location. (If the “blob” can’t be seen, ensure the power unroutes are visible and at width (controlled 
from the View Control  dialogue bar.) 
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Figure 165 

 
This “blob” should be pulled out using the Mroute > Corner command (right-button) and a track and via will 
appear to connect the smd pin to the inner layers Figure 165, right. 
The auto-router’s power pattern strategy or Specctra/Electra auto-routers will do this automatically. 
Once all routing is complete, create the power planes. 
If the Specctra/Elecctra auto-router will be used and the board has split power planes, the split planes have to 
be created prior to submission to the router.  
After any routing (manual/auto), the planes should be re-generated (split-polygons modified if necessary). 

Power Plane Tools 
Once all the routing on the board is complete, or the board will be submitted to the Specctra/Elecctra auto-
router, the power planes are ready to be generated. 
Note: when a power plane is generated, everything from the power plane layer(s) is automatically deleted first, 
including anything added to that layer by the user. This ensures the power plane is correct. 
Select the power plane tool (Tools > Powerplane). A new Powerplane dialogue bar appears and the display 
shows one plane layer similar to that shown in Figure 166. The heat-relief and anti-pads are shown in the plane. 

 

Figure 166 



 

233 

All the layers configured as power planes/split planes will appear in the top selection of the Powerplane dialogue 
bar, under the heading "Powerplane Layer".  Clicking on each layer will change the display to show that 
selected layer. (The colour for the layer is as defined by the View Control dialogue bar and can be altered as 
required.) 
In the mid-section of the dialogue, under the heading "Powerplane Nets", the power signal names to be used on 
the selected layer are shown.  
If the layer is a ‘split’ plane, the primary rail for that layer is always shown at the top of  the "Powerplane Nets" 
list, followed by the secondary rails - see Figure 167 where layer 7 has been selected as the powerplane layer 
and the powerplane nets are 0V (at the top, therefore the primary rail) and +12V, -12V and V+. 
 

 

Figure 167 

When a split plane layer is chosen, the display shows the primary plane with it’s heat-relief/antipads, and 
flashing coloured dots on some pads - Figure 168 
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Figure 168 

The coloured flashing dots represent the pins on the secondary power nets. 
Coloured boxes alongside the powerplane net names in the dialogue bar show the colour assigned to each 
power net for recognition purposes. (The colour can be changed from the Setup button which is described later.) 
Each of the secondary power net pins (flashing dots) have to be isolated from the other powerpin nets by a line 
that should enclose each of the same-coloured pins, to create an island of copper that forms the connection. 
Drawing the split-plane boundaries 

From the dialogue bar and with the split-plane layer selected, select one of the secondary powername nets.  
The SplitBoundary commands become active and the polygon can be drawn (SplitBoundary > Add Line) to 
isolate the pins associated with that net. The line has to start/stop in the same place to form an enclosed 
polygon shape, at which time the area will change colour to reflect the power rail and the heat-relief pads 
for that rail will appear. 
The line must not touch the edge of the board profile, cross itself or other lines.  
Tip: add an enclosed polygon shape around a/some of the same-coloured dots, then use the SplitBoundary 
> Corner command to stretch it out - this is usually easier than trying to draw the polygon "right first time". 
Pins that are within the wrong polygon region will flash on and off.  
The flashing colour indicates which net the pin belongs to.  
The "Net Error Count" area in the dialogue also indicates the number of pins on that net that are in error (ie 
outside of the polygon or in another polygon). There should be 0 errors for each power net. 
Select each of the secondary power names and define their polygons.  
As polygons are edited, the display will dynamically update changing pin powerplane features from antipad 
to heatrelief state as appropriate. 

Modifying the split-plane boundaries 
Once the polygon has been added, it can be modified with the SplitBoundary commands. Select the 
secondary power name from the dialogue (for example +12V)  then the SplitBoundray command required. 

Generating the planes 
The planes are not created until the Generate button in the dialogue bar has been used.  
Each layer is generated individually unless the “All Powerplanes” checkbox in the dialogue bar is ticked, 
when all the planes will be generated simultaneously when Generate is selected. 
A message appears in the status bar to indicate that the planes were successfully generated. 

Designs with split planes from earlier versions: 
The power plane tool was altered in XLD version 1.72. Designs with split power planes saved prior to that 
version remain unaffected by the changes until it is required to regenerate the split planes or run the artwork 
checks. 
When it is necessary to regenerate the planes, or run the artwork checks, for example following a modification, it 
is necessary to identify which split-plane polygon is associated with each power rail before the planes can be 
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updated and re-generated (the first time only). To do this:  
 

i. Open the artwork editor. Select the power plane tool, one power plane layer will be visible. If it’s a split 
powerplane layer, the embedded power rail pins will be flashing.  

ii. From the Powerplane dialogue bar, under the "Powerplane Nets" heading, select one of the secondary 
power rail names. 

iii. The first powername in this list is always the primary power rail (so don't select that one). The coloured 
boxes indicate the colour assigned to the power rails for identification purposes. 

iv. Once the power rail name has been selected, this will enable the SplitBoundary > Import Boundary 
command, which should now be selected (an icon is available for this command).  

v. The split plane polygons will now appear, and the one associated with the selected powername should 
be selected.  

vi. If the correct polygon is chosen, the same-coloured dots will stop flashing and be replaced with heat-
relief pads in that area.  

vii. If the dots continue to flash, the incorrect polygon was chosen - use Undo, then repeat until the correct 
polygon is selected. 

viii. Once all the polygons for that layer have been imported, use the Generate button (or Powerplane > 
Generate command) to create the plane. 

ix. Repeat for the other split-plane layers. 
Once completed, it is not necessary to import the polygons again. 
Note: all plane layers must be generated – the Generate button creates the selected plane only, unless 
the All Powerplanes checkbox is ticked. 

Adding text, logos, extra clearance areas, etc. to the power planes 
Any tracks, pads or text that are added to a power plane layer (using the Amend or Text commands) are “not” 
copper, they are clearances in the plane, they are therefore not included in the checking routines. It is possible 
to isolate heat-relief pads with this additional data. These instances will not be flagged by the artwork checking 
routines. 
Please note that logos placed in powerplane layers are currently invisible to the artwork checker.  No checks for 
violation with other powerplane features will be performed. 
When a power plane is generated/regenerated, the logos will be preserved within the layer.  

Notes:  
Tracks, pads and text that are added to the power plane layers will be deleted if the power planes are ever 
generated again. For this reason, the data could be added to one currently unused silk-screen layer of the board 
to save re-adding it if the planes are ever re-generated. That layer would need to be output with the power plane 
layer. (A silk screen layer should be chosen, as an inner copper layer would contain the inner layer pads of the 
components, these could lead to isolated pins in the resultant output file.) The data on the silk screen layer 
would not be checked by the artwork checking routines. 
When the planes are created a clearance line is added around the outside of the board to stop the plane 
reaching the edges of the board and possibly causing shorts once manufactured and in use. (The line is centred 
on the board profile and the power plane dialogue bar determines its thickness (boundary line size). Once 
added it can be altered using the Amend commands.) 
Due to the position of holes and or isolation lines, it is possible for heat-relief pads to become isolated from the 
power plane, or only connected by one or two channels. It is also possible for a heat-relief pad to be connected 
to more than one power net if the isolation line crosses through a heat-relief pad. Neither of these situations is 
identified by the checking routines. 
The powerplane isolation lines can be altered using the Amend commands but these changes are not back-
annotated to the powerplane tool - refer to the SplitBoundary > Import Boundary command to do this. 

Power plane commands 
When the Tools > Powerplane command is selected, a dialogue bar appears, similar to that shown in Figure 
169, which controls the plane generation, along with a new set of commands across the top of the window. 
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Figure 169 

Power Plane Dialogue Bar  
This should be set up as required, using the following information for guidance. The layers & nets that appear 
are controlled from the Configuration folder > Layer Assignments & Ordering. 
Powerplane Layer 

All the layers configured as power planes/split planes will appear in the top selection of the dialogue bar, 
under this heading. 
Clicking on each layer will change the display to show that selected layer. (The colour for the layer is as 
defined by the View Control dialogue bar and can be altered as required.) 

Powerplane Nets 
The power signal names used on the selected layer are listed here.  
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If the layer is a ‘split’ plane, the primary rail for that layer is always shown at the top of this list, followed by 
the secondary rails - see Figure 167 where layer 7 has been selected as the powerplane layer and the 
powerplane nets are 0V (at the top, therefore the primary rail) and +12V, -12V and V+. 
When the SplitBoundary commands are used to add or modify the isolation polygon, they will only operate 
on the isolation line of the selected power rail in this list. 

Boundary Line Size 
This setting corresponds to the size codes from the Track Sizes table and it controls the width of the 
isolation lines that are added between power rails in a split plane and the line that is added around the 
outside of the profile.  
The code can be changed by typing in a number (the cursor must remain in the dialogue bar whilst typing) 
or by selecting the spin controls alongside. The actual size is shown below the setting. 
New lines are added at the size selected. 
Existing lines can be altered by selecting the powerplane net from the dialogue, then changing the size 
control. 

Net Error Counts 
The numbers here correspond to the number of component pins that are outside of the polygon. The 
coloured box identifies which power rail they belong to. 

Setup button 
The powerplane setup windowFigure 170, contains information about each layer and power net(s) used. 

 

Figure 170 

Use the “+” button to expand the information on a particular layer or power rail. Figure 171. shows Layer 7 
expanded, along with the power rails on that layer. 
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Figure 171 

Items in the "Setup" window that are not ‘greyed’ can be edited. 
Board Profile/Polygon Status: the board profile and each secondary polygon line must form an enclosed 

area. This indicates whether the line is OK, not defined or not closed. 
 Note: to allow for non-coincident points in the board profile (typically 

occurs when the profile has been imported), a tolerance of 0.005” 
(0.127mm) is permitted in board profile line end-points. 

No. of points on profile/polygon: the number of points (typically corners, though a point can exist without a 
change of direction) in the polygon/profile. 

No. drill holes for this net: the number of drilled holes connected to the power rail. 
No. of connected net drill holes: the number of through plated component pins in this power rail that have 

been connected. 
Layer colour: the colour assigned to the layer by the View Control dialogue bar. The 

primary power rail will use this colour. 
Polygon colour: the colour assigned to the secondary power rail. 

Selecting the coloured box allows the colour to be changed. Once 
selected, select the arrow that appears alongside. A colour palette 
appears from which the colour can be selected. 

No heat-relief if drill size less than: any drilled pads for this net, that are smaller than the size specified will 
not have a heat-relief pad added around the hole. 
The default is zero, so heat reliefs are always created.  The size of heat 
relief pads (and anti-pads) is defined in the Sizes Table. 
A separate threshold may be specified for each net section of a split 
powerplane. 
Heat-relief pads are generally added to holes that are connected to the 
plane to avoid heat-dissipation when soldering to the hole. Excluding the 
heat-relief pads on smaller holes can free up channels that may 
otherwise cause pads that should be connected to the plane from 
becoming isolated. 

Once the settings in this window have been defined, select OK to continue.  
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Generate button 
Used to create the power planes. 
If the All Powerplanes check box is ticked, then all the powerplane layers are generated. 
If the check box is unticked, only the selected powerplane layer is generated. 
Everything previously added to the power plane layers, except for logos will be removed when Generate is 
selected. This ensures the planes are correct – a warning window will indicate that this is about to happen 
and the command can be cancelled if required. 
Heat-relief pads will be added around holes that are connected to the plane (depending on the threshold set 
in the setup window) and anti-pads around all other pads.  
An isolation line is also added around the board profile, its size is determined by the Boundary Line Size 
setting. This stops the plane shorting into metal objects that might touch the edge of the manufactured 
board. 

View Buttons 
Top/Bottom: when ticked, the tracking/text/vias/component pads on the selected layer are displayed. 
(Only the component pads/vias are displayed if the layer is set to invisible in the View Control dialogue bar.) 
Net colour: when unticked, the split power plane layer is shown in the primary power colour only, so the 
secondary power rails cannot be identified by their colour. 

 

Figure 172 

SplitBoundary commands 
These commands are used to add or modify the isolation barrier between power rails on the same split power 
plane layer. One isolation line for each secondary power rail, should form a polygon shape to enclose all the 
pads of that power rail. One isolation line/area is required for each secondary power rail. Multiple areas are not 
permitted. 

• The isolation line for each power rail must be defined from one continuous line that doesn't overlap or 
cross itself or other isolation lines or the board profile.  

• The line must form an enclosed polygon shape around all the pins connected to the same power rail 
(those of the same colour). Pins of other colours must not be enclosed within that polygon.  

• The checking routines do not identify isolated power pins caused by isolation lines or heat-relief and 
anti-pads. 

Do not: 
• lay the line across or touch any coloured power dots. The coloured dots must be completely inside or 

completely outside the isolation area – a heat-relief pad that has an isolation line through it will  be 
shorted between two power nets. 

• cross isolation lines, either of the same colour or different colours, otherwise areas will become 
isolated. 

• allow the isolation lines to touch the edge of the board profile or one another – this may lead to isolated 
areas and pins  

The additions/changes to the polygons are not updated on the powerplane layer until the planes are generated. 

SplitBoundary > Add Line 
Before adding the isolation line, ensure the appropriate layer & secondary power rail is selected from the 
dialogue bar. Position the cursor where you intend starting the isolation outline and click the left-hand mouse 
button. Move the cursor to stretch the line and insert corners in the line by clicking the left-hand mouse button. 
Enclose all the pins of the selected secondary power rail, excluding the other coloured pins. Complete the 
isolation line by inserting a corner on top of the starting point of the line to enclose the area, then click the right 
hand mouse button to release the line. Once the polygon forms an enclosed shape, the area inside the isolation 
line changes colour (unless the Powerplane dialogue bar View – NetColour check box is unticked).  
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If the polygon is not completely enclosed, or pins are incorrectly included/excluded, use the SplitBoundary > 
Corner command to adjust the line.  
Although multiple lines can be added, they should all be joined together and form an enclosed shape – whilst 
multiple disconnected lines exist, the area will not be valid or change colour appropriately. 

SplitBoundary > Delete Line 
Used to delete an isolation line that has been added. A complete isolation line is deleted, not just a segment in 
the line. 
Select SplitBoundary > Delete Line, select the appropriate layer & secondary power rail from the dialogue bar. 
Point at the isolation line to be deleted and click the left-hand mouse button. The line is deleted. 
(If the planes have already been generated, this will not remove the isolation line from the plane itself until the 
planes are re-generated.) 

SplitBoundary > Corner 
Used to add and move corners in isolation lines.  
(If the planes have already been generated, this will not update the plane layer until the planes are re-
generated.)  
Corners are added and then released with a click of the right hand mouse button. Corners are moved and then 
released with a click of the left hand mouse button. Clicking the opposite mouse button once a track has been 
selected cancels the operation. 
   right button   =   add corner 
   left  button    =   move corner 
   (Opposite button cancels.) 
Only lines from the selected power rail can be modified. 
Select SplitBoundary > Corner, then select the appropriate layer & secondary power rail from the dialogue bar. 

Adding a corner to an isolation line  
Point at an isolation line, and click the right hand mouse button. Move the cursor and the new corner. 
Locate the cursor in the position for the new corner and click the right hand mouse button again to release 
the corner. 
Clicking the left hand mouse button before releasing the line, releases the line without the new corner. 

Moving an existing corner in an isolation line  
Point at an existing corner in the isolation line, and click the left hand mouse button. Move the cursor and 
the corner stretches with it. Locate the cursor in the new position for the corner and click the left hand 
mouse button again to release the corner. 
Clicking the right hand button before releasing the line, returns the corner to its original position. 

SplitBoundary > Delete Point 
Used to remove points (or corners) from isolation lines. 
Delete Point will not remove the end points of lines. 
Select SplitBoundary > Delete Point, then select the appropriate layer & secondary power rail from the dialogue 
bar. Point at a point (corner) in the isolation line and click the left hand mouse button. The point is removed. 
(If the planes have already been generated, this will not update the plane layer until the planes are re-
generated.)  

SplitBoundary > Import Line 
There are two reasons why this command is used: 

i) the power plane tool was altered in version 1.72 and when it is necessary to regenerate the split 
planes or run the artwork checks in designs saved in v1.71 or earlier, it is necessary to identify 
which split-plane polygon is associated with each secondary power rail, before the planes can be 
re-generated (the first time only) or the artwork checks run.  

ii) If the isolation lines on the layer have been altered using the Amend commands, these changes 
are not back-annotated to the powerplane tool.  

In each case, it is necessary to re-link the isolation lines to the appropriate power rail as follows: 
Select the appropriate layer & one of the secondary power rails from the dialogue bar. Select SplitBoundary > 
Import Line (this command remains greyed out until the secondary rail is selected).  The display changes and 
the boundary polygons appear as white lines.  
Select the polygon associated (or is believed to be associated) with the selected secondary power rail. If the 
correct polygon is chosen, the same-coloured dots will stop flashing and be replaced with heat-relief pads in that 
area. Move onto the next power rail. However, if the dots continue to flash, the incorrect polygon was chosen - 
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use Undo, then repeat until the correct polygon is selected. 
Once all the polygons for the layer have been imported, use the Generate button (or Powerplane > Generate 
command) to create the plane. 
Repeat for the other split-plane layers. 
Once completed, it is not necessary to import the polygons again. 

Powerplane commands (Setup & Generate) 
These commands (Setup and Generate) replicate the commands with the same name in the dialogue bar on the 
left side of the screen. They are described above under the heading Power Plane Dialogue Bar. 
 

Slots & Extra Holes (Tools > Slots & Extra Holes commands) 
These commands allow the insertion of slots (for CNC routing). They also allow arbitrary extra plated or non-
plated drill locations to be inserted. 
(The same commands are available within the custom pad and outline editors.) 
Figure 173 shows slots and extra plated/non-plated holes added to the artwork editor. 

 

Figure 173 

Long machined slots are often used to allow breaking out of a board from a larger panel or to produce cut-outs 
within the board..  

Break-out tabs may be inserted in the slots to assist “breaking out of a board” from a larger panel. The tabs may 
be solid or perforated (a series of close spaced small holes). Figure 174 

 

Figure 174 

The slots can be pre-drilled (to avoid damaging the router cutter) if required.  
A configuration panel CNC Tools & Datasets (found within the Configuration folder) allows pre-definition of all 
drills and routing tools needed for the board manufacture.   
When the board is manufactured, it is likely that the drilling and/or routing will be done in stages: 

• Drill holes/rout slots that need plating.  Board is then plated. 
• Drill holes/rout slots that are unplated. 
• If slots need to be routed separately, an extra stage(s) would be required. 
• Multilayer designs with blind/buried vias require extra stages, depending on the number 

of layers in use. 
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Each of these stages needs the drilling/routing data in a separate file.  To achieve this, the drilling/routing data 
for each stage is added to its own “dataset” which can be output on its own. 
Two datasets are pre-defined: 

DS1 - plated holes (through the board) 
DS2 - non-plated holes (through the board) 

Additional user-defined datasets may be defined, from DS3 onwards. 
 

Known limitations with this feature (in v2.25) 
• The artwork checker is currently “blind” to the presence of slotted features and extra holes added to the 

design, so this must be borne in mind when slots or extra holes are added – a warning is given when 
checking is selected. 

• Copper fill tool does not “see” slots or extra holes – temporarily add keepout areas around them. 
• Powerplane tool does not “see” slots or extra holes – add clearance/anti-pads manually using Amend. 
• Once a breakout is added to a slot, it is not yet possible to edit its parameters without deleting and 

recreating it. 
• Once an extra hole is added, it is not yet possible to alter its size or drill dataset without deleting and 

recreating it. 
• The 'Identify Feature' tool will not provide any information about slots and extra drill holes. 
• Undo/Redo does not work within the Slots & Extra Holes tool. 
• If a slot is defined in a component outline, then the tool cutting direction will be reversed if the part is flipped 

to the other side of the board. 
 

Opening older jobs (prior to v2.23) 
All router lines in v2.23 onwards must have a thickness assigned.  
Any router lines defined in versions prior to v2.22 would not have had a thickness assigned to them.   
For this reason, all router lines already in existence will be assigned a thickness of 0.1”/2.54mm when the job is 
opened. This will impact upon the edge of the profile or any cutouts defined, so remedial action will be required.  
Either reduce the size of the cutter, move the lines appropriately, delete the lines and re-define them or a 
combination of all the above – the option chosen will depend on the circumstances of each job. 
 

Slots & Extra Holes Dialogue bar 
When the Tools > Slots & Extra Holes command is selected, a dialogue bar appears, similar to that shown in 
Figure 175, which contains controls and settings for slots and extra holes, along with a new set of commands 
across the top of the window. 
If no slots/holes exist, then the bar indicates that no slots are defined, arrowed in Figure 175 and most settings 
will be greyed out. 
This manual describes each control/setting and command; a step–by-step procedure for adding/modifying slots 
and extra holes is given in a separate guide available from: http://www.seetrax.com/xld_docs.htm  
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Figure 175 

 
Paths 
This indicates if any paths (or slots) have been created - a path cannot be defined/drawn until it has been 
created. 
Figure 176 shows a portion of the dialogue bar prior to a path/slot being created, then with one created. Once a 
path has been created, the appropriate greyed out settings in the bar become editable. 
 

 

Figure 176 

The slots/paths are numbered for reference purposes.  
Use the Create button to add a new slot 
Use the up/down arrows alongside the slot/path to make any of the paths, the “active” slot.  
Once drawn, the active path/slot is shown with a dotted white centre line. The other inactive paths/slots will be 
shown with a dotted green line. 
The Active slot/path has its settings displayed in the dialogue bar. Set these according to the path/slot being 
added. They can be modified later and the active path/slot will be updated correspondingly.  
The path/slot is actually drawn/modified using the Slot Definition commands (in the command menu). 
Use the Delete button to delete a path/slot that is no longer required. Ensure the path to be removed is the 
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active path as described above before pressing the Delete button. The remaining path numbers are updated 
accordingly.  
There is no need to remove the drawn path before using this command as the drawn path will be removed 
automatically. 
 
Path Parameters 
The Path Parameters show the settings associated with the active path/slot as shown in Figure 177. 

 

Figure 177 

All of these settings can be changed whilst the slot is being drawn, or after the slot has been added. Changes 
affect the currently selected or “active” slot - the dotted line/arrows in the active slot will be white. 
Tool diameter:  the width of the active slot (Edit > Units to change between inches/mm) 

Type in a value (keep the cursor within the area) or choose from the drop-down list, 
which is populated from the CNC Tools & Datasets table (Configuration folder). 

Pre-drill Start Point: Pre-drilling can help reduce tool breakage - a hole is drilled before the router tool 
plunges into the board to cut the slotted path. 
The pre-drill size is specified in the CNC Tools & Datasets table (Configuration 
folder).  
To see the pre-drills in a slot, the size of the pre-drill in the CNC Tools & Datasets 
table must be defined. 
If a pre-drill size is not specified in the CNC Tools & Datasets table, then it will not be 
pre-drilled even if this box is ticked. 

 The pre-drill will appear at the start of each slot, and after each break-out within the 
slot if added. 

Reverse direction: The slot is routed in the direction in which the line is drawn unless the box is 
checked. The direction is indicated by the dotted line/arrows in the slot. (It’s easier to 
draw the path first, then change its direction if required.) 
The direction can be changed as it is important to obtain the best edge finish on the 
correct side of the slot. 

CNC Dataset: Each slot can be added to one dataset and this controls which drill/router output file it 
is included in. 
When the slots are output, they are output with other drilled holes and/or slots in the 
same dataset. Which dataset is chosen depends on the stage in the manufacturing 
process that they will be used.  
There are two pre-defined datasets, one for plated (DS1) and one for non-plated 
holes/slots (DS2).  
Other user-defined datasets are available and they are defined in the CNC Tools & 
Dataset table (Configuration folder). 
 Speak to the manufacturer if you do not know which slots to include in which 
dataset. 
 

Closed Path 
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Figure 178 

This feature is not currently coded so remains greyed out. 

Break-out tabs 

Break-out tabs stop the board falling out of a panel once routed.   
Either solid or perforated tabs can be inserted - Figure 179.  
 

 

Figure 179 

A perforated tab is made up from a small row of holes that form the weak point where the board will be broken 
out. 
Figure 180 shows the settings available for solid and perforated break-out tabs. 

 

Figure 180 

Note: currently (v2.25) these settings cannot be altered once the tab has been added, so if changes are 
required, the tab will have to be deleted and a new one added. 

 
Type: The breakout can be solid or perforated (as shown in Figure 179). 
Length: If a solid break-out tab is chosen, then a length for the tab has to be specified. 
Drill Diam: If a perforated break-out tab is chosen, then a size for the drill that will make the perforations 

has to be specified. 
Type in a value (keep the cursor within the area) or choose from the drop-down list, which is 
populated from the CNC Tools & Datasets table (Configuration folder). 

Quantity: The number of drilled holes within the perforated break-out tab. 
Stepping %: Is the distance between the perforation holes as a percentage of drill diameter, see Figure 

181. 
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Figure 181 

150% would mean that the holes are spaced apart by one and a half times the drill’s diameter. 
Note: 105% is the minimum value permitted to avoid tool breakage. 

Offset: The holes can be offset away from the centre line of the slot, see Figure 182. 

 

Figure 182 

0 the perforations are along the centre line of the slot 
100 the perforations have their centre line aligned with the edge of the slot (i.e they are 

displaced by half the slot width from its centre line). 
Think about positioning the perforations so they do not violate the edge of the board, 
whilst leaving the board with minimum cleanup required after it has been broken out. 

Swap Side: Makes the holes appear on the opposite side of the path, Figure 183. 

 

Figure 183 

Extra Holes 
These holes are typically added for tooling purposes, they can be plated or unplated but will not have copper 
surrounding them. 
In v2.25 it is not possible to edit extra holes, so to change their diameter or dataset, they must be deleted and 
reinserted – this will be rectified in a future release. 
Depending on the screen size, it may be necessary to scroll down to the bottom of the dialogue bar to see the 
Extra Hole settings, as shown in Figure 184. 

 

Figure 184 

Set the parameters as required: 
Drill Diameter: Size of hole required. Type in a value (keep the cursor within the area) or choose from the 

drop-down list, which is populated from the CNC Tools & Datasets table (Configuration 
folder). 

CNC Dataset Which CNC Dataset the hole should be included in. 
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Slot Definition > Add Line 
Used to add a line to define the active path/slot which is selected from the dialogue bar. 
Only one continuous line can be added per path. Multiple paths can be added. 
Ensure a path is selected in the dialogue bar (if 0 paths are shown, then use the Create button in the bar first).  
If a path is selected/active and the Add Line command remains greyed out, then there is already a path drawn 
for that path. 
Alter the settings in the Slots dialogue bar as required for the new path/slot. 
Select Slot Definition > Add Line, point at the location where the path will start and click the left button. Move the 
cursor, a line appears attached to it, representing the path of the cutter, from start to finish - ignore the position 
of break-outs as they are added later. 
Click the left button to insert corners in the line.  
Once the first segment has been drawn, the thickness of the slot, the pre-drill hole (if selected) and a dotted line 
with an arrow in the centre of the slot, which shows the cutting tool direction, will appear.  
These settings can be changed in the dialogue bar whilst the line is attached to the cursor if required. 
Draw the shape required; if necessary make the two ends coincident to form a closed shape.  
When complete, release the line from the cursor with a click of the right-hand mouse button. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The shape of the line can be modified using the Slot Definition > Corner/Adjust Arc/Delete point, etc. 
commands. 
Changes to the dialogue bar are reflected in the active path immediately. 

Slot Definition > Add Arc 
Used to add an arc(s) or a combination of arcs/lines to define the active path/slot which is selected from the 
dialogue bar. 
Only one continuous arc/line can be added per path. Multiple paths can be added. 
Ensure a path is selected in the dialogue bar (if 0 paths are shown, then use the Create button in the bar first).  
If a path is selected/active and the Add Arc command remains greyed out, then there is already a path drawn for 
that path. 
Alter the settings in the Slots dialogue bar as required for the new path/slot,  
Select Slot Definition > Add Arc, point at the location where the arc/line is to start and click the left button. Move 
the cursor and its attached line to the position where the curve should end, and click the left button again. A 
straight segment is produced that bends as the cursor is moved. The shape of the arc is dependent on the 
position of the cursor. This represents the path of the cutter, from start to finish 
Once the first segment has been drawn, the thickness of the slot, the pre-drill hole (if selected) and a dotted line 
with an arrow in the centre of the slot, which shows the cutting tool direction, will appear.  
These settings can be changed in the dialogue bar whilst the line/arc is attached to the cursor if required. 
Draw the shape required; if necessary make the two ends coincident to form a closed shape.  
Click the left button to release the curve in its current position. The line remains attached to the cursor, allowing 
a 
series of curves to be added. 
Once the arc has been released, clicking the right-hand mouse button releases the line from the end of the 
cursor. 
If the right-hand mouse button is clicked whilst the curve is being stretched, a straight-line segment is 
introduced, 
thus allowing a mixture of curved and straight lines to be added. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Arcs can be modified with the Slot Definition > Corner/Adjust Arc commands. 

Slot Definition > Add Circle 
Used to add a circle to define the active path/slot which is selected from the dialogue bar. 
Only one circle (or arc/line) can be added per path. Multiple paths can be added. 
Ensure a path is selected in the dialogue bar (if 0 paths are shown, then use the Create button in the bar first).  
If a path is selected/active and the Add Circle command remains greyed out, then there is already a path drawn 
for that path. 
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Alter the settings in the Slots dialogue bar as required for the new path/slot,  
Select Slot Definition > Add Circle, point at the centre of the required circle and click the left-hand mouse button. 
As the cursor is moved, a circle appears attached to it. The size of the circle is controlled by the cursor position. 
Click the left hand mouse button to release the circle in its current position. Clicking the right-hand mouse button 
whilst adding the circle cancels the circle. 
The thickness of the slot, the pre-drill hole (if selected) and a dotted line with an arrow in the centre of the slot, 
which shows the cutting tool direction, will appear.  
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The circle can be subsequently moved or modified with the Outline > Move Point command. 

Slot Definition > Corner 
Used to add or move existing corners in the active line/arc. 
Lines and arcs can only be selected if they belong to the active path as selected in the Slots dialogue bar. 
The active path is displayed with a white, dotted centre line along its length. 
Corners are added and released with clicks of the right-hand mouse button.  
Corners are moved and released with clicks of the left-hand mouse button. Once the corner has been selected, 
clicking the opposite mouse button cancels the operation. 

right button = add corner 
left button = move corner 
Opposite button cancels 

Adding a corner to a line or arc: 
Once selected, point at the line or arc and click the right-hand mouse button. Move the new corner and 
release it with another click of the same (right) button. Clicking the opposite (left) hand button before 
the 
corner is released, cancels the new corner. 

Moving an existing corner in a line or arc: 
Once selected,point at the corner in the line or arc and click the left-hand mouse button. Move the 
corner and release it with another click of the same (left) button. Clicking the opposite (right) hand 
button before the corner is released, cancels the move. 
 

Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Slot Definition > Move Point 
Used to move the active circle and/or to change its size.  
Circles can only be selected if they belong to the active path as selected in the Slots dialogue bar. 
The active path is displayed with a white, dotted centre line along its length/circumference. 
(the command can also be used to move an existing point (corner) in a line or arc, but the Profile > Corner 
command is more flexible.) 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Moving a circle: 

Once selected, move the cursor over the centre of the circle and click the left-hand mouse key. Move the 
cursor with the circle attached, into the required position and click the left-hand mouse button again to 
release it. 
Clicking the right-hand mouse button whilst the circle is attached to the cursor returns it to its original 
position. 

Changing the size of a circle: 
Once selected, point at the circumference of the circle and click the left-hand mouse key. As the cursor is 
moved, the circle's size changes. Click the left-hand mouse button again to release the circle at its current 
size. 
Clicking the right-hand mouse button whilst circle is attached to the cursor returns it to its original size. 

Moving points on lines or arcs: 
Once selected, move the cursor over the point (corner) you want to move and click the left-hand mouse 
key. 
Move the cursor with the corner attached into the required position and click the left-hand mouse button 
again to release it. 
Clicking the right-hand mouse button whilst the corner is attached to the cursor returns it to its original 
position. 



 

249 

Slot Definition > Adjust Arc/Circle 
Used to convert straight lines into curved lines, curved lines into straight lines, and to change the shape of 
existing curved lines; also to move a circle and/or to change its size.  
Lines/arcs/circles can only be selected if they belong to the active path as selected in the Slots dialogue bar. 
The active path is displayed with a white, dotted centre line along its length/circumference. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Straight lines into arcs: 

Once selected, point at an active line segment and click the left-hand mouse button. Move the cursor, the 
segment is replaced with an arc on the end of the cursor. Once the arc is in the required position, click the 
left-hand mouse button to release it. 

Arcs into straight line segments: 
Once selected, point at an active arc and select it with a click of the left-hand mouse button. Follow this with 
a click on the right-hand mouse button to convert it to a straight line segment. 

Changing the shape of an arc: 
Once selected, point at an active arc and select it with a click the left-hand mouse button. Move the cursor 
with the arc attached, then click the left-hand mouse button when the arc is in the desired position. 
Clicking the right-hand mouse button toggles the last selected line or arc between a line and an arc. The 
shape of the arc is defined automatically and can be used to convert 45 degree lines into quadrants of a 
circle. The direction of the arc is determined by the position of the cursor about the line when the button is 
pressed. 

Moving a circle: 
Once selected, move the cursor over the centre of the circle and click the left-hand mouse key. Move the 
cursor with the circle attached, into the required position and click the left-hand mouse button again to 
release it. 
Clicking the right-hand mouse button whilst the circle is attached to the cursor returns it to its original 
position. 

Changing the size of a circle: 
Once selected, point at the circumference of the circle and click the left-hand mouse key. As the cursor is 
moved, the circle's size changes. Click the left-hand mouse button again to release the circle at its current 
size. 
Clicking the right-hand mouse button whilst circle is attached to the cursor returns it to its original size. 

Slot Definition > Delete Feature 
Used to delete path of the active line/arc/circle. This does not remove the path from the dialogue bar, so a new 
line/arc/circle could be added to that path after the feature has been deleted.  
To remove the path and its entry in the dialogue bar, use the Delete button from the dialogue bar. 
The complete path is deleted, between its start and end points, not just a segment between points. 
Ensure the correct path is selected/active in the dialogue bar. If a path is selected/active and the Delete Feature 
command remains greyed out, then a path has not be drawn for that path. 
Select Slot Definition > Delete Feature, point at the line/arc/circle and click the left button, it will be deleted. 
Select the item on a corner, or the centre of the circle if there is difficulty slecting the item, also zoom in if 
necessary. 

Slot Definition > Delete Point 
Used to remove corners (points) from the path of the active line or arc. 
Once selected, move the cursor over a point (corner) in a line or arc and click the left-hand mouse button. The 
point is removed. 
A start or end point of a line cannot be deleted. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Breakout commands 
Break-out tabs may be inserted in the path/slot to assist “breaking out of a board” from a larger panel. The tabs 
may be solid or perforated (a series of close spaced small holes) and this is controlled from the Slots dialogue 
bar as described previously. 

Slot Definition > Add Breakout 
Select Slot Definition > Add Breakout position the cursor over the centre of the intended breakout position and 
click the left button. Repeat as required.  
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Slot Definition > Move Breakout 
Used to move a break-out tab. 
Break-out tabs, are selected about their centre, along the axis of the slot - see Figure 185, not on the breakout 
itself if it has been offset.. 

 

Figure 185 

 
Slot Definition > Delete Breakout 
Used to delete a break-out tab. 
Break-out tabs, are selected about their centre, along the axis of the slot - see Figure 185, not on the breakout 
itself if it has been offset. 

Extra Holes commands 
Standard pads of any shape or custom pads with a hole, have a copper area with a hole inside the area. When 
drilled, they are always output with Dataset 1 (plated). 
Extra Holes added using the Slots command menu are simply a hole – they do not have a copper area of any 
shape around them, though the hole itself can be plated through. They can be added to any drill dataset. 
The Extra Holes section of the Slots/Routed Path Designer dialogue bar (Figure 184) controls the settings of the 
hole being added. 

Extra Holes > Add 
Select Extra Holes > Add Hole, the hole appears attached to the cursor, position as required with a left click. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
The size of the hole and which drill dataset it is included in, is controlled from the Extra Holes section of the 
Slots/Routed Path Designer dialogue bar Figure 184.  
(In version 2.25 of the software, once the hole has been added it cannot be changed, so delete the hole and re-
add if a change of size/drilldataset is required.) 

Extra Holes > Move 
Used to move a hole that’s already been added using the Extra Holes > Add command (not pads). 
When the hole is selected, the dialogue bar is updated to reflect the size/dataset of the selected hole (which 
cannot be changed whilst the hole is being moved in v2.25). 
Select Extra Holes > Move Hole, point at the centre of the hole and click the left hand mouse button. The hole 
moves with the cursor. Move the hole into position and click the left hand mouse button again to release it. 
Clicking the right hand mouse button whilst the hole is attached to the cursor returns it to its original position. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Extra Holes > Delete 
Used to delete a hole that’s already been added using the Extra Holes > Add Hole command (not pads). 
Select Extra Holes > Delete Hole, point at the centre of the hole and click the left hand mouse button. The hole 
is removed. 

Network commands  
The following Information applies to all the Network commands: 
These commands are used to add parts or connections to the artwork, or change connections on the artwork 
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without editing the wiring list.  
The changes are automatically back annotated to the parts and wiring lists. 
The artwork checks take these changes into account when checking the artwork.  
The circuit schematic is NOT updated. 
A log report is generated to allow the circuit schematic to be manually back annotated. The report is saved in 
the Log Files folder. The report is called netmods. 
When the circuit schematic is viewed, providing the netmods log report has not been deleted, a warning 
message is given to indicate that it may not match the parts/wiring list, and to refer to the netmods file for 
details. 
It is IMPORTANT that the changes are added to the circuit schematic before the parts/wiring list is extracted 
from the circuit again. Failing to do this, means the changes made via the Network commands will be lost from 
the new parts/wiring list.  
If that happens, the changes made via the Network commands will be lost and any tracks that remain on the 
board will be treated as shorts (unless they don't touch anything) by the artwork checking routines.   
Once the changes have been implemented on the circuit, the log report should be saved if required and the 
original deleted, otherwise the warning message will keep re-appearing when entering the circuit schematic. 
Once the changes have been added satisfactorily, the circuit can be recompiled. 

Tools > Network > Add Part 
Used to add a new part to the layout and the parts list. A part prefix and number plus an outline has to be 
specified for the new part, the part is then listed in the tray ready to be placed on the artwork. 
To aid selection, the prefix can be selected from those already defined in the design and the first available 
number for that prefix appears automatically (can be changed). The outline for the part is selected from a list. 
The list of outlines is made up from the outlines held in the design outline library and any others from the master 
outline library that are not already held in the design. If an outline from the master library is selected, a copy is 
automatically transferred to the design library when the part is added. 

To add a part: 
Select Tools > Network > Add Part, a window appears similar to that shown in Figure 186. 

 

Figure 186 

Select the down-pointing arrow alongside the Part reference setting and select the part prefix required from the 
list that appears. The number alongside is automatically set to the first unused number available - this can be 
changed if required using the spin controls alongside or by selecting the number and typing in the number 
required (duplicate references will not be accepted). Use the down-pointing arrow alongside the Outline setting 
to choose the outline for the part from the list available. 
Select the Add Part button when the window is set as required. The part is added to the placement tray. More 
parts can be added as required until the window is closed, by selecting the Close button. 

Tools > Network > Test Points Setup 
Used to control the part prefix and component outline used when test points are automatically added to the 
design.  
When selected, a window appears similar to that shown in Figure 187. 

 

Figure 187 
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There are two settings: 
Test Point Part Prefix Specifies the prefix that will be used for the auto-generated test points.  

It can be a prefix in use already or a new one.  
If a prefix that is not already defined in the part prefix table is specified, then the new 
prefix will be added to the part prefix table when the test points are added to the 
design.  
The testpoints will be added starting from reference 1. For example if TP is specified 
as the part prefix, then the test points will become TP1, TP2, TP3, etc. 
If a used prefix is specified, then the new test point references will fill in any gaps in 
the existing references, then be added to the end. For example, if TP is specified as 
the part prefix and TP’s 1, 3, 5 and 7 are already on the design, then the new test 
points will become TP2, TP4, TP6, TP7, TP8, etc. 

Test Point Outline  Specifies the component outline that will be used for the auto-generated test points. 
An outline that doesn’t exist can be specified in this setup window, but the test points 
cannot be added to the artwork until the outline exists within the design’s component 
outline folder. 

Once the required prefix and outline have been specified, the test points can be added to the design, using the 
Tools > Network > Test Points command. 

Tools > Network > Test Points 
Used to automatically add test points to the design. This command will add a test point to each user-selected 
net, which can be placed as required and routed. Unused (unplaced) test points can also be removed 
automatically using this command.  
The test points appear in the parts and wiring list automatically and a report is provided so that the schematic 
can be updated manually. 
Before using this command, ensure the Tools > Network > Test Points Setup window is set as required.  

Using the test point generator 
Typically test points are added once the layout is complete, as it is often unnecessary to add a test point to 
every net.  
Note: if a circuit diagram has been drawn, it is easier to update the circuit and know that it is correct, if the 
artwork has been completed and checked with no errors reported before you add the test points. 
Assuming the artwork is complete and correct (although this is not necessary, see note above), select Tools > 
Network > Test Point Setup. Specify the part prefix and outline to be used for the test points.  
Select Tools > Network > Test Points. A window appears similar to that shown in Figure 188. 
 

 
Figure 188 

The right hand side lists all the test points currently in the design (if any) and their locations. 
The left-hand side lists all the named nets in the design. Tick boxes below the list allow the unnamed nets and 
power nets to be added to the list if required.  
To add a test point to one of the nets in the list, select the net, then select the Add TestPoints button. A test 
point appears in the list in the right-hand side of the window and the net is removed from the left.  
Repeat for any other nets that require test points.  
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Groups of, or all the nets can be selected by holding down the left hand button over a net and moving the 
mouse up/down, to highlight them, let go of the button, then select Add TestPoints.  
Select OK once all the test points required have been added.  
The placement tray appears in the artwork editor allowing the new test points to be placed as required and then 
the connections routed. 

Removing unwanted test points 
Test points that have been added to the tray but un-required can be left in the tray (or returned to the tray if they 
were placed) and removed. 
Open the test point generation window (Tools > Network > Test Points), the right hand side of the window 
indicates which test points have been placed along with details about position, side of the board and whether 
the net has been routed, it also lists the unplaced test points. 
Select the Delete Unplaced button to remove all the unplaced test points from the design - the nets that the 
unplaced test points were connected to will re-appear in the left hand side of the window and test points can be 
added to those nets in the future if required. 

Back Annotation and Other Information 
The Undo/Redo commands can be used to undo/redo these actions if required (once the test point window is 
closed).  
The parts/wiring list is automatically updated.  
If the artwork checking routines are run after the test points have been added, and provided all the required test 
points have been placed and routed and unrequired test points removed, there should be no errors reported 
(provided there were none to start with).  
Upon entry to the hierarchical schematic editor a warning will appear to indicate that the circuit and parts/wiring 
list may not match. Note: if a p/w list is extracted from the circuit at this stage, all the added test points will be 
removed from the parts/wiring list and removed from the artwork (the tracks will remain) as they are not present 
on the schematic.  
Open the Log Files folder from the navigator and open the netmods file. A report appears listing all the parts and 
connections that have been added.  
This report should be used to update the schematic. 
If the p/w list is extracted once the changes to the schematic are complete, the artwork checking routines should 
not report any additional errors. If there are errors, then the schematic hasn't been updated correctly. 

Tools > Network > Add Link 
Used to add a connection (link) to the layout and the wiring list. Refer to the notes under the Network commands 
heading for details on updating the schematic. 
If the connection is added to an existing signal, the new connection uses the same track size code. If the new 
connection is being added between unconnected pins, a prompt appears requesting the track size code for the 
new connection. 
Select Tools > Network > Add Link, then select the component pin where the connection will start from. As the 
cursor is moved, a connection stretches with it. Once the connection has been started but not released, clicking 
the right hand mouse button cancels it. Select the component pin where the connection is to end. If either of the 
pins is already connected, the connection is inserted with the same size code. If both pins are unconnected, 
then a window appears requesting the size code for the new connection. If <enter> is pressed before changing 
the size code, the default signal track size code as displayed in the window is used.  
The connection should be routed in the usual way. 
A warning message is posted in the status bar if an attempt is made to add a connection to an unassigned pin. 
For instance to an unassigned mounting hole on a connector. The connection will not be made.  

Tools > Network > Delete Pin 
Used to delete all the connections from a pin and update the wiring list. Refer to the notes under the Network 
commands heading for details on updating the schematic. 
If the selected pin is connected to just one other pin, the connection is removed and both nodes are removed 
from the wiring list. 
If the selected pin is part of a larger net, the net is reconnected so that it is not split in two. This can cause 
routed tracks to be returned to connections. For instance, take a situation where pins 1 and 2 and 3 are 
connected and routed in that order. If pin 2 is selected, the tracks will be removed and a connection inserted 
between pins 1 and 3. The wiring list will show pins 1 and 3 as connected. 
Select Tools > Network > Delete Pin, then select the pin that the connection(s) will be removed from. 

Tools > Network > Move Node 
Used to move all the connections from one pin to another pin and update the wiring list. Refer to the notes under 
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the Network commands heading for details on updating the schematic. 

Connections are moved from one pin to another, they are not swapped. For instance, if a connection is moved 
to a connected pin, there will be two connections attached to that pin and the first pin will be unconnected. 
Connections may be moved to either unconnected or connected pins. If a connection is moved to a connected 
pin, it becomes part of that net.  
Once the move has taken place, the signal connections are automatically reconnected to show the shortest 
connection path, as defined by the Manual Routing Parameters window. Refer to the Parts > Reconnect Power 
command for details on reconnecting power connections. 
Routed tracks are converted back to connections when they are moved. 
Select Tools > Network > Move Node, then select a connected pin. As the cursor is moved, a line stretches from 
the selected pin to indicate which pin was selected. Select the pin that  the connection(s) will be moved to. The 
move takes place. 

Tools > Network > Pin Swap 
Used to swap connections between pins and update the wiring list. All the connections attached to one pin are 
swapped with all the connections on another pin. 
Refer to the notes under the Network commands heading for details on updating the schematic. 
The pins do not have to be equivalent to allow the swap to take place - this is not pin swapping between 
equivalent pins - this command will change the electrical functioning of the circuit (refer to Parts > Pin Swap for 
pin swapping equivalent pins).  
Routed tracks are converted back to connections when they are swapped. The signal connections are 
automatically reconnected according to the settings in the Manual Routing Parameters window after the swap 
has taken place. Refer to the Parts > Reconnect Power command for details on reconnecting power 
connections. 
Select Tools > Network > Pin Swap, then select a connected pin. As the cursor is moved, a line stretches from 
the selected pin to indicate which pin was selected. Select the connected pin that it will be swapped with. The 
swap takes place. 

Tools > Network > Set Net Name 
Used to rename a net on the artwork and in the wiring list. Refer to the notes under the Network commands 
heading for details on updating the schematic. 
Either a connection or track can be selected, the change affects the complete net. 
When the new name is selected, if the name is already in use by another net, then a warning window appears. 
The rename can be confirmed or cancelled. If the rename is confirmed, the selected net is NOT linked to the 
other net with the same name. 
It is possible to "join" the two nets together if required and this is achieved using the Tools > Group Signal 
Names command whilst the net list editor is open. Until that time, the two nets are treated separately and if they 
are shorted together on the artwork, this will cause a short-circuit error when the artwork is checked. 
Every net on the artwork has a name. Because signal names assigned by the user are optional, Ranger assigns 
its own id to each net.  Ranger's assigned names start at R0016 and proceed numerically, R0017, R0018, etc.  
(The auto-assigned names can be viewed from the net list editor if required.) 

To change a net name: 
Select Tools > Network > Set Net Name, then select the track to be renamed. A window appears showing the 
Nets Current Name and with a space for the New Net Name to be typed.  
The current name setting is set to the net's user-assigned signal name, whilst unnamed nets show their Ranger-
assigned name. Once the new name has been typed, select OK to proceed. 
Note: If OK is selected and a new name has not been typed, the net retains its Ranger-assigned name but its 
user-assigned signal name is removed (if it had one). 
Take care when using UNDO after this command has been used - the undo will take place but there is no visual 
indication of what has been "undone". 

Silk-screen 
The silk-screen outline definitions are added to the component outline using the outline editor.  
When the parts are placed on the artwork, a visual representation of the silk-screen outline and the labels can 
be displayed (View Control dialogue bar), but these are not the actual silk-screen outlines or labels that will 
appear on the finished board. They are used for identification purposes only and cannot be modified. 
The silk-screen outlines and labels have to be added to a silk-screen layer of the board. This can be achieved 
automatically from within the artwork editor using the Tools > Generate silk-screen command. 
Typically, the silk-screen layers are not created until all the placement, routing and part renumbering is 
complete, but they can be generated at any time. 
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Data added to the silk-screen layers can be checked to ensure the text or lines do not cover pads/holes on the 
outer copper layers and that the text is outside the area occupied by the auto-placement footprint. 

Silk screen information 
The silk data can be generated at any time, but it is typically created once the layout is complete. 
When the silk-screen layers are generated, the silk screen labels and outlines are added to user-specified layers 
of the board. This allows the labels to be moved using the Text commands, and the outlines to be modified 
individually using the Amend commands if required. It does not matter which layers are used, providing they are 
not used for anything else. 
The labels are positioned automatically on the datum of each part. (Do not be tempted to move the position of 
the datum points within each outline, because this will have the affect of moving the parts on the board.) The silk 
screen labels can subsequently be moved using the Text > Move command. 
When the silk-screen data is generated, the selected layer(s) is reassigned to a silk-screen layer if it is not 
already defined as one.  
it is assumed the silk screen data is made from a non-conducting material so no connectivity checks are made 
on silk-screen layers. However, checking routines are available which indicate whether silk-screen data covers 
pads/holes on the outer copper layers and whether the text is inside the area occupied by the auto-placement 
footprint.  
Tip: Modifications to the board in the future will be made easier if the silk screen outlines and labels are added 

to different layers. (The layers would obviously need to be output together.) This is because when the 
outlines (not labels) are generated, all the data from the specified layer is removed first. If the labels are 
on the same layer, the time spent moving them into position will have been wasted. Adding the labels to a 
different layer means that the outlines can be re-generated if a modification has been performed, without 
affecting the silk screen labels. 
When the silk-screen labels are generated, they are added to existing data on the chosen layer. This 
means that once the silk screen labels have been generated, they should not be auto-generated again 
even if new parts have been added to the artwork, otherwise duplicate labels will be produced for the 
original parts. Instead add extra labels using the Text > Get Label command. Redundant labels can be 
deleted using the Text > Delete command. This method is less time consuming than regenerating the 
labels and having to re-position them again. 

Free layers 
The Tools > Generate silk-screen command is also used to add data from the "free layers" as defined in the 
component outline editor, to user selected layers in the artwork. 

Free layer information 
Using the component outline editor, outlines can have additional pads and tracks added on upto 8 free layers, 
which are given user-defined names. When the outlines are placed on the artwork, the free layer information is 
not seen or present, until it is generated via the Tools > Generate silk-screen command, at which time it is 
placed on user-selected layers within the artwork editor. 
It does not matter which layer numbers are selected for the "free layer" data, providing they are not used for 
anything else, as the data is added to existing data on the layer. 
When the free layer data is generated, the selected layer(s) is converted into a silk-screen layer if it is not 
already defined as one.  
Although the free layer data was added using the Copper commands in the outline editor, it is defined as silk 
screen data when it is added to the artwork.  

Generating the silk screen data and/or "free layer" data. 
From within the artwork editor, select Tools > Generate silk-screen. A window similar to the one in Figure 189 
appears. The Outline Free Copper section of the window is not active unless there are some outlines on the 
artwork that have free copper in them. 
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Figure 189 

This window should be setup as required, using the following information for guidance. 

Component screen and Label Insertion 
Component labels silk screen labels for all parts that are un-flipped in the artwork editor. 
Component outlines silk screen outlines for all parts that are un-flipped. The outline shapes and the size of the 

lines are defined via the component outline editor. 
Flipped labels silk screen labels for all parts that have been flipped. 
Flipped outlines silk screen outlines for all parts that have been flipped. The outline shapes and the size of 

the lines are defined via the component outline editor. 
Important note: all the un-flipped parts are not necessarily on the top of the board and all 
the flipped parts are not necessarily on the bottom of the board.  
Un-flipped parts are placed on the side of the board as defined in the outline library. In the 
case of surface mounted parts, they can be defined on the top or bottom of the board. If 
the pads are placed on the bottom of the board in the outline, then this part when it's un-
flipped in the artwork will be on the bottom of the board. It's therefore important to define 
all outlines from the same side, usually the top to ensure that all flipped parts are on the 
same side of the board. 

Layer  Indicates which layer the silk-screen data for that category will be added to, providing the 
category is selected/ticked. 
Bear in mind that the component outlines and flipped outlines overwrite data already on 
the selected layer, so ensure you choose an appropriate layer.  
Use the spin controls to select the layer required. The coloured boxes indicate the colour 
of the selected layer, which may help you. 
Layers V, T and B cannot be used.  

Check-box  Between each of the above settings is a check-box. To indicate that the labels or outlines 
for parts and/or un-flipped parts should be generated, the check-box should be ticked. If 
the box is not ticked, then that category of data will not be generated. 

Text Height Specifies the height of the characters that form the silk screen labels.  
Line size Specifies the track code which will be used to form the characters in the labels. The actual 
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size related to this code is displayed underneath the code. (The line size for the outline is 
defined within the component outline definition.) 

Add component description to labels 
If this option is selected/ticked, then the value assigned in the "Type" field of the parts list 
is also added to the layer that the silk-screen labels are added to, for each part. If the 
labels are not included, then this setting has no effect. 
The setting alongside allows selection of the whole type field, part of the field up to the 
comma, or part of the field after the comma. (In an auto-generated parts list the Type field 
is made up of: "partname,value" for example R0.25W,10k. So either R0.25W,10k will 
appear, R0.25W or 10k depending on the setting chosen. ) 
The value is added as a separate text string that can be moved independently of the 
labels. 

Outline Free Copper 
This part of the window only becomes active if at least one outline on the artwork has some free copper defined 
within it. 
Each named free copper layer is listed, with a section for unflipped parts and one for flipped parts.  This allows 
layers to be created with reference to the side the parts are placed on. For example, when generating the top 
solder paste layer (if defined in the outline), then you would not want the bottom mounted parts included. 
To add the "free" data from the outlines onto the artwork, choose an appropriate layer (typically one that's not 
used by anything else) and tick the box alongside for each layer to be generated. 

Generating the data 
Once the window has been filled out as required, select Generate to create the data on the selected layers. A 
window indicates the generation is complete, select OK to continue.  
Create more silk-screen/free layers as required or Close the window.  
If selecting the Generate button more than once, ensure that label layers or free layers are not selected again 
(remove the tick) or duplicate labels and "free copper" will be created on the layer. 
When the window is closed, the layout is re-drawn and the data appears. If you cannot see it, ensure the layers 
are visible using the View Control dialogue bar. 

Modifying the silk-screen and/or free copper 
The silk screen labels can be moved using the Text > Move command. Generally, the labels are moved so that 
they can be seen on a populated board, and are not covering through plated holes or component pads. 
The text (labels and descriptions) can be edited/resized using the Text commands. 
The silk-screen outlines and data added to the "free layers" can also be modified if required using the Amend 
commands. 
To remove all the silk-screen data from a layer, use the Region  > Delete command with only that layer 
selected. 
Additional text can be added to the layer as required using the Text commands. 
If a label is accidentally deleted, use the Text > Get Label command to re-insert it. 

Modifications to completed designs 
At some stage in the future it's likely that a completed artwork will have parts added or removed which will mean 
the silk-screen outlines and labels have to be updated. 
If the labels and outlines have been added to separate layers as advised, this can be accomplished quite easily. 
Simply re-generate the silk-screen outlines as described previously (on to the same layer), the existing outlines 
will be removed (along with anything else on that layer) and the "new" set added. 
Do not re-generate the labels – unless duplicate labels for all the existing parts are required. Use the Text > Get 
Label command to add the new part labels and the Text > Delete command to remove unwanted labels. This 
method is usually less time consuming than starting from scratch, for example by Window deleting the existing 
labels and re-generating them, as all the labels will have to be moved into position again. 
If the labels and outlines were added to the same layer originally, then this will prove more time consuming. 
When the outlines are regenerated on the same layer, all the existing data is removed so you will lose all the 
labels. When regenerating the labels, put them on a different unused layer. 
The alternative is to manually amend the existing silk-screen outlines by deleting the unwanted outlines and 
drawing in the new ones (using the Amend commands) and removing and adding the labels using Text > Delete 
and Get Label commands. Note: if the manually drawn outlines do not exactly match the original outline defined 
in the outline library, the silk-screen outline will not move if the outline is subsequently moved. 
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Tear drop pads 
A "teardrop" widens a track as it enters a via pad, as shown in Figure 190. This facility can be quite useful if vias 
with very small copper areas are used, since the extra copper attached to the via can stop them peeling off the 
board. 

 
Figure 190 

Teardrops should be added once the tracking is complete. If modifications have to be performed to the board, it 
is best to delete the teardrops first. 
Once teardrops have been added to the board, the artwork checking routines should be run to ensure errors 
have not been introduced.  
The teardrops can be modified using the Amend commands.  

Creating the teardrops 
From within the artwork editor, select Tools  > Teardrop Pads. A window appears similar to that shown in Figure 
191. 

 

Figure 191 

Select Generate Teardrops to insert the teardrop pads. A report appears in the window to indicate how many 
tear drop pads have been added to each layer.  
Once the teardrops have been generated, close the window. The teardrops will be seeen on tracks leading to 
vias. 
Run the artwork checking routines to ensure errors were not introduced. 

Deleting teardrops 
From within the artwork editor, select Tools  > Teardrop Pads. A window appears similar to that shown in Figure 
191. Select Delete Teardrops. A report appears in the window to indicate how many tear drop pads have been 
removed from each layer.  
Once the teardrops have been generated, close the window.  
Only the teardrops are deleted, the vias remain. 

Parts commands 
Before parts can be placed on the board, they must appear in the tray. 
Parts are always selected by their datum. This is indicated by the position of the part's label. Part labels are 
shown in yellow for parts that are unflipped (typically mounted on the top of the board), and in cyan for parts that 
are flipped (typically mounted on the bottom of the board). The labels of flipped parts have their labels slightly 
offset, a tail extends to the datum point. This allows the labels to be read more easily when parts are mounted 
directly over the top of one another. Part labels can be switched on and off using the View > Part Labels/Setup 
Visibility command. 
The left mouse button is used to select parts that are unflipped. The right mouse button is used to select flipped 
parts. However, when the artwork is displayed in “flipped/mirrored” mode, the sense of the buttons becomes 
reversed making it easier to position parts when working on the back of the board. 
Each command is described individually as follows: 

Parts > Place 
Used to manually transfer parts listed in the tray onto the board. The tray is visible when the Parts > Place 
command is selected (though it can be hidden - refer to the View > Navigator/Browser/Properties command for 
details). 
Before parts may be manually or automatically placed on the board, they must appear in the tray. When the tray 
is open parts can be added to, and removed from it. 
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During manual placement, parts appear on the end of the cursor in the order that they appear in the tray, but 
this can be overridden. This allows the user to control which parts are placed, and in what order.  
During auto-placement, parts are added according to the settings in the Autoplace dialogue bar. 

Controlling the tray 
Select Parts > Place, the tray appears as shown in Figure 192 - it’s empty to start with. It has four commands 
that are used to control the parts that are added to the tray, Add, Delete, Sort and Empty. 

 

Figure 192 

Tray commands - Add 
Used to add parts to the tray in preparation for placement. When selected a window similar to the one in 
Figure 193 appears. 

 
Figure 193 

 
Parts may be added to the tray by typing in their part reference (IC1, R1, etc.) in the Add by Part Ident 
expression dialogue, then selecting Add to Tray from alongside.  The wildcards * and ? can be used to 
represent a group/range of parts. For example * represents all parts, IC* all IC's. IC? will select IC's with 
one numeric value (IC1-9), IC?? will select IC's with two numeric values (IC10-99), etc. All parts with idents 
matching the entered expression will be placed into the tray. 
Alternatively, the parts that should be added to the tray can be selected from the list, then the buttons in the 
Manual Part Selection area of the window used as follows: 
To select a part either, select the part so that it highlights, then select the Select button, or double-select the 
part quickly. A double asterisk (**) alongside the part indicates it’s selected. A group of parts in the list can 
be selected by pointing at a part, then holding down the left button, then moving the cursor up or down - the 
parts high-light - then select the Select button.  
Parts can be deselected in the same way with a double-click or using the DeSelect button. 
Once a/some parts are selected, select the Add to Tray button to transfer them to the tray. 
The order that the parts appear in the list is controlled by the Sort/Filter by parameter as follows:  

Ident  lists the parts in alphabetical/numeric order using the Ident field (A1, A2, A3, B1, B2, C1, 
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C2, etc.) to sort by. 
Outline  lists the parts in alphabetical/numeric order using the Outline field to sort by. 
Description  lists the parts in alphabetical/numeric order using the Description field to sort by. 

The Filter button can be used to further filter the list. For example, set the Sort/Filter by parameter to 
Outline, then type CAP in the box between the Select and Filter buttons. Select the Filter button to action 
the filtering. Any outlines with CAP in their name will appear in the list. Select the Unfilter button to restore 
the complete list. 
This facility is useful on larger designs.  

Tray commands - Delete 
Used to delete parts from the tray - the parts are not deleted from the design and can be re-added to the 
tray as required. The part must be selected, then the Delete button selected. 

Tray commands - Empty 
Used to delete all the parts from the tray. The parts are not deleted from the design and can be re-added to 
the tray as required. 

Tray commands - Sort 
Used to sort the parts in the tray into alpha-numeric order.  

Placing the parts 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Only parts that appear in the tray can be placed.  
Select Parts > Place, as the cursor is moved, the first part listed in the tray appears attached to it. Its ident is 
displayed in the status bar. If the part has been assigned to an EMC group on the schematic, then the group to 
which it belongs is also shown in the status bar. 
Clicking the left mouse button releases the part at the current mouse position, the next part in the tray attaches 
itself to the cursor. As the part is moved, its name is highlighted in the tray. The name is removed from the tray 
once the part has been released on the board.  
Parts appear attached to the cursor in the order they appear in the tray. The placement order can be altered by 
selecting any of the parts listed in the tray, placement continues from that part onwards. 
As the parts are moved, their signal connections are automatically reconnected, as defined by the Manual 
Routing Parameters in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Clicking the right hand mouse button stops the placement process. The part that was attached to the cursor 
remains in the tray. 
If the part labels are visible (View Control dialogue bar) the label will appear at the parts datum position – this is 
not the silk-screen label and is shown purely for identification purposes. 

Parts > Unplace 
Used to remove parts from the board. The parts are returned to the tray for subsequent re-placement. The parts 
are not removed from the design. 
Only unrouted parts can be removed. Use the Mroute > Ripup command to convert tracks back to connections. 
Unflipped parts (typically mounted on the top of the board) should be selected with a click of the left mouse 
button. Flipped parts (typically mounted on the bottom of the board) should be selected with a click of the right 
mouse button. 
(When the artwork is displayed in “flipped” mode, the sense of the buttons should become reversed, but this is 
not the case in versions upto v2.22 and possibly beyond, check the readme.txt file for details of changes made 
after the date of this guide.) 
Select Parts > Unplace. Select the datum of the part to be removed - the part label if visible (View Control 
dialogue bar) indicates the part’s datum position.  

Parts > Move 
Used to move parts that have already been placed on the board. 
Unflipped parts (typically mounted on the top of the board) should be selected with a click of the left mouse 
button. Flipped parts (typically mounted on the bottom of the board) should be selected with a click of the right 
mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes reversed.) 
Once a part is being moved, the opposite mouse button can be clicked to cancel the move and restore the part 
to its original location. 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
As the part is moved, its ident is displayed in the status bar and If the part has been assigned to an EMC group 
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on the schematic, then the group to which it belongs is also shown in the status bar. 
Connectivity is maintained when parts are moved, whether the connections are routed or unrouted. 
As the parts are moved, their signal connections are automatically reconnected, as defined by the Manual 
Routing Parameters in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Reconnection does not take place on partially routed connections or tracks. 
When a routed part is moved, the routed tracks will probably cause clearance violations when the part is 
released. In these situations, it is probably easier to unroute the last track segment going to each pin before 
moving the part to make re-routing easier, using the Mroute > Ripup command. 
Select Parts > Move. Select the datum of the part to be moved with the appropriate mouse button, then move 
the cursor and the part to its new position and click the same mouse button to release it. 
Clicking the opposite mouse button as the part is being moved, returns it to its original position. 
The part label if visible (View Control dialogue bar) indicates the part’s datum position. 

Parts > Key Move 
Used to move and/or rotate parts to specific positions on the board, by entering co-ordinates. 
Co-ordinates can be entered in imperial or metric units providing the required units are selected prior to 
selecting the part (Edit > Units). 
Connectivity is maintained when parts are moved and/or rotated, whether the connections are routed or 
unrouted. 
When the part is moved and or rotated, unrouted signal connections to it are automatically reconnected 
according to the settings in the Manual Routing Parameters window in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Reconnection does not take place on partially routed connections or tracks. 
When a routed part is moved and or rotated, the routed tracks will probably cause clearance violations. In these 
situations, it is probably easier to unroute the last track segment going to each pin before moving or rotating the 
part to make re-routing easier, using the Mroute > Ripup command. 
Unflipped parts (typically mounted on the top of the board) should be selected with a click of the left mouse 
button. Flipped parts (typically mounted on the bottom of the board) should be selected with a click of the right 
mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes reversed.) 
Select Parts > Key Move. Point at and select the datum of the part to be moved. A window appears containing 
the part's name, its current X, Y position and its angle of rotation. 
The part label if visible (View Control dialogue bar) indicates the part’s datum position. 
The angle of rotation is specified in degrees anti-clockwise. 0 degrees is the orientation of the outline in the 
library. 
To change any of the values, select the value to be changed and enter the new one. Once the appropriate 
values have been changed, select OK to implement the change. 
Select Cancel to leave the part in its original position. 

Parts > Rotate 
Used to rotate parts in 90 degree increments anti-clockwise. Use Parts > Key Move to rotate parts in increments 
of 1 degree. 
Unflipped parts (typically mounted on the top of the board) should be selected with a click of the left mouse 
button. Flipped parts (typically mounted on the bottom of the board) should be selected with a click of the right 
mouse button. 
Connectivity is maintained when parts are rotated, whether the connections are routed or unrouted. 
Unrouted signal connections to the part are automatically reconnected according to the parameters in the Edit > 
Manual Routing Parameters window when the part is rotated.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Reconnection does not take place on partially routed connections or tracks.  
When a routed part is rotated, the routed tracks will probably cause clearance violations. In these situations, it is 
probably easier to unroute the last track segment going to each pin before rotating the part to make re-routing 
easier, using the Mroute > Ripup command. 
Select Parts > Rotate, then point at and select the part's datum. Each click of the mouse button rotates the 
selected part anti-clockwise by 90 degrees. 
The part label if visible (View Control dialogue bar) indicates the part’s datum position. 

Parts > Flip 
Used to flip surface mounted parts from one side of the board to the other. 
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Parts are flipped about their original Y axis, as defined in the outline library. For instance, parts are turned left to 
right about their datum, unless they have been rotated by 90 or 270 degrees first, in which case they are turned 
from top to bottom about their datum. 
Unflipped parts are selected with a click of the left mouse button. Flipped parts are selected with a click of the 
right mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes 
reversed.) 
Connectivity is maintained when parts are flipped, whether the connections are routed or unrouted. 
When the part is flipped, unrouted signal connections to it are automatically reconnected according to the 
settings in the Manual Routing Parameters window in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Reconnection does not take place on partially routed connections or tracks. 
If the part has routed connections going to it, the last segment of the track is ripped up and becomes a partial 
unroute when the part is flipped, otherwise the track would become disconnected from the pad. 
Select Parts > Flip, then point at and select the datum of the part to be flipped. The part must now be selected 
with the opposite mouse button as it is mounted from the opposite side of the board. 
The part label if visible (View Control dialogue bar) indicates the part’s datum position. 
This command can also be used to introduce additional copper on parts that have had their outlines swapped 
using the Parts > Change Outline command, or to restore stringers that have been ripped up. (Use flip twice to 
restore the part to its original layer.) 

Parts > Swap 
Used to swap the position of two parts, one with the other. The parts do not have to be identical, be on the same 
side of the board, or have the same number of pins. 
If either part has routed tracks connected to it, the tracks must be completely unrouted before the parts can be 
swapped, using the Mroute > Ripup command. 
Outlines that have additional copper attached are regarded as partially routed. The copper will have to be ripped 
up using the Mroute > Ripup command before using the swap routine. Once the parts have been swapped, use 
the Parts > Flip command twice to restore the copper and the part to the correct side of the board. 
Connectivity is maintained when parts are swapped.  
When the parts are swapped, unrouted signal connections to them are automatically reconnected according to 
the settings in the Manual Routing Parameters window in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Unflipped parts are selected with a click of the left mouse button. Flipped parts are selected with a click of the 
right mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes 
reversed.) 
Select Parts > Swap, select the datum of the first part with the appropriate mouse button, it highlights. Now 
select the datum of the part it is to be swapped with, with the appropriate mouse button. The parts swap their 
positions over.  
The part label if visible (View Control dialogue bar) indicates the part’s datum position. 

Parts > Align X/Y 
Used to align parts in either the X or Y axis by their datum. The X axis is the vertical axis, and the Y horizontal. 
When positioning the reference axis (line), it will snap to part datums unless the cursor is located away from a 
part, in which case it will snap to grid/half grid if grid snapping is switched on.. 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Connectivity is maintained whether the parts are routed or unrouted. Typically, parts are aligned before any 
routing is performed. 
When the parts are aligned, unrouted signal connections to them are automatically reconnected according to the 
settings in the Manual Routing Parameters window in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Reconnection does not take place on partially routed connections or tracks.  
When a routed part is moved, the routed tracks will probably cause clearance violations. In these situations, it is 
probably easier to unroute the last track segment going to each pin before moving the part to make re-routing 
easier, using the Mroute > Ripup command. 
Select Parts > AlignX/Y. Locate the cursor in a position suitable for aligning the required parts, then click the left 
hand mouse button until the reference line is in the required location. 
A blue dashed line appears that represents the axis of alignment. Select each part to be aligned using the right 
hand mouse button (irrespective of the side of the board the parts are positioned on, or whether the artwork is 
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displayed in flipped/unflipped mode).  The parts move so that their datum lies over the axis line.  
The alignment axis can be moved by selecting another position with a click of the left hand mouse button. 

Parts > Highlight 
Used to highlight the unrouted connections radiating from a particular part. 
When a part is selected for highlighting, a message appears in the status bar indicating the length (in inches) of 
totally unrouted connections radiating from it. Partially unrouted connections are not included in the total. 
Select Parts > Highlight, then select the part whose connections you wish to hilite, with a click of the left button 
(irrespective of the side of the board the parts are positioned on or  whether the artwork is displayed in 
flipped/unflipped mode). The highlighting disappears when another part or command is selected. 
 

Parts > Find 
Used to find a particular part by virtue of its reference name. Once selected, a window appears where the part 
reference can be typed, or select the down-pointing arrow to the right of the text entry area to produce a list of 
all the parts in the design, from which one can be selected. Once the name has been entered/selected, the 
screen is panned if necessary to identify the required part. A balloon points to the part’s datum and supplies 
details about the part. The schematic and parts list icons can be selected from the balloon to locate the part in 
either the schematic or parts list. 

Parts > Change Outline 
Used to replace a part's outline shape for another within the same family group. (Family groups are defined by 
right-clicking on the Component Outline folder.) 
The datum of the new footprint is positioned in the same location as the one it is replacing.  
If the new outline has additional copper defined, it does not appear automatically. Use the Parts > Flip command 
(twice) on the part to introduce the copper (the second flip returns the part to the correct side of the board). 
Connectivity is maintained when part outlines are replaced, whether the connections are routed or unrouted. 
Connections or tracks remain connected to pins with the same pin number. For instance, a connection stays 
with pin 1, irrespective of its new position. 
When the part is changed, unrouted signal connections to it are automatically reconnected according to the 
settings in the Manual Routing Parameters window in the Configuration folder.  
Power connections may/maynot automatically reconnect, depending on the Parts > Dynamic Powernets setting. 
Reconnection does not take place on partially routed connections or tracks.  
When the outline of a routed part is replaced, the routed tracks may cause clearance violations. In these 
situations, it is probably easier to unroute the last track segment going to each pin before replacing the outline to 
make re-routing easier, using the Mroute > Ripup command. 
Select Parts > Change Outline, then point at and select the part whose outline shape will be replaced. A window 
appears listing the outlines in the same family group. Because an outline can belong to a family in the design 
library and the master library, the letter M alongside an outline means that it is from the master family. Select the 
outline required, followed by Apply to implement the change. If an outline from the master library is selected, a 
copy is transferred to the design library. 
Unflipped parts should be selected with a click of the left mouse button. Flipped parts should be selected with a 
click of the right mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons 
becomes reversed.) 
If Cancel is selected, the outline is not replaced. 
The outline change is back-annotated to the parts list. If the schematic is ever re-compiled, ensure the 
schematic extraction rules (Tools > Parts/Netlist Extraction > Setup) are set as required as they control whether 
the outline change remains, or reverts back to the original setting. A warning message will indicate that the 
outline called up by the schematic part is different to the one currently used on the artwork. 
There are a number of ways to restore the original outline, the easiest is to change the outline again in the 
artwork editor (Parts > Change Outline), alternatively, edit the parts list manually and re-type the outline name. 

Parts > Gate Swap 
Used to swap equivalent gates within the same part or between parts to reduce connection crossovers on the 
board. 
Only unrouted gates are available for swapping. Gates that have additional copper attached are regarded as 
partially routed. The additional copper will have to be ripped up using the Mroute > Ripup command before 
using the swap routine. Once the gates have been swapped, use the Parts > Flip command twice to restore the 
copper and the part to the correct side of the board. 
The wiring list and circuit schematic is automatically back annotated. 
A log report is generated and saved in the Log Files folder. The report is called renumber. 
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Parts must contain swappable gates before they can be selected for gate swapping. Swappable gates are 
defined within the schematic parts. This applies even if a circuit has not been drawn, i.e. if entry has been made 
via a parts and wiring list. The part name and value (Type field) in the parts list is the link between the parts on 
the board and the schematic parts. Gate swapping between parts is only permitted if the parts have identical 
type fields in the parts list. 
Once a part has been selected for gate swapping, all the equivalent gates on the board that are available for 
swapping highlight. The gates selected for swapping do not have to belong to the part originally selected. For 
instance, you may know that IC3 is a 74LS00. If it is selected, all the available gates, as permitted from the 
schematic part definition, belonging to 74LS00's highlight. Selection of the gates for swapping can be made 
from any of the gates, not necessarily from those belonging to IC3. 
It is easier to distinguish the gates if the part outlines are switched off. 
Select Parts > Gate Swap, then select a part. All the available equivalent gates highlight. Select the gate to be 
swapped, followed by the gate it is to be swapped with. The connections move as the gates swap. 
Unflipped parts should be selected with a click of the left mouse button, flipped parts with a click of the right 
mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes reversed.)  
The gates are always selected with a click of the left button. 
The right button, cancels the last action, so for instance if a gate within a part was selected, one click of the right 
button cancels the gate selection, the second the part. 

Parts > Pin Swap 
Used to swap equivalent pins within the same package to reduce connection crossovers on the board. 
Only unrouted pins within the same group are available for swapping. To swap routed pins, use the Mroute > 
Ripup command to restore the routes to connections. 
Pins that have additional copper attached, are regarded as partially routed. Any additional copper will have to be 
ripped up using the Mroute > Ripup command before using the swap routine. Once the pins have been 
swapped, use the Parts > Flip command twice to restore the additional copper and the part to the correct side of 
the board. 
The wiring list and circuit schematic are automatically back annotated.  
A log report is generated and saved in the Log Files folder. The report is called renumber. 
Parts must contain equivalent pins before they can be selected for pin swapping. Equivalent pins are defined 
within the schematic parts. This applies even if a circuit has not been drawn, i.e. if entry has been made via a 
parts and wiring list. The part name and value field (type column) in the parts list is the link between the parts on 
the board and the schematic parts. 
It is easier to distinguish the pins if the part outlines are switched off. 
Select Parts > Pin Swap, then select a part. All the available equivalent pins within the part highlight. Select the 
pin to be swapped, followed by a pin within the same group. The connections move as the pins swap. 
Unflipped parts should be selected with a click of the left mouse button, flipped parts with a click of the right 
mouse button. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes reversed.)  
The pins are always selected with a click of the left button. 
The right button, cancels the last action, so for instance if a pin within a part was selected, one click of the right 
button cancels the pin selection, the second the part. 

Parts > Dynamic Powernets 
Used to toggle the automatic reconnection of power connections on/off.  
It can be undesirable for the power connections to be reconnected automatically based upon shortest net 
length. Also, on slow machines and depending on the size of the power nets, automatic reconnection can slow 
the response. So for both these reasons, the automatic reconnection of power nets can be switched on (ticked) 
or off (unticked) as required.  
Power nets are reconnected in the direction defined in the Configuration folder, Manual Routing Parameters 
window.  
If this command is off (unticked), then the Power > Reconnect Power command can be used to reconnect the 
power nets if required. 
Select Parts > Dynamic Powernets to toggle on/off. 

Parts > Reconnect Power 
Used to reconnect the power connections. Only unrouted power connections are evaluated for reconnection. 
They are reconnected in the direction defined in the Configuration folder, Manual Routing Parameters window.  
(This command is greyed out/unselectable if the Parts > Dynamic Powernets command is enabled (ticked).) 
This command also restores signal connections to their part pins if their additional copper has been ripped-up 
and they were still hanging in mid-air. 
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Power connections, unlike signal connections, are not automatically reconnected as parts are moved, rotated, 
etc. unless the Parts > Dynamic Powernets command is enabled (on). 
It is also possible to manually reconnect unroutes and routed tracks in a user-preferred order, using the Mroute 
commands. 
Select Parts > Reconnect Power. The power connections reconnect. Any signal connections that have been left 
hanging in mid-air because of ripped-up copper are also re-attached to their pins. 

Parts > Auto Renumber 
Used to renumber the parts on the board in a specified logical order automatically. Manual part renumbering is 
also available (Parts > Manual Renumber). Parts on the board are often renumbered to make it easier for field 
engineers to find them. 
Note: once parts have been placed on the board, never de-allocate and re-allocate part numbers from the 
schematic editor as this will have the effect of shuffling the parts on the board. 
If the silk screen labels have been generated, they are automatically updated as the renumbering is performed. 
During the renumbering process, parts on both sides of the board are scanned, in user defined directions. When 
parts within the range specified are located, they are renumbered sequentially starting from a user defined 
number.  
The parts and wiring lists and circuit schematic are automatically back annotated. 
Duplicate names and numbers are not permitted. 
Note: if blocks were excluded from the schematic when the parts\wiring list was extracted, then it is possible that 
renumbering will duplicate part references on the schematic diagram. This will not cause a problem, unless the 
excluded block is subsequently included and a new parts\wiring list extracted. However a warning will be posted 
when the extraction is performed, indicating the duplicated references. 
A log report is also generated which lists the old and new part numbers. The report can be accessed from the 
Logfiles folder. The report is called renumber. 
Select Parts > Auto Renumber. A window appears as shown in Figure 194. 

 
Figure 194 

Choose the settings required then select Renumber to renumber the parts. Select Cancel to close the window 
without performing the renumber. 
Component Side, Directions (Left to Right, Top to Bottom) 

This setting controls the direction in which part datums on the component side of the board are 
scanned and renumbered. 
For example, consider the following settings: 
    left to right  
    top to bottom  
The board would be divided up into horizontal strips (left to right) as shown in Figure 195. 
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Figure 195 

Each strip would be scanned from left to right as shown by the arrows, starting from the top of the 
board (A strip), working downwards to the D strip. (The strip widths are user-defined.) 
If the settings were changed to: 
 right to left 
 top to bottom 
Each strip would be scanned from right to left in the opposite direction of the arrows, starting from the 
top of the board (A strip), working downwards to the D strip. (The strip widths are user-defined.) 
If the settings were changed to: 
 left to right  
 bottom to top 
The board would be divided up into horizontal strips in the same way, and the strips would be scanned 
from left to right. However, the strips would be scanned from the bottom of the board (strip D), working 
upwards (to the A strip). 
If the settings were changed to: 
 top to bottom  
 left to right 
The board would be divided up into vertical strips (top to bottom) as shown in Figure 196. 

 
Figure 196 

The strips would be scanned from top to bottom as shown by the arrows, starting from the left hand 
side (column A) across to the right (column H). 

Start at 
Specifies that the new part numbers should start at this number on this side of the board. Note: if this 
number is already in use, the next available number is used. 
This setting also determines whether the component side or solder side of the board is scanned and 
renumbered first. If the same numbers are entered for Component side, Start at and Solder side, Start 
at, the component side of the board is always scanned first. If the numbers are different, the lower 
number controls which side is renumbered first. 

Solder side, Directions (Left to Right, Top to Bottom) 
These settings operate in exactly the same way as the Component side settings, except that part 
datum's on the solder side of the board are scanned. 

Prefix 
Indicates the parts to be renumbered, according to their prefix, i.e. IC, or R, or C, etc. The * wild card is 
used to represent ALL prefixes. If specifying individual prefixes, only one prefix can be specified at a 
time. 

Strip width 
Specifies the width of the strip (row or column, see above) that is scanned for part datums. 
Parts within a strip are always scanned from bottom to top, right to left. This can cause unexpected 
results if a wide strip width is specified. For example, if left to right, top to bottom is selected, you would 
expect a vertical column of parts to be numbered 1, 2, 3, 4, etc. from the top down. However, if there 
were 3 parts in each strip, they would be numbered from the bottom of the strip up. The strip 
underneath would be numbered in the same way - see Figure 197. If this happens, select a narrower 
strip width. 
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Figure 197 

Min Part No. 
Specifies that parts from this number should be renumbered.  

Max Part No. 
Specifies that parts up to this number should be renumbered.  
Examples: 
 Prefix: IC 
 Component side start at: 1 
 Solder side start at: 1 
 Min Part No: 10 
 Max Part No: 25 
Using these settings, only ICs from IC10 to IC25 would be renumbered. IC's on the Component side 
will be renumbered first (because the Start at setting for Component side and Solder side were both set 
to 1). If IC's 1 to 9 existed, then the first available part number would be IC10 even though the Start at 
setting was set to 1. 
 Prefix: R 
 Component side start at: 2 
 Solder side start at: 1 
 Min Part No: 30 
 Max Part No: 55 
Using these settings, the resistors between R30 and R55 would be renumbered. Resistors on the 
solder side of the board will be renumbered first, starting from 1, followed by resistors on the 
component side of the board, starting from 2. 
Assuming that resistors from R1 to R100 exist on the layout, the following renumbering would take 
place. The solder side of the board is scanned in the directions defined at the top of the window for any 
resistors between R30 and R55. If any are found, an attempt is made to renumber them starting from 
R1. However, R1 to 29 exist, but are not being renumbered, so the first "free number" will be R30 
(because the existing resistors R30 to R55 are being renumbered). Once the resistors on the solder 
side of the board have been renumbered, the component side of the board is scanned. An attempt will 
be made to renumber the first resistor it finds to R2, but this will cause a duplication, so the next "free 
resistor" number will be used. If R30 to R43 had been used on the solder side of the board the next 
free number would be R44, renumbering would continue from there. 
A perhaps more typical application would be to renumber all parts on the component side of the board 
starting from 1000 and those on the solder side of the board starting from 2000. This would assist in 
finding parts on a populated board. 

Parts > Manual Renumber 
Used to renumber selected parts on the board. Automatic part renumbering is also available using the Parts > 
Auto Renumber command. 
If the silk screen labels have been generated, they are automatically updated as the renumbering is performed. 
The parts/wiring lists and circuit schematic are automatically back annotated.  
Duplicate names and numbers are not permitted on the artwork layout. 
Note: if blocks were excluded from the schematic when the parts\wiring list was extracted, then it is possible that 
renumbering will duplicate part references on the schematic diagram. This will not cause a problem, unless the 
excluded block is subsequently included and a new parts\wiring list extracted. However a warning will be posted 
when the extraction is performed, indicating the duplicated references. 
A log report is also generated which lists the old and new part numbers. The report can be accessed from the 
Logfiles folder. The report is called renumber. 
Select Parts > Manual Renumber  and then select the part to be renumbered. 
Unflipped parts should be selected with a click of the left mouse button and flipped parts with a click of the right 
mouse button. When the artwork is displayed in “flipped” mode, the sense of the buttons becomes reversed. 
(When the artwork is displayed in “flipped” mode, the sense of the buttons should become reversed, but this is 
not the case in versions upto v2.22 and possibly beyond, check the readme.txt file for details of changes made 
after the date of this guide.) 
 A window appears indicating the parts number and requesting a new number for the part (only the number can 
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be changed, not the prefix). 
Once the new number is typed and OK selected, the part is renumbered. If the new part number is already in 
use, an error message appears in the status bar to indicate the part already exists, and the renumber does not 
take place. 

Parts > Status 
Used to report the number of parts placed on the board and the number of parts waiting to be placed on the 
board. 
Routing should not normally be started until all the parts have been placed on the board. 
Select Parts > Status, and the report appears. Select OK to continue. 

Parts > Set Datum 
Used to move the datum of the artwork editor. 
Unless the datum has been moved, it is positioned in the lower left corner of the working area. 
The datum remains in the selected position until it is moved or restored to its original location. 
Note: the new datum position is local to the artwork editor. All other editors use the original datum position as a 
reference point. For instance, within the artwork editor, part positions are referenced to the datum. If the parts 
list is viewed, it will be found that the part's positions are referenced to the original datum position. 
The X-Y readout is given with respect to the datum position. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Parts > Set Datum. Position the cursor in the required datum location and click the left mouse button. The 
datum is shown as a small yellow cross surrounded by a circle. 
To restore the datum to its original position, select Parts > Set Datum, then click the right hand mouse button. 
The datum is restored to the lower left corner of the working area. 

PartFix commands 
These commands are used to fix parts in position so that they're not accidentally moved. Once fixed, they can 
be unfixed as required. 
The part toggles between fixed and unfixed status each time it is selected.  
If the PartFix > Show Fixed Parts toggle is enabled, then the area occupied by the component outline’s 
autoplacement footprint changes colour (Figure 198) which shows the unfixed and fixed status of the same 
part.. 
Note: fixed parts can still be moved via the parts list editor but their fixed status is retained (in the new position). 
When using the part fixing commands, unflipped parts should be selected with a click of the left mouse button 
and flipped parts with a click of the right mouse button. (This does not change whether the artwork is displayed 
in flipped/unflipped mode – check the readme.txt file for changes in future updates after v2.21.) 

PartFix > Fix/Unfix Selected Parts 
Used to fix or unfix individually selected parts. 
The PartFix > Enable Flipped Parts and PartFix > Enable Unflipped Parts settings control wether flipped and/or 
unflipped parts can be selected. 
Select PartFix > Fix/Unfix Selected Parts, then select a part, it toggles between a fixed and unfixed status. 
Use the PartFix > Show Fixed Parts command to indicate all the fixed parts. 

PartFix > Fix/Unfix All Parts 
Used to fix/unfix all the parts. 
The PartFix > Enable Flipped Parts and PartFix > Enable Unflipped Parts settings control wether flipped and/or 
unflipped parts are included. 
Select PartFix > Fix/Unfix All Parts. All the parts change their status between all fixed or all unfixed. 
Use the PartFix > Show Fixed Parts command to indicate all the fixed parts. 

PartFix > Fix By Partcode 
Used to fix parts by entering their part names. 
The asterisk (*) can be used as a wild card to fix a group of parts. For instance: * operates on all parts, IC* 
operates on all the parts with IC as a prefix, R3* operates on R3, R30 to 39, R300 to 399, etc. The questionmark 
(?) can be used to represent one number, for example R2? represents resistors R2, R20 - 29.  
The PartFix > Enable Flipped Parts and PartFix > Enable Unflipped Parts settings control which parts can be 
included and take precedence. 
Select PartFix > Fix By Partcode, a window appears in which the name of the part (or parts) to be fixed should 
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be entered. Select OK or press <enter>. 
The parts toggle between their fixed and unfixed status. 
Use the PartFix > Show Fixed Parts command to indicate all the fixed parts. 

PartFix > Unfix By Partcode 
Used to unfix parts by entering their part names. 
The asterisk (*) can be used as a wild card to unfix a group of parts. For instance: * operates on all parts, IC* 
operates on all the parts with IC as a prefix, R3* operates on R3, R30 to 39, R300 to 399, etc. The questionmark 
(?) can be used to represent one number, for example R2? represents resistors R2, R20 - 29.  
The PartFix > Enable Flipped Parts and PartFix > Enable Unflipped Parts settings control which parts can be 
included and take precedence. 
Select PartFix > Fix By Partcode, a window appears in which the name of the part (or parts) to be unfixed 
should be entered. Select OK or press <enter>. 
Use the PartFix > Show Fixed Parts command to indicate all the fixed parts. 

PartFix > Enable Unflipped Parts 
This setting can be active (ticked) or inactive (unticked). When active, all unflipped parts will be included in the 
PartFix/Unfix operations.  

PartFix > Enable Flipped Parts 
This setting can be active (ticked) or inactive (unticked). When ticked, all flipped parts will be included in the 
PartFix/Unfix operations.  

PartFix > Show Fixed Parts 
Used to highlight the fixed parts.  
This command shows all fixed parts irrespective of the PartFix > Enable Unflipped/Flipped Parts settings. 
Figure 198 shows how a part looks when unfixed on the left and fixed on the right - the area occupied by the 
component outline’s autoplacement footprint changes colour. 

 

Figure 198 

Whenever any of the PartFix commands are selected, this setting is enabled (ticked). 

Mroute commands 
Once all the parts have been placed on the board, the inter-connections are ready to be routed. They can either 
be auto-routed or manually routed. It is not recommended that tracks be routed until all the parts have been 
placed on the board. 
The Mroute (manual routing) commands are used to manually route the connections. They are used to stretch 
the point to point connections between pads to form routed copper tracks on the board and to modify existing 
routed tracks. They do not allow pads to become disconnected. 
(The Amend commands provide the flexibility for the user to "do what he/she wants" but should be used with 
caution by inexperienced users.) 
Critical connections are usually manually routed first, fixed in position using the NetFix commands, then the 
remaining connections routed, probably by the auto-router. 
The Seetrax auto-router is accessed via the Tools command in the artwork editor.  
The interfaces to other available auto-routers are accessed whilst the artwork editor is closed, then by right-
clicking on Artwork from the navigator and selecting Optional Auto-routers. (These other auto-routers have to be 
purchased separately and have to be enabled from the File > System Setup window before they become 
available for selection.) 
The Edit > Manual Routing Parameters window (accessed from the Configuration folder) controls the default 
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direction/ordering for unroutes. But it is sometimes a requirement to change the order in which connections or 
routed tracks are routed. To change the order manually, use the Mroute > Move Unroute/Track commands. This 
window also controls the way in which connections can be manipulated, whether on-line DRC is switched on 
and its clearance requirements. 
To start manually routing, the Mroute > Corner command is used, followed by Mroute > Layer Swap/ Move 
Segment, etc. as required. 
When any of the Mroute commands are selected, the Mroute dialogue bar appears. It controls how the Mroute 
commands operate.  

Mroute Dialogue Bar 
When the Mroute commands are selected, the Mroute dialogue bar appears. Its settings are described now 
and they control the tracks that can be selected and how they are operated upon. 
The dialogue bar will vary slightly depending on the number of layers in the design - two variants are shown 
in Figure 199. The (a) is from a double-sided design and (b) is from a design with 10 layers. The only 
difference is the number of layers listed. 

 
Figure 199 

Via Autoselect When enabled (ticked) and a via has to be inserted (for example whilst performing a layer 
swap or point insertion operation) the most appropriate via from those available is used.  
The via selection is made from the user-defined via list (defined in the Configuration 
folder, Via Hole Definitions window). 
The “most appropriate via” is one that traverses the minimum number of board layers 
whilst providing the correct connectivity.  
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If 'Via Autoselect' is not checked, or autoselect cannot find a suitable user-defined via, 
then a standard via is inserted. 

 Layer Control This section of the dialogue lists all the copper and power/splitpower plane layers in the 
design. The layers are listed in their layer assembly order to help visualisation of the layer 
stack (as defined in the Configuration folder, Layer Assignments and Ordering window). 
When working on single or double designs, it’s usual for all the other layers to be 
assigned as silk-screen layers, so only layers T & B will appear (Figure 199 (a)). 
When the list is too long to be displayed, the slider on the left of the layer list should be 
used to scroll up and down through the list when required. 

 The checkboxes indicate the active tracking layers – if the box isn’t ticked, then tracks 
can’t be added to, or selected from, that layer.  
Power/split power plane layers are listed and identified by the letters PP. They are 
displayed for information purposes only, so they are “greyed out” and cannot be selected. 
When working on a double-sided board the T and B (the outer layers of the board) should 
be active.  
When working on single-sided boards, only T or B should be active, to avoid the use of 
the other layer.  
When working on multi-layer designs, the active layers can be varied depending on the 
layers being worked upon - disabling layers stops the inadvertent selection of tracks from 
those layers. 
The coloured boxes along-side the layers help identify track layers.  
Note: The Mroute commands will only select visible tracks (View Control dialogue bar) 
from the active layers. 

>>> Whilst manually routing connections using Mroute > Corner, the new track can be added 
to any of the active layers, after pressing the user-defined layer swap key, providing the 
connectivity will be maintained. The chevrons (>>>) alongside the layer box indicates the 
layer the track will be added to.  

All/None These boxes can be selected to quickly select/deselect all the tick boxes. 
Neck Size This setting defines the track thickness to be used when the Mroute > Neck command is 

used. The number represents a line thickness taken from the track sizes table. Use the 
spin-controls to change the size code.  
The current size assigned to the size code is shown underneath in inches or millimetres 
depending on the units in use (Edit > Units).  

Neck Length This setting defines the length of necked track introduced when using the Mroute > Neck 
command. 
The units in use (inches/mm) are controlled by the Edit > Units command. 

Mroute > Corner 
This command is used to: 

add or move corners in tracks 
add corners to connections - as the corner is added, the connection is converted to a track or partially 
routed (one end becomes a track, the other remains as a connection, shown with a dotted line to 
differentiate it from connections that haven’t been partially routed). 
“lift off” the end-points of connections and move them to a pin, via or track corner on the same net, 
provided the Mroute > Enable Unroute Reconnect setting is checked. 

This command will not allow tracks to become disconnected from component pins or vias.  
Use the Mroute > Move Track command to change the order of routed tracks. 
Use the Mroute > Move Unroute command to change the order of unroutes. 
Use the Mroute > Convert to Track command to convert connections into tracks without adding corners. 

Corners are added and then released with a click of the right hand mouse button. Corners are moved and then 
released with a click of the left hand mouse button. Clicking the opposite mouse button once a track has been 
selected cancels the operation. 
   right button   =   add corner 
   left button     =    move corner 
   (Opposite button cancels.) 
Only tracks from a currently active layer in the Mroute dialogue bar can be selected. 
Refer to the GRID command for details on whether grid snapping is active. The current grid is shown in the 
information line above the graphical editor. 
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If the Mroute > Enable Unroute Reconnect setting is checked, the end of a connection can be selected with a 
click of the left hand button, then the connection can be moved to a component pin, via or track corner on the 
same net with a further click of the left button.  
To assist in finding alternate locations, especially when zoomed in on a large board, a small arrow points in a 
direction towards the next-nearest available attachment location. Click the right button to cancel the operation. 
If the connection is moved to a corner or via, then subsequent selections of that point with Mroute > Corner will 
move the connection and the corner/via. To lift the connection off separately, hold down the <shift> key whilst 
clicking on the end of the connection with the left mouse button. 

Adding a corner to a connection or a track 
Parameters within the Edit > Manual Routing Parameters window (Configuration folder) affect whether the 
connection remains attached to the cursor (multi-node), whether it is routed completely or partially, etc. 
when adding corners to connections. 
Select Mroute > Corner, ensure one of the active layer settings in the Mroute dialogue bar is set to the layer 
the track is on, or will be added to. Point at a connection, or a track from one of the active layers, and click 
the right hand mouse button. Move the cursor and the new corner. 
If a connection was selected, the chevrons (>>>) in the Mroute dialogue bar indicate which layer the track 
segment will appear on when the corner is released.  
If a connection was selected and the routing parameters are configured so that the connection is partially 
routed, then it is the shortest segment that gets converted to a track. 
Locate the cursor in the position for the new corner and click the right hand mouse button again to release 
the corner. 
Clicking the left hand mouse button before clicking the right hand button releases the connection or track 
without the new corner. 
If the connection remains attached to the cursor (multi-node is selected), further corners can be introduced 
until the left hand mouse button is clicked, which releases the connection.  
If the corner is being inserted into a track segment that is connected to a component pad and multi-node is 
selected, the track also remains attached to the cursor allowing more corners to be inserted until the left 
hand mouse button is clicked. This does not happen if a corner is inserted into a mid-segment. 
Whilst the connection is attached to the cursor the <layer swap> special function key can be pressed to 
change the layer the track segment will appear on (toggles between the active layers as defined in the 
Mroute dialogue bar).  This is provided the layer swap maintains connectivity, for example, a layer swap 
would not be permitted on the track segment entering a surface mounted pad, the track has to be on the 
appropriate layer. 
Orthogonal (0/90) and 45 degree segment locking can be switched on and off using the <Toggle track node 
lock mode> user-defined special function key (defined in the File > System Setup window, Special Function 
Keys, Setup button). Each time the key is pressed, the mode toggles between free movement and 0, 45 & 
90 degree fixed movement. 
The locking facility when activated comes into effect after the first corner has been inserted in a connection. 
If adding corners to an existing track, the facility is only available when the track segment closest to a pad 
or via is selected. 

Moving an existing corner in a track 
Select Mroute > Corner, ensure one of the active layers in the Mroute dialogue bar is set to the layer the 
track is on. Point at an existing corner from one of the active layers, and click the left hand mouse button. 
Move the cursor and the corner stretches with it. Locate the cursor in the new position for the corner and 
click the left hand mouse button again to release the corner. 
Clicking the right hand mouse button before clicking the left hand button returns the corner to its original 
position. 

Connections to power planes from SMD pins (assuming the power planes have been defined) 
Surface mounted pads that are connected to power planes have a connection complete with via attached to 
them automatically. The connection sits on top of the SMD pad so looks like a "blob" when the power 
unroutes/connections are visible at width (View Control dialogue bar), until it is positioned.  
It can be moved into an appropriate position using the Mroute > Corner (adding) command. (If the power 
plane layers have not been defined, the connections will appear as normal connections.)  
If the auto-router will not be used to insert the stubs required to make the connection between the SMD pad 
and plane, then proceed as follows. 
Zoom into a surface mounted pad that is connected to a power plane. Ensure the power connections 
(unroutes) are visible and displayed at width. A connection "blob" will be seen over the SMD pad. Select it 
with a click of the right hand mouse button. Move the cursor with the attached connection and via into a 
space and click the right hand mouse button again. The connection is converted into a track with a via on 
the end of it. This track and via will make the connection between the SMD pad and the power plane. 
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Where there are multiple blobs in close proximity, the vias can be released directly over the top of one 
another in order to save on the number of vias - the subsequent vias are automatically removed as the 
blob/stub is released so that there is only one via at the location. 
Via selection (standard or user-defined) is controlled from the Mroute dialogue bar (Via Autoselect). 

Implications of the routing parameters when adding corners (Mroute > Corner) to connections  
The routing parameters are found in the Edit > Manual Routing Parameters window, accessed from the 
Configuration folder. 
If the Corner Insertion setting is set to Multinode, the connection remains attached to the cursor until the left 
hand mouse button is clicked. Whether the last segment is left as a partial unroute is determined by the 
Unroute Convert and Unroute Minimum Length settings. 
Whilst the connection remains attached to the cursor, the layer swap special function key can be used to 
select the layer the next track segment will be released on. The layers used are controlled by the Mroute 
dialogue bar. 
If the Corner Insertion setting is set to Select/Drop the layer that the track appears on is controlled as 
follows:  

If the corner is inserted into a connection between two surface mounted devices that are on the same 
side of the board, the track will appear on that layer.  
If a corner is inserted into a connection between two surface mounted devices that are on opposite 
sides of the board, a prompt will appear in the status bar requesting a position for the via hole that will 
maintain the connectivity between the two parts. Move the cursor into the position where the via hole is 
required and click the right hand mouse button. 
If the corner is added to a connection between through plated pads and the connection is more 
horizontal than vertical, then a scan is done from the top of the board working downwards through the 
copper layers in assembly order until a layer is found that is enabled for routing. 
If the unroute is more vertical than horizontal, then a scan is done from the bottom of the board working 
upwards through the copper layers in assembly order until a layer is found that is enabled for routing. 

If the Corner Insertion setting is set to Multinode only the shortest segment of the connection is converted 
into a track, the rest of the connection remains attached to the cursor, and the layer it is added to is 
controlled by pressing the user defined layer swap key - the chevrons (>>>) in the dialogue bar indicate 
which layer the track segment will be added to.  
The track can be added to any of the active layers from the Mroute dialogue bar providing the connectivity 
will be maintained. Vias are inserted as required when layer swapping is activated. 

Mroute > Enable Unroute Reconnect 
This setting determines whether connection ends can be selected for movement when Mroute > Corner is in 
use.  
With this setting enabled it can sometimes be difficult to move a corner that is very close to the end of a 
connection, as the end point of the connection takes precedence.  
Disabling this setting will not allow connection end-points to be selected/moved when moving corners using 
Mroute > Corner. 

Mroute > Move Segment 
Used to move a complete track segment whilst stretching the adjoining track segments. 
The movement of horizontal and vertical track segments is controlled by the Segmove Mode setting in the 
Manual Routing Parameters window (Configuration folder). 
Track segments that end on a component pad cannot be moved, as one end of the segment is fixed. 
If on-line DRC is switched on, errors will be flagged if a violation occurs when the segment is moved. 
Select Mroute > Move Segment. Ensure one of the layer settings in the Mroute dialogue bar is set to the layer 
that the segment is on. Select the track segment. Move the cursor. The track segment moves and stretches the 
adjoining segments. Click the left hand mouse button again to release the segment in its new position. 
Clicking the right hand mouse button after the segment has been selected returns the segment to its original 
position. 

Mroute > Layer Swap 
Used to transfer a track segment from one layer of the board to another, inserting and/or removing vias as 
necessary. 
The track segment to be selected must lie on one of the active layers as defined in the Mroute dialogue bar. It 
will be swapped to the next active layer, in the Mroute dialogue bar, from top to bottom, then back to top. (The 
layer order is defined in the Configuration folder, Layer Assignments and Ordering window.) 
For example, if layers T, 1, 2, 5 and B were active and listed in that order, then a track segment that lies on layer 
2 will be swapped to layer 5, then B, then T, then 1 and back to 2 and so on, each time it is selected. 
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A track segment is a length of track between two points, not necessarily the complete run of a straight line. 
The last track segment attached to a SMD pin cannot be swapped otherwise connectivity would be lost. 
On-line DRC does not flag violations caused by this command. 
Select Mroute > Layer Swap. Ensure the layer that the track segment is on, along with the layer the segment is 
to be swapped to, are active in the Mroute dialogue bar. Select the track segment, the segment swaps between 
two layers adding or removing vias as necessary. It may be necessary to swap the segment again until it lies on 
the layer required if more than two layers are active. 

Mroute > Delete Point 
Used to remove points (or corners) from tracks. 
This command will not remove component pads, vias, track ends that meet at component pads or vias, or the 
end points of tracks. Use Mroute > Ripup to delete a track and restore the connection.  
If on-line DRC is switched on, errors will be flagged if a violation occurs when the point is deleted. 
Select Mroute > Delete Point. Ensure the layer is active in the Mroute dialogue bar. Select the point and it is 
removed.  

Mroute > Convert Arc 
Used to convert straight line track segments into curved tracks, curved tracks into straight line segments, or to 
change the shape of existing arcs. 
On-line DRC does not flag violations caused by this command. 
Ensure the layer the track is on, is active in the Mroute dialogue bar. 

Straight lines into arcs  
Select Mroute > Convert Arc, then select a track segment. As the cursor is moved, the segment is replaced 
with an arc that stretches with the cursor. Click the left hand mouse button to release the arc in its current 
position.  

Arcs into straight lines 
Select Mroute > Convert Arc, then select a curved track segment with a click of the left hand mouse button. 
Follow this by a click of the right hand mouse button, and the arc is replaced with a straight-line track 
segment. 

Changing the shape of existing arcs 
Select Mroute > Convert Arc, then select a curved track segment. Move the cursor with the arc attached 
and click the left hand mouse button to release it in its new position. 
Note: once an arc or segment has been selected and released, clicking the right hand mouse button 
converts that segment between an arc and a straight line until a new segment is selected with the left hand 
mouse button. The arc will always be the same size, but its direction is cursor position dependent. This 
facility is useful to convert 45 degree track segments into quadrants of a circle. 

Mroute > Fix 45 
Used to force non-45 degree angled track segments entering component pads to enter at 45 degrees. 
This command is often used when trying to enter pads at 45 degrees that are not on a multiple of the current 
snap grid. 
The point\corner before the pad is moved so that the track segment enters the pad at 45 degrees. 
Fix 45 will not work if the other end of the track segment is attached to a non-horizontal or non-vertical track 
segment, a curved track segment or a via. 
Select Mroute > Fix 45. Ensure the layer the track segment is on, is active in the Mroute dialogue bar. Select a 
non-45 degree track segment entering a pad. The segment forms a 45 degree angle. 

Mroute > Fix 90 
Used to force non-90 degree angled track segments entering component pads to enter at 90 degrees. 
This command is often used when trying to enter pads at 90 degrees that are not on a multiple of the current 
snap grid. 
The point\corner before the pad is moved so that the track segment enters the pad at 90 degrees. 
Fix 90 will not work if the other end of the track segment is attached to a non-horizontal or non-vertical track 
segment, a curved track segment or a via. 
Select Mroute > Fix 90. Ensure the layer the track segment is on, is active in the Mroute dialogue bar. Select a 
non-90 degree track segment entering a pad. The segment forms a 90 degree angle. 

Mroute > Neck 
Used to change the thickness of individual sections of tracks. This is typically used to route a thick track 
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between the pins of ICs. 
A neck length and neck size has to be specified in the Mroute dialogue bar. The neck length defines the length 
of the section of track that has to be changed. The neck size defines the thickness of the necked section of 
track. 
On-line DRC does not flag violations caused by this command. 
Ensure the layer the track segment is on, is active in the Mroute dialogue bar, and the neck size and length is 
set as required. 
Select Mroute > Neck. Select the centre of the required necked section of track. The necked track is introduced 
centrally about the cursor position. 

Removing necked sections of track 
* Use "Undo" when appropriate 
* Neck the segment back to its original size. 
* Layer swap the necked track segment until it returns to the original layer. This method only works if there 

is a track segment attached to the necked section that remains at its original size. 
The last two methods leave points in the tracks at the locations where the neck started and stopped. If layer 
swap was used, they can be removed using the Mroute > Delete Point command.  

Mroute > Convert to Track 
Used to convert a connection into a track segment on a copper layer of the board, without introducing corners. 
(Use Mroute > Corner instead if corners are also required.) 
The layer chosen for the track is selected as follows: 

If the corner is added to a connection between through plated pads and the connection is more horizontal 
than vertical, then a scan is done from the top of the board working downwards through the copper layers in 
assembly order until a layer is found that is enabled for routing. 
If the unroute is more vertical than horizontal, then a scan is done from the bottom of the board working 
upwards through the copper layers in assembly order until a layer is found that is enabled for routing. 
If a connection between two surface mounted devices that are on the same side of the board is converted, 
the track appears on that layer. 
If a corner is inserted into a connection between two surface mounted devices that are on opposite sides of 
the board, a prompt appears in the status bar, requesting a position for the via hole that will maintain the 
connectivity between the two parts. 

Select Mroute > Convert to Track, then select a connection. It appears as a track. 
On-line DRC does not flag violations caused by this command. 
Refer to the Mroute > Ripup command for details on converting tracks back into connections. 

Mroute > Ripup 
Used to convert a track segment attached to a pad, or the complete track, back to a connection or "unroute". 
(Only unfixed track segments can be selected – use the NetFix > Unfix Mode and associated commands to 
unfix, fixed tracks.) 
An unrouted connection is shown as a solid line between two pads. A partially unrouted connection is shown as 
a dashed line between a pad and the end of the routed section.  
Only track segments attached to pads or partial unroutes can be partially ripped-up. Track segments between 
track segments cannot be partially ripped up. 
Once tracks have been ripped-up, they can be manually routed or auto-routed (complete unroutes). 
If a stringer is ripped up, the connection remains "attached" to the position where the stringer's via was, and not 
to the pin of the component. Either use the Parts > Flip command twice on the part to restore the stringers, or 
use the Parts > Reconnect Power command to reconnect the connections to the part pins.  
Ensure the layer the track/track segment is on, is active in the Mroute dialogue bar. When ripping up a complete 
track, only the selected track segment layer needs to be active, the attached segments will be ripped up even if 
the layers they are on, are not active or visible. 

Ripping up complete tracks 
Select Mroute > Ripup, then select any (active layer) track segment with a click of the right hand mouse 
button. The complete track is replaced by a connection. 

Ripping up track segments 
Select Mroute > Ripup, then point at a track segment attached to a component pad or a partial unroute and 
click the left hand mouse button. The track segment is replaced by a partially unrouted connection. 
Selecting the next track segment in the same way replaces it with a partially unrouted connection line. The 
layer the segment is on, has to be active. 
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Note: if a track is deleted using the Amend or Region commands, its connection will not re-appear. It will be 
necessary to run the artwork checking routines to restore the “lost” connections. 

Mroute > Move Track 
Used to change the order of routed tracks belonging to one net, whilst maintaining connectivity. Often used to 
route power supplies in the order required. This command does not operate on unroutes. 
For example, take a net that joins pins A, B and C together, in that order (Figure 200, before). It may be 
preferable for the tracks to be attached in the order A to C and A to B (Figure 200, after).  

 

Figure 200 

The connectivity order has changed, not change the connectivity. 
On-line DRC does not flag violations caused by this command, though it is not possible to move the track to a 
pin on a different net. 
Ensure the layer the track is on, is active in the Mroute dialogue bar. 
Select Mroute > Move Track. Select a component pad belonging to the net you wish to modify, with one or more 
tracks attached to it. Component pads on all layers, or the top of the board should be selected with the left hand 
mouse button. Component pads on the bottom of the board should be selected with the right hand mouse 
button. As the cursor is moved, the track is disconnected from the selected pad and moves with the cursor. All 
the pads on the same net highlight. 
If more than one track is attached to the selected pad, and the wrong track is attached to the cursor, move the 
cursor back over the original component pad and select it again. Keep selecting the pad until the correct track is 
attached to the cursor. (Only tracks from active layers are selected.) 
Now move the cursor and the attached track, over the highlighted component pad that you would like it to be 
attached to, and click the same mouse button. The track moves. If a pad would become disconnected by this 
operation, a connection appears to maintain the complete net. 
The track is reconnected, providing the new component pad is on all layers, or on the same side of the board as 
the selected track. For example, moving a track from a top mounted SMD to a bottom mounted SMD would not 
be allowed as the track would become disconnected. 
To cancel the operation whilst the track is attached to the cursor, click the opposite mouse button. 

Mroute > Move Unroute 
Used to move the end of a connection, to a component pin, via or corner of a track on the same net in order to 
reduce the length of connection to be routed, or alter the order of connectivity (circuit connectivity cannot be 
altered with this command). 
Select Mroute > Move Unroute, select the end of a connection and if connectivity permits, the connection will be 
detached from the current location. Whilst moving the connection, a dotted line extends from the cursor to the 
nearest available node where the connection end may be attached. To assist in finding alternate locations, 
especially when zoomed in on a large board, a small arrow points in a direction towards the next-nearest 
available attachment location. Once an alternative connection point has been located (another part pin, via hole 
or track corner on the same net), select it with a click of the left-hand mouse button. Click the right button to 
cancel the operation. 
Where multiple connections are attached to the initial point being selected, select the required connection 
slightly away from its end point to be sure of selecting the connection required. 

Amend commands 
These commands provide the freedom to change and add items to the layout as required. Because of this 
freedom, it is possible to completely change the layout, for better or worse. It is therefore unlike the Mroute 
commands, which maintain connectivity at all times. If connectivity is lost, or short circuits or clearance errors 
are added whilst using the Amend commands, these problems will be highlighted when the artwork checking 
routine is performed. 
Typically, things like crop marks, plating bars, etc. are added using these commands. Copper filled areas can 
also be modified using the Amend > Move Point/Delete Track commands. 
The board profile and keepout lines can also be modified or added using the Amend commands. Any changes 
to these two categories of data are automatically back annotated to the board profile editor. This saves having to 
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return to the profile editor in order to re-define keep-out areas between auto-routing strategies, etc. 
The Amend commands can also be used to modify data on the silk screen layers, and data that has been added 
or imported onto a documentation layer 
Any errors that are introduced to the copper layers of the layout will be flagged when the artwork checking 
routines are performed. 
When any of the Amend commands are selected, the Enter/Amend dialogue bar appears and it controls how the 
Amend commands operate.  

Amend Dialogue Bar 
When the Amend commands are selected, depending on which command is selected, one of the Amend 
dialogue bars appears as shown in Figure 201. The bar is either configured for pads or tracks. The settings are 
described below. 

 
Figure 201 

Settings common to both dialogue bars: 
Layer selection this determines which layer tracks or pads are added to, or selected from. It is the "active" 

layer. All layers are available for selection. 
The Amend commands will only select tracks/pads from the layer indicated by the active 
layer setting. 
If the active layer has been assigned a title (Configuration > Layer Assignments window), 
this is also displayed. 
The colour of the box along-side (white is a colour) helps to identify and also select 
layers; it can be selected to produce the layer assignments list which aids layer selection 
when using the spin-controls to change layers might be cumbersome.  
Pads that are added to layer V will be drilled (if they have a drill hole defined). Pads that 
are added to any other layer, i.e. layer T, B, 1, 2, etc. will not be drilled. 

Size selection this setting corresponds to the size codes from the Track/Pad Sizes table and it controls 
the size of any tracks/lines or pads that are added/updated. The code can be changed by 
typing in a number (the cursor must remain in the dialogue bar whilst typing) or by 
selecting the spin controls alongside.  
The box underneath shows the actual size assigned to each code as it is selected, in 
whichever units are active. 
(Profile and keepout lines have no thickness so this setting is not used when 
adding/modifying these line types.) 

Track dialogue bar 
Profile tick this box to edit or add the board profile. Only one polygon line should form the profile 

- refer to the board profile editor for more details regarding the board profile definition. 
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Keepout tick this box when you wish to edit or add to the keepout definitions - refer to the board 
profile editor for more details regarding keepouts. 

Pad dialogue bar 
When this dialogue bar appears, either "standard pads" (including user-defined pads and heat-relief/anti-pads) 
or user-defined (UD) via stacks can be added or updated. The radio buttons alongside Pads or UD Vias 
determines which type of pad are active. Depending on which types are selected, parts of the dialogue bar will 
be greyed out. 

Pads  if this button is selected, then the following settings are enabled and can be used to 
add/modify or delete pads. (Component pads cannot be deleted from within the artwork 
editor.) 

Style allows the pad shape to be selected - select the arrow alongside to produce a list of pad 
styles from which one should be selected. Included are the standard pad shapes, user-
defined pads from the design library, heat-relief and anti-pads. If a standard pad shape or 
heat-relief/anti-pad is selected, then the Size setting should also be updated as required. 
Whichever pad style is chosen the Angle setting should also be set as required. 

Angle setting determines the orientation (angle) of the selected pad. The angle can be typed in 
(0, 90, 180 or 270), or a selection made from the list that appears when the arrow 
alongside the setting is selected.  

 
UD Vias If the user-defined vias (UD Vias) are selected, then the size of the vias that are added 

and the layers they appear on are controlled by the via style selected, the other settings 
in the dialogue bar are greyed out. 

Style allows the user-defined via to be selected - select the arrow alongside to produce a list of 
via styles from which one should be selected. Included are all the via stacks defined in 
the Configuration folder, Via Hole Definitions. 

Amend > Enter Pads 
Used to add a pad to the board. These pads are not associated with components. 
The pad's size, shape, layer and whether drilled is defined in the Amend Pads dialogue bar. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Enter Pads, ensure the Amend Pads dialogue bar is set as required, then move the cursor and 
the attached pad into position and click the left hand mouse button to release it. Another pad appears attached 
to the cursor until the right-hand button is clicked. 

Amend > Enter Tracks 
Used to add a track or a silk-screen line to the board, on the layer and at the size specified by the Amend 
dialogue bar, or to add a line to the board profile or keepout definition. 
Tracks that are added using this command, will not be recognised as belonging to a connection until they have 
been validated by the artwork checking routines. This means that routines such as Identify, Hilight and copper 
Fill will not recognise them as valid nets or tracks until that time.  
Note: if a track is accidentally deleted, the checking routines will re-introduce the connection again and flag an 
error unless it has been successfully reinserted using the Amend commands. Provided the new track completes 
a correct connection, the checking routines will validate it and it will be recognised as a valid track. 
Adding a piece of track in this way does not add a connection to the wiring list. Refer to the Tools > Network > 
Add Link command to achieve this, or add a connection to the schematic and recompile the parts and wiring list. 
If the piece of track causes a short or clearance errors on a copper layer, these will be reported when artwork 
checking is performed. 
If the line is added to the profile or keepout categories, the profile editor is automatically updated. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Enter Tracks, ensure the Amend Tracks dialogue bar is set as required, then point at the 
location where the track/line is to start and click the left hand mouse button. The line stretches as the cursor is 
moved. Click the left-hand mouse button to insert corners in the track. Release the track by clicking the right 
hand mouse button. 

Amend > Enter Arc Tracks 
Used to add a piece of curved track or line to the board, on the layer and at the size specified by the Amend 
dialogue bar, or to add a curved line to the board profile or keepout definition. 
The Mroute > Convert Arc command can be used to convert existing track segments to arcs. 
Tracks that are added using this command will not be recognised as belonging to a connection until they have 
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been validated by the artwork checking routines. This means that routines such as Identify, Hilight and copper 
Fill will not recognise them as valid nets or tracks until that time.  
Note: if a track is accidentally deleted, the checking routines will re-introduce the connection again and flag an 
error unless it has been successfully reinserted using the Amend commands. Provided the new track completes 
a correct connection, the checking routines will validate it and it will be recognised as a valid track. 
Adding a piece of track in this way does not add a connection to the wiring list. Refer to the Tools > Network > 
Add Link command to achieve this, or add a connection to the schematic and recompile the parts and wiring list. 
If the piece of track causes a short or clearance errors on a copper layer, these will be reported when artwork 
checking is performed. 
If the profile or keepout categories are modified, the profile editor is automatically updated. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Enter Arc Tracks, ensure the Amend Tracks dialogue bar is set as required, then point at the 
location where the track/line is to start and click the left hand mouse button. Move the cursor and the line that is 
attached to it, into the position where the arc should finish and click the left hand mouse button again. A straight 
segment is produced that bends as the cursor is moved. The size and shape of the arc is dependent on the 
position of the cursor. Click the left hand mouse button to release the curve in the position chosen. The track 
remains attached to the cursor allowing a series of arcs to be added. Once the arc has been released, clicking 
the right hand mouse button releases the track from the end of the cursor. 
If the right hand mouse button is clicked whilst the curve is being stretched, a straight line segment is 
introduced, thus allowing a mixture of curved and straight tracks to be added. The arcs can be subsequently 
modified with the Amend > Corner/Adjust Arc commands. 

Amend > Enter Circle 
Used to add a circle on to the profile or keepout layers of the artwork. This command will not add a circle on any 
other layer. 
Select Amend > Enter Circle, tick either the Profile or Keepout category in the Amend Tracks dialogue bar (the 
layer and size settings have no effect with this command), then point at the centre of the required circle and click 
the left hand mouse button. As the cursor is moved a circle stretches, click the left-hand mouse button to 
release the circle.  
Use Amend > Move Point to move or adjust the size of the circle. 

Amend > Corner 
Used to add and move existing corners in tracks, lines or arcs. 
This command is typically used to modify individual silk screen outlines, documentation data, keepout lines, etc. 
Note, that tracks and pads can be disconnected using this command. Any errors will be highlighted by the 
artwork checking routine. 
(Use the Mroute > Move Track to change the connection order of tracks as it will not let you make mistakes.) 
Corners are added and then released with a click of the right hand mouse button. Corners are moved and then 
released with a click of the left hand mouse button. Clicking the opposite mouse button once a track or line has 
been selected cancels the operation. 
   right button   =    add corner 
   left button      =   move corner 
   (Opposite button cancels.) 
Only tracks or lines from the currently active layer as specified by the Amend dialogue bar can be selected. 
If the profile or keepout categories are modified, the profile editor is automatically updated. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Adding a corner to a track, line or arc  
Select Amend > Corner, ensure the Enter/Amend Tracks dialogue bar is set to the layer the track/line is on, then 
point at the line and click the right hand mouse button. Move the cursor and the new corner. Locate the cursor in 
the position for the new corner and click the right hand mouse button again to release the corner. 
Clicking the left hand mouse button before clicking the right hand button releases the track or line without the 
new corner. 

Moving an existing corner in a track, line or arc 
Note: this move corner command does not perform in the same way as the Mroute > Corner command, as it 
does allow the ends of tracks to be disconnected from pads or vias. 
Select Amend > Corner, ensure the Enter/Amend Tracks dialogue bar is set to the layer the track/line is on, then 
point at an existing corner from the layer, and click the left hand mouse button. Move the cursor and the corner 
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stretches with it. Locate the cursor in the new position for the corner and click the left hand mouse button again 
to release the corner. 
Note: if a track end is being moved and it is released within the capture distance of a layer 0 pad, a pad on the 
selected layer or any part pins, then it will snap to the centre of that pad. If the end-point is not near a pad or 
part pin, then it will snap to the nearest half or whole grid point if grid snapping is switched on. (Track mid-points 
do not snap to pads or part pins when released.) 
Clicking the right hand mouse button before clicking the left hand button returns the corner to its original 
position. 

Amend > Move Point 
Used to change the size or position of circles. This command can also be used to move an existing point 
(corner) in a piece of track or line, or to disconnect a piece of track from a pad or via, but the Corner command 
is more flexible for these purposes. 
If the "circle" has been defined using arcs, then it cannot be moved, the endpoints of the arcs can be moved to 
adjust its shape though. 
(Use the Mroute > Move Track to change the connection order of tracks as it will not let you make mistakes.) 
Any errors introduced will be flagged during the checking routines. 
If the profile or keepout categories are modified, the profile editor is automatically updated. 
Only tracks or lines from the currently active layer as specified by the Amend dialogue bar can be selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Moving a circle 
Select Amend > Move Point, ensure the Enter/Amend Tracks dialogue bar is set to the layer the circle is on, 
then move the cursor over the centre of the circle and click the left hand mouse key. Move the cursor with the 
circle attached into the required position and click the left hand mouse button again to release it. 
Clicking the right hand mouse button whilst the circle is attached to the cursor will return it to its original position. 

Changing the size of a circle 
Select Amend > Move Point, ensure the Enter/Amend Tracks dialogue bar is set to the layer the circle is on, 
then point at the circumference of the circle and click the left hand mouse key. As the cursor is moved, the 
circle's size changes. Click the left hand mouse button again to release the circle at its current size. 
Clicking the right hand mouse button whilst circle is attached to the cursor returns it to its original size. 

Moving points in tracks, lines or arcs 
Select Amend > Move Point, ensure the Enter/Amend Tracks dialogue bar is set to the layer the line is on, then 
move the cursor over the point you want to move and click the left hand mouse key. Move the cursor with the 
corner attached into the required position and click the left hand mouse button again to release it. 
Note: if a track end is being moved and it is released within the capture distance of a layer 0 pad, a pad on the 
selected layer or any part pins, then it will snap to the centre of that pad. If the end-point is not near a pad or 
part pin, then it will snap to the nearest half or whole grid point. (Track mid-points do not snap to pads or part 
pins when released.) 
Clicking the right hand mouse button whilst the corner is attached to the cursor returns it to its original position. 

Amend > Delete Point 
Used to remove points (or corners) from tracks, lines or arcs. 
This command will remove the end points of tracks, unlike the Mroute > Delete Point command. 
If a piece of track consists simply of two points, the start and end points, and one of the points is deleted, the 
track is removed. The artwork checking routines will flag an error if this means a valid track has been removed. 
If the profile or keepout categories are modified, the profile editor is automatically updated. 
Only tracks or lines from the currently active layer as specified by the Enter/Amend dialogue bar can be 
selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Delete Point, ensure the Amend Tracks dialogue bar is set to the layer the track/line is on, then 
point at a point (corner) in a track and click the left hand mouse button. The point is removed. 
Amend >Adjust Arc 
Used to convert straight segments into curves, curves into straight segments, and to change the shape of 
existing curves. 
If the profile or keepout categories are modified, the profile editor is automatically updated. 
Only tracks or lines from the currently active layer as specified by the Enter/Amend dialogue bar can be 
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selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 

Straight lines into arcs  
Select Amend >Adjust Arc, point at a track segment and click the left hand mouse button. Move the cursor, the 
segment is replaced with an arc on the end of the cursor. Once the arc is in the required position, click the left 
hand mouse button to release it. 

Arcs into straight line segments 
Select Amend >Adjust Arc, point at the arc and select it with a click of the left hand mouse button. Follow this 
with a click on the right hand mouse button to convert it to a straight line segment. 

Changing the shape of an arc 
Select Amend >Adjust Arc, point at the arc and select it with a click the left hand mouse button. Move the cursor 
with the arc attached and click the left hand mouse button when the arc is in the desired position. 
Clicking the right hand mouse button toggles the last selected line or arc between a line and an arc. The shape 
of the arc is defined automatically, and can be used to convert 45 degree lines into quadrants of a circle. The 
direction of the arc is determined by the position of the cursor about the line when the button is pressed. 

Amend > Delete Pad 
Used to delete pads from the layout. 
Component pads cannot be deleted in the artwork editor, as they are defined as part of the component outline. 
(They can be replaced with a different pad, using the Amend > Replace Pad command.)  
Only pads from the currently active layer as specified by the Enter/Amend dialogue bar can be selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Delete Pad, ensure the Enter/Amend Pads dialogue bar is set to the layer the pad is on, then 
point at the datum of the pad to be deleted and click the left hand mouse button. The pad is removed. 

Amend > Delete Track 
Used to delete a track, line, arc or circle from the board (tracks/silkscreen), or the profile or keepout lines. A 
complete length of track is deleted, i.e. between pads or vias. 
To restore the track to a connection, use the Mroute > Ripup command. 
Deleting a piece of track in this way does not remove the connection from the wiring list. Refer to the Tools > 
Network > Delete Pin command, or delete the connection from the schematic and recompile the parts and wiring 
list. 
If a track is deleted, the point to point connection is not restored until the artwork checking routines are 
performed. 
If the profile or keepout categories are deleted, the profile editor is automatically updated. 
Only tracks/lines from the currently active layer as specified by the Amend dialogue bar can be selected. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Delete Track, ensure the Enter/Amend Tracks dialogue bar is set to the layer the track/line is 
on, then point at the track, line, arc or circle to be deleted and click the left hand mouse button. The track is 
removed. 

Amend > Move Pad 
Used to move existing pads. Component pads cannot be moved in the artwork editor, as they are defined as 
part of the component outline.  
If via pads are moved, the tracks do not move with the pad so become disconnected. Use the Mroute > Corner 
command to maintain connectivity.  
Only pads from the currently active layer as specified by the Enter/Amend dialogue bar can be moved. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Move Pad, ensure the Enter/Amend Pads dialogue bar is set to the layer the pad is on. Point at 
the pad's datum and click the left hand mouse button. The pad moves with the cursor. Move the pad into 
position and click the left hand mouse button again to release it. 
Clicking the right hand mouse button whilst the pad is attached to the cursor returns it to its original position. 

Amend > Rotate Pad 
Used to rotate existing pads in 90 degree increments anti-clockwise. 
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Component pads cannot be rotated – instead use the Amend > Replace Pad command and replace the pad 
with a rotated pad of the required size and shape. 
Only pads from the currently active layer as specified by the Enter/Amend dialogue bar can be moved. 
Select Amend > Rotate Pad, ensure the Enter/Amend Pads dialogue bar is set to the layer the pad is on. Point 
at the datum of the pad to be rotated and click the left hand mouse button. The pad rotates 90 degrees anti-
clockwise each time the mouse button is clicked. 

Amend > Replace Pad 
Used to replace an existing pad for the currently active pad. 
Pin numbers are maintained if component pads are replaced. 
The datum of the new pad is positioned directly over the datum of the pad it is replacing. 
If the layer setting in the pads dialogue bar is set to V and a component pad is selected, the complete pad stack 
is replaced. If it is set to layer T or B, just the pads on those layers will be replaced (these are the top and 
bottom pads of the pad stack). If any of the other layers is active, then all the inner pads are replaced. 
Via pads are on layer V and the complete stack is replaced. Note: the Mroute > Corner command recognises 
vias as being a code zero round or square pad. If a different size or shape via pad is used, the Corner command 
will not operate on that via. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Amend > Replace Pad, ensure the Enter/Amend Pads dialogue bar is set to the layer the pad is on and 
the new angle required if appropriate. Point at the datum of the pad to be replaced and click the left hand mouse 
button. The pad is replaced with the active pad. More pads can be replaced as required. 
Note: if pads within outlines are changed using this command in the artwork editor, any subsequent changes to 
the pad size/shape in the outline library part, will not be implemented on the outline in the artwork editor which 
has had its pads amended. 

Amend > Set Size 
Used to change the size code of a track. A complete length of track is changed, i.e. between pads or vias or end 
points. 
Note: this command cannot be used on Profile or Keepout lines which have no size. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Only tracks/lines from the currently active layer as specified by the Amend dialogue bar can be selected. 
Select Amend > Set Size, ensure the Amend Tracks dialogue bar is set as required. Point at the piece of track 
to be changed and click the left-hand mouse button. 
Note: changing the size code may not change the width of the track as the width is defined in the track sizes 
table. 

Text commands 
Text can be added at any time to the board. If it is added to a copper layer, it is included in the artwork checking 
routine (copper) to ensure it does not cause clearance errors or short circuits.  
If it is added to a power plane layer, it is"not" copper, so ensure it does not overlap heat-relief pads to isolate 
them from the plane. If it is added to a silk screen or documentation layer, it is not checked in the artwork copper 
checking routine, as it is assumed that the layer will be manufactured with a non-conducting material. 
Separate silk-screen checking is available within the artwork checking routine to identify text over holes, 
underneath parts, etc. 
Silk screen names (labels) can be generated automatically using the Tools > Generate SilkScreen command. 
Once generated, the names can be manipulated as required using the Text commands. 
When the Text commands are selected, the Text dialogue bar appears down the left-hand side of the screen as 
shown in Figure 202. 
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Figure 202 

This dialogue bar should be adjusted to suit the text being added or modified as follows: 
Layer This determines which layer text is added to, and which layer text can be selected from. It is the 

"active" layer. All layers are available for selection. 
The Text commands will only select text from the active layer. 
If the active layer has been assigned a title (Configuration > Layer Assignments window), this is also 
displayed. 
The colour of the box helps to identify and also select layers; it can be selected to produce the layer 
assignments list which aids layer selection when using the spin-controls to change layers might be 
cumbersome.  

Height this setting controls the height of new text strings or those being modified.  
Line Size  this setting corresponds to the size codes from the Track Sizes table and it controls the thickness of 

line used to draw text characters when adding or changing text strings. The code can be changed by 
typing in a number (the cursor must remain in the dialogue bar whilst typing) or by selecting the spin 
controls alongside.  
The box underneath shows the actual size assigned to each code as it is selected. 
When adding tiny characters, a thin line size should be used, otherwise the characters will appear as 
blobs. Larger characters can be drawn with thicker line sizes. 

Rotation this setting determines the orientation of text strings that are added. If a text string is moved the 
setting is updated to correspond to the orientation of the selected text string. 

Text > Add 
Used to add text strings to the artwork. Text strings may be added to any layer - see the introduction above for 
details. 
Text may be added outside the board profile for informational purposes if required. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Ensure the Text dialogue bar is set correctly for the text string you wish to add. 
Select Text > Add, a window appears.  
If text has already been added or edited, the old text string appears in the window and may be selected and 
modified.  
If not, type in the text string required and tick the “Insert mirrored” checkbox if mirrored text is required.  
Select Place, the window closes and the text string appears on the end of the cursor, represented by a 
rectangle. As the string is moved, it may be rotated by pressing the user defined special function key for <rotate 
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a part>.  
Move the cursor into position and click the left hand mouse button to release it. Clicking the right hand button 
before the text is released restores the window allowing the string to be changed or cancelled. 
As the text is released, another copy of the text string appears on the end of the cursor and can be released in 
the same way or the right hand mouse button clicked to restore the window allowing the string to be changed or 
text addition cancelled. 

Text > Move 
Used to move text strings, including silk screen labels and URL anchors that have been placed on the board. 
The lower left corner of the text string is its datum point, though it can be selected anywhere along its length. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar.  
Ensure the layer setting in the Text dialogue bar is set to the layer on which the text string/URL symbol resides. 
Select Text > Move, then select the text string/URL symbol you wish to move. If a silkscreen label is selected, a 
line extends to its associated part. Text strings may be rotated by pressing the user defined special function key 
for <rotate a part>. Click the left hand mouse button to release the text/symbol in its new position. Clicking the 
right hand mouse button returns the text to its original position. 
When the text string is selected, the rotation setting in the text dialogue bar is updated to show the current angle 
of the text string. 

Text > Rotate 
Used to rotate text strings through 90 degree increments, anti-clockwise about the lower left hand corner of the 
string. For instance, text that has been rotated to 45 degrees will rotate to 135, 225, 315 and back to 45 
degrees. (Text can be rotated in increments of 1 degree once it is has been placed on the board using the Text 
> Edit command.) 
Text at 0 degrees is placed horizontally and read from left to right. 
Select Text > Rotate. Ensure the layer setting in the Text dialogue bar is set to the layer on which the text string 
resides. Select the text string, it rotates anti-clockwise by 90 degrees each time it is selected. 

Text > Mirror 
Used to mirror text strings about their centre. 
The layout is usually viewed looking down onto the top layer. Text placed the bottom layer should be mirrored 
when it is added so that it can be read correctly when the board is manufactured. 
Select Text > Mirror. Ensure the layer setting in the Text dialogue bar is set to the layer on which the text string 
resides, then select the text string you wish to mirror. Selecting the text string again mirrors it again. 
Text may also be mirrored/unmirrored whilst being added or edited. 

Text > Edit 
Used to edit text strings, including silkscreen labels, to change their height, orientation, mirrored status or the 
line size used to form the characters, once they've been added to the board. Also used to edit URL anchors 
added using the Text > Add URL Anchor command. 
Select Text > Edit. Ensure the layer setting in the Text dialogue bar is set to the layer on which the text string or 
URL Anchor symbol resides, and the line size is set as required if editing text strings. (If the text's line size 
should not be changed, ensure the line size setting corresponds to the text's current line size - use Identify > 
Feature to find this out if it is unknown.) Select the text string or URL Anchor Symbol to be edited.  
Text strings: a window appears containing the text string, its height, orientation and mirrored status - 

these can be changed as required. The angle setting has a choice of 4 "standard" 
angles to choose from, or the angle can be selected and re-typed to specify a "non-
standard" angle, such as 27 degrees.  

URL Anchor symbol:  a window appears allowing the referenced file/address, colour or symbol to be edited. 
(To view the actual URL/file, use the Text > Display URL command.) 

Select OK to implement the changes. Selecting Cancel leaves the text/URL anchor symbol as it was. 

Text > Add URL Anchor 
Used to attach design notes held in a file or a web-address, to the artwork layers in the shape of a symbol that is 
associated to the URL or file. 
A component outline is used as the symbol for the URL anchor - only the silk screen data part of the outline 
library entry is used. It is suggested that an outline be specially made for the URL anchor, to avoid any future 
confusion with “real” parts. 
When selected, a window appears, similar to that shown in Figure 203. 
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Figure 203 

It requires the following information: 
Outline name:  selecting the down-pointing arrow from the right hand side of the setting produces the list of 

outline names from the design and master libraries, from which one should be selected. This will 
be the symbol used for the URL anchor on the artwork. Characters can be typed in the field if 
preferred, but only valid outline names will appear – for example if DI is typed, then DIL14 will 
appear (if it is the first outline commencing with DI, if DIL2 is typed then DIL20 will appear).  

Address: the full path to the URL or file must appear here. A path can be typed, files “dragged and 
dropped” or the Browse button used to locate a file.  

Once this window has been set appropriately, the Place button will become active and can be selected.  The 
symbol will appear attached to the cursor and can be positioned with a click of the left button. 
The Text > Move/Edit/Delete commands can be used on the symbol. 

Text > Display URL 
Used to display the file, web page etc. associated with a symbol that was added using the Text > Add URL 
Anchor command. 
This command will work on all displayed URL symbols regardless of the active layer selected in the Text 
dialogue bar. Once the command has been selected, select the symbol, the associated web-page or file will 
open on the screen. 
Note: if the associated file does not exist, no warning messages or indications are given when the symbol is 
selected. Use the Text > Edit command to check the path associated with the symbol. 

Text > Delete 
Used to delete text strings including part labels or URL anchors from the board. 
Select Text > Delete. Ensure the layer setting in the Text dialogue bar is set to the layer on which the text string 
or URL anchor resides and then select the text string/symbol. The string/symbol is deleted. 

Text > Change Width 
Used to change the line size used to form the characters in text strings. 
Ensure the layer setting in the Text dialogue bar is set to the layer on which the text string resides and the line 
size is set to the size code required. 
Select Text > Change Width, then select the text string to be changed with a click of the left-hand button. The 
line size is changed. 
Note: Line size can also be changed using the Text > Edit command. 

Text > Change Height 
Used to change the height of text strings. 
Select Text > Change Height. Ensure the layer setting in the Text dialogue bar is set to the layer on which the 
text string resides and the Height is set as required. Select the text string with a click of the left-hand button. The 
height changes. 
Note: Height can also be changed using the Text > Edit command. 

Text > Get Label 
Used to add individual labels (silk screen names/part references) to parts. 
Silk screen labels are usually added automatically using the Tools > Generate Silkscreen command. However, if 
a modification has been made to a completed board, selecting auto-generation will duplicate existing labels as 
well as adding the new ones. The Text > Get Label command should therefore be used.  
The Text > Get Label command should also be used if a silk screen label is deleted accidentally. 
Refer to the Grid command for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Ensure the layer, height and line size settings in the Text dialogue bar are set as required. 
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Select Text > Get Label, then select the datum of a part with the left button for unflipped parts and the right 
button for flipped parts. (When the artwork is displayed in “flipped” mode, the sense of the buttons becomes 
reversed.) 
A rectangle appears on the end of the cursor representing the silk screen name. It may be rotated by pressing 
the user defined special function key for <rotate a part>. Move it into position and click the left-hand mouse 
button to release it. 
Clicking the right hand mouse button before the label is released cancels that label. 
When adding a label for a flipped part, the label is inserted in mirrored mode (so if the artwork is displayed in 
“flipped”mode, the label will appear the correct way around). 
 

Logo commands 
These commands are used to add, resize or delete symbols that have already been imported to the Logos 
Folder (details on page 175). 
The Logo dialogue bar shown in Figure 204 controls which layer the logo is placed upon, its size, orientation 
and whether it is flipped. 

 

Figure 204 

Once a logo is attached to the cursor (during placement or moving), the settings can be changed to update the 
attributes of the attached logo. 
Logos may be placed on powerplane layers, and will be visible within the powerplane edit mode.   
 
Layer: indicates which layer the Logo can be selected from. As each layer is selected, the 

datum positions of any placed logos will be highlighted on the artwork. 
Width: indicates the width of the rectangular area that represents the attached logo 
Height: indicates the height of the rectangular area that represents the attached logo 
Constrain Proportions: when checked, the logo will not change shape when changing its width or height 

setting.  
Angle: indicates the angle at which the logo will be positioned, pre-set angles (0/90/180/270) 

can be selected using the drop-down arrow, or the setting can be manually changed to 
increments of 1 degree – select the current value, then type the new angle required – 
take care not to move the cursor away from the dialogue bar when making the change. 

Mirror:  when checked, the logo will be mirrored (flipped). 
 

Logo > Place 
 
Used to add a pre-defined logo/symbol from the Logos folder, onto the artwork. 
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The Logo dialogue bar indicates the layer/size/orientation of the logo as it is positioned; these settings can be 
altered whilst the logo is attached to the cursor. 
Once selected, expand the Logos folder in the navigator, then select the desired logo with a click of the left 
button. Move the cursor across into the artwork editor at which time the logo will be seen attached to the cursor. 
Release the logo on the artwork in the desired location with a click of the left mouse button, the right button will 
cancel the attached logo.  

Logo > Move 
Used to move a logo that has already been positioned on the artwork. 
The settings within the Logo dialogue bar can be altered whilst the logo is attached to the cursor to change its 
size/layer/orientation. 
Select Logo > Move, ensure the Layer setting in the dialogue bar is set to the layer the logo is on, the datum 
points of all logos on the current layer are shown by small white crosses. Select the logo to be moved with a 
click of the left mouse button, it attaches to the cursor. 
Use the <rotate> user defined special function key to rotate the logo as it is moved.  
Click the left mouse button to release the logo in its new position. Clicking the right hand mouse button returns 
the logo to its original position. 
When the logo is selected, the Logo dialogue bar is updated to show the current settings of the logo, which can 
be changed as required. 

Logo > Rotate 
Used to rotate a logo that has already been positioned on the artwork. 
Select Logo > Rotate, ensure the Layer setting in the dialogue bar is set to the layer the logo is on, the datum 
points of all logos on the current layer are shown by small white crosses. Select the logo to be rotated with a 
click of the left mouse button, it rotates anti-clockwise by 90 degrees from its current angle each time it is 
selected. 
It is often easier to rotate a logo whilst it’s being moved using the <rotate> special function key.  
When the logo is selected, the angle setting in the Logo dialogue bar is updated to show its current value (none 
of the other settings change). 

Logo > Mirror 
Used to mirror a logo that has already been positioned on the artwork. 
Select Logo > Mirror, ensure the Layer setting in the dialogue bar is set to the layer the logo is on, the datum 
points of all logos on the current layer are shown by small white crosses. Select the logo to be mirrored with a 
click of the left mouse button, it mirrors about its original vertical axis each time it is selected. (So if the symbol 
has been rotated by 90/270 degrees on the artwork, it appears to mirror about the horizontal axis.) 
When the logo is selected, the Mirror setting in the Logo dialogue bar is updated to show its current value (none 
of the other settings change). 

Logo > Edit 
Used to edit any of the settings shown in the Logo dialogue bar for a selected logo. 
Select Logo > Edit, ensure the Layer setting in the dialogue bar is set to the layer the logo is on, the datum 
points of all logos on the current layer are shown by small white crosses.  
Select the logo to be edited with a click of the left mouse button, a dotted line will be shown around the edges of 
the selected logo; a new “Apply changes” button will appear in the Logo dialogue bar which is greyed out until a 
change is made in the dialogue bar. 
Make the changes required to the settings in the dialogue bar (when adjusting Width or Height settings, use the 
<tab> key to move between settings to ensure the new value is accepted in the box).  
Once a change has been made, select the “Apply changes” button to make the change. To cancel the command 
select another logo or a new command. 

Logo > Copy  
Used to copy a logo that has already been positioned on the artwork. 
Select Logo > Copy and ensure the Layer setting in the dialogue bar is set to the layer the source logo is on, the 
datum points of all logos on the current layer are shown by small white crosses.  
Select the logo to be copied with a click of the left mouse button, a copy of the logo appears attached to the 
cursor. The settings in the Logo dialogue bar can be altered to adjust the new logo if required. 

Logo > Delete 
Used to delete a logo from the artwork. 
Select Logo > Delete and ensure the Layer setting in the dialogue bar is set to the layer the logo is on, the 
datum points of all logos on the current layer are shown by small white crosses.  
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Select the logo to be removed with a click of the left mouse button on its datum, it will be removed.  
 

Region commands 
The Region commands are used to define a rectangular area around a group of items on selected layers in 
order to move, copy, rotate, delete or store them.  
The Show Rules command determines which layers/categories of data are included in the rectangular area. 
Notes: when tracks are deleted using the Region commands, their unroutes are not restored until the artwork 
checking routine is run. 
Deleting individual layers with an option to retain fixed tracks is also available separately - right-click on the 
Artwork from the navigator pane and select the Delete Tool – refer to page 202 for details of this command. 

Region > Show Rules 
Used to display the rules dialogue that controls which layers/items are included/excluded when using the Region 
commands. 
When Region > Show Rules is selected, the Rules dialogue appears as shown in Figure 205. 

 

Figure 205 

The layers of the board are listed, along with coloured boxes representing those layers for ease of recognition. A 
check box alongside each layer allows it to be selected/deselected for use with the Region operations. By 
default, none of the layers are selected (ticked). 
Only 16 layers can be displayed at one time, so a layer selection setting will be found at the top of the dialogue, 
allowing layers V,T,B,1-13, 14-29, 30-45 or 46-61 to be displayed in the dialogue.  
When individual layers are selected/deselected they maintain their status even though they may not be visible in 
the dialogue bar. 
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To assist with the selection/deselection of all layers (V,T,B,1-63), None and All buttons are provided. 
In addition to the data on the layers, parts on the top and/or bottom of the board, the board profile, keepout 
areas and copper fill boundaries can also be selected/deselected for use with the Region commands.  
Depending on what is required, a combination of layers/items will probably be selected. 

Region > Move/Rotate 
Used to move and/or rotate data from selected layers/categories within a rectangular area. 
Refer to the Region > Show Rules command for details on item selection within the area. 
The datum of a part has to be inside the area for it to be included. 
If parts are not included in the rule selection, but there are tracks on the selected layers connected to their pins, 
the tracks will move and become disconnected from the pads. If tracks become disconnected in this way, 
connectivity (not the tracks) will be restored the next time the artwork is checked. 
Tracks, profile lines or keepout lines that straddle the region are excluded from the move/rotate. 
The datum of the region is the corner that is attached to the cursor. 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Region  > Move/Rotate. Click the left mouse button to locate one corner of the recatular area to be 
moved/rotated. Move the cursor, stretching the attached rectangle to its desired shape, then click the left mouse 
button again to define the area. The area will change colour and move with the cursor.  
Each press of the rotate function key will rotate the rectangle anti-clockwise by 90 degrees. 
Click the left mouse button again to release the area in its new position. A right-click will cancel the move/rotate. 

Region > Copy 
 Used to copy or copy/rotate data from selected layers within a rectangular area, excluding parts and component 
pads. 
(Use Region > Macro Generate/Add to include and copy component pads.) 
Tracks, profile or keepout lines that straddle the area are excluded from the copy. 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Refer to the Region > Show Rules command for details on item selection within the area. 
Select Region > Copy. Click the left mouse button to locate one corner of the recatular area to be copied. Move 
the cursor, stretching the attached rectangle to its desired shape, then click the left mouse button again to define 
the area. The area will change colour and move with the cursor.  
Each press of the rotate function key will rotate the rectangle anti-clockwise by 90 degrees. 
Click the left mouse button again to copy and release the area in its new position. A right-click will cancel the 
move/rotate. 

Region > Delete 
Used to delete data from selected layers within a rectangular area, excluding parts.  
Use Region > Unplace to remove parts from the artwork. 
Tracks, profile or keepout lines that straddle the region are excluded from the delete. 
If tracks are deleted using this command, the unroutes are not restored until after an artwork check is 
performed. To maintain the unroutes when deleting tracks, use the Mroute > Ripup command. 
Refer to the Region > Show Rules command for details on item selection within the area. 
Select Region  > Delete, click the left mouse button to locate one corner of the recatular area to be deleted. 
Move the cursor, stretching the attached rectangle to its desired shape, then click the left mouse button again to 
define the area. The area will change colour and a prompt will indicate that a left click will delete the area or a 
right-click will cancel the operation.  

Region > Unplace 
Used to return unrouted, unfixed parts within a rectangular area to the placement tray. 
The datum of a part has to be inside the area for it to be included in the area. 
Any parts that have routed or partially routed tracks connected to them will not be removed - a message 
appears in the information bar to that effect.  
Parts that have been fixed with the PartFix commands are not removed, they should be unfixed first. 
Region > Unplace operates on parts from the selected layers in the rules dialogue, refer to the Region > Show 
Rules command for details. 
Select Region > Unplace, click the left mouse button to locate one corner of the recatular area. Move the cursor, 
stretching the attached rectangle to its desired shape, then click the left mouse button again to define the area. 
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The area will change colour and a prompt will indicate that a left click will unplace the parts within the area or a 
right-click will cancel the operation. 
The unrouted, unfixed parts within the area are returned to the part placement tray. 

Region > Macro Generate 
Used to create a "macro" of the selected layers within a rectangular area and save it to disk. 
A "macro" is a piece of artwork that can be saved and then re-introduced into the same or another artwork. It 
has the advantage over Region > Copy as it will also include component pads (but not the parts themselves), 
however part and connectivity information is not saved with the macro.  
Note: the pads in the macro are not identified as component pads with pin numbers, etc. This means that 
routines that operate on component pads will ignore them, such as the automatic solder paste output.  
The datum of a part has to be inside the area for its pads to be included. 
The board profile and keepout data are not included when using the Region > Macro Generate command, even 
if they are selected via the Region > Show Rules command. 
Tracks that straddle the region are excluded from the macro. 
The layers the items reside on are maintained in the macro, but the layer usage is not. For instance, layer 3 
could have been a silk screen layer when the macro was generated. This macro can be added to any layout 
without affecting the layer usage of the layout.  
It is not possible to transfer data between layers using macros. (Depending on the requirement, either Gerber 
input, or input to a documentation layer from the output tools could be used.) 
The macro file is saved in a folder on the hard disk - by default in the folder defined by the File > System Setup 
window however, any other folder can be chosen. 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Refer to the Region > Show Rules command for details on item selection. 
Select Region > Macro Generate, click the left mouse button to locate one corner of the recatular area. Move 
the cursor, stretching the attached rectangle to its desired shape, then click the left mouse button again to define 
the area. The area will change colour and a prompt will indicate that a left click will store the macro or a right-
click will cancel the operation.  
If the left-click is used, the browser appears, allowing you to navigate around to locate the folder in which you’d 
like the macro stored. Type in a name for the macro (the default extension of .amf is added automatically). 
Once the name has been typed, press <enter> or select OK. The information bar should indicate the operation 
was successful. 

Region > Macro Place 
Used to add previously created macros to the layout. 
When the macro is added to the current layout, the actual pad and track sizes used in the macro (not the code 
numbers) are matched to the layout's existing pad and track sizes. As an example, a 0.065" round code 8 pad in 
the macro might become a 0.065" round code 12 pad in the layout. 
If a pad or track size does not appear in the sizes table of the layout but it is used in the macro, that size is 
added to the layout, providing an unused code is available. An error message is given if there are no unused 
codes available. 
Layer usage is not stored with the macro. For instance, layer 3 could have been a silk screen layer when the 
macro was generated. This macro can be added to any layout without affecting the layer usage of the layout. 
It is not possible to transfer data between layers using macros. (Depending on the requirement, either Gerber 
input, or input to a documentation layer from the output tools could be used.) 
Refer to the Grid commands for details on whether grid snapping is active. The current grid is shown in the 
information bar. 
Select Region > Macro Add. A window appears listing all the artwork macros that exist in the artwork macro 
folder, as defined by the File > System Setup window. Use the browser to locate a different folder if required. 
Select the macro required, followed by Open. The window closes, and a rectangle representing the macro 
appears attached to the cursor.  
Select the position required for the macro and the contents of the macro are added to the layout. Another copy 
of the macro appears attached to the cursor, which can be added in the same way. Click the right mouse button 
to cancel the next macro. 

Deleting/Renaming macros 
Artwork macro files can be deleted or renamed using the Windows browser, outside of XL Designer.  
Use the browser to locate the macro file, then select the file with a click of the right mouse button. Select Delete 
or Rename from the options that appear.  
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The browser window appears when Region > Macro Generate/Add is selected – at that time any of the files can 
be selected and then deleted/renamed. 

Check commands 
Check > Angles 45 OK 
Used to indicate any track segments that are at an angle other than 0, 45 or 90 degrees. Arced track segments 
are not included in this check. 
The check is run for user information only. No action is required if angle errors are flagged.  
When the check is selected, all existing angle error flags are removed. 
Select Check > Angles 45 OK. The checking is activated. The number of track segments that do not conform to 
the angles specified is given in the information bar. The segments are indicated with error flags showing the 
letter A, for Angle error, inside them. 
If angle errors were reported but the flags cannot be seen, they are probably invisible. The View Control 
dialogue bar controls their visibility, and the Check > Next ErrorFlag command can be used to locate them. 
The error flags are not removed until another angle check is performed, or they are deleted manually using the 
Check > Delete/Delete All ErrorFlag commands.  

Check > Angles No 45 
Used to indicate any track segments that are not at 0 or 90 degree angles. Arced track segments are not 
included in this check. 
The check can be run for user information only. No action is required if angle errors are flagged.  
When the check is selected, all existing angle error flags are removed. 
Select Check > Angles No 45. The checking is activated. The number of track segments that do not conform to 
the angles specified is given in the information bar. The segments are indicated with error flags showing the 
letter A, for Angle error, inside them. 
If angle errors were reported but the flags cannot be seen, they are probably invisible. The View Control 
dialogue bar controls their visibility, and the Check > Next ErrorFlag command can be used to locate them. 
The error flags are not removed until another angle check is performed or they are deleted manually using the 
Check > Delete/Delete All ErrorFlag commands. 

Check > Connectivity 
Before the artwork can be regarded as "finished" this command should always be used.  
It comprises two separate checks Copper checks and Silk-screen checks. It is essential that the Copper checks 
are performed and any errors investigated and corrected before proceeding to output/manufacture the design, 
otherwise an incorrect board may be produced. The Silk-screen checks are optional and used to produce a 
more manufacturable board. 
Only one of the checks can be selected and performed at a time. 
The copper checking routine is used to indicate any clearance violations between copper items, or differences 
between the artwork and the parts and wiring list (such as missing or shorted tracks).  
Providing the parts and wiring list was compiled from a circuit schematic and the schematic has not been 
changed, the checks will also indicate differences between the artwork and the schematic. 
The silk-screen checks are optional and indicate whether silk-screen data is touching pads/vias on the outer 
layers of the board, an undesirable feature from assembly/soldering purposes. They can also indicate whether 
the silk-screen text lies within the area occupied by the auto-placement footprint, something that is undesirable 
when trying to locate part references on a populated board.  
The Parts > Status command indicates whether all the parts have been placed. 

Other reasons to use the connectivity checker 
• Checking can also be performed to validate tracks that have been added using the Amend commands 

– these are not automatically recognised as belonging to a particular net. Provided they create a valid 
connection the artwork checker will validate them, they will then highlight, join to copper fill, etc.. 

• Schematic/parts/wiring list changes can sometimes result in unroutes appearing for routed tracks after 
the modification, in which case the checker will remove unroutes provided the associated tracking is 
correct (there are no short circuits).  

• Unroutes sometimes remain for routed tracks after the auto-router has been used. Running the check 
will remove unrequired unroutes. 

Copper checks 
Layers defined as silk-screen or documentation layers are not included in the artwork copper checking routines 
- they are ignored as it is assumed they will be produced from non-conducting materials or are not part of the 
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board.  
When the checking routine is selected, if any copper filled areas have been added to the artwork then the 
copper fill is automatically included in the copper checks, but this can slow down the checking process. The 
copper fill checks can be switched off if required using the switch provided, but ensure the implications of 
switching them off are understood – see below. 
The checking routine can also identify copper (tracks/pads/text) within a keepout area. This check can also be 
excluded if required. 
The copper checks require the minimum default clearance required between copper items to be specified. Any 
specific clearance requirements defined on the schematic or in the wiring list for selected connections will be 
applied to the appropriate connections. 
Note: when defining minimum clearance values on the schematic it is possible to define two different minimum 
clearance values for one net (using the Wires > Attributes and Tools > EMC Attribute Tags commands), if this 
occurs, the larger of the two minimum clearances specified is used.  
When started, the copper check routine checks every space between copper items (pads, tracks, text, etc.) to 
ensure the space or "gap" is at least the size specified. If gaps are found that are less than the size specified, a 
gap error is reported, and a gap error flag placed on the artwork next to the offending gap. 
Because it is possible to have more than one minimum gap requirement, each gap error flag is given a numeric 
suffix that appears inside the error flag. When error flags are visible, a table is displayed in the bottom left corner 
of the artwork editor, showing the numeric suffixes and the minimum clearance requirement for each one. 
Once the gap checking sequence has finished, a connectivity check is performed. The copper (not the copper fill 
unless it has been included in the check) on the board is scanned and a "wiring list" generated from the scan. 
This "wiring list" is compared against the original parts and wiring list for differences. 
Typical errors are connections that have not been routed or tracks that have been shorted to one another.  
If missing connections are found, the connections are re-inserted, and will need routing.  
If short circuits are found, the checking routine tries to determine where the actual short has occurred and will 
place a short circuit error flag there. This can take a considerable amount of time, so the user can move on to 
the next stage of the checks by selecting the Skip Short Search button when it becomes active. As a guide, if 
the short circuit check has been running for more than 30 seconds, it is unlikely to be able to find the exact 
location of the short. If skipped, the final error report indicates that short circuits were found between the nets 
identified, but doesn’t flag the actual locations. 
Unplaced parts and parts outside the board profile are also flagged as possible errors.  
 
Once the checking routine has finished, the error report can be printed or directed to a file.  
When the checks are complete, the artwork should be viewed and the reported errors corrected.  
Always run the artwork checks again once the errors have been corrected, as it is very easy to introduce more 
errors when clearing reported errors. The board should not be manufactured until all errors have been cleared 
and no errors are reported (it is possible to produce the output files with the errors uncorrected, but not 
recommended). 
Important Notes: 

• On power plane layers, the artwork checking routine does not detect isolated pins which can be caused 
by the proximity of anti-pads, heat-relief pads or isolation lines to one another. 

• On power plane layers, anything added to the plane layers is removing copper and could cause 
isolated areas/pins and this is not identified by the checking routine. 

• On power plane layers, short circuits caused by split plane boundaries crossing through heat-relief 
pads are not flagged. 

• Free copper added within a component outline is NOT included in the artwork checking routines. 
• Logos may be placed on powerplane layers, and will be visible within the powerplane edit mode.  

However, logos that are placed in powerplane layers are currently invisible to the artwork checker.  No 
checks for violation with other powerplane features will be performed 

• If a single node net has been assigned an EMC rules clearance parameter in the schematic, the default 
clearance value is used to check violations of the part pin on that single node net. (A single node net is 
a component pin that is not connected to any other component pin in the wiring list.) 

• If a net has been assigned an EMC rules clearance parameter in the schematic, and the checking 
routine detects that the net has been incorrectly routed, then the default clearance value is used to 
check that net until the net has been correctly routed. 

• Unroutes for routed tracks will disappear provided each track segment of the net is attached to the 
centres of connected pads/vias. By manually adding tracks that aren’t connected to the pad/via 
centres, it is possible to make a connection that would not be permanent if the part/via were to be 
moved in the future. In this event, an error is not reported because the connection has been made, 
however to indicate this may lead to a problem in future, the unroute will remain even though the track 
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is “joined”. To ensure the unroute is removed upon checking, ensure the tracks end on the centres of 
pads – this can best be identified with the tracks and unroutes set to centrelines and the pads unfilled. 
Use Amend > MovePoint to release the off-centre track-ends onto the centres of the pads, then re-
check. 

• Free copper features that interconnect component pins in an outline defined as a “star point” outline is 
never seen by the artwork checker.  It is essential that the star point outline is manually verified to 
ensure it does actually perform the desired interconnectivity between its pins. 

•  Parts outside the board profile may be flagged even though they appear to be within the profile - this is 
due to an approximation being made of the area occupied by the outline and the board profile shape – 
the check is designed to identify parts that have been temporarily placed outside the profile that may 
have been forgotten about, rather than a precise check. 

• The artwork checker tests all copper type layers to determine if any antipads or heat-reliefs are 
present, and will abort artwork checking if any are found.  A report of the unwanted pad locations will 
be displayed - they can be cleared automatically by right-clicking Artwork from the navigator pane, then 
selecting the Delete Tool. 

• Star points: the checking routine does not verify the copper connections between the star point outline 
pins, these must be manually verified to ensure the outline does actually perform the desired 
interconnectivity between its various pads.. 

• Logos: Artwork checking does not check for clearance to each individual vector within the logo. The 
boundary of each logo is represented by a rectangular area and it is this rectangular area that is used 
during artwork checking to identify the extents of the symbol.  

Running the copper checks  
Select Check > Connectivity. The window shown in Figure 206 appears and should be set up as required. A 
description of each setting follows. 
 

 
Figure 206 

Tick the button alongside Enable Copper Check if it isn't already ticked to enable the copper checks (this will 
automatically disable the Silk-screen Checks). 
Default Minimum Signal Clearance edit this value to correspond to the smallest clearance acceptable 

between separate (non-connected) signal items (pads/tracks/copper) on 
the board that do not have a minimum clearance specified from the 
schematic or wiring list.  
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Default Minimum Power Clearance edit this value to correspond to the smallest clearance acceptable 
between separate (non-connected) power items (pads/tracks/copper) on 
the board that do not have a minimum clearance specified from the 
schematic or wiring list.  
Ranger always checks using the largest minimum clearance specified if 
there is a conflict – for example if a connection on the schematic has a 
minimum clearance value of 0.005” assigned, but the default minimum 
clearance for the design is set to 0.012”, then the 0.012” value is used 
when checking. 
These settings are automatically updated to correspond to the values 
assigned for online-DRC in the artwork editor when manually routing 
tracks. If the values are changed in this window, then the change is 
automatically updated in the manual routing parameters window in the 
artwork editor. 

Include Copper Fill  This is automatically selected if copper fill has been detected on the 
board - only switch it off if the implications of not including it are 
understood. If unsure, keep it selected. 
The copper fill checks do slow down the running time of the checking 
routine and increase the memory requirements of the design which is why 
a switch is provided. 
The copper fill checks can safely be switched off if the copper fill was 
added using the non-smooth edge mode and it has not been modified 
manually (using the Amend commands). 
The copper fill checks should be included if: 
• the copper fill has been modified manually (using the Amend 

commands) 
• it is suspected that the connectivity provided by the copper fill has 

been broken. 
• the smooth edge mode was used to add the fill - this can result in 

isolated areas of copper occurring 
• the copper fill is being relied upon to provide the connectivity of a net 

. (Typically the copper fill is added after all the connections have 
been routed. However it is possible to leave a net unrouted and use 
the copper fill routine to form the connectivity of that net. In this case 
the fill routine cannot be relied upon to connect to every node in the 
net and this check should be performed to identify unconnected 
nodes. 

If the copper fill is included in the checking, then each segment of the 
copper filled area is checked: 
• to ensure it is not too close to any other piece of copper 
• it is not isolated from a component pin 
• not shorting different tracks together 
• that it completes the net to which it is attached 

Include Keepouts  This check will indicate any copper items (tracks/pads/text) inside a 
keepout area, or that cross a keepout line. This may/maynot be a 
problem so the check can be switched off if required. 

 Violations are indicated by an error flag on the artwork with a letter K (for 
Keepout). 

The Close button can be selected to abandon the checks, or select Start to run the checks.  
Whilst the check is running, messages appear at the top of the checking window to indicate what is happening 
as the checking routine runs through its various "phases".  
If short circuits are detected it can take a long time to identify exactly where the short exists. The Skip Short 
Search button can be selected to speed up the checks, but if selected, error flags will not be placed at the 
locations of the short circuits - but the nets which are shorted will be identified in the error report. 
When the checking routine is complete, the report will either indicate Artwork check complete, No errors found 
or a list of errors will be reported. 
If no errors were found, the artwork is complete.  
If errors were found they must be investigated and corrections made as appropriate.  
The error report can be printed or directed to a file by selecting the File > Print or File > Save As command from 
the top of the report window. If File > Save As is selected, the file can be placed wherever required using the 
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browser window that appears. 
When connectivity errors are reported, the missing connections are added to the artwork, and will be seen when 
the artwork is next viewed. They should of course be routed. 
The artwork should be viewed and the reported errors corrected. Ensure the error flags are visible using the 
View Control dialogue bar. The Check > Next Errorflag command can also be used to find the error flags. The 
flags, shown as a small circle with a tail, contain the letter G for a gap (clearance) error or the letter S for a short 
circuit error. 
Artwork checking Aborted 
Under certain conditions the checking routine cannot perform so the check will be aborted. A message is given 
and the reason for the failure to complete the checks will be given.  This problem should always be rectified so 
that the checking can be performed. 

Typical error messages 
The following messages are given as examples from an error report: 
Example 1  

----------Shorted Signals---------- 
Signal 
C4.1  R2.1  IC1.4  
  --- shorted to signal --- 
C3.1  C2.1  PL1.5 
Short circuit(s) detected at:- 
X 3606 Y 2798 (flagged) 

This message indicates that the two signals listed are shorted to one another at the location X 3.606", Y 
2.798", and a short circuit flag has been added. 

Example 2  
If more than two signals were shorted together, the message would include all the signals in the report. For 
instance, the following message indicates that three signals are shorted to one another:  

----------Shorted Signals---------- 
Signal 
C4.1  R2.1  IC1.4  
   --- shorted to signal --- 
C3.1  C2.1  PL1.5 
   --- shorted to signal ---  
IC3.10 C12.1  IC2.5 
Short circuit(s) detected at:- 
X 3606 Y 2798 (flagged) 
X 4500 Y 3609 (flagged) 

Typically flags identify the offending short-circuit so they are easy to locate and correct. However, where 
very large nets are involved the shorts may not be located. In these cases, the shorted signals are 
identified, but not the actual location of the short-circuit. These have to be located by eye. 
If it seems as though every net on the board is shorted to every other net on the board, does the board 
contain power planes? If it does, have they been generated, or have some extra pads or vias been added 
since the power planes were generated? If the answer is Yes to any of these questions, the power planes 
should be generated again and the checks re-run. 

Example 3 
If the report indicates a short circuit, but does not specify which other net the net is shorted to, then this 
indicates the net includes duplicate pins (which should be rectified). For example: 

----------Shorted Signals---------- 
Signal : GND 
C14.2  D19.2  D11.2  IC5.16   
D17.3  C5.1  D4.2  D5.2  
IC5.16  LK1.2  IC1.8  IC1.19 
IC2.10  IC3.10  IC4.8 
 

If this net is examined, you’ll notice that IC5.16 appears twice. To rectify this problem, return to the source 
of the wiring list – either the schematic diagram or the imported netlist and remove the duplicate pin 
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reference. 
On a schematic diagram a typical mistake involves defining one pin twice in a part, as a terminal and also 
an implied power pin. Edit the appropriate part and use the Terminals > Check command to identify multiple 
use of pins. Correct (by removing one of the definitions) as appropriate. Extract the parts/wiring list, then 
run the artwork check again. 
In an imported netlist there is no checking performed on the netlist when it is imported, so either edit the 
wiring list from the wiring list editor (remember to correct the change at the source as well) or correct the 
netlist at source and re-import. 
Example 4 
The following message is given when connections have not been routed for whatever reason: 

----------Connectivity Errors---------- 
Error in net 
R2.2  C4.2  BR1.4  C1.2  PL1.7  
Subnet R2.2  C4.2 
not connected to 
Subnet BR1.4  C1.2  PL1.7  

The above message indicates that there is an error in the net (signal) which is listed. It then indicates that 
the error is caused because the net has been split into two halves or "subnets", i.e. R2.2 and C4.2 are 
connected together, as are BR1.4, C1.2 and PL1.7, but there is a track missing between the two "subnets". 
When viewing the artwork, the missing connection will re-appear. 

Example 5  
The following message is similar, but this time PL1.6 is not connected to anything. 

----------Connectivity Errors---------- 
Error in net 
R3.2  BR1.2  PL1.6 
No connection to node(s):- 
PL1.6 

Example 6  
The following message is given when the complete net has not been routed: 

Error in net:- 
PL1.11  IC6.4  IC10.11 
Net has not been routed 

The same message which lists only one part pin as follows, indicates that a "single node net" exists. 
Error in net:- 
IC6.3 
Net has not been routed 

A single node net is an entry in the wiring list that is not connected to anything else. They can be caused on 
the circuit by a connection being added to a pin and not terminating on another pin, or a signal name being 
left off. Find out whether the pin should be connected, then rectify the schematic accordingly and recompile 
the parts and wiring list. Take appropriate action on the artwork. 

Example 7  
-----The following partpins should not be connected----- 
IC6.2 

This message indicates that a track has been connected to the pin listed (IC6.2), which should in fact be 
unconnected: 

Example 8  
Warning: 4 isolated copper fill regions found 

This message indicates that the copper fill has areas that are unconnected. It is undesirable to complete an 
artwork with isolated copper areas, so these should be removed. To view the isolated copper ares, ensure 
all the copper layers are visible (View Control dialogue bar) and isolated copper areas are visible (View > 
Isolated Copper). The isolated copper areas will be displayed in white. They can be deleted automatically if 
Tools > Copper Fill followed by Filled Copper > Delete All Isolated Copper is selected. A message will 
appear asking for confirmation of the deletion. 

Example 9  
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-------------------------- Parts check ----------------------------- 
 
Warning : Part MP5 is not placed 
Warning : Part MP6 is not placed 
Warning : Part MP8 is not placed 
Warning : Part SK11 is outside the board profile 
Warning : Part SK12 is outside the board profile 

This message indicates that the parts MP5, 6 & 8 have not been placed on the artwork and parts SK11 & 
12 have been placed outside the board profile. This is a warning and should be investigated but can be 
ignored if appropriate. 

Example 10 
------------ Artwork checker initialisation problems --------------- 
 
Split powerplane layer 1 : Subnet polygon error for power signal '12V 
    No polygon defined 
 
Split powerplane layer 1 : Subnet polygon error for power signal 
'EARTH 
    No polygon defined 
 
Copper_check aborted 

This message indicates that.the copper checking has been aborted because the split-powerplane layer 1 
has not been defined or generated. The split-plane must be created and the check run again. 

Example 11 
 

------------ Artwork checker initialisation problems --------------- 
 
Split powerplane layer 6 : Subnet polygon error for power signal '0VA1 
    Polygon is defined in powerplane generator, but cannot locate the matching 
    polygon on the artwork layer 
 
Split powerplane layer 6 : Subnet polygon error for power signal '0VA2 
    Polygon is defined in powerplane generator, but cannot locate the matching 
    polygon on the artwork layer 
 
Split powerplane layer 6 : Subnet polygon error for power signal '0VA3 
    Polygon is defined in powerplane generator, but cannot locate the matching 
    polygon on the artwork layer 
 
Split powerplane layer 6 : Subnet polygon error for power signal '0VA4 
    Polygon is defined in powerplane generator, but cannot locate the matching 
    polygon on the artwork layer 
Copper_check aborted 

 
This message indicates that.the copper checking has been aborted because the split-powerplane polygons 
for the secondary power rails (0VA1, 2, 3 & 4) on layer 6 have not been correctly identified. Use the 
SplitBoundary > Import Boundary command to identify the polygons and generate the planes again. Run 
the check once the planes have been re-generated. 
This message typically appears on designs that have been created with Ranger XL or SXLD prior to v1.72. 
Once the polygons have been imported and planes re-generated, the problem should be resolved. 
 

Example 12 
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Heat relief pad found on non-powerplane layer 1 at X   3.4500 Y   1.9500 
Heat relief pad found on non-powerplane layer 1 at X   1.8000 Y   2.5000 
Heat relief pad found on non-powerplane layer 1 at X   2.7000 Y   3.2000 
Antipad found on non-powerplane layer 1 at X   4.0500 Y   3.7000 
Antipad found on non-powerplane layer 1 at X   4.1500 Y   3.7000 
Antipad found on non-powerplane layer 1 at X   1.2000 Y   2.5000 
Copper_check aborted 

 
This message indicates that.the copper checking has been aborted because heat-relief and/or anti-pads 
have been found on a copper layer and this is invalid. These pads MUST be deleted before the checks can 
be run. Use the Delete Artwork tool (right-click on Artwork in the navigatior) to quickly remove unwanted 
heat-relief/Antipads from copper layers or use the Amend command in the artwork editor to remove them 
individually 
Note: X/Y co-ordinates are given with respect to absolute 0/0 and not the datum, which can be moved. 
This message typically appears on designs that have once had a powerplane and this has been changed to 
a copper layer. 

All errors should be investigated and corrected, then the checks re-run. Repeat until no errors are reported. 

Artwork checking, silk-screen checks 
This routine identifies any layers defined as silk-screen layers and indicates data (lines/text) on those layers that 
is close to or touching pads and/or vias on either of the two outer copper layers (top and bottom) of the board. 
It can also be used to indicate text within the area of a component outline's auto-placement footprint. 

Running the Silk-screen Checks 
Select Check > Connectivity. The window shown in Figure 207 appears.  
 

 
Figure 207 

Tick the button alongside Enable Silk-screen Check to enable the silkscreen checks (this will automatically 
disable the Copper Checks). (This button is not selectable if no silk-screen layers have been detected in the 
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artwork.) 
Set the window as required, a description of each setting follows. 
Check for silk-screen against outer copper layers 

This section is used to specify which silk-screen layers should be checked with which of the outer layers. 
A list of the silk-screen layers detected appears, and alongside them, three columns from which one setting 
can be selected: 

Disabled if selected this silk-screen layer is not included in the checks. If all the silk-
screen layers are disabled, due to there being nothing to check, the Start 
button will remain greyed out. 

Top Copper if selected, this silk-screen layer is checked against the top layer. 
Bottom copper if selected, this silk-screen layer is checked against the bottom layer. 

Silkscreen checking mode 
The buttons alongside Precise check or Check for text within auto-place footprint can be selected, 
depending on what is required. Both checks can be run, one after the other. 
Precise Check  

Features to check when the check is performed both silkscreen lines and text can be identified and 
checked or just the text. Select from: 
All features Lines and text on the selected silk-screen layers is included in the 

check. 
Text only Only the text on the selected silk-screen layers is included in the 

check. 
Check for conflict with Part pads when selected, the checking routine will identify any of the silk-

screen features being checked that are closer than the minimium 
clearance requirement to component pads.  

Check for conflict with Via holes when selected, the checking routine will identify any of the silk-
screen features being checked that are closer than the minimium 
clearance requirement to via holes. Pads added using the Amend > 
Enter Pad command are also included in this check. 

  
Minimum Clearance this defines the minimum distance required between silk-screen data 

included in the check and the pads/vias on the selected layer(s). 
Check for text within autoplace footprint 

This check if enabled will identify any text that is within the autoplacement footprint (as defined within 
the component outline). This check can be used to ensure the part references can be viewed on a 
populated board. 

The Close button can be selected at this stage to abandon the checks, or select Start to run the checks.  
Messages appear at the top of the checking window to indicate what is happening, the checking routine runs 
through various "phases".  
When the checking routine is complete, the report will either indicate Silkscreen check complete, No errors 
found or a number of errors will be reported. 
If errors were found they should be investigated and corrections made if required. When the artwork is viewed, 
ensure the error flags are visible using the View Control dialogue bar. The Check > Next Errorflag command can 
also be used to locate the error flags. The flags, shown as a small circle with a tail, contain the letter M for a silk-
screen Mask error. 
Re-run the check if changes were made. 

Check > Count Unroutes 
Used to indicate the number of unrouted tracks on the artwork. 
It is often easy to miss unrouted tracks that are between pins of ICs, etc. and think the board is completely 
routed. This check can be run to ensure that all the tracks have been routed before running the final artwork 
checks. (The final artwork checks also indicate unrouted tracks.) 
Select Check > Count Unroutes. A report appears in the information bar listing the number of normal unroutes 
and the number of partial unroutes - a "normal" unroute is a pad to pad connection that has not been routed, it is 
shown as a solid line - a partial unroute is a pad to pad connection that has been routed but not completed, the 
unrouted part is shown as a dashed line.  
Partially unrouted connections are highlighted with an error flag containing the letter U for Unroute, complete 
unroutes are not flagged. If partial unroutes were reported but the flags cannot be seen, they are probably 
invisible. The View Control dialogue bar controls their visibility, and the Check > Next ErrorFlag command can 
be used to locate them. 
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If  the dashed partial unroutes cannot be seen, they will appear when the copper layer that they are attached to 
is displayed. 
If the unroutes cannot be seen, ensure that all signal and power connections are visible (View Control dialogue 
bar). 
If they still cannot be seen, make all the layers temporarily invisible (View Control dialogue bar) except for the 
unroutes. 
The error flags remain until they are deleted using the Check > Delete/Delete All ErrorFlag commands or the 
checks performed again. 

Check > Next ErrorFlag 
Used to indicate the "next" error flag. It momentarily flashes the next occurrence of an error flag to aid its 
location. 
Ensure that the error flags are visible in order to see them, using the View Control dialogue bar. 
This facility is useful when clearing reported errors, since time is saved when trying to locate them. 
If the next error flag is outside of the current screen area, the screen is re-drawn to centre the flag. 
Each error flag is highlighted in turn until each one has been shown. If next is selected again, the errors are 
highlighted again. This happens even if the errors have been corrected. Use the Check > Delete ErrorFlag 
command to remove the individual error flags so they are no longer located. 
Select Check > Next ErrorFlag, the next error flag momentarily flashes on the screen. 

Check > Delete ErrorFlag 
Used to delete individual error flags. Deleting the error flag does not remove or correct the error. 
As reported errors are cleared, it is beneficial to remove the error flags, as it is easier to see which errors are 
left. The Check > Next ErrorFlag command highlights all error flags in turn, even if the cause of the error has 
been removed. 
Once errors have been corrected, it is good practice to run the checks again. This ensures that the error flags 
were not deleted accidentally, or that new errors have not been introduced. 
Select Check > Delete ErrorFlag. Point at the end of the tail extending from an error flag, and click the left hand 
mouse button to delete it. 
This command stays active until the right hand mouse button is clicked. 

Check > Delete All ErrorFlags 
Used to delete all types of error flags (angle errors, gap errors and short circuit errors). Deleting the error flags 
does not remove or correct the errors. 
When the error checking routines are selected, all existing error flags for that type of check are deleted 
automatically. For instance, existing angle error flags are deleted when angle checking is performed, but not 
when Check >Connectivity is selected. 
Once all the error flags have been deleted using this method, it is good practice to run the checks again. This 
ensures the error flags were not deleted accidentally, or that new errors have not been introduced. 
Select Check > Delete All ErrorFlags. All the error flags are deleted. 

Netfix commands 
These commands are used to fix and unfix tracks in the artwork editor. 
There is no requirement to fix tracks unless the board is being submitted to a rip-up auto- router. However, the 
Delete All Artwork command does allow individual layers to be deleted whilst retaining fixed tracks, which is 
useful if you want to start the artwork tracking again, but retain some existing routed features. 
The Seetrax rip-up router or Specctra/Elecctra routers will not rip-up fixed tracks. Before boards are submitted to 
the auto-routers, it is often desirable to pre-route some tracks that have specific routing requirements. Examples 
of this are power tracks and high speed clock signals which are best routed by the designer to ensure they meet 
the design criteria. 
Power and any hand-routed signal tracks are automatically fixed as they are added. 
Whilst in the Netfix menu, fixed tracks are highlighted to indicate they are fixed. The highlighting is removed as 
soon as they are unfixed. 
Note: before tracks that have been added using the Amend commands can be fixed, they must be identified and 
recognised as valid tracks by running the artwork checking routines. A valid track is one that makes a 
connection between pins in a net from the wiring list. 
The Netfix menu allows tracks to be fixed and unfixed in a variety of ways using the following commands.  

NetFix > Selected Nets 
Used to select tracks for fixing or unfixing, depending on whether the Fix or Unfix Mode is selected from the 
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NetFix pull-down menu. All the tracks connected to the selected track will become fixed or unfixed. 
Ensure the NetFix > Fix Mode/Unfix Mode is selected as required. Select NetFix > Selected Nets, then select a 
track. The highlighting switches on or off depending whether Fix Mode or Unfix Mode is selected to indicate the 
track is fixed or unfixed. 

NetFix > By Pin Reference 
Used to fix or unfix tracks, depending on whether the Fix or Unfix Mode is selected from the NetFix pull-down 
menu, that are connected to a pin of a specified part. 
Ensure the NetFix > Fix Mode/Unfix Mode is selected as required. Select NetFix > By Pin Reference. A window 
appears requesting a pin reference. Type in the pin reference as a part name, followed by a dot and the pin 
number, e.g. IC4.3 or R1.2, etc. Press <enter> or select OK and all the tracks attached to that pin become fixed 
or unfixed. The highlighting switches on or off depending whether Fix Mode or Unfix Mode is selected to indicate 
the track is fixed or unfixed. 
If the net has a name, its name is shown in the information bar.  

NetFix > By Signal Name 
Used to fix or unfix tracks, depending on whether the Fix or Unfix Mode is selected from the NetFix pull-down 
menu, by their signal name. 
Ensure the NetFix > Fix Mode/Unfix Mode is selected as required. Select NetFix > By Signal Name. A window 
appears requesting a signal name to be entered. Type in the signal name then press <enter> or select OK and 
all the tracks connected to that signal become fixed or unfixed. The highlighting switches on or off depending 
whether Fix Mode or Unfix Mode is selected to indicate the track is fixed or unfixed. 

NetFix > All Nets 
Used to fix or unfix, depending on whether the Fix or Unfix Mode is selected from the NetFix pull-down menu, all 
of the routed tracks. 
Ensure the NetFix > Fix Mode/Unfix Mode is selected as required. Select NetFix > All Nets. All of the routed 
tracks become fixed or unfixed. The highlighting switches on or off depending whether Fix Mode or Unfix Mode 
is selected to indicate the tracks are fixed or unfixed. 

NetFix > Fix Mode 
When selected/active the Netfix commands will fix any tracks that are specified from that point onwards, until the 
selection is changed. 

NetFix > UnFix Mode 
When selected/active the Netfix commands will unfix any tracks that are specified from that point onwards, until 
the selection is changed. 

Hilight commands 
These commands are used to high-light or hide specific connection nets and, or routed tracks with a chosen 
colour for identification purposes. 
Note: before tracks that have been added using the Amend commands can be highlighted, they must be 
identified and recognised as valid tracks by running the artwork checking routines. A valid track is one that 
makes a connection between pins in a net from the wiring list. 
When any if the Hilight commands is selected, the Hilight dialogue bar appears as shown in Figure 208.  
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Figure 208 

The coloured boxes can be selected to produce the colour palette (as shown in Figure 208) and the colour of 
choice selected.  
The radio button alongside one of the colours indicates which colour will be used to highlight the 
selected/named nets.  
If the colour is changed whilst a net is highlighted with that selection, the highlighting is changed to reflect the 
new colour chosen. 
The (Hide) setting allows the selected nets to be hidden from view by making them black. Clearing all highlights 
will bring the hidden nets back into view. 

Hilight > Selected Nets 
Used to high-light connections and/or tracks that are attached to the selected connection or track. 
Connection or tracks are highlighted in the colour selected from the Hilight Colour dialogue that appears when 
any of the Hilight commands are selected.  
Select the colour required for the highlight before high-lighting the tracks/nets.  
The highlighting remains on until it is switched off by either highlighting an already highlighted net or by selecting 
the Hilight > Clear All command. 
Select Hilight > Selected Nets, then select a track or a connection. All the tracks and connections belonging to 
that net are highlighted. If the net has a name, its name is displayed in the information bar. 
Selecting the track or connection again removes the highlighting. 

Hilight > By Pin Reference 
Used to high-light the position of connections and/or tracks that are attached to a pin of a specified part. 
Connection or tracks are highlighted in the colour selected from the Hilight Colour dialogue that appears when 
any of the Hilight commands are selected.  
The highlighting remains on until it is switched off by either highlighting an already highlighted net or by selecting 
the Hilight > Clear All command. 
Select Hilight > By Pin Reference. A window appears requesting a pin reference. Type in the pin reference as a 
part name, followed by a dot and the pin number, i.e. IC4.3 or R1.2, etc. Press <enter> or select OK and all the 
tracks and connections attached to that pin are highlighted. If the net has a name, its name is displayed in the 
information bar.  
Selecting the track or connection again removes the highlighting.  

Hilight > By Signal Name 
Used to highlight connections and tracks by their signal name. 
If a signal exists in both upper and lower case versions (i.e. CLOCK and clock), then only the one matching the 
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case entered will be highlighted. 
If a signal name is unique (i.e. only CLOCK exists) then the search name may be specified in upper\lower or 
mixed case.  
The wild card * can be used to represent all characters to highlight all named signals. 
Connection or tracks are highlighted in the colour selected from the Hilight Colour dialogue that appears when 
any of the Hilight commands are selected.  
The highlighting remains on until it is switched off by either highlighting an already highlighted net or by selecting 
the Hilight > Clear All command. 
Select Hilight > By Signal Name. A window appears requesting a signal name to be entered. Type in the signal 
name pin. Press <enter> or select OK and all the tracks and connections attached to that signal are highlighted.  
Selecting the track or connection again removes the highlighting. 

Hilight > Clear All 
Used to remove all highlighting from connections and tracks. 
If you wish to remove the highlighting from selected tracks only, highlight those nets again individually to toggle 
the highlighting off. 
Select Hilight > Clear All. All the highlighting is removed. 
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Specctra auto-router interface 
XL Designer comes with a two-way interface to the Specctra auto-router. The Specctra auto-router is an 
optional extra that can be purchased if required. 
The interface allows an artwork layout to be output from XL Designer in a format that the Specctra auto-router 
software can accept. Once the Specctra software has auto-routed the design, its output file can be converted 
back into XL Designer for further design work and checking as required. 
The artwork design that is submitted to Specctra can include keep-out data (Specctra will not cross a keepout 
line) and pre-routed fixed or un-fixed tracks. 
The Specctra auto-router will use user-defined via stacks if they are defined and enabled for use. 
To access the Specctra interface, it should first of all be enabled (File > System setup window). 
Then, open the design to be submitted to the Specctra auto-router. Right-click on Artwork from the navigator, 
then select Optional Autorouters > Cadence/ CCT Specctra router. A window similar to the one in Figure 209 
appears. 

 
Figure 209 

Before submitting the design to the auto-router, the settings in this window should be set as required. The 
window is divided into areas that control the options that are included in the file that is output for the Specctra 
auto-router. Use the following information to decide how it should be set. 
If the interface has not been used before, select the Installation button and ensure the window is set to match 
the Specctra auto-router to be used (described below). 

Routing options 
Off grid selections are Yes or No. With Yes selected, tracks can be routed off the chosen tracking grid 

where necessary. Typically set to No. 
45 degree angles selections are Yes or No. With Yes selected, the following command is added to the 

script file (rangerxl.do) that controls the routing of the design.  
bus diagonal 

Refer to the Specctra Reference Guide for details on this command, but basically if enabled, 
45 degree tracks are permitted in tracks. Typically set to Yes. 

Spread tracks - selections are Yes or No. With Yes selected, the following command is added to the script file 
(rangerxl.do) that controls the routing of the design.  

  spread (extra 5 25) 
Refer to the Specctra Reference Guide for full details on this command, but basically when 
routing is complete, tracks are spread apart. 

Mitre tracks selections are Yes or No. With Yes selected, the following command is added to the script file 
(rangerxl.do) that controls the routing of the design.  
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  miter (slant 50) (bend 50 25) 
Refer to the Specctra Reference Guide for full details on this command, but basically when 
routing is complete, right-angled tracks have their corners replaced with chamfers. 

Use EMC attributes selections are Yes or No. With Yes selected, any attributes added to connections or 
pins on the schematic using the Tools > EMC Attribute Tags will be included in the Specctra 
design file. The router will then attempt to comply with these commands. 
With No selected, none of the EMC Net or Pin attributes will be output in the design file. 

Allow standard vias selections are Yes or No. With Yes selected, code 0 round pads will be included in 
the output file produced, for use by the Specctra auto-router as vias. If No is selected, then 
code 0 round pads will not be included in the output file, so therefore these vias could not be 
used. 
(Vias defined in the Configuration folder (Via Hole Definitions) that have have the Enable for 
routing box ticked will always be included in the output file produced.) 

Clearances and Grids 
Edge clearance enter the default minimum clearance required between copper items on the artwork and 

the board profile. 
Track clearance enter the default minimum clearance required between adjacent copper items on the 

artwork. Specific clearance requirements added to the schematic will over-ride this default. 
Via grid Defines the minimum pitch that vias can be placed on. Unless there are specific reasons to 

choose a different via grid, use the same grid as defined for the tracking grid. Refer to the 
Specctra Reference Guide for details. 

Tracking grid Defines the minimum pitch that tracks can be placed on. Because Specctra is a shape-
based router, it would be unwise to restrict it with a course tracking grid. Refer to the 
Specctra Reference Guide for details on the size of tracking grid to use. 

Pass Counts 
Fanout passes supply the number of fanout passes required. Refer to the Specctra Reference Guide 

for details. As a rule of thumb, 0 fanout passes should be specified for boards with 
less than 6 layers and 5 passes for boards with 6 layers and above. 

Routing passes supply the number of routing passes required. Refer to the Specctra Reference Guide 
for details. Typically 50 are specified. 

Cleaning passes supply the number of cleaning passes required. Refer to the Specctra Reference 
Guide for details. Typically 2 are specified. 

Number of re-routes supply the number of re-route passes required. The number entered, multiplies the 
number of routing passes and cleaning passes performed in sequence. Refer to the 
Specctra Reference Guide for details. Try 3 to start with, but this may need to be 
increased depending on board complexity. 

Via Holes Under SMD Pads 
The following settings can be selected: 

Never allowed vias are not allowed within any SMD pads. 
Allowed on all outlines vias are allowed in all SMD pads. 
Only on outlines with "Allow vias at SMD" property 

vias are only allowed in SMD pads who have the "Allow vias at SMD pads" 
setting ticked in the outline's properties window (Component Outline editor, 
View > Properties). 

Layer routing strategy 
Each layer is listed, with its current layer assignment shown. Only layers defined as copper layers can be 
altered. The preferred routing direction for each copper layer should be selected. 
The layer can be set to Disabled if it should not be used. 

Starting the router 
Once the setup window has been set as required, the router can be run automatically from within XL Designer 
with no further intervention by the user, or the output files can be produced for manual submission to the 
Specctra autorouter. 

Automatic method 
This is the easiest way to run the router and requires little knowledge of the Specctra software.  
Once the settings in the window have been set as required, select the Run Router button. 
When this option is chosen, a design file (.dsn) and script (.do) file are extracted from XL Designer, the Specctra 
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software is run and both files submitted to the router automatically.  When routing is complete, the tracking is 
automatically fed back into the artwork design in XL Designer. 
If Run Router is selected, messages appear in the window to indicate what is happening, then the auto-router 
starts.  
If errors occur and the router doesn't start, close the Specctra interface window, then open the Logfiles folder 
from the navigator and select the file specctra_export.txt. This file supplies information that will be helpful in 
working out why the router didn't start, which can be for a variety of reasons. 
When the auto-router has finished, the results are saved, Specctra is closed down and the results fed back into 
the XL Designer design. 
When the artwork is being converted back into XL Designer, messages appear on the screen to indicate what is 
happening. If any errors or warnings are reported, they should be investigated and action taken where 
necessary. The errors and warnings are described in a file, which can be viewed by opening the Logfiles folder, 
then selecting the file specctra_import.txt. 
The Run Interactively button starts the Specctra auto-router in the same way, but when routing has finished, 
Specctra remains open and the design is not fed back into XL Designer automatically. 
Note: If the router is stopped manually, for instance stop is entered at the router prompt, the results are not 
saved. To force a save, type in the following command in response to the router prompt: 
   do $\xlsave.do 
The results are saved. Use the Import button to bring the routed tracks back into Ranger.  

Manual Method 
This method should be used if you wish to modify the design file or script file that Specctra will use, or the 
Specctra auto-router software is on a different machine. 
The layout has to be extracted in the correct format and submitted to the router manually.  
The layout is extracted using the Export button, at which time three files are produced. The design file 
(xldesigner.dsn) and two script files (xldesigner.do and xlsave.do) are placed in the folder specified by the 
Installation button.  
These files should be submitted to the Specctra auto-router for routing. Refer to the Specctra documentation for 
details on how to do this. 
The file xldesigner.do contains the commands as defined by the Specctra setup window within XL Designer. 
The file can be modified as required. 

Sample xldesigner.do file: 
# Script file for file c:\specctra\rxldesigns\rangerxl.dsn 
bestsave on $\best.w 
status_file $\rangerxl.sts 
bus diagonal 
route 50 
clean 2 
route 50 16 
clean 2 
route 50 16 
clean 2 
center 
spread (extra 5 25) 
miter (slant 50)(bend 50 25) 
write wire $\rangerxl.w 
write routes $\rangerxl.rte 
report status $\rangerxl.sts 
 

If any warnings or errors are reported when the file is being exported from XL Designer, the problems should be 
investigated. Close the Specctra interface window, then open the Logfiles folder, select the file 
specctra_export.txt. Take any action required, then export the data again if required. 
Once the Specctra router has completed routing the design and saved the results, a file called xldesigner.rte will 
have been created. This should be moved if necessary to the same folder that the files were originally exported 
to. This file has to be imported back into XL Designer; so within XL Designer, open the design from which the 
file was exported and open the Specctra auto-router interface. Select the Import button. 
When the artwork is being imported, messages appear on the screen to indicate what is happening. If any errors 
or warnings are reported, they should be investigated and action taken where necessary. The errors and 
warnings are described in a file called specctra_import.txt, which can be viewed from the Logfiles folder. 

Specctra configuration window 
Before submitting a design to the Specctra auto-router, this window has to be set to match the Spectra 
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installation to be used. 
From the Specctra interface window, select Installation, the window shown in Figure 210 appears. 

 
Figure 210 

 
Router executable path this path should be set to the location where the Specctra executable file is 

located. 
Specctra versions 6 and 7, path is typically: \specctra\bin\specctra.exe 
Specctra version 8, path is typically: \cct_cds\tools\SPECCTRA\bin\specctra.exe 
If this path is incorrect, then Ranger will be unable to start the Specctra auto-
router when Run Router/Run Interactively is selected. 

Routing Work File Directory this path can be set to any folder. The folder MUST exist prior to selecting 
Run/Export. XL Designer will place the files it creates for the Specctra router in 
this folder. It also expects to find the Specctra files that should be imported, in 
this folder. 

Licensed router capability The Specctra auto-router comes with different specifications and options 
enabled. In order that XL Designer only creates files that are within the 
specification of the auto-router, the following settings should be set correctly. 
Refer to the Specctra license file for details on your router's 
specification/options. 

Maximum pins the maximum number of component pins that this Specctra can handle. 
Maximum signal layers the maximum number of signal layers that this Specctra can handle - power 

plane/split power planes are not included in this count. 
DFM Option whether or not the DFM (Design for Manufacture) option has been enabled. 
ADV option whether or not the ADV (Advanced) option has been enabled. 
HYB option  whether or not the HYB (Hybrid) option has been enabled. 
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Electra auto-router interface  
XL Designer comes with a two-way interface to the Electra auto-router. The Electra auto-router is an optional 
extra that can be purchased if required. 
The interface allows an artwork layout to be output from XL Designer in a format that the Electra auto-router 
software can accept. Once the Electra software has auto-routed the design, its output file can be converted back 
into XL Designer for further design work and checking as required. 
The artwork design that is submitted to Electra can include keep-out data (Electra will not cross a keepout area) 
and pre-routed fixed or un-fixed tracks. 
The Electra auto-router will use user-defined via stacks if they are defined and enabled for use. 
Circular board profiles are converted into a polygon with 128 segments (2 degree steps). 
To access the Electra interface, it should first of all be enabled (File > System setup window). 
Then, open the design to be submitted to the Electra auto-router. Right-click on Artwork from the navigator, then 
select Optional Autorouters > Konekt Electra router. A window similar to the one in Figure 211 appears. 

 
Figure 211 

Electra router setup 
Before submitting the design to the auto-router, the settings in this window should be set as required. The 
window is divided into areas that control the options that are included in the file that is output for the Electra 
auto-router. Use the following information to decide how it should be set. 
If the interface has not been used before, select the Installation button and ensure the window is set to match 
the Electra auto-router to be used. 

Routing options 
Off grid selections are Yes or No. With Yes selected, tracks can be routed off the chosen 

tracking grid where necessary. Typically set to No. 
45 degree angles selections are Yes or No. With Yes selected, the following command is added to the 

script file (rangerxl.do) that controls the routing of the design.  
bus diagonal 
If enabled, 45 degree tracks are permitted in tracks. Typically set to Yes. 

Spread tracks currently not supported by Electra. 
Mitre tracks selections are Yes or No. With Yes selected, the following command is added to the 

script file (rangerxl.do) that controls the routing of the design.  
recorner pin 200 
recorner slant 500 
recorner bend 400 
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When routing is complete, right-angled tracks have their corners replaced with 
chamfers. 

Use EMC attributes  selections are Yes or No. With Yes selected, any attributes added to connections or 
pins on the schematic using the Tools > EMC Attribute Tags will be included in the 
Electra design file. The router will then attempt to comply with these commands. 
With No selected, none of the EMC Net or Pin attributes will be output in the design 
file. 

Allow standard vias selections are Yes or No. With Yes selected, code 0 round pads will be included in 
the output file produced, for use by the Electra auto-router as vias. If No is selected, 
then code 0 round pads will not be included in the output file, so therefore these vias 
could not be used. 
(Vias defined in the Configuration folder (Via Hole Definitions) that have the Enable 
for routing box ticked will always be included in the output file produced.) 

Clearances and Grids 
Edge clearance enter the default minimum clearance required between copper items on the artwork 

and the board profile. 
Track clearance enter the default minimum clearance required between adjacent copper items on the 

artwork. Specific clearance requirements added to the schematic will over-ride this 
default. 

Via grid Defines the minimum pitch that vias can be placed on. Unless there are specific 
reasons to choose a different via grid, use the same grid as defined for the tracking 
grid.  

Tracking grid Defines the minimum pitch that tracks can be placed on. Because Electra is a shape-
based router, it would be unwise to restrict it with a course tracking grid.  

Pass Counts 
Fanout passes supply the number of fanout passes required. As a rule of thumb, 0 fanout passes 

should be specified for boards with less than 6 layers and 5 passes for boards with 6 
layers and above. 

Routing passes supply the number of routing passes required. Typically 50 are specified. 
Cleaning passes supply the number of cleaning passes required. Typically 2 are specified. 
Number of re-routes supply the number of re-route passes required. The number entered, multiplies the 

number of routing passes and cleaning passes performed in sequence. Try 3 to start 
with, but this may need to be increased depending on board complexity. 

Via Holes Under SMD Pads 
The following settings can be selected: 

Never allowed vias are not allowed within any SMD pads. 
Allowed on all outlines vias are allowed in all SMD pads. 
Only on outlines with "Allow vias at SMD" property 

vias are only allowed in SMD pads who have the "Allow vias at SMD pads" 
setting ticked in the outline's properties window (Component Outline editor, 
View > Properties). 

Layer routing strategy 
Each layer is listed, with its current layer assignment shown. Only layers defined as copper layers can be 
altered. The preferred routing direction for each copper layer should be selected. 
The layer can be set to Disabled if it should not be used. 

Starting the router 
Once the setup window has been set as required, the router can be run automatically from within XL Designer 
with no further intervention by the user, or the output files can be produced for manual submission to the Electra 
autorouter. 

Automatic method 
This is the easiest way to run the router and requires little knowledge of the Electra software.  
Once the settings in the window have been set as required, select the Run Router button. 
When this option is chosen, a design file (.dsn) and script (.do) file are extracted from XL Designer, the Electra 
software is run and both files submitted to the router automatically.  When routing is complete, the tracking is 
automatically fed back into the artwork design in XL Designer. 
If Run Router is selected, messages appear in the window to indicate what is happening, then the auto-router 
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starts.  
If errors occur and the router doesn't start, close the Electra interface window, then open the Logfiles folder and 
select the file electra_export.txt. This file supplies information that will be helpful in working out why the router 
didn't start, which can be for a variety of reasons. 
When the auto-router has finished, the results are saved, Electra is closed down and the results fed back into 
the design. 
When the artwork is being converted back into XL Designer, messages appear on the screen to indicate what is 
happening. If any errors or warnings are reported, they should be investigated and action taken where 
necessary. The errors and warnings are described in a file, which can be viewed by opening the Logfiles foler 
and viewing the file electra_export.txt. 
The Run Interactively button starts the Electra auto-router in the same way, but when routing has finished, 
Electra remains open and the design is not fed back into XL Designer automatically. 
Note: If the router is stopped manually, the results are not saved. To force a save, execute the xlsave.do 
command from within Electra. Use the Import button to bring the routed tracks back into Ranger.  

Manual Method 
This method should be used if you wish to modify the design file or script file that Electra will use, or the Electra 
auto-router software is on a different machine. 
The layout has to be extracted in the correct format and submitted to the router manually.  
The layout is extracted using the Export button, at which time three files are produced. The design file 
(xldesigner.dsn) and two script files (xldesigner.do and xlsave.do) are placed in the folder specified by the 
Installation button.  
These files should be submitted to the Electra auto-router for routing. Refer to the Electra documentation for 
details on how to do this. 
The file xldesigner.do contains the commands as defined by the Electra setup window within XL Designer. The 
file can be modified as required. 

Sample xldesigner.do file: 
# Script file for file c:\Program Files\electra\rxldesigns\rangerxl.dsn 
bestsave on 
bus diagonal 
route 50 
clean 2 
route 50 16 
clean 2 
route 50 16 
clean 2 
recorner diagonal 
write routes c:\Program Files\electra\rxldesigns\rangerxl.rte 
write session c:\Program Files\electra\rxldesigns\rangerxl.ses 
status_file 

 
If any warnings or errors are reported when the file is being exported from XL Designer, the problems should be 
investigated. Close the Electra interface window, then open the Logfiles folder and view the file 
electa_export.txt. Take any action required, then export the data again if required. 
Once the Electra router has completed routing the design and saved the results, a file called xldesigner.rte will 
have been created. This should be moved if necessary to the same folder that the files were originally exported 
to. This file has to be imported back into XL Designer; within XL Designer, open the design from which the file 
was exported and open the Electra auto-router interface. Select the Import button. 
When the artwork is being imported, messages appear on the screen to indicate what is happening. If any errors 
or warnings are reported, they should be investigated and action taken where necessary. The errors and 
warnings are described in a file called electra_import.txt, which can be viewed via the Logfiles folder. 

Electra configuration window 
Before submitting a design to the Electra auto-router, this window has to be set to match the Electra installation 
to be used. 
From the Electra interface window, select Installation, the window shown in Figure 210 appears. 
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Figure 212 

 
Router executable path  this path should be set to the location where the Electra executable file is 

located. Select the browser button alongside the path name to assist in the 
selection of the correct path. 
Path is typically: c:\Program Files\electra\electra.exe 
If this path is incorrect, then Ranger will be unable to start the Electra auto-
router when Run Router/Run Interactively is selected. 

Routing Work File Directory this path can be set to any folder. The folder MUST exist prior to selecting 
Run/Export. XL Designer will place the files it creates for the Electra router in 
this folder. It also expects to find the Electra files that should be imported back, 
in this folder. 
Select the browser button alongside the path name to assist in the selection of 
the correct path. 

Router version There are two versions (1 and 2) of the Electra autorouter. Select the version 
you will be using. 
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Importing Files 
The following importers are available within Seetrax XL Desiger: 

Parts & Wiring List Import to import parts/wiring lists for artwork design 
Gerber Format File Import  to import gerber files for checking/design regeneration 
AutoCAD DXF File Input to import board profile definitions 

The importers are each described separately in the following chapters. They are accessed once a design has 
been opened, by right-clicking the design name from the Navigator pane, then selecting Import followed by the 
import routine required. 
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Gerber Format File Import 
The Gerber file import routine is used to re-create Gerber files in the artwork editor. Once imported, the data can 
be:  

visually checked to ensure the Gerber file(s) contain the correct type of information. 
modified and new Gerber files produced  
used to re-create a complete design (from another CAD system) for further design work 

Information: 
A file in the Gerber format is required. XL Designer can accept various Gerber formats and the following details 
will be required by XL Designer before the files can be imported accurately: 

the number of decimal places in the co-ordinates 
whether the co-ordinates are in incremental or absolute format 
the X and Y shifts used when outputting the data 
which DCodes have been used, the size and shape assigned to each DCode 

If this information is not available the resultant input may be incorrect. It may take 3 or 4 attempts at importing 
the file before success is achieved - if the size/shape assigned to the dcodes is unknown, then the pad and 
track sizes on the imported artwork are highly likely to be incorrect. 
An understanding of the Gerber file format can explain why some problems occur when importing the gerber 
files - sometimes the importer does not produce the results expected. (Refer to the chapter on gerber output for 
brief details on the gerber file format.) 
If the gerber file contains a header, the importer ignores the information within the header – this means the 
dcode table in the importer setup window has to be defined manually. 

Procedure: 
Open the design that the Gerber files will be imported into. 
Note: when working on an existing design, it is suggested that a backup copy of the design is taken before 
importing the file - the results may not be as expected at the first attempt. 
Right-click the design name from the Navigator pane, then select Import > Gerber photoplot data. A window 
similar to the one in Figure 213 appears: 

 

Figure 213 

This window controls the Gerber import and should always be checked before proceeding with each Gerber file 
as it is unlikely that any two Gerber files will use the same setup parameters. Change it as required, using the 
following information to assist you: 

Gerber Photoplot Importer window, Setup tab window settings: 
X and Y shift:  the Gerber files contain X/Y co-ordinates. The co-ordinates can be positive or negative 

numbers. In order to see the regenerated artwork in XL Designer, the co-ordinates must be 
positive and within XL Designer’s working area (0 to 99" in the X & Y axes). The values 
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entered here are added to all the co-ordinates in the gerber file as they are imported (the 
gerber file is not modified).  
Inspect the co-ordinates within the gerber file and calculate the values required for the 
shifts. Alternatively experiment with different values until the data appears in the artwork 
editor. 

Co-ordinate units:  Gerber files can be produced in either Imperial or Metric units (usually Imperial). The 
importer needs to know which units are being used so that the data is regenerated at the 
correct scale.  
If the data is imported, but it is too big or small by a factor of 2.54, then it's likely that the co-
ordinate units was set incorrectly.  

Co-ordinate type:  Gerber files can be produced in either absolute or incremental format. The importer needs 
to know which format to expect. (Absolute format gives co-ordinates with respect to a 
specific datum whilst incremental format gives co-ordinates with respect to the last co-
ordinate given.) 

Decimal Places: the Gerber file typically contains co-ordinates containing five figures without decimal points. 
The importer needs to know how many decimal places there are in each co-ordinate to 
ensure the artwork appears at the correct scale. 
If your data is imported, but it is too big or small by a factor of 10, then it is likely that the 
number of decimal places was set incorrectly.  

Layer mode:  the imported data is placed on a user-specified layer in the artwork editor. The data can be 
added to the existing data on the layer (select Append to Layers) or it can replace the data 
(select Replace layers). 

Main Layer: the layer number specified here specifies which layer the Gerber data will be placed on, 
with the exception of flashed apertures ("pads" and "vias"). 

Pads layer: the flashed apertures ("pads") within the Gerber file will be added to the layer specified 
here. Seetrax XL Designer recognises "pads" in a Gerber file as follows:  

any shaped DCode that is flashed 
any rectangular shaped DCode that is drawn and makes a one segment orthogonal 
line 

If the Gerber files are being imported for a visual check prior to plotting, add the contents of 
each Gerber file to one artwork layer (Main layer, Pads layer and Via Layer set to the same 
layer).   
When the artwork is viewed, the layer will correspond to the contents of the Gerber file. 
Each separate Gerber file should be added to a different layer. 
If the Gerber files are being imported to regenerate a design, the data within the file would 
probably be split on to different layers – refer to Regenerating a design from Gerber files for 
more details.  

Via Layer:  any pads produced by a flashed aperture using the dcode assigned for vias will be added to 
the layer specified here. If they are added to layer V, XL Designer will recognise them as 
vias. 
"Vias" within a Gerber file are recognised purely by their DCode number, indicated by the 
next parameter. 
If the Gerber files are being imported for a visual check prior to plotting, add the contents of 
each Gerber file to one artwork layer (Main layer, Pads layer and Via Layer set to the same 
layer).  
When the artwork is viewed, the layer will correspond to the contents of the Gerber file. 
Each separate Gerber file should be added to a different layer. 
If the Gerber files are being imported to regenerate a design, the data within the file would 
probably be split on to different layers - refer to Regenerating a design from Gerber files for 
more details.  

Via DCode:  any flashed apertures in the Gerber file with the DCode number specified here, will be 
assigned to round, code 0 in the pad sizes table. XL Designer will then regard them as vias. 
This facility is useful when re-generating designs. 
If a design is being imported for checking purposes only, this can be left at 0. 

Gerber filename:  specify the name of the Gerber file that will be imported. The browse button can be used to 
locate folders and files. 

Gerber Photoplot Importer window, Dcode tab window settings: 
When the DC 10-31 tab is selected from the top of the Gerber Photoplot Importer window, a window similar to 
the one shown in Figure 214 appears. This is the Dcode table for the incoming gerber file and should be set to 
suit the incoming gerber file. 
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Dcodes from 10 to 255 can be defined by selecting the appropriate tab from the top of the window. 
 

 

Figure 214 

The Gerber file contains DCodes which were defined when the Gerber file was created. Each DCode represents 
a specific size and shape of aperture, which in turn represents pads and tracks on the imported artwork. It is 
essential that the import DCode table is set up to exactly match the original DCode table used when creating the 
Gerber files. If it isn't, the regenerated pads and tracks will probably be the incorrect size or shape, although 
they will be in the correct relative places. 
The design’s pad and track size tables are updated automatically to include the sizes required when the file is 
imported. 
Note: even if the Dcode table is held within the gerber file being imported, XL Designer cannot use it and the 
importer’s Dcode table has to be filled in. 
Dcode nos:  DCode numbers are listed, 10 to 31 in the example shown above. They represent valid DCode 

numbers and cannot be changed. The correct size and shape should be assigned to each DCode 
number in this table to match those used in the Gerber file. Dcodes 32 to 255 are available by 
selecting the appropriate tab from the top of the window. 

Size:  enter the size that should be assigned to the Dcode. 
Sizes can be entered in inches or millimetres, the decimal point indicates which units are in current 
use (a dot (.) for Imperial values and a comma (,) for Metric values. 

Shape: select the shape that should be assigned to the Dcode.  Only Round or Square is available. (If 
other shapes were used in the gerber file, they can only be imported as round or square - it is 
possible to replace pads from within the artwork editor.) 

Once the Setup and DCode windows have been setup as required, select the Import button to start the import 
process. 
Information appears on the screen to indicate what is happening, as shown in Figure 215. This information will 
be stored in the report log.  

 

Figure 215 

Problems encountered during the import are separated into two types, Warnings and Errors - errors are 
generally more serious than warnings.  
Each problem encountered is reported in detail and each one must be investigated and corrected where 
necessary - this might involve editing the Dcode table or changing the parameters in the import setup window, 
then importing the file again. 
The first part of the report indicates when the importer was started and which file was used as input. 
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The report continues and two warnings are given in this example.  
The first warning will always appear if the Via Dcode in the “Import setup” window is set to 0. No action is 
required unless it is required that a particular Dcode should be converted to a via, in which case the import 
would have to be started again with the correct Dcode assigned for vias. 
A second warning is given which indicates that Dcode 12 has been used in the gerber file but has not been 
assigned a size in the Dcode table. 
Note: although the message indicates the dcode was not assigned correctly, XL Designer does not know what 
the correct sizes are, simply that no size has been assigned.  
Any used Dcodes that have not been assigned a size in the Dcode table will be imported as a code 4 round pad 
or track. 
The report finishes with a statement indicating the import is complete and the artwork has been saved. 
All the errors/warnings should be investigated and appropriate action taken.  
Close the report window when ready to continue. The import process is complete. 
The report can be re-viewed by opening the Logfiles folder from the navigator and viewing the report named 
“import_gerber”.  

Viewing/editing the imported artwork 
Once the file has been imported and the report acted upon as necessary, the imported data can be displayed 
from the artwork editor (or another Gerber file could be imported).  
It's a good idea to view the artwork after the first file has been imported, this will ensure the correct shifts, layers, 
etc. were used. 
If the import was unsuccessful investigate what went wrong using the following information to assist you. 

Typical problems when importing gerber files  
The data cannot be seen when the artwork editor is opened: 

• use View > Zoom out until the whole working area can be seen, the grid (Grid > On, Grid > Inch or 
Metric) will indicate the working area. (View > Full does not operate without a board profile.) 

• check the appropriate layers are visible (View Control dialogue bar) 
• check the number of points being used on the appropriate layer(s) (View Control dialogue bar or the 

Artwork Properties pane). If the layer contains some points but the data is not visible after trying the 
above, it is likely that the data is outside of the working area. Import the data again with different shifts 
until the data is found. Zero points indicate there is nothing on the layer. 

• open the gerber file (using Notepad/Wordpad or similar) and verify it is a valid Gerber file (a sample file 
is shown below) 

All the pads appear to be too big, and too close together: 
• check the number of decimal places in the Gerber file. Ensure that the Gerber input Setup window has 

been set to the same number of decimal places. 
• check whether the Gerber co-ordinates are in Imperial or Metric units. Ensure that the Gerber input 

Setup window has been set to the correct units. 

All the pads appear to be too small, and too far apart: 
• check the number of decimal places in the Gerber file. Ensure that the Gerber input Setup window has 

been set to the same number of decimal places. 
• check whether the Gerber co-ordinates are in Imperial or Metric units. Ensure that the Gerber input 

Setup window has been set to the correct units. 

Some pads are too small, or too big, or the wrong shape: 
• Check the importer’s Setup, DCode table. Ensure the DCode numbers correspond to the correct size 

and shape as originally defined in the gerber file. 
Note: Dcodes (pads) that are flashed in the gerber file can only be set to round or square when the file 
is imported, so other shaped, flashed Dcodes (pads) can only be imported as round or square.  

Sample Gerber file 
 

Command Brief description 
G01X00000Y00000D02* initialise 
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G54D37* 
G01X1000Y5000D02*D03* 
G01X5000Y5000D02*D03* 
G01X5000Y1000D02*D03* 
G54D58* 
G01X2000Y2000D02* 
G01X4000Y2000D01* 
G01X4000Y4000D01* 
G01X2000Y4000D01* 
G01X2000Y2000D01* 
G54D12* 
G01X2400Y3200D02* 
G01X2400Y2800D01* 
G01X2700Y2800D02* 
G01X2700Y2600D01* 
G01X2800Y3200D02* 
G01X3300Y3200D01* 
G01X3300Y2200D01* 
G01X2800Y2200D01* 
G01X2800Y2300D01* 
G54D60* 
G01X2400Y2300D02*D03* 
G01X2500Y2300D02*D03* 
G01X2600Y2300D02*D03* 
G01X2700Y2300D02*D03* 
G01X2800Y2300D02*D03* 
G01X2900Y2300D02*D03* 
G01X2500Y2600D02*D03* 
G01X2400Y2600D02*D03* 
G54D65* 
G01X3100Y2350D02*D03* 
G01X3100Y2550D02*D03* 
G01X2400Y3200D02*D03* 
G01X2800Y3200D02*D03* 
G54D55* 
G01X2400Y2800D02*D03* 
G01X2700Y2800D02*D03* 
M02* 

select aperture D37 
go to x=1", y=5" and flash 
go to x=5", y=5" and flash 
go to x=5", y=1" and flash 
select aperture D58 
go to x=2", y=2" and draw, continue 
to x=4", y=2" continue to 
x=4", y=4" continue to  
x=2", y=4" continue to  
x=2", y=2", turn light off 
select aperture D12 
go to x=2.4", y=3.2" draw, continue 
to x=2.4", y=2.8", turn light off 
go to x=2.7", y=2.8", draw, continue 
to x=2.7", y=2.6", turn light off 
go to x=2.8", y=3.2", draw, continue 
to x=3.3", y=3.2", continue to 
x=3.3", y=2.2", continue to 
x=2.8", y=2.2", continue to  
x=2.8", y=2.3", turn light off 
select aperture D60 
go to x=2.4", y=2.3" flash 
go to x=2.5", y=2.3" flash 
go to x=2.6", y=2.3" flash 
etc., etc. 
 
 
 
go to x=2.4", y=2.6" flash 
select aperture D65 
go to x=3.1", y=2.35" flash 
go to x=3.1", y=2.55" flash 
go to x=2.4", y=3.2" flash 
go to x=2.8", y=3.2" flash 
select aperture D55 
go to x=2.4", y=2.8" flash 
go to x=2.7", y=2.8" flash 
stop 

Regenerating a design from Gerber files 
Please read the following information carefully as it describes assumptions made during Gerber import, which 
will affect the regenerated design in the artwork editor. 

Import Assumptions: 
• flashed DCodes produce pads 
• any round, drawn DCodes produce tracks (round ended finger pads that were created with a draw in 

the Gerber file will be imported as tracks) 
• any square, drawn Dcodes that produce a one segment, orthogonal line, produce rectangular pads 
• vias were assigned a unique DCode, i.e. the DCode assigned to vias was not used for any other 

component pads. If this is not the case it will be impossible for XL Designer to differentiate between 
component pads and vias, which will cause problems when modifying tracks. 
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Gerber file content and implications for importing: 
The Gerber files for a double sided board would typically have been produced to include the following data: 

File 1 copper (tracks and text) from top component side  
component pads from top component side  
vias  
alignment markers 

File 2 copper (tracks and text) from bottom component side 
component pads from bottom component side  
vias 
alignment markers 

File 3 silk screen outlines and text  
alignment markers 

File 4 solder mask  
alignment markers 

To allow the re-created design to be worked upon and checked in the normal way, it is essential the imported 
data appears correctly within XL Designer. Some of the Gerber data will become redundant. 
For example, in the Gerber files listed above, the same vias appear in files 1 and 2. If both sets of vias are 
imported onto the XL Designer via layer, duplicate via information will be produced. Similarly, XL Designer must 
obtain component pad information from the outline library so that it has pin numbering information, hole sizes, 
etc. This will make the pad data in the Gerber files redundant. 
If the data is imported without thought, much manual editing may need to be performed to reduce the errors 
produced when the board is checked. 
The following parameters within the Setup window allow the imported data to be added in a way that allows 
duplicated or unrequired data to be separated onto different layers and then removed using the Window delete 
command. 

Main layer: Indicates which layer drawn items (tracks, text, round-ended-finger pads) will appear on.  
Pads layer: Indicates which layer flashed items will appear on, with the exception of "vias".  
Vias layer: Indicates which layer  "vias" will appear on.  
Via Dcode: Indicates the unique Dcode used for vias. If a unique DCode was not used for vias, every pad 

with the DCode specified will appear as a via in the regenerated design. These "extra" vias 
would obviously need to be removed from the artwork.  
If a DCode is not specified for vias, then the vias will be imported, but XL Designer will not 
recognise them as vias. 

If importing the example Gerber files listed above, the parameters would typically be set as follows for each file: 
File 1: Main layer  T 

Pads layer 11 
Via layer  V 
Via DCode 23 (assuming vias were output using D23) 

File 2: Main layer  B 
Pads layer 12 
Via layer  12 (because the vias from file 1 will be used) 
Via DCode 23 (assuming vias were output using D23) 

File 3: Main layer 1 
Pads layer 13 
Via layer  13 
Via DCode 23 (assuming vias were output using D23) 

File 4: Main layer 2 
Pads layer 14 
Via layer  14 
Via DCode 23 (assuming vias were output using D23) 

The pads in every case were placed on a different unused layer ready for removal later. They are not required 
as the component pads will appear automatically when a parts list is added to the data. As these pads will be 
removed, they could have all been placed on the same unused layer, but this approach will help the operator 
determine which pads belong to which Gerber file in the event of a query.  
One set of vias was added to layer V, the other sets were added to an unused layer for removal later. 
If power plane layers are included in the design it would be better if they were re-generated in XL Designer. 
However, if being re-generated from the gerber file, it is likely that the "pad" and "track" data should be imported 
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on to the same layer within XL Designer. The layer should be assigned as a power plane layer either before or 
after the Gerber files are imported. 
A board profile was not included in the Gerber files. If it was, it would appear as a TRACK on the main layer 
used when the file was imported. This "track" could be used as a guide to define the real board profile. 

Additional Data required to regenerate a design: 
Once the Gerber files have been imported into XL Designer, the following data has to be added: 
 Parts list 
 Net list 
 Physical outlines 
If the parts and net list data exists as a text file(s), it should be possible for the operator to manipulate the text so 
that it is in a format suitable for text importer. If not, the data will have to be entered by hand using the XL 
Designer parts/net list text editor, or extracted from a schematic. 

Parts List 
The parts list should include for each part, its position, orientation and reference to a physical outline. 
The positional information in the parts list is with respect to 0,0 in the artwork editor. The Gerber data may 
have been created, or imported with a shift. It is essential that the parts and Gerber data line up. Use the 
Identify > Pad command in the artwork editor to obtain the position of a known pad on the imported artwork, 
for instance IC1, pin 1. This can then be cross referenced to the parts list (the pin's offset from the 
component datum will have to be taken into account). 

Net List 
The net list should contain every inter-connection required on the design. 

Physical outlines 
The outline library should contain an outline for all the outlines referred to in the parts list. The outline 
should include pad/hole position and size, pin numbers, part size, part datum, etc. 
The co-ordinates given in the parts list refer to the datum of each outline. Note: different systems use 
different datum points within outlines. If the positional information was extracted automatically from a layout, 
it is essential that the datum point of each outline be known.  

Verifying the design: 
Once the parts\net lists and outlines have been added view the artwork. Check that the artwork "looks" correct. 
For instance the parts aren't offset from the tracks, that the component pads are the same size/shape as the 
pads added to the unused layers. If the data doesn't line up, take the appropriate action. For example the 
artwork could be deleted, leaving the parts and net list behind, and the Gerber files re-imported using different 
shifts.  
The point-point connections between the parts will appear even though the routed tracks are there. As yet XL 
Designer will not recognise the "tracks" as being valid. Running the artwork checks will rectify this providing the 
data is correct. 
If the artwork appears to be correct, delete the data that was added to unused layers during the Gerber import 
(layers 11 to 14 in the example given above) using the Region > Delete command in the artwork editor. 
All the layers within the design will be defined as copper layers. If silkscreen or power plane layers have been 
imported assign the layers appropriately (Configuration folder, Layer assignments & Ordering) otherwise the 
checking routines will flag problems that do not exist. 
Once the above have been checked, run the artwork checking routine from the artwork editor  (Check > 
Connectivity). Investigate and rectify any problems reported. The design is then ready for further work. 
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AutoCAD DXF File Input 
DXF is an ASCII file format that allows data to be transferred between CAD systems. 
When imported to XL Designer, DXF data appears in the profile editor.  
This allows complex profiles saved in a .DXF file format to be used and edited in XL Designer’s board profile 
editor. 
DXF data files can also be extracted from XL Designer, refer to the chapter describing the Outputs for details. 

Information: 
A file in the DXF ascii format is required. It should be output from AutoCAD in the "entity" mode. 
The DXF data can only be imported into the profile editor. However once imported, it could be transferred to a 
documentation layer within the artwork editor using the output tools. 

Procedure: 
Open the design that the DXF file will be imported into. 
Note: when working on an existing design, it is suggested that a backup copy of the design is taken before 
importing the file - the results may not be as expected at the first attempt. 
Right-click the design name from the Navigator pane, then select Import > Profile from AutoCAD DXF file. A 
window similar to the one in Figure 216 appears: 

 

Figure 216 

X shift and Y shift these settings allow the data being imported, to be positioned wherever required in the 
profile editor.  
If the shifts required are unknown, import the data into a copy of the design with the 
shifts set to 0, and view the board profile.  Calculate whether or not shifts are required 
and what they are, and then import the data into the original design, with the 
appropriate shifts. 

DXF Units:  XL Designer can import DXF files containing co-ordinates in inches, thousandths of 
inches, centimetres or millimetres. The importer needs to know which units are in use.  
If the units specified are incorrect, the scale of the imported data will be incorrect. 

Import Mode:  the DXF data can either be added (select Append) to the existing data or it can 
overwrite (select Overwrite) the existing data.  
Select the option required. (Only data within the same category is overwritten - see 
Import to.) 

Import to:  the DXF data being imported can be imported as either Profile, Keepout or Router 
data. Select the category the data should be imported to.  

DXF Filename:  specify the name of the DXF file that will be imported. The browse button can be used 
to locate folders and files. 

Set the parameters as required, then select the Import button to start the import process. 
A window indicates when the import is complete. Select OK to continue. 
A conversion report will appear. It includes details of the conversion and details of any problems encountered. 
Once closed, the report can be re-viewed by opening the Logfiles folder from the navigator and viewing the 
report named “import_dxf”.  
A sample indxf.txt report is shown in Figure 217.  
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Figure 217 

The first part of the report indicates when the importer started and the file used as input.  
The report then indicates the destination of the data (profile, keepout or router) and whether the data was added 
to any existing data in the editor or whether any existing data was overwritten. 
The details of the DXF file then follow, followed by Import Complete to indicate the report is complete.  
If any errors or warnings are listed, these should be investigated and the appropriate action taken. 
Once the file has been imported, the board profile may be viewed or modified using the profile editor – from the 
design’s open folder in the navigator, select Board Profile. 
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Parts & Wiring List Import 
This routine is used to import parts and/or wiring list files that exist in a specific format, into XL Designer.  
The following data will also be required, either before or after the parts/wiring list has been imported, in order to 
design the artwork: 

• A board profile 
• Details of which connections are power rails (unless specified in the file to be imported) 
• The physical footprints (in the component outline library) 
• Pad, track, etc, sizes 
• If gate and pin swapping will need to be performed, schematic parts will also need to be defined in the 

design’s schematic folder and the parts list updated with the correct Type field. 
Parts/wiring list files can also be extracted from XL Designer, refer to the chapter describing the Parts & Net List 
folders for details. 

Expected file format: 
The text file can exist as one complete file containing three sections, or up to three separate files each 
containing one or more sections. The sections are:  

Parts list  
Wiring list  
Power rails list  

Whether each section is held in its own file, or all three sections combined in one file, they must be imported in 
the following order:  

Parts section  1st or 2nd  
Power rails section 1st or 2nd  
Wiring section 3rd  

Each section must start and end with a unique delimiter or keyword which can be chosen by the user. Data 
within a section must follow the format rules, with fields separated by a space or spaces.  
The importer ignores lines added outside of a section.  

Parts list file/section 
This file/section should take the format described below. Fields cannot be omitted and there should be one line 
for each part. 

Keyword1  
Reference Type Outline X-Position Y-Position Rotation 
Keyword2  

where: 
Keyword1:  is replaced with a unique keyword to allow the start of the parts list section to be 

recognised within the file.  
User defined keywords can be used, but the keywords are case sensitive. 
The default parts list keyword is: .PARTS 

Reference:  is replaced with the name allocated as a unique reference for each component in the 
design, for instance IC1, R1, etc. It can contain up to 4 letters followed by a number, e.g. 
IC1, PLUG1, etc.  

Type:  this field will be accessed by the gate and pin swapping routines in the artwork editor, 
maximum of 32 characters.  
If gate or pin swapping will not be performed on the package, this field could contain a 
stock number, catalogue reference, etc. An entry must be given, though one character 
will suffice. 
If gate and pin swapping will be used, the field should take the form of a component 
name and value separated by a comma. For example: 
  PARTNAME,VALUE 
  R0.25W,10k 
Both items should correspond to a schematic part. For instance, in the above example 
there must be a part in the design’s schematic parts folder called R0.25W with a value 
field set to 10k. 
Gate swapping between packages is only permitted if the type fields of the packages are 
identical.  
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Outline: is replaced with the name of the component outline (footprint) from the component outline 

library that will be used for the part. Maximum of 16 characters.  
The outline does not have to exist in the component outline folder before importing the 
parts list, but should exist before designing the artwork.  

 X & Y-Position: are replaced with the position of the part's datum on the board, with respect to 0,0 in the 
artwork editor (lower left corner of working area, even if the datum in the artwork editor 
has been moved). Units can be entered in inches or millimetres, but not both.  
It is usual to leave these fields set to 0 and position the parts interactively.  

 Rotation: This field indicates the orientation and layer of the parts on the board. It is usual to leave 
this column set to 0 and rotate or flip the parts interactively.  
An entry of 0 represents the part as it was created in the outline library. Rotation is 
specified in degrees, anti-clockwise (0 to 359 degrees).  
If the part has to be flipped (or mirrored), as well as rotated, F (for flipped) should precede 
the entry. The part is flipped (mirrored) about its original Y-axis, as defined in the outline 
library. For example, F 45 will flip and then rotate the part through 45 degrees.  

Keyword2: is replaced with a unique keyword to allow the end of the parts list section to be 
recognised. User defined keywords can be used, but the keywords are case sensitive. 
The default parts list keyword is: .ENDPARTS 

 

Sample parts list file/section: 
.PARTS  
IC1 7400,74LS00 DIL14 0 0 0  
IC2 7400,74LS00 DIL14 0 0 0  
IC3 7402,74LS02 DIL14 0 0 0  
IC4 74244,74LS244 DIL20 0 0 0  
R1 RES,100k 1206R 0 0 0  
R2 RES,100k 1206R 0 0 0   
C1 CAP,100uF 0805R 6.3 4.2 F 90  
C2 CAP,100uF 0805R 0 0 0  
.ENDPARTS  

  

Power Rails file/section  
This file/section does not have to be included. However, if it is, it must be imported before the wiring list.  

Keyword3  
Powername  
Keyword4  

 where: 
Keyword3:  is replaced with a unique keyword to allow the start of the power rails section to be 

recognised within the file. User defined keywords can be used, but the keywords are case 
sensitive. 
The default parts list keyword is: .POWERNAMES 

Powername: is replaced with the name of a connection in the wiring list that has to be treated as a power 
rail. Each separate powername should occupy one line in the file. 

Keyword4: is replaced with a unique keyword to allow the end of the power rails section to be 
recognised within the file. User defined keywords can be used, but the keywords are case 
sensitive. 
The default parts list keyword is: .ENDNAMES 

 

Sample Power Rails file/section: 
.POWERNAMES  
VCC  
GND  
VEE  
0V  
+12V  
.ENDNAMES  



 

324 

  

Wiring list file/section  
This file or section should take the following format: 

Keyword5  
Signalname Node Node Node Node  
Keyword6 

where: 
Keyword5:  is replaced with a unique keyword to allow the start of the wiring list section to be recognised 

within the file. User defined keywords can be used, but the keywords are case sensitive. 
The default parts list keyword is: .NETS 

Signalname: is the signal name of the net and must be specified. The name can consist of up to 10 
characters. 
If more than 10 characters are used, the name will be truncated when the file is imported. 
Warnings are given, but this could result in two or more nets being joined together within XL 
Designer.  
For example, if the signal names 12345678901 and 123456789012 are used, they will both 
get truncated to 1234567890. This could result in XL Designer seeing them as one net. (Both 
nets will remain separate on the artwork, providing the group function is not used from within 
the wiring list editor.)  
& (ampersand) should not be used as a signal name. 
If & (ampersand) is used in the signalname field, this indicates the nodes on the previous line 
are connected to the nodes on the line the ampersand appears on. 

Node: is replaced with each node in the net. Nodes should be typed in as part reference dot pin 
number, e.g. IC3.3 or R1.2, etc. (The part reference must also appear in the associated parts 
list.  
Nodes on the same line are connected to one another, but not to nodes on the next line, 
unless the & (ampersand) sign appears in the signal name field of the next line.  

Keyword6:  is replaced with a unique keyword to allow the end of the wiring list section to be recognised 
within the file. User defined keywords can be used, but the keywords are case sensitive. 
The default parts list keyword is: .ENDNETS    

Sample wiring list file/section: 
 .NETS  
A1 R2.1 IC3.2 IC1.3 IC4.12 IC2.11 R1.2  
N0001 C2.2 IC1.4 
N0002 IC1.5 R2.2 
VCC IC1.14 IC2.14 IC3.14 IC4.20 IC5.14 IC6.14  
& IC7.14 IC8.14 C1.1 C2.1 C3.3 C4.4  
& C5.1 C6.1 
.ENDNETS  

 Example file containing all sections  
.PARTS  
IC1 74LS00,74LS00 DIL14 4.25 3.6 F 45  
IC2 74LS00,74LS00 DIL14 0 0 0  
IC3 74LS02,74LS02 DIL14 0 0 0  
IC4 74LS244,74LS244 DIL20 0 0 0  
IC5 74LS244,74LS244 DIL20 0 0 0  
R1 100k RESA8 0 0 0 
R2 - RESA8 0 0 0  
C1 - CAPA10 0 0 0  
C2 - CAPA12 0 0 0  
.ENDPARTS  
This line will be ignored because it is not within a section.  
.POWERNAMES  
VCC  
GND  
.ENDNAMES  
.NETS  
A0 IC1.1 R1.1 IC2.13 
A1 R2.1 IC3.2 IC1.3 IC4.12 IC2.11 R1.2 
N0001 C2.1 IC1.4 
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N0002 IC1.5 R2.2 
VCC IC1.14 IC2.14 IC3.14 IC4.20 
& IC5.14 
GND IC1.7 IC2.7 IC3.7 IC4.10 
& IC5.7 
.ENDNETS  

 

Information: 
When working on an existing design, it is suggested that a backup copy of the design is taken before importing 
the file - the results may not be as expected at the first attempt. 
If positional information is supplied within the file it will be used to place the parts on the layout. 
The board layout can be designed once the parts/wiring list data has been imported, but the circuit diagram will 
not be re-created. 
If gate and pin swapping is performed on the design, the imported parts and wiring list is automatically updated 
(back-annotated). A back-annotation file is generated within XL Designer, and can be used by the operator to 
update the original circuit diagram or parts and wiring lists. The back annotation file can be viewed/printed from 
the Logfiles folder. 
Sometimes the importer does not produce the results expected. Errors and warnings are produced which may 
indicate the original file is not in the format expected or silly mistakes have been made, like the same pin used 
twice in different connections, or the wrong outline name has been specified.  In this way, the importer highlights 
errors in the original file. 
In many cases the original file has to be modified, then the importer used again, or sometimes the corrections 
can be made from within XL Designer after the file has been imported. It all depends on the problem and which 
method will be most effective. If the changes are made within XL Designer, it is important for future 
modifications, to modify the original parts/wiring list (and circuit if that's where the parts/wiring list originated 
from). 
If the first import isn't successful and the files have to be imported again, it's easiest to delete the original design 
and start again with another new design. However, if modifications are being made to an existing design this 
wouldn't be an option, unless a copy of the original design was being worked on - so always work on a copy of 
the design. 
The importer overwrites any existing parts/wiring list information held in the design, except for certain items, 
which are user controlled via the importer setup parameters. 

Procedure: 
Open the design that the parts/wiring list file(s) will be imported into. 
Note: when working on an existing design, it is suggested that a backup copy of the design is taken before 
importing the file - the results may not be as expected at the first attempt. 
Right-click the design name from the Navigator pane, then select Import > Parts/Wiring Lists from Text File. A 
window similar to the one in Figure 218 appears. 
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Figure 218 

Set the parameters as required, using the following information to assist you: 
Part position units: set this parameter to suit the units defined in the parts list file. 
Part section start key: see description for “Power names end key” below. 
Part section end key:  see description for “Power names end key” below. 
Net section start key:  see description for “Power names end key” below. 
Net section end key:  see description for “Power names end key” below. 
Power names start key:  see description for “Power names end key” below. 
Power names end key: the text file can consist of up to three sections, a parts list, a wiring list and a 

power names list. Each section is recognised by keywords or delimiters at its 
beginning and end. If the default keywords are used, the section key fields can 
be left blank. If different keywords are used, they should be specified (case 
sensitive). 

Existing component replacement:  
Retain placement: If the text file is being imported into a design that already has parts placed on 

the layout (typically when modifications are being performed) there may be a 
conflict between part positions in the design and in the new parts list. This 
setting indicates whether the existing part placement should be retained or the 
part positions from the new file used. 
Typically the existing placement should be retained, in which case, Yes should 
be selected. Any part placement information found in the text file will be ignored.  
If No is selected, all the part positional information found in the file will be used. 
Parts that had previously been placed on the layout will take their positions from 
the imported text file.  

Retain Outline:  If the text file is being imported into a design that already has a parts list 
(typically when modifications are being performed) there may be a conflict 
between the outlines defined in the existing parts list and in the new parts list. 
This setting indicates whether the existing part outline should be retained or the 
part outline from the new file used. 
Care should be exercised with this setting if changes have been made to the 
outlines in the existing parts list that have not been back-annotated to the 
original circuit diagram and parts\wiring list. If you are unsure which option to 
select, take copies of the design and try both options. 
If the outlines are not retained, the report that appears after the import has taken 
place lists which parts have changed. 

Filename: specify the name of the file that will be imported. The browse button can be used 
to locate folders and files. 
If the parts list, power names list and wiring list are held in separate files, each 
file has to be imported separately. The parts list must be imported before the 
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wiring list, and the powernames list before the wiring list. 
Once this window has been setup as required, select the Import button to start the import process. 
Information appears on the screen to indicate what is happening. This information will be stored in the report 
log.  
The report that is generated will look similar to the one shown in Figure 219. 

 

Figure 219 

Problems are separated into two types, Warnings and Errors - errors are generally more serious than warnings. 
Each problem encountered is reported in detail and each one must be investigated and corrected where 
necessary - this might involve editing the original files or the imported parts/wiring list from within XL Designer. 
The first part of the report indicates when the importer was started and which file was used as input: 
The report then indicates what has happened during the part list import, for example, which outlines have been 
copied from the master library into the design. 
If power rails were specified in the file, then the number of power rails imported is indicated and finally the wiring 
list is imported.  

Typical Warnings/Errors 
If warnings/errors are given they should be investigated and changes made as and when appropriate 
Warning : Outline '0805' not available -  this warning is given because the outline name specified (0805) is 

not a valid name in the component outline library. (Either edit the imported parts list and correct 
the name, create the outline in the outline library or edit the original parts list and re-import.) 

Warning :  Net node 'IC2.15'  -  Pin not found on outline - this warning may be caused because an outline was 
specified that doesn’t exist or maybe the outline does exist but does not have enough pins. 

Warning :  Wiring list requires 'group' operation - this indicates that the net list has nets with the same name 
that have been separated. This can be rectified (if appropriate) from XL Designer’s own 
parts/wiring list editor, using the Edit > Group signal names command. 

 
Close the report window when you are ready to continue. The import process is complete. 
The report can be re-viewed by opening the Logfiles folder from the navigator and viewing the report named 
“import_textpwl”.  
If the import was unsuccessful, investigate what went wrong using the error/warning messages to guide you. It 
is essential that appropriate action is taken as the resultant artwork design may be incorrect and much time 
could be wasted. 

Viewing/editing the imported parts/wiring list 
By viewing and then scrolling through the imported parts and net lists it’s possible to identify any component 
outlines and/or pin numbers that are invalid – these should be rectified before the artwork is designed. 
To view or modify the imported parts/wiring list, from the open design folder in the navigator window, double-
select the Parts and/or Nets folders. Scroll through the windows and look for highlighted outline names (parts 
list) or pin numbers (net list). 
These problems must be rectified - in the case of highlighted outline names, by using a valid outline name or 
creating/copying the specified outline in the design’s component outline library. Once an outline name is 
corrected, this may also resolve invalid pin numbers, if they were associated with that part. If the pin numbers 
remain highlighted, check that the outline called up for the part has the appropriate pin numbers within it. 
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Calay parts/wiring lists import 
This routine is used to import Calay format parts\wiring lists. The board layout can be designed once this data 
has been imported, but the circuit diagram will not be re-created. 
The following data will be required either before or after the parts/wiring list has been imported in order to 
design the artwork: 

§ A board profile 
§ Details of which connections are power rails 
§ The physical footprints (in the component outline library) 
§ Pad, track, etc, sizes 
§ If gate and pin swapping will need to be performed, schematic parts will also need to be defined in the 

schematic library and the parts list updated with the correct Type field that matches the schematic 
part’s value field accordingly. 

Expected Calay file format: 
A Calay format parts/wiring list should be supplied as two separate files, one containing the parts list, the other 
the wiring list. 

The Calay parts list 
This file requires the following fields: 

 Type Reference Outline X-Position Y-Position Rotation 
 

Fields cannot be omitted. The X-Position, Y-Position and Rotation columns are typically set to zero. 
Type maximum of 23 characters. This field will be accessed by the Ranger gate and pin swapping 

routines if used.  
 If gate and pin swapping will be used, the field should take the form of a component name and 

value separated by a comma. For example: 
      TYPE,VALUE  
      R0.25W,10k 

Both items should correspond to a circuit part. For instance, in the above example there must be 
a part in the schematic library called R0.25W with a value field set to 10k. 

Reference maximum of 4 letters followed by a number. For example: IC1, R1, PLA1, XXXX1, etc. 
Outline maximum of 11 characters. The outline (footprint) does not have to exist in the outline library 

before the import takes place, but must exist before laying out the design. 
X &YPosition these fields are usually set to zero although co-ordinates can be entered to pre-place parts on the 

board. Units can be entered in inches or millimetres, but not both.  
Rotation this field is usually set to zero although parts may be pre-rotated as required. Units are degrees, 

from 0 to 359. The part is rotated anti-clockwise about its datum as defined in the outline library. 

Example: 
74LS00 IC1 DIL14 0 0 0 
74LS00 IC2 DIL14 0 0 0 
74LS02 IC3 DIL14 0 0 0 
74LS244 IC4 DIL20 0 0 0 
100k R1 RESA8 0 0 0 
100k R2 RESA8 0 0 0 
100uF C1 CAPA10 0 0 0 
100uF C2 CAPA12 0 0 0 

 

The Calay Wiring list 
This file requires the following fields: 

/NetID Node Node; 
/NetID Node Node Node Node Node Node Node, 
 Node Node Node Node Node Node; 

 
Each line represents a separate connection and is terminated by a semi-colon (;).  
If the connection extends beyond one line, a comma (,) should be used as a continuation character on the end 
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of each line that is not complete. 
 

/NetID The unique signal name of the connection or 'net'. Maximum of 10 ascii characters, excluding / at the 
beginning of the name which must be present but is not included as part of the signal name.  
If more than 10 characters are used the name will get truncated. Warnings are given if this happens.  
A netid must be supplied. 
The ampersand sign, (&) should not be used as a signal name as it is used as a continuation 
character elsewhere. 

Node Consists of the reference that must appear in the parts list and a pin number in brackets. Each node 
must be separated by at least one space or tab. 
A semi-colon (;) indicates the end of a connection. 
A comma (,) indicates the connection is continued on the next line. 

Example: 
 /N00001 IC1(1) R1(1) IC2(13); 
 /N00002 C1(1) R2(1) IC3(2) IC1(3) IC4(12) IC2(11), 
  R1(2) C2(1) IC1(4); 
 /N00003 IC1(5) R2(2); 
 /VCC IC1(14) IC2(14) IC3(14) IC4(20); 
 /GND IC1(7) IC2(7) IC3(7) IC4(10); 

Useful Information: 
Sometimes the importer does not produce the results expected. Errors and warnings are produced which may 
indicate the original file is not in the format expected or silly mistakes have been made, like the same pin used 
twice in different connections, or the wrong outline name has been specified.  In this way, the importer highlights 
errors in the original file. 
In many cases the original file has to be modified, then the importer used again, or sometimes the corrections 
can be made after the file has been imported. It all depends on the problem and which method will be most 
effective. If the changes are made after the file has been imported, it is important for future modifications to 
modify the original parts/wiring list (and circuit if that's where the parts/wiring list came from). 
If modifications are being made to an existing job, make sure a backup copy of the design has been taken 
PRIOR to importing the files – sometimes things don’t go according to plan. 
The importer overwrites any existing parts/wiring list information held in the job, except for certain items, which 
are user controlled via the Setup Parameters (described below). 
If the wiring list contains nets with the same name that have been separated, then these are grouped together 
during the import process. 
The files to be imported should be text files in the format shown above.  

Procedure: 
1. Create or open the job that the files will be imported into – when working on an existing design, always take a 

backup copy before importing the file - the results may not be as expected! 
2. Right-click on the design’s name in the navigator, select Import > Calay parts and wiring lists from text file. A window 

similar to the one in Figure 220 appears: 
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Figure 220 

Set the parameters as required, using the following information to assist you: 
Calay parts list file:  specify the name of the file containing the Calay parts list that will be imported. The browse 

button can be used to locate folders and files. 
Calay net list file:  specify the name of the file containing the Calay net list that will be imported. The browse button 

can be used to locate folders and files. 
Omit 'Nnnn' signal names: unnamed nets from the original circuit diagram are each given a unique name in the 

Calay wiring list, for example N00001, N00002, etc. These names are not required and the user 
can choose to omit them. Signal names that do not take this form are always imported. 

Part position units: Set this parameter to suit the units used in the Calay parts list file. 
Existing component replacement: 

Retain placement: If the text file is being imported into a design that already has parts placed on the layout 
(typically when modifications are being performed) there may be a conflict between part positions 
in the design and in the new parts list. This setting indicates whether the existing part placement 
should be retained or the part positions from the new file used. 
Typically the existing placement should be retained, in which case, Yes should be selected. Any 
part placement information found in the text file will be ignored.  
If No is selected, all the part positional information found in the file will be used. Parts that had 
previously been placed on the layout will take their positions from the imported text file.  

Retain Outline: If the text file is being imported into a design that already has a parts list (typically when 
modifications are being performed) there may be a conflict between the outlines defined in the 
existing parts list and in the new parts list. This setting indicates whether the existing part outline 
should be retained or the part outline from the new file used. 
Care should be exercised with this setting if changes have been made to the outlines in the 
existing parts list that have not been back-annotated to the original circuit diagram and 
parts\wiring list. If you are unsure which option to select, take copies of the job and try both 
options. 
If the outlines are not retained, the report file lists which parts have changed. 

Once the parameters are set as required, select the Import button to start the import process. 
A report log will appear on the screen to indicate what happened during the import process. This information will be 
stored in the report log (import_calay) that can be accessed from the Logfiles folder in the design’s navigator 
window. 
The report window that is generated will look similar to the one shown in Figure 221. 
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Figure 221 

Problems are separated into two types, Warnings and Errors - errors are generally more serious than warnings. 
Each problem encountered is reported in detail and each one must be investigated and corrected where necessary - 
this might involve editing the original Calay files, the imported parts/wiring list or introducing the required outlines. 
The total number of errors and warnings is then given, followed by a statement to indicate the report is complete. 
Close the report window when you are ready to continue. The import process is complete. 
The report can be re-viewed by opening the Logfiles folder from the navigator - the report is called import_calay and 
can be printed or saved as a text file as required by selecting the File command whilst the window is active. 
If the import was unsuccessful, then you need to investigate what went wrong using the report to guide - what do the 
error messages indicate - look at the original Calay file - is it in the expected format? 
 

Typical warnings/errors 
Warning: <part ref> value changed 
 Means that the value (type) of this part has been altered (will only occur if an existing design is being 
modified). 
Warning: <part ref> outline changed 

Means that the component outline of this part has been altered (will only occur if an existing design is being 
modified). 

Warning: Outline <name> not available 
Means that the outline specified has not been found in the outline library. It will need to be copied 
to/created in the design’s component outline library, or the original parts list file or design modified to suit 
what is available. 

Warning: Single node net <name> omitted 
Means that a connection was started in the Calay netlist file but it did not terminate on another pin so was 
not included in the imported file. The original Calay file/circuit should be checked and appropriate action 
taken. 

Warning: Net node <part ref.pin number> - Pin not found on outline 
Means that the pin specified does not exist in the outline specified - either the wrong outline was specified 
or the pin numbers are incorrect. 

Viewing/editing the imported parts/wiring list 
By viewing and then scrolling through the imported parts and net lists it’s possible to identify any component 
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outlines and/or pin numbers that are invalid – these should be rectified before the artwork is designed. 
To view or modify the imported parts/wiring list: from the open design folder in the navigator window, double-
select the Parts and/or Nets folders. Scroll through the windows and look for highlighted outline names (parts 
list) or pin numbers (net list). 
These problems must be rectified - in the case of highlighted outline names, by using a valid outline name or 
creating/copying the specified outline in the design’s component outline library. Once an outline name is 
corrected, this may also resolve invalid pin numbers, if they were associated with that part.  
If the pin numbers remain highlighted, check that the outline called up for the part has the appropriate quantity of 
pin numbers within it and they are numbered appropriately. 
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Outputs Folder - Tasks 
With a design open, a variety of output data can be produced from the Outputs folder. This folder contains two 
sub-folders: Tasks & Batches, both are empty initially. 
The Tasks folder will contain specific output tasks, for example tasks might be created to produce gerber files 
for the top and bottom artwork layers, top & bottom solder masks, top & bottom silk-screens, etc., other tasks for 
the schematic sheets to a printer, artwork layers to a printer, nc drill output files and so on. 
Once output tasks have been created, they can be added to a batch process to speed up the output or to 
ensure the same tasks are output together in the future – the batch processes are defined in the Batches folder 
and this is described later in this chapter. 

What can be output 
Typically during the design, printouts are produced of the schematic and artwork for checking purposes.  
Once a design is complete and checked without errors being reported, it's ready to be output for manufacturing. 
Manufacturing files can be produced even if the checking routines report errors, but this is not recommended. 
Typically gerber files are required to produce the artwork films (artwork layers, silk-screens, solder masks and 
solder pastes) and either Excellon or Sieb & Meyer files to drive NC drilling and routing machines.  
The Outputs folder gives access to all of these output tools.  
Note:  GenCAD and BSL (Bath Scientific Ltd) files can also be produced for automatic test equipment, pick & 

place machines, etc.  These are produced by right-clicking on the design name in the navigator and 
choosing the Export command. 
BOM’s can be produced from the schematic design sheet editor (Tools > Extract) or from the Parts list 
editor (View > BOM) - these two options produce different types of BOM. 

Creating a New Output Task 
With a design folder open in the navigator pane, open its Outputs folder. Right-click on the Tasks folder and 
create the new task required from the list that appears. The choices are to create a new Task for: 
Artwork Layers Choose this Task to output artwork data, such as the top, inner & bottom copper layers, 

power plane layers, silk screen layers and documentation layers. 
User-defined solder mask and solder paste layers (those created from the artwork 
editor, Tools > Generate silkscreen command) should also be output using this type of 
Task. 

Solder Mask Choose this Task to output an auto-generated solder mask, where all the pads and/or 
vias have a uniform pad swell (if required) applied.  
User-defined solder masks that have been generated using the Tools > Generate 
silkscreen command in the artwork editor should be output with an Artwork layers Task. 

Solder Paste Choose this Task to output an auto-generated solder paste where all the surface 
mounted component pads have a uniform pad size decrease (if required) applied.  
User-defined solder pastes that have been generated using the Tools > Generate 
silkscreen command in the artwork editor should be output with an Artwork layers Task. 

Drill sheet Choose this Task to output a drill sheet (drill drawing). Typically, a drill sheet (drawing) 
contains the positions of all the holes in the design, each hole being represented by a 
different symbol, and a table listing the symbols used, their sizes and number off of 
each. 

Schematic Choose this Task to output any of the schematic design sheets. 
NC Drill & Rout Data Choose this Task to output files that will be used to drive an NC drilling and/or routing 

machine. 
IDF Output Choose this Task to output files in an IDF version 3 format file, for use with mechanical 

CAD modelling tools. 
Once the new Task has been selected, supply an appropriate name – the names should help identify the type of 
output (sheet1, top, bottom, inner, etc.) and the output format (gerber, printer, documentation layer, etc.). 
Examples: “top copper - gerber”, “top copper - printer”,  “top soldermask -  gerber“, “sheet 3 - printer”, etc. 
Move on to the heading, Opening a task to define the settings within the Task. 

Renaming a Task 
Once a task has been created, it can be renamed by selecting it with a right-click of the mouse, then selecting 
Rename. Type in the name required followed by <enter>. 
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Copying an Output Task 
Once a task has been created and its content defined, it can be used as a template for other similar tasks, within 
the same design or other designs, by copying it and modifying the copy. This will be quicker than creating 
another Task from scratch.  
With a design folder open in the navigator pane, open its Outputs and Tasks folder. Right-click on the task to be 
copied, select Copy. Locate the destination Tasks folder (which might be in the same or a different design) then 
right-click on the Tasks folder and select Paste. The Task is copied. It can be opened (double-select it) and 
modified. 

Drag/Copy/Drop functionality 
In addition to the Copy/Paste command, “drag & drop” is available to copy tasks within or between designs. 
Select the task(s) required, then drag them by holding down the left mouse key to the target Task folder, 
releasing the button whilst hovering over the target folder. 

Deleting a task 
A task can be deleted by selecting it with a right-click of the mouse, then selecting Delete.  

Opening a task 
With a design folder open in the navigator pane, open its Outputs folder, then double-select the Task to open it. 
Either a self-contained window will open (for example when the NC Drill & Rout Data or the IDF Outputs are 
selected) or an editor will open. 
If an editor openes, use the Configure commands to control what is included in the output (symbols, 
connections, pads, tracks, etc.) and its format (gerber, dxf, printer, etc.).  

Layer selections 
Data types/categories 
For output purposes the artwork data is divided into two categories, Pads and Copper. If something is not a pad, 
then it is copper. (This may seem odd, for instance silk-screen labels and outlines being regarded as copper, but 
this only applies to the output settings.) 
Vias standard vias only exist on layer V, so if they should be included in the output, select layer V 

pads.  
Blind/buried vias are only included if the layer they appear on has the Pads box ticked AND layer V pads is 

included as well. 
Component pads component pads are made as a "stack" of pads, so if they should be included in the output 

then pads from the appropriate layer should be selected.  
Component pads do not exist on the via layer, V. 
Surface mounted component pads only appear on layer T (top component side) or layer B 
(solder side). 
Note: component pads do not appear on layers defined as Power planes, Silk-screen or 
Documentation layers. 

Other pads pads that have been added using the Amend menu are either added to particular layers or 
layer V. Include pads from the appropriate layer.  

Tracks tracks on a layer are included if copper from the appropriate layer is selected from the setup 
window. 

Copper fill is included if copper from the appropriate layer is selected from the setup window. 
Text on a layer is included if copper is selected from the appropriate layer (even if the layer is set 

to a silk-screen/documentation layer). 
Silk-screen (labels and outlines) are included if copper is selected from the appropriate layer. There are no 

component pads on a silk-screen layer. The only pads that would exist on a silk-screen layer 
are pads that have been added by user-actions such as Amend > Enter Pad. 

Power planes heat-relief and anti-pads are output if pads are selected from the appropriate layer. Copper 
should also be included from that layer to include the split-plane isolation lines and the 
clearance track around the edge of the board.  
Note: when outputting power planes, layer V (vias) should not be included. 

Typical layer selections: 
 
Artwork, top side:  Layer V and T Pads, plus Layer T copper 
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Artwork, bottom side:  Layer V and B pads, plus Layer B copper  
 
Inner copper layers:  Layer V and pads from the inner layer, plus copper from the inner layer 
 
Top silk-screen:    Layer 1 and 2 copper (assuming labels on layer 1 and outlines on layer 2) 
 
Bottom silk-screen:  Layer 3 and 4 copper (assuming labels on layer 3 and outlines on layer 4) 
 
Power plane/split plane:  Layer 5 pads and copper (assuming it's on layer 5)  

Note: do not include layer V pads) 
Bottom solder mask:  Layer B pads 

If vias should be exposed through the solder mask, then also Include vias 
from the Setup window and include layer V pads. 
Copper & pads from other layers can be included as/if required, in order to 
expose other areas of the board through the solder mask.  

 
Top solder mask:  Layer T pads 

If vias should be exposed through the solder mask, then also Include vias 
from the Setup window and include layer V pads. 
Copperm & pads from other layers can be included as/if required, in order 
to expose other areas of the board through the solder mask. 
 

Bottom solder paste:  Bottom pads 
 
Top solder paste:  Top pads 
 

Configure Commands 
These commands control what is output, where the output is directed, the position and scale of the output data. 
Some commands are context sensitive, so for example the Configure > Plot Source and Configure >Output 
Filter commands will produce different windows depending on which type of task is open and the type of output 
format selected. All the variants are described below. 

Configure > Plot Source (with an Artwork Layers Task open) 
The Artwork Layers Task is used to output artwork data, such as the top, inner & bottom copper layers, power 
plane layers, silk screen layers and documentation layers. 
User-defined solder mask and solder paste layers (those created from the artwork editor, Tools > Generate 
silkscreen command) should also be output using this type of Task. 
This command should be selected to control exactly what layers, etc., will be included in the artwork output.  
The Configure > Plot Source command can also be activated by selecting the Setup button alongside the 
Artwork Layers Source setting in the Toolbar, arrowed in Figure 222. 

 

Figure 222 

The Source setting Artwork Layers) determines what type of data will be output and this can’t be changed as it’s 
controlled by the type of Task that’s open. 
When the command is selected, a window appears as shown in Figure 223.  
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Figure 223 

This window, made up of 5 pages that are accessed from the Setup and Layers tabs at the top of the window, 
controls what will be included from the artwork when it is output. Different combinations of layers, pads and 
copper are output, depending on what is required – typical layer selections are described above under the 
heading: Layer selections. 
Output files are typically produced for the top copper layer, bottom copper layer, silk screen layer(s), 
documentation layer(s) and inner layers (copper & powerplanes) if used. 
User-defined solder mask and solder paste layers (those created from the artwork editor, Tools > Generate 
silkscreen window) should also be output using this task. 
Set the pages in the window as required using the following information to guide you. 
Board profile if enabled, the board profile (as defined in the profile editor) is output.  

Typically the profile is not included in gerber files, but it may be useful when producing 
check plots/prints. 

Keepout regions if enabled, the keep-out lines/regions as defined in the profile/artwork editors are output. 
(Not those defined within component outlines). 
Typically keepout lines are not included in output files unless there is a specific 
requirement, perhaps for a check plot/print in order to assess their positions. 

Alignment Targets  if enabled, three alignment target markers are output.  
Target markers or "alignment markers" are used to align the layers of the board together 
when manufacturing the board.  They would normally be included with all output files, and 
in the same relative positions.  
The alignment target markers are produced automatically by the output tool so are not 
visible in the artwork editor though they are seen in the output tool when selected. 
They are positioned automatically on the top corners and bottom right corner of the profile 
if it is rectangular. Irregularly shaped boards have an imaginary rectangle placed around 
them that is used for target positions - the rectangle is drawn as small as possible without 
overlapping the real profile. 
The Target X & Y Shifts setting is used to move the alignment targets away from the 
corners of the profile. 
Unless output to gerber files, the target markers appear as 4 unfilled quadrants of a 
circle, with 2 diagonally opposite quadrants missing.  
Target markers within gerber files are defined by the Dcode that is used to produce them. 

Display Colour the data will be displayed and output in the colour indicated on the screen. Note: there 
may not be a close colour match between the display colour and that output to the colour 
printer/plotter. 

 Select the coloured box and choose a colour from those in the colour palette window that 
appears. 

Drill Holes  This setting is useful when producing plots for prototype boards that will be spot drilled – 
a small sighting spot can be output to assist in the manual drilling process. The available 
options are: 
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Off Drill holes are not output. (Typically used when producing gerber 
photoplot files.) 

Include at true size Drill holes are displayed and output at the drill size specified 
within the pad 

Include at fixed size All drill holes are displayed and output at the diameter set in the 
Fixed drill diameter parameter. (Typically used when producing 
prototype boards for spot drilling.) 

Fixed Drill Diameter Specifies the drill size to be displayed and output if the Drill Holes parameter is set to 
Include at fixed size 

Target X and Y shift without a shift (0 specified) the target markers are positioned on 3 corners of the 
rectangular area occupied by the profile. The target markers do not need to be part of the 
finished artwork so a shift is usually entered to move the targets away from the edge of 
the profile. 
A positive X and Y shift is used to offset the targets away from the board. Typically, the 
targets are offset by 0.5"/10mm or 1"/20mm in the X and Y axis. 
The same shifts should be used for all the output files of a particular design. 

“Layer n1-n2” pages 
Because of the number of layers, the layer settings are sub-divided across pages. Use the appropriate Layers 
tabs to access the layers required. The page showing Layers V, T, B, 1 -13 is shown here. 
Note: always check all the layers pages to ensure there is nothing selected/unselected that shouldn't be. 

 
Whichever layers page is visible, it shows the selected range of layers and the following settings, which should 
be set as required. 
Layer The layers listed represent the layers of the board as displayed in the artwork editor. Whether the 

data on the layers is output, is determined by the selections made in the Pads and Copper columns 
alongside. 

Pads If ticked, all the pads from that layer are output. This includes any pads that have been added using 
the AMEND menu.  

Copper if ticked, anything from that layer that is not a pad will be output, for example, tracks, text, copper fill, 
silk-screen lines, irrespective of the layer type - for example a silkscreen layer does not contain any 
copper, but any lines, text, etc on that layer will be output when selected. 

Display Colour the data will be displayed and output in the colour indicated on the screen. Note: there may 
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not be a close colour match between the display colour and that output to the colour device. 
Select the coloured box and choose a colour from those in the colour palette window that appears. 

Description  if the layer is in use (i.e. not empty) useful information about it is displayed. The layer type, 
the number of points on the layer and its Title (if one was assigned) is displayed. (Refer to 
Configuration > Layer Assignments & Ordering for layer types and titles).  

Once the pages in the window have been set as required, move on to the heading: Configure > Output Filter 
 

Configure > Plot Source (with a Solder Mask Task open) 
This command should be selected to control exactly what will be included in an auto-generated solder mask 
when it is output.  
User-defined solder masks that have been generated using the Tools > Generate silkscreen command in the 
artwork editor should be output with anArtwork layers Task. 
Typically, a solder resist mask is created for the bottom of the board only, but some companies create a solder 
mask for the top of the board as well. One output file is required for each side of the board. Each output could 
also contain the profile, target markers and data from other layers if required.  
The Configure > Plot Source command can also be activated by selecting the Setup button alongside the Solder 
Mask Source setting in the Toolbar, arrowed in Figure 224 

 

Figure 224 

The Source setting (Solder Mask) determines what type of data will be output and this can’t be changed as it’s 
controlled by the type of Task that’s open. 
When the command is selected, a window appears as shown in Figure 225.  

 

Figure 225 

This window, made up of 5 pages that are accessed from the Setup and Layers tabs at the top of the window, 
controls what will be included in an auto-generated solder mask when it is output.  
Different combinations of pads/vias, sometimes copper, are output, depending on what is required.  
Data that is output, results in areas free of solder mask.  
It is usual to increase the size of pads that are output so that any mis-alignment of the actual solder mask 
doesn’t cover the pads on the board and hinder soldering. 
Set the pages in the window as required using the following information to guide you. 
Board Profile if enabled, the board profile (as defined in the profile editor) is output. Typically the profile 

would not be output, but can be included if required. 
Alignment Targets  if enabled, three alignment target markers are output.  
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Target markers or "alignment markers" are used to align the layers of the board together 
when manufacturing the board.  They would normally be included with all output files, and in 
the same relative positions.  
The alignment target markers are produced automatically by the output tool so are not 
visible in the artwork editor, though they are seen in the output tool when selected. 
They are positioned automatically on the top corners and bottom right corner of the profile if 
it is rectangular. Irregularly shaped boards have an imaginary rectangle placed around them 
that is used for target positions - the rectangle is drawn as small as possible without 
overlapping the real profile. 
The Target X & Y Shifts setting is used to move the alignment targets away from the 
corners of the profile. 
Unless output to gerber files, the target markers appear as 4 unfilled quadrants of a circle, 
with 2 diagonally opposite quadrants missing.  
Target markers within gerber files are defined by the Dcode that is used to produce them. 

Display Colour the output data will be displayed and output in the colour indicated on the screen. Note: 
there may not be a close colour match between the display colour and that output to the 
colour printer/plotter. 

 Select the coloured box and choose a colour from those in the colour palette window that 
appears. 

Pad swell the value entered here increases the size of all the pads that are output.  
Typically, a pad swell is specified to make the pads that are output, larger than the actual 
pads and therefore suitable for a solder resist mask.  
For instance a pad swell of 0.015" increases all the pad sizes by 0.015". i.e. a 0.060" pad is 
output at 0.075", and a 0.1" x 0.050" pad is output at 0.115" x 0.065".  
(In metric a 0.4mm swell would increase a 1.5mm pad to 1.9mm, and a 2.5mm x 1.2mm 
pad to 2.9mm x 1.6mm.) 

Swell method Options are Square corners or Filleted (rounded) corners. Typically Square Corners are 
output. 
Square corners: square and rectangluar pads will be swollen by a simple increase of their 
width and length so right-angled corners will be maintained. 
Filleted (rounded) corners: swollen pads are created that maintain a constant clearance 
from the original pad. For a pad with right-angled corners, this constant clearance results in 
a radiused corner to the swollen pad. 
This setting has no effect on round/round-ended finger pads and does not affect custom 
pads which are always swollen using the filleted method of maintaining constant clearance. 

Target X and Y shift without a shift (0 specified) the target markers are positioned on 3 corners of the 
rectangular area occupied by the profile. The target markers do not need to be part of the 
finished artwork so a shift is usually entered to move the targets away from the edge of the 
profile. 
A positive X and Y shift is used to offset the targets away from the board. Typically, the 
targets are offset by 0.5" or 1" (10mm or 20mm) in the X and Y axis. 
The same shifts should be used for all the output files of a particular design. 

Include vias Via pads can be included or excluded from the output. Some companies prefer to cover via 
holes with the solder mask, whilst others do not.  
Including the vias (ticked) will result in the via pads being exposed through the solder mask, 
provided the pads from layer V (in the Layer V, T, B -13 window) are also included.  
If layer V pads are not included, then the vias will not be included, even with this setting 
ticked – check the display before producing the output file if you are unsure. 
(If Vias are not included, but layer V pads are included, only added pads on the V layer will 
be output.) 

Once the Setup window has been set as required, the layers from the artwork have to be selected.  

Layer pages 
Because of the number of layers, the layer settings are sub-divided across pages. Use the appropriate Layers 
tabs to access the layers required. The page showing Layers V, T, B, 1 -13 is shown in Figure 226. 
Note: always check all the layers pages to ensure there is nothing selected/unselected that shouldn't be. 
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Figure 226 

Whichever layers page is visible, it shows the selected range of layers and the following settings, which should 
be set as required. 
Layer The layers listed represent the layers of the board as displayed in the artwork editor. Whether the 

data on the layers is output, is determined by the selections made in the Pads and Copper columns 
alongside.  
Just layer B (bottom) pads would be  output for a bottom solder mask which requires vias to be  
covered by the solder mask. 

Pads If ticked, all the pads from that layer are output. This includes any pads that have been added using 
the AMEND menu.  
Including the V layer (ticked) will result in all the added pads on the V layer being exposed through 
the solder mask.  
If the vias have to be exposed through the mask as well, ensure the “Include Vias” setting on the 
Setup page is also incuded.  
If layer V pads are not included, then no pads from the V layer will be output - check the display 
before producing the output file if you are unsure. 

Copper if ticked, anything from that layer that is not a pad will be output, for example, tracks, text, copper fill, 
silk-screen lines.  
For example, it may be a requirement to expose a drawing number, layer identification, issue 
number, etc. through the solder mask. 

Display Colour 
The data will be displayed and output in the colour indicated on the screen. Note: there may not be a 
close colour match between the display colour and that output to the colour printer/plotter. 
Select the coloured box and choose a colour from those in the colour palette window that appears. 

Description 
If the layer is in use (i.e. not empty) useful information about it is displayed. The layer type, the 
number of points on the layer and its Title if one was assigned is displayed. (Refer to Configuration > 
Layer Assignments & Ordering for layer types and titles).  
 

Once the pages in the window have been set as required, select Close to continue, then move on to the 
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heading: Configure > Output Filter  

Configure > Plot Source (with a Solder Paste Task open) 
This command should be selected to control exactly what will be included in an auto-generated solder paste 
when it is output.  
User-defined solder pastes that have been generated using the Tools > Generate silkscreen command in the 
artwork editor should be output with anArtwork layers Task. 
If surface mounted components exist on both sides of the board, typically two output files need to be generated. 
One containing pads from SMD's on the top of the board, the other containing pads from SMD's on the bottom 
of the board.  
Each output could also contain the profile and target markers, if they are required.  
Copper and/or pads from one other user-selected layer can also be included in the output. This allows text or 
special features to be included. 
The Configure > Plot Source command can also be activated by selecting the Setup button alongside the 
Source setting in the Toolbar, arrowed in Figure 227. 

 

Figure 227 

The Source setting (Solder Paste) determines what type of data will be output and this can’t be changed as it’s 
controlled by the type of Task that’s open. 
When the command is selected, a window appears as shown in Figure 228.  

 

Figure 228 

This window controls what will be included in an auto-generated solder paste when it is output.  
Set the pages in the window as required using the following information to guide you. 
Board profile If ticked, the board profile (as defined in the profile editor) is output. Typically the profile would not 

be output, but can be included if required. 
Alignment Targets if ticked, three target markers are output.  

Target markers or "alignment markers" are used to align the layers of the board together when 
manufacturing the board.  They would normally be included with all output files, and in the same 
relative positions.  
The target markers are produced automatically by the output tool so are not visible in the artwork 
editor though they are seen in the output tool when selected. 
The target markers are positioned automatically on the top corners and bottom right corner of the 
profile if it is rectangular. Irregularly shaped boards have an imaginary rectangle placed around 
them that is used for target positions - the rectangle is drawn as small as possible without 
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overlapping the real profile. 
The Target X & Y Shifts setting is used to move the targets away from the corners of the profile. 
Unless output to gerber files, the target markers appear as 4 unfilled quadrants of a circle, with 2 
diagonally opposite quadrants missing.  
Target markers within gerber files are defined by the Dcode that is used to flash them. 

Top pads if ticked, the pads of surface mounted components mounted on the top of the board (layer T) are 
output.  
Any pads that have been added to layer T using the Amend commands, or those belonging to 
conventional components or vias are not included.  

Bottom pads if ticked, the pads of surface mounted components mounted on the bottom of the board (layer B) 
are output.  
Any pads that have been added to layer B using the Amend commands, or those belonging to 
conventional components or vias are not included.  

Extra layer this setting allows copper (tracks, text and pads) from one specified layer to be included in the 
solder paste output, if required.  
Pad shrinkage is applied to the pads from the extra layer. 
For example, it may be a requirement to include a drawing number, layer identification, issue 
number, etc. in an output file. Tick the box to include the extra layer and type in the required layer 
number in the - number dialogue. 

Layer #  type in the number of the layer that should be included in the output if the Extra layer setting has 
been ticked. 

Pad shrinkage the value entered here reduces the size of all the pads that are displayed and output. 
This makes the pads that are output, smaller than the actual pads and therefore suitable for a 
solder paste mask.  
For instance a pad shrinkage of 0.015" reduces all the pad sizes by 0.015". i.e. a 0.060" pad is 
output at 0.045", and a 0.1" x 0.050" pad is output at 0.085" x 0.035". 

 Target X/Y shift without a shift (0 specified) the target markers are positioned on 3 corners of the rectangular 
area occupied by the profile. The target markers do not need to be part of the finished artwork so a 
shift is usually entered to move the targets away from the edge of the profile. 
A positive X and Y shift is used to offset the targets away from the board. Typically, the targets are 
offset by 0.5" or 1" (10mm or 20mm) in the X and Y axis. 
The same shifts should be used for all the output files of a particular design. 

Once the Setup window has been set as required, select Close to continue, then move on to the heading: 
Configure > Output Filter 

Configure > Plot Source (with a Drill Sheet Task open) 
This command should be selected to control exactly what is included in a drill sheet (drill drawing) when it is 
output. A sample drill drawing is shown in Figure 229. 

 

Figure 229 

It shows the board profile, the positions of all the holes in the design using a symbol to represent each hole size, 
and a table listing the symbols, their sizes and number off of each.  
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The output could also contain the keep-out areas and target markers, if required.  
If blind/buried vias have been used, then multiple drill sheets will be required for the different drill data sets. 
Refer to using blind/buried vias for more information. 
Many companies like to add extra information to their drill drawings, so it is possible to direct the output to a 
documentation layer in the artwork editor so that the additional information can be added. (That modified layer 
would then be output using an Artwork Layers Task, not a drill sheet task.) 
The drill table can be output in imperial or metric units (Edit > Units or the the special function keys can be used 
to toggle between the two units, however the Task will have to be closed/opened to see the effect of the 
change). 
The Configure > Plot Source command can also be activated by selecting the Setup button alongside the 
Source setting in the Toolbar, arrowed in Figure 230 

 

Figure 230 

The Source setting (Drill Sheet) determines what type of data will be output and this can’t be changed as it’s 
controlled by the type of Task that’s open. 
When the command is selected, a window appears as shown in Figure 231. 

 

Figure 231 

This controls what is included in the drill sheet output. Set the parameters as required, using the following 
information to assist you: 
Board Profile if ticked, the board profile (as defined in the profile editor) is output. Typically the profile is included 

in a drill drawing. 
Keepouts if ticked, the keep-out lines (as defined in the profile editor) are output.  

Typically keepout lines are not included in output files unless there is a specific requirement, 
perhaps for a check plot/print in order to assess their positions. 

Alignment Targets if ticked, three alignment target markers are output.  
Target markers or "alignment markers" are used to align the layers of the board together when 
manufacturing the board.  They would normally be included with all output files, and in the same 
relative positions.  
The target markers are produced automatically by the output tool so are not visible in the artwork 
editor though they are seen in the output tool when selected. 
The target markers are positioned automatically on the top corners and bottom right corner of the 
profile if it is rectangular. Irregularly shaped boards have an imaginary rectangle placed around 
them that is used for target positions - the rectangle is drawn as small as possible without 
overlapping the real profile. 
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The Target X & Y Shifts setting is used to move the targets away from the corners of the profile. 
Unless output to gerber files, the target markers appear as 4 unfilled quadrants of a circle, with 2 
diagonally opposite quadrants missing.  
Target markers within gerber files are defined by the Dcode that is used to flash them. 

Symbols  if ticked, the symbols that are used to represent each different hole size are output. 
Hole data if ticked, the table of information that cross-references the symbols used, to the hole sizes and 

quantities, is output. Sizes in the table can be displayed and output in imperial or metric units - 
changing the units will require the task to be closed/reopened for the change to be made. 

Display Colour 
The data will be displayed and output in the colour indicated on the screen. Note: there may not be a 
close colour match between the display colour and that output to the colour printer/plotter. 
Select the coloured box and choose a colour from those in the colour palette window that appears. 

Target X/Y shift without a shift (0 specified) the target markers are positioned on 3 corners of the rectangular 
area occupied by the profile. The target markers do not need to be part of the finished artwork so a 
shift is usually entered to move the targets away from the edge of the profile. 
A positive X and Y shift is used to offset the targets away from the board. Typically, the targets are 
offset by 0.5" or 1" (10mm or 20mm) in the X and Y axis. 
The same shifts should be used for all the output files of a particular design. 

CNC Dataset: 
Choose from the list, by selecting the arrow alongside. 
Typically an output is required for each drill data set. 

 
Once the Setup window has been set as required, select Close to continue, then move on to the heading: 
Configure > Output Filter 

Configure > Plot Source (with a Schematic Task open) 
This command controls what will be included in a schematic when it is output.  
The Configure > Plot Source command can also be activated by selecting the Setup button alongside the 
Source setting in the Toolbar, arrowed in Figure 232. 

 

Figure 232 

The Source setting (Hierarchical schematic) shows what type of data will be output and this can’t be changed as 
it’s determined by the type of Task that’s open.  
When the command is selected, a window appears as shown in Figure 233. 
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Figure 233 

This shows which sheets are available for output, their position in the hierarchy and what is included in the 
output. Set the parameters as required, using the following information to assist you: 
Block Name & Hierarchy Position 
 Select the sheet to be output from the list provided.  

Each sheet has its position in the hierarchy shown, along with a suffix (.1, .2, .3, etc.) useful for 
identification when the sheet is used multiple times in the hierarchy.  

Sheet border the default drawing border (lines and text) that appears when a schematic sheet is created, plus 
any non-electrical data added in Drawing sheet mode. 

Symbols  any thing added using the outline commands within a part. 
Connections includes signal and bus connections and junction blobs.  
Attributes the attribute text associated with symbols and connections. The attributes are only included if 

the associated symbol or connections are also included. 
Non-electrical  any non-electrical data added in Annotate mode in the schematic editor. 
Display Colour the data will be displayed and output in the colour indicated on the screen. Note: there may not 

be a close colour match between the display colour and that output to the colour printer/plotter. 
 Select the coloured box and choose a colour from those in the colour palette window that 

appears. 
Copy this colour setup to all other schematic tasks 

Use this button to copy the Display Colours assigned to this sheet, to all the schematic tasks in 
this design – useful when consistent colour choices are required for all sheets within the design. 

Once the Setup window has been set as required, select Close to continue, then move on to the heading: 
Configure > Output Filter  

Configure > Output Filter 
This command is used to control the type of output that is produced (Gerber, DXF, Bitmap, JPEG, Windows 
printer, etc.).  
The output format is controlled by making a selection from the Output setting in the toolbar shown in Figure 
234, select the arrow alongside the current setting and make a choice from the drop-down list, the choices are: 
 

 

Figure 234 
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 Photoplotter - for gerber files 
 2D/3D Drawing - for DXF files and re-directing data into the artwork editor 
 Windows Printer - for devices (printers/plotters/pdf) with a Windows printer driver 
 Image file - for bitmap, .png, .gif or .jpeg formats 
Once the Output format has been selected, select the Setup button from alongside it, the windows that appear 
will vary depending on which type of output format is selected. All the variants are described below.  

Configure > Output Filter - Photoplotter selected 
Selecting gerber file output 
Assuming the output task is open, ensure the Output dialogue is set to Photoplotter as shown in Figure 235.  

 

Figure 235 

  
Select the Setup button alongside it, or select the Configure > Output Filter command, to produce a window 
similar to the one shown in Figure 236 which indicates Gerber format RS274X is being output. 
 

 

Figure 236 

Select the Properties button to control the plotter variables which are shown below in Figure 237. 
 

 

Figure 237 

 
Set the parameters as required, using the following information to assist you: 

Film/Plotter bed size: Select a larger size than the data you are outputting requires.  
When the window is closed, the film is displayed on the screen as a white 
background. The dashed lines around the edge indicate the plottable area on the film, 
which is usually slightly smaller than the actual film. (Note: this setting does not 
control the size of film actually used in the plotter, it is shown purely for reference 
purposes.) 

Number of decimal places: The co-ordinates in the Gerber file can be output with either 4, 5, or 6 decimal 
places. Depending upon the accuracy required in the output file, choose the 
appropriate number - 4 decimal places is adequate for most designs.  



 

347 

Output mode:  Most outputs should be produced in positive mode.  
However, when power plane, solder mask and solder paste layers are created in 
positive mode, they have to be photo-reversed in order to create the correct image for 
board manufacture. 
A command can be inserted at the front of the gerber file to instruct the plotter to 
reverse the images of the supplied file.  It is achieved by setting the output mode to 
Negative (inverted). 
This will save having to perform the photo-reversal procedure, but not all plotters 
support the command so you may need to check with the plotting bureau.  

RS-274X Tuning: With "May use any feature defined in standard" selected, XL Designer will utilise the 
features described in the latest RS-274X specification document.  This will result in 
the most efficient Gerber output but may result in incompatibilities with some older 
output devices/viewers. 
With "Simplify for marginally compliant devices" selected, XL Designer will avoid 
known pitfalls in older, popular output devices/viewers that have partial or weak 
implementation of the RS-274X standard. 
These are some of the problems we have identified within the implentation of the 'AM' 
(Aperture Macro) command in popular Gerber viewers, and this mode will attempt to 
work around them: 

• Device requires an upper-case 'X' as the multiply sign in arithmetic 
expressions. The standard says it should be lower case. 

• Failure to rotate the x/y position of circle primitive (code 1). 
• Failure to rotate the x/y position of centre line primitive (code 21). 
• Failure to position the centre line primitive (code 21) at the corrent location, 

always placed at x=0,y=0 
• Failure to handle multiple arithmetic operations in one statement. 
• Failure to handle bracketing to control arithmetic precedence. 

Please note that the 'simplified' mode does not imply that the generated Gerber will be 
shorter.  It will in fact be longer and the AM definitions more difficult to read as various 
tactics are used to work around the above problem areas. 

Once the window has been setup as required, select OK, then Close. The white background now represents the 
film that the data will be placed on. You may be able to see some of the data but don't worry if you can't. 
Gerber output has now been selected you are ready to continue. Move on to the heading: Positioning and 
scaling the output data 

Information on gerber files & Dcodes 
A Gerber file does not contain pads, holes or tracks, or any electrical information.  
It contains commands in a Gerber format to expose areas on a piece of photographic film.  
The size/shape of the area is controlled by an aperture 
If the film is moved whilst the area is being exposed, elongated areas are exposed.  
These exposed areas become the “pads” and tracks” that you see on the film. 
If the film was stationary when the light was switched on/off, the exposed area was "flashed".  
If the film was moved whilst the light was switched on, the exposed area was "drawn".  
Each aperture is given a unique number for identification, known as its "DCode".  
The list of apertures and their associated DCodes is held within the header of the gerber file. 
The Gerber file simply contains commands to select apertures, move to the required positions and either 
"flash" or "draw" on to the film. It does not contain pads, tracks, holes, text, etc. 

Configure > Output Filter – 2D/3D Drawing selected 
This Output type provides access to the DXF output and Redirection of data to the artwork editor documentation 
layers output. 

Redirection of data to artwork documentation layers 
Any data that can be output from the graphical tasks can be re-directed back into the artwork editor. This facility 
can be used to accommodate tasks that would not otherwise be possible, for example, it allows the drill sheet 
output to be modified, or a border defined in a schematic to be added to the artwork for documentation 
purposes. 
When the output takes place, the selected layer automatically becomes a Documentation layer. 
Assuming the output task is open, ensure the Output dialogue is set 2D/3D Drawing as shown in Figure 238. 
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Figure 238 

Once selected, select the Setup button alongside or select the Configure > Output Filter command, to produce a 
window similar to the one shown in Figure 239. 

 

Figure 239 

Ensure the Device Type is set to Artwork documentation layer as shown in Figure 239 (select the arrow 
alongside the setting to list the options available and make your choice if it’s set differently), then select the 
Properties button to produce a window similar to that shown in Figure 240. 

 

Figure 240 

 
Set the window as required using the following information to assist you. 

Destination layer the data that is output will be placed on the layer specified, in the artwork editor of 
the current design. Select the entry then type the layer number the data should be 
placed on.  
Once the data has been added to the layer it can be modified in any way required. 
For example additional information could be added to a drill drawing, or the drill table 
moved/edited.   

Append to layer the data being output may be added to, or replace any data that is already on the 
layer specified. With No selected, the data being output replaces any data that is 
already on the layer specified. 

Once the window has been setup as required, select OK  to continue.  
The white background now represents the artwork editor and the layer the data will be placed on. You may be 
able to see some of the data but don't worry if you can't. You are now ready to continue. Move on to the 
heading: Positioning and scaling the output data 
Note: if attempting to align the output (maybe the drill drawing) with the existing artwork, output the data with the 
X and Y shifts set to 0 (Configure > Keymove Plot). 

Output to AutoCAD DXF file 
Any data that can be output from the graphical outputs editor can be output to an AutoCAD DXF (.dxf) file.  
Assuming the output task is open, ensure the Output dialogue is set 2D/3D Drawing as shown in Figure 238. 
Once set, either select the Setup button alongside (to the right) or select the Configure > Output Filter command 
to produce a window similar to the one shown in Figure 241. 

 

Figure 241 
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The Device type setting should be set to AutoCAD DXF File. If it isn't, then it must be changed by selecting the 
arrow alongside and selecting it from the list that appears. 
Once selected, select the Properties button to control the output variables. An example of the properties window 
is shown in Figure 242. 

 

Figure 242 

Set the parameters as required, using the following information to assist in your decisions: 
DXF units  the output data is produced in the units selected. Select the arrow alongside the setting 

and select the units required. 
Layer mode this setting controls the conversion of the Ranger layers to corresponding DXF layer 

identities.  
Use Named Layers  if this is selected, the .dxf output will be placed into layers that 

have symbolic names relating to the source that created the plot 
information.  e.g. via holes will be placed into a DXF layer called 
VIAHOLES. This is the recommended setting for clarity in 
AutoCAD when used by Ranger users. 

Fixed Layer Number  if this is selected, the .dxf data will be generated in the layer 
number specified in the Fixed Layer setting, which will become 
activated.  

Fixed Layer  this field becomes active when the Layer Mode is set to Fixed Layer Number. 
The fixed layer number may be in the range 1-16. 

Generate 3D data  when enabled (ticked) the .dfx output file that is subsequently created will contain a 
3D representation of the board layout. The 3D Mode & Board Thickness settings will 
become activated when this is enabled. 

3D mode if 3D data has been selected for output, two types of output file can be generated. One is 
a larger file that allows the resultant file to be viewed with shading, the other smaller file 
cannot be viewed with shading. 
Create Solid Model possible to display the resultant file with shading, larger file 
Create Wireframe only not possible to display the resultant file with shading, smaller 

file  
Board Thickness if 3D data has been selected for output, this setting specifies the thickness of the board 

material.   
Please note that as the board thickness is specified in the output filter, it has no 
knowledge of any plot scale factor that might have been used in the plot source setup 
dialog.  So if plots are created at a scale other than 1:1, then the thickness value should 
be adjusted by a corresponding amount. 

 
Setup Layer Colours this button permits the configuration of the colours used for the various layers. Three 
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settings are available by selecting the appropriate tab at the top of the window. 
Artwork Named Layers  permits assigning colours to various artwork features when 

Layer Mode is set to Use Named Layers 
Schematic Named Layers  permits assigning colours to various circuit schematic 

features when Layer Mode is set to Use Named Layers 
Numeric Layer Colours  tab permits assigning colours to the numeric layers that are 

created when the layer mode is set to Layer = Pen Number 
or Layer = Fixed Layer Number. 

Select OK to return to the DXF Output Setup window. 
The white background in the output task window represents the paper that the data will be placed on. You may 
be able to see some of the data but don't worry if you can't. 
The DXF output has now been selected. You are now ready to continue. Move on to the heading: Positioning 
and scaling the output data 

Configure > Output Filter – Windows Printer selected 
This output setting provides access to the Windows Printer drivers installed on the system. 
Assuming the output task is open, ensure the Output dialogue is set Windows Printer as shown in Figure 243. 

 

Figure 243 

Once selected, either select the Setup button alongside (to the right) or select the Configure > Output Filter 
command to produce a window similar to the one shown in Figure 244. The actual window and printers available 
will vary depending on the printer drivers loaded on your particular machine.  

 

Figure 244 

This Printer section of this window should be changed as required to suit the particular printer/plotter that is 
attached to your pc or network. Refer to the documentation supplied with the printer for help on the settings. 

Printer selection 
The printer selection and any selected printer options are retained with the task. If the design is later loaded on 
a computer not configured with the originally selected printer, then a warning will be displayed when the output 
task is opened and the printer selection will revert to the Windows default printer and settings. 
It to possible to return the output task Windows printer selections to the default printer at any time - right-click on 
the output tasks folder and select “Restore Default Windows Printer”, this will affect the Windows printer setting 
on all the tasks within the design. 
Right-click on individual tasks and select the “Restore Default Windows Printer” option to restore the default 
Windows printer on the selected task only. 
NB: Output task windows must be closed in order for the restore command to operate. 
The Print range and Copies sections are not used by Ranger. 
Select OK to continue. 
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The white background in the output task window represents the paper that the data will be placed on. You may 
be able to see some of the data but don't worry if you can't. 
The Windows Printer output has now been selected. You are now ready to continue. Move on to the heading: 
Positioning and scaling the output data 

Configure > Output Filter – Image File selected 
This output setting provides access to the Image file output to produce files in a PNG, BMP, GIF or JPEG 
format. 
When adding image output tasks to batch outputs, you must append the appropriate  .png, .bmp, .gif, or .jpg file 
name extension to each output file name in order for the  appropriate output encoder to be selected. 
Assuming the output task is open, ensure the Output dialogue is set Image File as shown in Figure 245. 

 

Figure 245 

Once selected, either select the Setup button alongside (to the right) or select the Configure > Output Filter 
command to produce a window similar to the one shown in Figure 246. 
 

 

Figure 246 

Select the Properties btton to produce the output setup window as shown in Figure 247. 
 

 

Figure 247 

Set the parameters as required, using the following information to assist in your decision: 

Positioning and scaling the output data 
Once the source (circuit, drill drawing, solder mask, solder paste or artwork) and output format (gerber photo-
plotter, printer, plotter, DXF, etc.) and have been selected, the output data has to be positioned on the screen 
representation of the paper/film, at the scale required. This ensures that it will appear on the physical medium 
when it is output. 
Depending on the source data and paper/film size, you may be able to see part of the board profile or schematic 
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border on the screen at this stage, but don't worry if you can't. The following Configure commands and 
procedure will reveal it. 

Making the output visible 
If the schematic sheet outline or board profile cannot be seen, ensure you are viewing the complete output area 
(View > Full or press <F4>). 
What is visible on screen is what will be output. The solder mask and solder paste output types are displayed on 
screen with the appropriate pad size expansion/shrinkage. 
Select Configure > Auto Centre to bring the data to the centre of the white background. 
If the data still cannot be seen, you may need to zoom in and pan (View commands). 
If the data still can't be seen, select Configure > Scale Plot, Fill sheet  to ensure the data is likely to be visible, 
for instance, an A1 schematic scaled at 10:1 is unlikely to be seen on an A4 back-ground. 
These commands may not necessarily put the data where you want it to appear, but it's a good place to start.  
Use some or all of the following commands to position & scale the data as required. Most of these commands 
have an icon shortcut in the toolbar. 

Configure > Move Plot 
Used to dynamically move the data into position on the white background. This command can only be used if 
the schematic sheet outline or board profile can be seen. If they can't, use the Configure > Keymove Plot 
command. 
Once active, select a corner of the sheet outline/board profile, or the centre of a circular profile. Move the cursor 
and attached data then click again to release the data. Clicking the right-hand mouse button whilst the data is 
being moved, returns the data to its original position. 
Note: wherever the data is positioned, it is located at a specific X and Y location. This location can be viewed 
using the Configure > Keymove Plot command.  
When plotting artwork layers, solder masks/pastes it's wise to output all the files at the same X and Y location.  
If the files will be imported back into the artwork editor, or aligned with the NC Drill files via a 3rd party viewer, 
then it's wise to output the data without "a shift", i.e. with the X and Y shift set to 0.  

Configure > Keymove Plot 
Used to position the data at an exact location by typing or "keying-in" co-ordinates.  
This command can also be used if the data cannot be selected using the Configure > Move Plot command 
because the sheet outline or board profile are not visible and therefore not selectable. 
Once selected, a window appears into which the offset values for the X and Y-axes should be typed. Select OK 
to implement the changes.  
When plotting artwork layers, solder masks/pastes it's wise to output all the files at the same X and Y location.  
If the files will be imported back into the artwork editor, or aligned with the NC Drill files via a 3rd party viewer, 
then it's wise to output the data without "a shift", i.e. with the X and Y shift set to 0.  

Configure > Rotate Plot 
Used to rotate the data, typically to make more use of the available paper/film. Each time Configure > Rotate 
Plot is selected, the data rotates through 90 degrees anti-clockwise. 
Schematic sheets and artworks are rotated about their centre, i.e. the centre of the smallest rectangle that 
completely encloses the sheet outline or profile. 

Configure > Mirror Plot 
Used to mirror the data. The icon alongside the command (and in the toolbar) is highlighted when the data is 
mirrored.  
Schematic sheets and artworks are mirrored about their original centre, Y-axis. For instance, they are mirrored 
left to right about their centre, unless they have been rotated by 90 or 270 degrees, in which case they are 
mirrored top to bottom about their centre.  
Typically one outer artwork layer is mirrored. (To allow both outer board layers to be produced with the emulsion 
side up or down.) 

Configure > Scale Plot 
Used to increase or decrease the size of the output data. 
Once selected, a window appears into which the required scale should be entered. For example, entering 2 
produces output data at twice full size, entering 0.5 produces output data at half full size, etc. To save typing 
when a 1:1 scale is required, a button Set 1:1 scale is provided. 
If the Fill sheet button is selected, the data is scaled up or down automatically to fill the plottable area of the 
sheet, which is indicated by the dashed lines on the white background. If the Configure > Scale Plot box is re-
selected, the scaling factor used is displayed in the Plot scale dialogue. 
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Fill sheet is typically used when plotting circuit diagrams, because for instance, an A3 schematic will not fit in the 
plottable area of an A3 piece of paper. 
Gerber files are generally produced at 1:1 and a warning will appear if a different scale is selected - the warning 
can be ignored if required.  

Configure > Auto Centre 
Used to position the data centrally on the sheet.  

Plot commands 
These commands are used to prevue what will be output and to start the output. 

Plot > Execute 
Used to produce the output selected. 
Once the appropriate source and output type has been selected, the data positioned and scaled as required, it 
is ready to be output.  
Select Plot > Execute (or the Go icon).  
If the data is being output to a file, use the Windows browser that appears to locate the folder where the file will 
be saved in, then supply a name for the file in the Filename dialogue. Select Save to create the file.  
Plot complete will appear in the status bar to indicate that the output was successful. 
If the data is being output to a device, the data will be spooled to the Windows device queue.  
Plot complete will appear in the information bar at the bottom of the window to indicate that the data has been 
sent to the queue. 

NC Drill & Rout Data Task 
Drilling and routing output files can be produced in either an Excellon or Sieb & Meyer format. The file(s) contain 
information that describes the drilling data for the holes in the board, or the routing data for the board.  
A separate NC drill output file (and Task) is required for each of the datasets: 

conventional through hole vias/component holes 
non-plated holes 
each set of blind vias  
each set of buried vias  

Some drilling machines can also rout short slots, so the slots might be included with the appropriate drilling 
datasets.  
Longer slots, particularly those that define the outer edge of the board may need their own separate output file.  
This is something that should be checked with the individual manufacturer. 

Producing the NC Drill/Router output files 
From the navigator pane and with the design open, open the Outputs folder. Right-click on the Tasks folder, 
select New NC Drill & Rout Data Output. Rename it to reflect the type of output file that will be produced.  
If the design has plated/non-plated holes, blind/buried vias, etc., then more than one file will be required, so 
supply a name that reflects the type of output file it is. One task will be required for each CNC Dataset. 
Open the Task by double-clicking it. A window similar to the one in Figure 248 appears. Each of the settings is 
described below. 
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Figure 248 

 
The window provides a summary of the output data, followed by the parameters that can be changed. 
The tool numbers, type, diameters and number of items obviously vary from design to design and this part of the 
window is updated automatically and cannot be changed. 
Set the parameters as required, some are greyed out if they aren’t applicable to the output type selected. Use the 
following information as a guide: 
Configuration: 

CNC Dataset: all the drills and slots included in the selected dataset will be included in the output file. 
File Type: Either Excellon or Sieb & Meyer format files can be output. Both file types have the tooling 

information embedded in the file. 
A separate file with just the tooling information can also be output for reference. 
Select the format required - discuss this with the board manufacturer if you are unsure 
which to choose. 

Units: An imperial (inches) or metric format file can be chosen. Select the format required - 
discuss this with the board manufacturer if you are unsure which to choose. 

 
Options: 

Include router pre-drilling:  all of the pre-drilling information within slots can be included or excluded as 
required. If unchecked, pre-drilling details included in the slot will be 
excluded. 

Include feed & speed info: if defined in the CNC Tool Parameters, the feed & speed information can be 
included or excluded as required. 
Note: most modern drilling/routing machines have pre-set speeds and feeds 
for different sized drills/cutters, therefore consult your manufacturer before 
over-riding these values. 

Default file extension: the output file will be given the specified file extension when created.  
If an extension is specified in this field, but a different extension is typed in 
when the file is being created, then the extension specified at the file 
creation stage is used in preference to the default setting. 
If no extension is specified in this field, then an extension is not added when 
the output file is created, unless one is specified at file output stage.  

 
Once these parameters have been set as required, the output files can be produced.  
When the drill datasets are used for drilling blind vias, it is essential that the holes are drilled from the correct 
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side of the board (top or bottom) and to the correct depth. Bear in mind that there could be more than one set of 
blind holes (drill datasets) drilled from the same side of the board, but to different depths. There is no drill depth 
information held within Ranger. 
Use the Create File button to create the file. Use the Windows browser that appears, to locate the folder where 
you would like the file to be created in, then supply a name for the file in the Filename dialogue.  
Select Save to create the file. 

Over-lapped drill holes 
When the NC Drill output task is run, a check is performed to identify any concentric drilled holes on the artwork. 
If any are found, a report appears as shown in Figure 249, before the NC Drill/Rout window appears.  

 

Figure 249 

This report is given for information, it does not stop the output files from being produced - though it would be 
wise to investigate the cause of the overlapped holes, by viewing the artwork and locating the holes at the co-
ordinates reported, then making any changes as appropriate. Typically vias may have been moved on top of 
other vias or component pads. 
You can choose to ignore the report and continue with the output. 
Although the report specifies "overlapped" drill holes, only concentric drill holes are identified, so there may be 
overlapped drill holes present that are not reported. 
Where concentric holes are reported, only the largest hole at the specified co-ordinate is included in the 
subsequent output file.  
The co-ordinate readout is given with respect to absolute 0,0 in the artwork editor. If the datum of the artwork 
editor has been moved, the co-ordinate readout of the mouse will not correspond to the co-ordinates in the 
report. The datum would have to be reset to 0,0 in the artwork editor to locate the position reported. 
Select OK to close the report, the output routine continues.  
 

IDF Output Task 
This output task will create two output files.  The ".emn" file contains the definition of the board outline and the 
placement information for all parts.  By selecting the appropriate options in the configuration dialog window, it 
can also optionally contain board drilling information. 
The ".emp" file is the part library which contains the outline definitions that the MCAD application “extrudes” by 
the component height along the Z axis to form the 3D representation of the part. 

Producing the IDF Version 3 output files 
From the navigator pane and with the design open, open the Outputs folder. Right-click on the Tasks folder, 
select New IDF Output. Rename it to reflect the type of output file that will be produced.  
Open the Task by double-clicking it. A window similar to the one in Figure 250 appears. Each of the settings is 
described below. 



 

356 

 

Figure 250 

 
IDF Units: the output file will contain values in the units specified here. The MCAD application will take 

these units into account when importing the file to ensure the scale of the object is correct. 
The setting does not alter the units used in the MCAD application. 

 
Board Thickness: this setting specifies the thickness of the board material.  The units are always in inches for 

this setting. 
Add Keepout regions as board cutouts: 

When enabled (ticked) any closed polygon shapes that have been added to the “Keepout” 
layer (in the profile or artwork editors) will be output as cutouts within the IDF file. 

Add Router regions as board cutouts: 
When enabled (ticked) any closed polygon shapes that have been added to the “Router” layer 
(in the profile editor) will be output as cutouts within the IDF file. 

Part library outline creation: 
When the output files are created, there are 3 ways in which the part outlines can be defined. 
Choose the most appriopriate to suit your requirements. 

Generate from outline placement bounds box – this mode will create a simple rectangular block to 
represent each part in 3D.  The dimensions of the box are taken from the auto-placement 
footprint definition in the component outline library entry associated with the part. 

Generate from outline silk screen data – this mode will attempt to create the footprint shape used for 
the 3D figure by processing the data in the outline silk screen.  If no suitable polygon can be 
created from the outline’s silkscreen definition (for example because the silkscreen is just a 
single straight line), then the auto-placement footprint is used as described above. 

Use 3D solid mode setting on outlines – this mode will generate the part outline according to the 3D 
solid mode setting stored within each individual component outline. This allows for a 
combination of the above two settings to be used. 

Default component height: 
If the height of any component outlines has not been specified (or left at 0) within the 
component outline in the library, then the height specified here will be used for those outlines.  

IDF package name/part numbering method: 
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Outline name / (blank) – this mode will create one part library entry for each component outline shape 
used in the design.  If several parts of different types share the same outline, then they will all 
be mapped to the same part library name. 

Outline name / component value – this mode will create one part library entry for each unique  
combination of outline name and part description (component value) field.  This permits more   
fine-grained control of the mapping of part references to 3D part models when using mapping   
files - such as the “ecad_hint.map” file in Pro Engineer. 

Use parts list MCAD model name for package: 
When enabled (ticked), then any model name specified in the "MCAD Model" field in the parts 
list editor of XL Designer will be used as the IDF model name for the part instead of the 
outline name. If no MCAD model value is defined for a part, the component outline name is 
used. 

Drilled Hole Output: 
Drilled holes can be included in the output file if required. To allow fine-tuning of the types of 
hole to be included in the output file, the following selections are available: 

Output part pin drill holes – if ticked will include all holes from component outlines. 
Output via holes – if ticked will output all via holes (holes in standard code 0 round/square pads on the 

via layer “V”) 
Output layer zero non-vias as mounting holes – if ticked will output holes from pads on the via layer 

“V”, excluding vias. 

Creating the output files 
To produce the files, ensure the appropriate selections have been made in the window using the descriptions 
above, then select Create file. Use the Windows browser that appears, to locate the folder where you would like 
the .emp (electro-mechanical neutral board) file to be created in, then supply a name for the file in the Filename 
dialogue. The job name will be used by default with a .emn file extension. Select Save to create the file.  
Repeat to provide a name for the .emp (electro-mechanical part) file. The job name will be used by default with 
a .emp file extension. Select Save to create the file.  
Two output files will be created, the ".emn" file contains the definition of the board outline and the placement 
information for all parts and board drilling information if selected. 
The ".emp" file is the part library which contains the outline definitions that the MCAD application 'extrudes' by 
the component height along the Z axis to form the 3D representation of the part. 
When opening the .emn file in Pro Engineer, it should be opened as an 'Assembly'.  Prompts will appear 
requesting the location of the corresponding .emp file. 
IDF output tasks may also be added to an output batch definition.  The output filename should be specified 
without a trailing extension.  When the batch is executed, the IDF exported will automatically append .emn and 
.emp to the output filename for the two files that it creates. 
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Outputs Folder - Batches 
Once the output tasks have been created, they can be used in a batch process to save selecting each output 
task individually. One batch process might contain all the output tasks to create the gerber files for the job. 
Another might contain all the schematic sheets to be output to a printer. This ensures that the same settings are 
used each time the files are created and also saves time. 
A batch process cannot be defined until the tasks to be included in it have been created/copied within the 
design’s Outputs/Tasks folder. 
In addition to running the batch process to output all the tasks within it, it is also possible to select and run an 
individual task from the batch process. 
Batch files created in Ranger XL jobs cannot be converted to Seetrax XL Designer format, so they have to re-
created. 

Creating a batch process 
With a design folder open in the navigator pane, open its Outputs folder. Right-click on the Batch folder and 
select New, supply an appropriate name. 
Names should help identify the type of batch process. Examples: “artwork layers, gerber”, “schematic sheets, 
printing” etc. 

Renaming a batch process 
Once a batch process has been created/copied, it can be renamed by selecting it with a right-click of the mouse, 
then selecting Rename. Type in the name required followed by <enter>. 

Copying a batch process 
Once a batch process has been created and its content defined, it can be used as a template for other similar 
batch processes, within the same design or other designs, by copying it and modifying the copy. This will be 
quicker than creating another batch process from scratch.  
With a design folder open in the navigator pane, open its Outputs and Batch folder. Right-click on the batch 
process to be copied, select Copy. Locate the destination Batch folder (which might be in the same or a different 
design) then right-click on the Batch folder and select Paste. The batch process is copied. It can be renamed or 
opened (double-select it) and modified. 
When copying tasks/batches between designs, be aware that schematic output task/batches may need to be 
edited as the design sheet names are likely to be different 

Deleting a batch process 
A batch process can be deleted by selecting it with a right-click of the mouse, then selecting Delete.  

Opening a batch process 
With a design folder open in the navigator pane, open its Outputs folder, then double-select the batch process to 
open it. 
A window appears similar to the one in Figure 251. 

 

Figure 251 

Adding/removing Tasks from the batch process 
Each of the Tasks that have been created in the design appears in the left pane of the window. Each Task that 
should be included in the batch process has to be transferred to the right pane. This is achieved by selecting the 
Task, then selecting the Transfer arrow as shown in Figure 252.  
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More than one task can be selected at a time - to select multiple tasks, hold down the left mouse button whilst 
moving over them, or hold down the <ctrl> key whilst selecting individual tasks. 

 

Figure 252 

The task is transferred to the right window pane. Repeat for all the tasks required.  
The tasks can be transferred between panes by selecting the task, then the appropriate (left/right) arrow. 

Specifying filenames for the resultant output files 
If the task will direct the output to a file (rather than directly to a device like a printer), then a filename has to be 
supplied for the new file – select the Output filename dialogue alongside the task in the right-hand pane and 
type in the filename required. A path should not be specified. Repeat for each task. 
If a Windows printer is targeted and the field is left blank, the output is sent directly to the printer device. Adding 
a filename can be useful when targeting Windows printer devices such as Print to PDF. 
NOTE: When adding image output tasks to batch outputs, you must append the appropriate  .png, .bmp, .gif, or 
.jpg file name extension to each output file name in order for the appropriate output encoder to be selected. 

Specifying the folder for the resultant output files 
In the Output Directory dialogue, either type in the path, or use the browser button alongside to use the 
Windows navigator to select the folder required, Figure 253. 

 

Figure 253 

Running the batch process or an individual task from the batch process 
When ready to run the batch process or a selected task within the batch process, select the Run all tasks or Run 
Selected Tasks button. (To select multiple tasks, hold down the left mouse button whilst moving over them, or 
hold down the <ctrl> key whilst selecting individual tasks.) 

Saving the batch process 
The batch process is part of the design, so is saved when the design is saved. 
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BSL (Bath Scientific Ltd) output files 
An output file can be produced which can be used to drive a Bath Scientific bare board connectivity tester. 

Creating the Bath Scientific output file 
With a design folder open in the navigator pane, right-click on the design name, then select Export > Bath 
Scientific Test Data. A window similar to the one in Figure 254 appears: 

 

Figure 254 

Output Filename:  type in a name for the output file that will be created. The browse button can be used to 
locate folders and/or files. 

Select Export to produce the output file. Information appears on the screen to indicate what is happening. This 
information will be stored in the report log, which will be found in the design’s Logfiles folder and named “export_bsl”. 
A typical report is shown in Figure 255.  

 

Figure 255 

If problems are encountered they are reported in detail. Each one should be investigated and appropriate action 
taken. 
Close the report window when you are ready to continue.  
The export process is complete and the exported BSL file will be found in the location specified. 

Output file format 
The BSL file takes the following format: 

Part Pin X Y Surface Signal 
Part Pin X Y Surface Signal 
Part Pin X Y Surface Signal 

Where: 
Part is replaced by component reference i.e. IC1, R1, etc. 
Pin is replaced by a pin number\name 
X & Y is replaced by the X & Y position of the pin, with respect to absolute 0, 0 in the artwork editor. 
Surface is replaced with the layer the pin appears on: 
  U = upper 
  L = lower 
  B = both 
  N = untestable 
Signal is replaced by the name assigned to the track that is attached to the pin, i.e. VCC, GND, 

CLOCK, etc. If a name has not been assigned, then a unique name is assigned automatically. 
i.e. RNET0015, RNET0016, etc. Unconnected pins are given the name _NC_1, _NC_2,  
_NC_3, etc. 

Lines preceded by ! are comments. 
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GenCAD output 
An output file can be produced in a GenCAD ASCII format. The file contains information that describes 
everything in the artwork: board profile, pads, tracks, outlines, parts, connections and tracks. 
This information can be used by Generic CAD Software (or any other software that can understand it) to drive 
various board manufacturing processes, such as automatic or manual component insertion machines, automatic 
test equipment (ate), etc. 

Creating the GenCAD text file 
With a design folder open in the navigator pane, right-click on the design name, then select Export > GenCAD-
format ASCII File Generation. A window similar to the one in Figure 256 appears. 

 

Figure 256 

Output Filename:  type in a name for the output file that will be created. The browse button can be used to 
locate folders and/or files. 

Select Export to produce the output file. Information appears on the screen to indicate what is happening. This 
information will be stored in the report log, which will be found in the design’s Logfiles folder and named 
“export_gencad”. A typical report is shown in Figure 257.  

 

Figure 257 

If problems are encountered they are reported in detail. Each one should be investigated and appropriate action 
taken. 
Close the report window when you are ready to continue.  
The export process is complete and the exported BSL file will be found in the location specified. 

Output file format 
The specification of the GenCAD version 1.4 format is available as a .pdf file upon request to: 
support@seetrax.com 
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