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 XL Designer   
Overview for Ranger XL Users 

Introduction 
This guide is for the XL Designer product. It is aimed at users who have a prior knowledge of the operation of Ranger XL, 
as it concentrates on the differences between the interface & operation of the two the products. It should make your 
introduction to the new software easier! 
A readme.txt file is supplied with each new update and will contain the latest information pertinent to the release. 
Information contained within that file will supercede information in this document, but the file will not contain all the 
information supplied here. Please refer to both sources of information. 
Ranger XL & XL Designer can be installed and run on the same machine without conflict.   
XL Designer has been designed as totally separate software to the existing Ranger XL software. This means that existing 
Ranger installations will not be overwritten and so does allow users to run both sets of software on the same machine 
whilst they become familiar with the new software.  
Note: due to the new features that have been added to XL Designer, designs saved in it are not backwards compatible 
with any earlier systems. 
Existing designs from Ranger1, Ranger2, Ranger3, Ranger2 XL and Ranger XL can be opened.  
Older designs with schematics drawn with the original schematic editor have their schematics converted to the new-style 
schematic editor automatically. 
Updates will become available on a regular basis and they can be obtained from: 

 http://www.xldesigner.com 

Installation 
The install program will install the XL Designer software into its own product directory, which is:  

C:\Program Files(x86)\Seetrax\XL Designer 
Do not attempt to install this new software over the top of an existing Ranger installation by altering the installation paths to 
those of your current Ranger installation. 

Minimum Hardware Requirements for XL Designer Software 
 PC capable of running Windows7 or later  

OS Windows7 or later 
100 MByte hard disk space 
Screen resolution 1280 x 1024 
Microsoft Mouse (or compatible) 

These requirements are given as a minimum guide, however it is likely that a faster processor, more RAM or higher screen 
resolution may be required if it is intended to work with large designs, multiple designs, libraries, etc. open at the same time.  

Installing the XL Designer software 
A license code is required to operate XL Designer – the Ranger XL license file is not valid for the new software.  
Ensure Windows is running and all other applications are closed. 
Provided XL Designer is loaded into the default folders it will not conflict with any existing Ranger (1, 2, 2XL, 3 or XL) 
installations that were also installed into the default locations. 
After downloading the software from: http://www.xldesigner.com/downloads, locate the downloaded file and then run it.  
There may be short delays (10-20 secs) whilst the s/w is installed.  The s/w installation is complete when a window indicates 
the process is complete and you are requested to select the “Finish” button. Install the license as prompted. 

Loading the license 
The license key code may have been sent via email or placed on the Seetrax CD, so locate the licensing information. The 
license will look similar to that shown below: 

DBYAA-KXRTC-LRMMB-8EFS2-C35SH-K72J 
 
Select and then copy (Ctrl  C) the license key code. In this example, the following text should be placed in the paste buffer: 

DBYAA-KXRTC-LRMMB-8EFS2-C35SH-K72J 
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Now run up XL Designer - select Start > All Programs, locate and select Seetrax from the list, then select XL Designer. The 
program will run.  
The license configuration window will appear, similar to the one shown in Figure 1 (if it doesn’t, select Help from the 
command bar, followed by License Configuration). 

 

Figure 1 

Copy and then Paste the License Key, into the “New License Key” area of the window.  

Select “Store License”. If the License Key is invalid an error message will appear, otherwise the license details will be shown 
in the window. 

Once the License Key Code has been Stored, an “Activate License” button will appear at the bottom of the window. 

Select the “Activate License” button from the window. 

A new window appears. This should indicate that the “License Server Status” is “OK”. If it isn’t, then check there is an 
Internet connection established on your pc. 

Enter the email address and password you used to register on the XL Designer web-site. (Links in the window allow you to 
register or obtain a new password if required.)  

Then select “Activate Now”. A message will indicate the license has been Activated. Select OK/Close to continue. The 
software can now be used without an Internet connection until it is required to deactivate the license, for example if you 
wanted to use the license on another machine. 

If error messages appear take action as appropriate. Close the window to continue. 

Changes to the directory structure (master libraries) 
In order to operate successfully on Windows7 or later, it is no longer possible to locate the master libraries or user files in the 
Program Files folder. 
By default in Ranger XL, the master libraries were held in:  C:\Program Files\Seetrax\rangerxl\Masters 
This meant that the program had to be run with Administrator priviledges. 
When XL Designer is installed a set of configuration files and master libraries are placed in the folder: 

C:\Program Files\Seetrax\XL Designer\UserTemplate 
However, these configuration files and libraries never get written to.  
At startup of XL Designer, a personal configuration and libraries structure will be created in the user's MyDocuments folder, 
and this will be seeded with files from the UserTemplate structure. 
The new personal files structure is layed out as follows: 
       MyDocuments/Seetrax/XL Designer/Artmacros 
       MyDocuments/Seetrax/XL Designer/Data 
       MyDocuments/Seetrax/XL Designer/Libraries/PCB 
       MyDocuments/Seetrax/XL Designer/Libraries/Schematic 
The File > System Setup window in XL Designer may be used to choose different locations. 
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The seeding of any directory from the above structure will only occur if the directory is found to be missing, or is empty.   
When computers are shared between multiple users, it also allows individuals to edit/pollute their personal configurations 
and libraries without affecting other users of the system.   
As in previous releases, it is possible to configure the system to use shared master libraries/configuration data. Just access 
the File > System Setup window and ensure that the Configuration Data directory, PCB Masters and Schematic Masters 
directory paths point to the intended shared content.  
As long as these directories are not empty, files from the UserTemplate area will never be copied over the top of your shared 
libraries and configuration.   
Please note that when running on Windows 7onwards, you will still need to take administrative action to ensure that all     
users have appropriate access permissions to the shared content. 

Running XL Designer 
Select Start > All Programs, locate and select Seetrax from the list, then select XL Designer. The program will run and a 
window similar to the one shown in Figure 2 will appear. 
 

 

Figure 2 

The title bar displays the version in use. Down the left hand side of the window are the Navigator and Browser panes. The 
Properties pane can be viewed by selecting the Properties Tab located at the bottom of the Browser pane. The remainder of 
the window is the area where your work will be displayed.  

Opening an existing Ranger design 

Select   or File > Open Design, use the navigator in the Open window to locate the folder where your designs are 
held. To use a supplied example, navigate to: ..\Seetrax\XL Designer\SampleDesigns\PCB 
The list of .rxl files will appear, select the design required, it will open and appear in the Navigator pane as shown in Figure 
3. 

 

Figure 3 

When opening Ranger1, Ranger2 or Ranger3 designs, change the Files of type setting in the Open Design window to the 
appropriate file type so they appear in the list. 
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Basic navigation within the design 
Select the + sign alongside the design name in the Navigator pane to open/expand the design’s folder when the individual 
items within the design will appear, as in Figure 4. 
 

 

Figure 4 

Each of the + signs can be selected to open/expand the folders.  
If, for example, the Component Outlines folder were expanded, this would list the outlines in the design library (Figure 5).  
 

 

Figure 5 

Selecting an individual outline from the list will display it in the Browser pane Figure 6. 
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Figure 6 

  

 

Figure 7 

 
Its Properties can be shown by selecting the Properties tab, Figure 7.  
Double-selecting an outline will open it for editing in the main window. (Figure 8.)  

 

Figure 8 

 
The editing window can be resized or maximised as required. 
The scroll wheel on the mouse can be used to zoom in/out.  
More than one outline can be selected and opened (Figure 9). 
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Figure 9 

Each open window has a title bar (Figure 9, “A”), which identifies the item. It also indicates whether the window is “active” 
or not. The “active” window is the one in which modifications will take place. The title bar in the “active” window is a 
deeper/brighter colour than the non-active ones.  
Because it is possible to open multiple designs, outlines, etc. it is important to be aware of which design/item you 
are working on, so get used to identifying the windows by their title bar. 
A tab for each open window (Figure 9, “B”) appears across the top of the main window, allowing windows to be located 
and popped forward easily. The left/right arrows at the right-hand end of this bar become enabled when there are too 
many tabs to be seen across the display. Use them to scroll through the tabs.  
A double-click on an entry in the design folder where a + sign isn’t shown (like the Board Profile or Artwork) will open the 
selected editor. 
The windows can be closed by selecting the close X from the top right of the window or selecting File > Close – the active 
window will close. Changes are stored in memory only at this point. 

Minimising/moving/resizing the Navigator/Browser panes 
Once several windows are open, it may be beneficial to hide the Navigator & Browser/Properties panes. 

Minimising:  

Select the  (pin head) from the top of either pane, the pane will be minimised and replaced by a tab on the side of the 
screen, similar to that shown in Figure 10, where both panes have been minimised. (The actual position will vary, 
depending on where the pane was docked.) 
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Figure 10 

Moving the cursor over either of these tabs will re-open the appropriate pane. The pane remains open whilst the cursor 
remains in the pane, if the pin-head remains horizontal. It will close as soon as the cursor is moved out-side the pane. 
This allows access to the panes whilst achieving maximum editing area. 

To re-open the panes permanently, select the  (horizontal pin head) from the top of the pane whilst it’s open.  

Resizing/Moving: 
Whilst permanently open, the panes can be resized or moved using the standard Windows methods. Whilst being 
moved around the edges of the window, the panes will “dock” like a toolbar along the sides or across the top/bottom of 
the window. They can be moved/resized as required.  

Restoring the Navigator/Browser pane positions: 
The panes can be restored to their original positions by selecting View > Restore Default Layout. If an editor is open 
then you are given the option of restoring just the editor’s layout or the overall layout. 

Editing Items 
Once an item (outline, artwork, schematic, etc.) has been opened and is the active window, the commands and icons 
across the top of the XL Designer window will change, depending on what is open - they are always context sensitive. The 
use of these commands in the main haven’t changed when compared with Ranger XL so will not be described here.  
A dialogue bar appears when appropriate - for example the Pads dialogue bar when an Outline is open/active (Figure 10) 
allows the pad size/shape, etc to be defined. 
It can also be minimised/reduced to a tab when the pinhead is selected. It re-opens once the cursor is moved over the tab. 
It remains open and the pinhead automatically returns to vertical (unlike the Navigator & Browser panes) and will not 
minimise until the pinhead is selected again.  
These dialogue bars can also be moved/resized as appropriate.  
It’s possible to have multiple dialogue bars (from the same editor) open at the same time, docked around the screen. For 
example, when the artwork editor is active, it’s possible to have the Parts, Mroute, Amend, Text, etc. dialogue bars docked 
around the screen. Use the View > Restore Default Layout > Editor Layout command to restore them. 

Saving a design 
When a design is opened it cannot be saved until a change has taken place.  
Once a change has taken place, an asterisk (*) will appear alongside the design name in the Navigator pane to 
indicate it has been changed and not saved. Once the * appears, the design can be saved as follows: 

In the Navigator pane, either select the design name so that it is highlighted, then select  from the toolbar (or File > 
Save <jobname>); or select the designname with a click of the right mouse button and select File > Save.  
The design is saved and the * will disappear. 
Note: this save operates on the complete design that has been selected from the navigator pane – not the active window, 
which may be from a different design. 
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Saving As 
To save a design with a new name, select the design name in the navigator with a click of the right-mouse button, then 
select File > Save As. Supply a new name as requested. Alternatively, select the designname with a click of the right 
mouse button and select File > Save As. 
The design is saved with the new name and this new design becomes the open design. (The design with the original 
name is closed without being saved.) 

Save all 

If more than one design is opened, the Save All icon  can be selected to save all the designs that are open and have 
been modified – the * will disappear from all the design names in the navigator pane to indicate the save has occurred. 

Copying/Pasting  
The Navigator pane uses the standard Windows methods for copying/pasting items.  
So, for example, to copy an outline from one design to another, locate the outline to be copied in the Navigator pane. 
Select it with a click of the right-hand mouse button, then choose Copy from the list that appears (Figure 11). 

 

 

Figure 11 
 

Figure 12 

The outline is copied to the Paste buffer.  
Now open and expand the Design where you’d like the outline copied to. Position the cursor over the Component Outlines 
folder, then right-click/Paste -  Figure 12. The outline will be pasted into the folder. If an outline with the same name 
already exists, the new entry will be renamed “copy of original name”. 
Items can be copied to the Master Library in the same way (right-click/copy the item, then position the cursor over the 
destination library folder and right-click/paste). 
It is not possible to copy items out of context, for example to copy a component outline to the schematic parts folder. This 
applies when copying/pasting any items. 
When a schematic part is copy between designs (either by copying/pasting directly using the navigator pane, or by using 
“Symbol > Place” and using another design's schematic as the symbol source) the outlines required for the copied 
schematic parts will now be imported into the target designs outline library. 

Dragging/Dropping using the Navigator pane 
Drag-drop functionality is now available for moving schematic library parts between the various folders in the master 
library and between designs; to copy outlines between designs and the master outline library; and to copy output tasks 
between designs. 
Parts that have dependencies on other library entries cannot be moved or copied by drag/drop. 
When dragging parts between the various master schematic library folders, the default action is “Move”.  Hold down the 
Ctrl key to change the action to “Copy”. 
When dragging parts from a design into another design or master library, the default action is “Copy”.  Hold down the Shift 
key to change the action to “Move”. 
Drag/drop 'Move' functionality is not available when removal of the part from the drag source would break design 
dependencies. 
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Parts/Nets List 
Parts List 

Expanding/opening the Parts folder from the open design in the Navigator pane, lists the parts in the pane. Select a part 
to reveal its properties in the Properties window, Figure 13. This information can’t be edited, but it is updated as changes 
are made. 
 

 

Figure 13 

 
Right-click on a part to access the cross-probing tools (Find in Schematic/Find in Artwork). 

 
To open the parts list editor, either double-select a part from the list in the navigator pane, double-select the Parts folder, 
or position the cursor over the Parts folder in the Navigator pane and right click, select Open Parts List . The parts list 
editor will appear similar to that shown in Figure 14. 

 

Figure 14 

Fields can be selected and edited as before (to edit the X/Y/Rot columns, select Edit > Allow Position Edit from the 
command bar.) 
A new column has been added and when switched on (View > Show MCAD Modelname), values entered in this column 
can be used as the 3D model/geometry library name when exporting designs to MCAD systems.  Note: this column is not 
updated from the schematic editor so will not change when extracting a new p/w list. 
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All the columns can be sorted in ascending or descending alpha-numeric order by selecting the column headers. 
Outlines can be dragged into the outline field from the design or master library folder to save typing.  
If the artwork editor is also open, changes to the parts are reflected in the artwork window.  
Net List 
The Net List folder is opened in the same way as the Parts list folder. 
Right-click on a net to access the cross-probing tools (Find in Schematic/Find in Artwork). 
Nets can be selected from the list in the navigator and the Properties window will provide information about the net – in 
Error! Reference source not found., VCC has been selected and its properties shown. 

 

Figure 15 

To open the net list editor, either double-select a net from the list in the navigator pane, double-select the Nets folder, or 
position the cursor over the Nets folder in the Navigator pane and right click/Open Net list. The net list editor will appear 
similar to that shown in Error! Reference source not found.. 
 

 

Figure 16 

The Name, UID, Min Clearance and Size columns can be sorted in ascending/descending alpha-numeric order by 
selecting the column headers. 
 

Missing/invalid entries 
When opening the parts or net list editors, there is no initial indication that outlines or net nodes may be invalid. You will 
need to scroll through each editor to look for highlighted entries, shown in Error! Reference source not found.. 



XL Designer Overview 

11 

 

Figure 17 

Saving to a File for use in Spreadsheets 
When saving parts and netlists to a file, the File > Save Parts/Nets window (Error! Reference source not found.) now 
allows the file to be saved with spaces or tab separated columns.  The tab separated output makes it easy to import into 
spreadsheets and other programs. 
 

 

Figure 18 

Sizes table 
When open (expand the Configuration folder in the navigator pane, then double-select Size Tables), the columns can be 
sorted in ascending/descending numeric order by selecting the column headers. Useful to determine which sizes have 
already been assigned and or used. 
The “Restore Default Sizes” command can be found by right-clicking on the Configuration folder in the navigator pane. 

Layer Assignments & Ordering 
• A new field has been added to allow Names to be assigned to layers to make identification easier in the artwork editor 

and output tools. (Expand the Configuration folder in the navigator pane, then double-select Layer Assignments & 
Ordering).  

• Power plane layers now have to be defined from this window rather than within the artwork editor, power plane tool. 
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Power names table 
When open (expand the Configuration folder in the navigator pane, then double-select Power Names), the columns can be 
sorted in ascending/descending alpha-numeric order by selecting the column headers.  

Multiple Windows 
Having the schematic editor, parts/wiring lists and artwork editing windows open at the same time allow you to see the 
effects of changes such as part renumbering, part move (in artwork or parts list), etc. in all editors. 

Schematic Editor 
Access to the schematic & schematic parts editors are via the Schematic folder. When opened/ expanded, sub-folders 
appear containing sheets, parts, ports, etc. which can be expanded/opened. Double-select any of the items to open the 
appropriate editor.  
Note: if you find the display is no longer as clear as you would expect, refer to the heading “Display in General” later in this 
guide, paying particular attention to the Line rendering width and Schematic ruled grid settings. 
In addition, the default colour settings may no longer suit your graphics display so it may be necessary to choose different 
colours for symbols, wires, etc. (Edit > Preferences). 
Schematics previously created with the old flat-style schematic editor are automatically converted to the new-style 
schematic editor – a report is given upon first entry to the schematic editor and saved to the Logfiles folder. 
New sheets/parts can be created by expanding the Schematic Folder, right-clicking on the appropriate folder (Design 
Sheets for schematic sheets, Parts for schematic parts, etc.) selecting New, supplying a name then opening the editor.  
Parts are placed on a schematic sheet using the Symbol > Place command as before, but they are selected with a click 
of the mouse from the schematic sub-folders of the current design, another open design, or the Masters, Schematic 
Libraries sub-folders – all found in the Navigator pane. 
* Connection crosses now disappear from symbol pins when the pins are connected, allowing confirmation that the 

connection is “made”. 
* Two new commands allow parts to be selected from the schematic sheet for addition to the artwork part 

placement tray (after the parts list has been extracted). They are: 
i)  Symbol > Add to Artwork Tray - clicking on schematic symbols that are related to parts list entries will cause those 

parts to be added to the artwork placement tray. In this mode, all symbols related to parts already placed on the 
board, or already in the placement tray will be shown with a dotted outline.  Symbols for parts that can be added to 
the tray will be shown with a solid outline. 

ii)  Region > Add to Artwork Tray - all parts associated with symbols in the selected region will be added to the artwork 
placement tray. (Symbols for parts that can be added to the tray will be shown with a solid outline.) 

* Symbols may now be displayed with a solid infill colour.  To show a symbol filled, open the schematic part, select 
Attributes > Symbol and tick the “Show Symbol Filled” box.  Choose the colour for the infill using the “Infill Colour” box.  
If an outline does not appear filled when this mode is activated, edit the symbol outline shape to ensure that it forms a 
closed path. Please note that colour infill will not currently be shown in a schematic output task.   

* By default, the ruled grid is now displayed with much finer lines. If the ruled schematic grid is too faint, or not visible, 
adjust the width of the grid lines from within the Edit > Display Adjustments  window. 
The "Schematic ruled grid line width control" value can be set in the range 10-100 where larger numbers result in thicker 
grid lines.  The default setting is '30'.  Changes to this setting only become visible in a view after the view is closed and 
reopened. 
Changing the colour assigned to the grid lines may also help (Edit > Preferences, Colours tab) if the grid is feint 

The Tools command will provide access to the Electrical Rules checking command, EMC Attributes and User-defined 
parts/nets extraction commands. These are all described in the Reference Manual.  
Multiple versions for schematics are described in the Getting Started Guide under the heading “Versions” of the chapter 
titled Schematic Capture & Part Creation. 

Importing/Exporting Schematic Attributes 
The attribute Import/Export commands are accessed from the Navigator pane, by right clicking on the Schematic folder for 
a design, or the folder of a master schematic library for example the folder, 741xx, 741xx (IEC), 741xxx, etc. 
Select Attributes > Export (or Import) from the options. 
Exported attributes can now be saved into tab separated (.txt) or comma separated (.csv) files as selected in the save 
dialog and they are easier to read and edit. 
The first row in the created file will always contain the column names for the data in the following rows. The first column is 
always the name of a block/part/symbol in the schematic or library.  Each additional column represents an attribute setting. 
To export a file suitable for editing in Microsoft Excel Spreadsheet, it’s recommended that the tab separated (.txt) file type 
be chosen.  On loading, Excel will display an Import Wizard where you may change the type of all imported columns to 
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“text” type. If you do not do this, and try to load from a .csv format, Excel always treats strings of digits as numbers, which 
is a problem if some of your symbols/attributes have all numeric names with leading zeros. 

Outline Editor 
To create a new outline, right-click on the “Component Outlines” folder, select “New”. An Untitled outline will be 
created in the folder, which can be renamed immediately (or later by right-clicking it, then selecting “Rename”). To edit an 
outline, double-click it or right-click/Open from the component outlines folder. 
This editor works in the same way as before. 
Note: if an outline used on the artwork is altered, and the artwork is open, the artwork will not be updated until the 
outline is closed. 

• The following new commands have been added/altered: 
Copper > Key Move Pad and Copper > Change Pad Style/Size  (new) 

They operate in the same way as the corresponding Pads commands, except they work on pads added 
using the Copper commands.  

View > Show Outline Filled (new) 
This permits outline display to be toggled between normal and “pads unfilled/tracks not at width”. 

     Copper > Add Keepout Circle (new) 
Copper > Adjust Arc/Circle (new)  
Copper->Describe Pad (new) 

To identify free copper pads on the currently selected free copper layer. 
       Outline > Change Width (altered) 

Now operates on outline text as well as lines. 
A new special function key has been added for Grid > Select Origin. It is blank by default so needs to be defined (File 

> System Setup, Special Function Keys “Setup” button, scroll to the end of the list.) 
• In addition to selecting standard pad angles of 0/90/180/270 degrees, it is now possible to type other angle values into 

the pad angle selector box.  
Note: it is not currently possible to enter standard pad shapes into the free copper section of an outline at angles other 
than 0/90/180/270 degrees.  Custom pads may be entered into free copper at any angle. 

• Added statistics line to the top of the window.  This displays the number of unique pin assignments on the outline 
together with the number of pads and number of unassigned pads on each pinstack layer. 

• The Region (formerly Window) commands have been simplified down to three basic menu actions : Move/Rotate, Copy 
& Delete.  For all these commands, the first two left-mouse button clicks will define the area to be operated on. 
For move/copy, a third mouse click will execute the action at the chosen position. Whilst moving the target frame, it can 
be rotated using the “Rotate” function key. For region delete, a third mouse click confirms the delete action or right click 
cancels the action. 
The region commands will display a warning message in the status bar if no features are enabled in the region section 
of the tool configuration pane. 

• If pin numbers, when visible, are too small, their size is controlled from the Edit > Display Adjustments window 
described later). 

Families 
Families re managed by right-clicking on the Component Outlines folder and selecting Manage Families. Create any 
families required using the Add button, then select an outline to be added/removed to/from a family, then choose a family 
(or none) from the Reset Family list. 

Free copper layers 
Free copper layers are managed from the Copper command (Copper > Free copper setup). 

Keepout areas in outlines 
It is now possible to define keepout areas within a component outline, using the Copper > Add Keepout Line command. A 
closed shape on the Top, Bottom or All layers should be drawn to define the required keepout area. 

Starpoint definition 
A new Star Points checkbox has been added to the outline’s properties window (View > Properties).  When activated the 
outline takes on a special mode of behaviour used for star-connecting multiple nets at a single point.   

Starpoints 
It is now possible to join differently named nets together at one location in a design – a starpoint. A sample design called 
Starpoints Example.rxl is included with the software and can be found in the ..\XLDesigner\SampleDesigns\PCB folder. A 
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component outline defines the tracking where the nets meet. It’s recommended that the example be studied before/whilst 
creating a starpoint.  
Creating a starpoint 
Create a new outline, then select View > Properties and tick the Outline is a Routing Star Point checkbox. Pads should be 
added to the star point outline - one pad for each net that will be connected at the star. The pads may be placed on the 
Top, Bottom or All layers and any pad style may be used. The pads should be numbered. 
The pads should be interconnected by inserting free copper on the Top, Bottom or All layers (Copper > Add Line). 
Keepout areas should be added to the outline using the Copper > Add Keepout Line command. The keepout areas limit 
the scope of autorouters and the copper fill routines and stop them from placing copper through the centre of the star point 
outline. The areas must not enclose the pads in the outline. 
Notes: the autorouter, copper fill routines and the artwork checker never see the free copper features that interconnect the 
various star outline pads.  To prevent the autorouter and copper fill routines from placing copper in the area of the star 
outline occupied by the interconnecting free copper traces, the keepout area must be defined within the star outline.  By 
using a keepout to prevent nets from violating the star interconnections, there is no need for the artwork checker to 
process the star interconnections and shorts will not be detected between those copper lines in the outline. 
Because the artwork checker does not verify the copper connections between the star outline pins, you must manually 
verify that your outline does actually perform the desired interconnectivity between its various pads. 
A schematic part that references the star point outline should be created, and one terminal placed for each pin on the star 
point outline. The terminal/pins should be numbered as for any normal part. 
On the schematic, each net that must meet at the starpoint must be added separately, and if named, each must have a 
unique name. Each net must then be connected to one of the pins on the starpoint part symbol. 
Within the artwork, the star point part should be placed at the desired location, and the board may be routed, copper filled 
and checked as normal. 

Profile Editor 
This editor works in the same way as before with the following changes: 
Keepout areas defined by an enclosed polygon shape are displayed with a crosshatch. 
Profile > Transfer to Current Layer command added - this will transfer selected items to the layer selected in the 'Mode' 
selector. 
A red “no go” area has been defined to prevent the use of the negative area in the editor. 

Artwork Editor 
Note: if you find the display is no longer as clear as you would expect, or labels/pin nos., etc., are too big/too small, then 
refer to the heading “Display in General” later in this guide. 
*  Dual-screen mode: the artwork editor can be opened in detached mode, which allows the editor to be dragged outside 

of the XL Designer main window on to another screen, so that for example the schematic and artwork editors can easily 
be viewed at the same time. 

* Layer names: artwork layers can now be named (i.e. Top Silk Screen Labels, Bottom Silk Screen Outlines, etc.) to aid 
identification both in the artwork editor and the output tools. The names are defined in the Configuration Folder, Layer 
Assignments and Ordering window. 

* Enclosed keepout areas are now displayed cross-hatched. 
* Colour palette – a new colour palette is available for layers. 
*  Flipped Mode: the artwork can now be viewed and edited whilst it is displayed flipped (mirrored).  It is flipped about 

the X axis. 
Notes whilst working in Flipped mode: 

Use the View > Artwork Flipped command to toggle the artwork between unflipped & flipped mode, or the tick box in 
the new View Control Dialogue bar (described below). 
Whilst working in “flipped” mode the x/y co-ordinate positions of the artwork are still given with respect to the datum 
position, which is also flipped. For example a part located at x=6.4, y=10.2 will still be in the same location at x=6.4, 
y=10.2. 
Whilst working in “flipped” mode, parts will retain the same outline colours (yellow & cyan), but the flipped parts will 
have a solid cyan line and unflipped parts will have a dotted yellow outline. 
Whilst working in “normal” mode, part related operations require clicking the left & right mouse buttons to select 
unflipped & flipped parts.  When the artwork is displayed in 'flipped' mode, the sense of the buttons becomes 
reversed, making it easier to position parts when working on the back of the board. 

* Part placement: when adding parts to the tray, two new commands have been added to the schematic editor to allow 
selection from the schematic sheet. They are Symbol > Add to Artwork Tray and Region > Add to Artwork Tray.  

* Power plane tool: has been redesigned to allow the use of one or more power signals on multiple plane/split plane 
layers. This has also allowed other features to be introduced at the same time. When opening designs from RangerXL 
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with split power planes, the planes need to be “imported” before they are modified in XL Designer for the first time. See 
Appendix A for more details on the new power plane tool and how to import the split planes.  

* The Grid > Origin command now also includes component datums in the locations where the origin may be snapped to. 
* A new special function key has been added for Grid > Select Origin. It is blank by default so needs to be defined (File > 

System Setup, Special Function Keys “Setup” button, scroll to the end of the list.) 
* The Parts > Align X/Y command will now snap the reference line to part datums.  If you do not click near a part, the 

reference line will be snapped onto grid. 
* A red “no go” area has been defined to prevent the use of the negative area in the editor – this can be switched off if 

required (View > Negative Space Shaded). 
* Dialogue boxes:  

All boxes which display the colour associated with a layer now have a 'tooltip' associated with them which will be 
displayed when you hover over the box. 
Layer colour boxes which have an associated edit/spin control to change layer selection, are now sensitive to clicking.  
Clicking the layer colour box will bring up a list of layers for quick selection. 
Layer names (where assigned) are displayed underneath the layer selection controls in the AddPad, AddTrack, Text 
and CopperFill toolbars.   

Manual routing dialogue bar 
The Mroute dialogue bar has changed slightly to allow user-defined vias to be used automatically if defined and 
required, and also to allow routing on as many copper layers as required (used to be max. 4).  Error! Reference source 
not found. shows the older Ranger XL layout and the new layout.  
If “Via Autoselect” is not selected only standard code 0 vias are inserted. If it is selected, then when vias are inserted, the 
most appropriate via from the user-defined via list is used. 
 

 

Figure 19 

All the copper & power plane layers are listed in the Layer Control area of the dialogue bar to aid identification of the layer 
stack. Any of the copper layers can be selected using the tick box alongside to allow tracks to be added to, or selected 
from that layer (the layer must be visible). The chevrons >>> indicate the “next layer”, which used to be shown underneath 
the layer controls in RXL.  
The Mroute bar is more manageable if all unused layers are defined as silk-screen layers (“Configuration folder, 
Layer Assignments & Ordering”), otherwise all the unused copper layers are listed which means a lot of scrolling to access 
the top & bottom layers.  
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View Control dialogue bar 

 

Figure 20 

The View > Set Colours and View > Setup Visibility 
commands have been replaced by a View Control dialogue 
bar, as shown inFigure 20. 
This bar brings together all the visibility controls that were 
previously available from those two commands which have 
been removed. 
All buttons on the View Control bar have 'tooltips' enabled, so 
hover over any button to get a description of the button's 
action.  The layer on/off buttons have layer usage and point 
count information in their tooltips. 
The following settings are new: 
Under the Unroutes section: 

i) The Net button allows manual selection of which unroutes 
to display.  When this button is checked, right click on a 
net from the expanded Nets folder in the navigator, and 
choose Show net unroutes. Multiple nets may be selected 
and switched on/off. 

ii) A slider controls the opacity of unroutes. At the left of the 
sliders travel, unroutes are displayed behind the copper 
layers, and at the right of its travel, they are displayed over 
the top of the copper layers. 
Be aware that if you choose to display unroutes behind the 
copper layers, SMD pad powerplane unroutes (which are 
shown as a small blob) may not be visible. 

Under the Misc section: 
i) The Clearance checkbox toggles the min clearance 

required around each net on/off. 
ii) The Flip checkbox flips the display about the vertical 

axis. 
Under the Layers section: 

There are now 64 layers available for use. To make it 
easier to display what you are interested in, specific 
categories can be shown or hidden from the toolbar. For 
example, in Error! Reference source not found. only the 
Used, Copper layers are listed because the other tick 
boxes are unchecked.  
Once the individual layers are listed, then they can be 
switched on/off as required. A scroll bar appears as 
required. 
Opacity Control:  
A layer opacity control slider will be found at the bottom of 
the dialogue bar. This replaces the automatic 
transparency of layers feature. Moving the slider adjusts 
the opacity of the copper layers so that it is possible to 
“see behind” dominant layer colours. 
If more control of the display is required, click the small 
check box to the side of the layers opacity slider. The 
window shown in Figure 21 appears. 
 



XL Designer Overview 

17 

 

Figure 21 

 

 
This provides opacity control of individual copper layers 
and Mask layers.  
You will need to experiment with your colour choices AND 
layer opacity to obtain a display that suits you. There is no 
longer a one-size fits all setting for all hardware 
combinations.  
Blue and green are very strong colours and tend to swamp 
the red palette. Changing the standard dark blue that was 
used for the Bottom layer, to a paler blue allows the reds 
to come through better when altering the opacity.

Part Labels, Pin Numbers, Grid Dot Size: 
Configuration settings have been added to a new Edit > Display Adjustments window to allow the size of text for part 
labels, pin numbers and the diameter and intensity of grid dots to be controlled.  The controls take a value in the range 20-
100 with larger numbers increasing the size of the corresponding feature. You will need to experiment with these values 
as there is no longer a “one size fits all” setting. 

 
If Artwork is selected from the navigator pane, the Properties pane will display the layer type and point count summary for all 
the artwork layers as shown in Figure 22. 

 

Figure 22 

Improved copper fill utility 
The copper fill routine has been re-coded to correct the introduction of short-circuits that occurred on some designs. 
In addition the fill settings (in the Fill dialogue bar, Figure 23) now have the following new options 

 

Figure 23 

 
Min Connections/Region :  to control the minimum number of part pins that must be connectable to a copper fill region for 
the region to appear in the fill result - setting this value to zero will result in the creation of isolated copper areas.  
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The Fill dialogue also now provides control over how the copper fill connects to via holes and part pins that are members 
of the fill net. Options are: 

No Connection no heat relief stubs are inserted on vias. 
Heat Relief heat relief stubs are inserted to connect the via/part pin to the fill region. 
Cover  the copper fill floods over the via. 
Cover All the copper fill floods over all part pins (smd & drilled pins). 
Cover SMD the copper fill floods over all SMD part pins (undrilled pins on layers T/B), but adds a heat-

relief on drilled pins. 
The fill also now takes into account individual minimum clearance requirements on nets.  

Updated powerplane tool utility  
See Appendix A. 

Display in General 
The move to Direct 2D graphics support has meant changes to the way items are displayed. There is no longer one setting 
that suits all hardware configurations, so if you find the display blurry, lines too thick/too thin, labels too small/big, grid 
dots/lines too small/big, etc., etc., then you will need to make some adjustments from the Display Adjustments window (Edit 
> Display Adjustments), Figure 24. 

 

Figure 24 

Display Anti-aliasing: the anti-aliasing feature of Direct2D means that the edges of displayed features are now much 
smoother – though they can appear “fuzzy” on some machines. 
Anti-aliased display is on by default, but it does cause some speed penalty when re-drawing.  If more performance is 
required when working with a very high-density design on a computer of limited performance, or the display appears 
“fuzzy”, anti-aliasing can be disabled.  
 Changes to the setting only take place after a view is closed and reopened.  A display rendering speed increase of 
40% is typical when anti-aliasing is disabled.  

Line Rendering Width: at different zoom levels, it may appear that lines have disappeared (particularly in the schematic 
editor) at low zoom levels, or they are too thick. Alter this value until an optimum size is achieved. 

Dotted Grid Dot Size/Intensity: Both these values affect the grid dots – if you find they are not clear/too big too small, then 
adjust both these values until an optimum value is achieved. 

Autogrid pitch change threshold: when using an auto-pitch grid, if there are too many or too few grid dots when zooming 
in/out, change this value. 

Ruled Grid Line Width: controls the thickness of the lined grid in the schematic editor. 
Part Labels/Pin Number Text Size: Previously, these items remained the same size at all zoom levels, this control is no 

longer available. Rather than have them get bigger/smaller depending on zoom level, a pre-set size can be defined.  
* The move to Direct2D meant we lost the “transparency” feature (when blue & red overlap, you see purple and so on). To 

overcome this, a new “opacity” control has been added to the View Control toolbar in the artwork editor, which allows the 
opacity of the topmost displayed layers to be adjusted to gain a clearer view of those lower down.  
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* Added a Colours folder to the navigator Configuration folder which allows a set of artwork layer and highlight colours to be 
applied to all newly created designs.   
The job has a corresponding Configuration > Colours folder to configure those colours within the design only.  Buttons 
allow the colour sets to be copied to/from the master set, or for the “factory” settings to be restored. 

Artwork checking 
The  Artwork checking is now performed from within the artwork editor (select Check > Connectivity) and now includes: 
* Checks to ensure copper layers do not include antipads or heat-reliefs – the check will terminate if any are found.  A 

report of the unwanted pad locations will be displayed. They can be deleted easily using the Artwork Delete Tool. 
* Checking for violation of keepout areas.  These are flagged on the artwork with a letter 'K' marker.  This extra check can 

be enabled/disabled in the artwork-checking window. 
* Check will not run unless the split powerplane layers (where defined) have been generated. 
* Checks for parts outside the profile. 

Artwork Delete Tool 
Will be found in the Navigator by right-clicking on the Artwork then selecting Delete Tool.  
A new category, Delete features that are invalid for layer type has been added. This will remove any features that are 
invalid for the layer type, i.e. heat-relief or anti-pads on a copper layer. 

Dual-Monitors 
If a dual-monitor system is in use, the artwork editor can be opened in “detached mode”, which will allow that window to 
be moved entirely outside the XL Designer main window and onto another screen. When opening the artwork editor, 
right-click on Artwork from the navigator pane, then select Open Detached. The artwork editor window can be moved as 
required.  

Cross-probing tools 
These tools allow you to easily and simultaneously find specific parts or nets from any of the main editors. 
The Identify/Find commands within the schematic/ artwork editors produce a balloon that allows the item to be located 
in the other editors as well - Figure 25. 

 

Figure 25 

If a multi-element part is located on the schematic, additional “arrow” icons in the window allow the next occurance of the 
part to be found on the schematic. 
The Properties pane provides information relating to the selected items. 
Cross-probing from the Parts/Nets list: 

With the Parts(or Nets) list folder open in the Navigator, right-click on any part, then select Find in 
Schematic/Artwork. The editor will open with the part indicated by a balloon. The balloon has icons to allow you to 
locate the part in the other editors.  

. 
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Specctra/Elecctra Interfaces 
These interfaces operate as before. They are enabled by selecting, File > System Setup and ticking the available 
autorouter.  Access the interface by opening the design and right-clicking on Artwork from the navigator pane (the 
artwork editor has to be closed if open), then Optional Auto-routers. 

New documentation tools 
New tools have been added so that it is now possible to create documentation files that are stored internally within 
each design file. 
To create a documentation file, right click on the Documentation folder within a design, and choose the appropriate file 
type from the New menu. 
Existing files can be added to the documentation folder of the design by right-clicking on the Documentation folder then 
selecting Import File. 

Adding a new file type to the documentation folder 
To add to the file types that are presented in the Documentation > New menu, close XL Designer if it is running. Use 
Windows Explorer to locate and open the folder:  

..\MyDocuments\Seetrax\XL Designer\UserTemplate\DocTemplates 
The index.txt file defines all the file extensions and descriptions that are to appear in the design’s Documentation > New 
menu.  When editing this file, separate the extension and description fields with a single tab character. 
For each file type defined in the index.txt file, if a corresponding file named templates.{extension} is created in the 
DocTemplates directory, then that file will be used as the initial file content for newly created documentation files.  If no 
template file is created for a file type, then the 'New' file action will create an empty (0 bytes long) file. 

Output tools 
Printing/Plotting/2D/3D Transfer/NC Drill  

From the navigator pane, open the Outputs folder. Right click on the Tasks directory, select the required option from 
the list. A new output item will appear in the tasks folder, which can be renamed immediately (or later by right-clicking it, 
then selecting Rename). It’s suggested the name reflects the type of o/p, i.e. artwork, solder paste, etc. and output format, 
i.e. gerber, printer, etc. For example, top copper – gerber, top silk – printer, drill drg – penplot, etc. 
Double-select it from the list to open the output tool (or right-click/Open).  
The Source and Output setup windows work in the same way as before.   
When an output task is configured to target a Windows printer, the printer selection and any selected printer options will 
now be retained with the task. The default printer can be restored by right-clicking on the Tasks folder (global) or individual 
task folders. 
Once a Task has been created, it can be copied/pasted within the design, or to other desigs, by selecting it with a right-
click/Copy.  To paste the copy, open the Outputs folder of the design where the copy will appear, then right-click the Tasks 
folder and select Paste. It can be renamed (right-click/Rename). 

Additional output formats (PNG, BMP, GIF or JPEG) 
A new category Image File has been added to the Output list (see Figure 26) 

 

Figure 26 

Images may be saved in PNG, BMP, GIF or JPEG format.  

Gencad/Bath Scientific Ltd 
Right-click on the design name in the navigator pane, select Export followed by the output type required. 

IDF 3.0 file exporter - New 
It is now possible to export an IDF version 3 file for use with MCAD modelling tools. To access the IDF file export, expand 
the Outputs folder in the navigator, then right click on the Tasks folder and create a New IDF Output task. 

Batch outputs 
Batch files saved in Ranger XL designs are not transferred, so they have to be re-created. 
Before a batch process can be created, all the Tasks that it should include have to be created and set as required. If no 
tasks exist, either copy/paste them from other designs, or create new ones. When copying tasks, ensure the task has 
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been set up as required – particularly the output type (gerber, printer, etc.) so that when it’s copied only the layers have to 
be re-assigned - to save time. 
Once all the tasks have been created, they can be used in the batch o/p tool as follows: 
From the navigator, open the Outputs folder, then right-click & New on the Batch folder. Supply a name, such as artwork - 
gerber then open it. A window appears similar to that in Figure 27. 

 

Figure 27 

The idea is to move the tasks that should be included in the batch output, from the left pane (the Available Output Tasks) 
to the right pane (Tasks in Output Batch) and supply a filename if appropriate for the o/p file.  
Select task(s) from the list of Available Output Tasks (more than one can be selected at a time), then use the right-pointing 
arrow in the window to transfer them to the Tasks in output Batch. (They can be transferred the other way in the same 
fashion.)  
Supply a name for each output file (with an extension as they are not assigned automatically) in the Output Filename 
field.  
When adding image output tasks to the batch output, you must add the appropriate file name extension (.png, bmp, gif or 
jpg) in order for the appropriate output encoder to be selected. 
From the bottom of the window, choose an Output directory (where the o/p files will be saved when the batch is run) - the 
... box can be used to browse the directory structure. 
To create the o/p files, select Run All Tasks.  
The Run Selected Task button will allow selected tasks to be run (use Ctrl or Shift and the mouse to select multiple tasks). 
Once a batch has been created, it can be right-clicked/Copied, then pasted to the same design or other designs.  
When copying tasks/batches between designs, be aware that schematic output task/batches may need to be edited as the 
design sheet names are likely to be different. 

Importers (Gerber, DXF, Parts/wiring list) 
Right-click on the design name in the navigator pane, select Import followed by the importer required. 

Closing a design 
From the Navigator pane, right-click the design name, then select File > Close. The design is closed - if the design has 
been altered a prompt will appear to allow the design to be saved if required. 

Master Libraries & Defaults 
When XL Designer is run, the Masters library folder appears automatically in the Navigator pane (always at the head of 
the list). Select the + sign alongside it to open it. Keep selecting the + signs to navigate through to the items required. The 
copy/paste & drag/drop functions can be used to copy parts from/to the master library, from/to other designs. 

Schematic library maintenance, including sub-folders 
New master schematic library folders can be created by right-clicking on the Schematic Libraries folder in the navigator 
pane, then selecting New Folder. Sub-folders at any level can also be created by right-clicking on the schematic library 
folders themselves.   
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Master schematic library folders can be renamed and deleted by right-clicking on the folder and choosing the appropriate 
action. 
Whilst a library is selected in the navigator pane, the Properties pane shows information relating to the selected library. 

Saving master libraries 
Once the master libraries have been altered, they can be saved - they cannot be saved until a change has taken place. 
Once a change has taken place, an asterisk (*) will appear alongside the Masters folder in the Navigator pane to indicate 
the libraries have changed and have not been saved. Once the * appears, the masters can be saved as follows: 
From the Navigator pane, right-click the Masters folder and select Save. The complete masters folder is saved and the * 
will disappear until they are modified again.  
Note: component outlines that are open are not saved – ensure all outlines are closed if they should be saved. 

Conclusion 
We hope this brief overview, which has been designed to highlight the main differences between Ranger XL and the new XL 
Designer, has been helpful. You should find everything else fairly logical, but if you think something is missing from this 
document, could be improved upon or have any suggestions please let me know so that it can be updated. Everything is 
subject to change! Thank-you! 
Seetrax Customer Support 
email: support@seetrax.com 
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Updated Powerplane Tool 
The power plane tool has been redesigned to allow the use of one or more power signals on multiple plane/split plane 
layers. This has allowed other features to be introduced at the same time. This short section will describe how to use the 
updated power plane generation tool. 
The first time a Ranger XL design with split power planes is opened, the split plane boundaries have to be imported. 
See heading below, Existing designs with split planes: on page A6. 

Assigning the power rails to the plane layers 
All assignment of power rails to power planes is now done from the Configuration folder (in the navigator pane) Layer 
Assignments and Ordering, Figure 28. 
 

 

Figure 28 

Once opened, double-select a layer to open the "Layer Assignment" window, which allows the layer type to be chosen - 
Figure 29. In this example, layer 5 is currently assigned as a Copper layer. 
 

 
Figure 29 

If the layer type is selected, a pull down list appears, allowing the layer type to be altered – Figure 30 
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Figure 30 

In addition to the standard layer types (copper, silk, etc.) all the power signal names (as defined in the power names table) 
appear, allowing that power net to be assigned to the layer as an individual power plane. 
Figure 31 shows layer 5 has been assigned as a GND power plane and layer 6 as a VCC plane. 
 

 

Figure 31 

If the "Split powerplane" option is chosen, then the rest of the “Edit Layer Assignment” window becomes active and a 
primary power rail should be chosen, followed by all the rails that will be embedded within that layer as secondary rails – 
Figure 32. 
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Figure 32 

In Figure 32, 0V is being assigned as the primary power rail for split power plane layer 7 and the power nets +12V, -12V and 
V+ as the secondary nets to be embedded in the primary plane.  
Figure 33 shows the layer assignments window with layers 5 to 7 defined as described above. 
 

 

Figure 33 

The same power rail can be used on multiple layers. 
Once the layers have been defined as required, close the windows. 

Power Unroutes 
In the artwork editor the power nets assigned to the plane layers will not appear as unroutes - unless there are smd 
component pins that are connected to the net. For these nodes an unroute “blob” will appear on the smd pin (provided the 
power unroutes are visible and at width).  
This “blob” should be pulled out using the Mroute > Corner command (right-button) and a track and via will appear to 
connect the smd pin to the inner layers. 
Figure 34 shows the before and after images of the unroute blobs and resultant tracks/vias.  
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Figure 34 

Creating the planes 
Assuming all other routing is complete.  
Select the power plane tool (Tools > Powerplane). A new dialogue bar appears and the display shows one plane layer 
(Layer 5, the GND plane in this example), similar to that shown in Figure 35. The heat-relief and anti-pads are shown in the 
plane. 

 

Figure 35 

All the layers configured as power planes/split planes will appear in the top section of the dialogue bar, under the heading 
"Powerplane Layer".  Clicking on each layer will change the display to show that selected layer. (The colour for the layer is 
as defined by the View > Set Colours window and can be altered as required.) 
In the mid-section of the dialogue, under the heading "Powerplane Nets", the power signal names used on the selected layer 
are shown.  
If the layer is a ‘split’ plane, the primary rail for that layer is always shown at the top of this list, followed by the secondary 
rails - see Figure 36 where layer 7 has been selected as the powerplane layer and the powerplane nets are 0V (at the top, 
therefore the primary rail) and +12V, -12V and V+. 
 

 

Figure 36 
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When a split plane layer is chosen, the display shows the primary plane with it’s heat-relief/antipads and flashing coloured 
dots on some pads - Figure 37 

 

Figure 37 

The coloured flashing dots represent the pins on the secondary power nets. 
Coloured boxes alongside the powerplane net names in the dialogue bar show the colour assigned to each power net for 
recognition purposes. (The colour can be changed from the Setup button, described later.) 
Each of the secondary power net pins (flashing dots) has to be isolated from the other powerpin nets by a line that should 
enclose each of the same-coloured pins. 

Drawing the split-plane boundaries 
From the dialogue bar and with the split-plane layer selected, select one of the secondary powername nets.  
The SplitBoundary commands become active and the polygon can be drawn to isolate the pins associated with that net. The 
line has to start/stop in the same place to form an enclosed polygon shape, at which time the area will change colour to 
reflect the power rail and the heat-relief pads for that rail will appear. 
Pins that are within the wrong polygon region will flash on and off.  
The flash colour indicates which net the pin belongs to. The "Net Error Count" area in the dialogue also indicates the number 
of pins on that net that are in error (ie outside of the polygon or in another polygon). There should be 0 errors for each power 
net. 
Select each of the secondary power names and define their polygons.  
Tip: It’s easier to add the enclosed polygon around one of the correct pins, then use the SplitBoundary > Corner command to 
stretch/modify the polygon around the rest of the pins. 
As polygons are edited, the display will dynamically update changing pin powerplane features from antipad to heatrelief state 
as appropriate. 

Polygon/Barrier line size 
The line width for the polygons can be altered before entering the line, or afterwards. The Boundary line size setting in the 
dialogue controls the size of the line as it is added. 
If a powerplane net is selected from the dialogue, then the size control can be changed for the existing polygon for that net. 

Generating the planes 
The planes are not created until the Generate button has been used. Each layer is generated individually, unless the 
Generate All checkbox is ticked – this is different to Ranger XL where all planes were generated simultaneously. 
Once the layer(s) is/are ready to be created, either ensure the layer is selected from the dialogue bar Powerplane Layer 
section, or the Generate All box is ticked, then select the Generate button (or Powerplane > Generate). Repeat for each 
layer if an individual layer was selected. 

Other items in the Dialogue bar 
The View - Top/Bottom buttons display the part outlines. If the "Net colour" check box is unticked, the layer is shown in one 
colour only. 

Powerplane Setup window 
The powerplane setup window Figure 38 contains information about each layer and power net used. 
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Figure 38 

Items in the "Setup" window that are not ‘greyed’ can be edited. 
No heat-relief if drill size less than:  a drill hole threshold below which a heat relief is not generated, can be specified. The 

default is zero, so heat reliefs are always created.  A separate threshold may be 
specified for each net section of a split powerplane. 

Polygon colour: the colour used to display the non-primary power nets can be selected - select the 
coloured box from the setup window, then the arrow from alongside that appears. A 
colour palette appears from which the colour can be selected. 
The primary power rail colour is controlled from the View > Set Colours window. 

Existing designs with split planes: 
Older designs with power planes/split planes remain unaffected by the new power plane tools, until it is required to 
regenerate the split planes.  
When the split planes need to be re-generated, for example following a modification, it is necessary to identify which split-
plane polygon is associated with each power rail before the planes can be updated and re-generated (the first time only).  
To do this:  
Open the artwork editor. 
Select the power plane tool, one power plane layer will be visible. If it’s a split powerplane layer, the embedded power rail 
pins will be flashing.  
From the Powerplane dialogue bar, under the Powerplane Nets heading, select one of the embedded power rail names. 
The first powername in this list is always the primary power rail (so don't select that one). The coloured boxes indicate the 
colour assigned to the power rails for identification purposes. 

Once the power rail name has been selected, this will enable the SplitBoundary > Import Boundary command, which 
should now be selected.  
The split plane polygons will now appear, and the one associated with the selected powername should be selected.  
If the correct polygon is chosen, the same-coloured dots will stop flashing and be replaced with heat-relief pads in that area.  
If the dots continue to flash, the incorrect polygon was chosen - use Undo, then repeat until the correct polygon is selected. 
Once all the polygons for that layer have been imported, use the Generate button (or Powerplane > Generate command) to 
create the plane. 
Repeat for the other split-plane layers. 
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Once completed, it is not necessary to import the polygons again. 
Note: all plane layers must be generated – this can be done individually or simultaneously if the All Powerplanes check-box 
is ticked. 
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