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Introduction 
Hello and welcome to the start of your journey into Excel! You’ve made an excellent 

choice in deciding to start this book, as Excel’s usefulness stretches from simple lists 

to keep track of tasks, to the most complex business applications, and its uses are 

limitless. In the chapters that follow, we will guide you step by step through the vast 

world of Excel, providing you with the knowledge and tools needed to become 

proficient in this powerful software. Whether you are a beginner looking to learn the 

basics or an experienced user seeking to expand your skillset, this guidebook is 

designed to cater to all levels of expertise. We will begin by introducing you to the 

Excel interface and its fundamental features, ensuring you are comfortable navigating 

the workspace and understanding the core components of a spreadsheet. As we 

progress, we will delve into essential functions and formulas, data management, and 

visualization techniques that will allow you to manipulate and analyze your data 

effectively. Throughout the guidebook, you will find practical examples, exercises, and 

tips to reinforce your learning and help you apply your newfound skills to real-world 

scenarios. It will not be easy, by the end of your journey, you will have gained one of 

the most valuable skills in the business world.  

 

The Very Basics 
You can think of an excel file as a book. In fact, they are called workbooks. Within each 

workbook that you make, you will have sheets or ‘worksheets’ which are like pages in 

that book. You can have over a million sheets in a workbook, so it’s not necessary to 

worry about making too many. So you have a workbook filled with worksheets. Now 

how do you write things? The logical choice would be to click somewhere on the page 

and start typing, and indeed this is the primary way to write in an excel workbook, but 

unlike something like Microsoft Word, it WILL matter where you click. This is because 

all the information you enter by this method will be contained in cells. You will notice 

when you open Excel and take a look at the first page, that it is covered in lines that 

give it a graphing paper type look. Each rectangle formed by these lines is called a cell. 

If you’ve played chess, you can think of these cells as like squares on a chessboard and 

think of the information you put into the cells as pieces. Or you can think of each cell 

as a box in which you can put things. Each of these cells has a unique name, and what 



would be the easiest way of naming them? If you have played chess, then you may see 

where I’m going with this. Each cell is in a certain position which can be described by 

the distance from the first cell in the sheet, which is the top left cell. Its name is given 

first by the number of columns to the right of the first one, written as a letter, (A, B, C 

etc.), then by the number of rows from the top, written as a number. The top left cell, 

which is the cell that is selected when you press ctrl + home on the keyboard, is cell 

“A1”. If you go down five rows and to the right by one column, you will be in cell “B6”. 

You can see how this will give each cell its own unique name. Now this may seem no 

more useful than something like Microsoft word, but it gets much more interesting and 

useful when you see how cells interact with each other, or more specifically, 

information in certain cells interacts with information in other cells. This can be done 

by referencing another cell and is done within a function which you put in the cell in 

which you want the output to be. So say I want cell “B6” to be the same as cell “A1”. I 

would write “=A1” in cell “B6” by clicking the cell and typing this or by selecting the 

cell, typing the “=”, then clicking the cell, “A1”, then pressing enter. One sometimes 

frustrating outcome of this feature is that you cannot click out of a cell when entering 

a formula. You can click enter to exit the cell instead. Once the formula has been 

entered, whatever is in cell B6 will also be in cell A1. You can perform operations in cell 

A1 as well. These include adding, subtracting, multiplying, dividing and many more. If I 

want cell A1 to be 2 less than cell B6, I can write “=B6-2” in cell A1. The same syntax is 

used for adding, multiplying and dividing. The same can be done for a range of cells. If 

I want cell “A1” to be less than cell B6, but by the value in B5, I can enter “=B6-B5”. You 

can do this with as many cells as you want. And you can combine multiple operations. 

When executing these operations, Excel follows PEMDAS, which means it starts with 

values in parentheses (P) then continues with exponents (E), multiplication (M), division 

(D), addition (A) and subtraction (S). With multiplication and division, neither is given 

priority over the other, so the first operation to be executed will be whichever is first in 

the set of operations. The same goes for addition and subtraction. If you want to 

specify to excel that you want to do any of these operations first, you can either put 

the operation in its own set of parentheses, or you can put the operation in a different 

cell and reference that cell in the cell that will contain subsequent operations. These 

are not the only ways to tell excel to perform operations though. You can also use 

what are called functions. To use a function, you write “=”, then write the name of the 

function you want to use. Then, you type a set of parentheses and within these 

parentheses, write the arguments for your function. Each argument is separated by a 



comma. For example, I might want to add several numbers. I would write 

“=Sum(1,2,3)”. After I write this and press enter, the cell will display the number 6, the 

result of the function. It is important to understand that the content of the cell is not 

the number 6, but the formula. The 6 that is shown does not replace the formula but is 

displayed over the cell instead. To edit a formula, click the cell and then the formula 

bar above the sheet, or double-click the cell. When a cell with a formula is referenced, 

the formula's result is used. This allows you to link formula cells continuously. For 

example, to create a list of numbers from 7 to 77 in increments of 5, enter 7 in cell A1, 

"=Sum(A1,5)" in cell A2, and "=Sum(A2,5)" in cell A3. Continue this pattern until you 

reach 77. Alternatively, use autofill by selecting cells A1 and A2, then dragging the 

bottom-right square of the selected cells downward. Excel will fill in the formulas for 

you. If you’ve done this, you may think that the result looks a bit drab. We can fix this 

with formatting, which we will discuss in the next section. 

 

Formatting 
In this section, we will discuss the importance of formatting in Excel and how it can 

enhance the visual appeal and readability of your spreadsheets. Formatting is the 

process of customizing the appearance of your workbook, including the font, size, 

color, and alignment of your text, as well as the borders, shading, and number 

formatting of your cells. Properly formatted spreadsheets not only look more 

professional but also make it easier for you and others to understand and interpret the 

data you're working with. 

Most of the formatting options are in the home tab, as shown here. 

 

  



To start, let's talk about font formatting. Excel offers a wide variety of fonts to choose 

from, allowing you to customize the look of your text. To change the font, first select 

the cells containing the text you want to modify, then choose the desired font from the 

drop-down menu on the Home tab of the ribbon. You can also adjust the font size, 

style (bold, italic, or underline), and color using the options located in the same area. 

Cell alignment is another crucial aspect of formatting. By default, text in Excel is left-

aligned, while numbers are right-aligned. You can change the alignment of your data 

by selecting the cells and clicking the appropriate alignment buttons on the Home tab. 

There are options for left, center, and right alignment, as well as top, middle, and 

bottom vertical alignment. You can also indent your text or rotate it within the cell 

using the corresponding options. All of these options can be used to designate 

sections of your workbook, for example, separating the title from subheadings, 

subheadings from body sections, and so forth. I tend to like to indent everything at 

least once, so that you can see some separation between the edge of the cell and the 

text. 

Number formatting, although similar in name, is entirely separate from font 

formatting. Excel offers a range of number formats, including General, Number, 

Currency, Accounting, Date, Time, Percentage, Fraction, and Scientific. To apply a 

specific number format to your data, select the cells containing the numbers, and 

choose the desired format from the drop-down menu in the Number group on the 

Home tab. Proper number formatting helps convey the meaning of your data more 

effectively and, more importantly, ensures that calculations are performed correctly. 

Borders and shading can be used to visually separate and highlight different areas of 

your spreadsheet, making it easier to read and interpret. This is an important step in 

making your spreadsheets look professional. To apply borders to your cells, select the 

cells, and click the "Borders" button on the Home tab. A drop-down menu will appear, 

allowing you to choose the border style and where you want the borders to appear 

(top, bottom, left, right, or all around the cell). To apply shading, select the cells, click 

the "Fill Color" button, and choose a color from the palette. 

Conditional formatting is an advanced feature that enables you to automatically apply 

specific formatting to cells based on their content. For example, you can highlight cells 

with values above a certain threshold, or color-code cells based on their text content. 

To apply conditional formatting, select the cells you want to format, and click the 



"Conditional Formatting" button on the Home tab. From there, you can choose from a 

variety of built-in rules or create your own custom rules to suit your needs. These rules 

will be elaborated on in another section. 

In summary, proper formatting is essential for creating clear, visually appealing, and 

easy-to-understand spreadsheets. Excel offers a wide array of formatting options, 

allowing you to customize the appearance of your workbooks to suit your preferences 

and requirements. By taking the time to format your spreadsheets, you'll enhance their 

readability and professionalism, making it easier for you and others to analyze and 

interpret your data. 

 

 

Functions Explored 
In this section, we will take a closer look at some of the more important functions. As 

we’ve alluded to earlier, functions are pre-defined formulas that perform specific 

calculations using the input data (or arguments) from the user. They can greatly 

simplify your work and help you perform complex tasks more efficiently. As we look at 

the more common functions, we will offer detailed explanations and examples of their 

usage.  

 

Note: In this section, we introduce all of the most commonly used functions. It’s a 

tough ask to understand all of this through one reading. I would advise you to read it 

casually and move on, and trust that in later examples you will gain a better 

understanding of many of these functions. Keep in mind you can always come back 

and review.  

 

Introduction to excel functions 

 

Excel functions are built-in formulas that automate specific calculations and data 

manipulations. There are over 450 functions available in Excel, grouped into categories 



such as financial, logical, text, date & time, lookup & reference, math & trigonometry, 

and statistical functions. 

Function syntax and arguments 

Excel functions follow a specific syntax: 

=FUNCTION_NAME(argument1, argument2, ...) 

FUNCTION_NAME: The name of the function, such as SUM or AVERAGE. 

Arguments: The values, cell references, or ranges required for the function to work. 

Some functions have optional arguments, while others have required arguments. 

Nesting functions 

One of the more advanced concepts in excel is that of nesting functions within other 

functions to create more complex calculations. For example, you can use the IF 

function to conditionally calculate the sum of a range:  

=IF(SUM(A1:A10)>100, "Greater than 100", "Equal to or less than 100") 

 

Absolute and Relative Cell References 

When using functions, it's essential to understand the difference between absolute and 

relative cell references: 

Absolute references (e.g., $A$1) remain fixed when a formula is copied or moved to 

another cell. 

Relative references (e.g., A1) adjust their row and column numbers when copied or 

moved to another cell. 

 

Error Messages and Troubleshooting 

Excel displays error messages when it encounters issues with a function or formula: 

#DIV/0!: Division by zero error. 

#N/A: The value is not available or not found. 

#NAME?: A function name is misspelled or does not exist. 



#NULL!: A space was used as an intersection operator. 

#NUM!: A numerical calculation error occurred. 

#REF!: An invalid cell reference. 

#VALUE!: An incorrect data type is used in a function or formula. 

Understanding these error messages can help you identify and correct issues in your 

functions and formulas. 

Functions can also be referred to as formulas, and there are helpful resources in the 

formulas tab here. 

 

You may want additional help with functions. If so, you can click this button, which will 

reveal this dialogue box, which prompts you to enter arguments and more clearly 

organizes them. 

 

 



 

 

 

Commonly used functions 

 

 

SUM Function 

As we’ve seen earlier, the SUM function is used to calculate the total of a range of 

numbers. The syntax for this function is: 

 

=SUM([number1], [number2], ...) 

 

You can enter individual numbers, cell references, or a range of cells as arguments. For 

example, to calculate the sum of numbers in cells A1 to A5, you would use the 

formula: 

 



=SUM(A1:A5) 

 

AVERAGE Function 

The AVERAGE function calculates the arithmetic mean of a range of numbers. The 

syntax for this function is: 

=AVERAGE(number1, [number2], ...) 

 

Similar to the SUM function, you can enter individual numbers, cell references, or a 

range of cells as arguments. For example, to calculate the average of numbers in cells 

A1 to A5, you would use the formula: 

 

=AVERAGE(A1:A5) 

 

COUNT Function 

The COUNT function returns the count of cells containing numbers in a specified 

range. The syntax for this function is: 

=COUNT([value1], [value2], ...) 

 

To count the number of cells containing numbers in the range A1 to A5, you would use 

the formula: 

 

=COUNT(A1:A5) 

 

There are also several different versions of this function. For example, the COUNTA 

function returns the count of cells that are not empty in a specified range. This 

includes cells containing numbers, text, logical values, errors, and empty strings. The 

syntax for this function is: 



 

=COUNTA([value1], [value2], ...) 

 

To count the number of non-empty cells in the range A1 to A5, you would use the 

formula: 

 

=COUNTA(A1:A5) 

 

COUNTIF Function 

The COUNTIF function returns the count of cells within a specified range that meet a 

single given condition. The syntax for this function is: 

 

=COUNTIF(range, criteria) 

 

To count the number of cells in the range A1 to A5 that contain a value greater than 

10, you would use the formula: 

 

=COUNTIF(A1:A5, ">10") 

 

COUNTIFS Function 

The COUNTIFS function returns the count of cells within a specified range that meet 

multiple given conditions. The syntax for this function is: 

 

=COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2], ...) 

 



To count the number of cells in the range A1 to A5 that contain a value greater than 10 

and in the range B1 to B5 that contain a value less than 5, you would use the formula: 

 

=COUNTIFS(A1:A5, ">10", B1:B5, "<5") 

 

When applying this function, Excel will look at each row and count as one each row in 

which all criteria are met. 

 

 

 

MAX and MIN Functions 

The MAX function returns the largest value in a set of numbers, while the MIN function, 

quite unsurprisingly I must admit, returns the smallest value. The syntax for these 

functions is: 

=MAX(number1, [number2], ...) 

=MIN(number1, [number2], ...) 

 

For example, to find the maximum and minimum values in cells A1 to A5, you would 

use the following formulas: 

 

=MAX(A1:A5) 

=MIN(A1:A5) 

 

VLOOKUP Function 

The VLOOKUP function searches for a value in the leftmost column of a table and 

returns a corresponding value from a specified column. The syntax for this function is: 



=VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup]) 

 

For example, to look up the value in cell A1 within a table located in cells B1 to E10 

and return the corresponding value from column 3 of the table, you would use the 

formula: 

 

=VLOOKUP(A1, B1:E10, 3, FALSE) 

 

This function will return the first instance that it finds. This is an incredible tool and 

will be elaborated on further in a later section. 

 

CONCATENATE Function 

The CONCATENATE function combines multiple text strings into one. The syntax for 

this function is: 

=CONCATENATE(text1, [text2], ...) 

 

For example, to join the text in cells A1 and B1 with a space between them, you would 

use the formula: 

 

=CONCATENATE(A1, " ", B1) 

 

You can concatenate as many cells as you want and you can use the same cell multiple 

times.  

 

LEFT, RIGHT, and MID Functions 



The LEFT, RIGHT, and MID functions extract a specified number of characters from a 

text string, starting from the left, right, or a specific position, respectively. The syntax 

for these functions is: 

=LEFT(text, [num_chars]) 

=RIGHT(text, [num_chars]) 

=MID(text, start_num, num_chars) 

 

For example, to display the first three characters from cell A1, the last three characters 

from cell B1, and three characters starting from the second character in cell C1, you 

would use the following formulas: 

 

=LEFT(A1, 3) 

=RIGHT(B1, 3) 

=MID(C1, 2, 3) 

 

Note: If you’ve read this far, you’ve done quite a bit. It might be time to grab a coffee 

or take a walk. 

 

Let’s continue. 

 

COUNTIF Function 

The COUNTIF function counts the number of cells within a range that meet a specified 

condition. The syntax for this function is: 

=COUNTIF(range, criteria) 

 

For example, to count the number of cells in the range A1 to A10 that contain the 

value 10, you would use the formula: 



 

=COUNTIF(A1:A10, 10) 

 

SUMIF Function 

The SUMIF function sums the values in a range that meet a specified condition. The 

syntax for this function is: 

=SUMIF(range, criteria, [sum_range]) 

 

For example, to sum the values in the range A1 to A10 that are greater than 10, you 

would use the formula: 

 

=SUMIF(A1:A10, ">10") 

 

 

INDEX and MATCH Functions 

The INDEX and MATCH functions can be combined to perform advanced lookups. The 

INDEX function returns a value from a specific position in a range, while the MATCH 

function searches for a value in a range and returns its relative position. The syntax for 

these functions is: 

 

=INDEX(array, row_num, [column_num]) 

=MATCH(lookup_value, lookup_array, [match_type]) 

 

In most cases, Index and Match are used together. For example, to look up the value in 

cell A1 within a table located in cells B1 to E10 and return the corresponding value 

from row 3 of the table, you would use the following formula: 

 



=INDEX(B1:E10, MATCH(A1, B1:B10, 0), 3) 

 

TEXT Function 

The TEXT function converts a number to text, applying a specified number format. The 

syntax for this function is: 

=TEXT(value, format_text) 

 

For example, to display the number in cell A1 as currency with two decimal places, you 

would use the formula: 

 

=TEXT(A1, "$#,##0.00") 

 

IF Function 

The IF function performs a logical test and returns one value if the test is true and 

another value if the test is false. The syntax for this function is: 

=IF([logical_test], [value_if_true], [value_if_false]) 

 

For example, to check if the value in cell A1 is greater than 10 and return "Greater" if 

true and "Smaller" if false, you would use the formula: 

 

=IF(A1>10, "Greater", "Smaller") 

 

The “Not equal” operator is a less than, then a greater than symbol, which looks like 

this, “<>”. To say greater than or equal to, or to say less than or equal to, write an 

equals sign after the greater than or less than sign, for example, “>=” or “<=”. 



To say that something is true if one or more conditions are met, you can put an or 

function inside the if function. For example, if you want the condition to be true when 

at least one of the cells in the range from “A1” to “A3” is greater than zero, you can say  

“=if(or(A1>0,A2>0,A3>0), [value_if_true], [value_if_false])” 

This is very confusing to look at admittedly, but you have a very useful tool to help you 

understand what is going on. If you double click the cell and hover your cursor over a 

part of the cell, a textbox will appear telling you which part of which function is being 

edited.  

 

 

  



 

MAKING SPREADSHEETS 

 

In this section, we will go through the process of creating three fairly simple but very 

useful spreadsheets from scratch. So let’s get started. 

 

CREATING A STADIUM SEATING SPREADSHEET 

Suppose you're an engineer tasked with designing stadium seating, but the maximum 

distance from front to back isn't specified yet. There is no exact requirement for how 

far it can stretch from left to right, but they would like you to keep that at a minimum, 

and they want the seating to accommodate 500 people. Each row requires 4 feet from 

back to front, and each person needs 3 feet from left to right. Therefore, 500 people 

require 6,000 square feet (500*3*4). 

 

To model this problem in Excel: 

In cell B5, write "Length" (the input once the school provides the maximum distance). 

In cell B6, write "Width" (the calculated output). 

In cell B7, write "Rows Allowed" (length divided by 4, rounded down). 

In cell “C7”, we will write “=C5/4”. You may be thinking, won’t this give us a decimal 

number most of the time? And that is right. What we need to do is change it so that the 

decimal is chopped off, because we of course can’t have a fraction of a row. To do this, 

we will use a formula. We’ve seen many formulas, but the one we will use here is 

completely new. We will use the round down formula. We will write 

“=ROUNDDOWN(C5/4,0). The second argument, which in this case is zero, is the 

number of digits after the decimal number should be kept. Since we want a whole 

number, we want no digits after the decimal.  

Since they want us to build the stadium as short from left to right as possible, we will 

want to use the maximum length from front to back, so in the eighth row, we will get 

our length used. 



In cell B8, write "Length to Use" (rows allowed times the length of each row). 

In cell C8, write "=C7*4". 

In cell B9, write "Total Footprint" (6,000 square feet). 

In cell C9, write "6000". 

In cell C6, write "=C9/C8" (the minimum width required to accommodate 500 people). 

Now, you can adjust the allowed length or footprint, and the spreadsheet will 

automatically update the dimensions. How about that! 

 

Result (Assuming a length of 43) 

 

Result (Assuming a length of 43) with formulas 

 

  

Length 43

Width 150

Rows Allowed 10

Length to Use 40

Total Footprint 6000

Length 43

Width =C9/C8

Rows Allowed =ROUNDDOWN(C5/4,0)

Length to Use =C7*4

Total Footprint 6000



CREATING A PERSONAL BUDGET SPREADSHEET 

 

Suppose you want to create a personal budget spreadsheet to track your income, 

expenses, and savings. You will organize the data on a monthly basis and create a 

summary for the entire year. You could make something like this. 

 

Create a new worksheet and name it "Personal Budget". 

In cell B2, write "Month". In cells C2 to N2, enter the names of the months (e.g., 

"January", "February", etc.). To do this faster, after writing in the first month, you can 

autofill the rest by selecting the cell, then dragging the small green box that will 

appear at the bottom right of the cell to the right. 

In cell B3, write "Income". In cell B4, write "Expenses". In cell B5, write "Savings". 

In cells C3 to N3, enter your monthly income values. 

In cells C4 to N4, enter your monthly expenses values. 

In cells C5 to N5, write the formula "=C3-C4" (replace "C" with the corresponding 

column letter for other months) to calculate your monthly savings. Again, to do this 

faster, you can start by populating the first cell, then auto filling the rest. The cell 

references will apply to cells that are in the same relative position. This is called a 

relative reference which will be discussed further at a later point.  

In cell O2, write "Total". In cell O3, write the formula "=SUM(C3:N3)" to calculate the 

total income for the year. Repeat this for expenses and savings in cells O4 and O5, 

respectively. 

In cell B7, write "Expense Categories". In cells B8 to B13 (or more, depending on the 

number of categories), list your main expense categories (e.g., "Rent", "Utilities", 

"Groceries", etc.). 

In cell C7, write "January". Autofill this header across columns D to N for the rest of the 

months. 

Enter the amounts spent for each expense category and month in the corresponding 

cells (C8 to N13, or further down if more categories are added). 



In cell O7, write "Total". In cell O8, write the formula "=SUM(C8:N8)" to calculate the 

total amount spent in each expense category for the year. Copy this formula down to 

the remaining categories. 

In cell B15, write "Yearly Summary". In cell B16, write "Total Income". In cell B17, write 

"Total Expenses". In cell B18, write "Total Savings". 

In cell C16, write the formula "=O3" to reference the total income. In cell C17, write the 

formula "=O4" for total expenses. In cell C18, write the formula "=O5" for total 

savings. 

Now, you have a personal budget spreadsheet that tracks your income, expenses, and 

savings on a monthly basis and provides a yearly summary. You can adjust the values 

as needed, and the spreadsheet will automatically update the summaries. Add 

formatting wherever you like. 

Result: 

 

Result with formulas: 

 

  

Month January February March April May June July August September October November December Total

Income 4000 4000 4000 4000 4000 4000 4000 4000 4000 4000 4000 4000 48000

Expenses 2000 2000 2000 2000 2000 2000 2000 2000 2000 2000 2000 2000 24000

Savings 2000 2000 2000 2000 2000 2000 2000 2000 2000 2000 2000 2000 24000

Expense Categories January February March April May June July August September October November December Total

Rent 1000 1000 1000 1000 1000 1000 1000 1000 1000 1000 1000 1000 12000

Utilities 200 200 200 200 200 200 200 200 200 200 200 200 2400

Groceries 300 300 300 300 300 300 300 300 300 300 300 300 3600

Other 500 500 500 500 500 500 500 500 500 500 500 500 6000

Yearly Summary

Total Income 48000

Total Expenses 24000

Total Savings 24000

Month January February March April May June July August September October November December Total

Income 4000 4000 4000 4000 4000 4000 4000 4000 4000 4000 4000 4000 =SUM(C3:N3)

Expenses =SUM(C8:C11) =SUM(D8:D11) =SUM(E8:E11) =SUM(F8:F11) =SUM(G8:G11) =SUM(H8:H11) =SUM(I8:I11) =SUM(J8:J11) =SUM(K8:K11) =SUM(L8:L11) =SUM(M8:M11) =SUM(N8:N11) =SUM(C4:N4)

Savings =C3-C4 =D3-D4 =E3-E4 =F3-F4 =G3-G4 =H3-H4 =I3-I4 =J3-J4 =K3-K4 =L3-L4 =M3-M4 =N3-N4 =SUM(C5:N5)

Expense Categories January February March April May June July August September October November December Total

Rent 1000 1000 1000 1000 1000 1000 1000 1000 1000 1000 1000 1000 =SUM(C8:N8)

Utilities 200 200 200 200 200 200 200 200 200 200 200 200 =SUM(C9:N9)

Groceries 300 300 300 300 300 300 300 300 300 300 300 300 =SUM(C10:N10)

Other 500 500 500 500 500 500 500 500 500 500 500 500 =SUM(C11:N11)

Yearly Summary

Total Income =O3

Total Expenses =O4

Total Savings =O5



CREATING AN EMPLOYEE WORK SCHEDULE SPREADSHEET 

 

For another example, suppose you want to create an employee work schedule 

spreadsheet to manage your team's weekly shifts and availability.  

 

To model this problem in Excel: 

 

Create a new worksheet and name it "Employee Schedule". 

In cell B2, write "Employee". In cells C2 to I2, enter the days of the week (e.g., 

"Monday", "Tuesday", etc.). 

In cell J2, write "Total Hours". In cell K2, write "Vacation Days". 

In cells B3 to B(n+2), list the names of your employees (replace 'n' with the number of 

employees). 

In cells C3 to I(n+2), enter the shift times for each employee and day of the week. You 

can use different formats, such as "9 AM - 5 PM" or "Morning Shift". It’s up to you. 

In cell J3, write the formula "=SUM(C3:I3)" to calculate the total hours worked by the 

employee for the week. Copy this formula down to the remaining employees. 

In cells K3 to K(n+2), enter the number of vacation days for each employee. You can 

adjust these values as needed throughout the year. 

In cell B(n+4), write "Total Hours per Day". In cells C(n+4) to I(n+4), write the formula 

"=SUM(C3:C(n+2))" to calculate the total hours worked by all employees for each day of 

the week. Adjust the cell references according to the number of employees. 

In cell B(n+5), write "Total Vacation Days". In cell C(n+5), write the formula 

"=SUM(K3:K(n+2))" to calculate the total vacation days taken by all employees. Adjust 

the cell references according to the number of employees. 

Apply formatting, such as borders, colors, and font styles, to improve the appearance 

and readability of the spreadsheet. 



Now, you have an employee work schedule spreadsheet that helps you manage your 

team's weekly shifts, track vacations, and ensure adequate staffing levels. You can 

adjust the shift times and vacation days as needed, and the spreadsheet will 

automatically update the total hours worked and vacation days taken. 

 

Result 

 

 

Result with formulas 

 

  

Employee Tuesday Wednesday Thursday Friday Saturday Sunday Monday Total Hours Vacation Days

Employee 1 0 0

Employee 2 0 0

Employee 3 0 0

Employee 4 0 0

Employee 5 0 0

Employee 6 0 0

Employee 7 0 0

Employee 8 0 0

Employee 9 0 0

Employee 10 0 0

Total Hours per Day 0 0 0 0 0 0 0

Total Vacation Days 0

Employee Tuesday Wednesday Thursday Friday Saturday Sunday Monday Total Hours Vacation Days

Employee 1 =SUM(C3:I3) 0

Employee 2 =SUM(C4:I4) 0

Employee 3 =SUM(C5:I5) 0

Employee 4 =SUM(C6:I6) 0

Employee 5 =SUM(C7:I7) 0

Employee 6 =SUM(C8:I8) 0

Employee 7 =SUM(C9:I9) 0

Employee 8 =SUM(C10:I10) 0

Employee 9 =SUM(C11:I11) 0

Employee 10 =SUM(C12:I12) 0

Total Hours per Day =SUM($C$3:$C$12) =SUM($D$3:$D$12) =SUM($E$3:$E$12) =SUM($F$3:$F$12) =SUM($G$3:$G$12) =SUM($H$3:$H$12) =SUM($I$3:$I$12)

Total Vacation Days =SUM(K3:K12)



DATA MANIPULATION 

Excel offers a plethora of tools that can speed up the process of data manipulation and 

learning them can slash the time you need to perform tasks significantly. In this 

section, we’ll look at all of them. And we’ll see how they are used in different 

situations.  

 

PIVOT TABLES 

An incredibly powerful tool, Pivot Tables allow you to quickly summarize, analyze, and 

present your data in a more organized and understandable manner. With the ability to 

filter, sort, and group your data, Pivot Tables can offer valuable insights in just a few 

clicks. 

 

Shortcut: Alt + N + V 

Use Case: Sales Data Analysis 

 

Imagine you have a large dataset containing sales data for multiple products across 

different regions and salespeople. You want to analyze the sales performance by 

region, salesperson, and product category. A Pivot Table can help you summarize and 

aggregate the data to quickly identify top-performing regions, salespeople, and 

products. 

 

To create a Pivot Table: 

 

Select any cell within your dataset. 

Press Alt + N + V to open the 'Create PivotTable' dialog box. 

Choose where you want to place the Pivot Table (new or existing worksheet). 

Drag and drop fields from your dataset into the Pivot Table's Rows, Columns, Values, 

and Filters areas to build the desired summary view. 



 

In this example, select anywhere in the data, then click pivot table in the ribbon. Make 

sure you do not have empty headers, as that is where your pivot table will stop. 

We will go over pivot tables in more detail later, as they are among the most important 

features in Excel. 

 

 

FILTERING AND SORTING 

Filtering hides the rows that don't match the specified criteria, making it easy to focus 

on a particular subset of data. Sorting, on the other hand, rearranges your data in 

ascending or descending order based on the values in one or more columns. 

 

Shortcut for Filter: Alt + D + F + F 

Shortcut for Sort: Alt + D + S 



 

Use Case: Employee Salary Analysis 

 

You have a dataset containing employee information, including names, departments, 

job titles, and salaries. You want to filter the data to display only employees within a 

specific department and sort them by salary in descending order. 

 

To apply filtering and sorting: 

 

Select any cell within your dataset. 

Press Alt + D + F + F to apply filters to each column header. 

Click on the department column header's filter icon and select the desired department. 

Click on the salary column header's filter icon and choose 'Sort Largest to Smallest.' 

 

 

 

 

 

CONDITIONAL FORMATTING 

 

This technique allows you to apply different formatting options, such as colors or 

icons, to cells or ranges based on specific conditions. This makes it easier to identify 

patterns, trends, or outliers within your data. 

 

Shortcut: Alt + H + L 

 



Use Case: Student Grade Highlighting 

 

You have a list of student names and their test scores. You want to visually highlight 

students who scored above 90 (Excellent) and those who scored below 60 (Needs 

Improvement). 

 

To apply conditional formatting: 

 

Select the range containing the test scores. 

Press Alt + H + L to open the 'Conditional Formatting' menu. 

Choose 'Highlight Cell Rules' and then 'Greater Than.' Enter 90 and choose the desired 

formatting. Click OK. 

Repeat step 3 but select 'Less Than' and enter 60. 

 

 

Data Validation 

Data Validation ensures that only specific types of data or values can be entered into a 

cell, thus maintaining data consistency and reducing the chances of errors. 

 

Shortcut: Alt + A + V + V 

 

Use Case: Order Form 

 

You are creating an order form where users can input product quantities. You want to 

ensure they can only enter whole numbers between 1 and 100. 

 



To apply data validation: 

 

Select the cells where users will enter quantities. 

Press Alt + A + V + V to open the 'Data Validation' dialog box. 

In the 'Allow' dropdown, choose 'Whole number.' 

Set the minimum value to 1 and the maximum value to 100. Click OK. 

 

 

FIND AND REPLACE 

Quickly search for specific text or values within your worksheet and replace them with 

new text or values if necessary. 

 

Shortcut: Ctrl + F for Find, Ctrl + H for Replace 

 

Use Case: Updating Customer Information 

 

You have a dataset containing customer information, and you need to update the area 

code for all phone numbers from 555 to 556. 

 

To use Find and Replace: 

 

Press Ctrl + H to open the 'Find and Replace' dialog box. 

In the 'Find what' field, enter "555." 

In the 'Replace with' field, enter "556." 

Click 'Replace All.' 



 

 

GROUPING AND OUTLINING 

Grouping data is an effective way to organize and summarize rows or columns based 

on similar characteristics. Outlining can help you create collapsible sections that make 

your data easier to navigate. 

 

Shortcut: Alt + Shift + Left Arrow for Group, Alt + Shift + Right Arrow for Ungroup 

 

Use Case: Monthly Expense Report 

 

You have a dataset containing daily expenses for an entire year. You want to group the 

data by month to make it easier to analyze and compare expenses. 

 

To use grouping and outlining: 

 

Sort the data by date in ascending order. 

Select the rows corresponding to a specific month. 

Press Alt + Shift + Left Arrow to group the selected rows. 

Repeat steps 2 and 3 for each month. 

 

 

REMOVE DUPLICATES 

This technique eliminates duplicate rows within your dataset, ensuring data 

consistency and preventing inaccuracies in your analysis. 

 



Shortcut: Alt + A + M 

 

Use Case: Merging Customer Lists 

 

You have two separate customer lists that you need to merge into one master list. 

However, some customers appear in both lists, and you want to ensure each customer 

is only listed once. 

 

To remove duplicates: 

 

Combine the two customer lists into one worksheet. 

Select the entire dataset, including headers. 

Press Alt + A + M to open the 'Remove Duplicates' dialog box. 

Select the columns that uniquely identify each customer (e.g., email or customer ID). 

Click OK. 

 

 

TEXT TO COLUMNS 

Split text data in a single column into multiple columns based on a specified delimiter. 

This can be useful when importing data from external sources or when cleaning up 

existing data. 

 

Shortcut: Alt + A + E 

 

Use Case: Splitting Full Names 

 



You have a dataset containing full names in a single column. You need to split the 

names into separate columns for first and last names. 

 

To use Text to Columns: 

 

Select the column containing the full names. 

Press Alt + A + E to open the 'Text to Columns' wizard. 

Choose 'Delimited' and click Next. 

Select the appropriate delimiter (e.g., space) and click Next. 

Choose the destination for the split data and click Finish. 

 

 

MERGE & CENTER 

Combining and centering the content of selected cells can be useful for formatting 

headers and improving the overall appearance of your data. 

 

Shortcut: Alt + H + M + C 

Use Case: Formatting Table Headers 

 

You have a dataset with multiple columns, and you want to create a merged and 

centered header that spans the entire table width. 

 

To use Merge & Center: 

 

Insert a new row above your dataset. 

Select the cells in the new row corresponding to the table width. 



Press Alt + H + M + C to merge and center the selected cells. 

Enter the desired header text. 

 

 

 

 

PASTE SPECIAL 

This feature allows you to paste only specific aspects of copied data, such as values, 

formatting, or formulas. This is particularly useful when transferring data between 

different worksheets or workbooks. 

 

Shortcut: Ctrl + Alt + V 

 

By mastering these data manipulation techniques in Excel, you'll be able to work more 

efficiently and accurately, making the most of your data and unlocking valuable 

insights. 

 

Use Case: Copying Formulas as Values 

 

You have a dataset with formulas that calculate various metrics. You want to copy the 

data to another worksheet without carrying over the formulas, only the calculated 

values. 

 

To use Paste Special: 

 

Select the range containing the formulas. 

Press Ctrl + C to copy the selected cells. 



Navigate to the destination worksheet. 

Press Ctrl + Alt + V to open the 'Paste Special' dialog box. 

Select 'Values' and click OK. 

 

 

DATA CONSOLIDATION 

 

Data consolidation helps you to combine data from multiple ranges and worksheets 

into a single location. It is useful for summarizing data from different sources, such as 

sales reports from multiple regions. 

 

Shortcut: Alt + A + M + C (opens the 'Consolidate' dialog box) 

Use Case: Summarizing Multiple Sales Reports 

 

You have multiple worksheets containing sales data for different regions. You want to 

consolidate the data into a summary report showing total sales for each product 

category. 



 

To use Data Consolidation: 

 

Create a new worksheet for the summary report. 

Select the cell where you want the consolidated data to start. 

Press Alt + A + M + C to open the 'Consolidate' dialog box. 

Choose the desired function (e.g., Sum) and click 'Add' to select the range from each 

source worksheet. 

Check 'Top row' and 'Left column' if your source data has labels. Click OK. 

 

 

GOAL SEEK 

 

Goal Seek is a powerful "what-if" analysis tool that allows you to find a specific value 

for a given input cell by adjusting the value of another cell. It's commonly used in 

financial modeling and break-even analysis. 

 



Shortcut: Alt + A + W + G (opens the 'Goal Seek' dialog box) 

 

Use Case: Break-even Analysis 

 

You have a financial model that calculates profit based on revenue, fixed costs, and 

variable costs. You want to determine the revenue required to achieve a break-even 

point (zero profit). 

 

To use Goal Seek: 

 

Click on the cell containing the profit formula. 

Press Alt + A + W + G to open the 'Goal Seek' dialog box. 

Set the 'Set cell' to the profit cell, the 'To value' to 0, and the 'By changing cell' to the 

revenue cell. Click OK. 

 

 

SOLVER 

Solver is an optimization tool that helps you find the best solution to a problem, 

subject to certain constraints. It is in my opinion, by far the most powerful tool 

available in Excel. It can be used to optimize production quantities, scheduling, and 

resource allocation, among other applications. 

 

Shortcut: Alt + A + W + S (opens the 'Solver Parameters' dialog box) 



Use Case: Optimizing Production 

You have a production model that calculates the total profit based on the number of 

units produced for various products. You want to determine the optimal production 

quantities to maximize profit, given certain constraints (e.g., production capacity, 

material availability). 

To use Solver: 

Click on the cell containing the total profit formula. 

Press Alt + A + W + S to open the 'Solver Parameters' dialog box. 

Set the 'Set Objective' to the profit cell and select 'Max.' 

Click 'Add' to define constraints for production quantities, capacity, or material 

availability. 

Click 'Solve.' 

 

 

 



Note: In order to get Solver to appear, you may have to enable it in the add ins center. 

To do this, go to File > Options > Add ins. Make sure you are looking at Excel add ins. 

Then click go. Enable solver by checking this box.  

 

 

 

By understanding the various data manipulation techniques in Excel and knowing when 

and how to apply them, you can save time, improve accuracy, and gain insights from 

your data that drive informed decision-making. As you gain experience, you'll become 

more efficient and confident in using these tools to tackle even the most complex data 

challenges. 

  



Importing And Exporting Data 
 

Managing data is a crucial aspect of working with Excel, and understanding how to 

import and export data can significantly improve your efficiency. In this comprehensive 

section, we will explore the various methods for importing and exporting data in Excel, 

including: 

 

Importing Data from Text Files 

Importing Data from CSV Files 

Importing Data from Other Excel Workbooks 

Importing Data from Databases 

Importing Data from the Web 

Exporting Data to Text Files 

Exporting Data to CSV Files 

Exporting Data to PDF 

Exporting Data to Other File Formats 

 

Importing data from text files 

 

Text files, such as .txt or .log, can be imported into Excel. Follow these steps: 

 

a. Go to the 'Data' tab and click 'From Text/CSV'. 

b. Locate and select the text file you want to import, then click 'Import'. 

c. In the 'Text Import Wizard', choose the file type, delimiter (e.g., tab, comma, or 

space), and text qualifier (e.g., double or single quotes). 

d. Click 'Finish' to complete the import process. 



 

Importing data from csv files 

 

CSV (Comma Separated Values) files are another common format for data storage. To 

import data from a CSV file: 

 

a. Go to the 'Data' tab and click 'From Text/CSV'. 

b. Locate and select the CSV file, then click 'Import'. 

c. In the 'Text Import Wizard', verify the delimiter (usually a comma) and text qualifier. 

d. Click 'Finish' to complete the import process. 

 

Importing data from other excel workbooks 

 

To import data from another Excel workbook: 

 

a. Go to the 'Data' tab and click 'Get Data', then 'From File', and finally 'From 

Workbook'. 

b. Locate and select the Excel workbook you want to import data from. 

c. In the 'Navigator' window, select the worksheet or table you want to import. 

d. Click 'Load' or 'Transform Data' if you need to make any changes before importing. 

 

Importing data from databases 

 

Excel can import data from various database systems, such as SQL Server, Access, or 

Oracle. To import data from a database: 

 



a. Go to the 'Data' tab and click 'Get Data'. 

b. Select 'From Database' and choose the appropriate database type. 

c. Enter the necessary connection information and credentials. 

d. Select the tables or views you want to import and click 'Load' or 'Transform Data'. 

 

Importing data from the web 

 

You can import data from websites using Excel's web query feature. To import data 

from the web: 

 

a. Go to the 'Data' tab and click 'Get Data', then 'From Other Sources', and finally 'From 

Web'. 

b. Enter the URL of the webpage containing the data you want to import. 

c. In the 'Navigator' window, select the tables or elements you want to import. 

d. Click 'Load' or 'Transform Data' if you need to make any changes before importing. 

 

Exporting data to text files 

 

To export data from Excel to a text file: 

 

a. Click 'File' > 'Save As'. 

b. Choose a folder location, and in the 'Save as type' dropdown menu, select 'Text (Tab 

delimited)' or 'Unicode Text'. 

c. Click 'Save' to complete the export process. 

 



Exporting data to csv files 

 

To export data from Excel to a CSV file: 

 

a. Click 'File' > 'Save As 

b. Choose a folder location, and in the 'Save as type' dropdown menu, select 'CSV 

(Comma delimited)'. 

c. Click 'Save' to complete the export process. 

 

Exporting data to pdf 

 

Excel allows you to export your data as a PDF for easy sharing and printing. To export 

data to a PDF file: 

 

a. Click 'File' > 'Save As'. 

b. Choose a folder location, and in the 'Save as type' dropdown menu, select 'PDF'. 

c. Click 'Save' to complete the export process. 

 

Exporting data to other file formats 

 

Excel supports exporting data to various file formats, such as XML, HTML, and older 

Excel versions. To export data to another file format: 

 

a. Click 'File' > 'Save As'. 

b. Choose a folder location, and in the 'Save as type' dropdown menu, select the 

desired file format. 



c. Click 'Save' to complete the export process. 

 

By understanding the various methods for importing and exporting data in Excel, you 

can easily transfer and share data between different sources and formats. This can 

save you time and effort while ensuring that your data is consistent, accurate, and up-

to-date across all platforms. 

  



Conditional Formatting In Excel: A Comprehensive 

Guide 
 

Conditional formatting is a powerful Excel feature that allows you to apply specific 

formatting to cells based on their content or other conditions. In this comprehensive 

guide, we will explore the various aspects of conditional formatting, including: 

 

Applying Basic Conditional Formatting 

Using Data Bars, Color Scales, and Icon Sets 

Creating Custom Conditional Formatting Rules 

Managing and Modifying Conditional Formatting Rules 

Copying Conditional Formatting to Other Cells 

Conditional Formatting with Formulas 

 

Applying basic conditional formatting 

 

Excel provides built-in conditional formatting options for common scenarios. To apply 

basic conditional formatting: 

 

a. Select the cells you want to apply formatting to. 

b. Go to the 'Home' tab and click 'Conditional Formatting'. 

c. Choose from the available options, such as 'Highlight Cell Rules', 'Top/Bottom 

Rules', or 'Data Validation'. 

 

Using data bars, color scales, and icon sets 

 



Data Bars, Color Scales, and Icon Sets are visualization tools within conditional 

formatting that help represent data values graphically. 

 

a. Select the cells you want to apply formatting to. 

b. Go to the 'Home' tab and click 'Conditional Formatting'. 

c. Choose 'Data Bars', 'Color Scales', or 'Icon Sets' and select a desired format. 

 

Creating custom conditional formatting rules 

 

For more specific needs, you can create custom conditional formatting rules. 

 

a. Select the cells you want to apply formatting to. 

b. Go to the 'Home' tab and click 'Conditional Formatting' > 'New Rule'. 

c. Select a rule type and define your conditions, then choose a desired format. 

 

Managing and modifying conditional formatting rules 

 

To modify or manage existing conditional formatting rules: 

 

a. Select the cells containing conditional formatting. 

b. Go to the 'Home' tab and click 'Conditional Formatting' > 'Manage Rules'. 

c. In the 'Conditional Formatting Rules Manager', you can edit, delete, or change the 

order of rules. 

 

Copying conditional formatting to other cells 

 



To copy conditional formatting from one cell to another: 

 

a. Select the cell with the desired conditional formatting. 

b. Press 'Ctrl + C' to copy the cell. 

c. Select the target cells. 

d. Go to the 'Home' tab and click 'Paste' > 'Paste Special' > 'Formats'. 

 

Conditional formatting with formulas 

 

Since using formulas in conditional formatting is more sophisticated, we will spend 

more time on this concept. 

 

Basics of using formulas in conditional formatting 

 

To use a formula in custom conditional formatting: 

 

a. Select the cells you want to apply formatting to. 

b. Go to the 'Home' tab and click 'Conditional Formatting' > 'New Rule'. 

c. Choose 'Use a formula to determine which cells to format'. 

d. Enter your formula in the 'Format values where this formula is true' field and choose 

the desired format. 

 

The formula should return a TRUE or FALSE result. When the formula is TRUE, the 

conditional formatting will be applied. 

 



Relative and absolute cell references 

 

When using cell references in a formula, keep in mind the difference between relative 

and absolute references. 

 

Relative references (e.g., A1) adjust automatically when the formula is applied to other 

cells. 

Absolute references (e.g., $A$1) remain fixed, regardless of where the formula is 

applied. 

Use a mix of relative and absolute references to create dynamic conditional formatting 

rules. 

 

Working with text, dates, and time 

 

Formulas can also work with text, dates, and time in conditional formatting. Some 

useful functions include: 

 

Text: LEFT(), RIGHT(), MID(), LEN(), FIND(), SEARCH() 

Dates: TODAY(), DATE(), YEAR(), MONTH(), DAY() 

Time: NOW(), TIME(), HOUR(), MINUTE(), SECOND() 

Combining multiple conditions 

 

You can combine multiple conditions using logical functions, such as AND(), OR(), and 

NOT(). 

 

For example, to format cells with values between 10 and 20: 

=AND(A1>10, A1<20) 



 

Formatting based on other cells 

 

Conditional formatting can be applied based on the values of other cells. Use a formula 

to reference the relevant cell(s). 

 

For example, to highlight cells in column A when the corresponding cell in column B is 

greater than 50: 

 

Copy code 

=B1>50 

 

Troubleshooting conditional formatting formulas 

 

If your formula isn't working as expected, consider the following tips: 

 

Check for errors in your formula or syntax. 

Ensure you are using the correct relative and absolute cell references. 

Verify that your formula returns a TRUE or FALSE result. 

Use the 'Evaluate Formula' tool (under 'Formulas' > 'Formula Auditing') to identify 

potential issues. 

By understanding the various aspects of conditional formatting and its nuances, you 

can create visually appealing and informative worksheets that highlight important data 

points and make it easier to analyze and understand your data.  

  



Excel Pivot Tables: A Comprehensive Guide 
 

Pivot tables are a powerful tool for summarizing and analyzing large amounts of data 

in Excel. They allow you to quickly and easily create interactive reports and 

visualizations that provide insights into your data. In this guide, we will explore the 

different aspects of pivot tables. 

 

Creating a Pivot Table 

To create a pivot table: 

 

a. Select the data range that you want to summarize. 

b. Go to the 'Insert' tab and click 'PivotTable'. 

c. Choose where to place your pivot table and click 'OK'. 

d. In the 'PivotTable Fields' pane, drag and drop the fields you want to include in your 

pivot table. 

 

 

  



Customizing a Pivot Table 

Once you have created your pivot table, you can customize it to fit your needs. This 

includes changing the layout, adding calculated fields and items, and applying 

different formatting options. 

 

Filtering and Sorting a Pivot Table 

Pivot tables allow you to quickly filter and sort your data to get a better understanding 

of your results. You can filter by specific values or conditions, or sort by different 

criteria. 

 

Using Pivot Charts 

Pivot charts are a great way to visualize your pivot table data. You can create different 

types of charts, such as bar charts, line charts, and pie charts, and customize them to 

suit your needs. 

 

 

 

By understanding the different aspects of pivot tables and how to use them effectively, 

you can turn your data into valuable insights that help drive better decision-making. 

  



Resources 

  

1. SUM: Adds up a range of numbers.

2. AVERAGE: Calculates the average of a range of numbers.

3. MIN: Returns the smallest value in a range of numbers.

4. MAX: Returns the largest value in a range of numbers.

5. COUNT: Counts the number of cells with numeric values within a range.

6. IF: Returns one value if a condition is true and another value if it's false.

7. VLOOKUP: Searches for a value in the leftmost column of a table and returns a value in the same row from a specified column.

8. HLOOKUP: Searches for a value in the top row of a table and returns a value in the same column from a specified row.

9. INDEX: Returns a value or the reference to a value from within a table or range.

10. MATCH: Searches for a specified item in a range of cells and returns the relative position of that item in the range.

11. DATE: Returns the date as a serial number based on year, month, and day.

12. TIME: Returns the time as a serial number based on hours, minutes, and seconds.

13. TODAY: Returns the current date.

14. NOW: Returns the current date and time.

15. DAY: Returns the day of the month from a given date.

16. MONTH: Returns the month from a given date.

17. YEAR: Returns the year from a given date.

18. HOUR: Returns the hour from a given time.

19. MINUTE: Returns the minute from a given time.

20. SECOND: Returns the second from a given time.

21. TEXT: Converts a value to text in a specified number format.

22. VALUE: Converts a text string that represents a number to a number.

23. CONCATENATE: Joins multiple text strings into one text string.

24. LEFT: Returns the left part of a text string with the number of characters specified.

25. RIGHT: Returns the right part of a text string with the number of characters specified.

26. MID: Returns a specific number of characters from a text string starting at the position you specify.

27. SEARCH: Finds one text value within another and returns the position where it starts.

28. REPLACE: Replaces part of a text string with a different text string.

29. SUBSTITUTE: Substitutes new text for old text in a text string.

30. TRIM: Removes all spaces from a text string except for single spaces between words.

Excel Functions Tier List
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31. AND: Returns TRUE if all of the conditions are true, otherwise returns FALSE.

32. OR: Returns TRUE if any of the conditions are true, otherwise returns FALSE.

33. NOT: Reverses the value of its argument; if the argument is TRUE, it returns FALSE and vice versa.

34. CHOOSE: Selects a value from a list of values based on an index number.

35. LOOKUP: Searches for a value in a one-row or one-column range and returns a value from the same position in a second one-row or one-column range.

36. OFFSET: Returns a reference to a range that is a specified number of rows and columns from a cell or range of cells.

37. INDIRECT: Returns the reference specified by a text string.

38. ROW: Returns the row number of a reference.

39. COLUMN: Returns the column number of a reference.

40. ADDRESS: Creates a cell address as a text based on specified row and column numbers.

41. NETWORKDAYS: Returns the number of whole workdays between two dates. 42

42. WORKDAY: Returns a number that represents a date that is the indicated number of working days before or after a date.

43. EOMONTH: Returns the serial number for the last day of the month that is the indicated number of months before or after the start date.

44. WEEKDAY: Returns the day of the week corresponding to a date.

45. DAYS360: Returns the number of days between two dates based on a 360-day year.

46. DATEDIF: Calculates the difference between two dates based on the specified interval.

47. RANK: Returns the rank of a number in a list of numbers.

48. LARGE: Returns the k-th largest value in a data set, where k is the number you specify.

49. SMALL: Returns the k-th smallest value in a data set, where k is the number you specify.

50. ROUND: Rounds a number to a specified number of digits.

51. ROUNDDOWN: Rounds a number down, toward zero.

52. ROUNDUP: Rounds a number up, away from zero.

53. INT: Rounds a number down to the nearest integer.

54. MOD: Returns the remainder after a number is divided by a divisor.

55. ABS: Returns the absolute value of a number.

56. SQRT: Returns the square root of a number.

57. LN: Returns the natural logarithm of a number.

58. LOG: Returns the logarithm of a number to a specified base.

59. LOG10: Returns the base-10 logarithm of a number.

60. EXP: Returns e raised to the power of a given number.
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61. RAND: Returns a random number between 0 and 1.

62. RANDBETWEEN: Returns a random integer number between the numbers you specify.

63. FORECAST: Returns a value along a linear trend, based on existing values.

64. TREND: Returns values along a linear trend.

65. GROWTH: Returns predicted exponential growth based on existing data.

66. NPV: Returns the net present value of an investment based on a series of periodic cash flows and a discount rate.

67. IRR: Returns the internal rate of return for a series of cash flows.

68. PV: Returns the present value of an investment.

69. FV: Returns the future value of an investment.

70. PMT: Returns the periodic payment for an annuity.

71. RATE: Returns the interest rate per period of an annuity.

72. NPER: Returns the number of periods for an investment based on periodic, constant payments and a constant interest rate.

73. DB: Returns the depreciation of an asset for a specified period using the fixed-declining balance method.

74. DDB: Returns the depreciation of an asset for a specified period using the double-declining balance method or another method you specify.

75. SLN: Returns the straight-line depreciation of an asset for one period.

76. SYD: Returns the sum-of-years' digits depreciation of an asset for a specified period.

77. ACCRINT: Returns the accrued interest for a security that pays periodic interest.

78. COUPDAYS: Returns the number of days in the coupon period that contains the settlement date.
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79. BIN2DEC: Converts a binary number to a decimal number.

80. BIN2HEX: Converts a binary number to a hexadecimal number.

81. BIN2OCT: Converts a binary number to an octal number.

82. HEX2BIN: Converts a hexadecimal number to a binary number.

83. HEX2DEC: Converts a hexadecimal number to a decimal number.

84. HEX2OCT: Converts a hexadecimal number to an oct

84. HEX2OCT: Converts a hexadecimal number to an octal number.

85. OCT2BIN: Converts an octal number to a binary number.

86. OCT2DEC: Converts an octal number to a decimal number.

87. OCT2HEX: Converts an octal number to a hexadecimal number.

88. DEC2BIN: Converts a decimal number to a binary number.

89. DEC2HEX: Converts a decimal number to a hexadecimal number.

90. DEC2OCT: Converts a decimal number to an octal number.

91. ERROR.TYPE: Returns a number corresponding to an error type.

92. ISERR: Returns TRUE if the value is any error value except #N/A.

93. ISERROR: Returns TRUE if the value is any error value.

94. IFERROR: Returns a value you specify if a formula evaluates to an error; otherwise, it returns the result of the formula.

95. ISNA: Returns TRUE if the value is the #N/A error value.

96. ISNUMBER: Returns TRUE if the value is a number.

97. ISTEXT: Returns TRUE if the value is text.

98. ISNONTEXT: Returns TRUE if the value is not text.

99. ISBLANK: Returns TRUE if the referenced cell is empty.

100. ISREF: Returns TRUE if the value is a reference.

101. PROPER: Capitalizes the first letter in each word of a text value.

102. UPPER: Converts text to uppercase.

103. LOWER: Converts text to lowercase.

104. FIXED: Formats a number as text with a fixed number of decimals.

105. CLEAN: Removes all non-printable characters from text.

106. CHAR: Returns the character specified by the code number.

107. CODE: Returns the numeric code for the first character in a text string.

108. REPT: Repeats text a given number of times.

109. LEN: Returns the number of characters in a text string.

110. EXACT: Compares two text strings and returns TRUE if they are exactly the same, FALSE otherwise.

111. T: Returns the text referred to by a cell.

112. N: Returns the value converted to a number.

113. EVEN: Rounds a number up to the nearest even integer.

114. ODD: Rounds a number up to the nearest odd integer.

115. MROUND: Rounds a number to the nearest multiple of another number.

116. CEILING: Rounds a number up to the nearest integer or to the nearest multiple of significance.

117. FLOOR: Rounds a number down to the nearest integer or to the nearest multiple of significance.

118. PRODUCT: Multiplies its arguments.

119. SUMPRODUCT: Returns the sum of the products of corresponding ranges or arrays.

120. QUOTIENT: Returns the integer portion of a division.

121. FACT: Returns the factorial of a number.

122. COMBIN: Returns the number of combinations for a given number of items.

123. PERMUT: Returns the number of permutations for a given number of items.

124. SERIESSUM: Returns the sum of a power series based on the formula.

125. SIGN: Returns the sign of a number.

126. LN: Returns the natural logarithm of a number.

127. LOG: Returns the logarithm of a number to a specified base.

128. LOG10: Returns the base-10 logarithm of a number.

129. SQRT: Returns the positive square root of a number.

130. PI: Returns the value of pi.

131. SIN: Returns the sine of a given angle.

132. COS: Returns the cosine of a given angle.

133. TAN: Returns the tangent of a given angle.

134. ASIN: Returns the arcsine of a number.

135. ACOS: Returns the arccosine of a number.

136. ATAN: Returns the arctangent of a number.

137. SINH: Returns the hyperbolic sine of a number.

138. COSH: Returns the hyperbolic cosine of a number.

139. TANH: Returns the hyperbolic tangent of a number.

140. ASINH: Returns the inverse hyperbolic sine of a number.

141. ACOSH: Returns the inverse hyperbolic cosine of a number.

142. ATANH: Returns the inverse hyperbolic tangent of a number.

143. ERF: Returns the error function.

144. ERFC: Returns the complementary error function.

145. GAMMALN: Returns the natural logarithm of the gamma function.

146. GAMMA: Returns the gamma function value.

147. GAMMA.DIST: Returns the gamma distribution.

148. GAMMA.INV: Returns the inverse of the gamma cumulative distribution.

149. GAMMALN.PRECISE: Returns the natural logarithm of the gamma function with increased precision.

F

D



 

 

1. Ctrl + C: Copy

2. Ctrl + V: Paste

3. Ctrl + X: Cut

4. Ctrl + Z: Undo

5. Ctrl + Y: Redo

6. Ctrl + S: Save

7. Ctrl + F: Find

8. Ctrl + H: Replace

9. Ctrl + Arrow Keys: Navigate to the edge of data regions

10. Ctrl + Shift + Arrow Keys: Select cells in data regions

1. Ctrl + P: Print

2. Ctrl + O: Open

3. Ctrl + N: New workbook

4. Ctrl + T: Create a table

5. Alt + =: AutoSum

6. Ctrl + D: Fill down

7. Ctrl + R: Fill right

8. Ctrl + 1: Format cells dialog

9. F2: Edit cell

10. F4: Toggle between absolute and relative references

1. Ctrl + A: Select all

2. Ctrl + G: Go to

3. Alt + Enter: Start a new line in the same cell

4. Ctrl + Space: Select the entire column

5. Shift + Space: Select the entire row

6. Ctrl + Shift + L: Toggle filter

7. Ctrl + K: Insert hyperlink

8. Ctrl + B: Bold

9. Ctrl + I: Italic

10. Ctrl + U: Underline

1. Alt + F11: Open Visual Basic for Applications (VBA) editor

2. Alt + E + S: Open Paste Special dialog

3. Alt + N + V: Insert PivotTable

4. Shift + F11: Insert a new worksheet

5. Ctrl + Alt + V: Paste Special dialog

6. Ctrl + Tab: Switch between open workbooks

7. Ctrl + Shift + F3: Create names from selection

8. Ctrl + Shift + ;: Insert current time

9. Ctrl + ;: Insert current date

10. Alt + F8: Open Macro dialog

1. Alt + I + R: Insert row(s)

2. Alt + I + C: Insert column(s)

3. Alt + E + A: Clear cell content

4. Alt + H + H: Fill cell background color

5. Alt + H + B: Add cell border

6. Ctrl + 5: Strikethrough

7. Alt + H + O + I: AutoFit column width

8. Alt + H + O + A: AutoFit row height

9. Alt + H + F + C: Change font color

10. Alt + H + W: Wrap text

1. Ctrl + Shift + F: Font dialog

2. Ctrl + Shift + O: Select all cells containing comments

3. Alt + H + M + C: Merge and center cells

4. Alt + H + A + L: Align text left

5. Alt + H + A + R: Align text right

6. Alt + H + A + C: Center text

7. Alt + H + 9: Hide a row

8. Alt + H + 0: Unhide a row 

9. Alt + W + F + F: Freeze panes

10. Alt + W + F + R: Unfreeze panes

11. Ctrl + 8: Toggle outline symbols

12. Ctrl + Alt + F9: Calculate all worksheets in all open workbooks

13. Shift + F3: Insert function dialog

14. Alt + F4: Close Excel

15. Ctrl + F1: Show or hide the Ribbon

16. Alt + W + V + G: Toggle gridlines

17. Alt + W + V + H: Toggle headings

18. Ctrl + Alt + F5: Refresh all external data connections

19. Ctrl + Shift + Space: Select the entire worksheet (if cells contain data)

20. Alt + H + 6: Clear cell formatting
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