3.1: Sculpting

Sculpting in Fusion 360 allows for the intuitive freeform creation of organic solid bodies and
surfaces by leveraging the T-Splines technology. In the Sculpt Workspace, you can rapidly
explore forms by simply pressing and pulling on subdivided surfaces. This “hands-on” approach
to 3D modeling allows for fast iteration and early stage conceptualization within Fusion 360.
Sculpted forms are easily converted to solid bodies, and can be used in conjunction with Fusion
360’s solid modeling commands. Modeling with T-Splines is unlike any other subdivision-
modeling tool. One of the main advantages of T-Splines is the ability to add detail only where
necessary - a single T-Spline surface can be incredibly smooth, while still having areas of high
detail and remaining easy to manipulate.

Lesson 1: Creating T-Spline Forms

Learning Objectives

1. Create a T-Spline Primitive Form
2. Create a T-Spline Revolve Form
3. Create a T-Spline Sweep Form
4. Create a T-Spline Loft Form

Datasets Required
In Samples section of your Data Panel, browse to:

Fusion 101 Training > 03 — Sculpt > 03_Sculpting_Introduction.f3d

Open the design and follow the step-by-step guide below to get started with the lesson.

Step-by-step Guides

Step 1: Go to the Sculpt workspace — Let’s go E e
to the Sculpt workspace to access the Sculpt I
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1. Inthe Model workspace select Create
Form to enter the Sculpt workspace 1

2. Adialog box appears, telling you to |
click Finish Form to return to the [0 i cn E 1
model workspace when you are
finished sculpting.

3. Select OK

{ @ You've entered the Sculpt Environment. Use the
Finish Form button to return to solid modeling.




Step 2: - Select the T-Spline Box primitive

1.

Select the drop-down arrow under
Create to expand the list of creation
commands.

Select Box to create a T-Spline box.
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Creates a T-Spline box.

Define a center corner rectangle then spec
the height. Specify number of faces. Apply
optional symmetry.

Step 3: Position the Box — When you create a
new primitive you first need to indicate which
plane you want to build on and then enter the
dimensions of the primitive.

1.
2.

Select the bottom plane

Select the origin to specify the center
point of the box 2D profile

Drag the mouse and click on the plane
again to specify the initial size of the
rectangle.




Step 4: Set the dimensions for the box

1. Inthe Box dialog window set the
length to 175mm, and the width to
150mm respectively by entering these
numbers.

2. Dragthe arrow pointing up from the
box, and set the height equal to
75mm.

Note: When dragging a manipulator in Fusion
360 the increments for the move are tide to
how close or far away the camera is to the
manipulator. The closer you are the smaller
the move increments, the farther you are the
larger the move increments. If you find that
the move is changing at too large of
increments, simply zoom in to reduce the size
of each step.
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Step 5: Increase the number of faces to the
box in Length and Width.

1. Inthe Box dialog window set the
Length Faces to 3

2. To set the width faces, drag the
double-headed arrow manipulator on
the box primitive up to increase the
number of width faces until it equals
3.

3. Select OK to complete the Box
primitive setup.

Height

Height Faces. 2

Direction [y one side
Symmetry £% None
Operation () New Body

Step 6: Finish the form. You have just created
your first T-Spline body. To include this form
as part of your solid model you need to
indicate that you are done creating T-Spline
forms for the moment and that you want to
go back to the Model workspace.

1. Select Finish Form at the end of the
Sculpt workspace toolbar.

2. The T-Spline form is automatically
converted to a solid body and you are
brought back to the Model

$o0QQA TrEs

in
- |

i §
277 I

L




workspace.

Note: If you create a closed T-Spline form it
will be converted to a solid body when you
select Finish Form. If you create an open T-
Spline form, for example a T-Spline Plane, it
will be converted to a surface body when you
select Finish Form.
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Step 7: Create a T-Spline Revolve Form. Let’s
create a T-Spline form by revolving a sketch
curve. The Revolve command creates a form
by rotation 2D geometry about a fixed axis

1.

In the Browser, select the drop-down
arrow next to your Bodies folder
Click the light bulb next to Body1 to
turn off the visibility.

Select Create > Create Form.

[ XX )
B OB H o~
b 03_Sculpt...ction v1* XI

| e @PO

CREATE™ MODIFY ¥ AS
[+« sROWSER ol

A ) () 03_Sculpting_Introduction v1
D EJ Named Views
[3  units: mm
D @ EJ origin

A TSN, Bodies
e
D ™EY sketches

D Q D/Conswcﬂ;n

/

[ JON )
#H B H &~
@ 03_Sculpt...ction 1z, |

i(g}]@@

MODIFY ¥

[« BROWSER Y

A4 ) () 03 Sculpting_Introduction v1
D B3] Named Views




Step 8: — Turn on the visibility of the sketch
curve that you will be revolving.

1.

In the Browser, select the drop-down
arrow next to your Sketches folder.

Select the light bulb icon next to Revolve to
turn on the visibility of the Revolve sketch.
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Step 9: Revolve a T-Spline using the sketch
curve as input.

1.
2.

Select Create > Revolve.

Select on the sketch curve to identify
it as the Profile curve to be revolved.
In the dialog window select no
selection next to Axis to show the axis
selector in the workspace

Select the Blue axis. A T-Spline form is
revolved 360 degrees around the Blue
axis.
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Step 10: Change the Revolve settings. Let’s
change the settings in the Revolve settings to
change the Angle the direction that the curve
is revolved.

1. Inthe Revolve dialog window, change
the Type from Full to Angle.

2. Enter 90 degrees for the Angle field.

3. Change the Direction from One Side
to Symmetric.

4. Select OK.

5. Select Finish Form to return to the
Model workspace.

Note: The Revolve manipulator can also be
used to adjust the number of faces in
longitude and latitude of the revolved shape
as well as the degree of the Angle.
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Step 11: Create a T-Spline Form using Sweep.
The Sweep command uses two sketch curves
to define a shape. One curve is selected as the
Profile, which is swept along a Path curve to
create the shape.

1. Inthe Model workspace hide the
previously created Body 2 (1)

2. Inthe Browser in the Sketches section
select the light bulb icon next to
Revolve Sketch to turn off the sketch
visibility.

3. Turn on the visibility for the Sweep
Path and Sweep Profile sketches.
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Step 12: Start the Sweep command.

1. Select Create Form in the Model
workspace to change to the Sculpt
Workspace.

2. Select Create > Sweep to launch the
Sweep dialog window.

3. Select the Sweep Profile sketch to
identify this sketch as the Profile

4. Select no selection next to Path.

5. Select the Sweep Path sketch to
identify this sketch as the Path. The
swept T-Spline Form is generated.
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Step 13: Add faces to the swept surface. In
order to match our rounded-square profile,
we need to increase the number of faces for
the profile.

1. Inthe dialog window, set the number
of faces for the Profile equal to 24.

Note: The greater number of faces, the closer
the body matches the path.
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Step 14: Change the sweep orientation. There
may be instances where the orientation of the
profile as is moves along the path will give you
a more desirable result. Use the Orientation
option to change the sweep behavior.

1. Inthe dialog window, change the
Orientation from Perpendicular to
Parallel. Observe how the sweep
behavior drastically changes.

2. Change the Orientation back to
Perpendicular.

P
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Step 15: Change the sweep distance. The
Sweep command allows you to alter the
amount of the path curve that is used to
create the T-Spline form.

1. Dragthe arrow at the end of the Path
to alter the sweep distance. In
addition to using this arrow, we can
set the distance in the dialog window.

2. Inthe dialog window, set the distance
equal to 0.5.

3. The sweep now travels half the length
of our Path curve.

6. Select OK.

7. Select Finish Form.

Step 16: Create a T-Spline Form with Loft
using 3 sketch profiles as input to create a
lofted shape.

1. Turn off visibility of Body 3 (1)

2. Turn off visibility of the two Sweep
sketches.

3. Turn on visibility for sketches labeled
Loft Centerline, Circle, and Triangle.

4. Select Create > Create Form to change
to the Sculpt workspace
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Step 17: Select the profiles to create the loft
form.

1. Select Create > Loft.

2. Click the Triangular profile in the
canvas.

3. Click the Circular profile in the canvas.
This creates a straight lofted shape
transitioning between the triangle and
the circle.

Note: You can have multiple profile shapes to
loft between.
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Step 18: Change the Loft shape by defining a
centerline. By default the loft will always
create straight transitional surfaces between
profiles. To control the direction of the
surface between the profiles you can add a
sketch curve a centerline.

1. Click the centerline curve

2. You receive an error because initially
the software assumes that you are
adding another profile for the loft.

3. To specify this curve as a centerline
select Convert to Centerline under
Swap in the dialog window.
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Step 19: The T-Spline surface is not matching
well to the triangle profile. Let’s increase the
number of faces to improve the match.

1. Inthe dialog window, set the number
of faces for the Width equal to 16.

2. Click OK.

3. Select Finish Form.
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Lesson 2: Modify a T-Spline Form

The real power of T-Splines is that it allows for freeform shape manipulation of shapes
by moving, rotating and scaling vertices, edges and faces of a T-Spline surface. The most
common command you will use to do this is Edit Form. You can also add and remove
faces in your forms to get detail where you need it without making the entire form
overly complex.

Learning Objectives

1. Move, Rotate and Scale T-Spline geometry with Edit Form
2. Add geometry to a T-Spline body with Edit Form

3. Change the display mode

4. Insert Edges
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Step 2: Edit the T-Spline shape in the Timeline

1. Inthe parametric timeline at the
bottom of the Model window, located
the 4 T-Spline form icons.

2. Hover your pointer over the first form
icon and you will notice that the
primitive box is highlighted on the
screen.

3. Right-click on the form icon in the _ g
timeline and select Edit. ATy o

Note: When using Fusion 360 with history
turned on, T-Spline operations do not have
history in the same way that the operations in
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the Model and Patch workspaces do.

However you can go back in history and make
adjustments to your T-Spline shapes and those
changes will be recomputed in the history of
your model when you exit the Sculpt
workspace.
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Step 3: Start the Edit Form command

. . . . ‘)B_Sculptlng_ll @ Slide Edge
1. Click Modify > Edit Form. The Edit amed Views | @ ool £dge
Form command can be used to nits:mm | <% insert Point
directly manipulate Faces, Edges, and | ] Orgin | Merge Edge
Vertices. Bodies <& subdivide
2. Click on a top face located at one of @ sody1 ‘?’W*'d i
k & UnWeld Edaes

the corners of the box.
3. The manipulator displays on the face
with an assortment of tools.

Note: Directly manipulating a face creates the
greatest changes in your form, while
manipulating a single vertex will result in
smaller changes.




Step 4: Move a face in a single axis direction.

1. Click and drag on the arrow
pointing up to translate (move)
the selected face up by 30 mm.

Note: When you move a face on a surface the
surrounding faces move to maintain
continuity.

Step 5: Move a face in a planar direction.

1. Click and drag on one of the white
squares to translate the selected face
on a plane parallel to a given plane in
world space.

Note: By default the Edit Form manipulator
uses the World Space coordinates, you can
also use View space (based on the camera
view) and Local space (based on the normal
direction of the surface). These can be
changed in the Coordinate options in Edit
Form.

Step 6: Move a T-Spline edge and vertex.

1. Select asingle edge.

2. Use any of the translate manipulators
to compare the effect.

3. Select a single vertex.

4. Translate this vertex to see how this
creates more subtle changes
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Step 6: Rotation with Edit Form

1. Make sure that at least one face is
selected.

2. Click and drag one of the circular arcs
to rotate the selected geometry about
a single axis.

Note: Be careful not to rotate geometry too
far, as self-intersecting faces, or geometry that
twists through itself will result in not being
able to convert it in to a solid body.

Step 7: Single direction scaling

1. Make sure that at least one face is
selected.

2. Click and drag one of the straight lines
to scale the selected face in one
direction.
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Step 8: Planar scaling

1.

Make sure that at least one face is
selected.

Click and drag one of the small corner
manipulators to scale the selected
face along a plane —or in two
directions.

Step 9: Universal scaling

Make sure that at least one face is
selected.

Click and drag the circular
manipulator at the center of the
manipulator.

Dragging left or right will scale the
geometry in all directions up or down.

Step 10: Extrude a face to add geometry

Select a single face of your T-Spline
form.

With the Edit Form command still
active, hold the alt-option on Mac or
alt key on Windows.

Click and drag the single arrow to add
geometry outward from the selected
face.

Let go of the alt-option/alt key as well
as the left-mouse button.

Select OK to close Edit Form

Note: You can use this hotkey function to
extrude any edge(s) or face(s) that are
selected on a T-Spline form.
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Step 11: Change display mode. When
modeling with T-Splines you have 3 different
display modes to choose from. Changing the
display mode can help you find problem areas
on your model and increase performance by
not having to constantly smooth the T-Spline
shape. For this example we will switch the
display to Box Mode — a polygon version of
the T-Spline form.

1. Select Modify > Performance >
Display Mode to bring up the Display
Mode window

2. Inthe Display Mode window select
Display Mode > Box Display to show a
unsmoothed version of the T-Spline
form.

3. Select Display Mode > Control Frame
Display to see a combination of the
unsmoothed and smoothed versions
of the T-Spline.

4. Select Display Mode > Smooth Display
to go back to the smoothed version.

5. Select Display Mode > Box Display

6. Select OK to close the window

Note: Display mode can also be switch by
using the combination of Control + 1 for Box,
Control +2 for Control Frame and Control + 3
for Smooth on a Mac. Or Alt +1, Alt +2, Alt +3
respectively on a PC. You can also find these
controls in the Selection Options section of
the Edit Form window.

© DISPLAY MODE }
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Step 12: Working in Box Display Mode.

1.

Hold down the right mouse button to
bring up the radial menu.

Select Edit Form in the radial menu
Select a face and hold alt-option/alt
while dragging the blue arrow up to
extrude the face. You will notice that
the performance is faster in Box mode
that in Smooth mode.

Hold control/alt +3 to return to
smooth mode.

Hold down the right mouse button
and select OK from the radial menu to
close the Edit Form window.

Select Finish Form from the menu bar
to go back to the Model workspace.

© EDIT FORM

» (O Object Snap
» O Soft Modification

» Selection Options

» Numerical Inputs

OK Can

Step 13: Add edges to a T-Spline form

7.

10.
11.
12.

Enter the Sculpt workspace by
selecting Create > Create Form.
Create another Box primitive whose
length, width, and height are 100mm,
100mm, and 200mm.

Set the number of length, width, and
height faces equal to 4, 2, and 2.

Click OK.

Click Modify > Insert Edge.
Double-click on one of the middle
edges to select the entire middle loop.

Note: Double clicking on an edge will select
the complete edge loop. Selecting a single
edge inserts an edge to a face on either side of
the selected edge. Selecting an edge loop
adds a second loop.
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Step 14: Adjust the insert location

4.

Click and drag the double arrow to
adjust the position of the inserted
edge.

By hand, or with the text field, set the
Insert Location equal to 0.75.

Change the Insert Side from Single to
Both.

Click OK.

Note: You probably noticed that the shape of
the T-Spline form changed after you inserted
additional edges. The top and the bottom of
the box became sharper by adding more
edges near the existing top and bottom edges.
If you want to insert an edge(s) and not
change the shape of the T-Spline form, change
the Insertion Mode to Exact.
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Cancel
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Step 15: Delete and edge

1.

Select the recently added the upper
edge loop.

Select Modify > Delete or press the
Delete key on your keyboard.
Select Finish Form.
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Lesson 3: Create a T-Spline Form using a reference image

When sculpting a shape with T-Splines it is helpful to have a reference image to guide
you. Reference images can be plan view sketches or photographs that are set in the
background of the workspace to model from. In Fusion 360 you can attach an image to
a work plane and then calibrate the image so that you are modeling in the correct scale.
In this lesson we will use a side view photograph of a utility knife as reference to sculpt a
T-Spline body that will be the outer shape body of the knife.

Learning Objectives

1.

2.
3.
4

Insert and image in to the workspace using Attach Canvas
Use Calibrate to set the proper scale for the reference image
Invoke symmetry when modeling a T-Spline box

Use Insert Point to draw edges on a T-Spline face(s)

Step 1: Attach a canvas

Select Insert > Attached Canvas.
Select the YZ Plane (between the
green and blue axis) to indicate which
plane the image should be attached
to.

In the dialog window, click the Select
Image button and navigate to the
03_UtilityKnife.jpg file.

Step 2: Adjust canvas settings

4.

Note:
the size and scale of the image at this point.
We will adjust the scale using the Calibrate
tool. Calibrating the image ensures that you
are modeling in the correct scale in the
workspace.

If necessary, rotate the canvas 90 pv————
degrees to orient it properly oo et
Lower the opacity to 85. Xpisuce 000 mm

Check the box for Display Through to
ensure that the canvas can be seen
through your T-Spline form.

Click OK.

Vertical Flip

© ADD CANVAS TIPS AND TRICKS

You don’t need to be concerned about
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Step 3: Calibrate the image.

1.

In the Browser, click the drop-down
arrow next to the Canvases folder.
Right-click on UtilityKnife and select
Calibrate.

Click Right on the ViewCube to view
the utility knife from the side.

Click once at the front of the utility
knife.

Click once at the back of the utility
knife.

Enter 180 mm in the length field and
hit enter.

The canvas will scale up accordingly.
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Step 3: Create a box primitive

1.

Click the Create > Create Form icon to
enter the Sculpt workspace.

Click Create > Box.

Select the same side plane (YZ) as the
canvas to specify the plane that the
Box is placed on.

Click once at the origin to specify the
Box's center point.

Move the mouse and click again at the
outer edge of the reference image to
draw its 2D profile.

# 6HYQA G @8
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Step 4: Set box dimensions and add symmetry

1.

Set the Box’s Length, Width, and
Height equal to 175, 35, and 25 mm,
respectively.

Set the number of Length Face equal
to 5, and the width and height faces
equal to 2.

In the dialog window, change the
Symmetry from None to Mirror.
Check the box for Height Symmetry.
Select OK.

© BOX
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Step 5: move faces to the top of the knife

image.

1.

If you are not in the right side view
still, click on the Right side of the
View Cube.

Select Modify > Edit Form.

Select the middle set of faces by
holding the left mouse button and
dragging to the lower right over top of
the faces you want to select.

Using the Planar Translation
manipulator, move the selected faces
to align the top of the T-spline body
with the top of the utility knife image.

| Select vertex, edge or face.

Step 6: move faces to the top of the knife

image.

1.

To align the bottom in this section,
select the bottom face and use the
planar translation and rotate
manipulators.

Repeat the previous 2 steps for the
rest of the T-spline form. It will also be
helpful to use the single-direction
scale manipulator in some cases.

For more controlled editing, try
modifying individual edges.

Select vertex, edge or face. Alt

to extrude
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Step 6: Insert edges to get closer to the knife
shape. Our T-Spline form is starting to
resemble our reference image but there aren’t
enough edges in the T-Spline to capture all the
detail of the Knife.

1. Hold Shift then select the edges
shown at the front of the knife.

2. Click Modify > Insert Edge.

3. Drag the direct manipulator to the
right to position the new edges at an
Insert Location around -0.5.

4. Click OK.

Note: With Symmetry enabled you only need
to select the edges one side of the symmetry
plane, the matching ones on the other side
will be automatically selected also and will be
displayed in yellow.
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Step 7: Insert additional edges with Insert

Edge.

1.

Holding Shift then select the edges
shown at the back of the knife.
Select Modify > Insert Edge.

Drag the direct manipulator to the
right to position the new edges at an
Insert Location around -0.5.

Click OK.

Step 8: Move the inserted edges with Edit

Form.
1.

Use the Edit Form command to
manipulate the recently inserted
edges to achieve the result shown in
the image.

Note: The planar translation manipulator
will be extremely useful.

Step 9: Use Insert Point to draw edges on a
face. To insert the final two edges we need,
we’ll use the Insert Point command. Slightly
different from Insert Edge, the Insert Point
command will easily insert an edge by
connecting two points together.

Click Modify > Insert Point.

Hover over the middle of the top edge
shown until a red circle appears — this
indicates the midpoint

Click and repeat for the edge directly
beneath, located along the line of
symmetry.

Ensure the Insert Mode set to Simple.
Click OK.
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| Select vertex or edge |

Step 10: Use Edit Form to move faces and
edges until you have matched the T-Spline
body to the profile of the Knife image.

1. Use the Edit Form command to
manipulate the recently inserted
edges (as well as the surrounding
geometry) to get the T-Spline
primitive to match as closely as
possible.

2. When you are satisfied with the shape
of the T-Spline body select Finish
Form from the Sculpt Menu bar.
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