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Getting Started
(MANDATORY)Install UCC

(Optional) Install Photon 2 and Enter app id in PUN settings

(Optional) Install UCC Multiplayer

(Optional) Install RCC => (Note: If using earlier version of RCC that does not use
Input System as standard then ignore this) => (MANDATORY) Input System
Package with latest RCC => (MANDATORY) Input System integration package for
UCC

(MANDATORY)Install SeatingController package last
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Layer Setup
If not using RCC and Its layers
Use one of your own layers or add at least one layer, Name it something unique like
“Boardable”. The Demo Scenes use layer 20: Boardable.

PRO TIP: For fast setup use Tools > FST > Seating Controller Manager > Add
Boardable Layer (20)

All BoardSources should use this new layer.

ProjectSettings > Physics > CollisionMatrix > Ignore all collision between new layer/s
and Character, SubCharacter, Overlay, VisualEffect and UI.

PRO TIP: For fast setup use Tools > FST > Seating Controller Manager > Update
Collision Matrix

On character set SolidObjectLayers to include Boardable/YourOwn layer

CharacterLayerManager > SolidObjectLayers > Add Boardable/YourOwn layer

NOTE: will also work with vehicles set to "Default" layer out of the box, not
preferrable for performance reasons.

If using RCC and its layers
ProjectSettings > Physics > CollisionMatrix > Ignore all collision between all RCC
layers and Character, SubCharacter, Overlay, VisualEffect and UI.

PRO TIP: For fast setup use Tools > FST > Seating Controller Manager > Update
Collision Matrix

On character set SolidObjectLayers to include RCC layer

CharacterLayerManager > SolidObjectLayers > Add RCC layer
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Input Setup
If using standard input
Tools > FST > Seating Controller Manager > Update Input Manager

OR

Create your own inputs and change the inputs to whatever you created on the Board
Ability Component when adding it to the character

NOTE: Default Input Names are "Equip Next Seat" and "Equip Previous Seat".
Default keys are numpad + and numpad -

If using input system
First, ensure your project is setup for input system.

Make sure you have the UCC input system integration installed.

Make sure you have input settings created in the project manager.

Add your seat inputs to input system, name them "Equip Next Seat" and "Equip
Previous Seat" for simplicity, or optionally create your own inputs and change the
inputs to whatever you like on the Board Ability Component

NOTE: Default Input Names are "Equip Next Seat" and "Equip Previous Seat".
Default keys are numpad + and numpad -
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Camera Setup
Ensure that the required ViewType’s have been added.

VehicleWeapon(First Person), VehicleWeapon(Third Person), Adventure and
FreeLook are essential if using both third and first person.

VehicleWeapon(First Person) and Freelook are required for First Person

VehicleWeapon(Third Person) and Adventure are required for Third Person

Add the State Presets that you will be using, see the Demo Scene for an example.

NOTE: I have included a set of presets that will get you started for most situations,
you can see how they are applied in the demo scenes.
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Setup Character to interact with a BoardSource
UPDATE: you can now easily setup your character within the Ultimate Character
Controller AddOn Manager, and save doing the following.

If not using the Add On Manager to setup your ability then...

Add Board Ability to character

Add BoardDemo Animator Controller to your character, or modify your animator to
match the BoardDemo animator where required.

PRO TIP: You can click on Build Animator in the ability inspector after you have
added the ability to build the animator for you.

Add state presets to character(whichever components you will affect(ik, thirdperson
objects etc)

NOTE: I have included a set of presets that will get you started for most situations,
you can see how they are applied in the demo scenes.

Ability Settings

OffsetY
For different characters you can set this value to set the character into correct
position. Saves changing seat reference positions.

Input Change Seat Forward
The name of the input that allows changing seats forwards.

NOTE: Default is "Equip Next Seat". Default key is numpad +

Input Change Seat Backward
The name of the input that allows changing seats backwards.

NOTE: Default is "Equip Previous Seat". Default key is numpad -

Auto Arms Setup
Now can also be done on a per seat basis via Hide First Person Arms seat property.
This option will force third person arms visible when in first person view and a) seat
Type is Driver or b) seat has Controllable Vehicle Weapons or c) the seat Allowed
Slot Mask allows no items.
This can be achieved with state presets but is tedious to setup all the objects,
suggested to have this true.

IMPORTANT: If you are using ucc first person controller only and you want the arms
visible you must set the “Visible Materials” on the relative “Third Person Object”
Component. In the demo scene this is handled under the hood upon install to give
you an example of the setup.
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Setup an object for use with Board ability
Quick Setup
Tools > FST > Seating Controller Manager

Drop or Select Gameobject in the Object to Setup field

Click Setup Object

OR

Add BoardSource component to vehicle

Add MoveTowards object/s and an ObjectIdentifier component and enter 14 for the
ID, as you would for drive.

Vehicles in demo scene will show different types of setups.

NOTE: Bake navmesh in OfflineDemo scene for rcc AI to work (can takeover ai cars
like in gta).

Setup Animator on vehicle if need left and right door animations

See “Setting up an animator for a BoardSource”

For IK
Use empty gameobjects with an AbilityIKTarget component to set the desired
positions. If they are not child of seat then set the root in the seat, eg hands to
steering wheel > steering wheel is root.

Pro Tip:
Naming conventions matter! Here’s what the asset uses for quick setup if you like
speedy setup.

For seats - The tool will search for names containing “Seat/seat” and “Driver/driver,
Passenger/passenger, Gunner/gunner” respectively. It will add the seats to the
component and prefill the Name, Type and Seat Position fields.

Example “DriverSeat”, “PassengerSeat”, “GunnerSeat”

It will also search for “Feet/feet” and “Hand/hand” combined with “Root/root”

Example “HandIkRoot”, “FeetIkRoot”

It will also search for ”FirstPersonCamPos/FirstPersonCameraPos/
FirstPersonCameraPosition” if added for vehicle weapons.

Attack Colliders are also found and added, It will search for “Attack/attack” combined
with ”Collider/collider”. Additionally it will find “Left/left”, “Right/right”, ”Front/front”,
“Rear/rear”. If none of these are found it cannot determine how you would like it
setup so it’ll show you a handly little window to assist the setup in a speedy manner.
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Base BoardSource Settings
Restore Perspective
Used for restoring perspective to the perspective that was used upon boarding. If the
seat cannot change views, this has no effect.

Instant Entry
Makes teleporting even faster by instantly unequipping items.

Instant Exit
Makes teleporting even faster by instantly equipping items.

Dont Destroy On Load
If the BoardSource GameObject should stay alive between scenes enable this.

Disable On Death
If using the Heath Component you can enable it there, this is just a handy bool to
save going to the Health Component.

Death Prefabs
Any prefabs you wish spawned upon death should added here, unless using the
health component to do so.

Insta Kill Players On Death
If enabled all players will be instantly killed when the BoardSource is out of Health.

If disabled then the players will be ejected only, it’s possible that explosion could kill
them then or they may survive.

Animator ID
Refer to UltimateCharacterController Drive Documentation

Attack Threshold
The BoardSource must be above this speed to make use of any Attack Colliders

NOTE: Requires RigidBody on root object

Front Attack Colliders
Colliders can be added here (imagine invisible bullbar). Any Colliders in this array will
become active to kill UltimateCharacterControllers upon contact, only if the
BoardSource speed is above the Attack Threshold

NOTE: Requires RigidBody on root object
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Side Attack Colliders
As above but for sideways speed

Rear Attack Colliders
As per front attack colliders, but for when speed is negative

Disable Colliders
Optionally add any colliders here that should be disabled when player boards. They
will be re-enabled when player disembarks the BoardSource

Far Clip Plane
Adjusts the camera far clip plane, useful for aircraft etc. -1 for no override.

Seats
Where the magic happens. Add seats players can utilise here. See next page for per
seat settings.
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Per Seat Settings
Name
You can set any name for the seat here for your own reference, this is entirely
optional.

Type
There is three main types of seat to choose from.

Driver

Has control of the vehicle and will be considered the owner online. If has vehicle
weapons, can also use them. If no vehicle weapons and allowed equipped slot mask
allows, character can use items from inventory.

Passenger

If has vehicle weapons, can use them. If no vehicle weapons and allowed equipped
slot mask allows, character can use items from inventory.

TODO: will be possible to walk around designated areas of vehicle(eg back of truck)
and not allow vehicle weapons OR allow one vehicle weapon and one inventory slot.

Gunner

If has vehicle weapons, can use them. If no vehicle weapons and allowed equipped
slot mask allows, character can use items from inventory.

Seat Position
GameObject attached to the BoardSource GameObject defining where the character
position will be when seated in this seat. The character will be parented to the Seat
Position GameObject.

Affect Third Person Cam Limits
Only used when not using any Override State.

Cam Limits
Only used when not using any Override State.

Field Of View
Overrides the camera field of view, -1 for no override. Only used when not using any
Override State
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Hand IK Links Root
A reference to the root Transform of the Hand Ability IK Targets. Useful for steering
wheels, handlebars, vehicle weapons etc.

NOTE: If Hand Ability IK Targets are child of seat GameObject then it is not
necessary to set this reference.

Feet IK Links Root
A reference to the root Transform of the Feet Ability IK Targets. Useful for pedals,
pegs, vehicle weapons etc.

NOTE: If Feet Ability IK Targets are child of seat GameObject then it is not
necessary to set this reference.

Force Independent Look
Useful to allow or restrict character rotations. Recommended to leave set to true.

Use Car Camera Controller
True to use RCC Camera while in the seat, else will use UCC camera

Can Change Perspective
Can the player change view perspectives while in this seat?

Hide First Person Arms
This option will force third person arms visible when in first person view.
Useful for showing arms while driving, shooting from a window or operating a
manned weapon etc.
This can be achieved with state presets but is tedious to setup all the objects,
suggested to have this true unless character can openly fire a weapon like on the
back of the quadbike.

Teleport To Seat
Set this true to have character snap to seat, false to use animated entry/exit from this
seat

Can Aim
Can the player aim while in this seat?

Visible Player
Should the character be visible while in this seat?
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Invincible Player (only available if Visible Player is true)
Should the player be invincible? If false the player can take damage while on board a
BoardSource and in this seat.

NOTE: If the character is invisible this will be true as naturally it should be. The option
will be hidden.

Override State
Optionally enter the name of the State that should be set when in this seat. Useful for
different IK and Camera setups etc.

Append View State
This option is available if Can Change Perspective is true. Useful for alternative
crosshair management.

Append Aim State
This option is available if Can Aim is true. Useful for zooming with vehicle weapons.

Components To Enable
Any components that should be enabled while character is in this seat.

Components To Disable
Any components that should be disabled while character is this seat.

Controllable Vehicle Weapons
Add VehicleWeaponShooters here, and enter input names they will use.(“Fire1”
“Fire2” are standard)

NOTE: If using character item setups with ShootableWeapon components, then the
characters Use Ability determines input as per character inventory items.

If first person perspective will be available, First Person Cam Pos CANNOT BE
EMPTY in the seat that uses this weapon.

NOTE: See page 19 for VehicleWeaponShooter documentation

Use Camera Pivot
If there is no vehicle weapons for the seat, there is still the option to use a custom
camera pivot. This will force the VehicleWeaponViewTypes active.

Camera Pivot
The reference GameObject for the camera position and rotation for seats with
VehicleWeapons or when using a custom camera pivot.
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Allow Equipped Items
Slots

Which slots are allowed to be equipped from the inventory?

Allow Item Definitons

Optionally only allow items specified in this array.
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Vehicle Weapon Shooter

This component delivers a way to shoot weapons attached to a vehicle eg. Tanks.

Weapons do not need animations as I have included a system that can simulate the
mechanics of the weapons.

If first person perspective will be available, Camera Pivot CANNOT BE EMPTY in the
seat that uses this weapon.

The main settings all replicate ucc shootable weapon settings combined with all of
the extra settings required (like found in usable item, third and first person properties
components on a UCC setup character weapon).

Grenades can also be launched. Just add as per projectile.

NOTE: Vehicle Weapon Shooters that fire grenades should have the “Minor Item
Setup” or no item and pickup at all. If using character item setups with
ShootableWeapon components, then the grenade should not be used and a warning
will prompt you to remove them upon equipping the item.

Objects To Rotate
Please ensure all origins are correctly aligned in your models, else make an empty
gameobject that will act as a pivot, I have included a demonstration of this on the
tank. Also, if using two or more weapons that will rotate, and they are parent child
setups, then only setup the Objects To Rotate on the parent.

Each Object To Rotate has some settings as follows.

Object To Rotate
The object that will be rotated towards the player look direction.

Input Axis
Which input should drive the object rotation when in first person view.

Axis To Rotate Around
Which axis should the object rotate around when in first person view.

Limit Min Max Angle
Limit the rotation here.

Smooth
This affects the speed of rotation.
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VehicleWeaponShooter Extra Settings
Pickup
You can create items to “pickup” when player enters the seat that makes use of this
vehicle weapon shooter. Currently this allows you to have UI crosshairs and Icons
very easily, much the same as any item is setup. This can also be further extended to
add ammo count etc to vehicles and have them reloadable by option “See Item
Setup for use with Vehicle Weapon Shooters on the following page”.

The Pickups should be a child of the BoardSource and the Pickup GameObject
should be disabled.

In the demo these items are designed as runtime pickups and items have been
assigned as runtime pickup prefabs in the character Inventory component. Items can
also be created on the character if you prefer that method.

Slot ID
Is which slot the item should equip to

Fire Force
How much force to apply to the object that is firing (if it has a rigidbody). Perfect for a
Tank Blast!

Add Object Velocity To Projectile
Should the BoardSource rigidbody velocity be added to the projectile?

Use First Person Layers
Should the renderers attached to the weapon be changed to Overlay when in First
Person perspective?

Attributes
Attributes are not an extra compared to Shootable Weapon except the Attribute
Monitor field but deserve a little explanation.

Atrributes can be used for item or character. If for item, then ensure you add the
Attribute Monitor it will use to the Vehicle Weapon Shooter Animator Monitor field
under the “Attributes” foldout. The Demo scene has an example use case for
“overheating” weapons.

Use Attribute will not display in the editor unless an Attribute Manager component is
attached to the Vehicle Weapon Shooter GameObject.

Projectile Safety Distance
When the projectile is spawned, if it will collide with the firing weapons BoardSource
then it will be moved this far forward.

NOTE: Has no effect on Major Item Setups.
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Projectile Safety Radius
The cast radius for collsion checks between the BoardSouce and the projectile that
will be fired.

NOTE: Has no effect on Major Item Setups.
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Item Setup for use with Vehicle Weapon
Shooters

No Item Setup
Vehicle Weapon Shooters can be used without any pickup, or character item.

The Vehicle Weapon Shooter Pickup field should be null. You will then get some
extra options for the full screen ui, crosshairs and item icon.

Pro Tip: Use attribute for a cooldown for overheat.

Minor Item Setup
Vehicle Weapon Shooters can be used with a pickup, and character item. The
minimal setup is best used when you only want an Icon and Crosshairs displayed
and there is no ammunition requirements. The character Item should only contain
Item components, no ShootableWeapon components.

NOTE: Yuo can now set crosshairs, full screen UI and icon directly in the
VehicleWeaponShooter component, therefore this setup has become obsolete. Its
much easier and faster to setup without using any character item.

Pro Tip: Use attribute for a cooldown for overheat.
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Major Item Setup
Full UCC character Shootable Weapon system, best used when there is requirement
for ammunition consumption and reload functionality.

As per Minimal Item setup except with Shootable Weapon components.

Pro Tip: Use attribute for a cooldown for overheat, yes you still can combine
attributes.
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For Minor Item and Major Item Setups
The Item has two fields that need to be set with a dummy prefab, they are First
Person Perspective Item > Render > Visible Item, and Third Person Perspective Item
> Render > Object. See Images on next page.

Also be sure to define the Item Sets in the character’s Item Set Manager or on the
Pickup. Standard procedure for a UCC item.

Please see Character Item GameObject Structure on the next page...
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Character Item Object Structure

Root GameObject

First Person GameObject
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Third Person GameObject
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Parachute
Included is a Parachute ability, along with a gunship example you can parachute
from. The Start Type and Stop Type should be set to Automatic.

The following fields are specific to Parachute ability.

Parachute GameObject
The GameObject that represents the visual transform of the parachute, can be
attached to root of player or a prefab to spawn.

Unequip When No Chute
If the bool is true, then weapons are only equipped whilst the parachute is depoyed.
If the bool is false the player can equip throughout all states during the fall.

Pickup On Board
Should a parachute be picked up when board is triggered. Lots of games use this
feature.

Requires Pickup
Does a parachute need to be picked up to be able to use the ability?

Is Single Use
Can the parachute be deployed more than once during a single fall? (useful if cord is
cut)

Min Deploy Altitude
The ability cannot start below this altitude.

Deploy Input
Any inputs in this array can deploy the parachute. Demo uses “Action”.

Cut Cord Input
Any inputs in this array can cut the parachute cord and resume the characters fall.
Demo uses “Crouch”.

Auto Start Altitude
The parachute can be auto deployed at or below this altitude. -1 to never
automatically deploy by altitude.

Auto Deploy Delay
The parachute can automatically deploy after a set delay. -1 to never automatically
deploy by delay.
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Pitch Force
The forwards force to be added when pitching forwards while the parachute is
deployed.

Roll Gravity Modifier
The multiplier for roll affecting gravity while the parachute is deployed.

Max Gravity Effect
The base gravity which determines fall rate while the parachute is deployed.

Gravity Transition Speed
The gravity transition speed when deploying the parachute, more for more snappy,
less for more smooth.

Parachute Root Bone
The root bone Transform of the parachute GameObject, should be located at the
harness location.

Parachute Root Bone Object ID
The root bone ObjectID of the parachute, for use at runtime when Parachute
GameObject is spawned.

Attach Point Bone
The character bone the Parachute Root Bone should attach to.

Altitude Text
Optional UI text to display altitude and rate of descent.

Is Wind Affected
Can Unity Wind affect the behaviour?

Skydive Wind Multiplier
How much the Unity Wind will affect the behaviour while in a skydiving state.

Parachute Wind Multiplier
How much the Unity Wind will affect the behaviour while the parachute is deployed.

Skydive Move Force
How much input can steer while skydiving.
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Auto Start Delay
The ability can automatically start after a set delay if the character has left the
ground. -1 to never automatically start by delay.

Auto Stop Delay
Upon landing the ability will stop after this delay.

Chute Disable Delay
The parachute GameObject will disable after this delay.

Auto Start Block Duration
The duration that ANY automatic starts should be blocked. -1 to never block
automatic starts.

Start Landing Altitude
When the character reaches this altitude it will go into a landing state which realigns
the character to the gravity direction.

Early Death Prevention Hieght
The character can cheat death if they cut the cord below this altitude.

Jump Force
Jump force that will be applied when the character leaves a ledge that is higher than
the Min Deploy Altitude.

Ambient Forward Force
While the parachute is deployed this much ambient forward force will be applied.

Rotation Speed
The speed at which pitch and roll character rotations will be applied while the
parachute is deployed.

Max Forward Pitch
The maximum amount the character can pitch forwards while the parachute is
deployed.

Max Backward Pitch
The maximum amount the character can pitch backwards while the parachute is
deployed.

Pitch Gravity Multiplier
The multiplier for pitch affecting gravity while the parachute is deployed.
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Max Roll
The maximum amount of roll that can be applied while the parachute is deployed.

Roll Force
The sideways force to be added when rolling while the parachute is deployed.
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Integrate with Crest
Note: UCC Swimming Addon Pack required (also UCC requires the Agility Pack
Addon for Swimming Pack)

You can easily use UCC + USC + Crest, No coding required, A perfect exmple is the
submarine, as it can go beneath the water this shows how to setup for swimming
also.

Open the UCC Main Manager, Setup Scene as per normal.

Setup your character, ensuring you have the swim and board ability added.

Simply open the USC Manager or UCC Addons Manager and setup the Submarine
Gameobject (found in the Crest Submarine demo scene) as you normally would via
quick setup (leave all default values for the driver seat).

In the driver seat section add the Submarine Component and the Submarine Camera
Component to Components To Enable array. Optionally you can just remove the
submarine camera entirely if using another camera or remove that component from
the Submarine GameObject if you setup that camera with UCC.

Add the Crest Simple Floating Object component to the Submarine GameObject.
Then add the freshly added component to the driver seat Components To Enable
array.

Within the Ultimate Character Locomotion Component Abilities section, ensure that
the MoveTowards Ability is at the top, followed by the Board Ability.

Add a box collider with the layer set to water and Is Trigger set to true. Scale it to size
you wish to play in.

Press play, its good to go.

NOTE: You can also use the Custom Water Height and the relative component to
have your character float with the waves.
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Multiplayer
The BoardSource must have a BoardSourcePun component.

The VehicleWeaponShooters must have a VehicleWeaponShooterPun component.

The above can be setup fast using the Seating Controller Manager (Tools>
FastSkillTeam> Seating Controller Manager)

IMPORTANT NOTE:
The UCC Multiplayer addon sometimes encounters a bug when firing projectiles at a
fast rate. And now that this asset makes use of the PunObjectPool you may
encounter it. Don’t worry the fix is easy.

This fix has been passed on to Justin and will be included in the next UCC update. To
fix this bug simply insert this line in the PunObjectPool script at line 118...
if (!m_ActiveGameObjects.ContainsKey(instanceObject))//hot fix >FastSkillTeam

Note: For Multiplayer Demo scene you are expected to know how to use UCC to
create a multiplayer character, you can simply copy the character from offline demo
and add the multiplayer components with UCC add on manager. The only thing the
character needs added is the Board ability if you are creating from scratch.

Once you have created your prefab for multiplayer you can add it to the
SingleCharacterSpawnManager Component attached to the “PunGame”
GameObject in the multiplayer demo scene.

The inspector for the PunGame GameObject should look something like this
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Setting up an animator for a BoardSource
Currently I have added support to open left/right door and enter from respective door.

I will be adding support for more than two doors soon, and it will be unlimited.
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Event System
The following events can be registered to. See Ultimate Character Controller
documentation to familiarise yourself with the Event System.

BoardSource Events
• EventHandler.ExecuteEvent<int>(m_GameObject, "OnSetOwner", actorNumber);

• EventHandler.ExecuteEvent<GameObject, bool, bool>(m_GameObject,
"OnEnablePlayerCollision", character, enable, transmit);

• EventHandler.ExecuteEvent<bool>(m_GameObject, "OnOpenCloseDoor",
board.IsOnLeft);

• EventHandler.ExecuteEvent<int>(m_GameObject, "OnTryAddPlayerToList",
actorNumber);

• EventHandler.ExecuteEvent<int>(m_GameObject,
"OnTryRemovePlayerFromList", actorNumber);

• EventHandler.ExecuteEvent<int, bool>(m_GameObject, "OnSetTeamOwner",
teamNumber, transmit);

• EventHandler.ExecuteEvent<GameObject, bool>(m_GameObject,
"OnEnableDisableUCCIK", character, enable);

Board Events
• EventHandler.ExecuteEvent<bool>(m_GameObject, "Board", true);

• EventHandler.ExecuteEvent<GameObject, int, bool, int,
bool>(m_BoardSource.GameObject, "OnSetSeat", m_GameObject, seatIndex,
seatActive, actorNumber, transmit);

• EventHandler.ExecuteEvent<bool>(m_GameObject, "Board", false);
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Tutorial Links
Basic Character and Vehicle Setup
https://youtu.be/wiBkLwvyBKM

Basic Tank Setup
https://youtu.be/-FwJBKTRPqU

Adding UI to the Tank
https://youtu.be/aagGvMV0DZs
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