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4. Header and Footer 

4.1How to add header in Excel 

Inserting a header in an Excel worksheet is quite easy. Here's what you do: 

1. Go to the Insert tab > Text group and click the Header & Footer button. This will switch the worksheet to Page 
Layout view. 

 

2. Now, you can type text, insert a picture, add a preset header in any of the three Header boxes at the top of 
the page. By default, the central box is selected: 

 
If you wish the header to appear in the top left or top right corner of the page, click the left or right box and 
enter some information there. 

3. When finished, click anywhere in the worksheet to leave the header area. To exit the header box without 
keeping the changes, press Esc. 

When you print out your worksheet, the header will be repeated on each page. 

4.2How to insert footer in Excel 

Like an Excel header, a footer can also be inserted in a few easy steps: 

1. On the Insert tab, in the Text group and click the Header & Footer button. 

2. On the Design tab, click Go to Footer or scroll down to the footer boxes at the bottom of the page. 

 

3. Depending on the desired location, click the left, center, or right footer box, and type some text or insert the 
element you want. When done, click anywhere in the worksheet to exit the footer area. 
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For example, to insert page numbers at the bottom of the worksheet, select one of the footer boxes and click Page 

Number on the Design tab, in the Header & Footer group. 

 

4.3How to add a preset header and footer in Excel 

Microsoft Excel comes equipped with a number of inbuilt headers and footers that can be inserted in your 

document in a mouse click. Here's how: 

1. On the Insert tab, in the Text group, click Header & Footer. This will display the worksheet in Page Layout 
view and get the Design tab to appear. 

2. On the Design tab, in the Header & Footer group, click the Header or Footer button, and select the built-in 
header or footer of your choosing. 
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As an example, let's insert a footer that displays a page number and file name: 

 

Voila, our Excel footer is created, and the following information will be printed at the bottom of each page: 

 

4.4Two things you should know about preset headers and footers 

When inserting an inbuilt header or footer in Excel, please be aware of the following caveats. 

4.5Preset headers and footers are dynamic 

Most of the preset headers and footers in Excel are entered as codes, which makes them dynamic - meaning your 

header or footer will change to reflect the latest changes you make to the worksheet. 

For example, the code &[Page] inserts different page numbers on each page and &[File] displays the current file 

name. To see the codes, just click the corresponding header or footer text box. If you have chosen to add a 
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complex header or footer, chances are that different elements will be inserted in different boxes like in the above 

example: 

 

4.6Preset headers and footers are inserted in predefined boxes 

When adding a built-in header or footer, you cannot control the location of specific elements - they are inserted in 

the predefined boxes no matter which box (left, center, or right) is currently selected. To position the header or 

footer the way you want, you can move the inserted elements to other boxes by copying / pasting their codes or 

add each element individually as explained in the next section. 

4.7How to make a custom header or footer in Excel 

In Excel worksheets, not only can you add preset headers and footers, but also make your own ones with custom 

text and images. 

As usual, you start by clicking the Header & Footer button on the Insert tab. Then, click one of the boxes at the 

top (header) or at the bottom (footer) of the worksheet and type your text there. You can also enter different pieces 

of information by selecting one of the built-in elements on the Design tab, in the Header & Footer Elements group. 

This example will show you how to create a custom header with your company logo, page numbers, file name 

and current date. 

1. To begin with, let's insert File Name (workbook name) in the central header box: 
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2. Then, select the right box and insert Page Number there. As you can see in the screenshot below, this only 
displays the number: 

 
If you want the word "Page" to appear as well, click anywhere in the right text box, and type "Page" in front of 
the code, separating the word and the code with a space character like this: 

 

3. Additionally, you can insert the Number of Pages element in the same box by clicking on the corresponding 
button on the ribbon, and then type "of" in between the codes so that your Excel header displays something 
like "Page 1 of 3": 

 

4. Finally, let's insert the company logo in the left box. For this, click the Picture button, browse for the image file, 
and click Insert. The &[Picture] code will be inserted in the header straight away: 

 

As soon as you click anywhere outside the header box, an actual picture will show up. 

Our custom Excel header looks pretty nice, don't you think? 

 

Tips: 
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• To start a new line in a header or footer box, press the Enter key. 

• To include an ampersand (&) in the text, type two ampersand characters without spaces. For example, to 
include Products & Services in the header or footer, you type Products && Services. 

• To add page numbers to Excel headers and footers, insert the &[Page] code in combination with any text you 
want. For this, use the built-in Page Number element or one of the preset headers and footers. If you enter the 
numbers manually, you will end up having the same number on each page. 

4.8Add headers and footers using the Page Setup dialog box 

If case you'd like to create a header or footer for chart sheets or for several worksheets at a time, the Page 

Setup dialog box is your option. 

1. Select one or more worksheets for which you'd like to make a header or footer. To select multiple sheets, hold 
down the Ctrl key while clicking the sheet tabs. 

2. Go to the Page Layout tab > Page Setup group and click the Dialog Box Launcher. 

 

3. The Page Setup dialog box will show up where you can select one of the preset headers and footers or make 
your own one. 
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To insert a preset one, click the drop-down arrow in the Header or Footer box and choose from the available 

options. For example: 

 

To create a custom header or footer, do the following: 

• Click the Custom Header… or Custom Footer… button. 

• Select the left, center or right section box, and then click one of the buttons above the sections. To find out exactly 
what element a particular button inserts, hover over it to display a tooltip. 
For example, this is how you can add a page number to the right hand side of your Excel header: 
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You can also type your own text in any section as well as edit or remove the existing text or codes. 

• When finished, click OK. 

Tip. To see how your header or footer will look like on a printed page, click the Print Preview button. 

4.9How to edit header and footer in Excel 

There are two ways to edit headers and footers in Excel - in Page Layout view and by using Page Setup dialog. 

4.10Change header or footer in Page Layout view 

To switch to Page Layout view, go to the View tab > Workbook Views group, and click Page Layout. 

 

Or, click the Page Layout button on the status bar in the bottom-right corner of the worksheet: 

 

Now, you select the header or footer text box and make the desired changes. 



 

 

12 

 

4.11Change header or footer in the Page Setup dialog 

Another way to modify an Excel footer or header is by using the Page Setup dialog box. Please remember that a 

header and footer of chart sheets can only be edited in this way. 

4.12How to close header and footer in Excel 

Once you have finished creating or editing your Excel footer or header, how do you get out of the header and 

footer view and return to the regular view? By doing any of the following: 

On the View tab > Workbook Views group, click Normal. 

 

Or, just click the Normal button on the status bar. 

 

4.13How to remove header and footer in Excel 

To remove an individual header or footer, simply switch to Page Layout view, click the header or footer text box, 

and press the Delete or Backspace key. 

To delete headers and footers from multiple worksheets at once, carry out these steps: 

1. Select the worksheets from which you want to remove a header or footer. 

2. Open the Page Setup dialog box (Page Layout tab > Page Setup group > Dialog Box Launcher). 

3. In the Page Setup dialog box, click the drop-down arrow to open the list of preset headers or footers, and 
select (none). 

4. Click OK to close the dialog box. 
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That's it! All headers and footers in the selected sheets will be removed. 

4.14Excel header and footer tips and tricks 

Now that you know the essentials of Excel headers and footers, the below tips may help you avoid common 

challenges. 

4.15How to add header and footer to all or selected sheets in Excel 

To insert headers or footers on multiple worksheets at a time, select all target sheets, and then add a header or 

footer in the usual way. 

• To select multiple adjacent worksheet, click the tab of the first sheet, hold down the Shift key, and click the tab of 
the last sheet. 

• To select multiple non-adjacent sheets, hold down the Ctrl key while clicking the sheet tabs individually. 

• To select all worksheets, right-click any sheet tab, and choose Select All Sheets from the context menu. 

Once the worksheets are selected, go to the Insert tab > Text group > Header & Footer and enter the header or 

footer information as you like. Or insert a header/footer via the Page Setup dialog. 

When finished, right click any unselected sheet to ungroup the worksheets. If all of the sheets are selected, click 

any sheet tab, and then click Ungroup Sheets in the context menu. 
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4.16How to format text in Excel header and footer 

To quickly change the font style or font color of your header or footer, select the text and pick the desired formatting 

option in the pop-up window: 

 

Alternatively, select the header or footer text you want to change, head to the Home tab > Font group and select 

the formatting options you want. 

4.17How to make a different header or footer for the first page 

If you'd like to insert a specific header or footer on the first page of your worksheet, you can have it done in this 

way: 

1. Change to Page Layout View. 

2. Select the header or footer. 

3. Go to the Design tab, and check the Different First Page box. 

4. Set up a special header or footer for the first page. 

 

Tip. If you want to create separate headers or footers for odd and even pages, select the Different Odd & Even 

Pages box, and enter different information on page 1 and page 2. 

4.18How avoid resizing the header / footer text when scaling the worksheet for printing 

To keep the font size of the header or footer text intact when the worksheet is scaled for printing, switch to Page 

Layout view, select the header or footer, go to the Design tab and clear the Scale with Document box. 
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If you leave this checkbox selected, the header and footer font will scale with the worksheet. For example, the 

header text will become smaller when you select the Fit Sheet on One Page printing option. 

 


