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IMPORTANT NOTICE: 
YOUR USE OF THESE MATERIALS SHALL BE DEEMED TO CONSTITUTE YOUR AGREEMENT 
THAT SUCH USE SHALL BE GOVERNED BY THE PROVISIONS OF YOUR AGREEMENT WITH 

REALPAGE, INC. OR ITS SUBSIDIARY (THE “AGREEMENT”). 
 

 

 Notification 

 All documentation, source programs, object programs, procedures, and any other 
material supplied in connection therewith (“Materials”) remain the exclusive property of 
RealPage, Inc., an affiliate of RealPage, Inc., or, in certain cases, its licensees. This 
document and the Materials are confidential and proprietary information of RealPage, 
Inc., its affiliates, or, in certain cases, its licensees. The Materials may not be copied, 
distributed, or otherwise disclosed, and may not be used in any way unless expressly 
authorized by RealPage. Any copying, distribution, or use of such Materials not 
specifically authorized by the Agreement shall be deemed a violation of the Agreement. 
Such a violation will terminate the licensee’s right to use such Material. This notification 
constitutes part of the documentation and accordingly may not be removed therefrom. 

 

 

© 2013 RealPage, Inc. All rights reserved. 
Printed in the United States of America 

All other brands and product names are trademarks or  
registered trademarks of their respective owners. 

 

 
 
 
 
 
 
 
 
This settings guide includes page images from RealPage WelcomeHome as 
they would be viewed by the resident. You are directed from these images of 
the WelcomeHome pages to the setup pages and options where you 
customize and maintain the look and information you want to appear on the 
WelcomeHome pages.  
 

Please note that setup options are found in diverse areas of the RealPage 
products. Some settings are in Leasing & Rents, some in CrossFire, and some 
are in Facilities. This settings guide is meant to direct you to the appropriate 
areas and settings that allow you to control the appearance and behavior of 
your WelcomeHome site.  

 

If you cannot find the information you need in this guide, please contact 
Welcome Home Implementation Team.  
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Prerequisites 
In addition to the WelcomeHome product center, the following centers will need 
to be enabled for a full implementation of all WelcomeHome features: 

• Concierge 
• Crossfire Residents 
• Crossfire Online Renewals 
• Crossfire Service Requests 
• Document Management 
• Facilities 
• Leasing & Rents 
• Payments 3.x 
• Property 

Roles and Rights 
You will need the role of Content Viewer to be able to change some 
WelcomeHome settings. If you do not have that role, assign the right of View 
property web site data to your existing role so that you can edit 
WelcomeHome settings. 
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SIGN-ON page 

 

The WelcomeHome SIGN-ON page greeting can be customized. The SIGN-ON 
page asks residents to register if they don’t have a user name, and provides a link 
if they have forgotten their password. WelcomeHome users (residents, 
applicants, past residents) can access features you give them permission to 
access on their Resident profile tab. The setup options for the SIGN-ON page are 
found in the following areas: 

Page 
Element 

Setup Information 

Greeting CrossFire → Portal sign-on requirements → Login page 
The greeting is set up on the Portal sign-on requirements page in 
the Login page text field.  

User 
Name, 
Password  

OneSite → Residents →Contact → Edit → Resident profile 
For residents who walk into the leasing office, you can set up user 
names and passwords in Leasing & Rents on the Resident profile 
tab. Residents are notified by e-mail of the user name/password 
you set up for them. WelcomeHome users can change their 
password from WelcomeHome–My Profile page. 
Applicants and residents can also create their own user 
name/password at the end of an Online Leasing application, and 
just by accessing the WelcomeHome site. The user 
name/password is set up automatically by the system. As long as 
an individual is associated with a specific unit at the property, the 
individual can have a user name/password for WelcomeHome. 
You can cancel their access on their Resident profile tab by 
selecting the features they can access on WelcomeHome. 

Forgotten 
Password 

CrossFire → Portal users → Find resident → Reset password 
—OR— 

Leasing & Rents → Residents → Resident profile → Reset password 
When a resident clicks Click here, they are asked for their e-mail 
address. After they enter it, a message says they’ll be receiving a new, 
temporary password at that e-mail address in a few moments. You can 
also change the residents’ passwords for them from the Resident profile 
tab on the Resident at a glance page, or through the Portal users page 
in CrossFire. 

Register 
Now 

CrossFire → Portal sign-on requirements → Terms & conditions 
The first time residents access WelcomeHome, they must click 
the Register button to open a page where they can create a user 
name. You receive e-mail notification of their registration at the 
e-mail address you set up in the Office e-mail field on the Portal 
content page of CrossFire. You receive e-mail notification of their 
registration so that you can go into their Resident profile tab and 
grant them access to WelcomeHome features.  

Figure 1: SIGN-ON page 

Policy is uploaded during implementation; no setup required. 

Created during implementation; no setup available.  
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DASHBOARD page 

 

When residents sign on to WelcomeHome, the DASHBOARD page opens. All 
the information displayed on the DASHBOARD page is setup for other 
WelcomeHome pages, as follows:  

Page Element Source of information in WelcomeHome: 
Logo CrossFire → Web site setup → Home page → Logo 

Your property logo is set up on the Home page page of 
web site setup, in the Logo field.  

Notification Center 
and Dashboard 
page 

All the information on the DASHBOARD page comes 
from other WelcomeHome pages and setup options. 
The Notification Center presents residents with the 
most current information about their apartment. This 
information changes dynamically.  

Account Snapshot The information displayed in the Account Snapshot 
comes from the Payments tab of the MY APARTMENT 
page. Setup information for the MY APARTMENT page 
is on page 7. 

Build Your Profile The information displayed in Build Your Profile comes 
from the MY PROFILE page. Setup information for the 
MY APARTMENT page is on page 25. The “nn% 
complete” changes as the resident adds a payment 
account, sets up recurring payments, adds emergency 
contact information, adds vehicles and so forth, until it 
reaches 100%. Until the profile is complete, this area 
provides links to items that remain to be completed on 
the MY PROFILE page.  

Community 
Calendar 

The information in the Community Calendar comes 
from the EVENTS page. Setup information for the 
EVENTS page is on page 29. Residents can page through 
events or view the details of a specific event from this 
snapshot on the DASHBOARD.  

Service Requests This information comes from the Service requests tab 
of the MY APARMENT page. Setup information for the 
MY APARMENT page is on page 14.  

 

Figure 2: DASHBOARD page  
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OneSite Payments Settings for WelcomeHome 
The next section of WelcomeHome requires OneSite Payments. The settings you 
configure include the fees you can charge and the types of payments (cash, 
checks, money orders, credit cards, debit cards) that residents can make through 
WelcomeHome. In Payments, these options are configured on the General 
property – Setup page, as follows: 

OneSite → Setup → Payments → Transaction codes 

 
 Settings that Must be Configured for Payments BEFORE Setting Up Payments for WelcomeHome 

OneSite → Setup → Payments → Online Living 

 
Settings that Must be Configured for Payments BEFORE Setting Up Payments for WelcomeHome 

After Payments is configured, you must then setup the CrossFire online 
payment options, explained below. 
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MY APARTMENT → PAYMENTS → Account History 
Note: The Payments product center must be set up for WelcomeHome to allow 
payments through the portal. The settings shown on the prior page must be 
configured prior to the settings explained 
below.

 
The MY APARTMENT page has, potentially, five tabs. The number of tabs that 
appear for a given WelcomeHome user depends on whether the user has been 
granted permission to use online payments on their Resident profile tab. There 
are setup options for each MY APARTMENT tab and sub-tab.  

The Payments tab can have five sub-tabs: Account History, Pay Rent Online, 
Rent Payment Coupon, My Recurring Payments, and My Saved Payment 
Accounts. Each tab displays the Account Snapshot shown above on the left. The 
Account History sub-tab has two main sections, as follows:  

Page Element Setup Information 
Account 
snapshot 

CrossFire→ Online rent payment settings  
You set up online rent payment for WelcomeHome on the 
General tab of the Online rent payment settings page of 
CrossFire through the following options: 

 Allow partial payments for current residents  Display SDE charges as upcoming  
 Allow partial payments for former residents  Current amount due (includes any past due) 
 All former residents*  Past due only 
 Display upcoming & SDE charges  Current + pre-pay upcoming 
*It is good practice to allow former residents to make payments through the portal.  
 You must also define recurring payment options for 

residents on the Recurring payments tab of the Online rent 
payment settings page of CrossFire through the following 
options: 
 Fixed amount 
 Total amount (not to exceed) 
 Current balance 
 

Make a 
payment, 
Recurring 
payment setup 
buttons 

OneSite → Residents → Contact → Edit → Resident profile 

Residents must have permission, on their Resident profile 
tab, to make online rent payments in order for these 
buttons to appear, and for all of the Payments sub-tabs to 
appear. 

Account 
History 

The Account History section shows residents how much 
they have paid to date and how the payments have been 
applied to their balance. Setup for what residents see in 
this section is done through the setup options for Payments 
and the options explained above for the Account Snapshot. 

Note: It is good practice to tell residents to sign out of 
WelcomeHome, wait ten minutes, and then sign on again to see 
recently submitted payments reflected in their account history.  

 

 

 

 

Figure 3: MY APARTMENT page, PAYMENTS tab: Account History 
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MY APARTMENT → PAYMENTS → Pay Rent Online 

 

The types of one-time payments a resident can make are defined by the 
Payments settings (described on the preceding page) and by CrossFire Online 
rent payment settings, as follows:  

 

 

Page Element Setup Information 
Make a One-
Time Payment 

CrossFire→ Online rent payment settings  
The ways in which a resident can pay rent are defined in 
the Payments setup options (see page 8) and in CrossFire 
on the General tab of the Online rent payment settings 
page through the following options: 

 Allow partial payments for current residents  Display SDE charges as upcoming  
 Allow partial payments for former residents  Current amount due (includes any past due) 
 All former residents*  Past due only 
 Display upcoming & SDE charges  Current + pre-pay upcoming 
*It is good practice to allow former residents to make payments through the portal.  
 You must also define recurring payment options for 

residents on the Recurring payments tab of the Online rent 
payment settings page of CrossFire through the following 
options: 
 Fixed amount 
 Total amount (not to exceed) 
 Current balance 
 

Make a One-
Time Payment 

OneSite → Residents → Contact → Edit → Resident profile 

Residents must have permission to make online rent 
payments on their Resident profile tab. 

Payment 
Accounts 

The payment types and accounts a WelcomeHome user can 
setup and use depend on the setup options configured for 
OneSite Payments (see page 8) and on the CrossFire 
Online rent payment settings.  

Preferred Date For a WelcomeHome user to be able to pre-pay an amount, 
the CrossFire Online rent payment settings must have the 
Current +pre-pay amount option enabled.  

  

 

Figure 4: MY APARTMENT page, PAYMENTS tab: Pay Rent Online  

 

The Account 
Snapshot appears 
on the left side of 
every sub-tab of the 
Payments tab. 
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MY APARTMENT → PAYMENTS → Print Payment Coupon 

 

 

 

 
Setup Information 

Setup → Payments → Transaction Types – Online living 
—AND— 

CrossFire → Online rent payment settings 
All information displayed and entered on the Print payment coupon sub-tab 
of the Payments tab of WelcomeHome is set up through the options and 
explanations on page 8. 

If your property uses the eMoney Order program or the Tel-IVR Program, 
residents will be able to print payment coupons and locate a payment center 
through the Print Payment Coupon sub-tab of the Payments tab on the MY 
APARTMENT page of WelcomeHome.  

 

Figure 5: MY APARTMENT page, PAYMENTS tab: Print Payment Coupon 
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MY APARTMENT → PAYMENTS → My Recurring 
Payments 

 

 

 

Page Element Setup Information 
Recurring payments CrossFire → Resident portal setup → Online rent 

payment settings → Recurring payments 
The Recurring Payments page lists the resident’s 
recurring payments and allows the resident to set up, 
manage, and review those payments. Residents can set 
up recurring payments which are paid on an 
automated schedule. Or, they can enter one-time 
payments.  

The types of payments that can be made by 
WelcomeHome user are determined by the settings in 
OneSite Payments and the following options on the 
Recurring payments tab of the Online rent payment 
settings page in CrossFire: 

• Fixed amount 
• Total amount (not to exceed) 
• Current balance 

Schedule a New 
Payment 

CrossFire → Resident portal setup → Online rent 
payment settings → General 

See page 12 for the list of setup options that govern 
scheduling payments.  

Preauthorized 
payment 

CrossFire → Resident portal setup → Online rent 
payment settings → General 

See page 12 for the list of setup options that govern 
preauthorized payments. 

  

 

Figure 6: MY APARTMENT page, PAYMENTS tab: Recurring Payments  

The Account 
Snapshot appears 
on the left side of 
every sub-tab of the 
Payments tab. 
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MY APARTMENT → PAYMENTS → My Saved Payment 
Accounts 

 

The My Saved Payment Accounts tab lists the resident’s payment accounts and 
allows the resident to set up and manage those accounts. Residents must set up 
one or more payment accounts before they can make online payments. The type 
of online accounts a resident can set up are defined through OneSite Payments 
and CrossFire. 

Setup Information 
Setup → Payments → Transaction Types – Online living 

—AND— 
CrossFire → Online rent payment settings 

All information displayed and entered on the My saved payment sub-tab or 
the Payments tab of WelcomeHome are set up through the options and 
explanations on page 8. 
 

  

 

Figure 7: MY APARTMENT page, PAYMENTS tab: My Saved Payment Accounts 

 

The Account 
Snapshot 
appears on the 
left side of every 
sub-tab of the 
Payments tab. 
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OneSite Facilities Setting for WelcomeHome 
If you allow residents to enter their own service requests from WelcomeHome, 
then you will need to check that the following settings are configured 
appropriately for OneSite Facilities.  

OneSite → Setup → Facilities → General Settings 

 

Settings to Configure for Facilities BEFORE Setting Up Service Requests for WelcomeHome 

OneSite → Setup → Facilities → Customize e-mail 

 

Settings to Configure for Facilities BEFORE Setting Up Service Requests for WelcomeHome 

If you will be allowing residents to schedule service appointment times, you 
will also need to configure Schedule settings in Facilities: 

OneSite → Setup → Facilities → Schedule settings 

 
Settings to Configure for Facilities BEFORE Setting Up Service Requests for WelcomeHome 

Once Facilities is set up appropriately, you must configure the Online service 
request settings in CrossFire as explained on page 14.   
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MY APARTMENT → SERVICE REQUESTS → Current 
Service Requests 

 

The WelcomeHome Service Requests tab is available if your property uses the 
Facilities and CrossFire Service Requests product centers. On this page, residents 
can see information about their service requests on the left side of the page and 
information about entering a new service request on the right side of the page.  

There is no setup required for what appears on the left side of the page. The 
information on the right side of the page is set up in CrossFire. 

Page Element Setup Information 
Service Requests CrossFire → Online service request settings 

To make service requests available to residents, select 
Online service request settings from CrossFire. There 
are several options to configure on the Online service 
request settings page, all of which are self-
explanatory. The settings correspond to the elements 
on the Current Service Request sub-tab of the Service 
Requests tab of the MY APARTMENT page as follows:  

Office Hours The Display office hours phone number check box 
must be selected AND the During office hours phone 
number must be entered. 

After Hours The Display after office hours phone number check 
box must be selected, AND the After office hours 
phone number must be entered. 

Emergencies The Display emergency phone number check box must 
be selected for your property’s emergency number to 
appear here. If you also select the Display “or 911” 
check box, then your property’s emergency phone 
number AND 991 will appear here.  

Emergencies text The emergency statement text that will appear in the 
Online Service request field is a text box into which 
you can type a paragraph of instructions for your 
residents to read when they open a service request. 

Service Policy The property’s service policy may be a long, legal 
document that is available on request at the leasing 
office, in which case you would want to refer residents 
to the office and that document, as has been done in 
this example. Alternatively, you can enter policy text 
directly into the text box titled The service policy text 
that will appear in the online service request.  

Submit a Service 
Request 

CrossFire → Portal users → Edit → Resident profile 
Residents must have permission to submit a service 
request. Make sure there is a check mark in the Online 
service requests field of the Resident profile tab to 
grant access permission. 

 

Figure 8: MY APARTMENT page, SERVICE REQUESTS tab: Current Service Requests 

 

This section of the page shows the residents 
the current status of their service requests. 
This information also appears on the 
DASHBOARD page.  

Residents can click 
the right-arrow to 
review a service 
request 
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MY APARTMENT → SERVICE REQUESTS → Submit 
Service Request 

 

The elements on the Submit a Service Request page are set up in Facilities, 
Leasing & Rents, and CrossFire.  

There may be information about the resident from a prior service request. If not, 
the resident will need to state on the service request they enter whether they 
give permission to service personnel to enter their residence, and if so at what 
time.  

Page Element Setup Information 
Service Issue Setup → Facilities → Service Categories 

 
Setup → Facilities → Items 

The options residents can pick from as the service issue 
and service item are set up in Facilities.  

Please provide 
more detail, if 
needed 

Any information that residents enter here will show up 
as comments on the service request. 

Unit Access 
 
Pet Information 
 
Alarm Code 

Leasing & Rents → Residents → Contact (Edit) → 
Miscellaneous 

The unit access information is defined at the 
Miscellaneous tab of the Resident at a glance page.  
The resident’s recorded options for permission to 
enter, pet information, and alarm code are defined on 
the Resident at a glance page, and that information 
will appear on the service request. The resident has 
the option to change that information when entering a 
new service request in WelcomeHome. 

Preferred 
Appointment Date 
and Time 

Setup → Facilities → Service requests – Scheduling 
settings 

If you want to allow residents to specify a preferred 
date and time for their service appointments, you must 
first define the appointment time ranges in Facilities.  
 
CrossFire → Online service request → Online service 

request settings 
In CrossFire, you choose whether you will allow 
residents to set a preferred appointment date and a 
preferred time.  

 
 

 

Figure 9: MY APARTMENT page, SERVICE REQUESTS tab: Submit Service Request 
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MY APARTMENT → DELIVERIES tab 

  

The Concierge product center must be enabled and configured for the resident 
portal if you offer concierge attended package delivery and pick-up, or guest 
admission to apartments, or guest key pick-up, or bulk key pick-up for service 
providers such as housekeepers. Access to these option is: 

OneSite → Setup → Concierge 

 

The Deliveries tab on the MY APARTMENT page of WelcomeHome is where 
residents will look for information about packages and other items they may 
have received or sent.  

Page Element Setup Information 
Deliveries CrossFire → Resident portal setup → Portal content 

For Concierge and CrossFire to be able to interface, 
you must select the Enable concierge service online 
check box on the Portal content page. (Scroll to the 
bottom of that page to find the Concierge settings.)  

Deliveries CrossFire → Portal users → Edit → Resident profile 
To view the Deliveries tab, the resident must have 
access permission. Make sure there is a check mark in 
the Online concierge services for guest registrations 
field of the Resident profile tab to grant access 
permission. 

Deliveries Message CrossFire → Resident portal setup → Portal content 
You enter the text for the deliveries message in the 
Online concierge services section of the Portal content 
page. The text is entered on the Delivery tab. 

  
 

 

Figure 10: MY APARTMENT page, DELIVERIES tab 
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MY APARTMENT → RESERVATIONS → Overview 

  

Before residents can reserve amenities for personal use, you must set up the 
features that are reservable. When you set up reservable features, you configure 
fees for use, duration of the reservation, and the hours during which the amenity 
or feature can be reserved.  

 Page 
Element 

Setup Information 

Reservations CrossFire → Reservable feature settings 
For reservable items to show up in this section of 
WelcomeHome, you must define what those items are when 
you add the feature through CrossFire. 
•  Be sure to select the Display feature online check box so 

that the item appears on WelcomeHome.  
• Select a picture for the item by clicking Select image on 

the Add a feature page. 

 
Reserve a 
Facility 

CrossFire → Portal users → Edit → Resident profile 
Residents must have access permission to reserve a facility. 
You set this up by making sure there is a check mark in the 
Feature reservations field on the Resident profile tab.  

Request to 
reserve 

CrossFire → Portal content 
After the resident clicks the link to the right of the item she 
wants to reserve, a reservation request is sent by e-mail to 
the leasing office. The e-mail address the notification will go 
to is set up on the Portal content page of CrossFire, in the 
Office e-mail field, shown below.  

 

 

 

Figure 11: MY APARTMENT page, RESERVATIONS tab: Overview 
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MY APARTMENT → RESERVATIONS → Reserve a Facility  

 

Residents enter a request to reserve a facility by completing the fields in the 
Build a Reservation section of the Reservation tab. The request is sent by e-mail 
to the address set up for the leasing office in CrossFire → Portal content.  

 

Page Element Setup Information 
Name CrossFire → Reservable feature settings 

Click Add on the Reservable feature settings page to 
open the Add a feature page. Enter the name of the 
reservable item in the Name field.  
• Be sure to select the Display feature online check 

box so that the item appears on WelcomeHome.  
• You can select a picture for the item by clicking 

Select image on the Add a feature page (assuming 
pictures have been uploaded and are available 
through the Image Picker.) 

No reservations 
before/after this 
time 

CrossFire → Reservable feature settings 
Define the hours that the reservable item is available 
for reservation in the Allow reservations overnight and 
the Hours of reservations sections of in the Fees 
section of the Add a feature page.   

Detail for this 
reservation 

No setup required for this field. Any information the 
resident enters here will appear on the e-mail request 
to reserve the item.  

Rental fee (per 
hour) 
Deposit 

CrossFire → Reservable feature settings 
Define the hourly rental fee and the deposit for the 
reservable item, if any, in the Fees section of the Add a 
feature page.  

Confirm 
Reservation 

When the resident clicks this button, an e-mail 
message is sent to the leasing office requesting the 
reservation. The request is also added to the Feature 
reservations page of CrossFire. Leasing staff must 
monitor the Feature reservations page in order to 
collect fees and deposits, get signed agreements, 
ensure that features are not double-booked, and 
approve and deny reservations. Once a resident’s 
reservation is approved, the resident receives an e-
mail notification confirming the reservation details.  

 

 

Figure 12: MY APARTMENT page, RESERVATIONS tab: Reserve a Facility 
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MY APARTMENT → MY LEASE INFO → My lease 
documents 

  

The My lease info tab of the MY APARTMENT page has four features residents 
can use to stay on top of their lease obligations. The first two features, My lease 
documents and Renewal, are driven by setup options in CrossFire and Document 
Management. The second two features, Authorized Guests and Authorize a New 
Guest, are driven by setup options in CrossFire, Concierge, and Document 
Management.  

 

Product Center Setup Information 
CrossFire A resident’s first and current lease may appear on 

WelcomeHome if the resident completed the 
application electronically. Otherwise, the current lease 
may not be viewable until the resident completes an 
online renewal of the lease.  

Document 
Management 

For a resident’s leasing documents to be available for 
review on the My lease documents page, the CrossFire 
Online Renewals product center must be enabled. 
Then, the packets and documents must be set up as 
viewable on the resident portal in Document 
Management. 

Packets and documents intended for use on 
WelcomeHome must be setup to autogenerate. Forms 
(documents) added to packets must be set up for the 
portal, as shown below.  

 
Concierge Concierge product center must be implemented and 

configured for WelcomeHome. If the property requires 
residents to sign authorization forms in order for the 
concierge to give keys to guests and let guests into 

 

Figure 13: MY APARTMENT page, MY LEASE INFO tab: My lease documents 
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apartments, then those Concierge documents must be 
set up in Document Management. The seeded packet 
called Concierge authorization and two seeded 
documents are available for this purpose, shown 
below.  
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MY APARTMENT → MY LEASE INFO → Renewal 

 

Online renewals are set up in CrossFire, Leasing & Rents, and Document 
Management.  

Product Center Setup Information 
RealPage Central 
User rights 

RealPage Central → Setup → Users 
There are specific user rights required for setting up 
online renewals: 

• Allow access to manage the setup information 
on the General, E-mail invitation, Portal 
notice, Lease offer introduction, Review lease, 
Sign lease, and Renewal receipt tabs 

• Allow access to manage the upgrades in 
Online Renewals setup 

• Allow access to manage the Incentives in 
Online Renewals setup 

CrossFire Online 
Renewals 

Setup → General information and property settings → Centers 
This product center must be enabled for the property 
to offer renewals online through the WelcomeHome 
resident portal.  

Leasing & Rents 
CHOOSE A LEASE TERM 

Leasing & Rents → Setup 
The terms of the leases offered during renewal offers 
are set up in Leasing & Rents. When you generate the 
renewal offer through the Renew Now Wizard, you 
select which of the leases that have been set up in 
Leasing & Rents are presented to the resident through 
the portal. Those are the lease offerings that show up 
here. 

Leasing & Rents 
Amenities as upgrades 
 

Leasing & Rents → Setup → Maintain site amenities 

CrossFire → Online renewals setup → Upgrades 
Amenities can be offered as upgrades by setting up 
the floor plans that are eligible for the amenity, as 
shown below.  

 
CrossFire  
Upgrades 

CrossFire → Online renewals setup → Upgrades 
After amenities have been set up as upgrades, you 
must enable those amenities as upgrade offerings in 
CrossFire . If you are also allowing rentable items (also 
set up in Leasing & Rents) to be offered as upgrades, 
they must be enabled as such in CrossFire , as shown 



RealPage WelcomeHome Settings Guide 

© 2013 RealPage, Inc. C O N F I D E N T I A L    Page 22 

below. Rentable items that have been set up in 
Leasing & Rents can also be offered as upgrades 
during online lease renewals by selecting the Do you 
want to display rentable items in Online Renewals? 
check box on the Upgrades tab. 

 
 

Additional Information About Online Renewals 

Renew Now Wizard 
When you finish all aspects of online renewal setup, and then begin 
processing online renewals for residents, you must always remember to finish 
the lease renewal in Leasing & Rents by completing the Renew now/MTM 
wizard. Receiving the resident's electronic signature (eSignature) and 
completing the countersignature does not complete the leasing process. You 
must have all of the required electronic signatures for the unit being 
renewed, and you must complete the last three steps of the Renew now 
wizard. Completing the Renew now wizard is what sets the new rent rate 
with any increases and amenities the resident has added, and updates the 
term of the lease. 

Incentives 
Incentives are set up through CrossFire . If you include incentives in online 
renewal offerings, you will need to ensure that you have a business process in 
place to account for the incentives that residents accept. There is not a way 
within CrossFire or Leasing & Rents to account for the cost of incentives or 
the reduction in your incentive inventory as the incentives are accepted by 
residents when they renew online.  

Online Renewal Setup Tabs 
In CrossFire , you must review all the tabs of the Online renewals setup page, 
shown below. Many of the text fields are optional, but there are other fields 
that you will want to configure according to your property’s business rules 
and lease terms and other legal criteria.  
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MY APARTMENT → MY LEASE INFO → Authorized Guests 

 

 
The Authorized Guests tab on the MY APARTMENT page of WelcomeHome is 
available if your property is using the Concierge product center. This page lists 
any pending guest authorizations for the resident. Depending on whether the 
property requires guest and employee signatures to manage resident keys and 
opening apartments for guests to enter, you may also need to set options in the 
Document Management product center, as explained on page 16. 

 

 

Additionally, there is setup to be done on the Portal content page of 
CrossFire in order for deliveries and guest services to work properly in 
WelcomeHome.  

Page 
Element 

Setup Information 

Authorized 
Guests 

CrossFire → Portal users → Edit → Resident profile 

To view the Authorized Guests and the Authorize a New Guest 
tabs, residents must be granted access to Online concierge 
services for guest registrations in their Resident profile.  

 
Authorized 
Guests 
Message 

CrossFire → Resident portal setup → Portal content → Online 
concierge services 

You must first select the Enable concierge services online check 
box before you will be able to edit the guest message. This check 
box is near the bottom of the Portal content page in the section 
titled Online concierge services.  

CrossFire → Resident portal setup → Portal content → Online 
concierge services 

Further down the same page, define the welcome message you 
want to appear on the Authorized Guests page of 
WelcomeHome by filling the Guest tab in the first text box with 
tabs under the Online concierge services section of the Portal 
content page.  

 

 
 

 

Figure 15: MY APARTMENT page, MY LEASE INFO tab: Authorized Guests 
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MY APARTMENT → MY LEASE INFO → Authorize a New 
Guest 

 

 When residents click the Authorize a new guest button, it opens the Authorize a 
new guest sub-tab of the My lease info tab on the MY APARTMENT page of 
WelcomeHome.  

 
The setup for authorizing guests involves CrossFire , Concierge, and 
Document Management.  

Page Element Setup Information 
Guest Information CrossFire → Resident portal setup → Portal content 

→ Online concierge services 
Concierge must be an enabled product center and it 
must be configured for portal use before residents will 
be able to access and use the guest pages of 
WelcomeHome. Online concierge services must be 
enabled at CrossFire. 

CrossFire → Portal users → Edit → Resident profile 
Residents must have access permission to use guest 
and key concierge services.  

Key Permission OneSite → Setup → Concierge 
Key permissions and apartment entry are configured 
primarily through the setup options for Concierge. 
Properties that require signature authorization from 
residents as a condition of the concierge providing 
keys or apartment entry to guests requires that a 
concierge packet with those kinds of documents be set 
up in Document Management, as explained on page 
24.  

  
 

Figure 16: MY APARTMENT page, MY LEASE INFO tab: Authorize a New Guest 
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MY APARTMENT → MY LEASE INFO → Submit a Guest 
Authorization? 

 

For properties that require resident signature authorization for concierge key 
and entry service, when the resident submits a request for the service, the 
resident is presented with the authorization forms for eSignature.  

If the packet has been set up correctly for the portal, then the resident can click 
the Read & Accept links, read through the PDF forms presented, and then apply 
his e-signature, and click Accept to submit the signed form to the leasing office.  

 

Page Element Setup Information 
Authorization 
Document Types 

Setup → Document Management → Manage 
document types 

If the property requires residents to sign authorization 
forms before staff provide guests with a key or entry to 
the apartment, make sure you have two document 
types enabled at the property:  

• Concierge Apartment Access 
• Concierge Key Release 

 
Concierge 
Authorization 
Packet 

Setup → Document Management → Packet library 
In most cases, you will perform Document 
Management setup at RealPage Central and push the 
Concierge authorization packet to the property. The 
packet is seeded and contains the Concierge 
Apartment Access and/or the Concierge Key Release 
document types. 
Each document type has one constraint applied to it: 
Concierge apartment access authorization and 
Concierge key release authorization, respectively.  

 

Figure 17: MY APARMENT page, MY LEASE INFO tab: Submit a Guest Authorization 
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MY PROFILE page 

 

The MY PROFILE page displays information from the OneSite Resident at a 
glance page. This information can be entered by a leasing consultant or by the 
resident through WelcomeHome. The resident can change some of this 
information from the MY PROFILE page. There are no setup options that control 
the information displayed on this page.  

 

Page Element Information Comes From or Is Entered Into: 
Contact Information CrossFire → Portal Users → Edit → General 

information 
 

Emergency Contact 
Information 

CrossFire → Portal Users → Edit → Emergency contact 

Access Information Find person → View → Miscellaneous 
Add a Vehicle Find person → View → Miscellaneous 

If the resident requests to add a vehicle, it is added to 
the information on the Miscellaneous tab of the 
Resident at a glance page as soon as the request is 
submitted. 

Request to Add Find person → View → Contacts → New 
If the resident requests to add a minor resident to the 
unit, an e-mail notification is sent to the e-mail address 
assigned to the Resident profile update notification 
type. This e-mail address is set up on the E-mail setup 
page of Web site setup in CrossFire .  

 

  

 

Figure 18: MY PROFILE page 
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MY COMMUNITY page, OVERVIEW tab 

 

On the Overview tab of the MY COMMUNITY page provides the resident with 
names of the community staff, a calendar of community events, access to the 
community policies and newsletters, and contact information on community 
utility providers.  

 

 

Page Element Setup Information 
Management Team CrossFire → Resident portal setup → Portal content 

In the Management staff section of the Portal content 
page, define the names and titles of four property staff 
contacts to display here.  

Community 
Newsletters, 
Policies, Lease 
Forms, and 
Resident Forms  

CrossFire → Upload documents 

To provide residents a copy of the property’s 
newsletters, policies, and forms, you must first upload 
those documents to the appropriate sections of the 
Upload documents page.  

OneSite → Residents →Contact → Edit → Resident 
profile 

To view policies or newsletters, residents must have 
access permission to Uploaded documents in their 
Resident profile.  

Utilities Directory CrossFire → Resident portal setup → Portal content 
To provide residents with contact information for the 
community’s utility providers, define each provider in 
the Utility contact information section of the Portal 
content page.  

For each provider, you enter the type of utility, and the 
provider’s name, phone number, and web site address. 
You must also flag each provider you want to display in 
WelcomeHome and the order in which they appear. 

Community 
Calendar 

The Community Calendar shown here is a summary of 
the information on the Events tab.  

 

Figure 19: MY COMMUNITY page, OVERVIEW tab 
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MY COMMUNITY page, COMMUNITY INFO tab 

 

The Community info tab of the MY COMMUNITY page presents information 
about the property and community amenities.  

The community information is set up in the Web site setup section of the main 
CrossFire page and the CrossFire section of the Setup page.  

Page Element Setup Information 
Management Office 
Address and Phone 
Number 

CrossFire → Web site setup – Address & phones 
The property address and phone number are defined 
at the Address & phones option.  

Community Map Setup → Crossfire – Property web site →Map & 
directions 

You can either upload a map of the property’s location 
or you can choose to use a Microsoft Map Point map.  

Yahoo Driving 
Directions and 
Mapping 

Setup → Crossfire – Property web site →Map & 
directions 

Choose the option to Use map and driving directions 
from mapping system? to include Yahoo links.  

Driving Directions Setup → Crossfire – Property web site →Map & 
directions 

Include your own customized driving directions at the 
Map & directions page.  

Community 
Amenities 

CrossFire → Web site setup – Amenities → Click here 
to set up your amenities 

The amenities listed here are the site amenities 
defined for the property. 

 

 

 

Figure 20: MY COMMUNITY page, COMMUNITY INFO tab  
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MY COMMUNITY page, EVENTS tab 

 

The Events tab displays a color-coded calendar for the current month on the left 
side of the page. When a resident clicks a day with an event, the event detail 
displays in the Community Events section of the page. Clicking the right-arrow on 
an event displays the event details. The information displayed on this page is set 
up on the Calendar of events page in CrossFire . Complete the following options 
for each event, categorizing each event as community, neighborhood, or other.  

 

 

 

 

 

Page Element Setup Information 
Events OneSite → Residents →Contact → Edit → Resident 

profile 
To view the community events calendar, residents 
must have access permission to the Calendar of events 
in their Resident profile.  

Event Title and 
Subtitle 

CrossFire→ Resident portal → Calendar of events  
To create an event for the calendar, click Add on the 
Calendar of events page to open the Add an event 
page. Enter a main title for each event. The subtitle is 
optional.  

Date and Time CrossFire → Resident portal → Calendar of events  
For one-time events, enter the event date and time on 
the Add an event page. For recurring events, enter the 
date and time when the first event occurs, and then 
define the frequency. You can also define an end date 
and end time.  

Location CrossFire → Resident portal → Calendar of events  
On the Add an event page, enter the location where 
the event occurs. 

Image CrossFire → Resident portal → Calendar of events 
On the Add an event page, upload an image for the 
event. Or, you can a graphic icon instead of a picture.  

Details  CrossFire → Resident portal → Calendar of events 
Enter a more detailed description of the event if 
necessary.  

 

 

  

 

Figure 21: MY COMMUNITY page, EVENTS tab  



RealPage WelcomeHome Settings Guide 

© 2013 RealPage, Inc. C O N F I D E N T I A L    Page 30 

E-mail Notifications 

New Resident E-mail Notification 
If you want to customize the wording and overall content of the first e-mail letter 
a new user of WelcomeHome may receive, you should configure the Portal e-
mail setup page in CrossFire.  

CrossFire → Resident portal setup - Portal e-mail setup 

Property Staff E-mail Notifications 

The E-mail setup page in CrossFire is where you set up who within your company 
receives the different types of e-mail messages that are automatically generated 
by CrossFire . On the right of the page, each category of automatic e-mail is 
listed, with the address(es) that will receive that automatic e-mail message 
beneath it. Use this page to set up the property e-mail addresses and then map 
the various types of notifications to those addresses. You can map multiple types 
of messages to the same address. 

CrossFire → Web site setup – E-mail addresses 

To ensure that the appropriate individuals and groups are notified when 
particular inquiries and events occur, take care to set up the following e-mail 
addresses appropriately.  

• Billing inquiries: Depending on the template used for your web site, 
there may be a link for residents to click when they have a question 
about billing. The link will be associated with the e-mail address you 
enter here. Make sure this e-mail address is one that is monitored 
frequently.  

• Comments & suggestions: Depending on the template used for your 
web site, there may be a link for residents to click when they have a 
comment or suggestion regarding the property and community. The link 
will be associated with the e-mail address you enter here. Make sure this 
e-mail address is one that is monitored frequently.  

• Daily appointments e-mail: Depending on the template used for your 
web site, there may be a link for residents and prospects to click to set 
up an appointment with your office personnel. The link will be associated 

with the e-mail address you enter here. Make sure this e-mail address 
is one that is monitored frequently.  

• General: Depending on the template used for your web site, there 
may be a link for residents to click when they have a general inquiry 
about the property, or have other communication they want to share 
with you. The link will be associated with the e-mail address you 
enter here. Make sure this e-mail address is one that is monitored 
frequently.  

• Notice to vacate: Depending on the template used for your web site, 
there may be a link for residents to click when they want to give 
notice that they will be moving out. The link will be associated with 
the e-mail address you enter here. Make sure this e-mail address is 
one that is monitored frequently.  

• Renewal notice: The leasing consultant assigned to a renewal will 
receive e-mail messages regarding the progress of an online renewal. 
If a renewal is assigned to “House” rather than to a specific leasing 
consultant, then the e-mail address that you put here is the address 
where automatic e-mail messages regarding renewals will be sent. If 
there is no e-mail address set up here, then the automatic e-mail 
messages regarding renewals will be sent to the property e-mail 
address in setup entered into General information and property 
settings.  

• Resident profile update: When residents renew any of the 
information on their profile through WelcomeHome, a notification of 
that update will be sent to the e-mail address for this notification 
type.  

• Transfer notice: Depending on the template used for your web site, 
there may be a link for residents to click when they are requesting a 
transfer to a different unit. The link will be associated with the e-mail 
address you enter here. Make sure this e-mail address is one that is 
monitored frequently. 
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