
The Learning Object Module
AIM addresses two methodologies for assembling Web-based training material. The default method 
uses Course/Module/Lessons supported by Sections that contain elements. The second method, in 
support of ILE and the Submarine Learning Center (SLC), of creating Course/Module/Lessons and 
Sections in which the Sections contain three folders (Learn, Explore, and Practice) which house the 
elements.

The SLC method can be used by selecting the AIM main menu Options menu item and the Preferences
option. Under the Advanced tab of the User Preferences window you can check the block to use the 
SLC grouping. The Section window in the Learning Object Module includes three subcategories for a 
Section (Learn, Explore, and Practice). The required and optional elements for a Concept, Fact, 
Principle, Procedure, and Process Section are the same as the default method.

The Course contains at least one Module, Lessons and Sections. A Module contains at least one Lesson 
and Sections. The Course, Module and Lesson are packaged with overview and summary information. 
The Lessons also contain instructional content (Sections).

The Course and Module structure are provided to allow the creation of Instructor-Led training in 
accordance with the ILE architecture.

A Lesson can be compared to a “wrapper” containing content and is based upon a single job task. The 
Lesson is a Terminal Learning Object (TLO) that supports a single Terminal Objective Statement 
(TOS).

The Section is an Enabling Learning Object (ELO) that supports a single Enabling Objective Statement 
(EOS). Normally the Sections are created first, then the Lesson would be developed and the supporting 
Sections would be selected for the Lesson in the order that they will be presented. When a Module is 
created, the Lesson(s) that support the Module are selected and Module(s) selected for a Course. AIM 
presents you with four windows, Courses, Modules, Lessons and Sections, which can be selected from 
the Contents menu item of the Learning Object Module or from the AIM main menu Document menu 
item and the Learning Object Module sub-menu item. From the Courses, Modules and Lessons 
windows you can develop the Overview and Summary elements, and select the Modules that support the 
Course, the Lessons that the support the Modules, and the Sections that will support the Lesson. From 
the Sections window you can develop any of the five types of Sections: Concept, Fact, Principle, 
Procedure, and Process.

Sections, Lessons, Modules and a Course can be developed from scratch in the Learning Object Module. 
A Curriculum Outline of Instruction for a course, developed in the Content Planning System (CPM) and 
exported to the Enterprise Data Environment (EDE), can be imported into the Learning Object module 
from the EDE. A Section can be created from a CTTL item, an Enabling Objective (EO) in the COI or a 
DP linked to an EO using the Options menu item and the Create Section from AIM Data option.

SCORM Metadata Selection
Select the SCORM Metadata specification and the version of SCORM that will be used to develop 
the material in the Section utility.
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Step 1 From the AIM main menu, select the Options menu item and the Preferences option.

Step 2 Click on the Advanced tab.

Step 3 In the Metadata Specification field, click on the down-arrow, and select one of the 
following:
· NSCORM
· SCORM

Step 4 In the SCORM version field, click on the down-arrow, and select one of the following:
· V1.2,
· 2004, or
· 2004 3rd ed.

NOTE
SCORM 2004 is selected by default if NSCORM was selected in Step 3.

Courses, Modules, Lessons and Sections 
Menu Items
The Courses, Modules, Lessons and Sections windows have the following menu items:

l • File: Allows you to Import or generate Output files. 
l • Options: Contains options applicable to Courses, Modules, Lessons, or Sections.
l • Resources: Allows you to manage Resources.
l • Contents: Allows you to select the windows for development of a Course, Module, Lesson, or 

Section and launch the Content Planning Module (CPM).
l • Edit: Allows you to save your editing to the database or cancel the editing accomplished since 

the last time you saved.
l • Exit: Allows you to exit to the AIM main menu.
l • Help: Allows you to retrieve the Learning Object Module HTML On-Line Help.

Lessons and Sections Contents Menu Item
When the Learning Object Module is selected from the Document menu item, choose the type of 
material you are developing: Course, Module, Lesson, or Section. Clicking on the Learning Object 
Module icon will open the Courses window by default. The Contents menu item provides selection of 
Course, Module, Lesson, Section or Launch CPM (Content Planning Module).

File Options
The following options are available under the File drop-down menu.

· Import Learning Object: Allows you to Import a SCORM Output file, created in AIM I or 
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AIM II, into the database.
· Import from EDE: Imports a Course from Enterprise Data Environment (EDE) that was 

originally designed and exported from CPM. 
· Update from EDE: Updates the Section with the latest EDE information.

· CBT
o Update Display Pages: Update the Display Pages associated with recently updated 

CBT content.
o Store Runtime Packages: Stores the Runtime Package associated with CBT content.
o Store Source File Package: Stores the Source Files associated with CBT content.
o Retrieve Runtime Package: Retrieves previously stored Runtime Packages.
o Retrieve Source File Package: Retrieves previously stored Source File Packages.
o Delete Runtime Package: Deletes a previously stored Runtime Package.
o Delete Source File Package: Deletes a previously stored Source File Package.

· Generate Output Package
o SCORM: This output uses the Metadata Specification and SCORM version selected from the 

AIM main menu Options>Preferences in the Advanced tab. It Allows you to create an AIM 
export file that can be:
§ Imported into another AIM I or AIM II database
§ Unzipped and used as a standalone preview of the Course/Module/Lesson/Section.
§ Imported into self paced authoring tools for the development of interactive ILT or Self-

Paced Sections.
§ Imported into Enterprise Data Environment (EDE).
§ Tested with the ADL test suite to verify it is a valid SCORM package

o Elite: Allows you to create a Section or Lesson output that can be imported into the electronic 
classrooms that employs Elite software. This output uses SCORM Version 1.2, regardless of 
the version selected under AIM main menu Options>Preferences in the Advanced tab.

· Export RRL to EDE: Allows the user to Export RRL data to the EDE, this RRL data can 
then be Imported into the Content Planning Module (CPM).

· Preview
o Course Level Preview: 

At the course level the preview options are:
· LP (or LP Change Package if available)
· TG (or TG Change Package if available)
· TPP from EDE
· TCCD from EDE

o Module Level Preview:
At the Module level the preview options are:

· LP
· TG

o Lesson and Section Level Preview:

· Web: For Self-Paced Sections
· Developer
· Student
· Storyboard
· LP: This option will output a Course in the classic AIM/LP format when a 

Course is highlighted.
· Sheets: For Instructor-Led Sections that contain Instruction Sheets.
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· At the Course level, when LP is selected from the Preview menu the 
following dialog box appears:

·
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· The top section allows the user to select page control printing and 
Header/Footer editing.

· The Course Matter Items allows the user to select additional; course 
materials to be Printed/Previewed, is includes Front Matter, Content, and 
Reference Materials.

· There is a check box to exclude Self-Paced sections, if unchecked Self-
Paced sections will be included in the Print/Preview.

· The Main DP Printing Options allows the Discussion Points to either be 
Printed/Previewed one per page or Continuously.

Glossary print options.jpg
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· DP Spacing allows the user to specify the number of blank lines between 
discussion points. There is also a checkbox that, when checked, will override 
any specified spacing that may have been used during development.

· The Glossary may be printed per Lesson or for the entire course. The Glossary will either 
print at the end of each Lesson, after the Summary or at the end of the Course, after the OAC. 
When the Glossary is printed it will be alphabetized.

· NOTE:

· At the Module, Lesson, and Section levels, when LP is selected from the 
Preview menu the following dialog box appears:

·
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· The top section allows the user to select page control printing and 
Header/Footer editing.

· There is a check box to exclude Self-Paced sections, if unchecked Self-
Paced sections will be included in the Print/Preview.

· The Section Printing Options includes check boxes for not including Self-Paced Sections 
as these are not Instructor-led Sections, Excluding Section Front Matter as it may be 
redundant to the Lesson Front Matter, and Excluding Information Sheet References.

· NOTE:
· If Exclude Section Front Matter is selected no Section Front Matter 

will be displayed, including Information Sheet References.

· The Main DP Printing Options allows the Discussion Points to either be 
Printed/Previewed one per page or Continuously.

· DP Spacing allows the user to specify the number of blank lines between 
discussion points. There is also a checkbox that, when checked, will override 
any specified spacing that may have been used during development.

· Submit Content: Sets the status of the selected course, module, lesson, or section to 
Submitted. Submitting a course, If the course was imported from CPM via the EDE the 
status will also be set to Submitted in CPM; any changes to the COI in CPM will reset the 
status to New in CPM and Complete in AIM LO Module.

o Accept Content: Sets the status of submitted content to Accepted. If the course was 
imported from CPM via the EDE, the status will also be set to Accepted in CPM. 
Note: Accepted content can only be approved or rejected in CPM. Approved content 
cannot be changed in AIM LO Module and a new version must be created in CPM, 

Module Print Options.jpg
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the course exported from CPM and updated from EDE in AIM LO Module. When 
content is rejected in CPM, a message is displayed stating that. The reason for a 
rejection can be viewed in CPM under the History for the content.

o Reject Content: Sets the status of submitted content back to Complete. If the course 
was imported from CPM via the EDE, the status will reset to New in CPM.

Generate Test Questions Package: Allows you to create a Questionmark QML file/package from the 
test items developed for the Section that can be imported into the Questionmark software. Practice and 
Assessment Items may be printed for review by selecting either "Practice Item to PDF" or "Assessment 
Item to PDF" from the Generate Test Items submenu. When selecting either practice items or assessment 
items the user will then have various printing options depicted in the figure below.

Regardless of which print option is selected the output will have a header of "For Review Only - Not a 
Test", as actual tests should be generated using a QML package.

Resource Options
The following options are available from the Resources drop-down menu, these options will vary 
depending on which level is highlighted (Course, Module, Lesson, Section, or Element):

· Add Resource: Allows you to add a resource from the Site RRL Utility to the Resources Tab 
of the Element you have open.

· Add Graphic: Allows you to add a graphic from the Graphics Utility to the Resources Tab of 
the Element you have open.

· Add Sheet: Allows the user to add Instructional Sheets as a Resource.
· Add Fault: This option brings up the Function Faulted box where users can Create Faults to 

an Element.
· Add Free Text: Allows the user to add free text to be used in a RIA.
· Delete Resource: Allows you to delete a resource from the Resources Tab of the Element you 

have open.

assessment print options.jpg
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· Copy Resource: Allows the user to copy a resource that is already used by an Element.
· Paste Resource: Used to Paste a previously Copied Resource in an Element.
· Replace Resource: Used to replace one Resource with a different Resource.
· Select Later IETM: Used to select a later version of an existing IETM.
· View IETM Structure: Allows you to open the browser with the structure of the IETM.
· Launch/View IETM: Allows you to view the IETM identified in the Resources.
· View RRL: Allows you to see what information is entered about a resource when highlighting 

a resource or graphic cited by a Section’s Element.
· Display Media: Allows you to display an IMI full screen.
· Modify/View Fault: Used to edit existing Faults.

Sheets Options
Instructional Sheets are added at the Section level. Outline sheets may be added at the Course, Module 
and Lesson level, all other Sheets can only be added at the Section level. Lesson sheets may only be 
assigned to the Lesson’s RIAs under Overview/Summary. Section sheets may only be cited within the 
RIAs or Assessment/Practice items of the section.
The options from the Sheet drop-down menu are:

· Add Sheet: Allows you to add Instruction Sheets to an Instructor-Led Section when the 
Section Title is highlighted.
o Assignment
o Diagram
o Information
o Job
o Outline
o Problem

· Modify/View Sheet: Allows you to modify and view the highlighted TG Sheet in the Sheets 
tab of the Section.

· Delete Sheet: Allows you to delete the highlighted TG Sheet in the Sheets tab of the Section.
· Copy Sheet: Copies the highlighted sheet for pasting into a different Section.
· Paste Sheet: Pastes a previously Copied Sheet into the desired Section.

What is a Section?
A Section is a self-contained chunk of information built to accomplish a single enabling objective 
statement. Sections are the instructional content selected for the Lesson. They are combined to form the 
Lesson. A Section is referred to as a “topic” within the Lesson. The Section content (elements) varies 
depending on the type of Section selected.

There are five types of Sections:
· Concept – A class of items that shares common key features and is known by a common 

name.
· Fact – Unique, one-of-a-kind types of information.
· Procedure – A sequential set of steps to be followed by one individual to accomplish a task or 

make decisions. Actions within the procedure must be done the same way each time within a 
given situation.
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· Process – A series of actions, changes, or functions that achieve an end result. It often is used 
when you need to illustrate a flow of events that describes how something works.

· Principle – A procedural job task that requires judgment or when guidelines must be applied 
to a situation.

Each type of Section has different elements. The Table 1 illustrates the Section types and the elements 
that are required and optional. Each element is presented on one screen for E-Learning content.

SECTION TYPE
Concept Fact Principle Procedure Process
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NOTE: R=Element is required and O=Element is optional.
Table 12-1. Required and Optional Elements for a Section

When developing each type of Section the Elements that are required will be identified in bold. The 
optional elements can be deleted if not desired by highlighting the element on the Sections window, 
selecting the Options menu item and the Delete option.

Additional Elements can be added to a Section by selecting the Options menu item, the Add Element
option. The Elements presented and available for selection are dependant on the type of Section being 
developed.

Sections Options Menu Item
The Sections window options are as follows:

l Create Section: Allows you to add a Section, of one of the types selected below, to the Section 
list. If there is doubt about the type a Decision Wizard is provided. Answering the questions in 
Decision Wizard will produce a suggested type by percentage. 

o Concept
o Fact 
o Principle
o Procedure
o Process
o Decision Wizard

l Copy Elements: With a Section highlighted all elements of the Section are copied.

ELEMENTS
Section Review O O O O O
Introduction R R R R R
Definition R
Fact-Image, List, or 
Table

O R O O O

Example R R
Non-Example O O
Analogy O O
Principle Statement R
Guidelines R
Decision, Procedure or 
Combined Table

R

Demonstration O
Practice Questions R R R R R
Process R
Section Review O O O O O
Assessment R R R R R
Interaction O O O O O
Glossary O O O O O
Safety Information O O O O O
Security Information O O O O O
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· Paste Elements: Allows the user to paste previously copied elements into a Section. After 
selecting Paste Elements the user will see a pop-up box like the one below. Users can select 
the type of elements that will be pasted into the current Section. 

l Copy/Paste Element: To copy and paste single elements, highlight the element, select Copy 
Element from the Option drop down menu, move the cursor to the location to paste the element, 
select Paste Element from the Option menu drop down.

l Create Section from AIM Data: Allows you to select the desired course, the COI and TLO, or 
DP in AIM I to initiate the development of a Section.

l Create an Elements List from AIM Data: Allows you to select DP/RIAs from an existing AIM 
course.

l Create Student Sheet From AIM Data: Allows you to create an entire Instruction Sheet from an 
Instruction Sheet that exists in a course in the AIM database when the Section Title is highlighted.

l Add Element: Allows you to add additional elements that are dependent on the type of Section 
being developed. Elements are automatically numbered when they are created. 

Paste Elements Options
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l Add Note/Caution/Warning Element: These can be placed after any existing Section Element or 
Sub-Element.

o Note
o Caution
o Warning

l Re-sequence Elements: Allows you to re-sequence the elements of the Section to put them in the 
order desired for presentation to the student.

l Storyboard: Allows the developer to detail concepts and add materials for the Storyboarding of 
Self-Paced Sections. The following tabs accept input in Rich Text Format (RTF) with the 
exception of the Comments tab that is used to add Notes and ISD Comments. ISD Comments are 
added in CPM and imported from the EDE into the LO Module. ISD Comments are not editable 
in the LO Module 

o Display
o Narration
o Animation
o Storyboard Notes
o Table Text
o Interaction
o Comments

l Copy: Allows you to duplicate a Section in the respective window. 
· Create New Version: Allows you to create a new version of an approved Section.
l Delete: Allows you to delete a Section in the respective window. 
l Add Test Item: Allows you to add a test item for Practice or Assessment Elements. 

o Fill-in the-blank
o Multiple Choice
o True/False
o Two-Column Matching
o Performance

l Modify/View Test Item: Allows you to modify or view a test item for a Practice or Assessment 
Element.

l Delete Test Item: Allows you to delete a test item for a Practice or Assessment Element.
l Trainee Preparation Materials: This option is used to identify any preparation materials the 

student may need to review before the Section.
l Security Markings

From the main AIM screen, with a course selected and the tree structure expanded, perform the 
following steps to access the Security Markings screen:

1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.
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The top portion of the Security Markings screen indicates the CIN and Title of the course. The 
center of the screen lists different sections of the Lesson Plan (LP) that can have security 
markings and the current marking assigned. The lower portion of the screen is broken into the 
following three sections:

· Classification: The available classifications that can be assigned, the options are:

o Unclassified

o Confidential

Security marking screen.jpg
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o Secret

o Top Secret

o Unclassified/NOFORN

· Modifier: This is an additional security modifier to the classification, the options are:

o (None)

o COMINT

o Talent Keyhole

o COMINT/Talent Keyhole

· Release Ability: This is an additional restriction on who the document may be released 
to, the options are:

o (None)

o NOFORN

o For Official Use Only

o REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from the 
dropdown menu to save the security markings. There is also a Reset option that will reset the 
security markings of the highlighted Entity to Unclassified.

l ISD Considerations: Considerations are entered into the Content Planning Module (CPM) and 
are brought over to the LO Module on import of a course. They are only editable in the CPM. This 
item will be hidden from the menu for non-imported content.

l Find Section: Allows you to enter text to find a Section. 
l Check Spelling: Allows you to check the spelling of a Section or an Element. 
l *Show: Allows you to select a specific type of Sections and list them. Default is All.

o All
o Concept
o Fact
o Principle
o Procedure
o Process

· Grant Privileges: Allows you to grant the privileges you have to another AIM User.
· Show In Use Information: If the In Use flag is set this option will display information regard 

which use caused the flag to be set.
· Reset In-Use: This option is used to rest the In Use flag, allowing the user to edit the data.
l Explain Flag
l Remove Flag

Create a New Section
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To create a new Section in the Learning Object Module:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object 
Module sub-menu item and Section or click on the Learning Object Module icon and 
when the Courses window opens select the Contents menu item and the Sections sub-
menu item.

Step 2 From the Sections window, select the Options menu item and the Create Section option 
for a Section that will be developed from data not present in the AIM database.

Step 3 Select one of the types of Section (Concept, Fact, Principle, Procedure, or Process).

NOTE
Select the Decision Wizard option if the type has not been determined. The Wizard will 
provide the type based on the answers you provide to the questions.

Step 4 AIM will add the New (Type) Section to the tree structure in the left-hand pane. Expand 
the structure of the Section by clicking on the + block. This will reveal the required 
elements (in Bold) and optional elements of the Section. 

Step 5 With the New (Type) Section highlighted in the tree structure, observe that there are tabs 
in the right-hand pane associated with the Section titled General, Job, Skills Data, Info, 
Sheets for an Instructor-Led Section, Resources, and Metadata. Add/identify the 
following information for each tab and select the Edit menu item and the Save sub-menu 
item when completed with each tab.
· General – Enter the Title, Identification Number and Objective in the fields 

provided. The Identification Number will be assigned for generating an output file for 
SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click 
on the down arrows for Section Type, Status, and Classification and select the 
appropriate information. Identify the Instruction Type by selecting Self-Paced or 
Instructor-Led. If the Section content is not releasable to foreign nationals, check the 
NOFORN block. Enter the Class/Lab/PA Time in minutes for an Instructor-Led 
Section or IMI Time in minutes for a Self-Paced Section.

· Job – Enter the Duty and Job Task that the Section supports in the fields provided. 
Click on the down arrows for Category (Knowledge or Skill) and select the 
appropriate entry. If the Section is created using the Create Section from AIM Data 
option the CIN, Learning Objective, and DP Number fields will have content from 
the material copied.

· Skills List – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and 
ID, Type and Text. If the Skills data is available in the EDE the Skill List data will 
automatically be entered when importing from EDE.

· Info – The Information tab can contain information about who the author and 
owner is, the date the Section was created, published, and an expiration date. 
Keywords can be added to facilitate searching the database for the Section. Click on 
the down arrows for Cognitive level (Remember or Apply) and select the appropriate 
entry.

· Sheets – Instruction Sheets can be added to support a Section. The TG Sheets are 
identified by Sequence, Type and Title in this tab. TG Sheets are added by 
highlighting the Section title, selecting the Options menu item and the Add Sheet
option.

· Resources – Resources that support the entire Section will be identified in this tab. 
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Resources cannot be added directly into this tab. Resources can be added to Element 
folders from the Site RRL by selecting the Options menu item and the Add 
Resource option when developing the Element folders of the Section.

· Metadata – Each of the folders in the metadata structure contain fields to enter 
appropriate information for SCORM specification and version selected. Bolded 
folders indicate that data entry is required. Right-clicking on headings will identify 
the information that can be added for the SCORM version selected.

Step 6 Develop each Element of the Section. Each Element contains an Element tab, a RIA tab 
is present if Section is identified as Instructor-Led, and Metadata tabs. The Element tab 
contains the Styled Text Editor that you can use to create information and to paste 
information saved as RTF. The Search AIM Data option can be used to access data for 
the Elements and RIA tab. The RIA tab works in conjunction with the Resources menu 
item and the Add Resource, Add Graphic, Add Sheet, Add Fault, Add Free Text and 
Delete Resource options. The Metadata tab contains folders and fields to enter key words 
for the Element. Add/identify the information for each element and select the Edit menu 
item and the Save sub-menu item when completed with each element. Refer to Table 1 
above to determine the required and optional elements for the type of Section being 
developed

Create a Section from AIM Data
The Create Section from AIM Data option allows you to select the desired course, CTTL, LO or DP, 
Unit, and Topic desired to build any of the types of Sections. If the type of Section is not readily 
identifiable, the Decision Wizard option can be used to determine the type of Section.

If test questions have already been developed (for the EO) in the database they can be selected for the 
Assessment Elements in the Section by using the Search AIM Data option in the Lesson/Section Utility 
after the EO or DP has been selected and the Section created.

Step 1 From the AIM main menu, select the Document menu item, the Learning Object 
Module sub-menu item and Section or click on the Learning Object Module icon and 
when the Courses window opens select the Contents menu item and the Sections sub-
menu item.

Step 2 From the Sections window select the Options menu item and the Create Section from 
AIM Data option.

Step 3 From the Select Course window click on the desired course containing the Duty/Task, 
LO, or Discussion Point (DP) that the Section will be converted from and then click on 
the Select menu item.

Step 4 From the Create Section from CIN window you can select either the CTTL, LO or DP. 
You can create a Section from; a Duty or Task in the CTTL module, a Terminal 
Objective or Enabling Objective in the LO module, or from a DP in the LP. For the 
purpose of this explanation click on the down arrow and select DP.
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Step 5 From the Course Structure in the left-hand pane open the desired Unit, to reveal the 
topics in the Unit.

Step 6 Click on the desired Topic to reveal the DPs for the Topic in the right-hand pane.

Step 7 Click on the desired DP and click on the Create menu item. A sub-menu will appear and 
you can select the type of Section to be created from the DP. If it is unclear which type 
the DP should become the Decision Wizard should be selected. When you have 
answered all questions in the Decision Wizard AIM will bold the type of Section based 
on your answers and provide a percentage for each type. Click on the appropriate type.

Step 8 AIM will return you to the Sections window where you can develop your Section after 
selecting the appropriate type of Section. 

Step 9 The Section converted from the DP is added to the tree structure in the left-hand pane. 
Expand the structure of the Section by clicking on the + block. This will reveal the 
required (in Bold) and optional Elements of the Section. If using the SLC method, the 
Learn, Explore, and Practice folders will contain the Elements that are required and 
optional.

Step 10 With the Section highlighted in the tree structure, observe that there are tabs in the right-
hand pane associated with the Section titled General, Job, Skills Data, Info, Sheets for 
Instructor-Led Section, Resources, and Metadata. Add/identify the following information 
for each tab and select the Edit menu item and the Save sub-menu item when completed 
with each tab.
· General – Enter the Title, Identification Number and Objective in the fields 

provided. The Identification Number will be assigned for generating an output file for 
SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click 
on the down arrows for Section Type, Status, and Classification and select the 
appropriate information. Identify the Instruction Type by selecting Self-Paced or 
Instructor-Led. If the Section content is not releasable to foreign nationals, check the 
NOFORN block. Enter the Class/Lab/PA Time in minutes for an Instructor-Led 
Section or IMI Time in minutes for a Self-Paced Section.

· Job – Enter the Duty and Job Task that the Section supports in the fields provided. 
Click on the down arrows for Category (Knowledge or Skill), and select the 
appropriate entry. If the Section is created using the Create Section from AIM Data 
option, the CIN, Learning Objective, and DP Number fields will have content from 
the material copied.

· Skills List – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and 
ID, Type and Text. If the Skills data is available in the EDE the Skill List data will 
automatically be entered when importing from EDE.

· Info – The Information tab can contain information about who the author and 
owner is, the date the Section was created, published, and an expiration date. 
Keywords can be added to facilitate searching the database for the Section. Click on 
the down arrows for Cognitive level (Remember or Apply) and select the appropriate 
entry.

· Sheets – Instruction Sheets can be added to support a Section. The TG Sheets are 
identified by Sequence, Type and Title in this tab. TG Sheets are added by 
highlighting the Section title, selecting the Options menu item and the Add Sheet
option.

· Resources – Resources that have been selected for the Elements of the Section will 
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appear in the Resources tab. Resources cannot be added directly to this tab.
· Metadata – Each of the folders in the metadata structure contain fields to enter 

appropriate information for SCORM specification and version selected. Bolded 
folders indicate where data entry is required. Right-clicking on headings will identify 
the information that can be added for the SCORM version selected.

Step 11 Develop each Element of the Section. Each Element contains Element, Instructor 
Activity for Instructor-Led Sections, Resource, and Metadata tabs.
· The Element tab contains the Styled Text Editor that you can use to create 

information and to paste information saved as RTF. The Search AIM Data options 
can be used to access DP and RIA information linked to the objective used to create 
the Section or from other courses and topics. DP and RIA information can be copied 
into the Element tab and resources selected in the RIA will be added to the Resources 
tab.

· The Instructor Activity tab will be present for Instructor-Led Sections. Enter the 
instructions for the instructor detailing how to teach the element.

· The Storyboard option will be present for Self-Paced Sections. Enter storyboard 
development concepts to be used in Outstart Evolution or Crossroads.

· The Resource tab works in conjunction with the Options menu item and the Add 
Resource, Add Graphic, and Delete Resource options. These options allow you to 
add items from the Site RRL and Graphics Utility.

· The Metadata tab contains folders in the metadata structure with fields to enter key 
words for the Section and appropriate information for SCORM specification and 
version selected. Bolded folders indicate where data entry is required. Right-clicking 
on headings will identify the information that can be added for the SCORM version 
selected. Add/identify the bolded information for each item and select the Edit menu 
item and the Save sub-menu item when completed with each Element.

Adding Test Items for a Section
If test questions have already been developed for the EO (linked to the CTTL item, LO item, or DP) in 
the database, they can be selected for the Assessment item in the Section by using the Search AIM 
Data option in the Lesson/Section Utility after the Duty/Task, EO, or DP has been selected and the 
Section created. The Test Items for the Section can then be edited as necessary.

To add new Test Items for a Section:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object 
Module sub-menu item and Section or click on the Learning Object Module icon and 
when the Courses window opens select the Contents menu item and the Sections sub-
menu item.

Step 2 Click on the Resource tab. Select the Resources menu item and the Select Resource
option. 

Step 3 Click on the Resource that contains the test question information, and select the Select
menu item. Resource options are IETM, IMM, or Publication.

Step 4 Enter the required resource information as determined by the resource selected.
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To develop Fill-in-the-blank questions:

Step 1 From the Sections window, select the Options menu item and the Add Test Item option. 
Select Fill-in-the-blank from the sub-menu.

Step 2 Click on the K Level field down arrow, and from the drop-down menu select the 
appropriate level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 - Comprehend
K4 - Analyze
K5 - Evaluate

Step 3 Click on the Q&A tab. Click on the Stem field, and enter the text of the question. Use the 
underline feature to enter the blank line.

Step 4 Click on the Answer field and enter the text of the answer.

Step 5 Click on the Resource tab. Select the Resources menu item and the Select Resource
option. 

Step 6 Click on the Resource that contains the test question information, and select the Select
menu item. Resource options are IETM, IMM, Sheet, or Publication.

Step 7 Enter the required resource information as determined by the resource selected.

Step 8 If there is an associated graphic to be used in conjunction with the test item perform the 
following:
a. Click on the Graphic tab. Select the Options menu item and the Select Graphic

option. AIM II will open the Graphics window that contains a list of all the graphics 
contained in the Graphics library.

b. Click on the desired graphic, and select the Options menu item and the Select option. 
Selection of a graphic enables the sizing portion of the window for the graphic 
selected. The width and height of the graphic can be edited to conform to the 6.5 
width and 8.5 height maximum values.

c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the 
Graphic tab, and the field for Graphic description will contain the graphic description 
from the graphics library for the graphic selected. The graphic description field can be 
edited and will print out below the graphic.

Step 9 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who 
Administratively approved the test item, and the Date the test item was first created. The 
default developer is the login name of the individual that first created the test item and 
can be edited. The default date can be edited before the test item is locked for approval.

Step 10 A down arrow will appear in the Status field when the required information has been 
added to the fields and tabs (fields identified with an asterisk are required) and the Status 
will change to Complete. The Status can then be changed from Complete to Locked or 
Approved by clicking on the down arrow and selecting the appropriate Status and saving 
the information to the database.
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Step 11 Select the Edit menu item and the Save sub-menu item to save the Fill-in-the-blank 
question to the database.

Step 12 Select the Exit menu item to return to the ELOs window.

To develop Multiple Choice questions:

Step 1 From the Sections window select the Options menu item and the Add Test Item option. 
Select Multiple Choice from the sub-menu.

Step 2 Click on the Q&A tab. In the Stem field, add the text of the question.

Step 3 In the Answer/Distractor fields, enter the text of the distractors and answer. At least four 
entries must be made to save the question to the database.

Step 4 Click on the Answer text, select the Options menu item and the Set Answer option, or 
double-click in the Correct Answer column adjacent to the answer. An “X” will appear in 
the Correct Answer column adjacent to the Answer.

NOTE
Entries made in the Answer/Distractor field can be re-sequenced by clicking on the text 
and using “drag and drop” to place the item where desired.

Step 5 Click on the Resource tab. Select the Resources menu item and the Select Resource
option. 

Step 6 Click on the Resource that contains the test question information, and select the Select
menu item. Resource options are IETM, IMM, Sheet, or Publication.

Step 7 Enter the required resource information as determined by the resource selected.

Step 8 Click on the K Level field down arrow, and from the pop-up menu select the appropriate 
level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 - Comprehend
K4 - Analyze
K5 – Evaluate

Step 9 If there is an associated graphic to be used in conjunction with the test item perform the 
following:
a. Click on the Graphic tab. Select the Options menu item and the Select Graphic

option. AIM II will open the Graphics window that contains a list of all the graphics 
contained in the Graphics library.

b. Click on the desired graphic, and select the Options menu item and the Select option. 
Selection of a graphic enables the sizing portion of the window for the graphic 
selected. The width and height of the graphic can be edited to conform to the 6.5 
width and 8.5 height maximum values.

c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the 
Graphic tab, and the field for Graphic description will contain the graphic description 
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from the graphics library for the graphic selected. The graphic description field can be 
edited and will print out below the graphic.

Step 10 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who 
Administratively approved the test item, and the Date the test item was first created. The 
default developer is the login name of the individual that first created the test item and 
can be edited. The default date can be edited before the test item is locked for approval.

Step 11 A down-arrow will appear in the Status field when the required information has been 
added to the fields and tabs, and the Status will change to Complete. The Status can then 
be changed from Complete to Locked or Approved by clicking on the down arrow and 
selecting the appropriate Status and saving the information to the database.

Step 12 Select the Edit menu item and the Save sub-menu item to save the multiple-choice 
question to the database.

Step 13 Select the Exit menu item to return to the Sections window.

To develop True/False questions:

Step 1 From the Sections window, select the Options menu item and the Add Test Item option. 
Select True/False from the sub-menu.

Step 2 Click on the K Level field down arrow, and from the pop-up menu, select the appropriate 
level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 - Recall
K3 - Comprehend
K4 - Analyze
K5 – Evaluate

Step 3 Click on the Q&A tab, and enter the text of the statement in the Stem field.

Step 4 Identify the correct answer by clicking on the box next to either TRUE or FALSE. An 
"X" will appear in the box to indicate the correct answer.

Step 5 Click on the Resource tab. Select the Resources menu item and the Select Resource
option. 

Step 6 Click on the Resource that contains the test question information, and select the Select
menu item. Resource options are IETM, IMM, Sheet, or Publication.

Step 7 Enter the required resource information as determined by the resource selected.

Step 8 If there is an associated graphic to be used in conjunction with the test item, perform the 
following:
a. Click on the Graphic tab. Select the Options menu item and the Select Graphic

option. AIM II will open the Graphics window that contains a list of all the graphics 
contained in the Graphics library.

b. Click on the desired graphic, and select the Options menu item and the Select option. 
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Selection of a graphic enables the sizing portion of the window for the graphic selected. 
The width and height of the graphic can be edited to conform to the 6.5 width and 8.5 
height maximum values.

c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the 
Graphic tab, and the field for Graphic description will contain the graphic description 
from the graphics library for the graphic selected. The graphic description field can be 
edited and will print out below the graphic.

Step 9 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who 
Administratively approved the test item, and the Date the test item was first created. The 
default developer is the login name of the individual that first created the test item and 
can be edited. The default date can be edited before the test item is locked for approval.

Step 10 A down-arrow will appear in the Status field when the required information has been 
added to the fields and tabs and the Status will change to Complete. The Status can then 
be changed from Complete to Locked or Approved by clicking on the down arrow and 
selecting the appropriate Status and saving the information to the database.

Step 11 Select the Edit menu item and the Save sub-menu item to save the True/False question to 
the database.

Step 12 Select the Exit menu item to return to the Sections window.

To develop Two-Column Matching test questions:

Two column matching test items are actually four to eight individual test items in one question. To 
develop a two-column matching test item you will enter data in two parallel columns that correspond to 
each other. The left-hand column (stimulus) will contain four to eight entries. The right-hand column 
(responses) will contain six to ten entries. The right-hand column MUST have two more entries than the 
left-hand column. These two additional entries are provided to prevent the trainees from being able to 
guess at the last few matching items after having ruled out the ones that they know.

Step 1 From the Sections window, select the Options menu item and the Add Test Item option. 
Select Two-Column Matching from the sub-menu.

Step 2 Click on the K Level field down arrow, and from the pop-up menu select the appropriate 
level of learning for the question.
K1 - Recognize (recommended selection for T/F Test Items)
K2 – Recall
K3 – Comprehend
K4 - Analyze
K5 – Evaluate

Step 3 Click on the Q&A tab. Click on the Stem field and enter the text of the directions for the 
Column Matching Test Item.

Step 4 Select the Options menu item and the Add Left Entry option, or click in the desired 
location to add an entry.

Step 5 Enter the text for the first item of the left-hand column.
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Step 6 Repeat Steps 9 and 10 for each item to be added to the left-hand column. AIM II will 
permit up to 8 entries. After four entries in either column, you will need to manually add 
entries using the Options drop-down menu.

Step 7 Select the Options menu item and the Add Right Entry option, or click in the desired 
location to add an entry.

Step 8 Enter the text for the first item in the right column.

Step 9 Repeat Steps 7 and 8 for each item to be added to the right-hand column. AIM II will 
permit up to 10 entries for the right-hand column. The right-hand column must have two 
more entries than the left-hand column.

NOTE
Entries made in the Right and Left-hand columns can be resequenced by clicking on the 
text and using “drag and drop” to place the item where desired.

Step 10 Click on the Answer column for the first item in the left-hand column, and select the 
letter of the matching item in the right-hand column. You can use an answer once, more 
than once or not at all.

Step 11 Repeat Step 10 for each item in the left-hand column.

Step 12 Click on the Resource tab. Select the Resources menu item and the Select Resource
option. 

Step 13 Click on the Resource that contains the test question information, and select the Select
menu item. Resource options are IETM, IMM, Sheet, or Publication.

Step 14 Enter the required resource information as determined by the resource selected.

Step 15 If there is an associated graphic to be used in conjunction with the test item perform the 
following:
a. Click on the Graphic tab. Select the Options menu item and the Select Graphic

option. AIM II will open the Graphics window that contains a list of all the graphics 
contained in the Graphics library.

b. Click on the desired graphic and select the Options menu item and the Select option. 
Selection of a graphic enables the sizing portion of the window for the graphic 
selected. The width and height of the graphic can be edited to conform with the 6.5 
width and 8.5 height maximum values.

c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the 
Graphic tab, and the field for Graphic description will contain the graphic description 
from the graphics library for the graphic selected. The graphic description field can be 
edited and will print out below the graphic.

Step 16 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who 
Administratively approved the test item, and the Date the test item was first created. The 
default developer is the login name of the individual that first created the test item and 
can be edited. The default date can be edited before the test item is locked for approval.
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Step 17 A down-arrow will appear in the Status field when the required information has been 
added to the fields and tabs, and the Status will change to Complete. The Status can then 
be changed from Complete to Locked or Approved by clicking on the down arrow and 
selecting the appropriate Status and saving the information to the database.

Step 18 Select the Edit menu item and the Save sub-menu item to save the Two Column 
Matching question to the database.

Step 24 Select the Exit menu item to return to the Sections window.

To develop Performance questions:

Step 1 From the Sections window select the Options menu item and the Add Test Item option. 
Select Performance from the sub-menu.

Step 2 Click on the K Level field down arrow, and from the drop-down menu select the 
appropriate level of learning for the question.

Step 3 Click on the Performance tab and enter the title of the Performance scenario in the Title 
field.

Step 4 Click in the text field below the Title and add the text for the Performance scenario. 

AIM II will open the Select Site RRL window that contains the Publications that are 
contained in the Site RRL.

Step 5 Click on the Resources tab. Click on the Options menu item and the Add Resource 
option.

AIM II will open the Select Site RRL window that contains the Publications that are 
contained in the Site RRL.

Step 6 Click on the publication that supports the Performance scenario and select the Select
menu item. AIM II will enter the publication identifier in the Resources tab of the 
Performance Test Item for Line Item window. You may also double-click on the desired 
publication to select it.

Step 7 Enter the publication breakdown information (e.g., Volume, Part, Chapter) in the Pub. 
Breakdown fields.

Step 8 The Info Tab is provided to enter Notes, identify the Developer, Reviewer, and who 
Administratively approved the test item and the Date the test item was first created. The 
default developer is the login name of the individual that first created the test item and 
can be edited. The default date can be edited before the test item is locked for approval.

Step 9 If there is an associated graphic to be used in conjunction with the test item, perform the 
following:
a. Select the Options menu item and the Add Graphic option. AIM II will open the 

Graphics window that contains a list of all the graphics contained in the Graphics 
library.
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b. Click on the desired graphic, and select the Options menu item and the Select option. 
Selection of a graphic enables the sizing portion of the window for the graphic 
selected. The width and height of the graphic can be edited to conform to the 6.5 
width and 8.5 height maximum values.

c. Select the Edit menu item and the Save sub-menu item. AIM II will return you to the 
Graphic tab, and the field for Graphic description will contain the graphic description 
from the graphics library for the graphic selected. The graphic description field can be 
edited and will print out below the graphic.

Step 10 Select the Edit menu item and the Save sub-menu item to save the Performance question 
to the database.

Step 11 A down-arrow will appear in the Status field when the required information has been 
added to the fields and tabs, and the Status will change to Complete. The Status can then 
be changed from Complete to Locked or Approved by clicking on the down arrow and 
selecting the appropriate Status and saving the information to the database.

Step 12 Select the Exit menu item to return to the Sections window.

Adding TG Sheets to a Section
When developing an Instructor-Led Section you can create Instruction Sheets (TG Sheets) for the 
students. There are six types of Instruction Sheets:

l Assignment 
l Diagram 
l Information 
l Job 
l Outline 
l Problem 

To develop an Assignment Sheet:

Step 1 From the Sections window click on the Section Title.

Step 2 Select the Options menu item and the Add Sheet option.

Step 3 Select Assignment.

Step 4 Add the Assignment Sheet Title and Introduction in the designated fields. The Section 
Title will be the default title of the Assignment Sheet and it can be edited.

Step 5 Select the Contents menu item and the Study Assignments sub-menu item.

Step 6 From the Sheet References window select the Options menu item and the Add option.

Step 7 Select the Options menu item and either “Select Reference for Document” or “Select 
IETM for Document”.

Step 8 From the Select Site RRL window click on the desired Reference or IETM and click on 
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the Select menu item.

NOTE: If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser 
and select the Options menu item and the Select option.

NOTE: The Type field will automatically be identified, depending on your selection of Reference or 
IETM.

Step 9 Click on the Before Text field and click on the down arrow. Select the desired verb.

Step 10 In the After Text field add the required text for the Assignment. (Example: Chapter 15, 
paragraphs 15.2.3 through 15.2.8.)

Step 11 Repeat Steps 6 through 9 for each additional assignment.

Step 12 After adding the last assignment select the Exit menu item.

Step 13 Select the Contents menu item and the Study Questions sub-menu item. Number and 
add the desired study questions to the Word document.

Step 14 Select the File menu item and the Save sub-menu item when finished adding study 
questions.

Step 15 Select the File menu item and the Exit sub-menu item to return to the Assignment Sheet 
window.

Step 16 Select the Contents menu item and the Answer sub-menu item.

Step 17 Number and add the answers to the questions added in Step 12.

Step 18 Select the Edit menu item and the Save sub-menu item to save your answers.

Step 19 Select the Options menu item and the Print Preview option to view and review your 
Assignment Sheet.

Step 20 From the Preview window select the File menu item and the Exit sub-menu item.

Step 21 When complete with the Assignment Sheet select the Exit menu item to return to the 
Sections window.

To develop a Diagram Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Options menu item and the Add Sheet option.

Step 3 Select Diagram.

Step 4 Add the Diagram Sheet Title in the designated field.
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Step 5 Select the Contents menu item and the Diagram sub-menu item.

Step 6 Select the Insert menu item and the AIM Graphic, or AIM IMI sub-menu item.

Step 7 If AIM Graphic was selected, click on the desired graphic from the Select Graphic 
window. Select the Options menu item and the Select option. This will place the graphic 
in the position of you cursor in your Word document.

If AIM IMI was selected, click on the desired IMI from the IMI Selection window. 
Select the Options menu item and the Select option. This will place a hot link to the IMI 
in the position of you cursor in your Word document.

Step 8 Select the File menu item and the Save sub-menu item when finished adding 
graphics/IMI.

Step 9 Select the Options menu item and the Print Preview option to view and review your 
Diagram Sheet.

Step 10 From the Preview window select the File menu item and the Exit sub-menu item.

Step 11 When complete with the Diagram Sheet select the Exit menu item to return to the 
Sections window.

To develop an Information Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Options menu item and the Add Sheet option.

Step 3 Select Information.

Step 4 Add the Information Sheet Title and Introduction in the designated fields.

Step 5 Select the Contents menu item and the References sub-menu item.

Step 6 From the Sheet References window select the Options menu item and either “Select 
Reference for Document” or “Select IETM for Document”.

Step 8 From the Select Site RRL window click on the desired Reference or IETM and click on 
the Select menu item.

NOTE: If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser 
and select the Options menu item and the Select option.

NOTE: The Type field will automatically be identified, depending on your selection of Reference or 
IETM.

Step 9 In the After Text field add the required text for the Information. (Example: Chapter 15, 
paragraphs 15.2.3 through 15.2.8.)

Step 10 Repeat Steps 6 through 9 for each additional document.
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Step 11 After adding the last document select the Exit menu item.

Step 12 Select the Contents menu item and the Information sub-menu item. Add the required 
text to the Word document.

Step 13 Select the File menu item and the Save sub-menu item when finished adding 
information.

Step 14 Select the File menu item and the Exit sub-menu item to return to the Information Sheet 
window.

Step 15 Select the Options menu item and the Print Preview option to view and review your 
Information Sheet.

Step 16 From the Preview window select the File menu item and the Exit sub-menu item.

Step 17 When complete with the Information Sheet select the Exit menu item to return to the 
Sections window.

To develop a Job Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Options menu item and the Add Sheet option.

Step 3 Select Job.

Step 4 Add the Job Sheet Title and Introduction in the designated fields.

Step 5 Select the Contents menu item and the Equipment sub-menu item.

Step 6 AIM opens the Equipment folder of the Site RRL for selection of the equipment for 
performance of the Job Sheet. Since there are 18 folders in the Site RRL that contain 
equipment, you can select the Resources menu item and select the equipment desired 
from any of the equipment related folders.

Highlight the desired item, select the Options menu item and the Select option. When all 
the equipment items have been selected select the Exit menu item to return to the Job 
Sheet window.

Step 7 Select the Contents menu item and the References sub-menu item.

Step 8 From the Sheet References window select the Options menu item and the Add option.

Step 9 Select the Options menu item and either “Select Reference for Document” or “Select 
IETM for Document”.

Step 10 From the Select Site RRL window click on the desired Reference or IETM and click on 
the Select menu item.
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NOTE: If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser 
and select the Options menu item and the Select option.

NOTE: The Type field will automatically be identified, depending on your selection of Reference or 
IETM.

Step 11 In the After Text field add the required text for the Job. (Example: Chapter 15, 
paragraphs 15.2.3 through 15.2.8.)

Step 12 After selecting all the references required select the Exit menu item.

Step 13 Select the Contents menu item and the Self Test Questions sub-menu item. Number and 
add the desired study questions to the Word document.

Step 14 Select the File menu item and the Save sub-menu item when finished adding self test 
questions.

Step 15 Select the File menu item and the Exit sub-menu item to return to the Job Sheet window.

Step 16 Select the Contents menu item and the Safety Precautions sub-menu item. Add the 
required safety precautions for performance of the Job Sheet to the Word document.

Step 17 Select the File menu item and the Save sub-menu item when finished adding safety 
precautions.

Step 18 Select the File menu item and the Exit sub-menu item to return to the Job Sheet window.

Step 19 Select the Contents menu item and the Job Steps sub-menu item. Number and add the 
desired job steps to the Word document.

Step 20 Select the File menu item and the Save sub-menu item when finished adding job steps.

Step 21 Select the File menu item and the Exit sub-menu item to return to the Job Sheet window.

Step 22 Select the Contents menu item and the Answer sub-menu item.

Step 23 Number and add the answers to the self test questions added in Step 13.

Step 24 Select the Edit menu item and the Save sub-menu item to save your answers.

Step 25 Select the Options menu item and the Print Preview option to view and review your Job 
Sheet.

Step 26 From the Preview window select the File menu item and the Exit sub-menu item.

Step 27 When complete with the Job Sheet select the Exit menu item to return to the Sections 
window.

To develop an Outline Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.
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Step 2 Select the Options menu item and the Add Sheet option.

Step 3 Select Outline.

Step 4 Add the Outline Sheet Title and Introduction in the designated fields. The Section Title 
will be the default title of the Outline Sheet and it can be edited.

Step 5 Select the Contents menu item and the Section Outline sub-menu item. Add the 
required text to the Word document.

Step 6 Select the File menu item and the Save sub-menu item when finished adding the outline.

Step 7 Select the File menu item and the Exit sub-menu item to return to the Outline Sheet 
window.

Step 8 Select the Options menu item and the Print Preview option to view and review your 
Outline Sheet.

Step 9 From the Preview window select the File menu item and the Exit sub-menu item.

Step 10 When complete with the Outline Sheet select the Exit menu item to return to the Sections 
window.

To develop a Problem Sheet:

Step 1 From the Sections window click on the Instructor-Led Section Title.

Step 2 Select the Options menu item and the Add Sheet option.

Step 3 Select Problem.

Step 4 Add the Problem Sheet Title and Introduction in the designated fields.

Step 5 Select the Contents menu item and the Equipment sub-menu item.

Step 6 AIM opens the Equipment folder of the Site RRL for selection of the equipment for 
performance of the Problem Sheet. Since there are 18 folders in the Site RRL that contain 
equipment, you can select the Resources menu item and select the equipment desired 
from any of the equipment related folders.

Highlight the desired item, select the Options menu item and the Select option. When all 
the equipment items have been selected select the Exit menu item to return to the 
Problem Sheet window.

Step 7 Select the Contents menu item and the References sub-menu item.

Step 8 From the Sheet References window select the Options menu item and the Add option.

Step 9 Select the Options menu item and either “Select Reference for Document” or “Select 
IETM for Document”.
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Step 10 From the Select Site RRL window click on the desired Reference or IETM and click on 
the Select menu item.

NOTE: If IETM is selected, an IETM Data Browser will open. Click on the desired item in the browser 
and select the Options menu item and the Select option.

NOTE: The Type field will automatically be identified, depending on your selection of Reference or 
IETM.

Step 11 In the After Text field add the required text for the Job. (Example: Chapter 15, 
paragraphs 15.2.3 through 15.2.8.)

Step 12 After selecting all the references required select the Exit menu item.

Step 13 Select the Contents menu item and the Problem sub-menu item. Add the text of the 
problem. Identify what has been Given to the student, the Initial and Final conditions for 
the performance of the Problem Sheet.

Step 14 Select the File menu item and the Save sub-menu item when finished adding the text.

Step 15 Select the File menu item and the Exit sub-menu item to return to the Problem Sheet 
window.

Step 16 Select the Contents menu item and the Answer sub-menu item.

Step 17 Number and add the answers to questions added in Step 13.

Step 18 Select the Edit menu item and the Save sub-menu item to save your answers.

Step 19 Select the Options menu item and the Print Preview option to view and review your 
Problem Sheet.

Step 20 From the Preview window select the File menu item and the Exit sub-menu item.

Step 21 When complete with the Problem Sheet select the Exit menu item to return to the 
Sections window.

Lessons Options Menu Item
The Lessons window contains the following options:

· Create Lesson: Allows you to add a new Principle or Procedure Lesson to the list.
· Add Section to Lesson: Opens a grid of Sections (that contains their title, version, and 

status) in the right-hand pane where you can select the Sections that pertain to the Lesson.
· Copy: Allows you to duplicate a Lesson in the Lessons window.
· Create New Version: Allows you to create a new version of an approved Lesson.
· Delete: Allows you to delete a Lesson in the Lessons window.
· Security Markings

From the main AIM screen, with a course selected and the tree structure expanded, perform 
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the following steps to access the Security Markings screen:
1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.

The top portion of the Security Markings screen indicates the CIN and Title of the course. 
The center of the screen lists different sections of the Lesson Plan (LP) that can have security 
markings and the current marking assigned. The lower portion of the screen is broken into 
the following three sections:

Security marking screen.jpg
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· Classification: The available classifications that can be assigned, the options are:

o Unclassified

o Confidential

o Secret

o Top Secret

o Unclassified/NOFORN

· Modifier: This is an additional security modifier to the classification, the options 
are:

o (None)

o COMINT

o Talent Keyhole

o COMINT/Talent Keyhole

· Release Ability: This is an additional restriction on who the document may be 
released to, the options are:

o (None)

o NOFORN

o For Official Use Only

o REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from 
the dropdown menu to save the security markings. There is also a Reset option that will reset 
the security markings of the highlighted Entity to Unclassified.

· ISD Considerations: Considerations are entered into the Content Planning Module 
(CPM) and are brought over to the LO Module on import of a course. They are only editable 
in the CPM. This item is hidden from the menu for non-imported content.

· Select: Enabled after selecting the Add Section to Lesson option, it allows you to select a 
highlighted Section to support a Lesson.

· Unselect: Enabled after selecting the Add Section to Lesson option, it allows you to 
unselect the highlighted Section from a Lesson.

· Find Lesson: Allows you to enter text to find a Lesson.
· Check Spelling Allows you to check the spelling of any element within the Lesson.
· Grant Privileges: Allows you to grant the privileges you have to another AIM User.
· Show In Use Information: If the IN-Use flag is set this option will display which user 

caused the flag to be set.
· Reset In-Use: This option is used to reset the IN-Use flag to allow editing.
· Explain Flag
· Remove Flag
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Create a Lesson
To create a Lesson in the Learning Object Module:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object 
Module sub-menu item and Lesson or click on the Learning Object Module icon and 
when the Courses window opens select the Contents menu item and the Lessons sub-
menu item.

Step 2 From the Lessons window select the Options menu item and the Create Lesson option.

Step 3 AIM will add the New Lesson to the Lesson tree structure in the left-hand pane. Expand 
the structure of the Lesson by clicking on the + block. This will reveal the Overview, 
Sections, and Summary portions of the Lesson and expanding the Sections will identify 
the elements required for each section.

Step 4 With the New Lesson highlighted in the tree structure, observe that there are tabs in the 
right-hand pane associated with the Lesson titled General, Job, Skills Data, Info, Sheets if 
Instructor-Led Sections containing Instruction Sheets have been selected for the Lesson, 
Resources, and Metadata. Add/identify the following information for each tab and select 
the Edit menu item and the Save sub-menu item when completed with each tab.
· General tab – Enter the Title, Identification Number and Objective in the fields 

provided. The Identification Number will be assigned for generating an output file for 
SCORM, NLCOM or AICC and if unknown can remain blank until assigned. Click 
on the down arrows for Lesson Type, Status, and Classification and select the 
appropriate information. If the Lesson content is not releasable to foreign nationals 
check the NOFORN block. 

· Objectives tab – Lists all the Enabling Objectives of the Sections selected for the 
Lesson.

· Job tab – Enter the Duty and Job Task that the Lesson supports in the fields 
provided. Click on the down arrows for Category (Skill or Knowledge) and select the 
appropriate entries.

· Skills List – Skills data identifies Task/Knowledge/Skill/Tools/Resources by and 
ID, Type and Text. If the Skills data is available in the EDE the Skill List data will 
automatically be entered when importing from EDE.

· Info – The Information tab can contain information about who the author and 
owner is. The date fields allow you to identify the date the Lesson was created, 
published, and an expiration date can be added when applicable. Keywords can be 
added to facilitate searching the database for the Lesson.

· Sheets – Lists the Instruction Sheets identified in the Sections selected for the 
Lesson.

· Resources – This is not an area where you can add resources. The collective 
resources of the elements of the Lesson and the selected Sections will appear in this 
tab.

· Metadata – Each of the folders in the metadata structure contain fields to enter 
appropriate information for SCORM specification and version selected. Bolded 
folders indicate where data entry is required. Right-clicking on headings will identify 
the information that can be added for the SCORM version selected.

Step 5 Develop the Overview section of the Lesson. The Overview folders contain Element, 
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Resource, and Metadata tabs. The Element tab contains the Styled Text Editor that you can use to 
create information and to paste information saved as RTF. The Resource tab works in 
conjunction with the Options menu item and the Add Resource, Add Graphic and 
Delete Resource options. The Metadata tab contains folders and fields to enter required 
data and key words for the Element. Add/identify the information for each item and select 
the Edit menu item and the Save sub-menu item when completed with each Element. 
Elements may be added, modified or deleted from the Overview unless they are required 
elements (Introduction and Importance) by highlighting the Overview and selecting Add 
from the submenu, this will display a list of elements that can be added. To delete an 
element, highlight the element and select Delete from the Options submenu. To Modify an 
element, highlight the element then select Change Element from the Options submenu. 
Elements may also be resequenced with some exceptions, for example the Introduction 
must be the first element. To resequence elements highlight Overview and then select 
Resequence from the Options submenu. It is also possible to add sub-elements by 
highlighting an element and selecting Add Sub-element from the Options menu.

Add/identify the following information for each of the following Lesson Overview items 
and select the Edit menu item and the Save sub-menu item when completed with each 
item.
· Introduction – The goal of the Information item is to explain the purpose of the 

Lesson.
· Importance- The goal of the Importance item is to inform learners why they 

should be interested in the Lesson by creating interest and relevance.
· Prerequisite – The goal of the Prerequisite item is to inform learners of 

knowledge and skills needed to complete the Lesson.
· Scenario – The goal of the Scenario item is to relate a story to a job function to 

motivate the learners and capture their attention.

Step 6 When the Sections that support the Lesson have been developed, click on the Sections 
heading in the tree structure of the Lesson. The Sections identified in the database will be 
reflected in a list of Section Titles in the right-hand pane. Highlight the desired Section 
and select the Options menu item and the Select option or double-click on the desired 
Sections. A check mark will appear in the square box to the left of the Sections selected. 
The Sections can be placed in the order desired for presentation by using the using the 
click and drag method in the right hand Title column.

The Sections will be reflected in the Lesson tree structure in the left-hand pane and their 
content can be edited. Select the Edit menu item and the Save sub-menu item after 
selecting the desired Sections and sequencing them in the desired order.

Step 7 Develop the Summary section of the Lesson. The Summary contain Element, Resource, 
and Metadata tabs. The Element tab contains the Styled Text Editor that you can use to 
create information and to paste information saved as RTF. The Resource tab works in 
conjunction with the Options menu item and the Add Resource, Add Graphic and 
Delete Resource options. The Metadata tab contains folders and fields to enter key words 
for the Element. Add/identify
the information for each item and select the Edit menu item and the Save sub-menu item 

when completed with each element. Add/identify the following information for each item 
and select the Edit menu item and the Save sub-menu item when completed with each 
item. Elements may be added, modified or deleted from the Summary unless they are 
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required elements (Review) by highlighting the Summary and selecting Add from the 
submenu, this will display a list of elements that can be added. To delete an element, 
highlight the element and select Delete from the Options submenu. To Modify an element, 
highlight the element then select Change Element from the Options submenu. Elements 
may also be resequenced. To resequence elements highlight Overview and then select 
Resequence from the Options submenu. It is also possible to add sub-elements by 
highlighting an element and selecting Add Sub-element from the Options menu.

· Review – The goal of the Review item is to recap the key points from all Sections 
in the Lesson.

· Next Step – The goal of the Next Step item is to direct the learner to additional 
steps that would further their knowledge of the subject presented in the Lesson.

· Resource – The goal of the Resource item is to provide more information about 
the knowledge and skills covered in the Lesson.

Modules Options Menu Item
The Modules window contains the following options:

· Create Module: Allows you to add a new Module to the list.
· Add Lesson to Module: Opens a grid of Lessons (that contains their title, version, and 

status) in the right-hand pane where you can select the Lessons that pertain to the Module.
· Copy: Allows you to duplicate a Module in the Modules window.
· Create New Version: Allows you to create a new version of an approved Module.
· Delete: Allows you to delete a Module in the Modules window.
· Security Markings

From the main AIM screen, with a course selected and the tree structure expanded, perform 
the following steps to access the Security Markings screen:

1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.
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The top portion of the Security Markings screen indicates the CIN and Title of the course. 
The center of the screen lists different sections of the Lesson Plan (LP) that can have security 
markings and the current marking assigned. The lower portion of the screen is broken into 
the following three sections:

· Classification: The available classifications that can be assigned, the options are:

o Unclassified

o Confidential

Security marking screen.jpg
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o Secret

o Top Secret

o Unclassified/NOFORN

· Modifier: This is an additional security modifier to the classification, the options 
are:

o (None)

o COMINT

o Talent Keyhole

o COMINT/Talent Keyhole

· Release Ability: This is an additional restriction on who the document may be 
released to, the options are:

o (None)

o NOFORN

o For Official Use Only

o REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from 
the dropdown menu to save the security markings. There is also a Reset option that will reset 
the security markings of the highlighted Entity to Unclassified.

·
· ISD Considerations: Considerations are entered into the Content Planning Module 

(CPM) and are brought over to the LO Module on import of a course. They are only editable 
in the CPM. This item is hidden from the menu for non-imported content.

· Find Module: Allows you to enter text to find a Module.
· Show In Use Information: If the IN-Use flag is set this option will display which user 

caused the flag to be set.
· Reset In-Use: This option is used to reset the IN-Use flag to allow editing.
· Check Spelling Allows you to check the spelling of any element within the Module.
· Grant Privileges: Allows you to grant the privileges you have to another AIM User.
· Explain Flag
· Remove Flag

Create a Module
To create a Module in the Learning Object Module:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object 
Module sub-menu item and Module or click on the Learning Object Module icon and 
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when the Courses window opens select the Contents menu item and the Modules sub-menu item.

Step 2 From the Modules window select the Options menu item and the Create Module option.

Step 3 AIM will add the New Module to the Module tree structure in the left-hand pane. Expand 
the structure of the Module by clicking on the + block. This will reveal the Overview, 
Sections, and Summary portions of the Module, expanding the Lessons will identify the 
elements required for each Lesson, and expanding the Sections will identify the elements 
required for each section.

Step 4 With the New Module highlighted in the tree structure, observe that there are tabs in the 
right-hand pane associated with the Module titled Module, Objectives, Metadata, and 
Resources. Add/identify the following information for each tab and select the Edit menu 
item and the Save sub-menu item when completed with each tab.
· Module tab – Enter the Title of the Module.
· Objectives tab – The Objectives tab will contain the Terminal and Enabling 

objectives of the Lessons and Sections selected for the Module.
· Sheets – The Sheets tab will contain a list of all the Instruction Sheets contained in 

the Lessons selected for the Module.
· Resources – This is not an area where you can add resources. The collective 

resources of the elements of the Module and the selected Lessons and Sections will 
appear in this tab.

· Metadata – Each of the folders in the metadata structure contain fields to enter 
appropriate information for SCORM specification and version selected. Bolded 
folders indicate where data entry is required. Right-clicking on headings will identify 
the information that can be added for the SCORM version selected.

Step 5 When the Lessons that support the Module have been developed, click on the Lessons 
heading in the tree structure of the Module. The Lessons identified in the database will be 
reflected in a list of Lesson Titles in the right-hand pane. Highlight the desired Lesson 
and select the Options menu item and the Select option or double-click on the desired 
Lessons. A check mark will appear in the square box to the left of the Lessons selected. 
The Lessons can be placed in the order desired for presentation by using the using the 
click and drag method in the right hand Title column.

The Lessons will be reflected in the Module tree structure in the left-hand pane and their 
content can be edited. Select the Edit menu item and the Save sub-menu item after 
selecting the desired Lessons and sequencing them in the desired order.

Courses Options Menu Item
The Courses window contains the following options:

· Create Course: Allows you to add a new Course to the list.
· Add Module to Course: Opens a grid of Modules (that contains their title, version, and 

status) in the right-hand pane where you can select the Modules that pertain to the Course.
· Copy: Allows you to duplicate a Course in the Courses window.
· Create New Version: Allows you to create a new version of an approved Course.
· Delete: Allows you to delete a Course in the Courses window.
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· Security Markings
From the main AIM screen, with a course selected and the tree structure expanded, perform 
the following steps to access the Security Markings screen:

1. Right click and Go To the appropriate location on the course tree (left pane).
2. From the menu bar click Options.
3. From the Options dropdown menu click Security Markings

This will display the screen show in the figure below.

The top portion of the Security Markings screen indicates the CIN and Title of the course. 
The center of the screen lists different sections of the Lesson Plan (LP) that can have security 

Security marking screen.jpg
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markings and the current marking assigned. The lower portion of the screen is broken into 
the following three sections:

· Classification: The available classifications that can be assigned, the options are:

o Unclassified

o Confidential

o Secret

o Top Secret

o Unclassified/NOFORN

· Modifier: This is an additional security modifier to the classification, the options 
are:

o (None)

o COMINT

o Talent Keyhole

o COMINT/Talent Keyhole

· Release Ability: This is an additional restriction on who the document may be 
released to, the options are:

o (None)

o NOFORN

o For Official Use Only

o REL TO

Once the appropriate settings have been made select Edit from the menu bar, then Save from 
the dropdown menu to save the security markings. There is also a Reset option that will reset 
the security markings of the highlighted Entity to Unclassified.

· Front Matter: Contains boilerplate LP and TG Safety, Security, and How to Use 
information that can be edited for the course.

· ISD Considerations: Considerations are entered into the Content Planning Module 
(CPM) and are brought over to the LO Module on import of a course. They are only editable 
in the CPM. This item is hidden from the menu for non-imported content.

· Find Course: Allows you to enter text to find a Course.
· Check Spelling: Allows you to check the spelling of any element within the Course.
· Grant Privileges: Allows you to grant the privileges you have to another AIM User for 

Lessons and Sections.
· Show In Use Information: If the IN-Use flag is set this option will display which user 

caused the flag to be set.
· Reset In-Use: This option is used to reset the IN-Use flag to allow editing.
· Explain Flag
· Remove Flag
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Create a Course
To create a Course in the Learning Object Module:

Step 1 From the AIM main menu, select the Document menu item, the Learning Object 
Module sub-menu item and Course or click on the Learning Object Module icon.

Step 2 From the Courses window select the Options menu item and the Create Course option.

Step 3 AIM will add the New Course to the Module tree structure in the left-hand pane. Expand 
the structure of the Course by clicking on the + block. This will reveal the Overview, 
Sections, and Summary portions of the Course, expanding the Modules will identify the 
elements required for each Module, expanding the Lessons will identify the elements 
required for each Lesson, and expanding the Sections will identify the elements required 
for each section.

Step 4 With the New Course highlighted in the tree structure, observe that there are tabs in the 
right-hand pane associated with the Course titled Course, Objectives, Metadata, and 
Resources. Add/identify the following information for each tab and select the Edit menu 
item and the Save sub-menu item when completed with each tab.
· Course tab – Enter the Title of the Course, the Version and the Status.
· Objectives tab – The Objectives tab will contain the Terminal and Enabling 

objectives of the Modules, Lessons and Sections selected for the Course.
· Sheets - The Sheets tab will contain a list of all the Instruction Sheets contained in 

the Modules selected for the Course.
· Resources – This is not an area where you can add resources. The collective 

resources of the elements of the Course, and the selected Modules, Lessons and 
Sections will appear in this tab.

· Metadata – Each of the folders in the metadata structure contain fields to enter 
appropriate information for SCORM specification and version selected. Bolded 
folders indicate where data entry is required. Right-clicking on headings will identify 
the information that can be added for the SCORM version selected.

Step 5 When the Modules that support the Course have been developed, click on the Modules 
heading in the tree structure of the Course. The Modules identified in the database will be 
reflected in a list of Module Titles in the right-hand pane. Highlight the desired Module 
and select the Options menu item and the Select option or double-click on the desired 
Module. A check mark will appear in the square box to the left of the Modules selected. 
The Modules can be placed in the order desired for presentation by using the using the 
click and drag method in the right hand Title column.

The Modules will be reflected in the Course tree structure in the left-hand pane and their 
content can be edited. Select the Edit menu item and the Save sub-menu item after 
selecting the desired Modules and sequencing them in the desired order.
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