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Carburization Model

2

Preliminary Notes: The following tutorial will detail the complete set of steps required to set up model geometry, 
pre-process the model, along with running and post-processing of the model in the Abaqus CAE using the Dante 
Model Builder Plug-In. As with any model, be sure to save often. For further details on pre-processing and post-
processing, please review the tutorial: Dante5_0_Tutorial_2D_Axisymmetric_Ring_Slice_CAE, which builds this 
model using the CAE instead of the Plug-In interface.
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Step 1: Start Abaqus CAE

3

1

2

1. Open Abaqus Command and set the working directory 
by using the command “cd DirectoryPath”

2. Start Abaqus CAE with the command “abqxxxx cae” into 
the command window

• xxxx represents the version of Abaqus to be opened

3. Click With Standard/Explicit Model to start a new model

3
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Step 2: Creating a Part

4

1
2 3 1. Under Module select Part to create a geometry

2. Click the Create Part icon or Part → Create in 
the dropdown menu at the top

3. Rename the part simple_2d_ring_c and select 
Axisymmetric, Deformable, Shell, and set the 
approximate size to 200 then click continue

4. The model can also be renamed to reflect 
model type

4
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Step 2b: Creating a Part

5

1. The ring has an inner diameter of 80 mm, outer 
diameter of 120 mm, and a height of 60 mm

2. An axisymmetric rectangular cross section will 
be used to model the ring

3. Select the Created Lines: Connected tool and 
type in (40,0), (60,0), (60,60), and (40,60)

4. Connect the last side by using your mouse and 
selecting the point (40,0)

5. Select the red X to exit the tool and press Done
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Step 3: Create an Instance

6

1
3

1. Under Module, select Assembly to 
create the instance

2. Click the Create Instance icon or select 
Instance → Create

3. Select the part to be instanced and 
check Dependent (mesh on part)

4. Click OK and the part should turn blue
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Step 4: Meshing the Part

7

41

21 1. Under Module, select Mesh to mesh part

2. Check Part instead of Assembly

3. Select Tools → Partition from the 
dropdown menu

4. Check Face under Type and select Sketch
under Method

5. Select Offset Curves, select all sides, then 
click Done

6. Set the Offset Distance to 2

• Click Flip if partition lines are on the 
outside of the part

• Click OK then Done when the offset 
lines are complete  
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Step 4b: Meshing the Part

8

1. Select Create Lines: Connected to extend 
the partition lines in each corner to 
create squares and click the red X when 
complete

• When creating  a line, the “x”, “H”, 
“V” means the line is perfectly 
horizontal or vertical as seen in the 
images to the left

2. Click Done when the partition is 
complete

• The final partition should look like 
the adjacent image
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Step 4c: Meshing the Part

9

1. In the dropdown menu, select Seed → Part then set the Approximate global size to 
1.0 and click ok

2. In the dropdown menu, now select Seed → Edges then select each edge of the four 
squares created during partitioning using Shift +  Click and click OK when complete

3. In Method, set the option to By Number and select 8 for Number of elements then 
click OK

4. The final seeding can be seen in the image to the bottom right

1

2

3
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Step 4d: Meshing the Part

10

1. In the pulldown menu, select Mesh → Controls

2. Box select the entire geometry then click Done

3. Select Quad under Element Shape then select 
Structured under Technique and click OK when 
complete

4. In the dropdown menu, select Mesh → 
Element Type

5. Box select the entire geometry then click Done

6. Under Family, select Heat Transfer, keep the 
default settings and click OK when complete

7. In the dropdown menu, select Mesh → Part
and click Yes to mesh the part

• There should be a total of 2304 elements

3 6
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Step 5: Model Continuation

11

• At this point, the following steps have been completed:

• Geometry has been defined

• Instance has been created

• Partitioning completed

• Geometry has been meshed

• To complete this model, the Dante Model Builder Plug-In may be used

• Before doing so, surfaces and sets should be defined for initial/boundary conditions and interactions

• However they can be defined at any time when using the Plug-In interface

• Typically, it is best to layout process steps and boundary conditions prior to model setup to better understand how to 
configure the process in the simulation

• This carburization model will include a single step to model the diffusion of carbon into the ring while in a furnace:

• Carburization, 10620 seconds total time

• Material: 5120 carburized to near 0.8% Carbon content by weight at the surface
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Step 6: Creating Preliminary Sets, Part Element Set

12

• With the mesh defined, sets and surfaces based on the mesh can be defined to ascribe boundary conditions to the model
• These boundary conditions will be created inside of the Dante Model Builder Plug-In
• Sets and surfaces must be created in the Abaqus CAE and they will appear in the Plug-In automatically to be selected
• First define sets of elements to ascribe material properties

1. Go to the Part module

2. Under Tools → Set → Create

3. Give a name, select Element, and click Continue

4. Box select all the elements and click Done

• The entire cylinder is made of one material 
so all elements in the part are selected

1 2 3 4
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Step 6b: Creating Preliminary Sets, Monitor Node Set

13

• A monitor node is a node selected to allow for monitoring of the simulation job during computation
• Any node can be chosen from the mesh, depending on the area to be monitored
• The monitor node will be created in the Dante Model Builder Plug-In

1. In the Assembly module, create a node set by going to Tools → Set → Create

2. Rename the set aptly and select Node and Continue

3. Select a node on the part and click Done

3

2
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Step 6c: Preliminary Sets, All Nodes 

14

• Field variable values, such as carbon content and temperature, are applied to the nodes of the model
• So a node set must be defined containing all the nodes in the model to which these field values are to be applied

1. In the Assembly module, create a node set by going through Tools → Set → Create

2. Rename the set ‘ALLNODES’ and select Node and Continue

3. Box select all the nodes in the model and click Done
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Step 6d: Preliminary Surfaces

15

• Heat transfer coefficient boundary conditions are applied on surfaces, so it is best to visualize what heat transfer 
conditions are like on the surfaces of the components in question

• In this ring slice, the entire outer surface is exposed to the furnace atmosphere so the surface will be the 
boundaries of the geometry

1. In the Assembly module, create a surface by going to Tools → Surface → Create

2. Rename the surfaces ‘Outer_Surface’ and select Geometry and Continue

3. Box select all the surfaces in the model and click Done
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Step 7: Launching the Dante Model Builder Plug-In

16

1. Be sure to have saved the cae model under File

2. Launch the Dante Model Builder Plug-In from Plug-ins →Dante Model Builder

3. The following graphical user interface (gui) will appear1

2

3

• The Dante Model Builder packages together all 
aspects of the model set up stages and inserts 
all the proper information relevant to interface 
the DANTE user subroutines into the model
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Step 8: Setting Up the Dante Model

17

1. To set up a carburization model, select the dropdown menu next to 
Model Type and select Carburization

2. Click Create DANTE Model to apply the change

• This will prompt a warning dialog asking to confirm model type

3. Click Yes on this dialog to create model type

• This will set the Dante model type for the model and the Active 
Model label at the top of the gui should update to reflect the change

1

2

3
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Step 9: Creating and Assigning Material

18

1. To create and assign material to the model, proceed to the Material/Section tab

2. Under the Part Element Set dropdown, select an element set

• These are defined in the Part or Property Module and will automatically 
appear in the dropdown menu when created

• A part element set was created in step 6 and should appear in the dropdown

3. Under the Material Name dropdown, select a Dante material

• Initial Microstructure may be used to set the initial microstructure

• Alloy Composition allows for slight variations to be made to the chemical 
composition of the selected alloy 

4. Click Add Material Section and the material will be created, a section will be 
defined for the material, and a section assignment will also be created, assigning 
the section to the selected part set

• A message box should appear if successful and can be dismissed

1

4
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Step 10: Defining the Carburization Model Process Steps

19

1. Select the Steps tab to create process steps

2. One step will be created, under the Step Name, name the 
step ‘Carburization’, a Description can be provided, and the 
Previous Step should be set as shown in the figure

3. Under Time Period, type 10620 seconds since this process 
step lasts 10620 seconds

4. The Max. Time. Inc. can be reduced to 500 seconds

5. Check the Monitor Node checkbox to create a monitor node 
for a given single node set defined as shown in step 6

6. Finally, click Create Step to create the process step, it should 
appear in the right-hand step/frequency table 

• Since this is a carburization model, an Abaqus heat 
transfer step is created for the model

NOTE: Selecting a created step in the Step/Frequency 
table and clicking Edit Step will repopulate the step 
table with information from the selected step. This 
allows the user to edit and save step information with 
Save Step Edit
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Step 11: Creating Initial Conditions, Carburizing Temperature

20

• With the process steps defined, initial, boundary, and interaction conditions can be added

1. In the Initial/Boundary Conditions tab, click Add Initial Condition/Predefined 
Field to add initial conditions

2. There are two types of initial conditions that are needed for a DANTE 
carburization model: Carburizing Temperature and Total Carbon Weight 
Fraction; both defined at the Initial step

3. The Carburizing Temperature is defined for all nodes, so a node set containing 
all nodes should be defined as in Step 6: Preliminary Sets, All Nodes. This set 
will appear in the Region dropdown menu

4. Check the Constant Value checkbox to set a constant value uniform 
temperature in the carburized part and type in 900⁰C

5. Click Apply to create the initial condition and continue

1

2

3

NOTE: To model multiple carburizing temperatures, 
multiple steps can be defined, and the predefined fields 
can be added to those steps 
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Step 12: Initial Conditions, Total Carbon Weight Fraction

21

1. In the Initial/Boundary Conditions tab, click Add Initial Condition/Predefined 
Field to add initial conditions

2. The Total Carbon Weight Fraction is defined for all nodes, so a node set 
containing all nodes should be defined as in Step 6: Preliminary Sets, All 
Nodes. This set will appear in the Region dropdown menu

• Carbon weight fraction defined at the initial step is the initial distribution 
of carbon in the part.  Either a constant uniform distribution of carbon 
can be specified OR a carbon profile can be provided through external 
data

3. In this case, check the Constant Value box and enter 0.002. This is the carbon 
content in 5120 steel, 0.2% carbon content or 0.002 carbon weight fraction

4. Click OK to create the initial condition and exit the dialog

1

2

3
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Step 12b: Reviewing Initial Conditions and Predefined Fields

22

1. To review and edit initial conditions and predefined fields, click Initial 
Condition/Predefined Field Manager

2. A table of the predefined fields will appear containing the status of each 
at each step. Click on any column of a row to highlight a predefined field

3. Click Edit to edit the predefined field or Delete to delete it

• Use checkboxes to the left to suppress or unsuppress the predefined 
field, a check means the predefined field is unsuppressed 

1

2 3
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Step 13: Film Interaction Properties

23

1. Heat transfer coefficients are needed to define the interactions 
of the environment and the surfaces of the part, so film 
interaction properties are created, click Add Film 
Property/Amplitude

2. Give the name ‘Reaction_Factor’

3. Film coefficients as a function of temperature are defined which 
represents the rate at which carbon is deposited on the surface 
of the part as a function of surface carbon, so check the 
Temperature Dependence checkbox

4. Enter in the film coefficient vs temperature data: 
(0.0005,0.0010), (0.0150,0.0150)

5. Click OK to create the property and close the dialog

1

2

NOTE: Recall the temperatures in the data are carbon content as 
carbon diffusion models are identical in form to heat transfer 
problems, so heat transfer steps are used
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Step 13b: Reviewing Film Interaction Properties

24

1. To review and edit interaction properties or amplitudes, click Film 
Property/Amplitude Manager

2. A table of the interaction properties and amplitudes will appear 
containing the type. Click on any column of a row to highlight a 
property or amplitude

3. Click Edit to edit the item or Delete to delete it

• For the film property created, changes can be made to the 
film coefficients vs temperature if needed

1

2

3
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Step 14: Adding Interactions

25

1. Finally the heat transfer interactions can be added to the model 
based on the film property added in the previous step, click Add 
Interaction

2. The HTC vs Temperature option should be checked

3. Check Carburizing Potential (Wt. Frac.) and enter in 0.008

• This is the target surface carbon content weight fraction. 
That is, the 5120 material is being carburized to 0.8% carbon 
content

4. All surfaces of the ring are carburized, so all surfaces in this 2D 
case should be selected in a surface object. This surface is the 
‘Outer_Surface’ defined in Step 6: Preliminary Surfaces

5. Select the first step, Carburization. Thus, the part will be 
carburized to a 0.8% carbon content in the first step, subject to 
furnace conditions defined by the ‘Reaction_Factor’ film 
interaction property

6. Click OK to apply the property and close the dialog

1

2

3

4

5
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Step 14b: Reviewing Interactions

26

1. To review and edit interactions, click Interaction Manager

2. A table of the interactions will appear containing the status in 
each step. Click on any column of a row to highlight an interaction

• The left-hand column check boxes can be used to suppress 
interactions, Activate and Deactivate can be used to turn the 
interaction on or off in a certain step

3. Click Edit to edit the item or Delete to delete it

• The selected surface, film property, and ambient magnitude 
(in this case carburizing potential) can be edited from here

1

2 3
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Step 15: Configuring Carbon Model DANTE Controls

27

• Carburization models allow for control of the maximum carbon 
change per substep and the material directory

• The default values will suffice

• Grayed out rows cannot be edited in the respective model type

• This concludes the set up of the carburization model

• The next step is to submit the job, so be sure to save 
the model beforehand
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Step 16: Creating and Submitting the Carburization Job

28

1. A new model name can be given for the job name if desired 
in the New Model Name box, skip this here to use the 
original model name ‘simple_2d_ring_c’ as the job name

2. Click Submit Job and the following dialog box will appear 
asking for confirmation to submit the job, click Yes

• This will run a series of checks in the model to verify it, if 
something is found to be problematic, an error message 
box should appear. Otherwise, the CAE should switch 
over to the Job module and text confirming the run 
steps should appear in the CAE console. This indicates if 
the model was input successfully:

• At this point, the carburization model is complete, and a job can be 
created. Note that an input file can be written without submitting the 
job. The input file will get written regardless and, in both cases, 
checks are applied to verify that the proper DANTE model parameters 
have been specified for the respective model type

1

2

NOTE: At this point, the Plug-In may be exited 
by clicking cancel or ‘x’ out in the corner
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Step 17: Carburization Model Post-Processing

29

1. With the model completed or even in simulation, the results file, or Abaqus 
output database, can be opened from File → Open, select *.odb in File Filter
and the odb file ‘simple_2d_ring_c.odb’ and click OK

2. By opening the odb file, the CAE will switch to the Visualization tab, click on 
the Plot Contours on Deformed Shape button to display result contours for the 
temperature at the final time increment of the model

• Note that the temperature variable NT11 is displayed and that it 
represents the carbon content weight fraction due to the use of heat 
transfer steps in the Abaqus model

• Thus, this contour image shows the carbon distribution along a cross-
section of a ring slice that is carburized from 0.2% Carbon to 0.8% Carbon 
content by weight 

1

2

→
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Step 17b: Carburization Model Post-Processing

30

Options → Common
• By setting the Visible edges to Feature edges through the Options → 

Common settings, the contours will be shown without the meshing

• This can be helpful to better visualize results
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Step 18: Visualizing Carburization Solution Dependent Variables

31

• The other results may be visualized by selecting solution dependent variable results from the dropdown menu in 
the Visualization tab

• These variables were automatically assigned to the model input file through the Dante Model Builder Plug-In 
based on the assigned DANTE model type

• For this material and model, SDV_CRBALL shows the total Carbon weight fraction and should be similar to NT11 
with slight differences caused by numerical precision

NOTE: For further information on post-processing of these 
results, please refer to the tutorial: 
Dante5_0_Tutorial_2D_Axisymmetric_Ring_Slice_CAE
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Step 18b: Set up a Path Plot

32

1. A path plot is desirable for carbon in order to easily see carbon case 
depths. While in the Visualization module, go to Tools→ Path→
Create to open the Create Path dialog window. Name the path and 
select Node list and click Continue to select the nodes to make the 
path. 

2. In the Edit Node List Path popup window click on Add Before… in the 
viewport selections section

3. Click on a node on the surface of the part and follow the mesh line to 
the core of the part and select a node to use as the end of the path 
plot. Middle click or select done to set the nodes in the Edit Node List 
Path window and click OK to continue. 

4. With the path defined, go to Tools-> XY Data-> Create to open the 
Create XY Data window. Choose Path and click Continue. In the XY 
Data from Path window that opens, ensure that the path that was 
created is selected and check the box that states Include intersections 
to include every node along the path. Finally, click plot to 

1. show the Carbon vs. Depth plot.
5. From the Report menu, select 
XY… to open the Report XY Data
window. In the XY Data tab select the 
data in the current viewport, and under
the Setup tab rename the file what you 
wish with a .xls extension to save the 
carbon path data. Click OK or Apply to 
write the carbon data to the Exel file. 

1

2

3
4

4
5



Copyright © 2019 DANTE Solutions. All rights reserved.

Step 19: Generating the Carbon Distribution File

33

• The Carbon distribution in the component can be written out into an external file and used in the thermal and stress models

1. To write out the carbon profile of the part from the end of the 
carburization process, go to the Carbon/Nitrogen File tab in 
Dante Model Builder and click File Select and open the output 
database ‘simple_2d_ring_c.odb’, the file name should appear 
next to Active ODB:

2. Give a name for the carbon profile to be generated, 
‘simple_2d_ring_c’, here it will be given a ‘.cbn’ extension 
automatically

3. The Step and Increment dropdown menus will be populated with 
the available steps and step increments from the output 
database, select the last step and last increment in the list to 
write out the final carbon weight fraction

4. For the Profile Type, Carbon Weight Fraction should be selected

5. Click Create Profile to write out the carbon file, a file with the 
name and extension: ‘simple_2d_ring_c.cbn’ will be written out 
to the current working directory

1

2

3
4

5
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Thermal Model

34
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Thermal Model

35

1. To create a thermal model, a new model can be added under the model tree, or in the Plug-
In, select Thermal for Model Type in the Model tab, with the carbon model as the Active 
Model

2. Give a New Model Name, here ‘simple_2d_ring_t’

3. Click Create DANTE Model

4. Click Yes to create the model

5. Since a model name and type are given, the active model will be 
copied and a new model should appear in the model tree if Yes is 
clicked in the next dialog box asking to create the model

6. Switch to the newly created Thermal model in the Active Model

1

2

3

4

5

6

NOTE: Be sure to save the model at this point
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Step 1: Creating and Assigning Material

36

• Materials and sections must be defined and assigned to the proper regions in the geometry. This is done from the 
Material/Section tab in the same way as in Step 9: Creating and Assigning Material and the material and element set 
should be the same
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Step 2: Defining the Thermal Model Process Steps

37

• The thermal model steps are defined like the carburization model steps from step 10, as follows: 

NOTE: All steps should have the Step Amplitude
set to Step EXCEPT for the Carburization step 
where the Carbon profile will be mapped into 

the thermal model. Set Step Amplitude to 
RAMP when mapping in Carbon profiles

1

2

3

4

5

• Be sure to check the Monitor Node check box and select the monitor node set. Once completed, save the CAE model
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Step 3: Creating Initial Conditions

38

• Thermal models require at least 4 types of initial conditions: Temperature, Phase Transformation Kinetics, Total Carbon 
Weight Fraction, and Nitride B Size Factor (which is added automatically so long as the others are defined properly)

• These initial conditions can be 
reviewed in the Initial 
Condition/Predefined Field Manager
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Step 4: Predefined Field to Map In Carbon Profile

39

1. To map in the carbon profile, the external .cbn file created 
previously will be read in at the Carburization step (where it 
will be gradually ramped into the model)

2. Carbon will be read in as a Total Carbon Weight Fraction
field in the set of all nodes, defined in ALLNODES

3. Check External Data and File Select the carbon profile with a 
.cbn file extension

• Since this field data is read in from an external file 
instead of an output database, the From Step and From 
Frame boxes do not need to be filled in

4. Click OK to finish 

3

2

4

NOTE: You may get this error message if the number of characters in 
the file path to the external file exceeds 80 characters. In that case, 

you can simply rename the *.cbn file to a shorter name or move it to a 
directory closer to root
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Step 5: Defining Film Properties

40

1. Click Add Film Property/Amplitude in the Initial/Boundary 
Conditions tab

2. Properties for the furnace, oil quenchant, and air cooling are 
defined; Give a name and check Temperature Dependence

3. Right click on the first row and column and click Read from 
File, film coefficient vs temperature information can be given 
in ascii text file format and some are in the DANTE parent 
directory in the Generic_HTC_Data folder

• These lines can also be pasted into table or filled out 
line-by-line

4. Click OK to insert the data lines, a warning box may appear, 
click Dismiss

2

3

4

NOTE: DANTE comes with 
representative HTC data files which can 
be used or modified to fit specific 
cooling rates. Cooling rates differ from 
process to process, so experimentation 
may be needed to fit HTC values to a 
certain process.

3
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Step 5b: Defining Film Properties

41

5. Some of the rows may contain extra information from the text file, highlight 
any rows containing non-values, right click and Delete Rows and click Apply

6. Data used from the Generic_HTC_Data folder for the following properties 
includes: Generic_Furnace_Heating.TXT for Heat-Up, Generic_Still_Air.TXT for 
Air-Transfer, Generic_Oil_Quench.TXT for Oil-Quench, and 
Generic_Air_Cool.TXT for Air-Cool →

5

Note: These heat transfer 
coefficients can be specified 

as constant values by 
unchecking both dependences 

and giving a single value or 
directly in the Add Interaction 
dialog. They can be edited or 

deleted from the Film 
Property/Amplitude Manager

6

6 6
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Step 6: Thermal Model Interactions

42

1. In the Initial/Boundary Conditions tab, click Add Interaction to now add the previously created film properties as 
interactions to the surfaces of the ring slice geometry at each respective step

Each step must have an 
ambient temperature 

associated with it, here those 
values are constant
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Step 6b: Thermal Model Interactions

43

NOTE: Nothing needs to be changed on the table at this point, but it is a good idea to be aware of it.

• Please review the interactions to make sure they are inserted at the proper step AND that each step has an 
interaction associated with it, EVEN if that interaction is Propagated from another step

• By default, this Plug-In deactivates the interaction properties at all the steps in which they are not defined. 
Thus it is important to review each step to be sure that an interaction is properly defined or propagated

• Failure to do so might result in an error during simulation run time
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Step 7: Thermal Model Dante Controls

44

• The thermal model allows the user to change every DANTE 
control keyword in the Controls tab except for Stress Effect 
on Phase Transformation and Stress Relaxation since these 
two are available only in the stress model

• Everything on this page can be left as default
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Step 8: Creating and Submitting Thermal Job

45

• Please refer to Step 16: Creating and Submitting Carburization Job for the steps on how to submit the job

• Once again, this thermal model input can be written out if desired or the job can be submitted directly

1. In the Model tab, click Submit Job

2. Click Yes to write input file and submit job

1

2

If the model run is successful, the lines should be 
displayed in the Abaqus CAE console
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Step 9: Thermal Model Post-Processing

46

1. To open the thermal model output database, similar steps may be taken to Step 17: Carburization Model Post-Processing

2. The simple_2d_ring_t.odb should be in the working directory and is the output database created from running the thermal 
model. It will open in the Visualization module and the dropdown menu in the CAE toolbar can be used to view results.

1

2

NOTE: Be sure to save the model at this point
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Step 10: Visualizing Thermal Solution Dependent Variables

47

1. By selecting a solution variable, the contour image of the ring slice will be shown. By inspection, the ring slice has 
formed a martensitic case on the surfaces of the ring with high hardness and soft core in the middle
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Stress Model

48
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Step 1: Creating a Stress Model

49

• As with the previous Carbon 
and Thermal model, the Stress 
model may be built in a similar 
fashion

• However, the Dante Model 
Builder Plug-In provides the 
option to convert a thermal 
model to a stress model which 
is the method used here. This 
allows for quicker stress model 
set up

1. Open the Abaqus CAE and the CAE model used in this tutorial

2. Set the Active Model to the previous Thermal model

— Note that when the Active Model is a Thermal model, the Convert to Stress 
button is no longer grayed out, meaning it can be used to convert an active 
thermal model into a basic stress model

3. Provide a New Model Name (simple_2d_ring_s)

1

2

3

NOTE: If a name is 
not provided, the 

Active Model 
name will be used 
with an ‘_s’ added 

to the end



Copyright © 2019 DANTE Solutions. All rights reserved.

Step 1b: Creating a Stress Model
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4. Click the Convert to Stress button and Yes to confirm model conversion

• If successful, this will create a DANTE stress model based on the thermal 
model by converting the heat transfer steps to static structural steps

5. Since a new model is inserted into the model tree, the Plug-In must update, so 
set the Active Model to the newly created stress model

• Note that the module should have changed to the Mesh module

6. Click Yes to switch to the stress model

4

5

6

NOTE: Be sure to save the model at this point

NOTE: The Convert to Stress feature is supposed to convert the 
relevant DANTE parameters for the stress model as well as recreate 
the thermal steps as stress steps. This saves the user time as they do 
not have to redefine the same steps in the stress model or insert the 
relevant DANTE stress model commands in the input file. What 
remains is to switch the mesh element type to stress elements and 
add basic stress displacement boundary conditions to the model
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Step 2: Converting Mesh to Stress Elements
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1. The user must manually change the mesh type by selecting Mesh → Element Type

2. Box select the entire ring slice and click Done

3. In the Element Type dialog box, select Axisymmetric Stress in this case and uncheck the Reduced Integration 
box to use CAX4 elements 

1 2

3



Copyright © 2019 DANTE Solutions. All rights reserved.

Step 3: Converting Mesh to Stress Elements 

52

NOTE: If the CAX4 elements are used, this slide is irrelevant. 

1. If you wish to use reduced integration points make sure to check the box

2. Then click on Stiffness in the Hourglass control section

3. At the top again, the Hourglass stiffness can be specified, so set it to 225, this value should work for most cases

1
2

3
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Step 4: Reviewing the Material
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• The material, section, and section assignment should have been preserved from the thermal model and 
the material properties should have been converted to Mechanical material properties

• Double click the material S51XX under the 
simple_2d_ring_s model tree to view the 
material definitions if desired. Clicking 
User Material will show that the material 
constants are now defined under the 
Mechanical material type

• When defining material for a stress model 
from scratch, the plug-in Material/Section 
tab may be used to insert the DANTE 
material information into the CAE model 
directly or it can be defined manually 
under the model tree
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Step 5: Reviewing Initial Conditions and Predefined Fields
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1. Back in the Plug-In, review the Initial Condition/Predefined Field Manager table, the temperature profile 
should have been mapped into the stress model from the thermal output database at each step

• If they are not there or if a stress model is being built independently of the thermal model, create these 
temperature predefined fields from the Add Initial Condition/Predefined Field box to specify the External 
Data from an external file or output database and setting the step and step increment to retrieve the 
temperature information

• All other predefined fields should be available as well
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Step 6: Defining the Displacement Boundary Conditions
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1. To fix this axisymmetric model, a single node must be fixed so a node set must be defined in the Assembly module → Tools 
→ Set → Create and give a name and select Node and Continue

2. Select the node on the corner at the inner diameter of the ring slice and click Done

3. Go to Initial/Boundary Conditions tab → Add Displacement Boundary Condition

4. Let the Step be ‘Initial’, choose the node set defined above, and check u2 so that the node does not move in Y-dir, thus 
fixing the 2D axisymmetric part while allowing it to grow and shrink due to the thermal and phase transformation effects

5. Click OK to finish the boundary condition, this can be reviewed and edited in the Boundary Conditions Manager

1

2

3
4

5

NOTE: Since this is an 
axisymmetric model, ONLY u1, 
u2, and ur3 can be selected
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Step 7: Reviewing the Stress Model Dante Controls and 
Submitting the Job
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• The DANTE controls can also be reviewed, no changes will be made here, but notice how the 
Latent Heat from Phase Transformation and Latent Heat due to Melting/Solidification are 
read-only 

• This concludes the stress model setup, be 
sure to save the model, go to the Model
tab and click Submit Job or Write Input File 
as was done previously

NOTE: If the model runs successfully, the following messages should appear in the CAE console 
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Step 8: Stress Model Post-Processing
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1. Open the stress model output database with File → Open 

2. From the dropdown, select a stress state to view such as Mises

3. Displacement as well as all the other DANTE solution dependent 
variables can be viewed as well

4. Under Options → Common, change the deformation scale factor 
to 1 to view actual deformed shape and select Feature edges

→

4

2
3

1


