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Introduction

2

Background
• This workshop will demonstrate nitriding modeling coupled between ANSYS 2020 R1 (or later) and DANTE 

using a simple sliced ring model

• This workshop includes sequentially coupled nitriding, thermal and stress models

Objectives
• Setting up heat treatment models

• Using ANSYS ACT for DANTE models

• Post-processing modeling results
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Step by Step Workshop

3

Thin Sliced Ring 

1. Model Geometry and Meshing

2. Nitriding Model

3. Nitriding Thermal Model

4. Nitriding Stress Model
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Model Geometry and Meshing 
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Step 1: Start Ansys Workbench

5

1. Start Workbench

Software required for this project:

➢ ANSYS Mechanical Enterprise 2020 R1 or later

➢ DANTE (Compiled user subroutines and materials database)

➢ DANTE ACT

NOTE: All packages should be installed prior to this workshop

NOTE: This workshop is developed under 2020-R1 but will 
work for any version 2020-R1 and later

1
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Step 2: Activate the DANTE ACT

6

1. Click Extensions →Manage Extensions

2. In Extensions Manager, check the DANTE ACT (Dante6-0_ACT2-8_ans194-and2022r2)

1

2
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Step 3: Check Units

7

It is critical that the units be properly defined

1. Select Units→ Unit Systems

2. Toggle cell 8B for Metric (kg,mm,s,°C,mA,N,mV)

Note: If you prefer these units as default, also toggle cell 8C

3. Ensure Metric (kg,mm,s,°C,mA,N,mV) is checked

1

2

3
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Step 4: Create Project

8

1. Drag and drop Mechanical Model from the Component 
Systems into the Project Schematic

2. Rename it as “Sliced Ring Model” 

3. Save the project with a unique name 

1

2

3
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Step 5: Import the Geometry

9

The sliced ring geometry for this workshop will be imported 
from a CAD model created by the instructor

1. Right click Geometry→ Import Geometry → Browse

2. Open the Ring_Slice_Nitrided.x_t file provided

3. Double click Model
1

3

2
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Step 6: Define Surfaces for Meshing & Boundary Conditions

10

1. Click Face Selection

2. Select the outer surface

3. Right-click and select Create Named Section

4. Name the selection Outer_Surface and click OK

3

1

2

4
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Step 7: Define Units

11

It is critical that the units be properly defined

1. Select Units under Home

➢ Metric (mm, kg, N, s, mV, mA)

➢ Degrees

➢ rad/s 

➢ Celsius (For Metric Systems)
1
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Step 8: Define Meshing Parameters

12

1. Select Mesh in the Project Tree

2. Modify the Details of “Mesh”

➢ Physics Preference → CFD

➢ Use Automatic Inflation → All Faces in 
Chosen Named Selection

➢ Named Selection → Outer_Surface

➢ Inflation Option → Total Thickness

➢ Number of Layers → 40

➢ Growth Rate → 1.1

➢ Maximum Thickness → 1.0 mm

1

2
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Step 9: Mesh the Component

13

1. Right click Mesh→ Generate Mesh

2. The mesh should look like the image below

3. Close ANSYS Mechanical and save the project

1

2

3
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Nitriding Model
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Step 1: Nitriding Model Analysis System

15

1. Drag and drop Transient Thermal Analysis 
System into the Project Schematic

2. Rename it “Nitriding Model”

3. Drag and drop Model to Nitriding Model

4. Right click Model→ Update

5. Double click Model

1

2

3

4

5
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Step 2: Check Units

16

It is critical that the units be properly defined

1. Click on Units in the Home toolbar

2. Select Metric (mm, kg, N, s, mV, mA)

3. Select Degrees

4. Select rad/s (This isn’t critical as there is no 
motion defined in the heat treatment models)

5. Select Celsius (For Metric Systems)

1

2

3

4

5
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Step 3: DANTE Model & Initial Temperature
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1. Select Dante Model → Nitriding

2. Click Initial Temperature

3. Enter 0 for Details of “Initial Temperature”

1

2

3
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Step 4: Define Processing Steps

18

1. Select Analysis Settings

2. Set the values under Details of “Analysis Settings”:

➢ Step End Time: 36000s

➢ Auto Time Stepping: On

➢ Minimum Time Step: 1e-6s

➢ Maximum Time Step: 36000s

3. Set Nonlinear Formulation to Full under Nonlinear Controls

1

2

3
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Step 5: Assign Material

19

1. Select Material from the Dante Toolbar

Details of “Material”:

2. Click on the yellow box next to Geometry
→ Select the part body

3. Select Apply for Geometry

4. Select Material Name → SH13

1

2

3
4
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Step 6: Define Nitriding Temperature

20

1. Select  Nitriding Temperature from the Dante 
Toolbar

2. Click Tabular Data

3. Add 2 rows to the table and input the time-
temperature data

➢ Constant 525⁰C for 36000s

4. Click Apply

2

3

4

1
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Step 7: Define Nitrogen Control

21

1. Select Model Control from the Dante toolbar

1



Copyright © 2023 DANTE Solutions. All rights reserved.

Step 8: Define Output Frequency

22

1. Select Output Frequency from the Dante toolbar

2. Click Tabular Data 

3. Keep the default values → click Apply

3

1

2
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Step 9: Define Nitriding Boundary Conditions

23

1. Select Convection from Environment toolbar

2. Select Scoping Method → Named Selection

3. Select Named Selection → Outer_Surface

4. Enter 5e-4 (W/mm2C) for Film Coefficient

5. Enter 9e-3 (N Wt. Fraction) for Ambient Temperature

1

2

3

5

4
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1

2

Step 10: Running the Nitriding Model

24

1. Select Finalize Model Settings from the Dante Toolbar

2. Save the model

3. Right click Solution→ Solve

3
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Step 11: Nitrogen Model Post-Processing

25

1. Under Dante Results select Nitrogen All

2. Right click Nitrogen All → Evaluate All Results

3. Check the result

NOTE: These DANTE results can be added 
before running the model, when solving the 
model, they will be evaluated along with it

1

1
2

3
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Step 12: Exporting Nitrogen Profile

26

1. Select Write Nitrogen Profile from the Dante
Toolbar

2. Under Details of “Write Nitrogen Profile”,
change the file name to “sliced_ring_nc” for
Save Data

3. Right click Write Nitrogen Profile → Evaluate All
Results

1

23
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Step 13: DANTE Carbon Profile Directory

27

Project 
Directory Project Name

Saved nitrogen file in Project directory (the 
directory in which you saved your current 
Project) with a folder name as “dante_files” 
as a .ntg file 

Save the Project and close Ansys Mechanical
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Nitriding Thermal Model
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Step 1: Thermal Model Analysis

29

1. Drag and drop a Transient Thermal Analysis 
System into the Project Schematic

2. Rename it as “Nitriding Thermal Model”

3. Drag and drop Model from Sliced Ring 
Model to Nitriding Thermal Model

4. Double click Model in the Nitriding Thermal 
Model

1

2

3

4
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Step 2: Check Units

30

It is critical that the units be properly defined

1. Click on Units in the Home toolbar

2. Select Metric (mm, kg, N, s, mV, mA)

3. Select Degrees

4. Select rad/s (This isn’t critical as there is no 
motion defined in the heat treatment models)

5. Select Celsius (For Metric Systems)

1

2

3

4

5
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Step 3: Define DANTE Model & Initial Temperature

31

1. Click on Dante Model in the Dante Toolbar and select Thermal

2. Select Initial Temperature in the Project Tree

3. Change the Initial Temperature Value to 20.0 °C

1

2

3
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1

Step 4: Define Processing Steps

32

1. Select Analysis Settings

2. Enter 3 for Number of Steps

3. Set Current Step Number to 3 and enter values

4. Set Current Step Number to 2 and enter values

5. Set Current Step Number to 1 and enter values

6. Set Nonlinear Controls → Nonlinear 
Formulation → Full

Current Step 
Number

Step End 
Time

Auto Time 
Stepping Define By

Carry Over 
Time Step

Initial Time 
Step

Minimum 
Time Step

Maximum 
Time Step

Time 
Integration

3 43200
On Time

Off
1.00E-02 1.00E-05

3600
On2 39600 36000

1 3600 N/A 3600

3

2

Thermal modeling of the nitriding process involves modeling 
of 3 steps: the part heat up, processing, and cooling down

4 5

6
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Step 5: Assign Material

33

1. Select Material from the Dante 
Toolbar

2. Click on the yellow box next to 
Geometry→ Select the part body

3. Select Apply for Geometry

4. Select SH13 for Material Name

5. Enter 0.004 for Carbon and Carbon in 
Carbide

6. Click Tabular Data for Mat. Initial 
Phase and set values as shown

➢ Initial microstructure composed 
fully of tempered martensite, 
set to 1 with other phases 0

7. Click Apply

1 2

3

7

5

4

6
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Step 6: Define Control File

34

1. Select Model Control in the Dante toolbar

2. Select Default Phase-Transform Kinetics-Mode → (-7): Rate Dependent|Active|Active

3. Click Tabular Data → Kinetics-Mode Table

4. Click Apply

2

1

3

4
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Step 7: Define Output Frequency

35

1. Select Output Frequency from the Dante toolbar

2. In Details of “Output Frequency”, click on Tabular Data 

3. Leave the default frequency values as 2

4. Click Apply

1

2

3

4

1
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Step 8: Importing Nitrogen Profiles

36

1. Select C/N Profile from the DANTE Toolbar

2. Set Number of Nitriding Profiles → 1

3. Click Nitriding file, navigate to dante_files, select the nitrogen profile and click Open

4. Under Carburization/Nitriding Activation Table, click Tabular Data

5. Set Nitriding→ 1 at Step 2 to activate it and click Apply

1

4

2
3

5
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Step 9a: Defined Thermal Boundary Conditions

37

1. Add 2 Convections from the Environment toolbar to the Project Tree

2. Right-click on the Convections and rename to Heating, Quench

2

1
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Step 9b: Heating Thermal Boundary Condition

38

1. Select Heating and set Scoping Method to Named Selection

2. Set Named Selection → Outer_Surface

3. Set Film Coefficient to 1e-4 (W/mm2C)

4. Set Ambient Temperature to 525⁰C

5. Under Details of “Heating” → Tabular Data, right-click on 
row 4 and select Activate/Deactivate at this step

2

1

3

4

5

This applies the boundary condition 
only to the heating/processing steps
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Step 10: Quench Thermal Boundary Condition

39

1. Select Quench and set Scoping Method to Named Selection

2. Set Named Selection → Outer_Surface

3. Set Film Coefficient to 1e-4 (W/mm2C)

4. Set Ambient Temperature to 20⁰C

5. Under Details of “Quench” → Tabular Data, right-click and 
highlight all rows except row 4 and select 
Activate/Deactivate at this step

2

1

3

4

5

This applies the boundary 
condition only to the quench step
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Step 15: Running the Thermal Model

40

1. Select Finalize Model Settings from the Dante toolbar

2. Save the model

3. Right-click Solution→ Solve

1

2

3
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Step 16: Post-Processing Thermal History

4141

1. Under Dante Results select Total 
Hardness

2. Right click Total Hardness→ Evaluate 
All Results

3. Check results

4. Save the Project and close Mechanical

NOTE: These DANTE results can be added 
before running the model, when solving the 
model, they will be evaluated along with it

2

3

1

4
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Quench Hardening Stress Model
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Step 1: Stress Model Setup, Add Analysis System to 
Project Schematic

43

1. Drag and drop a Static Structural Analysis 
Systems into the Project Schematic

2. Rename it as “Nitriding Stress Model”

3. Drag and drop the Model from Sliced Ring 
Model to Nitriding Stress Model

4. Drag and drop the Solution from Nitriding 
Thermal Model to the Setup of Nitriding 
Stress Model

5. Double click Setup in the Nitriding Stress 
Model

1
2

3

4
5
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Step 2: Check Units

44

It is critical that the units be properly defined

1. Click on Units in the Home toolbar

2. Select Metric (mm, kg, N, s, mV, mA)

3. Select Degrees

4. Select rad/s (This isn’t critical as there is no 
motion defined in the heat treatment models)

5. Select Celsius (For Metric Systems)

1

2

3

4

5
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Step 3: Define DANTE Model & Initial Temperature

45

1. Click on Dante Model in the Dante Toolbar and select Stress

2. Click on Static Structural in the Project Tree

3. In the Details of “Static Structural”, change Environment 
Temperature to 20 °C

1

2

3
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Step 4: Define Processing Steps

46

1. Select Analysis Settings

2. Modify the Details of “Analysis Settings”

NOTE: The step numbers MUST be entered from highest to lowest; i.e., start with 
Current Step Number 7

3. Repeat for Current Step Numbers 6 through 1

Current Step 
Number

Step End 
Time

Auto Time 
Stepping Define By

Carry Over 
Time Step

Initial Time 
Step

Minimum 
Time Step

Maximum 
Time Step

7 25812

On Time
Off

1.00E-02 1.00E-05

3600

6 18612 3600

5 11412 3600

4 4212 600

3 3612 10

2 3601 1

1 3600 N/A 3600

1

3

2
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1

Step 4: Define Processing Steps

47

1. Select Analysis Settings

2. Enter 3 for Number of Steps

3. Set Current Step Number to 3 and enter values

4. Set Current Step Number to 2 and enter values

5. Set Current Step Number to 1 and enter values

Current Step 
Number

Step End 
Time

Auto Time 
Stepping Define By

Carry Over 
Time Step

Initial Time 
Step

Minimum 
Time Step

Maximum 
Time Step

3 43200
On Time

Off
1.00E-02 1.00E-05

3600

2 39600 36000

1 3600 N/A 3600

3

2

The part heat up, nitriding, and cooling down steps are analyzed in the stress model

4 5
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Step 5: Assign Material

48

1. Select Material from the Dante 
Toolbar

2. Click on the yellow box next to 
Geometry→ Select the part body

3. Select Apply for Geometry

4. Select SH13 for Material Name

5. Enter 0.004 for Carbon and Carbon in 
Carbide

6. Click Tabular Data for Mat. Initial 
Phase and set values as shown

➢ Initial microstructure composed 
fully of tempered martensite, 
set to 1 with other phases 0

7. Click Apply

1

2

3

7

5

4

6
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Step 6: Define Control File

49

1. Select Model Control in the Dante toolbar

2. Select Default Phase-Transform Kinetics-Mode → (-7): Rate Dependent|Active|Active

3. Click Tabular Data → Kinetics-Mode Table

4. Click Apply

2

1

3

4
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Step 7: Define Output Frequency

50

1. Select Output Frequency from the Dante toolbar

2. In Details of “Output Frequency”, click on Tabular Data 

3. Leave the default frequency values as 10

4. Click Apply

1

2

3

4
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Step 8: Importing Nitrogen Profiles

51

1. Select C/N Profile from the DANTE Toolbar

2. Set Number of Nitriding Profiles → 1

3. Click Nitriding file, navigate to dante_files, select the nitrogen profile and click Open

4. Under Carburization/Nitriding Activation Table, click Tabular Data

5. Set Nitriding→ 1 at Step 2 to activate it and click Apply

1

4

2
3

5
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Step 9: Import Thermal History

52

1. Expand Imported Load (C4) in the Project Tree

2. Select Imported Body Temperature

3. In Details of Imported Body Temperature, set the 
Source Time to All

4. Right click on Imported Body Temperature in the 
Project Tree and select Import Load

1

2

3

4
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Step 10: Define Mechanical Boundary Conditions

53

1. From the Environment toolbar, add a 
Frictionless Support and Displacement to 
the Project Tree

➢ Click on Static Structural to add 
structural boundary conditions

2. In the Details of “Frictionless Support”, 
click the yellow box next to Geometry

3. Select the two internal faces of the ring 
slice holding the Ctrl key and click Apply

4. In the Details of “Displacement”, click the 
yellow box next to Geometry

5. Select the bottom inner vertex and click 
Apply

6. In the Details of “Displacement”, set the 
Y Component to 0

1

2

3

4

5

6

3
Note: Use the selection modes 

to select vertices and faces
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Step 11: Running the Stress Model

54

1. Select Finalize Model Settings from the 
Dante toolbar

2. Save the model

3. Right-click Solution→ Solve

2

3

1
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Step 12: Stress Model Post-Processing, Stress Results

55

1. Right-click Solution in the Project Tree and 
select Insert → Stress → Normal

2. In Details of “Normal Stress”, select the Y 
Axis, signifying axial stress

3. Right click on Normal Stress and select 
Evaluate All Results

1

2

3

4

1

The part surface is in high compression in the axial and circumferential direction

NOTE: This concludes the tutorial, save and close Ansys Mechanical
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