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Disclaimer and Safety
Lasers use intense beams of light to create heat and fire as a normal part of their operation, and

depending on the laser, the light might not be visible to you. When used safely, a laser cutter is

an incredibly useful tool. However if the proper safety measures are ignored, you could burn or

blind yourself or someone else, or start a fire that could damage or destroy your home, or in the

worst case, kill someone. CO2 lasers use high voltages, and if wired incorrectly could kill you.

Do not leave a running laser unattended.

By using this software, the user accepts complete responsibility for each and every aspect of

safety associated with the use of the laser machine, laser system and LightBurn Software.

You agree that:

You will not hold the author or contributors of LightBurn liable for any damage to equipment

or persons from the use of LightBurn.

You understand the potential hazards in using high power lasers and high voltages.

You will wear proper eye-protection rated for your laser when operating it.

You will use the LightBurn software in a legal and safe manner.

You relieve the author and contributors from any liability arising from the use or distribution

of the LightBurn software.

You are entirely operating at your own risk. Lasers can be lethally dangerous. 



Return to main page

Setting up LightBurn for the first time
Downloading the software

Installing LightBurn

Running LightBurn for the first time

Next Step: For more info on how to use LightBurn, check out the Software walk-through for

beginners
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Adding Your Laser to LightBurn
LightBurn can’t control every laser, but it can talk to a number of different types of laser

controllers, all of which use different ways of communicating, and have different abilities and

settings.

This step tells LightBurn what you have.

If you’ve never configured a device in LightBurn, you’ll be brought here automatically when you

run the software. It is important that you pick something because the interface in LightBurn will

change depending on the capabilities of the laser you choose.

LightBurn can also be configured to control more than one laser, and there are settings stored for

each device. If you don’t pick one, we have nowhere to put these settings, and a number of

features within LightBurn will not work until this is set up.

THE DEVICES PAGE

DevicesPage

This is the Devices page in LightBurn. Here you will see a list of all the laser devices you’ve added

to LightBurn, or an empty list when you’re first starting.



The simplest way to proceed is to click ‘Find My Laser’ and let LightBurn try to figure out what you

have. If that doesn’t work, your laser connects with Ethernet, or you have a Marlin device, you’ll

need to use ‘Create Manually’.

Find My Laser

Create Manually

file:///home/runner/work/NewDocs/NewDocs/docs/FindMyLaser.md
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Configuring a laser for use with
LightBurn
If you have a DSP controller that came already installed in your laser, you shouldn’t need to do

anything to set your machine up for use with LightBurn, and can move on to the beginner

walkthrough.

If you have a GCode controller, particularly if you also use your system as a CNC or 3D printer,

there may be additional configuration required.

Common GRBL setups

Troubleshooting (to be completed)
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LightBurn walk-through for beginners
If you’ve never used LightBurn before, the main window might seem a little intimidating. Try not

to let it scare you - we’ll break out the important sections to start with. LightBurn also has a

couple features to make it easier to learn:

Pop-up tips: If you hover the mouse over a control, you’ll see a small bit of text that describes that

button or feature, like this:

ToolTips-1

Context-help: If you hover the mouse over something and press the F1 key (help), LightBurn will

launch the help page for that feature in your browser. Most of the panels and buttons on the main

window of LightBurn will do this.

THE MAIN WINDOW

This is the default layout for the main LightBurn window:

MainWindow

Here it is again, with the sections labeled:



MainWindow

It’s worth noting that along the very bottom of the main display is a status bar that will

occasionally show information like an automatic backup in progress, position of the cursor, laser

connecting, and so on.

The main sections of the user interface are:

Menus

Main Toolbar

Creation & Modifier Tools

Color Palette

Cuts / Layers window

Size and Position / Numeric Edits

Font and Text properties

Laser control window

The workspace / Edit window

For a full list of the windows in LightBurn, see the LightBurn Windows topic in the help.

These are the windows you will use most commonly, though there are others. If you ever close

one accidentally and want it back, go to the menu, click Window, and re-enable the window you

want back.

MENUS

Almost all desktop software uses menus in some form. The menu bar at the top of the main

window gives you access to almost every feature available in LightBurn.



Menus

Depending on the operating system you’re using the menus might appear a little differently, and

some features may be removed if your laser doesn’t support them.

If a feature has a shortcut, it will be shown next to it in the menu, as shown above. Learning the

shortcuts for the features you use most often will make using LightBurn much faster, and

sometimes there are even ‘shorter’ shortcuts - you can find these in the help menu under Help >

Quick Help and Notes.

Menus in depth (to be completed)

MAIN TOOLBAR

The main toolbar in LightBurn gives you quick access to commonly used functions for opening or

importing files, saving, using the clipboard (copy & paste), moving or zooming the view. Right

beside it is the Arrangement toolbar, containing some commonly used arrangement tools for

arranging and aligning shapes.

MainToolBar

If you aren’t sure what a button is for, hover the mouse over it and it will tell you:

MainToolbar-Tooltip

Main Toolbar in depth (to be completed)

Arrangement Toolbar in depth (to be completed)



CREATION & MODIFIER TOOLS

The shape creation tools are normally arranged vertically, but we’re showing them sideways here.

By default, these are docked along the left side of the work space for quick access.

CreationTools

The first tool, ‘Select’ is probably the one you’ll use most, and is the default tool chosen when

LightBurn starts. The others are used to create basic shapes like circles and rectangles, text, and

lines, and there are few for modifying shapes in more complicated ways, like merging shapes, or

creating lots of copies of shapes.

Creation Tools in depth

Modifier Tools in depth

COLOR PALETTE

The color palette lives along the bottom of the main window by default, though a common

alternative is docking it next to the creation tools along the left.

ColorPalette

Lasers don’t “print” in color, so these colors are used to assign different kinds of operations to the

shapes in your design. A common convention is to use bright red for cuts, though how you use the

colors is up to you.

With nothing selected in the workspace, click a color entry and new shapes will be created in that

color. If you have something selected, clicking a color entry will apply that color to the shapes in

your selection. The colors currently in use in your design will also appear as entries in the Cuts /

Layers window, where you can choose the operations that each color represents.

CUTS / LAYERS

This window shows the colors currently in use in your design, and lets you quickly access the

settings assigned to them.



CutsAndLayers

The first column shows the name you’ve assigned to this layer, followed by the color, then the

Mode (Line, Fill, both, or Image). Then the speed and power are displayed, followed by the options

to enable or disable sending this layer to the laser, or displaying it in the workspace.

Underneath the layer list you can see and change the basic settings for the currently selected

layer. If you double-click an entry in the layer list, it will bring up a larger Cut Settings Editor, with

a more complete set of options.

Cuts / Layers window in depth (to be completed)

SIZE AND POSITION / NUMERIC EDITS

The Numeric Edits toolbar lets you resize, position, and rotate shapes, and change the unit of

measure.

NumericEdits

The lock button can be used to maintain the aspect ratio of your objects when changing the size,

and the 9-dot control lets you choose the point that positioning and sizing happens from. The

number entry boxes accept equations and units, too - You can enter 5mm, 5in, 5", 5*3mm, and so

on, and LightBurn will calculate the correct result for you.

Numeric Edits toolbar in depth (to be completed)

FONTS AND TEXT CONTROLS

The font and text toolbar will activate when you use the ‘Create Text’ tool, or select text objects.



FontAndText

This toolbar lets you change the font, size, spacing, alignment, and automatic welding. It also has

settings for variable text options, like serial numbers, dates, and using data tables from a CSV file.

Fonts and Text in depth (to be completed)

LASER WINDOW

The Laser window is used to choose the laser to use, test the position of a file (frame), run or stop

the laser, and choose various options that affect how the current file will be processed, ordered,

and positioned on the machine.

LaserWindow

Note that this window may look different for you depending on the type of laser chosen and the

options it supports, and some options will be hidden if you are in ‘Beginner Mode’.

Laser Window in depth (to be completed)

WORKSPACE / EDIT WINDOW

Finally, the workspace, or edit window, is the drawing area where you lay out your design. The

size of the border and grid drawn in the workspace matches the available work area on your

machine. When you import artwork it is displayed here, and the arrangement of things will match

the output sent to your laser.

Next Step: Zooming, Panning, and Selecting
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Zooming, panning, and selection
The Edit Window, the center of the main display, can be moved around and zoomed with the

mouse to help you focus on different parts of your design.

ZOOMING

Scrolling the mouse wheel will zoom in or out from the location of the mouse - you can simply

point at something with the mouse and scroll the mouse wheel to zoom in on that point. If you

have a touch-pad (like a Mac) using a two-finger swipe up or down does the same thing.

You can also use the - and + keys in the upper-right of the keyboard to zoom.

PANNING

To pan the view, sliding the window around, press and hold the middle mouse button and move

the mouse. If you don’t have a middle mouse button, you can hold the Space bar on your

keyboard down instead - you’ll see the mouse cursor change to a hand , and then you can

grab and drag the view with the left mouse button.

There are buttons on the main toolbar for panning and zooming too:

PanAndZoom

The first button, the four arrows, is the Pan control. Click that to enter Pan mode, to drag the view.

You’ll see the mouse cursor change to a hand, like this:  When the hand cursor is visible, you

can drag the view around by pressing the left mouse button and moving the mouse. The Space

bar acts as a shortcut for the Pan control.

The second button is Zoom to Page - clicking this will reset the view in the workspace to frame the

entire work area, which is the view that LightBurn starts with.

The next two buttons are Zoom in and Zoom out. Clicking them will zoom in or out of the center of

the view. You can also press the - and + keys in the upper-right of your keyboard for this, or use

the mouse wheel.

The 4th button is Frame Selection - Clicking this will zoom the view to focus on whatever is

currently selected, or all the shapes in your project if you haven’t selected anything.

SELECTION

There are multiple ways to select things in the edit window (workspace). The simplest is to point

the mouse at the outline of a shape and click it with the left mouse button.



ClickSelect

A few things happen when a shape is selected:

The selected shape is drawn with an animated pattern instead of solid lines

The edit handles for resizing, positioning, or rotating the selection appear

The size and position of your selection is shown in the Numeric Edits toolbar

Other controls in LightBurn may activate, depending on what you’ve selected

To clear the current selection, left click an empty space in the view, or press the Esc key.

You can select a collection of shapes by pressing and holding the left mouse button and dragging

a rectangle around the things to select, from left to right, like this:

DragSelect-Enclosing

The red rectangle will disappear when you release the mouse button, and all the shapes enclosed

within it will be selected. This is called an enclosing selection - only things fully contained in the

red enclosing rectangle will be selected.

You can drag from right to left instead, and this will create a green rectangle, which will select

anything that it crosses:



DragSelect-Crossing

In this case, all three items will be selected even though they are not fully contained by the

selection rectangle.

Experiment with these two selection methods - understanding how they work, and when to use

them, makes working on larger projects much faster.

Selection Modifiers

To supplement click-select and rectangle selection, LightBurn supports these modifier keys:

Shift: Holding Shift while selecting will add the new selection to the current one

Ctrl+Shift: Holding both Ctrl and Shift will remove the new selection from the current one

Ctrl: Holding Ctrl by itself will toggle the selection state of the new selection

Additional Selection Tools

There are also a few items in the Edit menu for special types of selection:

Select All: selects everything in the project

Invert Selection: Anything selected becomes unselected, and anything unselected is now

selected

Select open shapes: Selects anything in the design that is an open shape (IE, is not a closed

path that forms a continuous loop)

Select open shapes set to Fill: Similar to Select open shapes, but only selects open shapes

that are set to ‘Fill’ - This is useful, because LightBurn is unable to fill shapes that aren’t closed, so

this can help you find them.

Select all shapes in current layer: If you choose a layer setting and click this option, it will

select everything assigned to that layer.

Select contained shapes: this is one you won’t use often, but it’s incredibly powerful when you

need it. Select a single shape in LightBurn, then click ‘Select Contained Shapes’ to add everything

that is ‘inside’ the item currently selected. For example, if you wanted to select everything inside

one of the two blue outlines below, click-select or drag-select would be difficult and time

consuming, but ‘Select contained shapes’ does it in just two clicks:



SelectContainedExample

Next Step: Basic Usage - The Essentials
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Making a Simple Project
We’re going to go step-by-step through creating a small, simple project in LightBurn, from start to

finish, to show you how to use a few of the basic editing tools, and give you a feel for how things

work.

Before you start, make sure you have a laser set up in LightBurn (see Adding your laser).

This project will be a simple name tag, cut out around the letters, ideally made from thin wood or

acrylic, but a piece of cardboard will do.

Creating the text:

With LightBurn running, and an empty project, click the Create Text button shown below. It

normally lives along the left side of the main window:

CreateTextButton

Next, click the mouse somewhere in the middle of the Edit window (the workspace) to get a

cursor, then type your name:

Click the ‘Select’ tool button on the top left of the edit window, or press ‘Esc’ twice (once to finish

entering text, and again to exit text entry and go back to selection mode).



SelectButton

When you finish the text, you’ll see an entry appear in the Cuts / Layers list on the upper right of

the display. This is the “layer” that your text is on, and it holds the settings that will be sent to the

laser for all the objects on this layer:

NewLayerEntry

This tells us that the shapes on this layer will be drawn as lines, with 100 mm/sec speed, and 20%

power. Depending on your settings, the ‘100.0’ might be different - Diode lasers are less powerful

than CO2 lasers, and run slower, so they tend to use mm/minute as units, so the default there

would be 6000 mm/min. If you have your units set to Inches, you might see 3.9 in/sec, or 236 in/

min.

Previewing:

To see how the laser will run your project, click the Preview button in the middle of the main

toolbar:

PreviewButton

The preview window will pop up, showing the completed job, like this:



The lighter red lines are showing the laser moving between the shapes (traversal moves), and the

black lines are where the laser will burn. Click the ‘Play’ button and you can watch a simulation of

how the laser will run the job. You can also grab the slider and drag it around to see the cut at

different points in time. Spot checking the output like this is a good habit to get into, because

you’ll likely spot mistakes before you burn the project for real, saving time and material. Click the

‘Ok’ button to close the preview.

Changing text properties:

Make sure you’re still in Selection mode - the ‘Select’ tool should be highlighted. Click the name,

or click and drag a rectangle around it to select it. When it’s selected, it will be drawn as animated

dashes instead of solid lines, and handles will appear around the selection to let you change the

size, position, or orientation.



The options in the Text Toolbar at the top will activate, like this:

TextToolbar

Click the drop down for the font, and change it to anything you like. While you are choosing, the

changes will be displayed in real time in the edit window. You can change the height, make it bold

or italic, and adjust spacing here too.

Undo / Redo

If you make a change you don’t like, you can undo it by clicking the Undo button on the toolbar

(or pressing Ctrl+Z, or Edit > Undo in the menu). If you decide you liked it after all, you can also

Redo (Ctrl+Shift+Z). Undo and Redo in LightBurn are unlimited - the undo system doesn’t reset

unless you create a new file or close the program.

Changing the Layer settings

Rather than outline the text, we’re going to change it to be solid filled. In the Cuts / Layers

window, click where it says ‘Line’ and change it to ‘Fill’, like this:

LayerSettingToFill

You’ll notice that the display in the edit window hasn’t changed, but if you run the preview again,

it looks quite different. By default, the view in LightBurn shows outlines only, not fills, because it’s

much faster, and it prevents things from being hidden behind solid shapes that might still be run

on the laser.

Adding an outline: The Offset tool:

With the text selected, click the ‘Offset’ button on the left toolbar, shown here:

OffsetButton



The Offset options window will appear, and you should see something like this:

OffsetButton

The offset tool creates a new shape by outlining the shapes in your selection at a given distance,

either inward, outward, or both, and merging the result. If you point the mouse at the ‘Offset

Distance’ value, you can scroll the mouse wheel to change the number and watch the result

change on the fly. You can also click the box and just enter a number as well.

Make the Offset Distance value large enough that there are no internal gaps in the outline - Notice

the gap above between the L and the next letter is gone in the version below:

OffsetButton

When you’re happy with the result, click ‘OK’.

Changing Layers

Now, use the left mouse button to click the new outline you just made, so it is the only thing

selected, like this:

Then, click the Red button in the color palette at the bottom of the display:



ClickTheRed

The outline will turn red, and you should see two entries in your Cuts / Layers list, like this:

TwoLayersInList

The first, the black layer, is the fill for your text, and the second red layer is for the outline cut.

Speed and Power

This is where things get a little tricky for me, as the author of this tutorial. Speed and power

settings vary quite a bit between lasers, and LightBurn supports a lot of different types of

machines. It also depends on the kind of material you’re using - cutting through 1/8" basswood

uses much less power than cutting through 1/4" plywood or acrylic. I’m going to assume 1/8"

(3mm) plywood and give some guesses for settings, but you’ll probably have to change them.

To start with, click the black color entry in the Cuts / Layers window. Below the list of layers you’ll

see the Cut Info window, containing something like this:

CutInfo

For the text, you want enough power to engrave into the material you’re using, but not too deep.

If you have a CO2 laser, use 200 mm/sec, 15% power (both Power Min and Power Max - more on

this later) and leave everything else.

If you have a diode laser, use 50 mm/sec (or 3000 mm/min), and 50% power.

Understand that this is a rough starting point, and you will probably need to change this later.

Now, click the red entry in the Cuts / Layers window. This is going to be what cuts through the

material to cut out the shape. Cutting requires more power and much less speed.

For a CO2 laser, set 15 mm/sec, 75% power (again for both min and max power)

For a diode laser, use 2 mm/sec (120 mm/min), and 100% power. Depending on the strength of

the diode you have, you might need to go slower than this, or use more passes by setting the

Pass Count value higher.



Again, these are guesses, but they’re a starting point.

Open the Preview window again (Alt+P, or click the Preview button), then drag the progress slider

from left to right to watch how the job will run. You’ll see the text engrave first, followed by the

outline cut. If you don’t see those things, check the settings again, and verify that you have the

first layer (black) set to Fill, and the second layer (red) set to Line.

Positioning the Job on the Laser

When sending this to the laser, there are a couple of different ways that it can be positioned, and

the one you choose may depend on the kind of hardware you have. If you have a small diode

laser that does not having homing switches, you will likely want to run the job using the ‘Current

Position’ mode. For now, that’s what we’ll recommend for everyone, since it’s easy:

In the Laser window, which is in the lower-right of the main window by default, look for the ‘Start

From’ drop down box, and choose ‘Current Position’. If you see ‘Controller Setting’ in this window,

it means you have a Trocen Controller, and the start position is set from the controller menus, not

from software. Don’t sweat it for now.

CutInfo

With the ‘Current Position’ mode chosen, you’ll see the 9-dot “Job Origin” control under it activate,

and you should see a green square on your design in the same spot indicated by Job Origin

control, like this:

In the above image, the Job Origin is set to the lower-left, and that’s where the green origin

square is on the design. That green square represents the position of the laser before you start

the job, so the design is going to end up above and to the right of wherever the laser is when we

press Start.

Put a piece of material in the bed of the laser, and use the arrow keys on the laser controller to

move the head of the laser to the lower-left corner of the material. If your laser controller doesn’t



have arrows, click an empty spot in the edit window, then use the arrows on the Number Pad of

your keyboard to jog the laser around instead.

When you think it’s lined up, press the button labeled ‘Frame’. The head of the laser will move in

a rectangle around where the job will go. If you need to adjust anything, do so, then Frame again.

If you only have the option for ‘Controller Setting’ in the above window, when you position the

laser in the lower corner of the material, press the button labeled ‘Origin’ on the controller panel

to tell the controller this is where you’d like the job to start.

When everything is lined up, close the lid on the laser (or if you don’t have one, put on your

safety glasses), then press the Start button.

If anything goes wrong, hit the Stop button to abort the job, but if not, let it finish. When it

completes, have a look at how things ended up - if the engraving of the name is too deep or too

dark, you can increase the speed or reduce the power (or both). If the cut didn’t go all the way

through, reduce the speed or increase the power (or both).

Results and Next Steps

When it’s done, hopefully it looks like something like this:

That’s it for this quick tutorial - It’s only meant to be a starting point, but hopefully it was enough

to give you a little foundation, and a taste of how things work.

Next Steps:

I recommend going through some of our “LightBurn Basics” tutorials on YouTube, and we have a

great project tutorial that’s a little more in depth called the “WIFI QR Code tutorial” that covers

more ground, including importing.

LightBurn YouTube channel: https://www.youtube.com/LightBurnSoftware

WIFI QR Code Tutorial: https://www.youtube.com/watch?v=ZPyIuLlcuIE
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Advanced Topics
Engraving Images (to be completed)

Optimization Settings - Customizing the order of your cuts

Print and Cut - Perfect registration when cutting printed materials

Scanning Offset Adjustment - Correcting shifted fills
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DOWNLOADING LIGHTBURN

The first step is to go to lightburnsoftware.com

At the top, click “Download and Trial” (or click here)

You’ll see links for the current release of LightBurn. Download the version that matches your

computer.

Windows 64-bit - nearly all modern computers are 64 bit

Windows 32-bit - some older systems might need this

Mac OSX

Linux 64-bit

When you’ve completed the download, you should see the file in your “Downloads” folder. On

Windows and Mac you can just double-click the downloaded file.

Next Step: Installing LightBurn 

https://lightburnsoftware.com/
https://lightburnsoftware.com/pages/trial-version-try-before-you-buy
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Installing LightBurn
Choose your operating system:

Windows

MacOS

Linux

WINDOWS INSTALLATION

Launch the installer by double-clicking it. Windows may ask if you trust us first.

Click Next, then click ‘Install’. The installation will proceed. When it completes, you’ll see this:



If you have never installed LightBurn before, you might need to check the ‘Install FTDI driver’

button - this is mostly used by DSP controllers, like Ruida and TopWisdom, and it only needs to be

done once. If you update the software later, you do not need to repeat this step.

That’s it! Locate the LightBurn icon to launch the program

Next:

Running LightBurn for the first time

MACOS INSTALLATION

Double-click the LightBurn.dmg file to mount the disk image.

Drag the LightBurn application into your applications folder

Eject the LightBurn disk image, or drag it to the trash bin

Please note that at this time, LightBurn for MacOS is not digitally signed. This means that you will

need to tell MacOS that you trust us. To launch LightBurn for the first time:

Open a Finder window

Browse to the ‘Applications’ folder

Hold the Command key and double-click the LightBurn icon, or two-finger tap the icon

When MacOS asks if it should open the program, say yes, and it will be listed as an

exception in your launcher. From now on you can just launch the application normally.

Next:

Running LightBurn for the first time



https://support.apple.com/guide/mac-help/open-a-mac-app-from-an-unidentified-developer-

mh40616/mac

LINUX INSTALLATION

Open a terminal and run the following command: 

sudo adduser $USER dialout && sudo adduser $USER tty

IMPORTANT! Log out and log back in (this refreshes the permissions we just added)

Download the Linux 64-bit version, either the .run file or the .7z file and follow the

appropriate steps below:

.run installer

Open your terminal and cd to the directory you downloaded the file to.

Run bash ./LightBurn-Linux64-v*.run

It will not automatically install and great a program listing in your desktop environment.

.7z installer

Extract the folder wherever you want Lightburn to exist

Right click AppRun > Properties > Permissions > ‘Allow executing file as program’

Double click AppRun inside your Lightburn folder

Next:

Running LightBurn for the first time 
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Running LightBurn for the first time
Activating LightBurn

If you’ve never used LightBurn before, you’ll be shown the License and Trial page first. Here you

can either enter and activate a license key if you have one, or you can activate a free 30 day trial

by clicking “Activate Trial”. If you do have a license key, be sure to enter it exactly, including the

dashes, then click the ‘Activate License’ button. We recommend just copying the key and pasting

it into the License Key box.

You can get back to this screen in LightBurn at any time by going to the menu and clicking Help >

License Management.

LicensePage

Once you have activated your license or the trial, click ‘OK’

The next thing you’ll see is the ‘General Usage Notes’ page - this is a brief help page just to get

you going. You can get back to it any time in the Help menu, under Help > Quick Help and Notes.

Click OK.



You’re almost done!

Next Step: Adding your Laser to Lightburn 
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Manually adding a laser
If LightBurn can’t automatically add your laser, because it’s not connected to your computer, or is

connected over a network, you can click the ‘Create Manually’ on the Devices page.

Create Manually

Device type:

LightBurn will open the New Device Wizard, and the first thing you’ll see is a list of the controllers

supported by your version of LightBurn:



Create Manually

Choose the entry that matches the type of controller or firmware in your laser and click Next.

Connection type:

The next step is choosing how you connect to your laser. The choices you see will depend on the

type of connection methods supported by your controller and LightBurn. Serial/USB is the most

common. Some controllers allow connection by Ethernet (note that this includes both WIFI and

wired).



Create Manually

Choose how you wish to connect, and click Next.

Name and work area size:

You can name the laser, which is very useful if you have more than one, or just leave it as is.



NameAndPageSize

You must set the size of the work area for your laser so that LightBurn can make try to prevent

things from going out of bounds. If you don’t know the exact size, you can easily change this later

in the Device Settings page.

Laser Origin and homing:

The origin setting is where the ‘zero’ point of your X & Y axis meet. If you get this wrong, you can

change it later in the Device Settings page. This setting also controls the orientation of the output

- if it’s wrong, the output from your laser may be mirrored or upside down.



NewDeviceOrigin

If you have a GCode based controller, like GRBL, Smoothieware, or Marlin, commonly used with

diode lasers or smaller hobby systems, in almost all cases the origin will be in the front-left. With

GCode based systems, you are given the option to send the homing command when LightBurn

first connects. If your laser does not have homing switches, leave this off.

If you have a DSP controller, like Ruida, Trocen, or TopWisdom, common in larger CO2 lasers with

metal cabinets and LCD displays, the origin corner will be the corner that the laser head seeks out

when you power it up. With DSP controllers, the controller will automatically home itself when

powered up, so you will not see the option for homing on startup.

All done!

That’s it - The final page will show you a summary of your choices. You can go back and fix

anything if necessary, or click Finish to create the new device entry.



NewDevice-Finished

Next Step: Software walk-through for beginners 
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Find My Laser
In the Devices page, click the ‘Find My Laser’ button, and you’ll see this screen:

FindMyLaser

Make sure your laser is powered on, connected to your computer with a USB cable, and has

completed any startup sequence it needs to, like homing. When the laser is ready, click Next.

After a short scan, LightBurn will list the devices it was able to recognize:



FindResults

In the above image, I have two lasers connected to my computer - the first, a GRBL controller on

COM9, and the second, a Ruida DSP controller on COM3. Select your laser and click ‘Add Device’.

Is your laser a GCode or DSP device? What if it wasn’t found?

GCode devices

If you have a GCode controller, you’ll be asked if your machine is an X-Carve or Shapeoko,

because there are some specific settings that need to be configured for those machines. If you

have one, click the appropriate button, if not, click ‘Other’. You may be asked where the origin of

your machine is, and if you want to home on startup. Nearly all GCode systems use the front-left

as the origin.

If your machine has homing or limit switches, enable the homing on startup, otherwise leave it

off. If you see ‘Error: 9’ in the console later, it means you’ve enabled this feature, but your

machine isn’t configured for homing.

With some GCode devices, additional configuration of either LightBurn or the controller may be

necessary.

Next:

Configuring a laser for use with LightBurn

DSP devices

If you have a DSP controller, the next screen will ask you where your machine origin is. This is the

corner the machine goes to when looking for the homing switches when it powers up. Click the



home corner. If you get it wrong, things may be backwards or upside down, but don’t worry - you

can easily change it later.

When your laser is added, click ‘OK’ on the Devices page to exit.

Next:

Software walk-through for beginners

What if my laser isn’t found?

If LightBurn can’t find your laser, it could be for a number of reasons:

Missing drivers - If your laser came with its own software, install it. Even if you don’t plan to use

it, sometimes they contain necessary drivers that aren’t included with LightBurn.

Can’t connect - Only one application can talk to your laser at once. If you run other software, like

RDWorks, Easel, Carbide Create, AutoLaser, LaserCAD, etc, make sure that software is not running

when you run LightBurn.

Networked device - LightBurn can’t automatically configure a network-connected laser. For this,

you’ll have to click ‘Create Manually’ and follow the steps.

Marlin controller - If you are using a Marlin controller, they have a variety of baud rates and

configuration options, and they take significantly longer to reset than most other controllers, so

it’s not practical to auto-search for them - click ‘Create Manually’ and follow the steps.
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Common Grbl setups
If you have a GCode-based system, like a Shapeoko, Eleksmaker, X-Carve, or Acro system, you

might need to make some simple changes to get the most from LightBurn.

SHORT VERSION

You might need to adjust your spindle max RPM value ($30) to match the LightBurn default (1000)

or vice versa. The value in LightBurn is called “S-Value Max”, in the Device Settings.

You might need to enable “Laser Mode” if you have GRBL 1.1f or later ($32=1)

If you have an older version of GRBL (prior to 1.1f) it’s highly recommended to upgrade the

firmware, as Laser Mode also prevents the machine from pausing with every power change. The

pause, which happens on older versions, or when not using Laser Mode, will cause excessive burn

spots when engraving images.

If your machine uses negative workspace coordinates you’ll need to apply a workspace offset

(G10 L2 P1 xx yy).

Set your machine status reporting to be relative to the workspace origin, not the machine origin

($10=0).

Make sure the controller is reporting positions in mm, as expected by LightBurn ($13=0)

GRBL FLAVORS

Grbl firmware was originally designed for CNC machines and 3D printers, with laser support added

more recently. It is highly configurable, and this is both a blessing and a curse. The “standard”

way a CNC machine is configured is somewhat different than the way laser machines often are.

Luckily this is easy to change, and easy to switch from one to the other.

The more recent versions of Grbl (1.1f and up) support two things that are incredibly useful for

lasers. The first is Laser Mode, enabled by setting $32=1 in the firmware settings. Laser mode

eliminates the pauses that happen when changing power output, because Grbl knows it’s

controlling a laser which reacts instantly, instead of waiting for a spindle to change RPM.

The second is a feature called variable power mode, or the M4 command. In this mode, Grbl

adjusts the laser power as the machine speeds up and slows down, making for very consistent

cutting and marking. Older versions of Grbl do not have this feature, and simply run the laser at a

constant power output for the duration of a cut. Since the machine needs to slow down to take

sharp corners, this means corners get over-burnt, while long straight lines end up lighter.

This also has the benefit that when the laser comes to a complete stop, the beam turns off (zero

speed equals zero power), meaning that pausing a job automatically turns off the laser. This is not

always true with other versions of Grbl.

If you aren’t already running Grbl 1.1f (or later) on your controller, we highly recommend it for

laser use. If this isn’t an option, that’s ok, but your results won’t be as good, and pausing the laser

runs the risk of leaving the beam on and ruining the job.

file:///home/runner/work/NewDocs/NewDocs/docs/DeviceSettings.md#s-value-max


Shapeoko

Shapeoko machines typically use Grbl 1.1f, but are configured for negative workspace

coordinates, which LightBurn doesn’t support. This is an easy thing to work around though, using

a workspace offset.

We’ll use a Shapeoko XXL as our example setup. This machine has an 812mm x 812mm working

area, and the origin is set to the rear-right, with negative numbers going down and to the left

(onto our workspace). We’re going to leave the direction alone, but change the origin position by

using this command in the LightBurn Console window:

​ G10 L2 P1 X-812 Y-812

That command says “set an offset” (G10 L2) in the first coordinate system (P1) of X -812 and Y

-812. (If your machine is a different size, use your width and height values in mm instead of the

812’s shown here, and remember the minus signs - those are important)

This shifts the origin point of the machine left and forward by the size of the workspace. Then you

tell LightBurn that the origin is at the front-left of the machine, instead of the rear-right, and

you’re done.

When you want to go back to using your machine for CNC use, clear the offset with:

​ G10 L2 P1 X0 Y0

It is simple to set these up as macro buttons in the LightBurn console window. Enter the first

command into a macro and call it “Use Laser”, and enter the second command into a different

macro and call it “Use CNC”. When you want to use your laser, click the “User Laser” macro

button, and when you’re done and want to switch back to CNC, click the “Use CNC” button.

X-Carve

X-Carve machines sold prior to January 2018 generally run an older flavor of Grbl (1.0c) which

does not support the variable power (M4) command, meaning you’ll need to use the Grbl-M3

device in LightBurn. Machines sold after that date use Grbl 1.1f, and will work with the standard

Grbl device in LightBurn if the following settings commands are entered in the console:

$30=1000

$32=1

These two lines:

Set the spindle max value ($30) to match LightBurn and Grbl’s default setting (1000)

Enable laser mode ($32=1)

Other machines

If you aren’t sure how to configure your machine, there are some simple steps to take that can

help. First, figure out which firmware you’re running. In LightBurn, when you first connect to the

machine, the console window will usually show a ‘hello’ message from the controller. For

Smoothieware boards it’s just “Smoothie”. For Grbl, it will be “Grbl 1.1f [$ for help]” or similar -



this tells you it’s Grbl, and which version. Machines using Grbl 1.1f or later will support the M4

variable power command, and just use the “Grbl” driver in LightBurn. Grbl 1.1e or older (Grbl 1.0,

Grbl 0.9, etc) must use the Grbl-M3 device in LightBurn.

With the driver identified, it’s time to find the machine origin. First, home the machine by pressing

the Home button ( ) on the Move window.

In the console window, type

​ G0 X0 Y0

then hit enter. Your machine will head toward its origin position. This isn’t always the same as

where the home position is. Usually the home position is in one of the corners. Most often it will

be the rear-right, or front-left of the machine. In some cases, it might be the center of the work

area. If your machine does this, skip ahead to ‘Center Origin Machines’ below.

After it stops moving, type

​ G0 X10 Y10

then hit enter. If your machine moves 10mm into the work area on both axis that’s good - it

means your machine uses positive workspace coordinates. You simply set the origin in LightBurn

to match the machine origin discovered above. If your machine bumped the rails, it uses negative

coordinates.

Negative Coordinate Machines

If your machine uses negative coordinate space, we need to offset the origin.

LightBurn wants positive workspace numbers, like this:



This image shows the origin at the front-left, with positive X values moving to the right, and

positive Y values heading to the rear of the machine.

A negative workspace system looks like this:

In this image, the origin is at the rear-right of the machine. The X and Y directions are the same as

before, but now, to move into the work area, you would need to use negative numbers. Instead,

we’re going to set up a work offset.

You’ll need to know the total distance your machine can travel in both axis. For a Shapeoko XXL,

for example, it’s 812mm in X and Y. For a 500x500 X-Carve, it’s 250mm in X and Y. By applying a

workspace offset that is the size of your machine area, we can shift the offset to the opposite

corner, like this:



Enter the following command:

​ G10 L2 P1 X-250 Y-250

in the console, and hit enter. Note that the ‘250’ above should be replaced with the total travel

width and height of your machine. If your machine had a 600mm width and 400mm height, you

would use:

​ G10 L2 P1 X-600 Y-400

This command offsets the origin by the given amounts. If the origin used to be in the rear-right of

the machine, and you offset it in the negative direction by the width and height of the work area,

you’ve moved the origin to the front-left.

If you enable a workspace offset, you will also need to make GRBL report its location relative to

this shifted origin, instead of in “machine space” by setting $10=0. Some systems, like Easel or

Carbide Motion, may need a different value, so it is good to remember the existing setting.

Center Origin Machines

Some systems have their origin in the center of the workspace. After homing your machine, enter

this command in the console and hit enter:

​ G0 X0 Y0

That command says “rapid move to coordinate 0,0”

If your machine does this, you still need to move the origin just like in the “Negative Coordinate

Machines” above, but only by half the size of your workspace. Follow the directions for a negative

coordinate space machine, but divide your workspace numbers in half before issuing the GCode

offset command.
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LightBurn Windows
This is a list of all the standard windows (and toolbars) available in LightBurn:

Main window, menus, and status bar

Main Toolbar (file, clipboard, view, settings)

Edit window (the workspace)

Arrangement Toolbar (grouping, mirroring, alignment, distribution)

Creation tools (selection, shapes, text, node editing)

Modifier tools (offsetting, Boolean operations, grids)

Color palette

Numeric Edits (size, position, units)

Cuts & Layers

Laser Control

Move window

Shape Properties

File List

Console

Material Library

Art Library

Camera Control

Variable Text
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Menus
The various features in LightBurn are accessed through the menus. The various features in each

menu are listed and explained here.

File Menu

Edit Menu

Tools Menu

Arrange Menu

Window Menu

Language Menu

Help Menu

File Menu

New

Clicking “New” in the File Menu will clear any current project and create a new one. You can also

press “Ctrl + N” (Command + N on Mac).

Open recent projects

This will open a list of the most recently opened files to choose from.

Open

To open an existing or saved file, click on “Open” in the File menu or press “Ctrl + O” (Command

+ O on Mac).

Import

You can import any supported LightBurn files into the file you are currently working on. Click on

“Import” in the File menu or press “Ctrl – I” LightBurn supports importing the following file types:

svg, ai, pdf, dxf, hpgl, plt, png, jpg, bmp, tiff, gif.

Save

To save a project click on “Save” in the File menu or press “Ctrl + S”. Type the name you want the

file saved as in the dialog box that opens up. To save a file with changes, but still keep the original

file intact, click on the “Save As” icon in the File menu.

Export

To export a file to a different file format, click on “Export” in the File menu. LightBurn can export

to SVG or AI format, though bitmaps and text are currently not exported.



Exit

To exit LightBurn, click on the “Exit” in the File menu or press “Ctrl – Q”. You will be prompted to

save your file if you have unsaved changes.

Return to top

Edit Menu

Undo

To undo the last editing action done on the current file, click on “Undo” in the Edit menu or press

“Ctrl + Z”.

Redo

To Redo the last editing action done on the current file, click on “Redo” in the Edit menu or press

“Shift + Ctrl + Z”.

Select all

To select all objects in the current file click on “Select all” in the Edit menu or press “Ctrl + A” (or

Command + A on Mac).

Cut

To one or more objects from the current file, select them and click on “Cut” in the Edit menu or

press “Ctrl + X”. This will put the object on the clipboard, and remove it from the current file.

Copy

To copy one or more objects, select them and click “Copy” in the Edit menu or press “Ctrl + C”

This will put the objects on the clipboard, but leave the original object alone.

Duplicate

To duplicate a selection in place, select one or more objects and click “Duplicate” in the Edit menu

or press “Ctrl + D”. This is an “in-place” copy and paste operation all in one, bypassing the

clipboard. This means if you already have something on the clipboard, it’ll still be there after using

Duplicate. The duplicate is placed directly on top of the original.

Paste

To paste an object from the clipboard click “Paste” in the Edit menu or press “Ctrl - V”. This will

place a copy of the clipboard contents in the current file. Note that LightBurn can paste text or

images copied to the clipboard from other software.



Paste in place

To paste an object from the clipboard click “Paste in place” in the Edit menu or press “Alt - V”. This

will place a copy of the clipboard contents in the current file in the same spot that it was in the

original file.

Delete

To delete an object select it and click “Delete” in the Edit menu, or hit the Delete key. This will

remove the object from the current file.

Convert to path

This converts a built-in “shape” object, like a rectangle, ellipse, or text, into lines and curves that

can be edited. Click on “Convert to path” in the Edit menu. The original shape information is lost,

so you won’t be able to change text with the text tool after using this.

Close path

In order to “Scan” (Fill) a shape with your laser, the shape must be a closed loop, where the

starting and ending point are the same. If the start and end points are very close, but not quite

connected, “Close Path” will move them together. Click on “Close path” in the Edit menu or press

“Alt + C”

Auto join selected shapes

Looks at the start and end points of all the selected curves, and if any of them are close enough,

connects them together into a single shape. Useful when importing DXF files, which don’t contain

connectivity information. Click on “Auto join selected shapes” in the Edit menu or press “Alt + J”

Optimize Selected Shapes

Attempts to fit the selected shapes to arcs and lines within a specified error tolerance. Useful for

reducing the point count in a shape, or recovering arcs from software that exports them as many

small line segments.

Delete Duplicates

This will delete duplicate items within the drawing, for example if two squares are identical and

one on top of the other, this will delete the extra square. This helps to minimize erroneous moves

and double-cuts.

Select Open shapes

This will select all open shapes in the document.

Select open shapes set to scan

This will select all the open shapes that are set to scan in the document.



Select all shapes in current layer

This will select all the shapes that are set to cut in the current layer of the document. Note that if

some of these shapes are grouped, the system may have to un-group them in order to select

them.

Settings

Clicking on “Settings” in the Edit menu will open a Dialog box where you can enter information

about your laser and default application settings.

Device Settings

After initial setup, you can access device settings by choosing “Device Settings”.

Machine Settings

You can access the controller hardware settings by choosing this option.

Debug drawing

This is mostly an internal tool for LightBurn developers that shows the bounds of shapes being

drawn.

Convert to cut

Also an internal tool for LightBurn developers - It converts the selected shapes into the cuts that

would be sent to the laser, and makes a new shape from the result. This is not how you produce

gcode / cuts for your machine, it’s just a debugging tool. Click on “Convert to cut” in the Edit

menu or press “Ctrl + Shift + C”

Machine Settings

Return to top

Tools Menu

Many of the tools in this menu are also available as icons in the tool toolbar that by default, is on

the left side of the workspace. See Creating New Vectors for more information.

Select

Click on “Select” to select objects in the workspace, or to access menus and toolbars.

Draw Lines

Click on “Draw Lines” or press “Ctrl + L” to draw straight lines in the workspace.



Rectangle Tool

Click on “Rectangle” or press “Ctrl + R” to draw rectangles in the workspace.

Ellipse Tool

Click on “Ellipse” or press “Ctrl + E” to draw ellipses in the workspace.

Edit Nodes

Click on “Edit Nodes” or press “Ctrl + ~” to edit nodes of objects in the workspace.

Edit Text

Click on “Edit Text” or press “Ctrl + T” to create or edit text in the workspace.

Offset Shapes

Used to create new shapes that are offset from the current selection, inward or outward.

Weld Shapes

Fuses multiple shapes together into a single outline.

Trace Image

Opens a dialog box where you can trace the content of a bitmap image into vector graphics.

(Read more here)

Apply Path to Text

If you select a shape and a line of text, this command will attach the text to the shape, so the text

follows the path. (Read more here)

Zoom In

Click on “Zoom In” or press “Ctrl + =” to zoom in the workspace.

Zoom Out

Click on “Zoom In” or press “Ctrl + -” to zoom out in the workspace.

Frame Selection

Zoom the view to completely contain the current selection. (Ctrl + Shift + A)

Position Laser

Click on “Position Laser” to allow clicking on the workspace to move the laser head to that

location.



Preview

Click on “Preview” or press “Alt + P” to open the preview window. It will show the current laser

project and includes information on cut distance, rapid moves, and total time estimate. Cut lines

are in black and traversal moves are red. You can toggle the display of traversal moves on or off,

as well as shading by power level.

Rotary Setup

This will open the rotary setup dialog box. Use this to set up your rotary attachment.
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Arrange Menu

Group

Click on “Group” or press “Ctrl + G” to group the selected objects in the workspace.

Ungroup

Click on “Ungroup” or press “Ctrl + U” to ungroup the selected objects in the workspace.

Flip Horizontal

Click on “Flip Horizontal” or press “Ctrl + Shift + H” to flip the selected objects in the workspace

horizontaly.

Flip Vertical

Click on “Flip Vertical” or press “Ctrl + Shift + V” to flip the selected objects in the workspace

vertically.

Align Centers

Click on “Align Centers” to place the center points of the selected objects directly on top of each

other.

Align Left

Click on “Align Left” or press “Ctrl + Shift + Left arrow” to align the selected objects in the

workspace to the left.

Align Right

Click on “Align Right” or press “Ctrl + Shift + Right arrow” to align the selected objects in the

workspace to the right.



Align Top

Click on “Align Top” or press “Ctrl + Shift + Up arrow” to align the selected objects in the

workspace to the top.

Align Bottom

Click on “Align Bottom” or press “Ctrl + Shift + Down arrow” to align the selected objects in the

workspace to the bottom.

Align H-Center

Click on “Align H-Center” to align the selected objects in the workspace to the center of the

horizontal plane.

Align V-Center

Click on “Align V-Center” to align the selected objects in the workspace to the center of the

vertical plane.

Move H-together

Click on "H-together to move shapes like distribute, but keeps shapes together

Move V-together

Click on "V-together to move shapes like distribute, but keeps shapes together

Move to Page Center

Click on this to move selected objects to center of page

Move to Upper Left

Click on this to move selected objects to Upper Left of page.

Move to Upper Right

Click on this to move selected objects to Upper Right of page.

Move to Lower Left

Click on this to move selected objects to Lower Left of page.

Move to Lower Right

Click on this to move selected objects to Lower Right of page.

Grid / Array

Click on “Grid / Array” to create an array or grid of objects in the workspace. A window will open

allowing you to enter the parameters for the array or grid.



Circular Array

Click on “Circular Array” to create an array or grid of objects in a circle in the workspace. A

window will open allowing you to enter the parameters for the array.

Push forward in draw order

Click on “Push forward in draw order” or use “Page up” key to move the selected object up one

level in the draw order. Usefull when trying to see objects on the screen.

Push backward in draw order

Click on “Push backward in draw order” or use “Page down” key to move the selected object down

one level in the draw order. Usefull when trying to see objects on the screen. “Ctrl-PgDn” or “Ctrl-

PgUp” will send an object to the very bottom, or very top of the objects on the screen.

Break apart

Click on “Break apart” to break selected object into individual parts. Return to top

Window Menu

Reset to Default Layout

To arrange the windows and menus back to the original default layout, click on “Reset to Default

Layout” You can use the Window menu to toggle windows and menus on or off.

Return to top

Language Menu

Choose the language you would like to have LightBurn use in this menu.

Return to top

Help Menu

Quick Help and Notes

Click on “Quick Help and Notes” or press F1 to access hotkey list, general usage notes and version

information.

Online Documentation

Click on "Online Documentation to access the documentation for LightBurn.



Online Video Tutorials

Click on “Online Video Tutorials” to access the tutorial videos.

Check for Updates

Click on “Check for Upfates” to make sure you are on the most recent version.

License Activation and Trial

Click on “License Activation and Trial” to launch the license dialog, where you can enter your

license key, or see the status of your trial period or license.

Enable Debug Log

This is for the developers, turn on the log by clicking on “Enable Debug Log”. The log file will be

written to your “My Documents” folder on Windows, or Documents on Mac, and is cumulative -

each time you enable the debug log it will append to any existing log, so it’s a good idea to delete

it after you’re finished.

Return to top
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Main Toolbar
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Arrangement Toolbar
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Creation Tools

CreationTools

The shape creation tools are the basic ways you build stuff from scratch in LightBurn, along with

the Selection tool, and the ‘Click to Position’ tool.

The tools are:

Selection Tool

Draw Lines

Rectangle

Ellipse

Polygon

Edit Nodes

Create Text

Click-to-Move

SELECTION TOOL 

You’ll likely use this more than any other tool in LightBurn. The selection arrow is used to choose

which things in your workspace you want to change, and there are number of different ways that

selection happens in LightBurn.

Click Selection

Point at the outline of a shape and click with the left mouse button to select it. The shape will

change from solid to an animated pattern of dashes. There are several things you can tell from

this pattern:

SelectionPattern



The circle on the left is not selected. The circle in the middle is selected, and it is a simple shape,

because the pattern is just simple dashes. The two circles on the right are grouped - visible

because the pattern is a combination of dots and dashes.

The direction that the pattern animates shows the direction that the shape will be cut in (unless

you tell LightBurn that it’s ok to choose a different direction).

To clear the current selection, left click an empty space in the view, or press the Esc key.

Drag Selection

If you click an empty space in the edit window and drag the cursor, a selection rectangle appears.

Drag the rectangle out over a number of shapes and let go to select them. There are two types of

drag selection:

Enclosing Selection:

If you drag from left to right, you’ll see a red rectangle. Selecting a shape with an enclosing

selection means the shape must be completely contained by the rectangle in order to select it.

DragSelect-Enclosing

Crossing Selection:

If you drag from right to left, you’ll see a green rectangle. Selecting a shape with a crossing

selection means that if the rectangle crosses the shape at all, the shape will be selected:



DragSelect-Enclosing

Selection Modifiers

To supplement click-select and rectangle selection, LightBurn supports these modifier keys:

Shift: Holding Shift while selecting will add the new selection to the current one

Ctrl+Shift: Holding both Ctrl and Shift will remove the new selection from the current one

Ctrl: Holding Ctrl by itself will toggle the selection state of the new selection

(Note that on MacOS, the Command key is used instead of the Ctrl key)

Moving, Resizing, and Rotating

When one or more shapes are selected, several controls appear around them, like this:

ClickSelect

The small squares around the outside of the selection can be clicked and dragged to resize the

selection from that side or corner. If you move the mouse over one, the cursor will change to show

that the action is available.

When dragging one of the four corners, the shape will maintain its relative width to height (aspect

ratio) so it doesn’t ‘stretch’. You can override that by holding the Shift key while dragging a

corner.

When dragging any of the sizing adjustments, the behavior is asymmetric - the other side of the

object acts like an anchor and stays in place. Holding the Ctrl key (or Command on MacOS) makes

the action symmetrical, using the center of the object as the anchor instead of the other side.

The center square that appears is a movement handle - you can click and drag it to reposition the

shape, however you can also click anywhere on the boundary of the shape to do this, and you

don’t even have to select it first - Simply click the boundary, and while continuing to hold the left

button, drag the shape.

The circular arrows shown at the four corners are used to rotate the shape. By default the rotation

is “free”, however holding the Ctrl key will snap it to 5 degree increments.

When dragging, scaling, or rotating shapes, the bottom status bar in the main window will often

show feedback, like this:



RotateFeedback

Here I can see the position of my mouse, and the angle I have rotated the shape to while I’m

rotating it.

Snapping

When you move the mouse over a shape to select it, you will occasionally see the cursor change

to a small crosshair. This shows that you are over a snap point, like a corner, node, the center of a

line, or the center of a shape. If you click at this moment, the point you drag the object from will

be that snap point. When dragging an object to move it, as you get near other objects, those

objects may also snap the cursor location, allowing you to position shapes perfectly with each

other. If you are close to a grid point, the selection will snap to the grid as well.



If you do not want shapes to snap when dragging, hold the Ctrl key to temporarily turn off the

snapping behavior.

DRAW LINES TOOL 

Click the pencil to use the Line tool. Click anywhere on the page to start a line, then move to a

new location and click again to finalize the current line at that point. This will continue until you

either click back at the starting point of the shape to close it, or click the right mouse button to

stop. You can also press the Esc key to cancel the current line.



DrawLinesExample

Measuring

A little known feature of the Line tool is that it is also intended to be used for measuring

distances. The status display at the bottom of the main window shows the length of the line being

drawn, even before you’ve completed it.

If you want to measure the distance between two points in your design, start a line at one point,

then move the mouse to the other point, but don’t click yet. Look at the status window to see the

length of the line in progress. When you have noted your measurement, right-click or press Esc to

cancel the line.

LineToolMeasurement



RECTANGLE TOOL 

The rectangle tool is used to draw squares and rectangles. Holding Shift while dragging will lock

the width and height, producing a perfect square. Holding Ctrl will drag the rectangle or square

from the center, instead of the corner.

With a rectangle selected, if you look in the Shape Properties Window you can adjust the ‘Corner

Radius’ property to produce rounded rectangles, or frames with inward corners:

RectangleProperties

ELLIPSE TOOL 

The ellipse tool is used to draw ellipses and circles. Similar to the Rectangle tool, holding Shift

while dragging will lock the width and height, producing a perfect circle. Holding Ctrl will drag the

ellipse or circle from the center, instead of the corner.

POLYGON TOOL 

The polygon tool is used to draw regular polygons, like hexagons. Holding Shift while dragging will

lock the width and height. Holding Ctrl will drag the polygon from the center, instead of the

corner.

With a polygon selected, if you look in the Shape Properties Window you can adjust the Sides

property to change the number of sides the polygon has:

RectangleProperties



CLICK TO MOVE TOOL 

The Click-to-Move tool is a quick way to jog your laser to a location somewhere in the workspace.

Select this tool, then click anywhere on the page and LightBurn will issue a command to send

your laser there. This tool automatically turns itself off after about 10 seconds, in case you

accidentally leave it on. Trying to select a shape and having the laser move away from where you

want it can be confusing.
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Modifier Tools

ModifierTools

The modifier tools, as the name suggests, are primarily used to modify existing shapes.

The tools are:

Offset

Weld

Boolean Union

Boolean Subtract

Boolean Intersection

Grid Array

Radial Array

Start Point editor

Radiused Corner tool

Offset

The offset tool is used to create outlines around existing shapes, either inward or outward, offset

from the original by a given amount. We use the offset tool in the ‘Making a Simple Project’ topic,

so that’s a great introduction.

The corner style option chooses how outward corners are offset:



The offset tool remembers the last set of options you used, and if you hold the Ctrl key when you

click the offset button, it will perform the offset operation using the previous settings, without

bringing up the dialog.

Weld

Clicking on the Weld icon will join all the selected shapes into a single entity that is the outline of

all the selected shapes.

Boolean Union

Union is similar to weld, but works with 2 selected objects only. However these selected objects

can actually be grouped items, not just a single vector shape.

Boolean Subtract

Boolean subtract will remove the area that the second selected shape overlaps the first shape by.

The order in which you select shapes will determine the outcome. This tool also works with

grouped items. If you end up subtracting the items in the wrong order, Undo, then perform the

operation again - The undo switches the order of the items, so a simple Undo and click-again of of

the Subtract button is a quick fix.

Boolean Intersection

This will create a shape from 2 selected shapes that has an outline defined by only the areas in

which the shapes overlap. This tool also works with grouped items.

Quick Video Walkthrough of the Boolean Operations

Click for a Boolean demonstration video

https://www.youtube.com/watch?v=51cXqmNHgeI


The above video describes in more detail how the various Boolean operations differ, and why

welding text to a circle should be done with a Boolean Union instead.
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Cuts / Layers
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Numeric Edits Toolbar
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Edit Window (workspace)
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Basic Usage: The Essentials
So far we’ve done a brief introduction to the UI and covered zooming, panning, and selecting.

The next things we’ll cover are:

Creating Shapes

Importing Artwork

Cut Layer Settings

Controlling the Laser

CREATING SHAPES

LightBurn’s shape creation tools let you create simple shapes. Choose a tool from the left toolbar,

like the ellipse, rectangle, or polygon tools. With a tool selected, left-click in the workspace and

drag the mouse to adjust the size of the shape you’re creating. While dragging, the Shift key will

force the shape to have the same width and height, so you get circles and squares instead of

ellipses and rectangles. The Ctrl key causes the shape to be centered on the starting point,

instead of dragging it out from corner to corner. Release the mouse button to finalize the shape.

For text, select the text tool, then click in the edit window to place the cursor. Type your text, and

press the Esc key when finished.

IMPORTING ARTWORK

The shape creation tools let you make simple shapes in LightBurn, like circles, rectangles, text,

and polygons, and also give you the ability to edit and adjust them, but LightBurn isn’t intended

to be a complete artist package or dimensioned modeling tool. For that, external software like

CorelDraw, Adobe Illustrator, InkScape, or AutoCAD would be used. Photo or image manipulation

software can be used to create or manipulate image files.

When you have artwork ready in one of these programs, the next step is to import it into

LightBurn to adjust the settings. LightBurn can import the following file types:

Vector / mixed formats:

.ai - Adobe Illustrator

.svg - Scalable Vector Graphics

.dxf - AutoCAD Drawing Exchange Format

.pdf - Adobe Portable Document Format

.plt / .hpgl - Plotter / Hewlett-Packard Graphics Language

Image formats:

.png - Portable Network Graphics

.jpg / .jpeg - Joint Photographic Experts Group format

file:///home/runner/work/NewDocs/NewDocs/docs/BeginnerWalkthrough.md


.bmp - Windows Bitmap

.gif - Graphics Interchange Format

.tif / .tiff - Tagged Image File Format

Note that not all features of every format will be supported. Vector graphics formats in particular

are incredibly complex, and using more advanced features, like pattern fills, masking, gradients,

and so on will not likely translate well when importing. LightBurn cares about shape outlines - if

you want artwork to include the advanced features, the best option is usually exporting as a high-

DPI image.

You can import files into LightBurn in several different ways:

Clicking the Import button on the main toolbar ( )

Using the File > Import option from the main menu

Pressing the Import keyboard shortcut (Ctrl + I)

Dragging a file from the Windows Explorer or MacOS Finder into LightBurn

Copying and Pasting an image from a browser window into LightBurn

CUT LAYER SETTINGS

Artwork imported from vector files assigns shapes to layers in LightBurn based on the colors of

the vectors in the original file. If you create your files with this in mind, it can save you time.

Layers in LightBurn are used to assign different settings to the shapes in your design. For

example:

LayerColorsExample

In the above design, black could be used for a solid, dark engraving, blue could be a very light

engraving with an outline to add definition to the text, and red would be a slow, high-power

cutting layer. The final output to the laser might look like this:



LayerColorsExample

The information shown in the Cuts / Layers window is just the basics. You can see the full set of

options for a layer by double-clicking the entry in the layer list to bring up the Cut Settings

window.

CONTROLLING THE LASER

There are two windows primarily used to control the laser:

The Laser Window, shown in the lower right of the display by default, lets you select your laser,

Start, Stop, and Pause a job, Frame the design (move the laser head around the boundary of your

design to test alignment), and more.

LaserWindow

The Move Window, docked behind the Cuts / Layers window by default, gives you jog buttons and

positioning control, and the ‘Speed’ value there is used when framing or jogging the laser in

LightBurn.



MoveWindow

There are a couple other methods for moving the laser that are noteworthy:

The Click-to-Position tool (ClickToPosition) on the Creation Tools toolbar lets you click anywhere in

the workspace and LightBurn will jog the laser to that point. 

Note that this assumes that your laser has been properly homed - Some DIY-style machines do

not have homing switches, so using any form of absolute positioning in LightBurn requires extra

steps.

The number pad arrow keys can be used to jog the laser after clicking in the edit window

(workspace).

The Arrange menu and arrangement tools can be used to move the laser relative to artwork in the

workspace.
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Engraving Images
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Optimization Settings (the Cut
Planner)
Video Tutorial on YouTube - Click here

The cut planner gives you a great deal of control over the ordering of your cuts - you can let

LightBurn try to choose the best path for you, order it piece by piece yourself, or somewhere in

between. The new options are powerful, and we’ll have a video coming soon to demonstrate

them. If you have “Order by Layer” as the only entry in the list at the top (the default), it will

behave the way you’re used to. After selecting your choices in the cut planner, use the Preview

(Alt-P) to see how your choices have impacted things by using the slider at the bottom of the

window.

Access these settings by pressing the Optimization Settings button shown here:

OptimizationSettingsButton

The settings are displayed in this dialog (and the defaults are shown here):

CutPlannerSettings

https://www.youtube.com/watch?v=w1hG1wv8tS4


Order By

You can select what the initial ordering parameters will be. You have a choice of Layer, Groups or

Priority. As well you can use a combination of these three choices in any order you wish.

Note that the order is important. If you order by layer, then groups, the list of shapes will be split

into lists by layer first, then those lists will be sorted by group, and finally, the remaining

optimizations will be applied. If you order by groups first, then by layers, the list of shapes will be

first split by root-level groups, then the shapes within each set will ordered by layer, and so on.

This is good for doing large projects where you want an entire multi-layer item to complete before

moving on to the next, in case you have to interrupt the project, or something goes wrong.

Order By Layer

If you choose Order By Layer, the cut planner will apply all remaining optimizations to the first

layer, then the second layer, and so on.

##### Order By Groups

If you choose Order By groups the cut planner will apply all remaining optimizations to all the

objects in a root-level group, then the next Grouped object, and so on. Objects not part of a group

are treated as being in a group together.

Order By Priority

If you choose Order By Priority, the cut planner will apply all remaining optimizations to the

objects with the highest priority (Assigned in the Shape Properties Window) first, then the next

lowest and so on.

Optimizations

Cut Inner Shapes First

As the name implies, if there is an object within another object, and both are being cut, it will cut

out the inside object before the outside one.

Cut In Direction Order

This will try to cut the shapes in your project in the specified direction - top to bottom, left to right,

etc.

Reduce Travel Moves

This will have the cut planner try to order the cuts in a way that it will choose objects beside each

other to try and reduce non cutting travel moves.

Reduce Direction Changes

The cut planner will try to choose cuts that allow it to keep moving in the same direction. Note

that this option often increases cutting time. We’re continuing to try to improve it.



Choose Best Starting Point

Allows the system to start a cut at any point within a shape, not just the first point. Works best

when “reduce travel moves” is also enabled.

Choose Corners, If Possible

The cut planner will attempt to start a cut at a sharp corner to minimize burning or staining on the

surface of an item.

Choose Best Direction

The cut planner will attempt to choose the best direction to cut in.

Remove Overlapping Lines

The cut planner will remove lines that overlap each other that would cause the laser to cut in the

same place twice. This will remove any line fully covered by another line, but will not yet remove

partial overlaps, like this:

Optimizer-PartialOverlaps

(the lines are offset from each other slightly here to be able to see them)
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Print and Cut with LightBurn
“Print and Cut” normally refers to the ability to print a design on a printer, then have it

automatically cut it out with a blade or laser cutting machine by using registration marks on the

print to align the cut to it.

Note: In order for the output to be positioned correctly on your laser, you must use Absolute

Coords as the positioning mode, otherwise the output will not match the position of the print.

As an example, take this design, printed on sticker paper:

I’ve imported the same design into LightBurn, with the cross-hair markers, and added an outline

to the dragon using the offset tool:



The important part in this file is the two cross-hair marks - these are the target marks that you will

use to align the cutting path with the printed sticker. They don’t have to be cross-hairs, but these

are simplest to align with, as the center of the selected object is what is used for alignment when

recording positions. Each target marker must be a single object that can be selected - If you draw

two lines to make a crosshair, group them.

The red lines are set as cut vectors, with an appropriate power and speed, and the black lines can

either be set not to output, or simply deleted.

After placing the printed version of the file in the laser, follow these steps to align the laser output

with the print.

Using the red-dot pointer of your laser, jog the laser head to align with the center point of one of

the two cross-hair marks.

In LightBurn, select the same cross-hair mark, then go to Tools > Print and Cut > Set First Target

Location, like this:



Now, jog the laser to align the red dot pointer to the center of the second marker

In LightBurn, choose Tools > Print and Cut > Set Second Target Location:

You will notice that in the above image, the menu option for ‘Set First Target Position’ has the icon

highlighted as well - this means that the First Target Position is set and active.

After setting both targets, the menu will automatically enable the ‘Align Output to Targets’ option

for you, like this:



PrintAndCutAlign

You will also see the “(Print & Cut mode)” message in the status window, like this:

PrintAndCutReady

If you preview at this point, the orientation of the preview should match that of the print on your

laser:

AlignedPreview

In the above image, you can see the preview image is rotated slightly clockwise, matching the

orientation of the printed image in the laser.

Note: In order for the output to be positioned correctly on your laser, you must use Absolute

Coords as the positioning mode, otherwise the output will not match the position of the print. The

accuracy of the result will be affected by the accuracy of your red-dot pointer, so using one that is



either a cross-hair beam pointer or a red-dot marker that is in the same beam path as your laser

is ideal.

After running the job on the laser, this is the result:

PrintAndCutOutput
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Scanning Offset Adjustment
Modern lasers are capable of moving very fast, and with remarkable precision, however firing the

beam still takes time. Some power supplies and tubes may respond in less than a millisecond, but

many take longer.

At 100 mm/second, 254 dots per inch means your dots are 0.1mm in length, fitting 1000 of them

in 100mm. At 100 mm/sec, if your power supply and tube take 1 millisecond to fire, your

engraving will be offset by a full dot width.

At 500 mm/second, that 1 millisecond delay means you’ll be off by 5 dots, or 1/2 a millimeter. Still

not very much, but visible. Many power supplies and tubes will take even longer to fire.

The result often looks like ghosted edges. The image below is a 20mm square at 1000 mm/sec,

with a 1ms delay, resulting in a full mm of skew between scans:

LightBurn has a setting to counter this, called Scanning Offset Adjustment, in the Device Settings:

Device Settings Window

To use this feature, you need to measure the response of your machine at a couple of different

speeds. Create a small rectangle in LightBurn, 50mm wide and 10mm high, set it to scan, and set

the interval to 0.5mm. If you are on a GCode based device, enable overscan, and set it to 5% or

greater to be sure the machine is not slowing down before reaching the ends. (Ruida devices

overscan automatically). Note that in the image below I have power set to 0 - Don’t do this. You

will need to set the power high enough to mark your material.



Run this rectangle at multiple speeds, like 100mm/sec, 200mm/sec, 300mm/sec, and so on.

Depending on your hardware you may not even need to use these settings, however here is

example output from a machine that does:



To compensate for this, measure the distance between the ends of the lines at each speed, and

enter the speed and distance values into the scanning offset adjustment table. LightBurn will use

this information to compute the correct adjustments for other speeds as well. A minimum of two

measurements are needed for it to work. Note you will need enter half the measured value - The

software moves each line by the amount you specify, so each pair of lines only needs to move

half the distance.

There is an excellent tutorial online at Cartonus.com here: http://cartonus.com/how-to-improve-

engraving-quality-of-laser-machine/

You may need to do this multiple times, making minor adjustments to get clean results at each

speed. After entering the measurements for the above speeds, the resulting corrected output

looks like this:

Line Wobble
A different, but equally common problem, is line wobble, often caused by too high an acceleration

setting. When doing the test cuts above, you may notice lines that look like this:



If so, your machine is moving too quickly between the rows, and you’re seeing physical “bounce”

in the gantry because of it. Lowering the acceleration setting for your Y axis can correct this.
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Device Settings
After initial setup, you can access device settings under the Edit > Device Settings menu.

Device Settings Window

Working Size

This is the working size of your laser bed. Set this to the maximum X and Y travel for your laser.

Origin

This is the origin or 0,0 location for your laser. If you have a GCode based system, this is almost

always at the front left, regardless of the location of your limit switches. If you have a DSP laser,

like Ruida or Trocen, the origin is usually where the limit switches are placed.

Scanning Offset Adjust

Scanning offset is useful when doing raster or vector scanning at high enough speeds that delays

in your power supply cause the firing point to be a little behind where it should be. See the help

for Scanning Offset Adjustment here.



Fast Whitespace Scan

When engraving an image, LightBurn normally moves at the same speed across the entire image.

If you are engraving slowly to get a good burn, but the image contains a lot of empty space (white

space), this takes a long time. With the Fast Whitespace switch enabled, LightBurn will boost the

speed through blank areas to the speed you indicate, if it is faster than the current engraving

speed. This can save significant time.

A note for Marlin users: Since Marlin treats G0 and G1 moves identically, this value is used to

specify the speed for rapid moves. If you do not set this value, LightBurn will use the same speed

as the G1 moves.

S-Value Max

GRBL and Smoothieware use the S-Value (spindle speed setting) to control the PWM power output

to the laser. This setting is the number that corresponds to 100% power in LightBurn.

Smoothieware typically uses a value from 0 to 1 and supports fractional numbers in between.

GRBL defaults to 0 to 1000 for newer versions of GRBL, or 0 to 255 for older ones. The S-Value

Max setting in LightBurn must match your controller setting, or you’ll either get not enough power

output (if LightBurn’s setting is lower) or very small power numbers will set your laser to full

power (if LightBurn’s setting is higher).

Z Axis Controls

Enable Z Axis: turn this on to allow LightBurn to control the Z axis of your machine, IE the height

of the laser above the workpiece.

Note: enabling Z control means that LightBurn will always emit Z values for a running job, and

therefore requires that you set either the “Relative Z moves only” toggle below, or a material

height value on the main cut panel. If you to not set relative mode, and do not set a material

height, the default of 0 may cause LightBurn to raise your bed to a point where the workpiece

could contact the head of your laser.

Reverse Z Direction: Most DSP systems have 0 as the highest point, with positive numbers

moving the laser head further from the bed, however some systems reverse this. Toggle this

switch to change the overall direction for Z moves.

Relative Z moves only: This setting tells LightBurn to read the height of the machine when the

job starts, and uses that height as the starting point for all Z moves, ignoring any specified

material height. This is the simplest way to work, as you just set your focus manually, and

LightBurn will perform all moves relative to whatever height your machine is at when the job

starts. Note: for DSP systems this requires that you are connected to the machine. 
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Edit Nodes tool 
Video Tutorial #2: Node Editing

The Edit Nodes tool allows you to edit the nodes, lines, and curves that make up a shape in

LightBurn. Note that built-in primitives in LightBurn, like Text, Ellipses and Rectangles, cannot be

edited without converting them to a generic path object first using Convert to Path.

Allows you to move the vertices of a selected shape.

Pressing the S key when hovering over a node will convert it to a smooth node, and if required,

creates tangent handles that can be manipulated from it.

Pressing S while hovering over a line will convert the line to a smooth curve, with tangent

handles, but leaves the shape of the original line intact.

Pressing L while hovering over a smooth curve will convert it back to a straight line.

Pressing C while hovering over a node will convert it to a corner, allowing the two handles to be

manipulated independently of each other.

Pressing D when hovering over a node will delete it and connect the lines on either side together.

Pressing D when hovering over a line will delete it and open or split the shape.

Pressing I when hovering over a line or curve will insert a new node at that point along the line

Pressing B when hovering over a point will break the curve at that point

Snapping

Note that in all of the above tools, when creating a new shape, you will occasionally see the

cursor change if you hover over a point on an existing shape. This means LightBurn is going to

snap what you’re about to make to that point. You can bypass this behavior by pressing the Ctrl

key (Command on MacOS). LightBurn will snap to object centers, end points of lines or curves, or

center point of lines or curves, in addition to just snapping to the grid.

file:///home/runner/work/NewDocs/NewDocs/docs/index.md
https://www.youtube.com/watch?v=uzFsrUwONbw#t=9m15s
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Creating Text
Video Tutorial #2: Text Tool

With the Text tool in LightBurn you can:

Create text on the screen, or edit existing text by clicking within it.

Change font and size, alignment, and spacing

Enable / disable automatic welding

Create Variable Text objects

Creating text in LightBurn is simple - click the Create Text tool ( ) on the Creation Toolbar, click

somewhere on the page to get a cursor, and type.

When you enable the Create Text tool, the Text Options toolbar will activate as well.

Text Options Toolbar

This toolbar gives you access to settings on text objects, including font, size, spacing, alignment,

and more.

TextToolbar

You can select the font, size, and also Bold or Italic options here, as well at the Variable Text mode

to use, if any. LightBurn uses whatever fonts you have installed with your operating system, and

the font drop-down box displays a small preview of each font. When selecting a font, your text will

change instantly.

The other controls are:

Height - sets the height of the font in the current units

HSpace - adjusts the horizontal character spacing as a percentage of the font size. Positive

numbers space the characters out more, negative numbers move them closer together.

VSpace - adjusts the vertical line spacing as a percentage of the font height. Positive numbers

increase the distance between lines, negative numbers reduce it.

Align X - chooses the horizontal anchor position of the text - Left, Right, or Middle

Align Y - chooses the vertical anchor position of the text - Left, Right, or Middle

Bold - Displays the font in bold typeface, if available

Italic - Displays the font in italics, if available

Welded - Enables automatic welding of characters. When characters touch or overlap, as is

common with script fonts, enabling this option will automatically weld the overlaps together.

The remaining two options are for Variable Text, like serial numbers, dates, and so on. More

information about Variable Text can be found here. 

file:///home/runner/work/NewDocs/NewDocs/docs/index.md
https://www.youtube.com/watch?v=uzFsrUwONbw#t=9m45s
file:///home/runner/work/NewDocs/NewDocs/docs/CreationTools.md
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Cut Settings Window
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Variable Text in LightBurn
Variable text is a feature that allows you to use special codes in your text entries that will be

substituted for something else when you send the data to the laser (or the preview). Variable text

can be used for:

Date or time stamps

Serial numbers

Displaying cut settings

Merging a CSV file into your designs

In all of these cases, the text in LightBurn is set to one of the dynamic text modes, and the text

entered is used to tell LightBurn what you want it to display. You select the text mode like this:

VariableTextDropDown

With the mode selected, you enter one of the special codes for that mode, and when you preview,

save, or send the file to the laser, LightBurn will replace the text with the desired output.

The different formatting codes are listed here: Variable Text Formats

VARIABLE TEXT MANAGER

If using serial numbers or a CSV file, you have additional controls, available in the Variable Text

window in LightBurn, shown below:

Variable Text

The values shown are:

Current: The current serial number, or row from the CSV file, that will be displayed.

Start: The first serial number you want to use, or the first row in the CSV file to be used.

file:///home/runner/work/NewDocs/NewDocs/docs/index.md


End: The last serial number to use, or the last row in the CSV file to use.

Advance by: Imagine you are creating a series of numbered labels. Rather than cutting each one

separately, you would most likely want to do several at once on a page. The “Advance by” value

tells LightBurn how many entries to advance ahead when you click the Next or Previous buttons,

or when it automatically advances to the next page for you.

The buttons on the right are for:

Previous: Go to the previous page of values (decrements the Current entry by the ‘Advance by’

amount)

Next: Go to the next page of values (increments the Current entry by the ‘Advance by’ amount)

Test: Displays the text that will be output, for as long as the button is pressed.

Reset: Resets the Current value to the Start value

Auto-Advance: When this switch is enabled, each time you press one of the ‘Start’, ‘Send’ or

‘Save as..’ buttons in the Laser window, LightBurn will automatically advance the Current value by

the ‘Advance by’ amount. If you are running a large batch of parts, names, serial numbers, etc,

each time you send a job to the laser the software will advance to the next batch.

There is a property on text objects called Offset which controls is added to the current variable

text index when evaluating the text object. This allows you to have text objects on your design

that display different serial numbers, or different rows from the CSV file.

VariableTextOffset

If you created a design with 4 name tag labels on the page, you would set the Variable Offset

value for each of the four labels to 0, 1, 2, and 3, and tell the Variable Text manager to advance

by 4 with each run.
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Variable Text Formats
These are the different formatting codes used for Variable Text in LightBurn.

DATE / TIME TEXT FORMAT

When using the Date/Time mode for text, the system will automatically substitute special

combinations of characters with values for the current local date and time.

For example, if your text field is “d/MM/yyyy” the system would replace it with “15/6/2019”. The

values you can use for substitution are listed below.

These expressions may be used for the date:

Output Expression

the day as number without a leading zero (1 to 31) d

the day as number with a leading zero (01 to 31) dd

the abbreviated localized day name (e.g. ‘Mon’ to ‘Sun’). Uses the system locale

to localize the name.
ddd

the long localized day name (e.g. ‘Monday’ to ‘Sunday’). Uses the system locale to

localize the name.
dddd

the month as number without a leading zero (1-12) M

the month as number with a leading zero (01-12) MM

the abbreviated localized month name (e.g. ‘Jan’ to ‘Dec’). Uses the system locale

to localize the name.
MMM

the long localized month name (e.g. ‘January’ to ‘December’). Uses the system

locale to localize the name.
MMMM

the year as two digit number (00-99) yy

the year as four digit number yyyy

These expressions may be used for the time:

Expression Output

h the hour without a leading zero (0 to 23 or 1 to 12 if AM/PM display)

hh the hour with a leading zero (00 to 23 or 01 to 12 if AM/PM display)

H the hour without a leading zero (0 to 23, even with AM/PM display)

HH the hour with a leading zero (00 to 23, even with AM/PM display)

m the minute without a leading zero (0 to 59)

mm the minute with a leading zero (00 to 59)

s the whole second without a leading zero (0 to 59)

ss the whole second with a leading zero where applicable (00 to 59)
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Expression Output

z

the fractional part of the second, to go after a decimal point, without trailing

zeroes (0 to 999). Thus “s.z” reports the seconds to full available (millisecond)

precision without trailing zeroes.

zzz
the fractional part of the second, to millisecond precision, including trailing zeroes

where applicable (000 to 999).

AP or A use AM/PM display. A/AP will be replaced by either “AM” or “PM”.

ap or a use am/pm display. a/ap will be replaced by either “am” or “pm”.

t the time zone (for example “CEST”)

Any sequence of characters enclosed in single quotes will be included verbatim in the output

string (stripped of the quotes), even if it contains formatting characters. Two consecutive single

quotes (’’) are replaced by a single quote in the output. All other characters in the input string are

included verbatim in the output string.

Formats without separators (e.g. “ddMM”) are supported but must be used with care, as the

resulting strings aren’t always reliably readable (e.g. if “dM” produces “212” it could mean either

the 2nd of December or the 21st of February).

Example format strings (for the date & time 21 May 2001 14:13:09.120):

Input Result

dd.MM.yyyy 21.05.2001

ddd MMMM d yy Tue May 21 01

hh:mm:ss.zzz 14:13:09.120

hh:mm:ss.z 14:13:09.12

h​ : m : s ap 2 : 13 : 9 pm

SERIAL NUMBER TEXT FORMAT

When using the Serial mode for text, the system will automatically substitute certain special

combinations of characters with the current serial number value, and other characters control

how it is formatted.

These expressions may be used for serial numbers:

Output Expression

The serial number as a decimal value d

The serial number as a hexadecimal value, lower case h

The serial number as a hexadecimal value, upper case H

Tells LightBurn to pad the number with leading zeros 0

The number of characters used controls how many digits the system will display. If the serial

number is larger than the number of digits allowed, as many digits as will fit from the end of the

number will be displayed. For example, if your serial number is 1234, the table below shows how

that number would be formatted for each of the displayed formatting inputs:



Input Output Input Output

d 4 0d 4

dd 34 0dd 34

ddd 234 0ddd 234

dddd 1234 0dddd 1234

ddddd 1234 0ddddd 01234

dddddd 1234 0dddddd 001234

You cannot mix decimal and hexadecimal formatting in the same text entry, and you cannot split

a serial number with other characters. For example, this string is not valid: ddd-ddd because of

the hyphen between the two groups of format characters.

Like the Date / Time formatting, any text between a pair of single quotes is copied exactly to the

output, and a pair of single quotes together is replaced by one single quote in the output.

CSV/MERGE TEXT FORMAT

When using the CSV/Merge mode for text, the system will automatically substitute certain special

combinations of characters with entries from the selected row of a CSV file. A CSV file is “Comma

Separated Values” - a very simple text format that uses a line in the file as the row, and commas

to separate columns in the file.

For example:

LightBurn,80,10

Corel,300,20

In a CSV/Merge entry in LightBurn, the text you enter uses the percent sign followed by a number

to look up a column in the current row of the CSV file. For example, using this text with the above

table:

​ I’m thinking of buying %0 - it costs $%1

Would display:

​ I’m thinking of buying LightBurn - it costs $80

Columns are numbered starting from 0.

CUT SETTING TEXT FORMAT

When using the Cut Setting mode for text, the system will automatically substitute certain

characters with values from the cut setting applied to the text.

Like the Date / Time or Serial number formatting, any text between a pair of single quotes is

copied exactly to the output, and a pair of single quotes together is replaced by one single quote

in the output.



Expression Output

C
followed by a number, pulls settings from the numbered cut layer (ex, C03) for the

remainder of this string

s speed, as a number in the current speed units

S speed, including the current units (like mm/sec)

p max power, as a percentage

P max power, including the percent sign

m min power, as a percentage

M min power, including the percent sign

d DPI, as a number, always dots per inch

i interval, in the current distance units

I interval, including the current distance units (like mm)

L

Displays the name of the laser. Can optionally be followed by a character index to

start displaying from, and optionally, a comma and a 2nd number for the number

of characters to display. For example, if L displayed ‘Ruida 6442G’, L6 would

display ‘6442G’, and L6,4 would display ‘6442’ (without the quotes)

z Z offset for the current layer, in the current distance units

Z Z offset for the current layer including the units (eg, mm)


	Disclaimer and Safety
	Setting up LightBurn for the first time
	Adding Your Laser to LightBurn
	THE DEVICES PAGE

	Configuring a laser for use with LightBurn
	LightBurn walk-through for beginners
	THE MAIN WINDOW
	MENUS
	MAIN TOOLBAR
	CREATION & MODIFIER TOOLS
	COLOR PALETTE
	CUTS / LAYERS
	SIZE AND POSITION / NUMERIC EDITS
	FONTS AND TEXT CONTROLS
	LASER WINDOW
	WORKSPACE / EDIT WINDOW

	Zooming, panning, and selection
	ZOOMING
	PANNING
	SELECTION
	Selection Modifiers
	Additional Selection Tools


	Making a Simple Project
	Creating the text:
	Previewing:
	Changing text properties:
	Undo / Redo
	Changing the Layer settings
	Adding an outline: The Offset tool:
	Changing Layers
	Speed and Power
	Positioning the Job on the Laser
	Results and Next Steps

	Advanced Topics
	DOWNLOADING LIGHTBURN

	Installing LightBurn
	WINDOWS INSTALLATION
	Next:

	MACOS INSTALLATION
	Next:

	LINUX INSTALLATION
	.run installer
	.7z installer
	Next:


	Running LightBurn for the first time
	Activating LightBurn

	Manually adding a laser
	Find My Laser
	GCode devices
	Next:

	DSP devices
	Next:
	What if my laser isn’t found?


	Common Grbl setups
	SHORT VERSION
	GRBL FLAVORS
	Shapeoko
	X-Carve
	Other machines
	Negative Coordinate Machines
	Center Origin Machines



	LightBurn Windows
	Menus
	File Menu
	New
	Open recent projects
	Open
	Import
	Save
	Export
	Exit

	Edit Menu
	Undo
	Redo
	Select all
	Cut
	Copy
	Duplicate
	Paste
	Paste in place
	Delete
	Convert to path
	Close path
	Auto join selected shapes
	Optimize Selected Shapes
	Delete Duplicates
	Select Open shapes
	Select open shapes set to scan
	Select all shapes in current layer
	Settings
	Device Settings
	Machine Settings
	Debug drawing
	Convert to cut
	Machine Settings

	Tools Menu
	Select
	Draw Lines
	Rectangle Tool
	Ellipse Tool
	Edit Nodes
	Edit Text
	Offset Shapes
	Weld Shapes
	Trace Image
	Apply Path to Text
	Zoom In
	Zoom Out
	Frame Selection
	Position Laser
	Preview
	Rotary Setup

	Arrange Menu
	Group
	Ungroup
	Flip Horizontal
	Flip Vertical
	Align Centers
	Align Left
	Align Right
	Align Top
	Align Bottom
	Align H-Center
	Align V-Center
	Move H-together
	Move V-together
	Move to Page Center
	Move to Upper Left
	Move to Upper Right
	Move to Lower Left
	Move to Lower Right
	Grid / Array
	Circular Array
	Push forward in draw order
	Push backward in draw order
	Break apart

	Window Menu
	Reset to Default Layout

	Language Menu
	Help Menu
	Quick Help and Notes
	Online Documentation
	Online Video Tutorials
	Check for Updates
	License Activation and Trial
	Enable Debug Log


	Main Toolbar
	Arrangement Toolbar
	Creation Tools
	SELECTION TOOL
	Click Selection
	Drag Selection
	Enclosing Selection:
	Crossing Selection:

	Selection Modifiers
	Moving, Resizing, and Rotating
	Snapping

	DRAW LINES TOOL
	Measuring

	RECTANGLE TOOL
	ELLIPSE TOOL
	POLYGON TOOL
	CLICK TO MOVE TOOL

	Modifier Tools
	Offset
	Weld
	Boolean Union
	Boolean Subtract
	Boolean Intersection
	Quick Video Walkthrough of the Boolean Operations

	Cuts / Layers
	Numeric Edits Toolbar
	Edit Window (workspace)
	Basic Usage: The Essentials
	CREATING SHAPES
	IMPORTING ARTWORK
	CUT LAYER SETTINGS
	CONTROLLING THE LASER

	Engraving Images
	Optimization Settings (the Cut Planner)
	Order By
	Order By Layer
	Order By Priority

	Optimizations
	Cut Inner Shapes First
	Cut In Direction Order
	Reduce Travel Moves
	Reduce Direction Changes
	Choose Best Starting Point
	Choose Corners, If Possible
	Choose Best Direction
	Remove Overlapping Lines


	Print and Cut with LightBurn
	Scanning Offset Adjustment
	Line Wobble
	Device Settings
	Working Size
	Origin
	Scanning Offset Adjust
	Fast Whitespace Scan
	S-Value Max
	Z Axis Controls

	Edit Nodes tool
	Snapping

	Creating Text
	Text Options Toolbar

	Cut Settings Window
	Variable Text in LightBurn
	VARIABLE TEXT MANAGER

	Variable Text Formats
	DATE / TIME TEXT FORMAT
	SERIAL NUMBER TEXT FORMAT
	CSV/MERGE TEXT FORMAT
	CUT SETTING TEXT FORMAT


